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Getting Started with Enterprise Architecture Modeling

Getting Started with Enterprise Architecture Modeling

An enterprise architecture model (EAM) helps you analyze and document your organization and its business functions,
along with the applications and systems that support them and the physical architecture on which they are implemented.

Enterprise architecture modeling helps you to analyze and document the architecture of your organization. Such an
analysis, can be required:

e Asan end in itself as part of good corporate governance
* Where you are required to document your system's compliance with standards or regulations
 In the following kinds of change management situations:

< Rationalization — where cost savings and efficiencies are sought
e A change in technology — where your system will be upgraded
e Anacquisition or merger — where two disparate systems must be made to work together

The diagrams in the PowerDesigner® enterprise architecture model are divided into three layers as follows:
*  Business Layer - helps you to analyze your organization in various ways:

e Organization Charts— for documenting groups and people

e Business Communication Diagram — for documenting sites and analyzing the interactions between various parts
of your organization

e Process Map - for documenting functions

e City Planning Diagram - for providing a big picture, global view of the organization, and for descending to the
system and database level, to provide links into the next, application layer.

« Application Layer - descends into the applications, databases, and other systems that must implement the business
functions identified in the business layer. The two diagrams in the application layer allow you to identify what
applications you have, and how they interact with each other, in two different ways:

e Application Architecture Diagram - as traditional discrete applications
e Service Oriented Diagram - in terms of SOA services

e Technology Layer- models the hardware on which the software is deployed. If the business layer allows you to define
what it is your organization does, and the application layer identifies the software that implements these functions, the
technology layer documents the physical equipment on which the software will run. This layer has a single diagram:

o Technology Infrastructure Diagram—for documenting your existing infrastructure, your networks, server clusters,
firewalls, and client workstations, and the infrastructure that you want to put in place.

Extending Your Analysis into Other Modules

The enterprise architecture model is intended to give you the big picture of your organization, and to provide means to
decompose your functions, processes, and systems to a certain level of detail. However, when it comes time to model the
implementation of databases, web services, or OO components, you will want to do this in the PowerDesigner module
designed for the task.

The EAM contains wizards that allow you to import objects from and export objects to other PowerDesigner modules.
Obijects exported or imported remain linked to the original objects, in order to keep all your models synchronized and to
allow you to perform cross-module impact analysis to identify the technical impact of changes on your enterprise
architecture.

The following diagram illustrated how you can deepen the analysis of your architecture by linking your EA objects with
lower-level objects in other types of PowerDesigner models:

Enterprise Architecture Modeling 1
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PowerDesigner projects enable you to easily combine multiple models and view the connections between them. You can
follow an enterprise architecture framework such as FEAF by creating a project that combines your EAM diagrams with
those of a Physical Data Model and other PowerDesigner modules.
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Using Enterprise Architecture Frameworks

For more information, see Creating an Enterprise Architecture Framework Project on page 4.

Suggested Bibliography

< O'Rourke, Fishman, Selkow, Enterprise Architecture. Using the Zachman Framework, Thompson Course
Technology, 2003, 716 pages, ISBN 0-619-06446-3.

« David C. Hay, Morgan Kaufmann, Data Model Patterns: A Metadata Map, 2006, 406 pages, ISBN 0-12-088798-3.
The following online resources provide an introduction to enterprise architecture concepts:
*  Wikipedia on enterprise architecture and service-oriented modeling:

o http://en.wikipedia.org/wiki/Enterprise_architecture
e http://en.wikipedia.org/wiki/Service-Oriented Modeling
e The Zachman Institute for Framework Advancement (ZIFA):

e http://'www.zifa.com/
e The Federal Enterprise Architecture Framework (FEAF):

e http://'www.cio.gov/Documents/bpeaguide.pdf
e The Department of Defense Architecture Framework (DODAF):

o http.//www.defenselink.mil/cio-nii/docs/DoDAF Volume_I.pdf

Creating an EAM

You create a new enterprise architecture model by selecting File > New Model .

Note: Inaddition to creating an EAM from scratch with the following procedure, you can also create amodel by importing
a Visio file (see /mporting Visio Diagrams into PowerDesigner on page 51).
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The New Model dialog is highly configurable, and your administrator may have hidden options that are not relevant for
your work or provided templates or predefined models to guide you through model creation. When you open the dialog,
one or more of the following buttons will be available on the left hand side:

* Categories - which provides a set of predefined models and diagrams sorted in a configurable category structure.
* Model types - which provides the classic list of PowerDesigner model types and diagrams.
* Templatefiles - which provides a set of model templates sorted by model type.

5 New Model

Categon: Categony ftems;

ﬁ[ﬂ. _:}Business | L= | | ]
_E_ _P} Infarmation ?ﬁ I ’ J ?j

Categories : b Application

& Conceptual Data Data Flow Diagram Data Movement Logical D ata
} Technology Model
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E = : k Requirements and Planhing 3 - : 3
Model ypes i = i & g i
Phyzical Data LML Clazs Diagram =ML FuliDimenzional
Data

Templates

A phyzical data maodel [PDM] helps you to analyze the tables, views, and other objects in a databaze, including multidimensional nbiects;l
necezzany for data warehouzing, & PO iz more concrete than a conceptual [COM) or logical (LDM) data model, vou can model,
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kaodel hame: IF'hysicaI Data_1
LEMS: ISybase A5 Enterprize 15.0.2 j

% Share the DBMS defiritior
" Copy the DEMS definition in madel

ok I Cancel | Help |

1. Select File > New Modd to open the New Model dialog.
2. Click a button, and then select a category or model type ( Enterprise Architecture Model ) in the left-hand pane.

3. Select an item in the right-hand pane. Depending on how your New Model dialog is configured, these items may be
first diagrams or templates on which to base the creation of your model.

Use the Viewstool on the upper right hand side of the dialog to control the display of the items.
4. Enter a model name.

The code of the model, which is used for script or code generation, is derived from this name according to the model
naming conventions.

5. [optional] Click the Extensions button to open the Extended Model Definitions dialog, and attach one or more
extensions to your model .

6. Click OK to create and open the enterprise architecture model .

Note: Sample EAMs are available in the Example Directory.

EAM Model Properties

Double-click the model node in the Browser to open the model property sheet, which contains information about the
model.

Enterprise Architecture Modeling 3
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The General tab contains the following properties:

Property Description

Name The name of the item which should be clear and meaningful, and should convey the item's purpose to non-
technical users.

Code The technical name of the item used for generating code or scripts, which may be abbreviated, and should not
generally include spaces.

Comment Descriptive label of the model.

File name Specifies the location of the model file. This field is empty if the model has never been saved.

Author Specifies the author of the model. If you insert a space, the Author field in the title box remains empty; if you
leave the field empty, it will display the user name from the Version Info tab.

\ersion Specifies the version of the model. You can use this field to display the repository version or a user-defined
version. This parameter is defined in the display preferences of the Title node.

Default diagram Specifies the diagram displayed by default when opening the model.

Creating an Enterprise Architecture Framework Project

PowerDesigner provides support for some of the most popular enterprise architecture frameworks in the form of project

templates.

1. Select File > New Project to open the New Project dialog.
In the Project type pane, expand the EA Frameworks node and select one of the available frameworks.
3. Specify a name for the project and a location to save it, and then click OK to create the project.

The project opens to the framework matrix, from which you can create models, diagrams, lists, and other items to
complete the requirements of the framework:

PowerDesigner®




Flannears view

Cruner's vi e

Dezignears vism

Builder's view

Physical data model

=

Getting Started with Enterprise Architecture Modeling

Where

List of Business locations

Business logistic system

Deplayment architecture

Technology architecture

¥

Subcontractars
wiew

Data directaory

Programs

Metwork architecture

For detailed information about working with projects, see the Projects and Framework Matrices chapter in the Core

Features Guide.
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Building Business Layer Diagrams

The diagrams in the business layer of the enterprise architecture model help you to analyze your organization in terms of
business units, processes, and functions:

< Organization Charts — provide graphical representations of your organization's hierarchies (see Organization Chart

Basics on page 7).

e Business Communication Diagrams — provide a consistent framework for interactions between components of the
organization, and with customers, suppliers and partners (see Business Communication Diagram Basics on page

8).

* Process Maps — provide a view of how high-level processes are associated with business functions (see Process Map

Basics on page 9).

» City Planning Diagrams — provide a "big picture" view of the organization broken down into architectural areas (see

City Planning Diagram Basicson p

Organization Chart Basics

age 10).

An organization chartprovides a graphical view of your organization as a tree structure, and helps you analyze and display
the relationships between organization units (divisions, groups, teams, etc), individuals, and roles.

In the following example, the company is analyzed into its top-level departments and the major groups within them:

Organization Chart Objects

You can create the following objects in an organization chart:

Hierarchy link ﬂ

Object Tool Symbol Description
Organization unit ﬂ . B A group, department, function, or other collection of people or
w organization units. See Organization Units (EAM) on page 12.
Person g P An individual. See People (EAM) on page 13.
1
E'_

A link between organization units or people. See Roles (EAM)on
page 14.

Note: Most EAM objects can be displayed as icons or as boxes that can display additional properties and sub-objects. You
can toggle between the Icon and Detail modes via the contextual menu, or by pressing CTRL+Q. You can control the

Enterprise Architecture Modeling
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default mode, and the information displayed in each mode through the options available by selecting Tools > Display
Preferences.

Creating an Organization Chart
You can create an organization chart in an existing EAM in any of the following ways:

* Right-click the model in the Browser and select New > Organization Chart .
* Right-click the background of any diagram and select Diagram > New Diagram > Organization Chart .

To create a new EAM with an organization chart, select File > New Model , choose to create an enterprise architecture
model from the Model type list, choose Organization Chart as the first diagram, and click OK.

Business Communication Diagram Basics

A business communication diagram provides a graphical view of your organization, and helps you analyze, the
relationships, flows, and other connections between business functions, organization units, roles, and sites.

In the following example, communications between the company, its customers and suppliers are analyzed, as well as
those between the different company sites:

Customer Shipment
Wendor Inroice
Furchase Order

hanufacturing - Barcelona
Froduction Repaort

Cirder

Job Request G

Furchase Order

Custome i ayment Wendar Inveice f":‘-.:"ii Fraduct prices ﬂ
. Froposal
Fustomer Invoice HQ - Paris Purchasing - Reims Vendar nvoice Supp“e,.
Foresast Shipment Report Vendor Payment
Fraduction Report Order
Customer Shipment
Buziness Flow 7
Mlanufacturing - Lyon
Business Communication Diagram Objects
You can create the following objects in a business communication diagram:
Object Tool Symbol Description
Architecture Area I:' | F| See Architecture Areas (EAM) on page 16.
Zoke
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Object

Tool

Symbol

Description

Business Function

An aggregation of processes and/or sub-functions. See Business
Functions (EAM) on page 18.

Business flow [':p- A link between elements in a business layer diagram. See Business
| Flows (EAM) on page 20.

Process An ordering of tasks. See Processes (EAM) on page 19.

Site J A physical location. See Sites (EAM) on page 17.

e [' l

Organization unit m A group, department, function, or other collection of people or
organization units. See Organization Units (EAM) on page 12.

Person ; An individual. See People (EAM) on page 13.

Role ;J A set of responsibilities. See Roles (EAM) on page 14.

D

Note: Most EAM objects can be displayed as icons or as boxes that can display additional properties and sub-objects. You
can toggle between the Icon and Detail modes via the contextual menu, or by pressing CTRL+Q. You can control the
default mode, and the information displayed in each mode through the options available by selecting Tools > Display

Preferences.

Creating a Business Communication Diagram

You can create a business communication diagram in an existing EAM in any of the following ways:

* Right-click the model in the Browser and select New > Business Communication Diagram .
* Right-click the background of any diagram and select Diagram > New Diagram > Business Communication

Diagram .

To create a new EAM with a business communication diagram, select File > New Model , choose to create an enterprise
architecture model from the Model type list, choose Business Communication Diagram as the first diagram, and click

OK.

Process Map Basics

A process mapprovides a graphical view of your business architecture, and helps you identify your business functions and
high-level processes, independent of the people and business units who fulfill them.

In the following example, the major processes within the Manufacturing, Marketing, and Sales business functions are

displayed:

Enterprise Architecture Modeling
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Process Map Objects
You can create the following objects in a process map:

Object Tool Symbol Description
Architecture Area D F| An abstract container object. See Architecture Areas (EAM) on
Zone page 16.

An ordering of tasks. See Processes (EAM) on page 19.

Process |

Note: Most EAM objects can be displayed as icons or as boxes that can display additional properties and sub-objects. You
can toggle between the Icon and Detail modes via the contextual menu, or by pressing CTRL+Q. You can control the

default mode, and the information displayed in each mode through the options available by selecting Tools > Display
Preferences.

Business Function E An aggregation of processes and/or sub-functions. See Business
Functions (EAM) on page 18.

Creating a Process Map
You can create a process map in an existing EAM in any of the following ways:

* Right-click the model in the Browser and select New > ProcessMap .
* Right-click the background of any diagram and select Diagram > New Diagram > ProcessMap .

To create a new EAM with a process map, select File > New Modél , choose to create an enterprise architecture model
from the Model type list, choose Process M ap as the first diagram, and click OK.

City Planning Diagram Basics

A city planning diagram provides a graphical view of the big picture of your enterprise architecture, using the metaphor
of planning the infrastructure of a city to represent the organization of systems, applications, etc into architectural areas.

10 PowerDesigner®
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Inthe following example, the core system is broken up into five major sub-systems, which are in turn sub-divided into their
major functions. Major applications and databases are also highlighted.

City Planning Diagram Objects
You can create the following objects in a city planning diagram:

Object Tool Symbol Description
Avrchitecture Area E] 7| An abstract container object. See Architecture Areas (EAM) on
Zane page 16.
System :: A group of applications, services or sub-sytems. See Systems,
Applications, and Databases (EAM) on page 29.

Application :j A computer program. See Systems, Applications, and Databases
e (EAM) on page 29.

Database ﬂ A database. See Systems, Applications, and Databases (EAM) on
T | page 29.

Enterprise Architecture Modeling 11
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Object Tool Symbol Description

Business Function E | An aggregation of processes and/or sub-functions. See Business
Functions (EAM) on page 18.

Application Service = e B — An externally visible unit of functionality. See Application and
- Business Services (EAM) on page 27.

Note: Most EAM objects can be displayed as icons or as boxes that can display additional properties and sub-objects. You
can toggle between the Icon and Detail modes via the contextual menu, or by pressing CTRL+Q. You can control the
default mode, and the information displayed in each mode through the options available by selecting Tools > Display
Preferences.

Creating a City Planning Diagram
You can create a city planning diagram in an existing EAM in any of the following ways:

* Right-click the model in the Browser and select New > City Planning Diagram .
* Right-click the background of any diagram and select Diagram > New Diagram > City Planning Diagram .

To create a new EAM with a city planning diagram, select File >New Model , choose to create an enterprise architecture
model from the Model type list, choose City Planning Diagram as the first diagram, and click OK.

Organization Units (EAM)

An organization unitrepresents a group of people or other organization units.

An organization unit can be created in the following diagrams:

< Organization chart (see Organization Chart Basics on page 7)
e Business communication diagram (see Business Communication Diagram Basics on page 8)
« Technology infrastructure diagram (see Building Technology Layer Diagrams on page 37)

Example
In this example, the Manufacturing organization unit contains the Quality and Production sub-units:

&

gl

w Quality

M anufacturing

&

Froduction

Creating an Organization Unit
You can create an organization unit in any of the following ways:

* Use the Organization Unit tool in the diagram Palette.
« Select Model > Organization Units to access the List of Organization Units, and click the Add a Row tool.
* Right-click the model or package in the Browser, and select New > Organization Unit .
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For general information about creating objects, see the Objects chapter in the Core Features Guide.

Organization Unit Properties

To open an organization unit property sheet and view or edit its properties, double-click its diagram symbol or its Browser
entry.

The General Tab contains the following properties:

Property Description

Name Specifies the name of the item, which should be clear and meaningful, and should convey the item's purpose
to non-technical users.

Code Specifies the technical name of the object, which is used for generating code or scripts

Comment Descriptive comment for the object.

Stereotype Extends the semantics of an object derived from existing objects but specific to your needs.

Manager Specifies the manager of the organization unit. Select a user or role from the list.

Telephone Specifies the telephone number of the organization unit.

Email Specifies the email address of the organization unit.

Web site Specifies the url for the web site of the organization unit.

The following tabs are also available:

* Sub-Organizations - lists the organization units that belong to this organization unit.

« People - lists the people (see Pegple (EAM) on page 13) that belong to this organization unit.
* Roles - lists the roles (see Roles (EAM)on page 14) that this organization unit fulfills.

e Sites — lists the sites (see Sites (EAM) on page 17) where this organization unit is located.

People (EAM)

A person represents an individual who holds a position within an organization.

A person can be created in the following diagrams:

* Organization chart (see Organization Chart Basics on page 7)
e Business communication diagram (see Business Communication Diagram Basics on page 8)
« Technology infrastructure diagram (see Building Technology Layer Diagrams on page 37)

Example
In this example, David is the manager of Emily and Robert:

|
&

Emily

Q B Database Architect
David ﬂ

cTo
Robert
[atabase Administrator
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Creating a Person
You can create a person in any of the following ways:

» Use the Person tool in the diagram Palette.
» Select Model > People to access the List of People, and click the Add a Row tool.
* Right-click the model or package in the Browser, and select New > Person .

For general information about creating objects, see the Objects chapter in the Core Features Guide.

Person Properties
To open a person property sheet and view or edit its properties, double-click its diagram symbol or its Browser entry.

The General Tab contains the following properties:

Property Description

Name Specifies the name of the item, which should be clear and meaningful, and should convey the item's purpose
to non-technical users.

Code Specifies the technical name of the object, which is used for generating code or scripts

Comment Descriptive comment for the object.

Stereotype Extends the semantics of an object derived from existing objects but specific to your needs.

Manager Specifies the manager of the person. Select a person from the list or click the New tool to the right of the

field to create a new one.

Site Specifies the site where this person is located. Select a site from the list or click the New tool to the right
of the field to create a new one.

Job title Specifies the job title of the person.
Telephone Specifies the telephone number of the person.
Email Specifies the email address of the person.

The following tabs are also available:

* Roles - lists the roles (see Roles (EAM) on page 14) that this person fulfills.

Roles (EAM)

A roleis set of responsibilities that are fulfilled by a person or an organization unit.

For more information, see Pegple (EAM) on page 13 or Organization Units (EAM) on page 12.
A role can be created in the following diagrams:

e Organization chart (see Organization Chart Basics on page 7)

< Business communication diagram (see Business Communication Diagram Basics on page 8)
< Service oriented diagram (see Service-Oriented Diagram Basics on page 25)

< Technology infrastructure diagram (see Building Technology Layer Diagrams on page 37)

Example
In this example, the Supplier role interacts with the Central Purchasing site:
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product prices

Furchase order

Central purchasing Supplier

wendor invoice

Creating a Role
You can create a role in any of the following ways:

* Select Model > Roles to access the List of Roles, and click the Add a Row tool.
* Right-click the model or package in the Browser, and select New > Role.

For general information about creating objects, see the Objects chapter in the Core Features Guide.

Role Properties
To open a role property sheet and view or edit its properties, double-click its diagram symbol or its Browser entry.

The General Tab contains the following properties:

Property Description

Name Specifies the name of the item, which should be clear and meaningful, and should convey the item's purpose
to non-technical users.

Code Specifies the technical name of the object, which is used for generating code or scripts

Comment Descriptive comment for the object.

Stereotype Extends the semantics of an object derived from existing objects but specific to your needs.

Role Associations
Role associations are used to define links between objects and people, organization units, and roles. For example:

e A person may be defined as the administrator of a hardware server and the manager of a site
* An organization unit may be identified as being responsible for the Sales business function
< Arrole may be designated as the contact for the Madrid site

Creating a Role Association
You create a role association on the Role Associations tab of an object.

1. Open the property sheet of the object to which you want to connect a person, organization unit, or role, and click the
Role Associations tab.

2. Click the Add Obijects tool to open a selection box listing all the roles, people, and organization units available in the
model.

3. Select the roles, people, and organization units that you want to associate with the object and click OK.

4. [optional] On the Role Associations tab, select or enter a type for each added role association.
5. Click OK to return to the diagram.
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Architecture Areas (EAM)

An architecture areais an abstract object that can contain and group together other objects.

An architecture area can be created in the following diagrams:

< Business communication diagram (see Business Communication Diagram Basics on page 8)
e Process map (see Process Map Basics on page 9)

» City planning diagram (see City Planning Diagram Basics on page 10)

< Application architecture diagram (see Application Architecture Diagram Basics on page 23)
< Service oriented diagram (see Service-Oriented Diagram Basics on page 25)

e Technology infrastructure diagram (see Building Technology Layer Diagrams on page 37)

Example

In this example, the Supply chain management area contains the Supplier management and Inventory control areas:

Supply chain management

Creating an Architecture Area

You can create an architecture area in any of the following ways:

e Use the Architecture Area tool in the diagram Palette
* Select Model > Architecture Areas to access the List of Architecture Areas, and click the Add a Row tool.
* Right-click the model or package in the Browser, and select New > Architecture Area.

For general information about creating objects, see the Objects chapter in the Core Features Guide.

Architecture Area Properties

To open an architecture area property sheet and view or edit its properties, double-click its diagram symbol or its Browser

entry.

The General Tab contains the following properties:

Property Description

Name Specifies the name of the item, which should be clear and meaningful, and should convey the item's purpose
to non-technical users.

Code Specifies the technical name of the object, which is used for generating code or scripts

Comment Descriptive comment for the object.

Stereotype Extends the semantics of an object derived from existing objects but specific to your needs.

The following tabs are also available:
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* Role Associations - lists the organization units, people, and roles associated with the area, and the type of role they play
in relation to it (see Role Associations on page 15).

< Attached Objects — lists the objects that are contained within this area.
* Sub-Areas — lists the architecture areas contained within this area.

Sites (EAM)

A siteis a physical location that can contain and group people, organizations and other objects.

A site can be created in the following diagrams:

* Business communication diagram (see Business Communication Diagram Basics on page 8)
< Application architecture diagram (see Application Architecture Diagram Basics on page 23)
< Technology infrastructure diagram (see Building Technology Layer Diagrams on page 37)

Example
In this example, the Central and Manufacturing sites interact:

hanufacturing - Spain

COrder

Froduction report

Central - Paris

Creating a Site
You can create a site in any of the following ways:

* Use the Site tool in the diagram Palette.
* Select Model > Sites to access the List of Sites, and click the Add a Row tool.
* Right-click the model or package in the Browser, and select New > Site.

For general information about creating objects, see the Objects chapter in the Core Features Guide.

Site Properties
To open a site property sheet and view or edit its properties, double-click its diagram symbol or its Browser entry.

The General Tab contains the following properties:

Property Description

Name Specifies the name of the item, which should be clear and meaningful, and should convey the item's purpose
to non-technical users.

Code Specifies the technical name of the object, which is used for generating code or scripts

Comment Descriptive comment for the object.
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Property Description

Stereotype Extends the semantics of an object derived from existing objects but specific to your needs.
Address Specifies the street address of the site.

Zip Specifies the zip code of the site.

City Specifies the city where the site is located.

Country Specifies the country where the site is located.

Phone Specifies the telephone number of the site.

Population Specifies the number of people at the site.

The following tabs are also available:

* Role Associations — lists the organization units, people, and roles associated with the site, and the type of role they play
in relation to it (see Role Associations on page 15).

* Sub-Sites — lists the sites contained within the site.

Business Functions (EAM)

A business function is an aggregation of related processes and sub-functions.

A business function can be created in the following diagrams:

« Business communication diagram (see Business Communication Diagram Basics on page 8)
« Process map (see Process Map Basics on page 9)
» City planning diagram (see City Planning Diagram Basics on page 10)

Example
In this example, the Indirect sales function contains the Contact partner and Organize event processes:

Organize ewvent

Creating a Business Function
You can create a business function in any of the following ways:

e Use the Business Function tool in the diagram Palette.
« Select Model > Business Functions to access the List of Business Functions, and click the Add a Row tool.
* Right-click the model or package in the Browser, and select New > Business Function .

For general information about creating objects, see the Objects chapter in the Core Features Guide.

Business Function Properties

To open a business function property sheet and view or edit its properties, double-click its diagram symbol or its Browser
entry.

The General Tab contains the following properties:
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Property Description

Name Specifies the name of the item, which should be clear and meaningful, and should convey the item's purpose
to non-technical users.

Code Specifies the technical name of the object, which is used for generating code or scripts

Comment Descriptive comment for the object.

Stereotype Extends the semantics of an object derived from existing objects but specific to your needs.

The following tabs are also available:

« Role Associations — lists the organization units, people, and roles associated with the function, and the type of role they
play in relation to it (see Role Associations on page 15).

« Sub-Functions — lists the business functions contained within the function.
e Processes — lists the processes (see Processes (EAM) on page 19) associated with the function.
e Sites — lists the sites (see Sites (EAM) on page 17) associated with the function.

Processes (EAM)

A processis an ordering of tasks or activities that may include manual and/or automated operations. Processes can be
triggered by events, by initiatives, or by conditions.

A process can be created in the following diagrams:

e Business communication diagram (see Business Communication Diagram Basics on page 8)
* Process map (see Process Map Basics on page 9)
* Service oriented diagram (see Service-Oriented Diagram Basics on page 25)

Example
In this example, the Validate order process forms part of the Direct sales function:

Walidate order

Creating a Process
You can create a process in any of the following ways:

e Use the Process tool in the diagram Palette.
* Select Model > Processes to access the List of Processes, and click the Add a Row tool.
* Right-click the model or package in the Browser, and select New > Process.

For general information about creating objects, see the Objects chapter in the Core Features Guide.

Process Properties
To open a process property sheet and view or edit its properties, double-click its diagram symbol or its Browser entry.

The General Tab contains the following properties:
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Property Description

Name Specifies the name of the item, which should be clear and meaningful, and should convey the item's purpose
to non-technical users.

Code Specifies the technical name of the object, which is used for generating code or scripts

Comment Descriptive comment for the object.

Stereotype Extends the semantics of an object derived from existing objects but specific to your needs.

Reused process Specifies the name of the reused process.

The following tabs are also available:

Role Associations — lists the organization units, people, and roles associated with the process, and the type of role they
play in relation to it (see Role Associations on page 15).

Business Flows (EAM)

A business flowis an oriented link that is used to connect objects and can contain documents.

A business flow can be created in the following diagrams:

Business communication diagram (see Business Communication Diagram Basics on page 8)

Example

In this example the Price request flow goes from the Purchasing function to the Supplier role:

Order
Price request Supplier

Creating a Business Flow
You can create a business flow in any of the following ways:

e Use the Business Flow tool in the diagram Palette.

e Select Model > Business Flows to access the List of Business Flows, and click the Add a Row tool.
* Right-click the model or package in the Browser, and select New > Business Flow .

For general information about creating objects, see the Objects chapter in the Core Features Guide.

Business Flow Properties

To open a business flow property sheet and view or edit its properties, double-click its diagram symbol or its Browser
entry.

The General Tab contains the following properties:

Property Description

Name Specifies the name of the item, which should be clear and meaningful, and should convey the item's
purpose to non-technical users.

Code Specifies the technical name of the object, which is used for generating code or scripts
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Property Description

Comment Descriptive comment for the object.

Stereotype Extends the semantics of an object derived from existing objects but specific to your needs.
First object Specifies the object at the origin of the link.

Second object Specifies the object at the end of the link.

The following tabs are also available:

e Documents - lists the documents associated with the flow (see Forms, Documents, and Reports (EAM) on page
32).

Condition — lets you specify a condition to be evaluated to determine if the flow will be triggered, as well as a short
alias for the condition, which can be displayed on the flow symbol.
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Building Application Layer Diagrams

Application layer diagrams allow you to model the architecture of your systems in order to identify your applications and
their main components, and to analyze their interactions and how they implement business process and functions:

< Application Architecture Diagrams — organize applications as discrete, interconnected units (see Application
Architecture Diagram Basics on page 23).

» Service Oriented Diagrams — organize applications in terms of SOA layers (see Service Oriented Diagram Basicson
page 25).

Application Architecture Diagram Basics

An application architecture diagram provides a high-level graphical view of the application architecture, and helps you
identify applications, sub-applications, components, databases, services, etc, and their interactions.

In the following example, interactions between the major order processing and inventory systems at the company's
headquarters and manufacturing site are displayed:

D Manufacturing Site D Headquarters

Irventony

}

[Dratabase Senrer

Replicated Orders Irvoices Orders Customears

Application Architecture Diagram Objects
You can create the following objects in an application architecture diagram:

Object Tool Symbol Description
Avrchitecture Area D | F| An abstract object for grouping other objects. See Architecture
Zone Areas (EAM) on page 16.
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Creating an Application Architecture Diagram

Object

Tool

Symbol

Description

Site

A physical location. See Sites (EAM)on page 17.

Application Service

e o

An externally visible unit of functionality. See Application and

| N 3 - .
Business Services (EAM) on page 27.
System | m A packaged application. See Systems, Applications, and Databases
= ) (EAM) on page 29.
Application =5 ﬁ A computer program. See Systems, Applications, and Databases
i F-‘ (EAM) on page 29.
Database ﬁ g A database. See Systems, Applications, and Databases (EAM) on
page 29.
Component & ﬁ A replaceable part of an application. See Components (EAM) on
page 31.
Form =y A Ul component. See Forms, Documents, and Reports (EAM) on
== page 32.
Document _J [ Any conceptual document. See Forms, Documents, and Reports
(EAM) on page 32.
Report Document ...:,-’ A report. See Forms, Documents, and Reports (EAM) on page

32.

ETL Job

L3

An ETL job. See ETL Jobs (EAM) on page 34.

Application Link

&

A link between elements in an application layer diagram. See Ap-
plication Links (EAM) on page 35.

Note: Most EAM abjects can be displayed as icons or as boxes that can display additional properties and sub-objects. You
can toggle between the Icon and Detail modes via the contextual menu, or by pressing CTRL+Q. You can control the
default mode, and the information displayed in each mode through the options available by selecting Tools > Display

Preferences.

You can create an application architecture diagram in an existing EAM in any of the following ways:

* Right-click the model in the Browser and select New > Application Architecture Diagram .
* Right-click the background of any diagram and select Diagram > New Diagram > Application Architecture

Diagram .

To create a new EAM with an application architecture diagram, select File > New Model , choose to create an enterprise
architecture model from the Model type list, choose Application Architecture Diagram as the first diagram, and click

OK.
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Building Application Layer Diagrams

A service-oriented diagram provides a graphical view of your business and application services and the relationships

between them, and helps you associate applications and other application layer objects with business services and
processes to assist with SOA design.

In the following example, the Open Account and Order-to-cash business services are shown in relation to the application
services, applications, and technologies that implement them:

D Business Senices Layer
Dl g
Open Account Orderto-cash
D Senice Layer
ik _""'1_ i b ik _""'1_ i b S "'1_ i b — _""'1_ )
HR Senice Financial Senice Flanning Senice Reporting Senice
D Application Layer
r g > r Mg = br Mg = r Mg *
HR-FS Senrice SAF Senice Custom Senrice SA% Function Senice
= ST Flu. Dluu Dluu
PeopleSoft SAP Customn Legacy SAS
I:‘ Technology Layer
b g 1 b Mg = b: Mg > i Mg >
JavallZEE Service MWET Senvice DEMS Senice bdobile Senice
JawallZEE MET Wfind cws DBEMS Muobile Application

Service-oriented Diagram Objects

You can create the following objects in a service-oriented diagram:
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o

Object Tool Symbol Description
Architecture Area I:' | An abstract object for grouping other objects. See Architecture
Zone Avreas (EAM) on page 16.
Role ;J . ) A set of responsibilities. See Roles (EAM) on page 14.
“;
Process An ordering of tasks. See Processes (EAM) on page 19.

L |

36.

Application Link

d

Application Service ™| TR An externally visible unit of functionality. See Application and
- Business Services (EAM) on page 27.
Business Service bd iy — A service offered by an organization. See Application and Business
= Services (EAM) on page 27.
System s | m A packaged application. See Systems, Applications, and Databases
e i 1 (EAM) on page 29.
Application B ﬁ A computer program. See Systems, Applications, and Databases
= F-‘ (EAM) on page 29.
Database ﬁ A database. See Systems, Applications, and Databases (EAM) on
page 29.
Component & A replaceable part of an application. See Components (EAM) on
page 31.
Contract . An agreement between services. See Contracts (EAM) on page
—-

A link between elements in an application layer diagram. See Ap-
plication Links (EAM) on page 35.

Note: Most EAM objects can be displayed as icons or as boxes that can display additional properties and sub-objects. You
can toggle between the Icon and Detail modes via the contextual menu, or by pressing CTRL+Q. You can control the
default mode, and the information displayed in each mode through the options available by selecting Tools > Display

Preferences.

Creating a Service-oriented Diagram

You can create a service-oriented diagram in an existing EAM in any of the following ways:

* Right-click the model in the Browser and select New > Service-Oriented Diagram .
* Right-click the background of any diagram and select Diagram > New Diagram > Service-Oriented Diagram .

To create a new EAM with a service-oriented diagram, select File > New Model , choose to create an enterprise
architecture model from the Model type list, choose Service-Oriented Diagram as the first diagram, and click OK.
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Application and Business Services (EAM)

An application service is an externally visible unit of functionality, provided by one or more applications or components,
and exposed through well-defined interfaces.

An application service can be created in the following diagrams:

< Application architecture diagram (see Application Architecture Diagram Basics on page 23)
» Service-oriented diagram (see Service Oriented Diagram Basics on page 25)
» City planning diagram (see City Planning Diagram Basics on page 10)

A business service is a service offered by an organization to its customers that directly supports the work performed in a
business process or function, exposed by an application-to-business interface.

A business service can be created in the following diagrams:

» Service-oriented diagram (see Service Oriented Diagram Basics on page 25)

Example
In this example the Register sales business service is implemented by the Finance Service application service:

Fegister zales

Finance senvice

Creating an Application or Business Service
You can create an application or business service in any of the following ways:

e Use the Application or Business Service tool in the diagram Palette.

* Select Model > Application Services or Business Servicesto access the appropriate list of services, and click the
Add a Row tool.

* Right-click the model or package in the Browser, and select New > Application Service or Business Service.

For general information about creating objects, see the Objects chapter in the Core Features Guide.

Application and Business Service Properties

To open an application or business service property sheet and view or edit its properties, double-click its diagram symbol
or its Browser entry.

The General Tab contains the following properties:

Property Description

Name Specifies the name of the item, which should be clear and meaningful, and should convey the item's purpose
to non-technical users.
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For business services, you can choose between:

» Consulting

e Customer Service

« Distribution Service
* Marketing Service

e Personal Service

e Sales Service

For application services, you can choose between:

e Business Process
* Collaboration

e Data

» Infrastructure

e Integration

e Presentation

Property Description

Code Specifies the technical name of the object, which is used for generating code or scripts
Comment Descriptive comment for the object.

Stereotype Extends the semantics of an object derived from existing objects but specific to your needs.
Type Specifies the type of service.

Level .
*  Best effort service

» Differentiated service
» Guaranteed service

Quality of Service Specifies the quality of the service. You can choose between:

Security Level Specifies the security of the service. You can choose between:
* High
e Moderate
« Low

The following tabs are also available:

* Role associations — lists the organization units, people, and roles associated with the service, and the type of role they

play in relation to it (see Role Associations on page 15).

e Operations — lists the operations (see Operations on page 28) that support the service.

Creating Business and Application Service Operations

An operation is an abstract description of an action supported by a service. For example the Login service may require a

Get ID operation

You can create an operation by using the Add a Row tool on the Operations tab of a business or application service.

For general information about creating objects, see the Objects chapter in the Core Features Guide.

Operation Properties

To open an operation property sheet and view or edit its properties, double-click its Browser entry or its entry on the

Operations tab of a business or application service.

The General Tab contains the following properties:
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Property Description
Parent Specifies the service to which the operation belongs.
Name Specifies the name of the item, which should be clear and meaningful, and should convey the item's purpose

to non-technical users.

Code Specifies the technical name of the object, which is used for generating code or scripts
Comment Descriptive comment for the object.

Stereotype Extends the semantics of an object derived from existing objects but specific to your needs.
Operation type Specifies the type of the operation. You can choose between:

* Notification

*  One-way

* Request-Response
» Solicit-Response

Input Specifies the document or data required to start the service (see Forms, Documents, and Reports (EAM)on
page 32)

Output Specifies the document or data returned by the service (see Forms, Documents, and Reports (EAM)on page
32)

Systems, Applications, and Databases (EAM)

A System is a packaged application that can contain sub systems, applications, services and other application elements.

An application is a computer program, a collection of data groups (databases and/or parts of databases) and program
modules (components, database management systems, utilities, interactive modules, and system modules), which
implements a business function.

A database is a representation of an installed database.
These objects can be created in the following diagrams:

» City planning diagram (see City Planning Diagram Basics on page 10)
< Application architecture diagram (see Application Architecture Diagram Basics on page 23)
« Service-oriented diagram (see Service Oriented Diagram Basics on page 25)

Example
In this example, the Inventory system contains the Stock Management application and the Stock database:

Creating a System, Application, or Database
You can create a system, application, or database in any of the following ways:
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Use the appropriate too

tool.

I in the diagram Palette.

Select Model > Systems, Applications, or Databasesto access the appropriate object list, and click the Add a Row

Right-click the model or package in the Browser, and select New > System , Application, or Database.

For general information about creating objects, see the Objects chapter in the Core Features Guide.

System, Application, and Database Properties

To open a system, application, or database property sheet and view or edit its properties, double-click its diagram symbol

or its Browser entry.

The General Tab contains the following properties:

Property

Description

Name

Specifies the name of the item, which should be clear and meaningful, and should convey the item's purpose
to non-technical users.

Code

Specifies the technical name of the object, which is used for generating code or scripts

Comment

Descriptive comment for the object.

Stereotype

Extends the semantics of an object derived from existing objects but specific to your needs.

Type

For

[application and database only] Specifies the type of application or database. For applications, you can
choose between:

Web

Rich Client
Office

Tool

CRM

ERP

databases, you can choose between:

Data Warehouse

Data Mart

Multi-Dimensional Data Warehouse
OLTP Database

Virtual Database

DBMS

[database only] Specifies the DBMS of the database.

The following tabs are also available:

Detail — [application only] records the programming language, version, etc, for the application.
Role Associations — lists the people, organization units, and roles associated with the application or system, and the

type of role they play in relation to it (see Role Associations on page 15).

Source Models — [database only] lists the data models associated with the database. For more information about data

models, see Data Modeling.

Applications — [application and system only] lists the applications associated with the application or system.
Components — [application and system only] lists the components (see Components (EAM) on page 31) associated

with the application or system.

Forms — [application and system only] lists the forms (see Forms, Documents, and Reports (EAM) on page 32)

associated with the application or system.

Sites — lists the sites associated with the application or system (see Sites (EAM) on page 17).
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< Application Services — [system only] lists the application services (see Application and Business Services (EAM)on
page 27) associated with the system.

< Databases — [system only] lists the databases associated with the system.
« Documents — [system only] lists the documents (see Forms, Documents, and Reports (EAM) on page 32) associated

with the system.

e ETL Jobs — [system only] lists the ETL jobs (see E7L Jobs (EAM)on page 34) associated with the system.

< Report Documents — [system only] lists the reports (see Forms, Documents, and Reports (EAM) on page 32)
associated with the system.

e Systems — [system only] lists the sub-systems contained within the system.

Components (EAM)

A component is an encapsulated, reusable, and replaceable part of an application, which can be used to implement a
service or an application.

A component can be created in the following diagrams:

» Application architecture diagram (see Application Architecture Diagram Basics on page 23)
» Service-oriented diagram (see Service Oriented Diagram Basics on page 25)

Example

In this example, the Inventory Management system contains the Check Inventory component:

Creating a Component

You can create a component in any of the following ways:

* Use the Component tool in the diagram Palette.
* Select Model > Components to access the List of Components, and click the Add a Row tool.
* Right-click the model or package in the Browser, and select New > Component .

For general information about creating objects, see the Objects chapter in the Core Features Guide.

Component Properties

To open a component property sheet and view or edit its properties, double-click its diagram symbol or its Browser

entry.

The General Tab contains the following properties:

Property Description

Name Specifies the name of the item, which should be clear and meaningful, and should convey the item's purpose
to non-technical users.

Code Specifies the technical name of the object, which is used for generating code or scripts
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Property Description
Comment Descriptive comment for the object.
Stereotype Extends the semantics of an object derived from existing objects but specific to your needs.
Programming Lan- Specifies the programming language in which the component is written.
guage
Type Specifies the type of the component. You can choose between:

- EJB

e Servlet

* Presentation

» DataAccess

e Controller

« COM

e ActiveX

Forms, Documents, and Reports (EAM)

A form represents a Ul component of an application.

A document represents any conceptual document used in the enterprise.
A report represents any report used in the enterprise.
These objects can be created in the following diagrams:

< Application architecture diagram (see Application Architecture Diagram Basics on page 23)

Example

In this example the HR system contains the Employee Absence report, the Vacation form, and the Health and Safety
Guidelines document:

Creating a Form, Document, or Report
You can create a form, document, or report in any of the following ways:

< Use the appropriate tool in the diagram Palette.

* Select Model > Forms, Documents, or Reports to access the appropriate object list, and click the Add a Row
tool.

* Right-click the model or package in the Browser, and select New > Form , Document, or Report.

For general information about creating objects, see the Objects chapter in the Core Features Guide.

Form, Document, and Report Properties

To open a form, document, or report property sheet and view or edit its properties, double-click its diagram symbol or its
Browser entry.
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The General Tab contains the following properties:

Property Description
Name Specifies the name of the item, which should be clear and meaningful, and should convey the item's purpose
to non-technical users.
Code Specifies the technical name of the object, which is used for generating code or scripts
Comment Descriptive comment for the object.
Stereotype Extends the semantics of an object derived from existing objects but specific to your needs.
Type Specifies the type of the document, form, or report.
\ersion [document only] Specifies the version number of the document.
Category [report only] Specifies the category of the report. You can choose between:
*  Business
»  Specification
e Strategic
e Technical
Period [report only] Specifies the frequency with which the report is generated. You can choose between:
o Daily
° Weekly
*  Monthly
*  Yearly
Style [form only] Specifies the style of the form.
Document Format [document only] Lists the XML models that are used to represent the structure of the document. For more
information about XML models, see the XML Modeling guide.

The following tabs are also available:

e Data - [report and document only] lists the data (see Data on page 33) associated with the document.

Creating Document Data
Data objects are pieces of information that can be assigned to reports and documents.

You can create a data object by using the Add a Row tool on the Data tab of a report or document.

For general information about creating objects, see the Objects chapter in the Core Features Guide.

Data Properties
To open a data property sheet and view or edit its properties, double-click its Browser entry.

The General Tab contains the following properties:

Property Description

Name Specifies the name of the item, which should be clear and meaningful, and should convey the item's
purpose to non-technical users.

Code Specifies the technical name of the object, which is used for generating code or scripts
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Property Description
Comment Descriptive comment for the object.
Stereotype Extends the semantics of an object derived from existing objects but specific to your needs.

ETL Jobs (EAM)

An ETL job represents a task in an ETL data transformation.

An ETL job can be created in the following diagrams:

« Application architecture diagram (see Application Architecture Diagram Basics on page 23)

Example

In this example the Aggregate Sales ETL job aggregates the data from the Sales —Transactions database to the Sales —
Warehouse database:

|:| [rata Replication

—

o s

Sales- Transactions Aggregate Sales  Sales- Warehouse
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Creating an ETL Job
You can create an ETL job in any of the following ways:

e Use the ETL Job tool in the diagram Palette.
* Select Model > ETL Jobs to access the List of ETL Jobs, and click the Add a Row tool.
* Right-click the model or package in the Browser, and select New >ETL Job .

For general information about creating objects, see the Objects chapter in the Core Features Guide.

ETL Job Properties
To open an ETL job property sheet and view or edit its properties, double-click its diagram symbol or its Browser entry.

The General Tab contains the following properties:

Property Description

Name Specifies the name of the item, which should be clear and meaningful, and should convey the item's
purpose to non-technical users.

Code Specifies the technical name of the object, which is used for generating code or scripts

Comment Descriptive comment for the object.

Stereotype Extends the semantics of an object derived from existing objects but specific to your needs.

The following tabs are also available:

* Role Associations - lists the people, organization units, and roles associated with the ETL job, and the type of role they
play in relation to it (see Role Associations on page 15).
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Application Links (EAM)

An application linkis an oriented link that is used to connect objects in the application layer.

An application link can be created in the following diagrams:

< Application architecture diagram (see Application Architecture Diagram Basics on page 23)
» Service-oriented diagram (see Service Oriented Diagram Basics on page 25)

Example
In this example, the Create invoice component makes a request to the Invoice database:

Create invoice

"

e

Inwoice

Creating an Application Link
You can create an application link in any of the following ways:

e Use the Application Link tool in the diagram Palette.
* Select Model > Application Links to access the List of Application Links, and click the Add a Row tool.
* Right-click the model or package in the Browser, and select New > Application Link .

For general information about creating objects, see the Objects chapter in the Core Features Guide.

Application Link Properties

To open an application link property sheet and view or edit its properties, double-click its diagram symbol or its Browser
entry.

The General Tab contains the following properties:

Property Description

Name Specifies the name of the item, which should be clear and meaningful, and should convey the item's purpose
to non-technical users.

Code Specifies the technical name of the object, which is used for generating code or scripts

Comment Descriptive comment for the object.

Stereotype Extends the semantics of an object derived from existing objects but specific to your needs.

First object Specifies the object at the origin of the link.

Second object Specifies the object at the end of the link.
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Property Description

Type Specifies the type of the application link.

Contracts (EAM)

A contract is an agreement between services

A contract can be created in the following diagrams:

e Service-oriented diagram (see Service Oriented Diagram Basics on page 25)

Example

In this example, the contract defines acceptable response times for the link between the business and application login
services:

Creating a Contract
You can create a contract in any of the following ways:

e Use the Contract tool in the diagram Palette.
* Select Model > Contracts to access the List of Contracts, and click the Add a Row tool.
* Right-click the model or package in the Browser, and select New > Contract .

For general information about creating objects, see the Objects chapter in the Core Features Guide.

Contract Properties
To open a contract property sheet and view or edit its properties, double-click its diagram symbol or its Browser entry.

The General Tab contains the following properties:

Property Description

Name Specifies the name of the item, which should be clear and meaningful, and should convey the item's purpose
to non-technical users.

Code Specifies the technical name of the object, which is used for generating code or scripts

Comment Descriptive comment for the object.

Stereotype Extends the semantics of an object derived from existing objects but specific to your needs.

The following tabs are also available:

* Role Associations — lists the people, organization units, and roles associated with the contract, and the type of role they
play in relation to it (see Role Associations on page 15).

« Documents — lists the documents (see Forms, Documents, and Reports (EAM) on page 32) associated with the
contract.

XML Models —lists the XML Models that are used to define the contract. For more information about XSMs, see the
XML Modeling guide.
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A technology infrastructure diagramprovides a high-level graphical view of the physical architecture required to support
the application architecture.

A technology infrastructure diagram is the sole diagram in the technology layer.

In the following example, the deployment of servers within the company network is shown, along with the web access
afforded to thin clients:
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|:| Load balanced Web Farm
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Technology Infrastructure Diagram Objects

You can create the following objects in a technology infrastructure diagram:

Object Tool Symbol Description
Avrchitecture Area I:' | An abstract object for grouping other objects. See Architecture
Zore Areas (EAM) on page 16.

Site # @ A physical location. See Sites (EAM) on page 17.
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Object Tool Symbol Description
Organization Unit m . B A group, department, function, or other collection of people or
w organization units. See Organization Units (EAM) on page 12.
Person - 2 An individual. See Pegple (EAM) on page 13.
L3 1
Role ;J . ) A set of responsibilities. See Roles (EAM) on page 14.
“;
Network = G Any kind of network. See Networks (EAM) on page 39.
— [ —
Software Server i ~d A commercial software environment. See Servers, Workstations,
2 = Mobile Devices, and Network Nodes (EAM) on page 40
= == (&.‘ , page 40.
" 4

Hardware Server

A high availability resource machine. See Servers, Workstations,
Mobile Devices, and Network Nodes (EAM) on page 40.

A client machine. See Servers, Workstations, Mobile Devices, and

Workstation S
L= Network Nodes (EAM) on page 40.

Mobile Device ¥ A handheld client. See Servers, Workstations, Mobile Devices, and
b Network Nodes (EAM) on page 40.

Network Node Can represent various kinds of network components. See Servers,

Workstations, Mobile Devices, and Network Nodes (EAM) on
page 40.

Deployment Instance

i

An instance of an object defined elsewhere. See Deployment In-
stances (EAM) on page 41.

Infrastructure Link

Is

A link between elements in a technology layer diagram. See /n-
frastructure Links (EAM) on page 42.

Note: Most EAM abjects can be displayed as icons or as boxes that can display additional properties and sub-objects. You
can toggle between the Icon and Detail modes via the contextual menu, or by pressing CTRL+Q. You can control the
default mode, and the information displayed in each mode through the options available by selecting Tools > Display

Preferences.

Creating a Technology Infrastructure Diagram

You can create a technology infrastructure diagram in an existing EAM in any of the following ways:

* Right-click the model in the Browser and select New > Technology Infrastructure Diagram .
* Right-click the background of any diagram and select Diagram > New Diagram > Technology |nfrastructure

Diagram .
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To create a new EAM with a technology infrastructure diagram, select File >New M odel , choose to create an enterprise
architecture diagram from the Model type list, choose Technology Infrastructure Diagram as the first diagram, and
click OK.

Networks (EAM)

A network allows computers to communicate with each other either locally or over large distances via
telecommunications.

A network can be created in the following diagrams:

« Technology infrastructure diagram (see 7echnology Infrastructure Diagram Basics on page 37)

Example
In this example, the client communicates with the server via an intranet:

e Ree
Intranet Client
Desidop

Creating a Network
You can create a network in any of the following ways:

e Use the Network tool in the diagram Palette.
* Select Model > Networks to access the List of Networks, and click the Add a Row tool.
* Right-click the model or package in the Browser, and select New > Network .

For general information about creating objects, see the Objects chapter in the Core Features Guide.

Network Properties
To open a network property sheet and view or edit its properties, double-click its diagram symbol or its Browser entry.

The General Tab contains the following properties:

Property Description

Name Specifies the name of the item, which should be clear and meaningful, and should convey the item's purpose
to non-technical users.

Code Specifies the technical name of the object, which is used for generating code or scripts
Comment Descriptive comment for the object.

Stereotype Extends the semantics of an object derived from existing objects but specific to your needs.
Type Specifies the type of the network.

Site Specifies the site within which the network is located.

The following tabs are also available:

* Role Associations — lists the people, organization units, and roles associated with the object (see Role
Associations on page 15).
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Servers, Workstations, Mobile Devices, and Network Nodes (EAM)

A software server is a commercial software environment, which contains a set of applications. A software server can be
deployed on a hardware server.

A hardware server is a device that serves data or other support for devices on the network. It usually has higher
specifications than client devices, such as workstations or maobile devices.

A workstation is a client machine to which an application or a server can be deployed.
A mobile device is designed to be easy to carry and used remotely to access the network.

Network nodes can represent other type of objects connected to the network (routers, switches, firewalls, modems,
printers, faxes, etc).

These objects can be created in the following diagrams:

< Technology infrastructure diagram (see 7echnology Infrastructure Diagram Basics on page 37)

Example

In this example, the field workstation and smartphone connect via the web to the server, which is also connected to a
network node of type printer:

Field Modestation
Crazktop

Uy
Internet

Smartphone
BladkBerry

Frintert
Printer

Creating a Software or Hardware Server, Workstation, Mobile Device, or Network Node
You can create these objects in any of the following ways:

e Use the appropriate tool in the diagram Palette.
* Select Model > Objects to access the appropriate object list, and click the Add a Row tool.
* Right-click the model or package in the Browser, and select New > Object .

For general information about creating objects, see the Objects chapter in the Core Features Guide.

Software and Hardware Server, Workstation, Mobile Device, and Network Node Properties

To open a software or hardware server, workstation, mobile device, or network node property sheet and view or edit its
properties, double-click its diagram symbol or its Browser entry.

The General Tab contains the following properties:

Property Description

Name Specifies the name of the item, which should be clear and meaningful, and should convey the item's purpose
to non-technical users.
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Property Description

Code Specifies the technical name of the object, which is used for generating code or scripts

Comment Descriptive comment for the object.

Type Specifies the type of the object.

Site Specifies the site to which the object is deployed.

Stereotype Extends the semantics of an object derived from existing objects but specific to your needs.

Multiple [hardware server, workstation and mobile device only] Specifies that the object represents multiple ma-
chines.

The following tabs are also available:

Detail — contains information to identify the object in the environment.

Deployment Instances — [not network node] lists the deployment instances (see Deployment Instances (EAM)on page
41) associated with the object.

Software Servers — [workstation, hardware server, and mobile device only] lists the software servers associated with
the object.

Role Associations — lists the people, organization units, and roles associated with the object (see Role
Associations on page 15).

Deployment Instances (EAM)

A deployment instance is an instance of another object that is deployed on a server or elsewhere in the environment.

A deployment instance can be created in the following diagrams:

Technology infrastructure diagram (see 7echnology Infrastructure Diagram Basics on page 37)

Example
In this example, an instance of the Suppliers database is stored on the Failover server:

Creating a Deployment Instance

You can create a deployment instance in any of the following ways:

Open the property sheet of the object to deploy and use the Add a Row tool on its Deployment Instances tab.

Use the Deployment Instance tool in the diagram Palette.

Select Model > Deployment I nstances to access the List of Deployment Instances, and click the Add a Row tool.
Right-click the model or package in the Browser, and select New > Deployment Instance.

Note: In all but the first method above, you must specify the object of which you are creating an instance, by opening the
deployment instance property sheet and specifying the object of which it is an instance in the Deployed object field.

For general information about creating objects, see the Objects chapter in the Core Features Guide.
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Deployment Instance Properties

To open a deployment instance property sheet and view or edit its properties, double-click its diagram symbol or its
Browser entry.

The General Tab contains the following properties:

Property Description

Name Specifies the name of the item, which should be clear and meaningful, and should convey the item's purpose
to non-technical users.

Code Specifies the technical name of the object, which is used for generating code or scripts.

Comment Descriptive comment for the object.

Stereotype Extends the semantics of an object derived from existing objects but specific to your needs.

Type Specifies the type of the deployment instance.

Deployed Object Specifies the object being deployed. Click the buttons to the right of the field to create a new object, select

an existing object, or to open the property sheet of the selected object.

Infrastructure Links (EAM)

An infrastructure link is an oriented link that is used to connect objects in the technology layer.

An infrastructure link can be created in the following diagrams:

< Technology infrastructure diagram (see 7echnology Infrastructure Diagram Basics on page 37)

Example
In this example, the Field Workstation accesses the internet:

i

Field Wotstation
Desdop

AN
Intemet

Creating an Infrastructure Link
You can create an infrastructure link in any of the following ways:

e Use the Infrastructure Link tool in the diagram Palette.
* Select Model > InfrastructureLinks to access the List of Infrastructure Links, and click the Add a Row tool.
* Right-click the model or package in the Browser, and select New > InfrastructureLinks.

For general information about creating objects, see the Objects chapter in the Core Features Guide.

Infrastructure Link Properties

Toopen an infrastructure link property sheet and view or edit its properties, double-click its diagram symbol or its Browser
entry.

The General Tab contains the following properties:

42 PowerDesigner®




Building Technology Layer Diagrams

Property Description

Name Specifies the name of the item, which should be clear and meaningful, and should convey the item's purpose
to non-technical users.

Code Specifies the technical name of the object, which is used for generating code or scripts

Comment Descriptive comment for the object.

Stereotype Extends the semantics of an object derived from existing objects but specific to your needs.

First object Specifies the object at the origin of the link.

Second object Specifies the object at the end of the link.

Type Specifies the type of the infrastructure link.

Protocol Specifies the protocol of the infrastructure link.

Physical type Specifies the physical type of the infrastructure link.
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Working with Enterprise Architecture Models

Enterprise architecture models benefit from the powerful model tools available in the PowerDesigner enterprise modeling
environment.

Customizing the Enterprise Architecture Modeling Environment

The PowerDesigner enterprise architecture modeling environment includes a set of parameters and configuration options
that define various aspects of the model content and behavior. You can set these parameters:

e At model creation
< After creating a model with default options and parameters
*  When creating a model template

Setting EAM Model Options

This section explains how to set global options for the objects in your EAM. These options apply only to the current
EAM.

For information about controlling the naming conventions of your models, see "Naming Conventions" in the Customizing
your Modeling Environment chapter of the Core Features Guide.

To set Model Settings, select Tools > M odel Options or right-click the diagram background and select Model Options
from the contextual menu.

The following options are available on this tab:

Option Description

Name/Code case sen- | Specifies that the names and codes for all objects are case sensitive, allowing you to have two objects with
sitive identical names or codes but different cases in the same model.

If you change case sensitivity during the design process, we recommend that you check your model to
verify that your model does not contain any duplicate objects.

Enable links to re- Displays a Requirements tab in the property sheet of every object in the model, which allows you to attach
quirements requirements to objects in your model. These attached requirements are kept synchronized with your
requirements model.

For more information, see the Requirements Modeling guide.

Setting EAM Display Preferences

PowerDesigner display preferences allow you to customize the format of object symbols, and the information that is
displayed on them.

To set EAM display preferences, select Tools > Display Preferences or right-click the diagram background and select
Display Preferences from the contextual menu.

All EAM object symbols are fully customizable both in terms of their format and the information displayed upon them.
For more information, see "Display Preferences™ in the Customizing your Modeling Environment chapter of the Core
Features Guide.

Generating an EAM from an EAM

You can generate another EAM from your EAM. When changes are made to the source model, they can be easily
propagated to any generated models by regenerating, using the Update Existing Model generation mode.
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1. Select Tools > Generate Enterprise Architecture Model to open the EAM Generation Options Window:
2. On the General tab, select to generate a new or update an existing model, and complete the appropriate options.

3. [optional] Click the Detail tab and set any appropriate options. We recommend that you select the Check model
checkbox to check the model for errors and warnings before generation.

4. [optional] Click the Target Models tab and specify the target models for any generated shortcuts.
5. [optional] Click the Selection tab and select or deselect objects to generate.
6. Click OK to begin generation.

Note: For detailed information about the options available on the various tabs of the Generation window, see the Linking
and Synchronizing Models chapter of the Core Features Guide.

Checking an Enterprise Architecture Model

You can check the validity of your enterprise architecture model at any time in one of the following ways:

e Press F4, or
* Select Tools > Check Model , or
* Right-click the diagram background and select Check Model from the contextual menu.

Application, Application Service, Component and Database Checks
The following model checks are made on applications, application services, components, and databases:

Check Description and Correction

Name and code uniqueness Names and codes must be unique in the model.
Manual correction: Modify the duplicate name/code.

Automatic correction: Appends a number to the duplicate name/code.

No deployment instance The object must be deployed as at least one deployment instance.
Manual correction: Deploy the object as a deployment instance.

Automatic correction: None

Application Link Checks
The following model checks are made on application links:

Check Description and Correction

Unsuitable application link The link type is not compatible with the link extremities. For example, if the link type is "use" the
type link must have a role player as one extremity.

Manual correction: Change the link type.

Automatic correction: Changes the link type.

Contract Checks
The following model checks are made on contracts:
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Check Description and Correction
Contract name and code Contract names and codes must be unique in the model.
unigueness

Manual correction: Modify the duplicate name/code.

Automatic correction: Appends a number to the duplicate name/code.

Contracts are not correctly Contracts must have at least one incoming and one outgoing link with an application service, a
used business service, or a role.

Manual correction: Create input and output links with the appropriate objects.

Automatic correction: None

Multiple types of input All input objects must be of the same type.
Manual correction: Remove any input links that are not of the same type.

Automatic correction: None

Same input and output link Contracts cannot be the intermediary between the same service.
Manual correction: Modify the input or output link.

Automatic correction: None

Deployment Instance Checks
The following model checks are made on deployment instances

Check Description and Correction

Deployment instance name Deployment instance names and codes must be unique in the model.

and code uniqueness Manual correction: Modify the duplicate name/code

Automatic correction: Appends a number to the duplicate name/code

Deployment Instance not de- | Each deployment instance must be deployed to a platform or server.

ployed Manual correction: Deploy the deployment instance to the appropriate object.
Automatic correction: None
No Object to Deploy The deployment instance must be an instance of some object.

Manual correction: Specify the object to be deployed in the deployment instance property sheet
General tab.

Automatic correction: None

Unsuitable Software Server The deployment instance must be suitable for the server software type to which it is deployed.

Manual correction: Modify the software server type or delete the deployment instance from the
software server.

Automatic correction: None

Form Checks
The following model checks are made on forms:
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Check

Description and Correction

Form name and code unique-
ness

Form names and codes must be unique in the model.
Manual correction: Modify the duplicate name/code.

Automatic correction: Appends a number to the duplicate name/code

No deployment instance

The object must be deployed as a deployment instance.
Manual correction: Deploy the object as a deployment instance.

Automatic correction: None

Hardware Server, Mobile Device, Network Node and Workstation Checks

The following model checks are made on hardware servers, mobile devices, network nodes and workstations:

Check

Description and Correction

Name and code uniqueness

Names and codes must be unique in the model.
Manual correction: Modify the duplicate name/code.

Automatic correction: Appends a number to the duplicate name/code.

Serial number uniqueness

Serial numbers must be unique in the model.

Manual correction: Modify the duplicate serial numbers.

Automatic correction: Appends a number to the duplicate serial numbers.

Asset number uniqueness

Asset numbers must be unique in the model.
Manual correction: Modify the duplicate asset numbers.

Automatic correction: Appends a number to the duplicate asset numbers.

Mac address uniqueness

Mac addresses must be unique in the model.
Manual correction: Modify the duplicate mac addresses.

Automatic correction: Appends a number to the duplicate mac addresses.

Isolated node

The object must be linked with at least one other node.
Manual correction: Link the object to an appropriate object.

Automatic correction: None

Network Checks

The following model checks are made on networks:

Check

Description and Correction

Network name and code
unigueness

Network names and codes must be unique in the model.
Manual correction: Modify the duplicate name/code.

Automatic correction: Appends a number to the duplicate name/code.

Isolated node

The object must be linked with at least one other node.
Manual correction: Link the object to an appropriate object.

Automatic correction: None
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The following model checks are made on organization units:

Check

Description and Correction

Organization Unit name and
code uniqueness

Organization Unit names and codes must be unique in the model.
Manual correction: Modify the duplicate name/code.

Automatic correction: Appends a number to the duplicate name/code.

Manager must belong to the
managed organization

The manager specified in the Manager field must be listed in the People tab.

Manual correction: Add the manager in the list of people on the People tab.

Automatic correction: Adds the manager to the list of people.

Person Checks

The following model checks are made on people:

Check

Description and Correction

Person code uniqueness

People codes must be unique in the model.
Manual correction: Modify the duplicate code.

Automatic correction: Appends a number to the duplicate code.

No organization unit

A person must belong to an organization unit.
Manual correction: Add the person to an organization unit.

Automatic correction: None

Circular dependency through
manager property

A person cannot manage herself.

Manual correction: Remove the person from the Manager field of her own property sheet.

Automatic correction: None

Software Server Checks

The following model checks are made on software servers:

Check

Description and Correction

Software Server name and
code uniqueness

Software server names and codes must be unique in the model.
Manual correction: Modify the duplicate name/code.

Automatic correction: Appends a number to the duplicate name/code.

Software Server not deployed

A software server must be deployed to a physical server.
Manual correction: Deploy the software server in the appropriate object.

Automatic correction: None

Software Server serial number
uniqueness

Software Server serial numbers must be unique in the model.
Manual correction: Modify the duplicate serial numbers.

Automatic correction: Appends a number to the duplicate serial numbers.
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Exporting and Importing Objects to and from Other Models

An enterprise architecture model is intended to provide a big picture view of your organization and to permit you to
decompose your functions, processes, and systems to a certain extent, but it cannot show detailed information about how
they are (or will be) implemented. In order to model such information, you will want to use other PowerDesigner models,
such as the conceptual, logical, physical data models, business process models, or object-oriented models.

The EAM provides wizards to export EA objects to these other, lower-level models and to import implementation objects
to be represented in the EAM.

Exporting Objects from an EAM to Another Model

The Export Objects Wizard helps you to export EAM objects to other PowerDesigner models to allow you to model their
implementation in detail.

1. Select Tools > Export Objects to open the Export Objects Wizard:
Export Objects wizard x

Welcome to the Enterprige drchitecture Model Export Objects Wizard, Thiz wizard
helps you to expart objects fram an Enterprize Architecture Model to any other
FowerDegigner model. Extended dependency links are created between the
Enterprize Architecture Model objects and the objects that are created from them.

Select the objects that pou want to export:

Eﬁ&cme j £

B~ Oy~ = 4

M arne | Code | Parent |
= Distribution Driztribwtion Acme
[ ] Manufacturing t anufacturing Acme

[ A[* I\ Frocess Map £ Architecturs Area b Site b Crganization Unit b Ferson

Selected ohjects]: 142

< Back I MHeut » I Finish | Cancel | Help |

2. Specify the EAM objects that you want to export to another model by selecting them from among the sub-tabs in the
selection field, and then click Next.

3. Specify the model to which you want to export the EAM objects from among the models open in the workspace, and
then click Next.

4. Specify the kind of object that you want to create in the target model.

5. [optional] Enter or select a stereotype to identify the type of dependency that will be created between the EAM objects
and the objects that you are creating from them. For example, "Implemented by".

6. Click Finish to start the export.

The EAM objects are exported to and created in the specified model.

Importing Objects from Another Model into an EAM

The Import Objects Wizard helps you to import objects from other PowerDesigner models into an EAM to model their
placement in your enterprise architecture.
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1. Select Tools > Import Objects to open the Import Objects Wizard:
x|

WWelcome to the Enterprize Architecture Model Impart Objects \Wizard. This wizard
helps pou to import objects from any other PowerDesigner model as Enterprize
Architecture Model objects. Extended dependency links are created between the
original objectz and the Enterprize Architecture Model objects that are created from
them.

Select the model from which pou want to impart objects:

< Bacl I Mest » I Firmsty | Cancel | Help |

2. Specify the model from which you want to import the objects to the EAM from among the models open in the
workspace, and then click Next.

3. Specify the objects that you want to import to the EAM by selecting them from among the sub-tabs in the selection
field, and then click Next.

4. Specify the kind of object that you want to create in the EAM and the location (package) where you want to create
them.

5. [optional] Enter or select a stereotype to identify the type of dependency that will be created between the objects and
the EAM obijects that you are creating from them. For example, "Implements".

6. Click Finish to start the import.

The objects are imported to and created in the EAM.

Importing Visio Diagrams into PowerDesigner

Importing your Visio diagrams into PowerDesigner's rich metadata environment enables you to link your architectural
objects with the objects that will implement them, and to profit from PowerDesigner's powerful impact and lineage
analysis features. You must have installed Visio 2002 or higher and have selected to install the Visio plug-in from the
PowerDesigner installer.

You can import the following diagrams into a PowerDesigner BPM or EAM:

Visio diagram PowerDesigner

Audit Diagram BPM Analysis/ Business Process Diagram
Basic Flowchart BPM Analysis/ Business Process Diagram
Cross-functional flowchart BPM Analysis/ Business Process Diagram
Business Process/ Data flow Diagram BPM Data Flow Diagram

Software/ Data Flow Diagram

Event Driven Process Chain Diagram BPM Business Process Diagram

Enterprise Architecture Modeling 51



Working with Enterprise Architecture Models

Visio diagram

PowerDesigner

ITIL Diagram

BPM Business Process Diagram

Work Flow Diagram

BPM Business Process Diagram

Flowchart/ SDL Diagram

BPM Business Process Diagram

Organization Chart

EAM Organization Chart Diagram

Software/ Enterprise Application

EAM Application Architecture Diagram

Network/ Basic Network Diagram/ Detailed Net-
work Diagram

EAM Technology Infrastructure Diagram

Active Directory

EAM Organization Chart Diagram

LDAP Directory

EAM Organization Chart Diagram

1. Open your diagram in Visio and select Power Designer > Export to Power Designer model to open the

PowerDesigner Export wizard:

! PowerDesigner Export Wizard

Specify PowerDesigner Model

Model type: Business Process Madel
Eirst diagram: | Business Process Diagram

Model name: | Visio model

n
Specify the type and name of the model ta which wou wank o export vour diagrams., E "t

EOX

=

Rt

i

OF H Cancel ]

2. Specify the type of model to which you want to export your diagram, enter a name for the model to be created, and

then click OK to start the export.

3. When the export is complete, click OK to close the wizard.

The diagram is opened as a new BPM or EAM in PowerDesigner.
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