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PART I

The PowerDesigner Interface

The chapters in this part introduce you to the PowerDesigner® interface and the core concepts
available for all kinds of models.
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CHAPTER 1 Getting Started with PowerDesigner

PowerDesigner is a graphical and easy-to-use enterprise modeling environment.

It provides:

• Integrated modeling through standard methodologies and notations:
Data (E/R, Merise)
Business (BPMN, BPEL, ebXML)
Application (UML)

• Automatic code generation through customizable templates:
SQL (with more than 50 supported DBMSs)
Java
.NET

• Powerful reverse engineering capabilities to document and update existing systems
• A scalable enterprise repository solution with strong security and versioning capabilities

to aid multi-user development
• Automated, customizable reporting capabilities
• An extensible environment, permitting you to add new rules, commands, concepts and

attributes to your modeling and coding methodologies
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The Welcome Page
The Welcome page gives you one-click access to all your recent projects, workspaces, and
models, as well as providing a direct link to the New Model and New Project dialogs and a
range of help materials. To suppress this page, select the Do not show this page again check
box. You can redisplay it at any time by selecting View > Welcome Page.

By default, the following items are available:

• Getting Started
• Create Model - Opens the New Model dialog to let you create a model (see Creating a

Model on page 12).
• Create Project - Opens the New Project dialog to let you create a project (see Creating

a Project on page 38).

  4 PowerDesigner  



• Open Model or Project - Opens a standard Open dialog to let you browse for a model
or project to open.

• Examples - Opens the PowerDesigner Examples folder to let you select an example
model to open.

• Help - Opens the PowerDesigner online help.
• What's New in PowerDesigner - Opens the PowerDesigner New Features Summary.
• Documentation and Videos - Opens a Web page listing the available PowerDesigner

documentation and videos.
• PowerDesigner Web Site - Opens the PowerDesigner page on the Sybase website.
• PowerDesigner Newsgroup - Opens the PowerDesigner newsgroup page on the

Sybase website.
• Recent projects and workspaces - Lists your most recent projects and workspaces. Click

a project or workspace to open it.
• Recent models - Lists your most recent models. Click a model to open it.

PowerDesigner Interface Overview
A typical PowerDesigner window contains various panes providing you with various views on
your modeling project.

The following components are visible:

• The Browser - displays your models and the objects belonging to them, and allows you to
rapidly navigate between them (see Organizing Your Models in the Browser on page 81).
The Browser also has a tab that gives you access to a PowerDesigner repository (see the

CHAPTER 1: Getting Started with PowerDesigner
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Working with the Repository manual, where you can store all your models and associated
files.

• The canvas - is the primary pane that displays your present model diagram (see Diagrams
on page 167) or report outline (see Chapter 6, Reports on page 205).

• The palette - provides graphical tools to help you quickly build model diagrams. The tools
available will change depending on the type of diagram (see Creating an Object from the
Palette on page 101).

• The Output window - shows the progress of any PowerDesigner process, such as checking
a model or generating or reverse engineering a database.

• The Result List - displays the results of a search or a model check.

In addition, you will work extensively with:

• Object property sheets - which permit you to view and edit the object's properties (see 
Object Properties on page 104):

You can access an object's property sheet by double-clicking its symbol or browser entry,
or right-clicking it and selecting Properties.

• Object lists - provide a spreadsheet-like presentation of, and allow for the easy creation and
modification of objects in your model (see Object Lists on page 117):

  6 PowerDesigner  



Lists are available under the Model menu and on the property sheets of composite objects
such as entities, tables, and classes, which contain subobjects.
The tools in the list toolbar allow you to create or add and to copy and delete objects in the
list, and open their property sheets. You can Ctrl-click to select multiple objects in the list
and then edit their properties simultaneously. Other tools allow you to control the columns
displayed in the list and to filter the list.

Modeling with PowerDesigner
PowerDesigner provides a unique set of enterprise modeling tools that bring together the
standard techniques and notations of Business Process Modeling, Data Modeling and UML
application modeling with other powerful features to assist you in analyzing, designing,
building, and maintaining your applications, using software engineering best practices.

The PowerDesigner enterprise modeling solution enables you to closely integrate the design
and maintenance of your application's core data layers with your project requirements,
business processes, OO code, XML vocabularies, and database replication information. By
providing you with a comprehensive set of models at all levels of abstraction, PowerDesigner
helps you broaden the reach of your iterative design process to all aspects of your system
architecture, from conception to deployment, and beyond.

PowerDesigner does not impose any particular software engineering methodology or process.
Each company can implement its own workflow, defining responsibilities and roles,
describing what tools to use, what validations are required, and what documents to produce at
each step in the process.

CHAPTER 1: Getting Started with PowerDesigner
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A development team will comprise multiple user roles, including business analysts, analysts
and designers, database administrators, developers, and testers, each of whom will use a
different combination of PowerDesigner components:

• Business Analysts – define the architecture of the organization, the business requirements
and high-level business flows.
They may use an Enterprise Architecture Model (EAM)Enterprise Architecture Model
(EAM) for providing a big picture of the organization, for defining its structure, and
analyzing high-level functions, processes, and flows. These architectural objects can be
attached to implementation objects in any of the other models.
They may use a Requirements Model (RQM) for defining business requirements to be
refined into technical requirements by Analysts and Designers. An RQM describes a
project by listing and explaining precisely what features must be implemented during a
development process, and who is responsible for them. These requirements can then be
attached to any object in any of the other models in order to trace where, and how, they are
met.
They may also use a Business Process Model (BPM) to define the high-level business
process flows that describe existing and new systems, and to simulate business processes
to reduce time and resource and increase revenue. A BPM represents your organization's
processes in real business terms, and can be used as a design tool to identify your business
needs, organize them in a hierarchy, display your processes graphically, and then generate
components in process languages such as BPEL4WS.

• Data Analysts and Designers - will map technical requirements to business requirements.
Going deeper into the analysis, you can define Use Cases (using an OOM, see below), and
map them to requirements. You can write functional specifications and define more
precisely the nature and details of each process, the application and its data structure. You
will use a BPM, and additionally a Conceptual Data Model (CDM), which is a platform-
independent representation of a system, giving an abstract view of its static data structures.
A PowerDesigner CDM permits real normalized data structures with many-to-many and
super/sub-type relationships, and provides a clear view of business data across all systems,
making system information accessible to business users, system architects, and business
analysts.

• Database Administrators use the well-defined data structure to optimize, denormalize, and
create the database. You will use a Physical Data Model (PDM), which is a representation
of a real database and associated objects running on a server with complete information on
the structure of the physical objects, such as tables, columns, references, triggers, stored
procedures, views, and indexes.
A PowerDesigner PDM can be used to generate all of the database code for any of the 50
supported RDBMSs. The PDM can be created by reverse engineering from a script or from
a live server through a standard ODBC connection. By maintaining a PDM and a CDM,
you can ensure that your final implementation exactly matches your system requirements,
and that your analysis and design efforts are reflected exactly in your actual systems.
You may also use a Logical Data Model (LDM), which can act as a bridge between a CDM
and a PDM. More technically precise than a CDM, an LDM allows you to resolve many-
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to-many and super/sub-type relationships, de-normalize your data structures, and define
indexes, without specifying a particular RDBMS.
If you are responsible for database replication, you will also use an Information Liquidity
Model (ILM), which provides a global representation of the replication of information
from a source database to one or several remote databases.

• Developers will write technical specifications in an RQM, and will model the application,
defining object structures and behaviors, and Object/Relational mappings.
You will use an Object-Oriented Model (OOM), which uses standard UML diagrams and
notation to represent your objects and their interactions. It can be reverse-engineered from,
and used to generate code for Java, .NET and many other languages. Close integration with
your BPM, CDM, and PDM can greatly simplify the maintenance and development of
your system.
You may also use an XML Model (XSM) to graphically model the complex structure of an
XML file. Its diagram and tree views give you a global and schematic view of all the
document elements, and this type of model can be used to generate DTDs, and XSDs
directly from a PDM or OOM.

• Team Leaders will have an interest in all the models, and will want to ensure that all the
requirements, design objects and documents are linked together via traceability links to
allow for impact analysis and change management.
You will establish a PowerDesigner Enterprise Repository as a central point of storage.
The repository supports metadata sharing, versioning, impact analysis, and reporting for
models and other system documents, has a robust security model, and supports true
enterprise scalability from a single repository instance.
You can ensure that up-to-date and accurate documentation is produced and widely
available. The full-featured Report Editor allows you to automate the production of
detailed reports (in RTF and HTML formats) on any or all of the components of your
system for sharing design information within the project team and across the whole
company.
A Free Model (FEM) can be used to create diagrams to explain the architecture of your
system and applications, the use-case scenarios of applications, flowcharts, and other
graphics.

• Testers will use the RQM, CDM, and other models, together with the design documents to
understand how the application should work and how it is developed.

Linking and Synching
PowerDesigner's sophisticated inter-model and code and database generation capabilities
allow you to synchronize your models with each other and the applications they represent.

The following illustration shows the various file types that PowerDesigner can import and
export and the kinds of inter-model generation (such as CDM to LDM and PDM and PDM to
XSM and OOM) possible:
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Additional forms of linking are provided by:

• Requirements traceability links - allow you to associate an object with a requirement. For
more information, see the Requirements Modeling guide.

• Enterprise architecture objects – can be associated with objects in other models. For more
information, see the Enterprise Architecture Modeling guide.

• Business process data – can be associated with objects in CDMs, PDMs, and OOMs. For
more information, see the Business Process Modeling guide.

• Information liquidity inputs and outputs – are provided by BPMs, PDMs, and XSMs. For
more information, see the Information Liquidity Modeling guide.

• Shortcuts and replications - allow you to reuse an object from one model in another. For
more information, see Chapter 11, Shortcuts and Object Replications on page 355.
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• Extended links and extended dependencies - allow you to link any object in any model to
another. For more information, see Creating Extended Dependencies on page 334.

For detailed information about PowerDesigner's link and sync capabilities, see Part II,
Linking and Synchronizing Models on page 329.

PowerDesigner Documentation
Full documentation is provided in the form of context-sensitive help (available by pressing F1)
and as PDFs.

The following manuals are provided with your PowerDesigner installation:

• New Features Summary
• Installation Guide
• Core Features Guide
• Requirements Modeling
• Enterprise Architecture Modeling
• Business Process Modeling
• Data Modeling
• Information Liquidity Modeling
• Object-Oriented Modeling
• XML Modeling
• Working with the Repository
• Customizing and Extending PowerDesigner

This documentation is available:

• as online help by pressing F1
• as PDFs by selecting Help > Online Documentation
• for download from http://sybooks.sybase.com

Demonstration videos are also available. They can be installed with PowerDesigner (select
Help > Tutorial Videos) or viewed from the installation CD.

For documentation of the PowerDesigner metamodel, click Help > Metamodel Objects
Help (or click the Find in MetaModel Objects Help button at the bottom-right of the Version
Info tab of the property sheet of any object).
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Creating a Model
You create a new model by selecting File > New Model.

Note: A project can provide a convenient environment for working with multiple
interconnected models and other files. For detailed information about working with projects,
see Chapter 2, Projects and Frameworks on page 37.

Note: For information about creating new models in the PowerDesigner Eclipse and Visual
Studio plugins, see Creating a Model in Eclipse on page 456 and Creating a Model in Visual
Studio on page 471.

The New Model dialog is highly configurable, and your administrator may have hidden
options that are not relevant for your work or provided templates or predefined models to
guide you through model creation. When you open the dialog, one or more of the following
buttons will be available on the left hand side:

• Categories - which provides a set of predefined models and diagrams sorted in a
configurable category structure.

• Model types - which provides the classic list of PowerDesigner model types and
diagrams.

• Template files - which provides a set of model templates sorted by model type.
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1. Select File > New Model to open the New Model dialog.

2. Click a button, and then select a category or model type ( as appropriate ) in the left-hand
pane.

The following table lists the PowerDesigner model types:

Ico
n

Model definition File
ext

Back-
up ext

Requirements Model. A requirements model (RQM) helps you an-
alyze any kind of written requirements and link them with users and
groups who will implement them and with design objects in other
models. You can use an RQM to represent any structured document
(e.g. functional specification, test plan, business goals, etc.) and im-
port and export hierarchies of requirements as MS Word documents.

.rqm .rqb

Enterprise Architecture Model. An enterprise architecture model
(EAM) helps you analyze and document your organization and its
business functions, along with the applications and systems that sup-
port them and the physical architecture on which they are imple-
mented.

.eam .eab
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Ico
n

Model definition File
ext

Back-
up ext

Business Process Model. A business process model (BPM) helps you
identify, describe, and decompose business processes. You can ana-
lyze your system at various levels of detail, and focus alternatively on
control flow (the sequence of execution) or data flow (the exchange of
data). You can use BPEL, BPMN, and many other process languages.

.bpm .bpb

Conceptual Data Model. A conceptual data model (CDM) helps you
analyze the conceptual structure of an information system, to identify
the principal entities to be represented, their attributes, and the rela-
tionships between them. A CDM is more abstract than a logical
(LDM) or physical (PDM) data model.

.cdm .cdb

Logical Data Model. A logical data model (LDM) helps you analyze
the structure of an information system, independent of any specific
physical database implementation. An LDM has migrated entity
identifiers and is less abstract than a conceptual data model (CDM),
but does not allow you to model views, indexes and other elements
that are available in the more concrete physical data model (PDM).

.ldm .ldb

Physical Data Model. A physical data model (PDM) helps you to
analyze the tables, views, and other objects in a database, including
multidimensional objects necessary for data warehousing. A PDM is
more concrete than a conceptual (CDM) or logical (LDM) data
model. You can model, reverse-engineer, and generate for all the
most popular DBMSs.

.pdm .pdb

Information Liquidity Model. An information liquidity model (ILM)
provides a global view of the movement of information in your or-
ganization. You can analyze and document where your data origi-
nates, where it moves to, and how it is transformed on the way,
including replications and ETL.

.ilm .ilb

Object Oriented Model. An object-oriented model (OOM) helps you
analyze an information system through use cases, structural and be-
havioral analyses, and in terms of deployment, using the Unified
Modeling Language (UML). You can model, reverse-engineer, and
generate for Java, .NET and other languages.

.oom .oob

XML Model. An XML model (XSM) helps you analyze an XML
Schema Definition (.XSD), Document Type Definition (.DTD) or
XML-Data Reduced (.XDR) file. You can model, reverse-engineer,
and generate each of these file formats.

.xsm .xsb

Free Model. A free model (FEM) provides a context-free environ-
ment for modeling any kind of objects or systems. It is generally
associated with a set of extensions, which allow you to define your
own concepts and graphical symbols.

.fem .feb
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Ico
n

Model definition File
ext

Back-
up ext

Multi-Model Report. A multimodel report (MMR) is a PowerDe-
signer report that can document any number of models together and
show the links between them. To create such a report, you must have
at least one model open in the workspace, and you can add additional
models at any time.

.mmr .bmr

3. Select an item in the right-hand pane. Depending on how your New Model dialog is
configured, these items may be first diagrams or templates on which to base the creation of
your model.

Use the Views tool on the upper right hand side of the dialog to control the display of the
items.

4. Enter a model name.

The code of the model, which is used for script or code generation, is derived from this
name according to the model naming conventions.

5. [when available] Select a resource file , and specify whether to:

• Share the   resource file  definition – creates a link to the file in the Resource
Files\  directory. Changes made to the target affect all models that share it.

• Copy the   resource file   definition in model – makes a copy of the resource file and
saves it with the model. Changes made to the target affect only the current model.

For more information about PowerDesigner resource files, and how to add extensions to
them, see the Customizing and Extending PowerDesigner manual.

6. [optional] Click the Select Extensions button and attach one or more extensions to your
model.

7. Click OK to create and open the model .

Note: Sample models are available in the Example Directory.

Note: For information about attaching XEMs to your model, see Attaching Extensions on
page 15. For information about the diagrams that are available in these model types, see 
PowerDesigner Models and Diagrams on page 16.

Attaching Extensions
The Select Extensions dialog allows you to attach extensions to your model at creation time.
Extended model definitions may contain additional types of objects or extensions to standard
objects, along with additional generation targets and other extensions to PowerDesigner's
standard capabilities.

1. Click the Select Extensions tool in the New Model dialog.

2. Review the different sorts of extensions available by clicking the sub-tabs and select one or
more to attach to your model.
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3. Select one of the following radio buttons:

• Share – creates a link to the XEM file. Changes made to the target affect all models that
share it.

• Copy – creates a copy of the XEM and saves it with the model. Changes made to the
target affect only the current model.

4. Click OK to close the dialog and return to the New Model dialog.

Note: You can attach extensions to your model after creation by selecting Model >
Extended Model Definitions and clicking the Import an Extended Model Definition
tool.

PowerDesigner Models and Diagrams
PowerDesigner provides a wide range of models and diagrams for all your modeling needs.

• A requirements model (RQM) helps you analyze any kind of written requirements and link
them with users and groups who will implement them and with design objects in other
models. You can use an RQM to represent any structured document (e.g. functional
specification, test plan, business goals, etc.) and import and export hierarchies of
requirements as MS Word documents.
• A requirements document view displays a list of written requirements in a hierarchic

grid.
• A traceability matrix view displays the links between requirements and objects from

other types of models, external files or other requirements.
• A user allocation matrix view displays the links between requirements and the users

and groups who will fulfill them.
• An enterprise architecture model (EAM) helps you analyze and document your

organization and its business functions, along with the applications and systems that
support them and the physical architecture on which they are implemented.
• A process map provides a graphical view of your business architecture, and helps you

identify your business functions and high-level processes, independent of the people
and business units who fulfill them.

• An organization chart provides a graphical view of your organization as a tree
structure, and helps you analyze and display the relationships between organization
units (divisions, groups, teams, etc), individuals, and roles.

• A business communication diagram provides a graphical view of your organization,
and helps you analyze, the relationships, flows, and other connections between
business functions, organization units, roles, and sites.

• A city planning diagram provides a graphical view of the big picture of your enterprise
architecture, using the metaphor of planning the infrastructure of a city to represent the
organization of systems, applications, etc into architectural areas.

• A service-oriented diagram provides a graphical view of your business and application
services and the relationships between them, and helps you associate applications and
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other application layer objects with business services and processes to assist with SOA
design.

• An application architecture diagram provides a high-level graphical view of the
application architecture, and helps you identify applications, sub-applications,
components, databases, services, etc, and their interactions.

• A technology infrastructure diagram provides a high-level graphical view of the
physical architecture required to support the application architecture.

• A business process model (BPM) helps you identify, describe, and decompose business
processes. You can analyze your system at various levels of detail, and focus alternatively
on control flow (the sequence of execution) or data flow (the exchange of data). You can
use BPEL, BPMN, and many other process languages.
• A business process diagram (or process flow diagram) provides a graphical view of the

control flow (the sequence of execution) or data flow (the exchange of data) between
processes at any level in your system.

• A process hierarchy diagram (or functional decomposition diagram) provides a
graphical view of the functions of a system and helps you decompose them into a tree
of sub-processes.

• A process service diagram provides a graphical view of the services, operations, and
interfaces available in your system.

• A conceptual data model (CDM) helps you analyze the conceptual structure of an
information system, to identify the principal entities to be represented, their attributes, and
the relationships between them. A CDM is more abstract than a logical (LDM) or physical
(PDM) data model.
• A conceptual data diagram provides a graphical view of the conceptual structure of an

information system, and helps you identify the principal entities to be represented,
their attributes, and the relationships between them.

• A logical data model (LDM) helps you analyze the structure of an information system,
independent of any specific physical database implementation. An LDM has migrated
entity identifiers and is less abstract than a conceptual data model (CDM), but does not
allow you to model views, indexes and other elements that are available in the more
concrete physical data model (PDM).
• A logical data diagram provides a graphical view of the structure of an information

system, and helps you analyze the structure of your data system through entities and
relationships, in which primary identifiers migrate along one-to-many relationships to
become foreign identifiers, and many-to-many relationships can be replaced by
intermediate entities.

• A physical data model (PDM) helps you to analyze the tables, views, and other objects in a
database, including multidimensional objects necessary for data warehousing. A PDM is
more concrete than a conceptual (CDM) or logical (LDM) data model. You can model,
reverse-engineer, and generate for all the most popular DBMSs.
• A physical data diagram provides a graphical view of your database structure, and

helps you analyze its tables (including their columns, indexes, and triggers), views, and
procedures, and the references between them.
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• A multidimensional data diagram provides a graphical view of your datamart or data
warehouse database, and helps you identify its facts, cubes and dimensions.

• An information liquidity model (ILM) provides a global view of the movement of
information in your organization. You can analyze and document where your data
originates, where it moves to, and how it is transformed on the way, including replications
and ETL.
• An information liquidity diagram provides a high-level graphical view of the liquidity

of your information, including data sources, replications, and ETL operations.
• A data transformation diagram provides a graphical view of the inputs, outputs, and

steps involved in a data transformation task.
• A transformation control flow diagram provides a graphical view of the order in which

a series of data transformation tasks is linked together in a control flow.
• An object-oriented model (OOM) helps you analyze an information system through use

cases, structural and behavioral analyses, and in terms of deployment, using the Unified
Modeling Language (UML). You can model, reverse-engineer, and generate for
Java, .NET and other languages.
• A use case diagram is a UML diagram that provides a graphical view of the

requirements of your system, and helps you identify how users interact with it.
• A class diagram is a UML diagram that provides a graphical view of the classes,

interfaces, and packages that compose a system, and the relationships between them.
• An object diagram is a UML diagram that provides a graphical view of the structure of

a system through concrete instances of classes (objects), associations (instance links),
and dependencies.

• A composite structure diagram is a UML diagram that provides a graphical view of the
classes, interfaces, and packages that compose a system, including the ports and parts
that describe their internal structures.

• A package diagram is a UML diagram that provides a high-level graphical view of the
organization of your application, and helps you identify generalization and
dependency links between the packages.

• A sequence diagram is a UML diagram that provides a graphical view of the
chronology of the exchange of messages between objects and actors for a use case, the
execution of an operation, or an interaction between classes, with an emphasis on their
chronology.

• A communication diagram is a UML diagram that provides a graphical view of the
interactions between objects for a use case scenario, the execution of an operation, or
an interaction between classes, with an emphasis on the system structure.

• An interaction diagram  is a UML diagram that provides a high-level graphical view of
the control flow of your system as it is decomposed into sequence and other interaction
diagrams.

• An activity diagram is a UML diagram that provides a graphical view of a system
behavior, and helps you functionally decompose it in order to analyze how it will be
implemented.
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• A statechart diagram is a UML diagram that provides a graphical view of a State
Machine, the public behavior of a classifier (component or class), in the form of the
changes over time of the state of the classifier and of the events that permit the
transition from one state to another.

• A component diagram is a UML diagram that provides a graphical view of the
dependencies and generalizations among software components, including source code
components, binary code components, and executable components.

• A deployment diagram is a UML diagram that provides a graphical view of the
physical configuration of run-time elements of your system.

• An XML model (XSM) helps you analyze an XML Schema Definition (.XSD), Document
Type Definition (.DTD) or XML-Data Reduced (.XDR) file. You can model, reverse-
engineer, and generate each of these file formats.
• An XML diagram provides a graphical view of the elements that comprise an XML

schema definition in a tree format.
• A free model (FEM) provides a context-free environment for modeling any kind of objects

or systems. It is generally associated with a set of extensions, which allow you to define
your own concepts and graphical symbols.
• A free diagram provides a context-free graphical environment for modeling any kind

of objects or systems.
• A multimodel report (MMR) is a PowerDesigner report that can document any number of

models together and show the links between them. To create such a report, you must have
at least one model open in the workspace, and you can add additional models at any time.
• A multimodel report (MMR) is a PowerDesigner report that can document any number

of models. To create such a report, you must have at least one model open in the
workspace, and you can add additional models at any time.

Saving a Model
Each model is saved in a separate file, with an extension specific to its model type. When you
save a model, PowerDesigner also automatically creates a backup copy.

1. Select File > Save.

or

Click the Save tool in the PowerDesigner toolbar.

or

Right-click the model in the Browser and select Save.

2. Right-click the model and select Close.
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Next Steps
Now that you are familiar with the PowerDesigner Interface, you will want to start
experimenting with a particular type of model suitable to your needs:

• Requirements Model (RQM) - Now turn to the Requirements Data Modeling guidewhere
you will learn how to:
• Add, modify, promote and demote requirements in the requirements hierarchy
• Allocate requirements to particular team members and add traceability links to other

model components
• Import requirements from a structured MS Word document
• View traceability and user allocation reports

• Enterprise Architecture Model (EAM) - Now turn to the Enterprise Architecture Modeling
guide where you will learn how to:
• Create diagrams in the business, application, and technology layers
• Import Visio diagrams
• Export and Import objects to and from other models

• Business Process Model (BPM) - Now turn to the Business Process Modeling guide where
you will learn how to:
• Create Process Hierarchy, Business Process, Process Service, and Composite Process

diagrams
• Manipulate Service Description Objects
• Generate an executable BPM, and implement processes

• Conceptual Data Model (CDM), Logical Data Model (LDM), or Physical Data Model
(PDM) - Now turn to the Data Modeling guide where you will learn how to:
• Create CDM entities and relationships between them
• Create LDM or PDM tables, columns, primary keys, indexes, and references and

define referential integrity
• Create PDM views, triggers, and abstract data types
• Create business rules, domains, and data items
• Generate a PDM from your CDM or LDM
• Reverse engineer from and generate to database scripts
• Work with PDM multidimensional diagrams

• Information Liquidity Model (ILM) - Now turn to the Information Liquidity Modeling
guide where you will learn how to:
• Define databases, replication processes, event scripts, and other replication objects
• Reverse engineer from and generate to the Replication Server® and Mobilink

replication engines
• Object-Oriented Model (OOM) - Now turn to the Object-Oriented Modeling guide where

you will learn how to:
• Design class, use case, and other standard UML diagrams
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• Generate a PDM with O/R mapping
• Create an EJB
• Deploy a component

• XML Model (XSM) - Now turn to the XML Modeling guide where you will learn how
to:
• Define elements, entities, and other components of an XML schema
• Reverse engineer from and generate to DTD, XSD, and XDR files
• Generate an XSM from a PDM or OOM

Connecting to a Database
PowerDesigner allows you to define data connections to access information in different
database management systems (DBMSs) using Structured Query Language (SQL).

A data connection processes function calls and SQL requests coming from PowerDesigner
and sends them to a data source, and returns results to PowerDesigner.

The PowerDesigner physical data model (PDM) and information liquidity model (ILM) allow
you to define data connections for target databases in order to generate your models and
reverse engineer your data sources. The PowerDesigner repository requires a database to store
your models and other design documents.

See the Physical Data Model and Information Liquidity Model users guides, and Working
with the Repository.

PowerDesigner supports various forms of connection, and your choice will depend on the
interface that you have already installed:

You have... Configure a connection of type...

ODBC driver ODBC machine or file data source

DBMS client Native connection profile

JDBC driver JDBC connection profile

For information about connecting with an ODBC driver, see Configuring ODBC machine and
file data sources on page 22.

For information about connecting with a DBMS client or JDBC driver, see Configuring
connection profiles on page 24.
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Configuring ODBC Machine and File Data Sources
There are three types of Open Database Connectivity (ODBC) data sources:

Data source Description

Machine Data source is created on the client machine, and is available to the user currently
logged onto the system. Machine data sources are stored in the part of the registry
containing settings for the current user.

System Data source is created on the client machine, and is available to all users regard-
less of whether a user is logged onto the system or not. System data sources are
stored in the part of the registry containing settings for the current machine.

File Data source is stored as a file. A file data source has the extension .dsn. It can be
used by different users if it is placed in the default location for file data sources.
File data sources are usually managed by database administrators.

You define data sources using the Windows ODBC Administrator, which you can access
directly from PowerDesigner:

1. Select Database > Configure Connections to open the Configure Data Connections
window, and click the ODBC Machine Data Source or ODBC File Data Sources tab.
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2. Click the Add Data Source tool (see Data connection tools on page 29) to open the Create
New Data Source window, and select a File, User, or Machine data source as appropriate
and click Next.

3. Select the appropriate driver for your DBMS and click Next and then Finish to access a
driver-specific configuration dialog:
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4. Enter the appropriate parameters and then click OK to return to the Configure Data
Connections window.

5. Click OK to return to your model.

Configuring Connection Profiles
Before you can connect to a database through a DBMS client or JDBC driver, you must create
an appropriate connection profile.

1. Select Database > Configure Connections to open the Configure Data Connections
Window, and click the Connection Profiles tab:
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2. Click the Add Data Source tool (see Data connection tools on page 29) to open a
Connection Profile Definition window:
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3. Enter the properties (see Connection profile properties on page 27) appropriate to your
method of connection.

4. Click the Test Connection button to open the Test Connection window, and click OK to test
your connection.

5. Click OK to close the profile definition, and return to the Configure Data Connections
window

6. Click Ok to return to your model
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Connection Profile Properties
The following properties are available in the Connection Profile Definition window:

Property Description

Connection profile
name

Specifies the name of the connection profile.

Directory Specifies the directory in which the .dcp connection file will be created. By
default .dcp files are stored in the Connection Profiles directory directly
beneath the PowerDesigner installation directory.

Description Optional additional description of the connection profile.

Connection type Specifies the type of connection profile. You can choose between:

• Native
• JDBC

The choice of connection type will affect the remaining fields to be com-
pleted.

DBMS type Specifies the DBMS to which the connection profile will connect. The list
includes only those DBMSs supported for the specified connection type.

Server name [Native only] Specifies the name of the database server to connect to.

Database name [Native only] Specifies the name of the database to connect to.

User name Specifies the username to use when connecting.

Password Specifies the password to use when connecting.

JDBC driver class [JDBC only] Specifies the driver class to use for the connection.

JDBC connection URL [JDBC only] Specifies the connection URL to use for the connection.

JDBC driver jar files [JDBC only] Specifies the driver jar file to use for the connection.

Connection parameters Specifies advanced connection parameters. Click the parenthesis tool to the
right of this field to access the Connection Parameters window.

Connection Parameters Window
You access this window by clicking the parenthesis tool to the right of the Connection
parameters field in the Connection Profile Definition window.

1. Click the Add a Row tool to create a new parameter.

2. Enter a name and value pair in the two columns.

3. Click OK to return to the Connection Profile Definition window. All the parameters are
listed in the read-only Connection parameters field.

CHAPTER 1: Getting Started with PowerDesigner

Core Features Guide    27



Native Connection Profile Example
In the example below, I have installed the Oracle DBMS client, and so create a Native
connection to my database, "Green", on my server "Rainbow".
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JDBC Connection Profile Example
In the example below, I have installed the Sybase ASE JDBC driver. I specify the appropriate
driver class in the jar file, and assemble the connection URL to create a JDBC connection to
my database, "Green", on my server "Rainbow".

Data Connection Tools
The following tools are available in the Configure Data Connections window:

Tool Description

Properties – Opens the ODBC Setup or Connection Profile Definition dialog for the se-
lected profile.

Add Data Source – Creates a new connection.

Browse Data Source File [ODBC file data sources and connection profiles] – Opens a file
browser to select a .dcp profile file.

Delete – Deletes the selected connection.

Test Connection – Tests the selected connection.

CHAPTER 1: Getting Started with PowerDesigner

Core Features Guide    29



Tool Description

ODBC Administrator [ODBC machine and file data sources] – Opens the ODBC Data
Sources Administrator window.

Change Connection Profiles Directory [Connection profiles] – Opens a file browser in
which to search for profiles. The default directory is install_dir/Connection Profiles.

Refresh – Refreshes the list of connections.

Select All – Selects all the connections in the list. Connections that are selected will be
displayed in lists in the PowerDesigner interface.

Unselect All - Unselects all the connections in the list. Connections that are not selected will
not be displayed in lists in the PowerDesigner interface.

Connecting to a Data Source
When you connect to your database, PowerDesigner can communicate with it for reverse-
engineering, generation or any other form of request.

1. Select Database > Connect to open the Connect to a Data Source window:

2. Select one of the following radio buttons, depending on your chosen method for
connecting to your data source:

• ODBC machine data source (see Configuring ODBC machine and file data sources on
page 22)

• ODBC file data source (see Configuring ODBC machine and file data sources on page
22) - use the tool to the right of the data source field to browse to a new file
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• Connection profile (see Configuring connection profiles on page 24) - use the tools to
the right of the data source field to browse to a new directory or file

You can use the Modify and Configure buttons to modify or configure your connection.

3. Enter your user ID and password, and then click Connect. If prompted by your data source,
you may need to enter additional connection parameters.

Note: You stay connected until you disconnect or terminate the shell session.

Running SQL Queries Against Your Database
You can use the Execute SQL Query dialog to query your database. The following tools are
available in the Edit/Run Script editor toolbar:

Tool Description

Open Editor Contextual menu (shift + F11)

Edit With (ctrl + E). Opens the previously defined default editor (see "Specifying text
editors" in the Customizing your Modeling Environment). Click the down arrow to select
another editor.

Run (F5). Executes the current script

[n/a] Insert Bookmark (ctrl + F2) – inserts a blue bookmark box at the cursor position. Press ctrl
+ F2 to delete the bookmark.

[n/a] Go to Next Bookmark (F2)

[n/a] Go to Previous Bookmark (shift + F2)

PowerDesigner License Management
PowerDesigner is licensed as a package of modules, or types of model. Various packages are
available, each regrouping some or all of the modules. Your permission to use these modules is
controlled by the Sybase licensing system, SySam.

For detailed information about SySAM, visit http://www.sybase.com/sysam.

You can evaluate PowerDesigner by obtaining a fully featured trial version, which expires 15
days after installation. If you need more than 15 days to evaluate PowerDesigner, you can
obtain an extension from Sybase, which will be provided as a standalone local license granted
for a limited period of time.

To continue to use PowerDesigner after the trial period, you must purchase a regular license
from Sybase or a reseller. The following types of license are available:
• Standalone seat (local) – the license is installed on a specific machine and cannot be used

on other machines. PowerDesigner reviews the local license file and authorizes only the
use of modules for which a valid license is present.
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This license type is convenient for smaller teams as it does not require a license server, but
does not allow you to centralize license management. For information about obtaining the
license, see " Obtaining a license key file" in the Installing PowerDesigner chapter of the
Installation Guide.

• Standalone seat (served) – the license is for a specific machine but, instead of being
installed on that machine, it is served from a license server. You must be connected to the
license server to obtain the license when you start PowerDesigner, and connect to the
server at least once every 30 days in order to retain it.
This license type is convenient for larger teams, when you want the security of centralized
license activation and management.

Note: A 15 day grace period is granted for users with standalone licenses when the license
server cannot be contacted or the license file cannot be read. There is no grace period for
floating licenses.

• Floating license (served) –licenses are not assigned to a specific machine, but can be
requested from the license server by any machine, and are returned after use, or after 3
hours of inactivity. You must be connected to the license server in order to obtain a license,
and must remain in contact (brief losses of contact only are permitted) in order to continue
using it. If you lose contact with the server, you will be given 24 hours to save your work
before PowerDesigner closes.
This license type is convenient for teams of all sizes, where usage patterns allow the
sharing of licenses. For periods when you must be out of contact with the server, you can
request a mobile license (see Obtaining a mobile license on page 34) for up to 30 days.

Note: For information about setting up a license server, see the Installing PowerDesigner
chapter of the Installation Guide.

License Management Wizard
The License Management Wizard provides the same licensing options as the PowerDesigner
setup program. Note that you do not need to be administrator on your machine to access the
License Management Wizard. You may need to access the wizard when:

• Moving from a trial license to a regular license - Note that you may need to rerun the setup
program before launching the wizard if you need to install additional modules.

• Extending a trial license – After having requested your extension (which will be in the
form of a time-limited standalone local license) from Sybase

• Obtaining a trial of a new package – You will need to rerun setup to install the additional
modules before launching the wizard.

• Moving from a standalone local to a standalone served license – You must be able to
connect to the license server to make this change.

• Moving from a standalone to a floating license – You must be able to connect to the license
server to make this change.

Note: The PowerDesigner plugin for Sybase Workspace, which is called Enterprise
Modeling, is licensed with the other components of Workspace, and the following procedure
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is not available for Workspace users. For more information about licensing in Workspace, see
the Sysam documentation provided with Workspace.

1. Select Tools > License Parameters to open the Wizard. Note that:

• If you have taken a mobile license, you will be prompted to return it before accessing
the wizard

• If you are using a served license and the server cannot be contacted, an error message
will be displayed and you will not be able to access the wizard

2. Select a type of license (see PowerDesigner License Management on page 31) and then
click Next.

3. [if you select to use a local license] You will be required to provide a valid license key.
Follow the instructions on the page to load the key and then click Finish to validate your
license and exit the wizard:

4. [if you select to use a served license] Specify the name of the license server (and if your
administrator has specified one, a port number):

Click Next, specify the PowerDesigner package that you want to use, and then click Finish
to validate your license and exit the wizard.

Note: The list displays all the packages that are available on the server but does not
necessarily mean that a license for a particular package is available. If there is no license
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available for the package you have selected, you must either select an alternate package or
click Cancel to restore your existing license configuration.

5. When you click Finish, the following changes occur:

• If you are in trial mode, a license agreement dialog box is displayed.
• If you have selected a standalone local license, the license file information is added to

the license folder as a new license file.
• If you have selected a served option (standalone or floating) a new license file is created

to store the server name and port number.
• If you have selected a different package, the new models of the package will be

available the next time you start PowerDesigner.

Obtaining a Mobile License
When you are using a floating license and will be out of contact with the license server, you can
borrow a mobile license, which you can retain for up to 30 days.

1. Select Tools > Take Mobile License.

A confirmation dialog box is displayed.

2. Click Yes to obtain a mobile license and click OK to confirm.

Returning a Mobile License
When you no longer need the mobile license you should return it to the server to make it
available to the general license pool.

If you do not return it before 30 days, it is automatically recovered, and you will not be able to
use PowerDesigner before recontacting the server.

1. Select Tools > Return Mobile License.

A confirmation dialog box is displayed.

2. Click Yes to return the mobile license and click OK to confirm.

Troubleshooting Licensing Problems
In rare cases, PowerDesigner may repeatedly fail to obtain authorization from a local license
file or the license server. If this happens, you can troubleshoot as follows:

1. Exit PowerDesigner and navigate to the following directory:

C:\Documents and Settings\All Users\Application Data\PowerDesigner x

2. Move any file with the .lic extension this folder to a safe place.

3. Make a backup copy of the file sysam.properties, and open it in a text editor. Remove the
lines starting "Pd.LicenseMode" and "Pd.Package" at the end of the file and save the file.

4. Restart PowerDesigner.
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You will be prompted to open the License Management Wizard (see License Management
Wizard on page 32). Re-load your local license key or select the appropriate served license
type.
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CHAPTER 2 Projects and Frameworks

A project allows you to group together all the models and other types of documents you need
for a particular modeling task, and save them as a simple entity in your repository.

A project can contain one or more project diagrams (see Project Diagrams on page 39),
which show the connections between models and other documents:

Your project can also contain one or more framework diagrams and/or a framework matrix,
which direct how your project must be modeled and list the documents that are needed (see 
Completing Framework Diagrams and Matrices on page 46).

You can create a project from scratch or from a template. PowerDesigner provides a set of
predefined project templates, and you can also create your own (see Project Templates on page
70).

Note: Projects and framework diagrams and matrices are only available with Enterprise
versions of PowerDesigner.
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Creating a Project
Every project (.prj) contains at least one diagram, and any number of model or file documents.
The project can also contain one or more framework diagrams, a framework matrix, and one or
more dependency matrices.

1. Select File > New Project to open the New Project dialog box.

2. Select a type of project in the tree. You can choose to create:

• An empty project.
• A project based on a template (see Project Templates on page 70). Click the Change

Template Directory tool to search for templates in another location.

3. Enter a project name and location, and select the Append Name To Location check box if
you want to add the project name to the root directory.

4. Click OK to close the dialog box, and create the project.

The project opens. You can add models and other documents to your project (see Building
a Project on page 39 and Completing Framework Diagrams and Matrices on page
46).
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Building a Project
You build your project by creating (or adding existing) models and files. Project documents
are listed in the Browser and displayed as icons in the project diagram. You can open a model
or file by double-clicking its icon in the diagram or in the Browser.

In order to profit from the convenience of the project as a container, you should create (or
place) all the associated models and files inside the project directory. However, you can also
link to files outside the project directory. Such files are listed under the project node in the
Browser, but display small shortcut icons on their symbols to indicate that they are located
outside the project folder.

In the following example, Object Model is inside the project and Physical Model is outside the
project:

You can, at any time, right-click a document in the Browser or its symbol in the diagram, and
select Move to Project Directory to move it inside the project.

Project Diagrams
A project diagram allows you to display project documents and the relationships between
them.

You can create one or more project diagrams in an existing project to display different views of
your project in any of the following ways:

• Right-click a project in the Browser, and select New > Project Diagram.
• Right-click the background of any project diagram, and select Diagram > New Diagram

> Project Diagram.
• Select View > Diagram > New Diagram > Project Diagram.

In the following example, the models and other documents for the WebLibrary project are
organized into sub-folders, and the connections between them (by reference, mapping, and
generation) are displayed in the Main Diagram project diagram:
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The following tools are available in the palette of a project diagram:

Tool Description

New Model – Creates a PowerDesigner model (PDM, OOM, LDM etc.). For more infor-
mation, see Creating Models in a Project on page 40.

Add Project Document – Adds an existing document to the project, which can be:

• A PowerDesigner model (PDM, OOM, LDM etc.).
• An external file (PDF, text file etc.).

For more information, see Adding existing model and file documents to a project on page
41.

N/A Dependency links, such as generation, mapping, reference, and file links, are automatically
created between documents. These links cannot be created, but you may need occasionally
to rebuild them (see Rebuilding dependency links on page 43).

Creating Models in a Project
You can create new models in your project in any of the following ways:

• Click the New Model tool in the Palette, click in the diagram to open the New Model
dialog box, enter a model name and any appropriate information, and then click OK.

• Right-click a project or a project folder, select New > Model to open the New Model
dialog box, enter a model name and any appropriate information, and then click OK.
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Adding Existing Model and File Documents to a Project
You can add existing model or file documents to your project using the palette, Browser, or
drag and drop.

• Click the Add Project Document tool in the Palette, click in the diagram to open a
standard Open dialog box, browse to and select one or more documents in your file system,
and then click Open.

• Drag and drop one or more documents from:
• The file system to the Browser or to the project diagram. If a folder has sub-folders, the

hierarchy is preserved when it is added to the project. However, since projects are not
synchronized with the file system, if you subsequently add files to these folders outside
PowerDesigner, they will not automatically be displayed in the Browser.

• A project diagram to another project diagram.
• The Browser to the project diagram.

• Right-click a project or a project folder in the Browser, and select Add to open a standard
Open dialog box, browse to and select one or more documents, and then click Open.

Converting a Set of Repository Documents into a Project
You can retrieve a set of documents checked into the repository and convert them into a project
to benefit from the convenience of the project as a container.

1. In the Repository Browser, create a project root folder to contain the project documents.

2. [optional] Create project sub-folders to organize documents according to your needs.

3. Drag and drop repository documents into these folders.

4. Right-click the project root folder, and select Convert to Project to convert it and all its
contents into a project.

In the following example, repository documents in the Examples folder are are transformed
into the WebLibrary Project:
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Opening Project Documents
Once you have added a PowerDesigner model to a project, you should only open the model
within the context of the project, as links between it and any other models in the project are
managed by the project file. If you attempt to open the model outside of the project, you will be
prompted to cancel the operation, and to open the project instead.

You can open a project document in the context of its project by double-clicking it in:

• a framework matrix or diagram
• a project diagram
• the Browser under its parent project

Similarly, models that belong to a project should only be checked in and out of the repository
via the project.

Viewing Dependency Links
You can explore the details of any of the dependency links in your diagram by right-clicking it
and selecting Show Dependencies.

Each type of link has its own viewer:

• Generation – displays the generation links between models in the Generation Links
Viewer (see The Generation Links Viewer on page 350).

• Mapping – displays the mapping links between models in the Mapping Editor (see The
Mapping Editor on page 396).
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• Reference – displays the shortcuts and replications between models in the Shortcuts and
Replications dialog box.

In the following example, right-clicking the reference link between Data ETL and Replication
and Data Warehouse models opens the Shortcuts and Replications dialog box which displays
Data Warehouse object shortcuts:

Rebuilding Dependency Links
Dependency links are automatically generated in your project diagram when you add
documents that are linked to each other by, for example, generation, mappings, shortcuts, etc.

Rebuilding dependency links can be useful to update:

• Links between closed models you add to your project.
• Links deleted by error in your diagram.

1. Select Tools > Rebuild Dependency Links to open the Rebuild Dependency Links dialog
box.

2. [optional] Clear the Open closed models check box to rebuild only those links in a limited
number of models.

3. Select the check boxes that correspond to the dependency links you want to rebuild.

4. Click OK to close the dialog box and return to the diagram. Any missing links are updated
in the diagram.
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Project and Framework Display Preferences
PowerDesigner display preferences allow you to customize the format of object symbols, and
the information that is displayed on them.

To set project display preferences, select Tools > Display Preferences (or right-click the
diagram background and select Display Preferences).

Note: For information about changing the format of symbols, see Format Display Preferences
on page 301. Note that only framework architects (see Designing Framework Diagrams and
Matrices on page 53), are allowed to modify the framework diagram and matrix format
display preferences (see Symbol Format Properties on page 191).

To set display preferences for a particular object, select it under the Content category. The
following table lists the display preferences available. The objects available to be customized
in the Display Preferences window depend upon the current diagram type.

Preference Description

Code Displays the code of the object.

Comment Displays the comment of the object.
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Preference Description

Completion status [node and cell only] Displays a rectangle, which represents the work completion
status according to the percentage entered in node and cell floating lists and
property sheets.

Documents [node and cell only] Displays the list of documents in the node or cell, instead of
in floating lists.

Stereotype Displays the stereotype of the object.

Type [dependency link only] Displays the type of the dependency link, which can
include mapping links, shortcut links, generation links, etc.

Project Checks
You can check the validity of your project at any time with the Check Model command.

You can check a project in any of the following ways:

• Press F4, or
• Select Tools > Check Project, or
• Right-click the diagram background, and select Check Project from the contextual menu

The Check Project Parameters window opens, which allows you to specify the kinds of checks
to perform, and the objects to apply them to. For detailed information about this window and
correcting problems reported, see Checking a Model on page 92.

Model and File Checks
The following checks are made on models and files:

Check Description and Correction

Model and file location uniqueness Multiple models or files cannot have the same location.

Manual correction: Delete unnecessary model or file.

Automatic correction: None.

Model location empty [model only] There must be a path in the model document Lo-
cation field.

Manual correction: Save the model to specify a model location.

Automatic correction: None.

External document URL not under
a named path

A model or file is defined outside the project directory.

Manual correction: Right-click the model or file, and select
Move to Project Directory.

Automatic correction: None.
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Check Description and Correction

Target models not in project [model only] One or more target models of a model contained in
the project is missing.

Manual correction: Add missing target model with appropriate
dependency link.

Automatic correction: Yes.

Framework Node and Cell Checks
The following checks are made on framework diagram nodes and matrix cells:

Check Description and Correction

Node/Cell name and code unique-
ness

Node and cell names and codes must be unique in the project.

Manual correction: Modify the duplicate name/code.

Automatic correction: Appends a number to the duplicate name/
code.

Documents not consistent with
node/cell actions

A document in a node and cell must be consistent with its source
action.

Manual correction: Modify the node's and cell's content accord-
ing to its specified actions.

Automatic correction: None

Mandatory actions not executed A mandatory action in a node and cell must be executed.

Manual correction: Execute the mandatory action.

Automatic correction: None

Completing Framework Diagrams and Matrices
Your project may contain one or more framework diagrams and/or a framework matrix, which
direct how your project should be built.

• A framework diagram - lets you model a framework with nodes and links, which you can
style as necessary.
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• Framework matrix - lets you model a framework in a matrix, in which columns usually
represent various aspects of the enterprise that can be described or modeled, and the rows
represent various viewpoints from which the aspects can be described. Each cell formed by
the intersection of a column and a row represents an aspect of the enterprise modeled from
a particular viewpoint.
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PowerDesigner provides a set of predefined framework diagrams and matrices, and users with
framework design rights can also create their own (see Designing Framework Diagrams and
Matrices on page 53). You complete a framework diagram or matrix by creating (or adding
existing) documents in nodes, cells, and additional areas according to predefined rules:

• Documents — can be of different types and can each be associated with multiple nodes,
cells, and additional areas:
• Model – a PowerDesigner model, such as a BPM or a PDM, created from scratch,

based on a template, or generated from another model.
• Diagram – a PowerDesigner model diagram, such as an OOM use case diagram.
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• Dependency matrix – a grid that displays the links between model objects (see 
Dependency Matrices on page 178).

• List – a list of PowerDesigner model objects, such as BPM processes, or PDM tables.
• File – an external file, such as a .doc or .txt file.

• Nodes and cells [when active] — must be completed by particular kinds of documents.
• Additional areas [framework matrix only] — can be defined outside of the grid (for

example, the global view in the FEAF framework matrix that is created at the end of the
enterprise architecture implementation).

Navigating in Framework Diagrams and Matrices
You can interact with framework diagram and matrix elements using various mouse actions.

• Hover over a framework element – to display its name and any comment.
• Click a node or cell – to open a floating list, which lets you manage the documents attached

to the node or cell (see Working with Floating Lists on page 52).
• Right-click a node or cell – to opens contextual menu (see Working with the Framework

Node and Cell Contextual Menu on page 53).
• Double-click a framework matrix element [framework architects only] – to open the

property sheet of the element (see Framework Matrix Properties on page 74).

Attaching a Document to a Framework Node or Cell
You can attach new (or existing) documents to each node of a framework diagram and cell of a
framework matrix.

1. Open the framework diagram or matrix by double-clicking its Browser entry.

2. Click the node or cell to which you want to add the document to open its floating list, which
displays the documents attached to it.

3. Click one of the following tools:

• New Document – to create a document of the specified kind:
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• Model [from scratch or based on a template] – creates the model and opens it in the
diagram window.

• Model [generated from another PowerDesigner model] – opens the Model
Generation Options dialog box to let you create a model (see Generating a Model
on page 337).

• Diagram – opens a model selection dialog box to let you select a new or existing
model to create the diagram.

• Dependency matrix – opens a model selection dialog box to let you select a new or
existing model to create the dependency matrix (see Dependency Matrices on page
178).

• List – opens the List of Objects dialog box to let you create objects in a new or
existing model.

• File – opens a standard Save As dialog box to let you enter a file name. Click Save to
open the file in the application corresponding to the file extension.

• Add Document, and select:
• Attach Project Document – to add documents already in the project. Select the

type of document you want to attach.
• Add Document – to add documents from outside the project. Select the type of

document you want to add.

Note: You can also drag a project document from the Browser and drop it onto a node, a
cell or a floating list, or right-click a node or a cell, and select the New Document,
Attach Project Document, and Add Document commands. Documents can also be
moved from one node or cell to another.

4. [optional – New Document only] Complete the creation of the new document by, for
example, adding objects to the model or diagram, or entering text in the file, etc.

The document is displayed in the floating list.

Example: Creating a PDM from a Cell's Floating List
In this example, we create a PDM, which has been specified as a requirement to complete a
framework matrix cell.

1. Click a cell to open its floating list, which displays the documents attached to the cell.

2. Click the New Document tool, and then select New PDM to create the required PDM.

The new PDM document is displayed in the cell, and in the Browser in the folder specified
by the framework architect.

For information about specifying a model as a requirement to complete a framework node
or cell, see Example: Specifying a Model action on page 57.
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Example: Creating a List of Processes from a Node's Contextual Menu
In this example, we create a list of BPM processes, which has been specified as a requirement
to complete a framework diagram node.

1. Right-click a node, and select New > Document > List of processes to open the List of
Processes dialog.

2. Create an appropriate number of processes in the list, entering a name for each, and then
click OK  to close the dialog box.

The list of processes document is displayed in the node, and in the Browser under a BPM
node in the folder specified by the framework architect.

For information about specifying a list as a requirement to complete a framework node or
cell, see Example: Specifying a List action on page 59.

Deleting Documents from Framework Nodes and Cells
You can delete documents from framework nodes and cells. You can choose to simply detach a
document from the node or cell or completely remove it from the project.

1. Click a node or cell to open its floating list, select one or more documents in the list, and
then click the Delete tool.

Alternatively, select one or more documents in a node or cell and press the Del key or
right-click a document and select Edit > Delete.

The Confirm Deletion dialog box is displayed.

2. Choose one of the following delete options:

• Detach the document from the node or cell - the document is detached from the node or
cell but remains available in the project to be used elsewhere.

• Remove the document and any supporting file or model from the project - their deletion
from the project may affect files or models used elsewhere in the project.

3. Click OK to close the dialog box and confirm the deletion.
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Working with Floating Lists
You open a floating list by clicking a framework diagram node or matrix cell.

Note: Floating lists are not available when you select the Documents display preference (see
Project Display Preferences on page 44).

Floating lists contain the following tools to let you manage project documents in the
framework diagram and matrix:

Tool Description

Properties – opens the property sheet of the selected document.

Open Document – opens the selected document.

Add Document – contains the following tools:

• Attach Project Document – lets you select a document of the specified kind
from inside the project.

• Add Document – lets you select a document of the specified kind from
outside the project.

New Document – creates a document of the specified kind.

Delete – deletes the selected document from the node and cell. You can choose
to:

• Detach the document from the node and cell.
• Remove the document and any supporting file or model from the project.

For information see Deleting Documents from a Framework Node and Cell on
page 51.

Customize Columns and Filter – allows the definition of filter expression on the
columns of the floating list (see Customizing Object List Columns and Filtering
Lists on page 120).

Enable/Disable Filter – enables or disables the filter.

Views – controls the display of documents in the floating list. You can choose
between:

• Large Icons – displays documents as large icons.
• List – displays documents in multiple columns to optimize space.
• Details – displays documents in a grid, which can be filtered.

Status Status – indicates the percentage of work completed in the node and cell.
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Working with the Framework Node and Cell Contextual Menu
The contextual menu available on framework nodes and cells allows you to perform various
actions.

The contextual menu of a framework node and cell contains the following commands. For
information about the additional commands available only in Framework Design Mode, see
Styling Framework Nodes and Cells on page 69):

Command Description

List of Documents Opens the node's or cell's floating list.

New Document Creates a document of the specified kind in the node or cell. An action
must be specified in the node or cell in order for this command to be
available.

Attach Project Document Attaches a document from inside the project to the node or cell.

Add Document Adds a document from outside the project to the node or cell.

Designing Framework Diagrams and Matrices
Framework architects (users who have selected the Authorize Framework Design user profile
when installing PowerDesigner) can create, design, and delete framework diagrams and
matrices in projects, by enabling the Framework Design Mode.
Select Tools > Framework Design Mode.

In the framework matrix, you can alternately right-click the framework matrix top-left corner,
and select Framework Design Mode. The design icon displays in the matrix top-left corner.

In the framework diagram, the tool palette displays in the diagram.

Creating a Framework Diagram
Framework architects can create one or more framework diagrams to guide their modeling
teams through building a project. You can specify actions for each node in the framework
diagram that control what kind of document (model, diagram, model objects list etc.) must be
attached to them.

1. Right-click a project in the Browser, and select New > Framework Diagram to open the
framework diagram property sheet.

2. Enter a name for the framework diagram on the General tab, and click OK to close the
property sheet.

3. Click the Node tool in the palette, click in the diagram, and create an appropriate number
of framework diagram nodes.

CHAPTER 2: Projects and Frameworks

Core Features Guide    53



4. Click the Link tool in the palette, click in the diagram, and create an appropriate number of
framework diagram links between the nodes to express connections between them.

5. [optional] Decompose one or more nodes to analyze them in more detail (see 
Decomposing a Framework Node on page 54).

6. Create actions for each node to specify the types of documents that your modelers can
attach to the node (see Specifying Framework Node and Cell Actions on page 55).

7. [optional] Select File > Save As Template to open the Project Template Wizard, and
convert the project containing your framework diagrams into a template to allow it to be
reused as the basis for future projects (seeProject Templates on page 70).

Decomposing a Framework Node
You can decompose one or more nodes in the framework diagram to analyze them in more
detail. The decomposed node has its own sub-diagram, which models the links between its
sub-nodes. Sub-nodes can, themselves, be decomposed into further sub-nodes, and so on until
you obtain a sufficient level of detail.

You can decompose a node in a framework diagram in any of the following ways:

• Press CTRL and double-click the node symbol (this will open the sub-node directly)
• Open the property sheet of the node and, on the General tab, select the Composite check

box.

Decomposed node symbols in a framework diagram carry a plus-sign symbol to indicate that
they contain further detail

The sub-diagram of the decomposed node is empty at first. You have to create the appropriate
number of nodes and links between them to show their connections (see Creating a
Framework Diagram on page 53).

Creating a Framework Matrix
Framework architects can create a framework matrix to guide their modeling teams through
building a project. You can specify actions for each cell in the framework matrix that control
what kind of document (model, diagram, model objects list etc.) must be attached to them.

1. Right-click a project in the Browser, and select New > Framework Matrix Diagram to
open the framework matrix property sheet, or right-click the background of any project
diagram, and select Diagram > New Diagram > Framework Matrix, or select View >
Diagram > New Diagram > Framework Matrix.

Note: You can create only one framework matrix per project.

2. Enter a name for the framework matrix on the General tab (see Framework Matrix
Properties on page 74).

3. Click the Columns tab, and create an appropriate number of framework matrix columns,
entering a name for each.
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4. Click the Rows tab, and create an appropriate number of framework matrix rows, entering
a name for each.

5. [optional] Click the Additional Areas tab, and create an appropriate number of additional
areas, which will be displayed outside the main matrix grid, entering a name for each.

6. Click OK to close the property sheet and create your framework matrix.

7. Create actions for each cell to specify the types of documents that your modelers can attach
to the cell (see Specifying Framework Node and Cell Actions on page 55).

8. [optional] Select File > Save As Template to open the New Template Wizard, and convert
the project containing your framework matrix into a template to allow it to be reused as the
basis for future projects (see Project Templates on page 70).

Specifying Framework Node and Cell Actions
Actions control the types of documents that can be attached to nodes and cells when
completing framework diagrams and matrices. You can specify one or more action types per
node and cell.

1. Double-click a node or a cell to open its property sheet.

2. On the General tab, enter a node or a cell name, and any other appropriate properties (see
Framework Node, Cell and Additional Area Properties on page 75).

3. Click the Actions tab, and click the Add a Row tool to create a new action.

4. Double-click the action to open its property sheet.

5. On the General tab, enter an action name, and any other appropriate properties (see 
Framework Action Properties on page 77).

6. Click the Detail tab, and select one of the following types of actions as a means to populate
the node or cell:

• Model – a PowerDesigner model (see Example: Specifying a Model Action on page
57).

• Diagram – a PowerDesigner model diagram (see Example: Specifying a Diagram
Action on page 58).

• List – a list of PowerDesigner model objects (see Example: Specifying a List Action
on page 59).

• Model Generation –a PowerDesigner model generated from another model (see 
Example: Specifying a Model Generation Action on page 61).

• Object Generation –a PowerDesigner model populated with one type of objects
generated from another model (see Example: Specifiying an Object Generation Action
on page 62).

• File – an external file (see Example: Specifying a File Action on page 64).
• Matrix – a PowerDesigner dependency matrix showing links between model objects

(see Example: Specifying a Matrix action on page 65).
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• Script - a VB script that can define any scriptable action (see Example: Specifying a
Script Action on page 67).

7. Specify any other appropriate properties to refine the action (see Framework Action
Property Sheet Detail Tab on page 78).

8. Click OK to close the action and node or cell property sheets and return to the framework
diagram or matrix.

The action is now available for use by framework users (see Attaching a Document to a
Framework Node or Cell on page 49). Note that only fully-defined actions are available for
selection.
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Example: Specifying a Model Action
The Model action lets a framework user (add or) create one or more models of the specified
kind in the node or cell. The model will be displayed in the Browser under the project node and
as a document in the node or cell to which it has been attached.

In the following example, we will specify an action in a framework diagram node that enables
the user to create one or more Java OOMs with the EJB 3.0 xem attached.

1. Double-click a framework node to open its property sheet, and click the Actions tab.

2. Click the Add a Row tool to create a new action, and double-click it to open its property
sheet.

3. On the General tab, enter "Detailed object model" in the Name field.

4. Select the Multiple check box to specify that more than one OOM can be attached to the
node.

5. Click the Detail tab, and specify the following properties in the fields (see Framework
Action Property Sheet Detail Tab on page 78):

Property Select or enter

Type Model

Default document name Java Model

Model type Object-Oriented Model

Document template Leave blank

Model language Java

Diagram type Class Diagram

Extended model definition EJB3.0
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6. Click OK to close the action and node property sheets and return to the framework
diagram.

The Model action is now available for use by framework diagram users (see Attaching a
Document to a Framework Node and Cell on page 49).

Example: Specifying a Diagram Action
The Diagram action lets a framework user (add or) create one or more diagrams of the
specified kind in the node or cell. The diagram will be displayed in the Browser under an
existing or new model node and as a diagram in the node or cell to which it has been attached.

In the following example, we will specify an action in a framework matrix cell that enables the
user to create exactly one BPM process hierarchy diagram from a previously defined template.

1. Double-click a framework cell to open its property sheet, and click the Actions tab.

2. Click the Add a Row tool to create a new action, and double-click it to open its property
sheet.

3. On the General tab, enter "Process high level view" in the Name field.

4. Clear the Multiple check box to specify that exactly one BPM process hierarchy diagram
can be attached to the cell.

5. Click the Detail tab, and specify the following properties in the fields (see Framework
Action Property Sheet Detail Tab on page 78):
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Property Select or enter

Type Diagram

Default document name PHD

Model type Business Process Model

Document template Click the Ellipsis button to select the Orders.bpm template.

For information about creating model templates see Model Tem-
plates on page 97.

6. Click OK to close the action and cell property sheets and return to the framework matrix.

The Diagram action is now available for use by framework matrix users (see Attaching a
Document to a Framework Node and Cell on page 49).

Example: Specifying a List Action
The List action lets a framework user (add or) create one or more model object lists of the
specified kind in the node or cell. The list will be displayed in the Browser under the
appropriate model node and as a document in the node or cell to which it has been attached.

In the following example, we will specify an action in a framework diagram node that requires
the user to create at least one list of PDM clusters.
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1. Double-click a framework node to open its property sheet, and click the Actions tab.

2. Click the Add a Row tool to create a new action, and double-click it to open its property
sheet.

3. On the General tab, enter "List of PDM clusters" in the Name Field.

4. Select the Mandatory check box to specify that at least one list of PDM clusters must be
attached to the node.

5. Click the Detail tab, and specify the following properties in the fields (see Framework
Action Property Sheet Detail Tab on page 78):

Property Select or enter

Type List

Default document name List of clusters

Model type Physical Data Model

Document template Leave blank

Model language ORACLE Version 9i

Extended model definition <none>

Object type ExtendedObject

Object stereotype Cluster
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6. Click OK to close the action and node property sheets and return to the framework
diagram.

The List action is now available for use by framework diagram users (see Attaching a
Document to a Framework Node and Cell on page 49).

Example: Specifying a Model Generation Action
The Model Generation action lets a framework user generate one or more models from another
model. The generated model will be displayed in the Browser under the project node and as a
document in the node or cell to which it has been attached.

In the following example, we will specify an action in a framework matrix cell that enables the
user to generate exactly one Sybase AS Enterprise 15.0.2 PDM from a Logical Data Model.

1. Double-click a framework cell to open its property sheet, and click the Actions tab.

2. Click the Add a Row tool to create a new action, and double-click it to open its property
sheet.

3. On the General tab, enter Generate from Logical Model in the Name field.

4. Clear the Multiple check box to specify that exactly one generated PDM can be attached to
the cell.

5. Click the Detail tab, and specify the following properties in the fields (see Framework
Action Property Sheet Detail Tab on page 78):
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Property Select or enter

Type Generation

Model type Physical Data Model

Model language Sybase AS Enterprise 15.0.2

Source model type Logical Data Model

Source location Logical data model

6. Click OK to close the action and cell property sheets and return to the framework matrix.

The Model Generation action is now available for use by framework matrix users (see 
Attaching a Document to a Framework Node and Cell on page 49).

Example: Specifying an Object Generation Action
The Object Generation action lets a framework user generate objects from one model to
another. The generated model will be displayed in the Browser under the project node and as a
document in the node or cell to which it has been attached.

In the following example, we will specify an action in a framework matrix cell that enables the
user to generate exactly one Java OOM containing classes from a list of entities.
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1. Double-click a framework cell to open its property sheet, and click the Actions tab.

2. Click the Add a Row tool to create a new action, and double-click it to open its property
sheet.

3. On the General tab, enter Classes from Entities in the Name field.

4. Clear the Multiple check box to specify that exactly one generated OOM can be attached
to the cell.

5. Click the Detail tab, and specify the following properties in the fields (see Framework
Action Property Sheet Detail Tab on page 78):

Property Select or enter

Type Object Generation

Object type Click the Select Object tool, navigate to PdOOM > Class in the
dialog, and click OK to select it.

Model language C# 2.0

Source object type Click the Select Object tool, navigate to PdCDM > Entity in the
dialog, and click OK to select it.

Source location List of Business Objects

6. Click OK to close the action and cell property sheets and return to the framework matrix.

The Object Generation action is now available for use by framework matrix users (see 
Attaching a Document to a Framework Node and Cell on page 49).
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Example: Specifying a File Action
The File action lets a framework user (add or) create one or more files of the specified kind in
the node or cell. The file will be displayed in the Browser under the project node and as a
document in the node or cell to which it has been attached.

In the following example, we will specify an action in a framework diagram node that requires
the user to create at least one MS Word file from a predefined template.

1. Double-click a framework node to open its property sheet, and click the Actions tab.

2. Click the Add a Row tool to create a new action, and double-click it to open its property
sheet.

3. On the General tab, enter "MS Word File" in the Name field.

4. Select the Mandatory check box to specify that at least one MS Word file must be attached
to the node.

5. Click the Detail tab, and specify the following properties in the fields (see Framework
Action Property Sheet Detail Tab on page 78).

Property Select or enter

Type File

Document template Click the Ellipsis button to select the Functional specifications.doc
template.

File type .doc
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6. Click OK  to close the action and node property sheets and return to the framework
diagram.

The File action is now available for use by framework diagram users (see Attaching a
Document to a Framework Node and Cell on page 49).

Example: Specifying a Matrix Action
The Matrix action lets a framework user (add or) create one or more dependency matrices of
the specified kind in the node or cell. The dependency matrix will be displayed in the Browser
under the project node and as a document in the node or cell to which it has been attached.

In the following example, we will specify an action in a framework matrix cell that enables the
user to create exactly one dependency matrix between PDM tables and users connected by the
Owner dependency.

1. Double-click a framework cell to open its property sheet, and click the Actions tab.

2. Click the Add a Row tool to create a new action, and double-click it to open its property
sheet.

3. On the General tab, enter Table-User Matrix in the Name field.

4. Clear the Multiple check box to specify that only one dependency matrix can be attached
to the cell.
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5. Click the Detail tab, and specify the following properties in the fields (see Framework
Action Property Sheet Detail Tab on page 78):

Property Select or enter

Type Matrix

Model type Physical Data Model

Document template Leave blank

Model Language Sybase AS Enterprise 15.0.2

Extended Model Defini-
tion

<none>

Dependency matrix Click the Create tool to open the dependency matrix property sheet
and specify the following values:

• Matrix rows object type – Table
• Matrix columns object type – User
• Matrix cells dependency – Owner

6. Click OK to close the dependency matrix property sheet, and return to the action property
sheet.
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7. Click OK to close the action and cell property sheets and return to the framework matrix.

The Matrix action is now available for use by framework matrix users (see Attaching a
Document to a Framework Node and Cell on page 49).

Example: Specifying a Script Action
The Script action lets a framework user execute a script in the node or cell. You can use the
script to create a project document and attach it to the node or cell.

In the following example, we will specify an action in a framework diagram node that enables
the user to execute a script that generates a model from another model. The result of this
example is the same as that of a Generation action, but the script is intended to demonstrate the
possibilities that you can script in your own projects. You could, for example, write a script to
connect to a live database and reverse engineer it into a cell. For information about writing
scripts for use in your models and projects, see "Methods (Profile)" in the Extending your
Models with Profiles chapter of the Customizing and Extending PowerDesigner manual.

Before you can specify a script action, you have to create a method script on the
FrameworkAction metaclass in an extended model definition, and then attach it to your
project. In this case, the following script is called GenerateModel, and will generate a
PDM:
Sub %Method%(obj)

   ' This is a sample method that can be used in a script action
   ' It generates a PDM from a source cell CDM and attaches it to the 
current cell
   ' Steps:
   ' 1- Get the source cell: found by its code "mySourceCell"
   ' 2- Get the source model: first document in the source cell
   ' 3- Generate a PDM from the source model
   ' 4- Attach the generated model to the current cell
   ' 5- Set current action as source action for the new document
   ' => That will prevent generating twice if the action is not 
multiple
   
   If obj Is Nothing Then Exit Sub

   Dim sourceCell, targetCell, modelDoc, sourceModel, targetModel

   ' The script is defined on the action so the current cell is simply 
the action parent
   Set targetCell = obj.Parent

   ' First check if we can execute the action on the current cell
   ' for non multiple actions, the CanExecute should return true only 
the first time
   If obj.CanExecute(targetCell) Then
      ' Get Source cell
      Set sourceCell = FindCellByCode(targetCell.Parent, 
"mySourceCell") ' See function code below End Sub statement

      ' Get source model (supposed to be the first in its artifact 

CHAPTER 2: Projects and Frameworks

Core Features Guide    67



document list)
      Set modelDoc = sourceCell.ArtifactDocuments.Item(0)
      Set sourceModel = modelDoc.TargetModelObject

      ' Generate PDM Model
      Set targetModel = sourceModel.GenerateModel (Nothing, 
PdPDM.cls_Model)

      ' Attach generated model to current cell
      Set modelDoc = targetModel.SourceModelDocument
      targetCell.AttachDocument(modelDoc)

      ' Set current action as source for the new model document
      obj.SetAsSource(modelDoc)
   Else
      ' In this sample, the action is supposed to be non-multiple
      ' Therefore, CanExecute fails if it's already a source action 
for an existing document
      output "The action has already been executed"
   End If
End Sub

' FindCellByCode function (Global Script function):

Function FindCellByCode (fmx, Code)
   Set FindCellByCode = Nothing
   Dim Cell
   For Each Cell In fmx.cells
      If Cell.Code = Code Then
         Set FindCellByCode = Cell
         Exit For
      End If
   Next 
End Function

>>

1. Double-click a framework node to open its property sheet, and click the click the Actions
tab.

2. On the General tab, enter Generate Model Script in the Name field.

3. Clear the Multiple check box to specify that exactly one generated model can be attached
to the node.

4. Click the Detail tab, and specify the following properties in the fields (see Framework
Action Property Sheet Detail Tab on page 78).

Property Select

Type Script

Method GenerateModel
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5. Click OK to close the action and node property sheets and return to the framework
diagram.

The Script action is now available for use by framework diagram users (see Attaching a
Document to a Framework Node and Cell on page 49).

Styling Framework Nodes and Cells
Framework architects have access to additional commands that allow them to change the
format of framework nodes and cells.

Command Description

Format Opens the Symbol Format dialog box to let you specify line and fill colours,
fonts and formatting for each textual element, and an image for the node or cell
(see Symbol Format Properties on page 191).

Change Image Opens the Select Image dialog box to let you insert an image in the node or cell
(see Browsing for Images on page 196).

Get Format Copies the format of the selected node or cell for pasting in other nodes or
cells.
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Command Description

Apply Format Pastes a previously copied node or cell format into the selected node or cell.

Properties Opens the property sheet of the selected node or cell.

For information about the standard commands available outside design mode, see Working
with the Framework Node and Cell Contextual Menu on page 53.

Project and Framework Templates
A project template can provide predefined content, rules, and formatting for your project, and
can also include a framework matrix or framework diagram.

For example, you could create:

• A data project template - containing a CDM, LDM, and PDM targeting your preferred
DBMS

• An application project template - containing an OOM with the UML diagrams required for
your modeling practices, along with a PDM and XSM to handle data persistance and
format

• A framework project template - containing a FEAF or other framework matrix

1. Create a project (see Creating a Project on page 38).

2. [optional] Add any appropriate models or files (see Building a Project on page 39).

3. [optional] Create one or more framework diagrams (see Creating a Framework Diagram
on page 53).

4. [optional] Create a framework matrix (see Creating a Framework Matrix on page 54).

5. [optional] Specify any appropriate display preferences (see Project Display Preferences
on page 44).

6. Select File > Save As Template

7. [optional] Specify a template directory in which to save the template. By default, the
project template directory is selected. You can click the Change Template Directory tool
to select another location.

8. Select a template category from the list or enter a template category name that will be
available for when you create other projects. You can use the \ character to create sub-
directories, or right-click the project in the Browser, and select Save As Template  to open
the Template Wizard.

  70 PowerDesigner  



9. Click Next, and enter a description for the new template that will be displayed in the New
Project Wizard when you create projects with the new template. You can modify a
template description by right-clicking a project template in the Browser, and selecting
Edit Template.

10. Click Finish to close the wizard and create the template.

The project (.prj) and the models and files it contains are copied to the template directory.
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Note: If any documents are outside the project and only attached to it they will not be
copied to the template directory and thus may not be available to a user when she creates a
project from the template.

11. [optional] Select New > Project to open the New Project dialog box. The template you
have created is available for selection in the Project type tree.

Project and Framework Properties
Projects, model and file documents, and framework diagrams and matrices have a variety of
properties that you can configure to control their behavior.

Project Properties
The Project property sheet displays the definition of the current project.

A project has the following properties:

Property Description

Name Specifies the name of the item, which should be clear and meaningful, and
should convey the item's purpose to non-technical users.

Code Specifies the technical name of the item, which is used for generating code or
scripts.
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Property Description

Comment Specifies a descriptive comment for the item.

Author Specifies the author of the project. If you enter nothing, the Author field in
diagram title boxes displays the user name from the project property sheet
Version Info tab. If you enter a space, the Author field displays nothing.

Version Specifies the version of the project. You can use this box to display the re-
pository version or a user defined version of the project. This parameter is
defined in the Title page of the project display preferences.

File name Specifies the location of the project file. This field is empty if the project has
never been saved.

Default diagram Specifies the diagram displayed by default when opening the project.

Model and File Document Properties
Model and file document property sheet are available by right-clicking the document's
Browser entry or diagram symbol, and selecting Properties.

The General tab of a model or file document property sheet contains the following properties.

Property Description

Name Specifies the name of the item, which should be clear and meaningful, and
should convey the item's purpose for non-technical user's.

[model document] read-only.

Code Specifies the technical name of the item, which is used for generating scripts.

[model document] read-only.

Comment Specifies a descriptive comment for the item.

Stereotype Extends the semantics of an item derived from existing objects but specific to
your needs. You can enter stereotypes directly in this field, or add stereotypes
to the list by specifying them in your model's resource file or in an extended
model definition.

Location Specifies the path or URL to the document.

[model document] read-only.

Extension [read-only] Specifies the extension of the document name.

Inside project [read-only] Specifies whether the document is part of the project or is simply
referenced in the project.

Size [read-only] Specifies the size of the document.

Creation date [read-only] Specifies the date of creation of the document.
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Property Description

Modification date [read-only] Specifies the date of the last modification of the document.

Dependency Link Properties
You can view the properties of an object from its property sheet. To open a dependency link
property sheet, double-click its diagram symbol.

The General tab of a dependency link property sheet contains the following properties:

Property Description

Type [read-only] Specifies the type of the dependency link, which can include
generation links, reference links, mapping links, and file links.

Stereotype [read-only] Extends the semantics of an object derived from existing
objects but specific to your needs.

Influent object [read-only] Specifies the source object of the dependency link. Click the
Properties tool beside the list to open its property sheet.

Dependent object [read-only] Specifies the target object of the dependency link. Click the
Properties tool beside the list to open its property sheet.

Framework Matrix Properties
Framework architects can modify a framework matrix properties from its property sheet by
enabling the Framework Design Mode, and double-clicking the framework matrix top-left
corner.

For more information on enabling the Framework Design Mode, see Designing Framework
Matrices and Diagrams on page 53.

The General tab contains the following properties.

Property Description

Name Specifies the name of the item, which should be clear and meaningful, and should
convey the item's purpose for non-technical user's.

Code Specifies the technical name of the item, which is used for generating scripts.

Comment Provides descriptive information about the framework matrix.

Stereotype Sub-classification used to extend the semantics of the framework matrix. You can
create stereotypes in the Profile category of the resource file attached to the current
project.

In addition to the General tab, the framework matrix property sheet contains the following
tabs:
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• Rows tab – displays a sortable list of rows, in which you can create, edit or delete rows. See
Framework column and row properties on page 75.

• Columns tab – displays a sortable list of columns, in which you can create, edit or delete
columns. See Framework column and row properties on page 75.

• Cells tab – displays a list of cells, which is computed from the intersection of columns and
rows or from the creation of additional areas. You can edit cells but you cannot delete them
unless you delete the columns or rows to which they belong. See Framework node, cell and
additional area properties on page 75.

• Additional Areas tab – displays the four additional areas available to the framework
matrix. You can create, edit or delete additional areas. See Framework node, cell and
additional area properties on page 75.

Framework Column and Row Properties
Framework architects can modify a column or row properties from its property sheet by
enabling the Framework Design Mode, and double-clicking a column or row header in the
framework matrix.

For more information about enabling the Framework Design Mode, see Designing
Framework Matrices and Diagrams on page 53).

The General tab contains the following properties.

Property Description

Name Specifies the name of the item, which should be clear and meaningful, and
should convey the item's purpose for non-technical user's.

Code Specifies the technical name of the item, which is used for generating scripts.

Comment Provides descriptive information about the framework column or row.

Stereotype Sub-classification used to extend the semantics of the column or row. You can
create stereotypes in the Profile category of the resource file attached to the
current project.

Help file Specifies a location for the help file associated with the row or column.

Default folder Specifies a default folder for the creation of the cell's documents. If no default
folder is specified in the cell's property sheet, the row's default folder is used
first, then the column's default folder.

Framework Node, Cell and Additional Area Properties
Framework architects can modify a node, a cell and an additional area properties by enabling
the Framework Design Mode, and double-clicking a node in the framework diagram and a cell
or an additional area in the framework matrix.

For more information about enabling the Framework Design Mode, see Designing
Framework Diagrams and Matrices on page 53.
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The General tab contains the following properties.

Property Description

Name Specifies the name of the item, which should be clear and meaningful,
and should convey the item's purpose for non-technical user's.

Code Specifies the technical name of the item, which is used for generating
scripts.

Comment Provides descriptive information about the item.

Stereotype Sub-classification used to extend the semantics of the item. You can
create stereotypes in the Profile category of the resource file attached to
the current project.

Help file Specifies a location for the help file associated with the node and cell.

Default folder Specifies a default folder for the creation of the node's and cell's docu-
ments.

Cell location [framework matrix only - read-only]

[cell] Specifies the name of the column and row for which the cell is the
intersection. Click the Properties tool beside Row and Column fields to
open their property sheet.

[additional area] Specifies the location of the additional area: Left, Top,
Right, or Bottom area.

Completion status Controls the percentage of work completed in the node and cell. Enter a
value between 1 and 100 in the box. This value is also displayed in the
node's and cell's floating list and a rectangle on the node and cell shows
the work progression if you have selected the Completion status display
preference.

Inactive [cell only] Specifies a cell which is not available.

Constrain content Specifies a node and cell, whose content can only be completed by its
defined actions.

Composite [node only] Specifies whether the node is decomposed into sub-nodes
displayed in sub-diagrams. When selected a Sub-Nodes tab is displayed
in the property sheet to list these sub-nodes. If you deselect this property,
then any sub-nodes that you have created will be deleted.

In addition to the General tab, the framework node and cell property sheet contains the
following tabs:

• Actions tab – displays a list of actions, in which you can create, edit or delete actions (see
Framework Action Properties on page 77).
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• Documents tab – displays a list of documents, in which you can create or add existing
documents, and also edit or delete documents (see Attaching a Document to a Framework
Node and Cell on page 49).

Framework Action Properties
Framework architects can modify an action properties from its property sheet by enabling the
Framework Design Mode, and double-clicking an action on the Actions tab of a node or cell
property sheet.

For more information about enabling the Framework Design Mode, see Designing
Framework Diagrams and Matrices on page 53.

Property Description

Parent [read-only] Specifies the name of the parent node and cell to which the
action belongs.

Name Specifies the name of the action, which should be clear and meaningful,
and should convey the item's purpose for non-technical user's.

Code Specifies the technical name of the action, which is used for generating
scripts.

Comment Provides descriptive information about the action.

Stereotype Sub-classification used to extend the semantics of the action. You can
create stereotypes in the Profile category of the resource file attached to
the current project.

Multiple When selected, specifies that one or more documents of the selected type
can be created.

Mandatory When selected, specifies that at least one document of the selected type
must be created.
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Framework Action Property Sheet Detail Tab
The Detail tab contains the following properties:

Property Description

Type Specifies the nature of the document to attach to the framework nodes and
cells. You can choose one of the following types:

• Model – specifies a PowerDesigner model (see Example: Specifying a
Model Action on page 57).

• Diagram – specifies a PowerDesigner diagram (see Example: Speci-
fying a Diagram Action on page 58).

• List – specifies a PowerDesigner model object list (see Example:
Specifying a List Action on page 59).

• Generation – specifies a PowerDesigner model generated from another
PowerDesigner model (see Example: Specifying a Generation Action
on page 61).

• File – specifies an external file (see Example: Specifying a File Action
on page 64).

• Matrix – specifies a PowerDesigner dependency matrix (see Example:
Specifying a Matrix Action on page 65).

Default document name [Model, Diagram, and File only] Specifies the model, diagram or file name
created by default in the Browser.

Model type [not for File and Dependency Matrix] Specifies a model type to create, for
example Enterprise Architecture Model.

Document template [not for Generation and Dependency Matrix] Specifies the model or file
template on which the model or file to create is based, for example a PDM,
an LDM, or a .doc, a .xls etc. Click the Ellipsis button to browse for a file on
your system.

Model language [not for File and Dependency Matrix] Specifies a target language associ-
ated with the model to create, for example Analysis for a BPM or Java for
an OOM. Select a model language in the list. If you do not specify a
language, your system default model language is used.

Diagram type [Model and Diagram only] Specifies a diagram type for the model, for
example Class Diagram for an OOM, or Business Process Diagram for a
BPM.

Extended model defini-
tion

[not for File and Dependency Matrix] Specifies an extended model defi-
nition attached to the model, for example SIMUL8 for a BPM.

Object type [List only] Specifies the model object type in the list, for example entity,
process, table, class etc.
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Property Description

Object stereotype [List only] Specifies a stereotype to filter the metaclass, for example a
<<cluster>> stereotype on an extended object in a PDM targeted for the
Oracle Version 9i DBMS.

Dependency matrix [Dependency Matrix only] Specifies a dependency matrix definition be-
tween model objects. Click the Create tool to create a new dependency
matrix.

File type [File only] Specifies the extension of the file to create, for exam-
ple, .doc, .xsl, .txt, etc.

Source model type [Generation only] Specifies the model type from which to generate the
model, for example Business Process Model, Conceptual Data Model etc.

Source cell [Generation only] Specifies the node and cell containing the model type
from which to generate the new model.

Framework Link Properties
Framework architects can modify a link properties from its property sheet by enabling the
Framework Design Mode, and double-clicking a link in the framework diagram.

For more information about enabling the Framework Design Mode, see Designing
Framework Matrices and Diagrams on page 53.

The General tab contains the following properties:

Property Description

Name Specifies the name of the item, which should be clear and meaningful,
and should convey the item's purpose for non-technical user's.

Code Specifies the technical name of the item, which is used for generating
scripts.

Comment Provides descriptive information about the link.

Stereotype Sub-classification used to extend the semantics of the item. You can
create stereotypes in the Profile category of the resource file attached
to the current project.

First object Specifies the node that the link leads from. You can click the Properties
tool to the right of the list to view the properties of the selected object.

Second object Specifies the node that the link leads to. You can click the Properties
tool to the right of the list to view the properties of the selected object.
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CHAPTER 3 Models

Models are the basic work unit in PowerDesigner. You must create a model before you can
begin modeling. You can group models together in projects and framework diagrams. You can
break models down into packages to isolate a part of your model and make it easier to work
with.

PowerDesigner provides various forms of sophisticated generation and reverse engineering
for your models. For more information about:

• Generating another model from your model, see Chapter 9, Getting Started with Linking
and Synching on page 331.

• Generating and reverse-engineering code for a particular model type, see the appropriate
modeling guide.

• Customizing generation, including defining extended definitions to create additional
generation targets, see the Customizing and Extending PowerDesigner book.

Organizing Your Models in the Browser
The Browser provides a hierarchical view of all your model objects.

Note: To expand all nodes at once, press the numpad plus sign (+). To collapse all nodes at
once, press the numpad minus sign (-).

A typical hierarchy of objects in a PowerDesigner Browser tree is as follows:
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• Workspace - The root of every Browser tree is a special type of folder called a workspace, a
virtual environment that contains and organizes all the information and files you create to
support your designs. A workspace allows you to save your local design environment so
that it is available next time you start a session. For more information, see Workspaces on
page 82.

• Projects – Acts as containers for all your development artifacts, allowing you to save them
as a single unit in the repository. Each project has a diagram that automatically calculates
and displays the dependencies and other links between your models and other documents.
For more information, see Chapter 2, Projects and Frameworks on page 37.

• Folders - Workspaces can contain user-defined folders, which allow you to organize
models or other files into groups. For example, if you are working on two separate projects,
but want to be able to access both of them from a single workspace, you could organize the
files using folders. For more information, see Folders on page 85.

• Models - They are the basic design unit in PowerDesigner. Each model has one or more
graphical views called diagrams and any number of model objects. For more information,
see Chapter 3, Models  on page 81.

• Packages - When you are working with large models, you may want to split them into
smaller "sub-models" in order to avoid manipulating large sets of items. These sub-models
are called packages, and can be used to assign different tasks or subject areas to different
development teams. For more information, see Packages on page 89.

• Diagrams - Show the interaction of various model objects. You can create several diagrams
in a model or in a package. For more information, see Chapter 5, Diagrams and Symbols on
page 167.

• Model objects – Is a general term used for all items belonging to a model. Some model
objects, such as a class in an Object-Oriented Model, have graphical symbols while others,
such as business rules, do not appear in diagrams and can only be accessed from the
Browser or from an object list. For more information, see Chapter 4, Objects  on page
101.

• Reports – Can be automatically generated to document your models. For more
information, see Chapter 6, Reports on page 205.

Dragging and Dropping

You can drag and drop or copy objects in the Browser, or from the Browser to the diagram
window.

Searching

You can find the Browser entry for any object you see in a diagram by right-clicking the
symbol and selecting Edit > Find in the Browser from the contextual menu, from the object's
property sheet menu, or from the contextual menu in a Result list.

Workspaces
A workspace contains all the information you need to perform a modeling task with
PowerDesigner. It allows you to save your modeling environment in a file with a hierarchy of
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folders and models. During a work session, every change in the folder or models hierarchy is
saved locally in the workspace.

You can create several workspace files on your machine, but you can only work in one
workspace at a time. Workspaces are saved in files with an .sws extension. They do not have
property sheets

You can create the following new items in a workspace by right-clicking the workspace in the
Browser and select New→item:

• Models and multi-model reports
• Folders (see Folders on page 85)

In addition, you can add existing items (including external files, such as text files or MS Word
files, and other PowerDesigner workspaces) to a workspace by right-clicking the workspace
in the Browser, selecting Add, browsing to the item, and clicking OK. When you have external
files referenced in a workspace, you can open with a double-click.

A PowerDesigner model is the basic work unit, and may contain multiple packages and
diagrams. You can use folders in your workspace to organize your models.

Note: You can have a convenient environment for working with multiple interconnected
models and other files by creating a project. For information, see Chapter 2, Projects and
Frameworks on page 37.

Modifying the Filename of a Closed Item

To modify the filename of closed models, multi-model reports, or any document type
(workspaces or external files) you can right-click the item in the Browser and selecting
Properties, the Document Properties dialog box allows you to directly modify the item
filename.

Note: It is highly recommended to keep original models and their corresponding generated
models in the same workspace.

Creating a Workspace
By default, PowerDesigner opens with a workspace. Whether you want to model data in a
CDM or generate a multi-model report, there will always be a workspace open in the
PowerDesigner window.

To create a new workspace, you have to close the current workspace and a new workspace will
be automatically created.

Select File > Close Workspace.

Confirmation boxes prompt you to save the models before closing the current workspace and
opening a new work environment.
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Opening a Workspace
When you open an existing workspace, the hierarchy of folders and links to model and report
files appear in the Browser. The models linked to the workspace are not open by default.

1. Select File > Open Workspace.

A confirmation message prompts you to save the current workspace.

A standard file selection dialog box opens.

2. Select a file with the SWS extension and click OK.

The new workspace displays the hierarchy of folders, models, and packages defined in this
workspace.

Saving a Workspace
We recommend that you save your workspace whenever you modify its structure by the
creation, addition, modification or deletion of a model, report, or folder. When you save a
workspace, you will be prompted to save also any changes to models it contains.

To save your workspace, do one of the following:

• To perform a standard save - select File > Save Workspace or right-click the workspace
node in the Browser and select Save. You will be prompted to save any models that contain
changes.

• To save the workspace under another name - select File > Save Workspace As to open a
standard Save As dialog, or right-click the workspace node in the Browser and select Save
As. You will be prompted to save any models that contain changes.

• To save the workspace and all the models it contains - select File > Save All, or click the
Save All tool.

Changing Workspace
You can change workspace during a work session.

1. Select File > Open Workspace.

A confirmation message prompts you to save the current workspace.

A standard file selection dialog box is displayed.

2. Select another workspace and click OK.

The new workspace environment is displayed.

Deleting a Workspace
Deleting a workspace deletes the .sws file, but not the model or report files it contains. If you
want to delete a workspace file, you have to use the standard file deletion procedure in
Windows Explorer.
Right-click the workspace file in Windows Explorer and select Delete.
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Folders
A folder is a container object that can help you organize the hierarchy within your workspace.
It can contain models, multi-model reports, and other folders. Folders are saved in the
workspace file.

Creating a Folder
You can create a folder in the Browser.

1. Right-click the workspace or the folder where you want to create a new folder and select
New > Folder.

The new folder is created below the selected item in the tree structure.

2. Type a name in the highlighted area. Folder names must be unique in the folder hierarchy.

Deleting a Folder
When you delete a folder, you detach the models and reports it contains from the workspace,
but you do not delete the models and reports themselves.

Warning! Deleting a folder cannot be undone.

1. Select the folder in the tree view.

2. Click the Delete tool, select Edit > Delete, or right-click the node and select Edit > Delete
from the contextual menu.

Creating an Item in a Folder
You can create models, multi-model reports, and other folders in a folder.
Right-click the folder and select New >  New item  from the contextual menu.

The new item is created in the folder.

Adding an Item to a Folder
You can add an item to a folder by copying or through drag and drop. Note that you cannot
copy or move an open model into a folder.

Note: You can add several items simultaneously by selecting them using the ctrl key and
dragging them to the target folder. However, if you select an unauthorized item or an open
model, the drag and drop will fail.

1. Select an item.

2. Press the ctrl key and drag the item to the folder if you want to copy the item.

or

Press the shift key and drag the item to the folder if you want to move the item.

The new item is displayed in the folder.
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Model Files
You can create a new empty model by clicking the New tool, or populate a new model with
existing data in one of the following ways:

• Import one or more existing PowerDesigner models
• Import one or more Rose or ERwin models
• Generate from another type of model or resource
• Reverse engineer from another type of model or resource
• Open a model from a previous version

For more information on the different methods of model creation, see the Getting Started
chapter in the appropriate modeling guide.

Opening a Model
You open models using the File menu or directly in the Browser.

By default, when you open a workspace, the models linked to workspace are closed, in order to
save working memory. Simply double-click a model or right-click it and select Open to open
it. To open a closed model as read-only, right-click it and select Open as Read-only.

1. Select File > Open from the PowerDesigner menu bar to open a file selection dialog.

2. [optional] To open the model as read-only, select the Open as read-only check box.

3. Browse to and select a model, and then click OK.

The model is added to the workspace and opened in the Browser.

Saving a Model
When a model contains unsaved changes, an asterisk is appended to its name in the Browser.
You can save a model or all the models in the workspace.

When you save a model or a multi-model report, PowerDesigner automatically assigns to the
file a unique identifying number called GUID (Global Unique ID), and creates a backup copy
of your file with the same identifying number. The GUID is used to identify documents in the
Repository and during model generation.

The following formats are available when you save a model:

• XML - [default] Is larger and somewhat slower to load than binary, but the model file can
be edited in a text editor outside of PowerDesigner. Recommended for small to medium-
sized models.

• Binary - Is smaller and faster to load than XML, but cannot be edited outside of
PowerDesigner. Recommended for large models.

To save your model, do one of the following:

• To perform a standard save - select File > Save, click the Save tool, or right-click the model
entry in the Browser and select Save from the contextual menu. If you did not define a file
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name when you created the new model, the Save As dialog box asks you to indicate a name
and a path for the file of the new model.

• To save the model as a new model with the same GUID - select File > Save As, or right-
click the model node in the Browser and select Save As. This allows you to create a backup
version of a model with the same GUID as the original.

• To save the model as a new model with a new GUID - select File > Save As New Model, or
right-click the model node in the Browser and select Save As New Model. This allows you
to develop two separate models in parallel, starting from the same set of model objects.
Note that if you check the new model into the Repository, the Update mode will not be
available. External shortcuts located in the new model may also not work properly since
the identity of the model has changed.

• To save the workspace and all the model it contains - select File > Save All, or click the
Save All tool.

Renaming a Model
You can rename a model in the Browser.

1. Select the model node in the Browser.

2. Click in the selection to make the name editable, press F2, or right-click the node and select
Rename from the contextual menu.

3. Type a new name for the model and press Enter.

Closing a Model
When you close a model you free up working memory, but the model remains available in the
workspace to be re-opened.

1. Select the model node in the Browser.

2. Select File > Close, or right-click the node and select Close from the contextual menu.

If the model needs to be saved, a Save dialog box is displayed.

The node in the Browser is tagged with a red dot.

Deleting a Model
When you delete a model, you detach it from the current workspace, but do not delete the
corresponding file from your disk.

1. Select the model node in the Browser.

2. Click the Delete tool, press DEL, or right-click the node and select Detach From
Workspace from the contextual menu.
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The model node and all its related items are removed from the current workspace.

Adding Legacy Models to the Workspace
Your current models can coexist with non-migrated V6 models like Process Analyst Models
(PAM) or Warehouse Architect Models (WAM) and also external models like ERwin or
Rational Rose.

This feature allows you to keep on working with the non-migrated or external model
application together with PowerDesigner within the same workspace.

Right-click the workspace entry in the Browser and select Add from the contextual menu.

or

Drag the model from Windows Explorer, and drop it into the Browser.

or

Extract the model from the Repository (with the Add to workspace option selected and the
Open document option deselected).

Each time you add a model to the workspace, PowerDesigner lets you choose for each one of
them whether you want to:

• Add non-migrated V6 models and external models to the workspace and keep their
original format

• Open non-migrated V6 models and external models as PowerDesigner models

When you choose to add a model to the workspace and keep its original format, the model
opens in its associated application every time you want to open it.

For more information about:

• opening a PAM into a CDM, see chapter Working with Conceptual Data Models in the
Data Modeling guide.

• opening a PAM into a BPM, see chapter Working with Business Process Models in the
Business Process Modeling guide.

• importing a WAM into a PDM see chapter Working with Physical Data Model in the Data
Modeling guide.

Model Properties
You can modify the properties of a model from its property sheet. To open a model property
sheet, double-click the model node in the Browser or right-click the model node, or the model
diagram background, and select Properties from the contextual menu.

All model types share the following common properties:
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Property Description

Name The name of the item which should be clear and meaningful, and should convey the
item's purpose to non-technical users. By default, any new model is called Model n

Code The technical name of the item used for generating code or scripts, which may be
abbreviated, and should not generally include spaces

Comment A comment is an optional label that describes a model and provides more information
than the name

Filename Location of the model file. This box is empty if the model has never been saved

Author Author of the model. You can insert a name, a space, or nothing.

If you insert a space, the Author field in the title box remains empty.

If you intentionally leave the box empty, the Author field in the title box displays the
user name from the Version Info page of the model property sheet

Version Version of the model. You can use this box to display the repository version or a user
defined version of the model. This parameter is defined in the model display pref-
erences

Default dia-
gram/ view

You can select from the list the diagram or view to display by default when you open
the model

Sending a Model Via a Messaging Application
PowerDesigner uses the messaging application programming interface (MAPI) to send model
files by electronic mail.

This interface lets you use your internal messaging system to send model files directly to other
team members. Make sure your current email software supports MAPI or verify your email
software settings in Control Panel > Internet Options.

1. Select File > Send to open a profile selection dialog box.

2. Select a profile and click OK.

The file transfers to your internal messaging system, which may ask you for additional
information, such as a destination.

Packages
A package is a piece of a model. When working with large models, you can split them into
smaller subdivisions in order to avoid manipulating the entire model at once. Packages can be
used to organize your model into different tasks and subject areas, and to assign parts of it to
different development teams.

You can create as many packages as you need in a model. The name of each package must be
unique in the model. You can decompose a package into other packages, and there is no
limitation to the decomposition depth.
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Packages can contain the same kinds of items as models:

• Model objects
• Other packages
• Diagrams, in order to have different views of the contents of the package. Each package

has a default diagram

In the example below, a package called "Lending Records" (with a diagram of the same name)
has been added to the model "Library OOM":

Note that you cannot save a package individually. When you save the model you also save all
the packages it contains.

Creating a Package
You can create a package in any of the following ways:

• Use the package tool in the diagram palette
• Select Model > Packages to access the List of Packages, and click the Add a Row tool
• Right-click the model or package in the Browser and select New > Package

When you create a package in models with multiple kinds of diagrams, you may be required to
specify the type of diagram to create in the package.

For general information about creating objects, see Creating Objects on page 101.

Package Properties
You can modify an object's properties from its property sheet. To open a package property
sheet, double-click its diagram symbol or its Browser entry.

Note: The same properties (except where noted) are also available for project folders.

The General tab contains the following properties:

Property Description

Name The name of the item which should be clear and meaningful, and should convey the
item's purpose to non-technical users.

Code The technical name of the item used for generating code or scripts, which may be
abbreviated, and should not generally include spaces.
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Property Description

Comment A comment is an optional label that describes a package and provides more infor-
mation than the name.

Stereotype Sub-classification used to extend the semantics of an object without changing its
structure; it can be predefined or user-defined.

Default dia-
gram

[package only] Specifies the diagram to display by default when you open the
package.

Use parent
namespace

[package only] Option that defines the package as being the area in which the name
of an object must be unique in order to be used.

Controlling the Namespace of a Package
PowerDesigner applies uniqueness checks on the names of objects. The namespace defines an
area in which the name and the code of an object of a given type must be unique.

• For the CDM, PDM, ILM, and FEM - the entire model is, by default, a single namespace,
and all the packages use their parent namespace. PowerDesigner applies checks on
uniqueness at the model level.

• For the OOM, RQM and BPM – each package is, by default, a separate namespace.
PowerDesigner applies checks on uniqueness at the package level.

Depending on the type of model where you create a new package, the Use Parent Namespace
check box is selected in the package property sheet.

Note: The XML model does not support packages. For more information on namespaces in
the XSM, see the XML Modeling guide.

In the following example, the class Printer is located in the Peripheral Package of an OOM
where each package is, by default, a separate namespace:

If you were to select the Use Parent Namespace check box in the property sheet of Peripheral
Package, the internal names of objects in this package would no longer be prefixed by the
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name of the package. The parent of the folder, in this case the model itself, becomes the
namespace, and you could not create a Printer class in the Internal Network package, because
PowerDesigner would verify its uniqueness in the entire model.

1. Open the property sheet of the package.

2. Select or clear the Use Parent Namespace check box.

3. Click OK to return to the model diagram.

Checking a Model
You can check the validity of your model at any time. We recommend that you check your
model before generating code or another model from it. The Check model option is enabled by
default in the Generate dialog box and, if an error is found, the generation is stopped.

1. Press F4, select Tools > Check Model, or right-click the diagram background and select
Check Model from the contextual menu to open the Check Model Parameters dialog box.

The options tab lists the types of objects to be checked, and the individual checks to be
performed are displayed with symbols indicating their severity:
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2. [optional] Select or deselect types of objects to check, and expand object nodes to enable,
disable, vary the severity of, and enable or disable automatic correction of individual
checks (see Check model parameter tools on page 94).

Note: Right-click a check in the Check Model Parameters dialog box and select Help from
the contextual menu to display its documentation.

3. [optional] Click the Selection tab, and select or deselect individual objects for checking.
Sub-tabs are available for each type of object:
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Note: If you have selected object symbols in your diagram before starting the model
check, you can select them for checking by clicking the Use Graphical Selection tool in the
Selection tab tool bar.

For more information about selecting objects in Selection tabs, see the Adding an Item
from a Selection List on page 122.

4. [optional] Click Apply to save your selections so that they will be available for future
model checks.

5. Click OK to launch the model check.

The Check Model Result List displays errors and warnings based on the check options you
have defined. For information about how to correct errors, see Correcting errors in the
check model result list on page 95.

Check Model Parameter Tools
The following tools are available in the Check Model Parameters dialog box:

Tool Description

Select All – Click the arrow to the right of this tool to choose to select all checks, all error
checks, or all warning checks.

Deselect All - Click the arrow to the right of this tool to choose to deselect all checks, all
error checks, or all warning checks.

Error – Sets the selected check to error level. The check icon will change accordingly. When
errors are encountered, any model generation is stopped.

Warning - Sets the selected check to error level. The check icon will change accordingly.
Warnings do not prevent generation from your model.
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Tool Description

Automatic correction – [enabled if automatic correction is available for the selected check]
Enables automatic correction for the selected check. The check icon will change to bear a
small red cross in its bottom-right corner.

You should be aware of how automatic corrections can affect your models. For example, in a
PDM, if a column code length is longer than the length specified in the MaxColumnLen
field in the DBMS, then PowerDesigner can automatically truncate the code to the specified
length. However, such truncation can make create duplicate names and PowerDesigner will
automatically rename the duplicated column code. If you do not want this to occur, you
should deselect automatic correction for column code uniqueness.

All problems that can not be corrected automatically must be corrected manually. For
example, in a PDM, PowerDesigner will not create a column for an existing index, and you
will need to create the appropriate column.

Correcting Errors in the Check Model Result List
When errors and warnings are encountered during model checking, they are listed in the
Check Model Result List pane. You can correct the problems either by invoking a automatic
correction (if available) or by opening the property sheet of the affected object and correcting
it manually.

The following tools are available to assist you in correcting problems with your model. If this
toolbar is not displayed, select Tools > Customize Toolbars, select Check, and click OK.

Tool Description

Correct error – Opens the property sheet of the affected object to allow you to correct the
error.

Display help – Provides documentation for the error or warning.

Check again – Re-performs the check, to allow you to verify your correction.

Automatic correction – Only available if an automatic correction is defined for this kind of
error. Performs the automated correction.

First error – Goes to the first error in the list.

Previous error - Goes to the previous error in the list.

Next error - Goes to the next error in the list.

Last error - Goes to the last error in the list.

Note: These and other options are also available by right-clicking an item in the Check Model
Result List.
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Checking Generic Objects
Generic objects are available in all types of models and have standard checks defined for them.
For model-specific checks, see the appropriate modeling guide.

Business Rule Checks
PowerDesigner provides default model checks to verify the validity of business rules.

Check Description and Correction

Business rule name and code unique-
ness

Business rule names and codes must be unique in the model.

Manual correction: Modify the duplicate name/code

Automatic correction: Appends a number to the duplicate
name/code

Unused business rule The business rule you have created is not used in the model.

Manual correction: Apply the business rule to an object in
the model

Automatic correction: None

Extended Object/Link Checks
PowerDesigner provides default model checks to verify the validity of extended objects/links.

Check Description and Correction

Extended object/link name and code
uniqueness

Extended object and link names and codes must be unique in
the namespace (model or package).

Manual correction: Modify the duplicate name/code

Automatic correction: Appends a number to the duplicate
name/code

File Checks
PowerDesigner provides default model checks to verify the validity of files.

Check Description and Correction

Embedded file name uniqueness Embedded file object names must be unique in the model.

Manual correction: Modify the duplicate name/code

Automatic correction: Appends a number to the duplicate
name/code

Existence of external file location External file objects should have a valid path location.

Manual correction: Define a valid path location

Automatic correction: None
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Replication Checks
PowerDesigner provides default model checks to verify the validity of replications.

Check Description and Correction

Partial replication A replica object is partially synchronized with its replicated
object.

Manual correction: Modify the list of replicated attributes
from the replication property sheet

Automatic correction: Enforces the replication of de-
synchronized attributes of the replica object in the replica-
tion property sheet

Using the Free Model
A free model (FEM) provides a context-free environment for modeling any kind of objects or
systems. It is generally associated with a set of extensions, which allow you to define your own
concepts and graphical symbols.

For example, you could create a model to represent:

• how your models and documents relate to each other
• the organizations in your enterprise and how they interrelate
• a flowchart
• a hierarchy diagram
• the graphics you use in PowerPoint presentations and link them to the presentations they

are used in
• the users in your Enterprise Repository and link them to symbols representing the groups

they belong to
• an ORM model using ORM specific extended model definitions

You can enrich the diagrams in the Free Model by selecting different bitmaps for each symbol
and add extended attributes to collect specific metadata. VBScript and the Generic Generator
make it possible to program your own semantics into this model and create specific generated
code or other output particular to your own interpretation.

Model Templates
A model template is a shell model that contains a set of model options, display preferences,
extensions, and/or objects, which you can reuse in multiple models of the same type. For
example, a BPM model template can be used to create other BPMs, but not an OOM or PDM.
Model templates are stored in the model templates directory, which is, by default, the
PowerDesigner installation directory.
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You can make any model available as a model template by saving it to the model templates
directory. Alternatively, you can manage your model templates from the New Model dialog
(select File > New Model, or click the New Model tool, and then select the Templates button.

Note: The New Model dialog is highly customizable and its display is controlled by the Model
Creation general options. If the Enable model template files option is deselected or if no valid
template directory is selected then the Templates button will not be available. For information
about these options, see Customizing the New Model Dialog on page 314.

The New Model dialog lists the model templates that are available, sorted by model type, and
provides the following tools:

Tool Description

Copy Model as Model Template – allows you to select one or more models as model
templates, and copies them to the model templates folder.

Change Model Templates Folder – allows you to select a folder for use as the model
templates folder.

For information about using the New Model dialog, see Creating a Model on page 12.

Upgrading from Previous Versions of PowerDesigner
The resource files that customize PowerDesigner for particular target languages or DBMSs
are constantly evolving. When you open a model created with a previous version of
PowerDesigner, the resource file associated with the model will be automatically upgraded if
possible. Note that it may be possible to upgrade a model created with v6.x or earlier but only
upgrading from v7.x or later is supported.

Replacing DBMSs from Previous Versions
All DBMSs stored in the installation directory are updated when you upgrade PowerDesigner.

For DBMSs copied to the model file in previous PowerDesigner versions, you will be invited
to upgrade the DBMS when you open the old model. The following situations can occur:

• Shared DBMS - DBMS upgraded and message in the Output window. If you had
customized your DBMS, and want to keep your changes, merge the current version DBMS
with the previous version, using the merge feature available from the list of DBMSs (Tools
> Resources > DBMS).

• Copied DBMS - A confirmation dialog invites you to replace the DBMS, and if you do so,
a message appears in the Output window. If you had customized your DBMS, and want to
keep your changes, create a new model using a current version DBMS fairly similar to
your modified DBMS, and merge it with a model using the DBMS from a previous
version.

If no matching DBMS is found then you will continue with the previous version.
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Replacing Object Languages from Previous Versions
All object languages stored in the installation directory are updated when you upgrade
PowerDesigner.

For object languages copied to the model file in previous PowerDesigner versions, you will be
invited to upgrade the object language when you open the old model. The following situations
can occur:

• Shared Object Language - If the object language file is the original file delivered with
PowerDesigner, the object language is automatically replaced as mentioned in the Output
window. If the object language file is a renamed copy of an object language shipped with
PowerDesigner, a message box appears to advise you to change object language.

• Copied Object Language - A message box appears to advise you to change object
language. If you click Yes, the object language is automatically replaced in your model.
You lose all the changes performed on the definition file. If you click No, the object
language is not replaced and remains in the previous version format, you cannot generate
for the target language. If you click Cancel the model is not opened.

• Converting Generic Object Language - If you had customized an object language from
PowerDesigner v8.0 using the generic generation mechanism, the names of the templates
may conflict with the public names defined in the current version. You can use the script
_PublicNames.pl located in the \Tools directory to avoid conflicts with public names.
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CHAPTER 4 Objects

You populate your models with objects. The types of objects that you can create depend on the
type of model that you are working with.

Creating Objects
Model objects are the building blocks of your models. They are listed as items in the Browser
and often also appear as symbols in your diagrams.

There are two main types of objects:

• Ordinary Objects – such things as tables and entities, which are self-sufficient, and can be
created in isolation from other objects

• Link Objects – such things as associations or dependencies, which link two ordinary
objects, and cannot be created in isolation

There is detailed information about each object in the relevant modeling guide. The following
sections describe generic features available for all objects.

You can create objects:

• Directly in your diagram, using a Palette tool (only for objects that have symbols)
• From the Browser
• From an object list

Creating an Object from the Palette
The Palette is a toolbar that lets you quickly create objects and links. Objects, such as OOM
classes or PDM tables, can be created independently in any free space in the diagram, while
links, such as OOM messages or PDM references are drawn between objects.
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To create an object from the palette, simply select the appropriate tool and then click anywhere
in the diagram. When you release the mouse button, the object is created, and you can click
again elsewhere to create a second object and so on. To release the tool, simply right-click
anywhere.

To create a link, select the appropriate link tool, and then click in the object from which you
want the link to begin and again in the object in which you want the link to end. When you
release the mouse button, the link is created.

The standard palette tools are as follows:

Icon Action

Pointer [default] – Selects, moves, and resizes individual symbols. Double-click to select
all the objects in the diagram. To switch back to the Pointer from another tool, right-click
anywhere in the diagram.

Grabber – allows you to select, move and resize the entire diagram. Double-click to display
the entire diagram, centered.

Zoom in

Zoom out

Open the diagram of a composite object or packages

Delete a symbol and, optionally, its associated object.

Open the property sheet of an object

Create a package

The central tool area in the palette depends on the model you are working with, and will
contain tools to create all the objects relevant to that type of model. For details of these model-
specific tools, see the appropriate modeling guide.

The standard graphical tools are as follows:

Icon Action

Insert an area where you can write free notes

Draw one of the following:

• a graphical link between free symbols in the diagram
• a note link between a note and an object
• an extended dependency between objects (where possible)
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Icon Action

Insert a file symbol and object

Insert a title box

Insert text

Draw a line

Draw an arc

Draw a rectangle

Draw an ellipse

Draw a rounded rectangle

Draw a jagged line

Draw a polygon

Note: To revert to the previously selected tool, hold down CTRL and perform a double right-
click.

To rename an object from its symbol, select it and then press F2. If the symbol carries
additional editable properties (but not lists of sub-objects), you can navigate to the next with
Tab (or the previous with Shift+Tab). Select the Edit in place after creation general option to
have the name of each object that you create immediately selected for editing (see General
Options on page 301).

Creating an Object from the Browser
You can create any object in the Browser.

1. Right-click the model, package or object category where you want to create the object, and
select New >  object type  to open a new default object property sheet (see Object
Properties on page 104).

2. Type an object name and code in the General tab of the property sheet, and then add any
other relevant properties in the remaining fields of this or the other tabs.

3. Click OK to confirm the creation of the object.

The object is created in the appropriate object category in the Browser, under the current
model or package, and its symbol is added to the current diagram.
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Creating an Object from an Object List
You can create objects from an object list.

You can also create objects from the model object lists available by clicking Model >  object
type .

1. Select Model >  object type  to open the appropriate object list.

2. Click the Add a Row tool or, if the list is ordered, the Insert a row tool.

A new item is added at the end, or before the selected row, of the list.

3. Enter an object name and code and, for link objects, a source and destination object.

4. Repeat as necessary to create additional objects of the same type, and then click OK.

For more information about object lists, see Object Lists on page 117.

Object Properties
All model objects created in PowerDesigner have property sheets, which organize object
properties on tabs.

You can open an object property sheet in any of the following ways:

• Double-click the object symbol or its entry in the Browser.
• Right-click the object symbol or its entry in the Browser, and select Properties from the

contextual menu.
• Select the object in an object list or in the property sheet of its parent object, and click the

Properties tool
• Select an object symbol and press Alt + Enter.
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Property sheets of link objects display a picture of the link together with its extremities.
Additional information, such as the cardinality value and the role, may also be displayed:
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Property sheets allow you to assign extensive and sophisticated properties to objects. Most
PowerDesigner objects have the following tabs and properties, but many others, specific to the
particular object type, may be available:

• General – provides basic information about the object. Almost all objects have the
following properties:
• Name - clearly identifies the object. By default names can have up to 254 characters,

and can include upper, lower, and mixed case strings.
• Code – is used in scripts generated from the model. By default, codes are synchronized

with names, but you can decouple them by clicking to deselect the equal sign button to
the right of this field. You control this synchronization of codes with names with the
Name to Code mirroring general option (see Dialog Box General Options on page
303) and can modify the transformations performed on codes with naming conventions
(see Naming Conventions on page 315).

• Comment – [optional] provides a more detailed description of the object. You can
display (and edit) object comments on their many diagram symbols using the
"Comment" Display Preference. This feature can be useful when importing an ERwin
model into a CDM or PDM.
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• Notes – lists additional information about the object. For more information, see Notes Tab
on page 109.

• Rules – lists the business rules with which the object must comply. A business rule could
be a government-imposed law, a customer requirement, or an internal guideline. For more
information, see Business Rules on page 140.

• Version Info - provides details about the object owner, creation, and modification date and
allows you to access help for the PowerDesigner metamodel metaclass on which the object
is based. For more information, see Displaying object version information on page 114

• Dependencies - lists all the objects that depend on the object. For more information, see
Analyzing object dependencies on page 115

• Extended dependencies - lists all the objects on which the object depends. For more
information, see Using extended dependencies on page 334

• Requirements – lists the project requirements that the object is intended to satisfy. This
tab is not visible by default. For more information, see Attaching requirements to an object
on page 114

Note: Use Ctrl + Page Down or Ctrl + Page Up to move to the next or to the previous tab and
display the corresponding object type tab.

Property sheets open to the General tab by default. However, you can choose to open property
sheets at the last accessed tab by selecting Tools > General Options > Dialog, and selecting
the Keep Last Tab option in the Property Sheets groupbox.

You can control the form of the symbols, the background color, and the text format via the
default display preferences. If you want changes to the display preferences to appear in link
object property sheets, you must click the Set As Default button in the Display Preferences
dialog, for each modification.

Customizing a Property Sheet
Since PowerDesigner can hold a rich variety of information about your model objects,
property sheets can become overloaded.

The More or Less button at the bottom left corner of the property sheet allows you to toggle
between displaying all the available property sheet tabs, and a subset called "favorite" tabs.

You can customize your list of favorite tabs, and access various other property sheet features,
from the property sheet menu, which is accessible from the bottom-left corner of all property
sheets.

Command Description

Find in Diagram Finds the object in the diagram, found object is displayed centered and
selected.

Find in Browser Finds the object in the Browser and highlights it.

Impact Analysis Opens the Impact Analysis dialog box.
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Command Description

Parent Properties Opens the property sheet of the parent object.

New Attribute Opens the New Attribute dialog, which lets you add new properties to your
object property sheets. For more information, see Adding a New Attribute to
an Object on page 147.

New List of Associ-
ated Objects

Opens the New List dialog, which lets you add new lists of associated objects
to your object property sheets. For more information, see Adding a New List
to an Object on page 149.

Manage Object Ex-
tensions

Opens the Manage Object Extensions dialog, which lets you access the
metaclass on which the object is based in the Resource Editor. For more
information, see Managing Extensions on page 150.

Find in Metamodel
Objects Help

Opens the MetaModel Objects Help for the metaclass on which the object is
based.

Customize Favorite
Tabs

Opens a sub-menu, which allows you to define favorite tabs:

• Help – opens this help topic
• Display All Tabs - Displays all available property tabs for the current

property sheet
• Display Favorite Tabs for All - Displays favorite tabs for all property

sheets throughout all models
• Display All Tabs for All - Displays all tabs for all property sheets

throughout all models

Beneath the sub-menu are listed all the tabs available for the present object.
Favorite tabs have a check against them.

Click a tab in the list to select or remove it from the list of favorite tabs. Note
that the General tab cannot be unchecked.

When you check or uncheck a tab such as Notes, Rules, and Dependencies,
which are common to many objects, you are asked to confirm the change for
all other objects. If you click No, only the current property sheet is modified.

In the following example, all the tabs except Implementation are checked and are displayed:
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Any changes in the display of tabs are immediately applied to the current property sheet but
not to other property sheets that are currently open. The changes become the default setting for
any property sheet of the same type.

Note: You can choose to display tabs on one or several rows in property sheets by selecting
Tools > General Options > Dialog, and selecting the Tabs on one row option or the Tabs on
one several rows option in the Property sheets groupbox.

Notes Tab
The Notes tab in an object property sheet contains the sub-tabs Descriptions and Annotations,
intended to hold additional information about the object.

• Descriptions - in general, includes important information that does not fit into the General
tab. For example, a description of the Employee entity might read: This entity has one
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occurrence for each employee in our worldwide operations. This base should grow by 20
percent in 2002.

• Annotations - contains notes regarding the implementation of a model or the objects it
contains. For example, an annotation of the Employee entity might read: Verify list of
attributes with Director of Human Resources.

Both are editable directly in the tab with the internal PowerDesigner RTF editor, which
includes the following tools:

Tool Description

[Shift+F11] Open Editor Menu - provides various file and formatting options. For more
information, see Working with Textual Symbols on page 201.

[Ctrl+E] Edit With - Opens your default RTF editor. Click the down arrow beside this
tool to select another editor. For information, see Specifying Text Editors on page 305.

You can insert the content of an existing text or RTF file in the RTF editor to use it as a standard
for your descriptions or annotations. This can be very helpful to standardize objects notes as
you can have a description or annotation RTF file for each object type, and open it when
needed.

1. Open the object's property sheet and click the Notes tab.

2. Click the Description or Annotation sub-tab, depending on the kind of note you want to
add.

3. Click the Editor Menu tool and select Insert to open a standard Open dialog.

4. Browse to the file you want to insert and click Open.

The content of the file is displayed in the RTF editor.

Note: To see which objects have notes, open the appropriate object list and review the [N]otes
checkbox. For more information about customizing the display of a list, see Customizing
Object List Columns and Filtering Lists on page 120.
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Preview Tab
Many objects have a Preview tab in their property sheets, that allow you to preview the code to
be generated from the object. This provides an easy way to apply modifications to your code
and update the model.

All or some of the following tools are available on this tab:

Tool Description Keyboard
shortcut

Open Editor Contextual Menu Shift + F11

Edit With contextual menu. This allows you to select an editor for
the script

ctrl + E

Refresh F5
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Tool Description Keyboard
shortcut

Select generation targets. This tool is available when at least one
extended model definition flagged for generation is linked to the
model and when it contains GeneratedFiles entries for the current
object. When available, it displays the list of targets for the current
object. If you add a generation target, the corresponding tab is
added to the Preview tab. If you deselect a generation target, the
corresponding tab disappears from the Preview tab

ctrl + F6

Show generation options. If you select the Show Generation Op-
tions tool when available, the Generation Options dialog box is
displayed. You can change generation options from this dialog box
and see the impact on the code

ctrl + W

Ignore generation options. If you click the Ignore Generation Op-
tions tool when available, the preview ignores generation options
selected by using the Show generation options tool but uses a
predefined set of options

ctrl + D

In the Preview tab, you can add and remove bookmarks at specific points in the code and then
navigate forwards or backwards from bookmark to bookmark:

Keyboard
shortcut

Description

ctrl + F2 Adds a new bookmark. A blue bookmark box is displayed. If you repeat this action
from the same position, the bookmark is deleted and the blue marker disappears.
Note that bookmarks are not printable and are lost if you use the Refresh, or Show
Generation tools.

F2 Jumps to bookmark

shift + F2 Jumps to previous bookmark

For more information about how the Preview tab is used in the different modules, see the
appropriate modeling guide.

Finding Text Using Regular Expressions
You can use regular expressions to find script text displayed in the Preview or Script tab of a
table property sheet, as well as in the Edit/Run Script editor, the Resource Editor, and various
other windows.

In order to be able to search for text using regular expressions, you must select the Regular
Expression check box in the dialog box and enter a regular expression in the Find What box.

Regular expressions can contain ordinary characters and the following metacharacters:
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Character Description

\ Matches a special character

Examples:

"n" matches "n". "\n" matches a newline character. "\\" matches "\" and "\(" matches
"("

^ Matches the position at the beginning of the input string

Examples:

"^Win" matches strings beginning with "Win

$ Matches the position at the end of the input string

Examples:

"then$" matches strings ending with "then"

* Matches the preceding character zero or more times

Examples:

"zo*" matches "z" and "zoo"

+ Matches the preceding character one or more times

Examples:

"zo+" matches "zo" and "zoo", but not "z"

? Matches the preceding character zero or one time

Examples:

"to?" matches either "t" or "to"

. Matches any single character except the newline \n

Examples:

".ork" matches "Work", "Fork" etc

[ ] Matches any one of the enclosed character

Examples:

"[abc]" matches "a", "b", or "c" A range of character can be indicated with a dash
"[a-z]"

For a complete list of metacharacters and their behavior in regular expressions, see the Visual
Basic Documentation.
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Requirements Tab
You can attach one or more requirements to an object using the Requirements tab in the object
property sheet. This tab is not displayed by default, and can only be used if one or more
requirements models is open in the workspace.

Note: To display the Requirements tab, select Tools > Model Optionsand select the Enable
links to requirements option.

1. Open the object's property sheet and click the Requirements tab.

2. Click the Add Objects tool to open a selection dialog.

3. Select a Requirements model and, optionally, a package to display a list of the
requirements contained therein.

4. Select the requirements that you want to attach to the object and click OK.

The selected requirements appear in the Requirements tab.

5. [optional] Select the requirement in the list and click the Properties tool to open its
shortcut property sheet. To open the property sheet of the requirement itself, click the
Target Object Properties button to the right of the Name field.

Note: To access the property sheet of the requirement directly instead of passing by the
shortcut, select Tools > General Options > Dialog, and select the Target Object radio
button beside the External Shortcut option.

6. Click OK to close the property sheet and return to the model.

Version Info Tab
PowerDesigner automatically manages version information about model objects on the read-
only Version Info tab of the object's property sheet.

Property Description

Creation User Specifies the name of the User who created the object.

Creation Date Specifies the date of creation of the object

Last Modification User Specifies the Name of the user who made the last modification to the object.

Last Modification Date Specifies the date of the last modification of the object

Replicated From [replicated objects only]Specifies the name of the origin object from which
the object was replicated.

Click the button to the right of this field to open the origin object property
sheet
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Property Description

Generated From [generated objects only]Specifies the name of the origin object from which
the object was generated.

Click the button to the right of this field to open the origin object property
sheet

Note: In addition to the standard help accessible via F1 or by clicking the Help button, you can
obtain information about the PowerDesigner metamodel metaclass on which this object is
based by clicking the small question mark button at the bottom right of the tab.

Dependencies Tab
The PowerDesigner metamodel provides the capability to link objects to other objects in a
variety of semantic ways. For example, when you create an external shortcut, or when you
attach a business rule to an object, a dependency link is created between models or objects.
The Dependencies tab of the object's property sheet displays these links.

Dependencies can be of two types:

• Internal, when the links are within a model. These dependencies are saved in the model and
appear in the Dependencies tab of an object property sheet

• External, when the links exist between models. These dependencies are created during
intermodel generation or external shortcut creation, they appear in the Dependencies tab if
the related model is opened in the workspace. If the related model is not available, you can
use the repository to retrieve external dependencies (see "Auditing repository activities" in
the Repository Administration chapter in the Working with the Repository manual).
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Note: The Dependencies tab of a model also lets you check the model origin (Generated From
tab) and destination (Generated As tab).

Object Namespaces
In PowerDesigner, each package can be a namespace. It is however possible to expand the
namespace to the parent of a given package. You can cascade the expansion until you reach the
level of the model itself.

Objects that appear in the Browser obey the general rules that follow:

In Browser Namespace Uniqueness rule

Objects directly under a package or a
model (table, process, class)

Model Unique name and code in model

Package Unique name and code in package

Objects under parent object (column, at-
tribute)

Not applicable Unique name and code in parent

Linking objects (reference, relationship) Not applicable Unique name and code between
same end objects (i.e., parallel links
with same name and code are not al-
lowed between same end objects)
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However, you may encounter some exceptions to those rules. For example only the code of a
reference allows to identify the object in the entire model, when the "Unique code" option is
selected in the Model Options dialog box. PowerDesigner warns you when a general rule is
not respected.

Object Lists
PowerDesigner object lists provide a spreadsheet-like interface for manipulating large
quantities of objects. They offer you an overview of the objects in your model and can save you
time and effort in managing your metadata. While property sheets provide depth of detail for
individual objects, lists allow you to select and manipulate multiple objects simultaneously to
streamline creation and improve consistency.

Lists of all the major objects in your model are available under the Model menu or by right-
clicking your model in the Browser and selecting List of objects . Each list shows all the
objects of that type in the currently selected package or model, including those that do not have
symbols in the current diagram:

The properties of the listed objects are organized in columns. You can order the list by a
particular columns values by clicking on its column header. You can control which property
columns are displayed, and also filter the list based on the values in any of the columns (see
Customizing object list columns and filtering lists on page 120).

You can select multiple items in a list by Ctrl-clicking them in the far-left, numbered column.
To select all the items in a list, click the top-left corner box. When multiple items are selected,
any edits you make to properties are applied to all the selected items.
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Note: By default, you must click the Apply button to commit changes or the OK button to
commit and close the list. To have changes commited immediately when you enter them in a
field, enable the Auto commit general option (see Dialog Box General Options on page 303).
You can always use the Undo tool to cancel the change.

All or some of the following tools are available on object lists:

Tool Description

Opens the property sheet of the selected item (see Object Properties on page 104).

[ordered lists only] Inserts a row before the selected row in the list.

Adds a row at the end of the list.

Opens an object selection dialog box to select objects and copy them to the list (see Adding
an Item from a Selection List on page 122).

Creates a new object and opens its property sheet to allow you to complete its definition.

[CDM only] Opens an object selection dialog box to reuse objects. When you select an
item you create a link to the original instead of copying it to the list.

Cuts the row and stores it in the Clipboard.

Copies the selected row to the Clipboard.

Pastes the contents of the Clipboard.

Deletes the row.

Opens the Find dialog to search for an item in the list.

Finds the object's symbol in the diagram.

Opens the Customize Columns and Filter dialog to change the columns displayed in the list
or define a filter (see Customizing Object List Columns and Filtering Lists on page
120).

Enables/Disables the filter specified in the Customize Columns and Filter dialog.

Includes objects in sub-packages in the list.

Includes composite objects (such as sub-processes, sub-activities, sub states, etc.) in the
list.
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Tool Description

Includes object shortcuts (see Shortcuts on page 355) in the list. Shortcuts are grayed as
they cannot be modified. When you include shortcuts whose target model is closed, some
information may be unavailable.

[Related Diagrams tab] Opens a target model or a diagram (see Specifying Diagrams as
Related Diagrams on page 170).

Opens an object selection list to change the target object of a shortcut

Sub-Object Lists

Many objects have property sheets that contain sub-object lists, which list all of the child
objects of that type belonging to the object. For example, the Columns tab in a table property
sheet displays the list of columns in the selected table:

These lists provide the same features as the lists of objects available from the Model menu.
Depending on the properties of the listed objects, the list may have a natural order that you can
control. For example, a list of columns has such an order, and you can move objects in the list
by selecting them and then clicking on one of the arrows at the bottom left corner of the list.
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Customizing Object List Columns and Filtering Lists
You can choose which property columns to display in object lists, reorder them, and filter the
range of values that they display.

1. Click the Customize Columns and Filter tool on an object list toolbar to open the
Customize Columns and Filter dialog.

2. Perform any of the following functions to filter the list:

• Select columns to display - by checking the [D]isplay column checkbox.
• Reorder the columns in the list - by using the arrows at the bottom left of the dialog. To

move all the selected rows to the top of the list, press SHIFT+ENTER.
• Define one or more filter expressions - by selecting an operator in the Operator

column and entering an expression to filter by in the Expression column.

The [U]sed checkbox is automatically selected when you enter a filter expression. To
disable the expression but keep it in memory, clear the checkbox.

3. Click OK to return to the list. The filter is applied by default, and the Enable/Disable filter
tool is depressed. Click this tool to toggle between enabling and disabling the filter.

Defining a Filter Expression
The Operator and Expression columns are used in multiple dialog boxes to filter a query.

The following operators are available

Operator Description

= [default] Equal to

> Greater than

>= Greater than or equal to
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Operator Description

< Less than

<= Less than or equal to

Not Equal Different from

In List Belongs to the list. For example "global", "Architecture",
"proc*" finds any of these values.

Not In List Does not belong to the list.

Between In a range between two values. For example, (A,E) finds any values between A
and E.

Not Between Outside a range of two values. For example, (A,E) finds any values outside of the
range between A and E.

Empty Has no value. No expression is necessary with this operator.

Not Empty Has a value. No expression is necessary with this operator.

You can use the following wildcards in the Expression column:

Wildcard Description

* Any string (from none to any number of characters). For example P* finds "pro-
tocol" and "Paris".

? Any character. For example ????? finds "Table" and "inner" but not "Seller".

\ Escapes the special characters *, ?, and \ . For example, \?\\ finds "?\".

Examples

The following examples show some possible combinations of operators and expressions:

Operator Expression Find

= W* Work, Washington

= *CODE AREA CODE, COUNTRY CODE, CITY CODE

> 1?? 200, 405, 609

Between O,8 0,1,2,3,4,5,6,7,8

In List *_emp_???,
*_grp_???

div_emp_fun, _emp_idn, div_grp_fun, _grp_idn

= *\? Is this book ready for production?
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Adding Items to and Reordering Items in a List
If a list is ordered you can choose to add an item at the end or at a certain point in the list, and
you can reorder the items in the list. When you add a new item to a list, it is created with a
default name and code that you can edit. Objects are not actually created until you click Apply
or OK.

Note: In general, you are not required to provide any specific properties when you create an
object. However, when you create a link object, such as a reference, association link, or
inheritance link, you must specify the source and the destination.

Adding Items at the End or at a Particular Point in a List

The following tools are available for adding items to a list:

Tool Description

Add a Row - Adds an item to the end of the list. You can also add an item to the end of a list
by clicking in any empty row.

Insert a Row [ordered lists only] - Adds an item in the row above the selected row. You
can always reorder items in an ordered list by selecting and dragging and dropping them
or by using the arrow tools at the bottom left of the list.

Arranging Items in an Ordered List

In ordered lists, you can drag and drop objects to reorder them, or use the following buttons at
the bottom of the list:

Tool Description

Move the selected items to the top of the list.

Move the selected items up one page

Move the selected items up one line

Move the selected items down one line

Move the selected items down one page

Move the selected items to the bottom of the list

Adding an Item from a Selection List
Selection lists allow you to select items from a list in order to associate them with another
object.

Most selection lists display objects contained in the current model or in individual packages
contained in that model.
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Other selection lists such as the following allow you to display both objects contained in the
current model or its packages and objects contained in other models or other packages of these
models:

• Select Diagrams. From this dialog box you can select the diagram to which you want to
apply pre-defined display preferences.

• Add Shortcuts. From this dialog box you can select objects to include them as shortcut in
your model or package.

• Add Objects. From this dialog box you can select objects to which you want to attach
extended dependencies.

Object Selection

The following tools are available in selection lists:

Tool Description

- Model list - Lets you specify a model as the basis for the list.

- Package list - Lets you specify a package as the basis for the list.

- Owner List - [PDMs only] Lets you specify a user as the basis for the list. The list will
contain only objects owned by the specified user or by no user. If you select User
<NONE>, then all the objects are displayed.

Include Sub-Packages - Includes objects contained in sub-packages (Include Sub-
Packages) in the list.

As this tool allows you to display all objects, regardless of their package, some objects
in the list may have the same name and be difficult to identify. In this situation, you can
use the Customize Columns and Filter tool, to display the Object Location column to
identify where the objects are defined.

Include Composite-Objects - Includes composite objects, such as sub-process, sub-
activity, sub state, in the list

Include External Shortcuts - Includes shortcuts to objects in other models in the list. The
model containing the original objects must be open for external shortcuts to be available
for selection. When generating, external shortcuts are generated as ordinary objects.

Select All - Selects all check boxes in the current object type tab. To select all check
boxes in all object type tabs you can click the arrow and select All Lists or you can press
the Ctrl key and click the Select All tool.

Deselect All - Deselects all check boxes in the current object type tab. To clear all check
boxes in all object type tabs you can click the arrow and select All Lists or you can press
the Ctrl key and click the Deselect All tool.

CHAPTER 4: Objects

Core Features Guide    123



Tool Description

Use Graphical Selection - Uses the graphical selection.

Move Selected Items to Top - Moves all selected objects to the top of the list.

Move Selected Items to Bottom - Moves all selected objects to the bottom of the list.

Customize Columns and Filter - Opens the Customize Columns and Filter dialog (see
Customizing Object List Columns and Filtering Lists on page 120), which allows you
to define a filter expression to apply to the selection list.

Enable/Disable Filter - Applies the filter defined in the Customize Columns and Filter
dialog to restrict the list of objects available for selection to those meeting its criteria.

The currently defined filter is displayed in the Filter box underneath the object list.

Use Filter for Selection - Applies the filter defined in the Customize Columns and Filter
dialog to select all objects meeting its criteria from the list. This selection by criteria is
persistent for as long as the tool is applied.

Ctrl + se-
lection tool

Applies the action of the selection tool to all object types in the different tabs.

Saving Object Selections

In some selection lists, you can save sets of object selections in your model, so that you can
reuse them easily. Note that in case of reverse engineering from a live data source, object
selections are saved into separated files, as you can reverse a database without having any
model open in the Workspace.

To save a selection, enter a name in the Selection list at the bottom of the Selection tab then
click the Save tool beside the list. The selection is saved as part of the model file. For live
reverse engineering, you have to select a folder before being able to save the object selection
into a separated file.

For more information about live database reverse engineering, see the "Reverse Engineering a
Database into a PDM" chapter in the Data Modeling guide.

Confirming Object Selections

In a selection list, the display of your object selection may be modified whenever you perform
one of the following actions:

• Change the folder selection using the Model or Package list
• Deselect the Include Sub-Packages/Sub-Objects tool
• Deselect the Include Shortcuts tool
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• Apply a filter using the Enable Filter tool
• Change the database or owner in the Reverse Engineering from a data source dialog box

In this case, some objects that have already been selected will no longer be displayed, and a
dialog box opens offering you the following options:

• Select only the objects displayed - Other objects that are no longer displayed are
deselected.

• Keep the hidden objects in the selection – All the previously selected objects are retained,
including those that are no longer shown. This allows you to take into account object
selections you have made in several packages for example.

• Cancel - The commit of the selection list is canceled and the selection page now displays
all objects and sub-objects in the model to let you modify your selection if necessary.

When you confirm your selection by clicking OK, the confirmation dialog box will not be
displayed again, while you continue to edit your selection, even if you again modify your
parameters.

Selecting an Object from a Selection Tree
Certain selection dialogs allow you to choose objects from a tree view or by searching by
name.

The Browse tab allows you to choose an object from a tree view:

The Index tab lets you search for an object by entering all or part of its name (or code
depending on the Display Name/Code model option). Objects are sorted alphabetically in the
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list and dynamically update as you type. Select an object and click the Properties button to
view its property sheet:

You can select an object on either tab and then click the other tab to retain the choice and view
it in that context. Double-click an object, or select it and click OK, to commit the selection and
close the selection dialog.

Moving, Copying, and Deleting Objects
Objects in the PowerDesigner working environment are easy to manipulate and to reuse from
one model or package to another.

Dragging and Dropping Objects
You can drag and drop objects to copy, move, create a shortcut or a replica in the
PowerDesigner modeling environment.

You can drag and drop objects from the Browser, the diagram or the Result list to the Browser
or diagram window but not to the Result list.

By default you move an object (from one package or model to another) in the Browser by drag
and drop.

You can change this behavior temporarily by pressing one or more of the following keys:
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Drag and drop
with...

Result

[no key} Move (in the Browser) or paste as shortcut (between diagrams)

Shift Move

Ctrl Copy

Shift + Ctrl Shortcut creation

Shift + alt Replication creation

Note: If you select an object in the Browser or diagram and then right-click and drag it, when
you release the right mouse button, a contextual menu opens listing all the available drop
actions.

To modify the default Browser drag and drop behavior, select Tools > General Options and
select the appropriate radio button:
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Copying and Pasting Objects
You can copy objects from diagrams, the Browser, object lists, and the Results List and paste
them into diagrams, the Browser, object lists, and external applications.

When you copy an object, you copy not only its properties but also the properties of its related
objects to the clipboard. For example, if you copy a CDM entity, you also copy the attributes
and business rules attached to that entity. When you paste an object, you transfer all of its
properties from the Clipboard and create a new object, and not a graphical synonym or a new
instance of the copied object.

Copying Objects

To copy an object, select it in a diagram, the Browser, an object list, or the Results List, and
then do one of the following:

• Select Edit > Copy from the PowerDesigner menu bar.
• Press CTRL + c.
• Right-click and select Edit > Copy.
• Open a list of objects, select one or several lines in the list and Press CTRL + c.

Pasting Objects

Note: By default, when you drag and drop objects, you move them, but if you hold down the
ctrl key during a drag and drop, you can create a copy. For more information, see Dragging and
dropping objects on page 126.

To paste an object in PowerDesigner, click in a diagram, the Browser, or an object list, and then
do one of the following:

• Select Edit > Paste from the PowerDesigner menu bar.
• Press CTRL + V.
• Right-click and select Edit > Paste.
• Open a list of objects, select a line in the list and Press CTRL + V.

If you paste the selected object into an external application, the following will occur:

Copied item Paste result

Diagram symbol Image of the symbol (MS Word, PaintBrush)

List item from an object list List in CSV format (MS Word, Excel)

Item from the Check Result list List in CSV format (Excel)

Item from the Find Result list List in CSV format (Excel)
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Pasting Objects as Shortcuts

When you copy an object you can paste it as a shortcut that references the original object (see
Chapter 11, Shortcuts and Object Replications on page 355).

Note: By default, when you drag and drop objects, you move them, but if you hold down the
CTRL and SHIFT keys during a drag and drop, you can create a shortcut. For more
information, see Dragging and dropping objects on page 126.

To paste an object as a shortcut in PowerDesigner, click in a diagram, the Browser, or an object
list, and then do one of the following:

• Select Edit > Paste As Shortcut from the PowerDesigner menu bar.
• Right-click the Browser target or the diagram window and select Edit > Paste As

Shortcut.

When pasting as a shortcut into a diagram, the following rules are used. If the object copied is
in:

• The same model or package and the same diagram - a new graphical synonym of the object
is created.

• The same model or package but a different diagram - a new shortcut symbol or graphical
synonym is created.

• A different model or package:
• If the shortcut does not exist, a shortcut is created (with a symbol)
• If the shortcut already exists without a symbol, a symbol is created (if you are pasting

into a diagram)
• If a shortcut and a symbol already exist, a graphical synonym is created (if you are

pasting into a diagram)

Managing Paste Conflicts

When you paste an object in PowerDesigner, checks are applied in order to verify that no
conflict occurs between the identifying properties of the objects. The identifying criteria
depends on the type of object, for some objects it is just the code, for others, the name and the
code.

For more information about the identifying properties of an object, see Object namespaces on
page 116.

When a paste conflict occurs, PowerDesigner automatically renames the name and/or the
code of the object in the following way:

Source object First renaming Second renaming

Name Name2 Name3

CODE CODE2 CODE3
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A message is displayed in the Output pane to warn you that the object was renamed.

When a paste conflict occurs on a CDM entity, the entity is renamed according to the data item
options set in the model.

Data item options Result of copying an entity

Unique Code

Allow Reuse

New entity with new name and code

New identifier with new name and code

Reuses other attributes

Unique Code only New entity with new name and code

New identifier with new name and code

New attributes with new names and codes

Allow Reuse only New entity with new name and code

New identifier with same name and code

Reuses other attributes

None New entity with new name and code

New identifier with same name and code

New attributes with same names and codes

Deleting Objects
You can delete an object from a diagram, the Browser, or an object list.

Since PowerDesigner gives you the freedom to create multiple symbols in multiple diagrams
to represent the same object, when deleting a symbol in a diagram, you can choose to delete
just the symbol or the entire object.

When you delete an object, you also delete any sub-objects it contains (for example, when you
delete a table from a PDM, you delete its columns, keys, triggers and indexes), along with all
its diagram symbols. If you delete an object that is connected to another object via a link, the
link is also deleted.

To delete an object, do one of the following:

• Select its symbol in a diagram and press the Delete key or right click it and select Edit >
Delete. A dialog will open asking you whether you want to delete the object itself
(including any sub-objects it contains) or just the symbol:
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You can review the impact that deleting the object would have on other objects in your
environment by clicking the Impact button on the confirmation dialogs (see Chapter 13,
Impact and Lineage Analysis on page 421). You can undo a deletion by clicking the Undo
tool.
Make your choice and click OK. If you delete only the symbol, you can restore it to the
diagram, by selecting Symbol > Show Symbols and reselecting the object in the Show
Symbols dialog.

• Select its symbol in a diagram and press Shift+Delete. The object, any sub-objects it
contains, and any associated diagram symbols will be deleted immediately without the
need for confirmation.

• Select it in the Browser and press the Delete key or right click it and select Edit > Delete. A
dialog will open asking you to confirm the deletion:

Click OK to delete the object, any sub-objects it contains, and any associated diagram
symbols.

• Select it in an object list and click the Delete tool or press the Delete key. The object, any
sub-objects it contains, and any associated diagram symbols will be deleted immediately
without the need for confirmation.

Note: You can suppress the display of the Confirmation dialogs by deselecting the Confirm
Object Deletion general option (see General Options on page 301).

Deleting Domains and Data Items

If you have specified that domains and data items can be reused by multiple objects in a CDM
or PDM and you delete a parent object to which they belong, these sub-objects will not be
deleted with their parent. For more information, see the Data Modeling guide.
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Moving Objects from Package to Package
You can move an object from package to package using drag and drop feature.

Moving objects is different from cutting and pasting items, since you do not duplicate objects.

For entities containing data items, the following situations can occur when you move the
entity:

Data items Namespace Move result

Only used by selected entity Move within the same
namespace

The data items are moved with the
entity

Reused among different entities Move within the same
namespace

Shortcuts of data items are created
for reused data items

Used only by one entity or reused
among different entities

Change namespace Data items are copied in the other
namespace

For more information about shortcut and copy rules, see Shortcuts on page 355.

Moving objects is restricted as follows:

• Models must be compatible (same resource file)
• Global objects (business rule, domain, storage etc.) cannot be moved into a sub-package

When you move an object from a package to another, linking objects that you move keep their
links in the target package and a shortcut is usually created in the source package. The general
rule being that conceptual modeling must be preserved.

Shortcuts creation rules in PowerDesigner also apply to moving objects between packages.

For more information about shortcuts creation, see Shortcuts on page 355.

To move an object with a non-oriented link:
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Source package Moving result

In the source package, a shortcut of the moved
entity is created:

In the target package, the moved entity is dis-
played:

To move an object with an oriented link:
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Source package Moving result

Example 1: Move TABLE_2

In the source package, a shortcut of the parent
table (TABLE_2) is created:

In the target package, the parent table (TABLE_2)
is displayed:

Example 2: Move TABLE_1

In the source package, only the parent table (TA-
BLE_2) is displayed:

In the target package, the child table (TABLE_1)
is displayed with the reference link and a shortcut
is created for the parent table (TABLE_2):

1. Select an object.

2. Press shift while dragging the object to the target package.

The object is moved to the new destination and a shortcut is created either in the source
package or in the destination package depending on the link type.

Creating Graphical Synonyms for Objects
A graphical synonym is an additional symbol for an object. Sometimes, creating multiple
symbols for an object in a diagram can improve readability by reducing the length or
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complexity or links. You create a graphical synonym by right-clicking a symbol and selecting
Edit > Create Graphical Synonym.

You can create as many graphical synonyms as you want within the same diagram. You can
even create graphical synonyms of graphical synonyms and of object shortcuts.

You can create graphical synonyms of graphical synonyms and of object shortcuts. Each
graphical synonym displays the name of the object followed by a colon and the number of the
synonym. In the following example, Employee : 1 and Employee : 2 both represent
the Employee table:

If you move an object for which you have created graphical synonyms from one package or
model to another, shortcuts are created for the graphical synonyms in the original package.

Note: To find any graphical synonyms of a symbol, right-click the symbol, select Edit > Find
Graphical Synonym, and then select a graphical synonym from the list. The graphical
synonym is centered and selected in the diagram window.

Graphical Synonym Limitations

You can create graphical synonyms for link objects but only if both they and the symbols at
both their extremities (which will also be duplicated) support them. The following object
symbols do not support graphical synonyms:

• CDM - inheritances and inheritance links
• OOM - swimlanes, synchronizations, decisions, transitions, instance links, messages,

association class links, and interaction frames, fragments, and references
• BPM - swimlanes, synchronizations, decisions, and flows
• All - free symbol line

Note that though you cannot visually distinguish a graphical synonym of a link from a normal
link (unless you display the name attribute), when you select a link symbol, it is identified as a
graphical synonym in its tooltip:
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Finding Objects
PowerDesigner lets you search for objects within all the models currently open in your
workspace.

With the Find Objects dialog, you can:

• Locate objects in the different models in the workspace and modify their properties
• Find all the shortcuts related to a given object
• Reuse objects from one model to another

Note: Once you have started the Find Objects process, you can stop it at any time by clicking
the Stop button in the Find Object dialog box.

1. Select Edit > Find Objects to open the Find Objects dialog box.

2. Specify the appropriate parameters on the following tabs:

• Name and Location - to search on the name and/or location of PowerDesigner objects.
• User and Date - to search on the user and/or date of creation/modification of

PowerDesigner objects.
• Advanced - to search on other criteria.

For detailed information about these tabs, see Find object parameters on page 137.

3. Click the Find Now button.

The Find Object dialog box remains open, displaying messages in the Output pane, until
the end of the process, when the Result List displays the result:

  136 PowerDesigner  



Find Object Parameters
The Find Objects dialog contains three tabs to let you specify precisely your search criteria.

Name and Location Parameters

The following parameters are available on this tab:

Parameter Description

Look in Specifies the scope of the search. You can select the entire workspace, a project,
folder, model, or package.

Model type Specifies the type of PowerDesigner model to search. The options available in this
list are affected by your choice in the Look in field.

Object type Specifies the type of model objects to be searched. The options available in this list
are affected by your choice in the Model type field.

Include shortcuts Instructs PowerDesigner to include object shortcuts that match your criteria in the
results.
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Parameter Description

Name Specifies the object name to search for. You can use the following special char-
acters:

• * - none to any number of characters. For example:

• W* finds "Work" and "Washington"

• *96 finds "01/11/96" and "26/08/96"

• ? – exactly one character. For example:

• *_emp_??? finds "Div_emp_idn" but not "Div_emp_ident"

• \ - escapes *, ?, or \. For example:

• \?\\ - finds ?\

• true/false - Boolean value (True is when the check box is selected)

Code Code of the object. You can type the exact code of the object or use a string
expression.

Case sensitive Specifies that the results must match the case of the criteria.

User and Date Parameters

The following parameters are available on this tab:

  138 PowerDesigner  



Parameter Description

Created Enables searching on creation parameters. You can search against the name of the
user who created the object and/or against the creation date using the following
options:

• Before the specified date

• After the specified date

• Between the two specified dates

• In the specified number of days since today

Modified Enables searching on modification parameters.

Advanced Parameters

The Advanced tab allows you to specify advanced find parameters on each property of the
selected object type. For more information about the operators and the expression syntax, see
Defining a Filter Expression on page 120.

Note: If you do not select an object type on the Name & Location tab, then you can only
search on the name and code properties on the Advanced tab.

The following parameters are available on this tab:

Parameter Description

U (Used) Specifies a property on which to apply the search.

Operator Specifies an operator to use for the search. Click in the Operator column to
display the list of available operators.
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Parameter Description

Expression Specifies a string expression to search for.

Note: If you select the Used check box for a property without any expression, it is equivalent to
a null value, the find process will consequently look for objects which selected property is
null.

Using the Result List
You can perform various operations on objects directly from the Result List.

The following operations are available by right-clicking an object in the Results List:

• Properties - to open the object's property sheet.
• Find in Browser - to highlight the object in the Browser.
• Find in Diagram - to open the diagram with the symbol centered. If the object has

symbols in multiple diagrams, a list is displayed. If the object has no symbol, a warning
message is displayed.

• Copy - to copy the object. Select a destination in the Browser or a diagram and select Edit
> Paste or Edit > Paste as Shortcut from the contextual menu.

Business Rules
A business rule is a rule that your business follows. It is a written statement specifying what an
information system must do or how it must be structured. It could be a government-imposed
law, a customer requirement, or an internal guideline.

Business rules often start as simple observations, for example "customers call toll-free
numbers to place orders." During the design process they develop into more detailed
expressions, for example what information a customer supplies when placing an order or how
much a customer can spend based on a credit limit.

You can attach business rules to your model objects to guide and document the creation of your
model. For example, the rule "an employee belongs to only one division" can help you
graphically build the link between an employee and a division.

Business rules complement model graphics with information that is not easily represented
graphically. For example, some rules specify physical concerns in the form of formulas and
validation rules. These technical expressions do not have a graphical representation.

In the case of the PDM and OOM, you can generate business validation rules attached to
domains as check parameters.

Before you create business rules, formulate your rules by asking yourself the following
questions:
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• What business problems do I want to address?
• Are there any procedures that my system must respect?
• Do any specifications dictate the scope of my project?
• Do any constraints limit my options?
• How can each of these procedures, specifications, and constraints be described?
• How can each of these descriptions be classified? Possible classifications are definitions,

facts, formulas, requirements or validation rules

Creating a Business Rule
You can create a business rule in any of the following ways:

• Select Model > Business Rules to access the List of Business Rules, and click the Add a
Row tool

• Right-click the model or package in the Browser, and select New > Business Rule
• Open the property sheet of the object to which you want to apply the rule, click the Rules

tab, and click the Create an Object tool

For general information about creating objects, see Creating Objects on page 101.

Business Rule Properties
You can modify an object's properties from its property sheet. To open a business rule property
sheet, double-click its Browser entry in the Business Rules folder. The following sections
detail the property sheet tabs that contain the properties most commonly entered for business
rules.

The General tab contains the following properties:

Property Description

Name The name of the item which should be clear and meaningful, and should convey
the item's purpose to non-technical users

Code The technical name of the item used for generating code or scripts, which may be
abbreviated, and should not generally include spaces

Comment Descriptive label for the rule

Stereotype Sub-classification used to extend the semantics of an object.
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Property Description

Type Specifies the nature of the business rule. You can choose between:

• Constraint – a check constraint on a value. In a PDM, constraint business rules
can be generated in the database. For example, "The start date should be
inferior to the end date of a project."

• Definition – a property of the element in the system. For example; "A customer
is a person identified by a name and an address".

• Fact – a certainty in the system. For example, "A client may place one or more
orders".

• Formula – a calculation. For example, "The total order is the sum of all the
order line costs".

• OCL constraint [OOM only] – An Object Constraint Language expression.
• Requirement – a functional specification. For example, "The model is de-

signed so that total losses do not exceed 10% of total sales".
• Validation – a constraint on a value. For example, "The sum of all orders for a

client must not be greater than that client's allowance".

The following tabs are also available:

• Expression Tab - Though business rules typically start out as descriptions, as you develop
your model and analyze your business problem, you can enrich them by adding technical
expressions on this tab. Expressions are used primarily in CDMs and PDMs. Each rule can
include two types of expression, which you define on the appropriate sub-tab:
• Server
• Client

• OCL Constraint Tab - This tab is only available for business rules with a type of OCL
Constraint. The Object Constraint Language is the UML expression language. Enter your
OCL expression in the text field.

Applying a Business Rule to a Model Object
You can apply business rules that you have created to your model objects.

1. Open the property sheet of an object, and then click the Rules tab:
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2. Click the Add Rules tool to open a selection window listing all the business rules available
in the model:

3. Select the business rules you want to add to the object, and then click OK to return to the
object's property sheet.

4. Click OK to close the object property sheet and return to the model.
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Note: When you apply a business rule to an object, its U (Used) column in the List of
Business Rules is automatically checked. This column allows you to see what rules are
unused, and delete them if necessary.

File Objects
A file object is a representation in a PowerDesigner model of an external application file (for
example, a Java file, script SQL, or MS Word file). The file itself can be kept external to the
model or embedded within and saved with it.

For example you could:

• Attach a file object to any PowerDesigner object to enrich its description
• Attach a generated OOM class to a target Java file

You open the file in its associated editor by double-clicking its diagram symbol or browser
entry. To change the associated editor, right-click the file object and select Open With >
Choose Program

For more information about text editors, see Specifying Text Editors on page 305.

Creating a File Object
You can create a file object in any of the following ways:

• Use the File tool in the diagram Palette.
• Select Model > Files to access the List of Files, and click the Add a Row tool.
• Right-click the model or package in the Browser, and select New > File from the

contextual menu.
• Drag a file from Windows Explorer and drop it in the diagram or Browser.

For general information about creating objects, see Creating Objects on page 101.

File Object Properties
You can modify an object's properties from its property sheet. To open a file object property
sheet, double-click its diagram symbol or its Browser entry in the Files folder. The General tab
contains the following properties:

Property Description

Name The name of the item which should be clear and meaningful, and should convey the
item's purpose to non-technical users

Code The technical name of the item used for generating code or scripts, which may be
abbreviated, and should not generally include spaces

Comment Descriptive label for the file object
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Property Description

Stereotype Sub-classification used to extend the semantics of the file object. You can create
stereotypes in the Profile category of the resource file attached to the current model.

Location type Specifies the nature of the file object. You can choose from the following:

• Embedded – the file is stored within the model and is saved when you save the
model. If you subsequently change the type to external, you will be warned that
the existing contents will be lost.

• External – the file is stored in the Windows file system, and you must enter its path
in the Location field. If you subsequently change the type to embedded, you will
be prompted to import the contents of the file into the model.

• URL – the file is on the web and you must enter its URL in the Location field

Location [External and URL types only] Specifies the path or URL to the file.

Extension Specifies the extension of the file object, which is used to associate it with an editor.
By default, the extension is set to txt.

Generate Specifies to generate the file object when you generate the model to another model.

Artifact Specifies that the file object is not a piece of documentation, but rather forms an
integral part of the application.

If an artifact has an extension that is defined in the Editors page in the General
Options dialog box and is linked to the <internal> editor (see Specifying Text Editors
on page 305), a Contents tab is displayed in the artifact property sheet, which allows
you to edit the artifact file in the PowerDesigner text editor.

For more information about the use of artifact files, see "Files" in the Building
Implementation Diagrams chapter of the Objet-Oriented Modeling guide.

Attaching a File Object to a PowerDesigner Object
You can attach a file object to another object in any of the following ways:

• Right-click an object symbol in the diagram and select File > Add file from the contextual
menu.

• Use the Link/Extended Dependency tool in the diagram palette to draw a link from the
object symbol to the file object symbol.

• Open the property sheet of the object, click the Extended Dependencies tab, and select the
file object using the Add Objects tool..

The connection between the object and the file object takes the form of an extended
dependency, and is visible:

• Graphically in the diagram
• On the Dependencies tab of the file object property sheet and on the Extended

Dependencies tab of the dependent object property sheet

CHAPTER 4: Objects

Core Features Guide    145



• Under the File menu item in the contextual menu of the dependent object symbol.

For more information about extended dependencies, see Using Extended Dependencies on
page 334.

File Object Display Preferences
You can modify the following display preference for a file object using the Tools > Display
Preferences command.

Preference Description

Location Displays the location of the file object

Extending Objects
PowerDesigner includes powerful tools to extend and customize your modeling objects. You
can add new attributes and attribute lists to objects, create entirely new objects, and customize
object generation.

Extended Attributes
The model objects defined in the PowerDesigner metamodel can be extended and given
additional properties, called extended attributes. Some extended attributes are defined in the
resource files that are provided with PowerDesigner to support a particular language or
DBMS, and others will be defined by you or your colleagues to model features specific to your
environment.

You may not know that you are working with extended attributes, as they are frequently
assigned to standard or custom property sheet tabs. However, if one or more extended
attributes is not so assigned, an Extended Attribute tab will be displayed in the property sheet
of all objects of this kind, listing all the extended attributes in alphabetical order and with the
following columns.

Property Description

Name Specifies the name of extended attribute.

Data type Specifies the datatype of the extended attribute (such as boolean, color, date, file,
float, font, etc or customized data types).

Value Specifies the current value assigned to the extended attribute.

R Redefined value. This checkbox is selected if you modify the default value in the
Value column.

For information about adding extended attributes to model objects and displaying them in
property sheet tabs, see the Extending your Models with Profiles chapter of the Customizing
and Extending PowerDesigner manual.
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Adding New Properties to an Object
To quickly add new properties to an object, use the dialogs available from the property sheet
menu. Properties added to an object are available for all other objects of that type.

Adding a New Attribute to an Object
If the standard PowerDesigner attributes are insufficient for your modeling requirements, you
can add new ones using the New Attribute dialog available from the property sheet menu.

1. Open the property sheet of the object you want to extend, click the menu button, and select
New Attribute to open the New Attribute dialog:

2. Enter a Name and Datatype for the new attribute and complete any other appropriate
fields.

3. [optional] Click Next to specify the property sheet tab on which you want the attribute to
appear. If you choose to create a new property sheet tab, you must enter a tab label to
display.
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By default, the attribute is inserted on the tab from which you launched the New Attribute
dialog, if the tab is editable.

4. [optional] If you want to view the new attribute in the PowerDesigner Resource Editor,
select the Open Resource Editor on Finish checkbox.

All extensions are stored in PowerDesigner resource files. For detailed information about
working with these files, see the Extending Your Models with Profiles chapter in the
Customizing and Extending PowerDesigner manual.

5. Click Finish to close the dialog and create the new attribute.

The attribute appears on the specified property sheet tab:
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Adding a New List to an Object
Many PowerDesigner objects are associated with multiple instances of another type of object.
For example, a table can have multiple columns, a class can have many operations, and a
person can be in many groups. You can model new kinds of associations by adding new lists to
your object property sheets.

1. Open the property sheet of the object you want to extend, click the menu button, and select
New List of Associated Objects.

2. Enter a Name for your list. This name is used as the name of the property sheet tab on
which the list appears.
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3. Select the type of associated object that you want your list to display. You can choose from
any of the object types available in your model, but the association should make sense for
your modeling needs.

4. [optional] To limit the objects of the selected type that your object can be associated with,
specify a stereotype. If you specify a stereotype here, you will only be able to associate
your object with other objects bearing this stereotype.

5. Click OK to exit the dialog and create the new list.

The list appears as a new tab in your property sheet, containing tools that let you associate
existing and new objects of the specified type with your object:

Managing Extensions
To review your object extensions in the Resource Editor, select Manage Object Extensions
from the property sheet menu.

You can create basic new properties and lists using the wizards available from the property
sheet menu. To perform more advanced editing of extensions, you must open the appropriate
extended model definition.

1. Open the property sheet of the object, click the menu button, and select Manage Object
Extensions.
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2. Specify the Extended Model Definition that you want to open, from the list of definition
files attached to the model.

An object can be extended in the Profile category of multiple extended definitions. You can
select an existing definition file or create a new one.

3. [optional] Select the checkbox to set the chosen extended model definition as the default.

4. Click OK to open the chosen extended model definition in the Resource Editor.

For detailed information about editing files in the Resource Editor, see the Extending Your
Models with Profiles chapter in the Customizing and Extending PowerDesigner manual.

Extended Objects, Sub-Objects, and Links
Extended objects, sub-objects, and links are additional objects that can be added in any kind of
model to let you design specific business needs or concepts that are not supported by
PowerDesigner standard objects.

For example, you can use extended objects in a PDM to design database objects that are not
natively supported. You can specify "generated files" and templates in the definition of your
extended objects in order to enable their generation and reverse-engineering.

Extended objects and extended links are available in all PowerDesigner models. However,
only the free model (see Using the Free Model on page 97) displays these objects by default. If
you want to use extended objects and/or links in another type of model, you have to add the
corresponding metaclasses and their tools to the Profile category in the model's resource file or
in an extended model definition.

For information about adding extended objects, sub-objects, and links to the Profile category,
see the Extending Your Models with Profiles chapter in the Customizing and Extending
PowerDesigner manual.
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Extended Object, Sub-object, and Link Properties
You can double-click any extended object symbol in the diagram to open its property sheet:

Property Description

Name Specifies the name of the item which should be clear and meaningful, and should
convey the item's purpose to non-technical users.

Code Specifies the technical name of the item used for generating code or scripts, which
may be abbreviated, and should not generally include spaces.

Comment Specifies additional information about the extended object.

Source [extended links only] Specifies the name of the origin object of the extended link.

Destination [extended links only] Specifies the name of the destination object of the extended
link.

Stereotype Sub-classification used to extend the semantics of the extended object. You can
create stereotypes in the Profile category of the resource file attached to the current
model.

CanLinkKind Event Handler

You can use the CanLinkKind event handler to restrict the kind and stereotype of the objects
you want to link together. The CanLinkKind event handler has two input parameters: the
source and the destination extremity of the link, note that these cannot be shortcuts.

The CanLink event handler is called when you create a link using the corresponding tool in the
Palette or when you try to modify the ends of a link from its property sheet.

For more information about the CanLinkKind event handler, see "Event Handlers (Profile)" in
the Extending your Models with Profiles chapter of the Customizing and Extending
PowerDesigner manual.

Extended Object/link Display Preferences
You can modify the following display preference for extended objects using the Tools >
Display Preferences command:

Preference Description

Stereotype Displays the stereotype of the extended object

Comment Displays the comment of the extended object

Display sub-objects [extended objects only] Displays the sub-objects (defined in an ex-
tended composition) of the extended object
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Customizing the Generation of Files for an Object
In PowerDesigner, you can define a generated file on a selected metaclass (or stereotype or
criterion), in this case a file is generated for each instance of the metaclass existing in your
model. The generated files mechanism is defined in "Templates and Generated Files (Profile)"
in the Extending your Models with Profiles chapter of the Customizing and Extending
PowerDesigner manual.

You can modify the default generation of files using artifacts. Artifacts are used to generate
files only for selected instances of a metaclass in order to:

• Design a source file that includes the code of several objects in a single file.
• Generate only for selected instances of a metaclass.
• Customize the generated file name and path.

C# and VB .NET Reverse Engineering Use Case

Artifacts are visible in the C# and VB .NET object languages. This is to support round-trip
engineering for these languages: when you reverse engineer C# or VB .NET code, each source
file in the source code becomes an artifact in PowerDesigner. The artifact allows you to re-
generate the same collection of objects while preserving file structure.

Using Artifacts in a Model
To be able to use an artifact in a model, you have to declare it in a resource file attached to your
model. To declare an artifact you have to create a template called "DefaultTemplate" under an
artifact stereotype or criterion bearing the name of the corresponding file type to generate.

In the C# resource file, if you expand the Artifact folder, you can see that the stereotype
"Source" and the template "DefaultTemplate" are defined by default. This means that when
you create a new artifact and assign the Source stereotype, this artifact inherits the default
template defined below:
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Example

You define the following artifact criterion in an extended model definition:
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This criterion verifies that the last 4 characters of the artifact name are .TXT. You also need to
create the default template in order to define the content of the generated file. In this example,
DefaultTemplate is defined as follows:

This is a text file.

.foreach_item(ProductionObjects)
%ShortDescription%
.next(\n)

You can now create artifacts in the model using the New > Artifact command in the model
contextual menu. If you create an artifact with the .TXT extension and select the correct target
in the Template tab of the artifact property sheet, the default template is automatically
assigned to this artifact. This means that the short description of each instance of object
associated with the current artifact will be written in the generated file:
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You can now define instances of objects you want to include in the file generated from the
current artifact:
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Defining an Artifact
Artifacts can replace the standard generation of files; by default, an artifact generates the same
code as the generated file but only for selected instances of a metaclass.

An artifact has the following properties:

Property Description

Name Name of the artifact.

Comment Descriptive comment for the artifact.

Stereotype Sub-classification used to extend the semantics of an object without changing its
structure; it can be predefined or user-defined.

Encoding Allows you to modify the default file encoding of the files to reverse engineer.

An artifact definition also includes the following properties:

Property Description

Template Template used to generate the content of the generated file.

Objects List of objects associated with the current artifact.

Prerequisites List of artifacts that must be generated before the current artifact.

Preview Allows to visualize the generated code of the artifact.

1. Double-click the symbol of an object with generated files, for example a class in C#
language.

2. Click the Generated Files tab.

The Target column displays the resource file where the generated file is defined and the
File Type column displays the type of the generated file.

Each row in the list corresponds to a generated file type available for the current instance of
a metaclass, you can customize the generation of this file using an artifact.

3. Click the Create tool in the Artifact(s) column to add an artifact. This artifact will replace
the standard file generation for the current object.

CHAPTER 4: Objects

Core Features Guide    157



4. Click Apply and click the Properties tool to define artifact properties.

5. Click OK in both property sheets.

Managing Artifacts
Artifacts appear in the Artifact category of the Browser. You can perform the following actions
to customize an artifact:
• Change the artifact name using the Edit in place feature and avoid opening the artifact

property sheet
• Drag and drop authorized objects from the diagram or the Browser to an artifact in order to

add the code of this instance to the artifact

Artifact Folder

An Artifact folder is used to create an artifact hierarchy for generation.

You can create as many folders as you need using the New > Artifact Folder command in the
Artifact category or model contextual menu. The artifact folder property sheet is displayed to
let you define a name and comment for the folder. You can then create artifacts in the folder
structure.

  158 PowerDesigner  



Generated Files Tab
In the Generation dialog box, the Generated Files tab displays a checkbox tree with generated
files (with a dimmed icon) and artifacts. You can select or deselect the files you want to
generate.

You can modify generation options from this dialog box, and you can also check artifact
generation completeness: if an exclamation mark is displayed on the artifact icon it means that
one or several prerequisite artifacts are missing.

If you click the Enforce Dependencies tool in the upper part of the dialog box, the artifacts that
are prerequisites of other artifacts are automatically selected in the tree view in order to
properly generate artifacts.

Generate from an Artifact Folder

If you click the Generate command in the artifact folder contextual menu, a Generation dialog
box is displayed to let you manage the generation of a given artifact folder. This dialog box
also displays a checkbox tree with children artifacts of the selected artifact folder.

CHAPTER 4: Objects

Core Features Guide    159



You can enforce dependencies in the Generation dialog box to make sure all prerequisites are
selected for generation.

Importing Objects from Excel Files
You can import objects listed in an Excel files to any kind of PowerDesigner model. The Excel
Import extended model definition allows you to launch a wizard that guides you through
mapping tables of objects to be modeled from Excel files to PowerDesigner objects and
properties, and to import the contents of the files to your model. For example, you could create
a list of database tables in an Excel file, specifying any appropriate properties, and then import
them into a PDM.

You can import any number of different types of objects from a single Excel file, so long as
they can all be imported to a single type of model. Each type of object should be listed in its
own table on a separate worksheet of the Excel file. Each row in a table represents one object to
import, and each column represents one property (an attribute or list of associated objects) of
the object.

In the following example, the Excel file contains separate tables of objects containing tables,
keys, references, and reference joins. The Table sheet, contains a list of three table to import.
The columns Name, Owner, and Columns will be imported as the corresponding table
properties:
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For detailed information about how to organise the file, see Preparing Your Excel File for
Import on page 163.

You can create a new model by importing objects from an Excel file or import your objects into
an existing model.

1. Open the Excel Import Wizard:

• To a create a new model, select File > Import > Excel File. Specify the kind of model
you want to create in the New Model dialog (see Creating a Model on page 12), and
then click OK.

• To import objects into an existing model, attach the Excel Import extended model
definition (available for all model types on the Import subtab of the Select Extensions
dialog) to your model (see Attaching an Extended Model Definition to a Model on
page 328), then right-click the model in the Browser, and select Import Excel File.

2. Click the Select File tool, browse to and select the Excel file to import, and click Open to
return to the wizard.

3. [optional] Click the Options button to open the Import Options dialog (see Excel Import
Options on page 165), specify any appropriate options and then click Close to return to the
wizard.

4. Click Next to go to the Import Table page:
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On this page, you must either:
• Select a PowerDesigner object type to import the table lines As from the list.
• Select to import the table lines as a new object type by clicking the New tool to the right

of the list to open the New Object Type dialog.
• Deselect the check box to not import this table. When you click Next, PowerDesigner

will search the Excel file for another table of objects to import.

5. Click Next to go to the Import Column page:

On this page, you must either:
• Select a PowerDesigner attribute to import the table column as from the Attribute list.

To create a new attribute, click the New tool to the right of the list.
• Select the List of associated objects radio button to import the column as a list,

selecting the List to use and (if the list can contain multiple types of objects), the
appropriate Object. To create a new list, click the New tool to the right of the list.

• Deselect the check box to not import this table column.

6. Click Next. The wizard will search for the next column in the table and if there is none (or if
you have selected to skip importing the table), will search for the next sheet containing a
table of objects.

When all the sheets and all the columns have been processed, the import will begin. You
can stop the import at any time by clicking the Cancel button in the bottom-right corner.
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When it is complete, a dialog will appear showing how many objects have been created.
Click OK to return to your model.

In addition to the objects that you have created, PowerDesigner creates an Excel Import object
that contains your import parameters, along with a Table Mapping object for each of the
imported tables, which lists the column mappings used. Right-click the Excel Import Object to
access the following commands:

• Import - to re-import your file based on the options and mappings you have already
defined. All the objects will be reimported, overwriting any existing objects based on their
names. If you have added new objects to your worksheet tables they will be added to the
model, but any objects that you have deleted from your worksheet will not be deleted from
the model.

• Change Mappings - to re-import your file via the Excel Import Wizard in order to modify
your table or column mappings.

• Change Options - to change the import options preparatory to re-importing with the
command Import

• Properties - to open the Excel Import properties sheet.

Note: Advanced users may want to modify the Excel Import XEM to enable the import of data
from other external file types. For detailed documentation about its implementation, open the
XEM (which is located at  install_dir\Resource Files\Extended Model
Definitions\ExcelImport.xem in the Resource Editor and read the detailed
commentary on the root element.

Preparing Your Excel File for Import
By following certain simple rules, you can greatly help PowerDesigner to recognize the
information in your Excel files, and thus improve the accuracy and speed of the import.

Follow these rules to ensure that your import goes as smoothly and quickly as possible:

• Insert only one table of objects per worksheet –  If you have more than one table on a
worksheet, only the first will be recognized and imported.

• Name your worksheet after the object to import –  If the name of your worksheet
matches the name of a PowerDesigner object type, then the wizard will suggest mapping
the table to that object type. The wizard does not recognize plural forms so, if your sheet
contains tables, you should call it Table, and if it contains classes, call it Class.

For sub-objects (objects linked to their parent by composition), you must prefix the name
of the object with that of its parent object, (eg Table.Key) or it will not be recognized.

• Name table columns after the property they contain –  If you name each of your
columns after the attribute or collection that it contains, then the wizard will suggest
mapping the column to that attribute or collection. As a general rule, attributes are singular
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and collections plural so that, for example, you should name the column that contains your
tables' names Name and the column containing its columns, Columns.

• List items in a collection in a single cell –  You can quickly list items in a collection by
entering them in a single Excel cell separated by commas:

You can change the separator by specifying another symbol in the List value separator
import option.

• Represent relationships of composition using a Parent column –  To specify
relationships of type composition (such as columns in a table, classes in a package, or
attributes in a class) between objects on different worksheets, specify the parent or location
for the sub-object in a Parent column. You can specify a multi-level hierarchy of parents
separated by a qualified name separator. Whereas specifying a collection of sub-objects in
a single cell on the parent worksheet allows you to quickly populate the collection,
specifying sub-objects on a separate worksheet allows you to detail all their properties.
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Excel Import Options
The Excel Import Wizard provides a number of options to allow some flexibility in the format
of the data it can import.

Option Description

Auto-map columns to
properties

Instructs the wizard to automatically map tables and columns that share
names with objects or properties in the PowerDesigner metamodel without
requesting confirmation. If your Excel sheets and table column headings
conform to the PowerDesigner metamodel, this option can save considerable
time by only showing you (and requesting your input for) items that the
wizard is unable to match itself.

For information about helping the wizard match your data to the PowerDe-
signer metamodel, see Preparing Your Excel File for Import on page 163).

Default: Unselected

Create symbols in ac-
tive diagram

Instructs the wizard to create symbols, where appropriate, for the imported
objects in the currently selected diagram.

Default: Unselected

Create associated ob-
jects if not found

Instructs the wizard to automatically create objects referenced by the im-
ported objects where these are not otherwise defined in your Excel file. For
example, If you have a worksheet listing PDM tables, which contains a
column called Owner, PowerDesigner will create user objects for each of
the names appearing in this column unless you supply a list of users on
another worksheet. Similarly, if you do supply such a list of users but not all
the names in the Owner column are included, user objects will be created
for each of the missing names.

Default: Selected

Object identifier Specifies whether the object's name or code (the latter of which does not
usually permit spaces or special characters ) is used in columns that refer-
ence the object. In the example above, you could use the user's name or code
to reference it in the Owner column of the list of tables.

Default: Name

Qualified name sepa-
rator

Specifies the character used to separate namespaces in a qualified name. The
Qualified name separator is used to specify the location or parent of an
object. For example, to specify that architecture area Area3 is inside
Area2, which is in turn inside Area1, you would enter
Area1.Area2 in the Parent column for Area3.

Default: Dot
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Option Description

List value separator Specifies the character used to separate items in a list in an Excel cell. For
example, you could list all the columns of a table in a cell as follows:
ID,Name,Email,Password.

Default: Comma

String literal for 'True' Specifies the string used to signify 'True' for boolean attributes. False is
signified by an empty cell.

Default: X ('Y', 'Yes', 'True', and '1' also always signify 'True'.
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CHAPTER 5 Diagrams and Symbols

The majority of PowerDesigner models contain diagrams, in which your model objects are
represented by symbols.

Diagrams
A diagram is a graphical view of a model or a package. All models and packages have at least
one diagram.

Note: In the Requirements Model, there are no diagrams, but rather views. For more
information, see the Requirements Modeling guide.

You can add additional diagrams to a model or package to split the display and focus on certain
portions of the system. You can also use multiple diagrams to focus on different subject areas.
They allow you to see the symbols of the same objects, displayed with different kinds of
information.

For example, in a Publishing model, different diagrams could define the different activities
involved in this industry: the printing diagram, the sales diagram, the accounting diagram, the
book selection committee diagram.

Note: You can define your own custom matrices that act as diagrams and display the
connections between objects in a grid format. For more information, see the Extending your
Models with Profiles chapter of Customizing and Extending PowerDesigner.

Note that you cannot save a diagram individually, as it only represents a view of a model or
package. When you save the model you also save all the diagram it contains in their present
state of magnification.

Creating a Diagram
By default, any model or package opens with a default diagram. You can create as many
diagrams as you want in a model or in a package.

You can create a diagram in any of the following ways:

• Select View > Diagram > New Diagram >  Diagam type .
• Right-click the background of your diagram and select Diagram > New Diagram >

Diagram type  from the contextual menu
• Right-click the model node in the Browser and select New >  Diagram type  from the

contextual menu

In each case you will be invited to specify a name, code, and optional comment for the new
diagram.
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Diagram Properties
You can modify an object's properties from its property sheet. To open a diagram property
sheet, right-click its Browser entry and select Properties from the contextual menu, or right
click the diagram background and select Diagram > Properties from the contextual menu.
The General tab contains the following properties:

Property Description

Name Specifies the name of the item which should be clear and meaningful, and should
convey the item's purpose to non-technical users

Code Specifies the technical name of the item used for generating code or scripts, which
may be abbreviated, and should not generally include spaces

Comment Additional information concerning the diagram

Parent Specifies the name of the parent model or package

Stereotype Specifies a stereotype for the diagram. For example, a statechart diagram can serve to
model page flows in JSF and other web frameworks.

You can use a profile to provide special processing for diagrams and other objects
carrying stereotypes. For more information, see the Extending your Models with
Profiles chapter of the Customizing and Extending PowerDesigner manual.

Page scale Sets a default display for page scale. The page scale percentage lets you define a page
size according to your modeling needs. If you have a lot of objects on several pages,
you can reduce the page scale percentage in order for all the objects to fit on a single
printable page

Default Dia-
gram

Diagram by default. This check box is automatically selected if the diagram is the first
created diagram

Opening and Viewing Diagrams
You can open a diagram from the Browser or from the View menu.

• Double-click the diagram entry in the Browser.
• Press Ctrl +D, or select View > Diagram > Select Diagram to open the Select Diagram

dialog box, select a diagram node in the tree and click OK.
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• In the case of package diagrams, you can additionally:
• Select the Open Package Diagram tool from the Palette and click on a package symbol.
• Press Ctrl and double-click a package symbol.
• Right-click a package symbol and select Diagram > Open Diagram.

The following diagram viewing tools are available in the palette or from the View menu:

Tool Description

Zoom In (F6) - Select the Zoom In tool and click anywhere in the diagram. The point
clicked on is centered.

Alternatively, you can select View > Zoom In, or turn your mouse scroll wheel away from
you while holding the Ctrl key.

To zoom in to a particular area, select the Zoom In tool and click and drag a rectangle
around the area to be displayed. When you release the mouse button, the diagram zooms
to the selected area.

Zoom Out (F7) - Select the Zoom Out tool and click anywhere in the diagram. The point
clicked on is centered.

Alternatively, you can select View > Zoom Out, or turn your mouse scroll wheel towards
from you while holding the Ctrl key.

View the whole diagram (F8) - Double-click the Global View tool or select View > Global
View.

[none] View actual size (F5) - Select View > Actual Size.

[none] View the current (printable) page (Ctrl+F10) - Select View > Page View > Current
Page.

[none] View all pages that contain symbols (F10) - Select View > Page View > Used Pages.
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Tool Description

[none] View all pages in the diagram - Select View > Page View > All Pages.

[none] Center on selected symbols - Select View > View Selection.

[none] Return to previous view (F9) - Select View > Previous View.

This and the Next View option allows you to toggle back and forth between various
selections and zooms you have used to navigate in your diagram, for example between a
limited view and a global view of the diagram.

[none] Go to next view (Shift+F9) - Select View > Next View.

[none] Refresh View (Shift+F5) - Select View > Redisplay.

Finding an Object Symbol in the Diagram
You can locate any object with a symbol in a diagram or among several diagrams using Find in
Diagram (or, for an RQM, Find in Document View). Objects without graphical symbol such as
domains cannot be found in the diagram.

If the object has only one symbol, the appropriate diagram is opened with the object symbol
centered. If the object has several symbols, a dialog box opens to allow you to select one.

This feature can be very useful if you are looking for the target object of shortcut symbols, as
you can access the target object from the shortcut property sheet and then locate the target
object in the diagram.

Find in Diagram (or Find in Document View) is available from:

• The Browser — Right-click an object in the Browser and select Find in Diagram (or Find
in Document View) from the contextual menu.

• The Result List — Right-click an object in the Result List and select Find in Diagram (or
Find in Document View) from the contextual menu.

• The object property sheet dropdown menu — Open an object property sheet and select
Find in Diagram (or Find in Document View) from the dropdown menu at the bottom-left
corner.

• An objects list — From an objects list, select an object in the list and click the Find Symbol
in Diagram tool in the list toolbar.

Specifying Diagrams as Related Diagrams
Related Diagrams are diagrams that provide additional information about an object. You can
use related diagrams to further define the behavior and implementation of objects and to view
them from different angles and in terms of semantic relationships.

You can associate any type of diagram open in the workspace with an object, including
diagrams from other packages or models.
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Note: You can only attach related diagrams to objects that have a Related Diagrams tab in
their property sheet.

1. Open the property sheet of the object and click the Related Diagrams tab.

2. Click the Add Objects tool to open a selection window.

3. Select a model in the list, select the diagram(s) to attach and then click OK to return to the
object property sheet.

The diagram is displayed in the list of related diagrams of the object. To open the diagram
from the Related Diagrams tab, select it in the list and click the Open Diagram tool.

Deleting a Diagram
When you delete a diagram, you delete a view of a model or a package. This action does not
affect the objects in the model or package.

You can delete a diagram in any of the following ways:

• Select the diagram node in the Browser and press the del key.
• Right-click the diagram window background and select Diagram > Delete from the

contextual menu.
• Select View > Diagram > Delete.

Printing Diagrams
You can print the currently selected diagram at any time. You can print the whole diagram , a
selection of pages, or a selection of objects.

When you print a diagram, you do not print detailed information about the model objects. To
do this, you need to create a model report.

1. [optional] Select certain symbols in the diagram in order to print them and exclude the
others.

2. Select File > Print, or click the Print tool to open the Print Diagram dialog, which displays
default print options and the number of printed pages needed for the diagram.
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3. [optional] Specify the pages to print in the Page range groupbox or by clicking in the
Preview pane (see Print Diagram options on page 172). Only pages with an overlaid page
frame will be printed.

4. [optional] Specify a page scale or set of pages to fit to (see Print Diagram options on page
172). By default, diagrams are printed at 100% scale on as many pages as necessary.

5. [optional] Click the Page Setup button to open the Page Setup dialog and specify your page
layout (see Page Setup options on page 173).

6. Click OK to start printing.

Print Diagram Options
When you print a diagram, you can select the following print options from the Print diagram
dialog box. It also displays a preview of the selection you want to print:

Option Description

Number of copies Number of copies you want to print. You can type it or use the arrows.

  172 PowerDesigner  



Option Description

Page range Specifies which pages to print. You can choose between:

• All - Prints all the pages of the diagram.
• From / To - Prints a range of pages covered by the diagram. The corre-

sponding pages are framed in the Preview window.
• Selected - Prints the pages you select in the Preview window.

Number of pages Displays the number of pages required based on your zoom options.

Page scale Specifies the scale at which the diagram will be printed.

Fit to pages Reduces the scale of the diagram to print it on the number of pages specified,
for example 1x3. The Number of pages option is automatically updated and
the Center in pages option is unavailable. These parameters are not saved and
your diagram stays unchanged in the diagram window. If you want to apply
these changes to your diagram, you should use the Symbol > Fit to Page File
command from the menu bar and theFile > Page Setupfor paper orientation.

Center in pages Centers the diagram in the pages that it covers. The Fit to pages option is
automatically unavailable.

Frame Solid line border around graphic on all pages.

Corner Specifies the printing of "crop marks" in each corner to help align multiple
pages.

Mode: Specifies whether the diagram will be printed in Black & White or Color.

Printer: Name Name of the printer. Select a printer from the Name list. Click the Page Setup
button to modify the current printer parameters.

Page Setup Options
The Page Setup dialog allows you to modify standard printer parameters, such as Paper,
Orientation and Margins, and to add various kinds of information to the Header, Footer and
Page of your printed diagram.

You can arrive at the Page Setup dialog by selecting File > Page Setup, or by clicking the Page
Setup button in the Print Diagram dialog (see Printing diagrams on page 171).

The following fields let you specify the content of the header and footer:
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Option Description

Header Specifies the content of the page header. You can insert fixed text and use the arrow
button to the right of the field to insert one or more of the following variables:

• Current Date - inserts the date

• Current Time - inserts the time

• Current Page - inserts the content of the Page field

• Last Page - inserts the number of the last page

• Diagram - inserts the diagram name

• Location - inserts the file path

• Model - inserts the model name

• Package - inserts the package name

• Module - inserts the model type

• Application Name - inserts "PowerDesigner"

Footer Specifies the content of the page footer. You can insert fixed text and use the arrow
button to the right of the field to insert the same variables as for the page header.

Page Specifies the page number format to use in the header and footer. You can insert fixed
text and use the arrow button to the right of the field to insert one or more of the
following variables:

• Page Row - inserts the diagram pagination grid row number. This can be useful to
help assemble large diagrams printed on multiple pages. You may need to zoom
out to see the diagram pagination grid:

• Page Column - inserts the diagram pagination grid column number

• Page Number - inserts the standard page number
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Converting a Diagram to a Package
PowerDesigner lets you convert a diagram to a package. You can move all the objects in the
diagram to the new package or specify only certain objects. Other objects will stay in their
original package and be represented via shortcuts in the new package.

The linking objects that you move keep their links in the target package and a shortcut is
usually created in the source package. The general rule being that conceptual modeling must
be preserved.

Shortcuts creation rules in PowerDesigner also apply to moving objects between packages
(see Chapter 11, Shortcuts and Object Replications on page 355).

1. Select View > Diagram > Convert to Package (or right-click the diagram background
window and select Diagram > Convert to Package or right-click the diagram node in the
Browser and select Convert to Package) to open the Convert Diagram to Package wizard.
By default the package takes the name of the diagram.

2. Click Next to open the Selecting Objects to Move page, which lists all the objects in the
diagram available to move to the new package. Objects are organized by object type, with a
sub-tab for each object type. By default, all the objects are selected.
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3. [optional] Deselect any objects you do not want to move to the new package. Objects
deselected here will remain in the original package and be represented in the new package
via shortcuts.

4. Click Finish to create the new package and move the selected objects to it.

The new package and diagram are added in the Browser.

Moving a Diagram to a Package
In some cases, you may want to move a diagram and some or all of the objects it contains into
another package or composite object, such as a process or activity.

The linking objects that you move with the diagram keep their links in the target package and a
shortcut is usually created in the source package. The general rule being that the design of the
original diagram must be preserved.

Shortcuts creation rules in PowerDesigner also apply to moving objects between packages
(see Chapter 11, Shortcuts and Object Replications on page 355).

You can simply drag and drop the diagram from one package to another in the Browser to
move all the objects in the diagram to the target package. To control which objects are moved,
use the wizard.

1. Select View > Diagram > Move to Package (or right-click the diagram background
window and select Diagram > Move to Package or right-click the diagram node in the
Browser and select Move to Package) to open the Move Diagram to Package wizard.
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2. Select the target package to which you want to move the current diagram and click Next to
open the Selecting Objects to Move page, which lists all the objects in the diagram
available to move to the new package. Objects are organized by object type, with a sub-tab
for each object type. By default, all the objects are selected.
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3. [optional] Deselect any objects you do not want to move to the new package. Objects
deselected here will remain in the original package and be represented in the new package
via shortcuts.

4. Click Finish to move the diagram to the new package.

If the last diagram is moved or deleted from a package, a new diagram is automatically
created as all packages must contain at least one diagram.

Moving Entities Between Packages in a CDM
In a CDM, when moving entities containing data items from one package to another, the
following rules apply:

Data items Namespace Move result

Only used by selected en-
tity

Move within the same
namespace

The data items are moved with the entity

Reused among different
entities

Move within the same
namespace

Shortcuts of data items are created for reused
data items

Used only by one entity
or reused among differ-
ent entities

Change namespace Data items are copied in the other namespace

Dependency Matrices
You can create dependency matrices to review and create links between any kind of objects.
You can create an individual matrix from the Browser or define a matrix in a resource file for
reuse.

In the following enterprise architecture model (EAM) example, systems are listed along the
top of the matrix, and linked to the sites where they are in use, via extended dependencies:
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1. Right-click a model or package node in the Browser and select New > Dependency
Matrix to open the matrix property sheet to the Definition tab.

2. Select an object type from the current model to populate your matrix rows and an object
type from the current or another model type to populate the columns.

3. Specify how the rows and columns of your matrix will be associated by selecting a
dependency from the list.

In the following example, PDM tables are associated to users by the Owner dependency:

Only direct dependencies are available from the list. To specify a more complex
dependency, click the Advanced button to open the Dependency Path Definition dialog
(see Specifying Advanced Dependencies on page 180).

4. For certain dependencies, the Object type on which the dependency is based will be
displayed, and you can select an Object attribute to display in the matrix cells along with
the No value symbol, which is displayed if that attribute is not set in any particular
instance.

5. Click the General tab and enter a name for the matrix (for example Table Owners
Matrix).

6. Click OK to complete the definition and open your matrix.

Note: For information about defining a dependency matrix in a resource file (such as a DBMS
definition file, object language file or extended model definition) and for detailed information
about its properties, see the Extending Your Models with Profiles chapter in the Customizing
and Extending PowerDesigner book.
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Specifying Advanced Dependencies
You can examine dependencies between two types of objects that are not directly associated
with each other, using the Dependency Path Definition dialog, which is accessible by clicking
the Advanced button on the Definition tab, and which allows you to specify a path passing
through as many intermediate linking objects as necessary.

Each line in this dialog represents one step in a dependency path:

Property Description

Name Specifies a name for the dependency path. By default, this field is populated with
the origin and destination object types.

Dependency Specifies the dependency for this step in the path. The list is populated with all the
possible dependencies for the previous object type.

Object Type Specifies the specific object type that is linked to the previous object type by the
selected dependency. This field is autopopulated if only one object type is available
through the selected dependency.

In the following example, a path is identified between business functions and roles, by passing
from the business function through the processes it contains, to the role linked to it by a role
association:

Working with Dependency Matrices
The dependency matrix displays the connections between the objects of the types specified in
your definition.

In the following example, the same hierarchy of business processes is shown in the row and
column headers in order to analyze the dependencies between them:
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To add a link, click in the appropriate cell, and then click the Create link button at the bottom
of the matrix (or press the Spacebar or V).

To delete a link, click in a cell containing a link, and then click the Delete link button at the
bottom of the matrix (or press the Spacebar or Delete key).

The following tools are available above the dependency matrix:

Tool Description

Properties – opens the property sheet of the object associated with the selected row,
column, or cell.

Copy – Copies the entire matrix for pasting into a CSV environment such as Excel or
a plain text file.

Select Rows/Columns (Ctrl + N) – Opens a selection box which allows you to select
rows and columns to display in the matrix either by hand or by defining a filter (see
Adding an Item from a Selection List on page 122).

Display only Full Rows/Columns (Ctrl+R) – Filters the display to show only rows/
columns that are populated.
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Tool Description

Display only Empty Rows (Ctrl+E) – Filters the display to show only empty rows.

Vertical/Horizontal Column Header - Toggles between vertical and horizontal ori-
entation of column headers.

Shrink to Fit - Shrinks row and column headers to fit their contents.

Show Parents in Row Header - Displays the hierarchy of objects that are ancestors to
the row objects.

Show Parents in Column Header - Displays the hierarchy of objects that are ancestors
to the row objects.

Show Packages in Headers - Displays the hierarchy of packages that contain the row
and column objects.

Refresh - Refreshes the display of dependencies in the matrix.

Export to Excel - Exports the matrix as an MS Excel file. If the specified file already
exists, you will be given the option to overwrite it or append a new worksheet in the
file.

Note: You can modify the definition of the dependency matrix at any time by right-clicking its
Browser node, selecting Properties, and clicking the Definition tab.

Manipulating Symbols
You can modify the display of individual symbols in a model including object symbols, links,
graphic shapes, and lines.

Selecting Symbols
You can select symbols in a PowerDesigner diagram using standard gestures. Selected
symbols display handles.

For example, the illustration below shows the selection of the Member table.
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The following table lists the various ways of selecting symbols in a diagram:

To Select Tool How to use

One symbol Click the Pointer tool, and then click the symbol.

Several Symbols Click the Pointer tool. Click the first symbol to select, and
then press the shift key while you click additional symbols.

All symbols within a certain
area

Click the pointer tool. Click and hold while drawing a
rectangle around the area containing the symbols to select.

All symbols connected to a
selected symbol

Click the pointer tool. Click the first symbol to select, and
then select Edit > Select Connected Symbols.

All symbols Click the Grabber tool. Alternatively, select Edit > Select
All, or type Ctrl+A

Resizing Symbols
You can resize diagram symbols:

• Individually – Select the symbol and then click and drag on one of its handles
• All at once - Click the Grabber and then click and drag on one of the handles

Bending and Straightening Link Symbols
You can add and remove corners to and from link symbols.

1. Draw a link between two objects:

2. Press Ctrl while you click a point on the line to create a handle where you want to insert a
corner :

3. You can add a second handle, or as many as you need:

4. To create a corner, click and hold the handle and then drag it to where you want the corner
to be:
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5. You can drag the other handles too:

6. To remove a handle (and corner), press Ctrl and click on the handle to remove:

Dragging a Link Symbol from One Object to Another
You can drag a link symbol from one object to another.

1. Click a link symbol in the diagram.

2. Drag one of its end handles to a different object.

Creating a Graphical Link Between Any Two Symbols
You can create a graphical link between any two symbols in the diagram. This link is purely
graphical and does not convey any semantics.

1. Select the Polyline tool in the Palette.

2. Click inside the first symbol and while continuing to hold down the mouse button, drag the
cursor to a second symbol. Release the mouse button inside the second symbol and right-
click.

A link is created. You can double-click the link symbol to open the Link Symbol Text
dialog box and edit the link.

Arranging Symbols Using the Symbol Menu
The Symbol menu allows you to do many different things with your diagram symbols.

Menu Item Function

Format [Ctrl+T] Opens the Symbol Format window, which allows you to control many aspects of
the appearances of the selected symbols. For detailed information, see Symbol
Format Properties on page 191.

Get Format Copies the format of the selected symbol, making it available for applying to other
symbols. Only available if a single symbol is selected.

Apply Format Applies the format copied with Get Format to the selected symbols.
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Menu Item Function

Shadow [Ctrl
+W]

Applies the standard shadow effect to the selected symbols. See also Symbol
Format Properties on page 191.

Adjust to Text
[Ctrl+J]

Expands (or shrinks) the width of the selected objects to fit the length of their
names.

Normal Size Applies the default size (specified in the Format Display Preferences) to the
selected objects.

Fit to Page Opens the Fit to Page dialog, which lists the number of pages currently used and
the display scale, and allows you to specify the number of pages to use and to
center the symbols on the pages.

Auto-Layout Automatically rearranges the symbols in the diagram See Auto-layout on page
186.

Align Each of the submenu options aligns the selected symbols in a different manner. For
a list of options, see Aligning selected symbols on page 188.

Disposition Automatically arranges all (or selected) symbols in the diagram. There are various
forms of disposition:

• Horizontal [Ctrl+H] – straightens selected link objects and makes them hor-
izontal where possible.

• Vertical [Ctrl+L] - straightens selected link objects and makes them vertical
where possible.

• Flip Horizontal – reverses the horizontal disposition of the selected symbol
• Flip Vertical - reverses the vertical disposition of the selected symbol
• Arrange Symbols – distributes the selected symbols evenly.
• Arrange Connectors – straightens the selected link symbols and centers their

endpoints in the objects that they connect.
• Arrange Attach Points - centers the endpoints of the selected link symbols in

the objects that they connect.
• Arrange Attached Text – returns text objects associated with the selected link

symbols to its default position.
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Menu Item Function

Order Promotes or demotes the selected symbols in terms of layers within the diagram.
This can be useful when you have overlapping symbols and want to have one
appear above the other. The following options are available:

• Bring to Front
• Send to Back
• Bring Forward
• Send Backward

By default, when you insert a free symbol (for example, a note) on a design object
symbol (for example, a table), the free symbol is always inserted at the back, as
free symbols are usually used as backgrounds.

Priority is given to the front-most symbols. When symbols overlap, it may not be
possible to select the symbol in the background, even if its handles are visible.

Group Symbols Groups selected symbols, allowing them to be selected, moved and resized as a
single block.

Ungroup Sym-
bols

Separates selected objects that were previously grouped together.

Hide Symbols Hides (makes invisible) the selected symbols. You may want to do this to make a
large model more readable, or to focus on only a particular part of a model.

Show Symbols Opens the Show Symbols dialog box, in which you can select or deselect all the
symbols in the diagram to show or hide them.

Protect Symbols Protects the selected symbols, making them impossible to select and edit.

Unprotect Sym-
bols

Unprotects the selected symbols, making them available to select and edit.

Auto-layout
The auto-layout command automatically rearranges symbols in diagrams in order to avoid
node overlaps, link intersections with nodes and others links, or long distances between
related nodes.

Note that auto-layout is not available for the OOM sequence diagram or any diagrams
containing swimlanes.

1. Select Symbol > Auto-Layout to open the Auto-Layout window.
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2. Choose one of the available styles. Note that depending on the diagram from which you
launch auto-layout, some styles may not be available.

• Basic – Suitable for simple diagrams.
• Hierarchical – Highlights the main direction or flow within a directed graph. You can

additionally specify an orientation for the flow within the graph.
• Organic – For undirected graphs.
• Orthogonal - For undirected graphs. You can additionally specify an orientation for the

flow within the graph.
• Circular – Produces interconnected ring and star topologies to emphasize group and

tree structures within a network. You can additionally specify a cycle or radiation
shape.

• Tree – For directed or undirected trees. You can additionally specify an orientation for
the flow within the graph.

3. Specify if you want to apply the auto-layout to only selected or all symbols.

4. Click OK to apply the auto-layout and return to the diagram.

Note: You can, at any time, click the default button to revert to the default auto-layout
settings. Click the Set As Default button to set the currently selected style as the default.
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Aligning Selected Symbols
The following tools are available from the Symbol > Align submenu. Each tool acts on the
symbols presently selected in the diagram:

Align submenu item Tool Action

Left Aligns left borders of selected symbols with leftmost se-
lected symbol

Center on vertical axis Centers selected symbols on the most central selected
symbol

Right Aligns right borders of selected symbols with rightmost
selected symbol

Same width Stretches selected symbols to the width of the selection
area (from the leftmost symbol to the rightmost symbol)

Evenly space horizontally Assigns equal space between at least three symbols on a
horizontal axis

Top Aligns tops of selected symbols with topmost selected
symbol

Center on horizontal axis Centers selected symbols on the most central selected
symbol

Bottom Aligns bottom selected symbols with lowest selected
symbol

Same height Stretches selected symbols to the height of the selection
area (from the topmost symbol to the lowest symbol)

Evenly space vertically Assigns equal space between at least three symbols on a
vertical axis

Showing and Hiding Symbols
For PowerDesigner objects that have symbols, the symbol is automatically displayed in the
diagram when you create the object. Hiding some symbols can improve the readability of your
diagram. When you hide a symbol you do not delete it or the object.

Note: When you hide an object with link objects connected to it, the links are also hidden. For
example, if you hide a table symbol, any references attached to it will also be hidden.

To open the Show Symbols dialog, select Symbol > Show Symbols or right-click the diagram
background and select Diagram > Show Symbols:
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Object symbols are organized by type in sub-tabs. If shortcuts, extended dependencies and/or
free symbols are present in the package, they appear on their own sub-tabs. You show and hide
symbols by selecting or deselecting them.

The following tools are available for selecting symbols:

Tool Description

Allows you to select objects from other packages to display them in the current diagram.

Selects all objects in the current tab. You can select all objects on all tabs by pressing the
Ctrl key as you click or by clicking the arrow and selecting All Pages.

Deselects all objects in the current tab. You can deselect all objects on all tabs by pressing
the Ctrl key as you click or by clicking the arrow and selecting All Pages.

Moves all selected object to the top of the list

Moves all selected object to the bottom of the list

Note: To hide one or more symbols without using this dialog, select them and then choose
Hide Symbols from the Symbol or contextual menu. To show a symbol without using the
dialog, simply drag the object into the diagram from the Browser or another diagram. If you
drag the symbol from another package or model, a shortcut to the object will be created in the
destination model.
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Understanding Automatic Link Completion
The following rules apply to the display of link objects in the diagram window.

General Rules

Object Check box Result in the diagram...

Link Selected Objects at both ends are automatically displayed

Any Deselected Link objects attached to the hidden object are automatically
hidden

Non link Selected Link objects attached to the displayed non link object are au-
tomatically displayed if their other ending object is already
displayed

CDM Special Behavior

Object Check box Result in the diagram...

Association Selected Entities and association links attached to the displayed asso-
ciation are automatically displayed

Association
link

Selected Entities and associations attached to the displayed association
link are automatically displayed

Inheritance Selected Entities (parent and children) and inheritance links attached to
the displayed inheritance are automatically displayed

Inheritance
link

Selected Entities (parent and children) and inheritance attached to the
displayed inheritance link are automatically displayed

Parent entity Deselected Inheritances for which the hidden entity is the parent are au-
tomatically hidden

Finding a Symbol in the Diagram from an Object List
You can locate any object in a diagram from an object list using the PowerDesigner Find
feature.

1. Model >  Object type .

2. Select an object in the list.

An arrow is displayed at the beginning of the line.

3. Click the Find Symbol in Diagram tool.

The symbol is selected and centered in the diagram window. To see the symbol, you have to
move the list dialog box.
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When an object has several symbols within a model, a symbol selection dialog box is
displayed that lets you select an object symbol among all instances of the object within the
model diagrams. When you click OK the symbol is selected and centered in the current
diagram window. To see the symbol, you have to move the list dialog box.

Note: You can also find the symbol of an object in a diagram by right-clicking the object in the
Browser and select Find in Diagram (or, for an RQM, Find in Document View) from the
contextual menu. The symbol of the object is centered and selected in the diagram window.

Using Composite View to Display Sub-Objects within a Symbol
Many objects (packages, processes, classes, activities, states, EAM objects, etc.) have the
capability to display sub-objects within their symbols through one or more composite view
modes. Depending on the type of object, the sub-objects can be displayed either as a static
sub-diagram within the symbol or as dynamically editable symbols that you can create and
arrange directly from the parent diagram.

To toggle between the different composite view modes, right-click a symbol and select
Composite View and then one of the following commands:

• None - display the parent symbol only without any sub-objects
• Read-only (Sub-Diagram) - display sub-objects in a non-editable sub-diagram that can be

resized as necessary. To access the sub-diagram, press CTRL and double-click the symbol
• Editable - allow the creation and arrangement of sub-objects directly within the symbol in

the parent diagram.
• Adjust to read-only view - resizes the symbol to display all the objects in the read-only

view.

Note: Not all modes are available for all objects that support composite view. Certain objects
(for example, processes in the BPM) must be decomposed before you can access composite
view.

For information about the specific objects supporting composite view, see the appropriate
modeling guide.

Symbol Format Properties
You can change the format of symbols in the Symbol Format dialog.

You may arrive at the Symbol Format dialog when changing the format of:

• One or more individual symbols – select the symbols and then press Ctrl+T, select
Symbol > Format, or Format from the contextual menu.

• All symbols - via display preferences (see Display Preferences on page 289).
• Custom symbols defined for extensions – see the "Extending Your Models with Profiles"

chapter of Customizing and Extending PowerDesigner.

Note: When defining the format of custom symbols in the Resource Editor, each tab in the
Symbol Format dialog contains two additional options, Apply format to symbols, and Allow
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users to modify symbol format , which allow you to control the default format of symbols and
whether users can modify them to a very fine degree. For more information on these options,
see Controlling the Format of Custom Symbols on page 195.

The following sections list the tabs and properties available in this window.

Size Tab

The Size tab controls the size of the symbol and how the size can be manipulated:

Property Description

Current size Specifies the width and height (in pixels) for the symbol.

Normal size [read-only] Specifies the default width and height (in pixels) for symbols of this
kind.

Auto-adjust to text
[CTRL+J]

[Default] Auto-resizes the width of the symbol to display all the text it contains
up to 254 characters (mutually exclusive with Keep size). For example, a table
symbol adjusts its size to display full column names, or column codes, up to the
truncation or word wrap length. You can define default adjustment to all sym-
bols.

If you manually resize a symbol, this option is disabled for the symbol.

Keep aspect ratio Maintains the ratio of height to width when resizing the symbol.

Keep center Maintains the center position of the symbol when resizing it.

Keep size Prevents the resizing of symbols both manually and through Auto-adjust to text
(mutually exclusive with Auto-adjust to text).

Line Style Tab

The Line Style tab controls the color, size and format of lines (for link and other one-
dimensional symbols) and borders (for two-dimensional symbols, such as classes or tables).
You can modify the line style of any symbol in the model.

Property Description

Color Specifies the color of the line or border.

Width Specifies the thickness of the line or border.

Style Specifies the format of the line or border, such as invisible, solid, dashed or
dotted.

Corners [Link and line symbols only] Specifies the format of corners, such as sharp or
rounded right-angles and free angles.
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Property Description

Arrow [Link and line symbols only] Specifies the format of the link or line symbol at its
Beginning, Center, and End.

Use perpendicular
arrow

[Link and line symbols only] Specifies that the link or line object always touches
objects at its ends at a right angle. This option allows you to use free angles for
the body of a link or line object, while retaining a connection at right angles for
its beginning and end.

Note: These options may be overridden by the design semantics of a link symbol (such as a
PDM reference).

Fill Tab

The Fill tab controls the color, content, and effects for symbol filling.

Fill effects Description

Fill color Specifies the color to use for the fill.

The Fill color check box is available for free symbols, packages, interaction frag-
ments, and swimlanes, and when cleared will create a transparent symbol. This can
be useful when you wish to use an "in-box" UML representation, for packages for
example.

Note that transparent objects can only be selected by clicking near their borders.

Image Specifies a graphic file to display within the symbol. Click the Modify button to
select a file.

Display Mode Specifies the alignment of the image within the symbol.

Gradient Specifies the gradient fill options. Click the Modify button to open a dialog al-
lowing you to control Start and End colors, End Color Luminosity, Shading Style
and Gradient Mode.

Shadow Tab

The Shadow tab allows you to add a standard, 3D effect or gradient shadow to objects in a
diagram.

Font Tab

The Font tab allows you to define the display preferences for the font, size, style, and color of
text associated with symbols in the model. When you modify font preferences, they apply to
all existing and new symbols.
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Text Alignment Tab

The Text Alignment tab allows you to define the alignment of text in text boxes and rectangles,
ellipses, rounded rectangles, and polygons.

Note: You can only control the text alignment for these shapes, and not for model object
symbols. When working with RTF, all the options but Vertical are disabled.

Parameter Description

Center Centers the text horizontally and vertically.

Word wrapping Auto-wraps text in the symbol.

Horizontal Aligns text to the left, center, or right on the horizontal axis.

Vertical Aligns text to the top, center, or bottom on the vertical axis

Custom Shape Tab

The Custom Shape tab allows you to define a new symbol shape for most non-link symbols.

Property Description

Enable custom
shape

Enables or disables the customization of a symbol shape

Shape Type Specifies the type of shape to be used. Choose one of the following values, and
then click the Browse button to select an image (see Browsing for Images on page
196):

• Predefined symbol - Default shape assigned to symbols in PowerDesigner.

• Metafile (EMF, WMF) - Representation using geometrical formulas allow-
ing for resizing and stretching.

• Bitmap (DIB, RLE, JPG, JPEG, TIF, TIFF, PNG) - Representation of a
graphics image consisting of rows and columns of dots.

• Icon (ICO) - Small picture representing an object, usually smaller than
standard PowerDesigner symbols.

Shape Name List of the available shapes of the selected type. Click the Browse button to select
shapes.

Display name Specifies where the symbol name should appear (Center option is not available
for icon shapes)
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Content Tab

The Content tab allows you to specify the information that you want to display on the symbol.
The properties that are listed on this tab as being available for selection are controlled by the
content display preferences (see Content Display Preferences on page 294).

Sub-Objects Tab

The Sub-Objects tab is only available when you open the Format tab after having selected a
single object. It allows you very fine control over the sub-objects (such as PDM table columns
or OOM class attributes and operations) that you want to display inside your object symbol.
For each individual sub-object, you can decide whether to display it or not, and what font to
use for its display.

Note: For a collection of sub-objects to be available for selection and customization here, the
collection must be selected for display in the object's content display preferences (see Content
Display Preferences on page 294). Where the number of lines to display for a collection is
limited in the display preferences, that limit will take precedence over any choices you make
here.

Each collection of sub-objects that is enabled in the display preferences has its own sub-tab.
For each sub-object, you can:

• Select to display or hide it in the parent object symbol by selecting or deselecting its
checkbox in the [D]isplay column.

• Apply a specific font to its display by clicking the Select font tool or the ellipsis button in
the Specific Font column.

Note: When not all sub-objects in a collection are selected for display, the parent object
symbol will display ellipses to indicate that more items are available.

Controlling the Format of Custom Symbols
When defining custom symbols for your object extensions, you may want to enforce certain
aspects of the symbol format, while allowing users some liberty to change other aspects. If you
access the Symbol Format dialog from a custom symbol in the Resource Editor, you can
control the default format options for the symbol, and whether users can edit them, on a per-tab
basis.

For example, you could extend the PDM table metaclass with a criteria to specify a custom
symbol with a red border for tables that are anticipated to contain more than 1m records. You
may want to enforce this border style for all such tables while allowing users to change the
font, size, content, and other aspects of the symbol format.

For information about extending objects and creating custom symbols for them, see the
"Extending Your Models with Profiles" chapter of Customizing and Extending
PowerDesigner.

When you access the Symbol Format dialog from a custom symbol in the Resource Editor, the
following additional options are available at the top of each tab:
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Option Description

Apply format
to symbols

Specifies that the format options on the tab will be applied to custom symbols at
creation time or whenever the appropriate criteria are met or the specified stereotype
applied.

If this option is not selected, the standard display preferences for the format options
on the tab will be applied and users are free to modify them.

Allow users to
modify sym-
bol format

Specifies that users can modify the format options for the symbol and that any
changes that are made will be respected in the event that the definition of the custom
symbol is updated.

If Apply format to symbols is selected and this option is unselected, then the format
options specified on this tab cannot be changed by the user.

Browsing for Images
The Select Image dialog lets you manage the images that you use in your model diagrams, and
to insert them into your models as object symbols, diagram backgrounds, etc.

1. Open the Select Image dialog in any of the following ways:

• From the Symbol Format dialog Custom Shape tab, click the Enable Custom Shape
check box, and then click the Browse button next to the Shape type property (see 
Symbol Format Properties on page 191).

• From the Symbol Format dialog Fill tab, click the Modify button in the Fill Effects
group box (see Symbol Format Properties on page 191).

• Right-click a diagram symbol and select Change Image.
• Select Edit > Import Image (see Importing and Exporting Model Graphics on page

203).
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2. Click a collection in the Collections pane to display its available images in the Images
pane. You can add folders to the Collections pane by clicking the Add Directory tool.

3. [optional] In the Images tab, select an image type and/or dimension to filter by from the
Type and Dimension lists.

4. Select an image and click OK to return to the Symbol Format dialog or to display the image
in the diagram.

Browse Images tab tools
The Browse Images tab contains tools to help you manage images:

Collections Pane

The Collections pane displays a list of your image collections, and contains the following
tools:

Tool Description

Open Image File - Lets you browse to an image file to select it directly without
passing by an image collection.

Add Directory – Adds a directory to the list of collections. When you add a
directory, any sub-directories containing images are also added along with any
intermediate directories required to represent the directory tree.

CHAPTER 5: Diagrams and Symbols

Core Features Guide    197



Tool Description

Add Executable or DLL - Adds an executable or DLL and all the images associated
with it to the list of collections.

Remove Directory, Executable, or DLL – Removes a directory from the list of
collections. Predefined directories, such as Recent Images or Microsoft Office Clip
Art cannot be removed.

Up – Moves up a level in the collections tree.

Images Pane

The Images pane displays the images available in the selected collection, and contains the
following tools:

Tool Description

Type Filters images by type, such as PNG, Bitmap, Cursor, etc.

Dimension Filters images by dimension, such as 16, 48, 128, etc.

Refresh Preview – Refreshes the list of available images.

Delete Recent Image – Deletes a selected recent image.

Extra Large Icons – Displays images as extra large icons.

Large Icons – Displays images as large icons.

Medium Icons – Displays images as medium icons.

Small Icons – Displays images as small icons.
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Searching for an Image
You can search for images among your collections on the Search Images tab of the Select
Image dialog.

1. Specify the appropriate search criteria in the Search Criteria pane. You can specify:

• Search for – Enter all or part of a filename to search against. Wildcards are
automatically applied so that for example, entering "ec" will return an image named
"vector.png".

• Type – Select the type of image to search for, such as PNG, Bitmap, Cursor, etc.
• Search in collections – Specifies the scope of the search by selecting or deselecting

collections to search in.

2. Click the Search button to display the result of the search in the Images pane.

3. Select an image in the Images pane, and click OK to return to the Symbol Format dialog or
to display the image in the diagram.

The Clear button resets the search criteria to the default values.
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Working with Decorative Symbols
Decorative symbols have no technical meaning in your diagram, but help make it more
readable. You can use them to surround parts of a model, for example, to distinguish domains
of activity.

Drawing a Rectangle
You can draw a rectangle using the Rectangle tool in the Palette.

1. Select the Rectangle tool in the Palette.

2. Click at the point in the diagram where you want to insert one corner of the rectangle, hold
the mouse button, and drag to where you want to place the alternate corner.

3. Release the mouse button to create the rectangle.

4. [optional] Click on and drag a handle to resize the rectangle.

The following tools are available:

Tool Description

Line

Arc

Rectangle. Press ctrl while drawing to create a square.

Ellipse. Press ctrl while drawing to create a circle.

Rounded Rectangle. Press ctrl while drawing to create a rounded square.

Polyline - Release the mouse button at each point where you want to create a corner. Right
click to finish.

Polygon - Release the mouse button at each point where you want to create a corner. Right
click to finish and close the polygon.

Title Box - A diagram title box retrieves from the model properties and displays such
information as: the model and the package to which the diagram belongs, the name of the
diagram itself, the author and version of the model and the date of modification.

If no Author is specified in the model property sheet, the user name specified in the Version
Info page is used.

You can choose to display the repository version number of the model or a user-defined
version number on the Title display preferences page.
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Note: After creating certain shapes, you can modify the type of corner by right-clicking and
selecting Format > Line Style and selecting a type in the Corners list. You can also define a
default style for corners in the display preferences of graphic shapes.

Working with Textual Symbols
Free text is text that is not associated with an object in the model. For example, a note that you
type in a rectangle is free text, (while a column name is not). You can insert free text in your
model independently of any shape, and can select and move it like any symbol.

1. Click the Text tool in the palette, and then click in the diagram where you want to insert the
text. A symbol saying <Default text> is created.

2. Double-click the text to open a text input window.

3. Type text in the window, and then click OK.

Inserting Text into Shapes
You can insert text inside any graphic shape. This text is attached to the shape and will move
with it. If you change the fill color of the shape, the text also changes.

1. Double-click a shape in the diagram to open a text input window.

2. Type text in the window, and then click OK.

Assigning Text to Free Links
You can assign text to lines and polylines in the diagram to document links between object
symbols. The text is attached to the line. If you move the line, the text moves with it.

You can format the text attached to free links using the Symbol Format dialog box available
from the contextual menu of the link. The same format is applied to each text zone.
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1. Double-click a line or a polyline in the diagram to open the Link Symbol Text dialog box to
the Center Text tab. There are also tabs that allow you to add text to the Source and
Destination ends of the line.

2. Type the appropriate text in the appropriate tabs and then click OK

Formatting Free Text
Free text and text in graphic shapes support two modes. These are selectable at the bottom of
the text input window:

• Plain text - text formatting is controlled by the display preferences for Free Symbols
• RTF (Rich Text Format) – text formatting can be controlled directly in the text input

window

1. Create a free text object and double-click it to open a text input window

2. Select the RTF radio button at the bottom of the text input window to enter RTF editing
mode.

3. Use the RTF tools listed below, or click the Format tool to open the Text Format window.
This window has three tabs:

• Font – including style, size, effects, color and background
• Paragraph- including indentation, spacing, and alignment
• Tabs – including positioning and alignment

4. When complete, click OK to return to the diagram

Tool Function

Editor Menu

Launch External Editor

Save

Print

Find

Cut

Copy

Paste

Undo
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Tool Function

Redo

Open Format Menu

Bold

Italic

Underline

Align Left

Align Center

Align Right

Bullets

Importing and Exporting Model Graphics
You can import graphics to and export graphics from your PowerDesigner models.

To import an image into PowerDesigner, select Edit > Import Image to open the Select Image
window (see Browsing for Images on page 196), select an image and click OK to display it in
the diagram. Imported images are saved in the model.

To export one or more symbols from PowerDesigner, select them in the diagram and then click
Edit > Export Image to open a Save As dialog, select a format in the Save As Type list, enter
the filename and click OK.

You can export symbols in any of the following file type formats:

File type Extension

Enhanced Metafile EMF

Bitmap BMP, DIB, RLE

JPEG Compliant JPG, JPEG

Portable Network Graphic PNG

Graphics Interchanged Format GIF

Tagged Image File Format TIF, TIFF
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File type Extension

Scalable Vector Graphics SVG

Note: If you export symbols or cut or copy them to the Clipboard, you must select Edit >
Export in Color to retain them in color.
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CHAPTER 6 Reports

Reports allow you to publish information about your model, and can be used to provide
documentation for your system.

You can create the following types of report:

• A model report – documents the contents of a model, listing all or a selection of its objects,
and showing how they are associated with one another. Listed in the browser within the
Reports folder beneath its parent model, and saved with the model. See Creating a Model
Report on page 205.

• A list report – documents a single object type, and can help you to see, for example, the
type of each table in a physical data model (PDM). Listed in the browser within the List
Reports folder beneath its parent model, and saved with the model. See Creating a List
Report on page 216.

• A multi-model report – documents one or more models, and can help you to see, for
example, to which table in a physical data model (PDM) an entity in a conceptual data
model (CDM) corresponds. Listed in the browser as a top-level object, and saved as a .mmr
file. See Creating a Multi-Model Report on page 223.

Creating a Model Report
There are two steps to creating a PowerDesigner model report:

• Define the contents and format of the report - PowerDesigner provides a variety of ways to
define model reports:
• Standard Report Templates – to generate a model report directly, without any

configuration. See Creating a Report with a Report Template on page 206.
• The Report Wizard – to easily control the generation of a model report with minimal

intervention. See Creating a report with the Report Wizard on page 206.
• The Report Editor – to have full control over the content and format of your reports. See

Creating a report with the Report Editor on page 214.
• Generate the report – PowerDesigner supports generating reports in HTML or RTF, or will

print them directly. See Generating a model report on page 215

You can combine these methods as necessary. For example, you could create an initial report
with a standard template, refine your selection of objects with the wizard, and then fine-tune
formatting in the editor.

Core Features Guide    205



Creating a Report with a Report Template
The easiest way to create a model report without any configuration is to use one of the standard
model report templates. These allow you to generate a report directly in HTML or RTF format,
without specifying objects or formats.

The following standard templates are available:

• Full <Model Type> Report – provides lists of all the types of objects in the model, together
with detailed information on each object.

• List <Model Type> Report – provides lists of all the types of objects in the model.
• Standard <Model Type> Report – provides lists of all the types of objects in the model,

together with detailed information on each of the main objects.

You can also create your own report templates (see Report Templates on page 255).

Report templates are available in the Generate Report window. To generate a report using a
template, see Generating a model report on page 215.

Creating a Report with the Report Wizard
The Report Wizard is an easy way to select which objects will appear in your report, and to
control their formatting.

You can complete as much of the Wizard as you want. At each step, you click Next to advance
to the next stage, or Finish to exit the wizard and create a report based on your selections so
far.

The Report wizard can be launched from your model, to create a new report, or from the
Report Editor window of an existing report.

1. Select Report > Report Wizard (or select Report > Reports, and then click the Report
Wizard tool) to launch the wizard:

  206 PowerDesigner  



2. The Welcome page allows you to specify a name for the report and the language in which
you want its titles to appear. Note that this page is not displayed if you launch the wizard
from the Report Editor.

When you are satisfied, click Next:
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3. The Presentation Options page allows you to specify a format for your report. You can
choose between:

• HTML, for publishing your report on the internet or intranet – you can additionally
select, and preview, a presentation template using the tools to the right of the template
field.

• RTF, for publishing your report in a Rich Text Format file – you can additionally select,
preview, and edit, a presentation template using the tools to the right of the template
field.

• Local, for printing the report directly from its editor.

When you are satisfied, click Next:
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4. The Report Structure page allows you to specify the kinds of information that will appear
in your report. The preview pane on the left hand-side displays a sample report that
changes dynamically according to your selections. You can select any or all of the
following options:

• Introduction section – specifies an introduction sub-heading, preceded by a page
break. Makes available the following sub-options:
• Introduction text - Text paragraph. Click the Define button to open an editor.
• Model properties - Model card

• Short description section – specifies a short description section sub-heading, preceded
by a page break. Makes available the following sub-options:
• Display diagrams - [not for RQM] Diagram book, Graphics, Diagram description,

Diagram annotation
• List objects - List item for each object type in the model

• Full description section – specifies a full description section sub-heading, preceded by
a page break. Makes available the following sub-options:
• Display diagrams - [not for RQM] Diagram book, Graphics, Diagram description,

Diagram annotation
• List objects before full description - Title item and list item for each object type
• Objects detailed description - Book item for each object type

• List objects diagram by diagram - [not for RQM] Diagram book - Instead of a flat
display of object types, it allows you to display objects sorted by diagram in which they
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are displayed. Global objects, such as business rules for example do not belong to a
diagram but to the whole model, and therefore are listed under a specific Title book.

When you are satisfied, click Next:

5. The Package Options page is displayed only if your model contains packages, and allows
you to control the treatment of packages within the report. The preview pane (on the left
hand-side) changes dynamically in order to preview your selection. You can select
whether to base the report on the entire model or on a sub-package, and then choose
between the following options:

• Without packages, all objects are described at the same level [not available for HTML
or an RQM] – Lists all the objects together on the top level, whether or not they belong
to a package.

• One section per package, objects are described under their package [not available for
HTML or an RQM] – Groups objects by the package to which they belong.

• Hierarchical sections, each sub-package is a sub-section in the document - Groups
objects by the package to which they belong, and groups packages beneath their
parents to recreate the package hierarchy.

Note that:

• Global objects (such as business rules) are always included, even when you select a
package.
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• Composite objects (such as activities, or processes in an OOM) are always displayed in
an Hierarchy, even if you have selected a different package option.

When you are satisfied, click Next:

6. The Report layout page allows you to select the types of object to include in the report and
to configure the layout of the object lists and cards.

To specify the inclusion of an object type, select its checkbox in the list. The list includes
only those objects that are present in the selected model or package. Click on the plus sign
to the left of an object to reveal and select or deselect its sub-objects.

Stereotypes used as metaclass display in the list of object types, below those of their parent
object (see Reporting on stereotypes as metaclasses on page 213).

The Select All and Deselect All tools are available above the list. You must select at least
one object type to proceed with the wizard. The Move Up and Move Down tools allow you
to promote or demote the position of an object (though child object types cannot be moved
beyond the scope of their parents.

7. Select an object type in the object type list, and the click the List Layout or Card Layout tab
in the right-hand pane to configure its display. These tabs list the object attributes that can
be displayed in the report. The following parameters are available:
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• Attribute Name – You can use the arrows at the bottom of the list to promote or demote
the attribute in the list

• D[isplayed] – Select the checkbox to enable the display of the attribute
• Width [List Layout only] – Each attribute selected for display will be a column in the

list. Use this parameter to specify the width of the column either as a percentage or in
millimeters.

8. When you are satisfied, click Next:

9. The End page allows you to decide what you will do with your newly created report. Click
the Preview button to preview your report in:

• your Browser – for HTML reports
• your RTF Editor – for RTF reports
• the PowerDesigner preview window – for reports to be printed directly.

Before clicking Finish to complete the report creation, you can select one or both of the
following options:

• Open the report in the Report Editor to be able to fine-tune more options
• Directly generate or print the report

When you are satisfied, click Finish to exit the wizard and create the report.
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Reporting on Stereotypes as Metaclasses
When a stereotype is defined as "Use as metaclass" in a language, DBMS or extended model
definition, it inherits the attributes of a standard metaclass.

The report wizard support metaclass stereotypes as follows :

• Lists metaclass stereotypes in the list of object types, below the parent object in the Report
Layout page.

• Generates a book and a list separately for each metaclass stereotype, below those of the
parent object in the Report Editor.

For example, you create a stereotype "used as metaclass" (called metaclass stereotype) in the
process language associated with a BPM, then you associate the metaclass stereotype to a
process in the diagram and launch the Report Wizard. The metaclass stereotype is listed in the
object type list below the parent object in the Report Layout page. Its associated extended
attributes if any, are listed in the List Layout and Card Layout tabs.

And the generated report shows the list and the book for the metaclass stereotype below those
of the parent object in the Report Editor:
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Creating a Report with the Report Editor
The Report Editor gives you complete control over the content and format of your report. You
can create a blank report from the List of Reports, open it in the Report Editor, and build it
using Report Items.

1. Select Report > Reports to open the List of Reports, which shows an alphabetical list of
all reports saved in the model.

2. Click the New Report tool to open the New Report dialog box:

3. Enter a report name, and select a language for the report's titles from the list.

4. [optional ] Select a report template from the list.

5. Click OK to create the report and open it in the Report Editor (see Using the Report Editor
on page 224).
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Generating a Model Report
The Generate Report window also allows you to access the standard report templates, or
templates or reports that you have previously created, and to generate them in HTML or RTF
format, or to print them directly.

1. Select Report > Generate Report to open the Generate Report window.

2. Select a Generate report option. You can choose from the following options:

• Report template – PowerDesigner provides standard report templates to select the
objects to include in your report and to provide formatting. You can also create your
own templates. You can select an alternative folder to look for additional templates by
clicking the Browse button to the right of the radio button.

• Model report – lists any reports that you have previously created in the model.

3. Select the appropriate template or report from the list.

4. Select a Generation action. You can choose from the following options:

• Generate HTML – Generates a frameset named after the File name field, together with
a folder containing the necessary HTML and GIF files. For example MyReport.html
would have an associated folder called MyReport_files.

• Generate RTF - Generates a Rich Text Format file named after the File name field.
• Print report – Opens the Windows Print window to allow you to directly print the

report.
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• Print preview – opens the print preview window, from which you can choose to print
the report, or to generate it as HTML or RTF.

5. [for HTML or RTF only] Specify a report name and file name for the generated file.

6. Specify the language in which to generate the report.

7. Click OK to begin the generation. The Generation action specified above will be
performed.

Note: If you want to quickly generate a report that you have already defined, and which is
visible in the Browser, right-click its Browser entry, and select Print, Generate > RTF, or
Generate > HTML from the contextual menu.

Creating a List Report
A list report documents a single object type within a model, and is displayed as a customizable
list with columns and rows that you can filter as necessary.

You can create snapshots (called result sets) of a list report to keep a history of the execution of
a list report in your model. Result sets are listed in the browser beneath their parent list report,
and are saved with the model. For more information, see Creating Result Sets on page 221.

A list report is saved in the model and can be exchanged between models of the same type.

You can also right-click a list report in the Browser and select Generate >  Format .

You can right-click a list report in the Browser and select Preview to preview the list report
before printing. You can also right-click a list report in the Browser and select Print without
previewing the list report.

You can create a list report in any of the following ways:

• Select Report > List Report Wizard to launch the List Report Wizard. You can complete
all the steps or click the Finish button at any time after having selected an object type for the
report.

• Select Report > List Reports to access the List of List Reports, and click the Add a Row
tool.

• Right-click the model, package or object category in the Browser, and select New > List
Report.

1. Select Report > List Report Wizard (or select Report > List Reports and click the List
Report Wizard tool in the toolbar) to launch the Wizard:
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2. The Introduction page allows you to specify an object type for the list report. You can also
select whether to base the list report on the model or on a package, and whether to include
shortcuts and objects in sub-packages.

When you are satisfied, click Next:
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3. The Column Filter page allows you to specify which of the object's properties will be
included in the list report. Select a property in the left-hand pane to add it to the list in the
right-hand pane. You can promote or demote properties in the list using the arrows at the
bottom of the pane.

When you are satisfied, click Next:

4. The Row Filter page allows you to specify filters to restrict the objects that will be included
in the list report. Select a property in the left-hand pane to add it to the list in the right-hand
pane, select an operator, and then enter an expression to filter by. You can specify to sort the
list on the values of a property by selecting the S[ort] checkbox.

For more information about the operators and the expression syntax, see Defining a Filter
Expression on page 120.

When you are satisfied, click Next:
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5. The Content Preview page allows you to visualize the results of your choices so far. To
alter the definition click the Back button. Otherwise, click Next:
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6. The End page allows you to specify a name and code for the list report, and to add a
comment. You can also specify whether to generate the report to an external file.

Click Finish to exit the wizard. If you have selected to generate the report to an external
file, you will be asked to specify a file name.

The list report is added to the model and listed in the Browser under the List reports folder

List Report Properties
You can modify an object's properties from its property sheet. To open a list report property
sheet, double-click its Browser entry in the List Reports folder or in the List of List Reports.
By default, the property sheet of a list report always opens on the Content tab.

The General tab contains the following properties:

Property Description

Name Specifies the name of the list report.

Code Specifies the code of the list report.

Comment Descriptive comment for the object.

Object type Specifies the type of the object the list report will be based on. You must select an
object type to have any content in your list report.

Model or Package Specifies the model or package from which the objects will be drawn. Package
selection is unavailable for global objects such as users.

Include shortcuts Specifies whether the list report includes shortcuts.

Include sub-pack-
ages

Specifies whether the list report includes sub-packages. This option is unavail-
able for global objects such as users.

Column Filter Tab

In the Column Filter tab, you can choose the object properties to be used as column titles in the
list report and the order in which they will be displayed.

Row Filter Tab

The Row Filter tab lists the filters that restrict the rows included in the list report. Select a
property in the left-hand pane to add it to the list in the right-hand pane, select an operator, and
then enter an expression to filter by.

You can specify to sort the list on the values of a property by selecting the S[ort] checkbox. For
more information about operators and expression syntax, see Defining a Filter Expression on
page 120.

  220 PowerDesigner  



Content Tab

The Content tab displays the current values for the list report. Properties selected in the
Column Filter tab are displayed as column headings and property values in rows must satisfy
filter expressions defined in the Row Filter tab.

You can open the property sheet of any object included in the list report by clicking the
Properties tool.

Note that data displayed in the Content tab does not dynamically change when you perform a
change to your model that may affect your list report. To update the Content tab, you must
click the Refresh List Report tool.

Use the generation tools to generate a list report result set as a CSV, RTF, HTML, or XML
file.

Result Sets Tab

The Result Sets tab lists the result sets stored for the list report. Use the generation tools to
generate a list report result set as a CSV, RTF, HTML, or XML file.

Creating Result Sets
A result list is a snapshot of the content of a list report at a given system date and time. You can
create as many result sets as you want for the same list report, in order to keep a history of a
given list report for future reference.

You can create a result set in any of the following ways:

• Open the property sheet of a list report, click the Result Sets tab, and then click the Create
Result Set tool.

• Right-click a list report in the Browser and select New > List Report Result Set from the
contextual menu.

Result sets are stored within the model and display under the list report to which they are
related in the Browser:

Result Set Properties

You can modify an object's properties from its property sheet. To open a result set property
sheet, double-click its Browser entry in the List Reports folder just beneath the list report to
which it applies. The following sections detail the property sheet tabs that contain the
properties most commonly entered for result sets.

The General tab contains the following properties:
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Property Description

List Report Name of the list report to which the result set applies.

Report Date Date and time when the result set was created.

Comment Descriptive comment for the result set that allows you to identify it.

The Content tab shows the contents of the result set. Use the generation tools to generate the
result set as a CSV, RTF, HTML, or XML file.

Generating a List Report
You can generate a list report to a CSV, RTF, HTML, or XML file

• Right-click the list report in the Browser and select Generate Format  .
• Open the property sheet of the list report, select the Content tab, and click the Generation

Format tool.
• Select Report > Generate List Report to open the Generate List Report dialog box.

You can right-click a result set in the Browser and select Preview to preview the result set
before printing. You can also right-click a result set in the Browser and select Print without
previewing the result set.

Importing and Exporting List Report Files
It can be useful to exchange list report files between models of the same type. For example,
you may want to compare the properties of a certain subset of classes in two OOMs. You can
import and export list reports to and from your model using the List of List Reports.

To open the List of List Reports, select Report > List Reports.

The following tools are available on the List of List Reports:

Tool Description

List Report Wizard - Launches the List Report Wizard (see List Reports on page 216).

Import List Report from File - Opens a standard Open dialog, which allows you to browse
to the list report file to import. A list report file has a .LRT extension.

Export List Report to File - Opens a standard Save As dialog, which allows you to browse
to the location to save the list report.
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Creating a Multi-Model Report
A multimodel report (MMR) is a PowerDesigner report that can document any number of
models together and show the links between them. To create such a report, you must have at
least one model open in the workspace, and you can add additional models at any time.

1. Select File > New Model to open the New Model dialog box.

2. Select Multi-Model Report.

This option may be in the left or right hand pane, depending on the configuration of your
New Model dialog (see Creating a Model on page 12).

3. Enter a name for the report, specify a language, and select a model from the Model Name
list as the basis for the first section of the report.

4. [optional] Select a template (see Creating a Report with a Report Template on page 206)
from the Report Template list.

Note: When you use a template in a language different from the one specified for the
report, only user-defined items such as Title or Text paragraph will retain the language of
the template. Other items will be displayed in the report language.

5. Click OK to create the multi-model report.

The report opens in the Report Editor, and is added to the Browser:

6. Select File > Save to save your report.

Note: If you want to quickly generate a multi-model report from an existing one without
modifying it, right-click a multi-model report node in the Browser and select Print or
Generate > RTF or Generate > HTML.
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Adding a Second Model to a Multi-Model Report
It is perfectly acceptable to create a multi-model report that contains only one model, but in the
majority of cases, you will want to add additional models.

Each model in the report belongs to a separate "section", which can be accessed via the tabs at
the bottom of the Report Editor window (see Report Properties on page 247).

You can only add models that are currently open in the workspace to the report. However, once
a model has been added, you can edit the report even if the source model has been closed.

1. Open the multi-model report, and select Report > Report properties to open its property
sheet.

2. Click the Sections tab, and click the Add a Row tool.

3. In the Model column, select the model you want to add from the list.

4. In the Sections column, enter the name that you want the model to have in the Report
Editor.

5. Click OK to return to the Report Editor (see Using the Report Editor on page 224).

Configuring a Multi-model Report with the Report Wizard
You can use the Report Wizard to configure a multi-model report. The wizard works on a
single section at a time, and will delete any content currently in the section.

1. Open the multi-model report, and select the section you want to work on by clicking the
appropriate tab at the bottom of the Report Editor window.

2. Click the Report Wizard tool in the Reports toolbar to launch the Report Wizard, and
follow the procedure in Creating a report with the Report Editor on page 214.

Generating a Multi-model Report
You can generate a multi-model report from within the Report Editor by clicking one of the
Generate <format> tools on the Reports toolbar.

Alternatively, you can right-click the multi-model report entry in the Browser, and select
Generate > <format> from the contextual menu.

Using the Report Editor
You can edit model reports, multi-model reports, and report templates in the Report Editor. It
displays the structure of the report or template as a tree view.

The Report Editor window contains two panes:

• The Available Items pane (left pane), from which you can select items to include in the
report.
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• The Report Items pane (right pane), in which you add the items that compose your report.
It can also be filled with the items of a template that you select at the creation of your
report.

By default, the Available Items pane displays only the report items that correspond to objects
that exist in the current model. For example, if you have not created any interfaces in your
OOM, then the List of Interfaces and Interface book will not be listed. Select the Show All
Items check box at the top of the Available Items pane to display all the report items available
for this kind of model.

By default, in the Multi-Model Report Editor, all available report items are displayed if the
associated model is not open in the workspace.

Report Toolbar

The following tools are available from the Report toolbar:

Tool Description

Report Wizard - Opens the Report Wizard (see Creating a report with the Report Wizard on
page 206).

Print Preview - Displays a report print preview (see Previewing your Report on page
227)

Print - Prints the report.

Generate RTF - Generates the report as an RTF file.

Generate HTML - Generates the report as an HTML file.

Add Item - Adds an item to the Report Items pane.
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Tool Description

Up One Level - Moves item up one level.

Down One Level - Moves item down one level.

Raise Level - Moves item at the same level as the book item (item that contains other items)
that precedes.

Lower Level - Moves item within the book item that follows.

For information about managing toolbars, see "Toolbars" in the Models.

Opening a Report in the Report Editor
You can open and edit any existing report in the Report Editor.

For information about creating a report, see Creating a Model Report on page 205.

1. Select Report > Reports to open the List of Reports.

2. Select the report you want to modify and click the Edit Report tool to open it in the Report
Editor.

Note: If you want to quickly generate a report from an existing one without modifying it,
select a report in the List of Reports then click the Print Report, Generate HTML, or
Generate RTF tool.
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Previewing Your Report
You open the Print Preview window from the Report Editor or from the End page of the Report
Creation Wizard.

Note: You can preview a report item by right-clicking it in the Report Items pane and selecting
Quick View.

Opening the Preview
You can display a preview from the Report Editor or from the Report Creation Wizard.
Select Report > Print Preview or click the Preview tool in the End page of the Report
Creation Wizard to open the Print Preview window:

The following tools are available in this window:

Tool Goes to preview

Print the report.

Preview the report one page at a time.
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Tool Goes to preview

Display the report two pages at a time.

Go to the first page.

Go to the previous page.

Go to the Next page.

Go to the Last page.

Generate the report in HTML format.

Generate the report in RTF format.

Open the Find Objects dialog.

Help

Close the preview.

Finding Objects in the Preview
You can search for mentions of specific objects in your report.

1. Click the Find tool to open the Find Objects dialog.

2. [multi-model reports only] Select the model you want to search in.

3. Select an object type and an available object, and then click the Find button to display a list
of topics that mention the object.
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4. Select a topic in the list and click the Display button to navigate to that topic in the preview.

Saving a Model Report
Reports are saved with the model to which they belong.

Note: To reduce the size of your model, you can create its report as a multi-model report,
which is saved to a separate file. For more information, see Creating a Multi-Model Report on
page 223.

Adding Items to a Report
The Available Items pane of the Report Editor lists the items that you can add to your report.

You can add an item to the Report Items pane in any of the following ways:

• Double-click the item in the Available Items pane to place it below the currently selected
item in the Report Items pane.

• Drag the item from the Available Items pane and drop it at the desired position in the
Report Items pane. Use the ctrl or shift key to select multiple items. If the pointer becomes
a barred circle, that means the drop target is unauthorized. Note that you can drag and drop
an item only when the Report Items pane already contains at least one item.

• Right-click the item in the Available Items pane and select Add from the contextual menu

The following kinds of report items are available:
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Icon Description

Table of contents – Inserts a table of contents. PowerDesigner automatically inserts a
following page break.

Title - Free text to introduce what is next.

Paragraph – the following types are available, depending on the context:

• Text paragraph – free text that can be inserted anywhere
• Description – contents of the Description sub-tab of the Notes tab of the model or object

property sheet
• Annotation – contents of the Annotation sub-tab of the Notes tab of the model or object

property sheet
• Other – text paragraphs are available as necessary to display code preview, scripts,

validation rules, etc

Text file – Inserts the contents of a text file, selected via a file chooser.

Graphical file - Inserts the contents of a graphics file, selected via a file chooser.

Page break – Inserts a page break. Right-click the inserted item and deselect Generate in
HTML to disable it when generating HTML reports.

Card – Inserts a table listing the properties of the model or package. Right-click the item
after insertion and select Layout to control the properties listed (see Controlling the layout
of card report items on page 245)

List - Inserts a table listing the objects of a given type belonging to the model or another
object. Right-click the item after insertion and select Layout to control the properties listed
(see Controlling the layout of list report items on page 244)

Graphics – Inserts an image of a diagram.

Book – Inserts a set of sub-items to report on a particular type of object. May contain cards,
lists, text items, graphics, and other books as necessary.

When you add a book item to a report, you automatically add its dependent items. You can
delete any dependent item that you do not need.

When you add an item to the Report Items pane, the item remains in the Available Items pane.
You can insert the same item several times in the same report contents.

Notes:

• Composite objects - BPM processes can contain other processes, OOM activities can
contain other activities, and CDM entities can contain other entities. Such composite
object hierarchies are not included by default in the report, but you can display them by
adding a second instance of the appropriate report item inside the first. In the following
example, the second Entity book is added inside the first Entity book to display child
entities inside their parent entities:
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• Package and composite object hierarchy - When you add a package or composite object
book item to a report, you can select the Hierarchical Display command in the item
contextual menu to display the package or composite object hierarchy in the generated
report. You do not need to use this command when you generate for an HTML report, as
HTML reports always provide a hierarchical display.

• Drag and drop between reports - You can drag and drop items between reports of the same
type. If you simply drag and drop an item from one report to another without pressing any
key, you move the item from one report to another. You can copy an item by pressing the
ctrl key while dragging and dropping it. The report in which you want to drop the item must
already contain at least one item.

Note: When you generate an HTML report that contains a diagram graphic and the object
cards of the symbols, hyperlinks are created between the diagram symbols and the
corresponding object cards. You can click a symbol in the diagram to access the object card
that corresponds to it in the HTML page.

In the following example, the Available Items pane lists report items available for an
Information Liquidity Model (ILM), divided into independent items, and those that provide
model- and object-specific information:
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Modifying Items in the Report Items Pane
You can move items in the Report Items pane by dragging and dropping them.

To copy an item, hold down the ctrl key while dragging it.You can copy any item within the
Report Items pane except for the root folder. Any formatting applied to the copied item is
preserved. When you copy a book item, you also copy its dependent items.

Contextual Menu

The following actions are available by right-clicking items that you have added to the report in
the Report Items pane:
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Command Description

Show Title Controls the display of the item title in generated reports.

Show Book Title in
HTML TOC

[book items] Controls the display of the book item title in the table of contents
of HTML reports.

Show Contents in
HTML TOC

[book items] Controls the display of the sub-item titles in the table of contents
of HTML reports.

Up Moves the item up one line in the tree.

Down Moves the item down one line in the tree.

Raise Level Moves the item up one level in the tree.

Lower Level Moves the item up one level in the tree.

Format Opens the dialog allowing you to modify the formatting of the item (see 
Formatting textual report items on page 239 and Formatting graphical report
items on page 243).

Layout [list and card items] Opens a dialog allowing you to modify the layout of the
item (see Controlling the layout of list report items on page 244 and Con-
trolling the layout of card report items on page 245).

Collection [list and book items] Opens a dialog allowing you to define the collection to
which the report item will be applied (see Modifying the collection of a report
item on page 234).

Selection [list and book items] Opens a dialog allowing you to refine the selection of
objects to which the report item will be applied (see Refining the selection of
objects for a report item on page 236).

Edit Title Opens the item in a dialog allowing you to edit its title (see Modifying the title
of an item on page 233).

Delete Removes the item from the Report Items pane. You can delete any item except
the root.

Quick View Generates a preview of the item (see Previewing your Report on page 227).

Modifying the Title of an Item
Package, object, and object-dependent items all have default titles, and you can insert Title
items anywhere in the Report Items pane and as often as you want. You can edit the default text
of these report items.

1. Right-click an item in the Report Items pane and select Edit Title to open it in the Editor
dialog box.
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2. Enter any appropriate changes to the title text. The user-defined check box will be
automatically selected. To revert to the default value, clear this check box.

3. [optional] Clear the Show Title check box if you do not want to show the title of the item in
the previewed or generated report.

4. [optional] Insert GTL variables that represent the name of the object, its parent, or model,
etc at the cursor, by selecting them with the Insert button.

5. [optional] Click the Format button to open the Format dialog box, and select the
appropriate formatting.

6. Click OK to return to the Report Editor. The first line of the title is displayed next to the
item in the Report Items pane.

Note: You can edit the default titles of all report items in the report language resource file
that is attached to your report. For more information, see the Translating Reports with
Report Language Resource Files chapter in the Customizing and Extending
PowerDesigner book.

Modifying the Collection of a Report Item
The Report Editor and the report items contained within it are drawn from the PowerDesigner
metamodel. You can extend the metamodel to, for example, add new properties to an existing
object (extended attributes), to create new objects (extended objects), and to create new
connections between object types (extended and calculated collections and extended
compositions).

For more information about these extension mechanisms, see the Extending your Models with
Profiles chapter of the Customizing and Extending PowerDesigner manual.

While you can report on these new properties, objects, and collections, the collections are not
included, by default, in the object book report items in the Available Items pane of the Report
Editor and you must reconstruct them yourself. You can add any object list or book inside any
other object book to allow you to represent any extended or calculated collection. Since there
is no control over the location where you drop report items, and you are responsible for the
global consistency of items and collections in your report

Note: If you create extended or calculated collections in your model and use the Report
Wizard (see Creating a report with the Report Wizard on page 206) to create your report, the
generated report automatically creates a list for each type of extended and calculated
collection inside the book item for each affected metaclass.

Once you have dropped the appropriate item, you can modify its collection and select a
calculated or extended collection.

Book Item

In the following example, a calculated collection has been created on the operations metaclass
that retrieves the diagrams where messages using a given operation are displayed. To display
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these diagrams in the report, a diagram item must be inserted inside the operation book item
and the appropriate calculated collection selected for its collection:

List Item

In the following example, in order to manage the "schedule" and "event" concepts, the
extended object <<event>> has been created, along with an extended collection of extended
objects <<schedule>>. The Extended Object report item is added to the report and filtered on
the stereotype Event (see Refining the selection of objects for a report item on page 236) and
the List of Extended Objects is added to the Extended Object book, with its collection set to
Schedule:

Modifying the Collection of an Item
You can change the collection of an item.

1. Drag and drop the appropriate book or list item under the selected book item in the Report
Items pane.

2. Right-click the book or the list item and select Collection to display its Collection dialog
box.

3. Select a collection in the Collection list and click OK to return to the Report Editor.

Selecting Objects to Include in the Report
By default, the report includes all the objects in your model. You can restrict the objects
included by making a selection, which is saved with the report.

1. Select Report > Select Objects from the Report Editor to open the Report Object
Selection dialog box. All the objects (except any external shortcuts) are selected by
default.
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2. Select a report section from the Section list (see Report Properties on page 247).

3. [optional] Select a package from the package list.

4. Select the objects that you want to include in the report from each of the object-specific
sub-tabs.

5. [optional] Specify a name for your selection in the Selection list and click the Save tool
beside the list. The selection is saved as part of the model file (or in the .mmr file for a
multi-model report).

6. Click OK to confirm your selection and return to the Report Editor.

For information about the tools in this dialog, see Adding an Item from a Selection List on
page 122.

Refining the Selection of Objects for a Report Item
You can refine the selection of objects for individual report items. For example you can have a
list of all the tables in your PDM, but you need detailed information about only some of them.
You can refine the object selection either by selecting individual objects or by applying a filter.
You can also control the ordering of individual objects.

Note: If you have made a selection of objects at the report level (see Selecting objects to
include in the report on page 235), objects excluded there will not be available for selection at
the report item level.
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1. Right-click a book or model-dependent list item in the Report Items pane and select
Selection (or, for matrix items, right-click the matrix item and select Row Selection or
Column Selection) to open the Define Sort and Filter dialog box:

2. [optional] Sort and filter the objects you want to include as follows:

• Select the S column next to a property to sort by its value
• Select an operator to apply on the expression value in the Operator column.
• Enter an expression to filter by in the Expression column, and select the U column to

apply the filter to your selection.
For more information about the operators and expression syntax, see Defining a Filter
Expression on page 120.

• Use the arrow buttons at the bottom of the dialog to reorder properties in the list

3. [optional] If you want to refine your selection by choosing from a list of available objects,
click the Switch to Selection button in the lower left corner of the dialog box to display the
Select Objects dialog box:

Note: If you click the Switch to Selection button, any information entered in the Define
Sort and Filter dialog will be lost.
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4. Select the objects that you want to include at this place in the report. By default, all the
objects are selected. You can reorder the objects in the list by using the arrow buttons at the
bottom of the dialog.

Note: If you define a selection of ordered objects on a package for which have selected the
Hierarchical Display command (see Adding items to a report on page 229), any reordering
you do here is ignored.

5. When you are satisfied with your filtering or selection, click OK to return to the Report
Editor. Note that only the last of the filter or selection from which you clicked OK will be
applied.

Formatting Report Items
The formatting of your report is highly customizable. You can set default formats and/or create
specific formats for individual report items:

Note: Right-click any item and select Format to access its formatting options.

Specifying Default Fonts for Report Items
You can specify default fonts for report items, report templates and reports. The default fonts
are saved in the registry.

1. Select Report > Change Fonts from the Report Editor window to open the Change Fonts
Properties dialog box:

  238 PowerDesigner  



2. Select one or more available items in the left-hand list, and specify a font, style, size, and
effects as appropriate.

3. Click OK to return to the Report Editor.

Formatting Textual Report Items
You can access the report items Format dialog in any of the following ways:

• Select one or more text or list report items in the left-hand Available Items pane, and select
Report > Format in order to set default formatting for them.
Each instance of the item that you subsequently add to the right-hand Report Items pane
will have this same formatting, but your changes will not affect any report items already in
the Report Items pane.

• Select one or more text or list report items in the right-hand Report Items pane, and select
Report > Format to change their formatting.
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Available Items

Some report items contain more than one text element. You can format each separately or use
the ctrl or shift keys to select several at once:

Report Item Text Selections

Card items The following selections are available for card items (lists of properties), which
are output in table format:

• Title - Title of the item, eg "Card of the Table"

• Label - Property name on a list of properties, eg "Table Code"

• Text – Value of a property, eg "EMPLOYEE"

CRUD Matrix
items

The following selections are available for CRUD Matrix items, which are output
in table format:

• Matrix title – Title of the item, eg "CRUD Matrix "

• Matrix row and column – Resource and process name, eg " Check item
(process name in rows)" and " Stock (resource name in columns)"

• Matrix text – CRUD value, eg " RU "
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Report Item Text Selections

Model- and ob-
ject-dependent
items

The following selections are available for model- and object-dependent items,
which are output in text format:

• Title – Title of the item, eg " Table Description "

• Text – Text of the description, annotation, or script, eg "This table describes
different employee characteristics "

List items The following selections are available for list items, which are output in table
format:

• Title – Title of the item, eg " List of Indexes "

• Column Header – Heading of column, eg " Code "

• Text – Value in the column, eg " PK_EMPLOYEE "

Title page The following selections are available for the title page, which is output in text
format:

• Title – Title of the report, eg "OOM Report"

• Optional Fields – Text of the author, date, version or summary, eg " VB,
09.15.99, draft, report with lists only "

For more information about the title page, see Report Properties on page 247.

Table of contents The following selections are available for the table of contents, which is output in
text format:

• TOC title – Title of the table of contents, eg " Table of contents "

• Level x– Text of the different hierarchy levels in the table of contents, eg "2.1
Model information "

Note: Select the levels to display from the Show levels list beneath the Available items pane of
the Format dialog box. To define the levels to be shown in the TOC of an HTML report, see
Report Properties on page 247.

Font Tab

The Format dialog Font tab allows you to specify a font, style, size, and effects for the text
elements that you select in the left-hand Available items list.

Paragraph Tab

The Format dialog Paragraph tab allows you to specify indentation, spacing, and alignment for
the text elements that you select in the left-hand Available items list.
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Border Tab

The Format dialog Border tab allows you to specify elements of a frame around the text
elements that you select in the left-hand Available items list. The following border formatting
is available:

Option Description

Left Inserts a vertical line to the left of all the occurrences of the selected text elements.

Right Inserts a vertical line to the right of all the occurrences of the selected text elements.

Top Inserts an horizontal line on top of all the occurrences of the selected text elements.

Bottom Inserts an horizontal line at the bottom of all the occurrences of the selected text
elements.

Box [card and list items only] Inserts a rectangle around all the occurrences of the
selected text elements.

For card items, inserts a rectangle that groups all the occurrences of Text Label
(property names) including Text (corresponding property values).

For list items, inserts a rectangle that groups all the occurrences of Column Header
(heading of column, example Code), and also a rectangle that groups all the occur-
rences of Text (value in the column), if you have previously highlighted each of these
text selections in the Available Items pane.

Width Specifies the line width for the Left, Right, Top and Bottom frame options

Box width Specifies the line width of the box frame

From text Specifies the amount of space from text to top, bottom, left, and right border

Tab Tab

The Format dialog Tab tab allows you to specify tab positions and alignment for the text
elements that you select in the left-hand Available items list. This formatting is particularly
useful for the layout of headers and footers (see Modifying report section headers and footers
on page 246).

The following tab formatting is available:

Option Description

Tab stop position Specifies the measurement for a tab stop

Default tab stops Specifies the default spacing between tab stops
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Option Description

Alignment Specifies how text is to be aligned at the tab stop. To change the alignment
for an existing tab stop, click it in the Tab Stop Position box, and then click
the new alignment option

Editing Textual Report Items
You can edit the text of a text paragraph or a text file in a text editor by double-clicking it or
right-clicking it and selecting Edit.

For text paragraphs, you can select the following kinds of content:

• User-defined - Enter text directly into the box. Click the Format button to apply formatting
to selected text.

• Object attribute - Select an attribute from the list.

Formatting Graphical Report Items
You can access the report items Graph Format dialog in any of the following ways:

• Select one or more graphical report items in the left-hand Available Items pane, and select
Report > Format in order to set default formatting for them.
Each instance of the item that you subsequently add to the right-hand Report Items pane
will have this same formatting, but your changes will not affect any report items already in
the Report Items pane.

• Select one or more graphical report items in the right-hand Report Items pane, and select
Report > Format to change their formatting.

The following options are available in the Graph Format dialog:
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Option Description

Zoom Specifies the resizing of the graphic in the report. You can choose between:

• Fit to page

• Custom zoom

• Keep diagram layout - one page of the diagram per report page

Frame Specifies the borders to insert around the graphic.

Controlling the Layout of List Report Items
List report items are published as tables, ordered by the name or code of the objects. You can
specify which attributes will be displayed, in which order, and the width of their columns.

1. Select one or more list report items in the Report Items pane and select Report > Layout to
open the List Layout dialog, which lists all the attributes available for the object:

2. Enter any appropriate layout changes as follows:

• Use the arrow buttons at the bottom of the dialog to reorder columns in the table.
• Select the D column next to a property to display it in the table.
• Enter a width in the width column. You can specify the width in millimeters (mm),

inches (in) or as a percentage of the table width.

3. Click OK to return to the Report Editor.

Note: If extended attributes are specified for the object, they will be available for selection in
the List Layout dialog. You can choose to select all extended attributes or only those whose
value has been modified using the Display > All and Display > Only modified ones
commands from the list item contextual menu.
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Controlling the Layout of Card Report Items
Card report items represent the property sheets of individual objects and are published as
two-column tables. You can specify which attributes will be displayed, and in which order.

1. Select one or more card report items in the Report Items pane and select Report > Layout
to open the Card Layout dialog, which lists all the attributes available for the object:

2. Enter any appropriate layout changes as follows:

• Use the arrow buttons at the bottom of the dialog to reorder properties in the table.
• Select the D column next to a property to display it in the table.

3. Click OK to return to the Report Editor.

Note: Select the Displayed check box for the Class Name attribute to distinguish shortcuts
cards from the other object types cards in the generated report.

Suppressing the Titles of Report Items
You can suppress the title of any item in your report. The following illustration shows a portion
of a report, with the title of the process card displayed:

This illustration shows the same report with the title of the process card suppressed:
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Right-click an item in the Report Items pane and deselect the Show Title command.

or

Double-click an item to open the Editor dialog box, clear the Show Title check box, then click
OK.

Modifying Report Section Headers and Footers
The Report includes a default header and footer that you can modify.

For more information about the default header and footer, see Report Properties on page
247.

For RTF reports, you can specify separate headers and footers for each section of your report
(see Report Properties on page 247).

1. Right-click the root section item in the Report Items pane and select Header/Footer (or
click the Header & Footer button in the Presentation Options page of the Report Creation
Wizard) to open the Header and Footer dialog:

2. Enter any appropriate changes to the header text. Edit the Footer text by clicking on the
Footer sub-tab. You can use any of the variables available to the RTF template (see RTF
and HTML Report Presentation Templates on page 252).

If you change the default header or footer text, then the User-Defined check box is
selected, to indicate that you have overridden the default values in the associated report
language resource file. To revert to the default value, clear the check box. For more
information about report language resource files, see the Translating Reports with Report
Language Resource Files chapter in the Customizing and Extending PowerDesigner book.

Note: Use the key combination ctrl+tab to insert tabulations in a header or open the Tabs
tab in the Format dialog box (see Formatting textual report items on page 239) to set tab
stop values.

3. Click OK in each of the dialog boxes.
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Report Properties
To open the report property sheet, select Report > Report Properties from the Report Editor
window.

The report property sheet General tab contains the following properties:

Property Description

Name Specifies the name of the report.

Code Specifies the code of the report.

Comment Provides additional descriptive information about the report.

Language Specifies the language of the report. Click the tools to the right of this field to edit
the selected report language resource file or to change the path that populates the
list. For more information see the "Translating Reports with Report Language
Resource Files" chapter in the Customizing and Extending PowerDesigner man-
ual.

No paragraph
numbering

Suppresses section numbers in RTF and printed reports. Paragraph numbering is
not used in HTML reports.

Generate empty
paragraphs

Generates titles for all book items, even if they have no content.

Title Page Tab

The report property sheet Title Page tab allows you to specify the contents of a title page for
your report:

Property Description

No title page/ In-
clude title page

Select whether to include a title page. Selecting Include title page enables the
other fields on this tab.

Title Specifies the title of the report. Defaults to the name of the report.

Author Specifies the report author. Defaults to user shown on the Version Info tab.

Date Specifies the date of the report. Defaults to the current date.

Version Specifies the version number of the report. Defaults to the version in the model
property sheet.

Summary Specifies any additional text to be printed on the title page.

Click the Format button to customize the formatting of these fields.
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Note: For HTML reports, a home page is generated instead of a title page (see below). Title
pages are never generated for RTF reports generated with a report template.

RTF Format Tab

PowerDesigner provides a set of predefined RTF presentation templates, style sheets, and
header and footer files for generating RTF reports, which are located in the Resource
Files\RTF Report Templates directory. You can use these files as a basis to create
your own templates.

The report property sheet RTF Format tab allows you to specify an RTF presentation template
for your report, and contains the following properties:

Property Description

Template Specifies the RTF presentation template to be used to style the report. Click the tools
to the right of this field to edit the selected template (see RTF and HTML Report
Presentation Templates on page 252) or browse to an alternate template directory.

Use sections
header and
footer

Specifies to use the header and footer defined in each report section instead of those
defined in the RTF presentation template. If you want to preserve the header and
footer of the title page and the one of the table of contents page, you should add a
section break after the table of contents.

This option is recommended when formatting a multi-model report, as otherwise all
the pages of the report will have the same header and footer.

Note: Click the Set As Default button to specify your current settings as the default for RTF
reports. To revert to the previously saved values, click the Default button.

HTML Format Tab

PowerDesigner provides a set of predefined HTML presentation templates, style sheets and
header and footer files for generating HTML reports, which are located in the Resource
Files\HTML Report Style Sheets directory. You can use these files as a basis to
create your own templates.

The report property sheet HTML Format tab allows you to specify HTML presentation
options for your report, and contains the following properties:

Property Description

Template Specifies the HTML presentation template to be used to style the report. Click the
tools to the right of this field to preview, save, or delete the selected template, or to
browse to an alternate template directory.
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Property Description

Style sheet Specifies the style sheet to be used to style the report as an absolute or relative path or
a URL. Click the tools to the right of this field to edit the selected stylesheet (see RTF
and HTML Report Presentation Templates on page 252) or browse to an alternate
style sheet.

Header / Foot-
er

Specifies the HTML file to be used as the report header or footer as an absolute or
relative path or a URL. Click the tools to the right of the field to edit the selected file
(see RTF and HTML Report Presentation Templates on page 252) or browse to an
alternate file.

You can also specify the height, in pixels, of the header and footer.

Home page Specifies the HTML file to be used as the report homepage as an absolute or relative
path or a URL. Click the tools to the right of this field to edit the selected file (see 
RTF and HTML Report Presentation Templates on page 252) or browse to an
alternate file.

Table of con-
tents

These options control the format of the table of contents. You can specify:

• Level - the maximum number of levels to display in the HTML table of contents.
The default is 4.

• Width - the width of the frame as a percentage of the total width of the report
window. The default is 25%.

• TOC at right - whether the TOC will be generated on the left (default) or right
side of the screen.

You can reduce the size of the HTML TOC using the following commands from the
contextual menu of book items in the Report Items pane:

• Show contents in HTML TOC - deselect this option to display only the title of
the item without its contents in the TOC.

• Show book title in HTML TOC - deselect this option to remove the title of the
book item from the table of contents. Automatically deselects the Show contents
in HTML TOC option.

Image Format Specifies the file format for graphic files to be generated and embedded in the report.
You can choose from the following:

• SVG - XML-based language for Web graphics, which allows you to interact
with the graphics. Note that SVG is not supported for graphics embedded in RTF
in PowerDesigner property fields, and such graphics will be generated as PNG.

• PNG – higher quality than JPEG.

• JPEG – smaller file size than PNG.
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Property Description

List format Specifies the format for lists. You can specify the number of rows you want to
display per page in the list results and the number of links to additional results
displayed below the list. Additional results are numbers with hyperlinks to other
pages containing the next rows of the list.

Add page
break for top
level list and
cards

Inserts a page break before each top level list and card to avoid long HTML pages.

Note: Click the Set As Default button to specify your current settings as the default for HTML
reports. To revert to the previously saved values, click the Default button.

Depending on the type of location (local or UNC paths, or URL), style sheet files, header and
footer files and home page files are used as follows:

Location Use

Local path or UNC path The file is copied into the report generation folder.

URL The file is referenced in its location.

We recommend that you gather your style sheets and header and footer files in a subfolder with
the same name as the presentation template file with which they are associated to ensure that
the structure of links between them is simplified.

For example, the Header_Blue.html header uses files that are gathered in the
Header_Blue_files folder:

Sections Tab

You can use sections to structure your report. You can create, delete, modify and rename
sections in the report property sheet. Each section can only report on one type of model. In a
multi-model report, each different type of model (PDM, OOM, BPM, etc) must have its own
section.

Reports must contain at least one section. Sections are displayed as tabs at the bottom of the
Report Items pane of the Report Editor.
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The report property sheet Sections tab allows you to create, configure, and delete report
sections, and contains the following properties:

Property Description

Name Specifies the name of the section, which will be displayed on the sub-tab at the
bottom of the Report Editor window.

You can change the name of a section here or by right-clicking the section node in the
Report Editor and selecting Rename

Model [multi-model reports only] Specifies the model on which the section will report.

Template Specifies the template upon which the section is based. You can choose between:

• None [default] – creates an empty section.

• Full  Model Type  Report – provides lists of all the types of objects in the model,
together with detailed information on each object.

• List  Model Type Report – provides lists of all the types of objects in the model.

• Standard  Model Type  Report – provides lists of all the types of objects in the
model, together with detailed information on each of the main objects.

Apply Tem-
plate

Re-applies the specified template to the section, deleting any modifications you may
have made.

Note that you cannot undo this action.

Note: You can launch the Report Wizard from the Report Editor to configure the present
section. The wizard configures only one section at a time, and will delete the current contents
of the section. To configure a second section, select it using the section tabs at the bottom of the
window, and relaunch the wizard. For information, see Creating a report with the Report
Wizard on page 206.

Valid Codepage
By default, PowerDesigner generates in the HTML page a character set (charset) built from
the current language of the report. If this is not correct for your needs, you can change the
charset.

1. Right-click the report in the Browser, and select Properties from the contextual menu to
open its property sheet.

2. On the General tab, click the Properties button to the right of the Language field to open the
Report Language resource file in the Resource Editor.

3. Expand the Report Titles > Common Objects category, and set the appropriate values for
the CharSet and CodePage items.

For information about working with charsets and coding pages, see: http://www.w3.org/
International/tutorials/tutorial-char-enc/.
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Note: You can translate the navigation buttons (Previous, Next, Home) generated by default in
your HTML report using HtmlNext, HtmlPrevious and HtmlHome items in the Report Titles
\Common Objects category of the Report Language Editor. For more information, see the
"Translating Reports with Report Language Resource Files" chapter in the Customizing and
Extending PowerDesigner manual.

RTF and HTML Report Presentation Templates
PowerDesigner provides a set of predefined RTF and HTML presentation templates to style
reports in these formats. You can use these templates and their associated files as a basis to
create your own presentation templates. These RTF presentation templates are stored in the
Resource Files\RTF Report Templates folder.

The following GTL variables are available to these templates:

Variable Description

%DATE% Report date defined in report property sheet.

%TIME% Report generation time.

%MODELNAME% Model name of a report section.

%MODELCODE% Model code of a report section.

%MODULE% Module name of a report section.

%APPNAME% Application name (PowerDesigner).

%TITLE% Report title defined in report property sheet.

%AUTHOR% Report author defined in report property sheet.

%VERSION% Report version defined in report property sheet.

%SUMMARY% Report summary defined in report property sheet.

%COMPANY% Company name (Sybase, Quest).

%REPORTCONTENT% [RTF only] Report insertion point in the RTF presentation template.
If this variable is not defined, the report is appended at the end of the
RTF presentation template.

%NEXT% [HTML only] URL of the Next page of the home page.

%NEXTLABEL% [HTML only] Name of the Next page of the home page.
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RTF Presentation Templates
An RTF presentation template file has an .RTF extension and allows you to define the header,
footer, title page, table of contents, and general style of your RTF report. You can insert
pictures, page borders and variables in an RTF presentation template.

The presentation template takes into account all the presentation options that you have defined
in the Report Wizard or Report Editor, except the table of contents report item as this is defined
in the RTF presentation template.

Note: If you open a report saved in a previous version, the RTF Template list is set to <None>.

HTML Presentation Templates
An HTML presentation template file has an .HTMLTPL extension and allows you to define
the header, footer, home page, and style sheet (for font, color, background, size, margin, and
alignment) for your HTML report. The formatting defined in your style sheet will override any
defined in the Report Wizard or Report Editor.

Note: If you open a report saved in a previous version, the HTML presentation template has
the values of the default HTML presentation template or the Presentation template box will be
set to (<None>).

Style Sheet Structure

The following table describes the use of class names in the report style sheets:

Class names Description

BODY Defines the background styles for all report pages, except the
home page frame and the browser frame page.

.BROWSERBODY Defines the background styles for the browser page.

.HOMEBODY Defines the background styles for the home page.

.TEXT Defines the default font styles for text blocks, like description,
annotation, etc.

.TITLE Defines the default font styles for the title of the home page.

TABLE Defines the default styles for tables.

TD Defines the default styles for table cells.

Table.GRID Defines the styles for object list tables.

TABLE.GRID TD.HEADER Defines the styles for the header cells of object list tables.

TABLE.GRID TD Defines the styles for the cells of object list tables of even
rows.
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Class names Description

TABLE.GRID TD TD2 Defines the styles for the cells of object list tables of odd rows.

Table.FORM Defines the styles for object card tables.

TABLE.FORM TD.HEADER Defines the styles for the cell name of object card tables.

TABLE.FORM TD Defines the styles for the cell value of object card tables.

Table.TEXT Defines the styles for the tables around the text blocks.

TABLE.TEXT TD Defines the styles for the cells of tables around the text blocks.

Table.TITLE Defines the styles for the tables around the home page title.

TABLE.TITLE TD Defines the styles for the cells of tables around the home page
title.

Table.GRAPHICS Defines the styles for the tables around graphics.

TABLE.GRAPHICS TD Defines the styles for the cells of tables around graphics.

H1 Defines the styles for level 1 headings.

H2 Defines the styles for level 2 headings.

H3 Defines the styles for level 3 headings.

HR Defines the styles for separator lines.

A:LINK Defines the default colors for non-visited hyperlinks.

A: VISITED Defines the default colors for visited hyperlinks.

A: HOVER Defines the default colors for highlighted hyperlinks.

.BROWSER Defines the default font styles for the browser.

A.BROWSER:LINK Defines the default colors for non-visited hyperlinks of the
browser.

A.BROWSER:VISITED Defines the default colors for visited hyperlinks of the brows-
er.

A.BROWSER:HOVER Defines the default colors for highlighted hyperlinks of the
browser.

TABLE.NAVGROUP Defines the styles for the tables around the navigation buttons.

TABLE. NAVGROUP TD Defines the styles for the cells of tables around the navigation
buttons.
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Class names Description

.NAVBUTTON Defines the default font styles for the navigation buttons.

A.NAVBUTTON:LINK Defines the default styles for non-visited hyperlinks of the
navigation buttons.

A.NAVBUTTON:VISITED Defines the default styles for visited hyperlinks of the navi-
gation buttons.

A.NAVBUTTON:HOVER Defines the default styles for highlighted hyperlinks of the
navigation buttons.

Report Templates
A report template specifies content and formatting for a report section.

If your report has more than one section, you can apply report templates to each of the sections
(see Report Properties on page 247).

PowerDesigner provides a set of standard report templates that allow you to generate reports
without any configuration (see Creating a report with a report template on page 206). You can
also create your own report templates

Report templates are edited in the Report Template Editor, which is like the Report Editor
except that it can only contain a single report section, and the right-hand pane is called
Template Items.

Creating a Report Template from the List of Report Templates
You can create a report template from scratch, or based on an existing template, from the List
of Report Templates.

1. Select Tools > Resources > Report Templates to open the List of Report Templates:
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2. Click the New tool and enter a name for your template:

3. Select a language and model type for the template, and then click OK to open the empty
template in the Report Template Editor.

4. Add report items as appropriate to the Template Items pane (see Adding items to a report
on page 229) and set any desired formatting (see Formatting Report Items on page 238).

5. Select File > Save to save the template.

The template will be available the next time you create a report.

Creating a Template from a Report Section
Once you have created a report section, you can save it as a template for use with other reports.

1. In the Report Editor, click the tab corresponding to the section you want to save as a
template.
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2. Select Report > Create Template From Section to open the section in the Report
Template Editor.

3. Select File > Save, enter a name for the template, and click OK to save it for future use.

Note: You can rename a template in the Template Items pane by right-clicking the
Template node at the root of the tree and select Rename.

Modifying and Saving a Template
You can modify existing templates from the List of Report Templates.

1. Select Report > Report Templates to open the List of Report Templates.

Note: You can open the List of Report Templates from the List of Reports by clicking the
Manage Report Templates tool.

2. Select a template type to display the list of available templates of that type.

3. [optional] Click the Path tool to select a different directory in which to search for
templates.

4. Select a template and click the Properties tool to open it in the Report Template Editor.

5. Make any appropriate changes to the template and then select File > Save.
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CHAPTER 7 Comparing and Merging Models

PowerDesigner provides powerful tools for comparing models and merging them.

Comparing Models
You can compare the content of two PowerDesigner models or two resource files of the same
type at any time.

You may want to compare models or resource files to:

• Follow up evolutions in models or resources manipulated by different development teams
• Evaluate the differences that exist between the models or resources before merging them

Note: For more information about the comparison of resource files, see "Comparing Resource
Files" in the Resource Files and the Public Metamodel chapter of the Customizing and
Extending PowerDesigner manual.

1. Select Tools > Compare Models to open the Select Models to Compare dialog box.

The current model is displayed in the Model 2 field.

2. Select a model to compare in the Model 1 list. Only models of the same type in the
workspace are available for comparison.

3. [optional] Click the Options button to open the Comparison Options window and specify
which objects and properties you want to include in the comparison. For more information,
see Comparison options on page 260.

4. Click OK to open the Compare Models window, which displays the objects contained
within the models or resource files in a tree format, and highlights the differences between
them. See Analyzing differences in the Compare Models window on page 261. You can
apply a filter to simplify the list of differences (see Filtering Changes in the Compare and
Merge Windows on page 264).
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Comparison Options
The Comparison Options dialog box allows you to specify which types of objects you will
compare. By default, all objects are selected for comparison.

The dialog box is divided into three panes:

• Metaclasses – top-level objects such as tables, classes, entities, etc.
• Attributes – simple properties associated with the selected metaclass.
• Collections – properties that can contain multiple properties, and which are often sub-

objects in their own right.

When you select a metaclass, the lists of attributes and collections change accordingly.

When you merge two models, differences are ignored for metaclasses, attributes and
collections not selected for comparison. No changes will be applied to the model to be merged
for a metaclass, attribute or collection where the selection checkmark has been cleared in the
comparison options lists.

In the following illustration, the Entities collection check box is deselected for comparison:

Note: You can set your current selection of comparison options as default by clicking the Set
as default button in the Comparison Options dialog box.

You can perform the following option selections:
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You can... To...

Select or deselect a meta-
class check box

Select or deselect all its attributes and collections at once

Right-click a metaclass at-
tribute or collection

Select or deselect the attribute or collection for all metaclasses at once
from the contextual menu

Click the Select All or De-
select All tools

Select or deselect all metaclasses, attributes and collections at once

You can also select several metaclasses at the same time. Only attributes and collections that
are common to all metaclasses are listed on the right hand side. When an attribute or collection
property value is different from a selected metaclass to another, the attribute or collection
check box is grayed-out to indicate the difference.

When you select a metaclass check box, you do not select the metaclass itself for comparison,
but only its attributes and collections. If you want to select or deselect a metaclass for
comparison, you have to click a Model and/or Package metaclass to display its corresponding
attributes and collections and select or deselect the collection check box that corresponds to
the unwanted metaclass in the list of Collections on the bottom right hand side.

Analyzing Differences in the Compare Models Window
The Compare Models window allows you to compare the contents of two models.

Four types of differences between the models can be detected during a comparison:

• Creation: When an object is created in one of the models, it is displayed in blue.
• Deletion: When an object is deleted from a model, it is displayed as a ghost object in the

model tree.
• Modification: When the properties of an object are different between models, a red

exclamation mark is displayed in the bottom right corner of the object node.
• Move: When the object has been moved to a different position, for example, a column

moved in the list of columns. In this case a green triangle is displayed in the bottom right
corner of the object indicates that there has been a move. The green triangle is displayed
both on the ghost object indicating the original position of the item and on the object in its
new location.
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The window is divided in two parts:

• The object comparison panes in the upper part of the comparison window display two
models of the same type in a tree format and highlight the differences between them.

• The property comparison pane in the lower part of the comparison window displays the
properties of the nodes selected in the model trees. The property comparison part is
divided in three columns, listing the property name, and the values in the two models. The
following kinds of differences are possible:

Difference
type

Property name col-
umn

Model 1 properties
column

Model 2 proper-
ties column

Object creation No sign Object properties dis-
played

No properties dis-
played

Object deletion No sign No properties displayed Object properties dis-
played

Object modifica-
tion

Diverging property type
highlighted by an excla-
mation point

Divergent object prop-
erties displayed

Divergent object prop-
erties displayed
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Difference
type

Property name col-
umn

Model 1 properties
column

Model 2 proper-
ties column

Object move No sign Identical object proper-
ties displayed

Identical object prop-
erties displayed

Object moved
and modified

Diverging property type
highlighted by an excla-
mation point

Object properties dis-
played

Object properties dis-
played

Comparison Symbols

Symbol Description

Ghost object which does not exist in one of the models

Shortcut exists in model

 (yellow) Sub-objects are different

 (red) Object exists in both models with different properties

 (green) Object was moved and modified. This symbol indicates the initial location of the
object in the model.

This symbol always is displayed besides a ghost object.

 (red) Object was moved and modified. This symbol indicates the new location of the
object in the model.

 (green) Object was moved

Note: You can open the property sheet of an object (in read-only mode) by double-clicking its
node in the tree view. You can also right-click the object node and select Properties from the
contextual menu . You can open several property sheets in order to compare the properties of
different objects. However, all property sheets will be closed when you close the Comparison
window.

Navigating Among Differences

You can navigate among the differences that appear in the object comparison part using the
following tools from the comparison toolbar:

Tool Description

Goes to the first difference in the tree view

Goes to the previous difference in the tree view
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Tool Description

Goes to the next difference in the tree view

Goes to the last difference in the tree view

Note: To expand all nodes at once, you can press the numpad star (*). To collapse all nodes at
once, you can press the numpad minus sign (-).

Filtering Changes in the Compare and Merge Windows
You can filter the objects that are shown in the Compare and Merge windows.

1. In the Compare or Merge Models window, click the arrow next to the Change Filter tool to
display the list of filters:

• • All objects
• All changes
• Only created objects
• Only deleted objects
• Only modified objects
• Only moved objects
• Only identical objects
• Only selected objects [Merge Only]
• Show only conflicts [Merge Only] - A merge conflict occurs when the same object

has been modified differently in the origin and generated model or the local and
Repository model.

• Hide all preservations [Merge Only] - Hides all differences associated with
changes made in the model to be merged as well as all identical objects in order to
show only changes made in the model on the left since last generation.

• Advanced Filters – Opens the Comparison Filters dialog box, which allows you to
combine several filters.
[Merge Only] The following additional Filters on State are available for
combining:
• Show only selected objects - Displays only selected merge actions
• Show only conflictual objects - Displays objects that have been changed

simultaneously by two different users. This filter is only available for merge
during consolidation

• Show only non-preserved objects - Displays objects modified in a generated
model but not in the source model. This filter is only available for merge during
model generation

You can display all created and deleted objects in the same tree view, check which
objects have changed parent after a move (from one package to another package,
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for example), or which objects have been moved within the same collection (when
you move attributes within the same entity, for example).

2. Select the appropriate filter to apply it to the Compare or Merge Window. Only objects
complying with the filter criteria are displayed.

Previewing, Printing, and Saving Comparison Results
You can preview, save, and export the results of the comparison by clicking the Compare
Preview tool to launch the Compare Preview window.

This window provides three formats viewing the comparison results on the following tabs:

• Comparison Text – a textual representation of the differences between the models. This is
the most exhaustive format, and provides complete information about the whole object
tree. Select the Show Legend and/or Show Model Identification options to display
additional information at the beginning of the text.

• Actions Description – a list of the actions that would need to be taken to render the models
the same. This will often be the most readable format as it represents each change in the
form of a sentence:
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• List – a columnar representation of the required actions. This format is the most easily
manipulated. You can sort by any of the columns, and export the list in a variety of formats
to allow for various kinds of transformation:
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The following tools are available on each of the tabs:

Tool Description

Use Filter Filters the changes using the filter specified in the main window (see Filtering
Changes in the Compare and Merge Windows on page 264). If no filter has been
specified before the preview is launched, then this option is not visible.

Print

Save - Saves the comparison in text format for Comparison Text and Actions
Description , and in XML, CSV, RTF, or HTML format for List.

The following columns appear on the List tab:

Column Description

Action Type Specifies the type of action to perform. Can be any of the following:

• Create – creates an object
• Delete – deletes an object
• Modify – modifies an object
• Move Object – moves an object to a new parent
• Col Insert – inserts an object into a collection
• Col Remove – removes an object from a collection
• Col Move – moves an object from one position to another within a collection

Parent Specifies the parent of the object to be changed (the original parent, in the case of an
object that will be moved). For example, a class for an operation, or a diagram for a
symbol.

Type Specifies the type of the object to be changed.

Object Specifies the name of the object to be changed

Property Specifies the object property or collection to be changed. Empty for a Create, Delete,
or Move Object action.

Old Value Specifies the original value of the property to be changed. Empty in the case of a
Create or Col Insert

New Value Specifies the updated value of the property. Empty in the case of a Delete or Col
Remove.

For example, changing the datatype of attribute MyVariable from int to long would yield the
following column entries:

Action Type  Parent Type   Object  Property  Old Value  New Value
Modify   MyClass  Attribute  MyVariable  DataType  int    long
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Merging Models
You can merge the content of two PowerDesigner models or two resource files of the same
type at any time.

Note: For information about selecting resource files to merge, see "Merging resource files" in
the Resource Files and the Public Metamodel chapter of the Customizing and Extending
PowerDesigner manual.

1. Select Tools > Merge Models to open the Select Models to Merge dialog box.

The current model is displayed in the To field.

2. Select a model to merge in the From list. Only models of the same type in the workspace
are available for merging.

Note: If you want to merge two PDMs, BPMs, OOMs or XSMs, you have to select two
models with the same target DBMS or language

3. [optional] Click the Options button to open the Comparison Options window and specify
which objects and properties you want to include in the comparison and possible merging
(see Comparison options on page 260).

4. Click OK to open the Merge Models window, which displays the objects contained within
the models or resource files in a tree format, and highlights the differences between them
(see Analyzing Differences in the Merge Models Window on page 269). You can apply a
filter to simplify the list of differences (see Filtering the Changes to Merge on page 264).

5. After selecting the merge actions that you want to perform, click OK.

The Merge Models dialog box closes and the merge begins. Merge messages are displayed
in the Output pane. A final message informs you that the models were successfully
merged.
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Analyzing Differences in the Merge Models Window
The Merge Models window allows you to compare the contents of two models:

The window is divided in two parts:

• The object comparison panes in the upper part of the comparison window display two
models of the same type in a tree format and highlight the differences between them. Any
eventual merge will be effected on the "To" model in the right-hand pane.

• The property comparison pane in the lower part of the comparison window displays the
properties of the nodes selected in the model trees. The property comparison part is
divided in three columns, listing the name of the property and its values in the From and To
models.

Merge is performed from left to right, the model to be merged is compared to the model on the
left pane, differences are highlighted in this model, and merge actions are applied in the model
on the right pane.
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Navigating Among Differences

You can navigate among the proposed merge actions displayed in the model to be merged
using the following tools:

Tool Description

Goes to the first difference in the tree view

Goes to the previous difference in the tree view.

Goes to the next difference in the tree view

Goes to the last difference in the tree view

Note: You can right-click a moved object and select Next or Previous occurrence to go to its
next or previous occurrence.

Note: To expand all nodes at once, you can press the numpad star (*). To collapse all nodes at
once, you can press the numpad minus sign (-).

Understanding Merge Action Icons
For each difference detected during the comparison process, a merge action is proposed for
you to synchronize the model to be merged with the model on the left pane.

Merge icons are composed of a symbol and a color. A triangle provides an indication that there
is a difference between the two models. A circle with a check box, which only appears on the
right-hand pane specifies a merge action that will be performed if the check box is selected.

The following table explains the color code:

Color Description

Red Modification

Yellow Indication

Green Move

Purple Deletion and shortcut replacement

Blue Addition

The following table lists the indications and merge action symbols:

Icon Description

[yellow] Notification that children were modified

[red] Notification that object properties were modified
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Icon Description

[green] Notification that object was moved

Object creation [blue] - Adds object to model to be merged because it exists
in model on left pane

Object deletion [purple] - Deletes object from model to be merged

Object modification [red] - Updates object definition in model to be merged
using object definition in model on left pane

Object move [green] - Moves object in model to be merged to the same
location as in model on left pane or replaces it with shortcut

Shortcut merge [purple] - Replaces the shortcut with target object

Shortcut deletion [purple] - Deletes shortcut from target model

Shortcut creation [blue] - Creates shortcut in target model

Moving an Object from a Package to Another

When you merge models in one of which you have moved an object from a package to another
and modified its properties, the object is displayed in both packages of the model to be merged,
in the object comparison part.

In the following example, Entt_5 in Package 2 was modified and moved into Package 1:

Icon Description

One occurrence remains in the package on the left pane and the opposite icon is dis-
played at the bottom right corner of the object to indicate that the object properties were
modified
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Icon Description

The second occurrence is displayed grayed out in the package to be merged and the
opposite icon is displayed at the bottom right corner of the object to indicate that the
object was moved but does not yet exist in that location

You are invited to synchronize the models on the right and left panes by selecting both check
boxes.

Note: When you select or clear a merge action check box for a moved object, the check box of
the other occurrences are automatically selected or cleared.

When you move an object that is replaced with a shortcut, the merge action suggested is the
move with no indication of shortcut replacement. The unique indication of the object
replacement with a shortcut is displayed with the following icon in the model on the left pane
of the Merge Models dialog box:

In the following example, Entt_2 in the main diagram was moved into Package 2:

Left model Right model Description

Move target object

Replace target object with a shortcut

Note: When you merge models, move is not a suggested merge action for objects which are in
different namespaces but have identical name. In that case creation or deletion of the object are
proposed.
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For more information on namespace in models, see Object Namespaces on page 116.

User Permissions in the Repository

When a user does not have the appropriate rights and permissions in the repository, merge
actions appear with a grayed out check box and cannot be selected.

However, some actions can be applied to objects in packages on which the user does not have
the required permission, in order to be consistent with a permitted action.

In the following example, the model on the left pane corresponds to the local model and the
model on the right pane corresponds to the repository model. The user has a Read permission
on Package 1 and a Write permission on Package 2.

Model Package What happens...

Local model
(left pane)

Package 2 (Write per-
mission)

Entt_3 was deleted

Package 1 (Read per-
mission)

Entt_1 properties were modified

Entt_3 shortcut was deleted because of the deletion of
Entt_3 in Package 2

Repository
model (right
pane)

Package 2 (Write per-
mission)

The proposed merge action for Entt_3 is delete. The user
has a Write permission and can select this action

Package 1 (Read per-
mission)

Entt_1 check box cannot be selected (grayed) because the
user does not have Write permission

The check box for Entt_3 shortcut cannot be selected
(grayed) but the shortcut will be deleted anyway to be
consistent with the merge action for Entt_3 selected in
Package 2

For more information on user permission, see the Working with the Repository manual.
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Selecting Merge Actions in the Model to Be Merged
You can select or deselect merge actions in the pane of the model to be merged, using:

• A category contextual menu
• An object contextual menu

To do so, you right-click an object or a category in the pane of the model to be merged and
select the Select or Deselect command to open the sub-menu of the merge actions.

By default, all creation, modification and move actions are selected in the model to be merged,
deletion actions are not selected.

Note: For consolidated models, the merge actions selected by default depend on the latest
modifications saved in the model. For generated models, if the Preserve modification
generation option was selected, they depend on the modifications saved in the model to be
merged.

The following selection tools from the merge toolbar:

Tool Description

Select all merge actions. Click the arrow to select all of one kind of merge action.

Clear all merge actions. Click the arrow to deselect all of one kind of merge action.

Merging Object Properties
PowerDesigner lets you select individual object properties to merge.

Note: You can double-click a property in the property comparison part to display differences
between models. When a line is added the following symbol is displayed >>, when a line is
deleted, the following symbol is displayed <<.

1. Select objects with different definitions in the object comparison part of the Merge
window.

2. Select or clear the check boxes corresponding to the properties you want to merge in the
properties comparison part of the Merge window.

By default, the diverging properties are selected in the list:
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Synchronizing Objects Manually
When an object has been renamed or modified out of the PowerDesigner interface, the link
with the corresponding object in the compared model is lost, and the comparison interface will
display two disconnected objects in the model trees with object creation and deletion actions
in each model.

Manual synchronization lets you perform the following operations:

• Synchronize moved or disconnected objects. Use the Parent box to select the parent
package corresponding to the package on the left pane.

• De-synchronize objects that share common properties and are naturally related in the
comparison process. You can select <NONE> or another object from the Object list in
order to break the relation between objects.

The tree view of the model to be merged is automatically updated after you validate a manual
synchronization.

1. Select the item you want to synchronize from one of the model trees, and then click the
Manually Synchronize Two Objects tool to open the Manual Synchronization dialog box
is displayed:

Depending on the merge action proposed, the From or the To box is editable.
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2. Select a model or package in the Parent list, and then select the object that you want to
synchronize with in the Object list. You can use the Properties tool to better identify object

3. Click OK.

The selected items are synchronized and the tree view of the model to be merged is updated
in order to show the impact of the manual synchronization.

When you synchronize objects and linking objects, you obtain the following result:

Object Within the same package Between different packages

Object

Linking object

Objects on the left pane and parent
objects are synchronized

Object moved to package to be merged
and removed from package on the left
pane

Previewing, Printing, and Saving Merge Actions
You can preview and print the selected merge actions by clicking the Merge Preview tool to
open the Merge Preview window.

This dialog is the same as the Compare preview dialog. See Previewing, printing, and saving
comparison results on page 265.
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CHAPTER 8 Customizing Your Modeling
Environment

PowerDesigner is highly customizable. You can modify its interface to suit your work habits, ,
set default naming conventions, change the appearance of object symbols, add new properties
to objects, and even create your own types of objects.

User Profiles
User profiles help you to standardize the look and feel of your models and to support
standards. Profiles allow you to group options and preferences together for sharing and reuse
across your organization. Various profiles are provided with PowerDesigner, and you can
create your own.

The various kinds of PowerDesigner options and preferences are stored in your model files
and/or in your Windows registry. User profiles can contain default values for:

• Display Preferences – [model or registry] to control the color, shape, size, etc. of your
diagram symbols and the information that is displayed upon them

• Model Options – [model only] to control naming conventions, case sensitivity, notation,
default values, etc.

• General Options – [registry only] to control dialog preferences, environment variables,
fonts, etc.

• Check Model options – [model only] to control which checks are applied, and which are
errors, warnings, etc.

• Other options – [registry only] such as the layout of toolbars and windows, favorite pages,
default columns for grids, etc.

User profiles can contain any number of default preferences and options, the application of
which is cumulative. Thus, if you:

1. Apply a user profile that directs that table symbols in the physical data model are drawn by
default in red, and that view symbols are drawn in blue (via display preferences)

2. Apply a second user profile that directs that table symbols are drawn in green.

The result will be that table symbols are drawn in green, and view symbols are drawn in blue.
You can, of course, override these default preferences and options locally in the model.

User profiles are PowerDesigner resource files, and so can be opened and edited in the
resource editor, but in general you will create and edit them by extracting preferences defined
in a model, or from your registry.
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Applying a User Profile
You can apply a user profile at any time. The defaults; preferences, and options contained
within the profile will overwrite the existing values for those defaults, preferences and
options, while leaving all others unchanged. Note that while general PowerDesigner options
take effect immediately, model options and display preferences only take effect when you
create a new model.

1. Select Tools > Apply User Profile to open the Apply User Profile dialog:

2. [optional] Click the Change User Profile Directory button, and browse to a folder where
you have saved user profiles. By default they are saved in the install_dir/Resource Files/
User Profiles directory.

3. Select a profile from the list and click OK.

The user profile is applied, and overwrites the defaults, preferences, and options contained
within it with the values it defines.

Creating a User Profile
You can create a user profile by copying an existing profile, or by copying values from an open
model or from your registry.

1. Select Tools > Resources > User Profiles to open the List of User Profiles:
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2. Click the New Button to open the New User Profile dialog:

3. Enter a name for your profile and select a source from which to copy from. You can choose
between:

• Another user profile – makes a copy of the existing profile.
• <Registry> - copies all your PowerDesigner defaults from your Windows registry.
• <Model> - opens the Model for User Profile dialog which allows you to specify the

preferences to copy from an open model (see Copying preferences from a model on
page 280).

4. Specify a name and a location to create the profile and click Save.

The user profile is created and opened for review in the resource editor.

Updating a User Profile
You can update a user profile by copying values from an existing profile, from an open model,
or from the registry.

1. Select Tools > Resources > User Profiles to open the List of User Profiles, select the
profile to update and click the Merge tool to open the Select User profiles to Merge dialog.

2. In the From field, select a source from which to copy from. You can choose between:

• Another user profile
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• <Registry> - copies all your PowerDesigner defaults from your Windows registry.
Note that model check options and generation options are not stored in the registry and
can only be extracted from a model or another user profile.

• <Model> - opens the Model for User Profile dialog which allows you to specify the
preferences to copy from an open model (see Copying preferences from a model on
page 280). Note that general options, and options relating to the PowerDesigner
interface (such as toolbar and window layout, favorite property sheet pages and grid
layouts) are not stored in models and can only be extracted from the registry or another
user profile.

3. Click OK to open the Merge window, which lets you review and approve each proposed
change before committing it. For detailed information about using this window, see 
Chapter 7, Comparing and Merging Models on page 259.

4. When you are satisfied, click OK to update the profile and return to the list.

Copying Preferences from a Model
When you choose to create or update a user profile by copying preferences from a model, you
open the Model for User Profile dialog:

For more information, see Creating a user profile on page 278 or Updating a user profile on
page 279.

You can to specify the following options and preferences to capture:

Option Description

Model Specifies the open model from which you will capture preferences.
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Option Description

Model Options Captures the model options from the specified model.

Check, generation,
and other options

Captures the check model, generation, and other options from the specified
model.

Diagram Display
Preferences

Captures the display preferences from the diagrams that you select in the tree
below. Note that, to avoid conflicts, you can only select one instance of each
diagram type. Thus, if your chosen model is an OOM, which contains two
class diagrams, selecting one class diagram will deselect the other.

Using the List of User Profiles
The List of User Profiles lists all the user profiles available to you. The following tools are
available above the list:

Tool Description

Properties – opens the selected profile in the resource editor.

New – creates a new profile. See Creating a user profile on page 278

Save – saves the selected profile.

Save All – saves all the profiles.

Path – allows you to specify a directory from which to populate the list.

Compare – opens the Compare window, which allows you to compare the structure of two
profiles.

Merge – allows you to update the selected profile with preferences from another profile, a
model, or the registry. See Updating a user profile on page 279

Apply to Registry – applies the selected profile to your registry, overwriting your previous
defaults and preferences. This has the same effect as selecting Tools > Apply User Profile
(see Applying a user profile on page 278).
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Reviewing and Editing User Profiles in the Resource Editor
You can open any user profile in the Resource Editor to review and edit it. In the following
example, the Corporate user profile contains display preferences for CDMs, LDMs, and
PDMs, along with a general option and some model options:

The profile root node has the following properties:

Property Description

Name/Code Specifies the name and code (used for scripting) for the profile.

File name [read-only] Specifies the path to the profile file.

Family Specifies the family in which the profile will appear in the Apply User Profile
window (see Applying a user profile on page 278) and if it is added to the Power-
Designer installer image. If no value is entered, the profile is added to the General
family.

Subfamily Specifies a subfamily within the profile family.

Since the registry key names and values are not necessarily easy to read, we recommend that
you restrict your edits in this environment to deleting unwanted defaults.
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To delete an item, simply right-click it and select Remove. You can always make additions or
adjustments to the values of user profiles by extracting them from models or other profiles.

Making Custom User Profiles Available in the PowerDesigner Installer
Once you have developed your own user profiles, you may want to add them to your
PowerDesigner install image in order to allow your users to install them when they install
PowerDesigner.

The user profiles that are installed with PowerDesigner are stored in the following directory on
the first install CD:

Setup/User Profiles

To include your profiles in the install, simply copy them to this directory in your install image.

For information about installing PowerDesigner, see the Installation Guide.

Guiding Model Creation through Categories and Templates
You can create model templates with predefined targets, extensions, and first diagrams to help
guide users through model creation. You can organize these templates in categories and share
them with your team, supplementing or even replacing the default New Model dialog with
these categories.

A model category set is a PowerDesigner resource file that contains one or more categories,
which in turn contain templates to guide users through model creation in the New Model
dialog.

Using categories and templates for model creation simplifies the model creation process by
preselecting appropriate targets, extension, and diagrams, and by hiding irrelevant choices
from users. You can create different category sets for different users so that, for example, data
architects will have different choices from business analysts when they open the New Model
dialog.

You can use model category sets in conjunction with resource sharing (see "Sharing Resources
in the Repository" in the Working with Repository Documents chapter of the Working with
the Repository manual) to ensure that everyone on your team is creating models using the
same centralized targets and extensions checked out automatically from the repository.

In the following example, the Information category is selected and provides eight templates to
choose from:
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Selecting a Model Category Set to Display in the New Model Dialog
The model category set you select in the Model Creation general options will be displayed in
the New Model window.

1. Select Tools > General Options, and click the Model Creation category in the left hand
pane.
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2. Verify that the Enable categories check box is selected, and select the category set you
want to display from the Default category set list.

3. [optional] Click the Path tool to the right of this field to browse to another folder
containing model category sets or the Properties tool to open the currently-selected set in
the Resource Editor.

4. Click OK to close the General Options dialog.
The selected category set and the templates it contains will be displayed in the New Model
dialog next time you open it.

Creating a Model Category Set
You can create as many different model category sets as you need, creating different sets for
different types of users, for example.

1. Select Tools > Resources > Model Category Sets to open the List of Model Category
Sets.

2. Click the New tool to open the New Model Category Set dialog.

3. Enter a name for your model category set, and select a source to copy it from. You can
choose between:
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• <Default template> – creates an empty set that you complete by adding categories and
templates.

• Another model category set – makes a copy of an existing set that you can edit as
necessary.

4. Specify a name and a location to create the set and click Save.

The model category set is created and opened for review in the Resource Editor.

5. For each category that you need, right-click the root node, and select New. In the right-
hand pane, enter a name for the category and, optionally, click the Browse for icon tool to
change the default icon.

Note: You can reorder the categories if necessary by drag and drop.

6. When you have created your categories, you add templates to them by right-clicking the
category and selecting New and then one of the following:

• Model - creates a simple model template that can specify a default target, extensions,
and an empty first diagram (see Adding a Model Template to a Model Category Set on
page 287).

• Model from Template - which points to an actual model file that, in addition to
specifying a target and extensions, can contain multiple diagrams, display preferences,
general and model options, etc (see Adding a Model from Template to a Model
Category Set on page 288)

7. When you have finished creating categories and templates, click OK to close the resource
editor and click the Save tool in the List of Model Category Sets to save your edits.
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You can test your category set by selecting it in the General Options dialog (see Selecting a
Model Category Set to Display in the New Model Dialog on page 284) and selecting File >
New Model.

Adding a Model Template to a Model Category Set
Model templates are simple templates that can specify a default target, extensions, and an
empty first diagram.

1. Right-click the category to which you want to add the template, and select New >
Model.

2. On the General tab, enter a template name and select a model and diagram type.

3. [optional, for model types with targets] Specify a target (DBMS, object or process
language, etc). If you select None, then the user can select any available target language in
the New Model dialog.

4. [optional] On the Icon tab, click the Browse for icon tool to change the default template
icon.

5. [optional] On the Extended Model Definitions tab, click the Select Extended Model
Definitions tool to attach one or more extended model definitions to the model. Select one
or more XEMs to attach to your model, and select one of the following radio buttons:

• Share – creates a link to the XEM file. Any changes made to the extended model
definition will be shared.

• Copy – creates a copy of the XEM private to the model. Any changes made to the XEM
affect only the current model, with which it is saved.

6. [optional] Select the Allow additional extensions at model creation check box if you
want to allow users to attach additional XEMs to those you have specified. The Extensions
button in the New Model dialog is not available if you do not select this check box.

In the following example, the Physical Data template is specified to create a Physical Data
Model with a physical diagram, and since no DBMS is specified, the user will be able to
choose one at model creation time:
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Adding a Model from Template to a Model Category Set
Models from templates are templates that point to existing model files that, in addition to
specifying a target and extensions, can contain multiple diagrams, display preferences,
general and model options, etc.

In order to add a model from template to a category, you must have a model file that contains
all the appropriate parameters ready to point to.

1. Right-click the category to which you want to add the template, and select New > Model
from Template.

2. On the General tab, enter a template name and click the Select File tool to the right of the
Model file field to browse to and select the model file to use as the template.

3. [optional] On the Icon tab, click the Browse for icon tool to change the default template
icon.

In the following example, the Data Flow Diagram template is specified to create a
Business Process Model from an existing dfd.bpm model, and will inherit its pre-
configured options, preferences, extensions, and objects:
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Display Preferences
You can set default display preferences for the symbols in your model. Using the Display
Preferences dialog box you can:

• Define preferences for the current diagram
• Apply display preferences to a selection of diagrams
• Restore default display preferences
• Set new default display preferences

1. Open the diagram that contains the objects for which you want to change the display
preferences. Select Tools > Display Preferences to open the Display Preferences dialog
box:
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2. Select categories in the left hand panel and set preferences in the right-hand panel. There
are three broad categories of display preferences:

• General display preferences – which control the format of the diagram itself (see 
General display preferences on page 292)

• Content display preferences – which control what information is displayed on an
object's symbol (see Content display preferences on page 294)

• Format display preferences – which control the look (color, line style, font, and others)
of the symbol (see Format display preferences on page 301)

On each of the pages, you can, at any time click:

• the Default button, which reverts any changes to their default values
• the Set As Default button, which assigns the current values to defaults.

3. [optional] Click the Apply To button to open the Select Diagrams dialog box:
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Select the checkboxes of the diagrams to which you want to apply your changes and click
OK. You will be asked whether you want to apply your changes to all the symbols in the
selected diagrams. If you click:

• Yes – All existing and new symbols will reflect your changes to the Format, General
and Content display preferences.

• No – New symbols only will reflect your changes. Only the General and Content
display preferences are applied to existing symbols. The Format changes are canceled.

• Cancel – Your changes will not affect any symbols in any diagrams except the current
one.

In each case, you return to the Display Preferences dialog box.

4. On the Display Preferences dialog box, click OK. The Changing Formats dialog box will
open:

The choices in this dialog apply only to the present diagram and will not override your
choices made in the Select Diagrams dialog box.
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5. Click OK to apply your changes

General Display Preferences
The General category allows you to control the general look of the diagram.

You can set the following preferences:

Property Description

Window color Sets the background color for the diagram.

Unit Specifies the measurement unit for symbol size. You can choose between inches,
millimeters, and pixels.
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Property Description

Snap to grid Automatically aligns all new objects that you create in the diagram window to the
anchor points of a grid.

You can specify the size and visibility of the grid with the Display and Size
options.

All existing objects are aligned automatically when you move them within the
diagram.

Display Activates a grid in the background of the diagram.

Size Determines the number of anchor points per square inch in the grid.

Show page de-
limiter

Shows limit of pages on the diagram background

Constrain labels Limits the distance to which you can displace labels from link objects. Uncheck
this option to be able to move link labels anywhere in your diagram.

Organization
unit swimlane

[diagrams with swimlanes only] Specifies that organization units will be displayed
as swimlanes.

When this options is selected, you may also specify the direction of the swimlanes,
in choosing between Horizontal and Vertical.

Darken Child
Symbol

[diagrams with composite symbols only] Specifies that the symbols of child ob-
jects are darker than those of their parents in order to make them stand out more.

Orientation [diagrams with tree structures only] Specifies the direction in which branches will
expand. You can choose between Horizontal and Vertical.
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Content Display Preferences
The Content category allows you to control what information is displayed in object symbols.

Content Category

By clicking on the category itself, you can set the following preferences:

Preference Description

Name Splitting Controls the display of names on symbols. You can choose between:

• None

• Truncation - Truncates name (or code), to the specified length

• Word wrapping - Wraps name and code text onto additional lines (up to
the specified length) after the specified wrap character (up to the indi-
cated length)

Wrap characters Specifies a set of characters after which word wrapping is possible.
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Preference Description

Display overlay for
non-local objects

Enables the display of an overlay on objects being reused in the same con-
tainer but with distinct location. For instance an activity can be reused under
another activity of the same package or an inner class can be referenced by
another class of the same package. The overlay is a mirror image of the
shortcut overlay (see Shortcuts on page 355).

Objects

You can modify the information displayed on each type of object by selecting it in the list.

Choose the information that you want to display by selecting the appropriate checkboxes.

Customizable Display Preferences

The display preferences of many objects can be customized so that practically any of their
properties can be displayed on their diagram symbol, with the following exceptions:

• multi-line fields and collections (such as table columns or class operations) cannot be
displayed in icon mode or on link symbols

The following special preferences may be available for these objects:
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Preference Description

Default display mode Specifies the way the object will be displayed by default:

• Icon

• Detail – a rectangle permitting the display of additional information

This preference is only available if the object supports both modes.

Detail mode Specifies the additional information that will be displayed in Detail mode:

• Comment – from the General tab of the object's property sheet

• [collections] – for example, sub-sites, applications, etc.

• Composite view - displays child objects as symbols within the object
symbol. If this option is present, it cannot (unlike the other preferences)
be removed from this screen

Customizing Content Display Preferences
If an object supports customizing the information that you can display on its symbol, an
Advanced button is available in the bottom-right corner of its Content Display Preferences
page. Click this button to go to the Customize Content window, which allows you to choose
and reorder the information that is available for display in the Content window.

The list in the left hand pane shows the properties that are currently available to display on the
symbol in the Display Preferences dialog. In the case of link symbols the list contains three
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sublists, Source, Center, and Destination, which allow your to specify different content to
display on each of these parts of the link symbol.

You can drag and drop items to reorder the list, and use the following tools to modify it:

Tool Description

Add Attributes – allows you to select additional attributes to add to the list.

Add Collections – allows you to select additional collections (such as table columns, class
operations, etc) to add to the list.

Add Separator Line – inserts a separator line after the item selected in the list.

Add Exclusive Choice - inserts an item under which you can group properties from which
your users will choose one to display.

Delete – removes the selected item from the list.

Select the Small icon check box to display a small object icon in the top-left corner of the
symbol in detail mode.

Configuring Attributes

Click on an attribute in the list to set the following options:

• Label - Specify a label to use in the Display Preferences dialog in place of the attribute's
name.

• Prefix and Suffix - Add a prefix and/or suffix to the value of the attribute (text items only).
• Alignment - Specify the alignment of the text (unlimited text items only).
• True and False - Specify a value to display for true and false (booleans only) For example,

for a boolean attribute, "Annotated", you could specify "Annotated" and "Not Annotated"
for true and false. By default, boolean properties are displayed if they are true and do not
appear if they are false.

• Mandatory - Specify that it is mandatory. Mandatory properties are always displayed on
the symbol, and are not available for deselection in the Display Preferences dialog.
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Configuring Collections

Click on a collection in the list to:

• Label - Specify a label to use in the Display Preferences dialog in place of the collection's
name.

• List columns - Specify the properties displayed for each object in the collection. Click the
Select tool beside the List columns field to select attributes for display.

• Filters - Specify one or more filters to offer as options when choosing to display the
collection. Click the Select tool beside the Filters columns field to open the Define
Available Collection Filters dialog, enter a name for the filter and then click the ellipsis
button in the Filter Expression column to define the parameters of the filter. You can
specify as many filters as you need. They will be available for selection in the Display
Preferences dialog in the form of radio buttons under the checkbox to select the collection

• Mandatory - Specify that it is mandatory. Mandatory properties are always displayed on
the symbol, and are not available for deselection in the Display Preferences dialog.

• Limit number of lines - Provide a field allowing the user to limit the display of collection
members to a number that they enter.
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Configuring "Exclusive Choices"

Click on an exclusive choice in the list to:

• Label - Specify a label to use in the Display Preferences dialog in place of the collection's
name.

• Display - Specify whether the choice displays as horizontal or vertical radio buttons or as a
combo list.

• Mandatory - Specify that it is mandatory. Mandatory properties are always displayed on
the symbol, and are not available for deselection in the Display Preferences dialog.
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Format Display Preferences
The Format category allows you to control the look of object symbols.

By clicking on the category itself, you can set the following preferences:

Preference Description

Default Size Horizontal and vertical size of a symbol containing text (measured in units of
1/7200 of an inch)

Note: The Preview box displays the format of the new objects you are going to create not the
format of existing objets. In the case of existing objects, only the attributes modified in the
display preferences are modified in the diagram

General Options
You can control the look and behavior of the PowerDesigner interface through the general
options, the values for which are saved in the registry of your local machine.

To set general options, select Tools > General Options. The following options are available
under the General category:
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Option Description

Autosave Save recovery backup file every x minutes - Instructs PowerDesigner to save
changes to all open models to a recovery backup file at the specified interval.
Enabling this option provides you with a recovery option if PowerDesigner or
your computer crash before you have had a chance to save your changes.

The save will take place after the interval has passed, but only when Power-
Designer is idle for more than ten seconds. Note that saving large or multiple
models may take several seconds, and that PowerDesigner will not be respon-
sive while it is performing the save.

In the event that your modeling session exits abnormally, when next you open
PowerDesigner you will be invited to restore your unsaved models. You can
choose:

• Yes - to open the recovered models in the Browser allowing you to review
and save or delete them as necessary.

• No - to postpone reviewing the recovered models until the next time you
open PowerDesigner.

Note: This option is not supported for the PowerDesigner plugins for Eclipse
and Visual Studio.

Delete Confirm object deletion - Controls the display of a confirmation dialog box
when you delete an object. If you disable this option, the confirmation dialog
will no longer be shown and the default behavior is as follows:

• Deleting an object symbol - the symbol only is deleted
• Deleting an object in the browser - the object, any sub-objects it contains,

and any associated diagram symbols are deleted.

You can delete any object without confirmation at any time by selecting its
symbol in a diagram and pressing Shift+Delete

For more information, see Deleting Objects on page 130.

Startup Auto-reload last workspace - Opens the last-edited workspace when you
launch PowerDesigner. If this option is unchecked, PowerDesigner will open
with an empty workspace.

Show welcome page - Displays the Welcome Page when starting PowerDe-
signer. If you select the Do not show this page again check box in the Welcome
page, the Show Welcome page option is deselected.
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Option Description

Browser Browser drag and drop: Default action - Specify the default result of drag-
ging and dropping an object (without any modifier key) in the Browser. You can
choose from the following:

• Move (Shift) – The object is displaced to the new location (parent object,
package, model, etc).

• Copy (Ctrl) – A copy of the object is created in the new location.
• Create Shortcut (Ctrl + shift) – A shortcut to the object is created in the

new location.
• Create replica (Alt + shift) – A replica of the object is created in the new

location.

The modifier keys given after the option are valid no matter what the default
behavior.

Output log Log path - Specifies the path to the log file where PowerDesigner records all of
its outputs.

Graphical tool be-
havior

Edit in place after creation - Allows you to directly modify the name of an
object from the object symbol in the diagram without opening its property sheet
whenever you create an object with the palette

Sort Natural Sort - Treats numbers numerically when sorting objects in the
Browser. For example, a naturally sorted list of tables would have the order:
Table_1, Table_3, Table_12, Table_20.

Dialog Box General Options
To set general options for dialog boxes, select Tools > General Options, and select the Dialog
category in the left hand pane.

The following options are available:

Operating Modes

Option Description

Auto Commit Specifies that any change made in a property sheet is automatically committed in
the object definition. You cancel a change by using the Undo feature.

If this option is disabled, you must click Apply or OK to commit your changes.
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Option Description

Name to Code
mirroring

Automatically keeps the code of an object synchronized with its name via the
application of any naming conventions (see Naming Conventions on page 315).
To disable Name to Code mirroring on an individual object, click to deselect the
equal sign button to the right of the code field.

This option is independent of (but required by) the Enable name/code conver-
sions model option, which permits more complex transformations on codes via
controls the application of conversion scripts (see Name and Code Conversion
Scripts on page 317).

Property Sheets

In PowerDesigner, property sheets appear by default with a certain size and a series of tabs in
the upper part of the dialog box. The following options are available for property sheets:

Option Description

Keep size Preserves the customized size you have defined

Keep last tab Opens the property sheet to the last selected tab

Open mode Controls how property sheets are opened. You can choose between:

• Open each object in the same property sheet

• Open each object in its own property sheet

Tabs mode Controls the display of tabs. You can choose between:

• Tabs on one row - Aligns all tabs on a single line with arrow buttons < and >
for browsing

• Tabs on several rows - Displays tabs on two lines, their size corresponding to
the length of their title.

Shortcut Property Sheets

The following options are available:

Option Description

Internal Shortcut Controls whether double-clicking an internal shortcut opens the property sheet
for the shortcut or for the target object.

You can switch from one mode to the other by pressing the shift key while
opening the property sheet. If the target object cannot be found (target model is
closed for example), the shortcut property sheet automatically opens.
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Option Description

External Shortcut Controls whether double-clicking an external shortcut opens the property sheet
for the shortcut or for the target object.

For more information, see Shortcuts on page 355.

Object Lists

The following options are available:

Option Description

Auto-insert rows Specifies that a new item is created automatically in a list when you click an
empty row

Use default name Specifies that new items are given default names upon creation, allowing you to
create multiple new objects without having to supply names or other properties.

Specifying Text Editors
When you are using PowerDesigner, you will need to edit such things as descriptions and
annotations for objects, or generated scripts like SQL in the PDM or Java in the OOM

By default, all files are edited using PowerDesigner's internal editor. You can define an
external text editor to launch automatically for editing various kinds of objects. You can define
as many text editors as you need, and the same file extension can have several text editors
allocated, with the first listed acting as the default.

1. Select Tools > General Options and click the Editors category in the left-hand pane.

2. Click the Insert a Row tool, and enter a file extension (such as .DOC, .RTF, .TXT, .XLS) in
the Extension column.

The Editor Name and Editor Command columns are both set to <internal> to indicate that
the internal PowerDesigner editor will be used to edit files with this extension.

3. [optional] Enter an editor name (such as MS Word, Notepad, MS Excel) in the Editor
Name column, and enter an editor command (such as winword.exe) in the Editor
Command column. You can click the ellipsis button in this field to browse to the relevant
directory.

4. Click OK to close the dialog box.
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Defining Environment Variables
The following variables are created when you install PowerDesigner:

Variable Description Default

CMD Windows command interpreter command.com or
cmd.exe

HOME Variable defining the default home directory —

J2EEVERIF Batch program for verifying if the deployment jar for an
EJB is correct

verifier.bat

JAR Command for archiving java files jar.exe

JAVA Command for running JAVA programs java.exe

JAVAC Command for compiling JAVA source files javac.exe

JAVADOC Command for defining JAVA doc comments javadoc.exe

You can edit these variables and add your own.

1. Select Tools > General Options, and click the Variables category in the left-hand pane.

2. Click in the row of an existing variable in order to edit its values, or click the Add a Row
tool to create a new variable.

3. Click OK to close the dialog box.

Variables defined here are used in commands in the Generation\Commands sub-category of
the JAVA object language, and can be used in the Generation Template Language.

The syntax for using these variables in GTL requires that you add $ before the variable name
within the % signs, for example %$CMD%.

For more information about the GTL, see the Customizing Generation with GTL chapter of
the Customizing and Extending PowerDesigner manual.

Defining Named Paths
When you add a document or a model to the workspace, create an external shortcut, or perform
various other file operations, PowerDesigner saves the paths to these external files in the
workspace or model files.

However, in a team environment, when people exchange model files, the links may be broken
when one user opens the file of another .

To solve this potential problem, you can define named paths in PowerDesigner. A team leader
can define a list of names corresponding to shared resource files and specify a folder structure.
Then each team member recreates the named paths on his/her workstation.
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PowerDesigner provides a number of predefined named paths, each of which is preceded by
an underscore:

Name Path

_DBMS Folder where DBMS definition files are stored

_EXAMPLES Folder where the demo examples are stored

_HOME PowerDesigner installation folder

_LIBRARY Folder where object libraries are stored

_OBJLANG Folder where object language definition files are stored

_PRCSLANG Folder where process language definition files are stored

_RTPLANG Folder where report language definition files are stored

_XEM Folder where extended model definition files are stored

_XMLLANG Folder where XML language definition files are stored

_HOME Predefined Named Path

_HOME is a very useful named path that facilitates the installation of your add-ins without
having to modify your XEM or your XML or ActiveX add-ins commands.

For example: %_HOME%\add-ins\SpellChecker\SpellCheckAddIn.dll

By default, the path of a predefined named path corresponds to the installation path you have
selected. If you use files proceeding from another directory, the path of the predefined named
paths is not automatically modified. You have to carry out this change manually.

You should not modify the name of a predefined named path. If you do so, the predefined
named path is preserved in the list and a new named path is created with the name and path of
the modified predefined named path.

If you modify the path of a predefined named path and want to cancel the change, you have to
select the predefined named path in the list, delete it and click OK in the General Options
dialog box. The next time you open the Named Path page in the General Options dialog box,
the deleted predefined named path is displayed in the list with the default installation path.

Saving a File

When you save a PowerDesigner model or workspace, the name of a named path is substituted
for the actual path . For example, if the HOME named path is defined as:

HOME = c:\Program Files\Sybase

And you have the following path in your model:

c:\Program Files\Sybase\PowerDesigner\tempo_samples
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When you save this file, the path will be saved as:

%HOME%\PowerDesigner\tempo_samples

Opening a File

When you open a file, named paths are replaced by the value of that path in the local
environment. For example:

%HOME%\PowerDesigner\tempo_samples

becomes:

c:\Program Files\Sybase\PowerDesigner\tempo_samples

If you open a file containing a named path not defined on the current machine, the Unresolved
Named Path dialog box open, offering you the following options:

• Ignore the named path and keep the file name unresolved - The link between files is broken
and you may have update problems.

• Define a new named path ... - Allows you to define the path on your machine.
• Browse another existing variable to replace with – Allows you to resolve the path using one

of your existing names paths.
• Directly browse the target file – Allows you to browse for another target file. The selected

file will replace the file you were trying to open

Creating a Named Path
You can create additional named paths. Your team should agree on the names of any named
paths to be created.

1. Select Tools > General Options, and then click the Named Paths category.

2. Click the Add a Row tool and enter a name and a path for the named path.
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3. Click OK.

Defining Default Interface Fonts
You can modify the default font proposed for:

• User interface (lists)
• Code editor (SQL preview)
• RTF editor (description, annotation)

1. Select Tools > General Options, and then click the Fonts category.

2. Specify the appropriate font format options.
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3. Click OK.

Managing Add-Ins
An add-in is a module that adds a specific feature or service to PowerDesigner. PowerDesigner
provides several add-ins by default.

Add-in Description

Microsoft Analysis
Services

Imports multidimensional data from MS SQL Server into a PDM. Microsoft
Analysis Services must be installed on the current machine.

Microsoft Word Import
Export

Imports and exports MS Word documents to and from requirements models.

.Net Reverse Engineer-
ing

Reverse engineers VB .Net and C# source files.

Spell Checker Uses the MS Word spell checker for PowerDesigner object names, codes,
comments, descriptions, and annotations

XML Validation Checks that an XML document conforms to the current schema in the XML
model. This add-in requires MSXML 4.0

You enable an add-in by selecting its checkbox.
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Add-ins installed with PowerDesigner are called system add-ins, and are declared in a Local
Machine Registry key. If you modify system add-in properties, you can click the Reset Values
For System Add-In tool to recover add-in parameters as they are registered in the Local
Machine key.

You can create your own add-ins. User-defined add-ins are called user add-ins, they are
declared in a Current User Registry key.

.Net Reverse Engineering

In order to use the .Net binary reverse, you need to register the application reverseapp.exe.

.Net Framework 1.1 must be installed. You must use the regasm.exe program located in the
Windows directory under the Microsoft.NET\Framework folder. The command line is the
following:

regasm /codebase reverseapp.exe

The .net Assemblies command is displayed in the File > Reverse engineer menu. The
executable can also be used separately from PowerDesigner.

ReverseApp -c|-v [-l ] [-r ] [-g]

CHAPTER 8: Customizing Your Modeling Environment

Core Features Guide    311



-l: followed by library file name, this option can be repeated several times.

-r: recursively forces to reverse engineer parameter type and return type.

-g: does not display reverse engineering dialog box and directly proceeds with reverse
engineering.

-c: reverse engineers C# model.

-v: reverse engineers VB.Net model.

ReverseApp will retrieve the namespaces, classes, and other objects defined in these
assemblies and create a corresponding Object-Oriented Model.

Declaring Your Own Add-In
You can create your own XML or ActiveX add-ins by declaring and enabling them in the
Add-Ins page of the General Options dialog.

1. Select Tools > General Options, and then click the Add-Ins category.

2. Click the Add New XML Add-In or Add New ActiveX Add-In tool.

An ActiveX add-in implements an interface that defines methods, which are invoked by
PowerDesigner in order to dialog with menus and execute commands that are defined by
the ActiveX. An XML add-in uses a declarative program with a language linked to
an .EXE file or a VB script.

3. Enter the name of your add-in in the Name box and click the Select File tool to the right of
the File name field to browse to the .xml, .dll, or .exe file.

4. [ActiveX only] Enter the name of the ActiveX implementation class in the Class field.
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5. Click OK.

For more information about the add-in creation procedure, see "Customizing
PowerDesigner Menus Using Add-Ins" in the Scripting PowerDesigner chapter of
Customizing and Extending PowerDesigner.

Spell Checking
Spell checking in PowerDesigner is only available if you have MS Word 2000 or higher
installed on your machine, and if your system code page is consistent with the model
language. For example, for the spell checker to work properly on a Chinese model, your
system code page should be Chinese.

Enabling the Spell Checker
The spell checker is a PowerDesigner add-in that needs to be enabled to work properly.

1. Select Tools > General Options to open the General Options dialog box.

2. Click the Add-Ins node in the Category tree view and select the Spell Checker checkbox.

3. Click OK to return to the model diagram.

4. Select Tools > Spell Checking Options to open the Spell Checking Options dialog box.
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5. Select the properties of model objects for which you want to check the spelling. If you
select Check sub-objects, then all the child objects of any object you check will also be
checked.

6. Select the language of your model in the Dictionary Language list, and then click OK to
return to the model diagram.

Using the Spell Checker
You can use the spell checker at any time.

1. Right-click an object or a model node and select Spell Check in the contextual menu.

Spell checking starts. If an error is found the Spell Checking dialog box opens.

2. For each error, you can:

• Click Change to accept the suggested replacement word
• Type your own replacement and click Change
• Click Change All to apply the change to the entire object or model
• Click Add to add the word to your custom dictionary

A message is displayed to inform you that spell checking is successful.

Customizing the New Model Dialog
You can control the format of the New Model dialog by hiding some of the methods of model
creation.

To set general options for model creation, select Tools > General Options, and click the
Model Creation category in the left hand pane. The following options are available:

Option Description

Enable Categories Enables the display of the Categories button in the New Model
dialog, which lets you create models from predefined templates.
Select the model category set to use in the Default category set
list. If no valid model category set is selected then the Categories
button will not be available.

Click the Select Path tool to the right of this field to browse to
another folder containing model category sets or click the Prop-
erties tool to open the currently-selected set in the Resource
Editor. For more information about category sets, see Guiding
Model Creation through Categories and Templates on page
283.

Enable Model Types Enables the display of the Model types button in the New Model
dialog, which lets you create models from the classic list of
model types.
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Option Description

Enable model template files Enables the display of the Template files button in the New
Model dialog, which lets you create models from model tem-
plates. If no valid template directory is selected then the Tem-
plates button will not be available.

Click the Select Path tool to the right of this field to browse to
another folder containing model templates. For more informa-
tion about model templates, see Model Templates on page 97.

For information about using the New Model dialog, see Creating a Model on page 12.

Naming Conventions
You can use naming conventions to specify a case, maximum length, and valid characters for
object names and codes, and to invoke conversion scripts and conversion lists to generate
appropriate object codes from names (or names from codes).

To set naming conventions to control the names and codes of all objects, select Tools > Model
Options and click on the Naming Convention node. To set naming conventions for a
particular kind of object, select its node under the Naming Convention node.
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The following options are available on the Naming Convention node only and apply to all
objects:

Option Description

Display Specifies whether object names or codes are displayed in the Browser and on
diagram symbols. You can override this setting for diagram symbols by setting
the appropriate display preferences (see Display Preferences on page 289).

Enable name/
code conversions

By default, when you enter an object name, the object code is autogenerated by
applying the naming conventions specified on the Code tab below. Select this
option to additionally apply the conversion scripts and conversion tables speci-
fied on the Name to Code tab (see Name and Code Conversion Scripts on page
317).

You can decouple an object's code from its name by clicking to release the =
button to the right of the Code field in the object property sheet and entering your
own code (which will still be subject to the naming conventions). You can au-
togenerate a name from a code by clicking the = button to the right of the Name
field.

The following options are available on each of the Name and Code tabs of the Naming
Convention node (where they apply to all objects) and on each of the sub-nodes (where they
apply to the selected object):

Option Description

Naming Template Specifies a naming template to supply the naming conventions for the name or
code. A naming template contains the same fields as those on this tab, but in a
format that can be reused for other objects (see Creating a Naming Template on
page 317). Click the ellipsis button to the right of this field to open the List of
Naming Templates or click the Properties tool to view and edit the selected
template.

Maximum Length Specifies the maximum number of characters permitted in a name or code. In a
PDM, this maximum may be set here and/or in the DBMS definition file. If both
are specified, then PowerDesigner applies the stricter constraint. For example, in
the case where you set 128 here and the DBMS file specifies 30, PowerDesigner
will apply the 30 character limit.

Character Case Specifies the case to apply to the name or code. You can choose between:

• UPPERCASE
• lowercase
• Mixed CASe
• Title Case (Name only)
• UpperCamelCase (Code only)
• lowerCamelCase (Code only)
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Option Description

Valid Characters Specifies the list of characters permitted in the name or code. Character ranges
are entered between single quotes and separated by a dash. Individual or multiple
characters are entered between double quotes. Each valid item is separated by a
comma. By default, PowerDesigner allows the following valid characters for
codes:

'a'-'z','A'-'Z','0'-'9',"_"

Select the All valid check box to the right of this field to permit any character.

Invalid Charac-
ters

Specifies the list of characters not permitted in the name or code. By default,
PowerDesigner excludes the following characters for names:

"+-*/\.,!:;"

Select the No accents check box to the right of this field to remove accents from
accented characters.

Default Character Specifies the character that is used to replace any invalid characters that are
entered.

Creating a Naming Template
You can create a naming template to specify naming conventions for names or codes and reuse
it for multiple types of objects.

1. Select Tools > Model Options and click the Naming Convention node in the Category
tree.

2. Click the Ellipsis button to the right of the Naming Template field to open the List of
Naming Templates.

3. Click the Add a Row button and enter a name for the new naming template.

4. Click the Properties tool to open the template property sheet, complete all the appropriate
properties (see Naming Conventions on page 315), and then click OK to return to the list.

5. Click OK to return to the Model Options page.

Your template is now available for selection in the Naming Template field. Click the
Properties tool to the right of this field to modify the selected template.

Name and Code Conversion Scripts
Conversion scripts permit more complex transformations, including adding prefixes or
suffixes and the use of conversion tables. You specify the script on the Name to Code or Code
to Name tab depending on which direction you want to perform the conversion.

Note: To enable the use of your conversion script, you must select the Enable name/code
conversions check box in the upper part of the Naming Convention page of the Model
Options dialog.
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The following options are available on each of these tabs:
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Option Description

Conversion script The default Name to Code conversion script is:

.convert_name(%Name%,"_")

This script takes the value of the Name field (represented by the GTL variable
%Name%) and generates a Code by replacing any non alpha-numeric characters
with an underscore.

It also calls a conversion table (if one is selected in the Conversion table field) to
perform conversions on specific strings encountered in the name or code.

You can modify the conversion script as necessary. For example, to insert the
prefix tbl_ before the code of each table, use the following script:

.convert_name(tbl_%Name%,"_")

If the stdnames conversion table is selected then, for a table with the name
Customer, PowerDesigner will automatically provide a code tbl_CUST.

You can enter any valid GTL code (including macros such as .fore-
ach_part, .lowercase, .uppercase, .replace, and .de-
lete), but only the .convert_name and .convert_code macros
will call a conversion table if one is selected.

For detailed information about GTL, see Chapter 4, Customizing Generation
with GTL in Customizing and Extending PowerDesigner .

Conversion table Specifies the conversion table to use to perform conversions on specific strings
encountered in the name or code (see Creating a Conversion Table on page
320).

PowerDesigner provides an example conversion table called
stdnames.csv. For example, an object name Customer_1 would be
transformed into the object code CUST_1 if stdnames was selected.

Apply name to
code conversion/
Apply code to
name conversion
to all objects

Applies the conversion script (and conversion table) when you click OK:

• To synchronized objects - those objects in which the object code is presently
synchronized with the name.

• To all objects - all objects in the model regardless of whether the object name
is currently synchronized with the name.

The option on the Code to Name tab will always apply your changes to all
objects in the model.

Note: When generating one model from another, name to code conversion can be used to
provide appropriate codes for the target model objects. For more information, see the Convert
Names into Codes options on the Model Generation Options Window Detail Tab on page
339).
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Creating a Conversion Table
Conversion tables are .csv files containing a list of strings that may appear in object names
matched with equivalent (generally shorter) strings with which to replace them when
generating object codes.

For example, each instance of the word customer could be converted to cust. To review
the example conversion table provided with PowerDesigner navigate to and open
install_dir/Resource Files/Conversion Tables/stdnames.csv.

1. Select Tools > Resources > Conversion Tables to open the List of Conversion Tables.

To review an existing conversion table, select it in the list and click the Properties tool.

2. Click the New tool, enter a name and click Save to create the file and open the Conversion
Table dialog.

3. Click the Add a Row tool and then enter a name and the code into which you want to
convert it:

You can create as many conversion Name-Code pairs as required. The values in these
columns are not case-sensitive.

Note: It may be that several different names are converted the same code. For example,
client and customer may both be converted to CUST. If a table containing these lines
were used to convert codes to names, then the first value encountered in the Name column
is always used and there is a risk that multiple objects will be given the same name.

4. Click OK to return to the list of conversion tables, and then click Close to return to your
model.

Your conversion table is now available to be selected in the Model Options dialog.
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.convert_name and .convert_code Macros
These macros convert the object name to its code (or vice versa) and can search for and apply
values found in an associated conversion table.

Use the following syntax to convert a name to a code:

.convert_name (expression[,"separator"[,"separator_pattern"],case])

Use the following syntax to convert a code to a name:

.convert_code (expression[,"separator"[,"separator_pattern"]])

The following parameters are available:

Parameter Description

expression Specifies the text to be converted. For .convert_name, this is generally the %Name
% variable and may include a suffix or prefix.

Type: Simple template

separator [optional] Character generated each time a separator declared in pattern-separator
is found in the code. For example, "_" (underscore).

Type: Text

pattern-separa-
tor

[optional] Declaration of the different separators likely to exist in a code, and which
will be replaced by separator. You can declare several separators, for example "_ "
and "-"

Type: Text

case [optional for .convert_name only] Specifies the case into which to convert
the code. You can choose between:

• firstLowerWord - First word in lowercase, first letters of subsequent
words in uppercase

• FirstUpperChar - First character of all words in uppercase

• lower_case - All words in lowercase and separated by an underscore

• UPPER_CASE - All words in uppercase and separated by an underscore

In the following example, the .convert_name macro will convert a class name
Corporate Customer into clsCorporateCust if the stdnames conversion table
is selected:
.convert_name (cls_%Name%[,,,firstLowerWord])
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Windows
The PowerDesigner main window is divided into different windows with independent
behavior.

In the upper part of the window, you can see the PowerDesigner general title bar and the menu
bar. Below the general menus, the standard toolbar displays tools for carrying out standard
operations such as Open, Save or Undo.

Two dockable windows are displayed by default when you open PowerDesigner: the Browser
on the left and the Output pane at the bottom.

On the right hand side, the canvas is empty upon opening. This area is used to display the
different MDI child windows.

You can customize the PowerDesigner environment by docking windows in the interface.
Dockable windows are windows that align themselves with the edge of another interface
element, typically a window or a pane.

There are three dockable windows in the PowerDesigner interface:
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Window Purpose

Browser Provides a hierarchical view of the contents of the workspace

Output pane Displays PowerDesigner messages during check model, generation, reverse op-
erations, or script execution

Result List Displays result lists for a Find or a Check Model operation

Docking a Window
You can dock a specific window in a chosen location of the main window.

1. Click the window title bar and keep the mouse button pressed.

2. Drag the selected window to another location in the main window.

If you drag the window close to another interface element, the dockable window automatically
aligns itself with the edge of the closest interface element.

If you drag the window anywhere in the work environment, the window is resized and displays
a title.

Disabling the Docking Feature
You can disable the docking feature.
Right-click the dockable window background and deselect the Docking View command.

The window becomes an MDI window.

Note: If you want to move a window in the PowerDesigner environment without using the
docking feature you have to press ctrl while you drag the window.

Hiding a Docking Window
You can hide a docking window.
Click the X button in the window title bar.

Restoring a Window
You can restore a window that is no longer displayed.
Select View > Browser.

or

Select View > Output.

or

Select View > Result List.
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Toolbars
Toolbars are designed to provide quick access to specific menu commands and to ease creation
of objects related to a target language.

By default, the Standard toolbar is displayed when you start PowerDesigner for the first time.
You can display more toolbars in the interface, this is saved in the registry.

Creating a Toolbar
You can create new toolbars in the PowerDesigner environment.

1. Select Tools > Customize Toolbars to display the Toolbars dialog box.

2. Click the New button to display the New Toolbar dialog box.

3. Type a name in the Toolbar Name box.

4. Click OK.

The new toolbar is displayed in the list of toolbars, it is empty.

5. Select the new toolbar in the Toolbars list and click Customize to display the Customize
Toolbars dialog box.

6. Select a menu category in the Categories pane.

The tools corresponding to the commands of the menu appear in the right pane of the
window with a description in the lower part of the window.
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7. Select the tools you want to add, drag them to the new toolbar, and release the mouse
button.

The tools are inserted into the new toolbar.

Note: To delete a tool in a toolbar, you must be in Customize mode, then right-click the
tool to be deleted and select Delete from the contextual menu.

8. Click Close in each of the dialog boxes.

Customizing a Toolbar
You can customize the PowerDesigner toolbars according to your needs.

1. Select Tools > Customize Toolbars to display the Toolbars dialog box, and select a
toolbar in the list.

2. Select whether you want to Show Tooltips and have Flat buttons (instead of the standard
3D buttons).

3. Click the Customize button to open the Customize Toolbars window.

4. Select a menu category in the Categories pane to display the corresponding tools in the
right pane.

Select the Custom Graphical Tools category to view and add tools defined in an
extended model definition (see Chapter 3, Extending Your Models with Profiles in
Customizing and Extending PowerDesigner ).

5. Select the tool you want to add and drag and drop it onto the desired toolbar.

6. Click Close to return to the Toolbars dialog.

Click Reset or Reset All to undo your customizations.
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7. Click OK to return to your model.

Hiding and Showing a Toolbar
By default, the Standard toolbar is displayed in the PowerDesigner main window and the
Palette in the diagram window. You can choose to hide or show a toolbar from the
PowerDesigner interface.

1. Select Tools > Customize Toolbars to display the Toolbars dialog box.

2. Clear the check box corresponding to the toolbar you want to remove from the interface.

or

Select the check box corresponding to the toolbar you want to add to the interface

The toolbar instantly is displayed or disappears from the interface.

3. Click Close.

Deleting a Toolbar
You can delete any user-defined toolbar but you cannot remove a default PowerDesigner
toolbar.

1. Select Tools > Customize Toolbars to display the Toolbars dialog box.

2. Select a user-defined toolbar in the list of toolbars and click the Delete button.

3. Click Close.

Resource Files and Extended Model Definitions
The PowerDesigner modeling environment is powered by resource files, which define the
objects available in each model along with the methods for generating and reverse-
engineering them. You can view, copy, and edit these XML-format resource files in order to
customize and extend the behavior of the environment.

For detailed information about viewing and editing PowerDesigner resource files see the
Customizing and Extending PowerDesigner manual.

Extended model definitions (.XEM files) provide means for customizing and extending
PowerDesigner metaclasses, parameters and generation. Extended model definitions are
typed like models in PowerDesigner. You create an extended model definition for a specific
type of model and you cannot share these files between heterogeneous models. When you
create a new model, or when you reverse engineer into a new model, you can select one or
several extended model definitions and attach them to the model from the New dialog box.

For example, you can attach XEMs to a Java model to help you in working with a particular
IDE, or O/R mapping framework. The XEM may provide objects with additional properties or
property tabs, and define additional generation targets and options.
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PowerDesigner provides a number of predefined XEMs and you can also create your own.

An extended model contains:

• a profile definition - a set of metamodel extensions defined on metaclasses
• generation parameters - used to develop or complement the default PowerDesigner object

generation or for separate generation.

For more information about XEMs, including how to create your own, see "Extended Model
Definitions" in the Resource Files and the Public Metamodel chapter of the Customizing and
Extending PowerDesigner manual.

Missing XEMs

If you rename, move or delete extended model definition files that are attached to a model, you
will lose the links between them.

When you subsequently open the model, the following dialog box is displayed to list the
XEMs that are not available:

The following tools are available in this dialog box:

Tool Description

Open – Lets you browse to, and re-attach, the missing XEMs.

Update from Repository – Lets you check out the missing XEMs from the repository.
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Tool Description

Delete – Lets you remove the links between the model and the missing XEMs.

Attaching Extensions to a Model
You can attach an extended model definition (.xem) to your model when you create it by
clicking the Select Extensions button on the New Model dialog. You can attach an extended
model definition to an existing model from the List of Extended Model Definitions.

Note: You should never modify the original extended model definitions shipped with
PowerDesigner. To create a copy of the file to modify, open the List of Extended Model
Definitions, click the New tool, specify a name for the new file, and then select the .xem that
you want to modify in the Copy from field.

1. Select Model > Extended Model definitions to open the List of Extended Model
Definitions.

2. Click the Import tool to open the Select Extensions dialog.

3. Review the different sorts of extensions available by clicking the sub-tabs and select one or
more to attach to your model.

4. Select one of the following radio buttons:

• Share – creates a link to the XEM file. Changes made to the target affect all models that
share it.

• Copy – creates a copy of the XEM and saves it with the model. Changes made to the
target affect only the current model.

5. Click OK to return to your model.

Note: When you import an extended model definition and copy it into a model, the name and
code of the extended model definition may be modified in order to respect the naming
conventions of the Other Objects category in the Model Options dialog box.
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PART II

Linking and Synchronizing
Models

The chapters in this part describe the PowerDesigner features that help you create links
between models and trace the impact of changes between models.

Core Features Guide    329



  330 PowerDesigner  



CHAPTER 9 Getting Started with Linking and
Synching

The PowerDesigner Enterprise Modeling environment allow you to create and exploit
complex interdependencies between your models.

The richness of the PowerDesigner modeling environment enables you to model
interconnected systems and view them in many different ways.
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A single data item such as a product name can be implicated in multiple systems, which are
modeled in a number of interdependent models. It may also be represented at various levels of
abstraction in conceptual, logical, and physical data models, or in different contexts such as
object-oriented, XML, business process, and enterprise architecture models.

Instead of defining this same object and all its accompanying metadata multiple times,
PowerDesigner allows you to generate these instances or in other ways link them together, and
provides powerful tools for tracking and analyzing the dependencies between them.

Note: In order to obtain a complete view of the dependencies between your models, they must
either all be open in your workspace or stored in the repository and checked out with the
Check out dependencies option selected. When working with multiple connected models,
we recommend that you group your models together into a project (see Chapter 2, Projects and
Frameworks on page 37).

Creating Links Between Models
PowerDesigner provides many ways to link the objects of your models together.

You can create the following kinds of links between models:

• Generation links - are created during model or object generation. Each generated object is
linked with its origin object.
• Model Generation - generates one model from another and allows subsequent

synchronization on demand (see Generating Models on page 337).
• Object Generation - allows you to define the generation of objects from one model to

another with subsequent synchronization on demand (see Generating Model Objects
on page 349).

• Shortcuts - create a reference to an object in another model. You either create shortcuts
explicitly in order to share or reuse an object in another model (see Shortcuts on page 355)
or implicitly when creating other kinds of links. To create any of the kinds of links in this
list, the target model in which the referenced object resides must be open in your
workspace:
• RQM Traceability Links - link requirements with design objects that are intended to

satisfy them (see Chapter 4, Linking Requirements with Design Objects in
Requirements Modeling ).

• EAM Object Export/Import - link enterprise architecture objects with the design
objects that will implement them (see "Exporting and Importing Objects to and from
Other Models" in Chapter 7, Importing to and Generating and Exporting from an EAM
of Enterprise Architecture Modeling ).

• BPM Data Export/Import - link data objects in the BPM with objects in other models
(see "Data (BPM)" in Chapter 3, Building Business Process Diagrams of Business
Process Modeling ).
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• Extended Attributes and Collections - allow you to extend the PowerDesigner
metamodel to define new kinds of links between objects (see Extending Objects on
page 146).

• Object Mappings - specify connections between certain predefined types of objects
(see Chapter 12, Object Mappings on page 389).

• Related Diagrams - specify connections between objects and other diagrams in which
they are not present (see Specifying Diagrams as Related Diagrams on page 170).

• Extended Dependencies - specify connections between any objects without
restrictions (see Creating Extended Dependencies on page 334).

• Object Replications - duplicate an object from one model to another and allow you to vary
the properties you choose while keeping the rest synchronized with the original object (see
Object Replications on page 371).

Viewing Links Between Models
PowerDesigner provides an array of tools to allow you to view and analyze the links created
between your models.

Some or all of the following tools are available to you to view, analyze and edit the links
between your models:

• Project Diagram - provides a high-level read-only view of the links between the models in
your project (see Project Diagrams on page 39).

• Dependency Matrix - provides an editable view of all the links between the two object
types that you specify in the matrix definition (see Dependency Matrices on page 178).

• Generation Links Viewer - provides a read-only view of all the model or object generation
links between the present model and any models it is associated through generation (see
The Generation Links Viewer on page 350).

• Mapping Editor - provides an editable view of all the mappings between the present model
and any models it is associated with through mappings (see Creating Mappings from the
Mapping Editor on page 396).

• Multi-Model Report - provides a configurable report in HTML or RTF format
documenting your models and the links between them (see Creating a Multi-Model Report
on page 223).

• Impact and Lineage Analysis - provides a configurable analysis of the objects that impact
and/or are impacted by the selected objects (see Chapter 13, Impact and Lineage Analysis
on page 421).

• Object Lists - can include shortcuts to objects of the selected type if the Include Shortcuts
tool is selected (see Object Lists on page 117).

• Object property sheets (see Object Properties on page 104) - provide information on
various forms of links on the following tabs:
• Related Diagrams
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• Extended Dependencies
• Mappings - where available
• Requirements - if enabled (see Requirements Tab on page 114)
• Dependencies - lists the objects that depend on the object (see Dependencies Tab on

page 115)

Creating Extended Dependencies
You can specify additional kinds of connections between PowerDesigner objects through
extended dependencies. These links can be created between objects of any type of model.
They are used for documentation purposes only, and but are not interpreted or checked by
PowerDesigner.

You create an extended dependency between objects in the same diagram by selecting the
Link/Extended Dependency tool in the Palette. Click inside the influent object symbol and,
while continuing to hold down the mouse button, drag the cursor and release it on the
dependent object symbol.

In the following example, the CDM entities School and Work do not have any direct
calculable connection, but Work is shown as being dependent on School through an
extended dependency:

You can refine the meaning of extended dependencies by applying stereotypes to them to
identify the kind of dependency represented. You can enter a stereotype name by hand in the
Stereotype column of the Extended Dependencies tab of the dependent object, or select a
value from the list if you have previously defined stereotypes in an extended model definition
(see "Extended Model Definitions" in the Resource Files and the Public Metamodel chapter of
the Customizing and Extending PowerDesigner manual).

Creating Extended Dependencies Between Objects from Different
Models

You can create extended dependencies between objects in different models in the dependent
object property sheet. The model that contains the influent object must be open in the
workspace.

1. Open the property sheet of the object, and click the Extended Dependencies tab.

2. Click the Add Objects tool to open the Add Objects dialog box.

3. Select a model from among the models open in the workspace from the Model box,
(optionally) a package from the list, and an object from one of the sub- tabs and then click
OK to add an extended dependency to it.
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The extended dependency you have created is displayed simultaneously in the list of
extended dependencies but also in the diagram if objects at both extremities are displayed.

4. [optional] Enter a stereotype to further identify the extended dependency you have just
created in the Stereotype column, or select a stereotype from the list if available.

5. Click OK to close the property sheet and return to the diagram.
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CHAPTER 10 Generating Models and Model
Objects

Generating Models
PowerDesigner provides powerful capabilities for generating one model from another, and
keeping the two models synchronized. Thus, you could model your data at an abstract level in
a CDM, generate an LDM to model implementation-neutral features, and then generate
multiple PDMs for various DBMSs.

The following table shows which model types you can generate from each model type. The left
column lists the source model and the column headings the model types that can be generated
from it:

BPM CDM LDM PDM ILM OOM XSM

BPM X

CDM X X X X

LDM X X X

PDM X X X X X

ILM X

OOM X X X X

XSM X X

1. Select Tools, and then one of the following to open the appropriate Model Generation
Options Window:

• Generate Business Process Model... Ctrl+Shift+B
• Generate Conceptual Data Model... Ctrl+Shift+C
• Generate Logical Data Model... Ctrl+Shift+L
• Generate Physical Data Model... Ctrl+Shift+P
• Generate Information Liquidity Model...
• Generate Object-Oriented Model... Ctrl+Shift+O
• Generate XML Model... Ctrl+Shift+M
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2. On the General tab, select a radio button to generate a new or update an existing model, and
complete the appropriate options. For more details, see Model Generation Options
window on page 338.

3. [optional – PDM-PDM generation only] Click the DBMS Preserve Options tab and set any
appropriate options. For more details, see Model Generation Options window DBMS
Preserve Options tab on page 339.

4. [optional] Click the Detail tab and set any appropriate options. For more information, see
Model Generation Options window Detail tab on page 339.

5. [optional] Click the Target Models tab and specify the target models for any generated
shortcuts. For more information, see Model Generation Options window Target Models
tab on page 346.

6. [optional] Click the Selection tab and select or deselect objects to generate. For
information about using the tools on this tab, see Adding an Item from a Selection List on
page 122.

7. Click OK to begin generation.

Model Generation Options Window
The following options are available on the General tab:

Generate new ...

Option Description

DBMS, Object,
XML, or Process lan-
guage

Specifies the target for the model to be generated. Select one of the radio
buttons to:

• Share and link to the target definition

• Copy the target definition to the model to allow it to be modified without
affecting other models

Name Specifies the name for the model to be generated.

Code Specifies the code for the model to be generated.

Click the Configure Model Options button to open the Model Options dialog for the model to
be generated, in which you can specify naming conventions (see Naming Conventions on page
315) and other model options. For more information about the model options available for a
particular type of model, see the appropriate modeling guide.
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Update existing...

Option Description

Select model Specifies the target model to be updated. Select a model that has already been
generated from the current model from the list, or click the ellipsis button to
the right to open a list of other models of the same type open in the workspace.

DBMS, Object,
XML, or Process lan-
guage

Displays the target of the model to be updated.

Preserve modifica-
tions

Allows you to manually compare and merge the source model with the model
to be generated in the Merge Models window (see Chapter 7, Comparing and
Merging Models on page 259).

If this option is not selected, all the existing objects in the target model will be
automatically replaced by those in the generated model.

Model Generation Options Window DBMS Preserve Options Tab
This tab is only available when you generate a PDM from another PDM, and allows you to
choose to preserve or lose, the values associated with the following database objects:

• Physical options - for relevant objects
• Triggers and stored procedures – Note that, if the target belongs to a different DBMS

family, triggers are automatically rebuilt.
• Database objects – non-standard objects. If the source DBMS does not support an object

its option is not available. Only objects supported by the target DBMS will be generated.
• Extended attributes

Model Generation Options Window Detail Tab
The following options are available on this tab:

Option Description

Check Model Invokes a model check before generation, and stops generation if errors are
found. You can configure specific model checks before generation by select-
ing Tools > Check Model. For more information, see Checking a Model on
page 92.

Save Generation De-
pendencies

Instructs PowerDesigner to retain links between each source object and the
corresponding target object, which allow objects to be subsequently identi-
fied, even if they have been modified.

Generate Mappings Defines the source model as the data source of the generated model and
creates mappings between all source and target objects. This option is de-
pendent on the Save Generation Dependencies option.
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Option Description

Rebuild Triggers [CDM-PDM and OOM-PDM only] Instructs PowerDesigner to build triggers
with preservation option, after the PDM generation. Rebuild takes place after
merge if you are updating an existing PDM

Convert Names into
Codes

Instructs PowerDesigner to generate target model object codes from source
model object names using the appropriate conversion script (see Name and
Code Conversion Scripts on page 317). This option can be useful when gen-
erating models with very different naming conventions. If it is not selected,
target object codes are generated from source object codes.

For example an OOM Java class attribute code may be customerName
whereas the PDM table column that you want to generate must be called
CUSTOMER_NAME. By selecting this option and specifying the appropriate
conversion scripts in the model options available from the General tab, you
can generate your columns with appropriate codes.

Enable transforma-
tions

Enables pre- and post-generation transformations.

When you click this button, the Pre-generation tab is displayed if the source
model contains transformations. You can select the transformations to execute
before generation.

The Extended Model Definitions tab also is displayed for you to select
extended model definition files to attach to the generated model. These files
may contain post-generation transformations, in this case, the Post-Genera-
tion tab is displayed to let you select the transformations you want to be
executed in the generated model. If the generation is an update, and the
generated model contains extended model definitions with post-generation
transformations, the Post-generation tab is automatically displayed as soon
as you click the Enable Transformations button.

Skip single root ele-
ment

[XSM-PDM only] Specifies to ignore a single root element and to treat its
immediate child elements as multiple roots, which will be generated as tables.

Generate columns/
attributes as ele-
ments

[PDM-XSM only], Specifies that PDM table columns are generated as child
elements (instead of attributes) in the XML model. You can then set attributes
to these child elements.

Class Prefix Prefix for a class. It can help identify a class in a model

Table Options

The following options are available when generating a PDM:

Option Description

Table Prefix Specifies a prefix for the names of generated tables.
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Option Description

ID column type [XSM-PDM only] Specifies the type to use for ID columns, and which will be
used to generate xs:ID types.

Default: numeric

Reference Options

The following options are available when generating a PDM:

Option Description

Update Rule Specifies the default update constraint for referential integrity.

Delete Rule Specifies the default delete constraint for referential integrity.

FK column name
template

Specifies the naming convention for migrated foreign keys. You can select one of
the default templates from the list or enter your own using the following variables:

• %REFR% - Name / Code of the reference

• %PARENT% - Name / Code of the parent table

• %COLUMN% - Name / Code of the parent column

• %KEY% or %CONSTNAME% - Name / Code of the key constraint attached
to the reference

• %PROLE% - Role of the entity that generated the parent table, this variable
proceeds from the conceptual environment. If no role is defined on the rela-
tionship or association, %PROLE% takes the content of %PARENT% to
avoid generating a column with no name

The following example checks the %PROLE% value; if it is equal to the parent
name (which is the replacement value) then the template "%.3:PARENT%_
%COLUMN%" will be used, otherwise template "%PROLE%" will be used be-
cause the user has entered a parent role for the relationship:

[%PROLE%=%PARENT%?%.3:PARENT%_%COLUMN%:%PROLE%]

Customized naming templates reappear in the generation dialog box the next time
you open it, but are not saved to the list of predefined templates.

For more information about PowerDesigner variables, see "PDM Variables" in the
DBMS Resource File Reference chapter of the Customizing and Extending Pow-
erDesigner manual
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Option Description

Use template Controls when the FK column name template will be used. You can choose be-
tween the following radio buttons:

• Always use template

• Only use template in case of conflict

Index Options

The following options are available when generating a PDM:

Option Description

PK index names Specifies the naming convention for primary keys. You can use the following
variables in this and the Key index fields:

• %TABLE% - Generated code of the table. This is the table code that is gen-
erated in the database. It may or may not be truncated if the code contains
characters not supported by the DBMS

• %TNAME% - Table name

• %TCODE% - Table code

• %TLABL% - Table comment

Default: %TABLE%_PK

AK index names Specifies the naming convention for alternate keys. You can use the following
variables in this field:

• %REFR% - Generated code of the reference

• %REFNAME% - Reference name

• %REFRCODE%- Reference code

• %PARENT% - Generated code of the parent table

• %PNAME% - Parent table name

• %PCODE% - Parent table code

• %CHILD% - Generated code of the child

• %CNAME% - Child table name

• %CCODE% - Child table code

• %PQUALIFIER% - Parent table qualifier

• %CQUALIFIER% - Child table qualifier

The generated code of a variable is the code defined in the object property sheet,
which may be truncated when generated if the code contains characters not sup-
ported by the DBMS

Default: %TABLE%_AK
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Option Description

FK index names Specifies the naming convention for foreign keys, by default %REFR%_FK

FK threshold Specifies the minimum number of estimated occurrences of an entity necessary to
create an index on a foreign key. The estimated number of occurrences can be
specified in the entity property sheet. If this property is not set, foreign key indexes
are generated by default.

Note: If you modify a primary key in a PDM, then regenerate the PDM from a CDM, the
modified primary key is not preserved. If you want to preserve a modified primary key, you
need to modify the identifier in the CDM before regeneration.

Add Package Hierarchy

When you reverse engineer a database into a PDM and then generate an OOM with the
corresponding O/R mapping, you can use the Add Package Hierarchy feature to create the
appropriate packages in the OOM. You select the Add Package Hierarchy command from the
object model contextual menu. For more information, see the Generating and Reverse
Engineering OO Source Files chapter in Object-Oriented Modeling.

Applying Model Transformations
Transformations are used to perform standard modifications to your model objects. You can
apply transformations either on demand or during generation.

For information about creating transformations, see "Transformations and Transformations
Profiles (Profile)" in the Extending your Models with Profiles chapter of the Customizing and
Extending PowerDesigner manual.

Applying Transformations During Generation
Transformation profiles can be used during model generation:

• pre-generation transformations are applied to the source model
• post-generation transformations are applied to the target model

During inter-model generation, it is impossible to execute both lists of transformations of the
same transformation profile, because the current model is the source of generation but not the
target as defined in the following example.

CHAPTER 10: Generating Models and Model Objects

Core Features Guide    343



When you generate a model to the same type of model, you can execute both lists of
transformations of the transformation profile provided you select the same extended model
definition in the source and in the target model.
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1. Select Tools > Generate Model to open the Model Generation Options dialog box.

2. Click the Details tab, and click the Enable Transformations to display the Extended Model
Definitions, Pre-generation, and Post-generation tabs.

3. Click the Extended Model Definitions tab to select the extended model definitions in
which you have defined your transformations.

4. Click the Pre-generation tab and select profiles and transformations to be applied before
generation. If you deselect a profile checkbox, none of its transformations will be
executed. You can drag and drop profiles to modify transformation execution order.
During generation, transformations are executed in the following order:

• The order of profiles in the pre and post generation pages
• The order of transformations in the profile itself
• The order in which objects are treated in the model, that is to say beginning at the model

level and recursing into sub-packages

5. Click the Post-generation tab and select profiles and transformations to be applied after
generation.

6. Click OK in the Model Generation Options dialog box.
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Applying Transformations on Demand
Transformations can also be applied on demand in your model as a sort of design pattern. You
can design a pattern using the transformation feature and "play" it in your model in order to
modify objects.

For example, if you are working in an OOM, you can create a transformation that converts all
analysis classes with the <<control>> stereotype into components in order to add an
implementation layer to your model.

Note: You can only invoke post-generation transformations on demand.

There are two methods for applying transformations on demand in a model:
• Add a transformation as a command in a main or contextual menu (see "Menus (Profile)"

in the Extending your Models with Profiles chapter of the Customizing and Extending
PowerDesigner manual).

• Use the Apply Transformations window available from the Tools menu.
1. Add one or more extended model definitions containing post-generation transformations

to your model

2. Select Tools > Apply Transformations to open the Apply Transformations window.

3. Select transformations profiles and transformations on the Transformations tab.

4. [optional] Click the Selection tab and deselect any objects that you want to exclude from
the transformation.

5. Click OK to apply the transformations.

Model Generation Options Window Target Models Tab
Shortcuts reference a target object in a target model, to allow you to share objects between
different models. You can preserve the link between a generated shortcut and its target object
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during generation. By default, the Generate check box is selected and the Generated as
property is set to Shortcut in the shortcut property sheet, which allows you to preserve the link
between a shortcut and its target object through generation.

To generate shortcuts you have to select the generated models containing the target objects of
the generated shortcuts in the Target Models tab of the generation dialog box. The Target
Models tab displays the following columns:

Column Description

Target Models [read only ]Original target model of the shortcut.

Generated Models Specifies the target model for the generated shortcut.

The model generation process allows you to define the target object of a shortcut in a generated
model.

For example, here is the proper sequence of events for shortcuts generation:

1. Model 2 contains a shortcut of an object from Model 1.
2. Model 1 is generated into Model 1.1
3. Model 2 is prepared for generation to Model 2.2 and the Target Models tab is selected.

Model 1 is listed in the Target Models column and, if Model 1 is open in the workspace, the
Generated Models column displays the name of the last model generated from it. You can
select another generated model in the Generated Models column. If Model 1 is not open,
clicking its entry will open it.

4. The shortcut in Model 2.2 is correctly generated with a link to its target object in Model
1.1.
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Data Type Conversion
PowerDesigner converts from the data types of the source model to those of the target model
using its standard conceptual types (which are also used in the CDM). You can review the
conversions that will be made by accessing the relevant resource file.

1. Select Tools > Resources >  Type to open the appropriate list of resource files.

2. Select a resource file in the list, and click the Properties tool to open it in the Resource
Editor.

3. Expand the following categories:

• For DBMS resource files: Script > DataType
• For other resource files: Settings > DataType

4. Review the entries in the DataType category, each of which is described in its Comment
field.

For more information on data types, see the Resource Files and the Public MetaModel and
DBMS Resource File Reference chapters in Customizing and Extending PowerDesigner
manual

  348 PowerDesigner  



Generating Model Objects
You can extend the inter-model generation capabilities provided by PowerDesigner by
defining your own object generation commands. You can define as many commands as you
need, and generate any of your model's objects as any kinds of objects in any other model. The
generated objects are linked to the original objects and can be resynchronized at any time.

Before you can generate model objects, you must define the details of the generation (see 
Defining an Object Generation on page 349)

Note: This procedure deals with generating a single type of objects to another model. For
information about generating your entire model to another model, see Generating a Model on
page 337).

1. Select Tools > Generate Objects >  Menu command name  to open the Object Generation
Options window for the generation that you have previously defined (see Defining an
Object Generation on page 349).

2. On the General tab, select a radio button to generate a new or update an existing model, and
complete the appropriate options. For more details, see Model Generation Options
window on page 338.

3. [optional] Click the Detail tab and set any appropriate options. For more information, see
Model Generation Options window Detail tab on page 339.

4. [optional] Click the Target Models tab and specify the target models for any generated
shortcuts. For more information, see Model Generation Options window Target Models
tab on page 346.

5. [optional] Click the Selection tab and select or deselect objects to generate. For
information about using the tools on this tab, see Adding an Item from a Selection List on
page 122.

6. Click OK to begin generation.

Defining an Object Generation
You can define as many object generations as you need. The generations are stored as objects
in your model and are available as commands under the Tools menu.

1. Select Tools > Generate Objects > Define New Object Generation to open the Object
Generation Properties dialog.

2. Select the type of model object you want to generate other model objects from in the
Source model objects list.

3. Click the Choose Metaclass tool to the right of the Target model objects field to open the
Select Object Type dialog, which allows you to select the type of objects you want to
generate.
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You can choose any object (including extensions) from any PowerDesigner model type,
but some choices will be more appropriate than others.

4. [optional] Edit the Menu command name that PowerDesigner suggests, and which will
appear under the Tools > Generate Objects menu to allow you to launch the generation.

5. Click Generate to launch the generation immediately or OK to save the generation
definition for use later.

Once you have defined an object generation, you can launch it at any time by selecting
Tools > Generate Objects >  Menu command name . You can review the object
generations that you have defined by selecting Tools > Generate Objects > Manage
Object Generations.

The Generation Links Viewer
The Generation Links Viewer allows you to view (but not edit) the generation links of a given
model, which allow you to identify the origin of each generated or derived object of the model.

Note: Links are created between models during model generation only if the Save Generation
Dependencies option on the Detail tab of the generation dialog box is selected.

You can choose to view the:
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• Links to the model(s) derived from the present model, by selecting Tools > Generation
Links > Derived Models - the current model is shown in the Source pane and the derived
models in the Target pane.

• Links to the model(s) from which the present model was derived, by selecting Tools >
Generation Links > Origin Model - the current model is shown in the Target pane and the
origin models in the Source pane.

The Generation Links Viewer dialog box is divided in three parts:

• The Source pane - which is on the left-hand side, and displays the structure of the source
model

• The Target pane - which is on the right-hand side, and displays the structure of the target
model(s)

• The Generation Links pane – shows you the sources or the targets of the selected object in
the current model as a tree view. The root object is the source or target object from the
current model, and the generation link name is composed of the object type and name
(followed by, for link objects, the names of its extremities) followed by its parent model.
You can double click a generation link in this pane to view the properties of the source or
target object.
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Source object icons have a small green arrow symbol and target object icons have a small red
target symbol on their bottom right-hand corners.

Non-editable links are drawn from the origin object in the Source pane to the derived object in
the Target pane. Double-click the link in either pane to open the appropriate object's property
sheet, or in the area between the two panes to display its details in the Generation Links pane.

The following tools are available in the Generation Links Viewer:

Tool Description

Properties - Opens the property sheet of the selected source or target object.

Find Source Object - Finds an object in the Source pane and highlights it.

Find Target Object - Finds an object in the Target pane and highlights it.

Filter Generation Links – You can choose to filter by:

• All generation links
• Only generation links of the selected object
• Only generation links of the selected object and its child objects

Filter Objects - You can choose to filter by:

• All objects
• Only objects with generation links
• Only objects without generation links
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Using Impact Analysis with Generated Models
To use impact analysis on generated models, consolidate them in the Repository and extract
them with the Extract Dependencies option selected to display the Generated As subtab in
the Dependencies tab of source objects.

In the Impact Analysis dialog box, this link does not appear by default, you have to click the
Extract Dependencies tool to display the generation links:
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CHAPTER 11 Shortcuts and Object Replications

Shortcuts and object replications allow you to reuse objects defined in one model or package
elsewhere.

Shortcuts
A shortcut is an object that represents and references a target object. There are two types of
shortcuts:

• An Internal shortcut – is a shortcut to an object in a different package in the same model.
• An External shortcut – is a shortcut to an object in a different model. The external model

may take the form of a library of reusable objects.

With shortcuts you can benefit from:

• Reusability: You can create libraries of reusable objects whose properties are inherited by
multiple objects in different models. For example, the entity person and its four attributes:
Name, Age, Nationality and Address can be used via inheritance links in any model where
you have need of a Customer, Employee, etc.

• Automatic updates: When the target object changes, the updates cascades automatically to
all the shortcuts. Note that both the referencing and target models must be open in the
workspace for the changes to be propagated.

In the example below, the Person entity is created in one CDM, and a shortcut to it is created in
a second CDM. The Person symbol in the second CDM carries a small arrow in its bottom left
corner to indicate that it is a shortcut:
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Objects that Do not Support Shortcuts

You can create internal and external shortcuts on most of the object types that appear under a
model diagram or package in the Browser. You can also create shortcuts of shortcuts.

The following objects do not support shortcuts at all or support only internal shortcuts:

Model Internal and External Shortcuts not
supported

External shortcuts not sup-
ported

CDM — —

OOM Start, end, decision, synchronization, junction
point, transition, state, interaction fragment, inter-
action reference

Message

BPM Start, end, decision, synchronization, resource
flow, service provider, service interface, operation

Flow, correlation, variable

XSM [No internal shortcuts as there are no packages in
an XSM]

Import, include, redefine, annota-
tion

ILM — —

RQM Traceability link, user allocation —

However, it is still possible to create shortcuts in a model of a different type for traceability
purposes.
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You cannot create internal shortcuts to global objects, such as organization units, or business
rules, because they always belong to the model and cannot be displaced into a sub-package.
However, you can create external shortcuts to these objects.

Note: You can reuse data item shortcuts only if they are internal (same namespace). A
duplicated data item shortcut has the same characteristics as the original data item shortcut.

Creating a Shortcut
You can create shortcuts to target objects from another package in the current model, or from
another model open in the workspace through copy and paste, drag and drop, or from the List
of Shortcuts.

Creating a Shortcut by Copying and Pasting an Object
You can create a shortcut using copy and paste.

1. In the Browser or diagram window, select a target object in the target model or package and
press CTRL+C or select Edit > Copy.

2. Select the model or package where you want to create the shortcut in the Browser, or
double-click a target diagram.

3. Select Edit > Paste as Shortcut.

The shortcut symbol is displayed in the model or package diagram.

Creating a Shortcut by Drag and Drop
You can create a shortcut by drag and drop.

1. Select a target object in the Browser or diagram window.

2. Press ctrl + shift while you drag the object to the desired model or package and release the
mouse button.

The shortcut is displayed in the active model or package and in the Browser under the
appropriate node.

For more information on dragging and dropping objects, including how to change the
default behavior, see Dragging and Dropping Objects on page 126.
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Creating a Shortcut in the List of Shortcuts
You can create a shortcut from the List of shortcuts.

1. Select Model > Shortcuts to open the List of Shortcuts.

2. Click the Add Shortcuts tool to open the Add Shortcuts selection box.

3. Select the appropriate model and package in the upper part of the dialog box, and select
objects to add as shortcuts using the sub-tabs in the lower part of the dialog.

4. Click OK to return to the List of Shortcuts.

The newly-selected objects are displayed in the List of Shortcuts.

For more information, see Adding an Item from a Selection List on page 122.

The following rules restrict the use of shortcuts:

• You cannot create more than one shortcut to the same target object in the same model or
package

• You cannot create a shortcut for a data item outside the current namespace
• You cannot create links between two shortcuts, if the link implies a parent/child hierarchy

(for example: reference link between two table shortcuts in the PDM)
• You cannot create a link between an entity and the shortcut of an inheritance. For more

information, see Linking shortcuts on page 361.

When you create a shortcut, the following display rules apply to the shortcut symbol:

If referencing model or package... PowerDesigner creates...

Does not contain the shortcut Shortcut and shortcut symbol
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If referencing model or package... PowerDesigner creates...

Already contains shortcut without symbol Shortcut symbol

Already contains shortcut with symbol Shortcut synonym

Shortcut Properties
To open the property sheet of a shortcut, double-click its Browser entry or diagram symbol.
The General tab contains the following properties:

Property Description

Target type Type of model and object type

Name Name of the target object. The Properties button lets you open the target object
property sheet

Code Code of the target object.

Target model Name of the model to which the target object belongs. The Properties button lets you
open the target model property sheet

Target package Name and path of the package to which the target object belongs. The Properties
button lets you open the target package or model property sheet.

Shortcut type Type of the shortcut, external or internal

Status Displays the status of the target model or object. The following states are possible:

• Closed – the target model is closed and the status of the target object cannot be
determined

• Opened – the target model is open and the target object is present.
• Not Found – the target model or target object cannot be found. For more infor-

mation, see Changing the target object on page 361.

Object1 [link shortcut only] Name of the source object from which the link is dragged

Object2 [link shortcut only] Name of the target object towards which the link is dragged

Generate [external shortcut only] Shortcut is automatically included among the objects gen-
erated from the model when you launch the generation process

Generated as [external shortcut only] Specifies how the shortcut will be treated during a model-
to-model generation. You can choose between:

• Shortcut - the shortcut is generated as a shortcut and retains its link to the target
model

• Object – the shortcut is generated as an independent object and loses its link to
the target model

Change target
object

Click this button to change the target object of the shortcut
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A shortcut property sheet also includes the following tabs:

Property Description

Dependencies Objects with which the shortcut collaborates. See Displaying the objects that
are dependent on a shortcut on page 363.

Version Info Shortcut owner, modification and creation details

Modifying the Target Object Properties
You can access and change the properties of the target object from the shortcut property sheet.

1. Open the property sheet of the shortcut.

2. Click the Properties button to the right of the Name box to open the target object property
sheet.

If the target model is closed, you will be prompted to open it.

3. Modify the target object properties.

4. Click OK to return to the shortcut property sheet and OK again to return to the model
diagram.

Note: You can also access and modify the properties of the target model and package by
clicking the properties tools to the right of these fields.
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Changing the Target Object
You can change the target object that is referenced by the shortcut.

You may need to do this if the original target object or model has been deleted, and the shortcut
status is, consequently, Not Found.

In this case, you can either delete the shortcut or select a new target object. The new target must
be of the same object type, and cannot already be referenced by another shortcut in the same
package.

1. Open the shortcut property sheet.

2. Click the Change Target Object button in the bottom left corner of the shortcut property
sheet to open an object selection dialog box.

3. Browse to the appropriate package and select a new target object.

4. Click OK to return to the shortcut property sheet.

The new target object is displayed in the Name box and the shortcut status is changed to
Opened.

5. Click OK to return to the model diagram.

Note: You can also change the target object of a shortcut by opening the List of Shortcuts,
selecting a shortcut and clicking the Change Target Object tool.

Synchronizing Shortcuts
When you create an external shortcut to a target model that has never been saved, you should
save the target model before the referencing model in order to allow synchronization between
the models. If you attempt to save the referencing model first, you will be prompted to save the
target model.

When you make changes to a target object, the shortcut is synchronized automatically:

• If the referencing model is opened - synchronization occurs instantly.
• If the referencing model is closed - synchronization occurs when it is next opened.

Both the referencing and target models must be open for synchronization to occur.

Linking Shortcuts
You can create a link between two shortcuts in the referencing model if the link does not imply
a parent/child hierarchy. For example, you cannot create a reference link between two table
shortcuts in the PDM, as the reference is an oriented link.

You can also keep the link existing between two target objects in the referencing model.
Unlike shortcut symbols, the shortcut of a link does not show a particular icon that identifies
it.
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Creating the Shortcut of a Link
In the target model, when two target objects are linked, you can keep this link and create a
shortcut for the link.

1. Select both target objects and their link using the shift key for multi-selection.

2. Press ctrl + shift while you drag the symbols and their link to the desired model or package
and release the mouse button.

The object shortcuts appear with their link.

Updating the Display of a Link Between Shortcuts
When you create a link between two target objects in the target model, you can update the
referencing diagram in order for it to display the new link.

1. Display the referencing model diagram window.

2. Select Tools > Complete Links.

The link is displayed between the shortcuts in the referencing model.

Displaying Shortcuts
Shortcuts are visible in both the Browser and the diagram window.

In the Browser, a shortcut is treated as a regular object, except that its symbol carries a small
arrow in its bottom left corner. In the example below, the shortcut to Class C appears under the
Class folder, sorted alphabetically among the other classes that are native to the model:

In a diagram, the symbol of a shortcut is identical to the symbol of a regular object except that
it carries a small arrow in its bottom left corner.

If the target model is closed, only the name of the target model will be displayed. No other
properties or sub-objects will be available:
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Target model Description Default display Symbol

Opened Shortcut symbols displays target
object name, and target object at-
tributes

Closed Simplified shortcut symbol with
name, identical size but no attrib-
utes

Modifying Shortcut Display Preferences
You can modify the following display preferences for a shortcut using the Tools > Display
Preferences command:

Preference Description

Icon Displays the shortcut icon on shortcut symbols

Model [external shortcuts only] Displays the name of the target model on shortcut sym-
bols

Package Displays the package name on shortcut symbols. If you select this option, you
must choose one of the following options:

• Full path – displays the full path to the package

• Last package only –displays the last package name only

Displaying the Objects that Are Dependent on a Shortcut
Shortcuts can collaborate with other objects in a variety of ways. The Dependencies tab in the
shortcut property sheet lists the objects that are dependent on the shortcut.

This can be very useful to avoid deleting a shortcut whose deletion could seriously modify the
design of your model.

Open the shortcut property sheet, and click the Dependencies tab.

The Dependencies tab lists all the objects dependent on the shortcut in all the models open in
the workspace.

You can double-click an entry in the list to display the object's property sheet, or click the
Impact Analysis button to determine the impact of deleting the shortcut.
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Displaying the Shortcuts that Reference a Target Object
The Dependencies tab in an object's property sheet lists all the shortcuts that reference the
object

1. Open the target object property sheet and click the Dependencies tab.

2. Click the Shortcuts sub-tab.

The Shortcuts sub-tab lists all the shortcuts that reference the target object in all the models
open in the workspace.
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For more information on how to visualize external shortcuts of a target object in closed model,
see "Auditing repository activities" in the "Managing Repository Documents" chapter of the
Working with the Repository manual.

Displaying All the Shortcuts for a Particular Type of Object
You can display all the shortcuts for a particular type of object in the object lists.

1. Select Model >  Objects  to open the relevant list of objects.

2. Click the Include Shortcuts tool to display the shortcuts of this object type within the list.
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The shortcuts of this object type are displayed grayed out in the list. You cannot modify a
shortcut directly in this list, but you can select one and click the Properties tool to display
its property sheet.

Note: If both the Include Shortcuts and Include Sub-packages tools are enabled in the
selected list, all the objects shortcuts of the current package and those of the sub-packages
appear.

Displaying All the Shortcuts in the Model
You can display all the shortcuts in the model in the List of Shortcuts. The U[sed] column is
checked when the shortcut has a symbol in a diagram or if it is referenced by at least one other
object. If this column is not checked, the shortcut is not used in the model and you can safely
delete it.
Select Model > Shortcuts to open the List of Shortcuts.

All the shortcuts in the model are displayed grayed out in the list. You cannot modify a shortcut
directly in this list, but you can select one and click the Properties tool to display its property
sheet.
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Note: You can display the shortcuts of all packages by selecting the Include Sub-Packages
tool.

Working with the Target Models Referenced by the Model
In addition to external shortcuts that you create yourself, PowerDesigner also creates shortcuts
automatically when you perform certain tasks, such as linking requirements to design objects,
mapping objects, or selecting a library during OOM reverse engineering.

Opening the List of Target Models
You can display the list of target models for the current model.
Select Model > Target Models:
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Note: If a target model is presently closed, you can open it in the List of Target Models by
selecting it and clicking the Open Model tool. You can also open a closed model and review its
property sheet by clicking the Properties tool.

Changing a Target Model
You can change a target model that supplies shortcuts to your model from the List of Target
Models.

Note: You cannot use the Undo feature to cancel a Change Target Model action.

For example, you create a model, Project.pdm, which contains shortcuts to objects in a target
model, Library.pdm. A copy of the target model, Library2.pdm, is made, in which different
versions of the target objects are developed. You can switch between Library.pdm and
Library2.pdm in the List of Target Models.

1. Select Model > Target Models to open the List of Target Models.

2. Select a target model in the list, and then click the Change Target Model tool to open a file
chooser dialog.

3. Browse to the new target model, select it, and click OK.

A confirmation dialog box informs you that this change cannot be undone. If you click OK
to proceed:

• And the new target model is open in the workspace - the shortcuts are updated to the
new target objects. Otherwise they will be opened the next time you open the target
model.

• And a shortcut cannot find its target object - a message box warns you. You can either
delete the shortcut, or choose a new target object.
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4. Click OK to close the list of target models.

Deleting a Target Model
If you delete a target model, you delete all its shortcuts.

1. Select Model > Target Models to open the List of Target Models.

2. Select a target model in the list and click the Delete tool.

A message warns you that all the shortcuts related to the target model will be deleted
during this operation.

3. Click Yes to confirm the deletion of the target and of all its shortcuts.

Generating Shortcuts
You can generate shortcuts through the Target Models page located in the model type
Generation Options dialog box.

This page also allows you to generate replications (see Generating Replications on page
385).

When you generate a model from another models, shortcuts are, by default, generated in the
new model as independent objects. You can choose to instead generate them as shortcuts and,
thus, preserve their links to the target model.

The following example shows the generation of a PDM from an OOM:

Here is the proper sequence of events for external shortcuts generation:

• OOM 1 is the target model of a shortcut in OOM 2
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• OOM 1 is generated to PDM 1
• OOM 2 is prepared for generation to PDM 2 by associating appropriate properties and

parameters in both the shortcut property sheet and the Target Models page:
• If OOM 1 Is Still Opened in the Workspace, the Target Model column displays the

original target model (OOM 1), and its path. The Generated Models column displays
the last generated PDM the first time you generate the OOM into a PDM; the next time
you generate the OOM into a PDM, the Generated Models column displays the last
PDM selected. You can click the arrow in the Generated Models column to modify the
PDM selection in order to allow the creation of a correctly linked shortcut.

• If OOM 1 Is Closed in the Workspace, the Target Model column displays the original
target model (OOM 1), and its path. The Generated Models column displays <none>.
When you click into the Generated Models column, the original target model OOM 1 is
automatically opened in the workspace in order to find the models generated from
OOM 1. You can use the arrow to select PDM 1, the new target that will allow the
creation of a correctly linked shortcut in PDM 2.

• The external shortcut in PDM 2 is correctly generated with a link to its target object in
PDM 1

1. Before beginning the generation, verify that all the appropriate shortcuts have the
following properties set:

• Generate is selected to include the shortcut in the generation process
• Generated As is set to Shortcut

Note: You can select and modify the properties of multiple shortcuts in the List of
Shortcuts.

2. Select Tools > Generate model type  and click the Target Models tab, which contains a list
of :

• Target Models - of the current model that contain at least one shortcut generated as
shortcut

• Generated Models – from which you can select the model that will be used as a target
for the generated shortcut

3. Verify the list of generated models for each shortcut you want to generate as a shortcut or
make the appropriate changes.
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4. Click OK to start generation.

Object Replications
While shortcuts allow you to reference objects in other models, they have some limitations:

• the complete definition of the target object can only be accessed if the target model is
open.

• you cannot redefine locally any of the properties of the target object.

For example, in one model you may need a Client table with Name and detailed Address
columns, while in another model you may need only the Name column.

In this case, instead of using a shortcut, you should replicate the object.

When you replicate an object, PowerDesigner creates a complete copy (or replica) of the
object. The replica retains the name, code, type and Id of the original object and is
automatically updated when the original is modified.

A replica looks exactly like other objects in the Browser and diagram, but its property sheet is,
by default, uneditable, because all its properties are synchronized with the original:
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You can desynchronize any property that you want to change, while retaining synchronization
of the others.

The link to and synchronization with the original object is maintained by a replication, which
is not visible in the Browser or diagram, but whose properties are accessible via the List of
Replications.

You Use Shortcuts when

You want to reference an object in the same model or in different models or packages in order
to share this object representation between models or packages. The shortcut is not a local
copy of the target object and cannot be modified independently of its target object.

You Use Object Replications when

You want to have a local copy of an object that can also diverge from its original object.
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Objects that Support Object Replications?

You can create as many replicas as you want for most of the object types that appear under a
model diagram or package in the Browser.

You can also create replicas of replicas.

You cannot replicate links, but you can create a link between two replicas in the referencing
model.

The following table lists objects per module that support replications:

Module Object

CDM Conceptual Diagram Entity, Data Item

PDM Physical Diagram Table, View, User, Role, Group, Abstract Data Type, Test
Data Profile, Storage, Tablespace, Procedure, Trigger
Template, Trigger Template Item, Join Index, Sequence,
Database Package, Synonym

PDM Multidimensional Diagram Cube, Dimension, Fact, Data Source

OOM Class Diagram Class, Interface

OOM Use Case Diagram Use Case, Actor

OOM Sequence Diagram Object, Actor

OOM Activity Diagram Object State, Organization Unit, Object, Activity

OOM Component Diagram Component

OOM Object Diagram Object

OOM Deployment Diagram Component Instance, Node

OOM Collaboration Diagram Object, Actor

OOM Statechart Diagram Event, State

BPM Business Process Diagram Organization Unit, Resource, Message Format, Data,
Service Provider, Event, Data Transformation, Variable,
Correlation, Process, Correlation Key

XSM XSD Diagram Attribute Group, Attribute, Element, Simple Type, Com-
plex Type, Group, Notation, Import, Include, Redefine

XSM DTD Diagram Entity, Attribute Group, Attribute, Element, Group, Nota-
tion

RQM Term, User, Group, Replication
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Module Object

ILM Information Liquidity Diagram —

All modules File, Business Rule, Domain, Data Source

Creating a Replica
You can creating replicas using:

• the Replicate Objects dialog box
• drag and drop while holding alt + shift

Creating a Replica from the Replicate Objects Dialog Box
The Replicate Objects dialog box allows you to select one or more objects to replicate from
any model or package open in the workspace.

1. Select Edit > Replicate Objects (or right-click the diagram background and select Edit >
Replicate Objects from the contextual menu) to open the Replicate Objects dialog box.

2. Select a model and, optionally, a package from which to select objects to replicate. All the
available objects of the selected model and package are displayed.

Note: If you want to display all objects in the model and all objects in packages and sub-
packages, click the Include Sub-Packages tool in the list toolbar.

3. Select the objects you want to replicate from the various sub-tabs and click OK.

Note: If you select an object that owns sub-objects (a table that contains columns, for
example, or a class that contains attributes or operations), its sub-objects are also
replicated. If you want to directly replicate a sub-object, you must use drag and drop.
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The replicas appear in the active model and in the Browser under the appropriate node.

Creating a Replica Using Drag and Drop
You can use drag and drop while holding alt+shift to create replicas in the Browser or diagram,
or from one to the other. A rounded arrow within a circle is displayed under the cursor when
you are about to create the replica.

You can replicate sub-objects by drag and drop in the Browser while pressing the alt + shift
keys combination. It can be useful to replicate a sub-object independently of its parent object
(for example a column without the table that owns it) to create a reference library, in which you
can store columns, attributes or operations that you regularly use.

The following example illustrates a column (Column_1) in Table_1 that is replicated in
Table_2:

You can define the default behavior of drag and drop to directly create replicas (see General
Options on page 301).
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Name uniqueness is automatically checked when you replicate an object, so that replicas are
renamed in the referencing model when objects with the same name already exist in the model.

For more information on the definition of the namespace, see Object Namespaces on page
116.

The following example illustrates the replication of Entity_1 in a model that already contains
an entity named Entity_1. The Entity_1 replica is automatically renamed to Entity_2 in the
referencing model:

1. Select a target object in the Browser.

2. Press alt+shift while you drag the object to the desired model or package and release the
mouse button.

The replica is displayed in the active model or package and in the Browser under the
appropriate node.

Note: You can also create a replica by right-clicking and dragging the target object and select
the Replicate Here menu item from the contextual menu.

Replica and Replication Properties
Replicas have the property sheets appropriate to their object type. For example, a replica of a
class has a standard class property sheet. However, by default, the property sheet of a replica is
read-only because all its properties are synchronized with the original object.

Opening the Property Sheet of a Replication
In order to make editable any of the properties of a replica, you must open the properties of the
replication responsible for its link with the original object.

1. Open the property sheet of a replica and click the Version Info tab.

2. Click the Replication Properties button in the Replicated From groupbox.

The definition of a replication object includes the following general properties:
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Property Description

Original Object
Model

Model of the original object. The Properties button lets you open the property
sheet of the model containing the original object.

The List of Target Models shows models containing shortcuts or replicas in the
current session. It also allows you to get a model full name to distinguish from
another. For more information on how to use the List of the Target Model, see
Working with the target models referenced by the model on page 367.

Original Object Full
Name

Full path describing the location of the original object. The Properties button
lets you open the property sheet of the original object

Original Object
Type

Type of the original object

Original Object Sta-
tus

Displays the status of the original object. The following states are possible:

• Closed – the target model is closed and the status of the original object
cannot be determined

• Opened – the target model is open and the original object is present.

• Not Found – the target model or original object cannot be found. For more
information, see Deleting replicas, replications, and original objects on
page 380.

Replica Object Full
Name

Full path describing the location of the replica object. The Properties button
lets you open the property sheet of the replica object

Generate Replication is automatically included among the objects generated from the
model when you launch the inter-model generation process. For more infor-
mation, see the Generating Replications on page 385 section.

A replication definition also includes the following properties:

Property Description

Attributes List of replicated attributes

Collections List of replicated collections

Sub-Replications List of replicated sub-objects (for example a column of a replicated
table)

Note: Select Model > Replications to open the List of Replications, select a replication in the
list, and then click the Properties tool
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Modifying the Original Object Properties
You can access and change the properties of the original object from the replication property
sheet.

1. Open the property sheet of the replica, and then click the Version Info tab.

2. Click the Replication Properties button in the Replicated From groupbox to open the
replication property sheet:

3. Click the Properties button to the right of the Full name field to open the original object
property sheet.

4. Modify the original object properties.

5. Click OK to return to the replication property sheet and OK again to return to the model
diagram.

Synchronizing Replicas
When you create a replica to a target model that has never been saved, you should save the
target model before the referencing model in order to allow synchronization between the
models. If you attempt to save the referencing model first, you will be prompted to save the
target model.

When you make changes to an original object, the replica is synchronized automatically:

• If the referencing model is opened - synchronization occurs instantly.
• If the referencing model is closed - synchronization occurs when it is next opened.

Both the referencing and target models must be open for synchronization to occur.
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Desynchronizing Replica Properties
By default, when you replicate an object, all of its properties are also replicated, and
synchronized to the original, and are uneditable in the replica property sheet.

You can desynchronize any of these properties in the replication property sheet, and then
change their values in the replica.

1. Open the property sheet of a replica, and then click the Version Info tab.

2. Click the Replication Properties button in the Replicated From groupbox to open the
replication property sheet:

3. Click one of the following tabs to display the type of property you want to desynchronize:

• Attributes – properties that contain a single value
• Collections – properties that can contain multiple values
• Sub-replications – sub-objects, that have their own property sheets

4. Clear the check boxes next to the items that you want to desynchronize:
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5. [for sub-replications] Select the sub-object in the list on the Sub-replications tab and click
the properties tool to open its sub-replication property sheet. Then clear the relevant check
boxes to desynchronize its properties.

6. Click OK to return to the replica property sheet.

The desynchronized properties are now editable in the property sheet, and will no longer
be synchronized with the original.

Moving Replicas, Replications, and Original Objects
If you move a replica to a different package or model, the replication that links it to the original
object is also moved.

If you move an original object, any replications that link replicas to it will be automatically
updated.

You cannot move a replication separately from the replica that it serves.

For more information on moving objects, see Moving Objects from Package to Package on
page 132.

Deleting Replicas, Replications, and Original Objects
If you delete a replica, the replication that linked it to the original object is also deleted.

If you delete an original object, any replicas linked to it will be deleted too, unless they have
one or more property desynchronized, in which case they will be retained and become normal
objects.
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If you delete a replication, the link between the replica and its original is broken and the replica
becomes a normal, object. No further synchronization is possible.

1. Open the property sheet of a replica, click the Version Info tab, and then click the Delete
Replication button in the Replicated From groupbox.

2. Select Model →Replications to open the List of Replications, select a replication in the list
and click the Delete tool

Displaying Replicas and Replications
Replicas look identical to normal objects, but all or part of their property sheets will be grayed
out and uneditable.

Replications, which maintain the link between the replica and the original object have no
browser entry or diagram symbol, but their property sheets can be accessed from the property
sheet of the replica or from the List of Replications.

Displaying the Replications Linked to an Original Object
The Dependencies tab in an object's property sheet lists all the replications that reference the
object

1. Open the original object property sheet and click the Dependencies tab.

2. Click the Replications sub-tab.

The Replications sub-tab lists all the replications that reference the original object in all the
models open in the workspace.
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Displaying All the Replicas for a Particular Type of Object
You can display all the replicas for a particular type of object in the object lists.

1. Select Model >  Objects  to open the List of Objects.

2. Click the Customize Columns and Filter tool, select Replica in the list of filter options, and
then click OK.

When the R[eplica] column is selected, this indicates that the object is a replica. Any
property that is synchronized (and thus not editable) is grayed in the list.
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You can select a replica, and then click the Properties tool in order to open its property
sheet, and desynchronize any of its properties to make them editable. When a property has
been desynchronized, it is no longer greed in the object list, and can be edited.

Note: If the Include Sub-packages tools is enabled in the selected list, all the replicas of the
current package and those of the sub-packages appear.

Displaying All the Replications in the Model
You can display all the replications in the model in the List of Replications.

Note: You cannot create new replications from the List of Replications. You must use drag and
drop or select Edit > Replicate Objects

Select Model > Replications to open the List of Replications.

All the replications in the model are displayed grayed out in the list. You cannot modify a
replication directly in this list, but you can select one and click the Properties tool to display its
property sheet.
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Note: You can display the replications of all packages by clicking the Include Sub-Packages
tool.

Comparing and Merging Replicas
You can compare and merge the properties of a replica with those of the original object.

When merging models containing replications, you must merge both replicas and their
associated replications in order to merge a complete replication. Otherwise they will be
merged as ordinary objects and not as replicas.
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For more information on comparison and merging see Chapter 7, Comparing and Merging
Models on page 259.

Generating Replications
You can generate a replica in another type of model and preserve the link with its original
object through generation. You will then be able to continue the synchronization in the
generated model.

This requires first generating all original object models to the destination model type so that
these new objects can be referenced as the original objects for the generated replicas.

You specify original object models to be used during generation through the Target Models
page located in the Generation Options dialog box.

Before you generate a replication, you must:

• Select the Generate check box in the replication property sheet otherwise the replica will
be generated as an ordinary object and not as a replica

• Select generated models in the Target Model page located in the Generation Options
dialog box in order to retrieve the corresponding original object of each replica in the
generated model

The Target Model page also allows you to select generated model for shortcuts.
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For more information on the Target Model page, see Working with the target models
referenced by the model on page 367.

Example of an Inter-model Generation with Replications

The following example shows the generation of a PDM from an OOM:

Here is the proper sequence of events for replication generation:

• OOM 1 is the target model of a replica in OOM 2
• OOM 1 is generated to PDM 1
• OOM 2 is the referencing model that contains the replica
• OOM 2 is generated to PDM 2 while preserving the link between the replica in PDM2 and

the original object in PDM 1

Selecting a Type of Generation for a Replication
You can choose to generate a replication in another type of model and preserve the link with its
original object through generation. The list of replications allows you to perform a multiple
selection.

For more information on the generation of replications, see Generating Replications on page
385.

1. Select Model > Replications to open the list of replications.

2. Select a replication in the list.

3. Click the Customize Columns and Filter tool in the list toolbar, select the Generate check
box from the list of filter options that is displayed, and click OK.

You return to the list of replications.

4. Click the Generate column for the replication you want to generate during inter-model
generation.

5. Click OK.

  386 PowerDesigner  



The replication will be automatically included among the objects generated from the
model when you will launch the generation process.
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CHAPTER 12 Object Mappings

Object mapping allows you to establish connections between objects belonging to
heterogeneous models and diagrams. You create mappings between objects to model O/R
(Object-Relational) mappings, which associate classes with tables to store OOM objects into a
relational database, or simply to express a correspondence between objects in different
models.

The following table lists the supported types of model-to-model mapping in PowerDesigner:

Source
Model

CDM Target LDM Target PDM Target OOM Target XSM Target

CDM X X X X

LDM X X X X

PDM X X X X X

OOM X X X X

XSM X

Note: Mappings are also used to define data replications in the ILM. For more information,
see "Visualizing and Refining Data Replications with the Mapping Editor" in the Building
Information Liquidity Diagrams chapter of the Information Liquidity Modeling guide.

You can create mappings :

• in the Mapping Editor - which gives you a global view of all the mappings to objects in the
current (target) model (see Creating Mappings from the Mapping Editor on page 396)

• on the Mapping tab of the property sheet of the target object (see Creating Mappings from
an Object's Property Sheet on page 417)

• During model generation, by selecting the Generate Mappings option in the Model
Generation Options window (see Generating Models on page 337).

Each mapping is recorded in a query, a textual expression or an XPATH expression defined in
the target object, which permits the selection of data from the data source and its transfer to the
target model. You can view and refine these mappings in the Mapping Editor.

The following tables list the objects that can be mapped for each kind of model.

CDM Mappings

CDM objects can be mapped to other model objects as follows:
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CDM Source
Objects

CDM Target
Objects

LDM Target
Objects

PDM Target
Objects

OOM Target
Objects

Entity Entity, Associa-
tion, Relationship

Entity, Relation-
ship

Table Class, Associa-
tion

Entity attribute Entity attribute,
Association at-
tribute

Entity attribute Column Class attribute

Relationship Entity, Associa-
tion, Relationship

Entity, Relation-
ship

Table, Reference Class, Associa-
tion

Inheritance Inheritance Inheritance - -

Inheritance attrib-
ute

Inheritance attrib-
ute

Inheritance attrib-
ute

- -

Association Entity, Associa-
tion

Entity, Relation-
ship

Table, Reference Class, Associa-
tion

Association At-
tribute

Association at-
tribute, Entity at-
tribute

Entity attribute Column Attribute

Data item Data item - - -

Domain Domain Domain Domain Domain

Note: You can map inheritances with CDM objects only when its child entities are not
generated, i.e. when the "Generate children" option is deselected in the Generation tab of the
inheritance property sheet.

LDM Mappings

LDM objects can be mapped to other model objects as follows:

LDM Source
Objects

CDM Target
Objects

LDM Target
Objects

PDM Target
Objects

OOM Target
Objects

Entity Entity, Relation-
ship, Association

Entity, Relation-
ship

Table Class, Associa-
tion

Entity attribute Entity attribute Entity attribute Column Attribute

Relationship Entity, Relation-
ship

Entity, Relation-
ship

Table, Reference Class, Associa-
tion

Inheritance Inheritance Inheritance Reference Generalization
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LDM Source
Objects

CDM Target
Objects

LDM Target
Objects

PDM Target
Objects

OOM Target
Objects

Inheritance attrib-
ute

Inheritance attrib-
ute

Inheritance attrib-
ute

- -

Domain Domain Domain Domain Domain

PDM Mappings

PDM objects can be mapped to other model objects as follows:

PDM Source
Objects

CDM Target
Objects

LDM Target
Objects

PDM Target
Objects

OOM Target
Objects

XSM Target
Objects

Table Entity, Rela-
tionship

Entity, Rela-
tionship

Table,
Fact,Dimen-
sion

Class, Associ-
ation

Element,
Complex type

Table column Entity attrib-
ute

Entity attrib-
ute

Table column,
Measure, Di-
mension at-
tribute

Attribute Element,
Complex type

View - - Fact,Dimen-
sion

Class -

View column - - View column,
Table column,
Measure, Di-
mension at-
tribute

Attribute -

Reference Relationship Relationship Reference Class, Associ-
ation

-

Domain Domain Domain Domain Domain -

OOM Mappings

OOM objects can be mapped to other model objects as follows:

OOM Source
Objects

CDM Target
Objects

LDM Target
Objects

OOM Target
Objects

XSM Target
Objects

Class Entity, Associa-
tion, Relationship

Entity, Relation-
ship, Inheritance

Class Element, complex
type
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OOM Source
Objects

CDM Target
Objects

LDM Target
Objects

OOM Target
Objects

XSM Target
Objects

Attribute Entity attribute,
Association at-
tribute

Entity attribute,
Inheritance attrib-
ute

Attribute Element, Com-
plex type

Generalization - Inheritance Generalization -

Association Association Entity, Relation-
ship

- -

Domain Domain Domain Domain -

XSM Mappings

XSM elements and complex types and their attributes can only serve as source objects for
mapping to other XSM elements, complex types and attributes, but they can serve as the
targets for mapings from OOM or PDM source objects.

Object to Relational (O/R) Mapping
Developers tend to use object-oriented programming languages like Java, to develop business
objects and components. These objects can be stored in a database. A problem arises when the
user tries to store objects in a relational database because object modeling describes a system
through objects that have identity, behavior and encapsulated state whereas relational
modeling describes a system by its data.

Furthermore, object codes in an OOM for a given object language are often different than
codes used in a relational database. This requires that you modify object codes after
generating an OOM into a PDM or a PDM into an OOM to be compliant with the object
language.

You can use object mapping to bypass this impedance-mismatch.

The following schema illustrates the link between classes and tables to store objects in a
relational database:
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Object persistence implies to store and extract objects in a relational database.

Mapping Classes with PDM Objects

When a class inherits from a non-generated class via a generalization link, the attributes of the
class appear in the Selection dialog box in order to let you create a mapping with these
inherited attributes. The attributes of a non-generated derived class also appear in the
Selection dialog box.

Mapping Associations with PDM Objects

O/R mapping on an association allows you to define the role navigability of an association in
the database. When an association role is not navigable, there is no need to design a mapping
for the association since no information is transmitted between the classes. However, when an
association role is navigable, you have to set up the structure for data transmission within the
database. In relational databases, data transmission is implemented via foreign keys designed
to relate a record in one table with a record in another.

The type of mapping for an association depends on the association multiplicity:
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• One-to-one or one-to-many associations can be mapped to a reference in the source model.
This reference is used in the database to transfer data and migrate key columns to the
appropriate table

• Many-to-many associations have to be mapped to an associative table. This table is created
to maintain a relationship between two or more tables in a relational database. The
columns contained in the associative table are the combination of the keys in the tables
involved in the reference. For example, the following classes have a many-to-many
association:

In a relational database, this association is mapped to the following associative table:

SQL Queries

When the association roles are navigable, the following queries are automatically computed:

Query Action

Select (Role A) Retrieves related class A instances for the role A defined on class B

Insert (Role A) Associates an instance of class A with class B. It is computed only when the
source association is an associative table

Delete (Role A) Deletes from class B the association with class A. This query is computed only
when the source association is an associative table

Select (Role B) Retrieves related class B instances for the role B defined on class A

Insert (Role B) Associates an instance of class B with class A. This query is computed only
when the source association is an associative table

Delete (Role B) Deletes from class A the association with class B. This query is computed only
when the source association is an associative table
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Mappings between Operational, Data Warehouse, and OLAP
Databases

Data warehousing requires the extraction, transformation, and loading of data from
operational systems to a data warehouse database. You can map PDM objects to represent
links between operational and data warehouse data and from the data warehouse data and
OLAP cubes.

You can model operational and data warehouse data structures in PDMs, and specify
mappings to identify the operational data sources of the data warehouse. These mappings can
be used to generate extraction scripts to populate the data warehouse with operational data:

The following table lists the objects that are mapped in this kind of relational-to-relational
mapping:

Operational object Data warehouse object

Table Table (Fact or Dimension type)

Column Column

You can map physical objects to OLAP objects, and use these mappings to generate cube data
in text files to be loaded by OLAP engines. The mapping for a physical object (dimension or
fact) is used to supply data for the cube dimensions or cube measures in OLAP databases. The
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tables in the data source need not be of dimension or fact type. Once the source tables or views
are identified, you can define mappings between attributes or measures and table columns:

When you use the Rebuild Cubes feature to create cubes and dimensions from fact and
dimension tables, the mapping between source tables and OLAP objects is automatically
performed.

The Select sub-tab displays the entire SQL statement used to select data in the data source.
This statement is automatically generated. The Generate Cube Data feature uses this SQL
statement to fill the text files used to populate cubes in an OLAP database.

Note: For more information about rebuilding cubes and generating cube data, see the Building
Multidimensional Diagrams chapter in the Data Modeling guide.

The Mapping Editor
The Mapping Editor provides a global view of all the mappings to objects in your model,
allowing you to quickly identify mapped and unmapped objects.

To open the Mapping Editor, select Tools > Mapping Editor. If no data source is defined in
your model, you will be prompted to create one with the Data Source Creation Wizard (see 
Creating a Data Source on page 413).
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The Mapping Editor window is divided into three panes:

• The Source pane – has a gray background and is, by default, on the left of the window. For
more information, see Mapping Editor Source pane on page 408.

• The Target pane – has a white background and is, by default, on the right of the window.
The model from which you launch the Mapping Editor is displayed in the Target pane, and
the mappings are saved in this model. For more information, see Mapping Editor Target
pane on page 409.

• The Mappings pane - can contain a mapping list or the same content as the content of the
Mappings tab of an object's property sheet. If you define a mapping for an object using the
Mapping Editor, the Mappings tab is automatically updated in the object's property sheet.
For more information, see Mapping Editor Mappings pane on page 411.

Note: Click the Play Demo tool in the lower-left corner of the Mapping Editor window to
launch a video that briefly illustrates its main features.
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Mapping Links and Symbols

When a mapping is created, a non-editable link line is drawn between the mapped objects. The
arrow specifies the direction of the data transfer. When an arrow is displayed on both
extremities of the link, it means the data can be extracted from the source to target and vice
versa.

A link extends from the source pane to the target pane and passes through an area between the
two panes. If you click a link:

• In the Source pane – you open the property sheet of the source object.
• In the Target pane – you open the property sheet of the target object.
• In the middle area - you display the mapping in the Mappings pane.

A small symbol is displayed in the bottom right-hand corner of the icons and also on their
respective parent hierarchy icon to ease readability:

Pane Mapped object icon Parent hierarchy icon

Source (green)

Target (red)

When you define a mapping for an object (a table, for example) a mapping is automatically
defined for its sub-objects (columns, for example) when their name matches the name of the
source sub-objects.

Creating a Mapping from the Mapping Editor
You can create a mapping in the Mapping Editor in any of the following ways:

• Drag an object from one pane and drop it on an object in the other.
• Select an object in each of the target and source panes, and then click the Create Mapping

tool.
• Select an object in each of the target and source panes, and then click the Create Mapping

tool in the Mappings pane.
• Select an object in each of the target and source panes, right-click one, and select Create

Mapping.
• Right click a data source and select Generate Default Mappings.

Note: When dragging and dropping, you can either create a mapping if no mapping is defined
for an object icon or reuse and complement an existing mapping. When using the Create
Mapping tools or contextual menu command, you can create several different mappings for
the same target object. Each mapping object is added to the Mapping list and you can access its
property sheet.
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Generate Default Mappings

The Generate Default Mapping feature allows you to automatically create mappings between
source and target objects having the same name. When an object in the target model is mapped
to an object in the source model, their sub-objects are automatically mapped when their name
and code match.

Automatic Mapping

When objects in the Source and Target pane are mapped, their sub-objects are automatically
mapped if the current model (target) contains sub-objects whose name and code match those
of the sub-objects in the source models.

You can force the mapping using the Generate Mapping tool in the Sub-Object sub-tab of the
Mappings pane to automatically generate a mapping between sub-objects with same name or
code in the source and target models.

Note: You can multi-select object icons in the Source pane by holding down the SHIFT key
while clicking, and map them simultaneously to a target object.

Creating a Mapping by Dragging and Dropping
You can create a mapping by dragging one or more objects from the Source pane and dropping
them onto an object in the Target pane.
Drag one or more objects from the Source pane and drop it onto an object in the Target pane.

A visual link is drawn between the objects and a small symbol is displayed on the source and
the target object icons. The mapping details display in the Mappings pane.

Note: If a mapping is already defined for an object icon, the drag and drop feature reuse the
existing mapping to complement it.

The pointer becomes a barred circle when it is over an impossible drop position.

When a source object in a multi-selection cannot be dropped in the selected place in the Target
pane, the whole selection is rejected.

The result of a drag and drop depends on the objects being dragged and where you drop them:

• Object > Object - The objects are mapped together, along with any sub-objects that have
the same name and code. The mapping is displayed in the Mapping list in the Mappings
pane. The source object is in the Sources sub-tab and the mapping of its sub-objects
displays in the Sub-Object Mapping sub-tab.

• Sub-object > sub-object – [where the sub-objects were not mapped because their names
are different, and you have to "force" the mapping] The objects are mapped together and
this mapping is added to the list of attributes mappings in the Sub-Object Mapping sub-
tab.
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• Sub-object owned by a different object > sub-object - The objects are mapped together
and this mapping is added to the list of attribute mappings in the Sub-Object Mapping
sub-tab.

• Sub-object or object > folder – The object (and its sub-objects if any) are created in the
appropriate folder in the target model and are mapped to their respective source objects.
Objects are displayed as new mappings in the Mapping list, and sub-objects are added to
the list of attribute mappings in the Sub-Object mapping sub-tab.

• Sub-object owned by a different object > folder [XML target only] – The object owing
the sub-object is mapped to the target object (and displays in the Sources sub-tab), and the
sub-object is mapped to a new created sub-object in the target model, and added to the list
of attributes mappings in the Sub-Object mapping sub-tab.

[XML Specifics] As an XML element can correspond to a simple type containing only an
elementary value (for example <Name>Bill</Name>), you can directly map an element to a
class attribute, an element attribute or to a table column using the drag and drop feature.

Creating a Mapping with the Create Mapping Tool
You can create a mapping using the Create Mapping tool on the Mapping Editor toolbar.

1. Select one or more object icons in the Source pane and select an object icon in the Target
pane.

2. Click the Create Mapping tool in the Target pane toolbar.

3. [If one of the selected source objects is ambiguous (a folder for example)] A selection
dialog opens. Select an appropriate object from the list, and then click OK.

A visual link is drawn between the objects and a small symbol is displayed on the source
and the target object icons. The mapping details display in the Mappings pane.

In the following example, a mapping is defined between the tables EUROPEAN_SALES in
Model_2 and ASIAN_SALES in Model_3 and the table TOTAL_SALES in Model_1. Each
table has a column called TOTAL AMOUNT. You can define column TOTAL AMOUNT in
TOTAL_SALES as the sum of total amounts in EUROPEAN_SALES and ASIAN_SALES:
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Creating a Mapping with the Create Mapping Tool in the Mappings Pane
You can create a mapping using the Create Mapping tool from the Mappings pane.

1. Select an object in the Target pane .

or

[if the target object is a sub-object] Select one or more objects in the Source pane and then
select an object in the Target pane .

2. Click the Create Mapping tool in the Mappings pane.

A visual link is drawn between the objects and a small symbol is displayed on the source
and the target object icons. The mapping details display in the Mappings pane.

If the target object is an object owing sub-objects, a selection dialog box is displayed to let you
select one or more sources for the target. Then they are displayed in the Object Sources sub-tab
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of the Mappings pane. Besides, sub-objects that match are automatically mapped and are
displayed in the Sub-Objects Mapping sub-tab.

If the target object is a sub-object, you also need to select one or more object icons in the
Source pane. The mapping expression is displayed in the Mapped to sub-tab that you can
modify. You can also add other source objects using the Add Sources tool in the Sources sub-
tab.

Creating a Mapping Using an Object's Contextual Menu
You can create a mapping using the Create Mapping command from the contextual menu of an
object icon either in the Target or in the Source pane.

Note that this command is only available for object to object and sub-object to sub-object
mappings.

1. Select an object icon in the Target pane and select one or more object icons in the Source
pane.

or

Select one or more object icons in the Source pane and select an object icon in the Target
pane.

2. Right-click the object icon in the Source or in the Target pane and select Create Mapping.

A visual link is drawn between the objects and a small symbol is displayed on the source
and the target object icons. The mapping details display in the Mappings pane.

Mapping Examples
This topic contains different mapping examples.

Simple Mapping

A simple mapping can be designed as follows. The CITY table and its columns in the Source
pane are mapped to the CITY table and its columns in the Target pane. Note that columns
mapped automatically:
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Multiple Sources Mapping

A mapping with multiple sources can be designed as follows. The CITY table in the Target
pane has two sources (CITY and SALE tables):
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Different Mappings for the Same Target

A same target object can have different mappings. The SALE table in the Target pane is
mapped to the SALE table (Mapping_1) and to the STORE table (Mapping_2) in the Source
pane:
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Creating Forward and Reverse Mappings
You primarily create mappings from one or more source models to the target model. These
forward mappings define how to populate the objects of the current model with those of the
data source model.

In forward mapping mode, the Source pane is on the left side of the window, the target pane is
on the right side, and the right-hand arrow in the middle area is depressed:

You can also create reverse mappings, which define how to populate the objects of the source
models with those of the current model. To do this, click the left-hand arrow in the middle area.
What was originally the source model is renamed to the target:
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When you create a mapping in this mode, PowerDesigner defines a default reverse mapping
(bi-directional link) when the access type of the data source (see Creating a data source on
page 413) is Read/Write or Write-only.

You can modify the default reverse mapping by switching Source and Target panes and edit the
Insert, Update and Delete sub-tabs in the Mappings pane. These tabs summarize the reverse
mapping for a given mapping. Mappings are always owned by the model on the right-hand
side.

Depending on whether you are editing the source model mappings or the target model
mappings, the following types of links display. Solid lines indicate links that can be edited in
the current mode (forward or reverse), while dotted lines indicate links that cannot be edited in
the current mode:

Edit...mappings Type of link Description

Current model Forward mapping with potential reverse
mapping (bi-directional link).

Forward mapping only.

Reverse mapping with no forward map-
ping defined.

Data source models Reverse mapping with potential forward
mapping (bi-directional link).

Reverse mapping only.

Forward mapping with no reverse map-
ping defined.

Reverse mappings can be required when, for example, data has several sources and you want
to define how the data in the current model objects is inserted, updated or deleted in the data
source model objects.

Modifying the Default Mapping Syntax
The Object Expression Editor dialog box allows you to build a textual or an XPATH
expression from a list of objects.

The XPath expression allows you to locate a node (an element with its ramifications) in the
hierarchical tree structure of an XML document.

When an XML mapping has several sources, the XPATH expression is built using the
concatenation of the XPATH expression for each source object separated by a comma.

The Object Expression Editor dialog box is divided into specific panes containing the
information shown below:
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Information Pane location

Objects types Upper left part of the dialog box

Available objects Upper right part of the dialog box

Expression script textbox Lower part of the dialog box

The list of available objects depends on the selected object type. You can double-click
individual objects from the list of available objects for insertion in the expression script
textbox at the cursor last position.

When you commit your changes in the Expression script textbox, the object expression is
updated in the "Mapped to" box of the object mapping property sheet.

1. Click the expression script textbox where you want to insert the textual or XPATH script.

2. Select an object type from the upper left part of the dialog box.

For example, select Elements to display the list of available elements. The list of available
objects of this type is displayed in the upper right part of the dialog box.

3. Double-click the available object that you want to add to the script.

The item is added to the expression script.
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4. Click OK.

Mapping Editor Source Pane
The Source pane displays all the data sources and their source models showing all the objects
that can be mapped.

You need to create at least one data source and declare models in the list of data source models
to define where (in which database or model) data should be extracted to be transferred to the
model in the Target pane. You can create several data sources.

A data source can contain several models, you can select the source models among a list of
models open in the current workspace.

The Source pane always displays a gray background ; it is primarily displayed on the left in the
Mapping Editor. However, the Source pane is displayed on the right pane in case of reverse
mapping editing.

For more information about reverse mapping, see Creating Mappings from the Mapping
Editor on page 396.

The following toolbar helps you manage sources:

Tool Description

Properties - Opens the property sheet of the selected source object.

Create Data Source - Launches the Data Source Creation Wizard that allows you to name a
data source, specify an access type, a model type and select source models. See Creating a
data source on page 413.

Delete Data Source - Deletes the selected data source. Related mappings, if any, are auto-
matically deleted.

Add Model to Data Source - Adds one or more source models to an existing data source
from a selection dialog box.

Remove Model from Data Source - Removes the selected source model from the data
source. Related mappings, if any, are automatically deleted.

Find Source Object - Finds an object in the Source pane and highlights it.

Mapping Deletion and Object Deletion in the Source Pane

The following table lists how you can delete mappings and objects in the Source pane.
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Type of deletion Short keys

Mapping deletion del key on a mapped object in the Source pane to delete the mapping with
its target object in the Target pane

Contextual menu: Delete Mapping

Object deletion shift+del combination key to delete a selected object in the Source pane

Contextual menu: Delete

Generate Default Mappings

You can right click a data source and select Generate Default Mappings. The Generate Default
Mapping feature allows you to automatically create mappings between source and target
objects having the same name. When an object in the target model is mapped to an object in the
source model, their sub-objects are automatically mapped when their name and code match.

Mapping Editor Target Pane
The Target pane displays the model where data is extracted. It is primarily displayed on the
right in the Mapping Editor. However, the Target pane is displayed on the left pane in case of
reverse mapping.

For more information about reverse mapping, see Creating forward and reverse mappings on
page 405.

The following toolbar helps you manage mappings in the target model:

Tool Description

Properties - Opens the property sheet of the selected target object.

Create Mapping - Creates a mapping between selected source and target objects. The
mapping is materialized by a link and the mapping details appear in the Mappings pane. The
tool behavior depends on the two selected objects.

Delete Mappings - Deletes all the mappings for the selected target object.

Filter Mappings - Filters mappings to show:

• All mappings
• Only mappings of the selected object
• Only mappings of the selected object and its sub-objects
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Tool Description

Filter Objects - Filters objects to show:

• All objects
• Only objects with mappings
• Only objects without mappings

Find Target Object - Finds an object in the Target pane and highlights it.

Create Mapping Tool Behavior

Depending on the selected objects in the Source and Target panes, using the Create Mapping
tool can lead to diverse behaviors:

Selected source >target objects What happens...

Folder, model or sub-object > object A selection dialog box opens to let you select an
appropriate object in the source model.

Object > object Sub-object > sub-object Objects are automatically mapped together with
their respective sub-objects if any when their name
and code match.

Object > sub-object A selection dialog box opens to let you select an
appropriate sub-object from the selected object in
the source model.

For more information about objects and their sub-objects, see Creating a mapping from the
Mapping Editor on page 398.

Mapping Deletion and Object Deletion in the Target Pane

The following table lists how you can delete mappings and objects in the Target pane.

Type of deletion Short keys

Mapping deletion del key on a mapped object in the Target pane to delete the mapping with its
source object in the Source pane

Contextual menu: Delete Mapping

Object deletion shift+del combination key to delete a selected object in the Target pane

Contextual menu: Delete

For mapping deletion, you can also use the Delete Mappings tool from the Target pane toolbar.
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Mapping Editor Mappings Pane
When you create a mapping, it is displayed in the Mapping list in the lower part of the Mapping
Editor dialog box, called the Mappings pane.

The Mappings pane content changes automatically depending on the object you select in the
Target pane:

Selected object Mappings pane displays...

Folder, model or package A summary of the mappings it contains.

Object The same content as the Mapping tab in the object prop-
erty sheet: Sources of the mapped object, mappings of its
sub-objects if any, criteria, and SQL queries to execute the
mapping if any.

Sub-object The same content as the object mapping property sheet
("Mapped to" expression and the sources of the sub-ob-
ject, which are PDM, OOM, XSM or CDM source objects
for the target object).

You can create several different mappings for a single target object. Also, the same target
object can have several sources. In the following illustration the SALE class has two different
mappings Mapping_5 and Mapping_6. Also Mapping-6 has two sources: CITY and SALE.
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All the mappings for a selected object in the Target pane are displayed in the Mapping list
located in the lower part of the Mapping Editor dialog box. You can select one and modify it
using the different queries sub-tabs displayed in the lower part of the Mappings pane, or by
clicking the Properties tool to the right of the Mapping list to open its property sheet (see 
Object Mappings Properties on page 415).

The following tools help you manage mappings for a data source in the Mappings pane:

Tool Description

Create Mapping - Creates a mapping for a data source that you can further define using the
Mapped to sub-tab or queries sub-tabs located at the bottom part of the dialog box (PDM
data source only). By default, you are prompted to create a data source if no data source
exist for the model when you click the Create Mapping tool. Then, you have to declare one
or more source models in order to select source objects from a selection list. If sub-objects
match, they are automatically mapped. Each time you click the Create Mapping tool for the
current object, it creates a new mapping for the same data source if only one data source
exists. Otherwise you have to select one from the list of available data sources to proceed.

Delete Current Mapping - Deletes the current mapping for the data source. The link that
materializes the mapping between the Source and the Target panes is also deleted.
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Tool Description

Properties - Opens the property sheet of the current mapping.

Use Case Scenario

You have a target object but you do not know its sources yet. You create a mapping using the
Create Mapping tool. The mapping object can be compared to a container for the target object
and its source objects. A selection dialog box opens to let you select one or more sources for
your target object that is then displayed in the Object Sources sub-tab in the Mappings pane.

Then you have to select the sub-objects (source and target) to map using the sub-object column
for the target and the Mapped to column for the source in the Sub-Object mapping sub-tab.

Then you can configure SQL queries using the Criteria, Select, Insert, Update and Delete
sub-tab, as a mapping consists in performing modifications in the data source using SQL.

Creating a Data Source
A data source provides a connection to one or more other models for mappings and (in the
PDM) can also provide a connection to a database. You are prompted to create a data source
with a wizard the first time you open the Mapping Editor or click the Create Mapping tool on
an object property sheet Mappings tab.

1. On the Data Source Identification page, enter a name for the data source, and then specify
an access type. The selected type controls which types of queries (for PDM data sources)
are available in the Mappings pane, and the existence of forward and reverse mappings.
You can choose between:

• Read/Write – Enables Criteria, Select, Insert, Update and Delete queries.
• Read-Only - Enables Criteria and Select queries. You can only create forward (Source

> Target) mappings to a read-only data source, and such sources are not displayed
during reverse mapping (Target > Source). For more information about forward and
reverse mappings, see Creating forward and reverse mappings on page 405.

• Write-Only - Enables Criteria, Insert, Update and Delete queries. You can only create
reverse mappings to a write-only data source, and such sources are not displayed
during forward mapping

2. Select the type of the model to use as the data source.
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3. Click Next to go to the Source Model Selection page.

4. Select one or more models from the list of open models in the workspace, and then:

• For data sources created from an object's Mapping tab - click Finish to create the data
source and open a selection dialog to choose the external object to map to.

• For data sources created from the Mapping Editor - click Next to go to the Options
page. By default, the Create default mappings option, which creates mappings where
possible based on shared names, is selected. Click Finish to create the data source and
proceed to the Mapping Editor.
To create additional data sources in the Mapping Editor, click the Create Data Source
tool. To add additional models to a data source, click the Add Model to Data Source
tool.

Data Source Properties
You can modify an object's properties from its property sheet. To open a data source property
sheet, double-click its diagram symbol or its Browser entry in the Data Sources folder.

The General tab contains the following properties:

Property Description

Name Name of the item which should be clear and meaningful, and should convey the
item's purpose to non-technical users

Code Technical name of the item used for generating code or scripts, which may be
abbreviated, and should not generally include spaces

Comment Descriptive label for the data source
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Property Description

Access type Controls which types of queries (for PDM data sources) are available in the
Mappings property sheet or in the Mappings pane of the Mapping Editor, and
also controls the existence of forward and reverse mappings. For more infor-
mation about forward and reverse mappings, see Creating a data source on page
413.

Model Type Type of model(s) being used as data source. See Chapter 12, Object Mappings
on page 389

The following tabs are also available:

• Models - Lists the models associated with the data source. Use the Add Models tool to add
models open in the current workspace.

• Database Connection - [for data sources created in a PDM] Contains the parameters
needed to connect to the database associated with the data source. Click the Select a Data
Source tool to specify an ODBC data source or connection profile (see Connecting to a
Data Source on page 30).

• Cost - [for data sources created in a PDM that supports lifecycle modeling] Lets you
specify the cost per GB of storage for the data source along with the compression rate,
which is used to estimate the relative size of the data once it has been loaded to the data
warehouse (where 100% indicates no compression).

• Data Movement (Lifecycle) - [for data sources created in a PDM that supports lifecycle
modeling] Lets you define parameters to connect to a remote database, whose data will be
loaded into the warehouse.

Object Mappings Properties
Click the Properties button to the right of the Mapping field on the Mapping tab of an object
property sheet or in the Mappings pane of the Mapping Editor to open the mapping property
sheet. The tabs available for a particular mapping depend on the objects being mapped.

The General tab contains the following properties:

Property Description

Data Source Name of the data source where data is extracted.

Target Name of the target object that owns the mapping.

Parent [Sub-object only] Specifies the name of the parent object.

Name Specifies the name of the mapping.

Code Specifies the technical name of the mapping.

Comment Descriptive comment for the mapping.
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Property Description

Mapped to Specifies the mapping expression. You can edit the expression directly in this field or
click, the Edit tool to open it in a dedicated editor (see Modifying the Default
Mapping Syntax on page 406). To recover the default expression click to release the
User-Defined button.

The following tabs are also available:

• Sources - Lists the source objects mapped to the object. Use the Add Sources tool to add
additional source objects to the list.

• Sub-Object Mappings - Lists the sub-objects of the mapped object that are mapped with
sub-objects of the object.

Tool Description

Add Mapping - Select additional source sub-objects to map. After adding sub-objects,
select the sub-objects to map them against in the Mapped to column.

Create from Sources - Copy sub-objects from the source object to the object. The name,
code , description, annotation, and comment are copied and the data types are converted
in order to match the current model.

Generate Mapping - Automatically generate mappings between sub-objects with the
same name or code in the source and target models.

Click the Ellipsis button in the Mapped to column to edit the source expression for the
sub-objects.

• Operation Mappings - [OOM classes only] Lists the operations and queries associated
with the mapping Allows you to associate a SQL query to the operation. When an
operation implies action on the database, like data retrieval or data update, you can
associate this operation with a SQL query that will execute an action in the database.
Usually, this query is a SELECT statement used to retrieve one or several instances of the
current class according to the operation parameter. It can also be an UPDATE query. In the
context of an EJB, the SQL query mapped to an operation is used to implement finder or
select methods.

• Criteria - Allows you to specify join criteria between source objects. For example:
EMPLOYEE.ID < 100

• Query - Computes a SQL query from the information in the other tabs to retrieve or update
data in the database. If you modify the SQL query, it can no longer be automatically
calculated, even when you update the mapping. You can recover the computed expression
by clicking to release the User-Defined tool.
A Select query is available for a forward mapping, and Insert, Update and Delete queries
for a reverse mapping:
• The Select tab retrieves attribute values of class instances from the database using the

class identifying attributes. For example:
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select
  USER.USERNAME "USERNAME",
  USER.PASSWORD "PASSWORD"
from  USER

• The Insert tab creates an instance of the class and saves it with its attributes. For
example:
insert into USER(
   USER.USERNAME,
   USER.PASSWORD)
values (
   %USERNAME%,
   %PASSWORD%)

• The Update tab displays a statement that allows you to update attribute values of class
instances apart from identifying attributes. For example:
update USER
set USER.USERNAME = %USERNAME%,
  USER.PASSWORD = %PASSWORD%

• The Delete tab displays a statement that allows to delete a class instance from the
database using its identifying attributes. For example:
delete line* from USER

To modify the default syntax of the queries, edit the SelectStatement,
InsertStatement, UpdateStatement, and DeleteStatement entries in the
Profile category of the object language or extended model definition (see Chapter 3,
Extending Your Models with Profiles in Customizing and Extending PowerDesigner ).

Creating Mappings from an Object's Property Sheet
You can create mappings individually for a given object from the Mapping tab of its property
sheet.

The Mapping tab is equivalent to the Mappings pane in the Mapping Editor (see The Mapping
Editor on page 396).

1. Open the property sheet of the object and click the Mapping tab.

2. Click the Create Mapping tool to the right of the Mapping list to create a mapping for the
target object. If:

• No data source has yet been created in the model you will be prompted to create one
(see Creating a Data Source on page 413).

• Several data sources are available, you will be prompted to select one and click OK.

3. Select the object from the data source to map to the present object and click OK to create
the mapping.

The name and code of the object are displayed in the Object Sources sub-tab and a
mapping is created in the Mapping list.
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4. [optional] Click the Add Objects tool to select more source objects to map with the object.

5. Click the Sub-Object Mapping sub-tab and add or remove mappings between sub-
objects (see Object Mappings Properties on page 415)

To automatically generate mappings for sub-objects that share a name, click the Generate
Mapping tool.
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6. [optional] Review the other mapping tabs (see Object Mappings Properties on page 415)
and edit them as appropriate.

7. [optional] Click the Launch Mapping Editor tool to review your mappings in the
Mapping Editor.

Modifying the Default Mapping of a Sub-object
You can modify the default mapping created for a sub-object. The Attribute Mappings
property sheet can be used to fine-tune the mapping between a sub-object in the target object
and sub-objects in data source objects.

In the "Mapped to" box, you can see the attribute expression. By default, sub-objects used in
this expression are prefixed by their parent object. You can customize the content of the
"Mapped to" box by inserting comments manually. You can also click the Ellipsis button and
use the SQL Editor (for PDM data source) or the Object Expression Editor (for other data
sources) to modify the default mapping syntax. To recover the default sub-object expression,
click the User-defined tool.

In the Sources tab, it is possible to select several sub-objects and map them with the target
sub-object. To do so, you have to use the Add Sources tool to select sub-objects from the list of
sub-objects belonging to the source objects mapped to the target object. When you add sub-
objects from the Sources tab, and you have not modified the sub-object expression, the content
of the "Mapped to" box in the General tab is updated.
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1. In the Mapping tab, select the Attributes Mapping sub-tab to display the corresponding
tab.

2. Select a sub-object in the list and click the Properties tool to display the Attribute
Mappings Properties dialog box.

3. Click the Sources tab and click the Add Sources tool to select source sub-objects from a
selection dialog box and click OK.

The sub-objects appear in the Sources list.

4. Click the General tab to display the corresponding tab. The selected sub-objects appear in
the "Mapped to" box.

5. Click OK.

  420 PowerDesigner  



CHAPTER 13 Impact and Lineage Analysis

PowerDesigner provides powerful tools for analyzing the dependencies between model
objects. When you perform an action on a model object, you can use:

• Impact Analysis – to analyze the effect of the action on the objects that depend on the initial
object.

• Lineage Analysis – to identify the objects that influence the initial object.

Most of the time, the action is a deletion or a change, such as changing the data type of a
primary key column – the impact analysis shows which other tables and columns are impacted
by the change. The action can also be user-defined (see Creating a user-defined action on page
446).

The analysis applies analysis rule sets to one or more initial objects. You can use the rule sets
shipped with PowerDesigner or create your own rule sets (see Working with Analysis Rule
Sets Resource Files on page 439). You can also refine your analysis at any time, by for
example changing the analysis rule sets to be used (see Refining an Impact and Lineage
Analysis on page 432).

Each initial object is analyzed and displayed as a node with categories of influencing and/or
dependent objects.

PowerDesigner lets you review your analysis in two ways:

• Preview – which displays the analysis in a temporary tree form (see Reviewing an Analysis
in Preview on page 424).

• Impact and Lineage Model (IAM) – which displays the analysis in a diagram that can be
saved (see Reviewing an Analysis in an IAM Model on page 428).

The following example shows an impact and lineage analysis in preview. The Impact and
Lineage tab shows all the objects that depend on the 'Employee' table (impact analysis), which
is the initial object, and all the objects that influence it (lineage analysis).
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The following example shows the same impact and lineage analysis in an IAM. The
'Employee' table is displayed in the center of the diagram with its influencing objects above it
and its dependent objects beneath it:
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Launching an Impact and Lineage Analysis
You analyze the impact of a change to your model from the Impact and Lineage Analysis
dialog box, which lets you review your analysis through:

• A preview – the impact and lineage analysis displays in a tree form (see Reviewing an
Analysis in Preview on page 424).

• An Impact and Lineage Model (IAM) – the impact and lineage analysis displays in a
diagram (see Reviewing an Analysis in an IAM Model on page 428).

1. Open an impact and lineage analysis in any of the following ways:

• Select an object in the Browser or in the diagram and press ctrl+F11.
• Select one or more objects in the diagram and select Tools > Impact and Lineage

Analysis.
• Right-click an object symbol in the diagram and select Edit > Impact and Lineage

Analysis.
• Right-click an object entry in the Browser and select Impact and Lineage Analysis.
• [when deleting an object] Click the Impact button on the Confirm Deletion dialog

box.
• Open an object's property sheet, click the Dependencies tab, and then click the Impact

Analysis button.
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2. [Optional] Enter a name for your analysis result. This will be the name of the generated
model (see Reviewing an Analysis in an IAM Model on page 428).

3. Select an impact rule set for your analysis. You can choose one of the following predefined
rule sets:

• Conceptual Impact Analysis – to restrict the analysis to objects impacted by modeling
changes on the initial object, such as a modification on a requirement definition.

• Data Impact Analysis – to identify the use, if any, of a value contained in the initial
object.

• Delete Impact Analysis – [default when deleting an object] to restrict the analysis to
objects that are directly impacted by the deletion of the initial object.

• Global Impact Analysis – [default when not deleting an object] to identify all the
objects that depend on the initial object.

• None – no impact rule set is selected.

4. Select a lineage rule set for your analysis. You can choose one of the following predefined
rule sets:

• Conceptual Lineage Analysis – to justify the modeling existence of the initial object,
and ensure it fulfills a well-identified need.

• Data Lineage Analysis – to identify the origin of the value contained in the initial
object.

• Global Lineage Analysis – [default when not deleting an object] to identify all the
objects that influence the initial object.

• None – [default when deleting an object] no lineage rule set is selected.

5. [optional] Click the Properties tool next to each rule set to review it (see Editing analysis
rules on page 444).

The analysis displays in the Impact and Lineage tab of the dialog box (see Reviewing an
Analysis in Preview on page 424). You can click the Generate Diagram button to
graphically view the analysis in its default diagram (see Reviewing an Analysis in an IAM
Model on page 428).

Note: You can click the Select Path tool to change the default folder for analysis rule sets, or
click the List of Rule Sets tool to open the List of Impact and Lineage Analysis Rule Sets
window, and review a specific rule.

Reviewing an Analysis in Preview
The impact and/or lineage analysis preview displays when you select an impact and/or lineage
rule set in the Impact and Lineage Analysis dialog box.

For more information, see Launching an impact and lineage analysis on page 423.
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The impact and/or lineage analysis preview lets you review the application of your chosen
analysis rules to the initial object and the impact on its impact and lineage objects on the
following tabs:

• Impact and Lineage – to both identify the objects impacted by a change on the initial object
and the objects that influence the initial object (see Preview Impact and Lineage tab on
page 425).

• List – to save the analysis in RTF or CSV format, or print it (see Preview List tab on page
426).

In addition, you can customize and refine the analysis by adding or removing initial objects for
example, changing the action on an object, and so on (see Refining an Impact and Lineage
Analysis on page 432).

Preview Impact and Lineage Tab
The Impact and Lineage tab displays the result of the analysis.

This tab displays in a tree form:

• the result of the application of the selected impact rules on the initial object and on its
dependent objects, including external shortcuts to other models.

• the result of the application of the selected lineage rules on the initial object in order to
identify its influencing objects.

Each item in the tree displays an [action] information for impact analysis to designate the type
of action that is applied to it and a [lineage] information for lineage analysis to designate
lineage items.

You can modify the default action associated with an item (see Creating a user-defined action
on page 446). Each action is propagated through analysis rules and may, in turn, provoke
other actions.

For information about the various tools on the Impact and Lineage tab, see Impact and Lineage
tab tools on page 428.

The following example shows how a change on the 'Participate' entity affects its relationships
and which objects influence it:
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Preview List Tab
The List tab displays a tabular report of all the objects contained in the impact and lineage
analysis. You can customize the report by filtering which attributes you want to view, save the
report in RTF or CSV format, and print it.

The following example shows the impact analysis of the deletion of the Employee table. You
can see in the Action column that the Chief reference is also deleted, for example, and that the
Project table is changed.
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The following tools are available on the preview List tab:

Tool Description

Properties – Displays the property sheet of the selected object in the list.

Save – Saves the list in RTF (for MS Word) or CSV (for MS Excel) format.

Print – Prints the list.

Copy – Copies the list in RTF or CSV format.

Find a Row – Opens the Find dialog box to let you search the list for a specific object.
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Tool Description

Customize Columns and Filter – Opens the Customize Columns and Filter dialog box to let
you select attributes to display in the list and also specify expressions to filter by. For
example, you can select attributes specific to impact and lineage analysis such as "Action",
which specifies the action type. For more information, see Customizing Object List Col-
umns and Filtering Lists on page 120.

Enable/Disable Filter - Enables or disables the filter on the list.

Impact and Lineage Tab Tools
The following tools are available on the preview Impact and Lineage tab:

Tool Description

Properties – Opens the property sheet of the selected item.

Add Initial Objects – Opens an object selection dialog box to let you add objects to analyze.

Re-Analyze – Recalculates the dependent or influencing objects of the initial object using
the analysis rule sets. Since this tool applies only to the initial object, you must select the
root object to re-analyze the entire tree.

Check out Dependencies from Repository – If the current model contains links to other
closed models that are checked in into the repository, checks out these dependencies. For
more information, see Understanding cross-model dependencies during the analysis on
page 437.

In addition, there are many actions available from the item's contextual menu in the tree (see
Refining an Impact and Lineage Analysis on page 432 and Working with Analysis Rule Sets
Resource Files on page 439).

Note: If an object is dependent multiple times then, for performance reasons, only the first
entry is displayed in detail in the tree. You can right-click subsequent undeveloped entries and
select Go to First Occurrence to jump to this first occurrence.

Reviewing an Analysis in an IAM Model
You generate an Impact Analysis Model (IAM) by clicking the Generate Model button on the
Impact and Lineage Analysis dialog box.

For more information, see Launching an impact and lineage analysis on page 423.

You can review the application of the selected analysis rules to the initial object and the impact
on its dependent impact and lineage objects graphically in an IAM. Generating an IAM allows
you to save a snapshot of the analysis at a given time, as well as benefit from a range of features
such as comparing models (see Chapter 7, Comparing and Merging Models on page 259) or
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managing model's versions with the Repository (see the Working with the Repository
manual).

In addition, you can customize and refine the analysis by adding or removing initial objects for
example, changing the action on an object, changing IAM's options, and so on (see Refining
an Impact and Lineage Analysis on page 432).

The following example shows an impact and lineage analysis on the Employee table, which is
surrounded by a dotted line. Influencing (lineage) objects are displayed to the left of the initial
object, and dependent (impact) objects are displayed to the right of it. Links between the
objects represent the analysis rules that propagate actions on objects:

IAM Objects in the Diagram
The following object types are automatically generated:

Object Symbol Description

Initial object Model object to analyze. The initial ob-
ject symbol has the shape and format of
its referenced object. For example the
initial object referencing an OOM use
case has an ellipse shape.
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Object Symbol Description

Impacted object Model object impacted by the analysis
of the initial object. This can be its de-
pendent or influencing object. The im-
pacted object symbol has the shape and
format of its referenced object. For ex-
ample the impacted object referencing a
PDM table has a rectangle shape.

Link Analysis rule between initial objects
and impacted objects.

Note: You can complement your diagram, by adding graphical objects, such as notes or
decorative symbols.

IAM Objects in the Browser
The IAM Browser provides a hierarchical view of all your model objects, and allows you to
rapidly navigate between them.

The typical hierarchy of objects in the IAM Browser tree is as follows:

Symbol Description

Contains one or more initial objects with their dependent and influ-
encing objects grouped by object type. Categories correspond to the
initial object's collections, which propagate the impact or lineage anal-
ysis rule sets selected for the analysis. You can change the display of
these collections (see Controlling the display of object collections on
page 445). Each object in the tree displays an [action], which desig-
nates the type of modification that is applied to it. You can modify the
default action associated with an object (see Creating a user-defined
action on page 446).

Contains the initial objects' models and any other models affected by an
action on an initial object. Affected models can be discovered by:

• external shortcuts or replication links, when those models are
opened during the analysis.

• dependencies checking out from the repository, when those models
are closed.

Identifies an impact category containing dependent objects.

Identifies a lineage category containing influencing objects.

The following example shows how the deletion of the Employee entity affects its identifiers,
relationships, attributes, and parents. In addition, you can see that the Employee number
attribute is deleted, but the Employee number data item is only changed:
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Reviewing the List of Analysis Objects
You can review in the IAM the global list of analysis objects from the List of Analysis Objects
dialog box, save this list under a particular format, such as .csv or .rtf or print it.

You can right-click an object in the list to access a contextual menu offering the following
options:

• Find in Diagram
• Find in Browser
• Impact and Lineage Analysis
• Edit
• Properties
• Extended menus (created with the Resource Editor)

Select Model > Analysis Objects.

Reviewing the List of Analysis Models
You can review in the IAM the global list of analysis models from the List of Analysis Models
dialog box.

You can right-click a model in the list to access a contextual menu offering the following
options:

• Find in Browser
• Impact and Lineage Analysis
• Edit
• Properties
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• Extended menus (created with the Resource Editor)

Select Model > Analysis Models.

Refining an Impact and Lineage Analysis
When reviewing your analysis, you can refine it by removing or adding initial objects,
changing the analysis rule sets to be used, and/or customizing actions. If you have generated
an IAM, you can customize the display preferences and model options, print the model, and/or
compare it with another IAM.

Removing or Adding Initial Objects From/to the Analysis
Change the focus of your analysis by removing or adding initial objects.

• You can remove initial objects from the analysis in any of the following ways:
• [from the IAM] Select Tools > Change Analysis Options to open the Impact and

Lineage Analysis Options dialog box. Click the Initial Objects tab, select one or
more objects in the list and click the Delete tool.

• Right-click an object in the preview tree and select Remove.
• Right-click an object in the diagram and press Del.

• You can add initial objects to the analysis in any of the following ways:
• [from the IAM] Select Tools > Change Analysis Options to open the Impact and

Lineage Analysis Options dialog box. Click the Initial Objects tab, click the Add
Objects tool to open a selection dialog box, select one or more objects to add to the
analysis, and then click OK.
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• [from preview] Click the Impact and Lineage tab, click the Add Objects tool to open a
selection dialog box, select one or more objects to add to the analysis, and then click
OK.

Removing Collections of Influencing and Dependent Objects
You can remove objects collections from the analysis to make it more readable.

• You can remove collections of influencing and dependent objects in any of the following
ways:
• [from the IAM] Right-click an object's collection in the Browser or a link in the

diagram, and select Remove.
• [from preview] Right-click an object's collection in the tree, and select Remove.

• You can redisplay the removed collections at once by re-analyzing your model in any of the
following ways. If you want to redisplay individual collections use the Impact Analysis
Objects or the Lineage Analysis Objects dialog box (see Controlling the display of object
collections on page 445).
• [from the IAM] Select Tools > Re-Analyze to redisplay all the collections in the model

or right-click an object in the Browser or in the diagram, and select Re-Analyze to
redisplay the object's collections.

• [from preview] Click the root node or an object in the tree and click the Re-Analyze
tool to redisplay all the collections in the model or only the object's collections or
right-click the root node or an object in the tree, and select Re-Analyze.

Changing the Analysis Rule Sets
You can change the rule sets used to analyze your change to see it from a different point of
view, by for example moving from a data impact analysis to a conceptual impact analysis.

You can change analysis rule sets in any of the following ways:

• [from the IAM] Select Tools > Change Analysis Options to open the Impact and Lineage
Analysis Options dialog box. Select an impact rule set and/or a lineage rule set, select
Share or Copy for the rule sets definitions, and click OK to close the dialog box and apply
the new rules to the initial objects.
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• [from preview] Select an impact rule set and or a lineage rule set to apply the new rules to
the initial objects in the tree.

Customizing Actions
The predicted effect on an object in the analysis is called an action. You can modify actions
using the following commands available from the initial and dependent objects contextual
menu in the preview or in the IAM:

• Change Action Description – opens the Action Description dialog box, which lets you
select one or more actions, which have been previously defined in the current rule set (see
Creating a user-defined action on page 446).

• Change Action to [Delete].
• Change Action to [Change].

Printing the Analysis
You can print out your analysis from the preview List tab or from the IAM or create an IAM list
report in order to document and discuss your proposed changes.

You can print the analysis in any of the following ways:

• [from Preview] Click the List tab and select the Print tool (see Preview List tab on page
426).

• [from the IAM] Select File > Print to print the diagram (see Printing Diagrams on page
171).

• [from the IAM] Select Reports > List Report Wizard to create a list report for an object
type and print it (see List Reports on page 216).
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Comparing Two Analysis
Since the IAM is a PowerDesigner model, you can compare the content of two IAMs in order
to:

• Follow up evolutions in models manipulated by different development teams.
• Evaluate the differences that exist between the models.

The comparison window displays the objects contained within the models in a tree format, and
highlights the differences between them.

To compare two IAM's you have to:

• Select Tool > Compare Models to open the Select Models to Compare dialog box.

For detailed information about comparing models, see Chapter 7, Comparing and Merging
Models on page 259.

Customizing the IAM Environment
The IAM environment includes a set of parameters and configuration options that define
various aspects of the model content and behavior.

IAM Model Properties
The model property sheet displays the definition of the current IAM. You can check the last
analysis date of your model or add a comment for example.

To open an IAM property sheet, double-click its Browser entry.

The General tab contains the following properties:

Property Description

Name Specifies the name of the model, which should be clear and meaningful,
and should convey its purpose to non-technical users.

Code Specifies the technical name of the item used for generating code or
scripts, which may be abbreviated, and should not include spaces.

Comment Provides descriptive information about the model.

Filename Specifies the location of the model file. This field is empty if the model
has never been saved.

Author Specifies the author of the model. If you enter nothing, the Author field in
diagram title boxes displays the user name from the model property sheet
Version Info tab. If you enter a space, the Author field displays nothing.

Version Specifies the version of the model. You can use this box to display the
repository version or a user defined version of the model. This parameter
is defined in the Title page of the model display preferences.
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Property Description

Default diagram Specifies the diagram displayed by default when you open the model.

Last analysis date [Read-only] Computed date of the last model analysis, which is updated
every time you re-analyze the model. Click the Re-Analyze tool to re-
analyze the model and update the computed date.

Setting IAM Display Preferences
PowerDesigner display preferences allow you to customize the format of object symbols and
the information that is displayed on them.

To set IAM display preferences, select Tools > Display Preferences or right-click the diagram
background, and select Display Preferences from the contextual menu.

For information about changing the format of symbols, see Format Display Preferences on
page 301. The following sections list the options available to customize the information
displayed on IAM object symbols.
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Analysis Object Display Preferences
To set display preferences for analysis objects, select Tools > Display Preferences, and select
the analysis object sub-category in the left-hand Category pane.

Preference Description

Model name Displays the model name of the analysis object.

Object type Displays the type of the analysis object.

Action Displays the action name of the analysis object.

Highlight initial object Displays a dotted line around the symbol of the initial object.

Analysis Link Display Preferences
To set display preferences for analysis links, select Tools > Display Preferences, and select
the analysis link symbol sub-category in the left-hand Category pane.

Preference Description

Name Displays the name of the link.

Understanding Cross-model Dependencies During the Analysis
When you generate a model to another model or create an external shortcut, you create cross-
model dependencies, which are taken into account during impact and lineage analysis.

When an object belonging to an unavailable related model is encountered a red dot is
displayed on the object icon and the analysis is interrupted. To keep on with the analysis, you
have to open the related model by right-clicking the object in the IAM Browser or in the
preview, and select Open Model.

In the following example, the Employee entity is used to generate the Employee table in the
PDMproj model. This dependency is listed under the Generated Objects folder and a red dot is
displayed on the Employee table to indicate that its parent model is closed:
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Because the repository computes and saves external dependencies information in the checked
in models, you can retrieve from the repository information about external dependencies in a
model if the related model is also checked in.

You can check cross-model dependencies out from the repository in any of the following
ways:

• [from the IAM] Right-click the impacted model node in the Browser, and select Check Out
Dependencies from Repository.

• [from preview] Click the Check Out Dependencies from Repository tool in the toolbar.
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Working with Analysis Rule Sets Resource Files
An impact and lineage analysis provides a report on a list of impacted objects (dependent or
influencing objects), when an action on an initial object is performed. This report is obtained
from the application of one or more analysis rule sets to the initial object.

An analysis rule set resource file is an XML file with a .rul extension, which contains impact or
lineage analysis rules specified on PowerDesigner metamodel objects collections (see 
Understanding dependencies on page 440).

PowerDesigner ships with rule sets that you can customize in the Resource Editor. You can
also create your own rule sets.

The following rule sets are available:

Type Rule Set Description

Impact Conceptual Impact Analysis Restricts the analysis to objects impacted by
modeling changes on the initial object, such
as a modification on a requirement definition.

Data Impact Analysis Identifies the use, if any, of a value contained
in the initial object.

Delete Impact Analysis Restricts the analysis to objects that are di-
rectly impacted by the deletion of the initial
object.

Global Impact Analysis Identifies all the objects that depend on the
initial object.

Lineage Conceptual Lineage Analysis Justifies the modeling existence of the initial
object, and ensures it fulfills a well-identified
need.

Data Lineage Analysis Identifies the origin of the value contained in
the initial object.

Global Lineage Analysis Identifies all the objects that influence the
initial object.

The following example shows the Global Impact Analysis Rule Set open in the Resource
Editor:
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In the above example the Entity metaclass is selected, and displays the list of its associated
analysis rules. The second analysis rule in the list states that if an entity is changed (Action
column), then its associations (Collection column) will also be changed (Effect column). The
third rule states that if an entity is deleted then its associations will also be deleted.

Understanding Dependencies
Each metaclass (object) in the PowerDesigner metamodel is semantically linked with other
objects within the same model, or between different models.

These dependencies appear as categories in an analysis, and can belong to different types of
collections. You specify analysis rules on collections to determine their behavior when an
action on an associated metaclass occurs.

The following types of collections are available:

• Direct collection – objects directly related to the object. This link is displayed as an
association in the metamodel, and the objects usually appear in a list in the object property
sheet. For example, attributes in an entity, or data in a process.

• Inverse collection – objects on which the initial object depends and which are displayed on
the Dependencies tab. For example, diagrams where an object is displayed, or references
using a table.

• Calculated collection – user-defined collection used to display a list of associated objects
with a user-defined semantics on the Dependencies tab. For example, in a model where
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columns and domains can diverge, you can create a calculated collection on the domain
metaclass that lists all the columns that use the domain and have an identical data type.

• Extended collection – user-defined collection used to define an additional link between
two selected metaclasses or stereotypes, and displayed on the Dependencies tab. For
example, you can specify an extended collection in the package metaclass and specify
FileObject as the target metaclass in order to attach documents containing use case
specifications to the different packages of a model.

For more information about creating calculated and extended collections, see the Extending
your Models with Profiles chapter in the Customizing and Extending PowerDesigner manual.

The following example shows that deleting the Employee table will also affect its Columns,
Keys, Indexes, Incoming and Outgoing References collections:

Opening an Analysis Rule Set
You can review analysis rule sets in the Resource Editor.

If you want to edit a rule set, see Editing analysis rules on page 444.

You can open an analysis rule set in any of the following ways:

• [From the Tool menu, without any open model] Select Tools > Resources > Impact and
Lineage Analysis Rule Sets to open the List of Impact and Lineage Analysis Rule Sets
window, which shows all the available analysis rule sets, select a rule set, and then click the
Properties tool to open it.
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For information about the tools available in the List of Impact and Lineage Analysis Rule
Sets window, see the Resource Files and the Public Metamodel chapter in the Customizing
and Extending PowerDesigner manual.

• [from the IAM] Select Tools > Change Analysis Options, and click the Properties tool
next to the rule set to open it.

• [from preview] Click the Properties tool next to the rule set to open it.

Creating an Analysis Rule Set
You can create your own rule sets, which will be available in the List of Impact and Lineage
Analysis Rule Sets window.

1. Select Tools > Resources > Impact and Lineage Analysis Rule Sets to open the List of
Impact and Lineage Analysis Rule Sets window, which shows all the available rule sets.

2. Click the New tool to open the New Analysis Rule Set dialog box, and enter the name that
you want to appear in the List of Impact and Lineage Analysis Rule Sets window.

3. Select one of the following options:

• Impact – to create an impact analysis rule set.
• Lineage – to create a lineage analysis rule set.

4. Select a rule set from the Copy From list. This allows you to create a new analysis rule set
that is identical to the original set apart from the name.

5. Click OK to open a standard Save As dialog box, enter a filename and then click OK to
open the new rule set in the Resource Editor.

In order to populate the new analysis rule set, see Editing analysis rules on page 444.
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Analysis Rule Set Properties
Analysis rule sets contain a list of analysis rules for each metaclass contained in the
PowerDesigner metamodel librairies.

All analysis rule set files can be opened in the Resource Editor, and have the same basic
category structure:

For more information about using the Resource Editor, see "Working with the Resource
Editor" in the Resource Files and the Public Metamodel chapter in the Customizing and
Extending PowerDesigner manual.

The root node of each file contains the following properties:

Property Description

Name Specifies the name of the analysis rule set.

Code Specifies the code of the analysis rule set.

File name [read-only] Specifies the path to the .rul file.

Type Specifies the type of the analysis rule set (impact or lineage).

Comment Specifies additional information about the analysis rule set.

The following libraries are available. You can expand any of these libraries, and select a
metaclass in order to display its associated analysis rules:
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Library name Corresponding model

PdBPM Business Process Model

PdCDM Conceptual Data Model

PdCommon Objects common to all models

PdEAM Enterprise Architecture Model

PdFRM Free Model

PdILM Information Liquidity Model

PdLDM Logical Data Model

PdOOM Object Oriented Model

PdPDM Physical Data Model

PdPRJ Project Model

PdRQM Requirements Model

PdXSM XML Model

For more information about libraries and metaclasses, see the Resource Files and the Public
Metamodel chapter in the Customizing and Extending PowerDesigner manual.

Editing Analysis Rules
You edit analysis rules in the Resource Editor.

1. Open an analysis rule set in the Resource Editor (see Opening an analysis rule set on page
441).

2. Click a library to expand its available metaclasses tree.

3. Click a metaclass in the tree to display its analysis rules.

4. Select an analysis rule, and edit its properties (see Analysis rule set properties on page
443). You can also create or delete analysis rules.

5. Click OK to save the rule set and close the dialog box.

Note: When you modify an analysis rule, you can apply the changes to all the rules in the set
that have the same specified properties by clicking the Apply Changes to Rule Set tool.

Analysis Rule Properties
The following properties are available for each analysis rule:

Property Description

E [Enable] Enables the rule for use in the analysis.
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Property Description

Action Specifies the action on the metaclass, which triggers the application
of the rule. Select or enter an action in the list. You can also create a
user-defined action (see Creating a user-defined action on page
446). For lineage analysis rules, "Lineage" is the only possible
value.

Collection Specifies the name of the metaclass collection on which the rule is
applied. Select a collection from the list. For more information
about collections (see Understanding dependencies on page 440).

Effect Specifies the effect propagated to objects in the collection. Select or
enter an action in the list. You can also create a user-defined action
(see Creating a user-defined action on page 446). For lineage
analysis rules, "Lineage" is the only possible value.

L [Replace Link Object by Ex-
tremity]

Hides the link in the IAM Browser and diagram and/or in the pre-
view tree in order to simplify the display and view only the link
extremity.

R [Recursive] Propagates the effect recursively to the dependent objects of the
objects in the collection.

Controlling the Display of Object Collections
Control the way in which the collections of an initial object or of its dependent and influencing
objects can be displayed to narrow or widen the analysis.

You can specify user-defined collections that can be part of the analysis. For more
information, see the Extending your Models with Profiles chapter in the Customizing and
Extending PowerDesigner manual.

1. Open the Impact (or Lineage) Analysis Objects dialog box in any of the following ways:

• [from the IAM] Right-click an object in the Browser or in the diagram, and select
Change Impact Analysis Objects or Change Lineage Analysis Objects.

• [from preview] Right-click an object in the tree, and select Change Impact Analysis
Objects or Change Lineage Analysis Objects.
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2. Select or clear any of the following check boxes in order to control the display of one or
more collections:

• S [Selected] - Displays the corresponding collection.
• L [Replace link object by extremity] - If the object is a link, hides it to simplify the

display and view only the link extremity.
• R [Recursive] - Displays recursive collections in a single list.

3. [optional] Click the Properties tool to open the analysis rule set properties in the Resource
Editor and edit the properties (see Analysis rule set properties on page 443).

4. [optional] Click the Apply Changes to Rule Set tool to apply the current changes to the
original rule set saved in the Resource Editor.

5. Click OK to close the dialog box.

The display of the selected object collections is updated in the IAM Browser and diagram
or in the preview tree. If you re-analyze your model, only the default collections will be
preserved. These collections are available when at least one analysis rule is specified for
them in a rule set.

Creating a User-defined Action
You can specify a user-defined action on an object to analyze its consequences. You must
previously create the appropriate analysis rule in the Resource Editor.

In the following example, we will create an impact analysis rule, which specify that a
ModifyDataType action on the Data Item metaclass changes its attributes.

1. Open an impact analysis rule set in the Resource Editor (see Opening an analysis rule set
on page 441).

2. Click the PdCDM library to expand its available metaclasses tree.
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3. Select Data Item in the tree, and create the appropriate rule by specifying the following
options:

• Action – enter ModifyDataType, which specifies the action on the data item, and
triggers the impact analysis rule. The Enable check box is automatically selected.

• Collection – select Attributes, which specifies the metaclass collection for which you
define the impact rule.

• Effect – enter ModifyDataType, which specifies the action that is propagated to
attributes.

4. Click OK to save the rule set and close the dialog box.

5. Open the Action Description dialog box in any of the following ways:

• [from the IAM] Right-click a data item in the Browser or in the diagram, and select
Change Action Description.

• [from preview] Click the Impact and Lineage tab, right-click a data item in the tree, and
then select Change Action Description.

6. Enter ModifyDataType in the User-defined Actions field:
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You can enter several actions in a single word using semicolons as separators.

7. Click OK to close the dialog box.

The following example shows how the [ModifyDataType] action on the Employee number
data item affects its Employee number2 attribute, which in turns affects its Idtf_2 identifier:

IAM Custom Checks
PowerDesigner does not provide any predefined checks for the data testing of an IAM.
However, you can create custom checks in an extended model definition.

For more information about how to create custom checks, see "Defining the script of a custom
check" in the Extending your Models with Profiles chapter in the Customizing and Extending
PowerDesigner manual.

You can check an IAM in any of the following ways:
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• Press F4, or
• Select Tools > Check Model, or
• Right-click the diagram background and select Check Model from the contextual menu

The Check Model Parameters window opens, which allows you to specify the kinds of checks
to perform, and the objects to apply them to. For detailed information about this window and
correcting problems reported, see Checking a Model on page 92.
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PART III

Working with PowerDesigner
Plugins

The chapters in this part explain how to use PowerDesigner in the Eclipse and Microsoft
Visual Studio development environments.
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CHAPTER 14 Working with the PowerDesigner
Plugin for Eclipse

The PowerDesigner plugin for Eclipse is available for Eclipse v3.2 to v3.5. Additional
features are available when working in Eclipse.

The PowerDesigner plugin for Eclipse has the following limitations:

• You cannot use the Copy/Paste/Rename features available in the Eclipse contextual menu
for PowerDesigner resources.

• In the standalone PowerDesigner application, you can modify the source code of a class or
interface from its property sheet Preview tab. This feature is not available in the plugin for
Eclipse.

• You cannot export an Eclipse project containing PowerDesigner resources. If you want to
export a project, you must deselect any PowerDesigner resources on the File system page
of the Export wizard or the export will fail.

Getting Started with the PowerDesigner Plugin for Eclipse
During your installation of PowerDesigner, you can choose to install a plugin to allow you to
use PowerDesigner within your Eclipse environment. The PowerDesigner plugin for Eclipse
is available for Eclipse v3.2 to v3.5.

Note: For information about PowerDesigner features specific to Eclipse, see Chapter 14,
Working with the PowerDesigner Plugin for Eclipse on page 453.

When you launch the Eclipse platform for the first time, it opens the workbench window,
which initially displays the Resource perspective. A perspective defines the initial set and
layout of views in the workbench window.

The Resource perspective contains different views:

• The Navigator view displays a tree view of the projects and their resources
• The Editor area displays the content of the projects and resources
• The Outline view displays a content outline of the file being edited. (Except for a plain text

file)
• The Tasks view lists and marks all the tasks and problems to be solved

Note: The PowerDesigner plugin for Sybase Workspace, which is called Enterprise
Modeling, includes all the features of the standard PowerDesigner plugin for Eclipse. When
modeling within the Sybase Workspace environment, we recommend that you use the
Enterprise Modeling perspective.
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Activating the PowerDesigner Perspective
Click the title bar of a view to make it active. (The title bar turns blue). The name of the active
perspective is shown in the title bar of the window and its icon is pushed-in in the shortcut bar.
We recommend you use the PowerDesigner perspective.

1. Click the Open a Perspective icon in the shortcut bar and select Other, or select Window >
Open Perspective > Other, to open the Select Perspective dialog box:

2. Select PowerDesigner in the list of perspectives, and then click OK to display the
PowerDesigner perspective in the workbench window.

Note: Once you have activated the PowerDesigner perspective, a PowerDesigner icon is
displayed in the shortcut bar, which you can click when you need to activate the
PowerDesigner perspective

Activating PowerDesigner Toolbars
Specific toolbars are set by default in the PowerDesigner perspective. If for some reason, they
do not appear in the toolbar section, you can activate them manually.

1. Select Window > Customize Perspective or right-click the toolbar section and select
Customize Perspective in the contextual menu, to open the Customize Perspective dialog
box.
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2. In the Shortcuts tab:

• Select New in the Submenus list, and PowerDesigner in the Shortcut Categories tree
view. The Model icon is selected in the Shortcuts list.

• Select Open Perspective in the Submenus list, and PowerDesigner in the Shortcuts
list.

• Select Show View in the Submenus list, and Sybase in the Shortcut Categories tree
view. The Model Explorer, Modeling Output and Modeling Result List icons are
selected in the Shortcuts list.

3. In the Commands tab, select WorkSpace Modeling Diagram, WorkSpace Modeling
Standard and WorkSpace Modeling View.

4. Click OK.

The PowerDesigner toolbars appear next to the Eclipse toolbars. These toolbars are
common to all PowerDesigner modules. Module-specific toolbars will appear
automatically when you open or create a model.

Using the Window Menu
The Window menu supports all the features concerning perspectives:

Feature Description

Open Perspective Opens a perspective.

Show View Displays a view among the following: Bookmarks, Model Explorer,
Navigator, Outline, Output, Properties, Modeling Result List, Tasks,
Other.

Customize Perspective Opens a dialog box where you select items to be displayed in the
current perspective.

Save Perspective As Saves the current perspective with a predefined or user-defined name,
for future use.

Reset Perspective Resets the current perspective to its default parameters.

Close Perspective Closes the current perspective.

Close All Perspectives Closes all perspectives open in the workbench window.

PowerDesigner Perspective Components
The PowerDesigner perspective contains the following components:

• Model Explorer – Equivalent to the standard PowerDesigner Browser. Allows you to
manage the objects you use to perform a modeling task. It displays your models and the
objects belonging to them in a tree view, and allows you to rapidly navigate between them.
The Model Explorer also has a tab that gives you access to a PowerDesigner repository,
where you can store all your models and associated files.
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• Navigator - displays a tree view of all the resource files attached to Eclipse projects open in
the workbench window. These resource files can be model files, diagram files, source code
files, specification files, or any type of file. You can use the Navigator to open models,
create new projects and models, or even open object property sheets.

• Editor Area – Equivalent to the standard PowerDesigner canvas. The primary pane that
displays your present model diagram or report outline.

• Modeling Output - shows the progress of any PowerDesigner process, such as checking a
model or generating or reverse engineering a database.

• Modeling Result List - displays the results of a search or a model check.

Creating a Modeling Project in Eclipse
You can create a modeling project in Eclipse to group together all your models and other
resources.

1. Select File > New > Project to open the New Project window:

2. Select PowerDesigner > Modeling Project in the list of Wizards and click Next to open
the PowerDesigner New Project window.

3. Specify the project name and location, and select the type of PowerDesigner project to
create. PowerDesigner project templates allow you to create projects that are already
populated with models and/or that contain matrices that help you to follow various
modeling frameworks, such as FEAF.

4. Click OK to create the project.

For detailed information about working with projects, see Chapter 2, Projects and
Frameworks on page 37.

Creating a Model in Eclipse
A model is the basic work unit in PowerDesigner. Every model is contained within a project,
and contains at least one diagram and any number of other objects. Though a model may be
split into packages for organizational reasons or may contain several diagrams, it remains the
fundamental basis for your modeling work.

1. Select File > New > Model to open the New Model dialog box.

If there is no project open in the Navigator view, the Create a new project option is selected
by default and the Add to an existing project option is disabled. An Eclipse project will
then be created for the new model.

or

If there are projects already open in the Navigator view, you can select the Add to an
existing project option.

Select a project. (The new model will appear in the Navigator view within the existing
project)
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2. If you selected an existing project, click Next.

Expand (+) the project, and if it contains folders, select the sub-folder where folder in
which the new model will appear.

You can also create a folder or a sub-folder, to do so select the project or a folder, click the
New Folder button, and type a name in the New Folder dialog box and click OK. (The new
model will appear in the Navigator view within the new folder)

3. Click Finish in the Eclipse New model dialog box.

The New dialog box is displayed.

4. Select the appropriate model for your needs by clicking on it. Note that the tabs on the right
of the dialog box change depending on the model currently selected.

5. Type a name in the Model name box. This is the name of the model. The code of the model,
which may be used for script or code generation, is derived from this name according to the
model naming conventions. You can modify the name and/or code at any time from the
model property sheet by right-clicking the model entry in the Model Explorer and
selecting Properties from the contextual menu.

6. Choose any appropriate options in the right hand tabs (for example, if you are creating a
PDM, you will specify a particular DBMS to model or, for an OOM, you will specify an
object language).

7. If you are creating a BPM, OOM, or PDM, you can also specify the type of diagram you
want to start with (you can add additional diagrams to your model later by right-clicking on
the model in the Model Explorer and selecting New→Diagram_Type).

8. Click OK. The new model will be created in your project in the Model Explorer, and its
default diagram will be opened in the editor area.

Importing an Existing Model into Eclipse
To open an existing model you have to import it into Eclipse.

1. Select File > Import to open the Import dialog box.

2. Select Model in the list and click Next.

3. Type a model filename in the corresponding box or click the Browse button to select a
model from a selection dialog box.

4. Select the Create a linked resource check box if you want to associate the model to the
current project without copying the file to the project location.

5. Select an existing project or create a new project where to open the existing model and
click Finish.

The model default diagram is displayed in the Editor area.

Setting PowerDesigner Eclipse Preferences
The PowerDesigner plugin for Eclipse provides options to customize your environment.
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1. In Eclipse, select Window > Preferences to open the Preferences dialog.

2. Select Sybase, Inc > PowerDesigner or Enterprise Modeling and set preferences as
appropriate:

Preference Description

Close diagram editors on exit By default, when you restart Eclipse, any diagrams that were
previously open will be automatically reloaded. Select this
option to prevent reloading.

Flag diagram editor as dirty if
parent model requires save

Select this option if you want to be reminded that a model has
been modified before you save the changes.

Automatically merge models on
code-to-model synchronization

Select this option if you want the merge process to be silent
during reverse engineering.

3. Click OK.

For information about the standard PowerDesigner options and preferences, see 
Chapter 8, Customizing Your Modeling Environment on page 277.

Generating an Eclipse Java Project from an OOM
You can model the structure of your Java application (including EJBs, Servlets, and JSPs) in a
PowerDesigner OOM and then generate an Eclipse Java Project in which you will complete
the implementation of the classes, and from which you will compile, package, deploy, and
debug the application.

You can use the PowerDesigner plugin for Eclipse to enable round-trip engineering for Java
development:

• Perform high level analysis and design using PowerDesigner
• Design and create Java components in PowerDesigner
• Generate an Eclipse Java project containing the following files:

• A .project file - that defines the name of the project and the build commands

• A .classpath file - that defines the source directory, the binary directory and the
list of libraries

• Source files and other files
• A build.xml for Ant build script - to specify the necessary build tasks and libraries.

• Finish the implementation of Java classes within the generated Eclipse project
• Compile, package, deploy and debug the application
• Reverse engineer the final Java code to synchronize the PowerDesigner model

1. Select Tools > General Options and click the Variables category, then add the following
variables if they are not already present:

• ECLIPSE_HOME - your Eclipse home directory
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• J2EE_HOME - your J2EE SDK home directory

• JWSDP_HOME - [optional] your Java Web Service Developer Pack home directory

2. [optional] Preview the Eclipse .project, .classpath and Ant build.xml files by
right-clicking the model node in the Browser and selecting Properties. Each of the files is
available on its own sub-tab on the Preview tab of the property sheet.

3. Select Language > Generate Java Code to open the Generation dialog.

4. Enter the project folder where you want to generate the files in the Directory field. The
name of this folder will be used as the project name.

5. Verify that Eclipse is selected on the Targets tab.

6. [optional] Click the Selection tab and specify the packages, classes and interfaces that you
want to generate. By default, all objects are generated.

7. Click the Options tab and review the generation options, including those that control the
Eclipse version to generate for and whether to overwrite existing .project
and .classpath files.

8. [optional] Click the Generated Files tab and specify which files will be generated. By
default, all files are generated

9. Click OK to generate the Eclipse Java project.

If you are generating a new project from the PowerDesigner plugin for Eclipse, the project
opens automatically.

When generating code for an existing project, you must refresh the project by right-
clicking the project in the Eclipse Package Explorer and selecting Refresh.

If you have generated the Eclipse project from outside Eclipse, you will need to import the
project into Eclipse by selecting File > Import.

Synchronizing an OOM with Its Java Source
You can synchronize an Object Oriented Model (OOM) with its Java source code, so that each
time you modify the model, a source code file is automatically created (for a new object) or
updated (for an existing object). Similarly, each time you modify a source code file and save
the changes, they appear in the diagram and the Model Explorer.

You can activate synchronization from the Model Explorer or Navigator. A model is
synchronized per package. The default package regroups all the objects at the root of the
model. Once a package has been synchronized with a model, you cannot synchronize it with
another model.

Note: Synchronize is only available for OOMs targeted with Java.
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Activating Synchronization from the Model Explorer
You can activate the synchronization of an OOM from the Model Explorer.

1. In the Model Explorer, right-click the model and select Synchronize to open the
Synchronize dialog box.

2. Select the Synchronized check box, and then select the packages you want to synchronize
with their source code. The default package regroups all the objects at the root of the
model.

3. Click Finish.

A Java file (.java) and compiled file (.class) appear for each object in the synchronized
packages of the Navigator.
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If you double-click a Java or a compiled file, its source code is displayed in the Editor
area.

Note the synchronized symbol on the package icon...

...and the (synchronized) mention beside the model resource.

Activating Synchronization from the Navigator
You can activate the synchronization of an OOM from the Navigator.

1. In the Navigator, right-click the model and select Properties to open the model Properties
dialog box.

2. Select PowerDesigner in the left pane and the Synchronized check box in the
PowerDesigner page.
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3. In the Synchronized group box, select the packages you want to synchronize with their
source code. The default package regroups all the objects at the root of the model.

4. Click OK.

A Java file (.java) and a compiled file (.class) appear for each object in the synchronized
packages of the Navigator.

If you double-click a Java or a compiled file, its source code is displayed in the Editor.

Synchronization Example
The following example is developed from the synchronized OOM, demo.oom

Refresh Source Code

If you change generation templates, you can regenerate source code manually with the
Refresh Source Code feature:

• In the Model Explorer, right-click a class, an interface, a synchronized package or model
item, and select Refresh Source Code

• In a class diagram, right-click a class, an interface or a package symbol, and select Refresh
Source Code

Creating and Deleting an Attribute in a Synchronized Model
You can create and delete an attribute in a synchronized model.

1. Double-click the printer symbol, select the Attributes tab, and add a usbPort attribute with
a boolean data type and a public visibility.
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2. Click OK to return to the class diagram, where the usbPort attribute is displayed in the
printer symbol:

3. Right-click the printer symbol or the printer item in the Model Explorer and select Edit
Source Code to open the source code file of the printer class in a pane directly under the
diagram:
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Note that the usbPort attribute is displayed in the synchronized source code.

4. Delete the code concerning the usbPort attribute.

5. Select File > Save in the Eclipse menu bar.

The usbPort attribute disappears from the printer symbol because the printer class in the
OOM has been synchronized with its source code.
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Synchronizing a Package
You cannot only synchronize a package with one set of source files and each set of source files
with one OOM package.

If you try to synchronize a second model with a package, its check box is unavailable:

Deactivating Synchronization
If you decide to deactivate synchronization, the model and its source code remain as they were
after the last synchronization.

You can deactivate synchronization in the following ways:

• In the Model Explorer, right-click the model item and select Synchronize in the contextual
menu, deselect Synchronized, and click Finish.

• In the Navigator, right-click the model and select Properties in the contextual menu,
deselect Synchronized in the PowerDesigner page, and click OK.

• In the Navigator, right-click a synchronized package and select Unsynchronize.
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Navigating Between an OOM and Its Java Source Code
Once you have synchronized an OOM with its Java source code, you can use the Find In
Diagram and the Model Object Properties features in the contextual menus of the Model
Explorer, the Navigator and the source code files.

Find In Diagram
The Find In Diagram feature allows you to locate an object in a diagram from the Navigator or
a source code file.

Locating an Object from the Navigator
The Find In Diagram feature allows you to locate an object in a diagram from the Navigator.
In the Navigator, right-click an object Java file and select Find In Diagram.

The object symbol is displayed selected (with handles) in the center of the diagram.

Locating an Object from a Source Code File
The Find In Diagram feature allows you to locate an object in a diagram from a source code
file.

1. Double-click the name of an object in a source code file in order to select it.

2. Right-click the object name and select Find In Diagram.

The object symbol is displayed selected (with handles) in the center of the diagram.

Note: To display the Outline view, select Window > Show View > Outline. Activate a model
diagram. When you click an object in the Outline view, it triggers a Find In Diagram. The
object symbol is displayed selected (with handles) in the center of the diagram.

Model Object Properties
The Model Object Properties feature allows you to display an object property sheet from the
Navigator or a source code file.

Displaying an Object Property Sheet from the Navigator
The Model Object Properties feature allows you to display an object property sheet from the
Navigator.
Right-click an object Java file in the Navigator and select Model Object Properties in the
contextual menu.

The object property sheet is displayed. You can now define or modify the object properties.
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Displaying an Object Property Sheet from a Source Code File
The Model Object Properties feature allows you to display an object property sheet from a
source code file.

1. Double-click the name of an object in a source code file.

The object name is selected.

2. Right-click the object name and select Model Object Properties in the contextual menu.

The object property sheet is displayed. You can now define or modify the object properties.
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CHAPTER 15 Working with the PowerDesigner
Plugin for Visual Studio

The PowerDesigner plugin for Microsoft Visual Studio and Team Foundation is available for
Visual Studio 2005 to 2008. Additional features are available when working in Visual Studio.

Getting Started with the PowerDesigner Plugin for Visual
Studio

During your installation of PowerDesigner, you can choose to install a plugin to allow you to
use PowerDesigner within your Visual Studio environment. The PowerDesigner plugin for
Microsoft Visual Studio and Team Foundation is available for Visual Studio 2005 to 2008.

All Visual Studio development takes place in "solutions", which contain "projects". You can
create PowerDesigner models directly within a solution, or within any type of project,
including the PowerDesigner-specific "modeling project".

Creating a Modeling Project in Visual Studio
You can create a modeling project in its own standalone solution, or add a modeling project to
an existing solution.

1. [optional] Open an existing solution to which you want to add the modeling project.

2. Select File > New > Project to open the New Project window:
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3. Select PowerDesigner in the Project types pane, and then Modeling Project in the
Templates pane.

4. Enter a name for the project, and specify a location for its files.

5. Select one of the following options in the Solution field:

• Add to Solution – to add the project to an existing solution
• Create new Solution – to create a new solution.

6. Click OK to go to the PowerDesigner New Project window:
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7. Select the type of PowerDesigner project to create. PowerDesigner project templates
allow you to create projects that are already populated with models and/or that contain
matrices that help you to follow various modeling frameworks, such as FEAF.

8. Confirm the name, location, and root, and click OK to create the project.

For detailed information about working with projects, see Chapter 2, Projects and
Frameworks on page 37.

Creating a Model in Visual Studio
You can create any of the model types supported by PowerDesigner from within Visual
Studio. The following procedure focuses on how to create an object-oriented model (OOM).

1. Select a project in the Solution Explorer.

2. Select File > New > File to open the New File window:
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3. Select PowerDesigner in the Categories pane, and the type of model that you want to create
in the Templates pane.

4. Click OK to open the New Model window:

5. Select one of the following radio buttons:

• New model – Creates a new, standard, model.
• New model from template – Creates a model from a model template, which can contain

pre-configured options, preferences, extensions, and objects. For more information,
see Model Templates on page 97.
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6. Enter a model name. The code of the model, which is used for script or code generation, is
derived from this name according to the model naming conventions.

7. Select an Object language from the list.

Object languages are defined in dedicated XML files (with a .XOL extension), which are
provided as part of your PowerDesigner installation in the "\Resource Files\Object
Languages" directory, and contain all the syntax and specifications for each target
language.

8. Select one of the following radio buttons:

• Share the object language definition – use the original object language file in the
"Resource Files\Object Languages" directory. Any changes made to the object
language are shared by all linked OOM.

• Copy the object language definition in model –copy the object language file to the
model. The copied object language is saved with the OOM and cannot be used without
it. It is not affected by modifications made to the original language in the Object
Languages directory.
For more information on object language properties and customizing an object
language, see "Resource File Reference" and "Working with the Resource Editor" in
the Resource Files and the Public Metamodel chapter of the Customizing and
Extending PowerDesigner manual.

9. Select the type of the first diagram in the First Diagram list. The first type of diagram
selected remains in memory, and is the default for the next time when you create a new
OOM.

You can create as many diagrams as you need in the same OOM. They are sorted
alphabetically in the Model Explorer, except the diagram specified here, which is always
the first in the list.

10. [optional] If you want to attach one or more extended model definitions to complement the
selected object language, click the Extended Model Definitions tab, and select the
extended model definitions of your choice.

For more information on attaching extended model definition to a model, see "Extended
Model Definitions" in the Resource Files and the Public Metamodel chapter of the
Customizing and Extending PowerDesigner manual.

11. Click OK to create the OOM.
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The Visual Studio Development Environment
The Visual Studio development is highly configurable, with many different explorers and
other windows that can be moved all over the screen and be docked and tabbed together.
Consequently, the screen below shows only one possible configuration:

The main screen areas displayed here are as follows:

• The Toolbox is equivalent to the PowerDesigner Palette, and is the area where you choose
tools to build your diagrams.

• The Document Window is equivalent to the PowerDesigner canvas, and is the space where
you build your model diagrams.

• The Model Explorer is equivalent to the PowerDesigner Browser, and lists all the models
in your project along with all their model objects displayed in a tree view.

• The Properties window is equivalent to a PowerDesigner property sheet, and lists the
properties of the currently selected object. Note that regular PowerDesigner property
sheets are also available.

PowerDesigner Menus
The following PowerDesigner-specific menus are available in the Visual Studio menu bar:

• Diagram [View in the standard PowerDesigner interface] – tools for manipulating model
diagrams
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• Model – lists of model objects
• Symbol – tools for manipulating diagram symbols
• Language/Database etc. – depending on the type of model currently open in the document

window, this menu will change to provide tools for manipulating the subject of your
model, including code generation and reverse-engineering

• Repository – tools for working with the PowerDesigner model repository
• Model Tools [Tools in the standard PowerDesigner interface] – tools for manipulating the

model

Other PowerDesigner menu functions are integrated into the standard Visual Studio menus.

Working with an RQM and Visual Studio Team System
A PowerDesigner Requirements Model (RQM) is used to create a hierarchy of project
requirements that must be fulfilled during the development of the project.

For detailed information about developing and using an RQM, see the Requirements
Modeling guide.

You can export RQM requirements to one or more Visual Studio Team System projects and
then create task work items to structure how the requirements will be fulfilled. Doing so,
permits you to link the power and simplicity of a PowerDesigner hierarchical RQM to your
use of the Visual Studio Team System.

The RQM/Team Project Toolbar
The RQM displays the following toolbar when you are connected to a Team System server:

Icon Description

Import Requirements – imports requirement work items from a Team System project to an
RQM. See Importing Team Project Work Items to an RQM on page 480.

Export Requirements – exports requirements from an RQM as work items to a Team System
project. See Exporting RQM Requirements to a Team Project on page 476.

Update Requirements – updates the content (for example, description, status) of require-
ments already exported to a Team System project. See Updating Requirement Work Items
Linked to an RQM on page 482.
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Exporting RQM Requirements to a Team Project
Once you have created a requirements model you can export your requirements to a Team
project as work items. The exported requirements retain a memory of their place in the
requirements hierarchy:

To begin an export, you must be connected to a Team System server and have created a Team
project to receive your requirements.

You can export requirements from a single RQM to many Team projects by running the export
wizard multiple times, but you cannot export the same individual requirement to more than
one project.

1. Review the Team Explorer pane to ensure that you are connected to a Team System server,
and that you have created an project to receive your requirements.

2. Select Team > Requirements > Export (or click the Export Requirements tool) to open
the Export Requirements wizard.

3. The Team Project screen allow you to specify to which project you will export your
requirements and, optionally, an Area and/or Iteration, if these have been defined for the
project.
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Note that, although you cannot select multiple projects to export to on this screen, you can
relaunch the wizard as many times as necessary to export your requirements to a variety of
projects.

4. Click Next to continue. The Requirements Selection screen allows you to specify which
requirements you want to export. All requirements are shown except those that have
already been exported to another project, or to another area or iteration of the present
project.

Specify a requirement to export by selecting its checkbox. If you select the Export leaf
requirements only checkbox, then only those requirements without children will be
exported.
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5. Click Next to continue. The Work Item Type screen allows you to specify the type of work
item to which your RQM requirements will be exported. You can select an existing type or
create a new one.

This screen also allows you to specify how the properties of the RQM requirements will be
mapped to the fields of the designated work item type. Certain fields, such as the Title and
Description are hard-coded and cannot be changed. You can choose a Work Item Field for
the other properties by clicking on the entry, and then selecting the appropriate field (or
Add, in the case of a new work item type) from the list.

If you select to create a new work item type, you must create a new field for each of the
Requirement Properties you want to export by clicking in the Work Item Field column and
selecting Add from the menu, and specifying a Name for the field.

Note that any mappings set at this stage cannot be changed for subsequent exports,
although you can specify additional property-to-field mappings.

6. Click Finish to begin the export. When it is complete, you can view the work items that you
have created by accessing one of the standard queries in the Team Explorer, or writing your
own.

Linking Work Items to Requirements
Once your requirements have been exported into Team project work items, you will need to
create associated work items (generally of type Task), in order specify how they will be
fulfilled. You may link multiple Tasks and other work items to your requirements and, in
general, treat them like any other work items.

1. Display your requirement work items by using the All Work Items team query, or by
writing your own. In the window below, I have written a query called
RequirementsWorkItems to display only the requirements:
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2. Right-click a requirement in the list, and select Add Related Work Item > Task (or another
work item type) to create the new work item:

3. Complete whichever fields you deem necessary in order to specify the nature of the work
item. If you click on the Links sub-tab, you will see that it is linked to the original
requirement.
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For more information about the Team system, see your Microsoft documentation.

Importing Team Project Work Items to an RQM
We recommend that you begin by developing an RQM, export your requirements to a Team
project, and then add tasks to fulfill the requirements. However, there may be a situation where
you develop requirements in the Team project, and then wish to import them to a new or
existing RQM.

1. Review the Team Explorer pane to ensure that you are connected to a Team System server,
and that the project from which you want to import is available.

2. Open a new or existing RQM in Visual Studio, and select Team >  Requirements >
Import (or click the Import Requirements tool) to open the Import Work Items Wizard.

3. The Team Project screen allow you to specify from which project you will import your
work items and, optionally, an Area and/or Iteration, if these have been defined for the
project.
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4. Click Next to continue. The Work Item Type screen allows you to specify the type of work
item from which your RQM requirements will be imported. Note that the type may not be
changeable if you have previously specified a mapping during an export for this project.

This screen also allows you to specify how the fields of the designated work item type will
be mapped to the properties of the RQM requirements. Note that certain fields, such as the
Title and Description, cannot be changed. You can choose a Requirement Property for the
other fields by clicking on the entry, and then selecting the appropriate property from the
list.

Note that any mappings set at this stage cannot be changed for subsequent imports,
although you can specify additional field-to-property mappings.
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5. Click Next to continue. The Work Items screen allows you to specify which requirements
you want to import. Work Items appear greyed and cannot be selected if they are already
linked to requirements in the current or another requirements model.

Select the Create traceability links checkbox if you want to retain links between the
requirement work items in your Team project and the RQM. Note that traceability links
can only be created for work items that are not already linked with another RQM.

6. Click Finish to begin the import. Any hierarchy defined between the work items will also
be preserved.

Updating Requirement Work Items Linked to an RQM
Once you have exported your requirements from an RQM to a Team System project, it is
possible that you will continue to edit the details of these items (by adding or editing a detailed
description, changing the status, or any of the other available properties). To cascade these
edits to your requirements work items held with a Team System project, simply select Team >
Requirements > Update (or click the Update Work Items tool).

The Update tool refreshes all the requirement work items exported to any number of Team
System projects. Note that it does not export any new requirements (this requires that you use
the Export tool) and that it does not update any changes made in requirement work items to
their counterparts in the RQM.

Navigating Between RQMs and Team Projects
PowerDesigner provides various methods for navigating between an RQM and a Team
System project

When working in the Model Explorer, you can, at any time, double-click the file named after
your Team server and project (auto-generated in the Files folder):
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Doing so will navigate to the linked Team Project in the Team Explorer:

To navigate to a particular requirement work item (linked via a traceability link to an RQM
requirement), right-click the requirement in an RQM document view, and select Team
Foundation > Work Item Properties from the contextual menu:
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Creating a Traceability Links Matrix to Track Requirement Work Items
A Traceability Links Matrix View can list all the traceability links between your requirements
and work items.

1. Select Requirements > Create a Traceability Matrix View.

2. In the Matrix View toolbar, click the Change Traceability Matrix Type tool, and then select
the External files radio button in the dialog box.

3. Click OK. The Matrix View will display a column for each of the Team System projects to
which you have exported requirements, with a check mark in the cell of each requirement
that is linked to a work item by a traceability link:

For more information about the Traceability Matrix View, see the Requirements Modeling
guide.

You can also view the links to work items by opening the property sheet of a requirement and
clicking the Traceability Links tab. Select the link and then click the Properties tool to go to the
associated work item:
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Model-Code Synchronization
By using code synchronization with PowerDesigner genlets, you can realize aspects of the
model-driven development process to improve productivity through the automation of code
generation. The PowerDesigner plugin for Visual Studio provides the capability for
instantaneous bidirectional updates of model objects and actual code, including automating
the transformations and merging of generated files.

Code Synchronization
The PowerDesigner plug-in for Visual Studio enhances the standard PowerDesigner code
generation and reverse-engineering to permit real-time synchronization of model and code.

You configure synchronization initially through the Synchronization Wizard, and then can
continue with development, with additional changes automatically cascaded to the code.

Note that code synchronization is available for all PowerDesigner diagrams and models
supporting generic generation, and thus could be used with, for example, a state diagram, or a
BPM (Business Process Model).

1. Create an empty Visual C# or other code project, and then add your model project to the
solution.
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2. Select the model in the Solution Explorer, and then click the Synchronize tool in the
toolbar (or Synchronize from the contextual menu) to open the Synchronize dialog at the
Code Generation page:

3. This page allows you to specify file types that will be synchronized for forward generation
(i.e. changes made to model objects will be cascaded down immediately to the code files).
File types are organized by generation targets (C# 2.0 and WSDL for .NET in the
screenshot above), and defined in the resource file or extended model definition for the
target.

Select the file types that you want to synchronize for forward generation.

4. [optional] Select a file type and click the Details button to open the Generation Details
dialog (see Custom Generation Post-Processing with Genlets on page 488 for more
information):

5. Click Next to move to the Reverse-engineering page of the Synchronization dialog:
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This page, which is available only for C# and Visual Basic projects only) allows you to
specify file types that will be synchronized for reverse-engineering (i.e. changes made in
the code files will be cascaded up immediately to the model objects).

Select the file types that you want to synchronize for reverse-engineering.

6. Click Next to move to the Files page of the Synchronization dialog:
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This page allows you to specify the specific files that will be synchronized, and where they
will be generated.

By default:

• If the model is located directly in a solution folder (outside of a project) or in a
modeling project, the files are generated at the root of the solution, and project files are
added as projects in the Solution Explorer.

• If the model belongs to any other project type, the files are generated by default at the
root of the project, or in another folder within the project specified in the Root Folder
field.

If there is the possibility of a conflict because both model object and file already exist, the
file will not be selected to generate by default, and its checkbox will carry a small red cross.
To force synchronization and specify who will have priority, click the checkbox and select
Overwrite file or Overwrite model from the contextual menu. You can also click Select All
select all the files for overwriting.

7. Select the files that you want to synchronize and click Finish.

The wizard generates and marks as synchronized all the specified files.

Controlling Synchronization
Once you have synchronized your model and files, the synchronization tool and Synchronize/
Unsynchronize contextual menu options become available for each file to permit you to
disable or enable synchronization on a file-by-file basis.

Note that a record of the synchronization state of all the files in the solution is stored in a file
with the name of the project or solution and the extension ".pdsync".

1. Select the file in the Solution Explorer. If the file is currently synchronized, the
Synchronize tool is displayed as depressed in the Solution Explorer toolbar.

2. Click the Synchronize tool to change the state of the file. If the file was not previously
synchronized, the Merge Model window will open to enable you to review the changes that
synchronization will make.

Custom Generation Post-Processing with Genlets
Model-code synchronization provides a powerful method for visualizing your code and
providing a strong link between your source files and model objects. PowerDesigner genlets
enable you to additionally automate post-generation transformations and handle complex
merging of changes to your files.

Genlets are small .NET classes that can be automatically invoked by the synchronization
process to perform transformations on the generated files.

There are two kinds of genlets:

• Transformlets – perform a transformation on a generated file. They allow you to define
reusable cross-target policies to be applied to generated code. For example, you could use
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transformlets to add a standard header and footer to every file or to ensure that every static
field name begins with an underscore
You can chain multiple transformlets together to perform various steps in a transformation.

• Mergelets – are of use whenever a given file is being regenerated and the target content
may change independently of the model. This may be the case with an XML document in
which some sections are generated from a model and others are modified by another
system or where standard code skeletons are generated and custom code is added inside the
code editor.
In the case of source code, mergelets can be used to maximize readability by preserving
order and formatting over multiple generation cycles, by comparing and merging elements
at the code model level addresses this issue.
Although especially useful for languages that do not offer partial class support (facilitating
the separation of generated and user code), code model mergelets may nonetheless be of
use with the VB and C# programming languages. Only one mergelet may be used for each
generation.

PowerDesigner provides C# templates for three forms of transformlets and mergelets:

• Text genlets– transform any text file
• Xml genlets - manipulate XML data via the System.Xml classes
• Code-model genlets - use VisualStudio parsers and the CodeModel API to traverse and

transform source files

Creating a Genlet
You create genlets in a C# or other .NET projects.

1. Right-click your project in the Solution Explorer and select Add > New Item.

2. In the Add New Item dialog, expand the PowerDesigner category and select the File
Synclets item.

3. Choose a genlet type, specify a name, and then click OK to create the item. The editor
opens to display the genlet template:
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4. Enter your transformation code and save the file:

5. Right-click your model in the Solution Explorer and select Synchronize, to open the
Synchronization wizard (see Code Synchronization on page 485).
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6. On the Code Generation page, select a file type (for example Source), and click the Details
button to open the Generation Details dialog:

This dialog allows you to specify whether to synchronize object and file creation and
deletion, and also to add any genlets.

7. Click the Add button to open the Add Genlet dialog:

Select the genlet to add (or click the Open Assembly button to choose additional
assemblies from which to select your genlets) and click OK to return to the Generation
Details dialog, and then click OK again to return to the Synchronize dialog.
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8. [optional] Select a transformlet and use the Up and Down arrows to change its position in
the chain of genlets. Use the Remove button to remove the selected genlet.

9. Once you have completed the Synchronization wizard and generated your files, the
transformation specified will have been applied to all the files of the specified type.

Note that changes to genlets are not automatically updated in synchronized files. When you
change a genlet, you must then click the Refresh tool in order to force a synchronization.
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mapping 392

SQL query
execution 31

standalone seat 31
stereotype 334

extended dependencies 334
style sheet

structure 253
sub-diagram in decomposed object symbol 191
sub-object

mappings property sheet 415
object mapping 419
replicate 374
replicate by drag and drop 375

sub-replication 376
desynchronize 379

SVG (Scalable Vector Graphics) 203
Sybase Workspace

licensing 32
symbol

align 188
content 191
custom shape 191
default size 301
delete 130
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display 182, 188, 294, 301
edit in place 101
fill 191
font 191
hidden 188
line style 191
locate in diagram 190
manipulate 184
modify 182
move with keyboard arrows 188
preference 301
print 171
select 182
shadow 191
show in diagram 188
size 183, 191
text alignment 191

symbol sizer 183
synchronization 485

activate synchronization 459
deactivate synchronization 465
example 462

synchronize
replica 378
shortcut 361

synchronizing 332
sysam.properties 34
system add-in 310

T
tab

favorite 107
table

column 244
default 244

table of contents
limit depth level 239

target
list of models 367

target model 346, 355
change 368
change library model 368
delete shortcuts in list 369
replication 371
unresolved 368

target object 355
dependencies 364
modify 361

properties 360
replication 371
shortcut 364

team leader 7
Team System 476

navigating to requirements model 482
template

artifact 157
create from a report section 256
create model 12
model template 97
naming conventions 317
report 255

tester 7
text

align 191
assign to lines 201
assign to polylines 201
color 301
edit 243
font 239
format 239
free 201
in shape 201
insert 201
title 239

text alignment 191
text editor

options 305
title

format 239
removed from report 245
report item 233
text 239

tool
complete links 362
delete in a toolbar 324
select 182

toolbar
create 324
customize 101, 324–326
delete 326
Eclipse 454
hide 326
manage 324
palette 101
show 326

traceability link 332
transformation
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add in menu 346
apply 346
command 346
generate 343

transformlet 488, 489
tree view

diagram 168
drag and drop 126

trial version 31
troubleshooting license management 34

U
unresolved

change target model 368
status 368

update requirements 475
use parent namespace 92
user add-in 310
user profile

adding to install image 283
applying 278
copy preferences from a model 280
creating 278
display preferences 277
General Options 277
List of User Profiles 281
Model Options 277
Resource Editor 282
updating 279

user-defined action 446

V
validate model 92
variable option 306
VB .NET artifacts 153
version info 114
video 11
view

outline 466
Visual Studio

development environment 474
development menus 474
model 471
project 469

Visual Studio Team System 475

W
warning 94
Welcome page 4
wildcard 120
window

dock 322
manage 322

window menu (Eclipse) 455
WMF (Windows MetaLayout Format) 203
word wrap

code 101
name 101

work item
importing to requirements model 480
linking to requirement 478
updating from requirements model 482

workspace 5, 82
CDM and PDM in same workspace 82
change 84
create 83
define 82
delete 84
open 84
properties 82
save 84
save all 84

WYSIWYG 292

X
XEM (extended model definition) 326
XML

add-in 310
XML language

merge 268
resource 326

XML validation 310
XPATH expression 406

Z
zoom for graph 243
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