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About This Book

Audience This book is for new InfoMaker® users. 

How to use this book This book introduces InfoMaker and provides a tutorial for learning to use 
InfoMaker. The lessons teach InfoMaker basics and how to create forms, 
reports, queries, and graphs. The last lesson puts everything into an 
InfoMaker application.

Related documents When you have a question about using InfoMaker, you can access its 
online Help system or consult one of the following books:

Other sources of 
information

Use the Sybase® Getting Started CD, the SyBooks™ CD, and the Sybase 
Product Manuals Web site to learn more about your product: 

• The Getting Started CD contains release bulletins and installation 
guides in PDF format, and may also contain other documents or 
updated information not included on the SyBooks CD. It is included 
with your software. To read or print documents on the Getting Started 
CD, you need Adobe Acrobat Reader, which you can download at no 
charge from the Adobe Web site using a link provided on the CD.

Book Description

Installation Guide Provides instructions for installing InfoMaker

Getting Started Introduces you to InfoMaker and provides a tutorial you 
can step through to learn the basics

Users Guide Tells how to use InfoMaker to create reports, work with 
databases, transfer data between databases, create forms to 
update data, create queries to retrieve data automatically, 
and create applications to package reports and forms

Connecting to 
Your Database

Tells how to connect to a database from InfoMaker; 
describes how to set up, define, and manage database 
connections accessed through a standard database 
interface (such as ODBC or JDBC) or one of the 
InfoMaker native database interfaces
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• The SyBooks CD contains product manuals and is included with your 
software. The Eclipse-based SyBooks browser allows you to access the 
manuals in an easy-to-use, HTML-based format.

Some documentation may be provided in PDF format, which you can 
access through the PDF directory on the SyBooks CD. To read or print the 
PDF files, you need Adobe Acrobat Reader.

Refer to the SyBooks Installation Guide on the Getting Started CD, or the 
README.txt file on the SyBooks CD for instructions on installing and 
starting SyBooks.

• The Sybase Product Manuals Web site is an online version of the SyBooks 
CD that you can access using a standard Web browser. In addition to 
product manuals, you will find links to EBFs/Maintenance, Technical 
Documents, Case Management, Solved Cases, newsgroups, and the 
Sybase Developer Network.

To access the Sybase Product Manuals Web site, go to Product Manuals at 
http://www.sybase.com/support/manuals/.

If you need help Each Sybase installation that has purchased a support contract has one or more 
designated people who are authorized to contact Sybase Technical Support. If 
you cannot resolve a problem using the manuals or online help, please have the 
designated person contact Sybase Technical Support or the Sybase subsidiary 
in your area.
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C H A P T E R  1 Welcome to InfoMaker

InfoMaker is a powerful yet easy-to-use reporting and data maintenance 
tool that lets you work with data in the Windows environment.

With InfoMaker you can create sophisticated forms, reports, graphs, 
crosstabs, and tables, as well as applications that use these as building 
blocks. You can also move data between databases using the InfoMaker 
data pipeline.

This chapter describes:

• What you make with InfoMaker

• Starting InfoMaker

• Using the tutorials

• InfoMaker samples
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What you make with InfoMaker 
Forms

Reports
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Crosstabs

Reports with nested 
reports
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Composite reports

Forms with reports
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Graphs

Reports with graphs
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Labels

Applications
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Starting InfoMaker 
These instructions assume that you have already installed InfoMaker.

For information, see the Installation Guide.

❖ To start InfoMaker using the Windows Start menu:

• Display the Start menu and select All Programs, then Sybase, then 
InfoMaker 12.0, and then InfoMaker 12.0. The initial InfoMaker screen 
displays.

The initial screen includes the PowerBar, which has buttons for creating 
new objects and accessing existing objects. 

Notice that the buttons on the PowerBar display icons with no associated text. 
You can display button text if you want to, and you will learn to do that in 
Lesson 1.
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Using the tutorials 
Requirements To use the InfoMaker tutorials, you need to:

• Be connected to the EAS Demo DB

• Have the sample library named tutor_im.pbl open 

If you do not have 
SQL Anywhere

This tutorial uses the EAS Demo DB database that installs with InfoMaker. 
This is a SQL Anywhere™ database and requires a SQL Anywhere engine.

• If you do not already have SQL Anywhere on your local machine or 
server, you must install it now. (You can install it from the product CD.) If 
you installed InfoMaker in a nondefault location, you must make sure that 
the odbc.ini registry entry defining the EAS Demo DB as a data source 
points to the correct location of the SQL Anywhere engine.

Approximate times

InfoMaker samples 
The InfoMaker sample library named tutor_im.pbl is the library you use in the 
tutorials. The tutor_im.pbl library includes sample reports, forms, a sample 
query, and a sample pipeline. After you have finished with the tutorials, you 
might want to look at these samples to learn more. Many of the samples are 
discussed in the InfoMaker Users Guide. 

Tutorial Lesson Minutes

InfoMaker Basics 1 15

Form 2 45

Report 3 45

Table 4 45

Query 5 15

Graph 6 30

Environment 7 30

Application 8 30
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L E S S O N  1 InfoMaker Basics Tutorial

The InfoMaker world is a friendly and efficient environment in which to 
work. It provides features such as movable toolbars, pop-up menus, views, 
and more.

In this tutorial you learn the basic skills you need for working in 
InfoMaker.

How long does this tutorial take?
About 15 minutes.
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Start InfoMaker 

Where you are
> Start InfoMaker

Access objects and painters
Use toolbars
Use views
Use pop-up menus
Use the mouse with controls

First you start InfoMaker.

1 Display the Windows Start menu.

2 Select All Programs, then Sybase, then InfoMaker 12.0, and then 
InfoMaker 12.0.

The InfoMaker initial screen displays. It includes the PowerBar, which has 
buttons for various InfoMaker activities.
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Access objects and painters

Where you are
Start InfoMaker

> Access objects and painters
Use toolbars
Use views
Use pop-up menus
Use the mouse with controls

1 Click the Open button in the PowerBar.

Your toolbar does not show text on the buttons by default. You learn how 
to display text in a few minutes.
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The Open dialog box displays. It lists the objects in the current library, 
which is the library named tutor_im.pbl. This library includes samples that 
come with InfoMaker; it is the library you use for the tutorials.

If the current library is not tutor_im.pbl
If the current library is not tutor_im.pbl, you need to change it. Select 
File>Select Library and use the Browse page to navigate to tutor_im.pbl 
in the Tutorial folder (in your My Documents or Documents folder under 
Sybase\InfoMaker 12.0\Tutorial). Then click the Open button in the 
PowerBar.
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2 Select Reports as the Object type at the bottom of the dialog box.
Click expenses (scroll the list until you see the report named 
expenses) and then click OK.

InfoMaker connects to the EAS Demo DB and the report displays in the 
Report painter. You learn about the Report painter in the Report tutorial. 
For now you learn basic skills.

First you are going to make a few settings in your working environment.

3 If InfoMaker does not fill your screen, click the maximize box in the 
upper-right corner of the InfoMaker frame.

InfoMaker fills the screen.
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4 Select View>Layouts>(Default) from the menu bar.

InfoMaker displays the Report painter default layout of views. (Your 
views may already have been set to the default. Now you know how to get 
back to the default anytime you want to.)

Now you close the views at the bottom of the screen since you are not 
going to be using those views.

5 Move the pointer until it is over the Close button (the button with the 
X in it in the upper right) in the Export/Import Template view and click 
the button.

The view closes and the tabbed view (originally positioned on the bottom 
right) displays in the full horizontal space.
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6 Now close the tabbed view using the same process you used with the 
Export/Import XML Template view.

Your screen should look something like this now. Because InfoMaker 
offers so much flexibility in arranging your work area, your screens may 
not match many of the pictures in the remaining lessons. It does not matter 
as long as you are getting the correct results.
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Use toolbars 

Where you are
Start InfoMaker
Access objects and painters

> Use toolbars
Use views
Use pop-up menus
Use the mouse with controls

InfoMaker comes with several toolbars: the PowerBar, three PainterBars, and 
the StyleBar. You can control whether individual toolbars display and where 
they display. You can also choose whether to display text in the toolbars.

In this exercise you learn how to use toolbars.

(You can also create your own toolbars and customize toolbars. See the 
InfoMaker Users Guide for more information.)

1 Move the pointer to the toolbar area.
Click the right mouse button.

The pop-up menu for the toolbars displays.

About the pop-up menu
Throughout InfoMaker, pop-up menus provide a fast way to do things. The 
right mouse button accesses the pop-up menu. The menu changes 
depending on the painter you are in and where you are when you click the 
right mouse button.
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2 Select Floating from the pop-up menu.

The PainterBar changes to a floating toolbar.

3 Move the pointer to the title bar and drag the floating toolbar to 
another location.

How to drag the toolbar
Press and hold the left mouse button. While holding the button, move the 
mouse (an outline displays to show the current location of the toolbar). 
When the toolbar is where you want it, release the mouse button.

You can put toolbars in different locations: left, top, right, bottom, and 
floating.

4 Select Tools>Toolbars from the menu bar.

About the notation Tools>Toolbars
Throughout the tutorials, commands issued from the menu are shown as a 
sequence of choices separated by arrows. For example, to select 
Tools>Toolbars means to select Tools from the menu bar and then 
Toolbars from the menu items.

The Toolbars dialog box displays. Notice that the PowerBar is highlighted. 
If the PowerBar is currently displayed, the middle button says Hide.

5 Click PainterBar1 and then click the Bottom button.

The PainterBar displays at the bottom of the InfoMaker screen.
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6 Click Show Text to make text display on the buttons.
Click the Close button to close the dialog box.

7 Move the pointer over one of the toolbar buttons.

After a couple of seconds, the PowerTip that tells what the button does 
displays.
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8 Click the small black triangle next to the Text button in the PainterBar.

The Objects drop-down toolbar displays. It holds buttons for the controls 
you can add to reports. (A text control is one type of control you can add 
to a report.) Several buttons on other PainterBars have small black 
triangles. These buttons belong to other drop-down toolbars (such as the 
Border drop-down toolbar).

9 Click in the white space to the right of the toolbar to make the Objects 
drop-down toolbar close.

Now you know several ways to move the toolbars and you know how to turn 
text display on and off.

For the rest of these tutorials, you should move the toolbars where you like to 
have them. Your screen may not match the pictures in this book, depending on 
where and how you display toolbars.
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Use views

Where you are
Start InfoMaker
Access objects and painters
Use toolbars

> Use views
Use pop-up menus
Use the mouse with controls

InfoMaker provides a number of views in each painter to make it easier for you 
to work. The View menu in each painter lists the views available to you. You 
can use the View menu items to display and close the various views. In this 
exercise you learn how to manage views.

1 Move the pointer to the upper-left corner of one of the views.
When the bar drops and the pushpin displays, click the pushpin.
Repeat this for the other two views.

Now the three views have title bars that identify the Design view, the 
Preview view, and the Properties view.
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2 Move the pointer to the Preview view’s title bar and press the right 
mouse button.
Select Float from the pop-up menu.

Now the view is floating. You can drag it wherever you want it and resize 
it as needed.

3 Display the pop-up menu on the Preview view’s title bar and select 
Dock.

The view goes back to where it was. There are more options for moving 
views around, including dragging them and overlaying one view on top of 
another to make tabbed views. You can read about these in the InfoMaker 
Users Guide.
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Use pop-up menus

Where you are
Start InfoMaker
Access objects and painters
Use toolbars
Use views

> Use pop-up menus
Use the mouse with controls

Now you take a look at pop-up menus and the Properties view. 

1 Move the pointer to the words Expenses for.
Click the right mouse button.

The pop-up menu for a piece of text (also called a text control) displays. 
Whenever you position the pointer on something that has a pop-up menu 
and click the right mouse button, the appropriate menu items display.
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2 If the Properties view is not currently displayed, select Properties from 
the pop-up menu.
Look at the contents of the Properties view.

The Properties view displays the properties of the Expenses for text 
control because the text control is currently selected. For a text control, the 
Properties view has eight tabs, which identify eight pages of information. 
The General page is on top.

About the Properties view
The Properties view displays a collection of information about a control or 
the report object itself. You use the Properties view to find out and set 
properties.

For example, a text control has properties such as font, font size, location, 
border, and so on. You can see the current settings for these properties in 
the control’s Properties view. You can also change them there.
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3 Position the pointer on the word description and click.

The Properties view now displays information for the data column 
(Column control) called description. The property pages and options are 
different from those for the text control. 

4 Click the word Font on the Font tab.

The Font page comes to the front of the Properties view.
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5 Select the font size 14 from the drop-down list in the Size box.

The font size of the text control changes to 14 in the Properties view, the 
Design view, and the Preview view.

6 Select the font size 10 from the drop-down list in the Size box.

The font size of the text control changes back to 10.
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Use the mouse with controls

Where you are
Start InfoMaker
Access objects and painters
Use toolbars
Use views
Use pop-up menus

> Use the mouse with controls

Now you move some of the controls in the report. Be sure not to save the 
changed report, because you will use the original report later. When you leave 
the Report painter, you are prompted to save changes. The instructions remind 
you to say no.

1 Select Design>Options from the menu bar.

The Report Options dialog box displays. 

In this dialog box, you turn on some design options that make it easier to 
work with controls in reports.
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2 Select the Show Grid check box.
Select the Show Ruler check box.
Select the Show Edges check box.

3 Click OK.

Now edges display around the controls, and a grid and ruler display in the 
Report painter Design view.
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4 Click the text control with the text Expenses for.

Black boxes in the corners mean the control is selected.

5 Press and hold the Ctrl key.
Click the year box and the Amount in thousands box.
Release the Ctrl key.

Now you have selected all three controls.

6 Press and hold the Left Arrow key until the controls are on the far left 
of your screen.
Release the key.

7 Move the pointer to the word Expenses.
Make sure the controls are still selected.
Press and hold the left mouse button.
Drag all the controls to the right.
Release the mouse button.

While you are dragging, gray boxes show the current position of the 
controls.
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When you release the mouse button, you drop the controls where the 
pointer is currently positioned. Notice that the controls are still selected as 
indicated by the little black boxes.

8 Click in an unused area to deselect the controls.

The controls are no longer selected (the black boxes are gone).

9 Move the pointer to the position shown here by the big black dot.

10 Press and hold the left mouse button.
Drag the mouse diagonally down and to the right until the box 
surrounds or touches all three controls.
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11 Release the mouse button.

All the controls are selected. This is called lasso selection. You can use 
this lasso technique to select many controls quickly. Then you can move 
them all together or change something about them all at once.

12 Press the Delete key.

The three selected controls are deleted, but you really did not mean to 
delete them.

13 Select Edit>Undo Control Delete from the menu bar.

The deletion is reversed.

About Undo
You can undo as many operations as necessary.
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14 Select File>Close from the menu bar.

InfoMaker displays a message box to see whether you want to save the 
changes you have made to the expenses report. You do not want to save 
changes. You use this report later in the Graph tutorial.

15 Click No.

The Report painter closes. Now you are ready to learn how to create a form.
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L E S S O N  2 Form Tutorial

Forms display data and provide a way to interact with the database. You 
can use forms to view information and change it.

In this tutorial you create a form that updates the contact table. The form 
includes:

• All columns in the contact table

• Buttons for maintaining contact information

• A report that provides access to all information in the contact table

How long does this tutorial take?
About 45 minutes.
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Create the basic form 

Where you are
> Create the basic form

Preview (run) the form
Save the form
Add buttons to the form
Enhance the form
Use the form to update the database

Now you create the basic form. To do this you select a predefined InfoMaker 
form style and the data to be displayed in the form.

1 Click the New button in the PowerBar.

The New dialog box displays. 

2 Select the Object tab if it is not already on top.

The Object tab page contains the icon for creating any type of new form 
and icons for the various report presentation styles.
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3 Select the Form icon and click OK.

The New Form dialog box displays. It contains the data sources and form 
styles you can choose.

About data sources
Quick Select is simply for choosing columns and specifying selection 
criteria and sorting, which is what you want for this tutorial.

SQL Select is for using other SQL options not available with Quick 
Select.

Query is for specifying the name of a query that describes the data source. 
You define queries in the Query painter.

About form styles
A form style is a predefined way of presenting and processing information 
on the form. Usually the style includes the common database functions 
(insert, delete, and update).

InfoMaker comes with a set of form styles. PowerBuilder® users at your 
site can create additional styles, which also display in the New Form 
dialog box.
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4 Click Quick Select and Free Form to select them (the words are 
highlighted).

5 Click OK.

The Quick Select dialog box displays. In this dialog box you select the 
table to use and the columns you want to include in the form. 
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6 Click contact in the Tables box.

The columns for the contact table display. You include all columns in the 
form. 
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7 Click the Add All button.

All columns are selected. They display in a grid at the bottom of the dialog 
box.

You could reorder columns and enter sorting and selection criteria in this 
grid. For your form you do not need to do any of these things.
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8 Click OK.

Your form displays. It uses the columns and form style you selected. The 
text labels come from the extended attribute system tables. Instead of data, 
the names of the database columns appear where the data values will be 
displayed.

The extended attribute system tables
The extended attribute system tables store information about data such as 
labels and display formats. When you create forms and reports, InfoMaker 
uses extended attribute information to create the basic form or report.

You put information into the extended attribute system tables using the 
Database painter. For example, in the Table tutorial you define the label 
Job Role: for the title column. Then when you use the title column in a form 
or report, InfoMaker uses the label Job Role:.



Preview (run) the form 

40  InfoMaker

Preview (run) the form 

Where you are
Create the basic form

> Preview (run) the form
Save the form
Add buttons to the form
Enhance the form
Use the form to update the database

Now you preview the form. Running the form is the way you preview it while 
you are designing it and the way you use it when you have finished designing it.

1 Click the Run button in the PainterBar.

InfoMaker runs your form, which includes going to the database and 
retrieving data.

Notice that real values have replaced the column names in the form. 

The PainterBar now has buttons that let you view and change data. Now 
you view the data using the form.
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2 Click the Next button.
Click the Last button.
Click the First button.

This moves you among the rows. Later in this tutorial you insert a new 
row.

3 Click the Close button in the PainterBar.

You return to the Form painter Layout view.
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Save the form 

Where you are
Create the basic form
Preview (run) the form

> Save the form
Add buttons to the form
Enhance the form
Use the form to update the database

Now you save the form and give it a name. 

1 Click the Save button in the PainterBar.

The Save Form dialog box displays with the pointer positioned for you to 
type a name for the form.

2 Type contact_maintenance.

3 Click in the Comments box and type This form updates my contact table.

4 Click OK.

InfoMaker saves your form. Anytime you have completed a unit of work, 
you should save. To save, select File>Save from the menu bar or click the 
Save button.
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Add buttons to the form 

Where you are
Create the basic form
Preview (run) the form
Save the form

> Add buttons to the form
Enhance the form
Use the form to update the database

Now you add three buttons to the form. Later when you run the form, you can 
click the buttons to add and delete contacts.

About controls
The items you see on a form are called controls. For example, a button is a type 
of control. The controls you can use on a form are listed in the Insert menu on 
the menu bar.

1 Select Insert>CommandButton from the menu bar.

2 Move the pointer to an empty area of the form and click.
If you need to move the button, drag it.

How to drag
Position the pointer over an object, and press and hold the left mouse 
button. While pressing the button, move the mouse until the object is 
where you want it. Then release the mouse button.
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A button with the text none displays. The text none also displays in a text 
box in the StyleBar.

If the text box does not display
This means the button is not selected. To select the button, click it. Small 
black boxes in the corners mean it is selected.

3 Make sure the button is still selected.
Type Add a contact.

The text displays on the button as you type and in the text box in the 
StyleBar.

4 Click B (for bold) on the StyleBar.
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The text displays in bold. Next you make the button work. To do this you 
associate an InfoMaker action with the button.

Using the StyleBar
You can use the StyleBar to change text fonts, font size, and font style 
(bold, italic, and underline). You can also use it to specify text alignment 
(left-aligned, centered, and right-aligned).

To use options on the StyleBar, you select a control with text and then click 
the appropriate button on the StyleBar.

5 Move the pointer to the Add a contact button.
Press the right mouse button to display the pop-up menu for the 
button.
Select Action from the pop-up menu.

The Select Action dialog box displays. It lists the actions you can assign 
to the button.
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About InfoMaker actions
An action is what you want to have happen when the button is clicked.

Whenever you associate an InfoMaker action with a button, InfoMaker 
creates the code to enable the button to perform the action. You do not see 
the code. All you have to do is select the action for the button.

InfoMaker comes with predefined actions. PowerBuilder users at your site 
can create additional actions, which also display in the Select Action 
dialog box.

6 Scroll through the list of actions and double-click Insert_Row.

InfoMaker creates the code that enables your Add a contact button to 
display a blank form so that you can add information for a new contact. 
You will see the button work later.

Now you add two more buttons.
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7 Select Insert>CommandButton from the menu bar.
Move the pointer below the Add a contact button and click.
Type Delete a contact.
Display the Delete a contact button’s pop-up menu and select Action.
Select the action Delete_Row from the Select Action dialog box.
Click OK.

8 Select Insert>CommandButton from the menu bar.
Move the pointer below the Delete a contact button and click.
Type Save changes.
Display the Save changes button’s pop-up menu and select Action.
Select the action Update_Row from the Select Action dialog box.
Click OK.

Now you have three buttons. InfoMaker has created the code that enables 
the buttons to work.
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Enhance the form 

Where you are
Create the basic form
Preview (run) the form
Save the form
Add buttons to the form

> Enhance the form
Use the form to update the database

In this exercise you:

• Add a title

• Change the border for data

• Move the buttons

• Add a report

Add a title

1 Move the pointer to an unused area of the form and click.

This causes the Properties view to display the form’s properties.

2 Type Maintain Contact Information in the Title box.

The title does not display now. When you run the form, the title displays.
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Change the border for data
Now you change the border for all data values. This improves the form’s 
appearance. You use lasso select to select the data.

1 Move the pointer near the bottom of the data and on the right.

2 Press and hold the left mouse button and drag diagonally to the left 
and up until the box (the lasso) touches all the data.

3 Release the mouse button.

All the objects inside the box are selected. Black boxes display in all the 
corners.

4 Select Lowered or whatever value you want from the Border 
drop-down list on the General page in the Properties view.
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All the areas on the form used to display data values now have your 
selected border.

Move the buttons
Now you move the buttons to make room for the report you are about to add.

1 Select a button.

You can use lasso select or click one. Small black boxes in the corners 
mean it is selected.

2 Drag the button to the top of the form.
Select and drag the other two buttons until your form looks like this.

Now there is more room for the report you are about to add.
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Add a report
Now you add a report to provide information when you are working with the 
form. You can scroll in the report while you are filling out the form for a new 
contact. This means, for example, that you can look up an area code or zip code 
if it is already present for another contact.

1 Select Insert>Report from the menu bar.
Move the pointer into the workspace. 

Your next click positions the report that you are adding to the form.

2 Move the pointer to the empty space on the right part of the form and 
click.

Four dots marking the corners of the box that will hold the report display 
on the form.

Now you use the Properties view to specify a few things about the report. 
First you are going to select the report whose contents display in the box.
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3 Click the Browse button (the button with three dots on it) next to the 
DataObject field on the General page in the Properties view.

The Open dialog box displays. It lists the reports (DataWindow® objects) 
in tutor_im.pbl, the current library.

4 Scroll the list of reports, select contactgrid, and click OK.

The contactgrid report displays in the form, and its name displays in the 
DataObject field in the Properties view.

Next you specify that the report is to have the StyleBox border and scroll 
bars.
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5 Make sure the BorderStyle selection is StyleBox.
Select the HScroll Bar, VScroll Bar and Border check boxes.

When you run the form, the report displays as a window with horizontal 
and vertical scroll bars. This gives you flexibility in looking at data while 
working on the form.

6 Resize the report to show more data.

To resize, move the pointer near an edge until the pointer becomes a 
double-pointed arrow. Then press the left mouse button, hold, and drag. 
Align the left edge of the report with the Add a Contact button.

When you finish resizing, the report should look something like this.
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Use the form to update the database 

Where you are
Create the basic form
Preview (run) the form
Save the form
Add buttons to the form
Enhance the form

> Use the form to update the database

Now you use the form to add a new contact to the database.

1 Click the Run button.

Your finished form displays with data in place. The report on the form 
gives you a way to see all your contact data.

2 Click the Add a contact button in the form.

An empty form displays. You use this form to enter a new contact.
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The cursor is in the Id box, but you do not know the next available number. 
You look in the report to see what number was used last.

3 In the report window, use the scroll bar to scroll down to the last row 
of the report and check the value in the Id column.

If the data has not been changed since installation, the value is 60, so the 
next available number is 61.

4 Click the Id column and type 61.

5 Press Tab and type Clinton for Last Name.
Press Tab and type George for First Name.
Press Tab.

At this point you are on the Job Role box. In this box you cannot type. You 
must select a job role from a list of possible ones.

In the Database painter, the column was defined to be associated with a 
DropDownListBox edit style. The extended attribute system tables store 
this and other information about data.

6 Click the down arrow on the drop-down list to display the choices.



Use the form to update the database 

56  InfoMaker

7 Select Marketing.

8 Press Tab and type Pennsylvania Ave for Street.

9 Press Tab and type Houston for City.

10 Press Tab and type T and select TX for State (another drop-down list).

11 Press Tab.
To determine what to enter for Zip, scroll the report until you find 
another Houston entry.
Then click the Zip box in the form and type the zip code you see in the 
report.

12 Press Tab and type 7135557833 for Phone.

Notice that you type only the digits. The form formats the phone number. 
An Edit Mask edit style was defined for this column to handle the 
formatting. This edit style is stored in the extended attribute system tables.
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13 Press Tab and type 7135554291 for Fax.

This is what your screen should look like now.

14 Click the Save changes button in the form to update the database with 
the new contact.

The database is updated.

Note that the report always displays the information from the database 
when you start running the form. If you update the database, the report 
does not show the updates. To update the report, you return to the 
workspace and rerun the form.

15 Click the Close button in the PainterBar to return to the Form painter 
workspace.

16 Click the Run button again and scroll the report to the 61st row in the 
report.

Notice that your report has been updated.

17 Click the Close button in the PainterBar to return to the Form painter 
workspace.

18 Select File>Close from the menu bar.

If you have not already saved the current version of the form, you are 
prompted to save changes.

19 Click Yes.

The Form painter closes. 
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L E S S O N  3 Report Tutorial

Reports display and summarize data. You can view reports on the screen, 
save reports to a file, and print them on the printer.

In this tutorial you create a report using the data in the contact table. The 
report you create groups contacts by job role and lists phone and fax 
numbers for each contact.

This is what the report looks like when you have finished.

How long does this tutorial take?
About 45 minutes.
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Create the basic report 

Where you are
> Create the basic report

Preview the report
Save the report
Set up the design environment
Define sorting and grouping
Enhance the report
Save the report as an XML file
Print the report

Now you create the basic report. To do this you select a report style and the data 
to be used for the report.

1 Click the New button in the PowerBar.

The New dialog box displays.

2 Select the Object tab if it is not already on top.

The Object tab page contains the icon for creating any type of new form 
and icons for the various report presentation styles.
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3 Select the Tabular presentation style and click OK.

The wizard for creating tabular reports (also called DataWindows) starts 
up.

About report presentation styles
A report presentation style is a predefined way of presenting information 
in a report.

4 Select the Quick Select data source.
Make sure the Retrieve on Preview check box is selected and click 
Next.
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About data sources
Quick Select is simply for choosing columns and specifying selection 
criteria and sorting, which is what you want for this tutorial.

SQL Select is for using other SQL options not available with Quick 
Select.

Query is for specifying the name of a query that describes the data source. 
You define a query in the Query painter.

External is for specifying data that comes from a source other than a 
database.

Stored Procedure is for specifying data using a stored procedure.

The Quick Select dialog box displays. In this dialog box you select the 
table to use and the columns you want to include in the report. 

5 Click contact.
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The columns for the contact table display. For this report you select five 
columns.
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6 Click last_name, first_name, and title.
Use the scroll bar to scroll the list of columns.
Click phone and fax.

InfoMaker moves the selected columns to the grid at the bottom. You can 
use this grid for reordering columns and for providing sort and selection 
criteria. For this report you do not need selection criteria, and you specify 
sorting later.
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7 Click OK.

The Select Color and Border Settings dialog box displays. You are going 
to accept the defaults.

8 Click Next.

A dialog box summarizing all your specifications displays. 

9 Look over your specifications and then click Finish.
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Your report displays in several views in the Report painter. It uses the 
columns and report style you selected.

The Design view is where you do much of your work perfecting the report. 
The text for the column headers comes from the extended attribute system 
tables. The names of the columns appear where the data values will be 
displayed.

The extended attribute system tables
The extended attribute system tables store information about data such as 
labels and display formats. When you create forms and reports, InfoMaker 
uses extended attribute information to create the basic form or report. 

You put information into the extended attribute system tables using the 
Database painter. For example, in the Table tutorial you define the label 
Job Role: for the title column. Then when you use the title column in a form 
or report, InfoMaker uses the label Job Role:.
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Preview the report 

Where you are
Create the basic report

> Preview the report
Save the report
Set up the design environment
Define sorting and grouping
Enhance the report
Save the report as an XML file
Print the report

In this exercise you look at the Preview view of your report to see what it looks 
like when you print it. 

1 Position the pointer in the upper-right corner of the Preview view (this 
drops the title bar) and click the maximize button.
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The Preview view becomes large and overlays all the other views. Notice 
that it includes the header information for the report and information from 
the database. InfoMaker retrieves information for all contacts and displays 
as many as fit in the Preview view.

2 Use the scroll bar on the right side of the window to see more data.
Use the command File>Print Preview Rulers to turn the display of rulers 
on and off.

3 Click here in the upper-right corner to return the Preview view to its 
original size and location.
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Save the report 

Where you are
Create the basic report
Preview the report

> Save the report
Set up the design environment
Define sorting and grouping
Enhance the report
Save the report as an XML file
Print the report

Now you save the report and give it a name.

1 Select File>Save from the menu bar.

The Save Report dialog box displays, with the pointer positioned for you 
to type a name for the report.

2 Type contacts_by_jobrole.

3 Click in the Comments box and type This report shows my contacts 
grouped by job role.

4 Press the Enter key.

InfoMaker saves your report. Anytime you have completed a unit of work 
and are satisfied, you should save your work. 
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Set up the design environment 

Where you are
Create the basic report
Preview the report
Save the report

> Set up the design environment
Define sorting and grouping
Enhance the report
Save the report as an XML file
Print the report

In this exercise you set up the design environment to make it easier to work. To 
do this, you:

• Show the edges of controls

• Display the grid and ruler

Control edges show how big the controls are. By displaying control edges, you 
can easily check for overlapping and make sure the spacing around controls is 
what you want. Displayed edges are a design aid only; they do not appear in 
the report.

The InfoMaker grid and ruler help you align controls.

If you completed Lesson 2
The design options you set here may already be set correctly.

1 Select Design>Options from the menu bar.

The Report Options dialog box displays.
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2 Make sure the Show Grid option, Show Ruler option, and Show Edges 
option are selected.
Make sure Snap to Grid is not selected.
Click OK.

The Design view shows a dotted grid and a ruler. Text and columns show 
edges.



Define sorting and grouping 

72  InfoMaker

Define sorting and grouping 

Where you are
Create the basic report
Preview the report
Save the report
Set up the design environment

> Define sorting and grouping
Enhance the report
Save the report as an XML file
Print the report

Now you specify sorting and grouping. You want the report to group contacts 
by title. This means you need to sort by title and then specify grouping by title.

1 Select Rows>Sort from the menu bar.

The Specify Sort Columns dialog box displays.
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2 Move the pointer to the word title in the Source Data box and drag it to 
the Columns box.

(To drag, press and hold the left mouse button, move the mouse, then 
release the mouse button.)

Ascending and descending
Ascending and descending are options for sorting. Since you are 
alphabetizing in this tutorial, you want to sort in ascending (from A to Z) 
order. Ascending is the default, so you do not have to do anything.

You have specified the sorting required to group by title.

Next you specify sorting by last name and then by first name. This 
alphabetizes your contacts within each group.

3 Drag last_name and first_name to the Columns box.
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4 Click OK.

The sorting definition is complete.

5 Select Rows>Create Group from the menu bar.

The Specify Group Columns dialog box displays. You are going to group 
on the title column. All contacts with the same title will be grouped 
together.

6 Drag title to the Columns box and click OK.

The grouping definition is completed. You have two new bands for the 
group in the report. You learn about bands in the next exercise.
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7 Look at the Preview view.

You see the report and its data. Notice that the data is sorted. You do not 
see the groups yet. In a few minutes you will make some changes so the 
groups appear.
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Enhance the report 

Where you are
Create the basic report
Preview the report
Save the report
Set up the design environment
Define sorting and grouping

> Enhance the report
Save the report as an XML file
Print the report

You can enhance reports in many ways. In this exercise you:

• Rearrange controls

• Add a title and date

• Add page numbers

• Add a count of the total number of contacts

Rearrange controls
To rearrange controls, you:

• Put the job role into the group header and change its display font

• Move the remaining columns to close the gap left by moving the column

This is what the Design view looks like when you have finished rearranging the 
controls.
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About report bands
The design version of the report that you see in the Design view divides the 
report into bands of information.

The header band contains heading information and is located at the top of 
each page.

The detail band contains the retrieved data.

The summary band contains summary information that applies to the entire 
report and is located at the end of the report.

The footer band contains information to be located at the bottom of every 
page, such as a page number.

For groups, the group header band and group trailer band contain 
information for the group.

1 Move the pointer to the gray bar entitled 1: Header group title (where 
the black dot is) until you see a double-pointed arrow
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2 Drag the band down about 4 to 6 grid dots.

(To drag, press and hold the left mouse button, move the mouse, then 
release the mouse button.)

3 Move the pointer to the title column and drag it into the band for the 
group header.
Put it near the bottom of the band and on the left as shown.
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4 With the title column still selected, select the bold check box and the 
italic check box on the Font tab of the Properties view.

This makes the job role (title) stand out in the report.

5 Look at the Preview view.

You see the report and its data.

Notice that the value of the title column appears only once for each group. 
This is because the title column is now located in the group header band.

The Preview view is helpful for identifying problems. Notice that the 
header Job Role is still present even though there is no longer a column in 
the detail band. Next you delete the header.
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6 Click the text Job Role in the header band.

7 Press the Delete key.

8 Drag the First Name and Last Name text boxes in the header band to 
the right to fill the empty space.
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9 Drag the first_name and last_name columns in the detail band to the 
right to fill the empty space.

You make one final visual improvement now by left-aligning the text in 
the column headers.

10 Choose Edit>Select>Select Text from the menu bar.

This selects all the headers. It might be difficult to see that they are 
selected because the band is so narrow.

11 Click the left justification button on the StyleBar.
If your headers are not already bold, click the Bold button.

All the headers become left justified (and bold).
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12 Look at the Preview view.

Add a title and date
Now you add a title and date to the header band. They will be at the top of each 
page.

1 Move the pointer to the gray bar marked Header and drag it down 
about 10 grid dots.

2 Choose Edit>Select>Select Text from the menu bar (or use lasso 
selection).

This selects all the headers.
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3 Drag all the headers down close to the gray band.

This leaves room for the title.

4 Click the Text button in the Objects drop-down toolbar in the 
PainterBar (or select Insert>Control>Text from the menu bar).
Move the point of the pointer above the First Name box and down one 
grid dot from the top of the page.
Click the left mouse button.

This positions the text box for the title.
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5 Type My Contacts.
Select 14 from the Size drop-down list on the Font tab in the Properties 
view to make the title bigger (enlarge the text box if necessary).

The title is now enlarged.
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6 Select Insert>Control>Today( ) from the menu bar.
Move the point of the pointer to the upper-left corner.
Click.

This places a computed field in the report. The computed field is for 
today’s date.

7 Look at the Preview view.

Your report now has a title and today’s date.
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Add page numbers
Now you put page numbers in the footer band.

1 Move the pointer to the gray bar marked Footer and drag it down about 
4 grid dots.

If necessary, use the scroll bar to make room at the bottom of the Design 
view. Dragging down the footer bar makes space for the page number in 
the footer band. The page number is another computed field.

2 Select Insert>Control>Page n of n from the menu bar. 
In the footer band, move the pointer to the center and down 2 grid 
dots. Click.
Select a different font size (10) in the Properties view, Font page.

This places a computed field for page numbers.
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3 Look at the Preview view.
Click the scroll bar until you move to the bottom of the page.

You now have a page number on your report.

Add a count of the total number of contacts
Now you add a count of the total number of contacts you have to the end of the 
report. You put the information in the Summary band, which means it prints at 
the end of the report. 

Like the date and page number, the count is a computed field, only this time, 
you create it yourself.

1 Move the pointer to the gray strip marked Summary for the summary 
band and drag it down about 6 grid dots.

This makes space for the total number of contacts, which is a computed 
field.
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2 Select Insert>Control>Computed Field from the menu bar.
In the summary band, move the point of the pointer to the center and 
down 4 grid dots.
Click.

This sets the position for a computed field that you use for the total number 
of contacts. The Modify Expression dialog box displays.

3 In the Functions box, click count(#x for all).

Your dialog box should look like this. The placeholder for what to count 
is highlighted.
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4 In the Columns box, click last_name.

This selects the last_name column to apply the count function to. You are 
going to count all the last names to find out how many contacts you have 
in the report.

5 Click Verify.

You should get the message box stating that your expression is valid.

6 Click OK to close the message box.
Click OK to complete the definition of the expression for the 
computed field.

The computed field is in place.
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7 Select Insert>Control>Text from the menu bar.
Position the pointer to the right of the computed field and click.
Type contacts in all.
Drag the text box to line it up with the computed field.

8 Select the computed field and the text using lasso selection.
On the Font page of the Properties view, select 10 for the font size and 
select the Bold check box and the Italic check box.

How to use lasso selection
Position the pointer, press and hold the left mouse button, and drag the 
lasso around everything you want to select. Then release the mouse button.
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9 Look at the Preview view.
Use the scroll bar until you see the end of your report.

The summary band of your report now shows the total number of contacts 
in the report. The number you see may not be 60. The number depends on 
the contacts currently in your database.
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Save the report as an XML file

Where you are
Create the basic report
Preview the report
Save the report
Set up the design environment
Define sorting and grouping
Enhance the report

> Save the report as an XML file
Print the report

You can save the data in a report in many different formats, including XML, 
HTML, Microsoft Excel, and PDF.

Saving as PDF
Before you can save the data in a report object to a PDF file, you must install 
Ghostscript and PostScript printer drivers on your computer. For information 
about using the Ghostscript distiller, see the Users Guide.

Now you save the report as an XML file.

1 Select the Preview view by clicking it.

This ensures that the Preview view is the current view.



Lesson 3    Report Tutorial

Getting Started 93

2 Select File>Save Rows As from the menu bar.
Select XML from the Save as Type drop-down list.

3 Type a name for the file and click Save.
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Print the report 

Where you are
Create the basic report
Preview the report
Save the report
Set up the design environment
Define sorting and grouping
Enhance the report
Save the report as an XML file

> Print the report

1 Select the Preview view by clicking it.

This ensures that the Preview view is the current view.

2 Select File>Print Report from the menu bar.

The Windows Print dialog box displays.

3 Click OK.

4 Select File>Close from the menu bar.
If you are prompted to save changes, click Yes.

The Report painter closes.
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L E S S O N  4 Table Tutorial

This tutorial requires the Database painter
The Database painter component of InfoMaker is optional; you must have 
installed it to do this tutorial.

Tables are the way relational databases organize information. To take full 
advantage of InfoMaker’s ability to create forms and reports, you should 
learn how to create and work with database tables.

InfoMaker is installed with a SQL Anywhere database. You can create and 
work with tables in the SQL Anywhere database and in any other database 
you have access to.

After you create a table, you can display its columns on a form and use the 
form to add information into the database. For a final printed copy of the 
data in your tables, you can create and print reports.

In this tutorial you:

• Create a database table

• Define extended attribute information

• Add data to the table

When you have finished, you can create forms to view and update 
information, and you can create and print reports using information in the 
table.

How long does this tutorial take?
About 45 minutes.
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Create the database table 

Where you are
> Create the database table

Define extended attribute information
Add data to the table

 To create the database table, you:

• Define the columns in the table

• Define a primary key

• Enter comments to document the table

• Save the table

Define the columns in the table

1 Click the Database button in the PowerBar.
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The Database painter workspace displays. It contains many views for 
working with database information. If your workspace does not look like 
this, you may want to select View>Layouts>(Default). 
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2 Position the pointer on the Tables folder in the EAS Demo DB V120 IM 
database and select New Table from the pop-up menu.
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The view in which you define the columns in the table displays. The cursor 
is in the Column Name box for the first column. 

3 Type id and press Tab.

The cursor moves to the Data Type box. The default datatype is 
highlighted. The datatype for the id column needs to be integer.

4 Click the arrow in the Data Type box and select integer from the 
drop-down list of available datatypes.

This changes the datatype.
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5 Press Tab three times.

This moves you past the setting of No for the column labeled Null. No 
means you do not want to allow the column you are defining to be empty 
(to have a null value). Since you always want a value for id, you leave the 
value No. You also move past the column labeled Default. You are not 
going to specify a default.

6 Type last_name and press Tab.

The cursor moves to the Type column. The most recently used datatype 
(integer) is highlighted. The last_name column should be type char, so you 
change the datatype.

7 Type c and press Tab.

Typing c is a shortcut for choosing char quickly. The cursor moves to the 
Width column.

8 Type 15.

This allows 15 characters for the last name instead of 10.

9 Press Tab three times.

This moves you past the setting of No for the column labeled Null to the 
Column Name box for the next column. No is what you want (name cannot 
be empty). You move past the column labeled Default again.
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10 Finish entering information about the table columns.

The following table shows all the values needed to define the columns in 
the contact table. You have already entered values for the first two columns 
(id and last_name).

When you have finished, the Columns view should look like this.

Name Type Width Dec Null Default

id integer No (None)

last_name char 15 No (None)

first_name char 15 No (None)

title char 2 No (None)

street char 30 No (None)

city char 20 No (None)

state char 2 No (None)

zip char 5 No (None)

phone char 10 Yes (None)

fax char 10 Yes (None)
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Save the table
You have now entered all of the column information needed. Now you finish 
creating the table.

1 Select File>Save from the menu bar.

The Create New Table dialog box displays.

You leave the owner as dba (database administrator) and enter a name for 
the table.

2 Type contact1 in the Table Name box.
Click OK.

InfoMaker passes the SQL needed to create the table to the SQL 
Anywhere DBMS, which creates the table.

InfoMaker displays a representation of the table in the Database painter 
Object Layout view.

The list of columns displays. The scroll bar on the right side means that 
there are more columns than can be displayed at once. To see the other 
columns, you can click the down arrow at the bottom of the scroll bar.
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Define a primary key
A primary key uniquely identifies each row. In your contact table, id is the 
unique identifier of each row of data.

1 Select Object>Insert>Primary Key from the menu bar. (If the menu item 
is grayed out, click the Object Layout view to make it current and then 
select the menu item from the menu bar.)

The Primary Key properties dialog box displays in the Object Details 
view. Here you can pick one or more columns as the primary key.

2 Click id in the list of columns.

3 Select File>Save from the menu bar.
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This defines id as the primary key for your table. Notice that the 
representation of the table now includes a symbol for the primary key of 
the table.

Next you define a comment for the table.

Enter comments to document the table
Although not required, comments can be helpful in identifying tables.

1 Position the pointer on the title bar of the representation of the 
contact1 table, display the pop-up menu, and select Properties.

The Table Properties properties dialog box displays in the Object Details 
view.

2 Click in the Comments box and type This is the sample table for the 
tutorial created by [your name].

This associates the comments with the table you are creating. 

3 Select File>Save from the menu bar.
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Define extended attribute information 

Where you are
Create the database table

> Define extended attribute information
Add data to the table

Now you extend the basic definitions of the columns in the table.

The following table summarizes how you extend the column definitions of the 
contact1 table columns.

About extended attribute information
InfoMaker stores extended attribute information in the extended attribute 
system tables and uses it to display and validate data in forms and reports. In 
the Report painter or Form painter, you can override whatever you specified in 
the Database painter, which is where you are now.

Column name What you do to extend its definition

id

last_name

first_name

Nothing.

title Define a DropDownListBox edit style of job roles, change the 
column header and label to Job Role, and enlarge the display 
width of the column to 1.5 inches.

street

city

Nothing.

state Assign the DropDownDataWindow edit style for state to the state 
column.

Set the default value of state to MA.

zip Nothing.

phone

fax

Define an Edit Mask edit style for a phone number and apply it to 
phone and fax.
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Define a DropDownListBox edit style for the title column
Now you define a DropDownListBox edit style that has the valid job roles for 
the title column. When you have finished, this is what it looks like in a form.

1 Select View>Layouts>(Default) from the menu bar.

2 Click the Extended Attributes tab to bring the view to the front.

3 In the Extended Attributes view, display the pop-up menu for Edit 
Styles and select New.
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Edit Style settings display in the Object Details view.

4 Enter the name JobRoles1.
Select DropDownListBox in the Style Type box.
Check Sorted to alphabetize your entries.
Check Vertical Scroll Bar to display a vertical scroll bar on your list.
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5 Enter the Display Values and Data Values shown in the table below.
Be sure to use lowercase for the data values.
To enter each pair of values, type the values and press the Tab key.
For the last pair of values, do not press Tab.

About display values and data values
Display values show in forms and reports. Data values are stored in the 
database. Display values should be meaningful—such as Human 
Resources. In contrast, data values are often codes that are short—such as 
hr. Short codes conserve space in the database.

6 Select Save Changes from the pop-up menu.

InfoMaker adds the JobRoles1 edit style to the extended attribute system 
tables in the database and lists it as one of the available edit styles in the 
Extended Attributes view.

Display Value Data Value

Sales sa

Customer support cs

Product development pd

Administration ad

Training tr

Documentation do

Marketing ma

Human resources hr

Finance fi

Other ot
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7 Expand the tree view of Edit Styles by clicking the plus (+) sign.
Use the scroll bar to scroll down to the JobRoles1 Edit Style.

Now that JobRoles1 is defined in the extended attribute system tables, you 
can use it for any appropriate column in any table in the database. You are 
going to assign it to the title column in the contact1 table.
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8 Expand EAS Demo DB V120 IM in the Objects view to display Tables 
and then the Columns in the contact1 table.
Display the pop-up menu for the title column and select Properties.

The Object Details view now includes the properties dialog box for the title 
column.



Lesson 4    Table Tutorial

Getting Started 111

9 If the Edit Style tab is not visible, use the arrows in the upper-right 
corner of the Object Details view to display the Edit Style tab.
Click the Edit Style tab to bring it to the front.

10 Scroll the list of edit styles until JobRoles1 displays.
Click it to apply the edit style JobRoles1 to the title column.
Select File>Save from the menu bar.

Change the column header, label, and display width of title
Now you change the label and header text for the title column. The text you 
supply appears on forms and reports you create.

The column name is title, but the text you want to display is Job role. Also, you 
change the display width to 1.5 inches. The internally stored data value is only 
two characters, but the values you intend to display are longer.

1 The title column should still be current (if not, display its pop-up menu 
and select Properties). Click the Headers tab to bring the Headers 
property page for the title column to the front in the Object Details 
view.



Define extended attribute information 

112  InfoMaker

All the extended attribute information for a column is definable using the 
various pages in the Object Details view.

2 Type Job Role in the Label box.
Type Job Role in the Heading box.

3 Click the Display tab to bring the Display page to the front.
Type 1.5 in the Display Width box.

4 Select File>Save from the menu bar.

InfoMaker adds the extended attribute information for the column to the 
extended attribute system tables.
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Assign a DropDownDataWindow edit style and initial value to state
For the state column, you assign an edit style that includes all the state names 
(as well as the provinces of Canada). Then when you enter information into this 
field, you pick from a list of states. You also set the initial value to MA, since 
many of your contacts are in Massachusetts.

1 In the Extended Attributes view, display the pop-up menu for Edit 
Styles and select New.

Edit Style settings display in the Object Details view.
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2 Type StateCode1 in the Name box.
Select DropDownDW from the Style Type drop-down list.

3 Scroll down to the bottom of the view and click the browse button 
next to the DataWindow box.
Select d_dddw_states from the DataWindow list.

The StateCode1 edit style uses a report (DataWindow) named 
d_dddw_states. The report gets its values from the state table.

About DropDownDataWindow edit styles
A DropDownDataWindow edit style gets its values from a report that it 
references. The report gets its values from the database.
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This is what the d_dddw_states report looks like.

4 Select state_id from the list for Display Column and for Data Column.
Type 550 for the Width of DropDown.
Select Vertical Scroll Bar.
Select Save Changes from the pop-up menu to accept the definition of 
the StateCode1 edit style.

InfoMaker adds the StateCode1 edit style to the extended attribute system 
tables, where it is available to be assigned to any appropriate column in the 
database. Now you assign it to the state column in the contact1 table.
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5 Display the pop-up menu for the state column in the contact1 table 
and select Properties.

6 In the Column Properties view, select the Edit Style tab.
Select StateCode1 for the edit style to assign to the state column.
(If the StateCode1 edit style is not listed, select View>Reset View. This 
refreshes the list of edit styles.)

This assigns the StateCode1 edit style (which includes 63 entries—states, 
territories, and possessions of the United States and provinces of Canada) 
to the state column in the contact table. The values that this edit style 
displays and the values that it stores are state postal abbreviations (such as 
MA for the state of Massachusetts).
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7 Select File>Save from the menu bar.

8 Click the Validation tab.
Make sure the Validation Rule setting is (None).
Type MA in the Initial Value box.

This assigns an initial value of MA to the state column.

The Validation page lets you create and assign a validation rule to a 
column and enter an initial value for the column.

You are not going to assign a validation rule. You have handled validation 
by forcing the user to select from exactly 63 valid values presented in the 
States drop-down DataWindow.

About column validation rules
You can use column validation rules to express requirements for entries in 
a column. For example, you could define a rule for a salary column that 
requires salaries to be greater than $15,000 and less than $100,000.

When you assign a column validation rule to a column, no one can enter a 
value that breaks the rule.

9 Select File>Save from the menu bar.

InfoMaker saves the extended attributes you just defined for the state 
column in the extended attribute system tables.
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Define an Edit Mask edit style for phone and fax
Now you define an Edit Mask edit style to display phone and fax numbers for 
both viewing and editing.

1 In the Extended Attributes view, display the pop-up menu for Edit 
Styles and select New.

Edit Style settings display in the Object Details view.

2 Type TelephoneNumber1 in the Name box.
Select EditMask in the Style drop-down list.
Delete xxx and type (###) ###-#### in the Mask box.

The pound signs (#) in the Mask box are placeholders for numbers. Only 
numbers 0 through 9 can be entered in each of these positions. 
Parentheses, the hyphen, and the space are where you want them to 
display. When you type a telephone number in the Test box, you can see 
the effects of the edit mask.
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3 Select Save Changes from the pop-up menu to accept the definition of 
the Edit Mask edit style named TelephoneNumber1.

InfoMaker adds the TelephoneNumber1 edit style to the extended attribute 
system tables in the database and lists it as one of the available edit styles 
in the Extended Attributes view.

4 Display the pop-up menu for the phone column and select Properties.

5 In the Object Details view, click the Edit Styles tab, then scroll the list 
and select the TelephoneNumber1 edit style.
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This assigns the TelephoneNumber1 edit style to the phone column. Now 
you use the same edit style with the fax column. Once you have created an 
edit style, it is available for any column.

6 Display the pop-up menu for the fax column and select Properties.

InfoMaker prompts you to save the changes you just made in assigning the 
TelephoneNumber1 edit style to the phone column.

7 Select Yes.

8 In the Object Details view for the fax column, select the Edit Style tab 
and the TelephoneNumber1 edit style.
Select File>Save from the menu bar.

Now you have finished extending the definitions of your columns. Next you 
add data to the table.
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Add data to the table 

Where you are
Create the database table
Define extended attribute information

> Add data to the table

To add data to your table, you import a text file of tab-separated values. 
Importing the file quickly adds 60 rows of data.

Typically you create a form to add data to the database. In the form tutorial you 
saw how to add data using a form.

1 Display the pop-up menu for contact1 and select Edit Data>Grid.

The Results view shows column headers but no data. This view lets you 
view, add, modify, and delete data.
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2 Select Rows>Import from the menu bar.

The Select Import File dialog box displays. You might need to change to 
the Tutorial folder, which contains the file you use. 

3 If necessary, change to the Tutorial folder.
Double-click the contact.txt file.

InfoMaker imports the data into the Results view (the data is not yet in the 
database).

4 Select Rows>Update from the menu bar.

This adds 60 rows of data to the database. To be sure that the data is in the 
database, you retrieve it from the database.

5 Select Rows>Retrieve from the menu bar.

InfoMaker retrieves all the contact data from the database and displays the 
data in the Results view.

6 Select File>Close from the menu bar.

This closes the Database painter.

You have created a new database table, complete with extended attribute 
information and data.
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L E S S O N  5 Query Tutorial

A query is a SQL SELECT statement created with the Query painter and 
saved with a name so that it can be used repeatedly to define data 
requirements. A SQL SELECT statement is the way you tell the DBMS 
exactly which rows and columns to retrieve.

Queries save time because you can use them to define all your data 
retrieval needs. For example, you can specify the columns and rows to 
select, as well as the sorting requirements. Then you specify the query as 
the data source whenever you create forms and reports that use the data 
the query is intended to retrieve.

How long does this tutorial take?
About 15 minutes.

About the query 
The query you create retrieves financial data. When you have finished, the 
query returns data from the database that is similar to this.

The financial data is stored in two tables: the fin_data and fin_code tables.
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The following illustration shows the two tables with some data. The code value 
in the fin_data table gets its meaning from the fin_code table.

For example, the r1 circled in the fin_data table means the row reports a 
revenue amount for fees.
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Select columns 

Where you are
> Select columns

Save the query
Specify row selection criteria
Specify sorting for the rows
Create a report using the query

1 Click the New button in the PowerBar.

The New dialog box displays.

2 Select the Database tab and the Query icon.
Click OK.
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InfoMaker connects to the database, and the Select Tables dialog box 
displays. In this dialog box you can select one or more tables to use.

You are going to use two of the tables.

3 Click the tables named fin_code and fin_data.
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4 Click Open.

The fin_code and fin_data tables display. Both tables have a code column. 
The tables are joined on the code column. 

If your display does not include all the information shown in the picture, 
right-click in the Table Layout view and select the information you want 
to display from the Show menu.

The fin_data table has a code value in each row to indicate what the row of 
data applies to (for example, r1 means revenue from fees).

The fin_code table stores information about codes, including the actual 
values (such as r1 and e4), the type of each code (revenue or expense), and 
a description of each code.

Next you select columns from the tables.
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5 Click year in the fin_data table.
Click quarter in the fin_data table.
Click amount in the fin_data table.
Click type in the fin_code table.
Click description in the fin_code table.

When you click each column, it is highlighted in the table and added to the 
selection list above the tables.
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6 Select Design>Preview from the menu bar.

You can see the results of your query. InfoMaker uses your query as it is 
currently defined to access the database and retrieve data.

7 Use the scroll bar to view the data.

Each row has either the word expense or the word revenue in the Type 
column. First you save the query and then you use the value in the Type 
column to select rows for the query.

8 Select File>Close from the menu bar.

You return to the workspace.
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Save the query 

Where you are
Select columns

> Save the query
Specify row selection criteria
Specify sorting for the rows
Create a report using the query

Now you save the query and give it a name.

1 Make sure you are back in the workspace.
Select File>Save from the menu bar.

The Save Query dialog box displays with the pointer positioned for you to 
type a name for the query.

2 Type q_expenses.
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3 Click in the Comments box and type This query retrieves financial data 
from the fin_data and fin_code tables. The query selects expense rows and 
sorts rows by year, description, and quarter.

4 Click OK.

InfoMaker saves your query.
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Specify row selection criteria 

Where you are
Select columns
Save the query

> Specify row selection criteria
Specify sorting for the rows
Create a report using the query

Now you select the rows to include in the query. To do this you specify 
selection criteria.

The query you are creating is for expenses, so the rows you need are those 
whose type is expense. You do not need the rows whose type is revenue.

1 Click the Where tab at the bottom of the workspace if it is not in front.

The Where tab comes to the front. In the Where tab you specify selection 
criteria for retrieving rows.
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2 Click the first space under Column and then click the arrow to display 
a list of columns.
Click the column named "fin_code"."type" in the list of columns.

The equal sign (=) displays by default in the Operator box. This is what 
you want.

3 Move the pointer over the Value box.
Press the right mouse button to display the pop-up menu.
Select Value.
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When you select Value, InfoMaker lists the values in the "fin_code"."type" 
column, which are expense and revenue.

4 Select expense and click the Paste button.

The selection criteria are complete. Notice that the value expense is 
surrounded with single quotes. These are required. If you type the value 
here rather than choosing it, you need to type the single quotes.

Notice that the Logical box displays at the end of the line. This box is for 
choosing a logical connector such as AND so you can specify more than 
one selection requirement. You do not need to use this box for this query.
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5 Select Design>Preview from the menu bar.
Use the scroll bar to view the data.

Now all rows have expense in the Type column. Rows with revenue in the 
Type column are not retrieved.

6 Select File>Close from the menu bar.

You return to the workspace.
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Specify sorting for the rows 

Where you are
Select columns
Save the query
Specify row selection criteria

> Specify sorting for the rows
Create a report using the query

Now you specify sorting for the rows. When you specify sorting, you also 
enable grouping. Before you can define a group, the rows have to be sorted so 
that the data can be grouped.

1 Click the Sort tab at the bottom of the workspace.

The Sort tab comes to the front. In the Sort tab, you specify one or more 
columns to use for sorting the rows.

2 Scroll the list as needed to drag and drop column names.
Drag and drop "fin_data"."year" from the left box to the right box.
Drag and drop "fin_code"."description" from the left box to the right box.
Drag and drop "fin_data"."quarter" from the left box to the right box.

In all cases Ascending is what you want. Ascending means years and 
quarters are ordered by increasing values and descriptions are 
alphabetized from A to Z.
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3 Select Design>Preview from the menu bar.
Use the scroll bar to view the data.

First the rows are sorted by year. All the 2003 information is first. Then 
they are sorted by description so that expenses of the same category are 
together. Finally the rows are sorted by quarter so that the data is always 
time-sequenced.

4 Select File>Close from the menu bar.

You return to the workspace.

5 Select File>Close from the menu bar.
If prompted to save changes, click Yes.

The Query painter closes.
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Create a report using the query

Where you are
Select columns
Save the query
Specify row selection criteria
Specify sorting for the rows

> Create a report using the query

Now you use the query to create a new report.

1 Click the New button in the PowerBar.
Select the Object tab.
Select the Tabular presentation style.
Click OK.

The wizard for creating tabular reports displays.
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2 Select the Query data source.
Make sure the Retrieve on Preview check box is selected and click 
Next.

The Select Query dialog box displays. In this dialog box you specify the 
query to use. You are going to use the query you just created as the data 
source.

3 Click the button to the right of the Specify Query box.
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The Open dialog box displays.

4 Click q_expenses and click OK.

The query q_expenses displays in the Specify Query box.
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5 Click Next.

The Select Color and Border Setting dialog box displays. You are going to 
accept the defaults.

6 Click Next.

A dialog box summarizing all your specifications displays.

7 Look over your specifications and then click Finish.

Your report displays in the Report painter. This is the Design view.
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InfoMaker uses the query you created to retrieve data from the database. 
Because the query includes selection criteria and sorting requirements, the 
database returns only the data you selected, in the sort order you specified. 
Here is the report in the Preview view.

At this point you could continue designing and improving your report, but 
for this tutorial, you leave the Report painter now. You do not save the 
report.

8 Select File>Close from the menu bar.

This Message Box displays to see if you want to save your report.

9 Click No.

The Report painter closes.
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L E S S O N  6 Graph Tutorial

Graphs present data in a visual way so that you can interpret it more easily. 
You can use graphs to supplement the numbers in a report or you can 
replace numbers with a graph. InfoMaker provides a variety of graph 
styles and options.

The graph you create in this tutorial uses financial data (the same data as 
the Query tutorial). You start with a report that is already created and add 
a graph to the report. When you have finished, the report and the graph 
look like this:

How long does this tutorial take?
About 30 minutes.
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Open the report to contain the graph 

Where you are
> Open the report to contain the graph

Create the basic graph
Save the graph (report)
Enhance the graph
Print the graph (report)

First you open a report that has been created for you. This report provides the 
data for your graph.

1 Click the Open button in the PowerBar.

The Open dialog box displays. It lists objects in the current library 
(tutor_im). You will be using the report named expenses.
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2 Select the Reports object type at the bottom of the dialog box.
Click expenses (scroll the list).
Click OK.

The report displays in the Report painter. Here is the Design view.
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3 Look at the Preview view.

InfoMaker retrieves information from the database and displays as much 
as fits on the screen.

4 Use the scroll bar on the right edge of the report to see more data.

The entire report consists of three pages: one for 2003, one for 2004, and 
one for 2005.
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Create the basic graph 

Where you are
Open the report to contain the graph

> Create the basic graph
Save the graph (report)
Enhance the graph
Print the graph (report)

The report you are working with has three pages, one for each of three years. 
The graph you create will be on all three pages. Its format will look the same 
from page to page, but the data will be for the correct year for each page.

This is what a graph for 2003 looks like. It shows the year’s expenses in five 
categories.

1 Select Insert>Control>Graph from the menu bar.
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2 Click in the middle of the Design view.

The Graph Data dialog box displays. 

3 Click the down arrow on the Rows box.

The drop-down list shows choices for rows.

The All option includes all rows in the graph. Since you want to have the 
appropriate graph for each of three years, you do not want to include all 
rows in the graph at the same time.

The Group 1 option includes the rows for the current Group 1. Group 1 for 
this report is grouping by year, so Group 1 is what you want. When you 
specify Group 1, you ensure that the graph includes only rows from the 
current year.
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4 Select Group 1.

Next you fill in the Category and Value boxes. The graph will show 
expenses for the year by type of expense. (For this graph you do not need 
to fill in the Series box.)

The description column provides the categories (Administration, Fees, 
R&D, Sales & Marketing, Services).

The sum of the amounts for the four quarters for each category provides 
the values.

5 Click the down arrow next to the Category box.

A drop-down list displays the columns you can choose to supply the 
categories to use in the graph. (You can think of categories as X values.)
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6 Select description.

This specifies that the values in the description column are the categories.

7 Click the down arrow next to the Value box.

A drop-down list displays all the choices for the column to supply the 
values to use in the graph. Notice that the choices include expressions such 
as counts and sums.

8 Select sum(amount for graph).

This specifies that the sum of the amount column is the value. A separate 
value is calculated for each category within each year.
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9 Click OK.

The graph displays in the report. What you see in the Design view is a 
representation of the graph. To see what it looks like in the report, you 
need to look at it in the Preview view.

10 Look at the graph in the Preview view.

In the Preview view, InfoMaker displays the data retrieved from the 
database both in the report and in the graph. The graph is small right now. 
In a few minutes, you will resize it.
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Save the graph (report) 

Where you are
Open the report to contain the graph
Create the basic graph

> Save the graph (report)
Enhance the graph
Print the graph (report)

Now you save the graph. The graph is part of the report, so to save the graph, 
you save the report that contains it. To leave the original report unchanged, you 
will use the Save As command. Save As saves a new report with the name you 
supply.

1 Select File>Save As from the menu bar.

The Save Report dialog box displays; the name of the report you opened 
earlier is highlighted.

2 Type expenses_graph.



Lesson 6    Graph Tutorial

Getting Started 153

3 Click in the Comments box and type This report summarizes expense 
data for 2003, 2004, and 2005. It includes graphs as well as numeric data.

4 Click OK.

InfoMaker saves your report, including the graph.
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Enhance the graph 

Where you are
Open the report to contain the graph
Create the basic graph
Save the graph (report)

> Enhance the graph
Print the graph (report)

To enhance the graph, you:

• Resize and reposition it

• Add a title

• Change graph types

Resize and reposition the graph
Usually you work in the Design view when enhancing a report or graph, but to 
resize and reposition a graph, you may find it easier to work on it in the Preview 
view. You can get a much better idea of what the page looks like. The sizing 
and positioning changes you make are retained and reflected in the Design 
view.

1 Resize and reposition the graph so that it looks like the one shown 
here.
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To make the graph bigger, put the pointer near a corner or a side until the 
pointer changes shape. Then click and drag the corner or the side. To move 
the graph, put the pointer in the middle of the graph and then click and drag 
the graph.

2 Use the scroll bar to display the graphs for 2004 and 2005.

Add a title

1 Move the pointer to the middle of the graph in the Design view (not the 
Preview view) and click.

This selects the graph. The current title, (None), displays on the graph, in 
the text box in the StyleBar, and in the Properties view.

2 Type Expense Breakdown.

The title displays in the graph and in the text box.
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Change the graph type
You can use many different types of graphs to present the same data. 
Sometimes it is useful to try different types until you find the one that works 
best for the data you are presenting.

Now you try several graph types with the expense data.

1 If you need to, use the scroll bar to display the entire graph in the 
Design view.

2 Move the pointer to the graph in Design view and click it.

The graph is selected. The properties for the graph display in the 
Properties view, with the General page on top. On this page you can 
choose a graph type. The current graph type is Column (Col (7)).
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3 Select the Bar (2) graph type from the Graph Type drop-down list.

The graph looks like this in the Preview view.
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4 Select the Pie (13) graph type from the Graph Type drop-down list.

InfoMaker redisplays the graph using the Pie style.

Pie seems to be a good style for showing the data, so you do not change 
the graph style again.

This is what the report with the graph looks like now.
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Print the graph (report) 

Where you are
Open the report to contain the graph
Create the basic graph
Save the graph (report)
Enhance the graph

> Print the graph (report)

1 Click the Preview view to make sure that it is current.
Select File>Print Report from the menu bar.

The Print dialog box displays.

2 Click OK to accept the defaults and print the report.

Your report goes to the printer or the print queue.

3 Select File>Close from the menu bar.

If you have not saved all your changes, a message box displays to see if 
you want to save changes.

4 Click Yes (if the message box displays).

The Report painter closes. 
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L E S S O N  7 Environment Tutorial

You use the Library painter to manage forms, reports, queries, pipelines, 
and the InfoMaker environment. In the Library painter you can:

• Open a form, report, query, or pipeline, and go automatically to the 
appropriate painter

• Set the current library

• Copy, move, and delete forms, reports, queries, and pipelines

In this tutorial you learn how to do these tasks.

How long does this tutorial take?
About 30 minutes.
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Open forms, reports, and queries 

Where you are
> Open forms, reports, and queries

Create a new library
Copy forms, reports, and queries
Create a new report from an existing one

First you learn about using the Library painter to open forms, reports, and 
queries. When you open one of these, you automatically go to the appropriate 
painter. (This is also true for pipelines, but you do not work with pipelines in 
this tutorial.)

1 Click the Library button in the PowerBar.

The Library painter workspace displays. 
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2 Select View>Most Recent Object from the menu bar.

The painter lists the forms, queries, reports, and pipelines in the current 
library and selects the object you worked on most recently. When you 
install InfoMaker, the current library is the InfoMaker sample library 
(tutor_im.pbl).

The list includes many samples as well as the form, query, and reports you 
created earlier.

3 Scroll the list to the bottom until you see the form 
contact_maintenance, which is the form you created earlier.
Double-click the form.
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The form displays in the Form painter. Accessing your form by 
double-clicking its name in the Library painter is the same as opening the 
form in the Form painter.

4 Click the Run button in the PainterBar.

Your form runs.

5 Click the Close button in the PainterBar.

The running form closes.

6 Select File>Close from the menu bar.

You return to the Library painter. Now you look at some other forms.

7 Double-click the form customer_maintenance.

8 Click the Run button in the PainterBar.
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This form is for maintaining customer information.

9 Click the Close button to return to the Form painter workspace.
Select File>Close from the menu bar to return to the Library painter.

10 Double-click the report emp_total_compensation.

The report displays in the Report painter.

11 Scroll the report in the Preview view.

12 Select File>Close from the menu bar.

The Report painter closes and the Library painter displays.
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Create a new library 

Where you are
Open forms, reports, and queries

> Create a new library
Copy forms, reports, and queries
Create a new report from an existing one

Now you create a new library on a shared drive so that you can copy some 
items into the library. 

Shared drive
These instructions assume that H:\ is a shared drive, but you can use any shared 
drive on your computer.

InfoMaker uses special libraries to hold forms, reports, queries, and pipelines. 
These libraries have the file extension pbl. When you save (or copy or move) 
a form, report, query, or pipeline, it goes into a pbl file (pronounced pibble).

1 Select File>New from the menu bar.

The New dialog box displays.

2 Select the Library tab and click OK.

The Library wizard displays.

3 Type h:\mylib.pbl and click Finish.

InfoMaker creates the new library on the H drive. This library is now the 
current library; its name displays in InfoMaker’s title bar. The previous 
current library still displays in the Library painter.
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Copy forms, reports, and queries 

Where you are
Open forms, reports, and queries
Create a new library

> Copy forms, reports, and queries
Create a new report from an existing one

Now you copy a form, a query, and two reports into the library on the shared 
drive. Then you can make them available to another InfoMaker users who can 
use them as is or modify them as needed. 

Remember that the other users must also be able to access the database. All 
InfoMaker users have SQL Anywhere and the contact table. That means other 
InfoMaker users can run the form, query, and reports you have created in this 
tutorial.

1 Drag tutor_im.pbl from the Tree view in the left pane to the List view 
in the right pane.

2 In the List view of the Library painter, click contactgrid (scroll the list in 
the Library painter as necessary).
Press Ctrl and click contacts_by_jobrole.
Press Ctrl and click d_dddw_states.
Press Ctrl and click q_expenses.
Press Ctrl and click contact_maintenance.

The five objects you selected are highlighted. You can copy, move, or 
delete them. You are going to copy them to the shared drive.
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Tip
You can sort the view by modification date to make it easier to locate 
objects you have just created or changed.

Why you include the report named d_dddw_states
The contact_maintenance form uses a DropDownDataWindow edit style 
for the state column. That edit style uses the report named d_dddw_states, 
which must be present in the library when you run the form.

If you create a new library for objects you create using the EAS Demo DB, 
you need to copy the eight reports that begin with d_dddw from the 
tutor_im.pbl to the new library. These reports go with the 
DropDownDataWindow edit styles that the tables in the EAS Demo DB 
use.

There is a way to make the reports centrally available. See the InfoMaker 
Users Guide.

3 Click the Copy button in the PainterBar.

The Select Library dialog box displays.

4 Change drives to the shared drive.
Select mylib.pbl.
Click Open.

InfoMaker copies the selected objects to the shared drive. It takes a minute 
or so. You can see messages about the copying at the bottom of your 
screen.
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5 Navigate to the shared drive.

The Library painter lists the contents of mylib.pbl, the current library.
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Create a new report from an existing one 

Where you are
Open forms, reports, and queries
Create a new library
Copy forms, reports, and queries

> Create a new report from an existing one

Now you create a new report from one of the reports on the shared drive. You 
then make a slight modification to the report.

The modification adds powerful options to the report that you can see when 
you run the report.

1 On the H drive, double-click the contactgrid report.

You go to the Report painter with the contactgrid report open.
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2 Select File>Save As from the menu bar.

The Save Report dialog box displays. You are going to change the name 
of the report so that you can keep the old one and create a new one with 
some changes.

3 Type the name contactgrid_with_prompting and click OK.

The report name changes. You are now working on a report called 
contactgrid_with_prompting.
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4 If the View>Column Specifications view is not already in the lower right 
corner of the Report painter, select View > Column Specifications 
from the menu bar.

The Column Specifications view displays, listing all the columns in the 
report. You can choose one, many, or all columns for prompting. The 
columns you choose here let you control what rows are selected when you 
run the report.

For example, if you choose the city column here, you can specify a city 
when you run the report. Then only rows that include that city are 
retrieved.

5 Select all the check boxes.

You are choosing all columns so that you can enter criteria for any column 
you want when you run the report.
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6 Select Rows>Retrieve from the menu bar.

The Specify Retrieval Criteria dialog box displays. Since you said that you 
wanted to be prompted for all the columns, the dialog box includes all the 
columns.

7 Click in the first cell in the title column.
Use the horizontal scroll bar to move the title column into full view.

A box with an arrow displays to show there is a drop-down list for that 
column.

8 Click the arrow to open the list.

9 Select Customer support.

This puts Customer support in the title column. This means that the report 
is limited to contacts in Customer support.
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10 Click OK.

The report displays. It includes only contacts in Customer support.

By setting up a report to prompt for criteria, you give yourself a lot of 
power and flexibility when you run the report. You learn more about this 
when you create an application in the next tutorial.

11 Select File>Close from the menu bar.
When prompted to save changes, click Yes.

The Report painter closes and you return to the Library painter. 

Now your new report is listed. It is a good idea to add comments to 
document the report. You can do that now.

12 Position the pointer on contactgrid_with_prompting.
Press the right mouse button to display the pop-up menu.
Select Properties.

The Properties dialog box displays.
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13 Type This report lets me enter selection criteria when I run the report.

The newly added comment displays.

14 Click OK.

Now you have become familiar with many of the tasks you can do in the 
Library painter.

15 Continue directly to the next tutorial, the Application tutorial.

(Leave the Library painter open.)
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L E S S O N  8 Application Tutorial

An InfoMaker application is a collection of related reports, forms, and 
pipelines. For example, the Contacts application that you create in this 
tutorial has:

• A form to maintain data in the contact table

• A report to list all contacts

• A report to list only contacts that meet your criteria

How long does this tutorial take?
About 30 minutes.
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Create the application 

Where you are
> Create the application

Create a shortcut to the application
Start the application
Use the Data button
Use the By Job button
Use the Ad Hoc button

Now you will create an application, complete with toolbars and menus, and 
you will create a shortcut for the application. Then you can run it from your 
desktop, just the way you run InfoMaker or any other application.

The application you create consists of an executable file and an initialization 
file. The initialization file provides information about the database to the 
executable file.

For example, InfoMaker itself is an application that has an executable file 
called im120.exe. This is the file you start running when you start InfoMaker. 
InfoMaker also has an initialization file called im.ini.

Terms
The executable file is also called an exe file (pronounced exxy). The 
initialization file is also called an ini file (pronounced inny).
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1 If you are continuing from Lesson 7, go to step 2.

Otherwise, go to the Library painter in the H:\ drive with the library named 
mylib.pbl set to be the current library (File>Select Library).

The Library painter shows the contents of mylib.pbl.

2 Select Design>Create Executable from the menu bar.

The Create Executable dialog box displays. In this dialog box you specify 
a title for the application window, a file name for the executable file, the 
folder for storing the executable file, and an icon for the application.
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3 Type Contacts in the Executable Title box.

Later, when you run your application, the title bar displays the word 
Contacts.

4 Type contacts.exe in the Executable File Name box.

This assigns a name to your executable file.

5 Click the Browse button next to the Executable Icon box to select an 
icon for your application.

The icon will display in the Windows shortcut. You create a shortcut 
shortly.
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6 Change to the Tutorial folder (the icon is there).
Click emp.ico.
Click Open to accept the emp.ico file as the icon for your application.

You return to the Create Executable dialog box. The icon and its full name 
display.

7 Type Version 1.0.1 in the Product Version and File Version boxes on 
the right.
Leave 1,0,0,1 in the boxes on the left.

The text you type in the boxes on the right displays on the Version tab page 
of the Properties dialog box when you look at the properties of the 
executable file in Windows Explorer. The four numbers separated by 
commas on the left can be used by installation programs.
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8 Click Next to select items for the application.

The Select Items dialog box displays. Now you select the form and reports 
for your application.

9 Click the check box for contactgrid_with_prompting.
Click the check box for contacts_by_jobrole.
Click the check box for contact_maintenance.
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10 Click Next to define the toolbar items.

The Executable Items dialog box displays. It lists the form and reports to 
be included in your application. The information you enter in the boxes to 
the right of the list of items is for the currently selected item.

Traditional and Contemporary menu styles
In this tutorial, you use the Contemporary menu style. For information 
about menu styles, see the InfoMaker Users Guide.

Finish defining all information before you click Finish
Do not click the Finish button or press enter until you have finished 
defining information for all the items you want to include in the 
application’s toolbar. Once you click Finish or press enter, InfoMaker 
generates the executable file.

If you create the executable file before you mean to, select 
Design>Create Executable again. InfoMaker remembers what you have 
specified. You can continue where you left off and re-create the executable 
file.

11 Select the Contemporary radio button.

12 Make sure contactgrid_with_prompting is selected.
In the Picture box, display the list and select CheckStatus5!.
Click the Text box and type Ad Hoc.
Press Tab to go to the MicroHelp box.
Type List contacts that meet the specified criteria.
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The Picture box specifies the picture for the button, which will be in the 
application’s toolbar.

The Text box provides text for the button and for the menu item that will 
run contact_maintenance in your application.

The MicroHelp box provides MicroHelp for the button and menu item.

13 Click contacts_by_jobrole.
In the Picture box, display the list and select Cascade!.
Click the Text box and type By Job.
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Press Tab to go to the MicroHelp box.
Type List all contacts grouped by job role.

14 Click contact_maintenance.
In the Picture box, select the entry AddWatch5!
Click the Text box and type Data.
Press Tab to move to the MicroHelp box.
Type Maintain contact information in the database.

Now you have finished providing information for the form and the two 
reports that are in your application.
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15 Click Finish.

InfoMaker creates the application, which consists of an executable file and 
an initialization file. These files are in the Tutorial folder. 

Now that InfoMaker has finished creating the application, you return to the 
Library painter.

Before leaving the Library painter, you select tutor_im.pbl as the current 
library. This is where the samples and the tutorial work are kept.

16 Select File>Select Library from the menu bar.

17 Select tutor_im.pbl from the Recent page in the Select File dialog box 
and click OK.

The current library is tutor_im.pbl again.

18 Select File>Exit from the menu bar.

InfoMaker closes.
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Create a shortcut to the application 

Where you are
Create the application

> Create a shortcut to the application
Start the application
Use the Data button
Use the By Job button
Use the Ad Hoc button

Now you make the application easy to access. To do this you create a shortcut 
on the Windows desktop.

1 Move the pointer to an empty area of the desktop and press the right 
mouse button.

The pop-up menu for the desktop displays.

2 Select New and then Shortcut.

The Create Shortcut dialog box displays.

3 To locate contacts.exe, click the Browse button.
In the Browse dialog box, change folders to the Tutorial folder.
Select contacts.exe and click OK.

You return to the Create Shortcut dialog box with the full path of the 
contacts.exe file in place.
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4 Click Next.

The Select A Title For The Program dialog box displays.

5 In the text box, type Contacts over the name offered as a default 
(contacts.exe).

This provides a better title to display under the icon on the desktop.

6 Click Finish.

Windows creates the shortcut to your application and displays it on the 
desktop. Now you must modify a property of the shortcut so that you can 
run your application.

7 Move the pointer to the icon and press the right mouse button to 
display the pop-up menu.
Select Properties to display the shortcut’s properties dialog box.

8 Select the Shortcut tab and type the location (path) of the Sybase 
system files in the Start in box.
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About the location of Sybase system files
When you install InfoMaker, the installation process automatically puts 
the DLLs in a system folder. If you have changed the names of the folders 
used for installing, you need to use your names in this step.

The folder path is C:\Program Files\Sybase\Shared\PowerBuilder. 

You must specify the name of the drive. If you use backslashes to specify 
a relative path name, the application will be unable to locate the system 
files.

9 Click OK.

Windows modifies the shortcut to your application. This modification 
enables Windows to find some InfoMaker modules (DLLs) required for 
running your application.
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Start the application 

Where you are
Create the application
Create a shortcut to the application

> Start the application
Use the Data button
Use the By Job button
Use the Ad Hoc button

In this exercise you start the application you created and take a look at its 
toolbar, MicroHelp, and menus.

1 Double-click the Contacts shortcut on your desktop.

Your application runs. Do not be surprised if it takes a minute to get 
everything running. The database itself has to start up so that you can 
access data.

The main window of the Contacts application displays.
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2 Notice the toolbar.

The Forms, Reports, and Exit buttons are automatically included. The Ad 
Hoc, By Job, and Data buttons are in the toolbar because you defined them 
when you created the application.

3 Move the pointer to one of the buttons.

Notice the MicroHelp at the bottom of the screen.

4 Click the Objects menu item.

Notice that Ad Hoc, By Job, and Data are included in the Objects menu. 
Your application has a toolbar and a menu. You can run forms and reports 
from either place.
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Use the Data button 

Where you are
Create the application
Create a shortcut to the application
Start the application

> Use the Data button
Use the By Job button
Use the Ad Hoc button

Now you use the Data button to run your form. You add a new contact and 
change information about an existing one.

1 Click the Data button.

Your form displays. Notice that title bars identify your application and the 
particular part you are using. You also have the usual form toolbar that lets 
you view, add, and update information in the database.

2 Click the Add a contact button in the form.

A blank form displays.
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3 Enter information for a new contact.
Use 62 for the Id entry and make up the rest.

Be sure to fill in all blanks. (The only columns you can skip are phone and 
fax; the other columns are defined as required in the database.) Use the Tab 
key to move from box to box.

4 Click the Save changes button in the form.

Your new contact goes into the database. You will see it shortly.

Next you want to display information on the contact with Id 37 so that you 
can make a correction.

About updating the database and canceling changes
You can click the Update button to update the database immediately; or 
you can wait until you close the form, and InfoMaker prompts you then to 
see if you want to update the database.

The Cancel Changes menu item on the Rows menu cancels any changes 
you have made since the last time you clicked Update.

5 Click the Criteria button to display a blank form for setting retrieval 
criteria.
Type 37 in the Id box.

This sets the retrieval criteria.
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6 Click the Apply button.

This applies the retrieval criteria. InfoMaker retrieves the row with the Id 
37.

7 Change the Street to 134 Cherry St.
Click the Save changes button in the form.

Your changes are added immediately to the database.

8 Click the Next button.

A message box displays because you have set criteria that allow only row 
37 to be retrieved. You need to remove the criteria or specify other criteria.



Lesson 8    Application Tutorial

Getting Started 195

9 Click OK to close the message box.
Click the Criteria button.

10 Select 37 and press the delete key to delete 37 from the Id box.
Click the Apply button.

Now you have no criteria, so InfoMaker retrieves all rows.

11 Select File>Close from the menu bar.

Your form closes.
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Use the By Job button 

Where you are
Create the application
Create a shortcut to the application
Start the application
Use the Data button

> Use the By Job button
Use the Ad Hoc button

Now you run a report of all contacts grouped by job role.

1 Click the By Job button.

The report that lists all contacts grouped by job role displays.

2 Scroll the report to see your new contact.
When you have finished, select File>Close from the menu bar.

Once again you return to the main application window.
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Use the Ad Hoc button 

Where you are
Create the application
Create a shortcut to the application
Start the application
Use the Data button
Use the By Job button

> Use the Ad Hoc button

Now you use the Ad Hoc button to run several different reports based on the 
criteria you specify.

1 Click the Ad Hoc button.

The Specify Retrieval Criteria dialog box displays. This dialog box 
displays because you selected Prompt For Criteria for this report. 
Whenever you run this report, you are first prompted for criteria.
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2 Click OK.

Because you did not specify any criteria, the report retrieves all your 
contacts.

3 Select Rows>Retrieve from the menu bar.

The Specify Retrieval Criteria dialog box displays again. This time you 
enter criteria.

4 Go to the title column.
Select Documentation from the drop-down list.
Click OK.
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You have specified that the report is to list only contacts who have jobs in 
documentation.

5 Click the Retrieve button.

The Specify Retrieval Criteria dialog box displays again. Notice that the 
criterion in the title column is still in effect. To specify different criteria, 
you are now going to delete Documentation. Then you enter new criteria.

6 Select the Documentation entry in the title column.
Press delete.

This deletes criteria from the title column. Now you are going to enter new 
criteria.

7 Click in the first box underneath last_name.
Type like "c%".
Click OK.

This entry (like "c%") helps you find a name you cannot remember. All 
you can remember is that it starts with C.

The like operator specifies that only rows that match what follows should 
be retrieved. The quotes are required. The c means that the first character 
must be C. The % sign means any characters can follow the C.
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This is the report.

8 Click the Retrieve button.

The Specify Retrieval Criteria dialog box displays again. The requirement 
that the last name begin with C is still in effect. Now you add an additional 
requirement. The report is to list contacts whose last names begin with C 
and who are from Burlington.

9 Use the scroll bar to display the city column.
Click in the first box underneath city and type Burlington.

10 Click OK.

Now the report has only contacts whose last names begin with C and who 
are from Burlington.
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11 Click the Retrieve button.

The Specify Retrieval Criteria dialog box displays again. The 
requirements that the last name begin with C and that the city be 
Burlington are still in effect.

Now you change the city requirement slightly. The report is to list contacts 
whose last names begin with C or who are from Atlanta. To be listed, 
contacts have to meet either requirement; they do not have to meet both.

12 Use the scroll bar to display the city column.
Select Burlington and press delete to delete Burlington.

13 Press the down arrow key to move down one row.
Type Atlanta.

14 Click OK.

By specifying criteria in two different rows in the dialog box, you are 
specifying that the report should retrieve rows from the database that meet 
the first row of criteria or the second row of criteria.

Your report retrieves all contacts whose names begin with C. It also 
retrieves all contacts who are from Atlanta. It is hard to look at the two sets 
of rows, so now you sort by city. Then all the Atlanta rows will be together.



Use the Ad Hoc button 

202  InfoMaker

15 Select Rows>Sort from the menu bar.

The Specify Sort Columns dialog box displays.

16 Drag the Id column out of the Columns box and the city column into 
the Columns box.
Click OK.

InfoMaker sorts the rows by city. Now you can see the Atlanta contacts 
first. These are followed by contacts whose names begin with C.

Now you are finished using this report and using the application.

17 Click the Exit button.

This closes the report and the application.

Congratulations. Now you have done it all. You have created data, maintained 
it, and reported on it. And you have put all your work together into your own 
application. See the next page for some suggestions on what to do next.
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What to do next 
You might be ready to make your own InfoMaker application or you might be 
interested in learning more by using the sample library, tutor_im.pbl. Here are 
some ideas.

Personalize the contact data  Delete all the data in the contact table and add 
your own. You can run your Contacts application to do this. Use the form to 
delete and add data.

Look at other sample forms and reports  In the Environment tutorial, you 
accessed a few of the sample forms and reports delivered with InfoMaker. Now 
you can go back and look at more. The samples are located in tutor_im.pbl. 
When you look, notice both the design version and the results you get when 
you run a form or report.

Use the sample pipeline  The sample library includes a sample pipeline. 
Pipelines let you move data structures and data within and between databases. 
Open the library and double-click the pipeline. This takes you to the Data 
Pipeline painter. The sample pipeline creates a copy of the employee table in 
the EAS Demo DB. To create the copy, you execute the pipeline.

Change sample forms and reports  If you want to try some changes with 
samples, open the form or report and use Save As on the File menu. With Save 
As, you create a copy of the form or report and save it with a new name. Then 
you can make changes without affecting the original.

Create other forms and reports using the EAS Demo DB  Once you have 
looked at the sample forms and reports, try creating some on your own. The 
EAS Demo DB has several tables that you can use. You might want to start 
with the contact table since you are familiar with it. Use the other InfoMaker 
documentation and online Help as you work.
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A
actions in forms 46
AND operator 134
applications

about 177
applying retrieval criteria in forms 194
assigning version numbers 181
creating 186
creating shortcuts 187
defining menu items 185
defining MicroHelp 184
defining toolbar buttons 184
defining toolbar items 183
executable (EXE) files 178, 186
initialization (INI) files 178, 186
modifying most recently created 183
running forms 192
running reports 196
selecting objects for 182
setting retrieval criteria in forms 193
specifying a title 180
specifying icons 180
specifying the application file name 180
specifying the folder for the EXE file 180
starting 190
updating the database 193

Ascending sort order option 73

B
buttons

adding to forms 43
defining in application toolbars 184
moving in forms 50

C
columns

defining display widths 111
defining DropDownDataWindow edit style 113
defining DropDownListBox edit style 106
defining headers 111
defining in tables 96
defining labels 111
Null setting 100
setting initial values 117
validating data 117

comments
adding to objects in libraries 174
modifying for objects in libraries 174

computed fields, adding to reports 87
contact.txt file 122
control edges, showing in report Design view 70
controls in forms 43
controls in reports

deleting 30
deselecting 29
dragging 28
edges, showing in Design view 70
moving 28
selecting multiple 28
showing edges 27

copying
forms 167
queries 167
reports 167

counts, adding to reports 87
Create Executable dialog box 179

D
d_dddw_states report 168
data sources

defining for forms 35

Index
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defining for reports 62
Query 138
Quick Select 36, 61

data values in edit styles 108
data, importing into tables 121
database

canceling changes 193
inserting rows 54
retrieving 122
updating 57, 122, 193

Database painter 96
dates, adding to reports 85
deleting

forms 167
queries 167
reports 167

Descending sort order option 73
dialog boxes

Create Executable 179
Executable Items 183
Modify Expression 88
New Form 35, 36
New Report 140
Print 94, 159
Quick Select 36, 37, 38, 62, 125
Save As 93
Save Form 42
Save Query 130
Save Report 69, 152
Select Action 45
Select Form 34
Select Import File 122
Select Query 139
Select Tables 97
Specify Retrieval Criteria 173, 197
Specify Sort Columns 72
tabs in the SQL toolbox 132

display values in edit styles 108
dragging 43
DropDownDataWindow edit style

about 114
database and PBL requirements 168
defining for column 113

DropDownListBox edit style
defining 106
using 55

E
Edit Mask edit style

defining 118
using 56, 119

executable (EXE) files 178
Executable Items dialog box 183
extended attribute system tables 39
extended attributes 105

F
Form painter 34
forms

actions 46
adding buttons 43
adding reports 51
adding scroll bars to reports 53
adding titles 48
applying retrieval criteria 194
changing borders for data 49
controls 43
copying 167
creating 34
data sources 35
deleting 167
making reports resizable in 53
moving 167
moving buttons 50
opening in a library 162
previewing (running) 40, 54
resizing reports in 53
running in applications 192
saving 42
setting retrieval criteria 193
styles 35

G
graph type, changing 156
graphs

adding titles 155
Bar type 157
changing type 156
creating 147
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defining data 148
Pie type 158
previewing 151
printing 159
repositioning 154
resizing 154
saving 152

grid, displaying in report Design view 27
grouping in reports 74

I
icons, specifying for applications 180
im.ini 178
im110.exe 178
importing data 121
initial values, setting for columns 117
initialization (INI) files 178
inserting rows in the database 54

L
lasso selection 30, 49
libraries

adding comments to objects 174
changing current 166
copying objects 167
deleting objects 167
modifying comments for objects 174
moving objects 167
opening 166
opening objects 162

Library painter 161
LIKE operator 199

M
menu items, defining in applications 185
menu styles, selecting 183
menus, about WindowToolbars notation 17
MicroHelp, defining in applications 184
Modify Expression dialog box 88
mouse

displaying a pop-up menu 16
dragging toolbars 17

moving
forms 167
queries 167
reports 167

mylib.pbl 166

N
New Form dialog box 35, 36

O
objects in libraries

adding comments 174
copying 167
deleting 167
modifying comments 174
moving 167

operators
logical AND 134
logical LIKE 199

P
page numbers, adding to reports 86
painters

accessing 11
Data Pipeline 203
Database 96
Form 34
Library 161
Query 125
Report 144

PDF, saving a report as 93
pipeline 203
popup menus

displaying 16
using 22

previewing
(running) forms 40, 54
graphs 151
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queries 129
reports 67

primary key, defining for a table 103
Print dialog box 94, 159
printing

graphs 159
reports 92, 94

prompting for retrieval criteria 172, 197
Properties view 22

Q
queries

about 123
copying 167
deleting 167
moving 167
opening in a library 162
previewing 129
saving 130
selecting columns 125
specifying selection criteria 132
specifying sorting 136
using as data source 138

Query painter 125
Quick Select data source 36, 61
Quick Select dialog box 36, 37, 38, 62, 125

R
Report Options dialog box 26
Report painter 144
reports

adding a date 85
adding a title 82
adding computed fields 87
adding counts 87
adding page numbers 86
adding to forms 51
copying 167
creating 60
creating from queries 138
creating new from existing 170
data sources 62

deleting 167
deleting controls 80
detail band 77
displaying grid in Design view 27
displaying rulers in Design view 70
footer band 77
group header band 77, 79
group trailer band 77
grouping 74
header band 77
moving 167
opening 144
opening in a library 162
previewing 67
printing 92, 94
prompting for retrieval criteria 172
rearranging controls 76
resizing in forms 53
running in applications 196
saving 69
saving as PDF 93
selecting all text 81
showing control edges 70
sorting 72
specifying retrieval criteria 172
styles 61
summary band 77
tabular style 61
working with bands 77

retrieval criteria
applying in forms 194
selecting columns for prompting 172
setting in forms 193
specifying for reports 172, 197

retrieving data 122
rulers, displaying in report Design view 70

S
Save As dialog box 93
Save Form dialog box 42
Save Query dialog box 130
Save Report dialog box 69, 152
saving

forms 42
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graphs 152
queries 130
reports 69

scroll bars, adding to reports in forms 53
Select Action dialog box 45
Select Form dialog box 34
Select Import File dialog box 122
Select Query dialog box 139
selecting

lasso 30, 49
multiple controls in reports 28

shortcuts, creating for an application 187
sorting

in queries 136
in reports 72
in reports in an application 202

Specify Retrieval Criteria dialog box 173, 197
Specify Sort Columns dialog box 72
specifying retrieval criteria for reports 172
SQL Anywhere database 95, 102
starting InfoMaker 7, 10
StyleBar, using 45
styles

of forms 35
of reports 61

T
tables

about 95
commenting 104
creating 96, 102
defining a primary key 103
defining columns 96, 101
importing data 121
saving 102

text file, for importing data 121
titles

adding to forms 48
adding to graphs 155
adding to reports 82

toolbar items, defining for applications 183
toolbars

about 16
defining buttons for 184

dragging 17
making floating 17
Objects drop-down tool bar 19
showing PowerTips 19
showing text 18

TUTOR_IM.PBL 8
tutor_im.pbl 8, 163
tutorials

requirements for using 8
times 8

U
undoing changes 30
updating the database 57, 122, 193

V
validating data 117
validation rules 117
version numbers, for executables 181
views, managing 20

X
XML, saving a report as 93
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