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About This Book

Audience This book is for new InfoMaker® users.

How to use this book Thisbook introduces InfoM aker and providesatutorial for learning to use
InfoMaker. The lessons teach InfoMaker basics and how to create forms,
reports, queries, and graphs. The last lesson puts everything into an
InfoMaker application.

Related documents When you have a question about using InfoMaker, you can access its
online Help system or consult one of the following books:
Book Description
Installation Guide | Providesinstructionsfor installing InfoM aker
Getting Sarted Introduces you to InfoMaker and provides atutoria you
can step through to learn the basics
User’s Guide Tells how to use InfoM aker to create reports, work with

databases, transfer data between databases, createformsto
update data, create queries to retrieve data automatically,
and create applications to package reports and forms

Connecting to Tells how to connect to a database from InfoM aker;
Your Database describes how to set up, define, and manage database
connections accessed through a standard database
interface (such as ODBC or JDBC) or one of the
InfoMaker native database interfaces

Other sources of Use the Sybase Getting Started CD, the SyBooks CD, and the Sybase
information Product Manuals Web site to learn more about your product:

*  The Getting Started CD contains release bulletins and install ation
guidesin PDF format, and may also contain other documents or
updated information not included on the SyBooks CD. It isincluded
with your software. To read or print documents on the Getting Started
CD, you need Adobe Acrobat Reader, which you can download at no
charge from the Adobe Web site using alink provided on the CD.

Getting Started Vii



Sybase certifications
on the Web

Viii

The SyBooks CD contains product manuals and is included with your
software. The Eclipse-based SyBooks browser allows you to access the
manuals in an easy-to-use, HTML-based format.

Some documentation may be provided in PDF format, which you can
access through the PDF directory on the SyBooks CD. To read or print the
PDF files, you need Adobe Acrobat Reader.

Refer to the SyBooks I nstallation Guide on the Getting Started CD, or the
README.txt file on the SyBooks CD for instructions on installing and
starting SyBooks.

The Sybase Product Manuals Web siteis an online version of the SyBooks
CD that you can access using a standard Web browser. In addition to
product manuals, you will find links to EBFs/Maintenance, Technical
Documents, Case Management, Solved Cases, newsgroups, and the
Sybase Developer Network.

To access the Sybase Product Manuals Web site, go to Product Manuals at
http://www.sybase.com/support/manuals/.

Technical documentation at the Sybase Web site is updated frequently.

Finding the latest information on product certifications

1

4

Point your Web browser to Technical Documents at
http://www.sybase.com/support/techdocs/.

Click Certification Report.

In the Certification Report filter select aproduct, platform, and timeframe
and then click Go.

Click a Certification Report title to display the report.

Finding the latest information on component certifications

1

Point your Web browser to Availability and Certification Reports at
http://certification.sybase.com/.

Either select the product family and product under Search by Base
Product; or select the platform and product under Search by Platform.

Select Search to display the availability and certification report for the
selection.

InfoMaker



About This Book

Sybase EBFs and
software
maintenance

If you need help

Getting Started

O Creating a personalized view of the Sybase Web site (including support

pages)
Set up aMySybase profile. MySybaseisafree servicethat allowsyouto create
apersonalized view of Sybase Web pages.

1 Point your Web browser to Technical Documents at
http://www.sybase.com/support/techdocs/.

2 Click MySybase and create a MySybase profile.

You can find information about EBFs and software maintenance on the Sybase
Web site.

Finding the latest information on EBFs and software maintenance

1 Point your Web browser to the Sybase Support Page at
http://www.sybase.com/support.

2 Select EBFs/Maintenance. If prompted, enter your MySybase user name
and password.

3 Select aproduct.

4 Specify atime frame and click Go. A list of EBF/Maintenance releasesis
displayed.
Padlock icons indicate that you do not have download authorization for
certain EBF/Maintenance releases because you are not registered as a
Technical Support Contact. If you have not registered, but have valid
information provided by your Sybase representative or through your
support contract, click Edit Roles to add the “ Technical Support Contact”
role to your MySybase profile.

5 Click the Info icon to display the EBF/Maintenance report, or click the
product description to download the software.

Each Sybaseinstallation that has purchased a support contract has one or more
designated people who are authorized to contact Sybase Technical Support. If
you cannot resolve aproblem using the manuals or online help, please havethe
designated person contact Sybase Technical Support or the Sybase subsidiary
in your area.
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CHAPTER 1

Getting Started

Welcome to InfoMaker

InfoMaker is apowerful yet easy-to-use reporting and data maintenance
tool that lets you work with data in the Windows environment.

With InfoMaker you can create sophisticated forms, reports, graphs,
crosstabs, and tables, as well as applications that use these as building
blocks. You can also move data between databases using the InfoM aker
data pipeline.

This chapter describes:

¢ What you make with InfoMaker
e Starting InfoMaker

e Using thetutorials

¢ InfoMaker samples



What you make with InfoMaker

What you make with InfoMaker

Forms
Q Employee Data [_ (O]
Employee ID: im Birth Date:| 0B/05/1959
Manager ID:|501 Soc. Sec. No.:| 017-34-3033
Emp. First Hame:|Fran Salany:| $45,700.00
Emp. Last Name: [ihitney Start Date:| 02/26/1987
Department ID:[100 Termination Date:| 00/00/0000
Street: |49 EastWashington Street Status:| & active
City: [Meedham " Tarminated
i
State:lMA— On Leave
Zip Code:[02192- Health Insurance: v/
Phone:[(17) 555-3985 Life Insurance: [V
Sex: [ Male Day Care: [~
& Female
Reports
Preview - emp_total_compensation [=]
Total Compensation REPon Value of heaith ins. = 34,300 Page _1 O_f 2 =
Salary Plus Benefits Vaiue of life msurance = $(5.43 x salane1,000 08/14102
lraine af day care = $5,200
Department Employ Employ Employ Salary Health Life Day SalaryPlus
18] 18] First Name Last HName Ins. Ins. Care Benefits
100 145 Kirm Lull 87,900 I =2l - $93,177
501 David Scott $96,3200 I =2l =2l 106,823
Sheffield $87,900 = F . $98,3 s
Fad
200 902 Judy Snow 87,500 I =2l - $92,775
Total: §27.500 Total: $92779
Average: $87,500 Average: $92773
=
2 InfoMaker



CHAPTER 1 Welcome to InfoMaker

Crosstabs
Humber of employees by Total number of
department and salary employees making
the salary
(0,000 includes up to 39,999
Dept Id
Salary] 100 200 300 400 500
20000 2 ] 7
30000 3 g 2 5 2 20
40000 =1 5 2 5 1 19
50000 4 3 3 2 1 13
60000 4 1 2 7
T0000 2 1 1 4
0000 2 1 3
90000 1 1
130000 1 1
Total number of employees 2 18 g 18 g
n the department
Reports with nested
reports
272172001 Customers and Orders
Customer Information Order History
Customer ID: 105
First Name: Laura Sales Order Date Sales Line # Product Quantity Date
Last Name: McCarthy _(_"_d_er o Rep m_ o Shipped
Address: 1210 Highuay 35 2005
City: Carmel
State: N
Zip Code: 46032-
Phone Number: [317) 555-8437
Fumpany Name: Amo & Sons T Tosnoms e T an U enrm
TT2see pezims @se [ 00 W n9zzEE
el R P - 08/22085

Getting Started 3
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Composite reports

Forms with reports

2572001

Quick Reference Information

Pradusts and Gurrent Inventary Bales Reprosantatives and Total Humber of Ordars
Product  Product Product Halcs Skt ol
o e DoscHpton PHc  In Stk ReplD e Phane Ovdors
o Tew Shim Tank Top BT = 1= Phillp Chin () SE5-2141 T
ol T Shim Ntk EACTE =4 125 MWarc oIl (BT SE5-2144 EH
o T Shim Craw Hatk EACTE ™ = Rellin Cusrtsy [S10) SE5-T255 114
4o Basetall Cap  Comon Cap BT 1z 45T dames  mlcbucher (713 9552627 =
Ll Basetall Cap Wead cap BT 1z EET Mary Garcla MiNses-14M =4
o Wiser Closh Wisor o0 % = Ramlesn Polmas EATISES A 6z
Eal Msor Plasde Wisor ETOC = 256 Samudd Singer [502) S55-1255 o
B0 awsarshim oG Swsdshim Bl ol w o Malra wally [509) SE5-2TES g
21 awsarshim Tppsa Swearshim B2 0 1z 0 Pamala Savanno (M) S55-125T £1
o Shoms Comon Shoms BAS0 an 114z Allson Clark [S10) SE5-04 07 T
1506 Catharing Plckan EITSEsMTE 51
Product Sakz= Summary Sales Summary
TR I B S paes |
WG Tew Shim Tank Top 214 B21ETE W:‘i:::__
W1 Tesghin Vneck FL I SR Tank Top-J—
WE  TewShin Craw Hatk 242 FMETZ Plasde iz or- N
43t Baseball Cap Comon Cap T REEGE HODG
401 Bagsball Cap Wel cap e ORI Crew hack -
e Mlser Cleeh Wigar HER  BI3SE4 Comon Shor: -
S04 Wiser Blagds Visor U GComon Cap-
00 Sweamhln  Wooac Sweamhlm MEF  ETIAML ot iz —
501 Gwedwhbin  TIpp<d Swedamhin  XTR4 BESITE 600 abeie  sMie ande
T Shoms Caomon Shoms 4515 FE M0
o Maintai ntact Information [_[O] =]
1| Add a | Delste a | Save chang |
Last Name: ILamhert | 1
First Name: ITE"_\,I Id | Last Name First Name Job Role b
Job Role: W 1 Hildehrand Jane Marketing 12850 W
2 Simrmon Larry Sales 34 Grar—
Shreet: [204 Page St 3 Critch Susan Product development |45 Cerr
City: ICan[Un 4 Lambert Terry Addtministration 204 Far
State: IMA— 5 Sullivan Darothy C.usmmer suppart 54 Wiiri
[ Paull Riose Finance T4 Bay
Zip: |94503 7 Glassmann  Beth Product development |44 Oak
Phone: I[EW?]EW & Poel Gene Training 552 e
] Fish Jefrey Marketing 6% Red
Fan: [E771 555-3682 10 Clarke Mol (sales 6 Pine:
11 Heley Wit Docutmentstion 16 Rair =
4 | ;I_I

InfoMaker



CHAPTER 1 Welcome to InfoMaker

Graphs
Contacts by Job Role
B acministration A% S00%
I Customer support
B Cocumertstion
[  Finance 25.00%
l:l Hurnanh resources
[  Marketing
e
B Frocuct developmert
o
B Traiving 16.67%
1E7w  1000%
Reports with graphs
Breakdown of Salary Expenses
Department Total Sala
P v Salary Expense by Department
Finance $535500.00
Marketing $688,250.75 Shipping
R&D $1,282,198.19
Salkes
Sales $919,428.00 T
=
Shipping $303,769.50 & R&pD
&
Mareting
Financ=
DI ED:II:I:ID 10350:0 15:6:03
Total Salsny

Getting Started 5



What you make with InfoMaker

Labels

Applications

Alex Ahmed
114 Cushing Street
Meedham, WA 02192

Joseph Barker
58 West Drive
Bedford, MA 01730

Irene E
37 Gles
Eedfon

Jeannette Bertrand
208 Concord Street
Acton, MA 01720

Janet Bigelow
84 Lunda Street
Waltharn, MA 02154

66 Bea
MNeedh

Jane Braun Rohert Breault M atthe
45'Wood Street A8 Cherry Strest a7 Tayl
Cambridge, MA 02140 Milton, A 02186 Lexing
Joyce Butterfield Shih Lin Chao Doug «
119 Adams Street 549 Halyake Street a7 Wel
Cambridge, MA 02140 Lexington, MA 02173 Concol

AdHoo

=

Byjob

& I3

Data Exit

File Display Hows “Window Help

BE BE ® = © &

Farms Reparts Ad Hac Eyjob Data Exit

<9 14 4 > ] =i I3
Retrieve First Prior Mext Last Print. Close

Id | Last Name First Name Job Role Street

3 Critch Suzan Product development 45 Center St

T Glassmann Beth Product development 44 Oak 5t

14 Chin David Product development 16 Wiaverly Rd.
26 Mulley Joan Product development 108 Wiasthorn Ter.
30 Demarco Michael Product development 23 Clare Awve.
35 Burril Dana Product development 234 Beacon St
40 Jardan Suzan Product development %5 Gordon St
A UAdddand [= ] Dvmcdiied dlenlmmramet ey Dlmmemwnt OF

InfoMaker



CHAPTER 1 Welcome to InfoMaker

Starting InfoMaker
These instructions assume that you have aready installed InfoM aker.
For information, see the Installation Guide.

O To start InfoMaker using the Windows Start menu:

«  Display the Start menu and sel ect Programs, then Sybase, then InfoM aker
10.5, and then InfoMaker. The initial InfoMaker screen displays.

Theinitial screen includes the PowerBar, which has buttons for creating
new objects and accessing existing objects.

tutor_im.pbl - InfoMaker
File Tools ‘Window Help

IFEEIERIEECLE

[Ready

Notice that the buttons on the PowerBar display iconswith no associated text.
You can display button text if you want to, and you will learn to do that in
Lesson 1.

Getting Started 7



Using the tutorials

Using the tutorials

Requirements

If you do not have
Adaptive Server
Anywhere

Approximate times

To use the InfoM aker tutorials, you need to:
* Beconnected to the EAS Demo DB
* Havethe sample library named tutor_im.pbl open

Thistutorial usesthe EAS Demo DB database that installs with InfoM aker.
Thisisan Adaptive Server Anywhere database and requires an Adaptive
Server Anywhere engine.

* If you do not already have Adaptive Server Anywhere on your local
machine or server, you must install it now. (You can install it from the
product CD.) If youinstalled InfoM aker in anondefault | ocation, you must
make sure that the odbc.ini registry entry definingthe EASDemo DB asa
datasource pointsto the correct location of the Adaptive Server Anywhere

engine.
Tutorial Lesson | Minutes
InfoMaker Basics | 1 15
Form 2 45
Report 3 45
Table 4 45
Query 5 15
Graph 6 30
Environment 7 30
Application 8 30

InfoMaker samples

The InfoMaker sample library named tutor_im.pbl isthe library you usein the
tutorials. The tutor_im.pbl library includes sample reports, forms, a sample
query, and a sample pipeline. After you have finished with the tutorials, you
might want to look at these samplesto learn more. Many of the samples are
discussed in the InfoMaker User’s Guide.

InfoMaker



LESSON 1 InfoMaker Basics Tutorial

The InfoMaker world is afriendly and efficient environment in which to

work. It providesfeatures such asmovabletoolbars, pop-up menus, views,
and more.

In thistutorial you learn the basic skills you need for working in
InfoMaker.

&S| Report - emp_total_compensation

[_[O]x]

Total COMPeNnsation REPOMt [ vaw arrearn s, -s0:00 Page
|sa[ary Plus Beneﬁts‘ TUIDiin (Value of fife insurance = 805,43 X satanyi1,000 -
B Seiiririnin| Value of day care = 85,200 Lol

Department

Employee | Employes -~ Employee - |- Salary | [Health ay | [Salary Plus
L. I B 5 First Hame: - - - [asl Mame - -|--- - | Ins. - Care| | Benefits
Header 1

1: Header group dept_id T

Cldept Jd [ Clemp_id] T lerap fhame: C lerap Iname: ; [lsalan [T
Detail T_ -

IR e | | EETET A SO

i

Total Cﬂmpensation Report Vaive of heaith Ins. = $4, 800 Page 10f 4

Salary Plus Beneﬁts Vg of jife instvance = $(5.43 x saian 1,000 224199
Vgive of day care = 35,200

Department Empl Empl Empl

E

E Salary  Health Life Day SalaryPlus

ID ID First Name Last Name Ins. Ins. Care Benefits

100 102 Fran Whitney F45,700 o2l [0 380748
108 Matthiew Cobh $62,000 FF O gETaT

160 Rohert Breault $57,490
i :

[v! | 2l $B7,802

|Page 1 of 4 [ [

How long does this tutorial take?
About 15 minutes.

Getting Started



Start InfoMaker

Start InfoMaker

10

Where you are

> Start InfoMaker

Access objects and painters
Use toolbars

Use views

Use pop-up menus

Use the mouse with controls

Now you start InfoM aker.

1

Display the Windows Start menu.

Select Programs, then Sybase, then InfoMaker 10.5, and then
InfoMaker.

ThelnfoMaker initial screendisplays. It includesthe PowerBar, which has
buttons for various InfoMaker activities.

tutor_im.pbl - InfoMaker 10l =|
File Tools ‘Window Help

IFEEIERIEECLE

|Ready 4

InfoMaker



Lesson 1 InfoMaker Basics Tutorial

Access objects and painters

Getting Started

Where you are
Start InfoMaker
> Access objects and painters
Use toolbars
Use views
Use pop-up menus
Use the mouse with controls

What click means
The word click is used throughout these tutorials to mean move the pointer

somewhere and press the left (primary) mouse button. For example, click the
Open button.

1 Click the Open button in the PowerBar.

) tutor_im.pbl - InfoMaker _ ||:||1|

File Tools/w_u:low Help

Fel Lib Lib List To-DolList  Library DE Prof  Databaz, Exit

Your toolbar might not be showing text on the buttons. You learn how to
display text in afew minutes.

11



Access objects and painters

12

The Open dialog box displays. It lists the objectsin the current library,
whichisthelibrary named tutor_im.pbl. Thislibrary includes samplesthat

come with InfoMaker; it isthe library you use for the tutorials.

x|
ok |

e P |
customer_list

customer_mainkenance
departments_and_their_employees

employee_data

E
Comments:

Sample: Masterfdetail many-to-one form, The master ﬂ
part is a list of company names and IDs, Select a
company and look in the detail part for details about LI

Library:

asetInfolaker 10,5 tutorialibutor

4] |
Object Type:
I : Farms j

Cancel |
Help |

If the current library is not tutor_im.pbl
If the current library is not tutor_im.pbl, you need to change it. Select

File>Select Library and use the Browse page to navigate to tutor_im.pbl
inthe Tutorial folder (inthefolder structurewhere InfoM aker isinstalled).
Then click the Open button in the PowerBar.
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Lesson 1 InfoMaker Basics Tutorial

Getting Started

Select Reports as the Object type at the bottom of the dialog box.
Click expenses (scroll the list until you see the report named
expenses) and then click OK.

x|
Object: oK I
Expenses
F Cancel |
emp_nup_salary_benefits ;I
emp_telephone_attributes —IHEID

emp_total_compensation

emplovee grouped salar
printer_sales
tabular_orders 4

Comments:

Tutorial: Used For tutorial, Expenses for years ;I
1995-1997
E
Library:

=% C:\Program Files!s

1] |
Object Type:
Feports j

InfoMaker connects to the EAS Demo DB and the report displaysin the
Report painter. You learn about the Report painter in the Report tutorial.
For now you learn basic skills.

First you are going to make a few settingsin your working environment.

If InfoMaker does not fill your screen, click the maximize box in the
upper-right corner of the InfoMaker frame.

InfoMaker fills the screen.

Select View>Layouts>(Default) from the menu bar.

InfoMaker displays the Report painter default layout of views. (Your
views may already have been set to the default. Now you know how to get
back to the default anytime you want to.)

Now you close the tabbed view at the bottom right of the screen since you
are not going to be using those views.
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Access objects and painters

5

6

14

Move the pointer to a position just above the up-arrow (at the lower
right edge to the right of DB Name) until the title bar of the view drops
(displays).

(g4 tutor_im.pbl - InfoMaker ;IEIEI
File Edit View Insert Format Design Rows Tools Window Help
[Med@n0= 6|k
l@alevla-l«mza]as|d x|
E expenses - Report ;Iglil
T e T e T e e I j
ﬂ General |Po|nter| pricd Lt
Expenses for year :
Units
II,I'IDDU Inch (2) 'l
Amount Timer Interval:
in thousands IU =
=i
Header t
Color
1: Header group year(
_ILI ||:|Window EackaroL 'I
Q—I i J I Hide Gray Line on page
2 :
= I~ ‘Web Data'Window
Expenses for 1995
Amount
in thousand L
| i ;l_‘
= e
= @ Feml wersion="1.0" encoding="UTF-16LE" standalone="a Mame Type Prompt DE Mame o
=- ] expenses 1 |year char(4) [T |fin_data.year
R
2] BXpEnsEs_Tow 2 |quarter chatiZ) [ [Fin_daka.quarter
year 3 |amount decimal(®)] [ [fin_data. amount =
expenses_aroupl 4 |type char(10) | [ |fin_code.type -|
< | »
ML - {untitled) A [4Column Specification - Expenses‘Data - EXpEI‘ISESkCDI‘\U[;I
(Ready [Page1of3 | [ [

S

Continue moving the pointer until it is over the Close button (the
button with the X'in it in the upper right) and click it.

The tabbed view closes and the Export/Import XML Template view
(originally positioned on the bottom left) displaysin the full horizontal
space.

Now close the Export/Import XML Template view using the same
process you used with the tabbed view.
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Lesson 1 InfoMaker Basics Tutorial

Getting Started

Your screen should ook something like this now. Because InfoM aker
offers so much flexibility in arranging your work area, your screens may
not match many of the picturesin the remaining lessons. It does not matter
as long as you are getting the correct results.

i tutor_im.pbl - InfoMaker =10l x|
Fle Edit Wiew Insert Format Design Rows Tools indow  Help
MellEs gl
Balov|a-lemnslaz|d x|
Bl expenses * - Report ;IEIEI
= 1| General | painter | privtl:
Expenses for year i
II,I'IDUU Inch {2} il
Amount Timer Interwval:
in thousands |D =

Head
eader | Color

1: Header group year [ |:|W dow Backa
qroup indow Backarar ¥

di ripﬁon I™ Hide Gray Line on page
2: Header group description 1
quart amaun I~ wWeb Datawindow

Detail

sumiar

F
LIL.ILIL

Expenses for 1995

Amount
| in IhnusandT _ILI
4 »
||Ready [Page1of3 | |Mathing Selecte | |
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Use toolbars

Use toolbars

Where you are

Start InfoMaker

Access objects and painters
> Use toolbars

Use views

Use pop-up menus

Use the mouse with controls

InfoMaker comes with several toolbars. the PowerBar, three PainterBars, and
the StyleBar. You can control whether individual toolbars display and where
they display. You can also choose whether to display text in the toolbars.

In this exercise you learn how to use toolbars.

(You can also create your own tool bars and customi zetool bars, but thistutorial
does not cover these advanced activities.)

1 Move the pointer to the toolbar area.
Click the right mouse button.

The pop-up menu for the toolbars displays.

(i tutor_im.pbl - InfoMaker o =]
File Edit Wiew Insert Format Design Rows Tools Window Help

NoERs|fsgs|i)

v PowerBarl

|_|::J Li]| £ | AT|o 5B & |laz }:5‘ E x | » PainterBarl
- PainterBar2
o
B evp 2 PainterBar3 _I
StyleBar General |Pmnter| Pritt
Expenses for 1 L
7 T°°h 111000 Inch (2} -1
Amount ot Timer Interval:
in thousands iy ) =
Header | Floating je=al
Colar

1: Header group year{

Custamize... [window Backaro 'l

description New... [~ Hide Gray Line on page
2: Header group description t 53 AT I P
quarl amour Show Text [~ web Datawindow
Detail] ¥ Show PowerTips
] _ sumiar =

4 I I »
B
|

Expenses for 1995

Amount

Jq in thuusandﬁ Llj
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Lesson 1 InfoMaker Basics Tutorial

About the pop-up menu
Throughout InfoM aker, pop-up menus provide afast way to do things. The

right mouse button accesses the pop-up menu. The menu changes
depending on the painter you arein and where you are when you click the
right mouse button.

2  Select Floating from the pop-up menu.

The PainterBar changes to a floating toolbar.

3 Move the pointer to the title bar and drag the floating toolbar to
another location.

How to drag the toolbar
Press and hold the left mouse button. While holding the button, move the

mouse (an outline displays to show the current location of the toolbar).
When the toolbar is where you want it, release the mouse button.

&l tutor_im.pbl - InfoMaker =4
Fle Edit View Insert Format Design Rows Tools Window Help

@@ w|a-l¢ o8 Z]A%|E x|

H expenses * - Report 3 =100 x|

General |Pointer| Privt .

Expenses for year i

|1x1000 Inch (2) -

Amount Timer Interval:
in thousands IEI =
x|

Header [
1: Header group year {

Colar

- fit | II:lW\ndnw Backaror ¥
description Y = ] | @ e || I I™ Hide Gray Line on page

2: Header group description {

guatt amoun ER=N R, ‘ s I I web Datawindow
Detail EE)
surmiar
Z: Trailer group description T =
AT
Bl o
B
=

Expenses for 1995

Amount
in thousands =
1| | 3
[Ready |[Page1ofs | |Mothing Selecte | i

You can put toolbarsin different locations: left, top, right, bottom, and
floating.
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4  Select Tools>Toolbars from the menu bar.

About the notation Tools>Toolbars
Throughout the tutorials, commandsissued from the menu are shown as a

sequence of choices separated by arrows. For example, to select
Tools>Toolbars means to select Tools from the menu bar and then
Toolbars from the menu items.

The Toolbarsdialog box displays. Notice that the PowerBar ishighlighted.
If the PowerBar is currently displayed, the middle button says Hide.

Toolbars

Select Toolbar:

Cloze

Move
Py  Left
PainterB arl P £ok
PainterBar? & Top —I
PainterBar3 = Righl
Right
StyleBar i
it € Battom &I
~ .
LI Floating ml

™ Show Tegt V' Show PowerTips

Mew..

Font M ame: Font Size:

I Small Fonts j IB j

5 Click PainterBarl and then click the Bottom button.
The PainterBar displays at the bottom of the InfoMaker screen.
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InfoMaker Basics Tutorial

Getting Started

6

Click Show Text to make text display on the buttons.
Click the Close button to close the dialog box.

ll tutor_im.pbl - InfoMaker 10l x|
Fle Edit Wiew Insert Format Design Rows Tools indow  Help

el Sl e e R

New Open  Preview  Sellib  Liblit ToDolist Library  DEPFrof Datsbase  Exit
Bl expenses * - Report = |EI|£|

»

Expenses for year

Amount
in thousands
Header
1: Header group year [
description

Z: Header group description |

guart  amourn

Detail

i dar

o |

L|L-|;|L

Expenses for 1995

Units

Il,l'lDUU Inch {2} b

Tirner Interval:
a

Color

I:W\ndow Backgron ¥

I™ Hide Gray Line on page

I~ wWeb Datawindow

i

“[s]acf':>A-m: = me e P
||Ready |Page 1of 3 [ [ [ 7|
Move the pointer over one of the toolbar buttons.
After a couple of seconds, the PowerTip that tells what the button does
displays.
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8 Click the small black triangle next to the Text button in the PainterBar.

The Objects drop-down toolbar displays. It holds buttons for the controls
you can add to reports. (A text control is one type of control you can add
to areport.) Several buttons on other PainterBars have small black
triangles. These buttons belong to other drop-down toolbars (such asthe
Border drop-down toolbar).

{e tutor_im.pbl - InfoMaker o =]
File Edit Wiew Insert Format Design Rows Tools ‘Window Help
e B/ R o om B o= 8 8k
Newr Open  Preview  Sellib  Liblist To-Dolist Library DBProf Dotabase  Exit
Bl expenses * - Report 4 -0 1[
=1 General |Pmnter| Prira
Expenses for year ]
Units
11000 Inch (2) v[
Amount Timer Interval:
in thousands 0 =
=i
Header
Calor
1: Header group yeart
[Jwindow Backaroi Vl
description : ;
e Hide Gray Line on page
: Header group descriptiont B A @ [ - il
quar amc Talest  Butben Text Picturs  GroupBiox [~ wieh Datawindaw
Detail | ey (i1 =l o =
- Line Owal Rectangle  RndRect  Column _lll
EAE] w « H !
Compute  Giaph  Feport  OLE  DEOLE j
¥ = =)
x % (s 5
Average  Count  Page Sm  Todw |
- or 1995
nkPicture
B & ¢ v .4 B @ R e
Save Print Unde  Reds  Tem Cut Copy  Pasts  Delste  Sort Filter Dits  Cloce
|Create a text abject |Page1of3 | [ [ A

9 Clickinthe white space to the right of the toolbar to make the Objects
drop-down toolbar close.

Now you know several ways to move the toolbars and you know how to turn
text display on and off.

For the rest of these tutorial's, you should move the toolbars where you like to
have them. Your screen may not match the pictures in thisbook, depending on
where and how you display toolbars.
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Lesson 1

InfoMaker Basics Tutorial

Use views

Getting Started

Where you are
Start InfoMaker
Access objects and painters
Use toolbars
> Use views
Use pop-up menus
Use the mouse with controls

InfoMaker provides anumber of viewsin each painter to makeit easier for you
to work. The View menu in each painter lists the views avail able to you. You
can use the View menu items to display and close the various views. In this

exercise you learn how to manage views.

1 Move the pointer to the upper-left corner of one of the views.
When the bar drops and the pushpin displays, click the pushpin.

Repeat this for the other two views.

Now the three views have title bars that identify the Design view, the
Preview view, and the Properties view.

il tutor_im.pbl - InfoMaker
Flle Edit Wiew Insert Format Design Rows Tools indow Help

=10l x|

M = 6 B = B =m B .8

Haw Open  Proview  Sollib  Liblict To-Dolict Library  DEProf  Databacs

ik

Exit

H expenses

Amount
in thousands

Expenses for year

General |Po|nter| Pri

Units

|1x1000 Inch (2) v

Timer Interval:
0 ]
I =i

Header [

Colar

1: Header group year

description

||:|W\nduw Eackaroi ™

[ Hide Gray Line on page

2: Header group description |

fquart  amaour

I~ wWeh Datawindow

Detail

| Evrmmnmeanm frr AOOE

e e S % 3 B x
Fars Prist  Undo  Rede  Taxt Cut Copy  Pacte  Delts  Sot  Fiker  Data  Cloze
[Ready [Page1ofs | [ [ A
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Move the pointer to the Preview view’s title bar and press the right
mouse button.
Select Float from the pop-up menu.

Now the view isfloating. You can drag it wherever you want it and resize
it as needed.

Display the pop-up menu on the Preview view'’s title bar and select
Dock.

. tutor_im.pbl - InfoMaker I i i [ B
File Edit View Insert Format Design Rows Tools  Window  Help

Mo B OB =2 B =B B 8

Hew Open  Preview  Sollib  Liblit ToDolist Library DB Prof Datbase  Exit
H expenses * - Report - =10 1‘
= ol
= - b e |Pmnter| HT A | »]
Preview - expenses 5 E|
Restare ;I
MMaximize —nt &

Float

Header |

desnaked
1: Header g1 I r
ible ™
dex::pm Amount -
ricAEl AT s in thousands HoBorder (0) > |
Detail{ Administration kL

'| it 1 T LDLE& o &

=

21 Trailer group description |

1: Trailer group year f Arnount C10in LI
thousands
Summary {
Footer | Ll 2|
F
=) = ; T g - : =
B @ < > A L of = 2 B % H =
Fave Print Undo Rede Text Cut. Copy Paste Dielete Sort Filker Data Cloze
|Ready [Page 1of3 | |Text: amaunt_t [1.583,0.666 0. 2

The view goes back to where it was. There are more options for moving
views around, including dragging them and overlaying one view on top of
another to make tabbed views. You can read about these in the InfoM aker
User’s Guide.
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Use pop-up menus

Getting Started

Where you are
Start InfoMaker
Access objects and painters
Use toolbars
Use views
> Use pop-up menus
Use the mouse with controls

Now you take alook at pop-up menus and the Properties view.

1 Move the pointer to the words Expenses for.

Click the right mouse button.

The pop-up menu for a piece of text (also called atext control) displays.
Whenever you position the pointer on something that has a pop-up menu
and click the right mouse button, the appropriate menu items display.

(el tutor_im.pbl - InfoMaker

Fle Edit Wiew Insert Format Design Rows Tools indow Help

=10l x|

& 6 B = B = g @3 W
Hlaw Opan Provisw  Sellib  LibList Te-Dalist Library  DEPref Databaze  Esit
. E £ . General |Po|nter I HT.
Xpense~ for 1o
. p Cuk MName
Copy Iyear_t
Amount Delete Tag
in thousands Duplicate I—
Header {
2 — Hidesnaked
1: Header group year { a2 - ‘ .e na
Send to Back v Visible =
description R ———— Eorder
5 inti Propetties. . ]
2: Header group description | WoBarder (1) = EI
gquart  amaun -
PR 'l Aligrirnent
b L2 | = Right (1) v[
=11 Text
- Exzpenses fior -
-
‘ Expenses for 1995 e
H B & S A ek . d B % @ x
Save Print Unde  Redo  Text Cut Copy  Pats  Delsts  Sor Filtor Dats  Cloce
|Ready |[Page1ofs | [Text:vear & [z.416,0.1451. 4
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If the Properties view is not currently displayed, select Properties from
the pop-up menu.
Look at the contents of the Properties view.

The Properties view displays the properties of the Expenses for text
control becausethetext control iscurrently selected. For atext control, the
Properties view has five tabs, which identify five pages of information.
The General pageis on top.

[®] Froperties - year_t
General | Pointerl HTMLl Positionl Fontl

Mame

| year_t
Tag

I HideSnaked

v Wisible 2

Border

| MoBorder (0] =l e

Alignment

[= Right (1) =]

Text

Expenszes for ;I
ol

About the Properties view
The Propertiesview displaysacollection of information about a control or

the report object itself. You use the Properties view to find out and set
properties.

For example, atext control has properties such asfont, font size, location,
border, and so on. You can see the current settings for these properties on
the control’s property sheet. You can also change them there.
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Getting Started

Position the pointer on the word description and click.

The Properties view now displays information for the data column
(Column control) called description. The property pages and options are
different from those for the text control.

—
[ Design - expenzes topeties - description

= 1| General |F'Uinle|| HTMLI F’Usiliunl Edill FUrmall Funll

-

Nare

|dascriptinn
Amount Tag
in thousands |

Header T ™ HideSnaked

1- Header group yesr 1

. 7._9.. ¥ isible 2|
description w

(& Alignment
2 Meader group descrigfiomt™
4

|| |= et |
_’lj Border

- N -

= I oBorder (] J 0|
™ Display A3 Picture

Protect

™ Owenide Edit
I Equality Required

P | S -l

Click the word Font on the Font tab.

The Font page comes to the front of the Properties view.

=
[®] Design - expenzes iption =1 E3
E = Ganera\l F'Uinlell HTMLI F'Usiliunl Edill Format Font |
Xpens a
p FaceMame
Amount Siee
in thousands =
Header j !I
1 Header group year 1 v Bold e
description :Z ILtla‘:jc g L
. nderling =
2: Header group description 1 vI l_ Stikeout j
4 *
IA" _l_ Text Colar
;, I-Windnw Text j 2
B ackground Calor
I:Transuarent j =
EXF Charet
Iansi! j
4] | Ll_‘ Fitch LI
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Select the font size 14 from the drop-down list in the Size box.

The font size of the text control changesto 14 in the Properties view, the
Design view, and the Preview view.

ntion

Ganerall Pnintell HMLI Pnsilinnl Edill Format  Font |

Amount
in thousands FaceMame =
Header T _I I:'TAria\ j
1: Header group year [ N
description =l -
5 Hesa description [ g £
. Header group description
- ¥ Italic =
Tictail T quant_amoun ™ Underline =
[ Strikeaut Il
 Jrai]er aronin deseridinn T sumier || Test Color
4_' Ld I-Window Text j =
Amount j Eackground Calar
in thousands = I:Tmnsmmm j l
L Administration Lharsel
Iansi! j
351 Fitch
402 Ivanable‘ j
LI I 412 Llll Famnily ;I
Select the font size 10 from the drop-down list in the Size box.
The font size of the text control changes back to 10.
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Use the mouse with controls

Where you are
Start InfoMaker
Access objects and painters
Use toolbars
Use views
Use pop-up menus
> Use the mouse with controls

Now you move some of the controlsin the report. Be sure not to save the
changed report, because you will use the original report later. When you leave
the Report painter, you are prompted to save changes. The instructions remind
you to say no.

1 Select Design>Options from the menu bar.
The Report Options property sheet displays.

General | Generationl Prefixesl

Alignment Grid

: E e IS
I~ Show Grid ¥ Is
I~ Show Buler

I~ Show Edges

¥ Retieve on Preview

QK I Cancel | Lpply | Help |

In this property sheet, you turn on some design options that make it easier
to work with controlsin reports.
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Use the mouse with controls

2 Select the Show Grid check box.
Select the Show Ruler check box.
Select the Show Edges check box.

Report Options B
General | Generationl Prefixesl
Alighment Grid

I~ Snhap to Grid

1<

=7

Show Grid

¥ Show Buler

()8 I Cancel

Apply Help

3 Click OK.

Now edges display around the controls, and agrid and ruler display in the
Report painter Design view.

Design - expenses ]
_|I|||I|1||I|||I|2||I|||I|3||I|||I|4||I|||I|5||I|||I|
E -
4

Header t

1: Header group year t

|d'esc"ﬁp'ﬁbhﬁﬁﬁﬁﬁﬁZZ::::::ZZZ::::::ZZZ::::: N

2: Header group description t

—:::::::::::::hﬂl:hmwni

e
qooccc UMY
2: Trailer group description t
1: Trailer group year t
Summary 1
Footer t

-

K|
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Lesson 1 InfoMaker Basics Tutorial

Getting Started

Click the text control with the text Expenses for.

Black boxes in the corners mean the control is selected.

Press and hold the Ctrl key.
Click the year box and the Amount in thousands box.
Release the Ctrl key.

Now you have selected all three controls.

Press and hold the Left Arrow key until the controls are on the far left
of your screen.
Release the key.

Move the pointer to the word Expenses.
Make sure the controls are still selected.
Press and hold the left mouse button.
Drag all the controls to the right.
Release the mouse button.

While you are dragging, gray boxes show the current position of the
controls.

:.[Expenses:fod?.h;ear[: conrncpints

Amount | e
finthousands - ;000 oioooiin R
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Use the mouse with controls

When you rel ease the mouse button, you drop the controls where the
pointer is currently positioned. Noticethat the controls are still selected as
indicated by the little black boxes.

Expenses for year ]

8 Click in an unused area to deselect the controls.

The controls are no longer selected (the black boxes are gone).

10 Press and hold the left mouse button.
Drag the mouse diagonally down and to the right until the box
surrounds or touches all three controls.
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11 Release the mouse button.

All the controls are selected. Thisis called lasso selection. You can use
this lasso technique to select many controls quickly. Then you can move
them all together or change something about them all at once.

g

D St :::::.|Expgnse's:

for, year

12 Press the Delete key.

The three selected controls are deleted, but you really did not mean to
delete them.

13 Select Edit>Undo Control Delete from the menu bar.

The deletion is reversed.

T Beemet Tjearl

About Undo ]
You can undo as many operations as necessary.
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Use the mouse with controls

14 Select File>Close from the menu bar.

InfoMaker displays a message box to see whether you want to save the
changes you have made to the expenses report. You do not want to save
changes. You use this report later in the Graph tutorial.

Save changes to
c:iprogram files\sybasetinfomaker 10,5 tutorialitutor_im. pbl{expenses)?

Yes Mo Cancel

15 Click No.

The Report painter closes. Now you are ready to learn how to create a form.
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LESSON 2

Getting Started

Form Tutorial

This tutorial requires the Form painter
The Form painter component of InfoMaker is optional; you must have

installed it to do this tutorial.

Forms display data and provide away to interact with the database. You
can use forms to view information and change it.

Inthistutorial you create a form that updates the contact table. The form
includes:

e All columnsin the contact table
¢ Buttonsfor maintaining contact information

e A report that provides access to al information in the contact table

Q@ Maintain Contact Information [_[o] =]
d: Add a cnmactl Delete a cnmactl Save changesl
Last Name: [Fidebrard |
First Name: flane | Id | Last Name First Name Job Role [
Job Role: IW 1 Hildehrand Jane Marketing 1280 0
2 Sirmman Larry Sales 24 Grat
Sueet: lﬁﬂ Washinglon St k3 Crich Susan Product development 45 Cert
City: lEmErywHE— 4 Lambert Terry Administation 204 Pai
l_ 5 Sullivan Dorathy Customer support 54 Minu
State: MI 13 FPaull Rose Finance 7% Bay
Zip: [34608 7 Glassmann  Beth Product development 44 Ol
Phone: W b3 Powiell Gene Training 562 e
Kl Fish Jefirey Marketing B4 Red
Fa: [[510) 5554201 10 Clarke Moy Sales 55 Pire
11 Kelley iilliarm Documentation 16 Pirlll
4 | »

How long does this tutorial take?
About 45 minutes.
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Create the basic form

Create the basic form

34

Where you are
> Create the basic form
Preview (run) the form
Save the form
Add buttons to the form
Enhance the form
Use the form to update the database

Now you create the basic form. To do this you select a predefined InfoM aker
form style and the data to be displayed in the form.

1 Click the New button in the PowerBar.

44/'tutor_im.pbl - InfoMaker
File_Tgols ‘Window Help

Yy B B = B = & 68 I
\ Mew Open Preview el Lib Lib List To-DolList  Library DE Prof  Database Exit
‘ —

The New dialog box displays.

2  Select the Object tab if it is not already on top.

The Object tab page contains the icon for creating any type of new form
and icons for the various report presentation styles.

x|
Library Chiject |Database I Tool I
[
B @ = B
Composite Crosstab Freeform Graph
[ |
=E
Grid Label QLEZ2.0
RichText Tabular Treetiew
[8]4 I Cancel
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Getting Started

3

Select the Form icon and click OK.

The New Form dialog box displays. It contains the data sources and form
styles you can choose.

x|
r—Data Source
.
Eﬂj t/j Cancel |
S0L Select Query
Help |
—Form Style
— — — e
B =
ree Form Grid Master/Detail  Master/Detail

One-To-Many  Many-To-One

About data sources
Quick Select issimply for choosing columns and specifying selection
criteriaand sorting, which iswhat you want for this tutorial.

SQL Select isfor using other SQL options not available with Quick
Select.

Query isfor specifying the name of aquery that describesthe data source.
You define queriesin the Query painter.

About form styles

A form styleisapredefined way of presenting and processing information
on the form. Usually the style includes the common database functions
(insert, delete, and update).

InfoMaker comeswith aset of form styles. PowerBuilder usersat your site
can create additional styles, which also display in the New Form dialog
box.
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4

5

Click Quick Select and Free Form to select them (the words are

highlighted).

henrorm

Query

LI

x|
Cancel |

Help |

arm Skyle

ree Form|

— — —,
= =

Grid Master/Detail  Master/Detail

One-To-Many  Many-To-One

Click OK.

Quick Select

1. Click on table(s] to select or deselect

2. Select one or mare columns.

3. [Optional] Enter sorting and
selection criteria below.

Tables:

table or column, click
the: right mouze button.

Lolumns:

To display comments for a ok

Cancel

Al

bonus -
call_track
contact
custamer
department
employes
examn_xref_info
ewamn_xref_list
examples

KN —

Comments:

Help

aaafl,

Calumn:
Sart:
Criteria:
Or:

The Quick Select dialog box displays. In this dialog box you select the
table to use and the columns you want to include in the form.
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Getting Started

6

Click contact in the Tables box.

The columns for the contact table display. You include all columnsin the

form.

Quick Select

1. Click on table(s] to select or deselect

2. Select one or mare columns.
3. [Optional] Enter sorting and
selection criteria below.

Tables:

A4

Comments:
A list of contacts

To display comments for a
table or column, click
the: right mouze button.

Lolumns:

(i
Cancel

Add All

id
last_name
first_name
litle:

street

city

state

zip

Kl —

lefe LD

- Help

Calumn:
Sart:
Criteria:
Or:
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Create the basic form

7 Click the Add All button.

All columns are selected. They display in agrid at the bottom of the dialog

box.

Quick Select

1. Click on table(s] to select or deselect

2. Select one or mare columns.

3. [Optional] Enter sorting and
selection criteria below.

Tables:

A4

Comments:
A list of contacts

To display comments for a
table or column, click
the: right mouze button.

Lolumns:

Ok |
Cancel |

Calumn: Id
Sart:
Criteria:
Or:

4 |

Last Mame

First Mame

ol

You could reorder columns and enter sorting and selection criteriain this

grid. For your form you do not need to do any of these things.

38
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8 Click OK.

Your form displays. It uses the columns and form style you selected. The
text labels come from the extended attribute system tables. Instead of data,
the names of the database columns appear where the data values will be
displayed.

Layout ]

3

Last Name: |[contact_last_name

First Name: |contact_first_name

]
a
=
o
=}
_.

Job Role: contact_title

Street: |c:0ntac:t_street I

City: |c:0ntac:t_c:ity I

State: [contact
Zip:
Phone: [contact_phone

Fax: [contact_fax

[=]
=}
=3
o
0
I
o,
=]

A o

The extended attribute system tables
The extended attribute system tabl es store information about data such as

labelsand display formats. When you create forms and reports, InfoM aker
uses extended attribute information to create the basic form or report.

You put information into the extended attribute system tables using the
Database painter. For example, in the Table tutorial you define the label
Job Role: for thetitle column. Then when you use thetitle columninaform
or report, InfoMaker uses the label Job Role:.
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Preview (run) the form

Preview (run) the form

Where you are
Create the basic form
> Preview (run) the form
Save the form
Add buttons to the form
Enhance the form
Use the form to update the database

Now you preview the form. Running the form isthe way you preview it while
you are designing it and theway you useit when you havefinished designingit.

:k 1 Click the Run button in the PainterBar.
Bun InfoMaker runs your form, which includes going to the database and
retrieving data.

Notice that real values have replaced the column namesin the form.

€ Untitled =] B3
Id: 1
Last Name: Hildebrand

First Name: [Jane

Job Role: [Marketing

Street: |‘I 280w ashington St I

City: |E meryville I

State: i
Zip: [34603

Phone: |510) 555-1303
Fax: [510) 555-4209

i

The PainterBar now has buttons that let you view and change data. Now
you view the data using the form.
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Getting Started

Click the Next button.
Click the Last button.
Click the First button.

= E B I+

Criteria Apply Rixtrizes First

EAT T S |

Dieleke Ingerk Update Cloge

This moves you among the rows. Later in this tutorial you insert a new

row.

Click the Close button in the PainterBar.

You return to the Form painter Layout view.

41



Save the form

Save the form

Eave

42

Where you are

Create the basic form
Preview (run) the form

> Save the form

Add buttons to the form
Enhance the form
Use the form to update the database

Now you save the form and give it a name.

1 Click the Save button in the PainterBar.

The Save Form dialog box displays with the pointer positioned for you to
type a name for the form.

2 Type contact_maintenance.

3 Click in the Comments box and type This form updates my contact table.

Save Form

Forms:

Ok

Icontact_maintenance

customer_details
cugtomer_list

employes_data

LComments:

cugtomer_maintenance Help
departments_and_their_employees —

Library:

C:\Program Files

Thiz form updates my contact table.

[ ]
o |
Cancel |
[
=
[

base\Infolaker 10.5ikutarialitutor im.

4 Click OK.

InfoMaker saves your form. Anytime you have completed a unit of work,
you should save. To save, select File>Save from the menu bar or click the

Save button.
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Add buttons to the form

Where you are
Create the basic form
Preview (run) the form
Save the form
> Add buttons to the form
Enhance the form
Use the form to update the database

Now you add three buttons to the form. Later when you run the form, you can
click the buttons to add and delete contacts.

First Name: Add a contact|
Stieet: [contact_shraet I Wellis & EoEe
Save change:
State:
|Enl s

About controls

Theitemsyou seeon aform are called controls. For example, abuttonisatype
of control. The controls you can use on aform are listed in the Insert menu on
the menu bar.

1 Select Insert>CommandButton from the menu bar.

2 Move the pointer to an empty area of the form and click.
If you need to move the button, drag it.

How to drag
Position the pointer over an object, and press and hold the left mouse

button. While pressing the button, move the mouse until the object is
where you want it. Then release the mouse button.
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Add buttons to the form

A button with the text none displays. The text none also displaysin atext

box in the StyleBar.

=
1d: [contact_| ﬂ

Last Name: [cortact_last_name

First Name: [contac_fist_nams none

Job Role: [contact_title

[

Street: [contact_street |

City: [contact_city
State: [cortact
Zip: [contact_zip

Phone: [contact_phors

Fax: [Contact_fan

If the text box does not display

This means the button is not selected. To select the button, click it. Small

black boxesin the corners mean it is selected.

3 Make sure the button is still selected.
Type Add a contact.

The text displays on the button as you type and in the text box in the
StyleBar.

4  Click B (for bold) on the StyleBar.

[ [x]
B
First Name: Add a contact|

Street: [contact_street |

City: [contact_city
State: [cortact

Zip: [contact_zip
Phone: [contact_phons

Fax: [Contact_fan

A oL

The text displaysin bold. Next you make the button work. To do this you

associate an InfoM aker action with the button.
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Getting Started

Using the StyleBar

You can use the StyleBar to change text fonts, font size, and font style

(bold, italic, and underline). You can also use it to specify text alignment

(left-aligned, centered, and right-aligned).

To use optionson the StyleBar, you select acontrol with text and then click

the appropriate button on the StyleBar.

Move the pointer to the Add a contact button.

Press the right mouse button to display the pop-up menu for the
button.

Select Action from the pop-up menu.

Layout [=]
1a: =
Last Hame: [contact_last_name
First Name: [contact_iirst_name Add a contard]
Job Role: [contsct_title
Cut
Street: [contact_shest ]|
Lopy
City: [contact_city Delete
State: Duplicate:
Zip: Bring ta Eront
Send to Back
Phane: |[contact_phone
Properties
Fa: e

L v

The Select Action dialog box displays. It lists the actions you can assign

to the button.

Select Action [ %]
Select an action from the list below and
provide parameters as required.

Actions:
....................................................................... Cancel |
Clear_Filer Barameters... |
Cloze —

Delete_Row

Filter_Dialog hd| Heln |
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Add buttons to the form

46

About InfoMaker actions o
An action iswhat you want to have happen when the button is clicked.

Whenever you associate an InfoMaker action with a button, InfoMaker
creates the code to enabl e the button to perform the action. You do not see
the code. All you haveto do is select the action for the button.

InfoM aker comeswith predefined actions. PowerBuilder usersat your site
can create additional actions, which also display in the Select Action
dialog box.

Scroll through the list of actions and double-click Insert_Row.

Select Action [ %]
Select an action from the list below and
provide parameters as required.

Actions:

- - Cancel
Filter_Dialog ;I —I
First_F!ow
Impart File Pararmeters... |
LI Help |

InfoMaker creates the code that enables your Add a contact button to
display ablank form so that you can add information for a new contact.
You will see the button work later.

Now you add two more buttons.

Select Insert>CommandButton from the menu bar.

Move the pointer below the Add a contact button and click.

Type Delete a contact.

Display the Delete a contact button’s pop-up menu and select Action.
Select the action Delete_Row from the Select Action dialog box.
Click OK.

Select Action [ %]
Select an action from the list below and
provide parameters as required.

Actions:
Cancel |
-
h o Earameters...
First_Fow _—I
Import_File
Insert_Row LI Help |

Filter_Dialog

InfoMaker
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Getting Started

Select Insert>CommandButton from the menu bar.

Move the pointer below the Delete a contact button and click.
Type Save changes.

Display the Save changes button’s pop-up menu and select Action.
Select the action Update_Row from the Select Action dialog box.
Click OK.

Now you have three buttons. InfoMaker has created the code that enables
the buttons to work.

E
First Name: Add a contact
Steet: [conlac_siest | Eelabellcontact
Save change:
State:
LI s
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Enhance the form

Enhance the form

Where you are
Create the basic form
Preview (run) the form
Save the form
Add buttons to the form
> Enhance the form
Use the form to update the database

In this exercise you:

* Addatitle

»  Changethe border for data
*  Movethe buttons

* Add areport

Add atitle

1 Move the pointer to an unused area of the form and click.

This causes the Properties view to display the form’s properties.

2 Type Maintain Contact Information in the Title box.

The title does not display nhow. When you run the form, the title displays.

contact_maintenance - Form M= E3
1d: 41| General | Pairte: |
Last Name: |[contact_last_name Color
First Mame: [contact_first_name II:IW'indow Backaround j
Job Role: [contact_title ( |te. - -
|Ma|nta|n Contact Information
Street: |c:0ntac:t_street
City: |c:0ntac:t_c:ity I I ¥ScrollBar
State: [+ LiveScroll
Zi I HSplitSerall
I RightToLeft
Phone: lcontact ohone I _ILI
4 I I 3
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Change the border for data

Now you change the border for all data values. Thisimprovesthe form's
appearance. You use lasso select to select the data.

1 Move the pointer near the bottom of the data and on the right.

2 Press and hold the left mouse button and drag diagonally to the left
and up until the box (the lasso) touches all the data.

First Mame: @MI

Street: |c:0nta t_strest I

City: |c:0nta t_city I

State: @g
Phone: @EI

3 Release the mouse button.

All the objectsinside the box are selected. Black boxes display in al the
corners.

Layout ]

Id: contact_ii ﬂ

Last Name: |contact_last_name

First Mame: [contact_first_name Add a CDI’ItaC‘ll

Job Role: |contact_title

Street: [contact_street i Delete a Cﬂmac‘ll

City: [contact_city I Save change
State: @ |
Zip:lmi

Phone: |[contact_phone

Fax: [contact_fax

4  Select Lowered or whatever value you want from the Border
drop-down list on the General page in the Properties view.
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Enhance the form

All the areas on the form used to display data values now have your
selected border.

contact_maintenance - Form M= 3

[ —
Id: |contact_i General | Pointerl Positionl Editl Futl?
.

Last Name: [contact_last_name v Wisible |
First Name: [contact_first_name Alighment
! | [
Job Role: |contact_title
- - Border
Street: [contact_strest _ L — Lowered [5] j !I
City: |contact_city NoBorder (0]
Slale:-contact_ O3 ShadawBax (1)
Zin o O Box[2)
|p._ contact2p B ResizeBorder (3)
Phone: [contact_phone — Underline (4]
[ ——
Fax: |contact_fax
L] —I Raised [6)

Move the buttons
Now you move the buttons to make room for the report you are about to add.

1 Select a button.

You can use lasso select or click one. Small black boxes in the corners
mean it is selected.

2 Drag the button to the top of the form.
Select and drag the other two buttons until your form looks like this.

[

=

[x]
! :lm Add a cnmactl Delete a cnmactl Save changesl ﬂ
Last Name: [eontact last_name |
First Name: [eortact_fist_neme |
Job Role: [comtat_tile |
Street: [contact_stieet
City: [eortact ety |
State: [contact]
: [eortact_zp |
Phone: [cortact_phone |
Fax: [contact_fax |

e o

Now the buttons are near the top of the form. There is more room for the
report you are about to add.

o
i
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Add areport

Getting Started

Now you add a report to provide information when you are working with the
form. You can scroll in the report while you are filling out the form for a new
contact. Thismeans, for example, that you can look up an areacode or zip code

if it isalready present for another contact.

Select Insert>Report from the menu bar.
Move the pointer into the workspace.

Your next click positions the report that you are adding to the form.

Move the pointer to the empty space on the right part of the form and
click.

Four dots marking the corners of the box that will hold the report display
on the form.

contact_maintenance - Form [_ O] <]
1d: feonlact i Add a contact|  Delete a contact| 57| 5 | ater]
Last Name: [contact_ast_name DataDbjsct
First Name: [eontact_fist_name =
Tite
Job Role: [contact_tile
nane
Stieet: [contact_strest ¥ Visible
City: [contact_cty [ TiteBar
State: [cortact F HScrolBar
YScrolBar
Zip: [contaci_zp 7 LiveSorol
Phane: [coniact_phene I HSpitserol
Fan: [rontact_far I™ RightToLeft
[ Boder
BorderStyle
O SyleBosl -
KIS _’l_I

Now you use the Properties view to specify afew things about the report.
First you are going to select the report whose contents display in the box.

Click the Browse button (the button with three dots on it) next to the
DataObject field on the General page in the Properties view.
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Enhance the form

52

The Open dialog box displays. It lists the reports (Datawindows) in

tutor_im.pbl, the current library.

Ok

Cancel

| atiib_birthdays | AI
attrib_croszout_and_visible Browse...

altrib_escapement_rotation
attrib_font_height Help
attrib_format

attrib_graybar_emp_total_comp LI

LComments:

il

Sample: Demonstrates the color and underline attributes by ;I
highlighting birthdays of employess that fall in the curent
month. LI

Library:

1,5 bukarialitutor _im.|

1 |

Scroll the list of reports, select contactgrid, and click OK.

The contactgrid report displays in the form, and its name displaysin the
DataObject field in the Properties view.

1d: [pontact
Last Name: [portact_last_name |
First Name: [portact_frst_name |
Job Role: [contact e |
Steet: [contact_street
City: feortactciy |
State: [contact]
Zip: [eortact_zp |
Phone: [cortact_phore |
Fax: [cortact fax |

Add a cuntaﬂl Delete a cuntaﬂl Save changesl

ETju] 3

none

¥ WVisibls

I~ TileBar

[~ HScrolBar
™ VselBar
¥ LiveSeral
™ HSpitSerol
I~ RightToLeft
I~ Border
Borderdiyle

O3 StyleBox! hd

Fleady I [Name: dn_2

2143500 411x432 /’;l

Next you specify that the report isto have the StyleBox border and scroll

bars.
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5 Make sure the BorderStyle selection is StyleBox.
Select the HScroll Bar, VScroll Bar and Border check boxes.

: fortaet | General
1d: frontact § Add a cuntaﬂl Delete a cuntaﬂl Save changesl Snera! |DME’|
Last Name: [rontact last_name Datallbject
First Name: [contact_frst_name contactgrid [
Title
Job Role: [contact_title
nane
Steet: [contact_street I Visible
City: [cantact_oiy | L 1B I Tilga
State: [contact, v CE‘C'DI‘I‘E“
) v _WacolBar
Zip: [ontact_=p ]
Phone: [contact_phone = I HSpitSerol
Fax: [ontact fax 4 _>|_I I~ RightToLeh
¥ Barger
BorderSiyle
O3 StyleBon =]
K| _»l_I
Fleady [Name: dn_2 2148500 41ThiZ2 |

When you run the form, the report displays as a window with horizontal
and vertical scroll bars. This givesyou flexibility in looking at datawhile
working on the form.

6 Resize thereport to show more data.

To resize, move the pointer near an edge until the pointer becomes a
double-pointed arrow. Then press the |eft mouse button, hold, and drag.

When you finish resizing, the report should look something like this.

Layout [x]
1d: [contact_i =
- Add a cnma:tl Delete a [:unla[:ll Save changesl j
Last Name: [contact_last_name
First Name: [contact_first_name Id Last Name First Name Job Role E

Job Role: [contact e |
Steet: [contact_street
City: feortactciy |
State: [contact]
: [eortact_zp |
Phone: [cortact_phore |
Fax: [cortact fax |

N
iy
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Use the form to update the database

Use the form to update the database

Where you are
Create the basic form
Preview (run) the form
Save the form
Add buttons to the form
Enhance the form
> Use the form to update the database

Now you use the form to add a new contact to the database.

* 1 Click the Run button.
Run Your finished form displays with data in place. The report on the form
givesyou away to see al your contact data.

€ Maintain Contact Information M= E
fet Add a [:unla[:ll Delete a [:unla[:ll Save [:hangesl
Last Name: [Hidebrand |
First Name: pane Id | Last Mame First Name Job Role £
Job Role: W 1 Hildebrand — Jane arkeding 1280 i
2 Simmaon Larry Sales 34 Grar.
Street: I1 280w ashington St 3 Critch Susan Product dewelopment 45 Carr
City: lEmewvi"e— 4 Lambert Terry Administraion 204 Pay
l— 5 Sulliwan Dorothy Customer suppart 54 Mint
State: Ml 3 Paull Rose Finance T4 Bay
Zip: |34608 7 Glassmann  Beth Product dewelopmert 44 Oak
Phone: 51015551303 & Powell Gene Training 552 i
El Fish Jeffrey Marketing 64 Red
Fau: (510 5554209 10 |Clarke Molly Sales 56 Pine
11 Kelley llism Documertation 16 Rair =
<] | »
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2 Click the Add a contact button in the form.

An empty form displays. You use this form to enter a new contact.

€ Maintain Contact Information M= B3
b Add a [:nnla[:ll Delete a [:unla[:ll Save changesl
Last Name:
First Name: Id | Last Mame  First Name Jab Role H
Job Role: l— ul Hildehrand Jane Mbarketng 1280
2 Simmon Larry Sales 34 Gran
Stieet: [ 3 Critth Susan Product development 45 Cerr
City: l— 4 Lambert Terry Administration 204 Pal
l_ 5 Sullivan Dorothy Customer support 54 Minw
State: [Ha i Paull Rose Finance 74 Bay
Zip: 7 Glassmann  Beth Product development 44 Oak
Phone: I[]— i Pouvell Gene Training 552 e
9 Fish Jedirey Mbarketng 62 Red
Fax| ) - 10 Clarke Mol Sales 55 Pine
11 Kelley illiarm Docurmentation 16 Rjr'j
4 | »

Thecursor isinthe ld box, but you do not know the next available number.
You look in the report to see what number was used last.

3 Inthereport window, use the scroll bar to scroll down to the last row
of the report and check the value in the Id column.

If the data has not been changed since installation, the value is 60, so the
next available number is 61.

Id | Last Name First Name Job Role -
50 Shishow Irina harketing 567 Pal
51 Trayers Ken Sales 234 He
52 Long Peter Training TE Grav
53 Tippet Debbie Customer suppart 5 Ahel
54 Hodzon Jack Customer suppart 64 Ling
56 Kosko Kim Product development 334 Ple
56 McEwoy Jim Sales 23 Ham
57 Goodal Sandra Sales 56 Sum
5% Elking John Training #9% Go
549 Masalsky Kurt Customer suppart 249 Garg
60 Colling MaryBeth | Administation 56 Linct |
« | [

4  Click the Id column and type 61.

o Maintain Cnnt=ct Information

Id:l &
Add a contact
Last Mame: |

First Mame: I Id Las
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Use the form to update the database

56

10

Press Tab and type Carter for Last Name.
Press Tab and type Jimmy for First Name.
Press Tab.

At this point you are on the Job Role box. In thisbox you cannot type. You
must select ajob role from alist of possible ones.

In the Database painter, the column was defined to be associated with a
DropDownListBox edit style. The extended attribute system tables store
this and other information about data.

Click the down arrow on the drop-down list to display the choices.

U G
Last Name:ICarter
First Name:pimmy
Job Role: [N -~ |

Select Marketing.

Id: | E1
Last Mame: IEarter
First Hame: pimmy

Job Role: |Marketing
Adminiztration
Customer support
City: D ocumentation
Finance

State: |Human resources
ZiP: | Otpier
Phone: Product development -

Fax: I[ ] -

Street:

-
-

Press Tab and type Peanut Way for Street.
Press Tab and type Atlanta for City.

Press Tab and type G to select GA for State (another drop-down list).
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Getting Started

11

12

13

Press Tab.

To determine what to enter for Zip, scroll the report until you find

another Atlanta entry.

Then click the Zip box in the form and type the zip code you see in the

report.

€ Maintain Contact Information

1d: 61
Add a cnmactl Delete a cnmactl Save changesl
Last Name: [Cater |

First Name:l iy Street City State  Zip Phone =

Job Role: Flatkatng | 4 Siory Rl Emeryvile  (GA 94808 |(510)585-T

i i (10155535
Stieet: [Feanut way one Park Drive  Afiania GA 30229 404)555-48:J

City: [Etlanta 20% Brook Road  Burlingion MA 01202 (B17)555-534

State: [G4
T
o

19 Keaton Lane Arlinoton A, 02174 (6171555-381

% Corrfield Ave.  Acton MA 01720 |(50%)655-77:
6ilaverly Rd.  Buringlon  MA 01803 (617155633
B7 Frince & Houston T 7RO7S [(T136E6-3%
4 Gresnwile St Allanta GA 30339 [404)555-22

% East Main 8. Houston TX  TTOTS(F13)565-3%

0F Park Steet Burlington hiA, 01803 (1 7)555-8_8;;'
[ | »

[_[O]x]

Press Tab and type 4045557833 for Phone.

Notice that you type only the digits. The form formats the phone number.
An Edit Mask edit style was defined for this column to handle the
formatting. This edit styleis stored in the extended attribute system tables.

Press Tab and type 4045554291 for Fax.

Thisiswhat your screen should look like now.

€ Maintain Contact Information

d: o Add a cnmactl Delete a cnmactl Save changesl
Last Name: [Cater |
First Name: [y | Street City State  Zip Phone ~
Job Role: flafetrg | 4 Story Re Emeryvils |CA 84608 (51056673
6 Brianwood Ter, Emeryville  CA 246028 (B101665-36.
Steet: [Peanut Way One Park Drive  Aftanta GA 30339 f404)555-48:J
ciy: flas PO% Brook Road  Buringlon WA 01803 (617166663
49 Keslon Lane  Aringlon WA 02174 (6171555381
State: [ 3 Corield Ave.  Acton MA 01720 |(508)665-77:
Zip: 339 Gilaverly R, Buringon  MA 01803 (617)555-33
Phone: IS0 b7 Frince &t Houson X 7RO79 | (T13)666-55
4 Grognile St Alanta GA 30339 (40456622
Fa: [[404] 55542491 5 EastMain 8 Houston  TX 77079 (F13)SE6-33

‘ |

0% Park Street Burlington A, 01803 (61 ?)555-8_8;;'
3

[_[O]x]
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Use the form to update the database

58

14

15

16

17

18

19

Click the Save changes button in the form to update the database with
the new contact.

The database is updated.

Note that the report always displays the information from the database
when you start running the form. If you update the database, the report
does not show the updates. To update the report, you return to the
workspace and rerun the form.

Click the Close button in the PainterBar to return to the Form painter
workspace.

Click the Run button again and scroll the report to the 61st row in the
report.

Notice that your report has been updated.

Click the Close button in the PainterBar to return to the Form painter
workspace.

Select File>Close from the menu bar.

If you have not already saved the current version of the form, you are
prompted to save changes.

Click Yes.

The Form painter closes.
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Getting Started

Report Tutorial

Reports display and summarize data. You can view reports on the screen,

save reportsto afile, and print them on the printer.

In thistutorial you create areport using the datain the contact table. The
report you create groups contacts by job role and lists phone and fax
numbers for each contact.

Thisiswhat the report looks like when you have finished.

Preview - contacts_by_jobrole =]

N N N e LS

2111499

Admirixtation

[T T I U T IO

PP S——

My Contacts

Last Name First Name
Brier Michael
Caollins ManyBeth
Lambert Temy
Fomeo John

Phone

(617)555-2398
(617)555-1193
(617)555-2245
[310) 5554533

(6171 5553337
(6171 5559566
(617) 555-3692
(310) 5551233

How long does this tutorial take?
About 45 minutes.
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Create the basic report

Create the basic report

60

Where you are
> Create the basic report

Preview the report

Save the report

Set up the design environment
Define sorting and grouping
Enhance the report

Save the report as an XML file
Print the report

Now you create the basic report. To do thisyou select areport style and the data
to be used for the report.

Click the New button in the PowerBar.

tutor_im.pbl - InfoMaker - ol x|

F\I;,.IQ\DIS Window  Help

i) B B o= B = 8 8 k

Preview  Sellib  LibList Library DB Prof Database  Exit

The New dialog box displays.

Select the Object tab if it is not already on top.

The Object tab page contains the icon for creating any type of new form
and icons for the various report presentation styles.

InfoMaker
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Getting Started

3

Select the Tabular presentation style and click OK.

x|
==E] = | ]

0 =5 &

Farm Composite Crosstab Freeform Graph
= | |

EE

Grid Group Label M-Up QLEZ2.0
=

RichText Treetiew
[8]4 I Cancel |

The wizard for creating tabular reports (also called DataWindows) starts

up.

About report presentation styles

A report presentation style is a predefined way of presenting information

in areport.

Select the Quick Select data source.
Make sure the Retrieve on Preview check box is selected and click
Next.

i Tabular Report Generator 21xl

‘which data source would you like ko use?

8 8 B

SGL Select Query External

Stored
Procedure

¥l v Retrieve on Preview

< Back | Mext = I Cancel
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Create the basic report

About data sources
Quick Select issimply for choosing columns and specifying selection
criteriaand sorting, which iswhat you want for this tutorial.

SQL Select isfor using other SQL options not available with Quick
Select.

Query isfor specifying the name of aquery that describes the data source.
You define a query in the Query painter.

External isfor specifying data that comes from a source other than a
database.

Sored Procedureisfor specifying data using a stored procedure.

The Quick Select dialog box displays. In this dialog box you select the
table to use and the columns you want to include in the report.

5 Click contact.

Quick Select

1. Click on table(s] to select or deselect To display comments for a ok
2. Select one or mare columns. table or column, click
3. [Optional] Enter sorting and the: right mouze button. Cancel

selection criteria below.

Tables: Lolumns: sl

aaafl,

Ihorus - Help
call_track

L contact

department
employes
examn_xref_info
ewamn_xref_list

examples =
K — _>l_I K — i

Comments:

Calumn:
Sart:
Criteria:
Or:
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Getting Started

The columns for the contact table display. For this report you select five

columns.

Quick Select

1. Click on table(s] to select or deselect

2. Select one or mare columns.

3. [Optional] Enter sorting and
selection criteria below.

Tables:

. i
Comments:
A list of contacts

To display comments for a
table or column, click
the: right mouze button.

Lolumns:

id
last_name
first_name
litle:

street

city

state

zip

Kl —

(i
Cancel
Add All

Help

lefe LD

Calumn:
Sart:
Criteria:
Or:
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Create the basic report

6 Click last_name, first_name, and title.
Use the scroll bar to scroll the list of columns.
Click phone and fax.

InfoM aker moves the selected columns to the grid at the bottom. You can
use this grid for reordering columns and for providing sort and selection
criteria. For this report you do not need selection criteria, and you specify

sorting later.
Quick Select
1. Click on table(s] to select or deselect To display comments for a oK
2. Select one or mare columns. table or column, click
3. [Optional] Enter sorting and the: right mouze button. Cancel

selection criteria below.
Add All
Tables: Lolumns: =

adall,

Help

A4

Comments:
Fax Mumber of the contact

Column: Last Mame First Mame Title -
Sart:

Criteria:

Or: -
< | _>l_I
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Getting Started

7 Click OK.

The Select Color and Border Settings dialog box displays. You are going

to accept the defaults.

i Select Color and Border Settings 21xl

Select color and border options For your report:

Background Color:

Text
Colar: I-Window Text bt
Border: I MoBorder hd
r Columns
Calar: I-Window Text bt
Border: I MoBorder hd

[ Save as default

< Back | Mext = I Cancel

8 Click Next.
A dialog box summarizing all your specifications displays.

i Ready to Create Tabular Report : 21xl

A Tabular Report with the Following characteristics will be created or
generated, Click Finish when vou are ready,

Propert: | Walue

Data Source Select PESELECTE{TABLE{MAME="contact") COLUMNE]
‘Wrap Height {inches) 0

Background Color ‘Window Background
Text Color Window Text
Column Color Window Text

Text Border MNoBorder

Colurmn Border MNoBorder

| 2

¥ Generate To-Do List

< Back | Finish I Cancel |

9 Look over your specifications and then click Finish.
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Create the basic report

Your report displaysin several viewsin the Report painter. It usesthe
columns and report style you selected.

e |
B (Untitled) - Report M=
T I DN T UTU IV NI DU IS IUSU DTN IRONIUT. O N Generallenteu|Pnnt'
Last Name T First Name: Job Hole P
_ [Header 1 | Units
Jact_name Tfrst_name: fitle | PowerBuider (D) |
Defail £ Times Interval
Summar: ¥t o =
Fankar + hd =l
ﬂ_[ » Colar
M Chwecbkn =]
w12 T HTHL Dataindow
3 Last Name First Name Job Role
—  |Hidsbrand Jane Maketing
1 fsimmon Lary Sales
4 Critch Sugan Product development
- Lambert Teny Administration
- Sullivan Dorathy Customer support
3 Rose Finance
i Glassmann Beth | Product development v
4 »

The Design view iswhere you do much of your work perfecting thereport.
Thetext for the column headers comes from the extended attribute system

tables. The names of the columns appear where the data values will be
displayed.

|I|||I|1||I|||I|2||I|||I|3||I|||I|4||I|||I|5||I|||I
..... LastMame - - - - {--- - FirstMame- - - - - |- - - - - JobRole- - - - - |- - - -Phone - - - |- «|
Header t
Jast_name - first_name - -] e - [phone - Jf
[Detail
[Summary t
[Footer t
-
kI ' 4

The extended attribute system tables

The extended attribute system tables store information about data such as
label sand display formats. When you create formsand reports, InfoM aker
uses extended attribute information to create the basic form or report.

You put information into the extended attribute system tables using the
Database painter. For example, in the Table tutorial you define the label
Job Role: for thetitle column. Then when you usethetitle columninaform
or report, InfoMaker uses the label Job Role:.
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Report Tutorial

Preview the report

Getting Started

Where you are
Create the basic report

> Preview the report

Save the report

Set up the design environment
Define sorting and grouping
Enhance the report

Save the report as an XML file
Print the report

Inthisexerciseyoulook at the Preview view of your report to seewhat it |ooks
like when you print it.

Position the pointer in the upper-right corner of the Preview view (this
drops the title bar) and click the maximize button.

& (Untitled) - Report

[i#] Freien - [untitled)

R R R .
5 Last Name First Name Tob Hols
= |Hidebesnd Jare Maketing
3 fsimman Lany Sales
14 [Critch Susan Product development
o Lamber Teny Adninistration
- [Sullivan Dorothy Customer support
A Paul FRose Finance

[Glassmann Beth

Product development %
v

FOTTET I IETUTNTA DI DT DNUT DT TR TS TR TN IR T DN DTN Y Eene'ﬁ‘anlnlerannl
Last Hame | First Name: I Job Role - .

_ [ eader + || Units

Hlast_name frst_name Jtide: [PowerBuider (0] |
=R Timer Interval:
Summary T [o =
Footer T =

~ || Colar

[ TwindBkmnd =

™ HTML Datawindow
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The Preview view becomes large and overlays all the other views. Notice
that it includesthe header information for the report and information from
the database. InfoM aker retrievesinformation for all contactsand displays
as many asfit in the Preview view.

Bundted) -Repoe =]
Pr untitled) [=]x]
T T T T o T T T T T T T T T T T e

4 Last Name Fitst Name Job Role Phone Fax

- Hidetrand Jane Marketing [FI0)EEE1309  [510)555-4209

1 linmen Lary Sales [7131BEERIEN [713) HEE-G268

4 |pien Susan Pioduict dewslopmsrt [EOB] BEE-4A2Y  [SOR) HEE-O025

 Lamben Temy Admirishsticr: [F171BEBZ2E  [17) BEE-OR52

3 Bulivan Dersthy Customes support [EOB] BEEIE  [5OR) HEE-8531

A e Rass Firarics [B17|BEBEITR [17) HEE1498

3 [Glsssmann Beth Pioduict dewslopmsrt [F171BEEIZFA [17) BEE-8533

T o e Trsiving [F17|BEBIE [17) SEE-GEED

21 i Isthey Maksting [F17|BEBIE [17) SEE-GEED

3 [aks Molly Sales [B171BBBAT2  [17) HEE-7EO

E o il Documsrtation [F171BEEAATY  [17) HEE-2504

o Jman Thomss Customes support [BI0|BEBEITE (1) HEE-3372

3 Davidsan Josrn Maksting [BI0|BEETIED [510) EEE-5278

3] |Petiengil Mark Saes [I0)E553533 (5105551146

3 Mooe Dawn Saes [404)5E54334  [404) 5558291

1 |encki John Custamer support [E17)5555348 (6175554619

3 |eaphan Bun Saes (175553887 [617)555-2398

1 Hame william Custamer support [50B) BEE-TTE0  [50%) 5554422 -
< | v

Use the scroll bar on the right side of the window to see more data.
Use the command File>Print Preview Rulers to turn the display of rulers

on and off.

Click here in the upper-right corner to return the Preview view to its

original size and location.

I.|.ﬁ|.|.l.|.|.|.l.|.?|.|.l. n

Fax
(510) 555-4209
[713) 555-9265
(508) 555-3025

(171 RRR.IEA7
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Save the report

Getting Started

Where you are
Create the basic report
Preview the report

> Save the report
Set up the design environment
Define sorting and grouping
Enhance the report
Save the report as an XML file
Print the report

Now you save the report and give it a name.

1 Select File>Save from the menu bar.

The Save Report dialog box displays, with the pointer positioned for you

to type a name for the report.

2 Type contacts_by_jobrole.

3 Click in the Comments box and type This report shows my contacts
grouped by job role.

Save Report [ x]
Repoits:
= ok
Icontacts_by_\obrole
attrib_bitthdays ﬂ Cancel |
attrib_crogzout_and_wvisible
attrb_escapement_rotation Help |
attrib_font_height —
attrib_format
altrib_graybar_emp_total_comp ﬂ
LComments:
This report shows my cantacts grouped by job rale. ;I
E
Library:

4  Press the Enter key.

InfoMaker saves your report. Anytime you have completed a unit of work

and are satisfied, you should save your work.
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Set up the design environment

Set up the design environment

Where you are
Create the basic report
Preview the report
Save the report

> Set up the design environment
Define sorting and grouping
Enhance the report
Save the report as an XML file
Print the report

In this exercise you set up the design environment to make it easier to work. To
do this, you:

e Show the edges of controls
» Display the grid and ruler

Control edges show how big the controlsare. By displaying control edges, you
can easily check for overlapping and make sure the spacing around controlsis
what you want. Displayed edges are adesign aid only; they do not appear in
the report.

The InfoMaker grid and ruler help you aign controls.

If you completed Lesson 2
The design options you set here may aready be set correctly.

1 Select Design>Options from the menu bar.

The Report Options property sheet displays.
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2 Make sure the Show Grid option, Show Ruler option, and Show Edges
option are selected.
Make sure Snap to Grid is not selected.

Click OK.

General | Generationl Prefixesl

— Alignment Girid
3 IS_
¥ Show Grid ¥[8
¥ Show Buler

[¥ Show Edges

¥ Retieve on Preview

QK I Cancel | Lpply | Help |

The Design view shows adotted grid and aruler. Text and columns show

Design - contacts_by_jobrole [x]

TR NI ITTTIN INTNTNE: ICTUTI NI ICTUTI NI, ICTUTTI NI INTUT I ICTUTTE. ICTU T I

Last Name { First Name: ] Job Role | Phone | Fax |

_ [Header t |

Jlast_name first_name Jtide |phone Jfax |
Detail 1

Summary T

Footer t

Ll | H oA
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Define sorting and grouping

Define sorting and grouping

Where you are

Create the basic report

Preview the report

Save the report

Set up the design environment
> Define sorting and grouping

Enhance the report

Save the report as an XML file
Print the report

Now you specify sorting and grouping. You want the report to group contacts
by title. Thismeansyou need to sort by title and then specify grouping by title.

1 Select Rows>Sort from the menu bar.

The Specify Sort Columns dialog box displays.

Specify Sort Columns

1] Drag and Drop items.
2] Double click column to edit

Cancel |
Source Data Colurnnz Aszcending
last_name Help |
|first harme
litle:

phone
fau

InfoMaker
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Move the pointer to the word title in the Source Data box and drag it to
the Columns box.

(To drag, press and hold the left mouse button, move the mouse, then
rel ease the mouse button.)

Specify Sort Columns

[ ]
1] Drag and Drop items.
2] Double click column to edit
) Cancel |
Source Data Colurnnz Aszcending

last_name title [ Help |
first_name
litle:

phone
fau

KN i

Ascending and descending

Ascending and descending are options for sorting. Since you are
alphabetizing in this tutorial, you want to sort in ascending (from A to Z)
order. Ascending is the default, so you do not have to do anything.

You have specified the sorting required to group by title.
Next you specify sorting by last name and then by first name. This
alphabetizes your contacts within each group.

Drag last_name and first_name to the Columns box.

Specify Sort Columns

[ ]
1] Drag and Drop items.
2] Double click column to edit
) Cancel |
Source Data Colurnnz Aszcending
last_name / Help
first_name [

title: kN
honhe
fau
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Define sorting and grouping

4

Click OK.

The sorting definition is complete.

Select Rows>Create Group from the menu bar.

The Specify Group Columns dialog box displays. You are going to group

on thetitle column. All contacts with the sametitle will be grouped
together.

Drag title to the Columns box and click OK.
Specify Group Columns [ %]
1] Drag and Drop items. oK

2] Double click column to edit _I
Source D ata
last_name k
first_name
litle:
phone

fau

Columnis
litle:

KN M« | i

The grouping definition is completed. You have two new bands for the
group in the report. You learn about bandsin the next exercise.

NI DT IS DU I UUUINE. FEUUINN NI, IUUINN IUUITE. IUTIN IUUITE. INT
Last Name | First Name [ Job Role [ Phone | Fax []

_ [Weader ¢ |
{1 Header group title T

last_name Jirst_name: litle [phare [Fax |

Detail 1

1: Trailer group title 1

Summar; ¥t

Footer 1
Ll ] 4
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7 Look at the Preview view.

You see the report and its data. Notice that the dataiis sorted. You do not
see the groups yet. In afew minutes you will make some changes so the
groups appear.

Preview - contacts_by_jobrole [=]

TSI I IS T OO NN DU TS O T IO IS R T IO I ST T =
4 Last Name Tirst Name Tob Hols Phone Tax

B Michas! Admiristation [FI7)EE2090  [517) 5553
3 [Calling MarpBeth Administration [617) 5551133 (617) 555-9586
14 Lambert Temy Administration [617) 555-2246 (617) 555-3692

- Romea John Administration (310) 555-4533 (31015551233
- [Cabb Paul Customer support (404) 555-2233 (404) 5558111
A [Cohen Paul Customer support [617) 555-8883 (617) 555-4493
4 IG oogin Kevin Customer support (713) 555-3340 (713) 5559211
3 Hayne “William Customer support (50) 5557780 (508) 555-4422
4 Hodson Jack Customer support (503) 555-2938 (508) 555-0022
3 lLencki John Customer support [617) 5555348 (617) 555-4619

Il vnan Thomas Customer sonnort R1M RRR-RI7A IRIMFRR-2372 T
I | v
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Enhance the report

Where you are

Create the basic report
Preview the report
Save the report

Set up the design environment
Define sorting and grouping

> Enhance the report

Save the report as an XML file

Print the report

You can enhance reports in many ways. In this exercise you:

» Rearrange controls
* Add atitle and date
* Add page humbers

e Add acount of the total number of contacts

Rearrange controls

76

To rearrange controls, you:

* Putthejobroleinto the group header and change its display font

»  Movethe remaining columnsto close the gap left by moving the column

Thisiswhat the Design view lookslikewhen you havefinished rearranging the

controls.

Design - contacts_by_jobrole

Last-Hame

|First Name

e T

- Header group fitle T

fast_name:

irst_name

Jphone T

Detail £

- Trailer group title T

InfoMaker
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Getting Started

About report bands
The design version of the report that you seein the Design view divides the

report into bands of information.

The header band contains heading information and is located at the top of
each page.

The detail band contains the retrieved data.

The summary band contains summary information that appliesto the entire
report and islocated at the end of the report.

The footer band contains information to be located at the bottom of every
page, such as a page number.

For groups, the group header band and group trailer band contain
information for the group.

1 Move the pointer to the gray bar entitled 1. Header group title (where
the black dot is) until you see a double-pointed arrow

Design - contacts_by_jobrole ]
|I|||I|1||I|||I|2||I|||I|3||I|||I|4||I|||I|
..... Last Mame - - - - |- - - - -FirstName - - - - |- - - - Job-Role - - - - - |- - &
Header 1 |
1: Header group title
Jast_name - first_name - - - - - e - [pho

[ Detail t
[1: Trailer group title t
[Summary t
[Footer t
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Drag the band down about 4 to 6 grid dots.

(To drag, press and hold the left mouse button, move the mouse, then
release the mouse button.)

Design - contacts_by_jobrole ]

|I|||I|1||I|||I|2||I|||I|3||I|||I|4||I|||I|
..... LastMame- - - - -1 - - FirstMame- - - -- |- - - - - JobRole- - - - - | - =

1: Header group title t
Jast_name - first_name - -] e - [pho
[Detail
[1: Trailer group title t
[Summary t
[Footer t

L | o

Move the pointer to the title column and drag it into the band for the
group header.
Put it near the bottom of the band as shown.

Design - contacts_by_jobrole ]

|I|||I|1||I|||I|2||I|||I|3||I|||I|4||I|||I|
..... LastMame- - - - -1 - - FirstMame- - - - - |- - - - - Job Role
_ |Header ¢

1: T
Jast_name - iﬁ[st_name............::::::::::::::::::@
[Detail

1: Trailer group title 1
[Summary t
[Footer t

L | o
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4 With the title column still selected, click B for bold and | for italic on
the StyleBar.

Design - contacts_by_jobrole ]
|I|||I|1||I|||I|2||I|||I|3||I|||I|4||I|||I|
..... LastMame- - - - -1 - - FirstMame- - - -- |- - - - - JobRole- - - - - | - =
Header 1 _I

__[1: Header group title t
dlast name - - - fistoname -+ @

e SRS

1: Trailer group title 1
[Summary t

[Footer t
=
Ki| H oz
This makes thejob role (title) stand out in the report.
5 Look at the Preview view.
You see the report and its data.
Preview - contacts_by_jobrole [=]
RN RN AR R RN AN AR e
‘_: Last Name First Name: Job Role Phone Fax
3 | Administaton
19 [Brrier Michael [617) 555-2338 (617) 555-3337
4 [Calling MarpBeth [617) 5551133 (617) 5559586 _|
3 Lambert Temy [617) 555-2246 (617) 555-3692
— Romea John (310) 555-4533 (31015551233
2: Lustomear suppart
4 [Cabb Paul (404) 555-2233 (404) 5558111
3 [Cohen Paul [617) 555-8883 (617) 555-4493
— IG oogin Kevin (713) 555-3340 (713) 5559211
Haune “illiam (503

503 5?5—7750 15081 555—44224|ﬂ
LA

Notice that the value of the title column appears only once for each group.
Thisis because the title column is now located in the group header band.

The Preview view is helpful for identifying problems. Notice that the
header Job Roleisstill present even though thereis no longer acolumnin
the detail band. Next you del ete the header.
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Click the text Job Role in the header band.

Design - contacts_by_jobrole

T DT I PO TN

[x]
[ NN IO O B B

Last Name First Hame

[«

Job Role D Phone | Fax N

Header f

1: Header group title T

Jlast_name Jirst_name:

phoree T

Detail £

- Trailer group title T

Summary

Footer 1

KI|

Press the Delete key.

Design - contacts_by_jobrole

I DT TN DS TNE. DN DA DR D DTN SUTN DTS DEDUTNIN INOU TR OE T I

[<]

Last Name

First Hame

TS O
hone | Fax -]

Header f

1: Header group title T

Jlast_name Jirst_name:

phoree T

Detail £

- Trailer group title T

Summary

Footer 1

KI|

_>l7_!,

Drag the First Name and Last Name text boxes in the header band to
the right to fill the empty space.

Design - contacts_by_jobrole

[x]

o P T T B 5 T BT B DU DI T DI DU DI T DA T

Last Name | First Name Ty Phone | Fax ]
_[Header T |
BT |
Design - contacts_by_jobrole [=]
R S T N I . oree S AL TR L N e,
E| Idl Last Name First Name ™, Phone [ Fax N
_ [Meader £ |
dir of

|
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Getting Started

10

11

Drag the first_name and last_name columns in the detail band to the
right to fill the empty space.

Design - contacts_by_jobrole

[x]

FOUTETA SIS IFTUTNTN DI DT DNUT DUT TR TS DTN TN DTN D0 DI DI D ISR DU TR IS NS PO

E| [ Last Hame First Name l Phone | Fax N

_ [Header t |
E T |

Cless

Summary T

Footer 1

Design - contacts_by_jobrole

[x]
I T T IUY. IR DU IRV NS IR TUTN IRV TUS: IR OU DU TN DT OU TS YOV DU TN IRV USRI DU NI TS ST T TR
I e LastName:- - - - - |- - - First Name- - - - - {- - Phone - - - |- - Fag - - - - «|

groi

€ fast_name Jfst_name ehne Jres

1: Trailer group fitle £

Detail T

Footer t

L oL

You make onefinal visual improvement now by left-aligning the text in
the column headers.

Choose Edit>Select>Select Text from the menu bar.

This selects all the headers. It might be difficult to see that they are
selected because the band is so narrow.

Click the left justification button on the StyleBar.
If your headers are not already bold, click the Bold button.

All the headers become left justified (and bold).

Design - contacts_by_jobrole

[x]
FOUTETN I TS IFTUTNTN DO DT DAUE DT DTN DU DTN DTN DTN D0 DN DI D SR DU TR ITS.. INTU TN IO
| Last-Name |First Name: {Phone [Fax N
_ [Header t |
7
1= Header group fifle T
1. Tmtpame Trsiname -] Jphore - - o
Dekail £
1= Trailer group tille T
Summary t
Footer T
Ll | H oA
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12 Look at the Preview view.
Preview - contacts_by_jobrole =]
AR A AN RN A RN NN RN AL RN AR AN AN N AL AN AN
3 Last Name First Name Phone Fax
3 | Adwaissasion
ik Brier Michael (175552398 [617)555-33%7
E Collins ManyBeth (1715851199 [617)555.9886
3 Lambiert Teny (175552246 [617) 555-3692
- R John [310) 5554533 (3105551233
2 Lustamer supporf
E Cobb Paul (4045552239 [404) 5558111
3 Cohen Paul (175559883 [617) 5554439
= G Kevin 71315853340 [713)555-9211
F Haune illam 15081 sfswso =z 555'“22Jﬂ
4| Ld 97

Add a title and date
Now you add atitle and date to the header band. They will be at thetop of each

82

page.

1 Move the pointer to the gray bar marked Header and drag it down
about 10 grid dots.

Design - contacts_by_jobrole [=]
ST DTN SN D SUTTE. DN DU DU D TSN STNITT. DRUTINTN DTN OSBRI ST DTS ST B
E| LLast Hame [First Name [Phone [Fax -]
_ | meager =t
E
- Header group fifle T
E fast_name: [[rst_neme [phone: [Fat
Detail £
- Trailer group fitle T
Summary t
Footer T

e v

selection).

This selects al the headers.

Drag all the headers down close to the gray band.

Choose Edit>Select>Select Text from the menu bar (or use lasso

InfoMaker
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This leaves room for the title.

Design - contacts_by_jobrole
T SUT IS IFTTTNTN DN DU DA DA ETU I IO

TFirst Naime: [Phéne Fax
3 mtname [frstorame fphone - - - - - o

Footer T

e o

4  Click the Text button in the Objects drop-down toolbar in the
A PainterBar (or select Insert>Control>Text from the menu bar).
Move the point of the pointer above the First Name box and down one
grid dot from the top of the page.
Click the left mouse button.

Text

This positions the text box for thetitle.

Design - contacts_by_jobrole =]

et bt o B e T bl L S

e T il il

fast_name [first_name: [phone

Detail T
1: Trailer group fitle £

Footer t

Lol | -
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Enhance the report

5 Type My Contacts.

Select 14 from the Size drop-down list on the Fonttab in the Properties
view to make the title bigger (enlarge the text box if necessary).

= contacts_by_jobrole - Report M= E3
[ ——————

Generall Pointerl HTMLl Position  Fant |
FaceMame ﬂ
| M3 Sans Seri Jd|
Size
E =] »
8 e
10 =
12 =
=
18 =
24 =
Text Color
I-Black j =
Background Color
gl:TranSDarent j =
& ||ICharSet
anzil j
Fitch
waniable! j
F anily
= &
Thetitleis now enlarged.
Design - contacts_by_jobrole =]
[ T O T IO DU I UU DS IO DUTN IO DS IO DUTN IO DS DT DUTU DI D IR DU BT T NI N T
g My Contacts
E Last Hame | Fitst Hame [Phone [Fax
Header 1
E
_ |3z Header group titie
1 flast_name: [[frst_name [phone [fax
Detail 1
1: Trailer group title 1
Summary T
Footer 1
Ll ] 4
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Lesson 3 Report Tutorial

Getting Started

Select Insert>Control>Today( ) from the menu bar.

Move the point of the pointer to the upper-left corner.
Click.

This places a computed field in the report. The computed field isfor

today’s date.
IOV OTI DY DU IUD DTOU DR DU IS DFIU VTN U0 DR DU UUTU TN DTN DR DU OU DU TN DI DUS.) DU T DY SUIVE: IUTU DTN DO

Header T

_ |3 Header group fitle T

E| flast_name- [first_name: [phone [fax
Detail 1
1: Trailer group title 1
Summary T
Footer t
KI| )
Look at the Preview view.
Your report now has atitle and today’s date.
Preview - contacts_by_jobrole [=]
O O
]
3 2111499 My Contacts
3
| Last Name First Name Phone Fax |
—_ Adminisiration
- Brier Michael [617) 555-2338 (617) 555-3337
24 Caollins MarnBeth [617) 5551133 (617) 555-9586
= Lambert Teny [617) 555-2246 (617) 555-3692
3 Romeo John (310) 555-4533 (31015551233
Fleetomas somnct

| »
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Enhance the report

Add page numbers

Now you put page numbersin the footer band.

86

Move the pointer to the gray bar marked Footer and drag it down about

4 grid dots.

If necessary, use the scroll bar to make room at the bottom of the Design

VIiew.

Dragging down the footer bar makes space for the page number in the

footer band. The page number is another computed field.

Design - contacts_by_jobrole =]
[ T O T IO DU I UU DS IO DUTN IO DS IO DUTN IO DS DT DUTU DI D IR DU BT T NI N T
oday() My Contacts
E Last Hame | Fitst Hame [Phone [Fax
Header 1
E
_ [z Header group fifle T
1 flast_name: [[frst_name [phone [fax
Detail 1
1: Trailer group title 1
Summar; YT
[ Facter =
K1 1A

Select Insert>Control>Page n of n from the menu bar.

In the footer band, move the pointer to the center and down 2 grid

dots.
Click.

Select a different font size (10) in the Properties view, Font page.

This places a computed field for page numbers.

Design - contacts_by_jobrole =]

[ T O T IO DU I UU DS IO DUTN IO DS IO DUTN IO DS DT DUTU DI D IR DU BT T NI N T
oday() My Contacts
E Last Name |First Mame |Phone [Fax
_ [Weader
E
1- Header group fitle T
E fast_name: [[rst_neme [phone: [Fat
Detail £
1: Trailer group title 1
_ [Summary t
E '‘Page.' + page() + * of ' + pageCount()
Footer 1 . =
KT s
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3 Look at the Preview view.
Click the scroll bar until you move to the bottom of the page.

You now have a page number on your report.

Preview - contacts_by_jobrole [=]
| Qalin Liz [ECIEr=rra R
— Hildebrand Jane [510) 555-1303 [510] 555-4209
| Shishow liina [404) 555-1233 (404) 555-6837
o Weaver Joe [713) 555-1956 [713] 555-4455
= Citfer
— Rapner Doug [713) B55-8444 [713] 555-9934
109
— Page 1 of 2
-
19
T L L 0 AR A ) M AL R 0 R A R A B R M M
< | L'JA

Add a count of the total number of contacts

Getting Started

Now you add a count of the total number of contacts you have to the end of the
report. You put the information in the Summary band, which meansit prints at
the end of the report.

Like the date and page number, the count is a computed field, only thistime,
you create it yourself.

1 Move the pointer to the gray strip marked Summary for the summary
band and drag it down about 6 grid dots.

This makes space for the total number of contacts, which is a computed
field.

Design - contacts_by_jobrole =]

IOV OTI DY DU IUD DTOU DR DU IS DFIU VTN U0 DR DU UUTU TN DTN DR DU OU DU TN DI DUS.) DU T DY SUIVE: IUTU DTN DO

Header T

group

flast_name- [first_name: [phone [fax

< >

.“Pﬂge "+ page() + ol ! + pageCount() ‘.

Detail 1
1 Trailer group fitle t

Summary T

Footer T

KI| )
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Enhance the report

88

Select Insert>Control>Computed Field from the menu bar.

In the summary band, move the point of the pointer to the center and
down 4 grid dots.

Click.

Thissetsthe position for acomputed field that you usefor thetotal number
of contacts. The Modify Expression dialog box displays.

In the Functions box, click count(#x for all).

Your dialog box should look like this. The placeholder for what to count
is highlighted.

Modify Expression [ %]
Ex=pression:

Ok I
count] B for all | ;I Cancel |
Werify |

Help |

Functions: Lolumns:
s 5 avgl Hx for all ) - last_name
J J bitl_'qap [=] :ll first_name
ceilingl % ] Litle:
j / caze| ® when athenb v phone
char[ %] fax
coz ®] date_1

count] #x for all | page_1
ﬂ J crogstabaval 11 LI
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Getting Started

4

In the Columns box, click last_name.
This selects the last_name column to apply the count function to. You are
going to count al the last names to find out how many contacts you have
in the report.
Ex=pression: ’TI
.count[ last_name Ffor all | ;I Cancel |
Werify |
Help |
[
Functions: Lolumns:
=] [ - #x for al - last,
3 S b ECCE I S e
ceilingl % ] Litle:
j ﬂ caze| ® when athenb v phone
char[ %] fax
coz ®] date_1
#a for al 1
0 RN ) omitictS Y [ L
Click Verify.

You should get the message box stating that your expressionis valid.

Report B

& Expreszion iz OK.

Click OK to close the message box.

Click OK to complete the definition of the expression for the

computed field.

The computed field isin place.
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Enhance the report

90

Select Insert>Control>Text from the menu bar.

Position the pointer to the right of the computed field and click.
Type contacts in all.

Drag the text box to line it up with the computed field.

[count{ -Iﬂﬂcuntacts in all- | -----

. [Page "+ page( - ‘of ' + pageCount)) |. .

Select the computed field and the text using lasso selection.
On the Font page of the Properties view (or on the StyleBar), select 10
for a font size and click | for italic and B for bold.

How to use lasso selection
Position the pointer, press and hold the left mouse button, and drag the

lasso around everything you want to select. Then release the mouse button.
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Lesson 3 Report Tutorial

Getting Started

Look at the Preview view.

Use the scroll bar until you see the end of your report.

The summary band of your report now shows the total number of contacts
in the report. The number you see may not be 61. The number depends on
the contacts currently in your database.

P

eview - conlacts_by_jobiole
Fage
Fetiengl
Fhilley
Furcel
Buinn
Simmon
Trayers
whits

Frainineg
Elkins
Long
Mille
Powel

Lynn
Mark
Mary
Eeth
Peter
Lairy
Ken
Pauling

John
Pater

Henuy
Gene

(617) 555-8890
(510) 555-3533
[713)555-3338
(617)555-2343
(617) 5552222
[713) 555-8350
[617) 5552304
[713) 5553345

(603) 5551200
(617) 555-4519
(617) 555-3356
(617) 555-3528

cantacts in alf

=
[617] 5554544 &1
(51015551146
(713) 555-9066
(61715551765
(6171 5559337
(713) 555-9265
(E17) 5554127
(713) 5559222

(603) 5550078
[617) 555-4339
[617) 5551332
[617) 5559863
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Save the report as an XML file

Save the report as an XML file

92

Where you are
Create the basic report
Preview the report
Save the report
Set up the design environment
Define sorting and grouping
Enhance the report

> Save the report as an XML file
Print the report

You can save the datain areport in many different formats, including XML,
HTML, Microsoft Excel, and PDF.

Saving as PDF
Before you can save the data in areport object to a PDF file, you must install

GNU Ghostscript on your computer. For information about using the GNU
Ghostscript distiller, see the User’s Guide.

Now you save the report as an XML file.

1 Select the Preview view by clicking it.

This ensures that the Preview view is the current view.

2 Select File>Save Rows As from the menu bar.

InfoMaker
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Report Tutorial

Getting Started

3

Select XML from the Save as Type drop-down list.

Save in: I 4 Tutarial

21|

x| = @3k E-

File name:
Save as type:

Encoding:

HML

Save I

Cancel |

SYLK with headers
Teut

Text with headers
WS

WS with headers
w1

W1 with headers
“indows Metafile

HEL-FO

Help |

Type a name for the file and click Save.
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Print the report

Print the report

Where you are

Create the basic report
Preview the report
Save the report

Set up the design environment

Define sorting and grouping
Enhance the report

Save the report as an XML file

> Print the report

1 Select the Preview view by clicking it.

This ensures that the Preview view is the current view.

2  Select File>Print Report from the menu bar.

The Windows Print dialog box displays.

Frinter. HF Laserlet 551795 MX PS an

Copies: I

Fage Range
o Al
" Curent Page

" Pages: I

Enter page numbers and/or page ranges
separated by commas. For example, 2.5,8-10

Frint:  [All Pages in Range

=

Ok
Cancel

Frinter...

ilds

Help

™ Print ta File

IV Collate Copies

3 Click OK.

4  Select File>Close from the menu bar.

If you are prompted to save changes, click Yes.

The Report painter closes.

94
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LESSON 4 Table Tutorial

This tutorial requires the Database painter
The Database painter component of InfoMaker is optional; you must have

installed it to do this tutorial.

Tables are the way relational databases organize information. To take full
advantage of InfoMaker’s ability to create forms and reports, you should
learn how to create and work with database tables.

InfoMaker isinstalled with an Adaptive Server Anywhere database. You
can create and work with tables in the Adaptive Server Anywhere
database and in any other database you have access to.

After you create atable, you can display its columnson aform and use the
form to add information into the database. For afinal printed copy of the
datain your tables, you can create and print reports.

In thistutoria you:

*  Create adatabase table

»  Define extended attribute information
e Add datato thetable

When you are finished, you can create forms to view and update
information, and you can create and print reports using informationin the
table.

How long does this tutorial take?
About 45 minutes.
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Create the database table

Create the database table

Where you are

> Create the database table
Define extended attribute information
Add data to the table

To create the database table, you:

» Definethe columnsin the table

» Defineaprimary key

*  Enter comments to document the table
+ Savethetable

Define the columns in the table

1 Click the Database button in the PowerBar.

4/tutor_im.pbl - InfoMaker

File Tools ‘Window Help

“rﬁ&»l@!ﬁwa\me

Mew Preview Fel Lib Lib List To-DolList  Library DE Prof % Databaz, Exil

96

InfoMaker



Lesson 4 Table Tutorial

The Database painter workspace displays. It contains many views for
working with database information. If your workspace does not ook like
this, you may want to select View>Layouts>(Default).

\tutor_im.pbl - InfoMaker o =]
Fle Edit Wiew Object Design Rows Tools Window Help
G " o
- = : E B & B
New Open  Proview  Sullib  Liblit ToDelist Library DEProf Databaze  Exit
84 B H 2.4 & @ %
Connect Disconnect  §ave  CreateTsbl  Jrop Objec  Print  Properties anipulation nipulation [ipulstion[f Pipeline  Cloce

#% Database - 1 Connection: (Active Connection - EAS Demo DB ¥105)
— P ———————]
Installed Database Interfaces -~ (] o DB ] t Details (EAS Defm] B,
{4 DIR Direct Connect
5 IN9 Infarmix vo.x
E: f)DIBDJ(g)faEIE \0g Mo properties to display.
4 084 Oracle 8/8i
E4 090 Oracle 5

QDB ODEC
£ &) EAS Dema DB Y105
[ Driver Information
Groups
Metadata Types

(=]

(=]

[ Procedures & Functions bl
[0 Tables il »
7 Users Objeck Layout dFxtended Attributes

[ Views
EAS Demo DB Y105 IM

-4 EAS Demao DB Y105 IM Unicod =
4 EAS Demao DE Y105 Unicods & ﬂ »
e

« | 21 IiSQ session fectumreesuts AN

|Ready [ ‘ [ 4

-
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Create the database table

2

98

Position the pointer on the Tables folder in the EAS Demo DB V105 IM
database and select New Table from the pop-up menu.

l tutor_im.pbl - InfoMaker -10] x|
File Edit Wew Object Design Rows Tools ‘Window Help
B o
W e B o= = B 8 k
Hew Open  Preview  Sallib Lblist ToDo Library DB Prof Dukabace  Exit
854 8 EH B . 34 o o H P s
Cornect Disconnect  Save  JreateTabl  JropObjec  Print  Properties nipulation nipulstion [ipulation [f Cloze

atabase - 1 Connection: {Active Connecti

Installed Database Interfaces
E DIR Direck Connect
4 INT InFormix v3.x

JDE JDBC
010 Oracle 109

(7 Groups

o R
[J Users
[ Wiews
- EAS Dema
4 EAs Demo
~[E4 EAS Demo

RSN

EAS Dema OB V105
(3 Driver Information

(7 Metadata Twpes
(3 Procedures & Functions

al
Mew Table. ..
Show System Tables

Table Security. ..
Refresh

Properties

- EAS Demo DB ¥105)

Mo properties to display,

L Session ACalumns jResults

-

o

[ Vi

InfoMaker



Lesson 4 Table Tutorial

Getting Started

Theview inwhich you definethe columnsin the tabl e displays. The cursor

isin the Column Name box for the first column.

ltutor_im.pbl - InfoMaker
Fle Edit Wiew Object Design Rows Tools Window Help

=0l

How Open  Proview  Sallib

Lib List  To-Da Lick  Library

Moo g BRom B R B EH OB

DEProf  Database

Exit

B 2

Zroata Tabl

o o

Connect Disconnect  Save

5 o

Jrop Objec  Print

g B E B8 =x

Prapartioz snipalation nipulation [ ipulation [ Pipeline

. Installed Database Interfaces
'Q DIR Direct Connect

E3 N9 Informix va.x

£4 0B 1DEC

E4 o100rack 10g

E4 084 orack 5/8i

E4 090 Oracle 5

=1+ ©DB ODBC

£ EAS Dema DB Y105
[ Driver Information
-7 Groups

- -7 Metadata Types

-] Tables
-7 Users
B[ Views
-4 EAS Demo DB Y105 IM

M7 | il

- Procedures & Functions

-4 EAS Dema DB Y105 IM Unicod
3 EAS Demo DB Y105 Unicode

| 2 N ) s A

atabase - 1 Connection: {Active Connection - EAS Demo DB ¥105)

Mo properties to display,

| Colurn Marme

Data Type

-
4 »
Object Layout £Extended Attributes

wiidth  |Dec [rull

-

- |[(rone) ;I

Default r

|Ready

A

Type id and press Tab.

The cursor moves to the Data Type box. The default datatype is
highlighted. The datatype for the id column needs to be integer.

Click the arrow in the Data Type box and select integer from the drop-
down list of available datatypes.

This changes the datatype.
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Create the database table

100

Press Tab three times.

This moves you past the setting of No for the column labeled Null. No
means you do not want to allow the column you are defining to be empty
(to have anull value). Since you always want avaue for id, you leave the
value No. You also move past the column labeled Default. You are not
going to specify a default.

Column Marme Data Type WwWidth Dec Mull Drefault
id integer Mo [Maone]

t [Maone]

KK
Ll

IV

Type last_name and press Tab.

The cursor moves to the Type column. The most recently used datatype
(integer) ishighlighted. Thelast_name column should betypechar, soyou
change the datatype.

Type c and press Tab.

Typing cisashortcut for choosing char quickly. The cursor moves to the
Width column.

Type 15.
This allows 15 characters for the last name instead of 10.

Press Tab three times.

This moves you past the setting of No for the column labeled Null to the
Column Name box for the next column. No iswhat you want (name cannot
be empty). You move past the column labeled Default again.

| Column Marme Data Type WwWidth Dec Mull Drefault
id integer hd Mo hd [Maone] hd
last_name char hd 15 Mo hd [Maone] hd
I K | Nenel |~
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Lesson 4 Table Tutorial

Getting Started

10 Finish entering information about the table columns.

The following table shows all the values needed to define the columnsin
thecontact table. You have already entered valuesfor thefirst two columns
(id and last_name).

Name Type Width | Dec | Null | Default
id integer No (None)
last name | char 15 No (None)
first_name | char 15 No (None)
title char 2 No (None)
Street char 30 No (None)
city char 20 No (None)
state char 2 No (None)
zZip char 5 No (None)
phone char 10 Yes (None)
fax char 10 Yes (None)

When you have finished, the Co

lumns view should look like this.

| | Column Marme Data Type WwWidth Dec Mull Drefault
id integer hd Mo hd [Maone] hd
last_name char hd 15 Mo hd [Maone] hd
first_name char hd 15 Mo hd [Maone] hd
Litle: char hd 2 Mo hd [Maone] hd
strest char hd a0 Mo hd [Maone] hd
ity char hd 20 Mo hd [Maone] hd
state char hd 2 Mo hd [Maone] hd
zip char hd 2 Mo hd [Maone] hd
phone char hd 10 Yes hd [Maone] hd

_fax char hd 10 Yes hd
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Create the database table

Save the table
You have now entered al of the column information needed. Now you finish
creating the table.
1 Select File>Save from the menu bar.
The Create New Table dialog box displays.

You leave the owner as dba (database administrator) and enter aname for
thetable.

2 Type contactl in the Table Name box.

Click OK.

Owner Mame: Idba

Table Mame: Icontact‘l

Lancel |

InfoMaker passes the SQL needed to create the table to the Adaptive
Server Anywhere DBMS, which creates the table.

InfoM aker displays a representation of the table in the Database painter
Object Layout view.

id
last_name
first_name
Litle:

street

city

state

zip

phone LI
Thelist of columns displays. The scroll bar on the right side means that

there are more columns than can be displayed at once. To see the other
columns, you can click the down arrow at the bottom of the scroll bar.
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Define a primary key

A primary key uniquely identifies each row. In your contact table, id isthe
unique identifier of each row of data.

1 Select Object>Insert>Primary Key from the menu bar. (If the menu item
is grayed out, click the Object Layout view to make it current and then
select the menu item from the menu bar.)

The Primary Key property sheet displaysin the Object Detailsview. Here
you can pick one or more columns as the primary key.

] Primary

General |

Table:
contact1
Columnis:

[id f’
[last_name
[CIfirst_name
[hitle =l

Order:

1]

2 Clickidin the list of columns.

—
E']F'rirnar' 4 45 Demo DB 10 I8} - u:u:unt.an:tlE[ E

General |

Table:
contact1
Columnis:

d f’
last_name

v
i
First_name
[ltitle =l

Order:

[ 1]id

3 Select File>Save from the menu bar.
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Create the database table

This defines id as the primary key for your table. Notice that the

representation of the table now includes a symbol for the primary key of
the table.

id
last_name
first_name
Litle:

street

city
state
zip
phone

|

Next you define a comment for the table.

Enter comments to document the table

Although not required, comments can be helpful inidentifying tables.

1 Position the pointer on the title bar of the representation of the
contactl table, display the pop-up menu, and select Properties.
The Table Properties property sheet displaysin the Object Details view.

2

Click in the Comments box and type This is the sample table for the
tutorial created by [your name].

[ Tabls (EAS Demo DB ¥105) - contactl [l B3
General |Data Fonk | Heading Fonk | Label Fonk

Chwner:

| dba
Table:

| contactl

Comments:

This is the sample table for the tutorial ﬂ
created by Jane Sterling.

[~

This associates the comments with the table you are creating.

3 Select File>Save from the menu bar.
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Define extended attribute information

Where you are

Getting Started

Create the database table
> Define extended attribute information
Add data to the table

Now you extend the basic definitions of the columnsin the table.

The following table summarizes how you extend the column definitions of the
contactl table columns.

Column name

What you do to extend its definition

id Nothing.

last_name

first_name

title Define a DropDownListBox edit style of job roles, change the
column header and label to Job Role, and enlarge the display
width of the column to 1.5 inches.

street Nothing.

city

state Assignthe DropDownDataWindow edit stylefor stateto thestate
column.
Set the default value of state to MA.

zip Nothing.

phone Define an Edit Mask edit style for aphone number and apply it to

fax phone and fax.

About extended attribute information
InfoMaker stores extended attribute information in the extended attribute

system tables and uses it to display and validate datain forms and reports. In
the Report painter or Form painter, you can override whatever you specified in
the Database painter, which is where you are now.
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Define extended attribute information

Define a DropDownListBox edit style for the title column

Now you define a DropDownL istBox edit style that hasthe valid job roles for
thetitle column. When you have finished, thisiswhat it looks like in aform.

106

Marketing

=

Adminiztration
Customer support

-

D ocumentation
Finance
Human resources

Other
Product development -

1 Select View>Layouts>(Default) from the menu bar.

2 Click the Extended Attributes tab to bring the view to the front.

3 In the Extended Attributes view, display the pop-up menu for Edit
Styles and select New.

i tutor_im.pbl - InfoMaker
File Edit Wiew Object Design

Rows  Tools  Window Help

=10l x|

E 5 =2 B &8

Liblict Te-Dolict Library DBProf  Databace  Exit

=

L =

Mew Opsn el Lib

H 4 H B
Connect Dizeonnect Save Zreate Tabl

El
pulstion[f Pipeline  Cloze

- d = <o =5}

Jrop Objec  Print  Propertics anipulation nipulstior

B

x

#% Database - 1 Connection:
=

THE InFormix +3.3
ICB JDEC
010 Oracle 10g
084 Oracle 83
4 090 Oracle 5i
=4 ODBE ODBC
=& EAS Demn DB ¥105
+-(Z1 Driver Informat,
Groups
Metadata Type:
Procedures & Fi
Tahles
Users
Wiews
[ EAS Dema DB Y105
{4 EAS Dema DB Y105
-4 EAS Dema DB Y105
B[ Utilities 1)

4B validation  MEw..
Refresh

Propetties

Mo properties to display,

EObjact Layout 3Extended Attributes—

4

-4 5vC Sybase AsE
B St b 4 ST Fee B —I
4] 1 »

150 Session JCaunne yezuks A

il

[Ready

| ooaroo
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The Edit Style dialog box displays.
Edit Style
Hame: | Style: |Edit ﬂ
Options
Lirnit: 0 Case: En}l Accelerator: |— [T Passward
Fomat | [ Required
' [ Auto Horz Serall

[ Auto Selection [ Show Focus Rectangle [ AutaVert Scroll

[ Display Only [ Empty String is NULL [~ Horz Scroll Bar

[ Use Code Table [ [ Wert Seroll Bar

QK | Cancel | Help |

4  Enter the name JobRoles1.
Select DropDownListBox in the Style box next to Name.
Check Sorted to alphabetize your entries.
Check Vert Scroll Bar to display a vertical scroll bar on your list.

Edit Style
Name: [JobRoles1 Style: |DropD0wnListBox ﬂ
Options

Lirnit: o Casze: En}l Accelerator: |—

V' Saorted [ Always Show List [ Auto Horz Scroll

[ Required [ Alwaps Show Amaw [v et Scrall Bar

[ Allow Editing [ Empty String is NULL

Dizplay Yalue [rata Yalue Add

(& | |

Inzert

i

QK | Cancel Help
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Define extended attribute information

108

Enter the Display Values and Data Values shown in the table below.
Be sure to use lowercase for the data values.

To enter each pair of values, type the values and click the Add button.
For the last pair of values, do not click Add.

Display Value Data Value
Sales sa
Customer support cs
Product devel opment pd
Administration ad
Training tr
Documentation do
Marketing ma
Human resources hr
Finance fi
Other ot

When you finish entering values, the Edit Style dialog box looks like this.

Edit Style

Name: [JobRioles1

Style: IDropDownListBox j

—— Optiong
Lirnit: I—D Casze: w Accelerator: I_
¥ Sored [T Abwaps Show List [ Auto Horz Scrall
[~ Requied [ Always Show Amow [+ ‘et Scroll Bar
[ Allow Editing [ Empty String is NULL
Display alue D ata ' alue ;I

|D ocumentation

|d0

agd |
Delete |

|M arketing

|ma

IH uman resources

|hr

Inzert |

|Financ:e

[

@ |Dther

()8 I Cancel |

|0t

Help |

About display values and data values .
Display values show in forms and reports. Data values are stored in the

database. Display values should be meaningful—such as Human
Resources. In contrast, data val ues are often codes that are short—such as
hr. Short codes conserve space in the database.
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Getting Started

Click OK to accept the definition of the DropDownListBox Edit Style

named JobRoles1.

InfoMaker adds the JobRolesl edit style to the extended attribute system
tablesin the database and lists it as one of the available edit stylesin the

Extended Attributes view.

Expand the tree view of Edit Styles by clicking the plus (+) sign.
Use the scroll bar to scroll down to the JobRoles1 Edit Style.

[#-<H* Display Formats
<> Edit Styles
] #apes
BT ppe-ar-pper
BT e, arp00
----- ¥ BenefitsCheckBox
----- T Color List
Customers
----- ¥ Day Care
T Doy
5T DOMMPY HH:MM: 55
(] DDfMMYY HH:MM:S5:FFFFFF
T Doy
[ DDfMMPY Y HH:MM:SS
T Doy
-] DDfMMMPYY HH:MM:SS
] ooy
5T DODMY HH:MM: 55
T oooerey
-] DDDJY Y HH:MM:SS

. J=1 Marsvkrank Lick

-

[ |

emplovess
Financial Codes

-[¥ Health Insurance

B HH:MM:SS

-] HH:MM:55:FFF
-] HH:MIM: S5 FFFFFF
BT 1m0y

T 1200 HH:MM 55
BT ey

01 293P HH:MM: S5

T JobRoles
T JobRalest
- Life Insurance

T Moy

T MM{DDYY HH:MM: S5
T Mmooy

[ MMIDD Y HH:MM:SS
E}j rmddyy

Etl Phone

T Prod_desc
|

=

=

Now that JobRolesl isdefined in the extended attribute system tables, you
can useit for any appropriate column in any tablein the database. You are

going to assign it to the title column in the contactl table.
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Expand EAS Demo DB V105 IM in the Objects view to display Tables
and then the Columns in the contactl table.
Display the pop-up menu for the title column and select Properties.

The Object Details view now includes the property sheets for the title

column.

) tutor_im.pbl - InfoMaker
File Edit View Object Design Rows Tools Window Help

=loix|

W =

Hew Open

B B = =

Preview  Sellib  Liblizt To-Dolist Library

e 8 W
DE Prof  Database Exit

ad

Connect Disconnect

EH B2 .4 & o

El 8 x

Zave  SreateTabl  JropObjec  Frint  Properties aripulation nipulstion [ipulation [f Fipeline  Glase

ER=|

=3 Columns

contactl

urnr

General | Headers

O
id ~[Z] Financial Codes
last_narr W Health Insurance Table: ﬂ
First_nan HH:MM: 55 |contact1
HH:MM:55:FFF Calumn:
stre  Edit Column.., ;MM 55:FFFFFF I title
city  Drop Column N J
St — i - Column Details
2ip Column Mumber:
phone 2230 HH:MM: 55 |4
Fax -] JobRoles Data Type:
{27 Foreign Keys -] JobRolest Ichar
-7 Indexes - [ Life Insurance = _
F-0 Primary Key J [ = I B Display Width:
-1 Triggers o6 r B |
jeck Lavout 3Exkended Attributes =
[ customer
B department =
B-El employes
-2 exam_sref_infa
-] exam_xref_ist 5
- examples _|_I
1.7 mvamnlps catam 4 4
1] r 1501 Session £Columns yResults
|Ready [ | 4
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9 If the Edit Style tab is not visible, use the arrows in the upper-right
corner of the Object Details view to display the Edit Style tab.
Click the Edit Style tab to bring it to the front.

Lltutor_im.pbl - InfoMaker ==l 5'
Fle Edit View Object Design Rows Tools ‘Window Help

M e B B s B m & 8 B

Pew Open Preview Eellib Lib List  To-Dolist  Library  DEProf  Databaze Exit.
8 8 H BE. @ 8 o =2 Fa %
Connect  Discomnect  Save  SreateTabl  Jrop Objec  Print  Properties anipulation nipulation Cripulation (f - Pipeline Clase

=~ contactl
-3 Columns
last_narr - Health Insurance Style Name:
irst_nan % HH:MM: 55 AR P
HH:MM: 55 FFF
= street L] HHiMM: 55 FFFFFR BeneftsChecldfiox El
i B 200
~{f state @:I 122 HH:MMiSS J
- B 33pwery
--fF{ phone @:I 122 HH: MM S5
JobRoles
-7 Foreign Keys JobRolest
-7 Indexes - Life Insurance =
B[ Primary Key ‘] S e >
T,D Triagers Object Layout 4Exbended Atbributes
= customer
department 1=

employes
exam_zref_info

exam_xref_list =
- examples P s
1P avamnlae Faben— . e
B0

1501 Session AColumns yResults

0 0

4]

[Ready [ \ [

10 Scroll the list of edit styles until JobRoles1 displays.
Click it to apply the edit style JobRolesl to the title column.
Select File>Save from the menu bar.

Change the column header, label, and display width of title

Getting Started

Now you change the label and header text for the title column. The text you
supply appears on forms and reports you create.

The column nameistitle, but the text you want to display is Job role. Also, you
change the display width to 1.5 inches. Theinternally stored datavalueisonly
two characters, but the values you intend to display are longer.

1 Thetitle column should still be current (if not, display its pop-up menu
and select Properties).

Click the Headers tab to bring the Headers property page for the title
column to the front in the Object Details view.
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All the extended attribute information for a column is definable using the
various pages in the Object Details view.

2 Type Job Role in the Label box.
Type Job Role in the Heading box.

=
B8 Column (EAS Demo DB Y¥105) - contactl :tfm] B
General Headers |Display | Walidation | Eod u
=Label
Label:
| Job Rale
Position:
Jleft |
- Headi
Heading:
Job Rale ;I
E
Position:
Icenter j

3 Click the Display tab to bring the Display page to the front.
Type 1.5 in the Display Width box.

—
[E8 Column {(EAS Demo DB Y10 3 - contact 1 :t[=] B3
General | Headers  Display |Validati0n | [Z | »]

Display Format:

I(None) j
Justify:

Jleft

Display Height {in:
| 1.668

Display Width {in):
15

Case:

I(None) j

[~ Picture

Ll

4  Select File>Save from the menu bar.

InfoMaker adds the extended attribute information for the column to the
extended attribute system tables.
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Assign a DropDownDataWindow edit style and initial value to state

For the state column, you assign an edit style that includes all the state names
(aswell asthe provinces of Canada). Then when you enter information into this
field, you pick from alist of states. You also set theinitial valueto MA, since

Getting Started

In the Extended Attributes view, display the pop-up menu for Edit
Styles and select New.

xtended Attributes (EAS Demo DEIER|

[ Display Formats
<3

Etl ### pefresh

E}j dai,

..... ¥ Benefi  Properties

----- T Color List

Customers

----- ¥ Day Care

T Doy

5T DOMMPY HH:MM: 55

T Doy

L] DOMMPAY HHEMM:SS
T Doy

L] DOMMMPYY HH:MM: 55
-1 ooy

T DODMY HH:MM: 55

L] DDJMM{YY HH:MM:SS: FRFFFF

T ooorrry -
£ .
Object LayoutXExtended Attributes

many of your contacts are in Massachusetts.

The Edit Style dialog box displays.
Edit Style
Mame: || Style: IEdit j
Options

Lirnit; I 0 Casze: Eny Accelerator: I_ [~ Password
Format: [~ Requied

: I [ Auto Horz Scroll
[ Auto Selection [ Show Focus Rectangle [ Auto Vert Scrol
[ Display Only [~ Empty String iz MULL [ Horz Scroll Bar
[~ Use Code Table [~ “alidate Using Code Table [ et Scroll Bar

o]

Cancel Help
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Type StateCodel in the Name box.

Select DropDownDW from the Style drop-down list.
Select d_dddw_states from the DataWindow drop-down list.

The StateCodel edit style uses areport (Datawindow) named
d_dddw_states. Thereport getsits values from the state table.

Edit Style

Mame: [StateCode1

Style: I DropDownDia j

— Options

D ataiwindow:
Dizplay Column:

D ata Columi:

Linez in DropDow:

d_dddw_states

d_dddw_fin_code
d_dddw_products
d_dddw_sales_orders
d_dddw_sales_reps

Limit: [0 (3 e o

[~ Requied [ Always Show List

[ allow Editing [ Always Show Amow

I~ auto Horz Scroll [~ Empty String iz MULL

[~ % Scroll Bar [ Split Horz Scroll Bar

[~ H Scroll Bar [ AutcRetieve
’TI Cancel | Help |

About DropDownDataWindow edit styles

A DropDownDatawindow edit style getsits values from areport that it
references. The report gets its values from the database.

Thisiswhat the d_dddw_states report looks like.

= Report - d_dddw_states

=l 3

-

D Mame Country
AR |Alberta CAN
A |Alaska USA
AL [Alabama LUSA
AR |Arkansas LUSA
AL |Arizona LUSA
BC  |British Columbia CAN
CA  |California LUSA
CO  |Colorado LUSA
CT  |Connecticut LUSA

( Frrm | Frimteiod of Fom e i i

i
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3 Select state_id from the list for Display Column and for Data Column.
Type 550 for the Width of DropDown.
Select V Scroll Bar.
Click OK to accept the definition of the StateCodel edit style.

Edit Style [ %]
Hame: IStateEode‘I Style: IDropDownDW’ j

— Options

EyMndﬂv:—-ﬁ:ddg&v\__states

<Display Colurnm: state_id \
Linez in DropDow: l— ‘width of DropDow
Limnit: I—D Case: V Accelerator: I_

[~ Requied [ Always Show List
[ allow Editing [ Always Show Amow
[ crol [~ Empty String iz MULL

<: [ Split Horz Seroll Bar
[~ H Scroll Bar [ AutcRetieve

QK I Cancel | Help |

InfoMaker adds the StateCodel edit style to the extended attribute system
tables, whereit isavailableto be assigned to any appropriate columninthe
database. Now you assign it to the state column in the contactl table.
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4 Display the pop-up menu for the state column in the contactl table
and select Properties.

) tutor_im.pbl - InfoMaker - 10] x|
File Edit Wiew Object Design Rows Tools  Window Help

M = B B = a‘n&gsil@‘

Mew Opsn Preview el Lik Lk Lizt  Te-DolList  Library DE Prof  Databaze Exit

- = B &5 =] =

8 5 B BH. 4 & © H El B x
Comnect Disconnect  Save  SreateTabl  JropObjec  Print  Prapertics wnipulation nipulstion [dpulstion [ Pipeline  Close

=) D Columns H General |Headers | Display I Walidation | Edit Style I
i id [=-<0> Edit Styles
last_ni B rene Tahle: ﬂ
first_n B gaa-pa-raes [ corttact:
title B e aae00 T o
shreet - [¥ BenefitsCheckBox |state
city ] Color List
=1 cistpmers = Column Details

zip Edit Column...
phon Drop Column

are Calumn Murnber:
My [7

X Fax Data Type:
1 Foreign k
[ Indexes EL0 ooy | char
[0 Primary K2 L0 oopmpryvy ey | Display Width:
{7 Triggers L] Dofmmmpy B

-5 customer - EL] Coymmmp HH:M Mullable:

-] department -1 poojwy |Nn

-] employes L] DoDMY HH:MM:SE o || Defaulk:

B exam_xref_nf Pl T _,lJ |(None)

B2 encam_xref_ist 4 |4 Object Layout Extended_’l (Fraorien] oo LI

- examples —

W mvamnles rake T
ol s ;i_l I EEyemsTEy,

|Ready [ | | ooaroo

5 In the Column Properties view, select the Edit Style tab.
Select StateCodel for the edit style to assign to the state column.
(If the StateCodel edit style is not listed, select View>Reset View. This
refreshes the list of edit styles.)

Displayl ‘alidation ~ Edit Style LLILI

Style Mame:

SocSecHumber -
StateCode _I

StatusButtons
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Getting Started

This assigns the StateCodel edit style (which includes 63 entries—states,
territories, and possessions of the United States and provinces of Canada)
to the state column in the contact table. The values that this edit style
displaysand thevaluesthat it stores are state postal abbreviations (such as
MA for the state of Massachusetts).

Select File>Save from the menu bar.

Click the Validation tab.
Make sure the Validation Rule setting is (None).
Type MA in the Initial Value box.

Thisassigns aninitial value of MA to the state column.

Display Validaton | Ecit Style T

Y alidation Fule:

I [Maone] j

Initial % alue:

e g

The Validation page lets you create and assign a validation rule to a
column and enter an initial value for the column.

You are not going to assign avalidation rule. You have handled validation
by forcing the user to select from exactly 63 valid values presented in the
States drop-down DataWindow.

About column validation rules _ o
You can use column validation rulesto express requirementsfor entriesin

a column. For example, you could define arule for asalary column that
requires salaries to be greater than $15,000 and less than $100,000.

When you assign a column validation rule to acolumn, no one can enter a
value that breaks the rule.

Select File>Save from the menu bar.

InfoMaker saves the extended attributes you just defined for the state
column in the extended attribute system tables.
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Define an Edit Mask edit style for phone and fax

Now you define an Edit Mask edit style to display phone and fax numbers for
both viewing and editing.

1 Inthe Extended Attributes view, display the pop-up menu for Edit
Styles and select New.

[P¥JExtended Attributes (EAS Dermo DB v105]m] B3

[ Display Formats
4B Edit Styles
Bl ppens
BT ppe-ar-pper
T e, #p.00
----- ¥ BenefitsCheckBox
----- H Color List
Customers
----- ¥ Day Care
T Doy
5T DOMMPY HH:MM: 55
(] DDfMMYY HH:MM: 55:FFFFFF
T Doy
L] DDfMMY Y HH:MM:SS
T Doy
] DDfMMMYY HH:MM:SS
-1 ooy
T DODMY HH:MM: 55

T ooorrry -
Object LayoutXExtended Attributes
=

The Edit Style dialog box displays.
Edit Style [ %]
ﬂame:l Style: IEdit j
Options
Lirnit; I 0 Casze: Eny Accelerator: I_ [~ Password
[~ Requied

Farmat:

: I [ Auto Horz Scroll
[ Auta Selection [~ Show Focus Rectangle [ AutoVert Scrol
[ Display Only [~ Empty String iz MULL [ Horz Scroll Bar
[~ Use Code Table [~ “alidate Using Code Table [ et Scroll Bar

QK I Cancel Help
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2 Type TelephoneNumberl in the Name box.
Select EditMask in the Style drop-down list.
Delete xxx and type (###) ###-#### in the Mask box.

This specifies the edit mask. Now you can test it to make sureit iswhat

you want.
x|
Mame: ITeIephoneNumberl Style: IEditMask j
Masks:
Mask: K###) #a4-2ass ! - Uppercase 2
- - Lowercase =
Test:
Cptions
Type: Etring Accelerator: I_ Spin Increment: I 1

[~ Required [ spin Contral Spin Range
[ AutoSkip [T Code Table i
[~ Use Format I~ Read Only UEES

[ Focus Rectangle

OF I Cancel Help
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Press Tab.
Type 6175552145 in the Test box.

x|
Mame: I Telephonehumber 1 Style: IEditMask j
Masks:
Mask: K###) #a4-2ass ! - Uppercase =
- - Lowercase hd
Test: 617) 555-2145

Options

Type: Etring Accelerator: I_ Spin Increment: I 1

[~ Required [ spin Contral Spin Range
[ AutoSkip [T Code Table i
[~ Use Format I~ Read Only UEES

[ Focus Rectangle

OF I Cancel | Help |

The pound signs (#) in the Mask box are placeholders for numbers. Only
numbers 0 through 9 can be entered in each of these positions.
Parentheses, the hyphen, and the space are where you want them to
display. When you type a telephone number in the Test box, you can see
the effects of the edit mask.

Click OK to accept the definition of the Edit Mask edit style named
TelephoneNumberl.

InfoM aker addsthe TelephoneNumber1 edit styleto the extended attribute
system tables in the database and lists it as one of the available edit styles
in the Extended Attributes view.

Select File>Save from the menubar.
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6 Display the pop-up menu for the phone column and select Properties.

=-E] contacti ;I [#-<0> Display Formats
B3 Columns =<3 Edit Styles
e id ] #aees
last_name ] #ae-pa-raee
first_name ] e, 2a2.00
title ¥ BenefitsCheckBox
street H Color List
city Customers
skate ¥ Day Care
zip - E oojmpy
Edit Columm,.  |PIMMTY HH:M: S5
fax Drop Column DM HH: MM 55 FFFFFF
----- [ Foreign Ke DT
----- 7 Indexes Dy HH: PSS
-0 Primary Key DM
----- [ Triggers Etl DOJMMMSYY HH:MM: S5

7 In the Object Details view, click the Edit Style tab, then scroll the list
and select the TelephoneNumberl edit style.

Displayl Yalidation Edit Style 4 [ *

Style Mame:

statusedit -
| T elephonetumber _I

This assigns the TelephoneNumber1 edit style to the phone column. Now
you use the same edit style with the fax column. Once you have created an
edit style, it isavailable for any column.

8 Display the pop-up menu for the fax column and select Properties.

InfoMaker promptsyou to save the changesyou just made in assigning the
TelephoneNumberl edit style to the phone column.

9 Select Yes.
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10

In the Object Details view for the fax column, select the Edit Style tab
and the TelephoneNumberl edit style.
Select File>Save from the menu bar.

4]

QD tabase - 1 Connection: {Active Con

ElE contactt
El-C3 Col

H
-[*] Foreign Keys
[ Indexes
-1 Primary Key
(] Triggers
- customer

-5 department >
|

m
[El-<3> Edit Styles

tion - EAS Demo DB ¥105)

Display Formats

fETr e
[T Ty
00
- [¥ BenefitsCheckBo:x
' Colar List
Custamers

¥ Day Care

DOMM{TY

DDJMM{¥Y HH:MM:SS
DOMM{YY HH:MM:SS:FFFFFF
DOjMMYYYY
DOMMTYYY HHMMSS
DOjMMM[Y
DDMMMJYY HH:MM: S5
DODY
DODYY HHMM 55
DDDYYYY
DDDYYYY HH:MM:SS
Departrment List

Dollars with cents -
Object LayoutXExtendad Attributes

Telephonehumber -

Telephonehumberl
ZipCode
ZipCode _Shart

Now you have finished extending the definitions of your columns. Next you
add data to the table.
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Add data to the table

Getting Started

Where you are

Create the database table

Define extended attribute information
> Add data to the table

To add datato your table, you import atext file of tab-separated values.
Importing the file quickly adds 60 rows of data.

Typically you create aform to add datato the database. In theform tutorial you
saw how to add data using aform.

1 Display the pop-up menu for contactl and select Edit Data>Grid.

=7 Tables || <> Display Formats
711 bonus )-<B> Edit Styles
= call_track LT eperr
= contact ] #ae-pa-raee
=lE=E ot o .00
E-C7 Coloy MEw ' v BenefitsCheckBox
" Data Pipeline Tabular. ..
- Freeform...
b Aler Table... — —
s Drop Table 4] DO HH:MM: S5
C (4] DOJMM Y HH:MM: S5:FFFFF
. Add ko Layout 1] oM
©  Print Definition|FL) COMMM{YYY HH:MM:SS
F Export Synkax E:l DD{MMMYY
4] DOMMMPYY HH:MM: S5
----- (1 Fore  Properties ERE I
----- [ Indexes ~[T =] DoDfvY HH:MM:SS

The Results view shows column headers but no data. This view lets you
view, add, modify, and delete data.

o Fax [ DOfMMEeYY HHMM:SS
(1 Foreign Key g
-1 Indexes
"3 Primary ke bbjéct Layadt Extended Attributes
L[] Triggers

|
R esults

- customer

-EEl department
‘E& employee

‘= exam_xref _infc

) esam_wref _list ~| 4] 4
| 3 150L Session yColumns yResulks

Last Name First Mame Job Role

2  Select Rows>Import from the menu bar.

The Select Import File dialog box displays. You might need to change to
the Tutorial folder, which contains the file you use.
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3 If necessary, change to the Tutorial folder.
Double-click the contact.txt file.

InfoMaker imports the datainto the Results view (the datais not yet in the
database).

Id Last Name First Mame Job Role i’
il Hildebrand Jane Marketing 12
2 Simmon Larry Sales 3¢
3 Critch Susan Praduct development 44
Kl | LI_I

4  Select Rows>Update from the menu bar.

This adds 60 rows of datato the database. To be sure that the dataisin the
database, you retrieve it from the database.

5 Select Rows>Retrieve from the menu bar.

InfoMaker retrieves al the contact datafrom the database and displaysthe
datain the Results view.

6 Select File>Close from the menu bar.
This closes the Database painter.

You have created a new database table, complete with extended attribute
information and data.
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A query isaSQL SELECT statement created with the Query painter and
saved with a name so that it can be used repeatedly to define data
requirements. A SQL SELECT statement is the way you tell the DBMS
exactly which rows and columns to retrieve.

Queries save time because you can use them to define all your data
retrieval needs. For example, you can specify the columns and rows to
select, aswell as the sorting requirements. Then you specify the query as
the data source whenever you create forms and reports that use the data
the query isintended to retrieve.

How long does this tutorial take?
About 15 minutes.

About the query

The query you createretrievesfinancial data. When you have finished, the
query returns data from the database that is similar to this.

Year Quarter Type Description o

1897 03 ExpEnsE R&D

1997 04 ExpEnsE R&D

1957 1 ERpENSE Sales & Marketing

1897 Q2 ERpENSE Sales & Marketing

1897 03 ERpENSE Sales & Marketing

1997 04 ERpENSE Sales & Marketing

1957 1 ERpENSE Services

1897 Q2 ERpENSE Services

1897 03 ERpENSE Services

1997 04 ERpENSE Services A
| | »

Thefinancial datais stored in two tables: the fin_data and fin_code tables.
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Thefollowingillustration showsthe two tableswith some data. The code value
in the fin_data table gets its meaning from the fin_code table.

Year Quarter Code Amount in thousands =

1997 @t 2 1833
1997 62 el 204
1997 02 =2 375
1997 02 &3 4500
1997 02 =4 1472
w02 b s
1397 uz@

1937 Q2 12
1937 Q3 el

1937 Q3 e 984
1937 Q3 [=x} 4532
1937 Q3 ed 1433
1937 Q3 956
1937 Q3 13567
1937 Q3 12 2837
1937 04 el 21
1937 04 e 352
1937 04 [=x} 5238

|Ready |Rows B Yy

Code Type Description
el ExpEnsE Fees

el ExpEnsE Services

el ExpEnsE Sales & Marketing

ed ExpEnsE R&D

=] EHpEnse Adminiztration

1 Tevenue Fees vl

2 Tevenue Services

K »
+ i Calumns} Fresults £ 3

|Ready #Rows 1=2d: 7 [ i

For example, the rl circled in the fin_data table means the row reports a

revenue amount for fees.
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Select columns

Getting Started

Where you are

> Select columns
Save the query
Specify row selection criteria
Specify sorting for the rows
Create a report using the query

1 Click the New button in the PowerBar.

tutor_im.pbl - InfoMaker

File Tools ‘Window Help

(=5 B o= B o= B B
'| Open Preview el Lib Lib List To-DolList  Library DE Prof  Database Exit

The New dialog box displays.

2 Select the Database tab and the Query icon.
Click OK.

Library I Object Ml |

8 B %

Database Painte! Data Pipeline

[0]4 I Cancel
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InfoMaker connects to the database, and the Select Tables dialog box

., tutor_im.pbl - InfoMaker e

File Wiew Design Tools Window Help

displays. In this dialog box you can select one or more tables to use.

=10l x]

b = B B =

e 8

Raw Open  Praview  Sellib  Liblist Te-Dolizt Library DEProf Dambaze  Exit

B B ¥ & x

Swa  Tablee  Join  Proview  Close

Selection List: 4] | ]

?untitled - Query |

=101

Select Tables

b

bonus
call_track.
conkack
contackl
customer
department
employee
exam_xref_info
exarn_xref_ist
examples

4 examples_categories_list
fin code

DrsaiEd i I show system tables

= Open
j MNEW, .\,
Cancel

Help

=

Sork gWhere 4Group AHaving jCompute aSynkax

|Ready

You are going to use two of the tables.

Click the tables named fin_code and fin_data.

employes ;I
exam_xref_info
exam_xref _list

examples
examples_categories lisk

ink
messages
ole

prinker
oroduct LI

™ show system tables

x|

Open |
Tew, .. |
Cancel |

Help |
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Getting Started

4

Click Open.

Thefin_code and fin_data tables display. Both tables have a code column.
The tables are joined on the code column.

[ Table Layout

Selection List: o1 | ]
fin_rode fin_data ;

code wear =
bvpe quatker

descripkion code

arnounk

ol o

Thefin_data table hasacode valuein each row to indicate what the row of
data appliesto (for example, r1 means revenue from fees).

The fin_code table stores information about codes, including the actual
values (such asr1 and ed), thetype of each code (revenue or expense), and
adescription of each code.

Next you select columns from the tables.
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Click year in the fin_data table.

Click quarter in the fin_data table.
Click amount in the fin_data table.
Click type in the fin_code table.

Click description in the fin_code table.

When you click each column, it is highlighted in the table and added to the
selection list above the tables.

\'tutor_im.pbl - InfoMaker =10] x|
File W“iew Design Tools Window Help

& o B = F = F 6

reviow  Sellib  Liblist To-Dolist Library DB Prof Database  Exit

b

amount

Drag and drop columns in the order in which you want
"fin_code", "code”

"fin_cade"."type"

"fin_cade", "description”

"fin_data"."year"

"fin_data"."quarter"

"fin_data"."code"

"fin_data","amount”

Y T ) T B 2 A

[select display columns A
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Lesson 5 Query Tutorial

6 Select Design>Preview from the menu bar.

You can see the results of your query. InfoMaker uses your query asit is
currently defined to access the database and retrieve data.

{i'tutor_im.pbl - InfoMaker :-- ; =10l x|
File Edit Design Rows Tools Window Help
e B Bom B o=mog 8 Wk
Mew  Opsn  Praview  Sollib  Lblic To-Dolict Library DBFProf Datsbace  Exit
=2 (1] < b= = L=l x
Ratrieea  Firct Prior  Naxt Lact Print  Clozs
H 50L Preview i alglzl
Year Quarter Amount in thousands Type Description -
1935 M 107 expense Fees
1995 02 93 expense Fees
1995 03 129 expense Fees
1995 04 145 erpense Fees
1996 01 153 expense Fees
1936 02 149 expense Fees
1936 03 157 expense Fees
1996 04 163 expense Fees
1937 1 198 expense Fees
1997 02 204 erpense Fees
1997 Q3 214 expense Fees
1937 04 231 expense Fees
1935 M 403 erpense Services
1995 02 459 expense Services
1995 03 B4 expense Services
1995 04 E32 erpense Services
1996 01 E43expense Services
1936 02 B87 expense Services _l
|Ready |Rows 1 to 18 of 84 7

7 Usethe scroll bar to view the data.

Each row has either the word expense or the word revenue in the Type
column. First you save the query and then you use the value in the Type
column to select rows for the query.

8 Select File>Close from the menu bar.

You return to the workspace.
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Save the query

Save the query

Where you are
Select columns

> Save the query
Specify row selection criteria
Specify sorting for the rows
Create a report using the query

Now you save the query and giveit a name.

1 Make sure you are back in the workspace.
Select File>Save from the menu bar.

The Save Query dialog box displayswith the pointer positioned for you to
type aname for the query.

2 Type g_expenses.

x|
Queries:
QK
[a_swpenses [ o |
what_your_customers_are_ordering Cancel |
Help |
Comments:
El
E
Library:
C:YProgram Files\SvbaselInfoMaker 10.5\tutorialitutar im.
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Getting Started

3

4

Click in the Comments box and type This query retrieves financial data
from the fin_data and fin_code tables. The query selects expense rows and

sorts rows by year, description, and quarter.

x|
Queries:
QK
[a_swpenses [ o |
what_your_customers_are_ordering Cancel |
Help |
Comments:

This query retrieves financial data from the fin_data and ;I
fin_code tables, The query selects expense rows and
sorks rows by year, description, and quarter, LI

Library:

C:\Program Fil

Press OK.

InfoMaker saves your query.

133



Specify row selection criteria

Specify row selection criteria

Where you are
Select columns
Save the query

> Specify row selection criteria
Specify sorting for the rows
Create a report using the query

Now you select the rows to include in the query. To do this you specify
selection criteria

The query you are creating is for expenses, so the rows you need are those
whose type is expense. You do not need the rows whose typeis revenue.

1 Click the Where tab at the bottom of the workspace if it is not in front.

The Where tab comes to the front. In the Where tab you specify selection
criteriafor retrieving rows.

ﬁq_expenses - Query

=
[ Table Layout

SelectionList: 1|+ l[year][quarter ] [amount | [tvpe | [description

Ler

-

IH_| »

Calumn | Cperator | alue | Logical |

G Y T T e ey e
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Getting Started

2

Click the first space under Column and then click the arrow to display
a list of columns.
Click the column named "fin_code"."type" in the list of columns.

arnounk

A 3

m]
Column | Operator | Yalue | Logical

"fin_code","type"

T Y T e e ey |

The equal sign (=) displays by default in the Operator box. Thisis what
you want.

Move the pointer over the Value box.
Press the right mouse button to display the pop-up menu.
Select Value.

Coluran | Operator | Yalue | Logical

"fin_code". "type"

Columns, ..

Functions...
Arguments., .

Select...

Clear
Insett Clause

Sort yirhere AGroUp yHaving 4CompUEe 4oyntax A Delste Clause _

When you select Value, InNfoM aker liststhevauesinthe"fin_code"."type"
column, which are expense and revenue.

Type

revenue
Cancel |
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Specify row selection criteria

4  Select expense and click the Paste button.

The selection criteria are complete. Notice that the value expense is
surrounded with single quotes. These are required. If you type the value
here rather than choosing it, you need to type the single quotes.

Calurnn | Operator | alug | Logical

|"fin_c:0de"."type" |— |'expense|

iSorth’here Group , Having s Compute & Suntay

Notice that the Logical box displays at the end of the line. This box isfor
choosing alogical connector such as AND so you can specify more than
one selection requirement. You do not need to use this box for this query.

5 Select Design>Preview from the menu bar.
Use the scroll bar to view the data.

Now all rows have expense in the Type column. Rows with revenuein the
Type column are not retrieved.

loi
Fle Edt Design Rows Tools Window Help
= B B o= B = B 8 R
Wew  Open  Provier  Sdlb  Liblix ToDolist Ubrorg DBFrof Dsmbsse  Exit
o o 4 B OBl E X
Ratriove Fit  Pror  Met Lt Pim Cles
~181x|
Year Quarter Amount in thousands  Type Description -
1335 01 101 experse  Fees
1395 02 93experse  Fees
1335 03 129emperse  Fees
1395 04 145emperse  Fees
133 01 153emperse  Fees
13% 02 143emperse  Fees
13% 03 157 experse Fees
139 04 163enperse  Fees
1397 01 198emperse  Fees
1397 02 204ewperse  Fees
1397 03 Zldewperse  Fees
1397 04 231 ewperse Fees
1335 01 403ewpense  Services
1395 02 453enpense  Services
1335 03 E03espense  Services
1395 04 632ewpense  Services
133 01 G43ewpense  Services
13% 02 687 ewpense  Services B
[Ready [Rows 1 to 18 of 60 A

6 Select File>Close from the menu bar.

You return to the workspace.
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Specify sorting for the rows

Getting Started

Where you are
Select columns
Save the query
Specify row selection criteria

> Specify sorting for the rows

Create a report using the query

Now you specify sorting for the rows. When you specify sorting, you also
enable grouping. Before you can define a group, the rows have to be sorted so
that the data can be grouped.

1

Click the Sort tab at the bottom of the workspace.

The Sort tab comes to the front. In the Sort tab, you specify one or more
columns to use for sorting the rows.

Dirag and drop columns in the order that you want them
"fin_code","code”

"fin_code","type"

"fin_code","description”

"fin_data"."year"

"fin_data"."quarter"

"fin_data"."code"

“fin data","amount”

Scroll the list as needed to drag and drop column names.

Drag and drop "fin_data"."year" from the left box to the right box.
Drag and drop "fin_code"."description" from the left box to the right box.
Drag and drop "fin_data"."quarter" from the left box to the right box.

Inall cases Ascending is what you want. Ascending means years and
quarters are ordered by increasing values and descriptions are
alphabetized from A to Z.

Dirag and drop columns in the order that you want them

"fin_code","code" “fin_data".""year" v Ascending
"fin_code","type" "fin_code"."description” v Azcending
"fin_code","description” "fin_data"."quarter" v Ascending

"fin_data""year"
"fin_data"."quarter"
"fin_data"."code"
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Specify sorting for the rows

138

Select Design>Preview from the menu bar.
Use the scroll bar to view the data.

First the rows are sorted by year. All the 1995 information is first. Then
they are sorted by description so that expenses of the same category are
together. Finally the rows are sorted by quarter so that the datais always

time-sequenced.

Jtutor_im.pbl - InfoMaker =lal x|
File Edit Design Rows Tools Window Help
M e B B & B = 8 8 B
New Open  Preview  Sellib  Liblist To-Dolist Lbrary DEProf Datsbaze  Exit
£ I 4 B 2] = x
Rotrieve  First Prior Hlext Lazt Print  Clazc
B 50L Preview 2 o) x|
‘Year Quarter Amount in thousands Type Description -
1335 01 381 expense Administration
1935 02 402 expense Administration
1995 03 412 expense AL drministration
1935 04 4E7 expense Administration
1935 M 101 expense Fees
1995 02 93 expense Fees
19385 03 129 expense Fees
1935 04 145 expense Fees
1995 o B23 expense R&D
193985 02 784 expense R&D
1935 03 956 expense R&D
1995 04 1043 expense R&D
1335 01 1437 expense Sales & Marketing
1935 02 2033 expense Sales & Marketing
1995 03 2194 expense Sales & Marketing
1935 04 2145 expense Sales & Marketing
1935 M 403 expense Services
1995 02 459 expense Services
El
|Ready |Rows 1 to 18 of 60 |

Select File>Close from the menu bar.

You return to the workspace.

Select File>Close from the menu bar.
If prompted to save changes, click Yes.

The Query painter closes.
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Create areport using the query

Where you are
Select columns
Save the query
Specify row selection criteria
Specify sorting for the rows
> Create a report using the query

Now you use the query to create a new report.

1 Click the New button in the PowerBar.
Select the Object tab.
Select the Tabular presentation style.

Click OK.
X
0 B & &
Farm Composite Crosstab Freeform Graph
=E
Grid Label QLEZ2.0
RichText Treetiew
[8]4 I Cancel

The wizard for creating tabular reports displays.
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Create a report using the query

2  Select the Query data source.
Make sure the Retrieve on Preview check box is selected and click
Next.

i Tabular Report Generator 21xl

‘which data source would you like o use?

Quick Select  SGQL Select External

CIIEry

&

Stored
Procedure

v Retrieve on Preview

< Back. | Mext = I Cancel |

The Select Query dialog box displays. In this dialog box you specify the
query to use. You are going to use the query you just created as the data
source.

3 Click the button to the right of the Specify Query box.

Specify Query:

< Back Mext = Cancel
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Getting Started

The Open dialog box displays.

x|
ok |

[jsenescsnnnnnnnnass

what_your_customers_are_ordering

H

Comments:

This query retrieves financial data from the fin_data ;I
and fin_code tables, The query selects expense rows
and sorts rows by year, description, and quarter, LI

Library:

1 |

Object Type:

Ii@‘ Queties j

Cancel |
Help |

Click g_expenses and click OK.

The query g_expenses displays in the Specify Query box.

Specify Query:

2|

Iq_expenses

< Back Mext =

Cancel
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Create a report using the query

142

5

Click Next.

The Select Color and Border Setting dia og box displays. You are going to

accept the defaults.

i Select Color and Border Settings : 21xl

Select color and border options For your report:

Background Color:

Text
Colar: I-Window Text bt
Border: I MoBorder hd
r Columns
Calar: I-Window Text bt
Border: I MoBorder hd

[ Save as default

< Back | Mext = I Cancel

Click Next.
A dialog box summarizing al your specifications displays.

Look over your specifications and then click Finish.

Your report displays in the Report painter. Thisisthe Design

esign - (untitled)
Year Quarter Amount in thousands Type Description

view.

Header t

fin_dat:fin_d. fin_data_ fin_code_typefin_code_description

Detail
Summary {
Footer

S
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Lesson 5 Query Tutorial

Getting Started

InfoMaker uses the query you created to retrieve data from the database.
Because the query includes selection criteriaand sorting requirements, the
database returns only the data you selected, in the sort order you specified.
Here isthe report in the Preview view.

Year Quarter Amount in thousands Type Description

1935 a1 3 ERpENSE Adminizgtration

1995 Q2 402 ERpENSE Adminizgtration I

1995 (3 412 ERpENSE Adminizgtration

1995 (4 467 ERpENSE Adminizgtration

1935 a1 1m ExpEnsE Fees

1995 Q2 93 ExpEnsE Fees

1995 (3 129 ExpEnsE Fees

1995 (4 145 ExpEnsE Fees

1935 a1 EZ23 ExpEnsE R&D

1995 Q2 a4 ExpEnsE R&D

1995 (3 856 ExpEnsE R&D

1995 (4 1043 ExpEnsE R&D

1935 a1 1437 ERpENSE Sales & Marketing

1995 Q2 2033 ERpENSE Sales & Marketing

1995 (3 2184 ERpENSE Sales & Marketing

1995 (4 2145 ERpENSE Sales & Marketing

1935 a1 403 ERpENSE Services

1995 Q2 455 ExpEnsE Services -
¥ | v

At thispoint you could continue designing and improving your report, but
for thistutorial, you leave the Report painter now. You do not save the
report.

Select File>Close from the menu bar.
This Message Box displaysto seeif you want to save your report.

Save changes to
[Untitled)?

Click No.

The Report painter closes.
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Create a report using the query
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LESSON 6

Getting Started

Graph Tutorial

Graphs present datain avisual way so that you caninterpret it moreeasily.
You can use graphs to supplement the numbers in areport or you can
replace numbers with a graph. InfoMaker provides a variety of graph
styles and options.

The graph you create in thistutorial usesfinancia data (the same data as
the Query tutorial). You start with areport that is already created and add
agraph to the report. When you have finished, the report and the graph

look likethis:

B Report - expenses_graph

[_ D[]

Administration

a2
Q3
Q4

a1
Qz
a3
Q4

Expenses for 1995

Amount

3/19/98

Page 1 of 3

in thousands Expense Breakdown

=
402

412 B Administration
BT [ Fees
e M RaD
1662 [ Sales & Marketing
O services

101

93
129
145

13.71%

50.85%

10.34%

AR5

How long does this tutorial take?
About 30 minutes.
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Open the report to contain the graph

Open the report to contain the graph

Where you are
> Open the report to contain the graph
Create the basic graph
Save the graph (report)
Enhance the graph
Print the graph (report)

First you open areport that has been created for you. This report provides the
data for your graph.

1 Click the Open button in the PowerBar.

File ToolsMow Help

“ Mew Open review Fel Lib Lib List Te-DolList  Library DE Prof  Databasz, Exit

The Open dialog box displays. It lists objects in the current library
(tutor_im). You will be using the report named expenses.

2 Select the Reports object type at the bottom of the dialog box.
Click expenses (scroll the list).
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Getting Started

Click OK.

x|

Objeck: oK I
Expenses
P Cancel |
emp_nup_salary_benefits ;I

emp_telephone_attributes
emp_total_compensation
d

tabular__orders j

Comments:
Tutorial: Used For tutorial, Expenses for years ;I
1995-1997
E
Library:

1 |

Object Type:

Feports j

Help |

The report displays in the Report painter. Here isthe Design view.

Design - expenses

FOUTETN DU TS IFTUTNTN DI DT DNUY DUT DUUN TS DTN DTN DTN TN D0 DI DI D SUUR DU BTN DTS, INTU TN DO

moeunt
in theusands

oday() ﬂ

Header 1
- Header group year T
3 Weseription
_ [2: Header group description T
b huaﬂ moun
_ [Detsil £
E| urria

2: Trailer group description t

- Trailer group year T

Summary T

Footer t

KT
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Open the report to contain the graph

148

Look at the Preview view.

InfoMaker retrieves information from the database and displays as much
asfits on the screen.

N N R A R RN RN AN A R AL RN RN AN AR e

Administration

Q2
Q3
Q4

Q1
Q2
Q3
04

Amount
in thousands

381
402
412
467

1662

m

93
129
145

468

Expenses for 1995

2117199
Page 10f 3

B

Use the scroll bar on the right edge of the report to see more data.

The entire report consists of three pages: one for 1995, one for 1996, and
onefor 1997.
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Lesson 6 Graph Tutorial

Create the basic graph

Where you are

Open the report to contain the graph
> Create the basic graph
Save the graph (report)
Enhance the graph
Print the graph (report)

The report you are working with has three pages, one for each of three years.
The graph you create will be on al three pages. Its format will look the same

from page to page, but the data will be for the correct year for each page.

Thisiswhat a graph for 1995 looks like. It shows the year’s expensesin five

categories.

& Report - expenses_graph

Administration
o1
Q2
a3
Q4

Q1
a2
Q3
Q4

Amount
in thousands

381
402
412
467

1662

1m

93
129
145

468

3/19/98
Expenses for 1995 Page 1 0f3

(None)

Administratio Fees RE&D Sales &Mark Services
(None)

1 Select Insert>Control>Graph from the menu bar.

Getting Started
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Create the basic graph

Click in the middle of the Design view.

The Graph Data dialog box displays.

Graph Data [ %]
Eows:IAII 'l : ;
Lategory: j Cancel |
Walue: j
r §eries| j
Type: - IHand]
¥ E .
Area Bar i
gISG
Line
b A :} c o E
Catego
T + LI gory
Sample Graph

2 Click the down arrow on the Rows box.

The drop-down list shows choices for rows.

Graph Data [ %]
Bows:IAII ﬂ
LCategony: Group‘l; j Cancel |
Walue:| Group 2 7 j
r §eries| j
Type: - Hand)
¥ E .
Area Bar i
gISG
Line
b A :} c o E
Catego
T .. LI gory
Sample Graph

The All option includes all rowsin the graph. Since you want to have the
appropriate graph for each of three years, you do not want to include all
rows in the graph at the same time.

The Group 1 option includesthe rowsfor the current Group 1. Group 1 for
this report is grouping by year, so Group 1 is what you want. When you
specify Group 1, you ensure that the graph includes only rows from the
current year.
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Lesson 6 Graph Tutorial

3 Select Group 1.

Next you fill in the Category and Value boxes. The graph will show
expenses for the year by type of expense. (For this graph you do not need
to fill in the Series box.)

The description column provides the categories (Administration, Fees,
R&D, Sales & Marketing, Services).

The sum of the amounts for the four quarters for each category provides

the values.
T T T N T T N T N T T e
201799
Expenses for 1995 Page 1 of 3
Amount
in thousands
Administration
a1 381
a2 402
a3 412
Q4 467
1662
Fees
o 101
a2 93
a3 129
Q4 145
468 lj
Kl 1l

4  Click the down arrow next to the Category box.

A drop-down list displays the columns you can choose to supply the
categories to use in the graph. (You can think of categories as X values.)

Graph Data [ %]
Bows:lﬁroup'l 'l
Lategory: j Cancel |
Walygs| amount
- deszcription
[ Seties | quarter
type
Tupe: year ]
= =
Area Bar i
gISG
g g 15 E Ewo
S
Line
[
A :} c o E
Category
— : =
Sample Graph
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Create the basic graph

152

8

Select description.

This specifies that the values in the description column are the categories.

Click the down arrow next to the Value box.

A drop-down list displays all the choices for the column to supply the
valuesto useinthegraph. Noticethat the choicesinclude expressions such

as counts and sums.

Graph Data [ %]
Bows:l Group 1 ¥ l

Lategony: | description Cancel |

Walue:

[~ Serigg |amount
= count[description for graph)

Type:| count{quarter for araph)
counttype for graph)
count[year for graph)
deszcription

quarter

surmlamaunt for graph)]
type

[+ el

Category

Sample Graph

Select sum(amount for graph).

This specifies that the sum of the amount column isthe value. A separate

valueis calculated for each category within each year.

Graph Data [ %]
Qategory:ldescription j Cancel |
ST s urn( amnount for graph] j
r §eries| j
Tupe: - {Hang)
¥ E -
Area Bar s
gISG
l f E Rl
S
Line
b A :} c o E
Category
— : =

Sample Graph

Click OK.
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Getting Started

The graph displaysin the report. What you see in the Design view isa
representation of the graph. To see what it looks like in the report, you
need to look at it in the Preview view.

Design - expenses

I IETT IS ST R

n

[x]
i flaa

OTTETN IUNIVE. INTU TN DEIE D T DU I
Expenses fo

moeunt

in theusands

1
oday() ﬂl

: /__—._._\
Header 1
1: Header group year 1 yd
3 Weseriptfon. LI P / o
__[2: Header group description t 1
4 huaﬂ Mo l
_ [Detsil £ |
] \
N,

2: Trailer group description t
ar 1

rouj

- Trailer

Footer t

KT

Look at the graph in the Preview view.

In the Preview view, InfoMaker displays the data retrieved from the

database both in the report and in the graph. The graph is small right now.
In afew minutes, you will resizeit.

Preview - expenses [=]
T S I IO NN DT TR IS IO DT TN ST SOOI IS T T I =

o

4 201799

3 Expenses for 1995 Page 1 of 3

3 Amount

| in thousands

3 Administration

= o 331

- o2 402

3 o3 412

o Q4 467 i

E 1862

27 Fees

4 o 101

= o2 93

- a3 129

| Q4 145

47 468 -

Bl | v
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Save the graph (report)

Save the graph (report)

Where you are
Open the report to contain the graph
Create the basic graph
> Save the graph (report)
Enhance the graph
Print the graph (report)

Now you save the graph. The graph is part of the report, so to save the graph,
you savethereport that containsit. To leave the original report unchanged, you
will use the Save As command. Save As saves anew report with the name you

supply.

1 Select File>Save As from the menu bar.

The Save Report dialog box displays; the name of the report you opened
earlier is highlighted.

Reports:
= P — QK
atkrib_birthdays ﬂ Cancel
attrib_crossout_and_visible
attrib_escapement_rotation Help
attrib_font_height
attrib_format
attrib_graybar_emp_total_comp LI

Comments:

Lo b \_\_Il5

Library:

nfolMaker 10,5 tutorialitutar im.phil

2 Type expenses_graph.
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Lesson 6 Graph Tutorial

3 Click in the Comments box and type This report summarizes expense
data for 1995, 1996, 1997. It includes graphs as well as numeric data.

Ix

Reports:
=1
expenses_graph
atkrib_birthdays ﬂ Cancel |

attrib_crossout_and_visible

attrib_escapement_rotation Help |
attrib_font_height

attrib_format

attrib_graybar_emp_total_comp LI

Comments:

This report summarizes expense data for 1995, 1996,
1997, It includes graphs as well as numeric data,

K

Library:

4  Press Enter.

InfoMaker saves your report, including the graph.
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Enhance the graph

Enhance the graph

Where you are
Open the report to contain the graph
Create the basic graph
Save the graph (report)
> Enhance the graph
Print the graph (report)

To enhance the graph, you:
* Resize and reposition it
* Addatitle

»  Change graph types

Resize and reposition the graph

Usually you work in the Design view when enhancing areport or graph, but to
resize and reposition agraph, youmay find it easier towork onitinthe Preview
view. You can get a much better idea of what the page looks like. The sizing
and positioning changes you make are retained and reflected in the Design
view.

1 Resize and reposition the graph so that it looks like the one shown

here.
R R AN RN AR AN RN RN AR AN AR AL NN RN

o

4 2117199
3 Expenses for 1995 Page 1 0f 3
3 Amount

£ in thousands

3 L {None)

3 Administration a0

i o1 381

= oz 402

4 Q3 412 0o

E a4 467 =

3 1852 o

29 Fees 0.

4 o m

E a2 93

— a3 123 ° Adminfs mtian Fam. R&D  Saks i Marse  Servioss

4 Q4 1458 (Ham)

473 468 -
gl | v
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Add a title

To make the graph bigger, put the pointer near a corner or aside until the
pointer changes shape. Then press the left mouse button and drag the
corner or the side. To move the graph, put the pointer in the middle of the
graph. Then press the left mouse button and drag the graph.

Use the scroll bar to display the graphs for 1996 and 1997.

Move the pointer to the middle of the graph in the Design view (not the
Preview view) and click.

This selects the graph. The current title, (None), displays on the graph, in
the text box in the StyleBar, and in the Properties view.

Type Expense Breakdown.

Thetitle displaysin the graph and in the text box.

Design - expenses_giaph
FUTTETN DT IETUTNTN DI DT DAUE DT DUUN DU SUTE DTN BTN TS DU DN DI D DUTE DUT TR TS| IO 01

] 3
: .mnunt
17 En' i .

Header Expense Breakdown
1-_Header group year {

|2 Header group description T

huaﬂ Emnun

_ [Dekail £

¢
tHan)

e o

Change the graph type

Getting Started

You can use many different types of graphs to present the same data.
Sometimesit is useful to try different types until you find the one that works
best for the data you are presenting.

Now you try several graph types with the expense data.
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Enhance the graph

158

If you need to, use the scroll bar to display the entire graph in the

Design view.

Move the pointer to the graph in Design view and click it.

The graph is selected. The properties for the graph display in the
Properties view, with the General page on top. On this page you can
choose a graph type. The current graph type is Column (Col (7)).

—
[®]Properties - ar_1
General |P0inter | Position | other | Data | axis | Text |

Title =
| Expense Breakdown —_

Mame
| gr_1
Tag

|
[ HideSnaked

v wisible

Border

I MoBorder {0}

Text Color

I-Window Text
BackColor

I:Window Backaround
ShadeCalor

IGraphType
| Il <ol (7)
Legend
|Battom ¢4}
Perspective
Elexation -

s

L
s

L«

L«

L«

Lo

L«
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Lesson 6 Graph Tutorial

Getting Started

3

4

Select the Bar (2) graph type from the Graph Type drop-down list.

[®]Properties - ar_1
General |P0inter | Position | other | Data | axis | Text |

Title

| Expense Breakdown
Mame

| gr_1
Tag

[ HideSnaked
v wisible
Border

s

I MoBorder {0}

Text Color

L
s

I I indow Text
BackColor

L«

I [ Iwindow Backaround
ShadeCalor

L«

GraphType

L«

I E Bar (2}

Legend

Lo

|Battom ¢4}
Perspective

L«

Elexation

-

The graph looks like thisin the Preview view.

Expense Breakdown

Sarvions
Sakes & Martating

R&D

(Mone)

Fagz:

Adm infsLratian.

0 i} ) o)
(Hang)

o

Select the Pie (13) graph type from the Graph Type drop-down list.
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Enhance the graph

InfoMaker redisplays the graph using the Pie style.

Expense Breakdown

171% 108k

Sdmintiratian
Fas

R&D

Sakes & Martating

Benvioas

min] Jujr|

WA

Pie seemsto be a good style for showing the data, so you do not change
the graph style again.

Thisiswhat the report with the graph looks like now.

Preview - expenses_graph

[x]

RSN NN N INE T N NI T I NPT NI I IV I NN T =

a5

4 2117199
3 Expenses for 1995 Page 10f 3
1

3 Amount

3 in thousands

E . . Expense Breakdown

3 Administration

e al 381 GRS toak

= oz 402 A

4 Q3 412

Bl sminiion

i Qi 467 E ree

3 1662 L arsm

4 [ [ EAT—

:q Fees O sevice:

4 o m

E a2 93

4 Q3 129 e

4 Q4 1458
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Lesson 6 Graph Tutorial

Print the graph (report)

Where you are
Open the report to contain the graph
Create the basic graph
Save the graph (report)
Enhance the graph
> Print the graph (report)

1 Click the Preview view to make sure that it is current.
Select File>Print Report from the menu bar.

The Print dialog box displays.

Frinter: Doc printer || MT on YsprintfarmB41bb
Page Range Cancel |
& Al Frinter... |
" Curent Page e
" Pages: I LI
Enter page numbers and/or page ranges Print ta Fil
separated by commas. For example, 2.5,8-10 B Frt e

IV Collate Copies
Frint:  [All Pages in Range j

2 Click OK to accept the defaults and print the report.

Your report goes to the printer or the print queue.

3 Select File>Close from the menu bar.

If you have not saved all your changes, a message box displays to see if
you want to save changes.

4  Click Yes (if the message box displays).

The Report painter closes.
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Print the graph (report)
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LESSON 7 Environment Tutorial

You use the Library painter to manage forms, reports, queries, pipelines,
and the InfoMaker environment. In the Library painter you can:

e Open aform, report, query, or pipeline, and go automatically to the
appropriate painter

e Setthecurrent library
«  Copy, move, and delete forms, reports, queries, and pipelines

In thistutorial you learn how to do these tasks.

How long does this tutorial take?
About 30 minutes.
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Open forms, reports, and queries

Open forms, reports, and queries

164

Where you are
> Open forms, reports, and queries
Create a new library
Copy forms, reports, and queries
Create a new report from an existing one

First you learn about using the Library painter to open forms, reports, and
queries. When you open one of these, you automatically go to the appropriate
painter. (Thisis also true for pipelines, but you do not work with pipelinesin
thistutorial.)

If you have not installed the Form painter
A few of the stepsin thistutorial and the next onerefer to forms. Just skip those

steps. You can do the tutorials without the forms.

1 Click the Library button in the PowerBar.

4/tutor_im.pbl - InfoMaker
File Tools ‘Window Help

“fﬁ oEp:. P =Y -

Mew Teview Fel Lib Lib List  To-Do List NLibrars

The Library painter workspace displays.
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Lesson 7 Environment Tutorial

Getting Started

2

Select View>Most Recent Object from the menu bar.

\tutor_im.pbl - InfoMaker

=10l x|

Flle Wiew Library Enkry Design Tools  Window Help
= = 3 & ; - -
&= B B = B = & B F
New Open  Praview  Sallib  Liblit ToDelist Library DEProf Databaze  Exit
faal =
185 =] i fie il 7] o> ®

Select Al Edit Copy  Move  Delcke  Regen  Properties strecenkok  Close

4

=B tukor_jm.pbl

A8 attrib_birthdays
attrib_crossout_and_visible
attrib_escapement _rotation
attrib_font_height
attrib_Format
attrib_graybar_emp_total_com
attrib_italic
attrib_rotate_emp_tokal_comp
~8] attrib_start_date

attrib_sy

composite_base

composite_produck_sales
composite_products
tomposite_sales_reps
{5 contact_n_up
{5 contactgrid
{8 customers_with_nested_order:

{8 d_dddw_rust
_>l_I

d_dddw_customers
d_dddw_dept
d_dddw_Ffin_code

Modification Date

Compilation Date

emp_labels_pb_column

emp_nup_salary_be...
emp_telephone_attri...
emp_total_compens. ..

EXPENSE:
printer_sales
tabular_orders
B¢ pipe_emp_table_ext...
Fad q_expenses
Fd what _your_custome. .
; cuskomer_details
:, cuskamer_lisk
:, cuskomer_maintenance
:, departments_and_th. .,
:, employes_data

< |

8/5(2003 03:33:09
&/5(2003 03:33:08
&[5(2003 D3:33:08
B[5(2003 D3:33:08
8/5{2003 03:33:09
8/5{2003 03:33:09
8/5{2003 03:33:09
1/5j2006 16:03:15
1/5j2006 16:23:33
8/5(2003 03:33:09
8/5(2003 03:33:09
7312005 20:59. .
1[5j2006 14:42:13
B[5(2003 D3:33:08
12/22}2005 23:2...
12/22}2005 23:2...
12{22}2005 23:2...
122212005 23:2...
122212005 23:2...

1222 }2005 23:26:22
1222 }2005 23:25:23
1222|2005 73:26:23
12/22 2005 73:26:23
12/22}2005 23:28:23
12/22}2005 23:28:23
12/22}2005 23:28:26
1f5/2006 16:03:16
1f5/2006 16:23:33
12/22}2005 23:28:26
1222 }2005 23:26:26
71312005 20:59:00
1/5/2006 14:42:13
/52003 D3:33:08
12/22}2005 23:25:29
12/22}2005 23:28:29
12/22}2005 23:28:28
122212005 23:28:27
12/22 12005 23:28:28

|Ready

Scroll the list to the bottom until you see the form
contact_maintenance, which is the form you created earlier.
Double-click the form.

The painter lists the forms, queries, reports, and pipelinesin the current
library and selects the object you worked on most recently. When you
install InfoMaker, the current library is the InfoMaker sample library
(tutor_im.phl).

Thelist includes many samplesaswell astheform, query, and reportsyou
created earlier.
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Open forms, reports, and queries

The form displays in the Form painter. Accessing your form by
double-clicking its name in the Library painter isthe same as opening the
formin the Form painter.

Layout E3
1d: [oortact i =
_ Add a contact| Delete a contact| Save changesl :I
Last Name: [contact_last_name
First Name: |contact_first_name Id Last Name |First Name Job Role )

Job Role: [comtat_tile |
Street: [contact_stieet
City: [eortact ety |
State: [contact]
Zip: [cortact_ap |
Phone: [cortact_phone |
Fax: [contact_fax |

4  Click the Run button in the PainterBar.

Foun Your form runs.
€ Maintain Contact Information M= E
Id: I
Add a [:unla[:ll Delete a [:unla[:ll Save [:hangesl
Last Name: [Hildebrand

First Name: pane Id | Last Mame First Name Job Role £

Job Role: W 1 Hildebrand — Jane arkeding 1280 i

2 Simmon Larry Sales 34 Grar.

Street: [1280'/ashington St 2 Critch Susan Praduct development 46 Cerr

City: [Emerpille 4 Lambert Terry Administraion 204 Pan

. l— 5 Sullivan Dorothy Customer support 54 Mint

State: [l & Paull Rose Finance T4 Bay

Zip: [34608 7 Glassmann  |Beth Product development 44 Qak

Phone: [[510) 5551303 3 Pawell Gene Training 552 illig

El Fish Jefirey arkeding 6% Red

Fax: |[510) 555-4203 10 Clarke Moly Sales 55 Pine
11 Kelley Mlliam Documentzion 16 Rair =

4| | »

EIG‘ 5 Click the Close button in the PainterBar.

Elozs The running form closes.

6 Select File>Close from the menu bar.

You return to the Library painter. Now you look at some other forms.
7 Double-click the form customer_maintenance.
8 Click the Run button in the PainterBar.

Run
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Lesson 7 Environment Tutorial

Thisform isfor maintaining customer information.

€} Customer Maintenance

~lo| ]

— Customer Infarmation
for

IThe Power Group
IEHM Pioneer Avenue

- pro7o-

Customer D

Company Name

Address

>4

[1/5/2006 City, State, Zip  [Rutherford

~— Contact Infarmation

Contact  |Michaels Devlin

Phone  |(201) 555-8966

9 Click the Close button to return to the Form painter workspace.
Select File>Close from the menu bar to return to the Library painter.

Now you open areport.

10 Double-click the report emp_total_compensation.

The report displays in the Report painter.

11 Scroll the report in the Preview view.

Getting Started

=]
Total Compensation Report | vaue orsearn ins -54300 Pa“;f;;fg;
Salary Plus Benefits Value of life insurance = $5.43 x salang1,000
Valus of day cave = $5,200 o
Department Employee Employee Employee Salary Health Life Day SalaryPlus
D D First Name Last Name Ins. Ins. Care Benefits
100 102 Fran Wihitney §45,700 el F O $50,729
105 Matthew Cobb $62,000 =l F O $67,110
160 Robert 867,400 [
24 Natagha $2:895 o o O,
47 B42.824 W
T4 R Glievara fegHog [ g8
266 Ram Gowda §50,840 - §60,138
278 Terry Melkizetian $48,500 ~ $58,743
a1h Lunn Fastnr £74 A0 7 74 A73 lLI
Kl D7

12 Select File>Close from the menu bar.

The Report painter closes and the Library painter displays.




Create a new library

Create a new library

168

Where you are
Open forms, reports, and queries
> Create a new library
Copy forms, reports, and queries
Create a new report from an existing one

Now you create a new library on a shared drive so that you can copy some
itemsinto the library.

Shared drive
These instructions assume that H:\shared is the shared drive, but you can use

any shared drive on your computer.

InfoMaker uses special librariesto hold forms, reports, queries, and pipelines.
These libraries have the file extension pbl. When you save (or copy or move)
aform, report, query, or pipeling, it goesinto a pbl file (pronounced pibble).

1 Select File>New from the menu bar.

The New dialog box displays.

2  Select the Library tab and click OK.
The Library wizard displays.

3 Type h:\shared\mylib.pbl and click Finish.

InfoMaker creates the new library on the H drive. Thislibrary is now the
current library; its name displaysin InfoMaker’s title bar. The previous
current library still displaysin the Library painter.

InfoMaker



Lesson 7 Environment Tutorial

Copy forms, reports, and queries

Where you are
Open forms, reports, and queries
Create a new library
> Copy forms, reports, and queries
Create a new report from an existing one

Now you copy aform, aquery, and two reportsinto the library on the shared
drive. Then you can make them available to another InfoM aker userswho can
use them as is or modify them as needed.

Remember that the other users must also be able to access the database. All
InfoMaker users have Adaptive Server Anywhere and the contact table. That
means other InfoMaker users can run the form, query, and reports you have
created in thistutorial.

1 Drag tutor_im.pbl from the Tree view in the left pane to the List view
in the right pane.

2 IntheListview of the Library painter, click contactgrid (scroll the listin
the Library painter as necessary).
Press Ctrl and click contacts_by_jobrole.
Press Ctrl and click d_dddw_states.
Press Ctrl and click q_expenses.
Press Ctrl and click contact_maintenance.

The five objects you selected are highlighted. You can copy, move, or
delete them. You are going to copy them to the shared drive.
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Copy forms, reports, and queries

170

Copy

Tip
You can sort the view by modification date to make it easier to locate
objects you have just created or changed.

Thiz report shows my contacts grouped by job role
02/07/200...  Tutorial: Used for Tutorial. Added to a form in the Form painter.

=Nl (2/07/200..  Thiz form updates my contact table.

02/07/200...  This query retrieves financial data from the fin_data and fin_code tables. Tk

| states 02/07/200...  Report for DropDownD atawindow: Grid: State 1D, State Mame, Country
d_dddw_sales_reps 02/07/200...  Report for DropDownD atawindow: Grid: Employes 1D, name
d_dddw_sales_orders  02/07/200..  Report for DropDownD atawindow: Grid: Sales Order 1D, Customer 1D, Ord
d_dddw_products 02/07/200...  Report for DropD ownD atawindow: Product 1D, Product Mame, Product De
d_dddw_fin_code 02/07/200...  Report for DropD ownD atawindow: Financial codes -

| H oz

Why you include the report named d_dddw_states
The contact_maintenance form uses a DropDownDataWindow edit style

for the state column. That edit style usesthe report named d_dddw_states,
which must be present in the library when you run the form.

If you create anew library for objectsyou create using the EAS Demo DB,
you need to copy the eight reports that begin with d_dddw from the
tutor_im.pbl to the new library. These reports go with the
DropDownDataWindow edit stylesthat the tablesin the EAS Demo DB
use.

Thereisaway to make the reports centrally available. See the InfoMaker
User’s Guide.

Click the Copy button in the PainterBar.
The Select Library dialog box displays.

Change drives to the shared drive.
Select mylib.pbl.
Click Open.

InfoMaker copiesthe selected objectsto the shared drive. It takesaminute
or s0. You can see messages about the copying at the bottom of your
screen.
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Lesson 7 Environment Tutorial

5 Navigate to the shared drive.

The Library painter lists the contents of mylib.pbl, the current library.

[ rmylib. pbl in H:yshared

Mame | Modification Date Compilation Date

contackgrid g/5/2003 03:33:08 1/25/2006 22:49:56
contacks_by_jobraole 112602006 13:23:59 1/26/2006 13:23:59
d_dddw_states g/5/2003 03:33:08 1/25/2006 22:49:55
fq);'q_expenses 1)26/2006 17:47:15 1/26/2006 17:47:15

:, contack_maintenance  1/26f2006 11:12:12 1/26/2006 11:12:12

< | i
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Create a new report from an existing one

Create a new report from an existing one

172

Where you are
Open forms, reports, and queries
Create a new library
Copy forms, reports, and queries
> Create a new report from an existing one

Now you create a new report from one of the reports on the shared drive. You
then make a slight modification to the report.

The modification adds powerful options to the report that you can see when
you run the report.

1 Onthe Hdrive, double-click the contactgrid report.

e
B8 rmvlib.pbl in H:\shared
ame | Modification Date Compilation Date
@i:_) &/5/2003 03:35:08 1/25/2006 22:49:56

contacts_by_jobrole 11262006 13:23:59 11262006 13:23:59

d_dddw_states /52003 03:35:08 1/25/2006 22:49:55
l’;);'q_expenses 11262006 17:47:15 11262006 17:47:15
:, contact_maintenance 11262006 11:12:12 11262006 11:12:12

1

(1K1 | ]

You go to the Report painter with the contactgrid report open.

B contactgrid - Report

Id Last Na‘“e' Fim Name' .. JDIJ Rﬂle ........ street ....... [:i-tv .. state . Iip ..... FA
Header {

id - last mame: o frst name cBtle o celreet ety oo cstate i o c phone
Detail 1

Summary {

Footer {
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Lesson 7 Environment Tutorial

Getting Started

Select File>Save As from the menu bar.

The Save Report dialog box displays. You are going to change the name
of the report so that you can keep the old one and create a new one with

some changes.

contacts_by_jobrole
d_dddw_states

Comments:

X
contactgrid Cancel |
=
=

Library:

H:sharedimylib. pbl

Type the name contactgrid_with_prompting and click OK.

The report name changes. You are now working on areport called
contactgrid_with_prompting.

B contactgrid_with_prompting - Report

‘Id-  ‘Last Mame- - First Name - - - - Job Role- - - - - - - - Street- - - - - - City - - - -State: - ‘Fip- -

Header t

Detail t

Summary {

Footer
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Create a new report from an existing one

174

5

6

If the View>Column Specifications view is not already in the lower right
corner of the Report painter, select View > Column Specifications
from the menu bar.

The Column Specifications view displays, listing al the columnsin the
report. You can choose one, many, or all columnsfor prompting. The
columns you choose here let you control what rows are selected when you
run the report.

For example, if you choose the city column here, you can specify a city
when you run the report. Then only rows that include that city are
retrieved.

jon - cont. yith_prompting

_Name Type Prompt |DE Mame

1 |id number [T |conkact.id

2 |last_name |char(15) [~ |contact.last_name

3 [first_name |char{15) | [~ |contactfirst_name

4 [title char(Z) [T |conkact.title

5 |street char(30) [T |contact,skreet

6 |city char(z0) [~ |conkact.city

7 |state char(Z) [T |conkact.state

g [zip char(5) [T |contact.zip

9 |phone char{10) [~ |contact.phone

10 [Fax char{10) [~ |conkact.fax

A % Column Specification - contactgrid_withjrompting‘[m;l

Select all the check boxes.

You are choosing all columns so that you can enter criteriafor any column
you want when you run the report.

B8 Column Specification - contactarid_with_prompting
_Name Type Prompt |DE Mame

1 |id number ¥ |conkact.id

2 |last_name |char(15) ¥ |contact.last_name
3 (first_name |[char{15) ¥ |conkact. first_name
4 [title char(Z) ¥ |conkact. title

5 |street char(30) ¥ |contact,skreet

6 |city char(z0) ¥ |conkact.city

7 |state char(Z) ¥ |contact.state

g [zip char(5) ¥ |contact.zip

9 |phone char{10) ¥ |contact,phone

10 [Fax char{10) [+ |conkact.fax

A % Column Specification - contactgrid_withjrompting‘[m;l

Select Rows>Retrieve from the menu bar.
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Lesson 7 Environment Tutorial

Getting Started

The Specify Retrieval Criteriadialog box displays. Sinceyou said that you
wanted to be prompted for al the columns, the dialog box includes al the
columns.

Specify Retrieval Criteria [ %]
Colurar: |id last_name first_name lile = QK I
Criteria:

o Cancel |
Help |
4] | H

Click in the first cell in the title column.
Use the horizontal scroll bar to move the title column into full view.

A box with an arrow displaysto show thereis a drop-down list for that
column.

Specify Retrieval Criteria [ %]
Columnn: [last_name first_name Litle: /?%{Leet - QK I
Criteria: ( LI )

o AN 4 Cancel |
Help |
kil | ﬂ_l

Click the arrow to open the list.

Select Customer support.

This puts Customer support in thetitle column. This means that the report
is limited to contacts in Customer support.

Specify Retrieval Criteria [ %]
Columnn: [last_name first_name Litle: & street + QK I
Criteria: Fustomer supm =

or Adminiztration Cancel |
Documentation Help |
Finance
Human resources [~
Marketing
[ Other 4lll
il Product developmes D

10 Click OK.
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Create a new report from an existing one
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11

12

The report displays. It includes only contacts in Customer support.

‘_t Id  Last Mame First Name Street City State  Zip Phone Fax
16 Sullivan Dorathy 54 Minuterman Dr.  Lincaln MA 01742 (B0£)955-3025  (BU2IEEE-9931
12 Lyman Thatas 64 Story Rel. Emeryvile  CA G460%  (B10VGE5-537E  (B10)B65-23T2 wl
- 18 lencki John 20% Brook Road — Burlington A 01803 (B171555-5348 (B17)555-4613
14 18  Hayne Mlliam Customer support 3% Corrfield Awe.  Acton (1128 01720 [BOSIEEE-TTE0 (BO2)EE5-4422
B Cobb Paul Customer suppart 34 Greenwille St Allanta GA 30339 (4045552239 (A0EE5-8111
= 22 Goggin Kewin Customer support %% EastMain 8. Houston TX TTOTS  (T13)666-3340 (712)666-3211
4 22 Cohen Paul Customer suppart 10§ Park Strest Burlingtor A 01303 (B1T555-8583 (6171555-445%
4 32 Reeves Seott Customer support 39 Linden &t Iselin NJ 08830 [BOZ)EE6-098% (BOZ)BE5-5656
44 short Russell Customer support 12 Mewton 5t Needham A 02182 (B171555-0993 (B17)555-1170
21 53 Tinpet Debbie %5 Aberdeen Rl Schaumburg 1L 60172 (TOBYS55-8227  (TO4)555-2474
] 54  Hodson Jack 69 Lincoln St Acton A 01720 (B08)555-299% (508)555-0022
E ‘59 Masalsky Kurt 29 Garden 8t Aarta GA 30338 (404)555-5111 (404)566-8247 =
4| - | i

By setting up areport to prompt for criteria, you give yourself alot of
power and flexibility when you run the report. You learn more about this
when you create an application in the next tutorial.

Select File>Close from the menu bar.
When prompted to save changes, click Yes.

The Report painter closes and you return to the Library painter.

Now your new report is listed. It isagood idea to add comments to
document the report. You can do that now.

Position the pointer on contactgrid_with_prompting.
Press the right mouse button to display the pop-up menu.
Select Properties.

The Properties dialog box displays.
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Lesson 7 Environment Tutorial

13 Type This report lets me enter selection criteria when | run the report.

X
General |
Object Mame: contackgrid_with_prompting
Library: H:isharedimylib. pbl
Last Modified: 1/27(2006 12:10:43

Last Compiled: 112712006 12:10:43

Size in Bytes: 12204
SCC Yersion: I
Comments:

This report lets me enter selection criteria when I run the report, ;I

=
OF I Cancel | Apply | Help |

The newly added comment displays.

14 Click OK.
wlib.pbl in H:h
ame | Modification Date Compilation Date
contackgrid &/5/2003 03:35:08 1/25/2006 22:49:56
ontackgrid_with_prompting 112712006 12:16:38 112712006 12:10:43
contacts_by_jobrole 11262006 13:23:59 11262006 13:23:59
d_dddw_states /52003 03:35:08 1/25/2006 22:49:55
l’;);'q_expenses 11262006 17:47:15 11262006 17:47:15
:, contact_maintenance 11262006 11:12:12 11262006 11:12:12
4] | i

Now you have become familiar with many of the tasks you can do in the
Library painter.

15 Continue directly to the next tutorial, the Application tutorial.

(Leave the Library painter open.)
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LESSON 8 Application Tutorial

An InfoMaker application is a collection of related reports, forms, and
pipelines. For example, the Contacts application that you create in this
tutorial has:

A form to maintain data in the contact table
A report to list all contacts
A report to list only contacts that meet your criteria

E =10lx
|w¢mmt| |Dnb\na=nﬁxt||8m=l|uw|
Last Hame: [Fielaors
Fast Hame: e W LastMame Vs Mame  Jab Hole -
1 Hidebrad  Jare Marbetrg 12
Job Roke: ket @ e Ly S
Street: [TZ0Washngron 5L 2 Crch fusan Product development 45
T —— 4 Lamben Ty AdrevEon s
i Y Doroly  Cimdomis agen! 64
Stote: 1 T Rose  Fnance 78
E T 7 Qaimann  Bel Product daveiopment 44
— s Pow Caorny Trimwng 4]
Phone: [0 5130 a e . =
F o [0 B AR 10 Qs Moty ™ 5
PRy s

contactgrid_with_prompting

Bl Last Mame  Flrst Hame Jab Robe Street chy
1 Hidebrard  Jarw Mkt 1280 Wendingion 5 Emeryeil
2 Samemon Lary Salers 34 Geamille 3 Houson
¥ okn Susan Froduct develogment 45 Center 5t Danvers
4 Lamtan Tiry  Acmireyason 204 Page 81 Cortn
& Sullvan Doroltry  Customes support 54 Mirnderman Dr. Uncoln
6 Fad Faose Fnarce. TiBay & Martienead
T Ghesmrn B Proguct dengment 38 0ok 1 Linrign
8 Powaed Gere Training 552 West Main 8 Lendngon
9 Fah ey Wy E2RudAra R, Linkegn
10 Cur Moty Kol 66 Pray Gaown R Liniregon
1 Keley L Documentston 16 Rairbow P, Buringion
12 Lyman Thomst  Custbodr suppoel 64 Sory Ra eyl
13 Dawideon Joarn Merbirn 4 Sory Rd. Emiryvil
14 Petengl Mark Saes &% Briarwood Ter. Emeryvile
15 Moo [ Ot Pk et Ay
18 Lencki Joitn Cumdomin suppor 0% Brook Pood  Buringin
17 Kaplan Burt Salet 49 Kaston Lane  Aringion
1B Hyme W Cusoedr appodl 53 ComBsd Aew. KEn
19 Chin Darvid Product development 16 Waaverty R Buringion
.:in e Padng e £7 Fries 2 M

St dip Phone
(EEEE 20
TIPS (TIApEE-4060
VISE  (E66-4E
E0T  BITIREE-224E
OTAT  [SONSE-9EE
015 ATIS66-6350
02T EITEE-03TS
073 EATIEE-3528

i

NI EITEESETE BITESE B Michasl 117 5552200 (6175553007
WITE EINASAEE  EITESSE Collrey Mot 8171 555115 [617) 5553566

ETHSERTe  (FITIEEE Lasbert Teiy [E17)SE52208  (B17) 6553602
P IRESITE NS Homen Jote (105554533 (300555233

MEnt  EIOBEE-TIE)  (FIONEEE
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How long does this tutorial take?
About 30 minutes.
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Create the application

180

Where you are
> Create the application
Create a shortcut to the application
Start the application
Use the Data button
Use the By Job button
Use the Ad Hoc button

Now you will create an application, complete with toolbars and menus, and
you will create a shortcut for the application. Then you can run it from your
desktop, just the way you run InfoMaker or any other application.

The application you create consists of an executable file and an initialization
file. Theinitialization file provides information about the database to the
executablefile.

For example, InfoMaker itself is an application that has an executable file
called im105.exe. Thisisthe file you start running when you start InfoM aker.
InfoMaker also has an initialization file called im.ini.

Terms
The executablefileis also called an exe file (pronounced exxy). The

initialization fileis also called an ini file (pronounced inny).

InfoMaker
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Getting Started

If you are continuing from Lesson 7, go to step 2.

Otherwise, gotothe Library painter inthe H:\shared drive with thelibrary
named mylib.pbl set to be the current library (File>Select Library).

The Library painter shows the contents of mylib.pbl.

Y T = T T

| 3

-] edlipse =

| Modification Date

Compilation Date

contackgrid_with_prompting
contacts_by_jobrole
d_dddw_states
l’;);'q_expenses

f_ conkack_maintenance

e

852003 073:33:08
1)27/2006 14:17:50
1)26/2006 13:23:59
85/2003 03:33:08
1/26/2006 17:47:15
1)26/2006 11:12:12

1/25/2006 22:49:56
1/2712006 14:19:22
1/26/2006 13:23:59
1/25/2006 22:49:55
1/26/2006 17:47:15
1f26/2006 11:12:12

|

Select Design>Create Executable from the menu bar.

The Create Executable dialog box displays. In thisdialog box you specify
atitle for the application window, afile name for the executablefile, the
folder for storing the executable file, and an icon for the application.

Create Executable

Executable Title:

Executable File Mame:

Product Yersion:

[1.001

File Version:

1001

1001

Executable lcon:

1001

¥ hlew Wisual Skyle Controls

Biowse.. |

Browse.. |

< Back | IHewt s Cancel

Help
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Create the application

3 Type Contacts in the Executable Title box.

Later, when you run your application, the title bar displays the word
Contacts.

Create Executable

Executable Title

IEonlacts

Executable File Name:

I Browse.. |

Product Yersion:

[1.001 [1.o01
File"/ersion:
[1.00a 1001

Executable [con

I Browse.. |

v M Wisual Style Controls

< Back | [ent = | Cancel | Help |

4  Type contacts.exe in the Executable File Name box.
This assigns a name to your executable file.

Executable Title

IEonlacts

Executable File Name:

Icontacts exe Browse.. |

Product Yersion:

[1.001 [1.o01
File"/ersion:
[1.00a 1001

Executable [con

I Browse.. |

[V Mew Yisual Style Conkrols

< Back | [ent = | Cancel | Help |

5 Click the Browse button next to the Executable Icon box to select an
icon for your application.

Theicon will display in the Windows shortcut. You create a shortcut
shortly.
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Getting Started

Change to the Tutorial folder (the icon is there).

Click emp.ico.

Click Open to accept the emp.ico file as the icon for your application.

You return to the Create Executabl e dialog box. Theicon and itsfull name

display.

Create Executable

Executable Title:

I Contacts

Executable File Name:

I contacts.exe Browise... |

Froduct Yersion:

1001 L0010
File Yersion:
| 1.a,0,1 | L0,0,1

Executable Icon:

IC:\Program Files\Sybase\InfoMaker 10,5\ Tutariallemp.ico Browse, .., I

& [V Mew Yisual Style Controls

< Back Mext > Cancel Help

Type Version 1.0.1 in the Product Version and File Version boxes on

the right.
Leave 1,0,0,1 in the boxes on the left.

Thetext you typein the boxes on theright displayson the Version tab page

of the Properties dialog box when you look at the properties of the
executable file in Windows Explorer. The four numbers separated by
commas on the left can be used by installation programs.

Create Executable

Executable Title:

I Contacts

Executable File Name:

I contacts.exe Browise... |

Froduct Yersion:

1001 [ version 1.0.1
File Yersion:
| 1.a,0,1 | version 1.0.1

Executable Icon:

IC:\Program Files\Sybase\InfoMaker 10,5\ Tutariallemp.ico Browse, .., |

& [V Mew Yisual Style Controls

< Back Mext > Cancel Help
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Create the application

8 Click Nextto select items for the application.

The Select Itemsdial og box displays. Now you select the form and reports
for your application.

9 Click the check box for contactgrid_with_prompting.
Click the check box for contacts_by_jobrole.
Click the check box for contact_maintenance.

Select Items
Check itemis) to include in executable:
Mame | Comment
l_ contackgrid Tutorial: Used faor Tutarial, added to a
contackgrid_with_prompting This report leks me enter selection crike

& contacts_by_jobrale This report shows my conkacts groupes

[~ & d_dddw_states Report: For DropDownDataWindaw: Gri
—

W &l contact_rmaintenance This Form updates my contact table,

) | o]

[ select all [ Deselect All

< Back Mexk = | Cancel | Help |
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10 Click Next to define the toolbar items.

The Executable Items dialog box displays. It lists the form and reports to
beincluded in your application. Theinformation you enter in the boxesto
theright of thelist of itemsisfor the currently selected item.

Traditional and Comtemporary menu styles ) .
Inthistutorial, you usethe default Traditional menu style. For information

about the Contemporary menu style, see the InfoMaker User’s Guide.

Executable Items

To have a button for a form, report, or pipeline appear in the toolbar of the
executable, select the form, report, or pipeline in the list box on the left and set
the taolbar properties using the controls on the right.

Sek Toolbar Properties For: I Hide Report
contactgrid_with_promphing Picture:
contacts_by_jobrole
contact_maintenance (Mone) e
Text:
LI MicroHelp:
Wenu and Toolbar Style I
o Contemporary
& Traditional
< Back | Finish Cancel Help

Finish defining all information before you click Finish
Do not click the Finish button or press enter until you have finished

defining information for all the items you want to include in the
application’s toolbar. Once you click Finish or press enter, InfoMaker
generates the executablefile.

If you create the executable file before you mean to, select
Design>Create Executable again. InfoM aker remembers what you have
specified. You can continue whereyou | eft off and re-create the executable
file.
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11 Make sure contactgrid_with_prompting is selected.
In the Picture box, display the list and select CheckStatus!.
Click the Text box and type Ad Hoc.
Press Tab to go to the MicroHelp box.
Type List contacts that meet the specified criteria.

The Picture box specifies the picture for the button, which will be in the
application’s toolbar.

The Text box provides text for the button and for the menu item that will
run contact_maintenance in your application.

The MicroHelp box provides MicroHelp for the button and menu item.

To have a button for a form, report, or pipeline appear in the toolbar of the
executable, select the form, report, or pipeline in the lisk box on the left and set
the toolbar properties using the controls on the right.
Set Toolbar Properties For: I Hide Report
B — ——
contacks_by_jobrole
contack_mainkenance ICheckStatus! 'l m
Text:
I Ad Hoo
LI MicroHelp:
Menu and Toolbar Style I List contacts that meet the spe
o Contempotary
& Traditional
< Back | Finish Cancel Help
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12 Click contacts_by_jobrole.
In the Picture box, display the list and select Cascade!.

Click the Text box and type By Job.
Press Tab to go to the MicroHelp box.
Type List all contacts grouped by job role.

Executable Items

To have a button for a form, report, or pipeline appear in the toolbar of the
executable, select the form, report, or pipeline in the list box on the left and set
the taolbar properties using the controls on the right.

Sek Toolbar Properties For: I Hide Report

Pickure:

ICascade! 'l

Text:

I By Job
LI MicroHelp:

I List all contacts grouped by job

[l

Wenu and Toolbar Style
o Contemporary
& Traditional

< Back | Finish Cancel Help

13 Click contact_maintenance.
In the Picture box, select the entry AddWatch!

Click the Text box and type Data.
Press Tab to move to the MicroHelp box.

Type Maintain contact information in the database.

Enecutable Items

To have a butkon for & Farm, report, or pipeline appear in the toolbar of the
executable, select the Form, report, or pipeline in the list box an the left and set
the toolbar properties using the controls on the right.

Set Toolbar Properties for: I™ Hide Report

contactgrid_with_prompting ;I Picture:
brole

contacts by il .
3 IAddWatch! 'l jeiy

icontact maintenance
Text:

I Data
j MicraHelp:

I Maintain conkact information in

Menu and Toolbar Style
 Contemporary
@ Traditional

< Back | Finish | Cancel | Help

Now you have finished providing information for the form and the two

reports that are in your application.
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14

15

16

17

Click Finish.

InfoM aker createsthe application, which consists of an executablefileand
aninitialization file. These files are in the Tutorial folder.

Now that InfoMaker hasfinished creating the application, you return to the
Library painter.

Before leaving the Library painter, you select tutor_im.pbl as the current
library. Thisis where the samples and the tutorial work are kept.

Select File>Select Library from the menu bar.

Select tutor_im.pbl from the Recent page in the Select File dialog box
and click OK.

The current library istutor_im.pbl again.

Select File>Exit from the menu bar.

InfoM aker closes.

InfoMaker
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Create a shortcut to the application

Where you are
Create the application
> Create a shortcut to the application
Start the application
Use the Data button
Use the By Job button
Use the Ad Hoc button

Now you make the application easy to access. To do this you create a shortcut
on the Windows desktop.

1 Move the pointer to an empty area of the desktop and press the right
mouse button.

The pop-up menu for the desktop displays.

2 Select New and then Shortcut.
The Create Shortcut dialog box displays.

Create Shortcut x|

This wizard helps you to create shortcuts to local or
network programs, files, folders, computers, or Internet
addresses.

Type the location of the item:

Browse. .. |

Click Mext to continue,

= Back. Mexk = | Cancel I

3 To locate contacts.exe, click the Browse button.
In the Browse dialog box, change folders to the Tutorial folder.
Select contacts.exe and click Open.

You return to the Create Shortcut dialog box with the full path of the
contacts.exe file in place.
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4

Click Next.

The Select A Title For The Program dialog box displays.

In the text box, type Contacts over the name offered as a default

(contacts.exe).

This provides a better title to display under the icon on the desktop.

Select a Title for the Program

Type a name For this shorbcut:

Contacts

Click Finish to create the sharkout,

< Back I Finish I Cancel

Click Finish.

Windows creates the shortcut to your application and displaysit on the
desktop. Now you must modify a property of the shortcut so that you can

run your application.
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7

Move the pointer to the icon and press the right mouse button to

display the pop-up menu.

Select Properties to display the shortcut’s property sheet.

21|

Contacts Properties

General | Shortcutl Securityl Eompatibilityl

ol IEontacts
i

Type of file:  Shortout
Description:  Sybase Inc. Product File
Location: C:A\Documents and Settingsibzchott SYBASE\Desk
Size: 739 bytes [739 bytes]
Size on disk:  4.00 KB [4,095 bytes)
Created: Today, January 27, 2006, 3:33:00 PM
Modified: Today, January 27, 2006, 3:47:53 PM
Accessed: Today, January 27, 2006, 3:47:53 PM
Attributes: [~ Read-only [ Hidden Advanced... |

QK I Cancel | Apply
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8

192

Select the Shortcut tab and type the location (path) of the Sybase
system files in the Start in box:

Contacts Properties

21|

General Shortcut | Securityl Eompatibilityl

g' _f'; Contacts
Tt

Target type:

Application

Target location: Tutorial

Target: "C:\Program Filesh\Sybazehlnfokd aker 10.55T utori.

¥ Rurin separate memony space || Run as different user

Start in: I"E:\Program FilezSybazehShared\PowerBuilder

Shortcut key: INone

Rur: I Mormal window j
Comment: I
Find T arget... | Change lcon... |
QK I Cancel | Apply |

About the location of Sybase system files ]
When you install InfoMaker, the installation process automatically puts

the DLLsinasystemfolder. If you have changed the names of the folders
used for installing, you need to use your namesin this step.

The folder path is C:\Program Files\Sybase\Shared\PowerBuilder.

You must specify the name of the drive. If you use backslashes to specify
arelative path name, the application will be unable to locate the system
files.

Click OK.

Windows modifies the shortcut to your application. This modification
enables Windows to find some InfoMaker modules (DLLS) required for
running your application.
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Start the application

Getting Started

Where you are

Create the application

Create a shortcut to the application
> Start the application

Use the Data button

Use the By Job button

Use the Ad Hoc button

In this exercise you start the application you created and take alook at its
toolbar, MicroHelp, and menus.

1 Double-click the Contacts shortcut on your desktop.

Your application runs. Do not be surprised if it takes a minute to get
everything running. The database itself has to start up so that you can
access data.

The main window of the Contacts application displays.

# |Contacts 10l =|
File ©Objects Window Help
“ g m B =

Forms  Feports  AdHoc  Bylob Data Exi

[Ready A4
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Start the application

2 Notice the toolbar.

The Forms, Reports, and Exit buttons are automatically included. The Ad
Hoc, By Job, and Databuttons are in the tool bar because you defined them
when you created the application.

”aﬁm%z@n«

Forms Reports &d Hoc Ey Job Diata Exit

3 Move the pointer to one of the buttons.

Notice the MicroHelp at the bottom of the screen.

4  Click the Objects menu item.

Notice that Ad Hoc, By Job, and Data are included in the Objects menu.
Your application has atoolbar and amenu. You can run forms and reports
from either place.

@ (Contacts
File | Chjects ‘Window Help

“ Ad Hoo M % Jeiy “.q.

By Job AdHae  EyJob Data Exit
Data
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Use the Data button

Getting Started

Where you are
Create the application
Create a shortcut to the application
Start the application
> Use the Data button
Use the By Job button
Use the Ad Hoc button

Now you use the Data button to run your form. You add a new contact and

change information about an existing one.

1 Click the Data button.

Your form displays. Notice that title barsidentify your application and the
particular part you are using. You also have the usual form toolbar that |ets

you view, add, and update information in the database.

Lo/
File Edit Rows Window Help
= n B oz F
Forms Reparkz AdHoc By Job Data Exit
% g B oM 4 BBl 4 oo o Ik
Ciiteria Apply Fictrieve First Prior ezt Lazt Delete Inasrt Update Clazt
@ vt Contoct formation R
Id:l ] | Add a contact | ‘ Delete a contact | | Save changes |
Last Mame: IH\Idebrand
First Name:flane Id  LastName FirstName  Job Role Al
: il Hildebrand Jang Marketing 1%
Jsbi Rola; |Ma|ketmg 2 Simman Larry Sales o2 .
Street: |1 280w ashington St k3 Critch Susan Product developmert 45
I - 4 Larmbert Terry Administr ation 2C
City: |E mernpville =
5 Sullivan Daorothy Customer support 54
State: [l 6 Paul Rose Finance 7%
Zip: Ig4503 7 Glazsmann  Beth Procuct dewelopment 44
; b Poell Gere Training 55
Phone: 570 555 1303 9 Fish Jefrey  Marketing 68
Fax: |[5'| 0] 555-4209 10 Clarke holly Sales 58
|Ready A
2 Click the Add a contact button in the form.
A blank form displays.
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3

Enter information for a new contact.
Use 62 for the Id entry and make up the rest.

Besuretofill inall blanks. (The only columnsyou can skip are phone and
fax; the other columnsare defined asrequired in the database.) Usethe Tab
key to move from box to box.

=Y
File Edit Rows ‘Window Help
&l n B =2
| Fome Raparts AdHac EuJdob Data Exit
I & & 4 4 B Bl o o 58 e
Criteria Apply Fietricvs Firzt Priar Mext Lazt Dielete Inzert Updats Claze
RETET
i 63 | Add a contact | | Delete a contact | | Save changes |
Last Name: [Schatt
First Name: [fabores Id  LastName First Name  Job Role =
: _ 1 Hilchebrand Jane tarketing 1%
Job Role: |Documentation 5 m— Larry E 2|
Street: |31 ‘white Trelliz 3 Critch Susan Procuct development 4%
City: |Maynard 4 Larr.lbeﬂ Terry Adrministration 20
5 Sullivan Dty Customer suppart 54
State: [M4 8 Paul Rose Finance 7%
Zip: [11754 7 Glassmann  Beth Pracluct development 44
3 & Fowel Gene Training 58
Phone: |[50] 5552831 9 Fish Jefrey  Marketing 6
Fax: [[508] 555-3332 10 Clarke Molly Sales 58
11 Kelley illizrm Documertstion 16,
| | _'l_I
|Ready A

Click the Save changes button in the form.
Your new contact goes into the database. You will see it shortly.

Next you want to display information on the contact with Id 37 so that you
can make a correction.

About updating the database and canceling changes
You can click the Update button to update the database immediately; or

you can wait until you close the form, and InfoM aker prompts you then to
seeif you want to update the database.

The Cancel Changes menu item on the Rows menu cancels any changes
you have made since the last time you clicked Update.
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S

Ceriteria

&

Apply

Click the Criteria button to display a blank form for setting retrieval

criteria.
Type 37 in the Id box.

This sets the retrieval criteria.

1o
File Edit Rows Window Help
& B ®m B z B ‘
Forms FReparts Ad Hoc By Job Data Exit
e £ i< < B i i1 i ‘
Apply Fietrieve First Priat Mext Last Delete Update Clase
=
Id:l 3 | Add a contact | ‘ Delete a contact | | Save changes |
Last Name: I
First Name: I— Id  Last Hame First Name Job Role o
il Hildebrand Jane Miarketing 1E
Jky Rnle:l 2 Simman Larry Sales o2
Street: | k3 Critch Sugan Product development 4%
City: | 4 Lambert Terry Administration 20
5 Sullivan Dorothy Customer support 54
State: | 5 Paul Rose Finance 7%
Zip: I_ 7 Glassmann  Beth Product development 44
ks Fowell Gene Training 58
Phone: | 9 Fish Jefrey  Marketing 68
Fax: | 10 Clarke tally Sales 58
11 Kelley Wilizrm Documertstion 16,
| I _'lJ

|Specify selection criteria

Click the Apply button.

This appliestheretrieva criteria. InNfoMaker retrieves the row with the Id

37.

1ol
File Edit Rows \Window Help
S @ ®m B O3m R
Farms Reparks AdHoc By Job. Data Exit
U U T T R A B |
Crriteria Apply Rietricye Firzt Prior Hext Last Delets Inzert Update Close
R
Id:l 7 | Add a contact | ‘ Delete a contact | | Save changes |
Last Mame: IF'urc:eII
First Name: ot Id  LastName FirstName  Job Role =
i il Hildletrand Jane Marketing 1%
JbiRola; |Sa|es 2 Simman Larry Sales 3
Street: |1 34 Chemp Hill 5t 3 Critch Susan Product developmert 4%
City: It-‘uhngtun 4 Lan?ber‘t Terry Adlrninistation 20
5 Sullivan Dorathy Customer suppart 54
State: [ 6 Paul Rose Finance 7%
Zip: |U21 74 7 Glassmann  Beth Pracuct development 44
3 E3 Powell dene Training 58
Phone: 677 555 2343 9 Fish Jefrey  Marketing 6
Fax: |[81 7] 5551765 10 Clarke tally Sales 58
11 Kelley Wilizrn Diocumertstion 16,
4 | _'lJ

Retrieve all rows with new criteria
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Change the Street to 134 Cherry St.
Click the Save changes button in the form.

Your changes are added immediately to the database.

Click the Next button.

A message box displays because you have set criteriathat allow only row
37 to beretrieved. You need to removethe criteriaor specify other criteria.

Maintain Contack Inforn:i x|
& This is the last row For this table!

Click OK to close the message box.

Click the Criteria button.

Select 37 and press the delete key to delete 37 from the Id box.
Click the Apply button.

Now you have no criteria, so InfoMaker retrieves all rows.

Select File>Close from the menu bar.

Your form closes.
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Use the By Job button

Getting Started

Where you are

Create the application

Create a shortcut to the application
Start the application

Use the Data button

> Use the By Job button

Use the Ad Hoc button

Now you run areport of all contacts grouped by job role.

1

Click the By Job button.
The report that lists all contacts grouped by job role displays.

=TE
Flle Display Rows Window Help
=] n B =2 F
Forms Reports Ad Hoe By Job Data Exit
<8 o4 4 B Bl = Bk
Ratrivs Firzt Prior Mt Last Print Clozs
=
1/27{2006 My Contacts |
Last Name First Name Phone Fax
Admisirafion
Brier Michael (E17) B55-2338 [617) 555-3337
Calling MaryBath [F17)555-1133 [E17] 555-3586
Lambert Termy [E17) 555-2246 [E17) 555-3692
Romen John [310) 555-4633 [310) 555-1233
Lsstomer supeonf

Cobh Paul (404) B55-2233 [404] 555-8111
Cohen Paul [617) 555-8883 [617]555-4499
Goggin Kevin [713) 555-3340 [713] 555-3211
Hayne “william (508) 5557780 [507) 555-4422 -

a | 2oz

|Ready o

Scroll the report to see your new contact.
When you have finished, select File>Close from the menu bar.

Once again you return to the main application window.
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Use the Ad Hoc button

200

Where you are
Create the application
Create a shortcut to the application
Start the application
Use the Data button
Use the By Job button
> Use the Ad Hoc button

Now you use the Ad Hoc button to run several different reports based on the
criteriayou specify.

1 Click the Ad Hoc button.

The Specify Retrieval Criteria dialog box displays. This dialog box
displays because you selected Prompt For Criteriafor this report.
Whenever you run this report, you are first prompted for criteria.

§ Contacts
File Objects ‘Window Help

g 8 W B =

Formz  Reportz  AdHec  Eplob Data

0 « b ]

Cancal First Priar ezt Lazt

=10l x|

T

3 [

»
a
g

Calurnn; i last_name First_name title -

Criteria:

Or:

Cm

Hit: Cancel to stop retrieval. A
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Click OK.
Because you did not specify any criteria, the report retrieves all your
contacts.
=
File Display Rows Window Help
J 5 @ ®m B =3 B ‘
Forms Reparts Ad Hoe By Job Data Exit
@ 14 4 Pkl g5 B
Retricve Firzt. Priar Mext Lazt Print. Claze
=T
a
Id Last Name First Name Job Role Street City State  Zip Phone F |
1 Hildebrand  Jane Iarketing 1280 Washington &t Emerywile M 44608 (B100655-1308 (101555
2 Simtnor Larry Sales 24 Granville 5t Houston Tx TTOT9  (T12)555-2960 (T13)555
] Crilch Susan Product developmert 45 Center St Danvers [ 01822 (BO%)GEE-4829 (B08)556—
4 Lambert Terry Administration 204 Page 5t Carnton MA 94608 (B17)556-2246 617555
5 Sullivvan Darothy Customer support 54 Minuteman Dr.  Lincoln WA 01742 (508)555-3925 (508)555
3 Paull Rose Finance 7% Bay &t harblehead  MA 01945 (B17)555-6342 (617555
7 Glassmann Beth Froduct developmert 44 Oak 5t Lexington WA 02173 (B17)556-0273 617555
% Powell Gene Training 552 Whest Main 5t Lexinegton A 02173 (B17)555-3528 (617555
4 Fish Jefrey  Markefing 66 RedAme R, Lexingion  MA 02173 (BITISSS353% (B1TIEGE
10 Clarke Mally Sales 56 Pine Grove Rel. Lexington MA 02173 (B17)556-4326 617555
11 Kelley Williatn Documentatiorn 16 Rainhow Rd.  Burlington A 01803 (B17)555-2474 (617555
12 Lyman Thomas Gustomer support 64 Shory Rd Emerywile  CA 94608 (B10)656-5378 (E10)556
1% Dawidson Joann Marketing 64 Story Rl Emeryvile  CA 94608 (B100556-7363 5101555
14 Petendil hark Sales 26 Briarwood Ter. Emerywile  CA 94608 (5100555-3532 (5101555
16 Moore Dawn Sales Cne Park Drive AMlarta G 30338 (404)556-4834 (404)556
16 Lencki John Customer support 20% Brook Road  Burlington MA 01803 (B17)556-634% 617555
17 Kaplan Burt Sales 49 Keaton Lane  Arlingtan A 02174 (B17)555-3887 (617555
1% Havne ‘inilliam Gustomer support 4% Corrfield Ave.  Acton [ 01720 (BO$IEEE-TTED (B08)556
1% Chin Davicl Froduct developmert 16 Waverly Rel. Burlington MA 01803 (B17)556-337¢ 617555
?I[] Tiitite Pauling Salrs AT Prince Gt Hnustrn T FTOTS f?i RWERR-3345 i
4
|Ready £

Select Rows>Retrieve from the menu bar.

The Specify Retrieval Criteria dialog box displays again. Thistime you

enter criteria

Go to the title column.
Select Documentation from the drop-down list.
Click OK.

Specify Retrieval Criteria

Column: f_name First_name Litle blstreet & |

Criteria: Documentation

ar: Cancel |
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Use the Ad Hoc button

You have specified that the report isto list only contacts who have jobsin
documentation.

2 Report - contactgrid_with_prompting i |E| ﬂ
Id Last Name First Hame Job Role Street City State  Zip Phone F:
11 Kelley Williamm Documentation 16 Rainbow Rd.  Burlington MA 01803 (B1766E-5474 [B171666
29 Sinibaldi Joseph Cocumentation 1112 Center 5t Arlington A 0174 ([BITIEEE-669S (81755
47 Berfrand Coleman  Documentation 7% Dunster PI Schaumburg 1L B0TE  (TOEVSEE-2486 FOEES
62 Schott Barbara Documentation 1 White Trellis Maynard MA 01754 (BOE)5EE-2434 (B08)5E5
< | oy

5 Click the Retrieve button.

The Specify Retrieval Criteria dialog box displays again. Notice that the
criterion in the title column is still in effect. To specify different criteria,
you are how going to delete Documentation. Then you enter new criteria.

Specify Retrieval Criteria x|
Column: (last_name First_name Litle & |street OF I
Criteria: Documentation

ar: Cancel |

-
. | »

6 Select the Documentation entry in the title column.
Press delete.

This deletes criteriafrom thetitle column. Now you are going to enter new
criteria.
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Click in the first box underneath last_name.
Type like "c%".

Click OK.

Specify Retrieval Criteria x|
Column: (last_name First_name Litle & |street OF I
Criteria: (ke "c%" Documentation

ar: Cancel |

-
. | »

Thisentry (like "c%") helps you find a name you cannot remember. All
you can remember isthat it starts with C.

Thelike operator specifiesthat only rowsthat match what follows should
be retrieved. The quotes are required. The ¢ means that the first character
must be C. The % sign means any characters can follow the C.

Thisisthe report.

. Report - contactgrid_with_prompting 3 -0 x
Id Last Name First Hame Joh Role Street City State  Zip Phone F
3 Critch Susan Product development 45 Center &t Danvers Il 01423 (BOE)5EE-4824 (50565
10 Clarke Mally Sales 55 Pine Growve Rd. Lexington MA 02173 (B1TIEEE-4325 B17555_
18 Chin Drarvic Product development 16 Waverly Rd Burlingtorn MA 01303 (B17IEEE-2378 8179555
21 Cobb Paul Customer support 34 Greenvile 5t Allanta GA 30339 (404)EEE-2E3S (4049555
23 Cohen Paul Customer support 10% Park Strest Burlingtorn MA 01303 (B17IEE6-848% 8179555
3 Crowley Charles Human resources 6% Eclson St Burlingtorn MA 01803 (B17IEEE-1344 8179555
36 Caruso Milliarm Finance 43 Edison &t Becdford A 01730 (B17)565-2144 (B17)555
46 Crossland Ellen Product development 27 Fush Rd Burlinctor A 01303 (B17)565-0004 (B17)555
60 Coling MaryBeth  Administation 56 Lincoln Street  Burlincton A 01303 (B17)565-1189 (B17)555
61 Carter Jirmy Wharketing PeariLt iy Aiarta GA 30339 (404)555-7833 (4041555
4 | EE

Click the Retrieve button.

The Specify Retrieval Criteriadialog box displaysagain. Therequirement
that the last name begin with Cisstill in effect. Now you add an additional
requirement. The report isto list contacts whose last names begin with C
and who are from Burlington.
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9 Use the scroll bar to display the city column.
Click in the first box underneath city and type Burlington.
Specify Retrieval Criteria : ll
Colurnn: gt city state - 0K I
Crite::i:; Burlington Cancal
. | m
10 Click OK.

Now the report has only contacts whose last names begin with C and who
are from Burlington.

P Report - contactgrid_with_prompting O] =

-

Id Last Name First Name Job Role Street City State  Zip Phone Fim
1% Chin David Product development 1€ Waverly Rd. Burlincon hi& 01502 (B17I5E5-33T8 (B1TI1E55

2% Cohen Paul Customer suppart 108 Park Street Burlincton [ &0 ([B17)565-4383 {B17565_
34 Crowley Charles Hurman resources 64 Edson 8t Burlincton [ &0 ([B17)565-1344 {B17)555
46 Crossland Ellen Procuct developrment 27 Rush Rd Burlincton [ &0 ([B17)565-0004 {B17)555
80 Colling MaryBeth  Administration 56 Lincoln Street  Burfineton [T} 80%  (B17)565-11498 171555

! I

11 Click the Retrieve button.

The Specify Retrieval Criteria dialog box displays again. The
requirements that the last name begin with C and that the city be
Burlington are till in effect.

Now you changethe city requirement slightly. Thereport isto list contacts
whose last names begin with C or who are from Atlanta. To be listed,
contacts have to meet either requirement; they do not have to meet both.
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12 Use the scroll bar to display the city column.
Select Burlington and press delete to delete Burlington.

Specify Retrieval Criteria

Calurnn:
Criteria:
O

+|street

state

-

m

13 Press the down arrow key to move down one row.
Type Atlanta.

Specify Retrieval Criteria

X
Calumn: *|street city = [o]'4 I
Criteria:
Or: Atlanta Cancel |
-
. | »
14 Click OK.

By specifying criteriain two different rowsin the dialog box, you are
specifying that the report should retrieve rows from the database that meet
thefirst row of criteria or the second row of criteria.

Your report retrieves all contacts whose names begin with C. It also
retrievesal contactswho arefrom Atlanta. Itishardtolook at thetwo sets
of rows, so now you sort by city. Then all the Atlantarowswill be together.

4]

B Report - contactgrid_with_prompting
Id  Last Mame First Name Job Role

2 Critch Susan Procuct developmert
10 Clarke hally Sales

15 Moore Doy Sales

1% Chin David Procuct developmert
21 Cobb Paul Customer suppart

22 Cohen Paul Customer support

27 Ewans Carrie Sales

24 Crowley Charles Hurnan resources

36 Caruso Alliam Finance

46 Crossland Ellen Procuct developmert
50 Shishov Irina Marketing

59 Masalsky Kurt Customer support

B0 Collins MaryBeth  Adminisiraion

‘61 Carter Jimiry Marketing

Street
45 Center 8.
5 Pine Grove R
One Park Drive
16 Wiaverly Rd.
34 Greenwils 8t
10% Park Sreet
9 Miashington St
64 Edson 8t
99 Edison 5t
27 Rush Rd.
567 Park Drive
29 Garden &t
56 Lincoln Street
Peant Way

City
Darwers
Lexington
Allania
Burlinggon
Allania
Burlinggon
Allania
Burlinggon
Bediord
Burlinggon
Allania
Alianta
Burlingtor
Alianta

State  Zip
MA 01322
MA 02172
GA 30339
MA 01202
GA 30339
MA 01202
GA 30339
MA 01202
A, 01730
MA 01202
GA 30339
GA 30339
A 01803
GA 30339

Phone
(B0£)555-4329
(617)555-4325
(404)555-4834
(617)955-337%
(404)555-2239
(6171955-33%3
(404)555-1169
(6171555-1344
(61715552144
(617)555-0004
(404)555-1233
(404)555-5111
(61715551199
(404)555-T333

=10l x|

Fax |

(508)655-3025
(617)655-763%
[404)555-8291

(81716554458

[4041555-8111
(61716554499
[404)555-8244
(617)655-9877
(617)655-1656
(617)655-5005
[404)555-6837
(40415558347
(617)655-9586
(40415554291
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15 Select Rows>Sort from the menu bar.

The Specify Sort Columns dialog box displays.

Specify Sort Columns

1] Drag and Drop items.

B
2] Double-click colurmn to edit expression,

Source Data Colurmnns Ascending
lid «| i
Ilast name

first_name
Litle:

street

Cancel

ity

state
2
hone

5|

16 Drag the Id column out of the Columns box and the city column into
the Columns box.

Click OK.

Specify Sort Columns

B
1] Drag and Drop items.

2] Double-click colurmn to edit expression,

Source Data Columns

Ascending Eeme] |
lid | feit i
Ilast name
first_name
Litle:

street

ity

state
2
hone
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InfoMaker sorts the rows by city. Now you can see the Atlanta contacts

first. These are followed by contacts whose names begin with C.

N RI=F3
File Display Rows ‘Window Help
| & - ‘
|| Ferme Repantz AdHoe By Job Data Exit
<@ i < B =1} = 1 ‘
il Retriere. Firzt Prior Mexe Lazt Print Cloze
=
Id  Last Name First Name Job Role Street City State  Zip Phone Fax
61 Carter Jimmy Marketing Feanut Wiay Aflanta 3A FOER (40M)555-TEER (404)555-4291
16 Moore Dawn Sales One Park Drive Aflanta A FOEEH  (A04)5E5-45%4 (404)566-3291
50 Shishoy Irina Marketing 567 Park Drive Aflanta 3A FOZER (404)555-123% (4041555-6337
59 Masalshy Kurt Customer suppart 29 Garden 5t Aflanta GA 3E (404)555-5111 (4041555-8347
21 Cobb Faul Customer support 4 Greermile St Aflania aA F03ES (404)555-2Es (404565-5111
27 Evans Carrig Sales 3 Miashington 5t Alanta 3A FOER (404)555-1169 (4041555-5244
36 Caruso nAlliam Finance 29 Edison 5t Bedford A M7 (B17)555-2144 (B17)565-1656
&0 Collins haryBeth  Administration 5 Lincoln Sreet  Burlington A o1&0E  (B17)555-118% (B1TIE66-9556
23  Cohen Faul Customer suppart 10% Park Street Burlineon A ME0F  (B17)555-3%%2 (B17)565-4499
46 Crossiand Ellen Product development 27 Rush R, Eurlincion A oE0z  (617)555-0004 (B17I565-8005
34 Crowley Charles Human resources &4 Edson 5t Burlingon (L5 OE0E  (B17)666-1344 {B17)666-9877
19 Chin David Procuct development 16 Waverly Ra. Burlincon A ME0F  (B17)5556-337% (B17)555-4453
3 Critchy Susan Product development 45 Center St Darwers A om9zz  (508)555-4829 (508)565-3025
10 Clarke hdolky Sales 5& Pine Growe Rd.  Lexington A 0HTE  (B17)555-4525 (B1TIEEE-T638
| -
<| | v oz
|Ready A

Now you are finished using this report and using the application.

17 Click the Exit button.

This closes the report and the application.

Congratulations. Now you have doneit all. You have created data, maintained
it, and reported on it. And you have put all your work together into your own
application. See the next page for some suggestions on what to do next.
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You might be ready to make your own InfoMaker application or you might be
interested in learning more by using the samplelibrary, tutor_im.pbl. Here are
some idess.

Personalize the contact data Deleteall the datain the contact table and add
your own. You can run your Contacts application to do this. Use the form to
delete and add data.

Look at other sample forms and reports  In the Environment tutorial, you
accessed afew of the sampleforms and reportsdelivered with InfoM aker. Now
you can go back and look at more. The samples are located in tutor_im.pbl.
When you look, notice both the design version and the results you get when
you run aform or report.

Use the sample pipeline  The sample library includes a sample pipeline.
Pipelines let you move data structures and data within and between databases.
Open the library and double-click the pipeline. This takes you to the Data
Pipeline painter. The sample pipeline creates a copy of the employee tablein
the EAS Demo DB. To create the copy, you execute the pipeline.

Change sample forms and reports  If you want to try some changes with
samples, open the form or report and use Save As on the File menu. With Save
As, you create a copy of the form or report and save it with anew name. Then
you can make changes without affecting the original.

Create other forms and reports using the EAS Demo DB Onceyou have
looked at the sample forms and reports, try creating some on your own. The
EAS Demo DB has several tables that you can use. You might want to start
with the contact table since you are familiar with it. Use the other InfoMaker
documentation and online Help as you work.
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A

actionsinforms 46

Adaptive Server Anywhere database 95, 102
AND operator 136

applications

about 179

applying retrieval criteriain forms 197
assigning version numbers 183
creating 188

creating shortcuts 189

defining menuitems 187

defining MicroHelp 186

defining toolbar buttons 186

defining toolbar items 185
executable (EXE) files 180, 188
initidization (INI) files 180, 188
modifying most recently created 185
running forms 195

running reports 199

selecting objectsfor 184

setting retrieval criteriainforms 197
specifying atitle 182
specifyingicons 182

specifying the application filename 182
specifying the folder for the EXE file 182
starting 193

updating the database 196

Ascending sort order option 73

B

buttons

addingtoforms 43
defining in application toolbars 186
movinginforms 50

Getting Started

C
clicking 11
columns
defining display widths 111
defining DropDownDataWindow edit style 113
defining DropDownListBox edit style 106
defining headers 111
definingintables 96
defining labels 111
Null setting 100
setting initial values 117
validating data 117
comments
adding to objectsin libraries 176
modifying for objectsin libraries 176
computed fields, adding to reports 87
contact.txt file 124
control edges, showing in report Design view 70
controlsinforms 43
controlsin reports
deleting 31
deselecting 30
dragging 29
edges, showing in Designview 70
moving 29
selecting multiple 29
showing edges 28
copying
forms 169
queries 169
reports 169
counts, adding to reports 87
Create Executable dialog box 181
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D

d_dddw_statesreport 170
data sources

defining for forms 35

defining for reports 62

Query 139

Quick Select 36, 61
datavaluesin edit styles 108
data, importing into tables 123
database

canceling changes 196

insertingrows 55

retrieving 124

updating 58, 124, 196
Database painter 96
dates, adding to reports 85
deleting

forms 169

queries 169

reports 169
Descending sort order option 73
dialog boxes

Create Executable 181

Edit Style 113, 118

Executable Items 185

Modify Expression 88

New Form 35, 36

New Report 141

Print 94, 161

Quick Select 36, 37, 38, 62, 127

SaveAs 93

SaveForm 42

Save Query 132

Save Report 69, 154

Select Action 45

Select Form 34

Select Import File 123

Select Query 140

Select Tables 97

Specify Retrieval Criteria 175, 200

Specify Sort Columns 72

tabsinthe SQL toolbox 134
display valuesin edit styles 108
dragging 43

210

DropDownDatawWindow edit style
about 114
database and PBL requirements 170
defining for column 113
DropDownListBox edit style
defining 106
using 56

E

Edit Mask edit style

defining 118

using 57,121
Edit Styledidlogbox 113, 118
executable (EXE) files 180
Executable Itemsdialogbox 185
extended attribute system tables 39
extended attributes 105

F

Form painter 34
forms

actions 46

adding buttons 43

adding reports 51

adding scroll barsto reports 53
adding titles 48

applying retrieval criteria 197
changing bordersfor data 49
controls 43

copying 169

creating 34

datasources 35

deleting 169

making reportsresizablein 53
moving 169

moving buttons 50
openinginalibrary 164
previewing (running) 40, 54
resizing reportsin 53
running in applications 195
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saving 42
setting retrieval criteria 197
styles 35

G
graph type, changing 157
graphs
adding tittes 157
Bar type 159
changing type 157
creating 149
defining data 150
Pietype 159
previewing 153
printing 161
repositioning 156
resizing 156
saving 154
grid, displaying in report Design view 28
grouping inreports 74

I

icons, specifying for applications 182
IM.INI 180

IM100.EXE 180

importing data 123

initial values, setting for columns 117
initialization (INI) files 180
inserting rows in the database 55

L

lasso selection 31, 49
libraries
adding commentsto objects 176
changing current 168
copying objects 169
deleting objects 169
modifying comments for objects 176
moving objects 169
opening 168

Getting Started

Index

opening objects 164
Library painter 163
LIKE operator 203

M

menu items, defining in applications 187
menus, about WindowToolbars notation 18
MicroHelp, defining in applications 186
Modify Expression didlogbox 88
mouse

clicking 11

displaying apop-up menu 17

dragging toolbars 17
moving

forms 169

queries 169

reports 169
MYLIB.PBL 168

N

New Form dialog box 35, 36

O

objectsin libraries
adding comments 176
copying 169
deleting 169
modifying comments 176
moving 169

operators
logical AND 136
logical LIKE 203

P

page numbers, adding to reports 86
painters

accessing 11

Data Pipeline 208
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Database 96

Form 34

Library 163

Query 127

Report 146

PDF, saving areportas 93
pipeline 208
popup menus

displaying 17

using 23
previewing

(running) forms 40, 54

graphs 153

queries 131

reports 67

primary key, defining for atable 103
Print didogbox 94, 161
printing

graphs 161

reports 92, 94
prompting for retrieval criteria 174, 200
Propertiesview 23

Q

queries
about 125
copying 169
deleting 169
moving 169
openinginalibrary 164
previewing 131
saving 132
selecting columns 127
specifying selection criteria 134
specifying sorting 137
using asdatasource 139
Query painter 127
Quick Select datasource 36, 61
Quick Select dialog box 36, 37, 38, 62, 127

212

R
Report Options property sheet 27
Report painter 146
reports
adding adate 85
adding atitle 82
adding computed fields 87
adding counts 87
adding page numbers 86
addingtoforms 51
copying 169
creating 60
creating from queries 139
creating new from existing 172
datasources 62
deleting 169
deleting controls 80
detail band 77
displaying grid in Design view 28
displaying rulersin Design view 70
footer band 77
group header band 77, 79
group trailer band 77
grouping 74
header band 77
moving 169
opening 146
openinginalibrary 164
previewing 67
printing 92,94
prompting for retrieval criteria 174
rearranging controls 76
resizinginforms 53
running in applications 199
saving 69
savingasPDF 93
selecting all text 81
showing control edges 70
sorting 72
specifying retrieval criteria 174
styles 61
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summary band 77
tabular style 61
working with bands 77
retrieval criteria
applying informs 197
selecting columns for prompting 174
setting informs 197
specifying for reports 174, 200
retrieving data 124
rulers, displaying in report Design view 70

S

Save Asdidogbox 93
Save Form dialog box 42
Save Query didlog box 132
Save Report dialog box 69, 154
saving
forms 42
graphs 154
queries 132
reports 69
scroll bars, adding to reportsin forms 53
Select Action dialog box 45
Select Form dialogbox 34
Select Import Filedialogbox 123
Select Query dialog box 140
selecting
lasso 31,49
multiple controlsin reports 29
shortcuts, creating for an application 189

sorting
inqueries 137
inreports 72

inreportsin an application 206
Specify Retrieval Criteriadialog box 175, 200
Specify Sort Columnsdialog box 72
specifying retrieval criteriafor reports 174
starting InfoMaker 7, 10
StyleBar, using 45
styles

of forms 35

of reports 61

Getting Started

T

tables

about 95

commenting 104

creating 96, 102

defining aprimary key 103
defining columns 96, 101
importing data 123
saving 102

text file, for importing data 123
titles

adding toforms 48
adding to graphs 157
adding toreports 82
toolbar items, defining for applications
toolbars

about 16

defining buttonsfor 186
dragging 17

making floating 17
Objects drop-down tool bar 20
showing PowerTips 20
showingtext 19
TUTOR_IM.PBL 8, 165
tutorials

requirementsfor using 8
times 8

U

undoing changes 31
updating the database 58, 124, 196

Vv

validating data 117

vadidationrules 117

version numbers, for executables 183
views, managing 21

X

XML, saving areportas 93

185

Index
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