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About This Book

Audience This book is for new InfoMaker® users.

How to use this book Thisbook introduces InfoM aker and providesatutorial for learning to use
InfoMaker. The lessons teach InfoMaker basics and how to create forms,
reports, queries, and graphs. The last lesson puts everything into an
InfoMaker application.

Related documents When you have a question about using InfoMaker, you can access its
online Help system or consult one of the following books:
Book Description
Installation Guide | Providesinstructionsfor installing InfoM aker
Getting Sarted Introduces you to InfoMaker and provides atutoria you
can step through to learn the basics
User’s Guide Tells how to use InfoM aker to create reports, work with

databases, transfer data between databases, createformsto
update data, create queries to retrieve data automatically,
and create applications to package reports and forms

Connecting to Tells how to connect to a database from InfoM aker;
Your Database describes how to set up, define, and manage database
connections accessed through a standard database
interface (such as ODBC or JDBC) or one of the
InfoMaker native database interfaces

Other sources of Use the Sybase® Getting Started CD, the SyBooks CD, and the Sybase
information Product Manuals Web site to learn more about your product:

*  The Getting Started CD contains release bulletins and install ation
guidesin PDF format, and may also contain other documents or
updated information not included on the SyBooks CD. It isincluded
with your software. To read or print documents on the Getting Started
CD, you need Adobe Acrobat Reader, which you can download at no
charge from the Adobe Web site using alink provided on the CD.

Getting Started Vii



If you need help

Viii

*  The SyBooks CD contains product manuals and is included with your
software. The Eclipse-based SyBooks browser allows you to access the
manuals in an easy-to-use, HTML-based format.

Some documentation may be provided in PDF format, which you can
access through the PDF directory on the SyBooks CD. To read or print the
PDF files, you need Adobe Acrobat Reader.

Refer to the SyBooks I nstallation Guide on the Getting Started CD, or the
README.txt file on the SyBooks CD for instructions on installing and
starting SyBooks.

*  The Sybase Product Manuals Web siteisan online version of the SyBooks
CD that you can access using a standard Web browser. In addition to
product manuals, you will find links to EBFs/Maintenance, Technical
Documents, Case Management, Solved Cases, newsgroups, and the
Sybase Developer Network.

To access the Sybase Product Manuals Web site, go to Product Manuals at
http://www.sybase.com/support/manuals/.

Each Sybaseinstallation that has purchased a support contract has one or more
designated people who are authorized to contact Sybase Technical Support. If
you cannot resolve aproblem using the manuals or online help, please have the
designated person contact Sybase Technical Support or the Sybase subsidiary
inyour area.

InfoMaker
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CHAPTER 1

Getting Started

Welcome to InfoMaker

InfoMaker is apowerful yet easy-to-use reporting and data maintenance
tool that lets you work with data in the Windows environment.

With InfoMaker you can create sophisticated forms, reports, graphs,
crosstabs, and tables, as well as applications that use these as building
blocks. You can also move data between databases using the InfoM aker
data pipeline.

This chapter describes:

¢ What you make with InfoMaker
e Starting InfoMaker

e Using thetutorials

¢ InfoMaker samples



What you make with InfoMaker

What you make with InfoMaker

Forms

Reports

L] Employee Data

Employee Data

Employee ID: 102
Manager ID: 501
Emp. First Hame: Fran
Emp. Last Name: \Wwhitney
Department ID: 100
Street: 43 East\Washington Street
City: Meedham
State: ma
Zip Code: 02132-
Phone: (617) 555-3985

Sex: O Male
&) Famale

Birth Date: | 06/05/1966

Soc. Sec. No.: 017-34-9033

Salany:|  $45,700.00

Start Date:  02/26/19594

Termination Date:|  00/00/0000
Status: (=) Active

Health Insurance:
Life Insurance:
Day Care: [ |

O Terminated
) 0On Leave

B Report - emp,_total_compensation

BE2 John

Total Compensation Report Value of bealth ins, = §4,300 p:?ﬁ;;g;;
Sal ary Plus Beneﬁts Vaiue of life insurance = 3(5.43 x salang 1,000
VVatue of day care = §5,200
Department  Empl Empi Empl Salary Health Life Day Salary Plus
D D First Hame Last Name Ins. Ins. Care Benefits
100 445 Kim Lull $57,900 O 93177
501 David Scott $96,300 F106,823

200 anz Judy Snow $a7.500

Total: $a7.500
BAverage: 487,500

$92,775

Total: §92,775
Average: §42,775

InfoMaker



CHAPTER 1 Welcome to InfoMaker

Crosstabs
Humber of employees by Total number of
department and salary employees making
the salary
(0,000 includes up to 39,999
Dept Id
Salary] 100 200 300 400 500
20000 2 ] 7
30000 3 g 2 5 2 20
40000 =1 5 2 5 1 19
50000 4 3 3 2 1 13
60000 4 1 2 7
T0000 2 1 1 4
0000 2 1 3
90000 1 1
130000 1 1
Total number of employees 2 18 g 16 g
n the department
Reports with nested
reports
4/19/2007 Customers and Orders
Customer Information Order History
Customer ID: 101
First Name: Michael Sales Order Date Sales  Line # Product Quantity  Date
) Order ID Rep ID (1] Shipped
Last Name: Dgvin [ ]
. ; 200 03A 407 2495 1 300 12 040307
Address: 3114 Pioneer Avenue 2 01 12 anan?
City: Rutherford J . SR | 12 04114007 |
State: NJ
Zip Code: 07070-885s |
Phone Humber: (201 555-8955 W05 O0an7  BS 1 700 12 030an7)
Company Name: The Power Group
- -
2 36 o4ma7m?
3 36 o4ma7m?

Getting Started 3



What you make with InfoMaker

Composite reports

311812007 Quick Reference Information
Products and Current Inventory Sales Repri ives and Total Number of Orders
Product Product Product Unit  Humber Sales Humber of
1] Hame Description Price  in Stock Rep ID Hame Phone Orders
300 Tee Shirt Tank Tap $a.00 18 129 Philip Chin (4041 555-2341 57
3mM Tee Shirt W-neck 1400 39 148 Julie Jardan (B171555-7838 2
302 Tee Shirt Cresn Meck F14.00 72 193 htarc Dil (B171555-2144 a0
400 Bazehall Cap Cotton Cap Fa.00 a2 299 Rolin Overbey (5100 555-725E 114
401 Bazehall Cap Woal cap F10.00 12 467 James Klobucher (713) 555-8627 )
500 Wisor Cloth “isor $7.00 36 BET hiary Garcia (7131 555-3431 a4
s Wisor Plastic Yisor $7.00 28 690 Kathleen Poitres (6171 555-3920 52
600 Swvestshirt Hooded Swestshirt F24.00 34 856 Samuel Singer (5083) 555-3258 55
B01 Swyeatshirt Fipped Sweatshirt 24 00 32 anz Judy Snow (508) 555-376E 47
700 Shorts Catton Shorts #1500 a0 349 Pamela Savarino (310) 555-1857 52
1039 Shih Lin Chao (B17)555-5921 1
1142 Aligon Clark (5100 555-9437 a7
1596 Catherine Pickett (6171 555-347¢E a3
Product Sales Summai
v Sales Summary
Product Product Product GQuantity "
(1] Hame Description Sold Dollars Zipped Sweatshirt
R ool cap
300 Tee Shirt Tank Top 2374 521 366
) V-ne
301 Tee Shirt “-neck 2403 §33642 Tank Top
302 Tee Shirt Craw MNeck 239 §29946 Flastic Visor-
400  Basebsl Cap  Cotton Cap 3310 F29,790 Hooded Sweatshirt:
401 Basehall Cap  wool cap 2677 F2BIT0 Grew Ne oo
500 Visor Cleth Visor 2652 $18 564 Cotton Shors
Cotton Cap
a0 Visor Plastic Yisor 2508 §17 556
Cloth Visor:
GO0 Sweatshirt Hooded Sweatshirt 3060  §73 440 F T T T 1
] 20000 40000 60000 80000
B0 Swestshirt Zipped Sweatshit 2745 $65952 Dallars
700 Shaotts Cotton Sharts 4536 $55,040

Forms with reports

Contact Information

=)

[Add a contact] ’Delete a contact] ’Save changes]
Last Hame: |Hildebrand
First Name: 10 Last Kame First Name  Job Role ~
Job Role: 1 Hidebrand  Jane htarketing 12
Street: |1 280" ashington St. | z gimmon Larry Sales ]
. - i3 Critch Susan Product developmert 45
City: [Emenyile | 4 Lambert Tarry Administration 20
State: |3 Sulivan Dorothy Customer support 54
. 6 Paul Rose Finance %
Zip: [4608
. 7 Glassmann  Beth Product development 44
Phone: |510] 5551309 S Poell Gene Trairing B8 4
Fax: [[510) 555-4209 b L4

4 InfoMaker



CHAPTER 1 Welcome to InfoMaker

Graphs
Contacts by Job Role
B administration BET%  500%
I cCustormer support
B Docurmertstion
[ Finarce 25.00%
l:l Human resources
@ Marketing
Bl Cther
Bl Frocuct developrment
Bl seles
[ Training 16.67%
1 g7 10.00%
Reports with graphs
Breakdown of Salary Expenses
Department Total Sala
P v Salary Expense by Department
Finance $535500.00
Marketing $688,250.75 Shipping
R&D $1,292,198.19
Salkes
Sales $919,428.00 IS
=
Shipping $303,769.50 & R&pD
&
Mareting
Financ=
DI EDJIJJD 1Cl:l_ll:l:0 153_10:0
Total Salsny

Getting Started 5



What you make with InfoMaker

Labels

Applications

Alex Ahmed
114 Cushing Street
Meedham, WA 02192

Joseph Barker
58 West Drive
Bedford, MA 01730

Irene E
37 Gles
Eedfon

Jeannette Bertrand
208 Concord Street
Acton, MA 01720

Janet Bigelow
84 Lunda Street
Waltharn, MA 02154

66 Bea
MNeedh

Jane Braun
45Wood Street
Cambridge, MA 02140

Rohert Breault
A8 Cherry Strest
Milton, MA 02186

M atthe
a7 Tayl
Lexing

Joyce Butterfield
118 Adams Street
Cambridge, MA 02140

Help

B

By Job

% Contacts
File

Display  Rows

D w
Forms  Reports  Ad Hoc
<@ 5] <

: Rettiewe  First Prior

Window

@ B & B

By Job Data Exit

=

Mext Print

Help

Last

R Report - contactgrid_with_prompting

3 Critch Susan
7 Glassmann Beth

1% Chin Diavid
26 Mulley Joan
30 DeMarco Michael
35 Burril Dana
40 Jordan Susan
42 Haddad Paul
46 Crossland Ellen

55 Kosko Kirn

Last Name First Name

Job Role
Product development
Product development
Product development
Product development
Product development
Product development
Product development
Product development
Product development
Product development

Shih Lin Chao
549 Halyake Street
Lexington, MA 02173

Close

Street City
45 Certer St Daners
44 (ak 5t Lexington

16 Wigverly Rd. Burlington
109 Wigsthorn Ter. Burlington
2% Clare Ave. Bedford

224 Beacon St Meedham
46 Gordon St Burlington
449 Pleasant &t Schaumburg
27 Rush Rd Burlington
34 Pleasant 3. Houston

his
his
hiA
MA
18
18
18
IL

hdA
T

Doug «
57 Wet
Concol

923
0217y
M30%
L E
070
02192
01803
60T
20z
0TS

InfoMaker



CHAPTER 1 Welcome to InfoMaker

Starting InfoMaker
These instructions assume that you have aready installed InfoM aker.
For information, see the Installation Guide.

[TTo start InfoMaker using the Windows Start menu:

«  Display the Start menu and sel ect Programs, then Sybase, then InfoM aker
11.0, and then InfoMaker. Theinitial InfoMaker screen displays.

Theinitial screen includes the PowerBar, which has buttons for creating
new objects and accessing existing objects.

IT0 tutor_im. pbl - InfoMaker,

File Tools ‘Window Help

NeEE=n a8k

IReady |

Notice that the buttons on the PowerBar display iconswith no associated text.
You can display button text if you want to, and you will learn to do that in
Lesson 1.

Getting Started 7



Using the tutorials

Using the tutorials

Requirements

If you do not have
SQL Anywhere

Approximate times

To use the InfoM aker tutorials, you need to:

* Beconnected to the EAS Demo DB

* Havethe sample library named tutor_im.pbl open

Thistutorial usesthe EAS Demo DB database that installs with InfoM aker.
ThisisaSQL Anywhere® database and requires a SQL Anywhere engine.

» If you do not already have SQL Anywhere on your local machine or
server, you must install it now. (You caninstall it from the product CD.) If
you installed InfoM aker in anondefault location, you must make sure that
the odbc.ini registry entry defining the EAS Demo DB as a data source

points to the correct location of the SQL Anywhere engine.

Tutorial Lesson | Minutes
InfoMaker Basics | 1 15
Form 2 45
Report 3 45
Table 4 45
Query 5 15
Graph 6 30
Environment 7 30
Application 8 30

InfoMaker samples

The InfoMaker sample library named tutor_im.pbl isthe library you usein the
tutorials. The tutor_im.pbl library includes sample reports, forms, asample
query, and a sample pipeline. After you have finished with the tutorials, you
might want to look at these samplesto learn more. Many of the samples are

discussed in the InfoMaker User’s Guide.

InfoMaker



LESSON 1

Getting Started

InfoMaker Basics Tutorial

The InfoMaker world is afriendly and efficient environment in which to
work. It providesfeatures such asmovabletoolbars, pop-up menus, views,
and more.

In thistutorial you learn the basic skills you need for working in
InfoMaker.

How long does this tutorial take?
About 15 minutes.




Start InfoMaker

Start InfoMaker

Where you are
> Start InfoMaker
Access objects and painters
Use toolbars
Use views
Use pop-up menus
Use the mouse with controls

First you start InfoM aker.
1 Display the Windows Start menu.

2 Select Programs, then Sybase, then InfoMaker 11.0, and then
InfoMaker.

ThelnfoMaker initial screendisplays. It includesthe PowerBar, which has
buttons for various InfoM aker activities.

IT! tutor_im. pbl - InfoMaker,

File Tools ‘“Window  Help

e En fngE i

JReady

10 InfoMaker



Lesson 1 InfoMaker Basics Tutorial

Access objects and painters

Where you are
Start InfoMaker
> Access objects and painters
Use toolbars
Use views
Use pop-up menus
Use the mouse with controls

1 Click the Open button in the PowerBar.

{1 tutor_im. pbl - InfoMaker,

File Tools ‘Window Help

”rﬁel@nﬁUﬂﬁgé

Mew Open i Sel Lib LikLizt  To-DoList  Library DE Prof  Databaz, Exit

Your toolbar does not show text on the buttons by default. You learn how
to display text in afew minutes.

Getting Started 11



Access objects and painters

12

The Open dialog box displays. It lists the objectsin the current library,
whichisthelibrary named tutor_im.pbl. Thislibrary includes samplesthat
come with InfoMaker; it isthe library you use for the tutorials.

Open f'5__<|

Chiject:

8] 4
| o)

cuskomer_maintenance
departments_and_their_employess
employee_data

Cormments:

Sample: Master/detail many-to-one Form, The master #
patt is & lisk of company names and IDs, Select a =
company and lack in the detail part for details about

p E
Object Type:
| [£] Forms w |

If the current library is not tutor_im.pbl
If the current library is not tutor_im.pbl, you need to change it. Select

File>Select Library and use the Browse page to navigate to tutor_im.pbl
inthe Tutorial folder (inthefolder structurewhere InfoMaker isinstalled).
Then click the Open button in the PowerBar.

InfoMaker



Lesson 1 InfoMaker Basics Tutorial

Getting Started

2 Select Reports as the Object type at the bottom of the dialog box.
Click expenses (scroll the list until you see the report named
expenses) and then click OK.

Open ['5__<|
Object: oK
o '

Cancel
emp_nup_salary_benefits ~ -
emp_telephone_attributes -

emp_total_compensation

emEIoéee irouEed salari

printer_sales
tabular_orders

£

Camments:

Tutorial: Used for tutorial, Expenses for years
1995-1997

Library:

S %
Ohbject Type:

5 Reports w
@ |

InfoMaker connects to the EAS Demo DB and the report displaysin the
Report painter. You learn about the Report painter in the Report tutorial.
For now you learn basic skills.

First you are going to make a few settings in your working environment.

3 If InfoMaker does not fill your screen, click the maximize box in the
upper-right corner of the InfoMaker frame.

InfoMaker fills the screen.

13



Access objects and painters

14

Select View>Layouts>(Default) from the menu bar.

InfoMaker displays the Report painter default layout of views. (Your
views may already have been set to the default. Now you know how to get
back to the default anytime you want to.)

7 tutor,_im. pbl - InfoMaker

Fle Edit view Insert Format Design Rows Tools Window  Help
el R En@s|k
HES O A BEL| G E <

=} expenses ™ - Report

 —

[¥Fraperties - Dal =] X
|| General | pairker | Prink Speck ¥
Urits

1/1000 Inch (2) -

Amount Tirmer Interval:

i thoveonde i —

1: Header group year e i Back 7]
[Jtwindows Backaroun v
= [ Hide Gray Line on page break.
[ Web Datatwindow
[ show Backeolor On 2P

today()
Expenses for year ‘Page ' + page(

)|

Expenses for 2003 Pag

Amount
in thousands v

[ Export | Impor - =ML - (untitled)
[X] 7l version="1.0" encading="UTF-16LE" standalone="ro" ? ~
=4 expenses
E-¢] expenses_row
B year

(Colurnn Specification - expanses

Mame Type |Prompt DB Name
wear char(4) [J [Fin_data.year

quarker  char(2) [J [fin_data.quarter

1
2

3 |amount  decimalf)) [] [fin_data.amounk
4 |ype char(10) | [] fin_code.type
5

description char(50) | [ Fin_code.description

Column Specification - expenses {Data - expenses yControl List - expenses

Fage 1 of 3 Nothing Selected

Now you close the views at the bottom of the screen since you are not
going to be using those views.

Move the pointer until it is over the Close button (the button with the
Xinitin the upper right) in the Export/Import Template view and click
the button.

The view closes and the tabbed view (originally positioned on the bottom
right) displaysin the full horizontal space.

InfoMaker



Lesson 1 InfoMaker Basics Tutorial

Getting Started

Now close the tabbed view using the same process you used with the
Export/Import XML Template view.

Your screen should look something like this now. Because InfoM aker
offers so much flexibility in arranging your work area, your screens may
not match many of the picturesin the remaining lessons. It does not matter
aslong as you are getting the correct results.

) tutor_im, phl - InfoMaker

File Edit View Insert Format Design Rows Tools Window  Help
Hst=SEli=E ACE =110 0
He W At REAL|GRFE

z
H expenses * - Report

—
=] [=]
E , today] ™| General | painker | Print Specf ¢ *
Xpenses 1or year Page "+ page) | .
1§1000 Inch (2} v
Amount Timer Inkerval:
.
Header { Cok
1: Header group year | olor
[Jwindow Backaround b
description
= H“d:: aroup duscr i [JHide Gray Line on page break.
quart amoun [[] weh Datawindow
Detail T [ show Backeolor On &P
surmiar
: Trailer group description |
Expenses for 2003
Amount
in thousands
Administration
Q 381
Q2 402
Q3 412
2] Az s
< | ¥
Ready Page 1 of 3 Mothing Selected

=

5



Use toolbars

Use toolbars

Where you are

Start InfoMaker

Access objects and painters
> Use toolbars

Use views

Use pop-up menus

Use the mouse with controls

InfoMaker comes with several toolbars. the PowerBar, three PainterBars, and
the StyleBar. You can control whether individual toolbars display and where
they display. You can also choose whether to display text in the toolbars.

In this exercise you learn how to use toolbars.

(You can also create your own toolbars and customize toolbars. See the
InfoMaker User’s Guide for more information.)

1 Move the pointer to the toolbar area.
Click the right mouse button.

The pop-up menu for the toolbars displays.

il tutor_im.pbl - InfoMaker

File Edit Wiew Insert Format Design  Rows Tools  ‘Window Help

f:’B[._’Jl@EleJEEE_:E}l“‘: PowerBarl
B R RER R | 1% 3| B x PainterBiart

H expenses * - Report LT I
PainterBar3 i
StyleBar
Expenses for Let :
Amount Right
in thousands
Headar T 4] [
1: Header group year f Floating L
description Customize. .. L
Z: Header group description L
quart amaun New...
Detail Show Text -
surnfar Shiw Power Tips L

2: Trailer group description |

About the pop-up menu
Throughout | nfoM aker, pop-up menus provide afast way to do things. The

right mouse button accesses the pop-up menu. The menu changes
depending on the painter you arein and where you are when you click the
right mouse button.

16 InfoMaker



Lesson 1 InfoMaker Basics Tutorial

2  Select Floating from the pop-up menu.

The PainterBar changes to a floating toolbar.

3 Move the pointer to the title bar and drag the floating toolbar to
another location.

How to drag the toolbar
Press and hold the left mouse button. While holding the button, move the

mouse (an outline displays to show the current location of the toolbar).
When the toolbar is where you want it, release the mouse button.

You can put toolbars in different locations: left, top, right, bottom, and
floating.

4  Select Tools>Toolbars from the menu bar.

About the notation Tools>Toolbars
Throughout the tutorials, commands issued from the menu are shown asa

sequence of choices separated by arrows. For example, to select
Tools>Tool bars means to select Tools from the menu bar and then
Toolbars from the menu items.

TheToolbarsdialog box displays. Noticethat the PowerBar ishighlighted.
If the PowerBar is currently displayed, the middle button says Hide.

Toolbars g|

Select Toolbar: o
PinerBarl O Left
O Tap

PainterBarz
PainterBar3 O Right

StyleBar T
Opotton
(%) Flnating m

[ 5how Text Show Power Tips

Mew,
Conkemporary Style
Font Mame: Font Size:
Small Fonts w6 w

5 Click PainterBarl and then click the Bottom button.

The PainterBar displays at the bottom of the InfoM aker screen.
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Use toolbars

6 Click Show Text to make text display on the buttons.

Click the Close button to close the dialog box.

) tutor_im.pbl - InfoMaker,
File  Edit  Wigw

Insert  Format  Design  Rows  Tools  Window  Help

) RS R = S O T VO R T

Hen Opsn Preview  Sellin  Liblst  ToDalst Lty DEPral Db Exit

B expenses * - Report

Expenses for year

Amount
in thousands

1: Header group yeart

description

quant  amour

sumiar

Expenses for 2003

Amnnnt

Units

Timer Interval:

Color

[Hide Gray Line on page
[]web Datawindow
[I5how Backealar on %P

Reeady Page 1 of 3

Dam Gl

7 Move the pointer over one of the toolbar buttons.

After a couple of seconds, the PowerTip that tells what the button does

displays.
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8 Click the small black triangle next to the Text button in the PainterBar.

The Objects drop-down toolbar displays. It holds buttons for the controls
you can add to reports. (A text control is one type of control you can add
to areport.) Several buttons on other PainterBars have small black
triangles. These buttons belong to other drop-down tool bars (such as the
Border drop-down toolbar).

(] tutor_im. pbl - InfoMaker

EEIX

File  Edit Wew Insert Format Design  Rows  Tools  Window  Help

B = 8B 8 Bk

=4 : = 5
T = B B e
New Op=n Preview Sellib Liblet | ToDalet  Libary DEPal  Dabbees Exit

H expenses * - Report

Amount

Expenses for year

in thousands

Urits -
141000 Inch {2)
Tiner Interval:

T: Header group year |

description

[ I'indow Backaror
[[JHide Gray Line on page £

2: Header group description {

gquart  amoun

[] weh Datawindow

[ show Backealor On xp

Sum Iy
< Sebect
N
Lin=
5y
Gampue

X

Hverags

A & & % A
I Prim Tert
Feady

A B [ .
Butian Tem Picture  GraupBax b
[}
= ol of| = ~
Gl Rectingle Andfed  Galumn
] da H
Gmgh  Repnt OLE  ODBGLE
— =y Or 2003
& B & B
Gouml Poge Sum  Tody
v
o 3 » B x
Sart Fiier Do Glme
Page 1 of 3 Mothing Selecte

9 Clickin the white space to the right of the toolbar to make the Objects
drop-down toolbar close.

Now you know several ways to move the toolbars and you know how to turn

text display on and off.

For the rest of these tutorials, you should move the toolbars where you like to
have them. Your screen may not match the picturesin this book, depending on
where and how you display toolbars.
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Use views

Use views

Where you are
Start InfoMaker
Access objects and painters
Use toolbars
> Use views
Use pop-up menus
Use the mouse with controls

InfoMaker provides anumber of viewsin each painter to makeit easier for you
to work. The View menu in each painter lists the views available to you. You
can use the View menu items to display and close the various views. In this
exercise you learn how to manage views.

1 Move the pointer to the upper-left corner of one of the views.
When the bar drops and the pushpin displays, click the pushpin.
Repeat this for the other two views.

Now the three views havetitle bars that identify the Design view, the
Preview view, and the Properties view.

(] tutor_im.pbl - InfoMaker,

File  Edit View Insert Format Design  Rows Tools  Window  Help

& B B »m B mn B @ &

Opmn Freview  Sellin  Liblst  ToDalst  Llibmy DB Pl Dabe  Exit

Expenses for year

1/1000 Inch (2) v

;_Qmount Timer Interval:
in thousands

Color

[[Hide @ray Line on page bt
[J'web Datawindow

[ show Backeolor On 3P

description
Z: Header group description
guart  amaurr

cnfar

EFvnancac far 2NN ¥
) r

T e -]
Sant Fiiar Dot e

Reeady Page 1 of 3
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Move the pointer to the Preview view’s title bar and press the right
mouse button.
Select Float from the pop-up menu.

Now the view isfloating. You can drag it wherever you want it and resize
it as needed.

Display the pop-up menu on the Preview view'’s title bar and select
Dock.

(i tutor_im. pbl - InfoMaker
File  Edit Wiew

P B R B e e

Hew Opmn Preview  Sellib  Libli  ToDolid Libmy  DBFrol  Dasbse  Exit

Insert Format  Design  Rows  Tools  Window  Help

~ -
[SI 1| General [pornter [| prict
= |

Units

Edlterval:

A~ -

Expenses for year

Preview - expen: il s

, -

leader {
+ Header gro indow Backaro s

descriptio Expenses for 20 f &rayline onpaget
Dratavindow

Backcolor On P

: Header gr

Amount

tail -
e in thousands

Administration

Trailer gro s 204 =
: Trailer grot & >
-
&
[ TR, JNGRH NROLLIANC TRy SRl RN~ [
Unds R Tem Gut Gapy Pz Dale  San Fiier Dom  Gloe
!Ready |Page 1 of 3 | |Nothing Selecte | A

The view goes back to where it was. There are more options for moving
views around, including dragging them and overlaying one view on top of
another to make tabbed views. You can read about these in the InfoM aker
User’s Guide.
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Use pop-up menus

Use pop-up menus

22

Where you are
Start InfoMaker
Access objects and painters
Use toolbars
Use views
> Use pop-up menus
Use the mouse with controls

Now you take alook at pop-up menus and the Properties view.

1 Move the pointer to the words Expenses for.
Click the right mouse button.

The pop-up menu for apiece of text (also called atext control) displays.
Whenever you position the pointer on something that has a pop-up menu
and click the right mouse button, the appropriate menu items display.

i tutor_im.pbl - InfoMaker,
File  Edit

Tools  ‘Window  Help

View Insert  Format  Design  Rows

B expenses * - Report

General | pointer | HTML ¢ *

Expenses for year

N ame
o o
Amount = Tan
: = Copy q
in thousands 5
/7 Delete
‘ [(Hidesnaked
Duplicat
. tpltate [ visible =
description Bring ka Front Border
Z: Header group description T
- Alignment
Properties... = Right (1) -
Text

Expenses for

Evnancac far 20N01Y
| >

T VO RUDL SRR NARCITIe VAN YA e TN OSSR

Sarve Temt < Gapy Dbtz Sart Fibier Dot Chee

Ready Page 1 of 3 Text: vear b |2.416,0,1451.:
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2 Ifthe Properties view is not currently displayed, select Properties from
the pop-up menu.
Look at the contents of the Properties view.

The Properties view displays the properties of the Expenses for text
control becausethetext control iscurrently selected. For atext control, the
Properties view has five tabs, which identify five pages of information.
The General page is on top.

F'r-:-pertie-.: - year_k
Genetal |Painter | HTML | Position || Fort | % #

Mame
vear_k
Tag

[THidesnaked
Yisible

Border
MoBorder (00 il
Alignment
= Right (1) w
Texk
Expenses far

I

About the Properties view
The Propertiesview displaysacollection of information about acontrol or

the report object itself. You use the Properties view to find out and set
properties.

For example, atext control has properties such asfont, font size, location,
border, and so on. You can see the current settings for these propertiesin
the control’s Properties view. You can aso change them there.
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24

3

Position the pointer on the word description and click.

The Properties view now displays information for the data column
(Column control) called description. The property pages and options are

different from those for the text control.

=
213 J &5 - description

-I

E 1| General |P0|nter HTML | Pasition | Edit | Format | 104 #
Xpe
p ~ | Mame &
| description |
Amount Tag
in thousands | |
Header {
1: Header group year { D Hidesnaked
. . [¥] wisible |
i description alignment
Zibeadergrompdesrmtionl =gy ~|
quart  amour —
Border
| MNoBorder (0) V|ﬂ
[oisplay as Picture
Protect:
| |2l
v [ owerride Edit
L2 > [ Equality Required ~
I= ol [}

Click the word Font on the Font tab.

The Font page comes to the front of the Properties view.

=
Design - expenses Properties -

description
Painter | HTML | Pasiion | Edit | Format | Font | otk 4 *
FaceMame 2
|1]3Arial v|
. Size
in thousands =
10| v| =
1: Header group year 1 [“]Beld =
description Ttalic ™
2: Header group description T [ underline =
gquart  amour [ Strikeaut =
Texk Calor =
|-Wind0w Text v | 2|
Barckground Calar
| [ ITransparent w | g
Charset
45 |answ! v|
| > I
= |
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5 Select the font size 14 from the drop-down list in the Size box.

The font size of the text control changes to 14 in the Properties view, the
Design view, and the Preview view.

=]

[ Properties - description I=1 1

[=]
E || General | Pointer | HTML || Position | Edit | Form ‘I i
Xpens
p ~ | FaceMame 15
|:§?Arial v|
;.Qmuunt size
in thousands |
Header 1 b ﬂ
1: Header group year | [¥]Eiald g
) Y V] 1talic
description a
. [ underline =
7: Header group description [ [ strikeout =
gquart  amaun Texk Color
|-Window Text v | 2
Background Color
||:|Transuarent v|g —
CharsSet
|ansi‘ - |
Nt
> v
= ] M

6 Select the font size 10 from the drop-down list in the Size box.

The font size of the text control changes back to 10.
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Use the mouse with controls

Use the mouse with controls

Where you are
Start InfoMaker
Access objects and painters
Use toolbars
Use views
Use pop-up menus
> Use the mouse with controls

Now you move some of the controls in the report. Be sure not to save the
changed report, because you will use the original report later. When you leave
the Report painter, you are prompted to save changes. Theinstructions remind
you to say no.

1 Select Design>Options from the menu bar.

The Report Options dialog box displays.

Report Options

General | Generation | Prefixes

Alignment Grid

H v I8 __

[ show arid Y _3

[ shows Ruler
[I5how Edges
Retrieve on Preview
(oI aw] =

In this dialog box, you turn on some design options that make it easier to
work with controlsin reports.
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2

3

Select the Show Grid check box.
Select the Show Ruler check box.
Select the Show Edges check box.

Report Options

| General ..Generation | Prefixes |
Alignment Grid
[ 5nap ko Grid He
Show Grid vl
Show Ruler

Retrieve on Preview

ok ] [ Cancel ] [ Apply ] [ Help

Click OK.

Now edges display around the controls, and agrid and ruler display in
Report painter Design view.

the

(=l
[ Design

|I|||I|1|I|||I|2||I|||I|3|I|||I|4|I|||I|5|I|||I|

il

Header

| Header group year f

__|2:Header group description {

R quart CAMDUIT -5 -

2: Trailer group description t

1: Trailer group year t

Summary {

Footer

< >
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Use the mouse with controls

4  Click the text control with the text Expenses for.

Black boxesin the corners mean the control is sel ected.

5 Press and hold the Ctrl key.
Click the year box and the Amount in thousands box.
Release the Ctrl key.

Now you have selected all three controls.

6 Press and hold the Left Arrow key until the controls are on the far left
of your screen.
Release the key.

7 Move the pointer to the word Expenses.
Make sure the controls are still selected.
Press and hold the left mouse button.
Drag all the controls to the right.
Release the mouse button.

While you are dragging, gray boxes show the current position of the
contrals.
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When you rel ease the mouse button, you drop the controls where the
pointer is currently positioned. Notice that the controls are still selected as
indicated by the little black boxes.

8 Clickin an unused area to deselect the controls.

The controls are no longer selected (the black boxes are gone).

10 Press and hold the left mouse button.
Drag the mouse diagonally down and to the right until the box
surrounds or touches all three controls.
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Use the mouse with controls

11 Release the mouse button.

All the controls are selected. Thisis called lasso selection. You can use
this lasso technique to select many controls quickly. Then you can move
them all together or change something about them all at once.

ryear

N ZZZZZZZZZZZZZ.|Ex

12 Press the Delete key.

The three selected controls are deleted, but you really did not mean to
delete them.

13 Select Edit>Undo Control Delete from the menu bar.

The deletion is reversed.

Ex

About Undo ]
You can undo as many operations as necessary.
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Getting Started

14 Select File>Close from the menu bar.

InfoMaker displays a message box to see whether you want to save the
changes you have made to the expenses report. You do not want to save
changes. You use thisreport later in the Graph tutorial.

2 Save changes to
\-fJ/ c:program files\sybaselinfomaker 11,04 kuborialitutor_im.phli{expenses)?

I Yes ] [ Mo ] [ Cancel

15 Click No.

The Report painter closes. Now you are ready to learn how to create aform.
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Getting Started

Form Tutorial

This tutorial requires the Form painter
The Form painter component of InfoMaker is optional; you must have

installed it to do this tutorial.

Forms display data and provide away to interact with the database. You
can use forms to view information and change it.

Inthistutorial you create a form that updates the contact table. The form
includes:

e All columnsin the contact table
¢ Buttonsfor maintaining contact information

e A report that provides access to al information in the contact table

&} Maintain Contact Information

Id: -T
- [Add El contact] [De\ebe a contact] lSave changes]
Last Mame: [Hildebrand
AL LTS Id Last Name First Name  Job Role ~
Job Role: 1 Hidebrand  Jane Marketing 12
Street: [1 260 Washington St [z Smmon Larry Sales #
. 3 Crich Susan Product developmert 45
City: Emenyvile | 4 Lambert Terry Adtoiristration o0
State: 5 Sullivan Dorathy  Gustomer support &4
. 6 Paul Rose Firance 7§
Zip: [34602
" 7 Gssman Beh Product cevelopmert 44
Phone: |[510)555-1309 % Pouell Gene Training EEw
Fax: [510) 5554209 X b

How long does this tutorial take?
About 45 minutes.
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Create the basic form

Create the basic form

Where you are
> Create the basic form
Preview (run) the form
Save the form
Add buttons to the form
Enhance the form
Use the form to update the database

Now you create the basic form. To do this you select a predefined InfoM aker
form style and the data to be displayed in the form.

1 Click the New button in the PowerBar.

i1 tutor_im. pbl - InfoMaker,

File  Tools ‘Window Help

e B B = B = 8 8 Bk

Op=n Preview Sel Lib Libled  Ta-Dalet  Library DEPral  Databese Exit

The New dialog box displays.

2 Select the Object tab if it is not already on top.

The Object tab page contains the icon for creating any type of new form
and icons for the various report presentation styles.

T & o

Crosstab Freeform Graph

Label

Az Bal

RichText Tabular Treetiew

Ok ] [ Cancel
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3  Select the Formicon and click OK.

The New Form dialog box displays. It contains the data sources and form
styles you can choose.

New Form rg|
Data Source
-
2
55
SGL Select Query
Farm Style
— — = —
EE
Fee FOFm

Grid Master/Detal  Master/Detail
One-To-Many  Many-To-One

About data sources
Quick Select issimply for choosing columns and specifying selection
criteriaand sorting, which iswhat you want for this tutorial.

SQL Select isfor using other SQL options not available with Quick
Select.

Query isfor specifying the name of aquery that describesthe data source.
You define queriesin the Query painter.

About form styles
A form styleisapredefined way of presenting and processing information

on the form. Usually the style includes the common database functions
(insert, delete, and update).

InfoMaker comes with a set of form styles. PowerBuilder® users at your
site can create additional styles, which also display in the New Form
dialog box.
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36

4

Click Quick Select and Free Form to select them (the words are

highlighted).

New Form

Data Source

S0L Select Query

=
(==]
Grid Master/Detail  Master/Detail

One-To-Many  Many-To-One

Ok

Cancel

Help

X

Click OK.

The Quick Select dialog box displays. In this dialog box you select the
table to use and the columns you want to include in the form.

Quick Select

1. Click on table(s) to select or deselect

2. Select one or more columns,

3, {Optional) Enter sorting and
selection criteria below,

Ta display comments for a
table or column, click
the right mouse button,

Tables: Columnnis:

X

Cancel

Donus
call_track
contact
custamer e
department

employes

exam_xref_info

exam_xref _list

examples

£ |

Comments:

|

(.74
[l

Help

|

Calurnn:
Sort:
Criteria:
Qs
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6

Click contact in the Tables box.

The columns for the contact table display. You include all columnsin the

form.

Quick Select

1. Click on table(s) to select or deselect

2. Select one or more columns,

3, {Optional) Enter sorting and
selection criteria below,

Tables:

Comments:
A list of contacts

Ta display comments for a
table or column, click
the right mouse button,

Columnnis:

X

id
last_name
first_name
Litle:

street

city

state

zip

59 |

|w

~

| £

Help

Calumnn:
Sort:
Criteria:
Or:

23
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Create the basic form

38

Click the Add All button

All columns are selected. They display in agrid at the bottom of the dialog

box.

Quick Select X

1. Click on table(s) to select or deselect

2. Select one or more columns,

3, {Optional) Enter sorting and
selection criteria below,

Tables:

Comments:
A list of contacts

Ta display comments for a
table or column, click
the right mouse button,

Columnnis:

K

Cancel

Add Al

Help

Calumnn: 1d
Sort:
Criteria:
Or:

Last Mame

First Marne

{3

|£

You could reorder columns and enter sorting and selection criteriain this

grid. For your form you do not need to do any of these things.
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8 Click OK.

Your form displays. It uses the columns and form style you selected. The
text labels come from the extended attribute system tables. Instead of data,
the names of the database columns appear where the data values will be

displayed.

(=
Layouk

1d: A
Last Name:
First Mame:
Job Role:

Street: |c:0ntac:t_street

City: |c:0ntac:t_c:ity |
State:
Zi
Phone:
Fa

The extended attribute system tables
The extended attribute system tabl es store information about data such as

labelsand display formats. When you create forms and reports, InfoM aker
uses extended attribute information to create the basic form or report.

You put information into the extended attribute system tables using the
Database painter. For example, in the Table tutorial you define the label
Job Role: for thetitle column. Then when you use thetitle columninaform
or report, InfoMaker uses the label Job Role:.
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Preview (run) the form

Preview (run) the form

Where you are
Create the basic form
> Preview (run) the form
Save the form
Add buttons to the form
Enhance the form
Use the form to update the database

Now you preview the form. Running the form isthe way you preview it while
you are designing it and theway you useit when you have finished designingiit.

* 1 Click the Run button in the PainterBar.
Run InfoMaker runs your form, which includes going to the database and
retrieving data.

Notice that real values have replaced the column namesin the form.

{7 tutor_im.pbl - InfoMaker,
File Edt Rows Tools ‘Window  Help

e B B = B = B 8 Wk

Mew  Open Preview Sellib Liblist To-Do.. Lbrary DB Prof Datab Exit
o T oA b koGBS |

&
: Criteria Retrie First Priar Mext Last  Delete Insert Update Close
€ Untitled |'-_| |'E| E‘
T —
Last Name: Hildebrand

First Name:
Job Role:

Street: |1 280" ashington St

City: |E meryville |
State:
Zip:
Phone:
Fau

Ready

The PainterBar now has buttons that let you view and change data. Now
you view the data using the form.
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Click the Next button.
Click the Last button.
Click the First button.

= E B I+

Criteria Apply Rixtrizes First

EAT T S |

Dieleke Ingerk Update Cloge

This moves you among the rows. Later in this tutorial you insert a new

row.

Click the Close button in the PainterBar.

You return to the Form painter Layout view.
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Save the form

Save the form

Where you are
Create the basic form
Preview (run) the form
> Save the form
Add buttons to the form
Enhance the form
Use the form to update the database

Now you save the form and give it a name.

1 Click the Save button in the PainterBar.

Save The Save Form dialog box displays with the pointer positioned for you to
type a name for the form.

2 Type contact_maintenance.

3 Click in the Comments box and type This form updates my contact table.

Save Form rg|

Farms:
o]

| conkack_maintenance | -
customer_details
customer_list
customer_maintenance -
departments_and_their_employees
employee_data

Comments:

This Form updates my contact table,

Library:

eslsybaselinfomaker 11.0%tutarialifutor im.

4 Click OK.

InfoMaker saves your form. Anytime you have completed a unit of work,
you should save. To save, select File>Save from the menu bar or click the
Save button.
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Add buttons to the form

Where you are
Create the basic form
Preview (run) the form
Save the form
> Add buttons to the form
Enhance the form
Use the form to update the database

Now you add three buttons to the form. Later when you run the form, you can
click the buttons to add and delete contacts.

Id: A
Last Name:
First Name:
Job Role:

Street: [contact_street
City: [cantact_city | Save changes
State:
2z
Phane:
Fan

About controls
Theitemsyou seeon aform are called controls. For example, abuttonisatype

of control. The controls you can use on aform are listed in the Insert menu on
the menu bar.

1 Select Insert>CommandButton from the menu bar.

2 Move the pointer to an empty area of the form and click.
If you need to move the button, drag it.

How to drag
Position the pointer over an object, and press and hold the left mouse

button. While pressing the button, move the mouse until the object is
where you want it. Then release the mouse button.
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Add buttons to the form

A button with the text none displays. The text none also displaysin atext
box in the StyleBar.

(=
Layout

1d: s
Last Name: |[contact_last_name none

First Name: |contact_first_name
Job Role: contact_title

Street: |c:0ntac:t_street

City: |c:0ntac:t_c:ity |
State:
Zi
Phone:
Fa

If the text box does not display
This means the button is not selected. To select the button, click it. Small

black boxesin the corners mean it is selected.

3 Make sure the button is still selected.
Type Add a contact.

The text displays on the button as you type and in the text box in the
StyleBar.

4  Click B (for bold) on the StyleBar.

(=]
Layouk
e ~
Last Name: [contact_last_name Add a contact

First Name: |contact_first_name
Job Role: contact_title

Street: |c:0ntac:t_street

City: |c:0ntac:t_c:ity |
State:
Zi
Phone:
Fa
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Thetext displaysin bold. Next you make the button work. To do thisyou
associate an InfoM aker action with the button.

Using the StyleBar ]
You can use the StyleBar to change text fonts, font size, and font style

(bold, italic, and underline). You can also use it to specify text alignment
(left-aligned, centered, and right-aligned).

To use optionson the StyleBar, you select acontrol with text and then click
the appropriate button on the StyleBar.

Move the pointer to the Add a contact button.

Press the right mouse button to display the pop-up menu for the
button.

Select Action from the pop-up menu.

(=
Layout

e ~
Last Name: [contact_last_name Add a contact

First Hame: [contact_first_name JZ| Action...
Job Role: contact_title og' Cut

Street: |c:0ntac:t_street = Copy

City: [contact_cily | /7 Delete
State: Duplicate
Zip: g3, Bring to Fronk
Phone: Lh Send to Back
Fax: Properties

v
£ >

The Select Action dialog box displays. It lists the actions you can assign
to the button.

Select Action f5__<|

Select an action from the list below and

provide parameters as required, o

Actions:
Cancel

Cancel_LUpdates

Clear_Filber

Close

Delzte_Row

Filter_Dialog [

Help
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46

About InfoMaker actions o
An action iswhat you want to have happen when the button is clicked.

Whenever you associate an InfoMaker action with a button, InfoMaker
creates the code to enabl e the button to perform the action. You do not see
the code. All you haveto do is select the action for the button.

InfoM aker comeswith predefined actions. PowerBuilder usersat your site

can create additional actions, which also display in the Select Action
dialog box.

Scroll through the list of actions and double-click Insert_Row.

Select Action

Select an action from the list belaw and
provide parameters as required. o

Actions:

C |
Delete_Raow A s
Filter_Dialog
First_Fows

ImEort Filz

Last_Row bt

Help

InfoMaker creates the code that enables your Add a contact button to
display ablank form so that you can add information for a new contact.
You will see the button work later.

Now you add two more buttons.
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Getting Started

7

Select Insert>CommandButton from the menu bar.

Move the pointer below the Add a contact button and click.

Type Delete a contact.

Display the Delete a contact button’s pop-up menu and select Action.
Select the action Delete_Row from the Select Action dialog box.
Click OK.

Select Action ['5_<|

Select an action from the list below and
provide parameters as required. °

Actions:

Cancel
Clase A

Delete Row
Filter _Dialog
First_Raow
Irmport_File
Insert_Row w

= Help

Select Insert>CommandButton from the menu bar.

Move the pointer below the Delete a contact button and click.
Type Save changes.

Display the Save changes button’s pop-up menu and select Action.
Select the action Update_Row from the Select Action dialog box.
Click OK.

Now you have three buttons. InfoMaker has created the code that enables
the buttons to work.

—
(]
Layaut
m A
Last Name: [contact_last_name | Add a contact -
First N 3 tact_first
irst Name: [contact_first_name | P
Job Role: |contact_title |
Street: [contact_street |

City: |contact_cit}| |
State:
Zi
Phone:
Far

|
v
|
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Enhance the form

Add atitle

48

Where you are

Create the basic form
Preview (run) the form
Save the form

Add buttons to the form

> Enhance the form

Use the form to update the database

In this exercise you:

Add atitle
Change the border for data
Move the buttons

Add areport

Move the pointer to an unused area of the form and click.

This causes the Properties view to display the form’s properties.

Type Maintain Contact Information in the Title box.

The title does not display nhow. When you run the form, the title displays.

B contact_maintenance ™ - Form E”E‘E‘
s | —————————————

[=]
Id: ~ 1 General
Last Name: [contact_last_name \Add a contact — | Color
First Name: [contact_first_name [—Jwindow Backaround b
Delete a contact Tile
Streat: |Dnmact — | Maintain Cantact Information
- = [CIHscraliBar
City: [zontact_city | [Clvscrallar
State: LiveScroll
) [CIHsplitscrall
Zip: _cuntact_zlp
_ [IrightTaLeft
Phone: |contact_phone
Far
a
m >
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Change the border for data
Now you change the border for all data values. Thisimprovesthe form's

appearance. You use lasso select to select the data.

1 Move the pointer near the bottom of the data and on the right.

2 Press and hold the left mouse button and drag diagonally to the left
and up until the box (the lasso) touches all the data.

Id: |conthetl]
Last Mame: @Ml
First Mame: @Ml
e T —

Street: |c:0nt Acth_street

City: |c:0nt hot_city |
State: @ac

3 Release the mouse button.

All the objectsinside the box are selected. Black boxes display in al the

corners.
Id: |contact_j || General | pointer | Position |E ¢ *
Last Name: jcontact_last_name Add a contact [ visible =
f - Alignment
First Name: [contact_first_name DRI "
Job Role: [contact_title
Steel: [contact_strest . L O B (2) )
City: [contact_city L [ cwerride Edit
State: |cantact [C1Equality Required
K
Zip: [contact_zip [CIRightTaLeft

Phone: [contact_phone

Fax: jcontact_fax

4  Select Lowered or whatever value you want from the Border
drop-down list on the General page in the Properties view.
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Enhance the form

All the areas on the form used to display data values now have your
selected border.

B contact_maintenance * - Form

(==l
[ Layaut
I

a2

Last Mame: |contact_last_name | [ visitle =

First Name: |contact_first_name Aligrirent

Job Role: contact_title

Streel: |contact_street

- m

City: |contact_city

[ |

Slale:l contact [CJEqualicy Required
Zip: |cortact_zip [CIrightToLeft

Phone: |cortact_phane

Fax: |contact_fax

%

I~

Move the buttons

Now you move the buttons to make room for the report you are about to add.

1 Select a button.

You can use lasso select or click one. Small black boxes in the corners
mean it is selected.

2 Drag the button to the top of the form.
Select and drag the other two buttons until your form looks like this.

Id:
Last Name: |contact_last_name
First Mame:
Job Roe:

Stieet: |conlac:t_st|eat

~
[Add a cnntact] [Delete a contact] [Save changes ] =

City: |conlact_cily |
State:
Zi:
Phone:
Fax

i)

|

Now there is more room for the report you are about to add.
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Add areport

Getting Started

Now you add a report to provide information when you are working with the
form. You can scroll in the report while you are filling out the form for a new
contact. Thismeans, for example, that you can look up an areacode or zip code
if it isalready present for another contact.

1 Select Insert>Report from the menu bar.
Move the pointer into the workspace.

Your next click positions the report that you are adding to the form.

2 Move the pointer to the empty space on theright part of the form and
click.

Four dots marking the corners of the box that will hold the report display
on the form.

Id: [contact_i 2
[Add a contact] [Delete a contact ] [ Save changes ]
Last Name: contact_last_name
First MName: contact_first_name
Job Role: contact_titlle

Street: |contact_street

City: |contact_city ‘
State:
7w
Phone:
Fax

Now you use the Properties view to specify afew things about the report.
First you are going to select the report whose contents display in the box.

51



Enhance the form
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Click the Browse button (the button with three dots on it) next to the
DataObject field on the General page in the Properties view.

The Open dialog box displays. It lists the reports (DataWindow® objects)
in tutor_im.pbl, the current library.

Open r'5_<|

Datawindows;

attrib_crossout_and_visible o
attrib_escapement_rotation

attrib_font_height

attrib_format

attrib_graybar_emp_total_comp v

Comments:

Sample: Demonstrates the color and underline attributes
by highlighting birthdays of employees that Fall in the
current month,

Library:

elinfomaker 11.00kutorialitutor _im.p

Scroll the list of reports, select contactgrid, and click OK.

The contactgrid report displaysin the form, and its name displaysin the
DataObject field in the Properties view.

General | other
Id: [cantact [: e
[Add a contact] [Delete a cnntact] Saw DataCbject &
Last Name: |contact_last_name i contactgrid I:]
First Name: [contact_first_name Title
Job Role: |contact_title
| visible
Street: |contact_streel | [ TitleBar
City: [contact_city | [CIHserollsar
State: [vscrolpar
" - V| Li
e
Phone: ClrghroLeit
Fau: [l order
3 BorderStyle B
W > T ]l= StyleBox! ¥ =

Next you specify that the report isto have the StyleBox border and scroll
bars.
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Make sure the BorderStyle selection is StyleBox.
Select the HScroll Bar, VScroll Bar and Border check boxes.

1d: [contact_i

Last Name: [contact_last_name
First Name: |contact_first_name
Job Role: [contact_fitle
Street: [contact_street
City: [contact_city
State: [contact
Zip: |cortact_zip
Phone: [contact_phone

Fax: [conlact_fax

[Add a comtact] [Da\ehe a comtact] ISave chamgasl i

Id  Last Name First Name Jo

Getting Started

General | Other

DataObject
contactgrid
Title

visible
[ TitleBar
HscrolBar
VacrolBar
LiveScroll
[Hspiscrall
[rightToLsft
Border
BorderStyle

O StyleBox!

When you run the form, the report displays as a window with horizontal
and vertical scroll bars. This givesyou flexibility in looking at datawhile

working on the form.

6 Resizethereport to show more data.

To resize, move the pointer near an edge until the pointer becomes a

double-pointed arrow. Then press the |eft mouse button, hold, and drag.
Align the | eft edge of the report with the Add a Contact button.

When you finish resizing, the report should look something like this.

Last Name:
First Name:
Job Role:
Street:
City:

State:

Zip:
Phone:

: |contact_j

contact_last_name
contact_first_name
contact_title
contact_street
contact_city
contact |
contact_zip

contact_phone

: [contact_fax

[Add a contact] [Delete a cantact] [Save changesl

Id

Last Name First Name

Job Role

~
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Use the form to update the database

Use the form to update the database

Where you are
Create the basic form
Preview (run) the form
Save the form
Add buttons to the form
Enhance the form
> Use the form to update the database

Now you use the form to add a new contact to the database.

* 1 Click the Run button.
FRun Your finished form displays with data in place. The report on the form
givesyou away to see al your contact data.

€ Haintain Contact Information ._|@‘E‘
[ 1]
- [Add a Eunta[tl [Deleha a EDﬂtaEt] [Save Ehangesl
Last Name: [Hildebrand
AEILE G 10 LastName FirstHame  Job Role ~
Job Role: 1 Hidebrand  Jane Marketn 12
Street: ‘1 280 W ashington 5t | 2 Simmon Larry Bales 34
} 3 Crich Susan Procuct development 45
City: [Emenyvill ] 4 Lambert  Temy  Admiristaton 2
State: 5 Sullivan Dorathy Customer support &4
- 6 Paul Rose Finance 75
Zip: 34608
o P Glssman  Beh Prouet cevelopment 44
Phone: |[510] 555-1309 b3 Powel Gene Training BEw
Fax: [510] 5554209 < >

2 Click the Add a contact button in the form.

An empty form displays. You use this form to enter a new contact.

&) Waintain Contact Information

Id:
IAdd a contactl [Delehe a contact] [Save changesl
T —
FistName:[ | 10 Last Name First Name  Job Role ~
JobRole:[ ] 1 Hidebrand  Jane Markeing 12
Stieet: | [p smmon Larry Sales 3
i 3 Crith 5usan Product development 42
City: | ] 4 Lambert Tery  Administraion 2
State: 5 Sulivan Dorothy  Customer suppart 54
. 6 Paul Rose Finance 74
Zip:
e :l 7 Glassmann Beth Product development 44
Phone:[[ ] - | 5 Powel Gene Training 55 v
S — < :
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Getting Started

Thecursor isinthe ld box, but you do not know the next available number.
You look in the report to see what number was used last.

In the report window, use the scroll bar to scroll down to the last row
of the report and check the value in the Id column.

If the data has not been changed since installation, the value is 60, so the
next available number is 61.

Id Last Name First Name Job Role ~
5% Tippet Debbie Customer support &
54 Hodson Jack Customer support [
55 Kosko Kim Product development 23
56 McEvoy Jim Sales e
&7 Goodal Sancdra Sales s
5% Elkins Johin Training &%
59 hasalsky lurt Customer support 24
60 Caling MaryBeth  Administration 56w
< >

Click the Id column and type 61.

€» Maintain Contact Information

i
Lost Name: [
First Name: [

Press Tab and type Clinton for Last Name.
Press Tab and type George for First Name.
Press Tab.

At this point you are on the Job Role box. In thisbox you cannot type. You
must select ajob role from alist of possible ones.

In the Database painter, the column was defined to be associated with a
DropDownListBox edit style. The extended attribute system tables store
this and other information about data.

Click the down arrow on the drop-down list to display the choices.
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7

10

11

12

56

Select Marketing.
1

Last Name: ||

First Name:

Job Role: v
Adminiztration A~
Customer support -
City: D ocumentation
Finance —
State: |Human resources

. |Marketing

ZiP: \tpe
Phone: Product development v

o —

intan

Street:

Press Tab and type Pennsylvania Ave for Street.
Press Tab and type Houston for City.
Press Tab and type T and select TX for State (another drop-down list).

Press Tab.

To determine what to enter for Zip, scroll the report until you find
another Houston entry.

Then click the Zip box in the form and type the zip code you see in the
report.

& Maintain Contact Information g@@

1[5
- lAdd a mntact] IDeIete a mntatt] [Save changesl
Lot Name
Fist Name: ez | T Tem T 7E
Job Role: 2% Corrfield Ave,  Acton MA 01720 (5085
Street: FomaivaizAve 16 Waverly R, Budigion  MA 01803 (B17)5E
’ 57 Prince 5t Mouston  TX TROTS  (T13)5E
City: Houston | 24 Greenvile 81 Aanta GA 20339 (404)6F
State: ¢ EastMain St Houston TH O TROTS  (T1R6E
) 108 Park Stest  Burlngion A 01503 (§1TIE
Zip: [F7073
= $% Shaw R Needham  M& 02192 (G175
Phone:[ ] - ] 55 Blackstone St Aringtan MA 02174 (G176t
Y S — : E

Press Tab and type 7135557833 for Phone.

Notice that you type only the digits. The form formats the phone number.
An Edit Mask edit style was defined for this column to handle the
formatting. Thisedit styleis stored in the extended attribute system tables.
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Getting Started

13

14

18

19

Press Tab and type 7135554291 for Fax.

Thisiswhat your screen should look like now.

€ Maintain Contact Information E|E‘E|
16
[Add a mntactl lDeIete a mntactl ISave changes ]
Last Name:
Fist Nomo: fooge ] St w TEe
Job Role: ¢ Cornfield Ave.  Acion MA 01720 (504)5¢
Stroot: Famaiven Av 16 Waverly Rd.  Bulinglon  MA - 01903 @175
i 57 Prince 9t Houston T FTOFR (FIE
City: Houston | 34 Greenvile St Aanta GA 30339 (404)5¢
State: w5 Easthain & Houston TR TTOTR (TIE
i 103 Park Sreet  Barlingion MA 01803 (E1TIEE
Zip: [F7079
i s ShawRd.  Neecham  MA 02182 (B17)5¢
Phone: |[713) 555-7833 55 Blackstone St Arlington MA 02174 BI7IEE e
Fax: [713) 5554291 < >

Click the Save changes button in the form to update the database with
the new contact.

The database is updated.

Note that the report always displays the information from the database
when you start running the form. If you update the database, the report
does not show the updates. To update the report, you return to the
workspace and rerun the form.

Click the Close button in the PainterBar to return to the Form painter
workspace.

Click the Run button again and scroll the report to the 61st row in the
report.

Notice that your report has been updated.

Click the Close button in the PainterBar to return to the Form painter
workspace.

Select File>Close from the menu bar.

If you have not already saved the current version of the form, you are
prompted to save changes.

Click Yes.

The Form painter closes.
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LESSON 3

Getting Started

Report Tutorial

Reports display and summarize data. You can view reports on the screen,
save reportsto afile, and print them on the printer.

In thistutorial you create areport using the datain the contact table. The

report you create groups contacts by job role and lists phone and fax
numbers for each contact.

Thisiswhat the report looks like when you have finished.

8 Report - contacts_by_jobrole

3{21{2007

Last Name

Adlmirictration
Brier
Colling
Lambert
Romeo

Lirslomer sepport
Cobb
Cohen
Goggin
Hayne
Hodson
Lencki
Lyman
Maszalsky
Reeves
Short

My Contacls

First Name

Michael
MaryBeth
Temy
John

Paul
Paul
Kevin
iliam
Jack
John
Thomas
Kt
Scott
Russel

Phone

[E17) 555-2338
[E17) 555-1133
[E17) B55-2248
[310) B55-4533

404] 5652239
(517] 555-8063
[713] 555-3340
508] 555-7760
508 555-2058
517] 5555348
510] 5555378
(404] BEE-E111
(503 5550968
517] 555-0953

[E17) 555-3337
[E17) 555-9586
[617) B55-3692
[310) 8851233

404] 5E5-E111
(517] 555-4439
[713] 555-9211
508] 555-4422
508 555-0022
517] 555-4619
510] 5553372
404] 565347
503 5555556
(517] 5551170

How long does this tutorial take?

About 45 minutes.
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Create the basic report

Create the basic report

Where you are

> Create the basic report

Preview the report

Save the report

Set up the design environment
Define sorting and grouping
Enhance the report

Save the report as an XML file
Print the report

Now you create the basic report. To do thisyou select areport style and the data
to be used for the report.

1

60

Click the New button in the PowerBar.

i) tutor_im. pbl - InfoMaker,
File Tools Window Help

I B mo BN
N Hew Op=n Preview Sel Lib Liblet TaDaled  Library DEPral  Dertabese Exit

The New dialog box displays.

Select the Object tab if it is not already on top.

The Object tab page contains the icon for creating any type of new form
and icons for the various report presentation styles.
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Getting Started

3 Select the Tabular presentation style and click OK.

£
g
X

- — : —
0 = =

Farm Composite Crosstab Freeform Graph
a
nuE %
Label QLEZ2.0

(2] [l

RichText Treetiew
[ Ok ] [ Cancel ]

The wizard for creating tabular reports (also called DataWindows) starts
up.

About report presentation styles
A report presentation style is a predefined way of presenting information

in areport.

4  Select the Quick Select data source.
Make sure the Retrieve on Preview check box is selected and click

Next.

Tabular Report Generator

‘which data source would you like o use?

@ B E

SGL Select Query External

Stored
Procedure

Retrieve on Preview

Back L ek = ][ Canicel ]
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62

About data sources

Quick Select issimply for choosing columns and specifying selection
criteriaand sorting, which iswhat you want for this tutorial.

SQL Select isfor using other SQL options not available with Quick
Select.

Query isfor specifying the name of aquery that describes the data source.
You define a query in the Query painter.

External isfor specifying data that comes from a source other than a
database.

Sored Procedureisfor specifying data using a stored procedure.

The Quick Select dialog box displays. In this dialog box you select the
table to use and the columns you want to include in the report.

Click contact.

Quick Select g

1. Click on table(s) to select or deselect To display comments for a
2. Select one or more columns, table or column, click

3., (Optional) Enter sorting and the right mouse button,

selection criteria below,

Tables: Columns:

bonus - Help

call_track

contact

custarmer
department
employes
exam_xref_info
excam_xref _list
examples

< > < >

Comments:

Calurnn:
Sort:
Criteria:
Cr:

InfoMaker
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Getting Started

The columns for the contact table display. For this report you select five

columns.

Quick Select

1. Click on table(s) to select or deselect

2. Select one or more columns,

3, {Optional) Enter sorting and
selection criteria below,

Tables:

Comments:
A list of contacts

Ta display comments for a
table or column, click
the right mouse button,

Columnnis:

X

id
last_name
first_name
Litle:

street

city

state

zip

59 |

|w

~

| £

Help

Calumnn:
Sort:
Criteria:
Or:

23
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Create the basic report

64

6

Click last_name, first_name, and title.
Use the scroll bar to scroll the list of columns.

Click phone and fax.

InfoMaker moves the selected columns to the grid at the bottom. You can
use this grid for reordering columns and for providing sort and selection
criteria. For this report you do not need selection criteria, and you specify

sorting later.

Quick Select [z
1. Click on table(s) to select or deselect Ta display comments for a
2. Select one or more columns, table or column, click
3, {Optional) Enter sorting and the right mouse button,

selection criteria below,
Add Al
Tables: Columnnis:
first_name
phone
Fax -
o ) o >
Comments:
Fax Number of the contact
Column: Last Mame First Mame Title ~
Sort: =
Criteria:
Qs “
< 3
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Getting Started

7

8

9

Click OK.

The Select Color and Border Settings dialog box displays. You are going
to accept the defaults.

Select Color and Border, Settings le

Select color and border options For your report:

Background Color: E'-.-'-.-'iru:ll:n.-'-.l Eackground

Text

Calar: Il vindow Text
Border: MNoBorder
Columns

Color: W vindow Text
Border: MNoBorder

[5ave as default

[ < Back ” Mexk = ][ Cancel

Click Next.
A dialog box summarizing all your specifications displays.

Ready to Create Tabular Report

A Tabular Report with the Following characteristics will be created or
generated, Click Finish when vou are ready,

Property Walue
Data Source Select PESELECT({TABLE{MAME="contact") COLLIMNE]
Wrap Height {inches) 0
Background Color ‘Window Background
Text Color Window Text
Column Color Window Text
Text Border MNoBorder
Colurmn Border MNoBorder
& i
B

<« Back ]L Finish ][ Caniel

Look over your specifications and then click Finish.
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Your report displaysin several viewsin the Report painter. It uses the
columns and report style you selected.

B (Untitled) * - Report

e ————————————————————————————— ]
[ Design - (untitled) =l

=
General | pointer | Print ¢ ¥

_|\|I||\1|\|\I\|\2||||\|\|3\|\|I||\4|\|\I\|\5||| .
K| Last Name- - - - - - - - - - - First Name Job-Role - -----.... Phon | | Units
Header t PowerBuilder (0) v
Hlast_name - oo frst_name - - - Wlg - oo phone - - - - Timer Intervals
Detail | | 0 = |
Summary Color
Footer -
P 2 [ Jwindow Backaroun |+

¥ Frevien - (untitled)
~ [Jweb Datawindow

[[] showe Backeolor On %P

Last Name First Name Job Role Phor
Hildebrand Jane b arketing (510) 555-13
ISimmorn Larry Sales [713)] 55589
[Ciitch Susan Praduct development (508 555-45
Lambert Temy Administration (617) 555-22
15 ullivan Darathy Custorner support (508) 555-39
Praull Rose Finance (617 555-63
[Glassmann Beth Praduct development [617] 555-02 %
< >
—i L = m

The Design view iswhere you do much of your work perfecting thereport.
Thetext for the column headers comes from the extended attribute system
tables. The names of the columns appear where the data values will be

displayed.

H (Untitled) * - Report

(=]
[ Design - {untitled)

|I|||I|1||I|||I|2‘|I|||I|3|\I|||I|4||\|||I|5||I\||I
1. LastMeme - - - - - - - - - First Mame- - - - - - - - - - - JobRole - - - .. Phene - - - -~
Header t =
Hlast_name - -y first_name - - - - oo [ phone - - - e N
[ Detail
[Summary {
[Footer {

£

|~
|

The extended attribute system tables
The extended attribute system tables store information about data such as

label sand display formats. When you create formsand reports, InfoM aker
uses extended attribute information to create the basic form or report.

You put information into the extended attribute system tables using the
Database painter. For example, in the Table tutorial you define the label
Job Role: for thetitle column. Then when you usethetitle columninaform
or report, InfoMaker uses the label Job Role:.
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Report Tutorial

Preview the report

Getting Started

Where you are

Create the basic report

> Preview the report
Save the report

Set up the design environment

Define sorting and

grouping

Enhance the report

Save the report as
Print the report

an XML file

Inthisexerciseyoulook at the Preview view of your report to seewhat it |ooks
like when you print it.

1 Positionthe pointerin the upper-right corner of the Preview view (this
drops the title bar) and click the maximize button.

H (Untitled) * - Report

General | pointer
e e e e R e ’
E .. Last Mame- - - - - . FirstMame- - - --- - - - Job-Role- - - - - . - - . PhBr’: Units
_ [Headery PowierBuilder (03 w
Jastname - rstname o tle oo phonE | Timer Inberval:
Detail | 0 2 ‘
Summary 1 Color
Foorer | st
['web Datawindow
Last Name First Name Job Role Pho | [JShow Backeolor on ke
Hildebrand Jane Marketing [510) 585-1:
Simman Larty Sales [713) 5550
[Critch Suzan Product development [208) 555-4¢
lLambert Temy Administration [E17) 555-2
Sullivan Dorathy Customer support [508) 555-3
Paul Roze Finance [617) 5E5-6:
Glagsmant Beth Product development [B17) 555-0;
< | a ]
— LR m
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The Preview view becomes large and overlays all the other views. Notice
that it includesthe header information for the report and information from
the database. InfoM aker retrievesinformation for all contactsand displays
as many asfit in the Preview view.

vigw - (untitled)

Last Name First Name: Job Role Phone Fax
Hildebrand Jane Marketing (5101 555-1309 (510] 555-4209
ISimmon Lamy Gales [713) 555-8960 [713) 5559265
[Critch Susan Product development (608 555-4829 [608) 555-3025
Larmbert Termy Administration [E17) 555-2246 [E17) 555-3692
[Sullivan Darothy Customer support (608 555-3925 [508) 555-9931
Paull Rase Finance [E17) BE6-E392 [E17) 556-1495
Glassmann Beth Product development [E17) 555-0273 [617) 555-9933
Powell Gene Training [E17) 555-3528 [E17) 555-9563
[Fish Jeffrey M arketing [E17) 556-3628 [E17) 555-9563
Clarke Molly Gales [E17) B56-4325 [E17) B56-7638
Kelley “william Documentation [E17) 555-8474 [E17) 555-2594
Lyman Thomas Customer support [510) 555-5378 [510) 555-3372
D awidson Joann Marketing [510) 555-7363 [510) 555-9278
Pettengil Mark Sales [570) 555-3533 [570) 555-1146
Moore Davin Sales [404) 555-4834 [404) 5558291
lLencki John Customer support [E17) 5555348 (517 5554619
IK.aplan Burt Sales [617) 555-3887 [617) 5552398
Hayne wiliam Customer support (508) 555-7780 (508) 555-4422
IChiry David Product development [E17) 555-3378 [E17) 555-4453 3

< >

Use the scroll bar on the right side of the window to see more data.
Use the command File>Print Preview Rulers to turn the display of rulers

on and off.

Click here in the upper-right corner to return the Preview view to its
original size and location.

510) 555-4209

[

[713) 555-9265
[(509) 555-3025
(517) 555-3692
[505) 555-9931
[17) 5551495
5171 555-3953
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Save the report

Where you are
Create the basic report
Preview the report

> Save the report
Set up the design environment
Define sorting and grouping
Enhance the report
Save the report as an XML file
Print the report

Now you save the report and give it a name.

1 Select File>Save from the menu bar.

The Save Report dialog box displays, with the pointer positioned for you
to type a name for the report.

2 Type contacts_by_jobrole.

3 Click in the Comments box and type This report shows my contacts
grouped by job role.

Save Report ['5_<|
Reports:

Ok
|contacts_by_iobro|e | -
attrib_birthdays A
attrib_crossout_and_visible
attrib_escapement_rotation
attrib_fant_height
attrib_format
attrib_graybar_emp_total_comp b

comments:

This repott shows my contacts grouped by job role.

Library:

\infomaker 11, 0tukarialitutor im.phl

4  Press the Enter key.

InfoMaker saves your report. Anytime you have completed a unit of work
and are satisfied, you should save your work.
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Set up the design environment

Where you are
Create the basic report
Preview the report
Save the report

> Set up the design environment
Define sorting and grouping
Enhance the report
Save the report as an XML file
Print the report

In this exercise you set up the design environment to make it easier to work. To
do this, you:

e Show the edges of controls
» Display the grid and ruler

Control edges show how big the controlsare. By displaying control edges, you
can easily check for overlapping and make sure the spacing around controlsis
what you want. Displayed edges are adesign aid only; they do not appear in
the report.

The InfoMaker grid and ruler help you aign controls.

If you completed Lesson 2
The design options you set here may aready be set correctly.

1 Select Design>Options from the menu bar.

The Report Options dialog box displays.
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Getting Started

Make sure the Show Grid option, Show Ruler option, and Show Edges
option are selected.

Make sure Snap to Grid is not selected.
Click OK.

Report Options

General | Generation | Prefixes |
I [heabenetad Rebakey

Alignment Grid

% [a ]
l Show Grid s |8_|
Shows Ruler
[#] show Edges

Fetrieve on Preview

[ o] 4 ][ Cancel ]

The Design view shows a dotted grid and aruler. Text and columns show

edges.

=
[ Design - contacts_by_jobrole

TR I DT BN IO B

it el ot L D o A L U B Gt gl P e Bl L
- Last Name- - - - - - .- - . -First Name- - - - - - .- .. Job-Role - - -

. Phone - - - - - -

Fax - - - - ~

Header 1

=2 last_name first_name: title

phone

=

Detail 1

Summary 1

Footer {
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Define sorting and grouping

Define sorting and grouping

72

Where you are

Create the basic report

Preview the report

Save the report

Set up the design environment
> Define sorting and grouping

Enhance the report

Save the report as an XML file

Print the report

Now you specify sorting and grouping. You want the report to group contacts
by title. Thismeansyou need to sort by title and then specify grouping by title.

1 Select Rows>Sort from the menu bar.

The Specify Sort Columns dialog box displays.

Specify Sort Columns rg|
1) Drag and Drop items.
2} Double-click column to edit
_

Source Data Colurns Ascending

last_name Help
First_name

Litle:

phone

Fax

< ¥
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2 Move the pointer to the word title in the Source Data box and drag it to
the Columns box.

(To drag, press and hold the left mouse button, move the mouse, then
rel ease the mouse button.)

Specify Sort Columns rg|
1) Drag and Drop items.
2} Double-click column to edit

_
Source Data Colurns Ascending
last_name Litle | Help
First_name
Litle:
phone
Fax
/) >

Ascending and descending

Ascending and descending are options for sorting. Since you are
alphabetizing in this tutorial, you want to sort in ascending (from A to Z)
order. Ascending is the default, so you do not have to do anything.

You have specified the sorting required to group by title.
Next you specify sorting by last name and then by first name. This
alphabetizes your contacts within each group.

3 Drag last_name and first_name to the Columns box.

Specify Sort Columns fgl

1) Drag and Drop items.
2} Double-click column to edit

_
Source Data Columns Ascending
last_name Litle Help
First_name last_name
Litle First_name
phone
Fax
/) >
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Define sorting and grouping

4

6

74

Click OK.

The sorting definition is complete.

Select Rows>Create Group from the menu bar.

The Specify Group Columns dialog box displays. You are going to group
on thetitle column. All contacts with the sametitle will be grouped
together.

Drag title to the Columns box and click OK.

Specify Group Columns

1) Drag and Drop items, oK
2} Double-click column to edit

X
o)
Source Data Columnis
[Lrep ]

last_name Litle Help
First_name
Litle:

phone

Fax

The grouping definition is completed. You have two new bands for the
group in the report. You learn about bands in the next exercise.

Hl contacts_by_jobrole * - Report

N PO TRTIN DU TUT DUY DI D TUT: D DU DUYA DUUN TV ST PUTN DUTY D SUTRUUTN DYDY UL U UUTY DU DU ITY- SUU T BT
.. . LastMame ----- .- FirstName - -~ ----- JobRole------- - Phone - ------ Fak---- #
Header

1: Header group title {

Jlack name - - - -~ - fistname - - - MEe . phoRE- - fame
[Detail ©

[1: Trailer group title T
ey T

[Footer

InfoMaker
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Getting Started

7

Look at the Preview view.

You see the report and its data. Notice that the dataiis sorted. You do not
see the groups yet. In afew minutes you will make some changes so the

groups appear.
|

|~

Last Mame

[Birier
IColling
Lambert
Fomeo
[Cobb
Cohen
[Goggin
Hawne
Hodson
Lencki
Lyman

M azalsky

First Name

Michael
MarpBeth
Temy
John
Paul
Paul
Kewin
“williarm
Jack
John
Thomas
Kurt

Job Role

Ldministration
Adminiztration
Administration
Administration
Customer support
Customer support
Customer support
Customer support
Customer support
Cugtomer suppart
Customer support
Customer support

Phone
[617] 555-2398
[617) 5551199
[617] 555-2246
[310) 555-4533
[404) 556-2239
[617) 555-8883
[713) 565-3340
(506) 555-7780
[508) 555-2398
[617] 555-5348
[510) 555-5378
[404) 555-5111

Fax
[617) 5553337
[617) 555-9506
[617] 555-3692
[310) 5551233
[404) 555-8111
[617) 555-4433
(713 5559211
(506) 555-4422
[508) 555-0022
[617] 5554619
[510) 555-3372
[404) 555-8347
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Enhance the report

Enhance the report

>

Where you are

Create the basic report
Preview the report

Save the report

Set up the design environment
Define sorting and grouping
Enhance the report

Save the report as an XML file
Print the report

You can enhance reports in many ways. In this exercise you:

Rearrange controls

76

To

Rearrange controls
Add atitle and date
Add page numbers

Add a count of the total number of contacts

rearrange controls, you:
Put the job role into the group header and change its display font

Move the remaining columns to close the gap left by moving the column

Thisiswhat the Design view lookslikewhen you havefinished rearranging the
contrals.
B contacts_by_jobrole * - Report
bl ratelst o d it st Ukl Lo il atavasll b st B Uttt AL an sl S v st U
Last Name First Name: Job Role Phone Fax ~

Header |

1: Header group title [
o lastpame - - - first pame - e PHORE < [

1; Trailer group title {
[Summary T
[Footer [

InfoMaker
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Getting Started

About report bands
The design version of the report that you seein the Design view divides the

report into bands of information.

The header band contains heading information and is located at the top of
each page.

The detail band contains the retrieved data.

The summary band contains summary information that appliesto the entire
report and islocated at the end of the report.

The footer band contains information to be located at the bottom of every
page, such as a page number.

For groups, the group header band and group trailer band contain
information for the group.

1 Move the pointer to the gray bar entitled 1. Header group title (where
the black dot is) until you see a double-pointed arrow

B contacts_by_jobrale * - Report

B AN DTN, INIU DTN DU TNE: D OU TN DUTY U TR DTN DYDY I TR NI DUIU IV NN BTN T B BT BT |
Last Name First Name: -Job-Role Phone Fax ~
Header 1

T

1: Header group title

S lastnamer oo fitstaame - oo phonE s e A

77
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Drag the band down about 4 to 6 grid dots.

(To drag, press and hold the left mouse button, move the mouse, then
release the mouse button.)

|||I|||1||||I|||2||||I|||3||||I|||4||||I|||5||||I|||5||||I|||7|

-Last Name - - - - - - ... -First Name - - . - - - - Job-Role - - - Phone -o--Fax. ...
Header 1

1: Header group title
Jastpame oo fisbeeme s btler oo cphaner s te e
[Detail

[1: Teailer group title 1
[Summary {

[Footer [

Move the pointer to the title column and drag it into the band for the
group header.
Put it near the bottom of the band and on the left as shown.

.|.I.|.1|.|.I.|.2|.|.I.|.3.|.I.|."|.|.I.|.5|.|.I.|.5|.|.I.|.7\

- LastMame- - --. ... .. FirstMame - -- .- .. JobRole-.-- ... .. Phene - - - Fax-
Header {

Ne DU IIIIIIIl

1: Header group title {
st riame 0 frsname e phamee g

| Detail ¢

[1: Trailer group title |
[Summary [

[Footer1

InfoMaker
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4 With the title column still selected, select the bold checkbox and the
italic checkbox on the Font tab of the Properties view.

I=
L ) [ e SO e B 3
1. Last Mame- - - - - - - - - - - First Mame: - - - - - - - - - - Job-Role - - - - - - - - B | ceneral | Pointer [ HTLAE
Headert
3 Facelame 5
- - M3 Sans Seri
-
| = Sizer
1: Header group title { Hl v g
Jestpame oo oo fisbname ke Gy ™
[Detail t )
[1: Trailer group title 1 Tealic Z
[Summary t [[Junderline =
Footer { [ strikeout #
¥ et Calor
< ¥ N
. ! | Window T v | el

This makes thejob role (title) stand out in the report.

5 Look at the Preview view.

You see the report and its data.

I Fr
Last Name First Mame Job Role Phone Fax
Adiminiztration
Erier Michael [617) 556-23338 [617) 555-2337
Callins MarpBeth [617] 5551199 [617] 555-9596
Lambert Temy [617) 555-2246 [617) 555-3632
Fomen John [310) 555-4533 [310] 5551233
Lusfomer SEprent
Cobb Paul [404) B55-2239 [404) 5552111
Cohen Paul [617) 555-8883 [617] 555-4433
lGoggin Kevin [713) 555-3340 [713] 555-9211
Hawne Williarn [508) 555-7780 [608] 5565-4422 |+
< ¥

Notice that the value of the title column appears only once for each group.
Thisis because the title column is now located in the group header band.

The Preview view is helpful for identifying problems. Notice that the
header Job Roleisstill present even though thereis no longer acolumnin
the detail band. Next you del ete the header.
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Enhance the report

Click the text Job Role in the header band.

esign - conl ole

A e N S o ez O DOy
Last Name First Hame
Header |

Ll e e Ll ssavacala it i adlb
Job Rale - - |
ISR

ane Fax -~

e
1: Header group title |
Jast_name

Detail {

1: Trailer qroup title
Summary |

first_name

phone

Footer |

<

Press the Delete key.

ST DR TS I NI DN DU DRI DT DTN DTS- DTN DT A T T DU DTN DO DA DTS DT DO DS ONT R DT Y
Last Hame First Name:
Header

ene Fax Py

- [

1: Header group title T
Jastname s v fistname s
Detail {

1: Trailer group title T
Summary T
Footer T

<

Drag the First Name and Last Name text boxes in the header band to
the right to fill the empty space.

e s A s S o
hone

T oo AT O oA

1 Last Name First Name
Header |

Fax ~

HHE

__ [AHeader group tide |

last_name: first_names

phore et
Detail |
L: Trailer group title |
Summary |
Footer |

o E
----- Last Name

I e e

L

(bl

T  Lask Name . el First Name. - - - - |  Phene
FeaderT

Ll

B A

_ [1:Header group title T
last,_name:
Detail T

first_name:

phone

1: Trailer group title T
Summary [

Footer |

<
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Getting Started

9

10

11

Drag the first_name and last_name columns in the detail band to the
right to fill the empty space.

i B0 0 A e o e
.......... Fitst Name- -« - - - -Phong - - - -~ Fag -+ - &

13 Haader group title |

| Jiast_name first_name phone fan
Detail T I
[Tz Trailer group title T
Summar: v 1
Footer
v
< >
- -

ST DUR IS IR U N0 DU DRI DT DI DUTE-| DTN DT A I DU DTN DO DA DTS DT DO DU TR DT Y
Last Mame First Hame Phene Fax A

Header T

7

1: Header group title T

Detail

1: Trailer group title T
Summary T

Footer T

< >

You make onefinal visual improvement now by left-aligning the text in
the column headers.

Choose Edit>Select>Select Text from the menu bar.

This selects all the headers. It might be difficult to see that they are
selected because the band is so narrow.

Click the left justification button on the StyleBar.
If your headers are not already bold, click the Bold button.

All the headers become left justified (and bold).

i bt b il b e bbb Lt i bt b L
LastName First Hame Phone: Fax A

Header T

b7

1: Header group title T

Detail

1: Trailer group title T
Summary T

Footer T

< >
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Enhance the report

12 Look at the Preview view.

|
Last Name First Name
Adlmiriztration
Brrier Michael
Colling MarnBeth
Lambert Teny
Romeo John
Luxtomer suppert
Cobb Paul
Cohen Paul
Goggin Kevin
Hapne William
<
— - —

Add a title and date

Now you add atitle and date to the header band. They will be at the top of each

page.

Phone

(517) 555-2398
[617) 555-1199
[617) 555-2246
[310) 555-4533

[404) 555-2239
[617) 555-6853
[713) 555-3340
[508) 555-7780

(517) 585-3337
517) 565-9586
517) 555-3692
[310) 5851233

(404) 5856111
517) 585-4499
[713) 555-9211
(506 5854422

1 Move the pointer to the gray bar marked Header and drag it down
about 10 grid dots.

1: Trailer group title {

[Summary {

Footer |

2 Choose Edit>Select>Select Text from the menu bar (or use lasso

selection).

This selects al the headers.

82
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3 Drag all the headers down close to the gray band.

This leaves room for the title.

[#] Design - contacts_by_jobrole

N ST IR DO D DT S DTN DT DT DI DO DI DU TR DT DT AT, DI DI DO DU DT TR DT TS TR DT
- Last Name First Name
Header {
o R DD DLl M DLl DLl DLl DLl DLl DLl
1: Header group title t
1 DLl D1l lastname oo st name Ll  phone - Coiinifames
[Detail t
[1: Trailer group title {
[Summary [
[Footer T
7
< >
— -

4  Click the Text button in the Objects drop-down toolbar in the
PainterBar (or select Insert>Control>Text from the menu bar).
Move the point of the pointer above the First Name box and down one
grid dot from the top of the page.
Click the left mouse button.

Text

This positions the text box for thetitle.

an - conl _by_jobrole
N T TR DU DT AT DT U TS DT I DUTN DU DT DT DO DT I DO DU T DT DY T IS D BT
" " Ll
1: Trailer group title 1
| Smmars
[FooterT
g
< >
A e
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Enhance the report

84

5

Type My Contacts.
Select 14 from the Size drop-down list on the Fonttab in the Properties
view to make the title bigger (enlarge the text box if necessary).

General | Pointer | HTML | Pasition | ¢ *
Facellame 5
M5 Sans Serif v |
Size
E o
8 ]
10 J
12 2
=
15 _I
24 2
Text Color
|-Window Text w | =
Background Calor
||:|Transnarent v|ﬂ
CharSet
|ansi! v|
v

Thetitleis now enlarged.

] B e i B A i B et ] e o i ot oo
Ll

[Detail {

[1: Trailer group title {
[Summary
[Footer{
3
£ >
=l | |
InfoMaker
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Getting Started

7

Select Insert>Control>Today( ) from the menu bar.

Move the point of the pointer to the upper-left corner.

Click.

This places a computed field in the report. The computed field isfor
today’s date.

i 1: Header group title {

last_name

first_name

[Derail {

1; Trailer group title {

[Summary T

Footert

Look at the Preview view.

Your report now has atitle and today’s date.

conkacks_by_jobrole

3{2012007
Last Name
Adiministration
Brier
Calling
Lambert
Fomen
Lustomer seppor
bk

My Contacts

First Mame

Michael
MamBeth
Tery
John

Phone

(517) 555-2396
(61715551193
(B17) 5552246
(310) 655-4533

fARAY EEE A7nn

[§17) 556-2337
[517) 556-3586
[517) 555-2552
[310) 5651233

fAm41 EET A4
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Enhance the report

Add page numbers

Now you put page numbersin the footer band.

86

Move the pointer to the gray bar marked Footer and drag it down about
4 grid dots.

If necessary, use the scroll bar to make room at the bottom of the Design
view. Dragging down the footer bar makes space for the page number in
the footer band. The page number is another computed field.

: Trailer group title f

_ [Summaryt

| Fautert "
< >

— L

Select Insert>Control>Page n of n from the menu bar.

In the footer band, move the pointer to the center and down 2 grid
dots. Click.

Select a different font size (10) in the Properties view, Font page.

This places a computed field for page numbers.

[Detail

1: Trailer group title
[Summary [

Footer ! et

< td

InfoMaker
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3 Look at the Preview view.
Click the scroll bar until you move to the bottom of the page.

You now have a page number on your report.

Markating

Crowley Charles
Schott Amy
Davidzon Joann

Fish Jeffrey

Galvin Liz
Hildebrand Jane

Shighow Irina

Weaver Jog

Page 1 of 2

Add a count of the total number of contacts

Now you add a count of the total number of contacts you have to the end of the
report. You put theinformation in the Summary band, which meansit prints at
the end of the report.

[517) 585-1344
(713) 555-6912

[510] 555-7363
(517) 5563528
[517) 5569312
(510 5551309
[404) 5551233
[713) 5551556

[617) 5559877
[713) 555-4565

[510) 5559278
517) 5559563
517) 5553870
[510) 5554209
[404) 5556037
[713) 555-4455

Like the date and page number, the count is a computed field, only thistime,
you create it yourself.

1 Move the pointer to the gray strip marked Summary for the summary
band and drag it down about 6 grid dots.

This makes space for the total number of contacts, which is a computed

field.

fiibid bin i it el b b

[T DI DTN DT IO

today()

My Contacts

Last Name First Namg Phorie

Header T

7

_ [1:Header group title

last_name first_name: phone

Detail T

1: Trailer group titlet

Summary

<

Getting Started

‘Page:’ + page() + ' of "+ pag
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Enhance the report

88

2

Select Insert>Control>Computed Field from the menu bar.

In the summary band, move the point of the pointer to the center and
down 4 grid dots.

Click.

Thissetsthe position for acomputed field that you usefor thetotal number
of contacts. The Modify Expression dialog box displays.

In the Functions box, click count(#x for all).

Your dialog box should look like this. The placeholder for what to count
is highlighted.

Modify Expression rg|
Expression: -
OF
count( 28 For all )
Functions: Calumns:
E] casel x when athenb s last_name
ceilingl =) = first_name
chari x ) i Litle
* charai x ) phone
cos( %) Fax
count #x For all 3 date_1
crosstabavg{ 1) page_1
crosstabavaodect 15 %

InfoMaker
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4 In the Columns box, click last_name.

This selects the last_name column to apply the count function to. You are
going to count all the last names to find out how many contacts you have

in the report.
Modify Expression rg|
Expression:
-OK
count( last_name For al
(i pame fr )
Functions: Columnns:
E] casel x when athen by a last_name
ceilingg % 3 = first_name
char( x ) W Litle
# charai =) phone
cos %) Fax
counts #x For all ) date_1
crosstabavgl 1) page_1
crosstabavadeci 11

5 Click Verify.

You should get the message box stating that your expressionis valid.

L 'j Exprassion is K,
L3

6 Click OK to close the message box.
Click OK to complete the definition of the expression for the
computed field.

The computed field isin place.
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Enhance the report

90

Select Insert>Control>Text from the menu bar.

Position the pointer to the right of the computed field and click.
Type contacts in all.

Drag the text box to line it up with the computed field.

Select the computed field and the text using lasso selection.
On the Font page of the Properties view, select 10 for the font size and
select the Bold checkbox and the Italic checkbox.

How to use lasso selection
Position the pointer, press and hold the left mouse button, and drag the

lasso around everything you want to sel ect. Then rel ease the mouse button.

InfoMaker
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Getting Started

Look at the Preview view.

Use the scroll bar until you see the end of your report.

The summary band of your report now shows the total number of contacts
in the report. The number you see may not be 60. The number depends on

the contacts currently in your database.

toore Dawn
Page Lynn
Pettengil tark.
Philley Mary
Purcell Beth
Quiriey Peter
Sirarnon Larmy
Travers Ken
‘wihite Pauline
Fraining
Elking John
Long Peter
Miller Henry
Powel Gene
& EGIEETS i alf
Page 2 of 2
& i -

[404) 5E5-4534
51715558890
[510] 555-3533
[713]555:3338
(517) 565-2349
(5171 555-2222
71315558960
[517) 5552384
(713) 565-3345

B03) 5551 200
(51715554519
[517)555-3366
[517)555-3528

[404] 555-6231
517)555-4544
[5101555-1146
[713) 5559066
(517) 5651765
51715559337
(71315559265
[517)555-4127
(713) 5859222

(B03) 5550078
51715554339
51715551332
[517) 5559563
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Save the report as an XML file

Save the report as an XML file

92

Where you are
Create the basic report
Preview the report
Save the report
Set up the design environment
Define sorting and grouping
Enhance the report

> Save the report as an XML file
Print the report

You can save the datain areport in many different formats, including XML,
HTML, Microsoft Excel, and PDF.

Saving as PDF
Before you can save the data in areport object to a PDF file, you must install

Ghostscript and PostScript printer drivers on your computer. For information
about using the Ghostscript distiller, see the User’s Guide.

Now you save the report as an XML file.

1 Select the Preview view by clicking it.

This ensures that the Preview view is the current view.

InfoMaker
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Getting Started

Select File>Save Rows As from the menu bar.

Select XML from the Save as Type drop-down list.

Type a name for the file and click Save.

Save As
Save in; | I Tutorial v| ¢ ? s M-
File: rnarne: |M_I,J report | [ Save J
v | l Cancel ]

Save a3 vpe: | sl

Encoding:
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Print the report

Print the report

>

Where you are

Create the basic report
Preview the report

Save the report

Set up the design environment
Define sorting and grouping
Enhance the report

Save the report as an XML file
Print the report

94

Select the Preview view by clicking it.

This ensures that the Preview view is the current view.

Select File>Print Report from the menu bar.

The Windows Print dialog box displays.

Print
Printer: Y\PRT-CONCORDYpr-cong-04
Copies:

Page Range

®al

O Current Page

O Pages: |

Enter page numbers andjor page ranges
separated by commas, For example, 2,5,8-10

Print: | All Pages in F.ange

]

K
Cancel

Printer...

Help

[ erint ko File

Collate Copies

Click OK.

Select File>Close from the menu bar.
If you are prompted to save changes, click Yes.

The Report painter closes.

InfoMaker



LESSON 4 Table Tutorial

This tutorial requires the Database painter
The Database painter component of InfoMaker is optional; you must have

installed it to do this tutorial.

Tables are the way relational databases organize information. To take full
advantage of InfoMaker’s ability to create forms and reports, you should
learn how to create and work with database tables.

InfoMaker isinstalled with a SQL Anywheredatabase. You can createand
work with tablesin the SQL Anywhere database and in any other database
you have access to.

After you create atable, you can display its columnson aform and use the
form to add information into the database. For afinal printed copy of the
datain your tables, you can create and print reports.

In thistutoria you:

*  Create adatabase table

»  Define extended attribute information
e Add datato thetable

When you have finished, you can create forms to view and update
information, and you can create and print reports using informationin the
table.

How long does this tutorial take?
About 45 minutes.

Getting Started 95



Create the database table

Create the database table

Where you are

> Create the database table
Define extended attribute information
Add data to the table

To create the database table, you:

* Definethe columnsin the table

¢ Defineaprimary key

e Enter comments to document the table

¢ Savethetable

Define the columns in the table

1 Click the Database button in the PowerBar.

{7 tutor_im. pbl - InfoMaker
File  Tools ‘Window Help

O & B B = B = &

Hew Opsn Prewiew  Sellib  Liblst  ToDaled Libmy  DEPl | Dol
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Getting Started

The Database painter workspace displays. It contains many views for
working with database information. If your workspace does not ook like
this, you may want to select View>Layouts>(Default).

4 tutor_im. pbl - InfoMaker
File  Edit Wew Object Design Rows Tools  ‘Window  Help

e — B o= B = B 8 I

Hew Open Preview  Sellib  Liblit  ToDalid  Libmry  DBPral  Demmbeme  Exit

8 8 H 2.8 &5 ® =

Discannes Creme Ta

4 AsE Sybase ASE 15.x ~
&4 DIR Direct Connect
4 IN9 Informix v9.x

No properties bo display.
4 10B JDBC A o

E4 090 Cracle 9

[=-E4 ODB ODBC

[ Driver Information
[ Groups

[ Metadata Types 2
(7 Procedures & Functions = | i

g L:::s E)Ib]ect Layout AExtended Atttibutes i
3 Views

4 EAS Demo DB 110 1M Unicod:
4 EAS Demo DB V110 Unicode
[ Utilities
&4 OLE Microsoft OLE DE
4 5MC S0L Mative Client
=4 SviC Sybase ASE
E4 5v15vbase ASE for EAServer ¥
€ it} || [WIS0L Session 4Columns jResults

Ready
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i tutor_im.pbl - InfoMaker,
File Edit View Object Design

Rows

Tools  ‘Window  Help

B = B = 8 8 Wk

Hew Opsn Preiew  Sellib  Liblit TeDolid  libmy  DBFel  Dasbese  Exit

8 9 EH = .

D imcannec GremeTa

£ ASE sybase ASE 15.x
E;J DIR. Direct Connect
E_J M9 Informix wa.x
£4 0B IDEC
E4 010 0rack 10g
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4 ©90 Cracle 9
=4 0DB ODBC

[£4 EAS Demo DE V110

(= fg EAS Demo DB Y110 IM

[0 Driver Information

[ Groups

[0 Metadata Types

[0 Procedures & Functions

Position the pointer on the Tables folder in the EAS Demo DB V110 IM
database and select New Table from the pop-up menu.

Mo properties to display,

Ep— 4
g Ussl| ES Mew Table... ayout AExtended Attributes
[}
3 Wiel Show System Tables
Ed EnsDg
E4 ES e Table Security...
[ Utilities Refresh
E4 OLE Micros
SNC SOL M
4 5YC Sybase mse
E4 571 5vbase ASE For EAServer v .
< | _WI50L Session AColumns jResulks
Ready
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Theview inwhich you definethe columnsin the tabl e displays. The cursor
isin the Column Name box for the first column.

B tutor_im. pbl - InfoMaker

File Edit Wew Object Design Rows Tools  ‘Window Help
PR S [ R R N -

Hew Open Preview  Sellib  Liblit ToDalid  Libmry  DBPral  Dembeme  Exit

8 88 H 2.8 5 ® =

Discannaz GremeTa  Dropobie  Frim

4 ASE Sybase ASE 15.x ~

{4 DIR Direct Connect

4 N9 Informix v9.x

4 10B JDBC

4 010 Cracle 10g

4 064 Oracle 8/8i

4 090 Oracle 9

£4 ODE ODBC
4 EAS Demo DB Y110

(=45 EAS Demo DB Y110 IM
[ Driver Information
[ Groups
3 Metadata Types
7 Procedures & Functions
(7 Tables &)m) 4
7 Users _Olb]ect Layaut fExtended Attributes
[0 Wiews Column Mame  |Data Type Width  Dec  |Mull Default T
4 EAS Demo DB V110 1M Unicod: l ~ ~ |(Mone) v
4 EAS Demo DB V110 Unicode

[ Utilities

{4 OLE Microsoft OLE DE

4 SNC SQL Mative Client 4

4 5¥C Sybase ASE

E4 5v15vbase ASE for EAServer ¥

| _[SI50L Session jColumins {Results

Mo properties to display,

=3
o

@

- &8

|

Eadlzy]

Ready

3 Typeid and press Tab.

The cursor moves to the Data Type box. The default datatype is
highlighted. The datatype for the id column needs to be integer.

4  Click the arrow in the Data Type box and select integer from the

drop-down list of available datatypes.

This changes the datatype.
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Press Tab three times.

This moves you past the setting of No for the column labeled Null. No
means you do not want to allow the column you are defining to be empty
(to have anull value). Since you always want avaue for id, you leave the
value No. You also move past the column labeled Default. You are not

going to specify a default.
=T = ]
Column Mame Data Twpe width  Dec [ull Defaulk |
id linteger w [ [Mo s |{MNone) L7
w | + ((Mone) e

RI50L Sessian jCalumns AResults

Type last_name and press Tab.

The cursor moves to the Type column. The most recently used datatype
(integer) ishighlighted. Thelast_name column should betypechar, soyou
change the datatype.

Type c and press Tab.

Typing cisashortcut for choosing char quickly. The cursor moves to the
Width column.

Type 15.
This allows 15 characters for the last name instead of 10.

Press Tab three times.

This moves you past the setting of No for the column labeled Null to the
Column Name box for the next column. No iswhat you want (name cannot
be empty). You move past the column labeled Default again.

Column Mame Data Twpe Width  |Dec  rull Defaulk |
id integer w No s |(None) w
last_name char W 15 Moo+ [(None) W

~ + |(Mone) P

AISQL Session holumns AResulks
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Getting Started

10 Finish entering information about the table columns.

The following table shows all the values needed to define the columnsin
thecontact table. You have already entered valuesfor thefirst two columns
(id and last_name).

Name Type Width | Dec | Null | Default
id integer No (None)
last name | char 15 No (None)
first_name | char 15 No (None)
title char 2 No (None)
Street char 30 No (None)
city char 20 No (None)
state char 2 No (None)
zZip char 5 No (None)
phone char 10 Yes (None)
fax char 10 Yes (None)

When you have finished, the Columns view should look like this.

Column Mame Ciata Tvpe width  Dec Mull Ciefaul: |
il inteqer " Mo 4 [(Mone) w
last_name char w 15 Mo+ |(Mone) -
first_name char v 15 Moo s |(Mone) -
Fitle: char " 2 Mo s [(Mang) -
shreet char v a0 Mo 4 [(Moned w
rity char w 20 Mo |(Mone) w
ckate char " z Mo s [(Mone) w
Fip char " 5 Mo e [(Mong) w
phone char w 1 es 4 ((Mone) w
Fax char w 10 Yes w |(Mone) -
15GL Session wColmng 4Results
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Create the database table

Save the table

You have now entered al of the column information needed. Now you finish
creating the table.

1 Select File>Save from the menu bar.
The Create New Table dialog box displays.

You leave the owner as dba (database administrator) and enter aname for
thetable.

2 Type contactl in the Table Name box.
Click OK.

Create Hew Table

Owner Name: | dba

Table Wame: | conkacti|

InfoMaker passes the SQL needed to create the table to the SQL
Anywhere DBMS, which creates the table.

InfoM aker displays a representation of the tablein the Database painter
Object Layout view.

-
id

last_name
first_name

title

street

ciky

state

2ip

phone "

Thelist of columns displays. The scroll bar on the right side means that
there are more columns than can be displayed at once. To see the other
columns, you can click the down arrow at the bottom of the scroll bar.
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Define a primary key

A primary key uniquely identifies each row. In your contact table, id isthe
unique identifier of each row of data.

1 Select Object>Insert>Primary Key from the menu bar. (If the menu item
is grayed out, click the Object Layout view to make it current and then
select the menu item from the menu bar.)

The Primary Key properties dialog box displays in the Object Details
view. Here you can pick one or more columns as the primary key.

[P Prima (EAS Demo DE v110fmlEd
General

Table:

contactl

Columns:

[lid ~
[Clast_narme

[CIFirst_name

[ritle b
Order:

1

2 Clickidin the list of columns.

General

Table:

contactl

Columns:

[wiid A
[Clast_name

[CIfirst_name

[ltitle b
Order:

1)id

3 Select File>Save from the menu bar.
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This defines id as the primary key for your table. Notice that the
representation of the table now includes a symbol for the primary key of
the table.

coreact: 18

id
last_name
first_name

title

streek

city

state

2ip

phone v

Next you define a comment for the table.

Enter comments to document the table
Although not required, comments can be helpful inidentifying tables.

3

104

Position the pointer on the title bar of the representation of the
contactl table, display the pop-up menu, and select Properties.

The Table Properties properties dialog box displaysin the Object Details
view.

Click in the Comments box and type This is the sample table for the
tutorial created by [your namel].

[ Tabl= (EA ' DB Y110 IM) - cantact1 [l
General | Data Font | Heading Font | Label Font

Cner
dba

Table:
contact1

Comments:

This is the sample table For the tutorial
created by Barbara Schott,

This associates the comments with the table you are creating.

Select File>Save from the menu bar.
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Define extended attribute information

Where you are

Getting Started

Create the database table
> Define extended attribute information
Add data to the table

Now you extend the basic definitions of the columnsin the table.

The following table summarizes how you extend the column definitions of the
contactl table columns.

Column name

What you do to extend its definition

id Nothing.

last_name

first_name

title Define a DropDownListBox edit style of job roles, change the
column header and label to Job Role, and enlarge the display
width of the column to 1.5 inches.

street Nothing.

city

state Assignthe DropDownDataWindow edit stylefor stateto thestate
column.
Set the default value of state to MA.

zip Nothing.

phone Define an Edit Mask edit style for aphone number and apply it to

fax phone and fax.

About extended attribute information
InfoMaker stores extended attribute information in the extended attribute

system tables and uses it to display and validate datain forms and reports. In
the Report painter or Form painter, you can override whatever you specified in
the Database painter, which is where you are now.
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Define extended attribute information

Define a DropDownListBox edit style for the title column

106

Now you define a DropDownL istBox edit style that hasthe valid job roles for
thetitle column. When you have finished, thisiswhat it looks like in aform.

Marketing | -
Adminiztration -
Customer support I—
D ocumentation
Finance

Human resources

Other
Product development -

1 Select View>Layouts>(Default) from the menu bar.

2 Click the Extended Attributes tab to bring the view to the front.

3 In the Extended Attributes view, display the pop-up menu for Edit
Styles and select New.

i tutor_im.pbl - InfoMaker,
Flle Edit Wiew Object Design

%o e EoR o m B Ro@ B

Hew Opsn Frewiew  Sellib  Liblit  ToDalid Llibmy  DEFol  Dasbwe  Exit

8 %8 B 2. a5 » B

D iscannec CremeTa

Rows Tools  ‘Window  Help

. Installed Database Interfaces A
-3 ASE Sybase ASE 15.x ] [> Display Formats
=-E4 DIR Direct Connect
-4 N9 Informi va.x [ walidation Rules
¥4 0B DBC

£ 010 Oracle 10g

[£3 084 Cracle 86

[E3 090 Oracle %

4 ODB CDBC

£ EAS Demo DB Y110
iy EAS Demo DB Y110 IM
[ Driver Information
[ Groups

1 Metadata Types

[ Procedures & Fund Olbjact Layout 3Extended Attributes
& =

]

Mo properties o display,

Tables
Users

BT Views

4 EAS Demo DB W110IM

4 EAS Demo DE W110 Ur

[ [J Utilities

-4 OLE Microsaft OLE DB
-3 SNC 50U Native Client v
< | » NSGL Session {Columns pResults
—_—
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Getting Started

Edit Style settings display in the Object Details view.

10 DB Y110 IM) - Unititle[m]

General |

Edit Style

>

Skyle Type

|Edit v

Farrmat

Case

| v

Lirnit

[0 S

Accelerator

[J auto Selection
[oisplay Cnly
[ 5how Focus Rectangls

[CJEmpty String is MULL

<

Enter the name JobRoles1.

Select DropDownListBox in the Style Type box.

Check Sorted to alphabetize your entries.

Check Vertical Scroll Bar to display a vertical scroll bar on your list.

General |

Edit Style

| JobRolest

Skyle Type

| DropDownlistBox [

Accelerator

[ allow Editing

[ auto Horizontal Scroll
Sorted

[CJEmpty String is MULL
[required

[ always Show List

[ always Show arrow
WVertical Scroll Bar

Code Table

Display Yalue Data Value

1]

|«
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108

Enter the Display Values and Data Values shown in the table below.
Be sure to use lowercase for the data values.

To enter each pair of values, type the values and press the Tab key.
For the last pair of values, do not press Tab.

Display Value Data Value
Sales sa
Customer support cs
Product devel opment pd
Administration ad
Training tr
Documentation do
Marketing ma
Human resources hr
Finance fi
Other ot

About display values and data values
Display values show in forms and reports. Data values are stored in the

database. Display values should be meaningful—such as Human
Resources. In contrast, data val ues are often codes that are short—such as
hr. Short codes conserve space in the database.

Select Save Changes from the pop-up menu.

InfoMaker adds the JobRolesl edit style to the extended attribute system
tablesin the database and lists it as one of the available edit stylesin the
Extended Attributes view.
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Getting Started

7

Expand the tree view of Edit Styles by clicking the plus (+) sign.
Use the scroll bar to scroll down to the JobRoles1 Edit Style.

Demo DE 110 IM)

RANTA A
1231 HH:MM:SS
] JobRoles
f JobRolesi
[¥ Life Insurance
B Mmooy
L] MDD HH: MM SS
B MDDy
] MMIDD Y HH MM SS
B4 mmddyy
(4] Phone
H Prod_desc
Products
'EI region
] salary
Sales Orders
® sex
TH size List
(f] SocSechurmber
StateCode
(# StatusButtons
f statusDOLE
AB statusedit
Object Lavout AExtended Attributes

||
LY

w

Now that JobRolesl isdefined in the extended attribute system tables, you
can useit for any appropriate column in any table in the database. You are
going to assign it to the title column in the contactl table.
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8 Expand EAS Demo DB V110 IM in the Objects view to display Tables
and then the Columns in the contactl table.
Display the pop-up menu for the title column and select Properties.

The Object Details view now includes the properties dialog boxs for the
title column.

{7 tutor_im.pbl - InfoMaker,
File Edt View ©Object Design Rows Tools ‘Window Help

0o B OB o= n 8 8

Hew Opsn Fewiew  Sellib  Liblist  ToDalisl  Libmry  DEProl Dotk Exit

g 8 H B2 a4 5 = H

Dizcannes GremeTa  DrapObic Praperiie

[=-[1 Tables ed Attrib (EAS Dm] Calurmn ] 0
E borus ! Employee Status | General |Headers | Display | valid * *
E call_track mplovess
E contact Financial Codes Table: 4
=-E contactt ¥ Health Insurance | contackl |
=3 Columns EL] HH:mmM:55 Colurmn:
i [ HH:MM:S5:FFF [tile |
EL] HH:MM:55:FFFFFF
@j AR = Column Details
EJJ T/ HhiMMiss | cotumn mumber:
ELD 303pvey 4 |
R anpeeey prrrss | oo Tope:
T 0bRoles | har |
T JobRolest
W Life Insurance Display Width: =
EL1 MDD vy [2 |
(07 Forsign Key: EL MMIDD Y HH:MM: S5 Hullable:
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El examples v
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Change the column header, label, and display width of title

Getting Started

9 If the Edit Style tab is not visible, use the arrows in the upper-right
corner of the Object Details view to display the Edit Style tab.
Click the Edit Style tab to bring it to the front.

) tutor_im. pbl - InfoMaker,
Fil= Edit “iew Object Design Rows Tools Window Help

e B B » E = @ 8

e Dp=n Preview Sel Lib Liblet ToDalel  Libary DEFral  Daiaberse Exit
D T T e
D isann=s CremeTa DropObie Prapzrii= Ghme

=3 Tables n (€ i 1) [=1ER

|

E bonus - Employee Status it | General H Headers ii Display || valid ® %
E call_track employees - !
= contact Financial Codes Style Name:
=-E contact1 [ Health Insurance - ~
m HH:MM:55 [Mone) =
EenefitsCheckBox
] HH: MM 55:FFF ol Lot v

[ Foreign Key:
3 Indexes

[ Primary Key
[ Triggers
E customer
E department
.- emnlres
il | >

L] HH: MM 55:FFFFFF
E11 203y

L1 22304 HH:MM:SS
EL1 a03pvey

[ 333/ HH:MM: S5
JobRales

[w! Life Insurance
11 Mmyony vy v
i |

< *

Object Layouk hExtended Attributes
; i

NISQL Session AColumns jResults

10 Scroll the list of edit styles until JobRoles1 displays.

Click it to apply the edit style JobRolesl to the title column.

Select File>Save from the menu bar.

Now you change the label and header text for the title column. The text you
supply appears on forms and reports you create.

The column nameistitle, but the text you want to display is Job role. Also, you
change the display width to 1.5 inches. Theinternally stored datavalueisonly

two characters, but the values you intend to display are longer.

1 Thetitle column should still be current (if not, display its pop-up menu

and select Properties). Click the Headers tab to bring the Headers

property page for the title column to the front in the Object Details

view.
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3

All the extended attribute information for a column is definable using the

various pages in the Object Details view.

Type Job Role in the Label box.
Type Job Role in the Heading box.

L]
Column (EAS Demo DE Y110 IM) [=1HES
eneral | Headers | Display | valid © %

=Label

Label:
Job Rale

Positian:

left v

=Headi
L

Heading:
Job Rale

Positian:
center w

Click the Display tab to bring the Display page to the front.

Type 1.5 in the Display Width box.

=
[#® Column (EAS Demo DB ¥110 IM) [=1{ES |
General | Headers | Display |walid ¢ *

Display Format:

({Mone) w
Justify:
left v

Display Height {in:
1.66|
Display Width {in):
1.5
Case:
({Mone) w

|:| Picture

Select File>Save from the menu bar.

InfoM aker adds the extended attribute information for the column to the

extended attribute system tables.
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Assign a DropDownDataWindow edit style and initial value to state

Getting Started

For the state column, you assign an edit style that includes all the state names
(aswell asthe provinces of Canada). Then when you enter information into this
field, you pick from alist of states. You also set theinitial valueto MA, since
many of your contacts are in Massachusetts.

1 Inthe Extended Attributes view, display the pop-up menu for Edit
Styles and select New.

=

[FExtended Attributes (EAS Demo DB Y110
+-<E» Display Formats ~
=-<E*

Mew. ..
HEXE

EL a4 Refresh

EL .4

[ Benefit

H Color List

Customers

¥ Day Care

BT oompey

EL DOMMiy HH:MM: 55

] DOJMMYY HH:MM: 55:FFFFFF

EL ooy

B DOjMMpvyey HH:MM:SS

EL ooy

] DOJMMMyY HH:MM:SS

EL ooofvy

BT DODf HH:MM: 55 w
Olbject Layout yExtended Attributes

Edit Style settings display in the Object Details view.

EAS Dema DE Y110 IM) - Untitle[s]

General

Edit Style

|
Skyle Type

Edit R
Farrmat

Case
Lirnit

1)
Accelerator

L1

[J auto Selection

[oisplay Cnly

[ 5how Focus Rectangls

[CJEmpty String is MULL 3
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2 Type StateCodel in the Name box.
Select DropDownDW from the Style Type drop-down list.

(EAS Derma DB Y110 IM) - Stal

General

Edit Style e
StateCodel

Skyle Type

DrropCownDid .

Accelerator

[ allow Editi.ng o 2

= . o

3 Scroll down to the bottom of the view and click the browse button
next to the DataWindow box.
Select d_dddw_states from the DataWindow list.

The StateCodel edit style uses areport (Datawindow) named
d_dddw_states. Thereport getsits values from the state table.

0 o=
‘Width of DropDown(®e)
a ¥
Datawindow
d_dddw_states Q
Display Column
v
Data Colurmn
v
v

About DropDownDataWindow edit styles ]
A DropDownDataWindow edit style getsits values from areport that it

references. The report gets its values from the database.
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Thisiswhat the d_dddw_states report looks like.

& Report - d_dddw_states [_ O] =]
D Name Country| J
AB [Alberta CAN
Ak [Alaska LUSA
AL [Alabama LUSA
AR |Arkansas LUSA
AL |Arizona LUSA
BC  |British Columbia CAN
CA  |California LUSA
CO  |Colorado LUSA
CT  |Connecticut LUSA =
| A

4  Select state_id from the list for Display Column and for Data Column.
Type 550 for the Width of DropDown.
Select Vertical Scroll Bar.
Select Save Changes from the pop-up menu to accept the definition of
the StateCodel edit style.

S Demao DB Y110 IM

General

|| Harizontal Scroll Bar ~
Wertical Scroll Bar

[ 5plit Horizontal Scroll Bar

|:| AutoRetrieve
Lines In DropDown

0 s

‘Width of DropDown(®e)

550 ¥
Datawindow

d_dddw_states E]
Display Column

state_id v
Data Column

state_id v 2

InfoMaker adds the StateCodel edit style to the extended attribute system
tables, whereit isavailableto be assigned to any appropriate columninthe
database. Now you assign it to the state column in the contactl table.
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5

Display the pop-up menu for the state column in the contactl table
and select Properties.

i) tutor_im.pbl - InfoMaker,
File  Edit Ohbject

View

Design

8 ® B = .

B & B B =

Hew Opsn Prewiew  Sellib  Liblit  TeDalit  Libag

i & <= BH BE B %

Dbcannec Sare  crmeTa  Diopdbe Froperii=s

Tools  Window

B o= @

Rows

Help

g

DEFal  Dombse  Exit

(=[] Tables kk
£ borus -<B> Display Formats # | General | Headers | Display | valdation | Edit Style |
] call_track [=)-<0> Edit Styles
B contact B #awas Table: 4
= contact1 L] sttt [ contact1 |
=7 Calumns [T #i, .00 Column:
id [w BenefitsCheckBox ‘ state |
last_r TH Color List =
first 1 - (=] Customers - Column Details
title Iv Day Care Column Mumber:
streel EL ooy [7 |
L] DD{MMYY HH: MM Data Type:
Edit Column... FHM; ‘ char |
phon Drop Calumn He Display width:
. |
3 Forsign K H:Mr Mullable:
7 Indexes 3] ooy [ 1o |
(3 Primary K EL OoDfMY HH:MM:SS DieFault: =
[ Triggers 3] poofyryy v | [ thone) |
. custormzr < H_MMI\ ) | commerts:
= b= | L
w1 anmnlrwves | it -
£ i | > IAI50L Session AColumns AResulks £
Reeady Rows 1 ko 4 of 63

In the Column Properties view, select the Edit Style tab.

Select StateCodel for the edit style to assign to the state column.

(If the StateCodel edit style is not listed, select View>Reset View. This
refreshes the list of edit styles.)

L]

[ Column (EAS Demo 10 1M} - =] Eq
Display | Walidation | Edit Style SE
Skyle Mame:

SocSechumber rS

StateCode B
StateCodel
StatusButtons

This assignsthe StateCodel edit style (which includes 63 entries—states,
territories, and possessions of the United States and provinces of Canada)
to the state column in the contact table. The values that this edit style
displays and the valuesthat it stores are state postal abbreviations (such as
MA for the state of Massachusetts).

InfoMaker



Lesson 4 Table Tutorial

7 Select File>Save from the menu bar.

8 Click the Validation tab.
Make sure the Validation Rule setting is (None).
Type MA in the Initial Value box.

This assigns an initial value of MA to the state column.

[ Colurnn (EAS Dema DE w110 I0) - cqml
General | Headers | Display | Yalidatic * #

validation Rule:

(Mone) w
Initial value:
118 w

The Validation page lets you create and assign avalidation ruleto a
column and enter an initial value for the column.

You are not going to assign avalidation rule. You have handled validation
by forcing the user to select from exactly 63 valid values presented in the
States drop-down Datawindow.

About column validation rules ] o
You can use column validation rulesto express requirementsfor entriesin

acolumn. For example, you could define arule for asalary column that
requires salaries to be greater than $15,000 and less than $100,000.

When you assign a column validation rule to acolumn, ho one can enter a
value that breaksthe rule.

9 Select File>Save from the menu bar.

InfoMaker saves the extended attributes you just defined for the state
column in the extended attribute system tables.

Getting Started 117



Define extended attribute information

Define an Edit Mask edit style for phone and fax

Now you define an Edit Mask edit style to display phone and fax numbers for
both viewing and editing.

1 Inthe Extended Attributes view, display the pop-up menu for Edit
Styles and select New.

ded Attribubes (EAS Dermo DB v110[=HEY
+-<E» Display Formats ~
=J-<H*

Mew. ..
HEXE

EL a4 Refresh

EL .4

¥ Benefit

H Color List

Customers

¥ Day Care

BT oompey

EL DOMMiy HH:MM: 55

] DOJMMYY HH:MM: 55:FFFFFF

EL ooy

B DOjMMpvyey HH:MM:SS

EL ooy

] DOJMMMyY HH:MM:SS

EL ooofvy

BT DODf HH:MM: 55

EL oooveey w
Olbject Layout yExtended Attributes

Edit Style settings display in the Object Details view.

2  Type TelephoneNumberl in the Name box.
Select EditMask in the Style drop-down list.
Delete xxx and type (###) ###-### in the Mask box.

[P®IEdit Style (EAS Dema DB W10 IM) - Telephonm] 3

General | Calendar

Edit Style

TelephoneMumber 1
Skyle Type

EditMask. v
Mask.

(REE) REB-FREE i
Accelerator

v

The pound signs (#) in the Mask box are placeholders for numbers. Only
numbers O through 9 can be entered in each of these positions.
Parentheses, the hyphen, and the space are where you want them to
display. When you type a telephone number in the Test box, you can see
the effects of the edit mask.
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Getting Started

5

Select Save Changes from the pop-up menu to accept the definition of

the Edit Mask edit style named TelephoneNumber1.

InfoM aker addsthe TelephoneNumberl edit styleto the extended attribute
system tablesin the database and lists it as one of the available edit styles
in the Extended Attributes view.

Display the pop-up menu for the phone column and select Properties.

I=

= contact
=-E contact1
=3 Columns
id
last_name
first_name
Litle:
street
city
state
zip
Fax
7 Foreign Ke

[ Triggers

7 Indexes T —
[ Primary ke| 0% Properties vy

[=-<E* Edit Styles
EL #aens
EEEIT R TR
EI ###,#22.00
¥ BenefitsCheckBox
8 Color List
Customers
¥ Day Care
BT oompy
EL DOMMiy HH:MM: 55
] DOJMM[YY HH:MM: 55:FFFFFF
EL oompeey
B DDjMMpvyey HH:MM:SS

. Y
Edit Column... MM HHIMM:SS
Drop Column i

' HH:MM: 55

| {4l DODYYY HH:MM:SS

In the Object Details view, click the Edit Styles tab, then scroll the list
and select the TelephoneNumberl edit style.

Skyle Mame:

==
¥ Column (EAS Demo DB Y110 IM) - contactl :pi=lE3
General | Headers | Display | Validation | Edit Style

Telephoneumber

ZipCode
ZipCode_Short

(£
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Define extended attribute information

120

This assigns the TelephoneNumberl edit style to the phone column. Now
you use the same edit style with the fax column. Once you have created an
edit style, it isavailable for any column.

6 Display the pop-up menu for the fax column and select Properties.

InfoM aker promptsyou to save the changesyou just madein assigning the
TelephoneNumberl edit style to the phone column.

7 Select Yes.

8 In the Object Details view for the fax column, select the Edit Style tab
and the TelephoneNumberl edit style.
Select File>Save from the menu bar.

£ Datahbase - 1 Connection: (Active Connection - EAS Demo DB Y110 [#) '_ E rz|

=] Tables

E bonus
] call_track
E contact

E contactl

o-8-8-80

[ Fareign Keys
3 Indexes
3 Primary Key
[ Triggers
E customer
.- F danartment

Prod_desc
Products
Eﬁ region
[ salary
Sales Orders
® sex
T Size List
Etl SocSecMurmber
SkateCode
StateCodel
StateCodel
(® StatusButtons
T StatusDOLE
AB stabusedit
B:l TelephoneMumber
E:l TelephoneMumber 1
E:l ZipCode
E:l ZipCode_Shart b
< ¥
| 4 [sobject Layout 3Extended Atlﬂ

T E T T T T T T T T T TR TP TR eressrn
[#] Column (EAS Derno DB 110 =] E3
General | Headers | Display | val S

Style Mame:

TeIeEhoneNumber S
ZipCode

ZipCade_Shart b,

MISQL Session 4Colurnins jResuls

Now you have finished extending the definitions of your columns. Next you

add datato the table.
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Add data to the table

Where you are

Create the database table

Define extended attribute information
> Add data to the table

To add datato your table, you import atext file of tab-separated values.
Importing the file quickly adds 60 rows of data.

Typically you create aform to add datato the database. In theform tutorial you
saw how to add data using aform.

1 Display the pop-up menu for contactl and select Edit Data>Grid.

= Database - 1 Connection: (Active Connection - EAS Demo DB V110 IM)
e ]

rided Attributes (EAS Demo DB Y] ES
~

=1 Tables »~ <@» Display Formats ~
= bonus [=)-<E> Edit Styles
=] call_track EL #aed
=] contact FL] #a-#a-2hae
ER=]ortact! | New , .00
iterheckRoy G
Edit Data EREER
Data Pipeline Tabular...
Aleer Table... Freeform...
MY HHIMEES
Drop Tabl
rop T MIYY HH:MM: 55 FFFFFF
add ko Layout Y
—————————————— WYYV HHMMSS
Print Definition MM
Export Synkax MY HH:MM: S5
(7 Foreig _
[ Indew <E»  Properties P HH:MM: 55
< T 4 JoOjeCT Layour sExtended Attribute:

The Results view shows column headers but no data. Thisview letsyou
view, add, modify, and delete data.

EEri L
e DDJMM{YYYY HH:M

[ Foreign ke DDV}
[ Indsxes DDMMMYY HH: MM 55 Style Name:

I Primary Ke s | | € | Te\eshoneNumbe Al
| > J Object Layout xExtended Attributes J i s b

Id Last Hame First Name Job Role Strest

[
|w
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Add data to the table
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Select Rows>Import from the menu bar.

The Select Import File dialog box displays. You might need to change to
the Tutoria folder, which contains the file you use.

If necessary, change to the Tutorial folder.
Double-click the contact.txt file.

InfoMaker importsthe datainto the Resultsview (the datais not yet in the
database).

Id Last Name First Mame Job Role i’
il Hildebrand Jane Marketing 12
2 Simmon Larry Sales 3¢
3 Critch Susan Praduct development 44
Kl | LI_I

Select Rows>Update from the menu bar.

This adds 60 rows of datato the database. To be sure that the dataisin the
database, you retrieve it from the database.

Select Rows>Retrieve from the menu bar.

InfoMaker retrieves all the contact data from the database and displaysthe
datain the Results view.

Select File>Close from the menu bar.

This closes the Database painter.

You have created a new database table, complete with extended attribute
information and data.
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LESSON 5 Query Tutorial

A query isa SQL SELECT statement created with the Query painter and
saved with a name so that it can be used repeatedly to define data
requirements. A SQL SELECT statement is the way you tell the DBMS
exactly which rows and columns to retrieve.

Queries save time because you can use them to define all your data
retrieval needs. For example, you can specify the columns and rows to
select, aswell as the sorting requirements. Then you specify the query as
the data source whenever you create forms and reports that use the data
the query isintended to retrieve.

How long does this tutorial take?
About 15 minutes.

About the query

The query you createretrievesfinancial data. When you have finished, the
query returns data from the database that is similar to this.

Year Quarter Type Description o

1897 03 ExpEnsE R&D

1997 04 ExpEnsE R&D

1957 1 ERpENSE Sales & Marketing

1897 Q2 ERpENSE Sales & Marketing

1897 03 ERpENSE Sales & Marketing

1997 04 ERpENSE Sales & Marketing

1957 1 ERpENSE Services

1897 Q2 ERpENSE Services

1897 03 ERpENSE Services

1997 04 ERpENSE Services A
| | »

Thefinancial datais stored in two tables: the fin_data and fin_code tables.
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About the query
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Thefollowingillustration showsthe two tableswith some data. The code value
in the fin_data table gets its meaning from the fin_code table.

Year Quarter Code Amount in thousands =

1997 @t 2 1833
1997 62 el 204
1997 02 =2 375
1997 02 &3 4500
1997 02 =4 1472
w02 b s
1397 uz@

1937 Q2 12
1937 Q3 el

1937 Q3 e 984
1937 Q3 [=x} 4532
1937 Q3 ed 1433
1937 Q3 956
1937 Q3 13567
1937 Q3 12 2837
1937 04 el 21
1937 04 e 352
1937 04 [=x} 5238

|Ready |Rows B Yy

Code Type Description
el ExpEnsE Fees

el ExpEnsE Services

el ExpEnsE Sales & Marketing

ed ExpEnsE R&D

=] EHpEnse Adminiztration

1 Tevenue Fees vl

2 Tevenue Services

K »
+ i Calumns} Fresults £ 3

|Ready #Rows 1=2d: 7 [ i

For example, the rl circled in the fin_data table means the row reports a

revenue amount for fees.
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Lesson 5 Query Tutorial

Select columns

Where you are

> Select columns
Save the query
Specify row selection criteria
Specify sorting for the rows
Create a report using the query

1 Click the New button in the PowerBar.

T tutor_im. pbl - InfoMaker,

File Tools Window Help

B & @ B = B = B 8

Hew Op=n Preview Sel Lib Liblet TaDaled  Library DEPral  Databere

The New dialog box displays.

2 Select the Database tab and the Query icon.
Click OK.

Neww: |X|
| Library || Object | Database | Tool

g (B %

= g

Database Painter Query Data Pipeline

[ Ok ] [ Cancel
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Select columns

126

3

InfoMaker connects to the database, and the Select Tables dialog box
displays. In this dialog box you can select one or more tables to use.

? untitled - Query,

(=]

Select Tables

bonus
call_track
contack
contactl
customer
departrent
emploves
exam_xref_info
exan_xref_list
examples

examples_categories_list

Drag and drop column

[]show swskem tables

You are going to use two of the tables.

Click the tables named fin_code and fin_data.

Select Tables

X

exam_xref_info
exam_xref _list
examples

messages
ole
prinker
oroduct: ks

[ 5how system tables

employee ~ Cpen

examples_categories_lisk
Cancel
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Getting Started

4

Click Open.

Thefin_code and fin_data tables display. Both tables have a code column.
The tables are joined on the code column.

=
[ 7able Layvout
Selection Lisk: (400 (&

code char{2)  Unigue financial identification code
type char{10) Financial Code bype
description char{S0) Financial Code description

year  char(4) ‘ear financial data applies ko

quarter char(Z) The quarter that the financial data applies to

code  char(Z) Financial Identification Code

amount numeric(,0) Dollar amount recorded For vear, quarter, and financial code

If your display does not include all the information shown in the picture,
right-click in the Table Layout view and select the information you want
to display from the Show menu.

Thefin_data table hasacode valuein each row to indicate what the row of
data appliesto (for example, r1 means revenue from fees).

The fin_code table stores information about codes, including the actual
values (such asr1 and ed), thetype of each code (revenue or expense), and
adescription of each code.

Next you select columns from the tables.
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Select columns

5 Click year in the fin_data table.
Click quarter in the fin_data table.
Click amount in the fin_data table.
Click type in the fin_code table.
Click description in the fin_code table.

When you click each column, it is highlighted in the table and added to the
selection list above the tables.

2% (Untitled)

armount nurme

g and drop columnns in the order in which you want
fin_code"."code" A

fin_code"."tvpe"
fin_code"."description”
fin_data","year"

fin_data","quarter"
fin_data"."code”
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Getting Started

6

Select Design>Preview from the menu bar.

You can see the results of your query. InfoMaker uses your query asit is
currently defined to access the database and retrieve data.

{7 tutor_im. phl - InfoMaker "L”Elg‘
File Edit Design Rows Tools ‘Window Help

oo B B o= B =B 8 -

pen  Frexiew  Sellih  Lblst  ToDalet Libmy  DEProl  Dambee  Exi

He
B 4 4 B M O x

First Priar Hext L=t Prim  Choe

59(=1E3)
‘Year Quarter Amount in thousands Type Description ~
2003 @1 100 evperse Fess 1
2003 Q2 93 expense Fees
2003 Q3 129 expense Fees
2003 G4 145 expense Fees
2004 Q1 153espense Fees i
2004 Q2 149 expense Fees
2004 Q3 157 expense Fees
2004 Q4 163 expense Fees
2005 @1 198 expense Fees
2006 G2 204 expense Fees
2005 Q3 214 expense Fees
2005 Q4 231 expense Fees
2003 g1 403 expense Services
2003 Q2 459 expense Services
2003 Q3 609 expense Services
2003 G4 E32 expense Services
2004 @1 643 expense Services
2004 Q2 BB7 expense Services
2004 Q3 858 expense Services 2
Ready Rows 1 ko 19 of 84

Use the scroll bar to view the data.

Each row has either the word expense or the word revenue in the Type
column. First you save the query and then you use the value in the Type
column to select rows for the query.

Select File>Close from the menu bar.

You return to the workspace.
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Save the query

Save the query

Where you are
Select columns

> Save the query
Specify row selection criteria
Specify sorting for the rows
Create a report using the query

Now you save the query and giveit a name.

1 Make sure you are back in the workspace.
Select File>Save from the menu bar.

The Save Query dialog box displayswith the pointer positioned for you to
type aname for the query.

2 Type g_expenses.

Save Query rz|
Queties:
Ok
= | mEm
what_your_customers_are_ordering

Comments:

Library:
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3 Click in the Comments box and type This query retrieves financial data
from the fin_data and fin_code tables. The query selects expense rows and
sorts rows by year, description, and quarter.

Save Query rz|
Queties:
| q_Expenses |

what_your_customers_are_ordering

Comments:

This query retrieves financial data from the fin_data and
fin_code tables, The query selects expense rows and
sorks rows by year, description, and quarter,

Library:

fomaker 11.0%kutorialibutor im,

4  Press OK.

InfoMaker saves your query.
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Specify row selection criteria

Specify row selection criteria

Where you are
Select columns
Save the query

> Specify row selection criteria
Specify sorting for the rows
Create a report using the query

Now you select the rows to include in the query. To do this you specify
selection criteria

The query you are creating is for expenses, so the rows you need are those
whose type is expense. You do not need the rows whose typeis revenue.

1 Click the Where tab at the bottom of the workspace if it is not in front.

The Where tab comes to the front. In the Where tab you specify selection
criteriafor retrieving rows.

expenses - Queny

iz Open et

Alsroup AHaving hCompute jSynkas /
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Lesson 5 Query Tutorial

2 Click the first space under Column and then click the arrow to display
a list of columns.
Click the column named "fin_code"."type" in the list of columns.

? q_expenses * - Query

li o i oo ton R I ps i e el
|"Fin_c0de"."type" w

The equal sign (=) displays by default in the Operator box. Thisiswhat
you want.

3 Move the pointer over the Value box.
Press the right mouse button to display the pop-up menu.
Select Value.

Column Cperator Value Laogical
r fin_code","type Calmns. ..

Functions...

Value, ..
Select...
Clear

Insert Clause

Delete Clause priiii:

Where Group syHaving aCompuke i Svnkax
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Specify row selection criteria

134

Whenyou select Value, InfoM aker liststhevauesinthe"fin_code"."type"
column, which are expense and revenue.

Type
ExXPEMSE

TEVENLUE

Select expense and click the Paste button.

The selection criteria are complete. Notice that the value expenseis
surrounded with single quotes. These are required. If you type the value
here rather than choosing it, you need to type the single quotes.

=

Logical

where

I Colurin Operatar
"fin_code","type" E ‘expense”

Where Group aHaving aCompute i Syntas /

Notice that the Logical box displays at the end of the line. Thisbox isfor
choosing alogical connector such as AND so you can specify more than
one selection requirement. You do not need to use this box for this query.
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5 Select Design>Preview from the menu bar.
Use the scroll bar to view the data.

Now all rows have expense in the Type column. Rowswith revenuein the
Type column are not retrieved.

i) tutor_im. pbl - InfoMaker

File Edit Design Rows Tools  Window  Help
i E B o= B =8 8 W
Qpsn Peeview  Sellib  Libls  ToDolst Lbmy  DEProl  Dembss  Exit

=] = X

Prim S

Year Quart A t in th d: Type Description

2003 01 101 expense Fees

2003 02 93 expense Fees

2003 03 129expenze Fees

2003 04 145 expense Fees

2004 1 153 expense Fees

2004 02 149 expense Fees

2004 03 157 expense Fees

2004 04 163 expense Fees

2005 01 198 expenze Fees

2008 02 204 expense Fees

2005 03 214 expenze Fees

2005 04 23 expense Fees

2003 01 4003 expense Services

2003 02 4589 expense Services

2003 03 B9 expense Services

2003 04 632 expense Services

2004 o1 Ed43 expenze Services

2004 02 BB7 expense Services =
Ready Rows 1 to 15 of 54

6 Select File>Close from the menu bar.

You return to the workspace.
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Specify sorting for the rows

Specify sorting for the rows

136

Where you are
Select columns
Save the query
Specify row selection criteria

> Specify sorting for the rows

Create a report using the query

Now you specify sorting for the rows. When you specify sorting, you also
enable grouping. Before you can define a group, the rows have to be sorted so
that the data can be grouped.

1

2

Click the Sort tab at the bottom of the workspace.

The Sort tab comes to the front. In the Sort tab, you specify one or more
columns to use for sorting the rows.

"fin_data"."cods"
"fin_data"."amaunt"

Sork Awhere aGroup AHaving A Compute 3Synkax

Scroll the list as needed to drag and drop column names.
Drag and drop "fin_data"."year" from the left box to the right box.

Drag and drop "fin_code"."description" from the left box to the right box.
Drag and drop "fin_data"."quarter" from the left box to the right box.

In all cases Ascending iswhat you want. Ascending means years and
quarters are ordered by increasing values and descriptions are
alphabetized from A to Z.

Drag and drop columns in the order in which you want

"fin_cade" "code” "fin_data"."year" Ascending
"fin_cade"."description" Ascending
"fin_data"."quarter" Ascending

"fin_data"."code"
"fin_data"."amount"

Sark gwhere 4 Group WHaving sCompute aSynkax
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3 Select Design>Preview from the menu bar.

Use the scroll bar to view the data.

First the rows are sorted by year. All the 1995 information isfirst. Then
they are sorted by description so that expenses of the same category are
together. Finally the rows are sorted by quarter so that the datais always
time-sequenced.

{7 tutor_im. phl - InfoMaker

File  Edit

Year Quarter Amount in thousands

2003 @1
2003 Q2
2003 g3
2003 o4
2003 @1
2003 @1
2003 G2
2003 Q2
2003 g3
2003 3
2003 Q4
2003 o4
2003 @1
2003 Q2
2003 g3
2003 o4
2003 @1
2003 g2
2003 3
2003 Q4
2003 @1
2003 @1
2003 Q2

Window  Help

e B B = B =

Liblst  TeDalet  Libmo

2] =

L=t Frim

381 expense
402 expenze
412 expenze
4E7 expense
101 expense
1023 revenue
93 expenze
2033 revenue
129 expenze
2958 revenue
3014 revenue
145 expenze
B23 expense
784 expenze
856 expense
1043 expense
1437 expense
2033 expenze
2184 expenze
2145 expense
234 revenue
403 expense

459 revenue

Type

B 8

DBProl  Daaleme

Description

Adrinistration
Administration
Adrninistration
Adrinistration
Fees

Fees

Fees

Fees

Fees

Fees

Fees

Fees

R&D

R&D

R&D

R&D

Sales & Marketing
Sales & Marketing
Sales & Marketing
Sales & Marketing
Services

Services

Services

Bk

Rows 1 ko 23 of &4

4  Select File>Close from the menu bar.

You return to the workspace.

5 Select File>Close from the menu bar.

If prompted to save changes, click Yes.

The Query painter closes.

Getting Started
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Create a report using the query

Create a report using the query

Where you are
Select columns
Save the query
Specify row selection criteria
Specify sorting for the rows
> Create a report using the query

Now you use the query to create a new report.

1 Click the New button in the PowerBar.
Select the Object tab.
Select the Tabular presentation style.
Click OK.

[ ——————————— ]
0 EH = £ &

Farm Composite Crosstab Freeform Graph

EE]

Label

Bl

TreeYiew

RichText

[ Ok ] [ Cancel

The wizard for creating tabular reports displays.
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Getting Started

2

Select the Query data source.

Make sure the Retrieve on Preview check box is selected and click

Next.

Tabular Report Generator E| le

‘which data source would you like ko use?

@ 8 B B

Quick Select  SGQL Select External

Stored
Procedure

/ Retrieve on Preview

< Back [ Mexk = ][ Canicel ]

The Select Query dialog box displays. In this dialog box you specify the
query to use. You are going to use the query you just created as the data

source.

Click the button to the right of the Specify Query box.

Select Query

Specify Query:

[ < Back ][ Mexk = ]L Cancel
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Create a report using the query

140

The Open dialog box displays.

Open

Queries:

] X

Ok

what_your_customers_are_ordering

|

Comments:

This query retrieves financial data from the fin_data
and fin_code tables, The query selects expense
rows and sorts rows by year, description, and

Library:

< | &
Object Type:
i
Click g_expenses and click OK.
The query g_expenses displaysin the Specify Query box.

Select Query

Specify Query:

g_expenses

[ < Back ][ Mexk = I[ Canicel ]
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Getting Started

Click Next.

The Select Color and Border Setting dialog box displays. You are going to
accept the defaults.

Select Color and Border, Settings

Select color and border options For your report:

Background Color:
Text
Calar: Il vindow Text
Border: MNoBorder
Columns
Calar: Il vindow Text
Border: MNoBorder

[5ave as default

< Back ” Mext = ][ Cancel

Click Next.
A dialog box summarizing all your specifications displays.

Look over your specifications and then click Finish.

Your report displays in the Report painter. Thisisthe Design view.

=
Design - (untitied)

7|I|||I|1||I|||I|2||I|||I|3||I|||I|4||I|\|\|5|\|\|\|

4 Year Duarter - Amount in thousands. - - TFype - - - - .. ... ... Deseription

Header {

_hn_-datihn_d.: s fin_data- - - - - - fin_-code_typefin: eode - deseription- - -

| Detail t

[Summary 1

[Footer T

[l

|
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InfoMaker uses the query you created to retrieve data from the database.

Because the query includes selection criteriaand sorting requirements, the
database returnsonly the datayou selected, in the sort order you specified.
Hereisthe report in the Preview view.

Year Quarter Amount in thousands Type Description

1935 a1 3 ERpENSE Adminizgtration

1995 Q2 402 ERpENSE Adminizgtration I

1995 (3 412 ERpENSE Adminizgtration

1995 (4 467 ERpENSE Adminizgtration

1935 a1 1m ExpEnsE Fees

1995 Q2 93 ExpEnsE Fees

1995 (3 129 ExpEnsE Fees

1995 (4 145 ExpEnsE Fees

1935 a1 EZ23 ExpEnsE R&D

1995 Q2 a4 ExpEnsE R&D

1995 (3 856 ExpEnsE R&D

1995 (4 1043 ExpEnsE R&D

1935 a1 1437 ERpENSE Sales & Marketing

1995 Q2 2033 ERpENSE Sales & Marketing

1995 (3 2184 ERpENSE Sales & Marketing

1995 (4 2145 ERpENSE Sales & Marketing

1935 a1 403 ERpENSE Services

1995 Q2 455 ExpEnsE Services -
¥ | v

At thispoint you could continue designing and improving your report, but
for thistutorial, you leave the Report painter now. You do not save the
report.

Select File>Close from the menu bar.

This Message Box displaysto seeif you want to save your report.

2 Save changes ko
\-_“/

(Untitled)?

I Yes l [ Mo ] l Cancel

Click No.

The Report painter closes.
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LESSON 6 Graph Tutorial

Graphs present datain avisual way so that you caninterpret it moreeasily.
You can use graphs to supplement the numbers in areport or you can
replace numbers with a graph. InfoMaker provides a variety of graph
styles and options.

The graph you create in thistutorial usesfinancia data (the same data as
the Query tutorial). You start with areport that is already created and add
agraph to the report. When you have finished, the report and the graph

look like this:
F'r'Et'-«'iE‘. X PIE
10/30/2006
Expenses for 2003 Page 103
Amount
in thousands
Enpense Breakdown
Administration T 024%

o 381
oz 402
Q3 412

et} 467 | Omemmen | [
1662

Fees
at 101
o2 93
a3 122
Q4 145
468
|
< >

How long does this tutorial take?
About 30 minutes.
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Open the report to contain the graph

Open the report to contain the graph

Where you are
> Open the report to contain the graph
Create the basic graph
Save the graph (report)
Enhance the graph
Print the graph (report)

First you open areport that has been created for you. This report provides the
data for your graph.

1 Click the Open button in the PowerBar.

{71 tutor_in. pbl - InfoMaken

File Tools ‘Window Help

rs B = B = 8 8 Bk
Hew Qp=n Praviess SelLib Libled TaDale  Library DEPral  Dabbees Exil

The Open dialog box displays. It lists objects in the current library
(tutor_im). You will be using the report named expenses.
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Getting Started

Select the Reports object type at the bottom of the dialog box.
Click expenses (scroll the list).

Click OK.

Open r$_<|

Object:

o]
[experes |
Cancel
emp_name_tags A~ -
emp_nup_salary_benefits =
emp_telephone_attributes
emp_total_compensation

emsloéee irouied salari

printer_sales b

Comments:

Tutorial: Used For tutorial, Expenses for years
1995-1997

Library:

< >

Object Type:
i5| Reports w
L] |

The report displays in the Report painter. Here isthe Design view.

e R S i e B R e B [

today()

-~

Header[

1: Header group year

T deseription: oo IlIIIIII I CsiIIIIiiin

2: Header group description |

e CEUAR S AIOUIT © st

Summary
Footer {
b
< | kg
L= =
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Open the report to contain the graph
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Look at the Preview view.

InfoMaker retrieves information from the database and displays as much
asfits on the screen.

IE

Administration

R&D

=

a3
Q4

[}l
Q2
[RE}
Q4

a1

10/27/2006
Expenses for 2003 Page 1 of3

Amount
in thousands

381
402
12
467

1662

101

93
129
145

468

623

Use the scroll bar on the right edge of the report to see more data.

The entire report consists of three pages: one for 2003, one for 2004, and

one for 2005.
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Lesson 6 Graph Tutorial

Create the basic graph

Where you are

Open the report to contain the graph
> Create the basic graph

Save the graph (report)

Enhance the graph

Print the graph (report)

The report you are working with has three pages, one for each of three years.
The graph you create will be on al three pages. Its format will look the same
from page to page, but the data will be for the correct year for each page.

Thisiswhat a graph for 2003 looks like. It shows the year’s expensesin five

categories.
H Report - expenses,_graph
3/20/2007
Expenses for 2003 Page 1 of 3
Amount
inlthousands Expense Breakdown

Administration o
at 3|1
az 402 00
a3 412 _
Q4 467 ; <

1662 N
20

Fees

Q1 101 .
MU Fem S
Gz 93 Ll Ll (V;‘u&ulj Sak= @ Mak Se
Q3 129
a4 145
o] ~
< >

1 Select Insert>Control>Graph from the menu bar.
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Create the basic graph

148

Click in the middle of the Design view.

The Graph Data dialog box displays.

Rows: | all v1|
Cateqgaory: b Cancel
Value:| v
|:| Series
Type: A Hone)
= -z
= m
o
=
P
=
& LS L1 c o e
v Category
., + —
Sample Graph

Click the down arrow on the Rows box.

The drop-down list shows choices for rows.

Graph Data le
Rows:
Categary: [l '
qory Group 1 Cancel
Yalue: |Group 2 M
Page
I:‘Series
Tvpe: A {None)
M E " -
Area Bar = -
o
=
W x g
. .
Lne
. - o
- " Category
= e bt
Sample Graph

The All option includes al rowsin the graph. Since you want to have the
appropriate graph for each of three years, you do not want to include al
rowsin the graph at the same time.

The Group 1 option includesthe rowsfor the current Group 1. Group 1 for
thisreport is grouping by year, so Group 1 iswhat you want. When you
specify Group 1, you ensure that the graph includes only rows from the
current year.
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Lesson 6 Graph Tutorial

4  Select Group 1.

Next you fill in the Category and Value boxes. The graph will show

expenses for the year by type of expense. (For this graph you do not need
to fill in the Series box.)

The description column provides the categories (Administration, Fees,

R&D, Sales & Marketing, Services).

The sum of the amounts for the four quarters for each category provides

the values.

Administration

R&D

=

=]
Q2
Q3
Q4

Q1
Q2
Q3
04

=]

Amount
in thousands

381
402
412
467

1662

m

93
129
145

468

623

Expenses for 2003

5 Click the down arrow next to the Category box.

A drop-down list displays the columns you can choose to supply the

10/27/2006
Page 10f 3

categories to use in the graph. (You can think of categories as X values.)

Graph Data
Rows:| Group 1 %
Cateqgary: bt Cancel
Walug; [amount
description
I:‘Series quarker
bype
Type:|yvear )
‘W= -
Area Bar =
o
=
m =~ 5
"
Lne
. - o
v Category

Sample Graph

X

Getting Started

149



Create the basic graph

150

6

Select description.

This specifies that the values in the description column are the categories.

Click the down arrow next to the Value box.

A drop-down list displays all the choices for the column to supply the
valuesto useinthegraph. Noticethat the choicesinclude expressions such
as counts and sums.

Graph Data le
Rows:| Group 1
Category: | description b Cancel
Yalue: -

Series |aMmount
0 countidescription for graph)

Type: |count{quarker for graph;)
countibype for graph)
countiyear for graph)
description

quarker

sumiamount for graph)
bype

YEar
B T n
Line

Category

| £

N At

Sample Graph

Select sum(amount for graph).

This specifies that the sum of the amount column isthe value. A separate
valueis calculated for each category within each year.

Graph Data le
Rows:| Group 1
Category: | description b Cancel
Value: | ZMIELT v
I:‘Series
Type: ~ {Hone)
M E " -
Area Bar — -
o
=
l Q P
=
Line
" LS L] c o 13
_ v Category
P PN 2
Sample Graph
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Lesson 6 Graph Tutorial

9 Click OK.

The graph displays in the report. What you see in the Design view isa
representation of the graph. To see what it looks like in the report, you
need to look at it in the Preview view.

PRI D T DN I DT AT NI IR DRI T DT DU DA XTI T SO I DT T O I DTN BT
e ~todayd S d
3 s Expenses for year o page” s pageg
3 CUOPRMBMAE
17. P N .inthnusands U R

Header [

_ [TrHeader group yeart
:'desc”ri,bﬁoh::::::::::::::::::::::::::::::::::::::::::::::::
__[2eHeader group descriptiont
1 . ..quan.amoun-. F et e e e e e e e e

Detail [
_::::::::::::Sum(a’:::::::::::i” e
_ [2eTrailer group description 1 .

1: Trailer group year : o

Summary [

Footert

a
< >
. -

10 Look atthe graph in the Preview view.

In the Preview view, InfoMaker displays the data retrieved from the
database both in the report and in the graph. The graph is small right now.
Inafew minutes, you will resizeit.

I F'IE".-‘I
10/30/2006
Expenses for 2003 Page 1 of 3
Amount
in thousands
Administration
at 3|1
Q2 402
Q3 412
Q4 467
1662
-
Fees
at 1m
Q2 93
Q3 129
Q4 145
465
s
< >
—_ | BE -
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Save the graph (report)

Save the graph (report)

Where you are
Open the report to contain the graph
Create the basic graph
> Save the graph (report)
Enhance the graph
Print the graph (report)

Now you save the graph. The graph is part of the report, so to save the graph,
you savethereport that containsit. To leave the original report unchanged, you
will use the Save As command. Save As saves anew report with the name you

supply.

1 Select File>Save As from the menu bar.

The Save Report dialog box displays; the name of the report you opened
earlier is highlighted.

Save Report @

| Ok
attrib_birthdays ~
attrib_crossout_and_visible =
attrib_escapement_rotation
attrib_font_height
attrib_format
attrib_graybar_emp_total_comp b

Comments:

Library:

c:iprogram filesisybaselinfomaker 11.0%kutarialitukor im.pbl

2 Type expenses_graph.
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Lesson 6 Graph Tutorial

3 Click in the Comments box and type This report summarizes expense
data for 2003, 2004, and 2005. It includes graphs as well as humeric data.

Save Report [‘S_<|

Repaotts: |

| expenses_graph

attrib_birthdaws ~

attrib_crossout_and_wisible e
attrib_escapement_rokation

attrib_fonk_height
attrib_Format

attrib_gravbar_emp_total_comp b

Comments:

This repart summatizes expense data for 2003, 2004, and
2005, It includes graphs as well as numeric data.

Library:

rialitutar im.pbl

4  Click OK.
InfoMaker saves your report, including the graph.
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Enhance the graph

Enhance the graph

Where you are
Open the report to contain the graph
Create the basic graph
Save the graph (report)
> Enhance the graph
Print the graph (report)

To enhance the graph, you:
* Resize and reposition it
* Addatitle

»  Change graph types

Resize and reposition the graph

Usually you work in the Design view when enhancing areport or graph, but to
resize and reposition agraph, youmay find it easier towork onitinthe Preview
view. You can get a much better idea of what the page looks like. The sizing
and positioning changes you make are retained and reflected in the Design
view.

1 Resize and reposition the graph so that it looks like the one shown

here.
=] Report - expenses_graph El@lg‘
A
3/20/2007
Expenses for 2003 Page 10f3
Amount
inithousands Expense Breakdown
Administration 0
al 381
Q2 402 &m
a3 412 _
Q4 467 § 4o
1852 -
e
Fees
ol 101 .
Adminstu P RED Sab= @ Mt Sevios
Q2 93 i fiyini -
a3 128
Q4 145
468 3
< ks
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Lesson 6 Graph Tutorial

Add a title

Getting Started

To make the graph bigger, put the pointer near a corner or aside until the
pointer changes shape. Then click and drag the corner or the side. To move
thegraph, put the pointer in the middle of the graph and then click and drag
the graph.

Use the scroll bar to display the graphs for 2004 and 2005.

Move the pointer to the middle of the graph in the Design view (not the
Preview view) and click.

This selects the graph. The current title, (None), displays on the graph, in
the text box in the StyleBar, and in the Properties view.

Type Expense Breakdown.

Thetitle displaysin the graph and in the text box.

H expenses_graph * - Report

| [N DD DU DNOU DUTT DU DU DU DD DU 0 DOU DU U DU DU'EN DUDY DU N DO DT DU DUDN: DUTU DU TN DR IO
3 e PN . L | ISR
E . Expensesforyear - == = pagospagey
3 B T SR

7 -+ - - inthousands - - ------ .- .*

Expense Breakdown

1: Header group yearf

L dsseripiton
3 Header group description e
oo quatamouw oo - R
Detail T e

S S sumfar

2: Trailer group description
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Enhance the graph

Change the graph type

You can use many different types of graphs to present the same data.
Sometimesit is useful to try different types until you find the one that works

156

best for the data you are presenting.

Now you try several graph types with the expense data.

1 If you need to, use the scroll bar to display the entire graph in the
Design view.

2 Move the pointer to the graph in Design view and click it.

The graph is selected. The properties for the graph display in the
Properties view, with the General page on top. On this page you can
choose a graph type. The current graph type is Column (Col (7)).

i

[P Fraperties - ar_1

.| General |P0inter Position | Other | Data || Axis || Text

Title:

| Expense Breakdown

Mame

| agr_1

Tag

[THidesnaked
Yisible

Border

| MoBorder (00

Text Color

| Il indow Text

BackColor

| [ IwWindow Background

GraphType

|l ol 73

Legend

|Battom (4)
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Getting Started

3

Select the Bar (2) graph type from the Graph Type drop-down list.

! —_
General |Pointer ” Position " Other ||E||E||ﬁ|

Title
| Expense Breakdown |

Mame

| agr_1 |
Tag

| |
[JHidesnaked

Wisible =
Border

| MoBarder () “ | 2|
Text Color

| I vindow Text w |
BackColar

| [ Iwindow Backaround w |

or

GraphType
T |
Legend

|Bnttom (4 w |

oy S

£

The graph looks like thisin the Preview view.

Expense Breakdown

Sarvions
Sakes & Martating

R&D

(Mone)

Fagz:

Adm infsLratian.

(Hang)
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Enhance the graph

4  Select the Pie (13) graph type from the Graph Type drop-down list.

InfoMaker redisplays the graph using the Pie style.

Bl sdminiziation
E rem

M rz0

[ sake & Wartaing

O sevviems

Expense Breakdown

171% 108k

21353%

WA

Pie seemsto be a good style for showing the data, so you do not change
the graph style again.

Thisiswhat the report with the graph looks like now.

Administration

158

a1
Q2
Q3
04

o
Q2
Q3
Q4

10/30/2006
Expenses for 2003 Page 1 of 3
Amount
in thousands
Expense Breakdown
PER 1054%
381 I
402 B carietaration
412 O e
T

467
1662

2 sates viarketing
Serioes

1155%

sz
101
93
129
145

468
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Lesson 6 Graph Tutorial

Print the graph (report)

Getting Started

Where you are

Open the report to contain the graph
Create the basic graph

Save the graph (report)

Enhance the graph

> Print the graph (report)

Click the Preview view to make sure that

itis current.

Select File>Print Report from the menu bar.

The Print dialog box displays.

Print rg
Printer: Y\PRT-CONCORDYpr-cong-04
o
O Current Page
St Hel
e

Enter page numbers andjor page ranges

Print ko File
separated by commas, For example, 2,5,8-10 0

Collate Copies

Print: | All Pages in Range i

Click OK to accept the defaults and print the report.

Your report goes to the printer or the print queue.

Select File>Close from the menu bar.

If you have not saved all your changes, a message box displaysto see if

you want to save changes.

Click Yes (if the message box displays).

The Report painter closes.
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Print the graph (report)
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LESSON 7 Environment Tutorial

You use the Library painter to manage forms, reports, queries, pipelines,
and the InfoMaker environment. In the Library painter you can:

e Open aform, report, query, or pipeline, and go automatically to the
appropriate painter

e Setthecurrent library
«  Copy, move, and delete forms, reports, queries, and pipelines

In thistutorial you learn how to do these tasks.

How long does this tutorial take?
About 30 minutes.
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Open forms, reports, and queries

Open forms, reports, and queries

Where you are
> Open forms, reports, and queries
Create a new library
Copy forms, reports, and queries
Create a new report from an existing one

First you learn about using the Library painter to open forms, reports, and
queries. When you open one of these, you automatically go to the appropriate
painter. (Thisis also true for pipelines, but you do not work with pipelinesin
thistutorial.)

If you have not installed the Form painter
A few of the stepsin thistutorial and the next onerefer to forms. Just skip those

steps. You can do the tutorials without the forms.

1 Click the Library button in the PowerBar.

i tutor_im.pbl - InfoMaker

File  Tools ‘Window  Help

rﬁ&@%%ﬂ%@ﬂ*

L0 Jp=n Predizw el Lib Lihlen  TaDalin DEPral  Daiabess Exil

The Library painter workspace displays.
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Lesson 7 Environment Tutorial

2  Select View>Most Recent Object from the menu bar.

i) tutor_im. pbl - InfoMaker
File  “iew  Library Entry Design Tools  Window  Help

b & B o= B = 8B 8
Hear Dp=n Sellib Liblit  TorDaled  Library DEPral  Daiabere Exit
laal =N

L] = S s @ <& CE &3

I Sekect All Edit Gapr M= Dekie Regen  Properiss  Masimoe Gl

ag ial) in c:iprogiml B3

= buter_im.pbl A Mamne Y Modification Date | Compilation Date A
attrib_birthdays d_dddw_fin_code B/5/2003 03:33:08  10/10{2006 01:12:28
& attrb_crossout_snd_visble d_dddw_products B(S5/2003 03:33:08  10/10{2006 01:12:28
attrib_escapement_rotation d_dddw_sales_orders 8/5/2003 03:33:08  10/10/2006 01:12:28
Ztt::{z:';;’:e'ght d_dddw_sales_reps 8/5/2003 03:33:08  10/10{2006 01:12:28
- d_dddw_states 8(5(2003 033308 10/10{2006 01:12:28

attrib_gravbar_emp_total_comp

attrib_italic emp_business_cards 8/5/2003 03:33:08  10/10/2006 01:12:28
attrib_rotate_emp_total_comp emp_count_by_sala... 8/5/2003 03:33:08  10/10/2006 01:12:28
attrib_skart_date emp_info_freefarm_. .. 8/5/2003 03:33:06  10/10/20006 01:12:28
attrib_sy emp_labels_pb_column 8/5/2003 03:33:06  10/10/20006 01:12:28
compasite_base emp_ist_grid 4/5/2003 03:33:08  10/10/2006 01:12:28
emp_name_tags 8/5/2003 03:35:08  10/10/2006 01:12:28

composite_product_sales
composite_products emp_nup_salary_be. .. 8/5/2003 03:33:06  10J10/2006 01:12:28

composite_sales_reps emp_telephone_attr. .. BIS/2003 03:33:08  10/10/2006 01:12:28
contact_n_up emp_total_compens... 8/5/2003 03:33:08  10/10/2006 01:12:28
contactgrid emplayes_grouped_... 8/5/2003 03:33:08  10/10/2006 01:12:28
contacts_by_jobrole expenses 10/30/2006 09:4.., 10302006 09:41:39
customers_with_nested_orders b ] penses g 10/30/2006 10:4,.,  10{30{2006 10:41:11
d_dddws_cust printer_sales 8/5(2003 03:33:08  10/10/2006 01:12:28
:—:::x—;“e::m“ tabular_orders 8/5/2003 03:33:08  10/10/2006 01:12:28
d_dddw_fin ode Egﬁpipejmpftablejxt... 3feTiz006 21:50,,, 3272006 21;50:07
d_dddwljrn_ducts fg'f'q_expenses 10/2702006 12:1..,  10/27/2006 12:12:27
| W 2] Bt
( =0 ... . . > Edwhat woor costome RSO N33 N8 ASPONR N3 3308

Ready

The painter lists the forms, queries, reports, and pipelinesin the current
library and selects the object you worked on most recently. When you
install InfoMaker, the current library is the InfoMaker sample library
(tutor_im.phl).

Thelist includes many samplesaswell astheform, query, and reportsyou
created earlier.

3 Scroll the list to the bottom until you see the form
contact_maintenance, which is the form you created earlier.
Double-click the form.
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Open forms, reports, and queries

164

m4

The form displays in the Form painter. Accessing your form by
double-clicking itsnamein the Library painter is the same as opening the
form in the Form painter.

1
Last Name: contact_last_name
First Mame: contact_first_name d Last Name First Name Job Role V.
Job Role: |contact_title

[Add a contact] [Delete a contact] [Save changes

Streek: ‘cunla:l_slrael |

City: ‘cunlact_clty |
State:
Zi
Phone: b
T — : 2

Click the Run button in the PainterBar.

Your form runs.

£ }aintain Contact Information

Id: -1
iAdd a contact] [Delete a contact] [Save changesl
Last Name: Hildebrand
IESLELTES 10 LastHame First Name Jab Rale ~
Job Role: 1 Hidebrand  Jane Marketing 12
Street: [1250  ashingtan 5t | 2 gimmon Larry gales 3
i 3 Crich Susan Product development 45
City: Emenyville | 4 Llamoet  Temy  Adhinitaion 2t
State: 5 Sullivan Doroty Customer support 54
. 6  Paul Rose Finance 7
Zip: |34608
e 7 Glassmann Beth Product development 44
Phone: |[510] 5551303 H Pouell Gene Training EE
Fa: [510) 555-4209 X2 E

Click the Close button in the PainterBar.

The running form closes.

Select File>Close from the menu bar.

You return to the Library painter. Now you look at some other forms.
Double-click the form customer_maintenance.

Click the Run button in the PainterBar.

InfoMaker



Lesson 7 Environment Tutorial

Getting Started

Thisform isfor maintaining customer information.

€} Customer Maintenance

~lo| ]

— Customer Infarmation

Customer D 101

Company Name IThe Power Graup

i

Address Iﬂﬂd Pioneer Avenue

572008 City, State, Zip [Rutherford  JNJ i7070-

~— Contact Infarmation

Contact  |Michaels Devlin
Phone  |(201) 555-8966

9 Click the Close button to return to the Form painter workspace.

“41 Select File>Close from the menu bar to return to the Library painter.

10 Double-click the report emp_total_compensation.

The report displays in the Report painter.

11 Scroll the report in the Preview view.

=] Report - emp_total compensation E@El
J N |

Total Compensation Report Value of health Ins. = £4,500

Value of day care = $5,200

Salary Plus Beneﬁts Value of life insurance = $(5.43 x saiany 1,000

Page 10of 1
3192007

an2 John

Shefield $&7,500

Total: $87,500

Department  Empl Empl Empl Salary Health Life
(] (] First Name Last Name Ins.  Ins.

100 445 Kim Lull $&7,500
a01 Dawid Scoft $96,300

Day Salary Plus
Care  Benefits

4] $83177
$106,823
$98,377

200 a02 Judy Snow $87,500 O %9775

Total: $92,774
Average: $a7.500 Average: 92775

12 Select File>Close from the menu bar.

The Report painter closes and the Library painter displays.

165



Create a new library

Create a new library

166

Where you are
Open forms, reports, and queries
> Create a new library
Copy forms, reports, and queries
Create a new report from an existing one

Now you create a new library on a shared drive so that you can copy some
itemsinto the library.

Shared drive
Theseinstructionsassumethat H:\ isashared drive, but you can use any shared

drive on your computer.

InfoMaker uses special librariesto hold forms, reports, queries, and pipelines.
These libraries have the file extension pbl. When you save (or copy or move)
aform, report, query, or pipeling, it goesinto a pbl file (pronounced pibble).

1 Select File>New from the menu bar.

The New dialog box displays.

2  Select the Library tab and click OK.
The Library wizard displays.

3 Type h:\mylib.pbl and click Finish.

InfoMaker creates the new library on the H drive. Thislibrary is now the
current library; its name displaysin InfoMaker’s title bar. The previous
current library still displaysin the Library painter.

InfoMaker



Lesson 7 Environment Tutorial

Copy forms, reports, and queries

Where you are
Open forms, reports, and queries
Create a new library
> Copy forms, reports, and queries
Create a new report from an existing one

Now you copy aform, aquery, and two reportsinto the library on the shared
drive. Then you can make them available to another InfoM aker userswho can
use them as is or modify them as needed.

Remember that the other users must also be able to access the database. All
InfoMaker users have SQL Anywhere and the contact table. That means other
InfoMaker users can run the form, query, and reports you have created in this
tutorial.

1 Drag tutor_im.pbl from the Tree view in the left pane to the List view
in the right pane.

2 IntheListview of the Library painter, click contactgrid (scroll the listin
the Library painter as necessary).
Press Ctrl and click contacts_by_jobrole.
Press Ctrl and click d_dddw_states.
Press Ctrl and click q_expenses.
Press Ctrl and click contact_maintenance.

The five objects you selected are highlighted. You can copy, move, or
delete them. You are going to copy them to the shared drive.

Getting Started 167



Copy forms, reports, and queries

Tip
You can sort the view by modification date to make it easier to locate
objects you have just created or changed.

[®] tutor_im.pbl in :\Program Fi
| Modificatio...
02/07/200...  This report shows my contacts groupad by job rale
02/07/200...  Tutorial: Used for Tutarial. Added ta a form in the Formn painter. —
""" 02/07/200...  This form updates my contact table.
02/07/200...  This query retrieves financial data from the fin_data and fin_code tables. Tk
| | $ 02/07/200...  Report for DropDownDataw indow: Grid: State [D, State Name, Country
d_dddw_zales_repz 02/07/200...  Report for DropDownD atawindow: Grd: Employee 1D, name
d dddw_sales_orders  02/07/200.. FReport for DropDownD atawindow: Grid: Sales Order 1D, Customer 1D, Ord
lad dddw_products 02/07/200...  Report for DropDownDatawindow: Product 1D, Product Mame, Product De
i d_dddw_fin_code 02/07/200...  Report for DropDownD atawindow: Financial codes -

1 | 4

selInfoMaker 11.04Tutorial
Carmnment -

Why you include the report named d_dddw_states
The contact_maintenance form uses a DropDownDataWindow edit style

for the state column. That edit style usesthe report named d_dddw_states,
which must be present in the library when you run the form.

If you create anew library for objectsyou create using the EAS Demo DB,
you need to copy the eight reports that begin with d_dddw from the
tutor_im.pbl to the new library. These reports go with the
DropDownDataWindow edit stylesthat the tablesin the EAS Demo DB
use.

Thereis away to make the reports centrally available. See the InfoMaker
User’s Guide.

3 Click the Copy button in the PainterBar.

Copy The Select Library dialog box displays.

4  Change drives to the shared drive.
Select mylib.pbl.
Click Open.

InfoMaker copiesthe selected objectsto the shared drive. It takesaminute
or s0. You can see messages about the copying at the bottom of your
screen.
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Getting Started

5

Navigate to the shared drive.

The Library painter lists the contents of mylib.pbl, the current library.

rrr;.-'lil:-.|:-|:-| in H:y
Marme
contackgrid
contacks_by_jobrole
d_dddw_states
Fod q_expenses
: contack_maintenance

-~

Modification Dake

&/5/2003 03:33:08
312002007 11:49,.,
&/5/2003 03:33:08
312002007 11:59.,.,
32002007 12:42..,

Comnpilation Date

319f2007 23:33:50
3/20/2007 11:49:59
319f2007 23:33:50
3/20/2007 11:59:45
IZ0/2007 12:42:57
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Create a new report from an existing one

Create a new report from an existing one

170

Where you are
Open forms, reports, and queries
Create a new library
Copy forms, reports, and queries
> Create a new report from an existing one

Now you create a new report from one of the reports on the shared drive. You
then make a slight modification to the report.

The modification adds powerful options to the report that you can see when
you run the report.

1 Onthe Hdrive, double-click the contactgrid report.

I— = mylib. pblin H:Y,
Mame Modification Date Compilation Date
5l cantactarid Bi5iZ003 033308 3/19/2007 23:33:50
conkacks_by _jobrole 3/20{2007 11:49,.. 3/20f2007 11:4%:59
d_dddw_states Bi5iZ003 03:33:08  3/19/2007 23:33:50
Fd g_expenses 32002007 11:59,.,  3/20/2007 11;5%:45
: contact_maintenance /2002007 12:42... 3/20§2007 13:43:54
BES >

You go to the Report painter with the contactgrid report open.

B contactgrid - Report

Id Last Na‘“e' Fim Name' .. JDIJ Rﬂle ........ street ....... [:i-tv .. state . Iip ..... FA
Header {

id - last mame: o frst name cBtle o celreet ety oo cstate i o c phone
Detail 1

Summary {

Footer {
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2

Select File>Save As from the menu bar.

The Save Report dialog box displays. You are going to change the name
of the report so that you can keep the old one and create a new one with
some changes.

Save Report [z|
Reports:
Contackgrid |
contackgrid
contacts_by_jobrole
d_dddw_states
- - -Help
Comments:
Tutorial: Used for Tutarial, Added to a form in the Farm
painter.
Library:

H:irylib. pbl

Type the name contactgrid_with_prompting and click OK.

The report name changes. You are now working on areport called
contactgrid_with_prompting.

B contactgrid_with_prompting - Report

Id Last Na‘“e' Fim Name' .. JDIJ Rﬂle ........ street ....... [:i-tv .. state . Iip ..... FA
Header {

id - last mame: o frst name cBtle o celreet ety oo cstate i o c phone
Detail 1

Summary {

Footer {
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5

6

If the View>Column Specifications view is not already in the lower right
corner of the Report painter, select View > Column Specifications
from the menu bar.

The Column Specifications view displays, listing al the columnsin the
report. You can choose one, many, or all columnsfor prompting. The
columns you choose here let you control what rows are selected when you
run the report.

For example, if you choose the city column here, you can specify a city
when you run the report. Then only rows that include that city are
retrieved.

jon - cont. yith_prompting

_Name Type Prompt |DE Mame

1 |id number [T |conkact.id

2 |last_name |char(15) [~ |contact.last_name

3 [first_name |char{15) | [~ |contactfirst_name

4 [title char(Z) [T |conkact.title

5 |street char(30) [T |contact,skreet

6 |city char(z0) [~ |conkact.city

7 |state char(Z) [T |conkact.state

g [zip char(5) [T |contact.zip

9 |phone char{10) [~ |contact.phone

10 [Fax char{10) [~ |conkact.fax

A % Column Specification - contactgrid_withjrompting‘[m;l

Select all the check boxes.

You are choosing all columns so that you can enter criteriafor any column
you want when you run the report.

B8 Column Specification - contactarid_with_prompting
_Name Type Prompt |DE Mame

1 |id number ¥ |conkact.id

2 |last_name |char(15) ¥ |contact.last_name
3 (first_name |[char{15) ¥ |conkact. first_name
4 [title char(Z) ¥ |conkact. title

5 |street char(30) ¥ |contact,skreet

6 |city char(z0) ¥ |conkact.city

7 |state char(Z) ¥ |contact.state

g [zip char(5) ¥ |contact.zip

9 |phone char{10) ¥ |contact,phone

10 [Fax char{10) [+ |conkact.fax

A % Column Specification - contactgrid_withjrompting‘[m;l

Select Rows>Retrieve from the menu bar.
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10

The Specify Retrieval Criteriadialog box displays. Sinceyou said that you
wanted to be prompted for al the columns, the dialog box includes al the
columns.

Specify Retrieval Criteria le

Column: [id last_name first_name Litle A O
Criteria:
b
£ | >

Click in the first cell in the title column.
Use the horizontal scroll bar to move the title column into full view.

A box with an arrow displaysto show thereis a drop-down list for that
column.

Specify Retrieval Criteria le

Column: | last_name first_name title & stre: A [ O ]
Criteria: | v
b
< ¥

Click the arrow to open the list.

Select Customer support.

This puts Customer support in thetitle column. This means that the report
is limited to contacts in Customer support.

Specify Retrieval Criteria le

Column: | last_name first_name title & stre: A [ O ]
Criteria: ,':ustomer SUpRC % E
or: Administration

Customer support
Documentation -
Finance
Human resources
Marketing

(Cther

Product developmen

|

Click OK.
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The report displays. It includes only contacts in Customer support.

|_with_prompting
Id  Last Name First Name Job Role Street City State  Zip Phone Fax
3 Sullivan Dorathy Customer support £4 Minuteman Dr.  Lincoln MA 074z [BOLISES-2E25 (B0EIEES-4931
1z Lyman Thomas Customer support 64 Story Rd. Emeryvile A adenE  (510555-53T8 {51 05585-2372
16 Lencki John Cushomer support 20% Brook Road  Burlingtan MA 01803 [B17)565-634% B17)555-4619
14 Hayne Wlliarm Customer support %% Cornfield Ave.  Acton MA 720 (BOKBES-TTE0 (BO8IEEE-4420
21 Caobh Paul Customer support 34 Greenvile 5t Aflanta G4 30338 (A04)555-2239 (4045558111
22 Goggin Kewin Customer support £ East Main 5t Houiston T TTOTS  (F13)566-3340 (F13)666-5211
2% Cohen Paul Customer support 10% Park Street Eurlington hA 01803 [B17)555-8883 B17)555-4499
32 Reewes Soott Customer support 29 Linden St Iselin MNJ 08830 (B03)5665-0838 (B03)665-6556
44 Short Russell Customer support 12 Newton St Needham hA 02192 175550893 B17555-1170 2
< >

By setting up a report to prompt for criteria, you give yourself alot of
power and flexibility when you run the report. You learn more about this
when you create an application in the next tutorial.

11 Select File>Close from the menu bar.
When prompted to save changes, click Yes.

The Report painter closes and you return to the Library painter.

Now your new report is listed. It isagood ideato add comments to
document the report. You can do that now.

12 Position the pointer on contactgrid_with_prompting.
Press the right mouse button to display the pop-up menu.
Select Properties.

The Properties dialog box displays.
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13 Type This report lets me enter selection criteria when | run the report.

14

15

Properties

General |

X

Object Mame:
Library:

Last Modified:
Last Compiled:
Size in Bytes:

SCC Yersion:

Comments:

contactgrid_with_prompting
H:imylib.pbl

3f20/2007 13:06:32
3f20/2007 13:06:32

12212

[ ]

This report lets me enter selection criteria when I run the report,

o

H Cancel ][ Apply

] [ Help

The newly added comment displays.

Click OK.

<

.pbl {H:Y i HeY

ontackgrid_with_prompting
contacts_by_jobrole
d_dddw_states
ol g_expenses
,: contact_maintenance

Modification Date
/52003 03:35:08
F20f2007 13:16..,
3/20{2007 11:49,,,
/52003 03:35:08
3/20{2007 11:59..,
320f2007 12:42..,

Compilation Date
3192007 23:33:50
3202007 13:16:23
3{20/2007 11:42:59
3192007 23:33:50
3{20/2007 11:59:45
3f20/2007 12:42:57

Now you have become familiar with many of the tasks you can doin the
Library painter.

Continue directly to the next tutorial, the Application tutorial.

(Leave the Library painter open.)
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An InfoMaker application is a collection of related reports, forms, and
pipelines. For example, the Contacts application that you create in this
tutorial has:

* A formto maintain datain the contact table
e Avreporttolist all contacts

e Arreport to list only contacts that meet your criteria

Help

B & B

By Job Data Exit

@ Contacts

File Display Rows ‘Window Help

0 w @ B & B

Forms  Reports  AdHoc By Job Data Exit

<@ ] < 4 4] = g

: Retrieve  First Prior Mexk Last Prink Close

P Report - contactgrid, with,_prompting

CEX

Id  Last Name First Name Job Role Street City State  Zip
3 Critch Susan Product cevelopment 45 Center St Darvvers It 0923
T Glassmann Beth Product cevelopment 44 Oak St Lexington It 0217
19 Chin Draicd Product cevelopment 16 Wiawerly R, Burlincton A 003
26 hulley Joan Product development  10% Westarm Ter.  Burlington hd & 01802
30 DeMarco Michagl Product development 23 Clare Ave. Becfford hd & 01730
35 Burril Dana Product development 234 Beacon St Meedham hd& 02142
40 Jordan Susan Product development 95 Gorcdan 5t Burlincton [ 0180
42 Haddad Paul Product development  ££9 Pleasant 5t Schaumburg 1L BO1TE
46 Crossland Ellen Product development 27 Rush Rd Burlinction hA 01802
55 Kosko Kirn Product development 334 Pleasant 5t Houston T TOTS

How long does this tutorial take?
About 30 minutes.
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Create the application

Where you are
> Create the application
Create a shortcut to the application
Start the application
Use the Data button
Use the By Job button
Use the Ad Hoc button

Now you will create an application, complete with toolbars and menus, and
you will create a shortcut for the application. Then you can run it from your
desktop, just the way you run InfoMaker or any other application.

The application you create consists of an executable file and an initialization
file. Theinitialization file provides information about the database to the
executablefile.

For example, InfoMaker itself is an application that has an executable file
called im110.exe. Thisisthe file you start running when you start InfoM aker.
InfoMaker also has an initialization file called im.ini.

Terms
The executablefileis also called an exe file (pronounced exxy). The

initialization fileis also called an ini file (pronounced inny).
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1

If you are continuing from Lesson 7, go to step 2.

Otherwise, gotothe Library painter inthe H:\ drivewith thelibrary named
mylib.pbl set to be the current library (File>Select Library).

The Library painter shows the contents of mylib.pbl.

=
[ mylib.pbl (H: ) in H:Y

contacts_by_jobrole
d_dddw_states

ol g_expenses

: contact_maintenance

Modification Date

/52003 03:35:08
F20f2007 13:16..,
3/20{2007 11:49,,,
/52003 03:35:08
3/20{2007 11:59..,
320f2007 12:42..,

Compilation Date

3192007 23:33:50
3202007 13:16:23
3{20/2007 11:42:59
3192007 23:33:50
3{20/2007 11:59:45
3f20/2007 12:42:57

< *

Select Design>Create Executable from the menu bar.

The Create Executable dialog box displays. In thisdialog box you specify
atitle for the application window, afile name for the executablefile, the
folder for storing the executable file, and an icon for the application.

Create Executable

Executable Title:

Executable File Mame:

| ‘ Browse. ..
Produck Yersion:

[1,0,0,1 |[ 1o0,1 |

File Yersion:

[1,0,0,1 || 1,0,0,1 |

Executable Icon:

| ‘ Browse...

New Visual Style Controls
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Executable Title:

Type Contacts in the Executable Title box.

Type contacts.exe in the Executable File Name box.

This assigns a name to your executable file.

Create Executable

| Contacts

Executable File Mame:

| Browse, .,

| contacks.exe

Product Yersion:

[1,0,01 |[1,0,01 |
File Yersion:

[ |[ 1001 |

Executable Icon:

| [ Browse, .,

Mew Yisual Style Contrals

Later, when you run your application, the title bar displays the word
Contacts.

Click the Browse button next to the Executable Icon box to select an
icon for your application.

Theicon will display in the Windows shortcut. You create a shortcut
shortly.
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6

7

Change to the Tutorial folder (the icon is there).
Click emp.ico.
Click Open to accept the emp.ico file as the icon for your application.

You return to the Create Executable dialog box. Theicon and itsfull name
display.

Create Executable

Executable Title:

| Contacts ‘

Executable File Mame:

| conkacks.exe ‘ Erowse...
Produck Yersion:

[1,0,0,1 |[ 1o0,1 |

File Yersion:

[1,0,0,1 || 1,0,0,1 |

Executable Icon:

|C:'I,Program FilesSyvbaselInfoMaker 11.04Tutariallemp ico ‘ | Browse.., |

o New Visual Style Controls
¥ N

[ Mext = ] [ Cancel ] [ Help

Type Version 1.0.1 in the Product Version and File Version boxes on
the right.
Leave 1,0,0,1 in the boxes on the left.

Thetext you typein the boxes on theright displayson the Version tab page
of the Properties dialog box when you look at the properties of the
executable file in Windows Explorer. The four numbers separated by
commas on the left can be used by installation programs.

Create Executable

Executable Title:

| Contacts ‘

Executable File Mame:

| conkacks.exe ‘ Erowse...
Produck Yersion:

[1,0,0,1 |[ version 1.0.1 |

File Yersion:

[1,0,0,1 || version 1.0.1 |

Executable Icon:
| C:\Program Files\Sybase\InfoMaker 11.04Tutariallemp ico ‘ Browse...

o New Visual Style Controls
¥ N

[ Mext = ] [ Cancel ] [ Help
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8

Click Next to select items for the application.

The Select Itemsdial og box displays. Now you select the form and reports

for your application.

Click the check box for contactgrid_with_prompting.

Click the check box for contacts_by_jobrole.

Click the check box for contact_maintenance.

Select ltems

Check itemi(s) ko include in executable:

Mame

7 &l contactgrid

[ {&] contactarid_with_prompting
W & contacts_by _jobrale

[T &l d_dddw_states

-
¥ = contact_maintenance

¢

Comment
Tukorial: Used For Tukarial, Added to a
This report lets me enter selection crite

Report Far DropDownDatakindow: Gri

[ select al [ peselect al

< Back ][ Mext > ][ Cancel ] [ Help
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10 Click Next to define the toolbar items.

The Executable Items dialog box displays. It lists the form and reports to
beincluded in your application. Theinformation you enter in the boxesto
theright of thelist of itemsisfor the currently selected item.

Traditional and Comtemporary menu styles ) )
In this tutorial, you use the Contemporary menu style. For information

about menu styles, see the InfoMaker User’s Guide.

Executable ltems

To have a button For a form, report, or pipeling appear in the toobar of the
executable, select the form, repart, or pipeling in the lisk bax on the left and set
the toolbar properties using the controls on the right.

Set Toolbar Properties for: [ Hide Repart:

Pickure:

contacks_by_jobrole

contack_mainkenance {Mone) ~

Texk:

MicroHelp:
r Style

I < Back ][ Finish ]I Cancel ] [ Help ]

Finish defining all information before you click Finish
Do not click the Finish button or press enter until you have finished

defining information for all the items you want to include in the
application’s toolbar. Once you click Finish or press enter, InfoMaker
generates the executablefile.

If you create the executable file before you mean to, select
Design>Create Executable again. InfoMaker remembers what you have
specified. You can continue whereyou | eft off and re-create the executable
file.
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11 Make sure contactgrid_with_prompting is selected.
In the Picture box, display the list and select CheckStatus5!.
Click the Text box and type Ad Hoc.
Press Tab to go to the MicroHelp box.
Type List contacts that meet the specified criteria.
Select the Contemporary radio button.

The Picture box specifies the picture for the button, which will be in the
application’s toolbar.

The Text box provides text for the button and for the menu item that will
run contact_maintenance in your application.

The MicroHelp box provides MicroHelp for the button and menu item.

Executable ltems

Ta have a button For a Farm, repart, or pipeline appear in the toolbar of the
executable, select the Form, report, or pipeline in the list box on the left and set
the toolbar properties using the controls on the right.
Set Toolbar Properties For: [Hide Report
contackgrid with_prampking Picture:
contacks_by_jobrole N
contact_maintenance Checkstatuss! v g
Text:
Ad Hoo
MicroHelp:
Menu and Toolbar Skyle that meet the specified criteria
@ Contemporary!
O Traditional
[ < Back ][ Finish ] [ Cancel ] [ Help

12 Click contacts_by_jobrole.
In the Picture box, display the list and select Cascade!.
Click the Text box and type By Job.
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Press Tab to go to the MicroHelp box.
Type List all contacts grouped by job role.
Select the Contemporary radio button.

Executable ltems

To have a button For a form, report, or pipeling appear in the toobar of the
executable, select the form, repart, or pipeling in the lisk bax on the left and set
the toolbar properties using the controls on the right.

Set Toolbar Properties for: [ Hide Repart:
Picture:
Texk:

By Job

MicroHelp:

contackarid_with_prormpting

(il

Menu and Toolbar Style
(%) Contempaotary
() Traditional

‘ List all contacts grouped by job ‘

< Back. ][ Finish ] [ Cancel ] [ Help

13 Click contact_maintenance.
In the Picture box, select the entry AddWatch5!
Click the Text box and type Data.
Press Tab to move to the MicroHelp box.
Type Maintain contact information in the database.
Select the Contemporary radio button.

Executable Items

To have a buttan for a Form, repart, or pipeline appear in the toalbar of the
executable, select the form, report, or pipeline in the list box on the left and set
the toolbar properties using the cantrols on the right.

Set Toolbar Properties for:

contackgrid_with_prompting Pickure:

contacts_by_jobrole

contack_maintenance Addiatchg! | g5
Texk:
MicroHelp:

Menu and Toalbar Style ‘ sct information in the databasd ‘

@ Contemparary

O Traditional

I < Back ][ Finish ]I Cancel ] [ Help ]

Now you have finished providing information for the form and the two
reports that are in your application.
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14

15

16

17

Click Finish.

InfoM aker createsthe application, which consists of an executablefileand
aninitialization file. These files are in the Tutorial folder.

Now that InfoMaker hasfinished creating the application, you return to the
Library painter.

Before leaving the Library painter, you select tutor_im.pbl as the current
library. Thisis where the samples and the tutorial work are kept.

Select File>Select Library from the menu bar.

Select tutor_im.pbl from the Recent page in the Select File dialog box
and click OK.

The current library istutor_im.pbl again.

Select File>Exit from the menu bar.

InfoM aker closes.
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Create a shortcut to the application

Getting Started

Where you are
Create the application
> Create a shortcut to the application
Start the application
Use the Data button
Use the By Job button
Use the Ad Hoc button

Now you make the application easy to access. To do this you create a shortcut
on the Windows desktop.

1 Move the pointer to an empty area of the desktop and press the right
mouse button.

The pop-up menu for the desktop displays.

2 Select New and then Shortcut.
The Create Shortcut dialog box displays.

3 To locate contacts.exe, click the Browse button.
In the Browse dialog box, change folders to the Tutorial folder.
Select contacts.exe and click OK.

You return to the Create Shortcut dialog box with the full path of the
contacts.exe file in place.

Create Shortcut El

This wizard helps you ko create shortcuts to lacal or
network programs, files, folders, computers, or Inkernet
addresses,

Type the location of the item:

\InfaMaker 11,04Tukorialicontacts, exe|

Click Mext bo continue.
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Click Next.
The Select A Title For The Program dialog box displays.

In the text box, type Contacts over the name offered as a default
(contacts.exe).

This provides a better title to display under the icon on the desktop.

Click Finish.

Windows creates the shortcut to your application and displaysit on the
desktop. Now you must modify a property of the shortcut so that you can
run your application.

E]

L
Contacts

Move the pointer to the icon and press the right mouse button to
display the pop-up menu.
Select Properties to display the shortcut’s properties dialog box.

Select the Shortcut tab and type the location (path) of the Sybase
system files in the Start in box.

Contacts Properties E|FZ|

General | Shortcut | Compatibility | S ecurity

= Contacts
-

Target type: Application
Target location: Tutarial

Target: ' Subazehlnfobd aker 11.04Tutorialhcontacts. exe'

Start in: =%Program FilestSybasetShared PowerBuilder'|
Shortcut key: MNone
Fiur: Mormal windove ~

Comment:

Find T arget... ] [ Change lcon... ] [ Advanced...

[ Ok, ] [ Cancel ] [ Apply
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Getting Started

About the location of Sybase system files )
When you install InfoMaker, the installation process automatically puts

the DLLsin asystem folder. If you have changed the names of the folders
used for installing, you need to use your names in this step.

The folder path is C:\Program Files\Sybase\Shared\Power Builder.

You must specify the name of the drive. If you use backs ashes to specify
arelative path name, the application will be unable to locate the system
files.

Click OK.

Windows modifies the shortcut to your application. This modification
enables Windows to find some InfoMaker modules (DLLS) required for
running your application.
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Start the application

190

Where you are

Create the application

Create a shortcut to the application
> Start the application

Use the Data button

Use the By Job button

Use the Ad Hoc button

In this exercise you start the application you created and take alook at its
toolbar, MicroHelp, and menus.

1 Double-click the Contacts shortcut on your desktop.

Your application runs. Do not be surprised if it takes aminute to get
everything running. The database itself has to start up so that you can
access data.

The main window of the Contacts application displays.

¥ Contacts
File  Objects ‘Window  Help

Bl Mleiflle et lis

Forms Reports  AdHoc By Job Data Exit

IReady
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Notice the toolbar.

The Forms, Reports, and Exit buttons are automatically included. The Ad
Hoc, By Job, and Databuttons are in the toolbar because you defined them
when you created the application.

0 Ww @ B & [k

Forms Reports AdHoc By Job Daka Exit

Move the pointer to one of the buttons.

Notice the MicroHelp at the bottom of the screen.

Click the Objects menu item.

Notice that Ad Hoc, By Job, and Data are included in the Objects menu.
Your application has atoolbar and amenu. You can run forms and reports
from either place.

% Contacts
Ohjects

Window  Help
| Ad Hoc §

By Job By

l [ata .
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Use the Data button

Where you are
Create the application
Create a shortcut to the application
Start the application
> Use the Data button
Use the By Job button
Use the Ad Hoc button

Now you use the Data button to run your form. You add a new contact and
change information about an existing one.

1 Click the Data button.

Your form displays. Noticethat title barsidentify your application and the
particular part you are using. You also have the usual form toolbar that lets
you view, add, and update information in the database.

@ Contacts
File Edit Rows ‘Window Help

Bl e @Bl

Forms  Reports  AdHoc By Job Data Exit.
- & ] (L] « B ] & WP Ik

: Criteria Retrieve  First Prior Mext Last Delete  Insert Update Close

& Maintain Contact Information

1
- [Add El contact] [De\ebe a contact] lSave changes]
Last Mame: Hildebrand
UUEGL LTS |0 LastHame First Wame  Job Role ~
Job Role: 1 Hidehrand  Jane htarketing 1288
Street: [1280 Washington St | Sirthon Larry Sales 34
3 Critch Susan Product development 46
City: Emenywile | 4 Lambert Terry Adrministrafion 20
State: 5 Sullivan Dorothy Customer support £4
. 3 Faull Rose Finance 7%
Zip: (4603
" P Glssman  Bsh Prouct cevelopment 44
Phone: [510) 555-1309 i3 Pl Gene Training 55w
Fax: [[510) 5554209 53 I )

2 Click the Add a contact button in the form.

A blank form displays.
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+

Ci

iteria

3

Enter information for a new contact.
Use 62 for the Id entry and make up the rest.

Besuretofill inall blanks. (The only columnsyou can skip are phone and
fax; the other columns are defined asrequired in the database.) Usethe Tab
key to move from box to box.

% Contacts,
File Edit Rows Window  Help

Bl R sbaath

Forms  Reports  AdHoc By Job Data Exit

P & B4 4 Bl Bl
° Critetia Retrieve  First Prior et Last Delete  Insert  Update  Close
€ Waintain Contact Information [’L\ @|g|
Id:
E [Add a contactl [Delehe El contact] [Save changesl
Last Name:
AL id Lt Name First Name  Job Role ~
Job Role: 1 Hidebrand ~ Jane Marketing 12
Street: [Leas Ciiff Terrace J Sirnman Larry Sales =
. Critch Susan Procuct development 45
City: Folkestone | 4 Lambert Terry Addministration 0
State: 5 Sulivan Dorotty  Customer support 54
- [ Paul Rose Finance 7z
Zip: 01783
e 7 Glassmann Beth Product development 44
Phone: [751) 5551234 H Powell Geng Trairing 55w
Fan: [751) 565123 hd >

Ready

Click the Save changes button in the form.
Your new contact goes into the database. You will see it shortly.

Next you want to display information on the contact with 1d 37 so that you
can make a correction.

About updating the database and canceling changes
You can click the Update button to update the database immediately; or

you can wait until you close the form, and InfoMaker prompts you then to
seeif you want to update the database.

The Cancel Changes menu item on the Rows menu cancels any changes
you have made since the last time you clicked Update.

Click the Criteria button to display a blank form for setting retrieval
criteria.
Type 37 in the Id box.

This sets the retrieval criteria.
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Apply

194

Click the Apply button.

Thisappliestheretrieval criteria. InfoMaker retrieves the row with the Id
37.

§ Contacts
File Edit Rows ‘Window Help

Bl Ml Rl

Forms  Reports AdHoc By Job Data Exit
b & e i 4 L L o = 4 I

¢ Criteria Retrieve  First Prior Mext Last Delete  Insert  Update  Close

& Jaintain Contact Information El@lf@

[Add El contact] [De\ebe a contact] lSave changes]

Last Name:

ESLELTS Id  LastName First Name  Job Role S
Job Role: 1 Hidebrand  Jane Marketing 120
Street: [134 Cheny Hil 5t 2 Simmon Ly Sales 34

i - Critch Sugan Prouct development 45

City: [Alington | 4 Lambert Tery  Administraion 20

State: 5 Sulivan Dorothy Customer suppart 54

- 3 Paull Rose Finance e
Zip: 02174

L 7 Glassmann Beth Product development 44

Phone: [B17] 5552343 H Pauell Gene Training 56 %
Fax: [517) 5551765 £ I >

Retrieve all rows with new criteria

Change the Street to 134 Cherry St.
Click the Save changes button in the form.

Your changes are added immediately to the database.

Click the Next button.

A message box displays because you have set criteriathat allow only row
37to beretrieved. You need to removethe criteriaor specify other criteria.

Maintain Contact Information rz|

! E This is the last row for this table!
L]
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9 Click OK to close the message box.
Click the Criteria button.

bk

Ceriteria

10 Select 37 and press the delete key to delete 37 from the Id box.
e, Click the Apply button.
a'p'puy Now you have no criteria, so InfoMaker retrieves all rows.

11 Select File>Close from the menu bar.

Your form closes.
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Use the By Job button

Where you are
Create the application
Create a shortcut to the application
Start the application
Use the Data button
> Use the By Job button
Use the Ad Hoc button

Now you run areport of all contacts grouped by job role.

1 Click the By Job button.
The report that lists all contacts grouped by job role displays.

@ Contacts
File Display Rows Window Help

b w @ B « [

Forms Reports AdHoc By Job Data Exit

@ M 4 [N |

Retriewe  First Prior Mexk Last Print Close

B Heport - contacts_by_jobrole

3/20j2007 My Contacts

Last Name First Name Phone Fax

Adiministraiion
Brier Michael [E17) B55-2293 [E17] 565-3337
Colins MaryBeth [617] 5551199 [£17) 556-9586
Lambert Temy [617) 5552246 [617] 555-3692
Rameo John [310) 555-4533 [310] 5551233

Eersiomer sepport
Cobb Paul [404) 555-2239 [404] 5558111
Cohen Faul [E17) B55-BEE3 [E17] 565-4439
Gioggin Kevin [713] 5553340 [713) 556-9211 &

< | 3 ..

Ready

2 Scroll the report to see your new contact.
When you have finished, select File>Close from the menu bar.

Once again you return to the main application window.
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Use the Ad Hoc button

Where you are
Create the application
Create a shortcut to the application
Start the application
Use the Data button
Use the By Job button
> Use the Ad Hoc button

Now you use the Ad Hoc button to run several different reports based on the
criteriayou specify.

1 Click the Ad Hoc button.

The Specify Retrieval Criteria dialog box displays. This dialog box
displays because you selected Prompt For Criteriafor this report.
Whenever you run this report, you are first prompted for criteria.

Specify Retrieval Criteria g|
Column: [id last_name first_name title O
Criteria: ||
v
< ¥
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2

Click OK.

Because you did not specify any criteria, the report retrieves all your
contacts.

@ Contacts
File Display Rows

B.a

(L]
First

Window

orms Reporks  Ad Hoo

<

Prior

Help

B &

By Job Data Exit

| S -1

Next Last Print. Close

B Report - contactgrid_with_prompting

Id  Last Name First Name

1 Hidehrand
2 Simmon

3 Critth

4 Lambert

5 Sullan

13 Faul

7 Glassmann
8 FPouiell

4 Fish

10 Clarke

11 Kelley

12 Lyman

13 Dawidson
14 Petengil
15 Moore

18 Lencki

17 Kaplan

1% Hayne
EPS

Jang
Larry
Susan
Terry
Dorothy
Rose:
Beth
Gene
Jeffresy
Maly
illiar
Thomas
Joann
Mark
Dairy
John
Burt
illiar

Pewind

Job Role Street City
Marketng 1280 Washington 5t Emeryville
Sales 34 Granille 5t Houston
Product dewelopmert 45 Genter 5t Darters
Addinistration 204 Page 5t Canton
Gustormer support 54 Minuterman Dr. Lincoln
Finance: 7% Bay 5t Marhiehead
Product dewelopmert 44 Oak St Lexington
Traininey 552 ifest Main St Lexincton
Markednig 6% Red Acre Rl Lesington
Sales 55 Pine Grove Rd. Lexington
Documentaton 16 Rainbow Rd.  Burlington
Customer support &4 Slory Rd Emeryville
harketing 64 Shory Ref Emmeryvile
Sales 26 Briarwood Ter.  Emeryville
Sales One Park Drive  Aflarta
Customer support 208 Brook Road  Burlington
Sales 49 Keaton Lane  Arlington
Custormer support 38 Gorrfiel Ave.  Acton
Py o e bt A8 Wb scalis Pt Pl

State

M

T
)
MA
1)
MA
1)
)
MA
)
MA
Ch
CA
CA
GA
MA
1)
)

™

fip
4608
TrOTS
0923
4603
074z
01945
021728
02173
02173
02173
01803
H460%
94608
4608
30333
01803
02174
0720

A aan

Phone
(510)555-1308
(T13)855-3560
(50£)555-4829
(B17)566-2246
(B08)555-3905
(B17)566-6392
(17)855-0273
(B17)555-3528
(617)505-352%
(617)556-4305
(B17)566-3474
(510)855-537%
(51015557363
(510)505-3533
(4045554834
(B17)566-5348
[17)855-3887
(50£)555-7780

A EEr AnTe

EEX

Fax

Select Rows>Retrieve from the menu bar.

The Specify Retrieval Criteria dialog box displays again. Thistime you
enter criteria

Go to the title column.
Select Documentation from the drop-down list.

Click OK.

Specify Ret

val Criteria

Criteria:
Qs

Colurnn: first_name

title & |street

Documentation e

Administration

(Cuskomer suppork

Finance

Human resources
Marketing

(Cther

Product developmen
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5

You have specified that the report isto list only contacts who have jobsin
documentation.

R Report - contactgrid_with_prompting

Id  Last Hame First Name Job Role Street City State  7ip Phone Fax
11 Keley iflliam Documentafion 16 Rainbow Rd Burlingon (L5 030 (B17)6566-2474 {B17)566-2694
29 Sinibaldi Jozeph Documertation 1112 Center St Arlineon A 02174 (617)555-6639 B1TI565-4231
47 Berfrand Coleman  Documentation 74 Dunster PI Schaumburg 1L BTE  (FOE)BEE-244E (TO4)5E6-4632
62 Brough Artur Documertation Leas CIiff Terrace  Folkestone  MA M7ER (FH1)5550-1234 (F31)565-1235

Click the Retrieve button.

The Specify Retrieval Criteria dialog box displays again. Notice that the
criterion in the tittle column is still in effect. To specify different criteria,
you are now going to delete Documentation. Then you enter new criteria.

Select the Documentation entry in the title column.
Press delete.

This deletes criteriafrom thetitle column. Now you are going to enter new
criteria.

Click in the first box underneath last_name.
Type like "c%".

Click OK.
Specify Retrieval Criteria g|
Column: [id last_name first_name title O
Criteria; like: "]
v
< ¥

Thisentry (like "c%") helps you find a name you cannot remember. All
you can remember isthat it starts with C.

Thelike operator specifiesthat only rowsthat match what follows should
be retrieved. The quotes are required. The ¢ meansthat the first character
must be C. The % sign means any characters can follow the C.
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Thisisthe report.
B Report - contactgrid with, prompting
Id Last Hame First Name Job Role Street City State  Zip Phone Fax

2 Critch Busan Product dewelopment 45 Center St Danwers A 01923 (BOS)EES-4329 (BOEIEEE-3026
10 Clarke Malky Sales &5 Pine Grove Rd. Lexincton MA 02172 (B17)e66-4325 (B17)566-T632
1% Chin Draviict Procuct dewelopment 16 Wiaverly Rd. EBurlington WA 01903 (B17)555-33T% (B171555-4453
21 Cobb Paul Custormer support 4 Greenville St Mlanta GA 20339 (404)666-2238 (A04)EE5-8111
22 Cohen Paul Custormer support 10% Park Street EBurlington WA 01803 (B17)555-88%2 (B171555-4499
34 Crowley Charles Hurnan resources &9 Edson &t Burlincton WA 01803 [B17)665-1344 (B17)565-9877
36 Caruso William Finance 43 Edison S Bedford WA 01730 (B17)555-2144 (B171555-1656
46 Crossland Ellen Prociuct dewelopment 27 Rush Rid Burlincton (1) 01303 (B17)1565-0004 (B17)565-3005
&0 Coling MaryBelh  Administration &6 Lincoln Street  Burlington WA 01803 (BITIEE5-1188 (B17)555-95%8
B Clirton Gearge Marketng Fennsylvania Ave  Houston TX TTOTS  (T13)555-T8%: (713)555-4291

Click the Retrieve button.

The Specify Retrieval Criteriadialog box displaysagain. The requirement
that the last name begin with Cisstill in effect. Now you add an additional
requirement. The report isto list contacts whose last names begin with C
and who are from Burlington.

Use the scroll bar to display the city column.
Click in the first box underneath city and type Burlington.

Specify Retrieval Criteria rz|
Colurnn: city skake Iz~ oK,
Criteria; Eurlington|

Qs

Click OK.

Now the report has only contacts whose last names begin with C and who
are from Burlington.

Report - contactgrid_with_prompting \'._||'E\E|
~
Id Last Name First Name Job Role Street City State  Zip Phone Fax
1% Chin Draviict Procuct dewelopment 16 Wiaverly Rd. EBurlington WA 01903 (B17)555-33T% (B171555-4453
23 Cohen Paul Custormer support 10% Park Street EBurlington WA 01903 (BI7)E55-88%2 (B171555-4499
34 Crowley Charles Hurnan resources &9 Edson &t Burlincton WA 01803 [B17)665-1344 (B17)565-9877
46 Crossland Ellen Procuct development 27 Rush Rd Burlington MA 01303 (B17IE55-0004 (B171555-8005
&0 Coling MaryBeth  Administraion 56 Lincoln Steet  Burlington WA 01803 (BI7E05-1189 (6171555-95%8
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11 Click the Retrieve button.

The Specify Retrieval Criteria dialog box displays again. The
reguirements that the last name begin with C and that the city be
Burlington are still in effect.

Now you changethe city requirement slightly. Thereport isto list contacts
whose last names begin with C or who are from Atlanta. To be listed,
contacts have to meet either requirement; they do not have to meet both.

12 Use the scroll bar to display the city column.
Select Burlington and press delete to delete Burlington.

13 Press the down arrow key to move down one row.
Type Atlanta.

Specify Retrieval Criteria g|
Colurnn: city skake +zip -~ oK,

Criteria:

ar: Atlanta

14 Click OK.

By specifying criteriain two different rowsin the dialog box, you are
specifying that the report should retrieve rows from the database that meet
the first row of criteria or the second row of criteria.

Your report retrieves all contacts whose names begin with C. It also
retrievesall contactswho arefrom Atlanta. Itishard to | ook at the two sets
of rows, so now you sort by city. Then all the Atlantarowswill betogether.

B Report - contactgrid_with_prompting

Id Last Name First Name Job Role Street City State  Zip Phone Fax
3 Critch Susan Product developmert 45 Cerer St Danvers MA 01923 (S0%)E55-4829 (BOY5E5-3025
10 Clarke Mally Sales 55 Pine Grove Rd.  Lexington WA 0217 (B17)555-4325 (B17)555-7638
15 Moore Dan Sales One Park Drive Atarta GA 30339 (404)555-4%34 (404)555-3231
14 Chin Dravid Product developmert 16 Wiaverly Rd. Burlincton MA 01203 (BITIEEE-2278 (B171565-4453
21 Caobh Paul Customer support 34 Greerwile 5t Aflarta GA 0339 (0415552239 (4041555-3111
23 Cohen Faul Customer support 108 Park Street Burlincton A 01203 (B817)666-8883 (B17)666-44598
27 Ewans Cartie Sales 29 Wigshington & Aflarta GA 30239 (40415551169 (404)555-3244
34 Crowley Charles Human resources £4 Edson 5t Burlincton A 01803 (B17)5656-1244 (B17)655-9877
26 Caruso ‘iflliarm Finance 4% Edison &t Bedford MA 01730 (BITEEE-2144 (B171565-1656
46 Crossland Ellen Procuct development 27 Rush Rl Burlington WA 01803 (B17)555-0004 (6171555-3005
60 Shishow Irina Marketing 567 Park Drive Allarta GA 0329 (40436661233 (40)E65-6327
59 Masalsky Kurt Customer support 29 Garden 5t Alarta GA 0239 (404)555-5111 (404)555-2347
60 Colins MaryBeth  Administraton 56 Lincoln Street  Burlingon A 01803 (B17)656-1189 (B17)655-9586
3] Clirton Georoe Marketing Pennsylvania Ave  Houston T TIOTG  (T13)B5E-TE32 (F12)565-4291
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15 Select Rows>Sort from the menu bar.

The Specify Sort Columns dialog box displays.

16 Drag the Id column out of the Columns box and the city column into
the Columns box.
Click OK.

Specify Sort Columns

1] Drag and Drop items, ¥
2] Double-click column to edit expression,

Source Data Colurnns Ascending

id A ety |
last_name
First_name
Litle:

street

ity

state

zip

phone

.

InfoMaker sorts the rows by city. Now you can see the Atlanta contacts
first. These are followed by contacts whose names begin with C.

B Report - contactgrid_with_prompting

Id Last Hame First Hame Job Role Street City State  Zip Phone Fax
15 Moore Diaun Sales Cne Park Drive Aflanta G4 30338 (A04)555-4834 (A041555-8291
27  Ewans Carrie Sales £9 Washington 5. Allanta GA 30338 (40415551169 (404)555-5244
b Cobly Faul Customer support 34 Greenvile St Aflanta 38 30338 (A04)555-2E38 (A04565-2111
£0 Bhishoy Irina Markefing 567 Park Drive Alanta GA 30234 (404156551238 (404)565-6837
59 Masalsky lurt Customer support 29 Garcen S Alarta G4 30338 (0415555111 (404)555-8347
36 Caruso Wl Finance 99 Edison 8t Becfford A 01730 (B171666-2144 (617)666-1666
60 Caling MaryBeth  Administration 56 Lincoln Sreet  Burlingtan hA 01803 (B17)555-1199 (617)555-9585
23 Cohen Faul Customer support 10% Park Street Burlington MA 080%  (617)566-88%% (617)566-4499
46 Crossland Ellen Product development 27 Rush Rd. Burlincton MA 01£0%  (B17IRE5-0004 (B17)565-2005
34 Crowley Charles Human resources 69 Edson St Eurlingon MA 01803 (B17)555-1344 (B17)555-9877
1% Chin David Product development 18 Waverly Rd Burlington A 01802 (B17)666-3378 (E17)666-4463
3 Critch Susan Product development 45 Certer 5t Danvers hA 01923 (B08)555-4829 (508)555-3025
61 Clirton George Marketing Pernsylvania Awe  Houston T TI07E  (F1X)6EE-TEIE (F13)566-4291
10 Clarke hally Sales 55 Pine Grove Rd. Lexinofon MA 02173 (B17)555-4325 (B17)555-T63%

Now you are finished using this report and using the application.

17 Click the Exit button.
This closes the report and the application.

Congratulations. Now you have doneit all. You have created data, maintained
it, and reported on it. And you have put all your work together into your own
application. See the next page for some suggestions on what to do next.
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What to do next

You might be ready to make your own InfoM aker application or you might be
interested in learning more by using the samplelibrary, tutor_im.pbl. Here are
some idess.

Personalize the contact data Deleteall thedatain the contact table and add
your own. You can run your Contacts application to do this. Use the form to
delete and add data.

Look at other sample forms and reports  Inthe Environment tutorial, you
accessed afew of the sampleformsand reports delivered with InfoM aker. Now
you can go back and look at more. The samples are located in tutor_im.pbl.
When you look, notice both the design version and the results you get when
you run aform or report.

Use the sample pipeline  The sample library includes a sample pipeline.
Pipelines|et you move data structures and data within and between databases.
Open the library and double-click the pipeline. This takes you to the Data
Pipeline painter. The sample pipeline creates a copy of the employee tablein
the EAS Demo DB. To create the copy, you execute the pipeline.

Change sample forms and reports  If you want to try some changes with
samples, open the form or report and use Save As on the File menu. With Save
As, you create a copy of the form or report and save it with anew name. Then
you can make changes without affecting the original.

Create other forms and reports using the EAS Demo DB Once you have
looked at the sample forms and reports, try creating some on your own. The
EAS Demo DB has several tables that you can use. You might want to start
with the contact table since you are familiar with it. Use the other InfoM aker
documentation and online Help as you work.
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Index

A

actionsinforms 46

Adaptive Server Anywhere database 95, 102
AND operator 134

applications

about 177

applying retrieval criteriainforms 194
assigning version numbers 181
creating 186

creating shortcuts 187

defining menu items 185

defining MicroHelp 184

defining toolbar buttons 184

defining toolbar items 183
executable (EXE) files 178, 186
initidization (INI) files 178, 186
modifying most recently created 183
running forms 192

running reports 196

selecting objectsfor 182

setting retrieval criteriainforms 193
specifying atitle 180
specifyingicons 180

specifying the application filename 180
specifying the folder for the EXE file 180
starting 190

updating the database 193

Ascending sort order option 73

B

buttons

addingtoforms 43
defining in application toolbars 184
movinginforms 50

Getting Started

C

columns
defining display widths 111
defining DropDownDataWindow edit style 113
defining DropDownListBox edit style 106
defining headers 111
definingintables 96
defining labels 111
Null setting 100
setting initial values 117
validating data 117
comments
adding to objectsin libraries 174
modifying for objectsin libraries 174
computed fields, adding to reports 87
contact.txt file 122
control edges, showing in report Design view 70
controlsinforms 43
controlsin reports
deleting 30
deselecting 29
dragging 28
edges, showing in Designview 70
moving 28
selecting multiple 28
showing edges 27
copying
forms 167
queries 167
reports 167
counts, adding to reports 87
Create Executable dialog box 179
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Index

D

d_dddw_statesreport 168
data sources

defining for forms 35

defining for reports 62

Query 138

Quick Select 36, 61
datavaluesin edit styles 108
data, importing into tables 121
database

canceling changes 193

insertingrows 54

retrieving 122

updating 57,122,193
Database painter 96
dates, adding to reports 85
deleting

forms 167

queries 167

reports 167
Descending sort order option 73
dialog boxes

Create Executable 179

Executable Items 183

Modify Expression 88

New Form 35, 36

New Report 140

Print 94,159

Quick Select 36, 37, 38, 62, 125

SaveAs 93

Save Form 42

Save Query 130

Save Report 69, 152

Select Action 45

Select Form 34

Select Import File 122

Select Query 139

Select Tables 97

Specify Retrieval Criteria 173, 197

Specify Sort Columns 72

tabsin the SQL toolbox 132
display valuesin edit styles 108
dragging 43
DropDownDatawWindow edit style

about 114

206

database and PBL requirements

defining for column 113
DropDownListBox edit style

defining 106

using 55

E

Edit Mask edit style

defining 118

using 56, 119
executable (EXE) files 178
Executable Itemsdialogbox 183
extended attribute system tables 39
extended attributes 105

F

Form painter 34

forms
actions 46
adding buttons 43
adding reports 51
adding scroll barsto reports 53
adding titles 48
applying retrieval criteria 194
changing bordersfor data 49
controls 43
copying 167
cregting 34
datasources 35
deleting 167
making reportsresizablein 53
moving 167
moving buttons 50
openinginalibrary 162
previewing (running) 40, 54
resizing reportsin 53
running in applications 192
saving 42
setting retrieval criteria 193
styles 35

168
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G
graph type, changing 156
graphs

adding titles 155
Bar type 157
changing type 156
cregting 147
defining data 148
Pietype 158
previewing 151
printing 159
repositioning 154
resizing 154

saving 152
grid, displaying in report Design view 27
grouping in reports 74

icons, specifying for applications 180
imini 178

im110.exe 178

importing data 121

initial values, setting for columns 117
initialization (INI) files 178
inserting rows in the database 54

L

lasso selection 30, 49
libraries
adding commentsto objects 174
changing current 166
copying objects 167
deleting objects 167
modifying comments for objects 174
moving objects 167
opening 166
opening objects 162
Library painter 161
LIKE operator 199

Getting Started

Index

M

menu items, defining in applications 185
menus, about WindowToolbars notation 17
menu styles, selecting 183
MicroHelp, defining in applications 184
Modify Expression didlogbox 88
mouse
displaying apop-up menu 16
dragging toolbars 17
moving
forms 167
queries 167
reports 167
mylib.pbl 166

N

New Form dialog box 35, 36

O

objectsin libraries
adding comments 174
copying 167
deleting 167
modifying comments 174
moving 167

operators
logical AND 134
logical LIKE 199

P

page numbers, adding to reports 86
painters

accessing 11

DataPipeline 203

Database 96

Form 34

Library 161

Query 125

Report 144

PDF, saving areportas 93
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Index

pipeline 203
popup menus
displaying 16
using 22
previewing
(running) forms 40, 54
graphs 151
queries 129
reports 67
primary key, defining for atable 103
Print didogbox 94, 159
printing
graphs 159
reports 92, 94
prompting for retrieval criteria 172, 197
Propertiesview 22

Q

queries
about 123
copying 167
deleting 167
moving 167
openinginalibrary 162
previewing 129
saving 130
selecting columns 125
specifying selection criteria 132
specifying sorting 136
using asdatasource 138
Query painter 125
Quick Select datasource 36, 61
Quick Select dialog box 36, 37, 38, 62, 125

R

Report Options dialog box 26
Report painter 144
reports
adding adate 85
adding atitle 82
adding computed fields 87
adding counts 87

208

adding page numbers 86
addingtoforms 51

copying 167

creating 60

creating from queries 138
creating new from existing 170
datasources 62

deleting 167

deleting controls 80

detail band 77
displaying grid in Design view 27
displaying rulersin Design view 70
footer band 77

group header band 77,79
group trailer band 77
grouping 74

header band 77

moving 167

opening 144

opening inalibrary 162
previewing 67

printing 92,94

prompting for retrieva criteria 172
rearranging controls 76
resizinginforms 53
running in applications 196
saving 69

savingasPDF 93
selecting all text 81

showing control edges 70
sorting 72

specifying retrieval criteria 172
styles 61

summary band 77

tabular style 61

working with bands 77

retrieval criteria

applyinginforms 194

selecting columns for prompting 172
setting informs 193

specifying for reports 172, 197

retrieving data 122
rulers, displaying in report Design view 70
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Save Asdidogbox 93
Save Form dialog box 42
Save Query didlogbox 130
Save Report dialog box 69, 152
saving
forms 42
graphs 152
queries 130
reports 69
scroll bars, adding to reportsin forms 53
Select Action dialog box 45
Select Form dialogbox 34
Select Import Filedialogbox 122
Select Query dialogbox 139
selecting
lasso 30,49
multiple controlsin reports 28
shortcuts, creating for an application 187

sorting
inqueries 136
inreports 72

inreportsin an application 202
Specify Retrieva Criteriadialog box
Specify Sort Columnsdialog box 72
specifying retrieva criteriafor reports 172
starting InfoMaker 7, 10
StyleBar, using 45
styles

of forms 35

of reports 61

173, 197

T

tables

about 95

commenting 104

creating 96, 102

defining aprimary key 103
defining columns 96, 101
importing data 121
saving 102

text file, for importing data 121

Getting Started

titles

addingtoforms 48

adding to graphs 155
adding to reports 82
toolbar items, defining for applications
toolbars

about 16

defining buttonsfor 184
dragging 17

making floating 17

Objects drop-down tool bar 19
showing PowerTips 19
showingtext 18
TUTOR_IM.PBL 8
tutor_im.pbl 8, 163

tutorials

requirementsfor using 8
times 8

U

undoing changes 30
updating the database 57, 122, 193

V

validatingdata 117

vaidationrules 117

version numbers, for executables 181
views, managing 20

X

XML, saving areportas 93
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