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About This Book

Audience

How to use this book

Related documents

Getting Started

Thisbook is for anyone using PowerBuilder® to build applications.

This book provides information that enables you to start using
PowerBuilder:

Part 1 isan overview of the PowerBuilder devel opment
environment.

Part 2 isatutorial in which you build your first PowerBuilder
application.

Part 3 isatutorial in which you create and run a.NET Web Forms
target.

Part 4 isatutorial inwhich you create and run a.NET Windows
Forms target.

This table lists the information in the PowerBuilder documentation set,

grouped by topic:
Topic Book Description
Installation Installation Guide Tells you how to install
PowerBuilder
Introduction Getting Started Introduces you to PowerBuilder
and use of and provides atutorial you can step
PowerBuilder through to learn the basics
features
Programmer’s | User’'s Guide Tells how to use the paintersto
information build objects in PowerBuilder
Application Presents collections of techniques
Techniques for implementing many common
application features, along with
deployment details and tips for
cross-platform and international
development and deployment



Topic Book Description
Datawindow Explains how to use DatawWindows
Programmer’s Guide | in all the supported environments
(PowerBuilder, Web pages, Java)
and describes programming
techniques for accessing,
displaying, manipulating, and
updating data
.NET targets Deploying Tells you how to build, deploy,
information Applications and debug and run .NET Web Forms
Componentsto .NET | and Windows Forms targets, and
how to create .NET assembly
components and Web servicesfrom
PowerBuilder nonvisual objects
JSP targets Working JSP Targets | Tells how to build, deploy, debug,
information and run PowerBuilder JSP targets
JSP Target Reference | Provides reference information for
objects and classes in the Web
Target object model
Reference PowerScript Describes syntax and usage
information Reference information for the PowerScript
language, including variables,
expressions, statements, functions,
and events
DataWindow Provides reference information for
Reference the Datawindow object, including

properties and functions for
expressions; syntax for accessing
properties and data; and reference
information for the methods,
events, and properties of
Datawindow controls and
DataStoresin all supported
environments

Objects and Controls

Lists properties, events, and related
functions for PowerBuilder system
objects and controls

PowerBuilder Native
Interface (PBNI)
Programmer’s Guide
and Reference

Contains how-to and reference
information for using PBNI to
create PowerBuilder extensions
and interact with C++ applications

PowerBuilder
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Other sources of

information

Getting Started

Topic Book Description

PowerBuilder Contains reference information for
Extension Reference | PowerBuilder extension modules
created with PBNI (such as
PBDOM, EJBClient, and Web

services)
Communicating | Connecting to Your Tells how to connect to a database
with adatabase | Database from PowerBuilder; describes how

to set up, define, and manage
database connections accessed
through the ODBC interface or one
of the native database interfaces

Connection Includes procedures for preparing,

Reference defining, establishing, maintaining,
and troubleshooting your database
connections

Use the Sybase Getting Started CD, the SyBooks CD, and the Sybase Product
Manuals Web site to learn more about your product:

The Getting Started CD contains rel ease bulletins and installation guides
in PDF format, and may also contain other documents or updated
information not included on the SyBooks CD. It isincluded with your
software. To read or print documents on the Getting Started CD, you need
Adobe Acrobat Reader, which you can download at no charge from the
Adobe Web site using alink provided on the CD.

The SyBooks CD contains product manuals and is included with your
software. The Eclipse-based SyBooks browser allows you to access the
manuals in an easy-to-use, HTM L -based format.

Some documentation may be provided in PDF format, which you can
access through the PDF directory on the SyBooks CD. To read or print the
PDF files, you need Adobe Acrobat Reader.

Refer to the SyBooks Installation Guide on the Getting Started CD, or the
README.txt file on the SyBooks CD for instructions on installing and
starting SyBooks.

The Sybase Product Manual s Web siteisan online version of the SyBooks
CD that you can access using a standard Web browser. In addition to
product manuals, you will find links to EBFs/Maintenance, Technical
Documents, Case Management, Solved Cases, newsgroups, and the
Sybase Developer Network.

Xi



Sybase certifications
on the Web

Xii

To access the Sybase Product Manuals Web site, go to Product Manuals at

http://lwww.sybase.com/support/manuals/.

Technical documentation at the Sybase Web site is updated frequently.

Finding the latest information on product certifications

1

4

Point your Web browser to Technical Documents at
http://www.sybase.com/support/techdocs/.

Click Certification Report.

In the Certification Report filter select aproduct, platform, and timeframe
and then click Go.

Click a Certification Report title to display the report.

Finding the latest information on component certifications

1

Point your Web browser to Availability and Certification Reports at
http://certification.sybase.com/.

Either select the product family and product under Search by Base
Product; or select the platform and product under Search by Platform.

Select Search to display the availability and certification report for the
selection.

Creating a personalized view of the Sybase Web site (including support
pages)

Set up aMySybase profile. MySybaseisafree service that allowsyou to create
apersonalized view of Sybase Web pages.

1

2

Point your Web browser to Technical Documents at
http://lwww.sybase.com/support/techdocs/.

Click MySybase and create a MySybase profile.

PowerBuilder
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Sybase EBFs and
software
maintenance

If you need help

Getting Started

You can find information about EBFs and software maintenance on the Sybase
Web site.

Finding the latest information on EBFs and software maintenance

1

Point your Web browser to the Sybase Support Page at
http://lwww.sybase.com/support.

Select EBFs/Maintenance. If prompted, enter your MySybase user name
and password.

Select a product.

Specify atime frame and click Go. A list of EBF/Maintenancereleasesis
displayed.

Padlock icons indicate that you do not have download authorization for
certain EBF/Maintenance releases because you are not registered as a
Technical Support Contact. If you have not registered, but have valid
information provided by your Sybase representative or through your
support contract, click Edit Roles to add the “ Technical Support Contact”
role to your MySybase profile.

Click the Info icon to display the EBF/Maintenance report, or click the
product description to download the software.

Each Sybaseinstallation that has purchased a support contract has one or more
designated people who are authorized to contact Sybase Technical Support. If
you cannot resolve aproblem using the manualsor online help, please havethe
designated person contact Sybase Technical Support or the Sybase subsidiary
in your area.
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PART 1 Welcome to PowerBuilder

This part is an overview of the PowerBuilder development
environment.






CHAPTER 1

About this chapter

Contents

For more information

Introduction to PowerBuilder

This chapter introduces the PowerBuilder development environment,
which you usein the tutorialsin Parts 2-4. It also describes the building
blocks of a PowerBuilder application.

Topic Page
What PowerBuilder is 3
The PowerBuilder environment 6
PowerBuilder objects 11

For a more detailed description of the PowerBuilder devel opment
environment, see the Power Builder User’s Guide.

What PowerBuilder is

What's in a PowerBuilder
application?

What is a PowerBuilder
component?

Getting Started

PowerBuilder is an enterprise devel opment tool that allows you to build
many types of applications and components. It isone of agroup of Sybase
products that together provide the toolsto devel op client/server, multitier,
and Internet applications.

A PowerBuilder client application can contain:

« Auserinterface Menus, windows, and window controlsthat users
interact with to direct an application.

« Application processing logic Event and function scriptsinwhich
you code business rules, validation rules, and other application
processing. PowerBuilder allows you to code application processing
logic aspart of theuser interface or in separate modul es called custom
class user objects.

Inamultitier application, modul es containing application processing logic
(that you deploy to aserver) are called components. You can design, build,
and deploy custom class user objects as application server components.



What PowerBuilder is

PowerBuilder
applications are event
driven

PowerScript language

PowerScript functions

Object-oriented
programming with
PowerBuilder

.NET applications

Inaclient application, users control what happens by the actionsthey take. For
example, when a user clicks a button, chooses an item from amenu, or enters
datainto atext box, one or more events are triggered. You write scripts that
specify the processing that should happen when events are triggered.

Windows, controls, and other application components you create with
PowerBuilder each have a set of predefined events. For example, each button
has a Clicked event associated with it and each text box has a Modified event.
Most of the time, the predefined events are all you need. However, in some
situations, you may want to define your own events.

You write scripts using PowerScript, the PowerBuilder language. Scripts
consist of PowerScript commands, functions, and statements that perform
processing in response to an event.

For example, the script for a button’s Clicked event might retrieve and display
information from the database; the script for atext box’s Modified event might
evaluate the data and perform processing based on the data.

The execution of an event script can al so cause other eventsto betriggered. For
example, the script for aClicked event in abutton might open another window,
triggering the Open event in that window.

PowerScript provides arich assortment of built-in functionsthat can act on the
various components of your application. For example, thereis afunction to
open awindow, afunction to close awindow, afunction to enable a button, a
function to update the database, and so on.

You can also build your own functions to define processing unique to your
application.

Each menu or window you create with PowerBuilder is a self-contained
module called an object. The basic building blocks of a PowerBuilder
application are the objects you create. Each object contains the particular
characteristics and behaviors (properties, events, and functions) that are
appropriate to it. By taking advantage of object-oriented programming
techniques such as encapsulation, inheritance, and polymorphism, you can get
the most out of each object you create, making your work more reusable,
extensible, and powerful.

If you are using the Enterprise edition of PowerBuilder, you can develop
applications and components for the .NET environment. These include Web
Forms applications that you deploy to I1S servers using ASPNET and
Windows Forms applications that you can deploy with smart client
functionality. You can also convert nonvisual custom class objectsdirectly into
.NET assemblies and you can deploy them as .NET Web services.

PowerBuilder
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JSP applications

Multitier applications

Database connectivity

Online Help and
documentation

Getting Started

For information about .NET targets, see Deploying Applications and
Componentsto .NET.

If you are using the Enterprise edition of PowerBuilder, you can develop
PowerBuilder applications that run on the Web using JSP targets technol ogy.
With JSPtargets, you can build complex Web pagesthat can include client- and
server-side scripting, database content, Web Datawindows, and EA Server
components.

In all editions of PowerBuilder, you can use the DataWindow and
PowerBuilder window plug-ins, the PowerBuilder window ActiveX, and the
Datawindow Web control for ActiveX.

For information about JSP targets, see Working with JSP Targets. For
information about PowerBuilder plug-ins, see Application Techniques. For
information about the DatawWindow Web control for ActiveX, see the
DataWindow Programmer’s Guide and the DataWindow Reference.

PowerBuilder lets you build applications that run in a distributed computing
environment. A multitier application lets you:

e Centralizebusinesslogic on servers, such as EA Server, JBoss, WebL ogic,
WebSphere, or COM+

e Partition application functions between the client and the server, thereby
reducing the client workload

e Build scalable applications that are easy to maintain

For information about multitier applications, see the sections on distributed
application techniques in Application Techniques.

PowerBuilder provides easy access to corporate information stored in awide
variety of databases. Data can be accessed through the PowerBuilder ODBC or
JDBC interfaces, through a middle-tier data access server like the Sybase
Direct CONNECT server, or through a native or direct connection to a
database.

For information on database connectivity, see Connecting to Your Database.

PowerBuilder online Help can be accessed using Hel p buttonsand menu items,
or by selecting the F1 key from anywherein PowerBuilder. There arejumpsin
severa places from the online Help to booksin HTML format. Manuals are
also available on the Sybase Web site.



The PowerBuilder environment

The PowerBuilder environment

Workspaces and
targets

The development
environment

In PowerBuilder, you work with one or more targetsin a workspace. You can
add as many targets to the workspace as you want, open and edit objectsin
multiple targets, and build and deploy multiple targets at once.

A PowerBuilder target can be one of several types:
« Application target A client/server or multitier executable application.

« NETtarget A .NET target that you can use to deploy applications as
.NET Windows Forms or ASPNET applications or to deploy nonvisual
custom class components as .NET assemblies or Web services.

* An EAServer or Application Server Component target A component
that can be deployed to EA Server or another J2EE-compliant server.

e JSPtarget A Web application. A JSPtarget canincludeall the elements
you need to build a Web site—HTML files, scripts, images, downloaded
components—as well as settings for build options, database connections,
and deployment.

Thefirst lesson in the tutorial shows you how to create a workspace and a
PowerScript target. Later you learn how to create .NET targets.

When you start PowerBuilder, it opens in awindow that contains a menu bar
and the PowerBar at thetop, and the System Tree and Clip windows on the | eft.

=\ PowerBuilder, E”ﬁl@
File Run Tools Window  Help

rredEe 9 PdE=sRDEE 0 howw 5K k| 0
E(NnWﬂrkspaca)

Name Preview Descti...

Ready

PowerBuilder
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System Tree

Clip window

Output window

Painters

Editors

Wizards

Design-time controls

To-Do List

Getting Started

The System Tree window can serve as the hub of your development activities.
You use it to open, run, debug, and build your targets, and for drag-and-drop
programming.

The Clip window lets you store code fragments that you use frequently.

The output of avariety of operations (migration, builds, deployment, project
execution, object saves, and searches) displaysin an Output window at the
bottom of the main window. The Output window opens automatically when
output information is generated, but you can open the Output window at any
time by clicking the Output window toolbar button.

Once you have created a workspace and a PowerScript target, you build the
components of thetarget using painters. Painters provide an assortment of tools
for enhancing and fine tuning the objectsin atarget.

PowerBuilder provides a painter for each type of object you build. For
example, you build awindow in the Window painter. There you define the
properties of the window and add controls, such as buttons and text boxes.

For JSP targets, PowerBuilder provides HTML, style sheet, and frame set
editors. Inthe HTML editor you can edit pagesin source or display format and
preview the results. You can use a standalone script editor or onethat is built
into the HTML editor. The style sheet editor |ets you create external style
sheets that you link to your HTML pages, and the frame set editor lets you
select and edit frame structures for HTML pagesif you want to divide a Web
page into frames.

Wizards ssimplify the creation of applications, objects, components, Web sites,
and Web pages.

Design-time controls (DTCs) create basic HTML and scripts from information
you provide in property sheets. The property sheets display when you drop a
DTC on aWeb page in the HTML editor.

The Web DataWindow DTC provides an easy way to access adatabase from a
Web page. It displays dynamic database content in a variety of presentation
styles and supports inserts, updates, and deletes against the database.

The To-Do List displays alist of development tasks you need to do for the
current target. Entries on the To-Do list can be created automatically by most
PowerBuilder wizards. You can aso typein entries or import them from atext
file and then link them to atask that you want to complete.



The PowerBuilder environment

Browser

PowerBar

PainterBar

StyleBar

PowerTips

The Browser letsyou seeall the objects, methods, variables, and structuresthat
are defined for or available to your PowerScript target. Objectsin the Browser

can be displayed in alphabetic or hierarchical order. The Browser displays
methods with their complete prototypes (signatures), which include the

datatypes of all arguments and return values.
The PowerBar displays when you begin a PowerBuilder session. The
PowerBar is the main control point for building PowerBuilder applications.
You can use the New, Inherit, or Open buttons on the PowerBar to open all of
the PowerBuilder painters. From the PowerBar, you can al so open the Browser,

debug or run the current application, and build and deploy the workspace.

When you open a painter or editor, PowerBuilder displays a new window that

hasaworkspaceinwhich you design the object you are building. PowerBuilder

also displays one or more PainterBars with buttons that provide easy accessto

the tools available in the painter or editor. For example, hereis the PainterBar

for the DataWindow painter.
| % | 0 =

;-|AT|-.£.

|8 o<
The StyleBar displays when you open any painter that can contain text
controls, such as the Window painter. Using buttons on the StyleBar, you can

modify text properties such as the font and point size.
[ERTTETw—_ ] 0 -] |B 7 U= =

Il

When you leave the mouse pointer over a button for a second or two,

PowerBuilder can display a brief description of the button (a PowerTip). The
ability to display PowerTipsistoggled on and off by selecting the Show

PowerTips menu item in any toolbar pop-up menu.

File Run Tools ‘Window  Help
irih e EEe 99
|

@ (Mo Workspace)

You can also include brief descriptive texts on al toolbar buttons by selecting
PowerBuilder

ShowText from any toolbar pop-up menu.
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Customizing the In addition to displaying text in toolbar buttons, you can move the toolbars
environment around, add new toolbars, and customize existing ones. You can add buttons
for opening painters and performing other activities.

You can also rearrange the System Treg, Clip, and Output views, set up custom
layouts for each painter, choose whether PowerBuilder opens your last
workspace at start-up with or without painters and editors open, customize
shortcut keys, and change the colors and fonts used in scripts.

PowerBar buttons The buttons in the PowerBar give you quick access to the most common
PowerBuilder tasks:

Table 1-1: Buttons in the PowerBar

Button Use to
—a Create new workspace, target, component, or other object, or open a
i tool.
Mew
Inherit from menu, user object, or window.
[
Inherit
Open an existing application, DataWindow, function, menu, pipeline,
= project, query, structure, user object, window, HTML page, HTML
Opcn frame, style sheet, or script file.
= Preview awindow or DataWindow object.
Proview
5 Show or hide the System Tree window.
EysTree
z Show or hide the Output window.
&3
Cutput
< Move to the next line in the Output window.
Mexk
5 Move to the previous line in the Output window.
Previous
o Display alist of development tasks you need to do. These can be self
= entered or entered automatically by PowerBuilder wizards.
Ta-Oi List
z View object information (such as object properties or global variables)
. [:"i and copy, export, or print it.
Show or hide the Clip window.
'—=|EI p
Clip

Getting Started 9
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Button

Useto

]

Library

Create and maintain libraries of PowerBuilder objects.

&

DE Prof

Specify how to connect to a database.

&

EAZ Prof

Specify how to connect to EA Server.

=
Databasze

Maintain databases, control user access to databases, and manipulate
datain databases.

Edit

Edit afile.

10
I. Eild

Start an incremental build of the workspace.

l:l-Tl:l
F. Build

Start afull build of the workspace.

Deploy

Deploy the workspace.

=

Zhip

When a series of operationsisin progress, such as afull deploy of the
workspace, skip to the next operation.

=

Etop

Stop a build or deploy operation or series of operations.

%5

Debug

Debug the current target.

s

Zel Dbg

Select atarget and debug it.

¥

Run

Run the current target.

Select atarget and runit.

) g

Exit

10

Exit from PowerBuilder.

PowerBuilder
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PowerBuilder objects

Application object

Getting Started

The basic building blocks of a PowerScript target are objects:

Table 1-2: Basic building blocks of a PowerScript target
Object Use

Application Entry point into an application

Window Primary interface between the user and a PowerBuilder
application

Datawindow Retrieves and manipulates data from arelational database or
other data source

Menu List of commands or options that a user can select in the

currently active window

Global function Performs general-purpose processing

Query SQL statement used repeatedly as the data source for a
Datawindow object

Structure Collection of one or more related variables grouped under a
single name

User object Reusabl e processing module or set of controls, either visual or
nonvisual

Pipeline Reproduces data within a database or across databases

Project Packages application for distribution to users

These objects are described in more detail in the sections that follow.

The Application object isthe entry point into an application. It is a discrete
object that is saved in a PowerBuilder library (PBL file), just like awindow,
menu, function, or DatawWindow object.

The Application object defines application-level behavior, such aswhich fonts
are used by default for text, and what processing should occur when the
application begins and ends.

When auser runsthe application, an Open event istriggered in the Application
object. The script you write for the Open event initiates the activity in the
application. When the user ends the application, the Close event in the
Application object istriggered.

The script you write for the Close event typically doesall the cleanup required,
such as closing a database or writing to a preferencesfile. If there are serious
errors during execution that are not caught using PowerBuilder’s exception

handling mechanism, the Application object’s SystemError event is triggered.

11
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Windows
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Figure 1-1: Application life cycle

User starts application

Open event in application object is tnggered
L ]

Initial window opens

and environment set up System eror

&

Userinteracts

, Vvith window SystemError event in

Application runs: other application object is triggered

windows open and
close, data is retrieved
from the database. written System eror
to the database, .. .

x

T

User ends application

Close event in application object is tiggered
L

Windows close and
cleanup done

Windows are the primary interface between the user and a PowerBuilder
application. Windows can display information, request information from a

user, and respond to the user’s mouse or keyboard actions.

A window consists of:

Properties that define the window’s appearance and behavior (for
example, awindow might have atitle bar and a Minimize box)

Events triggered by user actions

Controls placed in the window

PowerBuilder
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DataWindow objects

Getting Started

Windows can have various kinds of controls, asillustrated in the following
picture;

: Progress Bar Conbrols [-]0]
Move the Track Bar to zoom the datawindow  Option
: _
S Dosempion || Tie| | UmSi: 3 = il Tick Poslan —
" |Fumctions - Externa Display system informa Systerm Infor Page Size: g = g EE & Bottam
- |Datastores This evample shows a Sales Order L SatPaion [0 = | & Borom
* [windosCortc This exsrple shows & Sales Drder L e [T ;  Heiber
= |User Objects This Windaw uses an Analog Clock ; =
- |Miscellansous This example runs var Performance | gt | Tl Vsl Tick Pastion
= | Datawindows - Events & FuniThis example s a simp Reporting Wit el iz B 2 | £ LeftdFight
"~ |User Objects 4 User Dhject that loal Drop Down C Tick Frequency: [5 = ; :T;:n
= |Datawindows - Updating  This s simple: sl ol Incremer I ShowSicst | ¢~ paiter
* |Datawindows - Retrisval  Shows how to cancel Cancel Retis
| Object Communication  Shows how to cancel Cancel Retie
- |orsg & Drop Select a depatment aiChange Emph
T | D atchwindss - Ewents & Funia, digial clock, buit us Digital Clack Ext
- [Dtewindows - Everts & Fun: This exsmple fsts al et Computed Fis
-~ |Datawindows - Retiieval  Datawindow that is & Referencing €
I J

Ontheleft of thewindow isaDataWindow control with horizontal and vertical
trackbars. On the right is a group box that contains static text controls
(containing descriptive labels), edit mask controls (as they appear when the
SpinControl property is on), a check box, and two smaller group boxes with
radio buttons. Under the main group box isa command button.

A Datawindow object isan object that you useto retrieve and manipulate data
from arelational database or other data source (such as an Excel worksheet or
dBASE file).

Presentation styles DataWindow objects also handle the way datais
presented to the user. You can choose from several presentation styles. For
example, you can display the datain Tabular or Freeform style.

13
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There are many ways to enhance the presentation and manipulation of datain
aDatawindow object. For example, you can include computed fields, pictures,
and graphs that are tied directly to the data retrieved by the Datawindow.

o |
E T M= E
Sales Summary Report 9101 =
October-December, 2000 Page 4of 4
Product Product  Product Quantity
0 Hame Description  Sold  Dollars Sales Summary
300 TesShit  TankTop 2 BN | zipped swestshin
301 TesShit  Woneck 285 §334%2 Wiool cap
302 Tee Shit Crew Meck 2148 §an,072 V-nedk
Tank T
400 Basehall Cap Cotton Cap 3278 $29,502 e Tep
Plastic Vizor-
401 Bosehel Cap  Wool cap A0 O | o ed swestenin
500 isor Cloth Visor 2652 3564 Crew Hedk
S0 visor Plastic visor 2608 17556 Catton Sherts
600 Swestshit  Hooded Swesishit 3080 373440 Cofton Cap
Cloth Vizar-
601 Swesishii  Zipped Swesishit 2724 985,378
o 20000 40000 BO000 80000
700 Shorts Cofton Sherts 4535 68,040 Dollam

14|

m

Display formats, edit styles, and validation You can specify how to

display the values for each column, and you can validate data entered by users
in a Datawindow object. You do this by defining display formats, edit styles,
and validation rulesfor columns.

For example:

* If acolumn can take only a small number of mutually exclusive values,
you can have the data appear as radio buttons in a Datawindow so users
know what their choices are.

B DataWindow - d_edit_styles

1D Dept Hame
102 100 ‘whithey . Fran
105 100 Cobb, Matthew
129 200 Chin , Philip
14 |

Status

@ Active
0 Teminated
) On Leave
@ Active
0 Teminated
) On Leave
@ Active
0 Teminated
) On Leave

=l 3

Salary
$45,700.00

$62.000.00

$38,500.00

-

'n

PowerBuilder
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e [If thedataincludes phone numbers, salaries, and dates, you can format the

display to suit the data.
B DataWindow - d_formats M= E3
11} Hame Phone Salary Start Date o
=
102 whiney [617) 555-3985 $45,700.00 02/26/96

105 Caobb [617) 555-3340 $62,000.00 07/02/96
123 Chin [404) 555-2341 $38500.00 03/04/96
143 Jordan [617) 555-7335 $51.432.00 10/04/96
160 Breault [617) 555-3033 $57.430.00 12M16/96

1< | Llﬂ

e If acolumn can take numbers only in a specific range, you can specify a
simple validation rule for the data. This can spare you from writing code
to make sure users enter valid data.

Web Datawindow Using the XML Web Datawindow, the XHTML Web
DataWindow, or the HTML Web Datawindow, you can generate DataWindow
objectsin XML (with subsequent XSLT transformationto XHTML), XHTML
directly, or HTML and display them in a browser, using a PowerBuilder
component running in either EAServer or COM+ to generate the Web
Datawindow. One of thelessonsin the tutorial showsyou how to usean XML
Web Datawindow in a JSP target.

Menus Menus are lists of items that a user can select from amenu bar for the active
window. The items on amenu are usually related. They provide the user with
commands (such as Open and Save As on the PowerBuilder File menu) or
aternate ways of performing atask (for example, the items on the Edit menu
in the Window painter correspond to buttons in the PainterBar).

You can select menu items with the mouse or with the keyboard, or use
accelerator (mnemonic access) keys defined for theitems. You can define your
own keyboard shortcuts for any PowerBuilder menu item from a dialog box
that you open with the Tools>K eyboard Shortcuts menu item.

A drop-down menu isamenu under anitemin the menu bar. A cascading menu
isamenu that appears to the side of an item in a drop-down menu.

! Untitled =] B3
B

Delete...
Lancel

LCurrent Row
All Rows
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Queries

Structures
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Each choicein amenu is defined as a Menu object in PowerBuilder. The
preceding window shows two Menu objects on the menu bar (File and Data),
three Menu objects on the drop-down Datamenu (Update, Delete, and Cancel),
and two Menu objects on the cascading menu beside Update (Current Row and
All Rows).

PowerBuilder lets you define two types of functions:

e Object-leve functions are defined for a particular type of window, menu,
or other object type and are encapsul ated within the object for which they
aredefined. Theseare further divided into system functions (functionsthat
are always available for objects of a certain object class) and user-defined
functions.

e Global functions are not encapsulated within another object, but instead
are stored as independent objects.

Unlike object-level functions, global functions do not act on particular
instances of an object. Instead, they perform general-purpose processing
such as mathematical calculations or string handling.

A query isa SQL statement that is saved with a name so that it can be used
repeatedly as the data source for a DataWindow object. Queries enhance
developer productivity, because they can be coded once but reused as often as
necessary.

A structure is a collection of one or more related variables of the same or
different data types grouped under a single name. In some languages, such as
Pascal and COBOL, structures are called records.

Structuresallow you to refer to related entitiesasaunit rather than individually.
For example, you can define the user’s 1D, address, access level, and a picture
(bitmap) of the employeeasastructure called user_struct, and then refer to this
collection of variables as user_struct.

There are two kinds of structures:

»  Object-level structures are associated with a particular type of object such
as awindow or menu. These structures can always be used in scripts for
the object itself. You can also choose to make the structures accessible
from other scripts.

e Global structures are not associated with any object or type of objectinan
application. You can declare an instance of the structure and referenceitin
any script in an application.

PowerBuilder
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User objects

Libraries

Projects

Getting Started

Applicationsoften have featuresin common. For example, several applications
might have a Close button that performs a certain set of operations and then
closes the window, or they might have Datawindow controls that perform the
same type of error checking. Several applications might all require a standard
file viewer.

If you find yourself using the same application feature repeatedly, you should
define a user object. You define the user object once and use it as many times
as you need.

User objects can be visual or nonvisual. They can be further divided into
standard or custom user objects. Standard user objects, whether visual or
nonvisual, are system objectsthat are always avail able with PowerBuilder. You
can aso use controls for external visual objects that were created outside
PowerBuilder. The main types of user objects are:

« Visual user objects These are reusable controls or sets of controls that
have a consistent behavior. For example, avisual user object could consist
of several buttons that function as a unit. The buttons could have scripts
associated with them that perform standard processing. Oncethe abject is
defined, you can use it as often as you need.

« Nonvisual user objects These are reusable processing modul es that
have no visual component. Standard class user objects inherit events and
properties from built-in system objects. You typically use nonvisual
objects to define business rules and other processing that acts as a unit.

For example, you might want to cal culate commissions or perform
statistical analysisin several applications. To do this, you could define a
custom class user object. To use a custom class user object, you create an
instance of the object in a script and call its functions.

Custom class user objects, which define functions and variables, are the
foundation of PowerBuilder multitier applications. This is because you
typically use nonvisual components for applications that are run on a
server.

You save objects, such aswindows and menus, in PowerBuilder libraries (PBL
files). When you run an application, PowerBuilder retrieves the objects from
the library. Applications can use as many libraries as you want. When you
create an application, you specify which libraries it uses.

You can create Project objects that build executable applications and
components you can deploy to a server, aswell as proxy objectsyou usein
EAServer applications.

17
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CHAPTER 2 About the PowerBuilder Tutorial

About this chapter This chapter describes what you will do in the PowerBuilder tutorial and
how to get set up for it.

Contents

Topic Page
Learning to build a client/server application 19
Learning to build a .NET Web Forms application 21
Learning to build a .NET Windows Forms application 21
How you will proceed 22
Setting up for the tutorial 24

Learning to build a client/server application

The PowerBuilder tutorial is divided into parts. Thefirst part of the
tutorial isaset of eleven exercisesin which you build a Multiple
Document Interface (MDI) database application for afictional company
called Sportswear, Inc. The application allows you to retrieve customer
and product information from the database and perform insert, update, and
delete functions against the customer and product data.

Getting Started 19
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Customer and Product
windows

Login window
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The MDI application includes two windows that provide access to the
Customer and Product tablesin the EAS Demo DB database.

A Maintain Customers _ O] x|
Customer First Hame Last Hame Company Hame 3
D
é—_. 101 Michaels Devlin The Power Group
102 Beth Reiser AMF Corp,
103 - - P .
o
108 Product  Product Name Product Description Unit Price =
106
107 & Bl Tee shin Tank Top $9.00
301 Tee Shirt “-neck $14.00
Customer ID: 1 302 Tee Shirt Crew Meck $14.00
First Name: @ 400 Baseball Cap Cotton Cap 5300
401 Baseball Cap YWool cap $10.00
Last Name: Devlin H
Company Name: @
Product 10: Calar [White 'l
Phone Number: [(201] 5
Product Mame: Gluantity:

Size

Unit Price: $9.00)

Thesewindows are master/detail windows: each allowsyouto display amaster
list of rowsin aparticular table and also see detailed information for each row
in the table. For example, the top half of the Maintain Products window

containsalist of productswith a pointer to a single product; the bottom half of
the window displays extra detail for the current product.

The MDI application a so includes alogin window that allows you to connect
to the database at start-up time.

F VWelcome to Sportswear, Inc.

User |D: |

Passwaord I

Cancel

PowerBuilder
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Learning to build a .NET Web Forms application

In the second part of thistutorial, you convert the client-server application that
you built inthefirst set of exercises. However, you do not need to compl ete the
client-server tutoria in order to follow theinstructionsin the .NET Web Forms
tutorial. You can use the application provided in the PowerBuilder
Tutoria\Solutions directory as the starting point for the Web Forms tutorial
instead of the application that you build in the client-server tutorial.

The end result of the .NET Web Formstutorial ooks reasonably similar to the
completed client-server tutorial, except for the fact that you run the application
in a Web browser. There are other minor differences, such as the page
navigation toolbar that you select in the Web Forms application. The tutorial
does not cover al features of .NET Web Forms applications that you can build
with PowerBuillder. Additional topics, such as Web Forms printing, theme
setting, and user management are covered in the Deploying Applications and
Componentsto .NET book.

Learning to build a .NET Windows Forms application

In the third part of thistutorial, you convert the client-server application that
you built in thefirst set of exercises. However, you do not need to compl ete the
client-server tutorial in order to follow theinstructionsin the NET Windows
Formstutorial. You can use the application provided in the PowerBuilder
Tutoria\Solutions directory as the starting point for the Windows Forms
tutorial instead of the application that you build in the client-server tutorial.

The end result of the .NET Windows Forms tutorial 1ooks reasonably similar
to the completed client-server tutorial, except for the fact that you deploy it as
athin client application solution. The tutorial does not cover al features of
.NET Windows Forms applications that you can build with PowerBuillder.
Additional topics, such asintelligent updating and using the bootstrapper are
covered in the Deploying Applications and Components to .NET book.
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How you will proceed
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Table 2-1 describes what you will do in each of the tutorial lessons.

Table 2-1: Tutorial lessons and what you will accomplish

Lesson What you will do

1 Start PowerBuilder; begin familiarizing yourself with the
development environment; use the Workspace wizard and the
Template Application wizard to create an Application object,
windows, and menus in a PowerBuilder workspace and target.

2 Explore the PowerBuilder environment and customi ze the workspace.

3 Create alogin window to alow the user to enter database connection
parameters (user 1D and password).

4 Connect to the database using the Transaction object and user-entry
parameters; see how database profiles are defined in the PowerBuilder
environment.

5 Change the base sheet window by adding master and detail
Datawindow controls; add scripts to allow users to retrieve data and
perform insert, update, and del ete operations against the database.

6 Modify the frame menu and create a new sheet menu for the
application.

7-8 Build the DataWindow objects that retrieve customer and product
information, then add them to the Customer and Product windows.

9 Runthetutorial application in debug mode; see how to set breakpoints
in scripts, step through the code, and display the contents of variables.

10 Create a new window to test exception handling in PowerBuilder.

11 Create an executabl efilethat you can useto runthe application outside
the PowerBuilder development environment.

12 Convert the PowerBuilder client-server tutorial applicationto a.NET
Web Forms application.

13 Convert the PowerBuilder client-server tutorial applicationto a.NET

Windows Forms application.

PowerBuilder
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How long it will take

You can do all thetutorialsin about six hours, or you can stop after any lesson
and continue at another time.

If you are interrupted
You can save your work and exit PowerBuilder at any time. When you are

ready to continue, you can open the tutorial workspace and continue where you

left off.

What you will learn

This tutorial will not make you an expert in PowerBuilder. Only experience
building real-world applications can do that. It will give you hands-on
experience, though, and provide a foundation for continued growth.

Client/server You will learn basic PowerBuilder techniques and concepts, including those

applications listed in Table 2-2:

Table 2-2: Features demonstrated in the PowerScript tutorial

How to use the

To

Application painter

Define an Application object and application-level scripts

Window painter

Create SingleLineEdit controls, StaticText controls,
CommandButton controls, DataWindow controls,
window-level scripts, and control-level scripts

Datawindow
painter

Define selection and display options

Menu painter

Define menus, menu items, accelerators, and shortcut keys

Layout view

Design how the windows, menus, and DataWindows will ook
when you run the application

Script view

Define scripts for applications, windows, window controls,
and menus

Debugger

Identify logic errorsthat may cause problemswhen you runthe
application

Project painter

Getting Started

Create an executable version of an application
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.NET applications

You will learn basic .NET target techniques and concepts, including those
listed in Table 2-3:

Table 2-3: Features demonstrated in the .NET target tutorial

How to use To

.NET Web Forms | Convert aclient-server target to a Web Forms target and

wizards deploy it as a Web Forms project

Global variables Modify the page navigation toolbar type in a Web Forms
application

.NET Windows Convert aclient-server target to a Windows Forms target and

Forms wizards deploy it as a Windows Forms project

Intelligent update Publish a Windows Forms application to a Web browser and

technology install the application from the browser

Setting up for the tutorial

Connecting to a
database

The Tutorial directory

24

Before you start the tutorial, you need to make sure that you can connect to a
database and that you have the tutorial files.

The tutorial uses the EAS Demo DB V110 database that installs with
PowerBuilder. Thisis an SQL Anywhere database and requires the Sybase
SQL Anywhere engine.

If you do not already have SQL Anywhere on your local machine or server, you
must install it now. You can install it from the PowerBuilder CD. If you
installed PowerBuilder in a nondefault location, you must make sure that the
odbc.ini registry entry defining the EAS Demo DB as a data source pointsto
the correct location of the SQL Anywhere engine.

Thetutoria also usesthe fileslisted in Table 2-4:

Table 2-4: Files required by the PowerScript tutorial

File Contents

tutor_pb.pbl PowerBuilder library that contains several objects that you
usein the tutorial

pbtutor.hlp A Helpfilethat provides context-sensitive Help to awindow
that you build in the tutorial

tutsport.bmp A bitmap

tshirtw,jpg A graphic

tutorial.ico Anicon

PowerBuilder
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When you install PowerBuilder, these files are installed in the Tutorial
directory, which is a subdirectory of the PowerBuilder installation directory.

When you have finished the tutorial, you can delete thefiles.

The Tutorial\Solutions The Tutorial\Solutions directory contains a PowerBuilder library called

directory pbtutor.pbl that contains all the objects and scripts that you create in the first
part of the tutorial, as well as workspace and target files. You can use this
solutionslibrary as areference while you completethefirst part of thetutorial.
You can also useit as a starting point if you want to complete only the .NET
application parts of the tutorial.
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PART 2 Building a Client/Server
Application

This part is a tutorial that shows you how to get started
with PowerBuilder. It provides step-by-step instructions for
creating a simple database application.






LESSON 1

Getting Started

Starting PowerBuilder

Thislesson provides the information you need to start PowerBuilder and
create an application.

In this lesson you:

Create a new workspace

Create a target

Specify anicon for the application
Change the size of the main window

Run the application

How long does it take?
About 20 minutes.
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Create a new workspace
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Where you are

> Create a new workspace
Create a target
Specify an icon for the application
Change the size of the main window
Run the application

The workspace iswhere you build, edit, debug, and run PowerBuilder targets.
You can build several targets within asingle workspace, including JSP targets,
which are covered in Part 3 of thistutorial.

Now you start PowerBuilder and create a new workspace.

First read the Release Bulletin for this release .
Any last-minute items are documented in the Release Bulletin. To make sure

you have all thefiles necessary to complete the tutorial, see“ Setting up for the
tutoria” on page 24.

1 Double-click the PowerBuilder icon (representing PB110.EXE) in the
Sybase>PowerBuilder 11.0 path
or
Select Programs>Sybase>PowerBuilder 11.0>PowerBuilder 11.0 from
the Windows Start menu.

The Welcome to PowerBuilder dialog box displays.

Welcome to PowerBuilder §|
PowerBuilder can be used to create Windaws client applications,

server components, JMET ‘Web and Windows Farms, (MET Web

services and assemblies, and much maore,

Each component or component collection is stored as a target.
Multiple targets are grouped tagether as a workspace,

Would vou like ta:

Create a new workspace and & new target

Create a new workspace and add an existing target

Create just a new workspace
Open an existing workspace

Close this dialog box

[ shows this dislog box at startup with no workspace
Reload last workspace at skartup

PowerBuilder
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Getting Started

The Welcome to PowerBuilder dialog box allows you create a new
workspace and add a new target or an existing target to the workspace.

If you do not want PowerBuilder to display the dialog box again
You can leave the “ Show this dialog box at startup with no workspace”

check box unchecked to keep PowerBuilder from displaying the welcome
dialog box every time you start PowerBuilder. Select the “ Reload | ast
workspace at startup” check box to load the most recently used workspace
each time you start a PowerBuilder session. Then click “Closethis dialog
box.”

The PowerBuilder devel opment environment displays.

If thisisthefirst timeyou are opening PowerBuilder on your machine, you
seeonly atop-level entry inthe System Treeto indicate that no workspace
is currently open. Otherwise, the System Tree might show a workspace
with targets and objectsin it.

(% PawerBuilder

Fle Run  Tools Window Help

rJB-BII‘él@i’?l%ﬂﬁl‘%ﬁ]@@’l-@y@u@ﬁ\%&%xmﬂ‘

-

(Mo Warkspace)
g ! (=]

Marme: Presview Descri,. .

31



Create a new workspace

32

2

Select New from the File menu
or
Click the New button in the PowerBar.

The Workspace page of the New dialog box displays.

PowerBuilder displays the page of the New dialog box that was used
before the dialog box was last closed. In this exercise, make sure that the
Workspace page of the New dialog box displays.

New &‘

Target:

Workspace .Targat PB Object | ISP Datawindow || Database | Project | Tool

Select Workspace from the Workspace page of the New dialog box.
Click OK.

The New Workspace dialog box displays.

Navigate to the Tutorial folder.

The Tutorial folder islocated directly under the PowerBuilder 11.0 folder.
The solutions for the tutorial are in the Tutorial folder, but you will create
your own solutions as you work your way through the tutorial.

PowerBuilder
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Getting Started

Type MyWor kspace in the File name text box.

New Workspace

Save in: | 12 Tutarial V| @ ?‘ = L

File name: |MyW0rkspace | L Save ]

Save as type: |W’orkspace Files [*.pbw] v| [ Cancel ]
Click Save.

The New Workspace dialog box closes and the workspace you created
appears as the first item in the System Tree.
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Create a target
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Where you are
Create a new workspace

> Create a target

Specify an icon for the application
Change the size of the main window
Run the application

Now you create a new target using the Template Application wizard. Based on
the choices you make, the Template Application wizard creates precoded
events, menus, windows, and user objectsin addition to the application object.

1

Select New from the File menu and click the Target tab

or

Right-click MyWorkspace in the System Tree, select New from the
pop-up menu, and click the Target tab.

The Target page of the New dialog box displays.

X

New:

Target:

| Workspace | Target |PB Obiject | JSP Datawindow | Database | Project | Tool |

BE ® N @ @

Template Existing Application EAServer Application Server
Application Component Component
L
Q ® @ @&

JSP Target Source Controlled  \MET Web Forms MET Windows — MWET Web Service
JSP Target Application Forms Application

MET Assembly

Ok ] [ Cancel

Select the Template Application icon and click OK.

The Template Application wizard displays. Thefirst page of most wizards
explains what the wizard is used for. Asyou step through the wizard, you
can press F1 to get Help on most fields.
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3 Click Next until the Specify New Application and Library page
displays.

4  Type pbtutor inthe Application Name text box.

Thewizard automatically assignsfile namesto alibrary and target that use
this application name. It assignsthelibrary aPBL extension and the target
aPBT extension.

5 Click Next.

The Specify Template Type page displays. The MDI Application with
Microhelp radio button is selected. You will create an MDI template
application, so you do not need to change this selection.

About MDI
MDI stands for multiple document interface. In an MDI application, the

main window for the application is called the MDI frame. Using the MDI
frame menu bar, you can open additional windows known as sheet
windows that display inside the frame window.

6 Click Next 4 times until the Name Individual Sheets page displays.

Inthistutorial you accept the default application type, library search path,
frame and frame menu names, sheet menu and manager service, and MDI
base sheet.

If you have clicked Next too many times
You can use the wizard's Back button to navigate back to the correct

wizard page.
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Create a target
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7

On the Name Individual Sheets page, type w_cust oner s for Sheet 1,
w_pr oduct s for Sheet 2, and clear the Sheet 3 text box.

PowerBuilder will generate two windows based on the default basesheet
(w_pbtutor_basesheet), one for customers and one for products. You will
add a third sheet window later—in the lesson on exception handling.

Name Individual Sheets

The wizard will create three sheets inherited From
w_pbtutor_basesheet, Enter the names for these sheets here, or
clear the field to eliminate a sheet.

Sheet 1:

|w_cust0mers |

Sheet 2:

|w _products |

Sheet 3:

< Back ][ Mesxk = ][ Cancel

Click Next.
Type Mai nt ai n Cust oner s as the display name for Sheet 1.
Type Mai nt ai n Product s as the display name for Sheet 2.

The names you type will display in the title bars of these sheet windows.

Assign Display Names to Sheets

Enter a display value for the sheets, These values will appear in the
Title Bar and Menu,

w_customers Title (13

|Maintain Customers |

w_products Title (2)

|Maintain Products |

w_pbtutor_sheet3 Title (3)

< Back ][ Mesxk = ][ Cancel
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Getting Started

10

11

Click Next twice.

You do not need to change the names of the About and Toolbar windows.

On the Specify Connectivity page, select None.

You will add a Connection object later.

Click Next twice to display the Ready To Create Application page.

You will create a project |ater.

Thisisthe last wizard page. It lists your current selections so that you can
review them and use the Back button to go back and change them if
necessary.

Ready to Create Application

An Application with the Following characteristics will be created or
generated, Click Finish when you are ready,

Property

Target File
Application Library
Application
Application Type
Library Search Path
MO Frame Window
MDT Frame Menu
Base Sheet Mame
Sheet Menu

Sheet Manager
Sheet 1 Mame
PR

<

Yalue i
C:\Program Files\SybaselPowerBuilder 11,
C:\Program Files)SybaselPowerBuilder 11,
phtutar

MDI with Help

C:\Program Files)SybaselPowerBuilder 11,
w_pbtutor_frame

m_pbtutor_frame

w_pbtutor_baseshest

m_pbtutor_sheet

n_pbtutor_shestmanager

w_customers v

Generate To-Do List

< Back ” Finish ][ Cancel
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12 Make sure the Generate To-Do List check box is selected.

Click Finish.

The Template Application wizard creates the pbtutor.pbt target and the
pbtutor.pbl library, and sets the new pbtutor application as the default
application.

You can expand the System Tree to view al the objects that have been
created by the Template Application wizard. The System Tree does not
display the file extension of the pbtutor target, but it does display the
directory where the target file is saved.

The pbtutor.pbl library displays under the pbtutor target in the System
Tree. It contains the target Application object, which has the same name
asthe target object but displays under the library file. Other objects
generated by the wizard also display under the library file.

=) MyWorkspace - PowerBuilder,

File Run Tools ‘Window  Help

ﬂ.

Yo ce i« 5 erBuilder 11.01Tutaorial)
=@ pbtutor {C:\Program Sy PowerBuilder 11.0% Tutorial)
=B pbtutor.pbl {C:YProgram Files\Sybase\PowerBuilder 11,00 Tutorial)
& phtutor
= m_pbtutor_frame
7 Properties
[ Events
[ Functions
3 Structures
= Controls
m_File
m_edit
m_twindaw
m_help
m_pbtutor_sheet
8 n_pbkutor_sheetmanager
1 w_customers
1 w_pbtutor_about
] w_pbtutor_baseshest
1 w_pbtutor_frame
1 w_pbtutor_taolbars
=] w_products
7 Properties
[ Events
[ Functions
3 Structures
3 Controls

< >

Ehwiarkspace | b Page [ Language || (B Comparents
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Lesson 1 Starting PowerBuilder

Specify an icon for the application

Getting Started

Where you are
Create a new workspace
Create a target

> Specify an icon for the application
Change the size of the main window
Run the application

Now you specify anicon for theapplication. Theicon appearsin the workspace
when you minimize the application during execution. PowerBuilder includes
the icon automatically when you create an executablefile. You specify anicon
from the Properties view in the Application painter.

1 Double-click the pbtutor Application object in the System Tree
or
Right-click the pbtutor Application object in the System Tree and
select Edit from the pop-up menu.

The pbtutor Application object islocated under the pbtutor library, which
is under the pbtutor target object that you created with the Template
Application wizard. Different views of the Application object display in
the Application painter.
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Make sure the Properties view displays in the Application painter.

If the Properties view is not open, you can open it by selecting
View>Properties from the menu bar. The menuitem is grayed out if the

Properties view is aready open.

[P®IProperties - pbtutor inherited Frofm] B3

General | Toolbar

DisplayMame

MicroHelpOef ault

DWiMessageTitle

DDETimeout

0 &
[JrightToLeft

[ ]FreeDELibraries

’ Additional Properties

Properties {Mon-Yisual Object Lisk

Click the Additional Properties button in the Properties view.

A tabbed Application property sheet displays.

Select the Icon tab.

Click Browse.

Navigate to the Tutorial directory.
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Getting Started

6

7

Select the tutorial.ico file.
Click Open.

If you do not see the ICO file extension

You do not see | CO file extensionsiif the Hide File Extensions for Known

File Types check box is selected in the Options dialog box of your
Windows Explorer.

Thetutorial icon displays on the Icon page of the Application property
sheet.

Application rg|
Text Font Column Fonk Header Font
Lahel Font Icon Yariable Types
Icon Mame:
| C:\Program Files!SybasePowerBuilder | | Browse, .. |

2

OF ] [ Cancel ] [ Apply ] [ Help

Click OK.
Click the Save button in PainterBarl or select File>Save.
Click the Close button in PainterBar1 or select File>Close.
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Change the size of the main window

Change the size of the main window

42

Where you are
Create a new workspace
Create a target
Specify an icon for the application
> Change the size of the main window
Run the application

Now you change the size of the application’s main window. When you run the
application, the main window displaysin the position and size that you specify.

1 Double-click w_pbtutor_frame in the System Tree.

The Window painter opens the application’s frame window.

2 Check the Center check box on the General page in the Properties

view.

Now when you run the application, the frame window will be centered.
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Getting Started

Scroll down and select nornal ! inthe WindowState drop-down list
box.

L]
[®IFroperties - w_pbtutor_frame inherited From wilm] JE3

General |Scr0|| Toolbar | Other

Title -
| Frame |

Tag

Menuhlame

| m_pbtutor_frame | E]
Wisible

Enabled

ControlMenu
MaxBox
MinBox

[ clientEdge

[JrightToLeft
Center
Resizable

WindowType

|mdihelp! v|
Windowstate

3
BackColor

||:|Butt0n Face v| 3

IhProperties 4Control List yMon-Wisual Object List

If your Properties view looks different ) o
You can change the position of Propertiesview labels by right-clicking the

Propertiesview and sel ecting a preference from the pop-up menu. You can
position the label s either to the left of all fields, or on top of thetext fields
and to the right of the check boxes.

Click the Other tab in the Properties view.

Type 3000 in the Width text box and 2400 in the Height text box.

The size of the window rectangle in the Layout view changes. The values
you type are in PowerBuilder Units (PBUs).
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44

6

Press the Tab key.

General | Scrol Toolbar| Other |

=
[Properties - w_pbtutor_frame inherited Fram I.-'-.Iiﬂ.

= Position
*

[ 256

W

[132

Width

[ 3000

Height:

[ 2400

= Pointer

Painter

= Accessibility

AccessibleMame

AccessibleDescription

AccessibleRole

| defaultrole!

| WProperties AConkrol List aMon-Visual Object Lisk

Select File>Close from the PowerBuilder menu.
Click Yes when you are prompted to save your changes.

The Window painter closes.

Next you run the application. When you run the application, the frame

window will be centered and sized as you specified.
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Run the application

Getting Started

Fun

Where you are

Create a new workspace

Create a target

Specify an icon for the application

Change the size of the main window
> Run the application

Now you run the application to see how it works. At this point the application
does not do very much. By running the application, you can see the windows
and menus that were created for you when PowerBuilder generated the
application based on your choices. You will modify them |ater.

1 Click the Run button on the PowerBar.

TheMDI frame window displaysand is maximized. All MDI applications
created using the Wizard have a menu bar and a toolbar with some items
aready coded for you.

2 Select File>New>Maintain Customers.

The application opens a sheet window. The display name that you typedin
the Template Application wizard for Sheet 1 appearsin thetitle bar. The
sheet window title has anumber after it to indicate the instance of the
window that displays.
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About the number in the window title bar o )
The number 1 appears following the window title because thisis the first

instance of thew_customers sheet window that is open. The code that adds
the instance number to thetitle bar isin the ue_postopen event of the
w_master_detail _ancestor base sheet window.

-+ Frame

File Edit “Window Help
& | |
- Maintain Customers: 1 |;”E‘El

| Ready /

Select File>New>Maintain Products.

A second application sheet window displays.

Select Window>Tile Horizontal.

The sheet windows are arranged horizontally inside the MDI frame, with
the active sheet window at the top.

Select File>Toolbars from the menu bar.

The application displays the Toolbars dialog box.
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Getting Started

10

Select Floating in the Toolbars dialog box.

The toolbar floats within the MDI frame. You might need to move the
Toolbars dialog box to see the floating toolbar.

Select Top.
Thetoolbar is repositioned at the top of the frame.

Click Done to close the Toolbars dialog box.

Select File>Exit.

The application closes and you return to the PowerBuilder devel opment
environment.

When you exit and restart PowerBuilder, you might want to have
PowerBuilder in the state it was in when you exited, with the workspace
and painters you were working in open.

Select Tools>System Options from the menu bar and then click the
Workspaces tab.

System Options g|
Profiling Firewall Setting Java J5P
General Workspaces Syskem Fonk Prinker Fonk

[ 5how skart dialog at startup with no workspace
Reload painters when opening workspace
Automatically set current target

Recent objects list contains g ikems (limit 36)
Recent workspaces list contains | 8 | ikems (limit 36)

Recent connections list contains |5 |ikems (limit 10)

PowerBuilder creates registry entries for each workspace
and target: file you open, "Clean Up" will remove the
reqgistry entries for all workspace and target files that no

longer exist,
Clean Up

OF ] [ Cancel ] [ Apply ] [ Help
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Run the application

11 Make surethe Reopen Workspace On Startup and the Reload Painters
When Opening Workspace check boxes are selected.
Click OK.

Now when PowerBuilder startsup, it openstheworkspace and the painters
that were open when you exited. If you were coding in PowerBuilder when
you exited, the last script you were working on opens at the last line you
edited.
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LESSON 2

Getting Started

Customizing the PowerBuilder
Environment

Thislesson providestheinformation you need in order to become familiar
with the PowerBuilder environment and to customizetheworkspace. This
lesson is optional—you can skip to Lesson 3 if you want to.

In this lesson you:

e Manipulate the System Tree window
e Open an object

e Manipulate views

e Set up thetoolbars

How long does it take?
About 25 minutes.
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Manipulate the System Tree window

50

Cutput

Where you are
> Manipulate the System Tree window
Open an object
Manipulate views
Set up the toolbars

The Workspace pagein the System Tree provides you with an overview of your
work. (The other pages of the System Tree are relevant for JSP targets, but not
for PowerScript targets). By expanding the workspace and the objects it
contains, you can see the content and structure of your target.

You can work directly with all the objectsin the workspace. For example, you
can edit, run, search, or regenerate awindow using its pop-up menu in the
System Tree. In this exercise you reposition, close, and open the System Tree.
You can reposition the System Tree in relation to the main window using its
drag bar. You can also change the way the System Tree, Clip, and Output
windows are arranged.

1 Click the Output button in the PowerBar to display the Output
window.

2 Select Tools>System Options from the menu bar.
Clear the Horizontal Dock Windows Dominate check box on the
General page and click OK.

The System Tree and Clip windows now occupy thefull height of themain
window.

3 Click and hold the drag bar at the top of the System Tree.
Drag the System Tree to position it above, below, or to the right of the
painter workspace.

The painter workspace isthe gray (blank) area, initially to the right of the
System Tree, where painters display when you open an object.

When you start dragging the System Tree, agray rectangular outline
displays. It indicates the area that the System Tree would occupy if you
released the mouse button.
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Lesson 2 Customizing the PowerBuilder Environment

=

Clip

Getting Started

b

EysTree

=

Clukput

5

8

When the gray rectangular outline is positioned where you want the
System Tree to display, release the mouse button.

The System Tree displays in the new location.

Close the System Tree by clicking the SysTree button in the
PowerBar.

The current workspace remains open, but the System Tree closes. Closing
the System Tree leaves more space for the painter workspace views.

Reopen the System Tree by clicking the SysTree button in the
PowerBar again.

Select Tools>System Options from the menu bar.
Select the Horizontal Dock Windows Dominate check box on the
General page and click OK.

You change back to the default selection for this design-time property.

Close the Clip and Output windows by clicking their buttons on the
PowerBar or by clicking the small x in the corner of each window.

Right-click MyWorkspace and select Close from the pop-up menu.

The workspace closes. No workspaces display in the System Tree.
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Open an object

Open an object

Where you are

Manipulate the System Tree window
> Open an object

Manipulate views

Set up the toolbars

Now you open an object created by the Template Application wizard.

1 Select File>Recent Workspaces from the menu bar, then
MyWorkspace from the cascading menu.

2 Inthe System Tree, expand MyWorkspace, the pbtutor target, and
pbtutor.pbl.

3 Double-click the pbtutor Application object
or
Right-click the pbtutor Application object and select Edit from the
pop-up menu.

The Application painter opens. It displays different views of the pbtutor
Application object. Your view layout scheme may look different. To
display the default layout, select View>Layouts>Default.

pbtutar 1= open { string comm B E General | Toolbar
i *
{* open: Application Open Script:
i 1) Opens frame window
i ] DisplayMamne
f* This prevents double toolbars *} MicroHelpDef ault
this.ToolBarFrameTitle = "MDI Application Toolbar" |
this.ToolBarSheetTitle = "MDI Application Toolbar" DhMassageTitls

¥ Open MDI frame window *}

Open [ w_pbtutor_frame ) DDETimeout

0 ~
¥

[IrightToLeft

[CIFresDEBLibraries

Additional Properties

£ [ | >
open AEvent List WFunction List aDeclare Instance Variables |4Properties AMon-Wisual Object List

52 PowerBuilder



Lesson 2 Customizing the PowerBuilder Environment

The default Application painter layout displays two stacks of tabbed
panes. Theleft stack containstabsfor a Script view (Open tab—it isset to
the Open event on the Application object), an Event List view, a Function
List view, and the Declare Instance Variables view. The right stack
contains tabs for the Properties view and a Non-Visual Object List view.

4  Look at the code in the Open event in the Script view.

The Power Script code that was generated by the wizard in the Application
Object Open event calls a PowerScript function to open the main window
in the application. You will modify this code later in the tutorial.
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Manipulate views

Manipulate views

54

Where you are
Manipulate the System Tree window
Open an object
> Manipulate views
Set up the toolbars

Now you learn to control the location and appearance of PowerBuilder painter
views. You can add views to a painter workspace by selecting them from the
View menu in the workspace menu bar.

You can add multiple views of the same type and you can combine views into
astack of panes with selection tabs at the bottom. You can resize aview by
grabbing and dragging the separator bars that surround it or that surround
neighboring views in the painter workspace.

These exercises demonstrate how you can change the appearance of
Application painter views, but you can manipulate viewsin all paintersin the
same way.

Now you:

e Add an extra Script view

e Display view title bars

»  Float and dock views

e Manipulate tabbed views

e Saveaview layout scheme

»  Reset the default view layout scheme
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Add an extra Script view

Getting Started

The default Application painter layout actually has two Script views. One of
the Script views displays the script for an Application object event, and the
other Script view displays the declared variables for the object instance or the
entire application. Both of these Script views are in the same stack of tabbed
views (panes).

Now you add athird Script view that isnot part of astack of tabbed panes. You
can add multiple Script views to your painter layout, but no two Script views
can display the same script at the same time.

1 Select View>Script from the menu bar.

A new Script view displays. It isnot attached to a stack of tabbed panes. It
lists the Application object in the left drop-down list box. The other two
drop-down lists are empty and the right drop-down list is grayed out.

. phtutor, (pbtutor) (C:¥Program FilesiSybaseiPowerBuilder 11.05Tutorialip. .. [Z”E|g|

pbtutor inherit{m]Ed

pbtutar * || = open { string comm % =l General | Toolbar
i * el ~
{* open: Application Open Script:
i 1) Opens frame window
i ] DisplayMamne
f* This prevents double toolbars *} — | MicroHelpDefault

this.ToolBarFrameTitle = "MDI Application Toolbar"
this.ToolBarSheetTitle = "MDI Application Toolbar" v/ | pymessageTitle
< ¥ b
open AEvent List WFunction List aDeclare Instance Variables Properties Akon-Visual Object Lisk

pbtutar w v El = |I

If an existing Script view shows the Open event, the new Script view is
empty. Otherwise it displays the Open event.

2 Select the Close event from the second drop-down list box.

If another Script view isalready open to the Close event, an error message
displaysin the PowerBuilder status bar.
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Display view title bars

Now you display aview title bar by pinning it to the painter workspace
background. If atitle bar is unpinned, you seeit only when your cursor pauses
near the top edge of aview.

Move the cursor to the top of the extra Script view you just added.

The view title bar rolls down. It contains a pushpin button on the left and
a maximize/minimize button and a close button on the right. The name of
theview displays on theleft side of thetitle bar, next to the pushpin button.

Click the pushpin in the title bar
or
Right-click the view title bar and click Pinned from the pop-up menu.

The pushpin button and the Pinned menu item are toggle switches. You
can click the pushpin button or the pop-up menu item to pin and unpin the
view title bars.

Float and dock views

Now you float and dock a view in the painter workspace. Floating aview
enables you to move it around outside the painter frame.

56

Right-click the title bar of an unstacked view you want to float
or
Right-click the tab of a view in a stack of tabbed panes.

If thetitle bar isnot pinned, movethe cursor over thetitle bar areaand wait
until it displays before you right-click it.

Click Float in the pop-up menu.

When aview isfloated, the Float menu item is not enabled. When aview
is docked, the Dock menu item is not enabled.

Drag the view around the screen.

Notice that the floating property allows you to move the view outside the
painter workspace.
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Right-click the title bar of the floating view.
Click Dock in the pop-up menu.

The view returnsto its original location.

Manipulate tabbed views

Getting Started

Now you separate a view from a stack of tabbed panes and place it above the
stack. You then return it to the stack and change its position in the stack.

Press and hold the mouse button on the Function List tab.

Drag the tab onto the separator bar that separates the two default
stacks in the Application painter.

Release the mouse button.

When you rel ease the mouse button, the Function List view isno longer
part of astack. If you drag thetab too far and releaseit over theright stack
with the Properties view and Non-Visual Object List, the Function List
becomes part of that stack.

Alternate way to float a view from a stack
If you hold the Ctrl or Shift key down as you drag a tabbed pane from a

stack, the pane becomes a floating view.

Press and hold the mouse button on the Function List title bar.
Drag it over the stack from which you separated it.

Release the mouse button when the gray rectangular outline of the
Function List view overlaps the stack.

The Function List view returnsto its original stack, but it is added asthe
last pane in the stack.

Press and hold the mouse button on the Function List tab.

Drag it sideways over the other tabs in the same stack.

Release the mouse button when the small gray rectangular outline
overlaps another tab in the stack of tabbed panes.

The Function List view moves to the position in the stack where you
release the mouse button.
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Save a view layout scheme

You can save view layout schemes for a PowerBuilder painter and use them
every time you open the painter.

1

Arrange the views in the painter as you like.
Select View>Layouts>Manage from the menu bar.
Click the New Layout button in the Layout dialog box.

Enter a name for your layout in the text field, click the background of
the dialog box, and then click the x button in the upper right corner of
the dialog box to close it.

Your layout scheme is saved. Now, when you select View>Layouts, you
see your layout listed on the cascading menu.

Saving the toolbars and System Tree layouts
PowerBuilder saves the customizations you make to the toolbars and

System Tree separately from the view layout. It retains those settings and
reapplies them to every workspace you access and every view layout you
select.

Reset the default view layout scheme

Each PowerBuilder painter has adefault view layout scheme. You can always
reset the layout scheme to this default layout.

1

2

58

Select View>Layouts from the menu bar.

Choose Default from the cascading menu.

The default view layout scheme displays in the painter workspace.
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Set up the toolbars

Where you are
Manipulate the System Tree window
Open an object
Manipulate views
> Set up the toolbars

A painter workspace always includes the PowerBar and other PainterBar
toolbars that you can use as you work. The buttons in the toolbars change
depending on the type of target or object you are working with. You can also
customize the toolbars to include additional functionality.

Now you change the appearance of the toolbars to:
e Show labels on toolbar buttons
e Float thetoolbars

*  Reposition the toolbars

Show labels on toolbar buttons

Getting Started

You can learn atoolbar button’s function by placing the cursor over it to view
its PowerTip. A PowerTip is pop-up text that indicates a button’s function.

You can also display alabel on each toolbar button.

1 Move the pointer to any button on the PowerBar, but do not click.

The button’s PowerTip displays.

|cie &

J]

2 Select Tools>Toolbars from the menu bar.

The Toolbars dialog box displays.

3 Select the Show Text check box, then click the Close button.

PowerBuilder displays alabel on each of the buttonsin the PowerBar and
the PainterBars.
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Set up the toolbars

Float the toolbars

You can float the toolbars so that you can move them around the painter
workspace as you work.

1 Right-click anywhere in the PowerBar.

The pop-up menu for the tool bars displays. From the pop-up menu you can
set thetoolbar’slocation to thel eft, top, right, or bottom of the workspace.
You can also set it to floating.

PainterBarz

Left

Top
Right
Battorn
Floating
Customize. ..
Mew. ..

Show Text

Show PowerTips

About pop-up menus
Throughout PowerBuilder, pop-up menus provide afast way to do things.

The menu items available in the pop-up depend on the painter you are
using and where you arein the workspace when you click the right mouse
button.

2  Select Floating from the pop-up menu.

The PowerBar changes to afloating toolbar. You can adjust its shape.

PowerBarl

rﬁbeﬂ%@@}@@@ms_z

Hew Inhert Open  Prewiew | Sy=Tres | Ouwpi TaDalist Brawser  Glip  Libmry DB Pl
EJ = | E 01 ah =] L~ L7 ﬁ % »* * “4'
Sre Pral  Databese Edit 1. Buikd F. Buik Deplay Debug Sel Dby Run Sel Run Exit
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3 Move the pointer to an edge or border area in the PowerBar.
Press and drag the PowerBar toward the left side of the workspace.
Release the mouse button when the PowerBar becomes avertical bar.

5 MyWorkspace - PowerBuilder

File Edit Wiew Insert Design Run  Tools

i P @ £ F

[

x
5
I \[2 & Mywiorkspace (CiProgram Fiss)
" =@ pbtutor {C:Program File
o == phtutor.pbl (C:iFrogram

window  Help

g B G B B B O

ampile  Pate Fun P30l PaleSt PGl

& pbtutor
m_pbtutor_frame
| m_pbtutor_shset
& n_pbtutor_shestmar
1 w_customers

9 w_pbhutor_sbout
9 w_pbhutor_bassshes
9 w_pblutor_Frame
& 9 w_pblutor_toolbars
o 9 w_products

<

{* open: Application Open Script:
n 1) Opens frame window

{* This prevents double toolbars *

*t

this.ToolBarFrameTitle = "MDI Application Tool

this.ToolBarSheetTitle = "MDI Appli

Toolt

DisplayMame

MicroHelpDeFault

{* Open MDI frame window *}
Open [w_pbtutor_frame )

¥

o

DDETimeouk

]

[ RightTal sft
[IFrecDBLibraries

Additional Properties

Mopen 4Event ListiFunction List yDeclare Instance Variables £

7 |« I\Properties Ahon-visual ¢ * |

Nothing Se

lected

The PowerBar is docked at the |eft side of the frame.

Reposition the toolbars
You can customize the position of the toolbars to suit your work style.

Getting Started

1 Select Tools>Toolbars fr

om the menu bar.

The Toolbars dialog box displays. The selected Move radio button
indicates the position of the currently selected toolbar.

Toolbars
Select Toolbar:

; Move
PainterBar1 @ Left
PainterBar2 O Top

O Right

O Bottom

() Floating
Show Text Show PowerTips
Contemporary Style
Font Mame: Font Size:
| Small Foriks v| | 3 v|

X
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Click Top.
This repositions the PowerBar at the top of the workspace.

Radio buttons are grayed if a selected toolbar is hidden
If aselected toolbar ishidden (not visible) inthe painter, you cannot select

where it appears in the workspace. In this case, the radio buttons are
grayed and you must first click the Show button before you can select a
radio button. The Show button replaces the Hide button when atoolbar is
hidden.

Click PainterBarl in the Select Toolbar list box and select Right.
Click Close in the Toolbars dialog box.

Right-click PainterBar2 and select Left from the pop-up menu.

You have swapped the locations of the two painter bars.

Arrange the toolbars to suit your preferences.

You can also drag the toolbars to the top, bottom, left, or right of the
painter workspace. When atoolbar isin afixed location, it has adrag bar
at the left or top of its buttons. You can click the drag bar and drag the
mouse to move the toolbar around the painter workspace.

PowerBuilder applies toolbar configuration properties to all painters and
saves them for the next PowerBuilder session.

Close the Application painter.

If you are not continuing immediately with the tutorial
You can close PowerBuilder or thetutorial workspaceif youwant. Inthat case,

you must open the tutorial workspace before you continue with the next lesson.
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LESSON 3

Getting Started

Building a Login Window

Windows are the main interface between users and PowerBuilder

applications. Windows can display information, request information from
a user, and respond to mouse or keyboard actions.

Windows are separate objects that you create using the Window painter.
In PowerBuilder, you can create windows anytime during the application
development process.

In this lesson you:

Create a new window

Add controls to the window

Change the tab order on the window

Code some Help events and preview the window

Write the script to open the window

How long does it take?
About 25 minutes.
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Create a new window
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Where you are
> Create a new window
Add controls to the window
Change the tab order on the window
Code some Help events and preview the window
Write the script to open the window

Now you create a new window for the application. Thewindow you createisa
login window that allows the user to enter auser 1D and password and connect
to the database. The login window is a response window.

About response windows o )
Response windows are dialog boxes that require information from the user.

Response windows are application modal. When a response window displays,
it isthe active window (it has focus) and no other window in the applicationis
accessible until the user responds. The user can go to other applications, but
when the user returns to the application, the response window is still active.

1 Click the New button in the PowerBar.

The New dialog box displays.

Click the PB Object tab.
Select the Window icon and click OK.

The Window painter opens. Notice that you have two new toolbars, the
StyleBar (with character style and text alignment buttons) and PainterBar3
(with color and border buttons, as well as grayed out control alignment
buttons).

3 Make sure that the Layout view and the Properties view display in the
Window painter.

You can display these views by selecting them from the View menu. If
they are grayed out in the menu, the views are already displayed in the
painter.

The default view layout scheme contains both views.
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Getting Started

To retrieve the default painter layout
Select View>L ayouts>Default from the workspace menu bar.

Therectangleinthe Layout view represents the window you are building.
The default properties in the Properties view indicate that the window is
visible and enabled, and has the Main window type. You might need to
scroll down in the Properties view to see the window type.

EE&

W (Untitled) {pbtutor) inherited from window - Window:

Visible
Enabled

[#] ContralMenu
[#] MancBione
[ MinBox
[C]clientEdge

[CrightTaLeft
[#]centar
[“] resizable

WindowType

| main! v
Windowstate

3 3 | normalt ~ =

Layout {open jEvent List jFunction List Declare Instance Variables |« Isproperties 4Control List jfon-, > |

If your window does not have a pegboard look .
If thewindow inyour Layout view displaysasasolid color, the Show Grid

option has been disabled. To enableit, select Design>Options from the
menu bar. Then select the Show Grid check box on the General page of the
Optionsdialog box. Click Apply, then OK to save the change and closethe
dialog box.
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Type Wl cone in the Title text box on the General page of the
Properties view.

Select r esponse! in the Window Type drop-down list box.
Make sure the TitleBar and ControlMenu check boxes are selected.
Select the ContextHelp check box.

The ContextHelp property adds a question-mark button next to the
(ControlMenu) close button in the login window’s title bar. Users of your
application can click the question-mark button to trigger Help events for
the window controls. You can add a question-mark button to a response
window, but not to a main window.

Click the Other tab in the Properties view.
Type 2300 in the Width text box and 1000 in the Height text box.
Press the Tab key.

The size of the window rectangle in the Layout view changes. The values
you type are in PowerBuilder Units (PBUs). You might need to modify
these values later, while you are adding controls to the window.

Other methods for entering position properties
You can use the spin controls to enter values instead of typing them.

Alternatively, you can change the size of the login window in the Layout
view by moving the pointer to the bottom or right edge of the window.
When it turns into a double-headed arrow, you can drag the arrow to
change the window size.

Select File>Save from the menu bar.

The Save Window dialog box displays. Theonly library in the Application
Librariestext box is pbtutor.pbl, and it is selected.
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8 Type w_wel cone for the window name.

The prefix w_is standard for windows.

Save Window rz|
Windows:
Ok
| w_welcome |
w_customers
w_pbtutor_about
w_pbtutor_baseshest
w_pbtutor_frame
w_pbtutor_toolbars
w_products
Comments:

Application Libraries:

selPowerBuilder 11,00 Tutorialipbtutor.pl

< | =

9 (Optional) Type the following lines in the Comments text box:

This is theloginw ndow It requires the application
user to enter an | D and a password before continui ng.

These comments are visible in the List view of the Library painter.

10 Click OK.

PowerBuilder saves the new login window. If you expand MyWorkspace,
pbtutor, and pbtutor.pbl in the system tree, you can seew_welcome listed
under it.
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Add controls to the window

68

Where you are
Create a new window
> Add controls to the window
Change the tab order on the window
Code some Help events and preview the window
Write the script to open the window

Controls allow users to interact with PowerBuilder objects, such as windows
and DataWindows. You set properties of these controls and later add script for
control events and functions.

Selecting a control button from the PainterBar You can add controlsfrom
the Insert menu or by selecting a control button in PainterBarl. Unlessyou
customize your toolbars, there is only one control button that appearsin the
PainterBar. When you first open a painter, PainterBarl includes the
CommandButton control button, which hasadown arrow to itsright. Clicking
the down arrow displays a drop-down list of control buttons.

Some of the controls you can select from the drop-down list are described in
the table below:

Button
appearance Control type Use in tutorial
CommandButton Default icon for the control button in
PainterBar1. You add command buttons
S later in this lesson.
Picture To add a picture to the login window.
(2
Picture
PictureHyperlink Not used in tutorial. Its purposeisto
L provide alink to a\Web site.
Picture
PictureButton Not used in tutorid. It is like acommand
button, but it displays a picture aswell as
PctEtn text.
StaticText To add text labels to the login window.
A
Text
StaticHyperLink To provide alink to a Web site.
A
Text
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Button
appearance Control type Use in tutorial
SingleLineEdit To add user entry text boxes to the login

E window.

EngleEdit

: MultiLineEdit Not used in tutorial. Its purposeisto add a
L multiline edit text box.
PAultiE dik

After you select acontrol, it appearsin place of the CommandButton button on
PainterBarl.

Adding controls with a 3D appearance
To make your controlslook three dimensional, select Design>Optionsfrom the

menu bar and make sure that the Default To 3D check box is selected on the
General page of the Options dialog box. You can change the window
background color from the default color of ButtonFace gray using the
Properties view in the Window painter.

Now you modify the login window you just created by adding controls and
changing some of their properties. You:

* Add aPicture control

* Add StaticText controls

«  Specify properties of the StaticText controls

e Add SingleLineEdit controls

e Specify properties of the SingleLineEdit controls
*  Add CommandButton controls

«  Specify properties of the CommandButton controls
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Add a Picture control

Now you add a Picture control to the login window.

- 1 Select the Picture button from the drop-down list of controls
Rl or

Ficturs Select Insert>Control>PictureButton from the menu bar.

2 Click inside the rectangular window in the Layout view.

A Picture control displays at the selected location. At the same time you
add the control, the Properties view switches from displaying the window
properties to displaying the control properties.

If you do not see the Properties view, select View>Properties from the
menu bar. If the Properties view does not display the control properties,
click the picture control in the Layout view.

How to delete controls ) ) )
If you add a control to the window and later decide you do not want it,

select the control and pressthe Delete key. This deletesthe control and its
scripts.

3 Select the text p_1in the Name text box on the General tab of the
Properties view.
Type p_sports in the Name text box.

This names the Picture control. The prefix p_is standard for Picture
contrals.

4  Click the ellipsis button next to the PictureName text box.

The Select Picture dialog box displays.

5 Navigate to the Tutorial directory if it is not already selected.
Select the tutsport.omp file.

The bitmap you selected appears in the control you added to the Layout
view. The Visible, Enabled, and Original Size check boxes are selected by
default in the Properties view.
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6 Make sure the picture control is selected in the Layout view.
Click the Other tab in the Properties view.
Type 40 in the X text box and 50 in the Y text box.

You can use the spin controlsinthe X and Y text boxes to enter these
values. You might want to adjust the position of the picture control again
after you preview the window at the end of thislesson.

7 Type 300 in the Width text box and 250 in the Height text box.

You change the size of the picture control. You might want to adjust the
picture size again after you preview the window.

| General | Other
~
= Position
*
[40 3|
i
[50 3|
‘Wwidth
[ 300 3|
Height:
[ 250 3|
= Pointer
Painter
| vl &
Layout dopen AEvent Lisk 4Function List hDeclare Instance Variables _;l\Properties Control List kMon-Visual ObgI

Add StaticText controls

Now you add StaticText controls to the login window. You will use these
controls to add descriptive labels to the login window.

A 1 Select the Text button from the drop-down list of controls
or

e Select Insert>Control>StaticText from the menu bar.

2 Click to the right of the Picture control you added in the Layout view.

A StaticText control displays at the selected location.
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3 Right-click the StaticText control and select Duplicate from the
pop-up menu.

PowerBuilder creates a duplicate of the selected control.

4  Select Duplicate from the StaticText control’s pop-up menu again.
PowerBuilder creates another duplicate.

You now havethree StaticText controlsarranged vertically at thetop of the
window.

5 Adjustthelocation of the Static Text controls so that there are at least
two grid lines between them.

Specify properties of the StaticText controls

Now you specify the properties of the StaticText controls (Iabel text boxes) to
define how they should appear on the login window.

1 Select the first StaticText control you added by clicking on it.

The Propertiesview displays properties of the StaticText control. If you do
not see the Properties view, select View>Properties from the menu bar.

2 Select the text st_1 in the Name text box on the General page of the
Properties view.
Type st _wel cone in the Name text box.

Now the control has a more descriptive name. The prefix st_ is standard
for StaticText controls.

3 Select the text none in the Text text box.
Type Wl come to SportsWar, Inc.

If you press Enter, click to another field or tab to another pagein the
Properties view, or click in adifferent view, the text you typed replaces
none in the Layout view.
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Getting Started

Click the Font tab in the Properties view.
Change the TextSize property for this control to 18 points.

The size of the text in the control changes.

Thedefault typefaceis Arial TrueType. You can select adifferent typeface
and font size if this oneis not available on your system.

Using the StyleBar
You can also use the StyleBar to change fonts. If you do not see the

StyleBar, select Tools>Toolbars from the menu bar, click StyleBar in the
Select Toolbar list box, and then select one of the Move positions such as
bottom or floating.

Adjust the size of the StaticText control to fit the text you entered.
Keep adjusting the size until you see all of the text you entered.

To adjust the size, drag the upper-right corner of the control toward the
upper-right corner of the window in the Layout view. You can also adjust
the size by entering appropriate values on the Other page of the Properties
view for this control.

Select the second StaticText control you added in the Layout view.
Type st _useri dinthe Name text box on the Properties view General

page.
Type User | D: in the Text text box and press the Tab key.

Thetext displayed in the control changes.
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7 Select the third StaticText control you added in the Layout view.
Type st _passwor d in the Name text box on the Properties view
General page.

Type Passwor d: in the Text text box and press the Tab key.

Your changes display in the Layout view.

B w_welcome * (pbtutor) (C:\Program Files\SybasePowerBuilder 11.0%Tutorialipbt

Layout dopen AEvent Lisk 4Function List hDeclare Instance Variables
-

Add SingleLineEdit controls

Now you add two SingleLineEdit controls to the window to alow the user to
enter auser ID and password for connecting to the database. A SingleLineEdit
control isatext box in which the user can enter asingle line of text.
SingleLineEdit controls are typically used for the input and output of data.

or

i= 1 Select the SingleLineEdit button from the drop-down list of controls
el Select Insert>Control>SingleLineEdit from the menu bar.

2 Clicktotheright of the st_userid StaticText control in the Layout view.

A SingleLineEdit control displays where you clicked.

3 Increase the width of the SingleLineEdit control.
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Right-click the SingleLineEdit control and select Duplicate from the
pop-up menu.

Adjust the position of this SingleLineEdit control so that it is just to
the right of the st_password StaticText control.

You should now have two SingleLineEdit controls arranged vertically to
the right of the StaticText controls.

B w_welcome * (pbtutor) (C:\Program Files\SybasePowerBuilder 11.0%Tutorialipbt

Password:

Layout dopen AEvent Lisk 4Function List hDeclare Instance Variables

Specify properties of the SingleLineEdit controls

Getting Started

Now you define the properties of the SingleLineEdit controlsyou just added to
the login window.

Select the first SingleLineEdit control you added.

The General page of the Properties view displays properties of the
SingleLineEdit control. If you do not see the Properties view, select
View>Properties from the menu bar.

Select the text sle_1 in the Name text box.
Type sl e_useri d in the Name text box.
Clear the default text none in the Text text box.

The prefix sle_is standard for SingleLineEdit controls.
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3 Select the second SingleLineEdit control you added.
Type sl e_passwor d in the Name text box.
Clear the default text none in the Text text box.
Select the Passwor d check box.

Because you checked the Password check box, the password the user types
at runtime will display as a string of asterisks.

Add CommandButton controls

Now you add CommandButton controls. Later you define scripts that execute
when users click these buttons.

1 Select the CommandButton button from the drop-down list of
controls

Eutton
or

Select Insert>Control>CommandButton from the menu bar.

2 Click to theright of the sle_userid SingleLineEdit control.

A CommandButton control displays where you clicked.

3 Right-click the CommandButton control and select Duplicate from the
pop-up menu.

PowerBuilder creates a duplicate of the selected control.

4  Adjust the location of the controls as needed so that there is some
space between them.

Specify properties of the CommandButton controls

Now you define the properties of the CommandButton controls.

1 Select the top CommandButton control.

The General page of the Properties view displays properties of the
CommandButton control.
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Getting Started

Type cb_ok in the Name text box on the Properties view General page.
Type OKin the Text text box.
Select the Default check box.

This step changes the default name of the control to something more
descriptive and adds atext label (OK) to the button. Because you selected
the Default check box, when an application user pressesthe Enter key, the
Clicked event for this button will be triggered. (The user does not have to
click the button itself for the event to be triggered.)

Select the bottom CommandButton control.
Type cb_cancel in the Name text box.
Type Cancel in the Text text box.

Select the Cancel check box.

Because you selected the Cancel check box, when an application user
presses the Esc key, the Clicked event for this button will be triggered.

B w_welcome * (pbtutor) (C:\Program Files\SybaseiPowerBuilder 11.0%Tutorialkpbtut

Layout 4open AEvent Lisk 4Function List hDeclare Instance Variables
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Change the tab order on the window
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Where you are
Create a new window
Add controls to the window
> Change the tab order on the window
Code some Help events and preview the window
Write the script to open the window

When you place controlsin awindow, PowerBuilder assignsthem adefault tab
order. The tab order determines the sequence in which focus moves from
control to control when the user presses the Tab key.

Now you change the tab order for the window you created.

1 Select Format>Tab Order from the menu bar.

PowerBuilder displaysthe default tab order. The number inred at theright
of each control shows the control’s relative position in the tab order.
Controls with the number zero are skipped when the user tabsin the
window.

2 Click the tab order number for the sle_userid control.
Type 10 if the tab order value for this control is not already 10.

You can type anew tab order number only when the old number turns blue
against a red background.

3 Make changes as needed so that the other controls have these

values:
Click this control Control name | Has this value
SingleLineEdit control for entering a sle_password 20
password
CommandButton control for the OK cb_ok 30
button
CommandButton control for the Cancel | cb_cancel 40
button
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Getting Started

Select Format>Tab Order from the menu bar.

Thisisatoggle switch. Selecting this menu item a second time saves your
changes and clearsthe tab order numbers from thelogin window. You can
also use the Tab Order button on the PainterBar.
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Code some Help events and preview the window

Where you are

Create a new window

Add controls to the window

Change the tab order on the window
> Code some Help events and preview the window

Write the script to open the window

Now you use the Script view to add context-sensitive Help messages to the
SingleLineEdit controlsthat you placed on the login window, and you preview

the window.

Using the Script view The Script view has three drop-down list boxes.
The first drop-down list box displays the list of available controls for the
current object plustwo special entries, Functions and Declare. The contents of
the second drop-down list box depend on the selection in the first drop-down
list box. The third drop-down list box contains all ancestor objects of the

current object, if any.

Selection in first
drop-down list box

Contents of second
drop-down list box

Contents of third
drop-down list box

An object or control
name

List of eventsfor the
selected object or control.

All of the ancestor objects of
the current object, if any

Functions

List of editable functions.
Displays (New Function) if
no editable functions exist.

All ancestor objects with
functions having the same
signature as selected function

Declare

List of declaration types:
global, shared, and instance
variables, and global and
local external functions.

Empty

If the Script view isnot currently displayed in your Window painter, you can
open it by double-clicking an object in the Layout view.

1 Double-click the top SingleLineEdit control in the Layout view.

The object name, sle_userid, appearsin the first drop-down list box inthe

Script view.
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Getting Started

Select the Help event in the second drop-down list box in the Script
view.

The Help event has the prototype: hel p (i nteger xpos, integer
ypos) returns | ong [ pbm hel p]

Type the following line of PowerScript code in the script area:
ShowPopupHel p("pbtutor. hl p", this, 100)

You can find the pbtutor.hlp file in the Tutorial directory. The second
argument refers to the current SingleLineEdit control, and the last
argument refersto a context 1D in the pbtutor.hlp file.

[#® Script - help For sle_userid returns lang
sle_userid w help { integer xpos, integer ypos B E
ShowPopupHelp['pbtutor.hlp", this, 100)

< ¥
Layvout yhelp AEvent List AFunction List hDeclare Instance Variables

Asyou typetext in the Script view, notice that PowerBuilder changes the
text colorsto show what kind of syntax element you have entered (such as
keywords, variables, and comments).

Select sle_password from the first drop-down list box in the Script
view.
Select the Help event in the second drop-down list box.

PowerBuilder compiles the code you typed for the Help event of the
sle_userid SingleLineEdit text box. You now add a Help event for the
sle_password SingleLineEdit text box.

Type the following lines in the script area:

ShowPopupHel p("pbtutor. hl p", this, 200)

Select File>Run/Preview from the menu bar
or
Click the Run/Preview Object in the PowerBar.

The Run dialog box displays. Be sure the Objects of Typelist box displays
Windows and the w_welcome object is selected.
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10

Previewing the window ) ] ] )
You can preview the window without running scripts by selecting

Design>Preview on the menu bar or the Preview button in PainterBarl
(which uses the same icon as the Run/Preview Object button in the
PowerBar). However, you must run scripts to view the results of the Help
event scripts you just entered.

Click OK.

A message box prompts you to save your changes.

Click Yes.

The login window appears as it would at runtime. If you do not like the
window layout, you can changethe si ze, location, and fonts of the window
controls when you go back to the Window painter workspace.

Welcome E]@

@, \Welcome to Sportswear, Inc.

User ID: L |
Passwords | |

Click the question-mark button in the login window title bar.
Click inside the sle_userid SingleLineEdit text box.

A message displays: Type your user |D here. Thistext isassociated
with context ID 100 in the pbtutor.hlp file. You entered the context ID as
an argument of the ShowPopupHelp call for the sle_userid Help event.

Click anywhere in the window to close the message.
Click inside the sle_password SingleLineEdit text box.
Press F1.

A message displays: Type your password here. Thistext isassociated
with context ID 200 in the pbtutor.hip file.
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Getting Started

11

12

Click anywhere in the window to close the message.
Click the close button in the login window title bar.

You return to the Window painter workspace.

Later you add code to the Clicked event for the Cancel button that closes
the application.

Close the Window painter by clicking the close button in PainterBar 1.

The close button is labeled with an x.
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Write the script to open the window
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Where you are

Create a new window

Add controls to the window

Change the tab order on the window

Code some Help events and preview the window
> Write the script to open the window

Now you add a one-line script to open the login window as soon asthe
application starts executing. Although you could change the script in the
Application object Open event to open the login window, in this tutorial you
make the call to open the login window from the Open event of the MDI frame
window. Thiswindow (w_pbtutor_frame) was created by the Template
Application wizard.

In wizard-generated script, the frame window is called by the Application
object Open event. When you add a call to open the login window from the
MDI frame window Open event, the login window still displays before the
frame window. Because the login window is aresponse window, it temporarily
blocks execution of the remainder of the frame window Open event script.

In this exercise you:
*  Modify the frame window Open event

»  Compilethe script
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Modify the frame window Open event

Getting Started

Now you modify the frame window Open event script to open the login
window.

Wizard-generated script
The frame window Open event already has a script associated with it that was

generated by the Template Application wizard. The script creates an instance
of awizard-generated user object that servesasasheet (window) manager. The
Open script then calls the ue_postopen event.

The ue_postopen event registers sheet windows with the sheet manager. The
event is posted to the end of the messaging queue for the window and is not
processed until the remainder of the Open script (that you add in thislesson) is
executed.

1 Select File>Open from the menu bar.
Make or verify the following selections in the Open dialog box:

Open dialog box item | Selection to make (or verify)
Target pbtutor—currently your only target

Libraries pbtutor.pbl—currently your only library; if you
cannot see the full library name, you can drag the
edge of the dialog box to increase its size

Object Name w_pbtutor_frame

Objects of Type Windows—you must make sure thisis selected
before you can select a named object of thistype

Using Painter

Thew_pbtutor_frame object is the main application window created by
the Template Application wizard.

2 Click OK.

The Window painter opens and displays views of the main application
window in the painter workspace.

If the Script view isnot open, you can open it by selecting View>Script in
the workspace menu bar or by double-clicking inside the Layout view.
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3

Move the cursor to the top of the Script view.

The view title bar rolls down. It contains a pushpin button on the left and
a maximize/minimize button and a close button on the right.

Click the pushpin in the title bar of the Script view.
Thetitle bar of the Script view reads:

Script - open for w pbtutor_frane returns |ong

Make sure the Open event displays in the Script view.

[ 5cript - open For w_pbtutar_frame returns long

w_pbtutor_frame || 1= open () returns long [pbr_op » = E
i =t
I open: Create sheet manager and post event
i =t

string Is_sheets]]

f* Create an instance of the sheet manager */
inv_sheetmgt = Create n_pbtutor_sheetmanager

this.Post Event ue_postopen []
< >
Lavout jopen 4Event List yFunction List yDeclare Instance Yariables
=

The PowerScript code in the Script view is preceded by comments.

Using comments
A comment in PowerScript isindicated by either two forward slashes (//)

at the start of a single-line comment, or a slash and an asterisk (/*) at the
start and an asterisk and aslash (*/) at the end of asingle-line or multiline
comment. Comments are not parsed by the script compiler.

You now modify the Open event script to cause the login window to
display.

Click after the parentheses in the line that reads:
this. Post Event ue_postopen ( )

The ue_postopen event does not take any arguments.

Press Enter twice.

Thisadds ablank line in the Script view for legibility. The cursor moves
to anew linefollowing the blank line.
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Comment

Type Open the | ogi n wi ndowon the new line in the Script view.
Click the Comment button in PainterBar2.

Two dashes appear in front of the line you typed—it is changed into a
comment.

Move the cursor to the end of the comment.
Press Enter to add a new line.
Type open (w_wel cone) on the new line.

This calls the Open function to display the login window you created.

[¥% Script - open For w_pbtutor_frame returns long

w_pbtutor_frame “ || 2 open () returns long [pbm_open] =
string Is_sheets[]

» (I}

I* Create an instance of the sheet manager *f
inv_sheetmgt = Create n_pbtutor_sheetmanager

this.Post Event ue_postopen []

H{Open the login window
open [w_welcome]

£ >
Layout sopen AEwent List 3Function List ,Declare Instance Yariables
P

Accessing context-sensitive Help ]
To access context-sensitive Help for afunction or reserved word (such as

Open), select the function or reserved word in the Script view and press
Shift+F1. You can always open the main Help screen by pressing F1.
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Compile the script
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Now you compile the script you just typed. In this exercise, you use a pop-up
menu item to compil e the script. PowerBuilder al so compilesascript when you
close the Script view or when you select a different object, event, or function
for display in the Script view.

Handling errors in scripts
When thereisan error in ascript, an error window displays at the bottom of the

Script view with the line number of the error and the error message.

To find an error  Click on an error message to move the cursor to thelinethat
containsthat error. After you correct the error, you can try to compile the script
again.

Commenting out errors  PowerBuilder does not save scripts that have
errors. If you want to save a script that has errors, select the entire script and
click the Comment button to comment out the code. You can come back |ater,
uncomment the code, and fix the problem.

1 Right-click anywhere in the Script view script area.
Select Compile from the pop-up menu.

The script compiles. You do not leave the Script view or the Window
painter workspace.

2 Select File>Save from the menu bar.

Select File>Close from the menu bar.

The Window painter closes.
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LESSON 4

Getting Started

Connecting to the Database

Thislesson shows you how to make the application connect to the
Enterprise Application Sample demonstration database (EAS Demo DB)
at execution time and how to use the Database painter to look at the table
definitions and database profile for this database.

In thislesson you:

Look at the EAS Demo DB database
Run the Connection Object wizard
Declare aglobal variable

Modify the connection information
Complete the login and logout scripts

Run the application

How long does it take?
About 30 minutes.
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Look at the EAS Demo DB database

Look at the EAS Demo DB database

90

Where you are

> Look at the EAS Demo DB database
Run the Connection Object wizard
Declare a global variable
Modify the connection information
Complete the login and logout scripts
Run the application

In many organizations, database specialists maintain the database. If thisistrue
in your organization, you might not need to create and maintain tables within
the database. However, to take full advantage of PowerBuilder, you should
know how to work with databases.

Defining a data source Using the ODBC administrator or other database
connection utilities, you can define a database as a data source for your
application. You can access the ODBC Administrator from the DataBase
Profiles dialog box. The definitions of ODBC data sources are stored in the
odbc.ini registry key.

Using database profiles to connect Onceyou defineadatasource, you can
create adatabase profilefor it. A database profileis anamed set of parameters
that specifies a connection to a particular data source or database. Database
profiles provide an easy way for you to manage database connections that you
use frequently. When you are developing an application, you can change
database profiles to connect to a different data source.

When database connections occur PowerBuilder can establish a
connection to the database in either the design-time or runtime environment.
PowerBuilder connects to a database when you open certain painters, when
you compile or save a PowerBuilder script that contains embedded SQL
statements, or when you run a PowerBuilder application that accesses the
database.

To maintain database definitions with PowerBuilder, you do most of your work
using the Database painter. The Database painter allows you to:

e  Create, dter, and drop tables

e Create, dter, and drop primary and foreign keys

e Create and drop indexes

» Define and modify extended attributes for columns

e Dropviews
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In this exercise you:
e Look at the database profile for the EAS Demo DB database
* Look at table definitions in the EAS Demo DB database

Look at the database profile for the EAS Demo DB database

If you installed PowerBuilder with standard options, you aready have adata
source and a database profile defined for the EAS Demo DB database. You use
the EAS Demo DB database in this tutorial.

The EAS Demo DB database is an SQL Anywhere database that is accessed
through ODBC. In this lesson you look at the database profile for the EAS
Demo DB database. PowerBuilder stores database profile parametersin the

registry.
1 Click the Database Profile button in the PowerBar
E2 or
DB Prof Select Tools>Database Profile from the menu bar.

PowerBuilder displaysthe Database Profiles dialog box, which includes a
tree view of theinstalled database interfaces and defined database profiles
for each interface. You can click the + signsor double-click the icons next
toitemsin the tree view to expand or contract tree view nodes.

2 Expand the ODB ODBC node by clicking on the plus sign, and select

EAS Demo DB V110.
PowerBuilder created this profile during installation.
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If you do not see the EAS Demo DB V110 database profile
If there is no profile for the EAS Demo DB V110 database, you may not

have installed the database. You can install it now from the product CD.

If you did install the database and it is defined as a data source in the
ODBC Administrator, select ODBC in the tree view of the Database
Profile painter and click New. In the Database Profile Setup dialog box,
select the data source from the Data Source drop-down list and type EAS
Deno DB V110 inthe Profile Name text box. Typedba for the user ID and

sql for the password, then click OK to return to the painter.

Database Profiles fg
% Installed Database Interfaces Conneck
4 ASE Sybase ASE 15.x
4 DIR Direct Connect
4 IND Informix v3,x
4 0B J0BC
4 ©10 Cracle 10g
4 084 Cracle 85
4 090 Cracle 9
=4 ODB ODEC

{=JEAS Demo DB Y110

4 EAS Demo DE Y110 Unicode
[ Ukilities
4l OLE Microsoft OLE DE
B4 SMC S0L Mative Client
4 5vC Sybase ASE
4 51 Sybase ASE for EAServer
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Getting Started

3

4

Click Edit.

Database Profile Setup - ODBC

X

Network Cptions || EAServer/COM+ || Preview |
Connection | System || Transackion || Synkas
Profile Name: | EAS Demo DB Y110 |

Connect Information

DataSource: | EAS Demo DE Y110 |
User 10 | dba |
Password: | oo |
Driver-Specific Parameters:

Other

Isolation Lewvel: |(Default Driver Behavior) v |
[ AutaCommit Made [CIrrampt For Dakabase Information
Commit on Disconnect [ | Generate Trace

I K H Cancel ]

Select the Preview tab.

PowerBuilder displays the Connection page of the Database Profile Setup
dialog box.
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The PowerScript connection syntax for the selected profileisshown onthe
Preview tab. If you change the profile connection options, the syntax
changes accordingly.

Database Profile Setup - ODBC E|
Connection Syskem Transaction Synkax
Metwark Options EAServer/COM+ Prewiew

Database Connection Svnkax:

11 Profile EAS Demo DE ¥110

SQLCA.DEMS = "CDBC"

SQLCA. AutoCommit = False

SQLCA.DEParm = "ConnectString="DSM=EAS Dema DE ¥110;

Test Connection

< >

Ok l [ Cancel

Click the Test Connection button.

A message box tells you that the connection is successful.

If the message box tells you the connection is not successful
Close the message box and verify that the information on the Connection

page of the Database Profile Setup dialog box is correct. Then check the
configuration of the data sourcein the ODBC Administrator. You can run
the ODBC Administrator by expanding the Utilities folder under the
ODB ODBC node of the Database Profile painter and double-clicking the
ODBC Administrator item.

Click OK to close the message box.
Click Cancel to close the Database Profile Setup dialog box.
Click Close to close the Database Profiles dialog box.
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Look at table definitions in the EAS Demo DB database

1
=
Databasze

Getting Started

Now you look at the definitionsfor the Customer and Product tablesinthe EAS
Demo DB database. This hel psyou become familiar with the Database painter
and the tables you will use in the tutorial.

What happens when you connect Tolook at thetable definitions, you have
to connect to the database. When you connect to adatabase in the devel opment
environment, PowerBuilder writes the connection parameters to the Windows
registry.

Each time you connect to a different database, PowerBuilder overwrites the
existing parametersin the registry with those for the new database connection.
When you open a PowerBuilder painter that accesses the database, you
automatically connect to the last database used. PowerBuilder determines
which database thisis by reading the registry.

Click the Database button in the PowerBar.

PowerBuilder connects to the database and the Database painter opens.
The Database painter title bar identifies the active database connection.

The Objects view of the Database painter displays all existing database
profilesinatreeview under theInstalled Database | nterfaces heading. The
EAS Demo DB V110 database is visible under the ODB ODBC node in
the tree view.

If the Objects view is not open ) )
The Objectsview is part of the default view layout scheme. Toreset to this

scheme, select View>Layouts>Default. You can also open an Objects
view by selecting View>Objects from the menu bar.
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Look at the EAS Demo DB database

2 Expand the EAS Demo DB V110 database node in the Objects view.
Notice the folders under the EAS Demo DB V 110 database node.

n:::ll:ujeu:l:::

E4 ASE Sybase ASE 15.x

2 DIR Direct Connect

B4 IND Informix v3,x

E4 IoE 10BC

E4 010 Oracle 10g

E2 084 Oracle 85

E4 090 Oracle 9

=-E2 ODE ODEC

= ﬁ_é EAS Demo DE Y110

(3 Driver Information

[ Events

(3 Groups

[ Metadata Types

|

=)

|

] ) ]

Procedures & Functions
Tables
Users
[ Wiews
&4 EAS Demo DE Y110 Unicode
(3 Utilities
E2 OLE Microsoft OLE DB
B4 SMC SQL MNative Client
B4 5YC Sybase ASE
E2 3¥1 Sybase ASE for EAServer

3 Expand the Tables folder.
You see thelist of tables in the database.

Table names might have a prefix
The table names in the Select Tables dialog box might have a prefix such

asdba or dbo. This depends on the login ID you are using. You canignore
the prefix.

4  Right-click the customer table and select Add To Layout from the
pop-up menu
or
Drag the customer table from the Objects view to the Object Layout
view.

96 PowerBuilder



Lesson 4 Connecting to the Database

Getting Started

Dragging an object from one view to another ) )
When you start dragging an object from the Objects view to another view,

the pointer changes to a barred circle. If you continue moving the cursor
to aview that can accept the object, the barred circle changes back to a
pointer with an additional arrow symbol in asmall box. When you seethis
symbol, you can release the object.

Repeat step 4 for the product table.

Widening the Object Layout view
You can widen the Object Layout view by dragging its separator bars

toward the painter frame. If the Object Layout view is part of a stack, you
might find it easier to separate it from the stack before you changeitssize.

The Object Layout view shows the two tables you selected.

A list of customers

id Unique Identification number of the customer
frame First name of the customer

Iname Last name of the customer

address Mailing address of the customer

city City where the customer is located

skate State where the customer is locaked

zip Zip Code where the customer is located
phone Phone number of the customer

company_name  Mame of the company

E

id Unique Identification Code of the product —
name Mame of the product
description Describes what the product is
| prod_size Measurements of the product
L color Color of the product
quantity Amount of the product in stock
unit_price: Unit price per product
picture_name  .bmp filename that shows what the product looks like
catalog_picture  Blob containing a catalog picture of the product in RLE format
v

< ¥
Object Layout AExtended Attributes
—
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Viewing table data types, comments, keys, and indexes
In the Object Layout view, you can see a description for each column, as

well asicons for keys and indexes. If you do not see this, right-click a
blank areainside the view and select Show Comments, Show Referential
Integrity, and then Show Index Keys from the pop-up menu. If you select
Show Datatypes, you al so seethe datatype for each column inthe selected
tables.

Right-click the title bar of the customer table in the Object Layout view
and select Alter Table from the pop-up menu

or

Right-click the customer table in the Objects tree view and select Alter
Table from the pop-up menu.

The Columns view displays the column definitions for the table.

Right-click a column in the customer table in the Object Layout view.
Select Properties from the pop-up menu.

In the Database painter, the Properties view is also called the Object
Details view.

Thetitle bar and tab headings for the Object Details view change
dynamically depending on the current object selection. Thetitle bar gives
the abject type, the database connection, and the object identifier.
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The Object Details view for a column has five tabs, one for general
database properties, one for column header information, and the othersfor
column extended attributes.

[#%] Zclurnn (EAS Dema DB ¥110) - custarner:id 0]

General | Headers | Display | Validation | Edit Style

Table:
custormer
Calurn:
id

= Column Details
Colurnn Murnber:

1
Data Type:

integer
Nullable:

Mo
Default:

(Mone)
Comments:

Uniqua Identification number of the cuskomer

About extended attributes ) ) o
PowerBuilder stores extended attributeinformation in system tables of the

database. Extended attributes include headers and labels for columns,
initial values for columns, validation rules, and display formats.

You can define new extended attributes or change the definitions of
existing extended attributes from the pop-up menus of itemsin the
Extended Attributes view of the Database painter.

8 Close the Database painter.
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Run the Connection Object wizard

Run the Connection Object wizard

Where you are

Look at the EAS Demo DB database
> Run the Connection Object wizard

Declare a global variable

Modify the connection information

Complete the login and logout scripts

Run the application

Now you run the Connection Object wizard to create a connection service
manager, which you use to establish the runtime database connection.

The connection service manager is anonvisua user object. It is nonvisual
because it does not have a graphic representation in the runtime application; it
isauser object becauseit isacustomized object. You useit to perform database
connection processing in a PowerBuilder application.

Why you run a second wizard
If you had specified connection information in the Template Application

wizard, you would have created the connection service manager when you
generated the application. You can use multiple wizards in building your
application.

E] 1 Click the To-Do List button in the PowerBar.

Ta-Da List The To-Do List was generated by the Template Application wizard.

M To Do List EHE El

&) phkukor (CriProgram Files)SybaseiPowerBuider 11.0 +

Design Maintain Customers sheet: w_customers
Design Maintain Products sheet: w_products

Create additional new sheets inheriting From
w_pbtutor_baseshest

Reqgister new sheets with the sheet manager service:
n_pbtutor_sheetmanager

Add copyright infarmation ko the About dialog:
w_pbtutor_abouk

Fun Connection Object Wizard For additional
connections

Run the Project Wizard to Build Project
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Getting Started

Double-click the Run Connection Object Wizard item in the list
or

Right-click the Run Connection Object Wizard item.

Select Go To Link from the pop-up menu.

Thisisthe next-to-last itemin thelist. The To-Do List listswhat you need
to do to complete the application. You can also use the list to make
comments to yourself or other developers working on the application.

You can also run the Connection Object wizard from the PB Object page
of the New dialog box. You used the New dialog box to run the Template
Application wizard in Lesson 1, “ Starting PowerBuilder.”

Thefirst page of the wizard tells you what it can do.

Click Next until the Choose Database Profile page displays.

You accept the wizard's default selections for the destination library
(pbtutor.pbl) and the database connectivity options (SQL). The Choose
Database Connection Profile page lists al the database profiles stored in
the registry.

Select EAS Demo DB V110 in the Database Profiles list box if it is not
already selected.

Click Next until the Ready To Create Connection Object page
displays.

You accept the default settings for the following items:

Wizard page Option Default selection
Specify Source of Connection Application INI File
Connectivity Source | Information
Info
Connection Service n_pbtutor_connectservice
Object
Name Application Application INI File pbtutor.ini
INI File

The wizard creates the n_pbtutor_connectservice user object to manage
your database connections. If you change an instance variable in this
connection service object, you can change the source of connection
information to the registry or to a script file. Otherwise, the pbtutor.ini
file—created by the wizard—is used for application connection
information.
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The last wizard page contains a summary of your choices, including the
default selections.

Ready to Create Connection Object

A Connection Object with the Following characteristics will be created

or generated. Click Finish when you are ready.

Properky

Current Application
Application Library
Library Search Path
Selected Library
Connectivity To?
Database Profile
Connection Cbject
Connection Source
INI File

<

Walue
phtutor

C:\Program Files!Svbase\PowerBuilder 11.04T)
C:\Program Files!Svbase\PowerBuilder 11.04T)
C:\Program Files!Svbase\PowerBuilder 11.04T)

a0L Database

EAS Dema DE Y110
n_pbtutor_connectservice

IMI File

C:\Program Files!Svbase\PowerBuilder 11.04T)

£l

Generate To-Do List

< Back ] [

Finish

] [ Cancel

Click Finish.

The wizard creates the connection service object and opensit in the User
Object painter. You can seen_pbtutor_connectservicein the System Tree.
The wizard also creates the application INI file. The To-Do List is still

open.

Close the To-Do List.
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Declare a global variable

Getting Started

Where you are
Look at the EAS Demo DB database
Run the Connection Object wizard

> Declare a global variable
Modify the connection information
Complete the login and logout scripts
Run the application

You will next examinethe new connection service manager and create aglobal
variableto referenceit. A global variable is available to all objectsin the
application.

In more complex applications, you might prefer to reference the connection
service manager with local variables. Thiswould rel ease more memory as soon
asthelocal variable went out of scope. But in the tutorial, you should keep an
instance of the connection service manager available aslong as the database
connection is open.

Establishing a connection  To make it possible for an application to
connect to the database at execution time, the connection service manager calls
awizard-generated function to set properties for a Transaction object that
serves as a communications area between the application and the database.

SQLCA Transaction object The connection service manager uses abuilt-in
nonvisual system object, the SQL Communications Area (SQLCA) object, as
the default Transaction object. The SQLCA object has several default
properties (including database name, login ID, and password) that are
populated by the connection service manager.

If an application communicates with multiple databases, you can create
additional Transaction objects as needed, one for each database connection.

What is required and what is not
You must have a Transaction object to connect to a database. The connection

service manager is not required, but is used in the tutorial because it generates
Transaction object properties you would otherwise have to type in an
application script.
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Declare a global variable

1 Make sure n_pbtutor_connectservice is open in the User Object
painter.

Opening the connection service manager
If the n_pbtutor_connectservice object is not open in the User Object

painter, double-click n_pbtutor_connectservice in the System Tree.

The default view layout scheme for the User Object painter includes a
Script view and a Declare Instance Variables view as part of a stack of
tabbed panes.

2 Make sure n_pbtutor_connectservice is selected in the first drop-
down list box of the Script view.
Make sure the Constructor event is selected in the second drop-down
list box.

The Script view displays the script created by the Connection Object
wizard for the Constructor event.

rns long X
n_pbtutor_connectservice onstruckor {3 returns long [pbm v E‘%

£ *f o
fi* Connection Information is obtained from either:
i - Aan INI File
i - The \Windows Registry
£ - Script
i

/f* The source of connection infar mation can be changed by

/f* altering the value of the 'is_connectfrom' varisble,

£ *f

string ls_dbms, |s_database, ls_userid, 1s_dbpass, ls_logid, ls_logpass
string ls_server, ls_dbparrm, ls_lock, ls_autocormmit

If of_GetConnectionInfo { ls_dbms, ls_database, ls_userid, ls_dbpass, Is_logid, ls_logpass

SOLCA.DEMS = ls_dbrms
SQLCA. Database = Is_database
SOLCA, UserlD = ls_userid
SOLCA.DEPass = ls_dbpass
SOLCA LoglD = ls_logid
SQLCA. LogPass = Is_logpass

SOLCA. ServerMame = ls_server
SOLCA.DEParm = ls_dbparm
SOLCA. Lock = Is_lock
Choose Case Lower ( ls_autocommit )
Case "1", "true”, "on", "yes"
SOLCA AuCommit = True
Casze "0", "falze", "off", "no" ¥
< >
conskruckar dEvent List sFunction Lisk xDeclare Instance Variables

The script calls the function of_GetConnectionlnfo to obtain connection
information. You will next look at the script for this function.
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Getting Started

Select Functions in the first drop-down list box in a Script view.
Select of_GetConnectionInfo in the second drop-down list box.

The script for thisfunction passes database connection information to the
Constructor event of the connection service manager. The information
passed depends on an instance variable. In this case, the value of the
is_connectfrom variableis 1. You will verify thisin amoment. The
instance variable is available to al functions and events of the
n_pbtutor_connectservice object.

Becausetheis_connectfrom variableis 1, the connection service manager
looks to the Database section of the named INI file to get database
connection information using ProfileString function calls. In this case, the
named INI fileis pbtutor.ini. You created this file with the Connection
Object wizard.

Later you modify the pbtutor.ini file and the of _GetConnectionlnfo
function to make sure that user D and password information comes from
the login window instead of the INI file.

Select of_ConnectDB in the second drop-down list box.

This is the connection service manager function that actually connects to
the database using the SQLCA Transaction object. You call this function
from the login window you created in Lesson 3, “Building aLogin
Window.”

Notice that the wizard-generated script for this function also opens a
message box if the database connection fails.

Select of_DisconnectDB in the second drop-down list box.

Thisisthe connection service manager function that disconnects from the
database. You call this function from the application Close event.

Click the Declare Instance Variables tab.
Make sure Instance Variables is selected in the second drop-down list
box.

Selecting Declare in Script views o )
The Declare Instance Variables view is aspecia instance of the Script

view. It displayswhen you select Declarein thefirst drop-down list box of
the Script view. However, you cannot select Declare if a second Script
view already displaysinstance variables.
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You can now verify that the value of theis_connectfrom variableis 1.

=
[®Ceclare Instance Yariables

1= Instance Variables hd = E

string is_connectfrom ="1"

COMSTANT string IS_USE_INIFILE ="1"
COMSTANT string IS_USE_REGISTRY ="2"

COMSTANT string IS_USE_SCRIPT ="3"

- ¥
of _disconnectdb jEwent List sFunction List jDeclare Instance Yariables

Select Global Variables in the second drop-down list box.
Drag n_pbtutor_connectservice from the System Tree to the Script
view.

Dragging object and function names from the System Tree to the Script
view saves time and helps avoid typing errors.

Complete the line by typing the variable name after the object name:
n_pbt ut or _connect servi ce gnv_connect

Although you declare this object in the Script view for the
n_pbtutor_connectservice user object, it is available everywherein the
application.

Naming conventions for variables .
To make scripts easier to read, it is best to follow a standard naming

convention. The recommended standard isto give each variable a 2-letter
or 3-letter prefix followed by an underscore (). Thefirst letter of the
prefix identifies the scope of the variable (for example: g for global, | for
local) and the next | etter or |ettersidentify the datatype (for example: sfor
string, | for long, or nv for nonvisual object).

Click the Save button in the PainterBar
or
Select File>Save from the menu bar.

PowerBuilder compilesthe script and savesit. If you had typed the global
variable datatype (instead of dragging it from the System Tree) and you
made a typing error, an error message would display. You would then
correct the error and select Save again.
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Modify the connection information

Where you are
Look at the EAS Demo DB database
Run the Connection Object wizard
Declare a global variable

> Modify the connection information
Complete the login and logout scripts
Run the application

You can now call the connection service manager to establish a database
connection, but you should open a database connection only if the user enters
avalid ID and password in the login window. You will therefore add the
connection service call to the Clicked event of the OK button on this window,
substituting user-entered information for information from the pbtutor.ini file.

Before you do that though, you remove or comment out the ProfileString calls
that the connection service manager makesto get user 1D and password
information from the INI file. Then you modify the DBParm parameter in the
pbtutor.ini file, because it includes hard-coded user ID and password values
that were copied from the pb.ini file.

In this exercise you:
e Modify the of _GetConnectionlnfo function

e Call the connection service manager

Modify the of_GetConnectioninfo function

Getting Started

Youlooked at theof _GetConnectionlnfo functionin thelast exercise. Now you
comment out the information that the function returns for the user ID and
password information.

If you closed the User Object painter, you must open it again for the
n_pbtutor_connectservice user object. You can use the File>Recent Objects
menu to redisplay it.

1 Select Functions in the first drop-down list box in the Script view.
Select of_GetConnectionInfo in the second drop-down list box.
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2 Select the two ProfileString assignment lines that begin:

as_userid = ProfileString (...)
as_dbpass = ProfileString (...)

Thefour arguments of aProfileString call arethe NI filenameor variable,
the INI file section, the INI file key, and the default value to be used if the
INI file name, section, or key isincorrect. These lines are part of the

IS USE INIFILE case of the CHOOSE CASE statement for the

of GetConnectionlnfo function.

— 1 3 Clickthe Comment button in PainterBar2.

Comment By commenting out these lines, you make sure that the user ID and
password information do not come from the pbtutor.ini file.

4  Click anywhere in the line that begins:

as_dbparm = ProfileString ( ... )

5 Click the Comment button in PainterBar2.

The DBParm parameter in the ptutor.ini file includes hard-coded values
for the user ID and password aswell asthe database name. You do not use
these values. Instead, you assign values to the DBParm parameter from
user-entry information for user ID and password.

The SQLCA DBParm parameter
Although the user ID and password are not required for the DBParm

ConnectString, assigning them to the ConnectString overwrites user 1D
and password values in the data source definition for an SQL Anywhere
database. For this DBMS, the DBParm parameter also takes precedence
over the SQLCA UserlD and DBPass parameters.

6 Click the Save button in PainterBarl.
Click the Close button in PainterBar1.
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Call the connection service manager

Getting Started

You will next call the connection service manager to connect to the database.
Because you eventually need to add user-entry information from the login
window, you add the call to the Clicked event for the OK button on this
window.

An object is considered to be the parent of the controlsthat are added toit. The
login window is therefore the parent of the OK button.

When referring to a parent object in ascript, it isusually better practice to use
the qualifier parent than to name the object explicitly. This allows the code to
be reused more easily for controls placed on adifferent object. In the script for
the Clicked event, you refer to the login window as parent.

Using a single wizard to create the application and connection
If you had created the connection service user object with the Template

Application wizard, the code you enter in this exercise to call the connection
service manager would have been generated automatically, but it would have
been added to the application Open event, not to a Clicked event in alogin
window. It would also have used alocal variable, not a global variable.

1 Double-click w_welcome in the System Tree.

The Window painter opens.

2 Select cb_ok in the first drop-down list box of the Script view
or
Double-click the OK button in the Layout view.

The Clicked event should be the selected event in the second drop-down
list box. If it isnot, select it. The Clicked event script is empty.

3 Typetheselines:

/1 1) Instantiate the Transacti on object
/1 2) Close login window if connection successful

These lines explain the code you add to the Clicked event. Adding double
slash marks at the front of aline turnsit into a comment.

4  Type the following assignment statement below the comments:

gnv_connect = CREATE &
n_pbt ut or _connect service
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Do not type the ampersand (&) if you combine the lines of the script into
asingle line. The ampersand character indicates that aline of scriptis
continued on the next line.

The CREATE statement instantiates the SQLCA Transaction object with
all the valuesretrieved by the of GetConnectionlnfo function from the
pbtutor.ini file. Because you previously commented out the lines for the
user 1D and password, thisinformation is not retrieved.

For ease of reading, you can add blank lines between the comments and
the assignment statement for the global variable gnv_connect.

Type the following lines below the CREATE statement:

I F gnv_connect. of _ConnectDB ( ) = 0 THEN
Cl ose (parent)
END I F

The of _ConnectDB function connects the application to the database. As
you saw earlier in thislesson, if the connection fails (the SQLCodeis
not 0), a message box opens and displays the SQL error text.

If of _ConnectDB returns a zero (the SQL Code for a successful
connection), the lines that follow the IF-THEN statement line are parsed.
In this case, the parent window for the cb_ok control (w_welcome) closes.

—
[#® Script - clicked For ch_ok returns long
cb_ok A clicked () returns long [pbm_ »

1 1] Instantiate the Transaction object
{1 2] Close login window if connection successful

gnv_connect = CREATE &
n_pbtutor_connectservice

IF gnv_connect.of_ConnectDB [] = 0 THEN
Close [parent]
END IF

4 >
Lawout hclicked AEvent List jFunction List aDeclare Instance Variables
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Getting Started

Click the Compile button in PainterBar2

or

Right-click inside the Script view and click Compile in the pop-up
menu.

The script should compilewithout error. If you get an error message, make
sure you have typed object and function names correctly and saved
gnv_connect as aglobal variable.

Toggling the Error window of the Script view
You can show or hide the Error window by clicking theicon at thefar right

of the Script view just under the title bar.

You still need to code the Clicked event to instantiate the Transaction
object with user-entered connection information.
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Complete the login and logout scripts

Where you are
Look at the EAS Demo DB database
Run the Connection Object wizard
Declare a global variable
Modify the connection information

> Complete the login and logout scripts
Run the application

Earlier in thislesson, you called the connection service manager from the
Clicked event for thelogin window OK button. Next you add code to the same
Clicked event to instantiate the Transaction object with information entered by
the user.

You also add code to the login window Cancel button Clicked event and to the
application Closed event.

Minimizing typing errors in the Script view

If you right-click inside the scripting area, you open a pop-up menu that
includes Paste Special commands. You can use these commands to paste
statements, objects, functions or even the contents of text filesinto the event
script. Thisreducesthe risk of typing errors. You can also use AutoScript to
complete code, as you will seein thislesson.

In this exercise you:

e Set up shortcuts for AutoScript

* Add codeto the OK button Clicked event

* Add code to the Cancel button Clicked event
e Add code to the application Close event
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Set up shortcuts for AutoScript

When you are coding scripts, AutoScript provides help by completing the
statement you are typing or displaying alist of language elements that are
appropriate to insert in the script at the cursor location.

Getting Started

1

Select Design>Options from the menu bar and click the AutoScript
tab.

Make sure all the check boxes in the first three group boxes are
selected.

Make sure the Activate Only After A Dot and Automatic Popup check
boxes in the fourth group box are cleared, and click OK.

With these settings, AutoScript provides Help wherever it has enough
information to determine what code to insert, but it does not pop up
automatically when you pause. By selecting the Statement Templates
check box (not selected by default), you can use AutoScript to enter
structures for a multiple line PowerScript statement.

Select Tools>Keyboard Shortcuts from the menu bar.
Expand the Edit node in the tree.

Scroll down and select Activate AutoScript.
With your cursor in the Press Keys For Shortcut box, press
Ctrl+space.

Expand the Edit>Go To node in the Current Menu list and select Next
Marker.
Type Ctr | +Min the shortcut box and click OK.

Now whenever you want help completing code, you can press Ctrl+space
to pop up alist of possible completions. If you paste in a statement or
function with comments, you can press Ctrl+M to move to the next
comment.

Click OK.
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Complete the login and logout scripts

Add code to the OK button Clicked event
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Asis often the case when you are devel oping production applications, you get
some of the connection properties from an initialization file and some from
user input.

For the tutorial application, you should not get the user ID and password from
the tutorial INI file. Get them directly from the user in the login window and
then pass the database information in a script.

1 Make sure you are looking at the Clicked event script for the cb_ok
control.

Thisisthe script in which you added the call to the Connection Service
object.

2 Click before the IF-THEN statement.
Type the following lines:

//Local variable declarations
string | s_database, |s_userid, |s_password

[ Assi gnnent statenents

I's_userid = Trim( sle_userid.text )

| s_password Trim( sle_password.text )

| s_dat abase = "Connect Stri ng=' DSN=EAS Deno DB V110;"

With theselinesyou declarelocal variablesand assign them values. Do not
use blank spaces around the = signs in the ConnectString text. Do not
worry about the lone single quotation mark. You will add asingle
quotation mark in the next step to complete the connection script.

Using AutoScript to help code the assignment statements
When you typethe assignment statements, if you typetheletters beforethe

underscorein avariable name and then press Ctrl+space, AutoScript pops
up alist of possible completions. Usethe arrow keysto moveto the correct
completion and the Tab key to paste it into your script. If you type the
underscore and the first letter after the underscore and then press
Ctrl+space, AutoScript pastes the completion directly into your script, as
long as there is a unique completion.

The Trim function removes leading and trailing spaces from the user ID
and password values passed as arguments to the function from the
SingleLineEdit boxes on the login window.
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Getting Started

3

Click after the lines you just added (which follow the CREATE

statement) but before

the IF-THEN statement.

Type the following lines:

/llnstantiate

SQLCA. userid =
SQLCA. dbpass
SQLCA. dbparm =

s _userid + "; PAD=" + |s_password + "'"

These lines instantiate SQLCA parameters with values from the

with user-entry val ues
| s_userid
| s_password
| s_database + "UD=" + &

SingleLineEdit text boxes.

Thelines must be added to the script after the CREATE statement to keep
them from being overwritten with blank valuesfrom the Constructor event
of the connection service manager. They must be added before the IF-
THEN statement or their values are not used by the Transaction object
whenitiscalled by the of _ConnectDB function of the connection service

manager.

(=]
[#® Script - clicked For ch_ck returns long

cb_ok w
{1 1] Instantiate the Transa
i1 2] Close login window if

gnv_connect = CREATE &

}{Local variable declaratio

HtAssignment statements

Is_password = Trim [ sle_

SQLCA.userid = Is_userid
SQLCA.dbp =ls_p

1= clicked {3 returns long [pbm_ B

ction object
connection successful

n_pbtutor_connectservice

ns

string Is_database, Is_userid, Is_password

Is_userid = Trim [ sle_userid.text ]

password.text]

Is_database = "Connect5tring="DSN=EAS Demo DB V110;"

Hinstantiate with user-entry values

a

SQLCA.dbparm = |s_database + "UID="+ &
Is_userid + ";PWD="+ Is_password + '™

IF gnv_connect.of_ConnectDB [] = 0 THEN

Close [parent]
END IF

Click the Compile button in PainterBar2

or

Right-click inside the Script view and click Compile in the pop-up

menu.
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The script should compilewithout error. If you get an error message, make
sure you have typed object and function names correctly.

Add code to the Cancel button Clicked event

Now you add codeto the Cancel button to stop the application when thisbutton
is clicked.

Double-click the Cancel button in the Layout view
or
Select cb_cancel in the first drop-down list box of the Script view.

The script areafor the Cancel button is blank.

Type this one-line script for the Clicked event:
HALT

This statement terminates the application immediately when the user
clicks Cancel on the login window.

Click the Save button in the PainterBar
or
Select File>Save from the menu bar.

PowerBuilder compiles the script.

Click the Close button in the PainterBar
or
Select File>Close from the menu bar.

The Window painter closes.

Add code to the application Close event

116

Because the connection service manager was called by a global variable, it is
still available to the application and does not need to be instantiated again (as
it would if you had used alocal variable).

Now you call the connection service manager disconnect function to close the
database connection.
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Getting Started

Double-click the pbtutor application icon in the System Tree.

The Application painter displays different views of thetutorial application
object. The Script view is part of a stack in the default layout, but you
might find it easier to detach it from the stack or open asecond Script view.

Selectcl ose ( ) returns (none) inthesecond drop-down list box
of the Script view.

Thereis no code yet for the application Close event.

Type the following lines for the Close event comment:

Application C ose script:
Di sconnect fromthe dat abase

Select all or part of the lines you just added.
Click the Comment button.

Type the following line below the comment you typed (you can use
AutoScript to complete the variable name and the function name):

gnv_connect. of _Di sconnectDB ( )

[#® Script - close For phtutar returns (Mane)

pbtutar w close ) returns (none) W =] E
Happlication Close script:
i Disconnect from the database

gnv_connect.of_DisconnectDB []

Releasing memory by setting global variables to null
If this were not the application Close event and you no longer needed an

instance of the global connection variable, you could rel ease the memory
it occupies by calling the SetNull function.

PowerBuilder also provides a DESTROY statement to destroy object
instances. Do not use the DESTROY statement for local or global
variablesfor nonvisual objects. PowerBuilder garbage collection removes
any local variables that go out of scope.
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Complete the login and logout scripts

6 Right-click anywhere in the script area of the Script view.
Click Compile in the pop-up menu.

PowerBuilder compilesthe Close script. If you get an error message, look
carefully at the lines you typed to make sure thereis no mistyped variable
or object name.

7 Click the Close button in PainterBar1.

A message box asks if you want to save your changes to the Application
object in the application library file.

8 Click Yes.

This saves your changes and closes the Application painter.
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Run the application

Where you are

Look at the EAS Demo DB database

Run the Connection Object wizard

Declare a global variable

Modify the connection information

Complete the login and logout scripts
> Run the application

Now you run the application.

1 Click the Run button in the PowerBar.
F If a message box prompts you to save changes, click Yes to save
Run
them.

The workspace closes and your application runs.

2 Typedbain the User ID box.
Type sql inthe Password box.

The password text is displayed as asterisks. Because you set the tab order
for this window, you can tab from the User ID box to the Password box,
and then to the OK button.

3 Click OK.

The database connection is established and the MDI frame for your
application displays.

If you enter an invalid user ID or password
If you mistyped the user 1D or password, the Connect to SQL Anywhere

(ODBC Configuration) dialog box displays. You get a second chance to
enter avalid user ID and password on the Login page of thisdialog box. If
you click the Test Connection button on the ODBC page of the dialog box
without changing thisinformation, a message box tells you that your user
ID or password is not valid.

4  Select File>Exit from the menu bar.

The application terminates and you return to the devel opment
environment.
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LESSON 5

Getting Started

Modifying the Ancestor Window

In thislesson you create awindow that inherits from the basesheet
window that you generated with the Application Template wizard. You
add predefined user objects containing DataWindow controls to the
inherited window. You then create new w_customers and w_products
windowsthat inherit from this extension layer window instead of from the
original basesheet. Finally you make sure that the sheet windows open at
runtime with the size you set at design time.

But first you add alibrary to the library list that contains the predefined
user objects with Datawindow controls. In this lesson you:

Add alibrary to the search path

Create a new ancestor sheet window

Add user events and event scripts

Add scriptsto retrieve data for the DataWindow controls
Adjust aruntime setting for sheet window size

How long does it take?
About 30 minutes.
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Add a library to the search path

Add a library to the search path

Where you are
> Add a library to the search path
Create a new ancestor sheet window
Add user events and event scripts
Add scripts to retrieve data for the DataWindow controls
Adjust a runtime setting for sheet window size

Next you add alibrary to the tutorial application search path. You must add all
libraries on which an application depends.

Thelibrary you add to the current application contains some precoded objects,
including the user object (u_dwstandard) that you will later add to the base
sheet window.

1 Right-click the pbtutor target (not the pbtutor application object) in
the System Tree.

The pbtutor target contains the pbtutor.pbl and the pbtutor application.

2 Select Properties from the pop-up menu.

The pbtutor target properties dialog box displays.
3 Make sure the Library List page displays.

Click Browse.

The Select Library dialog box displays.
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Getting Started

4

5

Navigate to the Tutorial folder.
Select tutor_pb.pbl and click Open.

You return to the Library List page. The tutor_pb.pbl fileis now included

in the search path for the tutorial application.

Properties of Target pbtutor

Library Lisk | Deploy

Library search path:

Z:\Program Files\3vbaseiPowerBuilder 11,04 Tuborial\pbtutor, pbl;
C:\Program Files\SvbaseiPowerBuilder 11.0%Tutarialtutar_ph. phbl;

X

[ Mew, H Browse, ..

[ a4 ] l Cancel l [ Apply ] [ Help

)

Click OK.
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Create a new ancestor sheet window

Where you are
Add a library to the search path
> Create a new ancestor sheet window
Add user events and event scripts
Add scripts to retrieve data for the DataWindow controls
Adjust a runtime setting for sheet window size

Now you create awindow that inherits from the basesheet window you
generated with the Template Application wizard and add Datawindow controls
to it. In the Source editor, you change the inheritance of the generated sheet
windows (w_customers and w_products) to use the new window.

The Datawindow controls you add to the new ancestor window inherit their
definitions from a user object that was created for the tutorial application. The
user object is provided in the PBL file that you just added to the target library
list. The user object is a customized DataWindow control that includes scripts
to perform standard database error checking.

Why use a user object ) )
You can build auser object in PowerBuilder to perform processing that you use

frequently in applications. Once you have defined a user object, you can reuse
it as many times as you need without any additional work.

In this exercise you:

e Create anew sheet window inheritance hierarchy

* Add aDatawindow control for the master DataWindow
* Add aDatawindow control for the detail DatawWindow

»  View the scriptsinherited from the user object
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Create a new sheet window inheritance hierarchy

Now you create anew window that inherits from the basesheet window. In this
tutorial, you use the new window as an extension layer between the basesheet
window and application sheet windows. Later in thislesson you make changes
to the extension layer window. The changes you make are automatically
extended to any new sheet windows that you inherit from the extension layer
window.

In the current tutorial application, the w_customers and w_products windows
aready inherit from the w_pbtutor_basesheet window. Because you have not
yet added any non-generic property val ues or functionsto these sheet windows
(other than their names and display text), you can write over these
wizard-generated windows without having to transfer any code to the
replacement windows. In this lesson you overwrite these windows with new
windows that inherit from the extension layer window.

1 Select File>Inherit from the PowerBuilder menu.

The Inherit from Object dialog box displays.

2 Makesurethat pbtutor.pblis selected in the Libraries list box and that
Windows is selected in the Objects Of Type drop-down list.

If you cannot see thefull library list, you can change the size of the dialog
box by clicking on one of its edges and holding down the mouse button
while you drag the edge toward a corner of the screen. The pbtutor.pbl
should be the first of two librarieslisted in the Libraries list box.

3 Selectw_pbtutor_basesheet in the Object column of the main list box
and click OK.

4  Select File>Save As, and in the Save Window dialog box, select
w_nmast er _detai | _ancest or in the Windows field for the new
window name.

5 (Optional) Type the following text in the Comments box:

New ancestor basesheet for the w _custoners and
w_products sheet w ndows.
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10

11

12

13

Make sure that pbtutor.pbl is selected in the Application Libraries list
box and click OK.
Select File>Close to close the new ancestor basesheet.

You cannot create descendant windows if an ancestor window is openin
the Window painter.

Select File>Inherit from the PowerBuilder menu.

Make sure that pbtutor.pbl is selected in the Libraries list box and that
Windows is selected in the Objects Of Type drop-down list box.
Select w_master_detail_ancestor and click OK.

Type Mai nt ai n Cust oner s in the Tag text box on the General page
of the Properties view.

Select File>Save As from the PowerBuilder menu and select
w_cust orer s in the Windows list box.

Change the Comments text to:

Cust omer sheet w ndow i nheriting from
w_mast er _detai |l _ancestor.

Click OK, then click Yes in the Save Window message box that asks
if you want to replace the existing w_customers window.

The new sheet window inheritsfromw_master _detail _ancestor instead of
fromw_pbtutor_basesheet.

Repeat steps 7-11, with the following modifications:

Step Modified instruction

9 TypeMai nt ai n Product s in the Tag text box on the General
page of the Properties view. Select File>Save As from the
PowerBuilder menu and select w_pr oduct s inthe Windows list

box.

10 Change the Comments text to: Pr oduct sheet wi ndow
inheriting fromw_naster_detail _ancestor.

11 Replace the existing w_products window.

Close the new w_customers and w_products windows.

You cannot open an ancestor window in the Window painter if any of its
descendants are already displayed in the painter.
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14 From the PowerBuilder menu, select Run>Full Build Workspace.

You should rebuild the workspace after changing theinheritance hierarchy
and before making modificationsto the new ancestor window. You can see
the status of the build in the Output window, which displays below the
System Tree at the bottom of the PowerBuilder main window. Thebuildis
finished when the Output window displays Fi ni shed Full build of
wor kspace MyWor kspace.

15 Close the Output window.

Add a DataWindow control for the master DataWindow

Getting Started

Now you add a DataWindow control (saved as the user object, u_dwstandard)
tothew_master_detail _ancestor window. It serves asthe master DataWindow
for the ancestor window and its descendants.

How to create a user object like u_dwstandard
You can create a user object based on a Datawindow control by clicking the

New button and sel ecting Standard Visual from the PB Object page of the New
dialog box. This opens the Select Standard Visual Type dialog box. You can
then select DataWindow in the Types text box and add user events as needed.
You see how to add user events later in this tutorial.

1 Double-click w_master_detail_ancestor in the System Tree.

Thew_master_detail _ancestor window opensin the Window painter. You
generated thiswindow with the Template Application wizard. Thewizard
also created and attached a menu to this window, m_pbtutor_sheet. The
menu isindicated in the Properties view for the window. You change this
property later.

2 Make sure the Layout view is visible in the Window painter.

3 Expand tutor_pb.pbl by double-clicking it in the System Tree.
Drag u_dwstandard from the System Tree to the
w_master_detail_ancestor window in the Layout view.

4 Widen the window so that the control is completely visible inside the
window.
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PowerBuilder creates a DataWindow control that inherits its definition

from the user object.

Make sure the new control is selected in the Layout view.

Small black squares at the cornersindicate that the control is selected. The
Properties view displays the properties of the selected control.

Select the text dw_1 in the Name text box in the Properties view.

Type dw_nast er in the Name text box.
Select the VScrollBar check box.

T
F'n:u;nerties- dw_master inI‘E.

General | Other

Mame

Data0bject
Title

L]

Tag

L ]
visible

Enabled

[ Titlegiar

[ contraltenu

I:‘ MaxBox

I:‘ MinBox

[HscrolBar

vscrolBar

LiveScroll

[CIHsplitserall

[ rightToLeft

[IResizable

Border b,
7;|\Propert\es Control List Non—\u'\j_l

PowerBuilder adds a vertical scroll bar to the control. It also changes its
nameto dw_master. The prefix dw_is standard for Datawindow controls.
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Add a DataWindow control for the detail DataWindow

Now you add a second DataWindow control that is the detail Datawindow in
the application.

1 Resize the window so that there is room for a second DataWindow
control below the first.
Drag u_dwstandard from the System Tree to below the dw_master
control in the Layout view.

PowerBuilder creates another Datawindow control that inheritsits
definition from the user object u_dwstandard.

2 Move the DataWindow control so that it is completely visible inside
the window.

If you need to, you can maximize the Layout view and enlarge the window
object inside it to make more room for the Datawindow controls.

Layaut

3 Make sure that the new control is selected in the Layout view.

The Properties view displays the properties of the selected control.
4 Replacethetextdw_1inthe Name text box in the Properties view with

dw detail .

PowerBuilder changes the name of the control to dw_detail.
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View the scripts inherited from the user object
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Now you view the scripts the DataWindow controlsinherited from
u_dwstandard.

Double-click the dw_detail DataWindow in the Layout view

or

Select dw_detail from the first drop-down list box in the Script view if
it is not already selected.

The Script view opens to the empty script for the dw_detail control’s
ItemChanged event.

Unscripted events are al phabetized separately from scripted events.
Scripted events are listed at the top of the drop-down list box. You will
next look at the dberror event, which contains an ancestor script, so you
need to scroll up in the event drop-down list box to find it.

Select dberror from the second drop-down list box in the Script view.

This script isalso empty, but apurple script icon displays next to the event
name. This indicates that the ancestor control (u_dwstandard) has an
associated script.
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Select Edit>Go To>Ancestor Script from the menu bar
or
Select u_dwstandard in the third drop-down list box.

PowerBuilder displaysthe script for the DBError event in the Script view.

The ancestor script is read-only when it is accessed from the Script view

for one of its descendants.

IE 5

dwe_detail w | | B dberrar ( long sqldbcode, string sgler || = u_dwstandard ==
I* Event profile

X

>

Name: DBError
Applies to: u_dwstandard
Kind: System
Processing: See below

*
..:i.|'.".|'.|'.|'.f.|'.|'.".|'.|'.|'.|'.|'.|’.|'.".|'.|'.|'.|'.|'.|".f.|".|'.".|'.|'.|'!.|'.|'.|'.".|'.|'.|'.|'.|'!.f.l’!."!.l’.l’ﬁ!.l’.".l’!.l’!ﬁ."ﬂ."i

I Overview — !

i

I When a database error occurs in the DataWindow control !

}! [resulting from a Retrieve function or an Update function], /

J{ then get the error code and message that the DBMS returned

J and display them nicely to the user. ! v

Scroll through the window to view the database error-handling logic
defined for the DBError event.

The script suppresses the default error message that the DBError event
normally displays. Instead, it causes an appropriate message to be
displayed for each database error that might occur. The script makes calls
to user events that were declared for the user object.

Because you used the u_dwstandard object to define both DataWindow
controls in the window, thislogic is automatically reused in both controls.

Select Edit>Go To>Descendant Script from the menu bar
or

Right-click inside the script area of the Script view.
Select Go To>Descendant Script from the pop-up menu.

Thethird drop-down list box again displaysw_master_detail_ancestor, the
identifier of the object that contains the current control. The script for the
DBError event of this control (dw_detail) is still blank.
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Add user events and event scripts

132

Where you are
Add a library to the search path
Create a new ancestor sheet window
> Add user events and event scripts
Add scripts to retrieve data for the DataWindow controls
Adjust a runtime setting for sheet window size

Windows, user objects, and controls have predefined events associated with
them. Most of the time, the predefined events are all you need, but there are
times when you want to declare your own events. Events that you define are
called user events.

Purpose of user events One reason to define a user event isto reduce
coding in situations where an application provides several waysto perform a
particular task. For example, atask like updating the database can be
performed by clicking a button, selecting a menu item, or closing a window.
Instead of writing the code to update the database in each of these places, you
can define a user event, then trigger that user event in each place in which you
update the database.

Now you define some user eventsto handleretrieval, insert, update, and delete
operations against the tutorial database. You make these changes in the Script
view of the Window painter. Later in the tutorial, you add code in the Menu
painter to trigger these events.

1 Selectw_master_detail_ancestor in the first drop-down list box of the
Script view.

2 Select Insert>Event from the menu bar
or
Select New Event in the second drop-down list box of the Script view.

The Script view displays the Prototype window for defining a new event.
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3

The first button to the right of the third drop-down list box is atoggle
switch that displays or hides the Prototype window.

(=]
[ (Untitled)

w_master_detail_ancestor w (Mew Event) w B =
Access Return Type Event Mame
({Mone) w |
Pass By Argument Type Argument Mame
value + | inkeger v |
Throws:
LIExternal EventID  |{MNone) w

Type ue_retrieve in the Event Name text box in the Prototype
window.

Click inside the Script view below the Prototype window.

Type these lines (or use AutoScript as described below):

IF dw_master. Retrieve() <> -1 THEN
dw_mast er . Set Focus()
dw_mast er. Set RowFocusl ndi cat or ( Hand!)
END I F

Using AutoScript instead of typing
You can use AutoScript to pastein the IF THEN template aswell asthe

variables and function names:

Type IF, then press Ctrl+space.

Press Tab to paste an IF THEN statement.

Type dw_m, then press Ctrl+space.

Place the cursor after dw_master, type a dot, then type Ctrl+space.
Scroll and select retrieve( ), press Tab, and type the rest of the line.
Press Ctrl+M to jump to the next comment.

Enter the other function calls by typing them or using AutoScript.

Assoon asyou clicked in the script area, thetext in the second drop-down
list box of the Script view changed from New Event to ue_retrieve. It has
no arguments, does not return a value, and does not throw user-defined
exceptions. For information on throwing user-defined exceptions, see
Lesson 10, “Exception Handling.”
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The script lines you entered execute the Retrieve function and place the
retrieved rowsin the dw_master Datawindow control. If the retrieval
operation succeeds, the script sets the focus to the first row in the
Datawindow control and establishes the hand pointer as the current row
indicator.

If the retrieve fails . )
If theretrieval operation does not succeed, PowerBuilder triggers the

DBError event. The logic for the DBError event is handled in the user
object u_dwstandard. You looked at this script in the previous exercise.

(=]
'Eu: For w_master_detail_ancestor inherited from w_pbtutor_basesheet returns
w_master_detail_ancestor w ue_retrieve { ) returns {none) B =
Access Return Type Event Mame
({Mone) w |ue_retrieve
Pass By Argument Type Argument Mame
value + | inkeger v |
Throws:
LIExternal EventID  |{MNone) w

IF dw_master.Retrieve() <> -1 THEN
dw_master.SetFocus()
dw_master.SetRowFocusindicator[Hand!)
END IF

4  Select File>Save from the menu bar.
Right-click the Prototype window and select New Event from the
pop-up menu.

PowerBuilder compiles the script you entered for the ue_retrieve event.
The Script view displays the Prototype window for another new user
event.

If you get an error message
Mistyped or incomplete script entries generate compiler errors. If you

select No when prompted to ignore compilation errors, a compiler error
areadisplaysat the bottom of the Script view, identifying your error. If this
happens, retype the script for the ue_retrieve event.

You can display or hide the compiler error area by clicking the second
toggle switch at the top right of the Script view.
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5 Repeat steps 3 and 4 for the following entries:

Event name Script

ue_insert dw_det ai | . Reset ()

dw_det ai | . I nsert Row 0)

dw_det ai | . Set Focus()

ue_update | F dw_detail . Update() = 1 THEN

COW T using SQLCA;

MessageBox (" Save", " Save succeeded")

ELSE
ROLLBACK usi ng SQLCA;
END | F
ue_delete dw_det ai | . Del et eRow( 0)

What the scripts do Thefirst line of the script for the ue_insert event
clearsthe dw_detail DataWindow control. The second line inserts a new
row after the last row in the Datawindow (the argument zero specifiesthe
last row). The third line positions the cursor in the dw_detail control.

Theue _insertand ue_del ete eventsoperate on the DatawWindow buffer, not
on the database. When these events are triggered, arow is not inserted or
deleted from the database unless the Update function is also called (the
ue_update event cals this function). If the Update function returns the
integer 1, changes made to the buffer are committed to the database. If it
returns a different integer, changes to the buffer are rolled back.

In the script for the ue_delete event, the argument zero in the DeleteRow
function specifies that the current row in the dw_detail control be deleted.

6 Make sure your work is saved.

If you repeated step 4 for each new event and script that you added, you
have already saved your work.
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Add scripts to retrieve data for the DataWindow

controls
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Where you are
Add a library to the search path
Create a new ancestor sheet window
Add user events and event scripts
> Add scripts to retrieve data for the DataWindow controls
Adjust a runtime setting for sheet window size

The scripts you just typed have no effect on the dw_master DataWindow
control, but now that you have ascript for the ue_retrieve event, you need only
trigger this event to retrieve datainto the dw_master Datawindow.

You trigger the ue_retrieve event from the sheet window Open event. This
retrieves data into the dw_master DataWindow as soon as the window (or one
of its descendent windows) opens. Then you add a script for the
RowFocusChanged event of dw_master to retrieve data into the dw_detail
Datawindow. The RowFocusChanged event istriggered each timethefocusis
changed inside the dw_master DataWindow.

RowFocusChanged occurs upon DataWindow display
The RowFocusChanged event also occurs when thew_master Datawindow is

first displayed. This alows the application to retrieve and display detail
information for the first row retrieved in the master DataWindow.

Hereishow the script works for thew_master_detail _ancestor window and its
descendants when you are done:

e When a sheet window first opens, alist (of all customers or products)
displaysin the top Datawindow control. Detail information for the first
itemin thelist displaysin the bottom Datawindow control.

*  When auser moves through the list in the top Datawindow control using
the up arrow and down arrow keys or by clicking in arow, the details for
the current row display in the bottom Datawindow control.

1 Select openfromthe second drop-down list box in the Script view for
w_master_detail_ancestor.

The Open event hasapurple script iconindicating it hasan ancestor script.
If you check the ancestor script, you seethat it callsthe ue_postopen event
and postsit to the end of the window’s message queue.
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Getting Started

Type these new lines in the script area for the
w_master_detail_ancestor Open event:

dw_mast er. settransobject ( sqlca )
dw detail .settransobject ( sqglca)
this. EVENT ue_retrieve()

Thefirsttwo linestell thedw_master and dw_detail DataWindowsto look
in the SQL CA Transaction object for the values of the database variables.
Thethirdlinetriggersthe ue retrieve event. The pronoun Thisrefersto the
current object. In this example, thew_master_detail _ancestor window is
the current object.

Select dw_master in the first drop-down list box of the Script view.
Select rowfocuschanged in the second drop-down list box.

Read the event name carefully
Make sure you select the RowFocusChanged event, and not the

RowFocusChanging event.

You now add a script for the RowFocusChanged event of the dw_master
Datawindow control. This script sends aretrieval request and the ID
number of the selected row to the dw_detail Datawindow control.

Type this line in the script area for the RowFocusChanged event:
long I'l _itemum

Thislinedeclaresthelocal variablell_itemnum (I isaletter, not anumber),
which has the long data type.

Type this line below the variable declaration line you just typed:

Il _itemmum = this.object.data[currentrow, 1]

Use square brackets
The expression shown above requires square brackets, not parentheses.

Thisline uses a DataWindow data expression to obtain the item number in
column 1 of the currently selected row of dw_master. It storesthe number
inthevariablell_itemnum.
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CurrentRow is an argument passed to the RowFocusChanged event that
specifies the current row in the Datawindow control. The current row is
the row the user has selected by clicking or by scrolling with the arrow or
tab keys.

Type these lines below the data expression line you just typed:

IF dw detail.Retrieve(ll_itemum = -1 THEN
MessageBox("Retrieve","Retrieve error-detail")
END I F

Thisgroup of linessendsaretrieval request to the dw_detail DataWindow
along with the argument the Datawindow expects (an ID number stored in
thell_itemnum variable). The IF statement that encloses the Retrieve
function checks for successful completion. If theretrieval operation fails,
it displays an error message box.

(=]
I [#® Script - rowfacuschanged For dw_master inherited from u_dwstandard returns long

dw_master w rowfocuschanged ¢ long currentrow w_master_det + | = =2
Access Return Type Event Mame
Pass By Argument Type Argument Mame
Throws:
External Event ID

long Il_itemnum

I_itemnum = this.object.data[currentrow, 1]

IF dw_detail.Retrieve(ll_itemnum] = -1 THEN

MessageBox['Retrieve',"Retrieve error-detail"]

END IF
£ >
Layout yrowfocuschanged AEvent List AFunction List hDeclare Instance Variables

Click the Save button in PainterBarl.
Click the Close button in PainterBarl.

PowerBuilder compiles the script you typed and savesiit.

Click the Full Build Workspace button in the PowerBar.

Itisagood ideato rebuild al your objects after modifying an ancestor
object.

Close the Output window.
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Adjust a runtime setting for sheet window size

Getting Started

Where you are

Add a library to the search path

Create a new ancestor sheet window

Add user events and event scripts

Add scripts to retrieve data for the DataWindow controls

> Adjust a runtime setting for sheet window size

The Template Application wizard creates a sheet manager that makes the
Opensheet function call to open a sheet window. The OpenSheet function has
an argument that can affect the sheet window size at runtime. By default the
wizard sets this argument to the Cascaded! value that overrides the sheet
window size you set at design time. Now you change this value to allow the
runtime window size to be the same as the design time size.

3

4

Double-click n_pbtutor_sheetmanager in the System Tree

or

Right-click n_pbtutor_sheetmanager in the System Tree and select
Edit from the pop-up menu.

In the Script view, select (Functions) in the first drop-down list box.
Select of_opensheet in the second drop-down list box.

Go to the following line in the script:

OpenSheet ( |w_sheet, as_sheetnane, w pbtutor_frane, 0, Cascaded! )

Change the Cascaded! argumentto Ori gi nal ! :

OpenSheet ( |w_sheet, as_sheetnanme, w pbtutor_frane, 0, Oiginal! )

Click the Save button in PainterBarl.
Click the Close button in PainterBarl.

Thenext timeyou run thetutorial application, the sheet windowswill open
in the size you set at design time. They will still be cascaded relative to
other open sheets.
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LESSON 6 Setting Up the Menus

In this lesson you set up the menus for the application. You:
¢ Modify the frame menu

*  Create anew sheet menu

e Add menu scriptsto trigger user events

«  Attach the new menu and run the application

Menus are separate objects that you create using the Menu painter. After
you create amenu, you can attach it to as many windows asyou want. You
can create menus at any time during the application devel opment process.

How long does it take?
About 30 minutes.
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Modify the frame menu

Where you are
> Modify the frame menu
Create a new sheet menu
Add menu scripts to trigger user events
Attach the new menu and run the application

The frame menu was created automatically by the Template Application
wizard. Them_pbtutor_frame menu is the ancestor of al the other menus you
work with in the tutorial. Changes you make to this menu are automatically
propagated to descendent menus.

Inthe WY SIWY G (What You SeelsWhat You Get) view of the Menu painter,
you see menus as they appear when the application isrunning. In thistutorial,
you use the WY SIWY G view to make changes to the application menus, but
you can make the same changes from the Tree Menu view. You use the
Properties view to change a toolbar button.

In this exercise you:
e Modify the File menu

e Enable Help menu items

Modify the File menu

142

Now you modify the File cascading menu of the m_pbtutor_frame menu.

1 Double-click m_pbtutor_frame in the System Tree.

The Menu painter displays the menu associated with the MDI frame
window in the application. Because m_pbtutor_sheet inherits from
m_pbtutor_frame, changes you make to the frame menu are propagated to
the sheet menu.

In the WY SIWIG view, the menu items appear across the top of the view.
If aWY SIWY G view isnot open, you can select it from the View menuin
the Menu painter menu bar.
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2 Click the File menu in the WYSIWYG view of m_pbtutor_frame.

When you click amenu item in the WY SIWY G view, its menu items
appear just asthey would at runtime.

If the File menu does not display its menu items
The File menu is selected when you display the WY SIWY G view. You

might need to click one of the other menus (Edit, Window, or Help) and
then click again on the File menu to display its menu items.

3 Right-click New under the File menu.
Select Edit Menu Item Text in the pop-up menu.
Type &Report and press Enter.

You change the display name of the New menu item to Report. The menu
name remains m_new and its purpose (to open new sheet windows)
remains the same.

Define accelerator keys with the ampersand character
The character following the ampersand is used as an accelerator key

(mnemonic) and appearswith an underscoreinthe WY SIWY G display. In
the runtime application, the user can access the File>Report menu by
pressing Alt+F+R.

4  Make sure that &Report appears in the Text text box in the Properties
view.
Click the Toolbar tab in the Properties view.

Thetoolbar item text isNew, Open New Sheet . Thereisno selectionin
the Tool barltemName box, so no toolbar button appears at runtime for the
Report menu item. You do not add atoolbar button here, because you use
the Report menu item to access cascading menu items rather than asa
command to open a new sheet.
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Click the Open menu item under the File menu in the WYSIWYG view.
Click the General tab in the Properties view.

Clear the Visible and Enabled check boxes on the General page of the
Properties view.

You hide the Open menu item in al runtime menus. When you clear the
Visible property, the WY SIWY G view displays the menu item with a
dithered (broken) appearance. It isnot visible at runtime. When you clear
the Enabled property, the WY SIWIG view displays the menu item with a
very faint and inverted relief appearance. If it isvisible at runtime, the
menu item will still be grayed out.

L]

[ m_pbtutor_frame
File Edit ‘Window Help
Report: 4

Prink Setup...

Toolbars., ..

Exit

Click the Toolbar tab of the Properties view.
Clear the ToolbarltemVisible check box.

This prevents the toolbar button for this menu item from appearing in the
frame menu toolbar (a button can beincluded in atoolbar even if its
corresponding menu item is not visible or enabled).

Click Exit under the File menu in the WYSIWYG view.

The Toolbar page of the Properties view remains open. The
ToolbarltemText and ToolbarltemName values change to show the values
for the m_exit menu item.
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Enable Help menu items

Getting Started

The Help menu has three items, but only one, Help>About, is enabled. Now
you enabl e the other menu items, using commented-out code that was provided
by the Template Application wizard and the pbtutor.hip file in the Tutorial
directory.

You call application Help topics with the ShowHelp function, passing it an
enumerated value that identifies whether you want the Help contents or index
to display, or a specific topic or keyword. ShowHelp can open Windows Help
or compiled HTML Help (CHM) files.

1 Click the Help menu in the WYSIWYG view and then double-click the
Help Index menu item.

You can double-click the Help Index item even though it is not currently
enabled. The full name of the Help Index menu item,
m_help.m_helpindex, displaysin the Script view. It includes the m_help
prefix to indicate that it isin the Help menu.

2 Select Clicked in the second drop-down box if it is not already
selected.

3 Position the cursor in the line that contains the ShowHelp function
and click the Uncomment button in the PowerBar.
Change myapp.hlp to pbtutor.hlp:

ShowHel p ("pbtutor. hlp", I|ndex!)
This displays the default topic in the Help file.

4  Select the Enabled check box on the General page of the Properties
view for the m_helpindex menu item.

5 Repeat the preceding steps for the Search For Help On menu item
using the following Show Help function.

ShowHel p ("pbtutor. hlp", Keyword!, "")

If thethird argument contained astring that wasakeyword inthe Helpfile,
the associated topic would display. Because the argument is an empty
string, the Help Search window displays.

6 Select File>Save from the main PowerBuilder menu bar.
Select File>Close from the main PowerBuilder menu bar.
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Create a new sheet menu

Where you are
Modify the frame menu
> Create a new sheet menu
Add menu scripts to trigger user events
Attach the new menu and run the application

Now you create a new menu that displays whenever the user opens an MDI
sheet to look at customer or product information. The menu you createis a
descendant of the m_pbtutor_sheet menu that was generated by the Template
Application wizard.

The m_pbtutor_sheet menu inheritsin turn from m_pbtutor_frame, but has
some additional menu items enabled. In the menu you create, you add menu
items that are not present in the ancestor menus.

In this exercise you:
e |nherit and save a new menu
e Add itemsto the new menu

e Add anew toolbar for the new menu items

Inherit and save a new menu

By inheriting from the application sheet menu, you retain the sheet menu
characteristicswithout modifying the ancestor menu. It isgood practiceto save
the new menu immediately, then save it again after you modify it.

1 Click the Inherit button in the PowerBar.

IE:it The Inherit From Object dialog box displays.

2 Make sure Menus is selected in the Objects of Type drop-down list
box.
Select m_pbtutor_sheet in the Object list box and click OK.

PowerBuilder displays an untitled menu that has all the characteristics of
m_pbtutor_sheet.
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On theinherited sheet menu, the Window menu itemsare enabled to allow
for tiling and cascading windows, just asthey arefor the m_pbtutor_sheet
menu. These items are disabled on the m_pbtutor_frame menu.

Changes made to the MDI frame menu
If you click the File menu in the WY SIWY G view, you see that the first

item is now Report. The Open item is dithered to indicate that it is not
visible and is grayed to indicate that it is disabled. These characteristics
were propagated through the inheritance chain from m_pbtutor_frame.

Select File>Save from the menu bar.

The Save Menu dialog box displays.

Type m ny_sheet as the menu name in the Menus box.
Type the following line in the Comments box:

New sheet nenu for w_naster_detail _ancestor and its
descendant s.

Click OK.
This names the menu. The prefix m_is standard for menus.

The nameyou just assigned to the new menu displaysin thetitle bar of the
Menu painter workspace and them_my_sheet menu appearsin the system
tree.

Add items to the new menu

Getting Started

Next you add items to the Edit menu of the menu you just inherited from
m_pbtutor_sheet. You use the WY SIWY G and Properties views.

Click the Edit menu in the WYSIWYG view for the new menu.

Thelist of Edit menu items appears just asit would in aruntime
application. All items of the Edit menu are visible but disabled (they
appear gray—but not dithered—in the WY SIWY G view).
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Right-click a menu item under the Edit menu in the WYSIWYG view.
Select Insert Menu Item At End from the pop-up menu.

The cursor movesinto ablank box that appears at the end of the Edit menu
list.

Type - (hyphen) and press Enter.

The hyphen changesinto a separator line. In the Properties view, the menu
item name changesto m - . Even the separator lines between menu items
must have unique names. Other separator linesin the menu have aunique
index number preceded by the prefix m_dash.

Clear the Enabled check box in the Properties view for the new
separator line.

Right-click the new separator line in the WYSIWYG view.

Select Insert Menu Item At End from the pop-up menu.

Type & nsert in the box that appears under the new separator and
press Enter.

The menu item name is set automatically to m_insert. If PowerBuilder
displays a message that the default name isincorrect, it suggests an
alternative name. If this occurs, click OK to accept the suggested name.

Alternative method of inserting menu item names
You can type & Insert in the Text box in the Properties view instead of

typing it in the box that appearsinthe WY SIWY G view. In this case, you
do not need to press Enter afterwards. First, however, you haveto clear the
Lock Name check box if the Name box is grayed (otherwise, the menu
name does not reset to m_insert).

Typelnsert a rowin the MicroHelp box in the Properties view.
The new menu item is visible and enabled by default.

Thetext I nsert a rowdisplaysinthe MicroHelp line at the bottom of
the application window whenever the user selects the menu item.
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Getting Started

Repeat steps 5 and 6 for the following menu items:

Menu item MicroHelp text
Upd& ate Update the database
&Delete Delete the current row

You add Edit menu itemsfor updating and del eting database records. Even
though it is not enabled, the Undo item already uses the letter U as an
accelerator key, so you should not use the same accel erator key for the
Update menu item. Instead, you use the letter A for this purpose.

Insert
Update

Delete

F =5 - 7

General | Taolhar

Lock Mame
Text

| &Delete

MicroHelp

| Delete the current row

Tag

Wisible
Enabled
[Jchecked
[Joefault

[ shiftToRight
MergeCption

| exclude!

MenultemType

| menuitemtypenormall

Shorkcut Key

| ({Mone)

=
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Add a new toolbar for the new menu items
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Now you add toolbar buttons for the menu items you just defined and then
place them in a second toolbar.

1 Click the new Insert menu item in the WYSIWYG view Edit menu.

2 Click the Toolbar tab in the Properties view.
Type | nsert in the ToolbarltemText box.
Type or select | nsert! in the ToolbarltemName drop-down list.

This defines atoolbar button for the Insert menu item that uses the stock
picture called Insert!. When the Show Text option in the runtime
application is enabled for toolbars, the text Insert appears on the button.

3 Typeorclick to 1 in the ToolbarltemSpace spin control.
Type or click to 1 in the ToolbarltemOrder spin control.
Type or click to 2 in the ToolbarltemBarIindex spin control.

When you start a new toolbar for the added menu items, the Insert button
will bethe first item in this toolbar.

4  Click the new Update menu item in the WYSIWYG view Edit menu.
Make sure it is also displayed on the title bar in the Properties view.

5 Click the Toolbar tab if the Toolbar page is not already open.
Type Updat e in the ToolbarltemText box.
Type or select Updat e! in the ToolbarltemName drop-down list box.

This defines atoolbar button for the Update menu item that uses the stock
picture called Update!. The button text is Update.

6 Type or click to 2 in the ToolbarltemOrder spin control.
Type or click to 2 in the ToolbarltemBarIindex spin control.

Thiswill add the Update button after the Insert button in the new toolbar.

7 Click the new Delete menu item in the WYSIWYG view Edit menu.
Make sure it is also displayed on the title bar in the Properties view.
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8 Click the Toolbar tab if the Toolbar page is not already open.
Type Del et e in the ToolbarltemText box.
Type or select Del et eRow! in the ToolbarltemName drop-down list
box.

This defines atoolbar button for the Delete menu item that uses the stock
picture called DeleteRow!. The button text is Delete.

9 Type or click to 3 in the ToolbarltemOrder spin control.
Type or click to 2 in the ToolbarltemBarIindex spin control.

You add the Delete button after the Update button in the new toolbar.

10 Select File>Save from the PowerBuilder menu bar.
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Add menu scripts to trigger user events

152

Where you are
Modify the frame menu
Create a new sheet menu
> Add menu scripts to trigger user events
Attach the new menu and run the application

Now you add scripts to trigger user events from the sheet window menu bar.

You added these user eventsin Lesson 5, “Modifying the Ancestor Window.”
The Menu painter should still be open for them_my_sheet menu. If it is not,

you can open it using the Open button in the PowerBar.

1 Select m_edit.m_insert in the first list box in the Script view
or
Double-click the Insert menu item in the WYSIWYG view.

The full name of the Insert menu item displays in the first list box of the
Script view. It includes the m_edit prefix to indicate that it isin the Edit
menu.

2 Select Clicked in the second drop-down box if it is not already
selected.
Type these lines for the Clicked event:

w_mast er _detail _ancestor |w_ activesheet
| w_activesheet = w_pbtutor_frane. Get Acti veSheet ()
| w_activesheet. EVENT ue_insert ()

Thefirst two lines determine which sheet in the MDI frameis currently
active. Thethird linetriggers the user event ue_insert for the active sheet.

3 Repeat steps 1 and 2 for the following menu items and scripts:

Menu name Script for Clicked event

m_edit.m_update | w_master_detail_ancestor Iw_activesheet
lw_activesheet=w_pbtutor_frame.GetA ctiveSheet()
lw_activesheet. EVENT ue_update()
m_edit.m_delete w_master_detail_ancestor lw_activesheet
lw_activesheet = w_pbtutor_frame.GetA ctiveSheet()
lw_activesheet. EVENT ue_delete()
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4  Select File>Save from the PowerBuilder menu bar.

PowerBuilder compiles and saves the menu scripts.

5 Click the Close button in PainterBarl
or
Select File>Close from the PowerBuilder menu bar.
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Attach the new menu and run the application
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Where you are

Modify the frame menu

Create a new sheet menu

Add menu scripts to trigger user events

> Attach the new menu and run the application

Now you attach the new sheet menu and run the application again.

1

Double-click w_master_detail_ancestor in the System Tree.

If you cannot see the Properties view
Select View>Properties from the menu bar.

The menu listed in the MenuName box in the Properties view of the
Window painter is still m_pbtutor_sheet.

Click the ellipsis button next to the MenuName box.

The Select Object dialog box displays.

Select m_my_sheet in the Menus list box and click OK.

Thisis the sheet menu you modified after inheriting it from
m_pbtutor_sheet. It isnow listed asthe menu namein the Propertiesview.

Click the Save button in PainterBarl.
Click the Run button in the PowerBar.

The application login window displays.

Type dba in the User ID box.
Type sql in the Password box and click OK.

The database connection is established, and the MDI frame for the
application displays. The File menu now includes a Report cascading
menu in place of the New menu item. The Open menu item is no longer
visible.
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10

11

12

13

Getting Started

Select File>Report>Maintain Customers from the menu bar.

Notice that a second toolbar appears and the Edit and Window cascading
menus include enabled menu items.

Select the Edit menu.

The Edit menu has the Insert, Update, and Delete options you added.
These options do not function yet, because the Datawindow controlsin
the Customer window do not have DatawWindow objects associated with
them.

Select the Window menu.

Notice that anew menu item has been added for the sheet you just opened.

Select File>Report>Maintain Products from the menu bar.

A second MDI sheet opens. This sheet cascades relative to the first sheet.
The menu bar does not change. That is because m_my_sheet isthe menu
for both w_customers and w_products.

Select the Edit menu.

Because the w_products window uses the m_my_sheet menu, the Insert,
Update, and Del ete options are al so avail able when the Product window is
open.

Select the Window menu.

Another menu item has been added for the second sheet you opened. The
checkmark next to this menu item indicates that it is the active sheet.

Select File>Exit from the menu bar.

The application terminates and you return to the Window painter
workspace.

Close the Window painter.
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LESSON 7 Building DataWindow Objects

The Datawindow object is one of the most powerful and useful features
of PowerBuilder. A DataWindow object can connect to a database,
retrieve rows, display the rows in various presentation styles, and update
the database.

In thislesson you:

e Create and preview a new DataWindow object

e Savethe DataWindow object

* Make cosmetic changes to the first DataWindow object
*  Create a second Datawindow object

»  Make cosmetic changes to the second DataWindow object

How long does it take?
About 20 minutes.
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Create and preview a new DataWindow object
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| it d
L |
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Where you are
> Create and preview a new DataWindow object
Save the DataWindow object
Make cosmetic changes to the first DataWindow object
Create a second DataWindow object
Make cosmetic changes to the second DataWindow object

Now you create a new DatawWindow object and display it in the Datawindow
painter. Like other painters, the Datawindow painter has an assortment of
views that you can open simultaneoudly.

About the Design view of the DataWindow painter o
The Design view in the DataWindow painter is similar to the Layout view in

other painters. You can open only one Design view at atime.

The Design view is divided into four areas called bands. header, detail,
summary, and footer. You can modify the contents of these bands. For example,
you can change their sizes, add objects (contrals, text, lines, boxes, or ovals),
and change colors and fonts.

In the Preview view of the Datawindow painter, you can see how the object
looksin an application at runtime, compl ete with table data.

1 Click the New button in the PowerBar.

The New dialog box displays.

2 Click the DataWindow tab.
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Getting Started

3

4

Select Tabular from the list of presentation styles.

New:
Target: | (@) phtutor (C:\Program FilestSyvbase) PowerBuilder 11,00 Tutorial) v|
| ‘workspace || Target | PE Object | Jsp | DataWindow | patabase | Project | Tool |

[w[= - = =
=5 = s ==
Composite Crosstab Freeform Graph Grid
Group Label CLEZ.0 RichText
Treeiew
[a]4 l [ Cancel

Click OK.

The Choose Data Source for Tabular DatawWindow page of the

Datawindow wizard displays.

which data source would vou like to use?

Choose Data Source for Tabular DataWindow E|E|

_ ) —.
% ;ﬁ g JJ =
SQL Select Query External
@
W
Stored Web Service
Procedure
Rettieve an Preview
< Back Mext = .] [ Cancel
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Create and preview a new DataWindow object

160

5

Select Quick Select as the data source and select the Retrieve On
Preview check box if it is not already selected.
Click Next.

PowerBuilder connects to the EAS Demo DB Database, and the Quick
Select dialog box displays.

Click the customer table in the Tables list box.

This opens the table and lists its columns. For this Datawindow, you will
select four columns.

Click id, fname, and Iname in the Columns list box in the order listed.
Scroll down the list and click company_name.

Quick Select FZ|
1. Click on table(s) to select or deselect  To display comments For a
2. Select one or more columns, table or column, click
3, {Optional) Enter sorting and the right mouse button,

selection criteria below,
Add Al
Tables: Columnnis:
sales_order
ary_name
< 2 £ ¥
Comments:
Mame of the company
Calurnn;: Id Friame Lnarme Compa
Sort:
Criteria:
Qs “
< ¥

PowerBuilder displays the selected columnsin agrid at the bottom of the
Quick Select dialog box.

Selection order determines display order
The order in which you select the columns determines their |eft-to-right

display order in the DataWindow object. If you clicked a column by
mistake, you can click it again to clear the selection.
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You can use the grid area at the bottom of the dialog box to specify sort
criteria (for the SQL ORDER BY clause) and selection criteria (for the
SQL WHERE clause). Now you specify sort criteria only. You sort theid
column in ascending order.

8 Inthe grid area of the Quick Select dialog box, click in the cell next to
Sort and below Id.

A drop-down list box displays.

9 Select Ascending from the drop-down list box.

This specifies that the id column is to be sorted in ascending order.

Quick Select FZ|
1. Click on table(s) to select or deselect Ta display comments for a
2. Select one or more columns, table or column, click
3, {Optional) Enter sorting and the right mouse button,

selection criteria below,
Add all
Tables: Columnnis:
sales_order
COmpany_name
£ [ >
Comments:
Mame of the company
Calurnn;: Id Friame Lnarme Compa
Sork: e
Criteria:
Qs “
£ >

10 Click OK.

The Datawindow wizard asks you to select the colors and bordersfor the
Datawindow object. By default, there are no borders for text or columns.

11 Click Next.

You accept the border and color defaults. The Datawindow wizard
summarizes your selections.
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Create and preview a new DataWindow object

12 Click Finish.

PowerBuilder creates the new DataWindow object and opens the
Datawindow painter.

In the Design view, PowerBuilder displays a Heading band with default
headings and a Detail band with the columns you selected:

B (Untitled) * (pbtutor) - DataWindow

sign - (unkitled)
Customer  First Mame Last Name Company Hame
1D

Header {

id fname Iname company_name
Detail t

Summary {

Footer

v
£ >

The Preview view displays the DatawWindow as it appears during
execution. PowerBuilder displaysdatafor all customers. Thedatais sorted
in ascending order by customer 1D, just as you specified.

Last Name Company Hame

10 Michaels Drevlin The Power Group

102  Beth Fieizer AMF Corp.

103 Erin Miedringhaus Darling Associates

104 Meghan Mazon F5.C

105 Lawra MeCarthy Amo & Sons

106 Paul Fhillipz Ralston Inc.

107 Kelly Colburn The Home Club

108 Matthew Goforth Fialeigh Co.

109 Jessie Gagliardo Mewtan Ent.

110 Michael Agliori The Pep Squad

111 Dylan Ricci Dynamics Inc.

112 Shawn MeDonough Mok anusz Inc. e
— [ N =

Displaying the Preview view
If the Preview view is not displayed, select View>Preview from the menu
bar. If Preview is grayed, it isaready displayed and you cannot select it.

You can open only one Preview view at atime.
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Save the DatawWindow object

Where you are
Create and preview a new DataWindow object
> Save the DataWindow object
Make cosmetic changes to the first DataWindow object
Create a second DataWindow object
Make cosmetic changes to the second DataWindow object

Now you name the DataWindow object and save it in the pbtutor.pbl library.

Saving to another library o ) ) )
You can save objects to different application libraries, but to avoid

complications, you save al your new tutorial objectsin onelibrary. You can
also copy or move objectsfrom onelibrary to another using the Library painter.

1 Select File>Save from the menu bar.

The Save Datawindow dialog box displays with the insertion point in the
Datawindows box.

2 Make sure pbtutor.pbl is selected in the Application Libraries box.
Type d_custli st in the Datawindows box.

This names the Datawindow object. The prefix d_is standard for
Datawindow objects.

3 (Optional) Type the following comments in the Comments box:

Thi s Dat aW ndow obj ect retrieves custoner nanes and
conpany associ ati ons.

4  Click OK.

PowerBuilder saves the DataWindow object and closes the Save
Datawindow dialog box.
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Make cosmetic changes to the first Datawindow object

Make cosmetic changes to the first DataWindow object

164

Where you are
Create and preview a new DataWindow object
Save the DataWindow object
> Make cosmetic changes to the first DataWindow object
Create a second DataWindow object
Make cosmetic changes to the second DataWindow object

Now you can make cosmetic changes to the DataWindow. You reposition the
columns and column headings to make room for the hand pointer, which
displaysto the left of the currently selected row. You also move some of the
columns to make them line up with their headings.

You make these changes in the Design view. You can keep the Preview view
open at the same time to see how the changes you make affect the appearance
of the Datawindow at runtime.

1 Select Edit>Select>Select All from the menu bar
or
Press Ctrl+A.

All of the controlsin the DatawWindow object are selected in the Design
view.

2 Position the mouse pointer over one of the selected objects.
Drag the object to the right about one inch.

All of the selected objects move together.

3 Clickin ablank area in the Design view.

You clear the object selection.

4  Click the Customer ID header above the Header band.
Hold down the Ctrl key and click the id column above the Detail band.
Release the Ctrl key and drag the id column to the left about one-half
inch.

The column and its header move together.
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Center

=

Click the Center button in the StyleBar.
Click in a blank area in the Design view.

This centers the Customer |D column header text and the column data.

Click the First Name header.
Hold down the Ctrl key and click the Last Name and Company Name

headers.

Click the Left button in the StyleBar.

When you have finished, the Design view should look something like this:

=
Design - d_custlist
Customer

1D

First Name

Last Name Company Name ~

Header {

id

frame

Iname COMPANY_name

[Detail

[Summary

|Footer {

IL\A

Select File>Close from the menu bar.

A message box asks if you want to save your changes.

Click Yes.

PowerBuilder saves the DataWindow object and closes the Datawindow

painter.
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Create a second DataWindow object

Create a second DataWindow object

Where you are

Create and preview a new DataWindow object

Save the DataWindow object

Make cosmetic changes to the first DataWindow object

> Create a second DataWindow object

Make cosmetic changes to the second DataWindow object

When you built thefirst DataWindow object, you used Quick Select to specify
thetable and columns. Thislet you retrieve all the customerswithout having to
use the Select painter.

To build the second DataWindow object, you use the Select painter. You need
to define aretrieval argument and WHERE criteria so you can pass an
argument to the DataWindow object during execution. In this case, you will
pass the customer ID.

In this section, you:

Select the data source and style

Select the table and columns

Define aretrieval argument

Specify a WHERE clause

View the DataWindow in the DataWindow painter
Save the Datawindow object

Select the data source and style

Now you select a data source and define how the data is to be presented.

166

1

=
L]
Mlew

2

Click the New button in the PowerBar.

The New dialog box appears.

Click the DataWindow tab if it is not already selected.
Select Freeform from the list of presentation styles and click OK.
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3 Select SQL Select as the data source and select the Retrieve On
Preview if it is not already selected.

Since the data source is SQL Select, you go to the Select painter and the
Select Tables dialog box displays.

Selecting the Retrieve On Preview check box allows you to view the data
returned by a query in the devel opment environment, but you need to
provide initial values for any retrieval arguments that you specify.

4  Click Next.

Select the table and columns

Now you select the table and the columns from that table to use in the
Datawindow object.

1 Select customer in the list of tables and click Open.

The Select painter displays the customer table and its columns.

Alternative method
If you double-click the customer table instead of selecting it and clicking

Open, the Select Tables dialog box remains open. In this case, you must
click Cancel to continue.

2 Right-click the header area of the Customer table in the Table Layout
view.
Select Select All from the pop-up menu.

The column names appear in the Selection List area above thetable in the
Table Layout view.

The column order in the Selection List reflectsthe order in which columns
are selected. Since you selected all the columns at once, the order
displayed isthe original order of the columnsin the database. You change
the column presentation order later.

Getting Started 167



Create a second DataWindow object

You can also see the order of selection in the Syntax view. Display the
Syntax view by clicking the Syntax tab at the bottom of the stack of tabbed
panes. The Syntax view displays the generated Select statement.

8 Select - EASDemoDB110.0DBC. easdemo10.dba

153

Drlag and drop columns in the order in which wou want
"cuskomer”,"id"

"cuskomer”."fname"

"cuskomet” "Iname"

"cuskomer” . "address"

"cuskamer”,"city"

"cuskomer” "state"
"cuskamer" "zip"
“cuskomer” . "phone”

"customer"."company _name"

Sort AWhere WEroup hHaving hComplte 3 Synka

Define a retrieval argument

Now you define aretrieval argument.

1 Select Design>Retrieval Arguments from the menu bar.

The Specify Retrieval Arguments dialog box displays.

2 Typecust _i din the Name box.
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The default data type is Number, which is what you want.

Specify Retrieval Arguments

Argument
o
Pasition MName Tvpe
—— e Cancel
i | & [ |
I [1 | cust_d | [Mumber ~|

Help

Insert

Delete

About retrieval argument names

You can choose any hame you want for the retrieval argument; itisjust a
placeholder for the value you pass during execution. Nonetheless, it isa

good idea to make the name meaningful.

3 Click OK.
Theretrieval argument is defined.

Specify a WHERE clause

Now you specify a WHERE clause using the retrieval argument to retrieve a

specific customer.

1 Click the Where tab in the stack.

The Where view displays.

2 Click in the box below Column in the Where view.

A down arrow displays, and the box becomes a drop-down list box.

3 Select "customer"."id".
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Create a second DataWindow object

170

Your selection displaysimmediately below the Column heading. An equal
sign (=) appearsin the Operator box. Thisis correct, so do not change it.

Calurin Cperator Walue Logical
r'customer"."id"

Sort ahere AGroup yHaving ACompube 3 Syntax
E——

Right-click in the box below the Value column header in the Where
view.

Select Arguments from the pop-up menu, select : cust _i d, and click
Paste.

Column Cperator Walue Logical
r'customer"."id" '= |: cust_jd

Sort aWwhere 4Group hHaving aCompuke 3 Syntax

Click the Syntax tab in the stack.
The Syntax view displays the modified SELECT statement.

Scroll down until you see the generated WHERE clause.

You have now created a complete SQL SELECT statement that retrieves
data from several columnsin the customer table where the id columniis
equal to an argument that will be supplied during execution.
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View the DataWindow in the DataWindow painter

Now you view the Datawindow in the DataWindow painter using the Design
and Preview views.

1 Click the Return button in the PainterBar
or
Select File>Return To DataWindow Painter from the menu bar.

The Datawindow wizard asks you to select the borders and colors for the
new DatawWindow object.

2 Select Raised from the Border drop-down list box for columns.
Click Next.

You have added raised borders to the columns, but not to the labelsin the
Datawindow object. The DatawWindow wizard summarizes your
selections.

3 Click Finish.

Because you sel ected the Retrieve On Preview check box and because the
Preview view is part of the default layout scheme for the Datawindow
painter, the Specify Retrieval Arguments dialog box appears.

This dialog box prompts you for an argument value. When you put this
Datawindow object into the tutoria application, you write a script that
passes the required argument to the DataWindow object automatically.

Specify Retrieval Arguments @

Apgurnent

Paosition Manne Type Yalue

J_-’— |—1 }:ust_id F\.Iumber [ J
E=r T
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Create a second DataWindow object

Type a customer ID (such as 101, 102, or 103) in the Value field.

Click OK.

The Datawindow painter opens. The Design view displays the new

Datawindow object.

B (Untitled) * (pbtutor) - DataWindow

(=]
[ Design - {untitled)
Header { -
Customer ID: id =
First Name: frame
Last Name: Iname
Address: address
City: city
State: state
Zip Code: zip
Phone Humber: phone
Company Mame: company_name
[Detail t
[Summary {
:FoolerT b
< | >
=i —n

Changing font sizes

If you cannot see all lettersin alabel, press Ctrl+A to select al theitems
in the Datawindow, then select asmaller font size in the StyleBar.

The Datawindow Preview view retrieves the requested customer data.

[ #rre

ew - (untitled)

Customer ID: m

First Name: Michaels
Last Name: Devin

Address: 3114 Pioneer Avenue

City: Rutherford
Slale:M
Zip Code: 07070-
Phone Humber: [201] 555-8966

Company Mame: The Power Group
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Retrieving other records ) )
If you want to preview the record for another customer, you can right-click

inside the Datawindow Preview view, select Retrieve from the pop-up
menu, then specify a different customer ID in the Specify Retrieval
Arguments dial og box.

Save the DataWindow object

Now you name the DataWindow object and save it. You could wait to save it
until you leave the painter, but it is good practice to save your work frequently.

1 Select File>Save from the menu bar.

The Save Datawindow dialog box displays.

2 Make sure pbtutor.pbl is selected in the Application Libraries box.
Type d_cust oner in the DataWindows box.

Earlier you saved a DataWindow object asd_custlist.

3 (Optional) Type the following comments in the Comments box.

This DataW ndow retrieves all colums for the
Custoner table. It is useful as a detail DataW ndow.

4  Click OK.
Save DatalWindow E|
Datawindows:
d_cuskomer
d_custlist

Comments;

This Datawindow retrieves all columngs For the Customer
table, It is useful as a detail Datavindow,

Application Libraries:

\PowerBuilder 11,01 Tutorialipbtutor .l
\PowerBuilder 11,04 Tutorial\tutor_pb.)

C:iProgram Filesy
C:\Program Files!,

£ >

You return to the DataWindow painter.
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Make cosmetic changes to the second DataWindow object

Make cosmetic changes to the second DatawWindow

object

Where you are
Create and preview a new DataWindow object
Save the DataWindow object
Make cosmetic changes to the first DataWindow object
Create a second DataWindow object
> Make cosmetic changes to the second DataWindow object

Now you modify the Datawindow object. You:

» Rearrange the columns and labels

» Align the columns and labels

» Display the arrow for a drop-down Datawindow edit style

Columns on freeform DataWindows
Data fields on freeform DataWindow objects are till called columns, even

though they are shown in a nontabular display.

Rearrange the columns and labels

174

Now you rearrange the columns and label sin the new DataWindow object. You
can maximize the Design view for greater ease in manipulating the columns
and their labels.

1 Click the Address: label in the Design view.
Hold the Ctrl key and click the address column.

The two items are selected.

2 Keep the Ctrl key pressed and click the following column labels and
column controls:

Label Column
City: city
State: state

Zip Code: zZip
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If necessary, scroll down until you can see all the columnsin the
Datawindow.

Release the Ctrl key.
Position the cursor on one of the selected objects and drag it to the
top-right corner of the DataWindow object.

The objects move together.

Use the Ctrl+click technique to move the following label and column
controls to the location indicated:

Label Move with column Move under
Company Name: company_name Last Name:
Phone Number: phone Company Name:

Drag the Detail band up below the last column label.
This removes any extra space in the detail area.

Some of the fields might overlap others. You fix thisin the next exercise.
The Datawindow should now look like thisin the Design view:

[=]
[ Design - {untitled)

Header { -
Customer ID: id Address: address |
First Name: fname City: city
Last Name: Iname State: state
Company Mame: company_name Pip Code: zip |
Phone Humber: phone
| Detail t
:SummarguI T
:Fooler T bt
£ >
— -

The DatawWindow Preview view |looks like this:

I [ Preview - (untitled)

Customer ID: m Address: 3114 Pioneer Avenue
First Name: Michaelz City: Rutherford
Last MName: Devin Slale:M
Company Mame: The Power Group Pip Code: 07070- |
Phone Humber: [201] 555-8966
r— - =
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Align the columns and labels

[k
(R ol

176

Left

Now you align the columns and labels on the new Datawindow.

Select the Zip Code: label in the Design view.
Move the Zip Code: label as close as possible to the company_name
column.

A narrow space should separate the | eft edge of thelabel box from theright
edge of the column box.

While the Zip Code: label is still selected, use the Ctrl+click technique
to select the Address:, City:, and State: labels.

Select Format>Align from the menu bar.

A cascading menu of align options displays.

Select the first option (Align left).

PowerBuilder alignstheleft edges of the sel ected objectswith theleft edge
of thefirst item you selected (the Zip Code: 1abel).

Selecting an alignment tool from the PainterBar
You can access adrop-down list of alignment tools by clicking the Align

button on PainterBar?2.

Move the zip column so that it is next to the Zip Code: label.
Align the address, city, and state columns with the zip column, just as
you aligned the column labels.
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Display the arrow for a drop-down DataWindow edit style

The column for the customer state of residence has a DropdownDatawWindow
edit style. Thisis an extended attribute associated with the State column in the
EAS Demo DB database. The (drop-down) Datawindow with which the
column is associated has alist of states and their two-letter postal codes.

Getting Started

You can make the state selection list visible at all timesin your application or
you candisplay anarrow at all timestoindicatethat aselectionlistisavailable.
Now you change the property for the state column to show the arrow at all
times.

4

Click the state column in the Design view.
Make sure the Properties view displays.

The Properties view displays properties of the column.

Click the Edit tab in the Properties view.

You might need to click the arrow keys near the top of the Properties view
to display the Edit tab before you can click it. Notice that the Style Type
selection is DropDownDW.

Select the Always Show Arrow check box.
Make sure the state column in the Design view is wide enough to
display two characters plus the arrow symbol.

An arrow appears next to the state column in the Design and Preview
views. While the column is selected in Design view, you can make the
columnwider by holding the cursor over the right edge of the column until
the cursor symbol changes to a double-headed arrow, then dragging the
edge toward the rightmost frame of the view.

Customer ID: id Addiessaddiess |
First Hame: fname City:city
Last Name: Ihame Slale.:stateﬂ
Company Hame: company_name |Zip Code:zip |

Phone Number: phone

Detail T
Summary T

Footer |

< >

Click the Save button in PainterBarl.
Click the Close button in PainterBarl.
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LESSON 8

Getting Started

Attaching the DataWindow
Objects

After you create and save a Datawindow object, you can useitina
window. You have already created thed_custlist and the d_customer
Datawindow objects. Now you associate each of these DatawWindow
objects with a Datawindow control in the w_customers window.

In this lesson you:

e Attach the Datawindow object to the master Datawindow control

e Attach the Datawindow object to the detail DatawWindow control

* Runthe application
e Attach Datawindow objects to the Product window
* Runthe application again

How long does it take?
About 15 minutes.
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Attach the DataWindow object to the master DataWindow control

Attach the DataWindow object to the master
DataWindow control

180

Where you are
> Attach the DataWindow object to the master DataWindow control
Attach the DataWindow object to the detail DataWindow control
Run the application
Attach DataWindow objects to the Product window
Run the application again

Now you attach the DatawWindow object to a Datawindow control in the
w_customers window.

1 Expand the pbtutor.pbl branch in the System Tree.

=]

<

or

@ MyWorkspace {Z:\Program Files!Sybase\PowerBuilder 1.4
(2] pbtutor {C:"Program Files'\Sybase'PowerBu
=B pbtutor.pbl {C:\Program Files\Sybase\PowerBui

#-[d pbtutor

[# d_custlist

+) m_rmy_sheet

| m_pbtutor_frame

|- =] m_pbtutor_sheet

g n_pbtutor_connectservice

n_pbtutor sheetmanager

detall |_ancestor
11 w_pbtutor_about
I w_phtutor_basesheet
1] w_pbtutor_Frame
11 w_pbtutor_toolbars
1 w_products
11 w_welcome

[#-[J Properties

[#-(7 Events

[ (3 Functions

3 Struckures
[ 3 Controls

08888888888

=B, tutor_pb.pbl {C:\Program Files|Syvbase|PowerBL ¥

@Workspace Q' Page Language |_=E-C0mponents

Right-click w_customers and select Edit from the pop-up menu

Double-click w_customers in the System Tree.

The Window painter displays the w_customers window.
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Getting Started

Right-click the top DataWindow control (dw_master) in the Layout
view.

If the Properties view is not displayed, select Properties from the
pop-up menu.

Click the ellipsis button next to the DataObject box in the Properties
view.

The Select Object dialog box displays.

Select d_custlist in the DataWindows list box and click OK.

PowerBuilder associates the d_custlist DataWindow object with the
dw_master Datawindow control.

The Layout view now showsthe d_custlist DataWindow headings inside
the dw_master control, but you do not see any data yet. The DataWindow
does not execute its SELECT statement until you run the application.

W w_customers * {pbiutor) (C:\Program Files\Sybase\PowerBuilder, 11.0¥Tutorialipbtutor. pbl)... E]@\g|

A1 General | Other
Customer First Name Last Name
]

DataCbiject

d_rustlist D

Title

I L} ‘Tag |
gl |
Visible

Enabled

[CITitlear

[ cantrolMenu

[ maxgox
...................................... g
...................................... [Hscrolbar

¥5crollBar

LiveScrol

¥ | CHsplitscrall
< * [ PO >

.\I_ayuut open JEvent List yFunction Lisk \Declare Instance Yariables Lt I\Properties AControl List jNon-visual Otﬂ

Adding DataWindow objects to the window using drag and drop
In thistutorial, you use a custom Datawindow control that has built-in error

handling. If you want to use the standard DatawWindow control, you do not need
to add the control to the window and then attach a DataWindow object to it as
you did in thislesson. You can simply select the DataWindow object you want
from the System Tree and drag it onto the window in the Layout view.
PowerBuilder creates the Datawindow control for you.
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Attach the DataWindow object to the detail DataWindow control

Attach the DataWindow object to the detail
DataWindow control

Where you are

Attach the DataWindow object to the master DataWindow control
> Attach the DataWindow object to the detail DataWindow control

Run the application

Attach DataWindow objects to the Product window

Run the application again

Now you attach a DataWindow object to the detail Datawindow control. The
Window painter should still be open for the w_customers window.

1 Select the bottom DataWindow control (dw_detail) in the Layout view.
Click the ellipsis button next to the DataObject box in the Properties
view.

Select d_customer in the Select Object dialog box and click OK.

PowerBuilder associates the d_customer DataWindow object with the
dw_detail Datawindow control. The Window painter workspace now
shows the d_customer DatawWindow object inside the dw_detail control.

2 Inthe Layout view, make the dw_detail control larger so that you can
see all of the columns you added to the Datawindow object.

If you need to, you can al so enlarge the window to make moreroom. If you
make the dw_detail control wider, you may also want to make the
dw_master control the same width.

—
L ayvout
Customer First Mame Last Name Company Mame i
...................................................................... R
Customer 1D: Addiess:
First Mame: City:
Last Name: State: v
Company Name: Zip Code: - |
Phone Mumber: [ | -
ZZZZZZZZZZZZZZZZZZZZ.ZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZZ s
< >
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Run the application

Where you are

Attach the DataWindow object to the master DataWindow control

Attach the DataWindow object to the detail DatawWindow control
> Run the application

Attach DataWindow objects to the Product window

Run the application again

Now you run the application again to test the insert, update, and delete
capabilities of the second Datawindow.

:ﬁ.’ 1 Click the Run button in the PowerBar.

R PowerBuilder prompts you to save your changes.

2 Click Yes.

The application begins running, and the login window displays.

3 Typedba inthe User ID box.
Type sql inthe Password box and click OK.

The database connection is established, and the MDI frame for the
application displays.

4  Select File>Report>Maintain Customers from the menu bar.

The Customer window displays.

= maintain customers:1

Customer Firgt Name Last Mame Companp Mame A
1D
ﬁ Michasls Devin The Power Group
I 102 Beth Fisiser AMF Corp.
103 Erin Miedringhaus Darling Associates
104 Meghan Mazon P.5.C.
105 Laura McCarthy Amo & Sons @
Customer 1D: 1 Address3114 Pioneer Avenue
First Name: Michaels City:Rutherford
Last Mame: Devin State: M) w
Company Mame: The Power Group ‘Zip Code:07070- |
Phone Number: [201) 555-8366
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Run the application

184

The top Datawindow control (dw_master) showsall of the rowsretrieved
from the Customer table. The hand pointer shows which row is selected.

The bottom DatawWindow control (dw_detail) shows further information
about the selected customer.

In the running application, click the Insert button in the toolbar
or
Select Edit>Insert from the Frame window menu bar.

This clears (resets) the dw_detail Datawindow, allowing you to add
information for anew row that you will insert into the data source. The
cursor isin the Customer 1D box in the dw_detail control.

Add a new customer row by entering information in the boxes in the
detail Datawindow.

Typing information for a new customer
The Customer ID number must be unique. To avoid duplicate numbers,

useafour-digit number for your new database entry, or scroll down thelist
of three-digit customer numbers in the master Datawindow and select an
ID number that does not appear in thelist.

Enter values for the remaining fields.

The phone number and zip code use edit masks to display the information
youtype. You must enter numbersonly for these datafields. To specify the
state in which the customer resides, you must click the arrow next to the

state column and select an entry from the drop-down list box.

Click the Update button in the toolbar
or
Select Edit>Update from the menu bar.

This sends the new customer data to the database and displays a
confirmation message, as coded in the script for the ue_update event.

The new customer does not yet display in the master Datawindow. (You
could add code to include this feature). However, if you open another
instance of thew_customers sheet, the new customer dataisvisiblein both
the master and detail DataWindow controls.

PowerBuilder



Lesson 8 Attaching the Datawindow Objects

8 Click OK in the message box.
Click a customer in the master DataWindow.

That customer data displaysin the lower DatawWindow.
9 Change the customer address in the detail DataWindow.

10 Click the Update button in the toolbar
or
Select Edit>Update from the menu bar.

This sends the revised customer data to the database and displays another
confirmation message.

11 Click OK in the message box.
Select another customer in the master DataWindow.

That customer data displays in the detail DataWindow.

12 Click the Delete button in the toolbar
or
Select Edit>Delete from the menu bar.

The customer is deleted from the DatawWindow immediately but is not
deleted from the database unless you select the Update option on the Edit
menu. In this particular situation, the Update operation may fail, because
rows in other tablesin the EAS Demo DB database may refer to the row
that you are trying to delete.

You should be able to delete any row that you have added to the database.

13 Select File>Exit from the menu bar.

The application terminates and you return to the Window painter.

14 Close the Window painter.
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Attach DataWindow objects to the Product window
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Where you are
Attach the DataWindow object to the master DataWindow control
Attach the DataWindow object to the detail DataWindow control
Run the application

> Attach DataWindow objects to the Product window
Run the application again

Now you add two Datawindow objects to the w_products window. These
Datawindow objects are provided for you in the tutor_pb.pbl library.

1 Right-click w_products in the System Tree and select Edit from the
pop-up menu
or
Double-click w_products in the System Tree.

The Window painter displays the w_products window.

2 Ifthe Control List view is not open, select View>Control List from the
View menu.
Select the dw_master DataWindow control in the Control List view.
Click the ellipsis button next to the DataObject box in the Properties
view.

PowerBuilder displays the Select Object dialog box.

3 Select tutor_pb.pbl in the Application Libraries box.
Select d_prodlist in the DataWindows box and click OK.

The Data Object box in the Properties view of the Window painter now
displaysd_prodlist.
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PowerBuilder associates the d_prodlist DataWindow object with the
dw_master Datawindow control in the w_products window. You see the
headings for the DataWindow object in the Layout view. You might need
to resize the control and/or the window.

Product  Praduct Mame Product Description Unit Price
10

Click the dw_detail DataWindow control in the Control List view.
Click the ellipsis button next to the DataObject box in the Properties
view.

The Select Object dialog box displays.

Select tutor_pb.pbl in the Application Libraries box.
Select d_product in the DataWindows list box and click OK.

You return to the Window painter.

PowerBuilder associates the d_product DataWindow object with the
dw_detail Datawindow control. The Layout view now shows the
d_product DataWindow object inside the dw_detail control. The
d_product DataWindow object has seven columns labeled Product 1D,
Product Name, Product Description, Size, Color, Quantity, and Unit Price.

If necessary, in the Layout view, make the dw_detail control larger so that
you can see al of the columns in the Datawindow object. You can also
enlarge the window to make more room.
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Run the application again

Where you are
Attach the DataWindow object to the master DataWindow control
Attach the DataWindow object to the detail DataWindow control
Run the application
Attach DataWindow objects to the Product window

> Run the application again

Now you run the application again to test the Product window.

At this point the Product window should have al of the capabilities of the
Customer window. Like the Customer window, the Product window functions
as a master/detail window, providing support for retrieval, insert, update, and
delete operations against the database.

1 Click the Run button in the PowerBar.

Run PowerBuilder prompts you to save your changes.

2 Click Yes.
The application begins running, and the login window displays.

3 Type dbain the User ID box.
Type sql in the Password box and click OK.

The database connection is established, and the MDI frame for the
application displays.

188 PowerBuilder



Lesson 8 Attaching the Datawindow Objects

Getting Started

Select File>Report>Maintain Products from the menu bar.

The Product window displays. The top Datawindow control showsall of
the rows retrieved from the Product table.

The bottom DatawWindow control shows information about the product
selection in the top Datawindow control.

2 Frame
File Edit Window Help

| &0

| =2 =@ =

= maintain products:1 E“E]FT_(J
Product  Product Mame Product Description Unit Price
D
T3 S Tee Shin Tank Top $9.00
301 Tee Shirt Weneck §14.00
302 Tee Shirt Crew Meck $14.00
400 Baseball Cap Cotton Cap $9.00

v

Product 1D: | SDDF Color: [White V}_
Product Mame: ; Cluantity:
Praduct Descriptian: |T_ank Tap Unit Price: | _$5.00f

Size:fgmal |

Select Edit>Insert from the menu bar.

This clearsthe dw_detail DataWindow and allows you to add a new row
to the Datawindow. The cursor isin the Product ID box in the dw_detail
control.

Add a new product row by entering information in the boxes in the
lower DataWindow.

Use the Tab key to move from box to box.
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12
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Select Edit>Update from the menu bar.

This sends the new product data to the database and displays a
confirmation message, as coded in the script for the ue_update event.

The new product does not display yet in the top DatawWindow, but if you
open another product sheet, the new information displays. If you want, you
can add code to the Clicked event of the update button to automatically
refresh the data in the master DatawWindow control.

Click OK in the message box.
Click a product in the master DataWindow.

That product data displaysin the detail Datawindow.

Change the product’s unit price.
Select Edit>Update from the menu bar.

This sends the revised product data to the database and displays another
confirmation message.

Click OK in the message box.
Select another product in the master DataWindow.

That product’s data displays in the detail Datawindow.

Select Edit>Delete from the menu bar.

The product is deleted from the DatawWindow immediately but is not
deleted from the database until you select the Update option on the Edit
menu.

Select File>Exit from the menu bar.

The application closes and you return to the Window painter.

Close the Window painter.
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Running the Debugger

Sometimes your application does not behave the way you think it will.
Perhaps a variable is not being assigned the value you expect, or a script
does not do what you want it to. In these situations, you can closely
examine your application by running it in debug mode.

In debug mode, you can set breakpoints (stops) in scripts and functions,
step through the code line by line, and display the contents of variablesto
locate logic errors and mistakes that result in errors during execution.
When you run your application in debug mode, PowerBuilder suspends
execution just before it hits aline containing a breakpoint. You can then
look at and correct the values of variables.

In this lesson you:

e Add breakpointsin application scripts

¢ Runindebug mode

e Set awatch and a conditional breakpoint

How long does it take?
About 20 minutes.
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Add breakpoints in application scripts

Where you are

> Add breakpoints in application scripts
Run in debug mode
Set a watch and a conditional breakpoint

Now you open the Debugger and add breakpoints to examine the behavior of
the login and Customer windows. When PowerBuilder runs the application in
debug mode, it stops just before executing a line containing a breakpoint.

When you insert breakpointsin a script, you should select lines that contain
executable statements. If you try to set a breakpoint in variable-declaration
lines, comment lines, or blank lines, PowerBuilder sets the breakpoint at the
next executable line.

fﬁ 1 Click the Debug button in the PowerBar.

s PowerBuilder opensthe Debugger. There are three stacks of tabbed panes
in the default view layout scheme. The Source view isvisiblein asingle
pane at the top left of the Debug window. The Source Browser view is
open in the pane at the top right.

If the Debug window looks different
If you have opened the Debug window before and opened, moved, or

closed any views, your display may look different. To restore the default
view layout scheme, select View>Layouts>Default from the menu bar.

® Debugger - pbiutor

commandline ) for pbrutor

Fix open: Application Open Script: £5 dose ()
Iz 1) Opens frame windou £F gpen ( string commandiine )
Windows

/* This prevents double toolbars =/
this.ToolBarFrameTitle = "MDI Application Toolbar™
this.ToolBarSheetTitle = “MDI Application Toolbar™

User Objects
Functians

f+ Open MDI frame windouw =/
Open { w_pbtutor_frame )

B
B

Source Browser 45ource History

Local {Global kInstance aParent hShared sObijects in Memory 4Call Stack dBreakpoints hwatch
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The source code for the application Open event displaysin the Source
view at top left. If it does not display, expand the Application node in the
Source Browser view's tree view and double-click the Open event under
the pbtutor application.

In the Source view, double-click the line containing the following
assignment statement:

this. Tool Bar Sheet Title = "MDl Application Tool bar"

A black breakpoint symbol displays at the start of the line to show that a
breakpoint has been set on the statement.

fi= open: Application Open Script:
IF 1) Opens frame window

/* This prevents double toolbars =/
this.ToolBarFrameTitle = "MDI Application Toolbar™
#this.ToolBarSheetTitle = "HDI Application Toolbar™

/= Open HDI frame window =/
Open { w _pbtutor_frame )

Expand the following node in the Source Browser view:
Windows>w_welcome>cb_ok

The Source Browser view listsonly eventsthat have been coded. The only
event for the login window OK button is the Clicked event.

Double-click the Clicked event for the cb_ok button in the Source

Browser view.

The code for the Clicked event displaysin the Source view.

193



Add breakpoints in application scripts

194

5

Double-click the following line:

gnv_connect = CREATE &
n_pbt ut or _connect service

A breakpoint symbol displays at the start of the line.

#f 2) Close login window if connection successful [T w_customers
@[ w_master_detail_ancestor
egnu_connect = CREATE & =~ w_pbtutor_about
n_pbtutor_connectservice -7 w_pbtutor_basesheet

#- [ w_pbtutor_frame
- w_pbtutor_toolbars
- w_products
=3 w_welcome
[ ch_cancel

/fLocal variable declarations
string 1s_database, 1ls_userid, 1s_password

/ffAssignment statements

1s_userid = Trim { sle_userid.text )

1s_password = Trim ( sle_password.text )
1s_database = "ConnectString='DSH=EAS Demo DB U118;"

//Instantiate with user-entry values

SQLCA.userid = 1s_userid - sle_userid

SQLCA.dbpass = 1s_password st_password

SOLCA.dbparm = 1s_database + "UID=" + & st_userid
1s_userid + ";PWD=" + 15_passuord + "'" st_welcome

e} Menus
IF gnv_connect.of_ConnectDB { ) = 8 THEHN L 8 User Ohiects
Close (parent) [+ 8 Functions
END IF - o
£ >

4 b Source Browser gSource History
=i =i = ]
I\anal.{GInbaIhInstantexParantaSharedaOh]ects in Memory j\(all Starck {Breakpoints Awatch

Double-click w_master_detail_ancestor in the Source Browser view.
Double-click dw_master, then rowfocuschanged.

PowerBuilder displays the script for the RowFocusChanged event of the
dw_master Datawindow control in the Source view.

Double-click this line:
IF dw detail.Retrieve(ll_itemum = -1 THEN
A breakpoint symbol displays at the start of the line.
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8

Select the Breakpoints tab in the lower-right stack.

® Debupger - pbtutor

w_customers
wi_master_dstail_sncestor
E7 open () returnslong
E" ue_delsts ()
£ ue_insert ()
E" ue_retrieve ()
E" ue_update ()
[ dw_detail
[ dw_master
EF rowfacuschanged ( long currentrow ) returns long

i

7 w_pbhutor_sbout

3 w_pbhutor_bassshest

3 w_pbhutor_Frame

7 w_pbhutor_toolbars

9 w_products

=7 w_welcome -
[l cb_cancel
=L ch_ok

EF clicked () returns long
[ p_sparts
[ sle_password v
Source Browser dSource History

butor.open.&
* w_welcome.cb_ok, clicked.4

® w_master_detail_sncestor dw_master.rowfocuschanged.

long 11_itemnum
11_itemnum = this.object.data[currentrow, 1]
®IF duw_detail.Retrieve{11l_itemnum) = -1 THEH
MessageBox("Retrieve","Retrieve error-detail")
EHD IF
|
Local {GlobalInstance yParent s3hared yObjects in Memary

| |hCall Stack yBreakpoints gwatch

You should see the breakpoints you set in the Breakpoints view. To
complete this lesson, you need to have these breakpoints set correctly.

If you have additional breakpoints

You can clear any excess breakpoints using the pop-up menu in the

Breakpoints view.
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Run in debug mode

Where you are
Add breakpoints in application scripts
> Run in debug mode
Set a watch and a conditional breakpoint

Now you run the application in debug mode. You step through the code line by
line.

About the Step buttons
You can use either Step In or Step Over to step through an application one

statement at atime. They have the same result except when the next statement
contains a call to afunction.

Use Step Over to execute the function as asingle statement. Use Step In if you
want to step into a function and examine the effects of each statement in the
function.

If you have stepped into afunction, you can use Step Out to execute the rest of
the function as a single step and return to the next statement in the script that
called the function.

1 Click the Start button in PainterBarl

iﬁ& or

Stk Select Debug>Start pbtutor from the menu bar.

The application starts and runs until it hits a breakpoint (in this case, the
call to the assignment statement for the toolbar title for sheet windows).

You return to the Debug window, with the line containing the breakpoint
displayed. The yellow arrow cursor means that this line contains the next
statement to be executed.

2 Click the Global tab in the lower-left stack.

The Global Variables view displays.
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.

Etep In

Double-click transaction sqlca.
Find the DBMS property, which has a String datatype.

Notice that this property does not yet have a value associated with it
because the Debugger interrupted execution before the ProfileString
function executed.

Global
+-{4)= error ervor
+-9)= message message

(%)= n_pbtutor _conneckservice gnv_conneck
+-{4)= pbtutor pbtutar
=R transaction sglca

<B* boolean autocommit = False
<H> long sqlcode = 0

<07 long sgldbcode = 0

<H> long sqinrows = 0

<07 powerobject classdefinition
<H» string database = "

<07 string dbms = ™

<H? string dbparm = "

<@ string dbpass = ™

<H* string lock= """

<@ string logid = ™

<H* string logpass= "

<H> string servername = ™'

<0 string sglerrtext = ™

<H> string sqlreturndata = "
<@ string userid = ™

To execute the next statement, click the Step In button in PainterBarl
or
Select Debug>Step In from the menu bar.

The application starts execution of the Open event for the MDI frame
window.

Use Step In or Step Over to step through the code until you reach this
statement in the script for the frame window Open event:

open(w_wel cone)
After PowerBuilder finishes executing this statement, the login window
displays and the Debug window is minimized.

The Open event for the frame window also has a posted call to the
ue_postopen function (that you stepped through without examining). This
function in turn includes code that starts the processing of a chain of sheet
manager functions. These functions are processed at the end of the script
for the Open event, after the login window displays.
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R
Etep Cver

-

Etep COut

Click Step Over until the login window displays and the Debugger is
minimized.

Type dba in the User ID box of the login window.

Type sql in the Password box and click OK.

You return to the Debug window. The yellow arrow in the Source view
points to the next executable statement, the CREATE statement for the
connection service object. Thisisthefirst executable linein the script for
the Clicked event of the cb_ok command button.

Select the Call Stack tab in the lower-right stack.

The yellow arrow in the Call Stack view indicates the current location in
the call stack. If you double-click another linein the stack, the Source and
Variables views change to display the context of that line, and a green

arrow indicatesthelineinthe Sourceview. If youthen single-click another
linein the stack, agreen arrow displaysin the Call Stack view to indicate
thelinefor which context is displayed. When you continueto step through
the code, the Source and Variables views return to the current context.

Click the Step In button.

The Debugger takes you to the script for the Constructor event of the
connection service object.

Click the Step Out button.
Click the Global tab in the lower-left stack.
Look again at the Transaction object properties.

You step out of the Constructor event in asingle step and return to the
script for the OK button Clicked event. Now the value of sglcode has
changed, and the sglerrortext and DBM S property have values, but the
UserID, DBPass, and DBParm properties do not.
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Thevalueswere assigned during execution of the Constructor event of the
connection service object after the of _GetConnectionlnfo function
returned information fromthe NI file, but because you commented out the
linesin the code for the UserlD, DBPass, and DBParm properties, these
values were not retrieved.

()= pbtutor phtutar A
[=-#49= transaction sglca 1
<H» boolean autocommit = False
<E¥ long sglcode = -1
4% long sgldbcade = 0
<@¥ long sglnrows = 0
<0 powerobject classdefinition
£@» string database = ™
<[ string dbms = "ODBC"
4@ string dbparr = ™
4@ string dbpass =
<M string lock = ™
<@ string logid =
<[ string logpass =
<H* string servername =
4@¥ string sqlerrtext = "Transaction not connected”
<[ string sglreturndata = ™
<@ skring userid = ™
[#-049= window w_pbtutor_frame “
Local yGlobal {Instance hParent 3Shared yObjects in Memory

10 Click on the Local tab in the lower-left stack.

Thelocal variables for the Clicked script have not yet been assigned
values.

11 Usethe Step In button to step through the three assignment
statements for the local variables.

As you step through each statement, you can check that the values
assigned to the local variables are what you expected.

FELocal =]
(7 string ls_database = "ConnectString="DSM=EAS Demao DB ¥110;"
(05 string ls_password = "sql"

7 string ls_userid = "dba"

Local AGlobal yInstance aParent 3,Shared yiobjects in Memory
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U=

Cantinue:

12 Click again on the Global tab in the lower-left stack and expand the

13

14

Transaction object.

Use the Step In button to step through the three lines that instantiate
the Transaction object (SQLCA) with user-entry values for UserID,
DBPass, and DBParm.

Asyou step through each statement, you can check that the values you
entered in the login window are being assigned to the Transaction object.
You are still not connected to the database until the connection service
object of _Connect function is executed.

Global

= (%)= transaction sqlca ~
<0 boolean sutocommit = False
40 long sglcode = -1
40 long sqldbcode = 0
40 long sqlnrows = 0
<M» powerobiect classdefinition
<M string database = ™
<M string dbms = "0ODEC"
40 string dbparm = "ConnectString="0SN=EAS Demo DB ¥110;UID=dba;PWD=sg"
£M string dbpass = "sql"
A0 string lock = ™
£M string logid = ™
40 string logpass = ™ “w

Local yGlobal Instance yParent i Shared yObjects in Memary

Click the Continue button in PainterBarl.

The Continue button resumes execution until the next breakpoint. The
database connection is established, the login window closes, and the M DI
frame for your application displays. The application is waiting for user
input.

Select File>Report>Maintain Customers from the menu bar.

The application continues until it reaches the line in the
RowFocusChanged event that contains the next breakpoint you added.

The RowFocusChanged event for a Datawindow occurs before the
Datawindow is displayed. For this reason, execution stops before the
Customer window is opened.
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Set a watch and a conditional breakpoint

Getting Started

(e

Cantinue:

Where you are
Add breakpoints in application scripts
Run in debug mode

> Set a watch and a conditional breakpoint

Next you set awatch on a variable whose value changes when the user selects
arow inthe Customer window. You then change one of the simple breakpoints
you have set into aconditional breakpoint that istriggered only when avariable
has a specific value.

1 Click the Watch tab in the lower-right stack.
Click the Local tab in the lower-left stack.
Select the |l_itemnum variable in the Local view and drag it to the
Watch view.

Thell_itemnum variableis set to 101, the ID of the first customer
retrieved. Displaying it in the Watch view makesit easier to observe when
itsvalue changes. You can also drag Global, I nstance, and Parent variables
to the Watch view so that you can easily keep track of several variables of
different types.

2 Click the Continue button.

The application resumes execution. The Customer window displays and
shows the list of customers retrieved from the database. The detail
Datawindow shows information about customer 101.

3 Select a different row in the master DataWindow of the Customer
window.

You return to the Debug window. The new value of |l_itemnum displays
in both the Local Variables view and the Watch view.

4  Click the Breakpoints tab in the lower-right stack.
Double-click the rowfocuschanged breakpoint.

The Edit Breakpoints dialog box opens with the breakpoint in the
RowFocusChanged event selected.
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5

Type the following line in the Condition text box and click OK:
I'l _itemum = 107
Edit Breakpoints X
Location | yariable
® phiutor.open, 7

* w_welcome.ch_ok.clicked 4
® w_master_detail_ancestor.dw_master.rowfocuschanged. 3

Hew ][ Clear ][ Clear Al
Location: w_master_detail_ancestor.dw_master rowfocusche
Qccurrence:
Condition: | I _itemnum=107

[ OK ] [ Canicel ] [ Apply ] [ Help ]

The breakpoint in the RowFocusChanged event script isnow aconditional
breakpoint. PowerBuilder suspends execution only when it reaches this
statement and the value of |l _itemnumis 107.

Click OK to close the dialog box.
Click the Continue button.

The application resumes execution. Now you can select different rowsin
the Customer window, and the Debug window opens at the breakpoint
only if you select the customer whose ID is 107.

If you select customer 107, click the Continue button again to return to the
application.

Select File>Exit from the application’s menu bar.

The application terminates and you return to the Debug window.

Select File>Close from the menu bar.

You return to the PowerBuilder development environment.
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Exception Handling

Exception handling allows you to trap errors that occur during the
execution of aprogram and to provide useful information about those
errorsto the application user. This lesson describes how to create
user-defined exception objects and use them to catch exceptions that you
throw from amethod in a TRY -CATCH statement.

In this lesson you:

Add anew sheet window to the existing application
Create user-defined exception objects

Create a new user function and user event

Call the methods and catch the exceptions

Run the application

How long does it take?
About 45 minutes.
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Add a new sheet window to the existing application

Where you are
> Add a new sheet window to the existing application
Create user-defined exception objects
Create a new user function and user event
Call the methods and catch the exceptions
Run the application

In thislesson you add athird sheet window to the main tutorial application. You
create and call afunction to perform aroutine operation (calculate a
percentage) on values returned from embedded SQL commands and a value
selected by the application user from a drop-down list box control.

The prototype for the function you create throws user-defined exceptions. You
call the function in a TRY-CATCH block inside the Clicked event on a
command button control. The CATCH clausesin the Clicked event catch
user-defined exceptions thrown by the new function as well asa system
exception thrown up the application call stack.

You use the new sheet window to calculate the percentage of customers that
resides in a selected state. The controls you add to the new sheet window are:

»  Two static text boxesthat you change programmatically to display
read-only results

* A command button to call afunction that calculates percentages
» A drop-down list box for alist of states where customers reside

* A text box that displays the percentage of customersresiding in the state
that application users select from the drop-down list box

To add a sheet window to the existing application, you must:
*  Create the sheet window

»  Provide access to the sheet window from the main application frame
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Create the sheet window

You inherit the sheet window from the w_pbtutor_basesheet window. Thisis
the base class for sheet windows that you generated with the Template
Application wizard. You do not use thew_master_detail_ancestor extension
layer window, since the modifications you madeto it are not useful in the new
sheet window.

1 Select File>Inherit from the PowerBuilder menu.
Make sure the Objects of Type box displays Windows.
Select w_pbtutor_basesheet from the available windows in the
pbtutor.pbl library and click OK.

2 Make sure the Layout view displays in the Window painter.
Select Insert>Control>StaticText and click near the top left corner of
the Layout view.

3 Inthe Properties view, highlight the default text in the Text text box
and type the following:

1. Select or type a state code in drop-down Iist:

4  Lengthen the control width and the width of the sheet window to
display the entire text and allow room for a drop-down list control at
the top right of the window.

A length of 2250 should be sufficient for the sheet window width. You can
set this on the Other tab of the Properties view for the window, or you can
drag the window edge in the Layout view to make room for an additional
control.

5 Right-click the static text control in the Layout view and click
Duplicate from the pop-up menu.
In the Properties view, highlight the default text in the Text text box of
the new static text control and type the following:

2. Cick Percentage button
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6 Select Insert>Control>DropDownListBox and click to the right of the
static text boxes near the top right corner of the Layout view.

(=
Layout

7 Inthe Properties view for the drop-down list box, type ddl b_st at e
for the control name.
Select the AllowEdit and the VScrollBar check boxes.

8 Click the command button in the painter bar and click below the two
static text boxes.
Inthe Properties view, type cb_per cent for the button name and type
Per cent age for the button text.

9 Select Insert>Control>SingleLineEdit and click below the command
button in the Layout view.
In the Properties view, type sl e_resul t for the control name and
type the following for the control text:

Text box for percent of custoners in the sel ected
state

10 Lengthen the control width to display the entire text.

-1 2. Click Percentage button

|Text boy for percent of customers in the selected state
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11 Make sure no control is selected and the sheet window properties are
displayed in the Properties view.
Type Cust omer Locat i on for the Tag property.

The text you typed will be visible in the sheet window title at runtime.
Code in the basesheet ue_postopen event assigns the Tag text to the sheet
window title.

12 Select File>Save from the PowerBuilder menu.
Select pbtutor.pbl for the application library, type w_cust _pct for the
new sheet window name, and click OK.

This saves the new sheet window with all its controls to the main tutorial
library.

Provide access to the sheet window from the main application
frame

You must register the new sheet with the sheet manager.
1 Double-click w_pbtutor_frame in the System Tree.

2 If the ue_postopen event is not visible in the Script view, click the
Event List tab and double-click ue_postopen.

The ue_postopen event script displaysin the Script view.

3 Type the following line in the list of registered sheet windows:

| s_sheets[3] = "w_cust_pct"
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4

Type the following line below the list of sheet window titles to display:

I's_display[3] = "Customer Location"
c ] B
w_pbtutor_frame * | | = ue_postopen { ) returns none » EIEI
i *
¥ ue_postopen: Register the sheets
i 1

string Is_sheets]], Is_display[]

I* Register sheet windows with sheet manager */
Is_sheets[1] = "w_customers"

Is_sheets[2] = "w_products"

Is_sheets[3] = "w_cust_pct”

Is_display[1] = "Maintain Customers"
Is_display[2] = "Maintain Products"
Is_display[3] = ""Customer Location™

inv_sheetmgt.of_RegisterSheets [ 1s_sheets, Is_display ]

< ¥
Layaout hue_poskopen 4Event Lisk WFunction Lisk sDeclare Instance Yariables

Better coding practice
You could reduce the six lines of code for defining sheet windows and

their display names by replacing them with the following lines of code:

/1 Define sheet wi ndows and their display nanes
string |Is_sheets[]={"w_custoners", "w_products", &
"w_cust _pct"}
string |Is_display[]={"Mintain Custoners", &
"Mai ntain Products", "Custoner Location" }

Select File>Save and close the w_pbtutor_frame window.

The next time you run the pbtutor application, you should be able to open
the new sheet window from the File menu of the main frame window.
Although you can now run the new sheet window from the devel opment
environment, you must make sure that you can run it from a compiled
application aswell.

For this purpose, you reference the sheet windows as window objectsin
the sheet manager of _registersheet script. The reference is necessary for
the compiler to know that this object is used in the application so that it
will includeit in the executable.

You create a compiled application in Lesson 11, “ Preparing the
Application for Deployment.”
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6 Double-click n_pbtutor_sheetmanager in the System Tree.

7 Click the Function List tab and double-click of_registersheet.

The script for the of_registersheet function displaysin the Script view.

8 Typethefollowing after the lines declaring sheet window variables for
the w_customers and w_products windows:

w_cust_pct | w sheet3

% n_pbtutor_sheetmanager * (pbtutor) (C:\Program Files\Sybase\PowerBuilder 11.0

[ [m]
{Functions) w || = of_registersheet { readonly string & =]
i 1
If* of_RegisterSheet. Add a new sheet to the sheet array
i *1

long Il_s, Il_sheets

(I E3

I* These references to the mdi sheets provide the ability to
build an executable that includes these objects. Without
these references, these objects [ previously referenced only
in strings ] would not otherwise be included.

If you choose to use a PBR file or dynamic libraries, these
references can be removed *

w_customers lw_sheet]

w_products lw_sheet2

w_cust_pct Iw_sheet3

Il_sheets = UpperBound [ is_sheets ]

I* Make sure sheet is not already registered */
Forll_s =1 to ll_sheets

If Lower [ as_sheet] = is_sheets[ll_s] Then Return -1
Next

is_sheets[ll_sheets+1] = Lower [ as_sheet]
is_display[ll_sheetst1] = as_display

of_AddToMenu [ as_sheet, as_display ]
Return 1

£ | >
of _reqistersheet {Event Lisk yFunction Lisk hDeclare Instance Variables

9 Save and close the n_pbtutor_sheetmanager user object.
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Where you are

Add a new sheet window to the existing application
> Create user-defined exception objects

Create a new user function and user event

Call the methods and catch the exceptions

Run the application

Now you create two user-defined exception objectsthat you will throw from a
function that is invoked when the user clicks the command button on the
w_cust_pct window. You also create a user-defined exception object that you
throw from auser event on the drop-down list box control that you added to the
w_cust_pct window.

1 Select File>New from the PowerBuilder menu and click the PBObject
tab in the New dialog box.

2 Select the Standard Class icon and click OK.
Select t hr owabl e from the Types list box and click OK.

The new exception object displays in the User Object painter.

3 Inthe Text box of the Properties view, type the following:

No rows were returned fromthe database. |If you typed
or selected a state code in the drop-down |ist box
and the dat abase connecti on has not been cl osed,
either the state you entered has no custoners or you
entered the state code incorrectly.

The exception object has get and set methods for handling the Text
property. Here you set the text property directly in the user interface.

4  Click outside the Properties view to enable the Save button.
Select File>Save, select the pbtutor.pbl application library, and type
exc_no_rows in the User Objects box for the new exception object
name, and click OK.

5 Select File>Close.
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Repeat steps 1-5 using the
the exception object name:

Property

following values for the Text property and

Value

Text

Percent age too | ow. Only one cust oner
inthis state. Notify regional sales
manager. . .

Exception object name

exc_|low_number

Repeat steps 1-5 using the following values for the Text property and

the exception object name:

Property

Value

Text

You must use the two-letter postal
code for the state nane.

Exception object name

exc_bad_entry
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Where you are
Add a new sheet window to the existing application
Create user-defined exception objects
> Create a new user function and user event
Call the methods and catch the exceptions
Run the application

Now you add a function that you invoke from the Percentage command
button’s Clicked event and an event that istriggered when the focusis changed
from the drop-down list box on thew_cust_pct window. The function
calculates the percentage of customersliving in aparticular state. The event
processes the current value of the drop-down list box control to make sureit is
two charactersin length (for the state code).

1 Open w_cust_pctin the Window painter if it is not already open.
Select Insert>Function from the Window painter menu.

The Script view displays the Prototype window. The first drop-down list
box in the Script view displays (Functions) and the second drop-down list
box displays (New Function).

2 Select decimal for the Return Type and type uf _per cent age for
Function Name.

3 Select integer for the Argument Type and type ai _cust byst at e for
the Argument Name.

You will add a second argument in the next step.

4  Right-click anywhere in the Prototype window and select Add
Parameter from the pop-up menu.

5 Selectinteger for the second Argument Type and type ai _t ot al cust
for the second Argument Name.

6 Type exc_no_rows, exc_|l ow_nunber in the Throws box.
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7 Type the following script for the new function:

Deci mal ny_result
exc_no_rows le_nr
exc_|l ow_nunber |e_ex

/* Process two integers passed as paraneters.
Instantiate and throw exceptions if the first
integer value is 0 or 1. Gtherwise calculate a
percentage and return a nuneric value truncated to a
singl e deci mal place. If the second integer value is
0, catch and rethrow the runtine di vi debyzero error
during the cal cul ation.
*/
CHOOSE CASE ai _custhbystate
CASE 0

le_nr = create exc_no_rows

throw le_nr
CASE 1

| e_ex = create exc_| ow_nunber

throw | e_ex
CASE ELSE

TRY

my_resul t=(ai _custbystate/ai_total cust)*100
CATCH (di vi debyzeroerror |e_zero)
throw |l e_zero

End TRY
END CHOOSE
return truncate(my_result,1)

Later in thistutorial, you will call the uf_percentage function from the
Clicked event on the command button, passing in two integers and
processing the return value.

You now add a user event for the drop-down list box that throws the
exc_bad_entry exception object when a user-entered state code is not
exactly two charactersin length.

8 Selectddlb_statein the first drop-down list box of the Script view and
select (New Event) in the second drop-down list box.
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9 Select integer for Return Type and type ue_nodi fi ed for Event
Name.
Select string for Argument Type and type as_st at ecode for
Argument Name.
Type exc_bad_entry in the Throws box or drag it from the System
Tree to the Throws box.

Note that the Event ID is (None). You do not select an Event ID for the
ue_modified event. If you selected an Event 1D, you could not enter
user-defined exception objects in the event Throws clause.

10 Type the following script for the new ue_modified event:

exc_bad_entry |le_ex
/1 Make sure the current text in the drop-down |ist
//box is two characters in | ength. O herwi se,
//instantiate the exc_bad_entry excepti on obj ect and
//throw t he exception.
IF len(this.text)<>2 Then

le_ex = create exc_bad_entry

throw | e_ex
END | F
Return 1

Next you call the ue_modified event and the uf_percentage function, and
catch the exceptions thrown by these methods.

214 PowerBuilder



Lesson 10 Exception Handling

Call the methods and catch the exceptions

Where you are
Add a new sheet window to the existing application
Create user-defined exception objects
Create a new user function and user event
> Call the methods and catch the exceptions
Run the application

You now write code to populate the drop-down list box controls with state
codes from the customer tablein the EAS Demo DB database. Since you made
the control editable, an application user can also type in avaue for the state
code. Before you process a user-entered value, you check to make sure the
value conformsto the conditionsyou set inthe ue_modified event, namely that
it istwo charactersin length.

You also add code to the Clicked event of the command button control to
process the current state code in the drop-down list box control. In the Clicked
event you call the uf_percentage function to cal culate the percentage of
customers from the selected state and catch all exceptions that can be thrown
by the function.

1 Make sure the w_cust_pct is open in the Window painter and that
ddlb_state displays in the first drop-down list box of the Script view.

2 Select | osefocus () returns | ong [ pbm cbnkillfocus] inthe
second drop-down list box.

3 Call the ue_modified event and catch the exception object that it
throws by typing the following lines for the losefocus event script:

Try
this. EVENT ue_nodified(this.text)
Catch (exc_bad_entry | e_be)
messagebox ("from exc_bad_entry", &
| e_be. get nessage())
End Try

return 1

4 Selectconstructor ( ) returns |ong [ pbm constructor]
from the second drop-down list box in the Script view prototype
window for the ddIb_state control.
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5 Type the following lines in the Constructor event to populate the
drop-down list box control:

int li_nrows, n
string |Is_state

//Get the distinct count of all states in the
//custonmer table

SELECT count (distinct state) INTO :li_nrows
FROM cust oner ;

//Declare the SQ. cursor to select all states
//in custoner table but avoid
//rows with duplicate values for state.
DECLARE cust st at ecur sor CURSOR FCR
SELECT state FROM custoner
GROUP BY state HAVING count(state) =1
UNI ON
SELECT state FROM cust omner
GROUP BY state
HAVI NG count (st at e)>1;
OPEN cust st at ecursor ;
/! Popul ate the control with a single entry for
/levery state in the custoner table.
FOR n=1 TO |'i _nrows
FETCH NEXT custstatecursor INTO :|s_state;
this.additem |s_state)
NEXT
CLCSE cust st at ecur sor
/1Set first itemin list as selected item
this.selectitem (1)

6 Select cb_percent from the first drop-down list in the Script view.
Make sureclicked () returns long [ pbm bnclicked]
displays in the second drop-down list box.

7 Type the following lines for the Clicked event script:

Deci mal ny_result

Doubl e entry_1, entry_2
Int Ii_int, Ii_rtn
String sel _state

sel _state=ddl b_state.text

/1 Get the nunber of rows with custoners fromthe
//selected states and place in the entry_1 vari abl e.
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/Il Change the first static control to display this
/I number .

SELECT count(*) INTO :entry_1 FROM cust omner
VWHERE cust oner . st at e=: sel _state;
st_1.text="Custoners in state: " + string(entry_1)

/1 Get the total number of custonmers and place in
//the entry_2 vari abl e.
/] Change the second static control to display this
/I nunmber .
SELECT count(*) INTO :entry_2 FROM custoner;
st _2.text="Total nunber of customers: " &

+ string(entry_2)

[/ Call uf_percentage and catch its exceptions.
TRY
my_result = uf_percentage (entry_1, entry_2)
CATCH (exc_no_rows e_nr )
MessageBox(" From exc_no_rows", &
e_nr.get message())
CATCH (exc_l ow_nunber e _In )
li_int=1
MessageBox(" From exc_| ow_nunber"”, &
e_I n. getnessage())
CATCH (di vi debyzeroerror e_zero)
li_rtn = MessageBox("No Custoners", &
"Term nate Application?", Stopsign!, YesNo!)
IF li_rtn=1 THEN
HALT
END I F
END TRY

/1 Display the nmessage in the text box. Vary the
/I message dependi ng on whether there is only one
//customer for the selected state or if nmore than
/1 one customer resides in selected state.

IF li_int=1 THEN
sle_result.text ="Value not calculated for " &
+ sel _state + "." + " Try another state."
ELSE

sle_result.text = String (ny_result) + &
" 9% of custonmers are in " + sel_state + "."
END | F
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Run the application

Where you are
Add a new sheet window to the existing application
Create user-defined exception objects
Create a new user function and user event
Call the methods and catch the exceptions
> Run the application

You are now ready to run the application and cal cul ate the percentage of
customersin a selected state.

You can test the exception conditions you scripted, but to test the
divide-by-zero error condition, you need to artificialy set the number of
customers in the database to zero. You do this by adding a check box to the
sheet window, then setting the number of customersto zero if the check box is
selected.

In this exercise you:
*  Test the new sheet window
* Add atest for the divide-by-zero error

Test the new sheet window

¥

Run

218

1 Click the Run button in the PowerBar.

If PowerBuilder prompts you to save changes, click Yes.

2 Type dbain the User ID box.
Type sql in the Password box and click OK.

The database connection is established, and the MDI frame for the
application displays.
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Select File>Report>Customer Location from the menu bar.

The Customer Location window displays. The current entry in the
drop-down list is AB for Alberta.

# Customer Location: 1

1, Select or type a state code in drop-down list:
2, Click Percentage button

|Text box for percent of customers in the selected state

Click the Percentage button.

Because there is only one customer in Alberta, the exc_low_number
user-defined exception is thrown. The message from the exceptionis
displayed in a message box that was defined in a CATCH clausein the
button Clicked event.

Click OK to close the message box.

The text in the static text boxes now displays the number of customersin
Alberta and the total number of customersin the database. The text in the
editabletext box tells you the value was not cal culated and promptsyou to
select another state.

& Customer Location: 1

Customers in state: 1 i
Total number of customers: 126

i\ﬁalue not calculated for AB. Try another state.
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Select or type CAin the drop-down list box and click the Percentage
button.

The results from the database show 10 customersin Californiafor atotal
of 7.9% of all customersin the database. The percentage may be different
if you have modified the database.

= Customer Location: 1

Customers in state: 10 Lo =5

Total number of customers: 126

_?‘9 % ui-’-customers are in CA,

Type Chi o into the drop-down list box and click the Percentage
button.

When you lose focus from the drop-down list box by clicking the
Percentage button control, the L oseFocus event fires. This event callsthe
ue_modified event that throwsthe exc_bad entry user-defined exception.
The exception messagetellsyou to use atwo-letter postal codefor the state
name.

Click OK to close the message box, type USin the drop-down list box,
and click the Percentage button.

Because no rows are found in the database with US as the state code, the
exc_no_rows exception isthrown. A message displaysindicating no rows
have been returned and suggests reasons why that might be the case. A
more robust application might compare the typed text to alist of state
codes and throw the exc_bad entry exception instead, |etting you know
that USis not a state code.

Click OK to close the message box.
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7

10

11

12

Right-click the database icon for the EAS Demo DB, ared and yellow
SQL symbol, in your Windows System Tray.

Select Exit from the pop-up menu, and click Yes in the Warning
message box that displays.

This shuts down the connection to the EAS Demo DB database.

Select or type AB again in the drop-down list box and click the
Percentage button.

The message from the exc_no_rows exception object displaysfor Alberta
because the connection to the database was closed. To obtain resultsagain,
you need to terminate the application and restart it. PowerBuilder
reestablishes a connection to the database at runtime when you restart the
application.

Click OK to close the message box and select File>Exit from the
application menu to return to the development environment.

The Database painter and the Database Profile painter might still list the
database connection as being open. In this case you can use either painter
to disconnect and reconnect to the database at design time.

Add atest for the divide-by-zero error

You now add a check box to thew_cust_pct window. You then write code to
force a divide-by-zero error if the check box is selected. Because this test
requires an instantiated check box object, you surround the new codein a
TRY-CATCH statement that checks for null object errors.

Getting Started

1

Make sure the w_cust_pct window is open in the Layout view.
Select Insert>Control>CheckBox from the Window painter menu.

Click in the window just to the right of the Percentage command
button.

In the Name box in the Properties view, type cbx_zer o.
In the Text box, type Test di vi de-by-zero error.

Click the Function List tab.
Double-click the uf_percentage function.
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5

Type the following text just above the CHOOSE CASE statement:

//Set denominator to zero to test error condition
// Nunmer at or uni nportant, avoid user exception cases
TRY
I F cbx_zero. checked=TRUE THEN

ai _total cust=0

ai _custbystate=2

END I F
CATCH (nul | obj ecterror e_no)

MessageBox ("Null object”, "Invalid Test")
END TRY

Testing for the null object error
After you finish thislesson, you can test for the null object error by adding

the following line above the TRY statement: DESTROY cbx_zer o.

Click the Run button in the PowerBar.

If PowerBuilder prompts you to save changes, click Yes.

Type dba in the User ID box.
Type sql in the Password box and click OK.

The database connection is established, and the MDI frame for the
application displays.

Select File>Report>Customer Location from the menu bar.
Select a state code from the drop-down list box.

Select the Test divide-by-zero error check box.

= Customer Location:1

co v|
1. Select or type a state code in drop-down list: ==

2, Click Percentage button

Test divide-by-zera errar

[Text box for percent of customers in the selected state
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10 Click the Percentage button.

11

Thedivision by zero error is thrown during the percentage cal cul ation and
caught by the button Clicked event. The message box that you coded in the
CATCH clause for this error displays.

Mo Customers

@ Terminate Application?

[ es ] [ Mo

Click No to continue running the application.
Continue to test the application by selecting another state code and
optionally clearing the check box.

If the check box is selected when you click the button again and you select
Yesin the error message box, the application closes and you return to the
devel opment environment.

12 Close the application when you have finished testing it.
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Getting Started

Preparing the Application for
Deployment

In thislesson you create an executable version of the application for
distribution to users. Users can run this executable version of the
application just as they can any other application.

You:

e Create the Project object
*  Create the executable file
*  Create a shortcut

»  Test the executable file

How long does it take?
About 10 minutes.

225



Create the Project object

Create the Project object

226

Where you are

> Create the Project object
Create the executable file
Create a shortcut
Test the executable file

Now you create the PBTUTOR Project object. You can then use the Project
object to create the executable file for the application.

About machine code If you are running PowerBuilder Enterprise, you can
choose between Pcode (pseudocode) and machine code as the compile method
for your project executable file. However, you cannot sel ect machine code as
the compile method for the tutorial application becauseit contains Try-Catch
statements.

When you deploy an application to users, you may want to take advantage of
the execution speed of machine code for some computations, such as loops,
floating point or integer arithmetic, and function calls. While you are
developing the application, you usually use Pcode because it is faster to
generate.

About dynamic libraries You can also create dynamic libraries for your
application. Dynamic libraries can be used to store the objectsin the
application. By using dynamic libraries, you can break the application into
smaller units that are easier to manage and al so reduce the size of the
executablefile.

For small applications like the one that you are working on now, you do not
need to use dynamic libraries.
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1 Click the New button in the PowerBar.
Click the Project tab in the New dialog box.

£

Mews

Target: | (@) phtutar (C:\Program FilestSyvbase)PowerBuilder 11,00 Tutorial) v|

| ‘workspace || Target | PE Object | 35 | Datatwindow | Database | Project | Tool |

@ ¥ v o

Applics Zar Application EAServer Proxy  EAServer Proxy  Application Server
Wizard Provey Sizard

Application Server
Procy

-5

‘web Service Proxy

Wizard
W & @
‘Web Service Proxy  EJB Client Proxy  EJB Client Proxy EAServer EAServer
Wizard Component Wwizard omponent

Application Server  Application Server Web DW Container Web DW Container COMITOM+
Carpaonent Wizard Cormpanent ‘Wizard Cormpanent Wizard

g2 ® W

COMICOM+ Automation Server Autamation Server
Component Wizard

QK l [ Cancel

2 Select the Application Wizard icon and click OK.

Using the Project painter
If you clicked the Application icon on the Project page instead of the

Application Wizard icon, you open the Project painter. You can make the
same selections in the Project painter that you make with the wizard, but
the wizard prompts you for this information.
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Click Next.

The Specify Destination Library page displays.

Select pbtutor.pbl in the Application Libraries list box if it is not

already selected.

Click Next until the Specify Build Options page displays.

The wizard will generate a project with the following default selections:

Wizard property

Default value

Project name p_pbtutor_exe
Executable filename pbtutor.exe
Optional resourcefile none

Select Incremental Build for the Build Option.
Click Next until the Specify Version Information page displays.

The wizard will generate a project with the following default selections:

Wizard property

Default value

Generate machine code

No

Build dynamic libraries

No

If you want to, enter your own version information on the Specify
Version Information page.

If you do not change the information on this page, the defaults display in
Windows Explorer when you ook at the properties of the executable.
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Click Next.
Review the information on the Ready to Create Application page.
Click the Finish button.

PowerBuilder creates a Project object for your application and displaysit
in the Project painter workspace.

£ p_pbtutor_exe (pbtutor) (C:¥Program FilesiSybase\PowerBuilder, 11.0%Tutorial... [ZI[EI[XI

Executable file name:

Resource file name:

Project build options
[CJerompt For avervrite Rebuild: (&) Incremental

[Jwindows classic style OEul

Code generation options

(& Prode
(O Machine code

Enable DEBUG symbol

After aproject is defined, you can easily create an executable version of
the application. Using a project saves time when you are working on an
application that includes dynamic libraries that you expect to rebuild
often. Selecting incremental build meansthat if you make afew changes,
you can rebuild your project quickly, rebuilding only files that have
changed or filesthat depend on files that have changed.
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Create the executable file

Where you are

Create the Project object
> Create the executable file

Create a shortcut

Test the executable file

Now you create the executabl e file for your application. The executablefile
you generate contains definitions for al the objectsin the application. For the
tutoria application, thisincludes the bitmap file used in the login window,
since you did not include a separate resource file with your project.

You can create the executabl e in the Project painter, but usually, once you have
defined the project, you do not need to open the painter again.

Workspaces and targetsin the System Tree have Incremental Build, Full Build,
and Deploy items on their pop-up menus that enable you to build and deploy
some or al of the projectsin atarget or in the whole workspace. Incremental
Build and Full Build compile your code. Deploy compiles the code and, for
applicationslikethe oneyou built inthistutorial, creates an executablefile and
optional dynamic libraries. For other projects, such as server component
projects, Deploy also deploys the component and supporting files to the server.

In this lesson you look at the property sheets where build and deploy options
are specified and then create the executable from the PowerBar.

1 Close the Project painter.
Click Yes if prompted to save changes.

2 Right-click the pbtutor target in the System Tree.
Select Properties and then select the Deploy tab.
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This page shows all the projectsin thistarget (currently only one).

Properties of Target pbiutor, E]

Library List | Deploy

|Use the checked praojects in the Fallowing arder;

[mi=3p_pbtukor_exe

[ O H Cancel ]

If you have more than one project in the target, you can change the order
in which they are executed and select which projects you want to build.

Leaving p_pbtutor_exe checked, click the Cancel button.
Right-click MyWorkspace in the System Tree.
Select Properties and select the Deploy Preview tab.

The Deploy Preview page shows all the targetsin your workspace and the
projects in each that have been selected for deployment, in the order in
which they are to be deployed. You cannot change anything on this page—
you use it to check that you have set up deployment options for your
workspace the way you want to. All the projects shown on this page are
deployed when you click the Deploy button in the PowerBar.

This workspace has only one target and only one project, so you can use
the Deploy button to create the executable.
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4  Click the Cancel button to close the property sheet.

5 Click the Deploy button in the PowerBar.

Deploy The process of creating the executabl e file might take a few moments.
While PowerBuilder isworking, you canlook at the Output window at the
bottom of the screen to see what PowerBuilder is doing.

If you wanted to stop the deployment process, you could click the Stop
button in the PowerBar. When deployment is complete, the Output
window displays the following text: Finished Deploy of workspace
MyWorkspace.
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Create a shortcut

Getting Started

Where you are

Create the Project object

Create the executable file
> Create a shortcut

Test the executable file

Now you create ashortcut for the executable file. Theicon serves as ashortcut
to open the executable file. You can add the shortcut directly to the desktop or
to the program group of your choosing.

1 Minimize PowerBuilder.

PowerBuilder is minimized to an icon on the taskbar.

2 Right-click on a blank area of the desktop.
Select New>Shortcut from the pop-up menu.

The Create Shortcut dialog box displays.

3 Click the Browse button and locate pbtutor.exe.
If you accepted the default installation folder, thisisthe location:

C:\ Program Fi | es\ Sybase\ Power Bui | der 11. 0\ Tutori al
\ pbt ut or. exe

4  Click OK.
5 Click Next.
6 Type SportsWar, |nc. asthename of the shortcut.

7  Click Finish.
An icon and name display on the desktop.

Now you must modify a property of the shortcut so that you can run the
application. You can also change the icon.
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8

Right-click the SportsWear, Inc. icon on the desktop.
Select Properties in the pop-up menu.

The properties sheet for the desktop shortcut displays.

SportsWear, Inc. Properties

General | Shortcut | Compatibilty | Security

& Sportstiear, [ne.

Target type: Application

Target location: Tutonial

Target: | "C:A\Program Files\Sybase PowerBuilder 17.08Tu |

Start in: | "C:\Program FilessSybase \PowerBuilder 17.04Tu |

Shartcut key: | Manhe |

Rure | Mormal window B |

Camment; | |

[ Find Target. . l [ Change lcon... ] [ Advanced. . l

[ 0K l [ Cancel

Select the Shortcut tab.
Type the path to the PowerBuilder shared modules in the Start In box.
Click OK.

About the location of the shared modules
When you install PowerBuilder, the installation process putsthe DLLsin

ashared directory. The default location is:
C:\Program Files\Sybase\Shared\PowerBuilder.

If you want the user to be able to run the application by double-clicking
the executable file, you must include the shared directory location in the
system environment path.
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Test the executable file

Where you are
Create the Project object
Create the executable file
Create a shortcut

> Test the executable file

Now you test the new executablefile.

1 Make sure the pbtutor.ini file is in the same directory as the
pbtutor.exe executable file.

The default location of the pbtutor.ini file and the pbtutor.exefileis
C:\Program Files\Sybase\PowerBuilder 11.0\Tutorial.

2 Double-click the icon for the tutorial application.

The application begins running.

3 Test the application.
Notice the changes you made to the customer information.

4 When you have finished testing the application, select File>Exit from
the menu bar.

What to do next

Congratulations. You have completed the client-server part of the tutorial.
Now you know the basics of application devel opment with PowerBuilder. You
can now continue on to the .NET Web Forms and Windows Forms lessons.

The Preface to this book includes a guide to the PowerBuilder documentation.
To further your education, you should continue with these books:

User’s Guide
Application Techniques
DataWwindow Programmer’s Guide
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What to do next

All the PowerBuilder books are available in the Online Books and on the
Sybase Web site at http://www.sybase.com/support/manuals/. For information
on how to install the Online Books, see the Installation Guide.
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PART 3

Building a Web Forms
Application

This part is a tutorial that shows you how to get started
using .NET Web Forms targets. It provides step-by-step
instructions for converting a client-server application to a
Web Forms application.






LESSON 12

Getting Started

Converting the PowerBuilder
Tutorial to a Web Forms
Application

Thistutorial provides the information you need to convert the
PowerBuilder tutorial applicationtoan ASPNET Web Forms application.
It assumes you have installed the Microsoft .NET Framework 2.0 and an
I1S server on your development computer. You can use a different
computer to run the Web Forms application from a standard Web browser.

In thistutorial, you:

Run the tutorial in PowerBuilder

Make changes for a .NET Web Forms application
Create a .NET Web Forms target and project
Deploy a.NET Web Forms project

Run the application from a Web browser

How long does it take?
About 40 minutes.
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Run the tutorial in PowerBuilder
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Where you are

> Run the tutorial in PowerBuilder
Make changes for a .NET Web Forms application
Create a .NET Web Forms target and project
Deploy a .NET Web Forms project
Run the application from a Web browser

Before you deploy the PowerBuilder tutorial application asan ASPNET Web
application, make sure the application runs successfully from the
PowerBuilder environment. The complete tutorial applicationisincluded in
the Tutorial\Solutions directory in the PowerBuilder installation path.

Since you add a Web Formstarget to the sol utionsworkspace, it is best to copy
thetutorial application workspace and targetsto aseparate directory first. That
iswhat you do in thefirst steps of thistutorial.

Tutorial requirements .
To run the tutorial application successfully, you must have configured

ASPNET for a.NET Web Forms project. Thisincludes setting up appropriate
permissions for running SQL Anywhere and connecting to the EAS Demo DB
V110 database asan ASP.NET user. For information on configuring ASPNET,
see thefirst chapter in the Deploying Applications and Componentsto .NET
book.

1 Create a subdirectory under the Programs>Sybase>PowerBuilder
11.0>PowerBuilder 11.0>Tutorial directory and label it Web Forms.

2 Copy all the files from the Tutorial\Solutions folder to the new
Tutorial\Web Forms folder.

There are four files you must copy: MyWorkspace.pbw, PBTutor.pbt,
PBTutor.pbl, and Tutor_pb.pbl.

3 Select Programs>Sybase>PowerBuilder 11.0>PowerBuilder 11.0 from

the Windows Start menu.

The PowerBuilder development environment displays.
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Select Open Workspace from the File menu.

The Open Workspace dialog box displays.

Navigate to the Tutorial\Web Forms folder under the PowerBuilder
11.0 installation folder, select MyWor kspace. pbw, and click Open.

The workspace containing the pbtutor.pbt PowerScript target file opensin
the PowerBuilder IDE. This target contains two library files (pbtutor.pbl
and tutor_pb.pbl) with all the objects of the tutorial application.

Click the Run button in the PowerBar.

The Login window displays for the tutorial application.

Enter dba as the value for the user ID and sql as the password.

Upon successful login, an MDI frame window with a menu and toolbar
displays.

Test available menu options to make sure they are working, then
terminate the application.

Make changes for a .NET Web Forms application

Getting Started

Where you are
Run the tutorial in PowerBuilder

> Make changes for a .NET Web Forms application

Create a .NET Web Forms target and project
Deploy a .NET Web Forms project
Run the application from a Web browser

Unlessyou plan alwaysto start the tutorial database manually before your Web
Formsapplication connectsto the database, you must grant ASPNET usersfull
control of the directories containing the database and the SQL Anywhere

database engine, and extend that permission to all thefilesin those directories.

In Windows Explorer, browse to the Sybase\Shared\PowerBuilder
directory.

This directory contains the tutorial database.
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Right-click the directory and select Properties from the pop-up menu.

Select the Security tab of the Properties dialog box for the directory
and click the Add button.

The Select Users, Computers, or Groups dialog box displays.

If the Security tab does not display
To display the Security tab, you might need to modify a setting on the

View tab of the Folder Options dialog box for your current directory. You
open the Folder Options dial og box by sel ecting the Tool s>Folder Options
menu item from Windows Explorer. To display the Security tab, you must
clear the check box labeled “ Use simple file sharing (Recommended)”.

Click Locations, choose the server computer name from the
Locations dialog box, and click OK.

Type ASPNET, I | S WPG or | | S_USRSin the list box labeled “Enter the
object names to select” and click OK.

Before you click OK
If you click the Check Names button, a message displaysif the system

does not recognize the user name you entered. If the nameis not
recognized, you might have to reinstall the Microsoft 2.0 .NET
Framework.

Enter ASPNET for 11S5, 1S WPG for 11S6, or 1I1S_USRSfor [1S7. The
ASPNET account you enter is added to the Security settingstab for the
current directory.

Select Users, Computers, or Groups ilil

Selectthis ohjecttype:

IUsers, Groups. or Built-in security principals Objact Typas... |

From this location:

IMYXPMACHINE Locations. . |

Enter the object names to select (examples):

ASPMET Check Mames |

Advanced... | oK I Cancel |

4
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Select the new user account in the top list box on the Security tab,
then select the “Full Control” check box under the Allow column in
the bottom list box.

Click the Advanced button.

The Advanced Security Settings dialog box displays for the current
directory.

Select the check box labeled “Replace permission entries on all child
objects with entries shown here that apply to child objects” and click
OK.

A Security dialog box displaysto warn you it will remove current
permissions on child objects and propagate inheritable permissions to
those objects, and prompts you to respond.

Click Yes at the Security dialog box prompt, then click OK to close the
Properties dialog box for the current directory.

10 Repeat steps 1-9 for the Sybase\SQL Anywhere 9\win32 directory.

Create a .NET Web Forms target and project

Getting Started

Where you are

Run the tutorial in PowerBuilder

Make changes for a .NET Web Forms application
> Create a .NET Web Forms target and project

Deploy a .NET Web Forms project

Run the application from a Web browser

You can use the PowerBuilder .NET Web Formstarget wizard to createa.NET
Web Formstarget based on an existing PowerBuilder application target. Inthis
tutorial, you create a .NET Web Forms target based on the PowerBuilder
tutorial target. You also create a .NET Web Forms project that you will use to
deploy the Web Forms application.

Select File>New from the PowerBuilder menu, and click the Target
tab.

The Target page of the New dialog box displays.
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2

Select the .NET Web Forms Application icon and click OK.
Thefirst page of the wizard tells you what the wizard can do.

Click Next to display the second wizard page, then select the radio
button to “use the library list and application object from an existing
target” and click Next again.

The Choose a Target page of the wizard displays. It contains alist box for
targets of the current workspace. The PBTutor target isthe only target in
the tutorial workspace at thistime.

Make sure PBTutor is selected, and click Next.

The Specify Target File page displays. It lists a default name for the new
Web Forms target based on the name of the existing target file that you
selected. The default target file name is pbtutor_webform.pbt.

Click Next to use the default target name.

The Specify Project Information page displays. It lists a default name for
the new Web Forms project. The default project name is
p_pbtutor_webform. Thewizard page al so letsyou sel ect thetarget library
where you save the new project object. By default, the project object is
saved in the main library of the new target—in this case, pbtutor.pbl.

Click Next again to accept the default values for project name and
library.

The Specify Settings for .NET Web Forms Application page displays
default values for the following fields:

.NET Web Forms parameter | Default value

Web application name pbtutor

Application URL preview http://<ServerName>/pbtutor, where
<ServerName> isaplaceholder for thename
of thellS server

Accept the default values by clicking Next.

The Specify Resource Files/ Directories page of the wizard displays.
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8 Click the Add Files button.

The PowerBuilder Tutorial application uses some image filesthat must be
selected for deployment with the Web Forms application.

The Choose Resource Files dialog box displays.

9 Select Al Fil es fromthe Files of Type drop-down list and navigate
to the parent Tutorial directory.

10 Hold down the Ctrl key and select thet shirtw. j pg,tutsport. bnp,
andtutorial.icofiles, and click Open.

The selected resources are added to the page as shown below:

Specify Resource Files / Directories ilil

Resource file and directory list:

|23 D4y Program Files\ Sybase'\PowerBuilder 11.04Tutorialytutorial.ico
&3 D:4Program Files\SybasePowerBuilder 1104 Tutorialtutsport brmp
&3 D:4yProgram Files\ SybasePowerBuilder 11.04 Tutorialitshirw. jpg

Add Files... | Search PBR Files... |

Add Directony... | Delete |

< Back | Mext = | Cancel |

11 Click Next to include the selected resource files for deployment with
the tutorial Web Forms application.

The Specify Win32 Dynamic Library Files page of the wizard displays.
Thetutorial application does not use any external DLLSs.

12 Click Next twice to display the Specify Deployment Options page of
the wizard.
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You do not include any extra JavaScript files on the Specify JavaScript
Files page of the wizard, because none are needed for the tutorial
application.

The Specify Deployment Options page displays:

Specify Deployment Options ilil

Choose the desired deployment mode and enter the required information

| Generate setup file

Setup file narme:

C:4Program FileshSybasetPowerBuilder 11.04TutorizhSolutic |

(@ Directly deploy to IIS

1IS server address:

< Back | Mext = | Cancel

13 Accept Localhost for the IIS server address or change this to the
formal name for the local IS server, then click Next.

In thistutorial, you deploy the Web Forms project directly to thelocal 11S
server. After you click Next, the Summary page of the wizard displays.

14 Click the Finish button.

The .NET Web Forms Application wizard createsa .NET Web Forms
target named PBTutor_WebForm that uses the library list from the
pbtutor.pbl library. It also creates a .NET Web Forms project named
p_pbtutor_webform.
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Deploy a .NET Web Forms project

Getting Started

Where you are
Run the tutorial in PowerBuilder
Make changes for a .NET Web Forms application
Create a .NET Web Forms target and project
> Deploy a .NET Web Forms project
Run the application from a Web browser

After you create a Web Forms project, you must deploy it to an I1S server
before you can run or debug the Web Forms application. However, before you
deploy aWeb Forms application, you can modify the runtime global properties
for the application. In thislesson you change a global property for page
navigation in the application’s DataWindow controls before you deploy the
application.

1 Inthe System Tree, expand the PBTutor_WebForm target and the
pbtutor.pbl under that target.

Note that the pbtutor.pbl and tutor_pb.pbl libraries are listed under both
the PBTutor target and the PBTutor_WebForm target. In the
PBTutor_WebForm target, the only project that displays in pbtutor.pbl is
the NET Web Forms project that you just created.

Althoughthislibrary is shared with the PBTutor target listed in the current
workspace, the new project (p_pbtutor_webform) does not display under
PBTutor in the System Tree. In the PBTutor target, you still seethe
projects for creating a standard executable file and a Web DatawWindow
container.

2 Right-click the p_pbtutor_webform project in the System Tree and
select Edit from the pop-up menu.

The .NET Web Forms project opens in the Project painter.

3 Click the Configuration tab and make sure the “System defined
configuration settings” radio button is selected.

4  Select the PBDataWindowPageNavigatorType global property in the
Key column of the Configuration tab list view, and click Edit.

The Set Configuration Value dialog box displays.
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5 Inthe Set Configuration Value dialog box, change the Value
drop-down list entry to display Numeric and click OK.

You change the navigator control type from NextPrev to Numeric.

Set Configuration Value x|

kKey: I PEData\indowPageMavigator Type

(04 | Cancel

For a description of page navigation types, see the chapter on best
practices in the Deploying Applications and Componentsto .NET book.

6 Click the project’s Run tab and note the default values in the
Application and Arguments field.

The default application should be the Internet Explorer browser and the
default argument should be the URL for the Web Forms application after
deployment.

% p_pbtutor_webform (pbt ;Iglil

General | Deploy | Resource Files | Library Files | JavaScript Files | Configuration | Yersion | Post-build - Run |

Application: IC:\Program FilesyInternet Exploreriiexplore.exe |

Argurnents: I http: Aflocalhost/pbtutor

7 Note the selections on the other tab pages of the project.

You sel ected most of the propertiesfor the project in thetarget wizard. The
project properties sheet al so has default selectionsfor other propertiesthat
you did not set in the wizard. For thistutorial, you do not need to modify
these default settings. These settings are described in Chapter 2 of the
Deploying Applications and Componentsto .NET book. You can also
right-click on a Project painter tab page and select Help from the pop-up
menu for additional property descriptions.
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8 Select Design>Deploy Project from the Project painter menu or click
the deploy icon in the PainterBar.

You build and deploy the project to thelocal 11S server. A success message
displays on the Default tab of the Output window. The Unsupported
Featurestab containsalist of propertiesthat are not supported inthe .NET
Web Forms environment. The unsupported features listed for this tutorial
application mostly have to do with toolbar and menu styles and do not
affect the main functionality of the application.

9 Close all open painters.

Run the application from a Web browser

Getting Started

Where you are
Run the tutorial in PowerBuilder
Make changes for a .NET Web Forms application
Create a .NET Web Forms target and project
Deploy a .NET Web Forms project

> Run the application from a Web browser

You are now ready to run the tutorial as a Web Forms application. In this
lesson, you start one application session from PowerBuilder and another
session by typing the application URL in a Web browser Address box.

1 Start the EAS Demo DB V110 database manually if necessary.

You do not need to start the database manually if you set full control
permissions for the ASPNET user for the database and database engine
directories, as described in “ Grant ASPNET users full control over key
directories and files’ on page 112.

Starting the database manually
You can start the database manually by selecting

Programs>Sybase>PowerBuilder 11.0>Demo Database from the
Windows Start menu.
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Right-click the p_pbtutor_webform project in the PowerBuilder
System Tree and select Run from the pop-up menu.

If you left the p_pbtutor_webform project open in the Project painter, you
can select Design>Run from the Project painter menu or you can click the
Run Project icon in the PainterBar instead of using the System Tree
pop-up menu. You cannot run the project from the System Tree pop-up
menu while a PowerBuilder painter is open for any of the project objects.

The welcome window (login screen) for the tutorial application displays
in the Web browser. When you run the application from the PowerBuilder
design-time environment, you do not see the browser menus and toolbars.

Open a second Internet Explorer (IE) browser from the Windows Start
menu or task bar.

You can open a browser on adifferent computer if you have one available.
Next, you start a second session for the tutorial application.

Type http://serverName/pbtutor/default.aspx in the IE Address box,
where serverNameis the name of the IIS server where you deployed
the tutorial application.

If you open a Web browser on the |1S server machine, and you deployed
the application to “localhost”, you can uselocal host for the server namein
the browser’s Address box. When you start the application from a Web
browser and include the default.aspx start page, the browser menus and
toolbars remain visible when the Web Forms application displaysin the
browser window.

Enter dba for the user ID, sl for the password, and click OK.

After asuccessful login, the tutorial application’s Frame window displays
in the Web browser.

Select File>Report>Maintain Customers from the Frame window
menu.

The Maintain Customers sheet window displays. The master Datawindow
on this page usesthe Numeric style page navigation control. You can click
on anumber to navigate to a different page. Because you did not change
the PBDataWindowRowsPerPage property in the 1S manager, the number
of Datawindow rows per pageis 20.
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Getting Started

Frame window and the sheet window toolbars display separately.

File Edit ‘Window Help

| B
| c= 28 =
x|
Customer First Name Last Name Company Name a
D
101 Michaels Desdin The Power Group
102 Beth Reiser AMF Caorg.
103 Etin Miedringhaus Darling Associates
104 eghan Masan FS.C
105 Laura MeCarthy Ama & Sans
106 Paul Phillips Falston Inc.
107 Kelhy Calburn The Home Club ﬂ
(121 [E1 [ [S1[61[7] Page 1of 7
Customer ID: 10 Address: 3114 Pioneer Averue |
First Name: Wichaels | City: Rutherford |
Last Name: De\;hn—l State: INJ vl

Company Name: The Power Group Zip Code: 07070

Phone Number: (201) 555-8966

7  Select File>Report>Maintain Products from the Frame window menu.

The Maintain Products sheet window displays. Sheet windows display in
atab page format rather than as detached, cascading windows.

You do not see any page navigation controls on the Maintain Products
page becauseits DataWindow controls do not have more than 20 rows (the
value set by the global PBDataWindowRowsPerPage property) and are
therefore completely visible in asingle page.
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Thefollowing picture displaysthe tab page format used in the classic Web

style presentation.

File Edit ‘Window Help
| O
| 28 o
Maintain Customers:1 Maintain Products:1
x|
Product  Product Name Product Description Unit Price
1D
300 Tee Shirt Tank Top $9.00
301  Tee Shirt W-neck $14.00
302 Tee Shirt Crew Meck $14.00
400  Baseball Cap Cotton Cap $9.00
401  Baseball Cap Wool cap $10.00
500 Visor Cloth Wisor $7.00
Product 1D 300 Color; |White =]
Product Name: [Tee Shirt Quantity:
Product Descriptio|Tank Top | Unit Price: $9.00
size

Continue testing the tutorial or select File>Exit from the application
Frame window menu.

You should be able to insert, update, and del ete database entries from the
tutorial Web Forms application, just as you were able to do from the
PowerBuilder native tutorial application.

After you finish with the current Web Forms session, you might want to
experiment with changing other global propertiesin addition to
PBDatawindowPageNavigator Type. For example, to examine the File
Manager and the Mail Profile Manager, you can set the PBFileM anager
and PBMailManager global properties to true.

For more information about Web Forms targets, including the File
Manager and Mail Profile Manager, seethe Deploying to Applicationsand
Components to .NET book.
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Application

This part is a tutorial that shows you how to get started using
.NET Windows Forms targets. It includes step-by-step
instructions for converting a client-server application to a
Windows Forms application.






LESSON 13 Converting the PowerBuilder
Tutorial to a Windows Forms
Application

Thistutorial demonstrates how to convert the PowerBuilder tutorial
application to a Windows Forms application. It assumes you have
installed the Microsoft .NET Framework 2.0, the .NET Framework 2.0
SDK, and an 11S server on your development computer. The |1S server is
used as the central server for intelligent update. You can use a different
computer to run the Windows Forms application.

In thistutorial, you:

* Runthetutoria in PowerBuilder

e Copy resource files to the Solutions directory

e Create a.NET Windows Forms target and project

*  Deploy and run the Windows Forms target

e Publish the application to a Web browser

e Install the application from a Web browser and run it
e Install the application on another computer

e Update the application

How long does it take?
About 40 minutes.
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Where you are

> Run the tutorial in PowerBuilder
Copy resource files to the Solutions directory
Create a .NET Windows Forms target and project
Deploy and run the Windows Forms target
Publish the application to a Web browser
Install the application from a Web browser and run it
Install the application on another computer
Update the application

Before you deploy the PowerBuilder tutorial application as a Windows Forms
application, make sure that the application runs successfully in the
PowerBuilder development environment. The complete tutorial application is
included in the PowerBuilder installation fol der.

To run the tutorial application successfully, you must have installed SQL
Anywhere software and you must be able to connect to the EAS Demo DB
V110 database.

1 Select Programs>Sybase>PowerBuilder 11.0>PowerBuilder 11.0from
the Windows Start menu.

2 Select Open Workspace from the File menu.

3 Navigate to the Tutorial\Solutions folder under the PowerBuilder 11.0
installation folder, select MyWor kspace. pbw, and click Open.

The workspace containing the pbtutor.pbt application target opensin
PowerBuilder. This target contains two library files (pbtutor.pbl and
tutor_pb.pbl) with all the objects used in the tutorial application.

4  Click the Run button in the PowerBar.

The Login window for the tutorial application displays.

5 Enter dba as the value for the user ID and sql as the password.

The MDI framewindow for the tutorial with amenu and tool bar displays.
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6 Test some menu and toolbar items to make sure they work, then
terminate the application.

For example, select File>Report>Maintain Customers, use the toolbar
icons or the Edit menu items to insert a new customer and update the
database, then open a new instance of the Maintain Customers report to
check that the new row was added.

Copy resource files to the Solutions directory

Getting Started

Where you are
Run the tutorial in PowerBuilder

> Copy resource files to the Solutions directory
Create a .NET Windows Forms target and project
Deploy and run the Windows Forms target
Publish the application to a Web browser
Install the application from a Web browser and run it
Install the application on another computer
Update the application

You can use the PowerBuilder .NET Windows Forms Application target
wizardtoreusethelibrary list and application object of an existing target inthe
current workspace to create a new Windows Forms target.

In the wizard, you can select any resource files that your application requires
and they are deployed with the application, but the resource files must be
present in the directory where you create the application. You need to copy
three image files from the Tutorial directory to the Solutions directory and
change the path of the bitmap in the w_welcome window.

1 In File Explorer, select and copy tshirtw.jpg, tutorial.ico, and
tutsport.omp in the Tutorial directory.

2 Copy thefiles to the Tutorial\Solutions directory.

3 In PowerBuilder, open the w_welcome window and select the Picture
control.
Inthe Properties view, remove the path in the PictureName box so that
it contains only t ut sport. bnp.
Close the w_welcome window.
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Where you are
Run the tutorial in PowerBuilder
Copy resource files to the Solutions directory
> Create a .NET Windows Forms target and project
Deploy and run the Windows Forms target
Publish the application to a Web browser
Install the application from a Web browser and run it
Install the application on another computer
Update the application

Now you create anew Windows Formstarget using the .NET Windows Forms
Application target wizard.

1 Click the New button on the PowerBar and select the Target tab.

2 Select the .NET Windows Forms Application icon and click OK.

The first page of the wizard displays information about what the wizard
does.

3 Click Next. On the Create the Application page, select “Use the library
list and application object from an existing target” and click Next.

4  Select the pbtutor target and click Next.

By default, the new target name is pbtutor_winform.pbt.
5 Click Next to accept the target name.

6 On the Specify Project Information page, click Next to accept the
default project name and library.

7 Onthe Specify Application General Information page, specify Acrre
Updat e as the product name and AcneUpdat e. exe as the executable
file name, and click Next.

8 Onthe Resource Files/Directories page, click Add Files, select
tutsport.bmp,thsirtw jpg,andtutorial.ico,click Open, and
click Next.
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9 Click Next on the Specifying Win32 Dynamic Library Files page.

Since the tutorial application does not call any external functions, you do
not specify any DLL names for deployment with the application.

10 On the Specify Support for Smart Client page, select the Publ i sh as
smart client applicationcheck box and click Next.

11 Click Next on the Specifying Application Running Mode page.

You accept the default option that allows usersto run the application from
the Windows Start menu as well as from a browser.

12 On the Specify How Application Will be Installed or Launched page,
changel ocal host to the name of your computer, change pbt ut or to
acneupdat e, and click Next.

You can |leave the host name as localhost if you do not plan to access the
published application from another computer. Thisisdescribed in “Install
the application on another computer” on page 266.

13 Click Next on the Specify Application Update Mode page, then click
Finish on the final page.

The .NET Windows Forms Application wizard creates the
pbtutor_winformtarget and the p_pbtutor_winform project. You now have
two targets in MyWorkspace, both using pbtutor.pbl and tutor_pb.pbl.

14 Expand pbt ut or. pbl in both the pbt ut or target and the
pbt ut or _w nf or mtarget in the System Tree and look at the project
objects that display.

When you use the library list and application object of an existing target
to create aWindows Forms project, thelibraries are shared by both targets,
but the System Tree displays only projects that are appropriate for the
target type. In the pbtutor target, you see p_pbtutor_exe and
p_pbtutor_webdw. In the pbtutor_winform target, you see
p_pbtutor_winform.

15 Collapse the pbt ut or target, but leave the pbt ut or _w nf or mtarget

expanded.
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Deploy and run the Windows Forms target

Where you are
Run the tutorial in PowerBuilder
Copy resource files to the Solutions directory
Create a .NET Windows Forms target and project
> Deploy and run the Windows Forms target
Publish the application to a Web browser
Install the application from a Web browser and run it
Install the application on another computer
Update the application

Before you publish the application as a smart client application, deploy it to a
local directory to make sure it builds successfully, and then run it from the
deployed executable file to make sure the application runs asit did in the
development environment.

1 Double-click the p_pbt ut or _wi nf or mproject in the System Tree to
open the Project painter.

If you select each of the tab pages, you see that there are options you can
set in the painter that cannot be set in the wizard. For now, use the defaults
set in the wizard.

2 Select Design>Deploy Project from the Project painter menu or click
the Deploy button in the PainterBar.

Deploy builds the application and deploysit to the local directory
specified in the Output Path field on the General page in the Project
painter.

A success message displays on the Default tab page in the Output window,
and a new tab displays showing unsupported features. Some menu
properties, such as ToolbarHighlightColor, are not supported in Windows
Forms.
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Troubleshooting
If the applicationfailsto deploy, make sureyou havethe .NET Framework

2.0 SDK installed on your computer and that its bin directory isin your
system PATH environment variable.

If you see the syntax error “Unexpect ed token: 'line 4:8'
unexpected token: -",open m_my_sheet in the Menu painter, select
Design>Options from the PowerBuilder menu, and select the Allow
Dashes in Identifiers check box on the Script tab page in the Options
dialog box.

For more troubleshooting tips, see the chapter on troubleshooting in the
Deploying Applications and Componentsto .NET book.

3 Select Design>Run Project from the Project painter menu or click the
Run Project button in the PainterBar.

The AcmeUpdate.exe file in the pbtutor_winform_ W nFormQOutput
directory runs and displays the Wel come window.

4  Enter dba as the value for the user ID and sqgl as the password.

Notice that the application’sicon in the Windows task bar indicatesitisa
Windows Forms application.

5 Run the application as you did in the development environment and
test some database operations.

Close the application when you have finished testing. Next, you publish
the application to a Web server and install it from the publish page.
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Publish the application to a Web browser

Where you are
Run the tutorial in PowerBuilder
Copy resource files to the Solutions directory
Create a .NET Windows Forms target and project
Deploy and run the Windows Forms target

> Publish the application to a Web browser
Install the application from a Web browser and run it
Install the application on another computer
Update the application

Next you publish the application using intelligent update technol ogy.
1 Openthe p_pbt ut or _wi nf or mproject if it is not already open.

2 Onthe Version page, enter Acne, |nc. as the Company name.

The product name and company name display on the publish pageandin
the Windows Start menu.

3 Examine the options on the Publish and Install/Update pages.

The application will be published to a Web site on your computer. A
publish page named publish.htm is generated and opened when the
application has been published so that you can install the application from
it onto your computer. When you make a change and republish the
application, the revision number isincremented automatically.

The defaults on the Install/Update page specify that the application will be
installed so that you can run it from the Start menu on your computer
whether or not it is connected to the Internet or intranet. Before the
application starts, it checks for updates on the publish Web site.
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On the Notify page, clear the “Use default notifier icon” check box and
browse to selecttutori al . i coin the Tutorial\Solutions directory.

Thetutoria icon displaysin the Notification area of the Windows task bar
when the application is running. You can also specify a different
background image for the window that displays when you check for
updates.

On the Prerequisites page, select Microsoft .NET Framework 2.0 and
PowerBuilder 11 Runtime Library.

If this application needs to be installed on a computer that does not have
the Microsoft .NET Framework 2.0 installed, you must modify the
package that installs it. For more information, see the chapter on
intelligent deployment in the Deploying Applications and Components to
.NET book.

Save the project and select Design>Publish Application or click the
Publish button on the PainterBar.

PowerBuilder redeploys the project and publishes the application to the
Web server on your local computer, typically
C:\Inetpub\wwwroot\AcmeUpdate. It also opens a browser and displays
the publish.htm page so that you can install the application and any
prerequisites.

Troubleshooting
If the publish operation does not succeed, see the chapter on

troubleshooting in the Deploying Applications and Componentsto .NET
book.
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Install the application from a Web browser and run it

Where you are
Run the tutorial in PowerBuilder
Copy resource files to the Solutions directory
Create a .NET Windows Forms target and project
Deploy and run the Windows Forms target
Publish the application to a Web browser

> Install the application from a Web browser and run it
Install the application on another computer
Update the application

Next you install the application on your computer from the Web browser and
runit.

1 Inthe publish.htm page, click the Install button.

24 Acmellpdate - Microsoft Internet Explorer E”E”g|
© File Edit ¥iew Favorites Tools  Help l'.u'
M > a — i . ot . £
O~ © HRG P Jorows @ 25 @ -
© Address @ http:fflocalhost/pbtutor/publish, htm V| Go
A

Acme, Inc:

AcmeUpdate

Name: Acmellpdate
VYersion: 1.0.0.0
Publisher: Acme, Inc.

The following prerequisites are required:

e Microsoft \NET Framewark 2.0

e PowerBuilder 11 Runtime Library

If these components are already installed, you can launch the application
now, Otherwise, click the button below to install the prerequisites and run the

application.
Install
PowerBuilder Intelligent Updater Resources =
v
< |3

‘g Local intranet
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Click Run in the File Download dialog box that displays and in any
other dialog boxes that display.

The dialog boxes that display depend on your security settings.

The Acme Update Installation dialog box displays. Since the Microsoft
.NET Framework isalready installed on your computer, it does not display
in the dialog box. If you click the Advanced button, the Components List
shows all the components required for the application.

[ et BIEI]

In order to install the App you must install these components:

PowerBuilder 11 Runtime Library
Acmelpdate

Select the components to install.

[ Microsoft .MET Framework 2.0 (Installed)

[ PowerBuilder 11 Runtime Library Advanced

v Acmelpdate

Install | Close |

oK | Cancel |

If the Runtime Library package is installed
If the PowerBuilder 11 Runtime Library package is aready installed on

your compuiter, clear its check box in the Components List and click OK.

Click the Install button on the Acme Update Installation dialog box.

The PowerBuilder 11 Runtime Library and Acme Update application are
installed on your computer. Follow the prompts in the dialog boxes that
display and close the Acme Update I nstallation dialog box when the
installation is complete.

A pop-up “Launching Application” window displays, then the Acme
Update application opensand anicon with thelabel AcneUpdat e displays
in the notification areain the task bar.

Enter dba as the value for the user ID and sql as the password.
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5 Test the application to make sure it runs correctly.

If another computer has access to the 11S server on the devel opment
computer, you can use it to test installation on a client computer. Thisis
described in the next exercise. If you want to try the next exercise, close
the application on the development computer. If you want to test the
update properties on the devel opment computer, leave the application
open and go to “Update the application” on page 267.

Install the application on another computer

266

Where you are

Run the tutorial in PowerBuilder

Copy resource files to the Solutions directory

Create a .NET Windows Forms target and project

Deploy and run the Windows Forms target

Publish the application to a Web browser

Install the application from a Web browser and run it
> Install the application on another computer

Update the application

You can install the application on a client computer from the Web page

http: //hostname/acmeupdate/publish.htm, where hosthame is the name of the
development computer. The client computer must have access to the
development compuiter.

1 Ontheclient computer, create an ODBC system DSN called EAS Deno
DB V110 that connects to the easdenodb. db on a server.

2 Open Internet Explorer and navigate to the publish page for the
application (http://hostname/acmeupdate/publish.htm, where
hostname is the name of the development computer).

3 Click Install and click the Run buttons in the windows that display, as

you did in the previous exercise.
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Click the Install button on the Acme Update Installation dialog box.

The PowerBuilder 11 Runtime Library and Acme Update application are
installed on your computer. Follow the prompts in the dialog boxes that
display and close the Acme Update I nstallation dialog box when the
installation is complete and the application opens.

Enter dba as the value for the user ID and sql as the password.
Test the application to make sure it runs correctly.

Right-click the Acme Update notifier icon and try each of the enabled
menu items.

If you select Check for Updates, a pop-up window displays that indicates
no updatesare available. Next, you makeaminor changein the application
to test intelligent update.

Update the application

Getting Started

>

Where you are

Run the tutorial in PowerBuilder

Copy resource files to the Solutions directory
Create a .NET Windows Forms target and project
Deploy and run the Windows Forms target

Publish the application to a Web browser

Install the application from a Web browser and run it
Install the application on another computer

Update the application

Now you change a background color in the application and republish it to the
server, then test the notification feature.

On the development computer, open w_pbt ut or _basesheet and
change its BackColor property from ButtonFace to a color of your
choice and save and close the window.

Select Design>Deploy or click the Deploy button on the PainterBar.

PowerBuilder builds and deploys the application.

267



Update the application
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Select Design>Publish or click the Publish button on the PainterBar.

PowerBuilder publishes the updated application. If you look in the
Inetpub\wwwroot\acmeupdate fol der, you see 1.0.0.0 and 1.0.0.1
subdirectories.

Starting the application from the Windows Start menu
If the gpplication is not running, select Program Files>Acme Inc.>Acme

Update from the Start menu. An Update Available dialog box displays
informing you that a new version of Acme Update is available. You can
download the new version or click Skip to run the older version. Click
Skip to continue to the next step in this exercise.

On the development or client computer, right-click the Acme Update
notifier icon and select Check for Update.

A pop-up window displays informing you that a new version of Acme
Update is available on the server.

Right-click the Acme Update notifier icon again and select Retrieve
Update.

The updated version of the application is downloaded.

Right-click the Acme Update notifier icon again and select Restart
with New Version.

The Welcome window opens.
Enter the login information, click OK, and open a customer or product

report.

The background color is changed to the color you specified.
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