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About This Book

ECRTP/TP is a customized version of ECRTP™, a graphical user 
interface for trading partner maintenance. ECRTP/TP is designed for users 
who do not develop maps, but who need to do more than run existing 
maps. ECRTP/TP uses the Run Time Program (RTP) to convert data from 
a proprietary application format to a standard, from a standard format to a 
proprietary application, or from an application to an application. In 
addition, RTP lets you perform operations on trading partner and cross-
reference data, as well as test new maps provided by your vendor. 

Audience This book is for application engineers and technical consultants who 
manage trading partner information.

How to use this book This guide describes how to use ECRTP/TP. It is organized into the 
following chapters:

• “About This Book” briefly introduces ECRTP/TP and provides a list 
of available documentation and technical support information.

• Chapter 1, “Getting Started” describes how to log in and administer 
users.

• Chapter 2, “Working with Projects” describes how to manage 
projects.

• Chapter 4, “Working with Maps” describes how to create and run 
maps.

• Chapter 3, “Working with Trading Partners and Trade Agreements” 
describes how to create trading partners and trade agreements.

• Chapter 5, “Performing Additional Tasks” provides information 
about cross-reference tables, updating the database structure, and 
running reports.

Related documents This section describes the available documentation.

Cross-platform Documentation The ECRTP/TP documentation set 
includes:

• Installation Guide

• Reference Guide
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• Feature Guide

• Release Bulletin

Other sources of 
information

Use the Sybase Getting Started CD, the SyBooks Bookshelf CD, and the 
Sybase Product Manuals web site to learn more about your product: 

• The Getting Started CD contains release bulletins and installation guides 
in PDF format, and may also contain other documents or updated 
information not included on the SyBooks Bookshelf CD. It is included 
with your software. To read or print documents on the Getting Started CD, 
you need Adobe Acrobat Reader, which you can download at no charge 
from the Adobe Web site using a link provided on the CD.

• The SyBooks Bookshelf CD is included with your software. It contains 
product manuals in a platform-independent bookshelf that contains fully 
searchable, HTML-based documentation.

Some documentation is provided in PDF format, which you can access 
through the PDF directory on the SyBooks Bookshelf CD. To view the 
PDF files, you need Adobe Acrobat Reader.

Refer to the README.txt file on the SyBooks Bookshelf CD for 
instructions on installing and starting SyBooks.

• The Sybase Product Manuals Web site is the online version of the 
SyBooks Bookshelf CD that you can access using a standard Web browser. 
In addition to product manuals, you will find links to EBFs/Maintenance, 
Technical Documents, Case Management, Solved Cases, newsgroups, and 
the Sybase Developer Network.

To access the Product Manuals Web site, go to Product Manuals at 
http://www.sybase.com/support/manuals/.

Sybase EBFs and 
software 
maintenance

❖ Finding the latest information on EBFs and software maintenance

1 Point your Web browser to the Sybase Support Page at 
http://www.sybase.com/support.

2 Select EBFs/Maintenance. If prompted, enter your MySybase user name 
and password.

3 Select a product.

4 Specify a time frame and click Go. A list of EBF/Maintenance releases is 
displayed.
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Padlock icons indicate that you do not have download authorization for 
certain EBF/Maintenance releases because you are not registered as a 
Technical Support Contact. If you have not registered, but have valid 
information provided by your Sybase representative or through your 
support contract, click Edit Roles to add the “Technical Support Contact” 
role to your MySybase profile.

5 Click the Info icon to display the EBF/Maintenance report, or click the 
product description to download the software.

Sybase EBFs and 
software 
maintenance

❖ Finding the latest information on EBFs and software maintenance

1 Point your Web browser to the Sybase Support Page at 
http://www.sybase.com/support.

2 Select EBFs/Maintenance. If prompted, enter your MySybase user name 
and password.

3 Select a product.

4 Specify a time frame and click Go. A list of EBF/Maintenance releases is 
displayed.

Padlock icons indicate that you do not have download authorization for 
certain EBF/Maintenance releases because you are not registered as a 
Technical Support Contact. If you have not registered, but have valid 
information provided by your Sybase representative or through your 
support contract, click Edit Roles to add the “Technical Support Contact” 
role to your MySybase profile.

5 Click the Info icon to display the EBF/Maintenance report, or click the 
product description to download the software.

Conventions The formatting conventions used in this manual are:

Formatting example Indicate

command names and 
method names

When used in descriptive text, this font indicates 
keywords such as:

• Command names used in descriptive text

• C++ and Java method or class names used in 
descriptive text

• Java package names used in descriptive text
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If you need help Each Sybase installation that has purchased a support contract has one or more 
designated people who are authorized to contact Sybase Technical Support. If 
you cannot resolve a problem using the manuals or online help, please have the 
designated person contact Sybase Technical Support or the Sybase subsidiary 
in your area.

Italic font indicates:

myCounter variable 

Server.log

myfile.txt

User Guide

• Program variables

• Parts of input text that must be substituted

• Directory and file names.

• Book titles

sybase/bin A forward slash (“/”) indicates generic directory 
information. A back slash (“\”) applies to Windows users 
only.

Directory names appearing in text display in lowercase 
unless the system is case sensitive.

Chapter 1, “Getting 
Started”

References to chapter titles have initial caps and are 
enclosed within quotation marks.

File > Save Menu names and menu items are displayed in plain text. 
The angle bracket indicates how to navigate menu 
selections, such as from the File menu to the Save option. 

The vertical bar indicates:

parse|put|get

Name|Address

• Options available within code

• Delimiter within message examples

Monospace font indicates:

create table

table created

• Information that you enter on a command line or as 
program text.

• Example output fragments

Formatting example Indicate
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C H A P T E R  1 Getting Started

About this chapter This chapter describes how to log into ECRTP/TP for the first time, create 
additional users, and administer passwords.

Topics This chapter includes the following topics:

Topic Page

User administration 2
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User administration
ECRTP/TP is password protected to prevent unauthorized access. ECRTP/TP 
includes a default administrative login ID, Admin, and password, ecrtp. 

As an initial step, administrators should log in to ECRTP/TP, add as many new 
users as needed and distribute the login IDs to those users. 

❖ Starting ECRTP/TP

1 Select Start > Programs > Sybase > ECRTP/TP.

The Login dialog displays. 

2 Accept the default administrator password, Admin, in User Name box.

3 In the Password box, type ecrtp.

❖ Adding a new user

1 In the main ECRTP/TP window, select File > User Administration.

2 When the User Administration window opens, click New.

3 On the Login tab, type the new user name and password in the appropriate 
text boxes.

4 In the Confirmation box, retype the new user’s password.

5 Click the Private Directory tab and then click Browse to navigate to the 
appropriate directory.

❖ Changing a user’s password

1 In the main ECRTP/TP window, select File > User Administration.

2 When the User Administration window opens, click a user name and 
choose Properties.

3 On the Login tab, type the user’s new Password in the Password box.

4 In the Confirmation box, retype the user’s new password.

❖ Deleting a user

1 In the main ECRTP/TP window, select File > User Administration.

2 When the User Administration window opens, click a user name and 
choose Delete.

3 In the Confirmation dialog, click Delete.
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C H A P T E R  2 Working with Projects

About this chapter This chapter describes how to create projects in ECRTP/TP and set up 
trading partner profiles.

Topics This chapter includes the following topics:

Topic Page

Setting up projects 4

Setting up company profiles 6
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Setting up projects
Projects are an organizational tool for storing maps. While you cannot develop 
maps in ECRTP/TP, you can set up the project structure that holds those maps 
in any way that you want. You can also import projects, with all of their 
associated maps, from other systems and export projects that you want to share 
with others. 

❖ Creating a new project

1 Click .

 – Or –

In the main ECRTP/TP window, select File > Project > New.

2 In the Project Name box type the name of the project. This information is 
required.

3 In the Project Description box, type a brief description of the project. This 
information is optional.

4 Click the Browse button next to the Directory box and navigate to the 
directory where you want to store the project.

5 In the Contact Name and Phone Number boxes, type the name and 
telephone number of the person responsible for the maps in this project. 
This information is optional.

Windows adds the Project to the list in the project window.

❖ Selecting a project

1 Click .

 – Or –

In the main ECRTP/TP window, select File > Project.

2 In the Project Window, Right-click a project and choose Select from the 
submenu.

Note  After you select a project, ECRTP/TP closes the Projects window, and 
the project you selected appears in the status bar at the bottom left of the screen.

❖ Modifying a project

1 In the main ECRTP/TP window, select File > Project > Properties.
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2 In the Project Window, right-click the project you want to modify and 
choose Properties from the submenu.

3 In the Project Properties window modify the project properties.

Note  Project properties include the Project Name, Project Description, 
Directory, Contact, and Phone Number. All of these properties are optional 
except Directory, which is required.

❖ Deleting an existing project

• In the Projects window, right-click a project and choose Delete from the 
submenu.

Deleting a project removes the project and all of its associated files.

❖ Importing a project with associated maps

1 In the main ECRTP/TP window, select File > Project > Import.

2 In the Project Import Definition dialog, click the Browse button and 
navigate to the directory that contains the project you want to import.

3 Click Run.

4 Add the appropriate project name.

You can accept the default project name or create a new one.

Note  If you try to import a project that already exists, ECRTP/TP displays a 
warning. To clear the warning and import the project, click Yes to return to the 
Project screen, rename the project, then click OK 

After you rename the project, the Project Directory screen prompts you for the 
full path of the project you want to import. You can accept the default directory 
path that displays, or enter a different directory path and click OK. 

You can open the Projects window to verify that ECRTP/TP imported your 
project.

❖ Exporting a project with associated maps

1 In the main ECRTP/TP window, select File > Project > Export.

2 In the Export Project Definition window, click next to the Project box, then 
choose the project you want to export. 
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3 Click the Browse button next to the Select Export Directory box and 
navigate to the directory where you want to store the project.

4 Click Run.

When you export the project definition, you export the files containing the 
project definition (mproject.*), the definitions of the maps in the project 
(mtable.*), and the cross-reference tables (mxref.*). However, you also need to 
send all the other map-related files for the project. 

Open the directory of the project you are exporting, place the export directory 
you created inside it, and zip the entire directory. Make the zipped directory 
available for importing into ECRTP/TP.

Setting up company profiles
Company profiles provide an electronic signature on your outgoing messages 
that tells the recipient who sent the message. ECRTP/TP uses your company 
profile as the sender address on both the interchange and group-level envelopes 
that hold the EDI message.

Because the requirements for exchanging business messages may differ from 
trading partner to trading partner, you can set up multiple profiles for your 
company, letting you tailor the messages you exchange for each trading 
partnership. 

On incoming messages, the company ID identifies your company as the 
recipient of the message.

❖ Adding a new company profile

1 Click .

 – Or –

In the main ECRTP/TP window, select File > Address Book > Signature 
(Company ID).

2 When the Company ID window opens, select File > New.

3 In the Profile Number box, type the number you want to assign this profile.

4 In the Name box, type the name of your company. 

5 Right-click in the Interchange Qualifier box and choose the interchange 
qualifier. 
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6 Right-click in the Authorization Qualifier box and choose the 
authorization qualifier. 

7 Right-click in the Security Qualifier box and choose the appropriate 
security option. 

You can choose 00 No Security Information Present or 01 Present.

❖ Deleting a company profile

1 Click .

 – Or –

In the main ECRTP/TP window, select File > Address Book > Signature 
(Company ID).

2 In the Company ID window, right-click the company profile and choose 
Delete from the submenu.

❖ Modifying a company profile

1 Click .

 – Or –

In the main ECRTP/TP window, select File > Address Book > Signature 
(Company ID). 

2 In the Company ID window, right-click a company profile and choose 
Properties from the submenu.

3 In the property sheet for the company, change the company’s profile as 
appropriate.
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C H A P T E R  3 Working with Trading Partners 
and Trade Agreements

About this chapter This chapter describes how to set up your trading partners and trade 
agreements.

Topics This chapter includes the following topics:

Topic Page

Setting up trading partners 10

Setting up trade agreements 13
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Setting up trading partners
Trading partners are entities with whom your company exchanges messages. 
The trading partner files contain demographic information about the trading 
partner and the data needed to process the electronic messages that are 
exchanged, identifying information used in EDI envelopes (sender and 
receiver codes), routing data (mailbox name), and information required to read 
the data (delimiter, release, and repeat characters). If you are creating a 
transaction map, you must enter information about your trading partners.   
Any-to-Any maps do not require trading partner information.

ALL TradePartner
If ECRTP/TP cannot find a trading partner in the trading partner database or 
trade agreement that links the current map and trading partner, ECRTP/TP runs 
the map using the ALL TradePartner default. 

You cannot remove or modify the ALL TradePartner or use ALL TradePartner 
properties for any other trading partner. (The ID is thirteen spaces, the Name is 
ALL, and the Group is 0 (zero). In the trading partner database, the CUST_NO 
for the ALL TradePartner is 35 spaces, and the GSID is 0 followed by 34 
trailing spaces. No other trading partner is allowed to have these values.)

❖ Adding a new Trading Partner

1 Click 

 – Or –

In the main ECRTP/TP window, select File > Address Book > Contacts. 

2 In the Trading Partners window, select File > New.

When the New Trading Partner property sheet appears, the General tab is 
in focus.

3 In the Trading Partner Group, add the following information:

• Internal ID is the internal application number that links EDI 
envelopes to the application information.

• Name is the internal name for the Trading Partner

• Mailbox Name is the Trading Partner’s routing location. 

• Mailbox Folder is the routing directory for inbound and outbound 
data.
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4 If you intend to use the copy utility and want to include this Trading 
Partner in a selective copy of the data (as opposed to the default all), click 
Copy this Trading Partner's data when Copy Tables utility is used.

5 Bring the Contacts tab into focus, and in the Address group add the 
Trading Partner's address information.

6 In the Personnel group, identify the Trading Partner’s contact names and 
telephone numbers.

7 In the Ship and Bill group, add the Trading Partner’s electronic addressing 
information about the trading partner’s: 

For both the shipping and billing address, right-click in the Qualifier field, 
and choose a qualifier from the submenu. ECRTP adds the appropriate 
qualifiers and descriptions. You must provide the appropriate codes. 

8 What happens next depends on the map standard:

If the standard is... Do this...

NCPDP Click the NCPDP tab.

• In the Outbound Receiver Default Envelope 
Values and Inbound Sender Lookup Values 
group, type the Batch Receiver ID in the 
appropriate text box.

• In the Outbound Sender Override Envelope 
Values and Inbound Sender Lookup Values 
group, add the Batch Sender ID, Bin Number, 
Processor Control Number, Service Provider ID 
Qualifier, Service Provider ID/Pharmacy 
Number, and Software Vendor/Certification ID in 
the appropriate text boxes. 

 X12, EDIFACT, HL7 Click the Delimeter tab.

• In the Outbound Receiver Default Envelope 
Values and Inbound Sender Lookup Values 
group, right-click in the Interchange, Group, 
Authorization, and Security boxes and choose the 
appropriate look up values

• In the Outbound Sender Override Envelope 
Values and Inbound Sender Lookup Values 
group, right-click in the Interchange and Group 
boxes and choose the appropriate look up values. 

ECRTP adds the appropriate qualifiers and 
descriptions. You must provide the appropriate 
codes.
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9 If you need to overwrite the default, delimiter values, bring the 
Delimiter/Terminator tab into focus, and edit by map standard:

❖ Deleting a Trading Partner

1 Click 

 – Or –

In the main ECRTP/TP window, select File > Address Book > Contacts. 

2 In the Trading Partners window, right-click the Trading Partner and choose 
Delete from the submenu.

If the standard is… Do this

X12 In the X12 group, right-click in the text box next 
to the Segment, Element, Subelement, or Repeat 
Characters fields, and choose the appropriate 
value from the submenu.

EDIFACT In the EDIFACT group, right-click in the text 
box next to the Segment, Element, Subelement, 
Release Character, or Repeat Characters fields, 
and choose the appropriate values from the 
submenus.

From the Decimal Indicator drop-down box, 
choose the character you want to use to indicate 
a decimal.

HL7 In the HL7 group, right-click in the text box next 
to the Segment, Field, Component, 
Subcomponent, or Escape Characters, and 
Repetition Character fields, and choose the 
appropriate values from the Selection windows.

The HL7 segment terminator is defined as <CR> 
and technically cannot be changed. However, 
since some trading partners mandate that it be 
different, ECRTP/TP allows you to override this 
value.

For HL7 maps, you must type the actual 
delimiter values on this screen because there are 
no default values for HL7 message delimiters.

Data Encoding In the Packed Decimal Character box in the Data 
Encoding group, choose the appropriate legal 
value B, C, or D. 

ECRTP/TP uses this value to determine whether 
a signed packed decimal field in a record is 
positive.
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❖ Modifying the properties of a Trading Partner

1 Click 

Or -

In the main ECRTP/TP window, select File > Address Book > Contacts. 

2 In the Trading Partners window, right-click the Trading Partner and choose 
Properties from the submenu.

Setting up trade agreements
A trade agreement associates a specific map with a specific trading partner. 
They also add additional routing capabilities so that documents can be sent to 
the correct mailbox within your and the Trading Partner's organization - since 
the routing information associated with a trade agreement overrides routing 
information associated with a map, including a mailbox. 

❖ Adding a Trade Agreement

1 Click 

 – Or –

In the main ECRTP/TP window, select File > Address Book > Contacts. 

2 In the Trading Partners window, right-click a Trading Partner and choose 
Trading Agreement from the submenu. 

3 In the Trade Agreements with… window, select File > Add Map.

4 Double-click the new Trade Agreement row, then choose the map standard 
from the submenu.

When the Trade Agreement properties sheet appears, the General tab is in 
focus. Values in the Trade Agreement and Map Information groups reflect 
the map standard, map, and Trading Partner properties.

5 Modify the Trade Agreement properties as necessary. Field requirements 
for each tab depend on the map standard.

• The Overrides tab of the Trade Agreements screen for outbound X12 
and HL7 maps contains mailbox override information and override 
information for the receiver on outbound envelopes:
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• The X12 tab contains information that is used only for X12 
transaction sets, and the terminology is X12-specific. Values on the 
X12 tab differ for inbound and outbound maps.

• The EDIFACT tab contains information that is used only for 
EDIFACT messages, and the terminology is EDIFACT-specific. 
EDIFACT tab is the same for both inbound and outbound maps, but 
differs for Syntax 3 and Syntax 4. 

• The HL7 tab of the Trade Agreements screen contains information 
that is used only for HL7 messages. The HL7 tab is the same for both 
inbound and outbound maps. 

❖ Modifying an existing Trade Agreement

1 Click 

 – Or –

In the main ECRTP/TP window, select File > Address Book > Contacts. 

2 In the Trading Partners window, right-click a Trading Partner and choose 
Trading Agreement from the submenu. 

3 In the Trade Agreements with… window, select Edit > Properties

4 Modify the Trade Agreement properties as necessary. Field requirements 
for each tab depend on the map standard.

• The Overrides tab of the Trade Agreements screen for outbound X12 
and HL7 maps contains mailbox override information and override 
information for the receiver on outbound envelopes:

• The X12 tab contains information that is used only for X12 
transaction sets, and the terminology is X12-specific. Values on the 
X12 tab differ for inbound and outbound maps.

• The EDIFACT tab contains information that is used only for 
EDIFACT messages, and the terminology is EDIFACT-specific. 
EDIFACT tab is the same for both inbound and outbound maps, but 
differs for Syntax 3 and Syntax 4. 

• The HL7 tab of the Trade Agreements screen contains information 
that is used only for HL7 messages. The HL7 tab is the same for both 
inbound and outbound maps. 

❖ Deleting a Trade Agreement

1 Click 
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 – Or –

In the main ECRTP/TP window, select File > Address Book > Contacts. 

2 In the Trading Partners window, right-click a Trading Partner and choose 
Trading Agreement from the submenu. 

3 In the Trade Agreements with… window, right-click the Trading 
Agreement and choose Delete from the submenu.
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C H A P T E R  4 Working with Maps

About this chapter This chapter describes how to define, modify and run maps in ECRTP/TP.

Read this section to learn how to change the properties of a map you 
defined or to copy a map in order to rename it.

Topics This chapter includes the following topics:

Topic Page

About maps 18

Defining maps 18

Modifying maps 26

Running maps 30
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About maps
Maps provide a standard format, which makes the exchange of business 
information between trading partners possible. Running an outbound map 
retrieves data from various applications as input that creates a message for 
specific trading partner. Running an inbound map takes a message sent from 
various trading partners to create the map’s output. For example, a sales order 
from a trading partner might represent a typical inbound map; an 
acknowledgement sent in response to that sales order might represent a typical 
outbound map. 

Most maps conform to specific standards and support specific industries. 
ECRTP/TP runtime engine allows you to define and run maps that conform to 
X12, HL7 (non-billing medical data), EDIFACT (United Nations standard), 
NCPDP (National Council for Prescription Drug Programs), and Any-to-Any 
(application to application) standards.

Note  The instructions in this chapter assume that you used ECMap to construct 
your map. ECMap users should refer to the ECMap Reference Guide for more 
information.

Defining maps
Before you can run a map, you must define the map’s properties to the runtime 
engine. In general, these properties include the map’s name, associated 
attributes and other items that relate to a particular standard.

Defining a map includes three parts:

• Map Properties provide general information about the map, which 
includes the map’s name, type, underlying standard and transaction 
set/message.

• Map Directories tell ECRTP/TP where to find information about the map, 
including the standards directory.

• Map DSN tells ECRTP/TP how to connect to the Trading Partner and Log 
databases.

Procedures in this section are organized as they appear on Map Definition 
window.
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❖ Defining an Any-to-Any map

1 Click .

 – Or –

In the ECRTP/TP window, select File > Map > New.

2 In the Map Definition window, choose Any-to-Any as the Map Type; then 
type the map name in the Map box. 

Create a name that describes the map. Use CAPITAL letters and a 
maximum of 60 characters. 

3 In the Options group, type a value in the Century Minimum box.

The Century Minimum value defines the year used in the conversion of 6-
digit dates (with 2-digit years) to 8-digit dates (with 4-digit years). Every 
year after the Century Minimum is presumed to be in the current century; 
every year before and including the Century Minimum is presumed to be 
in the next century. This year is the global century minimum for this map.

4 In the Description box, describe the map.

5 Bring the Map Directories tab into focus, click Change All, then choose 
the map directory from the Directory selection dialog.

If you store your Trading Partner and Log information in an ODBC 
database, bring the Map DSN tab into focus. Otherwise, skip the following 
step.

6 In the Map DSN tab, do the following:

• If you have a DSN to the trading partner database

a Click the arrow next to the Data Source Name box in the Trade 
Partner group.

b Choose the DSN from the list of Data Source Names

• If you have a DSN to the Log database

a Click the arrow next to the Data Source Name box in the Log 
group.

b Choose the DSN from the list of Data Source Names.
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Notes

• If you need to create a DSN to the trading partner database, click 
Configure Data Source in the Trade Partner group. If you need help, click 
the help button on the ODBC Data Source Administrator dialog in 
Windows.

• If you want to test the connections to your databases, click Test Trade 
Partner Connection or Test Log File Connection. ECRTP/TP starts the 
database and tests the connection. 

❖ Defining an EDIFACT map

1 Click .

 – Or –

In the ECRTP/TP window, select File > Map > New.

When the Map Definition window appears, the Map Properties tab is in 
focus. ECRTP/TP associates the new map with the current project, which 
appears in the Project name box.

2 Choose the appropriate EDIFACT syntax from the Map Type. In the Map 
box, type the map name.

Create a name that describes the map. Use CAPITAL letters and a 
maximum of 60 characters. 

3 In the Message box, type the identifier for the EDIFACT message you 
want to map.

4 From the Direction box, choose the maps direction.

Direction determines whether the data in the map is input or output. If the 
data is the input, the direction is IN (inbound). If the data is the output, the 
direction is OUT (outbound). 

5 From the Version drop-down box, choose the map’s EDIFACT version. 

Projects can contain maps with different standards and versions of 
standards. ECRTP/TP comes with multiple versions of each standard.

6 In the Options group, type a value in the Century Minimum box.
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The Century Minimum value defines the year used in the conversion of 6-
digit dates (with 2-digit years) to 8-digit dates (with 4-digit years). Every 
year after the Century Minimum is presumed to be in the current century; 
every year before and including the Century Minimum is presumed to be 
in the next century. This year is the global century minimum for this map.

7 In the Description box, describe the map. 

8 Bring the Map Directories tab into focus, click Change All. From the 
Directory selection dialog, choose the map directory.

If you store your Trading Partner and Log information in an ODBC 
database, bring the Map DSN tab into focus. Otherwise, skip the next step.

9 In the Map DSN tab, do the following:

• If you have a DSN to the trading partner database

a Click the arrow next to the Data Source Name box in the Trade 
Partner group.

b Choose the DSN from the list of Data Source Names

• If you have a DSN to the Log database

a Click the arrow next to the Data Source Name box in the Log 
group.

b Choose the DSN from the list of Data Source Names.

Notes

• If you need to create a DSN to the trading partner database, click 
Configure Data Source in the Trade Partner group. If you need help, click 
the help button on the ODBC Data Source Administrator dialog in 
Windows.

• If you want to test the connections to your databases, click Test Trade 
Partner Connection or Test Log File Connection. ECRTP/TP starts the 
database and tests the connection. 

❖ Defining an HL7 map

1 Click .

 – Or –

In the ECRTP/TP window, select File > Map > New.
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When the Map Definition window appears, the Map Properties tab is in 
focus. ECRTP/TP associates the new map with the current project, which 
appears in the Project name box.

2 Choose HL7 from the Map Type, then type the map’s name of the map in 
the Map box.

Create a name that describes the map. Use CAPITAL letters and a 
maximum of 60 characters. 

3 In the Message/Type box, type the identifier for the HL7 message you 
want to map.

4 From the Direction drop-down box, choose the map’s direction. 

Direction refers to whether HL7 data is the input to or the output of the 
map. If HL7 data is the input, the direction is IN (inbound). If HL7 data is 
the output, the direction is OUT (outbound).

5 In the Options group, type a value in the Century Minimum box.

The Century Minimum value defines the year used in the conversion of 6-
digit dates (with 2-digit years) to 8-digit dates (with 4-digit years). Every 
year after the Century Minimum is presumed to be in the current century; 
every year before and including the Century Minimum is presumed to be 
in the next century. This year is the global century minimum for this map.

6 From the Version drop-down box, choose the HL7 version you want to use 
to create the map. 

Projects can contain maps with different standards and versions of 
standards. ECMap comes with multiple versions of each standard.

7 In the Description box, describe the map. 

8 Bring the Map Directories tab into focus, click Change All. From the 
Directory selection dialog, choose the map directory. 

9 If you store your Trading Partner and Log information in an ODBC 
database, bring the Map DSN tab into focus. Otherwise, skip this step.

10 In the Map DSN tab, do the following:

• If you have a DSN to the trading partner database

a Click the arrow next to the Data Source Name box in the Trade 
Partner group.

b Choose the DSN from the list of Data Source Names

• If you have a DSN to the Log database
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a Click the arrow next to the Data Source Name box in the Log 
group.

b Choose the DSN from the list of Data Source Names.

Notes

• If you need to create a DSN to the trading partner database, click 
Configure Data Source in the Trade Partner group. If you need help, click 
the help button on the ODBC Data Source Administrator dialog in 
Windows.

• If you want to test the connections to your databases, click Test Trade 
Partner Connection or Test Log File Connection. ECRTP/TP starts the 
database and tests the connection.

❖ Defining an NCPDP map

1 Click .

 – Or –

In the ECRTP/TP window, select File > Map > New.

When the Map Definition window appears, the Map Properties tab is in 
focus. ECRTP/TP associates the new map with the current project, which 
appears in the Project name box.

2 Choose NCPDP from the Map Type. In the Map box, type the map’s name.

Create a name that describes the map. Use CAPITAL letters and a 
maximum of 60 characters. 

3 In the Transaction box, type the identifier for the message you want to 
map.

4 From the Direction box, choose the map’s direction.

Direction determines whether the data is the map's input or output. If the 
data is the input, the direction is IN (inbound). If the data is the output, the 
direction is OUT (outbound). 

5 From the Version drop-down box, choose the map’s version. 

Projects can contain maps with different standards and versions of 
standards. ECRTP/TP comes with multiple versions of each standard.

6 In the Options group, type a value in the Century Minimum box.
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The Century Minimum value defines the year used in the conversion of 6-
digit dates (with 2-digit years) to 8-digit dates (with 4-digit years). Every 
year after the Century Minimum is presumed to be in the current century; 
every year before and including the Century Minimum is presumed to be 
in the next century. This year is the global century minimum for this map.

7 In the Description box, describe the map. 

8 Bring the Map Directories tab into focus, click Change All. From the 
Directory selection dialog, choose the map directory.

If you store your Trading Partner and Log information in an ODBC 
database, bring the Map DSN tab into focus. Otherwise, skip the next step.

9 In the Map DSN tab, do the following:

• If you have a DSN to the trading partner database

a Click the arrow next to the Data Source Name box in the Trade 
Partner group.

b Choose the DSN from the list of Data Source Names

• If you have a DSN to the Log database

a Click the arrow next to the Data Source Name box in the Log 
group.

b Choose the DSN from the list of Data Source Names.

Notes

• If you need to create a DSN to the trading partner database, click 
Configure Data Source in the Trade Partner group. If you need help, click 
the help button on the ODBC Data Source Administrator dialog in 
Windows.

• If you want to test the connections to your databases, click Test Trade 
Partner Connection or Test Log File Connection. ECRTP/TP starts the 
database and tests the connection. 

❖ Defining an X12 map

1 Click .

 – Or –

In the ECRTP/TP window, select File > Map > New.



CHAPTER 4    Working with Maps

Reference Guide 25

2 When the Map Definition window appears, the Map Properties tab is in 
focus. ECRTP/TP associates the new map with the current project, which 
appears in the Project name box.

3 Choose X12 from the Map Type. In the Map box, type the map’s name. 

Create a name that describes the map. Use CAPITAL letters and a 
maximum of 60 characters. 

4 In the Transaction box, type the identifier for the X12 message you want 
to map.

5 From the Direction box, choose the maps direction.

Direction determines whether X12 data is the map’s input or output. If 
X12 data is the input, the direction is IN (inbound). If X12 data is the 
output, the direction is OUT (outbound). 

6 From the Version drop-down box, choose the map’s version. 

Projects can contain maps with different standards and versions of 
standards. ECRTP/TP comes with multiple versions of each standard.

7 In the Options group, type a value in the Century Minimum box.

The Century Minimum value defines the year used in the conversion of 6-
digit dates (with 2-digit years) to 8-digit dates (with 4-digit years). Every 
year after the Century Minimum is presumed to be in the current century; 
every year before and including the Century Minimum is presumed to be 
in the next century. This year is the global century minimum for this map.

8 In the 8-digit Date in X12 Envelope box, specify whether refers to whether 
the date in the X12 GS segment has 6 digits (N) or 8 digits (Y). 

Some earlier versions of the standard required a 6-digit date, while later 
versions accept 8-digit dates. The version of the standard being used in the 
map is specified in GS 08 (the date in ISA 09 always has 6 digits). 

9 In the Description box, describe the map. 

10 Bring the Map Directories tab into focus, click Change All. From the 
Directory selection dialog, then choose the map directory. 

If you store your Trading Partner and Log information in an ODBC 
database, bring the Map DSN tab into focus. Otherwise, skip the next step.

11 In the Map DSN tab, do the following:

• If you have a DSN to the trading partner database
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a Click the arrow next to the Data Source Name box in the Trade 
Partner group.

b Choose the DSN from the list of Data Source Names

• If you have a DSN to the Log database

a Click the arrow next to the Data Source Name box in the Log 
group.

b Choose the DSN from the list of Data Source Names.

Notes

• If you need to create a DSN to the trading partner database, click 
Configure Data Source in the Trade Partner group. If you need help, click 
the help button on the ODBC Data Source Administrator dialog in 
Windows.

• If you want to test the connections to your databases, click Test Trade 
Partner Connection or Test Log File Connection. ECRTP/TP starts the 
database and tests the connection.

Modifying maps
After you define a map, you may need to modify its properties, move another 
map into the workspace, or copy to another project or directory.

❖ Selecting a map

1 Click .

 – Or –

In the ECRTP/TP window, select File > Map > Select.

2 In the Projects window, expand the Project Tree where the map resides, 
right-click the map and choose Select from the submenu.

Selecting a map makes the map active in the workspace. The status bar on 
the main ECRTP/TP window displays the name, project, and other 
information about the map.
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❖ Modifying the properties of an existing map

1 Click .

 – Or –

In the ECRTP/TP window, select File > Map > Select.

2 In the Projects window, expand the Project Tree where the map resides, 
right-click the map and choose Properties from the submenu.

3 Change the properties of the map as appropriate. 

❖ Copying a map from the Projects window

Copying a map allows you to reuse a map other projects or copy the map to 
another directory. Use this method to copy maps not currently in the 
workspace.

1 Click .

 – Or –

In the ECRTP/TP window, select File > Map > Select.

2 In the Projects window, expand the Project Tree where the map resides, 
and click the map you want to copy.

3 Click Options > Map Copy. 

When the Copy Map dialog appears, Project and Map names reflect the 
current map.

4 In the Trading Partner Option group, decide whether you want to include 
or exclude the Trading Partner Tables.

5 Choose the appropriate option in the Map Copy Direction group. 
Additional text boxes let you specify where you want the copy to reside.

Choose this option To do this…

This Map to Map Copy the properties of this map to another 
map.

In the Copy Map To group, click the Browse 
button next to the Map Name box, choose the 
appropriate Project Name and Map Name from 
the dialog box.
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❖ Copying a map from the workspace

Copying a map lets you reuse maps in other projects or copy maps to another 
directory. Use the following instructions to copy the map that is currently in the 
workspace.

1 With a map in the workspace, select Utility > Map Copy. 

When the Copy Map dialog appears, Project and Map names reflect the 
current map.

2 In the Trading Partner Option group, decide whether you want to include 
or exclude the Trading Partner Tables.

3 Choose the appropriate option in the Map Copy Direction group. 
Additional text boxes let you specify the where you want the copy to 
reside.

This Map from Map Move the properties of another map into this 
map.

In the Copy Map From group, click the Browse 
button next to the Map Name box, choose the 
appropriate Project Name and Map Name from 
the dialog box.

This Map to Directory Copy this map to a new directory.

In the Copy Map To box, click the Browse 
button, then choose the destination directory.

This Map from Directory Moves the properties of a map in another 
directory into this map.

In the Copy Map From box, click the browse 
button, then choose the directory where the 
map resides.

If you want to define a new map based on the 
copy, click Create This Map Definition from 
Directory Copy. 

Choose this option To do this…

Choose this option To do this…

This Map to Map Copy the properties of this map to 
another map.

In the Copy Map To group, click the Browse 
button next to the Map Name box, choose the 
appropriate Project Name and Map Name 
from the dialog box.
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❖ Deleting a map

1 Click .

 – Or –

In the ECRTP/TP window, select File > Map > Select.

2 In the Project Window, expand the Project Tree where the map resides, 
right-click the map and choose Delete from the submenu.

This Map from Map Move the properties of another map into this 
map.

In the Copy Map From group, click the 
Browse button next to the Map Name box, 
choose the appropriate Project Name and 
Map Name from the dialog box.

This Map to Director Copy this map to a new directory.

In the Copy Map To box, click the Browse 
button, then choose the destination directory.

This Map from Directory Moves the properties of a map in another 
directory into this map.

In the Copy Map From box, click the browse 
button, then choose the directory where the 
map resides.

If you want to define a new map based on the 
copy, click Create This Map Definition from 
Directory Copy. 

Choose this option To do this…
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Running maps
This section describes how to run inbound and outbound maps.

Inbound maps
Inbound maps take messages sent from various trading partners to create the 
map’s output. Running inbound maps tests this data before you move the maps 
into production. 

Note  Before you can run a map, you must set up the trading partner 
information. See Chapter 3, “Working with Trading Partners and Trade 
Agreements.”

❖ Running an inbound map

1 Click .

 – Or –

In the ECRTP/TP window, select File > Map > Select.

2 In the Project window, expand the Project Tree where the map resides, 
right-click the map and choose Select from the submenu.

ECRTP moves the map into the workspace.

3 In the ECRTP/TP window, click Tools > Run Map.

A property sheet appears that allows you to define the run parameters for 
the map. Although there are seven tabs, the most typical run time options 
appear on the Required, Option 1, and Option 2 tabs.

4 Define the map’s runtime parameters. See online help for information 
about specific options.

5 Click Run Map.

Outbound maps
Running an outbound map retrieves data from various applications as input that 
creates a message for specific Trading Partner. An acknowledgement sent in 
response to a sales order might represent a typical outbound map.
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❖ Running an outbound map

1 Click .

 – Or –

In the ECRTP/TP window, click File > Map > Select.

2 In the Project window, Right-click the map and choose Select from the 
submenu.

ECRTP moves the map into the workspace.

3 In the ECRTP/TP window, select Tools > Run Map.

A property sheet appears that allows you to define the run parameters for 
the map. Although there are eight tabs, the most typical run time options 
appear on the Required, Option 1, and Option 2 tabs.

4 Define the map’s runtime parameters. See online help for information 
about specific options.

5 Click Run Map.



Running maps 

32  ECRTP/TP



Reference Guide 33

C H A P T E R  5 Performing Additional Tasks

About this chapter This chapter describes additional tasks you can perform in ECRTP/TP.

Topics This chapter includes the following topics:

Topic Page

Working with cross-reference tables 34

Updating the database structure 38

Generating standard reports 38
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Working with cross-reference tables
Cross-reference tables provide a quick and easy way to convert data during 
mapping. They can be used to produce preassigned EDI codes when 
application data does not meet the EDI standard format, or for any other one-
to-one conversion. The most common reason for needing to modify a cross-
reference table in a map is to account for the differences in internal application 
codes when that same map is being run for multiple trading partners. 

Note  The features in ECRTP/TP for cross-reference tables and Run Map are 
identical to ECMap. Users of ECMap refer to the ECMap Reference Guide for 
additional information.

❖ Creating a cross-reference table

1 In the main ECRTP/TP window, select Tools > Cross Reference Tables.

2 In the Cross Reference Tables window, select File > New.

When the New Cross Reference Tables dialog appears, the Project and 
Map names reflect those of the map currently in the workspace.

3 In the File Name box, type the name of the new cross-reference table. 

File names must be 8 characters or less. 

4 What happens next depends on the value you choose in the Standard Field 
Number group

Choose this... To do this...

No Field Number Create a cross-reference table that does not use 
EDI values. If you choose this option, you must 
specify the following values:

• Standard Field Length

• Application Field Length

Select Field Number Open a dialog box and choose an element from the 
map that you want to cross reference. 

When the element selection window appears, 
click the row with the element you want to add, 
click OK. ECRTP/TP updates these values on the 
New Cross Reference Tables dialog 

• Standard Field Length

• Application Field Length

• Field Number
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5 In the Description box, describe the EDI data associated with the element 
number, or a brief general description of the data elements being cross-
referenced in the table. 

❖ Adding elements to a cross-reference table

After you create a table, use these instructions to add elements to an existing 
cross-reference table.

1 In the main ECRTP/TP window, select Tools > Cross Reference Tables.

2 In the Cross Reference Tables window, right-click the table you want to 
change and choose Properties from the submenu.

3 In the Cross Reference Table property sheet, select File > New. 

4 In the Cross Reference Entries dialog, add the following values:

5 Do one of the following:

• Click Next to add another entry or

• Click OK to return to the Cross Reference Table properties sheet

❖ Automatically creating entries in a cross-reference table

Use these instructions to populate all blank application fields in a cross- 
reference table entry with either the description or the EDI code value.

1 In the main ECRTP/TP window, select Tools > Cross Reference Tables.

For this field... Do this...

EDI Value Type a value from the code list for the standard used 
in the current map. 

For both inbound and outbound maps, this value is 
the EDI side of the EDI/application code conversion 
done by the cross-reference table. For non-EDI 
conversions in an outbound or any-to-any map, this 
is the source or input value.

 Application Value Type the value in the application data that 
corresponds to the value in the EDI Value textbox. 

For both inbound and outbound maps, this value is 
the application side of the EDI/application code 
conversion done by the cross-reference table. For 
non-EDI code conversions in an inbound map, this is 
the destination or output value.

Description Description the cross-reference entry you want to 
create.
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2 In the Cross Reference Tables window, right-click the table you want to 
change and choose Properties from the submenu.

3 In the Cross Reference Table property sheet, select one of the following:

• Options > Fill Fields from > Description 

• Options > Fill Fields from > EDI Value

4 What happens next depends on how you chose to populate the table.

❖ Importing cross-reference data from file

1 In the main ECRTP/TP window, select Tools > Cross Reference Tables.

2 In the Cross Reference Tables window, click the table where you want to 
insert the data.

3 Click File > Import and choose either Delimited File or Fixed Length File.:

4 In the Import window, choose the file you want to import.

❖ Viewing EDI Elements with values in a cross-reference tables

Use these instructions to toggle views between a full EDI code list and an 
abbreviated list of only those EDI elements that have corresponding 
application values in the cross-reference table. 

1 In the main ECRTP/TP window, select Tools > Cross Reference Tables.

2 In the Cross Reference Tables window, select Options > Modify View.

3 What happens next depends on the current view.

If you chose... The program does this

Description Populates any blank cross application 
fields in the Cross Reference column with 
values from the Description column. 

EDI Value Populates any blank application fields in 
the Cross Reference column with values 
from the EDI Field Value column.

If the current view is... ECRTP displays...

ALL RECORDS A full EDI code list
REFERENCE ONLY An abbreviated list of EDI elements 

with corresponding application values 
in the cross-reference table



CHAPTER 5    Performing Additional Tasks

Reference Guide 37

❖ Searching cross-reference tables for values

Use the Find function to search for values in a cross-reference table.

1 In the main ECRTP/TP window, select Tools > Cross Reference Tables.

2 In the Cross Reference Tables window, right-click the table you want to 
change and choose Properties from the submenu.

3 In the Cross Reference Table property sheet, select Edit > Find. 

4 In the Find dialog, Type a Search String in the text box. 

To search for additional occurrences of the string, click Find Next.

❖ Deleting an entry in a cross-reference table

1 In the main ECRTP/TP window, select Tools > Cross Reference Tables.

2 In the Cross Reference Tables window, right-click the table you want to 
change and choose Properties from the submenu.

3 In the Cross Reference Table property sheet, right-click the element you 
want to delete and choose Delete from the submenu. 

Note  ECRTP truncates any description or EDI field that exceeds 100 
characters. Maximum field length is 100 characters.

❖ Scanning a directory for unreferenced tables

Use these instructions to scan unreferenced cross-reference tables stored in a 
common directory. 

1 In the main ECRTP/TP window, select Tools > Cross Reference Tables.

2 In the Cross Reference Tables window, select File > Directory Scan.

3 In the Cross Reference Table property sheet, select Edit > Find. 

4 Select any of the unreferenced tables you want to use.

• To select a single table, click the row that contains the table.

• To select multiple contiguous tables, click the row with the first table, 
press SHIFT, then click the last table.

• To select non-contiguous tables, click row with the first table, press 
CTRL, then click the next table. Repeat this until you have selected all 
the tables you want.

5 Click OK.
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Notes

• Storing all cross-reference tables in a common directory allows multiple 
maps to share the same tables.

• Sometimes unreferenced tables can also unintentionally.This sometimes 
happens when you copy a map from one directory to another without using 
the Copy Map utility, or when files for a particular cross-reference table 
are moved from one map to another.   In cases like this, ECRTP does not 
update the mxref table, which leaves the tables undefined in the map.

Updating the database structure
When the version of the software used to run a map is different from the version 
of the software used to create the map, ECRTP/TP alerts you that you need to 
update your database structures.

Changes to the software often require changes to the databases, usually to add 
additional fields or to modify existing ones. The databases associated with 
maps that were created with prior versions of the software must be changed to 
reflect the new formats.

❖ Updating the database structure

• In the main ECRTP/TP window, select Utility > Update Database 
Structures.

Generating standard reports
ECRTP/TP includes these standard reports:

• Project Listing provides details about the maps in each project, including 
Map Name, Transaction, Direction, Standard, Description, and 
Directories.

• Company Identification identifies all trading partners by group code, and 
includes Interchange Qualifier, Authorization Qualifier and Security 
Qualifier.
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• Trading Partner Listing report identifies all trading partners, and 
includes Name, Trading Partner ID, and 

Group.

•  Trading Partner Detail provides detailed information about each trading 
partner, including Name, Trading Partner ID, Group, Interchange codes, 
shipping and billing information, map direction, delimiters, contact 
information, and map details.

❖ Generating a standard report

• In the main ECRTP/TP window, click Reports and choose the report you 
want to generate.



Generating standard reports 
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