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About This Book

The tutorials in this book provide a brief hands-on introduction to 
ECMap™. Each tutorial walks through the creation of a particular type of 
map and uses specific methods for creating the record definitions needed 
by ECMap. 

The objective of each tutorial is to allow you to perform all of the basic 
functions of creating a map and then add a few capabilities to the finished 
map, giving you an understanding of the overall functioning of the 
product. It is not the intention of the tutorials to teach you how to use the 
product, although it can help to serve that purpose. 

Audience While you certainly do not need to be a programmer to use ECMap, it is 
helpful to be familiar with certain technical concepts.

How to use this book • Chapter 1, “Mapping Sequential File Data”.

• Chapter 2, “Creating an Outbound Map”.

• Chapter 3, “Mapping XML Data”.

Related documents The following documents ship with ECMap:

• ECMap New Features Guide

• ECMap Installation Guide

• Release Bulletin for ECMap

• ECMap Reference Guide

• ECMap User Guide

• ECMap Getting Started

Additional documents are referred to in the ECMap documentation to 
supply you with specific information that supports this product:

• ECRTP Reference Guide to use the data transformation engine

Documentation that supports ECMap can be found on the Sybase Product 
Manuals web site. Go to Product Manuals at 
http://www.sybase.com/support/manuals, select ECMap from the drop-
down list, and click Go!
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Other sources of 
information

Use the Sybase Getting Started CD, the SyBooks Bookshelf CD, and the 
Sybase Product Manuals web site to learn more about your product: 

• The Getting Started CD contains release bulletins and installation guides 
in PDF format, and may also contain other documents or updated 
information not included on the SyBooks Bookshelf CD. It is included 
with your software. To read or print documents on the Getting Started CD, 
you need Adobe Acrobat Reader, which you can download at no charge 
from the Adobe Web site using a link provided on the CD.

• The SyBooks Bookshelf CD is included with your software. It contains 
product manuals in a platform-independent bookshelf that contains fully 
searchable, HTML-based documentation.

Some documentation is provided in PDF format, which you can access 
through the PDF directory on the SyBooks Bookshelf CD. To view the 
PDF files, you need Adobe Acrobat Reader.

Refer to the README.txt file on the SyBooks Bookshelf CD for 
instructions on installing and starting SyBooks.

• The Sybase Product Manuals Web site is the online version of the 
SyBooks Bookshelf CD that you can access using a standard Web browser. 
In addition to product manuals, you will find links to EBFs/Maintenance, 
Technical Documents, Case Management, Solved Cases, newsgroups, and 
the Sybase Developer Network.

To access the Product Manuals Web site, go to Product Manuals at 
http://www.sybase.com/support/manuals/.

Sybase EBFs and 
software 
maintenance

❖ Finding the latest information on EBFs and software maintenance

1 Point your Web browser to the Sybase Support Page at 
http://www.sybase.com/support.

2 Select EBFs/Maintenance. If prompted, enter your MySybase user name 
and password.

3 Select a product.

4 Specify a time frame and click Go. A list of EBF/Maintenance releases is 
displayed.
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Padlock icons indicate that you do not have download authorization for 
certain EBF/Maintenance releases because you are not registered as a 
Technical Support Contact. If you have not registered, but have valid 
information provided by your Sybase representative or through your 
support contract, click Edit Roles to add the “Technical Support Contact” 
role to your MySybase profile.

5 Click the Info icon to display the EBF/Maintenance report, or click the 
product description to download the software.

Conventions The formatting conventions used in this manual are:

If you need help Each Sybase installation that has purchased a support contract has one or more 
designated people who are authorized to contact Sybase Technical Support. If 
you cannot resolve a problem using the manuals or online help, please have the 
designated person contact Sybase Technical Support or the Sybase subsidiary 
in your area.

Formatting example Indicates

command names and 
method names

When used in descriptive text, this font indicates 
keywords such as:

• Command names used in descriptive text

• C++ and Java method or class names used in 
descriptive text

• Java package names used in descriptive text

myCounter variable 

Server.log

myfile.txt, sybase\bin

User Guide

Italic font indicates:

• Program variables

• Parts of input text that must be substituted

• Directory and file names.

• Book titles

Chapter 1, 
“Introduction”

References to chapter titles have initial caps and are 
enclosed within quotation marks.

File > Save Menu names and menu items are displayed in plain text. 
The angle bracket indicates how to navigate menu 
selections, such as from the File menu to the Save option. 

parse|put|get

Name|Address

The vertical bar indicates:

• Options available within code

• Delimiter within message examples

create table

table created

Monospace font indicates:

• Information that you enter on a command line or as 
program text.

• Example output fragments
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C H A P T E R  1 Mapping Sequential File Data 

About this chapter The tutorial in this chapter walks through the creation of an any-to-any 
map to convert a sequential file to a COBOL file.

Contents Topic Page

Creating an any-to-any map for sequential file to COBOL conversion 2

Setting up your mapping environment 3

Mapping your data 7

Running your map 25
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Creating an any-to-any map for sequential file to 
COBOL conversion

A map is a set of instructions used to transform source data in one format to 
destination data in a different format. ECMap provides many options for your 
source and destination data. Each can be a flat file, a database, XML/HTML, 
or standards data – X12, EDIFACT, or HL7. This means that ECMap can 
convert X12 data to a flat file, a flat file to a database, EDIFACT to 
XML/HTML, a database to HL7, a flat file to a flat file, a database to a 
database, HL7 to X12, and many other combinations.

During this tutorial of ECMap, you create and run a map to convert data from 
the format of one proprietary application to the format of a different proprietary 
application. ECMap calls this kind of map an any-to-any map. The data in each 
application is a flat file.

For this exercise, you are a company called Major Insurer, Inc. that sells 
insurance policies to large companies. In order to provide health insurance 
coverage to the employees of these companies, you need enrollment 
information for each covered employee. The goal of this exercise is to create 
and run a map to convert data from the format of the proprietary Human 
Resources application of your trading partner, Big Manufacturing Company, to 
the format of your own enrollment database. 

Complete this exercise in three easy steps:

1 “Setting up your mapping environment” on page 3

2 “Mapping your data” on page 7

3 “Running your map” on page 25

Install ECMap on your PC to use this tutorial. 

 Warning! You must create the following directory in order for the map to run:

c:\QT\output

❖ Starting the tutorial 

1 From the desktop, double-click the ECMap (globe) icon on your desktop. 
(When you install ECMap, the installation process automatically places 
this icon on your desktop.)

2 In the Password text box on the Login window, type ecmap. Press Enter or 
select OK.
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The main ECMap window opens and you are ready to begin the tutorial. 
To perform actions in ECMap, you can use the menu options at the top of 
the window or the icons on the toolbar. (The icons are also available on the 
ECMap Work Space, which can be opened by choosing Workspace from 
the View menu on the main ECMap window.)

Table 1-1: Menu icons

Hints • On many windows with a drop-down list of available choices, if you begin 
typing your choice, ECMap automatically enters it for you.

• You can use the Tab key to move from text box to text box when entering 
data on a window.

• On windows with a Next option, you can either select Next or press Alt-N.

• We assume you are using C as your hard drive. If not, substitute your hard 
drive letter for C.

Setting up your mapping environment 
Less maps required equals less time and money spent.

Project Map Company

Partners Application Directories Files/Databases

Records/Tables Memory Variables Rules

Mapping Map Flow Generate Map

Run Map
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ECMap Project and Map definition allows you to group related information 
together. This forms the baseline for sharing information and logic across 
projects and maps. The design of ECMap is oriented towards minimizing the 
number of maps created – a map can serve multiple trading partner 
relationships. 

The bottom line is that development costs are reduced and maintenance costs 
are lowered as well. 

Setting up your mapping environment involves:

• Setting up a project

• Setting up a map

❖ Setting up a project

To set up a project, you must provide a project name and a directory path for 
grouping your maps. Optionally, you may also provide a description of the 
project and the name and telephone number of a contact person. In this tutorial, 
you name your project Health Insurance and place your mapping information 
in the project directory c:\hlthmaps.

1 Select Project on the toolbar or Workspace. The Project window displays.

2 From the File menu on the Project window, select New. From the New 
submenu, select Project. The New Project window displays.

3 Enter Health Insurance in the Project Name text box.

4 Project Description is an optional field.

5 Enter c:\hlthmaps in the Directory text box. You can also Browse for the 
directory if it already exists.

6 Contact is an optional field.

7 Phone Number is an optional field.

8 Select OK to exit from the New Project window and return to the Project 
- Health Insurance window.

❖ Setting up a map

ECMap makes it easy to ensure that your data is Y2K compliant. You simply 
define a specific “windowing” year as your “Century Minimum”. All 6-digit 
dates with years beginning at this year are assumed to be in the current century, 
while all dates with prior years are assumed to be in the next century. ECMap 
automatically converts all 6-digit dates to 8-digit dates for you.
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If you are using an ODBC database for your log database, you must also set up 
the DSN (Data Source Name) to connect the database that contains log 
information to this map.

Optionally, you can also provide a description of the map.

1 From the File menu on the Project - Health Insurance window, select New. 
From the New submenu, select Map. The New Map Definition window 
displays. It has three tabs – Map Properties, Map Directories, and Map 
DSN. Enter the required information on each tab before you select OK at 
the bottom of the window.

2 On the map properties tab

a ECMap automatically populates the Map/Project text box with the 
name of the project – Health Insurance.

b In the Map/Map text box, enter BIGMANCO.

c From the Map/MapType drop-down list, select ANY2ANY.

d In the Options/Century Minimum text box, enter 11.

e Options/Description is an optional field.

3 On the map directories tab, projects and maps can be stored in the 
directory structure of your choice. This allows for extreme flexibility for 
both map development and map management in the operations 
environment.

• Select the Map Directories tab to make it active. ECMap 
automatically populates the text boxes of all the directories, in the 
format c:\ <project directory path>\<map name>. The directory 
entries for this example appear as follows:

 c:\hlthmaps\BIGMANCO
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For this example, you use these default directories. However, ECMap 
gives you the option to change the default entries, and it makes changing 
them a very easy process. You can use the Change All button in 
combination with the Change/Protect buttons to change multiple 
unprotected directories at once, or you can manually change the 
directories one at a time. The protection status does not affect manual 
changes.

Note  To change multiple directories at one time, set the protection status 
of each directory you want to change to Change and set all others to 
Protect. Select Change All to browse for a new directory. All the 
unprotected directories are changed to the directory you select.

Since you are allowed to browse for unprotected directories only, the 
Invert button is a handy feature that allows you to temporarily change a 
protected directory to unprotected, browse for and select a new directory, 
and then change the status back to protected by selecting the Invert button 
again. 

4 On the Map DSN tab:

a Enter information on the Map DSN tab only if you are using ODBC 
databases. Since you are not using ODBC databases in this tutorial, do 
not enter information on this tab.

b Select OK to return to the Project Maps window.

❖ Creating an any-to-any map

Assign a name to the map and associate that name with attributes, including a 
list of directories. You must:

1 Define the type of map as Any2Any

2 Specify the transaction as ANY

3 Specify the Y2K windowing year (Century Minimum)

4 Specify the directories in which map-related information are stored 

❖ Making your new map the current active map

• The project map that you just defined is highlighted on the Map – Health 
Insurance BIGMANCO window. You now make the map “current” by 
double-clicking on it. 
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You return to the main ECMap window and the “current” map information 
displays in the status bar at the bottom of the window.

Note  Each time you start ECMap, it “remembers” the last map you used 
and automatically opens it for you.

Mapping your data
Choose to use a record definition as the source, the destination, or both. The 
default is both.

Mapping your data involves:

• Defining the source data.

• Defining the destination data.

• Mapping the source data to the destination data.

• Creating the map flow.

Defining the source data 
Manually enter the record definitions for the source data, which is enrollment 
data from your trading partner. The enrollment file is produced by your trading 
partner’s human resources application (HR_ENRL.SEQ) and consists of two 
record types – one for subscribers (ENRL_SUB) and one for dependents 
(ENRL_DEP). These formats are displayed below:

HR_ENRL.SEQ
REC_TYPE 1 AN
SUBSCR_ID 9 AN
RELATIONSHIP 1 AN
SSN 9 AN
NAME_LAST 20 AN
NAME_FIRST 20 AN
NAME_MI 1  AN
ADDR1 35 AN
ADDR2 35 AN
CITY 20 AN
STATE 2 AN
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ZIP_5 5 AN
DT_OF_BRTH 8 DT
COVG_START_DT 8 DT
COVG_END_DT 8 DT

❖ Manually entering record definitions

ECMap automatically calculates the record length for you as you add fields to 
the record.

1 Select Records/Tables on the toolbar or Workspace. The Records/Tables 
window displays. 

2 Right-click Records on the Records/Tables window and choose New 
Record from the drop-down menu. The New Record window displays 
with the Required tab selected.

3 Enter the following on the New Record window, Required tab:

• Record Name – enter ENRL_SUB

• Record Description – enter Employee/subscriber record

• Record Length – enter 0

• End Character – select CRLF from the drop-down list

4 Select the Optional tab.

5 In Record Type, select Source (input data to map).

6 Select OK to display the New Field window. The New Field window has 
two tabs – Fields and Options.

❖ Navigating through the fields in a record

ECMap automatically fills in the Start Position of the current field. For the first 
field in a record, ECMap enters “1”. For subsequent fields, ECMap calculates 
the start position based on the field lengths you entered for the previous fields.

1 On the Fields tab, ECMap automatically enters the Record Name, 
ENRL_SUB. 

2 The Field Description is optional; if you leave it blank, ECMap populates 
it with the Field Name. 

3 You must enter the Field Name, Length, and Type on the Fields tab. 

4 The Web Parameter is required only for HTML or XML data. 
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5 If you begin typing “AN” ECMap automatically enters the alphanumeric 
Field Type for you.

6 After you enter the information on the Fields tab for each field (except the 
last), select Next. A blank New Field window displays. After you enter the 
information for the last field in the record, 

7 Select OK to return to the New Record window.

8 After you have entered the information for one field, to move to a new 
field, you can TAB down to Next and press Enter, select Next, or press the 
“N” key while holding down the ALT key.

❖ Entering information in the fields in a record

1  Enter the following on the Fields tab, then select Next:

Field Name REC_TYPE
Field Length 1
Field Type AN

2  Enter the following on the Fields tab, then select Next:

Field Name SUBSCR_ID
Field Length 9
Field Type AN

3  Enter the following on the Fields tab, then select Next:

Field Name RELATIONSHIP
Field Length 1
Field Type AN

4  Enter the following on the Fields tab, then select Next:

Field Name SSN
Field Length 9
Field Type AN

5  Enter the following on the Fields tab, then select Next:

Field Name NAME_LAST
Field Length 20
Field Type AN

6  Enter the following on the Fields tab, then select Next:
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Field Name NAME_FIRST
Field Length 20
Field Type AN

7  Enter the following on the Fields tab, then select Next:

Field Name NAME_MI
Field Length 1
Field Type AN

8  Enter the following on the Fields tab, then select Next:

Field Name ADDR1
Field Length 35
Field Type AN

9  Enter the following on the Fields tab, then select Next:

Field Name ADDR2
Field Length 35
Field Type AN

10  Enter the following on the Fields tab, then select Next:

Field Name CITY
Field Length 20
Field Type AN

11  Enter the following on the Fields tab, then select Next:

Field Name STATE
Field Length 2
Field Type AN

12  Enter the following on the Fields tab, then select Next:

Field Name ZIP_5
Field Length 5
Field Type AN

13  Enter the following on the Fields tab, then select Next:

Enter on the Fields tab:
Field Name DT_OF_BIRTH
Field Length 8
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Field Type DT

14 Two text boxes appear. Select from the drop-down list, then select Next:

Date Format YYYYMMDD
Century Minimum Type Use global century minimum

Note  If you start typing “YYY..” ECMap automatically enters the Date 
Format for you.

If you start typing “Use Glo...”, ECMap enters the Century Minimum 
Type for you automatically.

15 Enter on the Fields tab:

Field Name COVG_START_DT
Field Length 8
Field Type DT

16 Two text boxes appear. Select from the drop-down list, then select Next:

Date Format YYYYMMDD
Century Minimum Type Use global century minimum

17 Enter on the Fields tab:

Field Name COVG_END_DT
Field Length 8
Field Type DT

18 Select from the drop-down list:

Date Format YYYYMMDD
Century Minimum Type Use global century minimum

Select OK to return to the Records/Tables window. The fields in the record 
ENRL_SUB are displayed.

Note  If you accidentally select Next instead of OK, you must select 
Cancel to exit from the Field Properties window and return to the New 
Record window.
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❖ Creating a copy of a record and its fields

1 Right-click ENRL_SUB and choose Template Record from the 
drop-down menu. 

The Template Record window displays with the Required tab selected. 
Record Description, Record Length, and End Character are automatically 
populated with information from the ENRL_SUB record.

2 For the Required tab, enter or change the following:

• Name – enter ENRL_DEP. 

• Description – change the description to Employee dependent record. 

• Length – do not make any changes.

• For End Character – keep CRLF.

3 Select the Optional tab.

• For Record Type, keep Source (input data to map).

• Leave Record Tag blank.

4 Select OK to return to the Records/Tables window.

❖ Adding field attributes to the manually entered records

1 On the Records/Tables window, open ENRL_SUB, right-click 
REC_TYPE under ENRL_SUB, and choose Field Properties from the 
drop-down menu. The Field Properties window displays.

2 Select the Options tab to make it active. Select the check box next to 
Record Type to check it and then select in the Record Type text box. 

3 Type S in the text box and select OK to return to the Records/Tables 
window. Close the ENRL_SUB record by selecting the minus button next 
to it.

Note  The “record type” field property associates an application data 
record with a layout. In this example, assign “S” as the record type for a 
subscriber record and “D” as the record type for a dependent record. This 
is an arbitrary choice, and you may assign any unique value you choose.

4 Open ENRL_DEP, right-click REC_TYPE under ENRL_DEP, and choose 
Field Properties from the drop-down menu. The Field Properties window 
displays.

5 Select the Options tab to make it active. 
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6 Select the check box next to Record Type to check it and then select in the 
Record Type text box. 

7 Type D in the text box and select OK to return to the Records/Tables 
window.

8 From the File menu on the Records/Tables window, choose Close to return 
to the main ECMap window.

Defining the destination data 
Import the file definition for the destination application data from a COBOL 
copybook. The description of the enrollment file in the enrollment database is 
contained in the COBOL copybook whose format displays below:

ENROLL.CBL01 HLTH_INS_ENRL.
10 EMPLOYER_ID PIC X(5). 
10 EMPLOYER_NAME PIC X(20). 
10 SUBSCRIBER_ID PIC X(12). 
10 COVERAGE_EFFECTIVE_DATE PIC 9(8). 
10 COVERAGE_TERMINATION-DATE PIC 9(8). 
10 SUBSCRIBER_SSN PIC X(9). 
10 SUBSCRIBER_LAST_NAME PIC X(15). 
10 SUBSCRIBER_FIRST_NAM PIC X(15). 
10 SUBSCRIBER_MI PIC X(1). 
10 SUBSCRIBER_DOB PIC 9(8).
10 ADDRRESS_1 PIC X(25). 
10 ADDRRESS_2 PIC X(25). 
10 CITY PIC X(25). 
10 STATE PIC X(2). 
10 ZIP_CODE PIC X(10). 
10 DEPENDENT_SSN PIC X(9). 
10 DEPENDENT_FIRST_NAME PIC X(15). 
10 DEPENDENT_LAST_NAME PIC X(15). 
10 DEPENDENT_MI PIC X(1). 
10 DEPENDENT_DOB PIC 9(8). 
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❖ Changing field attributes in the imported COBOL data

1 Select Record/Tables on the toolbar or Workspace. The Records/Tables 
window displays, with three records – the two records you manually 
entered (ENRL_SUB and ENRL_DEP) and the record you just imported 
(HLTH_INS_ENRL).

Note  When ECMap imports a record definition, the program 
automatically populates the text boxes on the Fields tab – Record Name, 
Field Name, Field Description, Start Position, Field Length, and Field 
Type.

2 Right-click HLTH_INS_ENRL and choose Record Properties from the 
drop-down menu. The Record Properties window displays. Select the 
Optional tab. For the Record Type field, select the dropdown list box and 
choose Destination. Select OK to exit the Record Properties window.

3 Double-click HLTH_INS_ENRL to display the fields in the record.

4 Right-click EMPLOYER_ID and choose Field Properties from the 
drop-down menu. Select the Options tab of the Field Properties window to 
make it active and check Fixed String. Select the text box and type 13579. 
Select Next to display the Field Properties window for the next field in the 
record, EMPLOYER_NAME.

5 On the Options tab of the Field Properties window for 
EMPLOYER_NAME, check Fixed String. Select the text box and type 
Big Manufacturing Co. Select OK.

6 Right-click COVERAGE_EFFECTIVE_DATE and choose Field 
Properties from the drop-down menu. The Field Properties window 
displays. It has two tabs – Fields and Options.

7 For Field Type on the Fields tab, select DT-DATE from the drop-down list. 
Two additional text boxes appear – Date Format and Century Minimum 
Type.

Note  COBOL date fields are imported with a Field Type of UI. They must 
be changed to DT and a date format selected.

8 For Date Format, select MMDDYYYY from the drop-down list. 
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In the Century Minimum Type field, select Use global century minimum. 
Select Next to display the Field Properties window for the next field – 
COVERAGE_TERMINATION_DATE.

Note  The Y2K logic in ECMap allows the default values specified in the 
map definition process to be overridden on a field-by-field basis.

9 For Field Type on the Fields tab, select DT-DATE from the drop-down list. 
Two additional text boxes appear – Date Format and Century Minimum 
Type.

10 For Date Format, select MMDDYYYY from the drop-down list. In the 
Century Minimum Type field, select Use global century minimum. Select 
OK to exit the Record Properties window.

Note  If you choose different date formats for your input and output data, 
ECMap automatically makes the conversion for you.

11 Right-click SUBSCRIBER_DOB and choose Field Properties from the 
drop-down menu. The Field Properties window displays.

12 For Field Type on the Fields tab, select DT-DATE from the drop-down list. 
Two additional text boxes appear – Date Format and Century Minimum 
Type.

13 For Date Format, select MMDDYYYY from the drop-down list. In the 
Century Minimum Type field, select Use global century minimum. 

14 Select OK to exit the Record Properties window.

15 Right-click DEPENDENT_DOB and choose Field Properties from the 
drop-down menu. The Field Properties window displays.

16 For Field Type on the Fields tab, select DT-DATE from the drop-down list. 
Two additional text boxes appear – Date Format and Century Minimum 
Type.

17 For Date Format, select MMDDYYYY from the drop-down list. In the 
Century Minimum Type field, select Use global century minimum. 

18 Select OK to exit the Record Properties window.

19 On the Records/Tables window, choose Close from the File menu to return 
to the main ECMap window.
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❖ Importing record definitions from a COBOL copybook

1 From the Application Files menu on the main ECMap window, select 
Import Definition. 

2 From the Import Definition submenu, select COBOL. The COBOL 
Record Definition Import window displays. ECMap automatically enters 
the names of the Project and Map.

3 Select Browse next to the COBOL Definition Import File/File Name. The 
Choose COBOL Import File window displays. 

4 Locate c:\Program Files\Sybase\ECMap\maps\data\enroll.cbl and 
double-click it. You return to the COBOL Record Definition Import 
window and the program automatically enters the full directory path in the 
COBOL Definition Import File/File Name text box.

This specifies the location of the file (directory and file) containing the 
COBOL record definitions.

5 In the Options section of the window, select Add Application Record, File 
Name, and Directory. This populates the File Location/File Name and the 
File Location/Directory with the file name and directory path of the 
imported record definition.

6  In the File Location section of the window, select the File Name text box 
and change enroll.cbl to enroll.seq. Then, select the Directory text box and 
change the directory to c:\QT\OUTPUT. This specifies the location of the 
file (directory and file) containing the COBOL application data.

7 Select Continue. If a file with this name:

• Does not exist, the New File window displays. Go to the next step. 

• Already exists, the Select COBOL Records window displays. Go to 
Step 9. (A file with this name would already exist, for example, if you 
repeat this sequence of steps.)

8 On the New File window, ECMap automatically enters the enroll.seq as 
the File Name. Select SEQUENTIAL-ASCII as the File Type from the 
drop-down list. The File Description is an optional field. Select OK. The 
Select COBOL Records window displays.

Note  The file enroll.cbl contains the COBOL record definitions. The file 
enroll.seq contains the COBOL data.
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9 Select 01 HLTH_INS_ENRL to select it and select LOAD. The View Log 
dialog box appears with the message “Run Complete”. The definition of 
the record HLTH_INS_ENRL has been imported into ECMap and is 
associated with the file enroll.seq. The file enroll.seq is associated with the 
directory c:\QT\OUTPUT. Select Yes on the View Log dialog box.

10 The COBOL Import Log window displays, with a listing of the extracted 
records and a summary of any syntax errors in the file. 

11 Select OK. In the excobol dialog box, the message “Extract Run 
Completed Successfully” displays.

12 Select OK on the excobol dialog box to return to the COBOL Record 
Definition Import window. 

13 Select Cancel to exit from the COBOL Record Definition Import window 
to return to the main ECMap window.

❖ Linking records to files and directories

When you imported the COBOL record definition, you chose Add Application 
Record, File Name, and Directory. This automatically linked the records (to be 
read using the imported definitions) with a file and directory. ECMap uses this 
directory path to locate the application data when the map is run. When you 
manually entered record definitions, you told ECMap how to read the records, 
but not how to find the data. Now, link the records (to be read with the 
definitions you manually entered) with a file and a directory.

1 Select Applications Directory on the toolbar or Workspace. The 
Directories (Mailboxes) window displays. The directory path you set up 
when you imported the COBOL record definitions displays – 
c:\QT\OUTPUT. 

2 Double-click a directory to display the files it contains. Double-click a file 
to display the records it contains. Double-click a record to display the 
fields it contains. 

3 On the Directories (Mailboxes) window, right-click Application 
Directories and choose New Directory. The New Directory window 
displays. For Directory, Browse for or enter c:\Program 
Files\Sybase\ECMap\ maps\data. Select OK to return to the Directories 
(Mailboxes) window.

4 Select c:\..\maps\data and choose Open from the Application Files menu 
at the top of the window. The Files/ Databases window displays beside the 
Directories (Mailboxes) window.
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5 Right-click Files on the Files/Databases window and choose New File. 
The New File window displays. Select in the File Name text box and enter 
HR_ENRL.SEQ. For File Type, choose SEQUENTIAL-ASCII from the 
drop-down list. File Description is optional. Select OK to close the New 
File window.

6 Select HR_ENRL.SEQ and choose Open from the Record menu at the top 
of the Files/Databases window. The Records/Tables window displays 
beside the Directories (Mailboxes) and Files/Databases windows.

7 On the Records/Tables window, all three record definitions associated 
with this map are displayed.

8 Drag ENRL_SUB from the Records/Tables window and drop it on 
HR_ENRL.SEQ on the Files/Databases window. Now, drag ENRL_DEP 
from the Records/Tables window and also drop it on HR_ENRL.SEQ on 
the Files/Databases window. You have associated the records with a file.

9 Drag HR_ENRL.SEQ from the Files/Databases window and drop it on 
c:\Program Files\Sybase\ECMap\maps\data on the Directories 
(Mailboxes) window. You have associated the file with a directory.

You have now linked your input records with a file and a directory. On all 
three windows, you can double-click to display files in a directory, records 
in a file, and fields in a record. 

10 Choose Close from the File menu on each of these three windows to close 
them and return to the main ECMap window.

❖ Mapping the source data to the destination data

Mapping in ECMap is an easy drag-and-drop procedure. On the Any-to-Any 
mapping window, the source records are on the left, the destination records are 
on the right, and the mapping results are at the bottom of the window. Between 
the source and destination records, there is a temporary mapping workspace 
where you can map multiple records at one time. 

Note  To make sure that you have “grabbed” the element that you want to 
drag-and-drop, a small icon of a page must appear when you highlight the 
element. If the small page icon does not appear until after your cursor moves 
onto the section of the window with application data, you did not “grab” the 
element and you cannot drop it onto a record field to map the element to the 
field.

Create your mapping instructions with one of these methods:
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• Drag record fields from the source data and dropping them on record fields 
in the destination data one at a time 

• Enter multiple source and destination record fields in the temporary 
mapping workspace and mapping them simultaneously with the select of 
a button.

• Select Mapping on the toolbar or Workspace. The Rule Definition – New 
window displays. For Rule Number, enter 20. For Rule Definition, enter 
Mapping Commands. Select OK and the Any-to-Any Map window 
displays. Under Rules in the upper right corner of the window, 20 displays 
in the Number text box and 1 displays in the Line text box. You are ready 
to begin entering the individual mapping commands.

❖ Individually mapping fields from the ENRL_SUB record

Mapping in an any-to-any map takes place in one rule, and each instance of 
mapping is a command in this rule. Each time you map a field, ECMap assigns 
a new line number to the command that is being created.

To individually map fields in the ENRL_SUB record, drag a Source field from 
the right side of the window and drop it onto a Destination field on the left side 
of the window. The results show up in the Mapping section in the bottom 
middle of the window. 

1 Double-click ENRL_SUB under Source and HLTH_INS_ENRL under 
Destination to display the fields in the records.

• Drag the SUBSCR_ID field of the ENRL_SUB record under Source 
and drop it on the SUBSCRIBER_ID field of the HLTH_INS_ENRL 
record under Destination.

• Drag SSN and drop it on SUBSCRIBER_SSN.

• Drag NAME_LAST and drop it on SUBSCRIBER_ LAST _NAME.

• Drag NAME_FIRST and drop it on SUBSCRIBER_ FIRST _NAME.

• Drag NAME_MI and drop it on SUBSCRIBER_MI.

• Drag ADDR1 and drop it on ADDRESS_1.

• Drag ADDR2 and drop it on ADDRESS_2.

• Drag CITY and drop it on CITY.

• Drag STATE and drop it on STATE.

• Drag ZIP_5 and drop it on ZIP_CODE.

• Drag DT_OF_BIRTH and drop it on SUBSCRIBER_DOB.
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• Drag COVG_START_DT and drop it on 
COVERAGE_EFFECTIVE_DATE.

• Drag COVG_END_DT and drop it on 
COVERAGE_TERMINATION-DATE.

2 Under Source, close the ENRL_SUB record by selecting the minus button 
next to it. Double-click the ENRL_DEP record to open it.

❖ Mapping multiple fields simultaneously from the ENRL_DEP record:

In addition to individual drag-and-drop mapping, you can also map multiple 
fields at one time. First, you double-click the Source fields that you want to 
map, and they appear under Source in the temporary mapping workspace in the 
middle of the window. Then, you double-click the Destination fields you want 
to map, and they appear under Destination in the temporary mapping 
workspace. Finally, you select => between the two sides of the temporary 
mapping workspace and each Source field is mapped to the Destination field 
directly across from it. The results of all the mappings show up in the middle 
section at the bottom of the window.

1 From the ENRL_DEP record under Source, double-click:

• SSN

• NAME_LAST

• NAME_FIRST

• NAME_MI

• DT_OF_BIRTH

There are five Source entries in the temporary mapping workspace.

2 From the HLTH_INS_ENRL record under Destination, double-click:

• DEPENDENT_SSN

• DEPENDENT_LAST_ NAME

• DEPENDENT_FIRST_NAME

• DEPENDENT_MI

• DEPENDENT_DOB

There are five Destination entries in the temporary mapping workspace.
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3 Select => between the two sides of the temporary mapping workspace. 
Each Source field is mapped to the Destination field directly across from 
it. The temporary mapping workspace is now blank, and the results of all 
the mappings show up in the middle section at the bottom of the window. 
Select X in the upper right corner of the Any-to-Any Map window to close 
that window and return to the main ECMap window. 

❖ Creating the map flow

The map flow defines the relationship between the source application data and 
the destination application data. Levels and rules are the tools you use to create 
flow. You just created one rule – 20 Mapping Commands – when you mapped 
your data. Now, create the rules to read and write the data. Also create the 
levels that tell ECMap when to perform these rules.

• Select Map Flow on the toolbar or Workspace. The Any-to-Any Map Flow 
window displays. From the Option menu at the top of the window, select 
Multiple Files so that it is unchecked.

Note  To toggle between checking and unchecking an option, simply select 
the option.

❖ Adding rules

1 From the View menu at the top of the Any-to-Any Map Flow window, 
choose Rules. The Rule Definitions window displays.

2 From the File menu of the Rule Definitions window, choose New Rule. 
The Rule Definition – New window displays:

a For Rule Number, enter 10. 

b For Rule Definition, enter Read Subscriber Record. 

c Select OK to return to the Rule Definitions window.

Note  ECMap usually offers you more than one way to perform an action. 
For example, whenever you can choose New from a File menu, you can 
also right-click an object on the window to display a drop-down menu that 
allows you to add a new object.

3 Right-click rule 10: Read Subscriber Record and choose New Command 
from the drop-down menu. The Rule Command - New window displays. 
The Rule Number and Line Number are automatically entered by ECMap.



Mapping your data 

22  ECMap

4 In the Command text box on the Rule Command - New window, choose 
Sequential I/O from the drop-down menu. Four additional text boxes 
appear:

a Select the I/O Command up arrow and choose Read Record. 

b Select the Application Directory up arrow to display the Directories 
(Mailboxes) window. 

c Double-click c:\Program Files\Sybase\ECMap\maps\data, then 
double-click HR_ENRL.SEQ, and finally double-click ENRL_SUB. 

d When you double-click ENRL_SUB, the program automatically 
enters the directory, file, and record you double-clicked in the 
Application Directory, Application File, and File Record text boxes. 

e Select OK on the Rule Command – New window to close both that 
window and the Directories (Mailboxes) window.

5 From the File menu of the Rule Definitions window, choose New Rule. 
The Rule Definition – New window displays:

a For Rule Number, enter 30. 

b Rule Definition, enter Read Dependent Record. 

c Select OK to close the Rule Definition - New window.

6 Right-click rule 30: Read Dependent Record and choose New Command 
from the drop-down menu. The Rule Command - New window displays.

7 In the Command text box on the Rule Command - New window, choose 
Sequential I/O from the drop-down menu. Four additional text boxes 
appear. 

a Select the I/O Command up arrow and choose Read Record. 

b Select the Application Directory up arrow to display the Directories 
(Mailboxes) window. 

c Double-click c:\Program Files\Sybase\ECMap\maps\data, then 
double-click HR_ENRL.SEQ, and finally double-click ENRL_DEP 
(the record you want to read). When you double-click ENRL_DEP, 
the program automatically enters the directory, file, and record you 
double-clicked in the Application Directory, Application File, and 
File Record text boxes. 

d Select OK on the Rule Command – New window to close both that 
window and the Directories (Mailboxes) window.
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8 From the File menu on the Rule Definitions window, choose New Rule. 
The Rule Definition – New window displays. 

a For Rule Number, enter 40. 

b Rule Definition, enter Write Output Record. 

c Select OK to close the Rule Definition - New window.

9 Right-click rule 40: Write Output Record and choose New Command from 
the drop-down menu. The Rule Command – New window displays.

10 In the Command text box on the Rule Command – New window, choose 
Sequential I/O from the drop-down menu. 

a For the I/O Command, choose Write Record. Select the Application 
Directory up arrow to display the Directories (Mailboxes) window. 

b Double-click c:\qt\OUTPUT, the double-click enroll.seq, and finally 
double-click HLTH_INS_ ENRL (the record you want to write). 
When you double-click HLTH_INS_ENRL, the program 
automatically enters the directory, file, and record you double-clicked 
in the Application Directory, Application File, and File Record text 
boxes. 

c Select OK on the Rule Command – New window to close both that 
window and the Directories (Mailboxes) window.

11 Choose Close from the File menu of the Rule Definitions window to close 
that window and return to the Any-to-Any Map Flow window.

❖ Adding levels

Our source file is read sequentially, and the record type field determines when 
to break to a new level.

1 From the File menu of the Any-to-Any Map Flow window, choose New. 
Choose Add Master Level from the New submenu. 

The Any-to-Any Record Flow window displays side-by-side with the 
Any-to-Any Map Flow window. It has two tabs – Required and Advanced. 
In this exercise, enter information only on the Required tab.

2 On the Required Tab of the Any-to-Any Record Flow window, identify the 
following:

a Under Levels, select the Current up arrow. The Levels window 
displays to the left, superimposed over the Any-to-Any Map Flow 
window.
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b From the File menu of the Levels window, choose New. The New 
Level window displays. In the first text box, enter 100 as the level 
code. In the second text box, enter Read and Map Subscriber Record. 
Select OK to close to the New Level window. 

c On the Levels window, double-click 100 Read and Map Subscriber 
Record. The program enters 100 in the Current text box under Levels.

d Under Record Type, Mandatory has already been selected and cannot 
be changed.

e Under Records, select the Current up arrow. The Records/Tables 
window displays to the left, superimposed over the Any-to-Any Map 
Flow window. 

f On the Records/Tables window, double-click ENRL_SUB, and the 
program enters it in the Current text box under Records. 

g Under Rules, select the I/O up arrow. The Rule Definitions window 
displays to the left, superimposed over the Any-to-Any Map Flow 
window.

h On the Rule Definitions window, double-click rule 10: Read 
Subscriber Record. The program automatically enters 10 in the first 
I/O text box and Read Subscriber Record in the second I/O text box. 
Leave the default 0: DO Nothing rule as both the Before rule and as 
the After rule.

i Select OK on the Any-to-Any Record Flow of Level 100 window to 
return to the Any-to-Any Map Flow window.

j From the File menu on the Any-to-Any Map Flow window, choose 
New. Choose Add Child Level from the New submenu. The 
Any-to-Any Record Flow window displays.

3 On the Advanced Tab of the Any-to-Any Record Flow window:

a Under Levels, select the Current up arrow. The Levels window 
displays to the left, superimposed over the Any-to-Any Map Flow 
window.

b From the File menu on the Levels window, choose New. The New 
Level window displays. In the first text box, enter 200 as the level. In 
the second text box, enter Read Dependent Record and Map. Select 
OK to close the New Level window.

c On the Levels window, double-click 200 Read Dependent Record and 
Map. The program enters 200 in the Current text box under Levels.
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d As the Record Type, choose Optional (No Msg).

e Under Records, select the Current up arrow. The Records/Tables 
window displays to the left, superimposed over the Any-to-Any Map 
Flow window. 

f On the Records/Tables window, double-click ENRL_DEP, and the 
program enters it in the Current text box under Records. Close the 
Records/Tables window.

g Under Rules, select the I/O up arrow. The Rule Definitions window 
displays.

h On the Rule Definitions window, double-click rule 30: Read 
Dependent Record. The program automatically enters 30 in the first 
I/O text box on the Any-to-Any Record Flow window and Read 
Dependent Record in the second I/O text box. 

i On the Rule Definitions window, double-click rule 20: Mapping 
Commands. The program automatically enters 20 in the first Before 
text box on the Any-to-Any Record Flow window and Mapping 
Commands in the second Before text box. 

j On the Rule Definitions window, double-click rule 40: Write Output 
Record. The program automatically enters 40 in the first After text 
box on the Any-to-Any Record Flow window and Write Output 
Record in the second After text box. Close the Rule Definitions 
window.

k Select OK on the Any-to-Any Record Flow of Level 200 window to 
close that window and return to the Any-to-Any Map Flow window. 
Choose Close from the File menu of the Any-to-Any Map Flow 
window to return to the main ECMap window. Close all other open 
windows.

Running your map
ECMap is known for its high speed and quality performance. Map generation 
results in an efficient map run process, which in turn contributes to the speed 
and throughput of the ECMap mapping product.

Running your map involves:

• “Generating your map” on page 26
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• “Running your map” on page 26

The final steps in the mapping process are to generate and run your map. 
During generation, your map is checked to make sure that everything is set up 
properly. Generating the map produces the .map file, which contains all the 
mapping instructions you created. Running the map – with the ECRTP runtime 
program – interprets the .map file, reads the input data, performs the mapping, 
and creates the output file.

❖ Generating your map

When you generate a map, ECMap compiles all of your business rules and 
logic into your finished map.

1 Select Generate Map (the yellow traffic light) on the toolbar or Workspace. 
The Generate Map window displays.

2 Make sure that the Multiple Files check box is not checked.

Note  Multiple Files is checked by default. Select the check box to 
uncheck it, or you receive a warning – “All Recd Files with Multiple Recs 
must have Record Type Fields”

3 Select Run on the Generate Map window. Messages flash across the text 
box until the following message appears: “Map generation completed 
successfully”.

4 You can view the results of the map generation process by selecting View 
Log. The Generate Log window displays.

5 Select Exit to return to the main ECMap window.

❖ Running your map

Map files are distributed and deployed with the runtime engine.

1 Select Run Map (the green traffic light) on the toolbar or Workspace. 

The Run Any-to-Any Map window displays. It has several tabs – 
Required, Option 1, Option 2, File Alias, ODBC Alias, Parameters, I/O 
Redirect, and Web Script. 

For this exercise, you have to enter only one value. The program has 
already entered the other required information for you.
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If a map run is successful and Short Trace is used, the message “Maprun 
Complete – No Errors Encountered” appears. If the run is not successful, 
you need to run the map again, choosing Long Trace. You would then use 
the expanded information in this log to correct your errors.

2 On the Option 1 tab, select Short Trace as the Trace Type.

3 Select Run Map.

4 Select View Trace to review the trace log. The message “Maprun 
Complete – No Errors Encountered” displays on the outgoing.err-Notepad 
window. 

Note  If you choose Long Trace as the Trace Type, ECMap gives you a 
detailed list of records read and written, rules performed, etc. 

5 Close the outgoing.err Notepad window.

6 Close the Run Any-to-Any Map window to return to the main ECMap 
window.
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C H A P T E R  2 Creating an Outbound Map

About this chapter The tutorial in this chapter walks through the creation of an any-to-any 
map to convert COBOL data to an X12 850 transaction.

Contents Topic Page
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Mapping your data 39

Running your map 50

Adding complex business logic to your map 53
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Creating an outbound transaction map
During this tutorial of ECMap, create and run a map to convert data from a flat 
file to an X12 transaction set. ECMap calls this kind of map an outbound 
transaction map.

For this exercise, you are a company called Computer Services, Inc. who 
orders supplies from a trading partner called Memory Plus. The goal of this 
exercise is to create and run a map to convert data from the format of your 
Order Management System (COBOL-based application) to an X12 850 
Transaction Set (the standard EDI Purchase Order) to send to your trading 
partner.

You can complete this exercise in three easy steps:

• “Setting up your mapping environment” on page 31

• “Mapping your data” on page 39

• “Running your map” on page 50

After you successfully create and run your map, we introduce you to a few of 
the features that set ECMap apart from other mapping software and give you 
the ability to integrate complex business logic into your maps easily and 
quickly.

In order to use this tutorial, you need to have installed ECMap on your PC.

 Warning! You must create the following directory in order for the map to run:

c:\ Program Files\Sybase\ECMap\maps\data\OUT.X12

❖ Starting the tutorial 

1 From the desktop, double-click the ECMap (globe) icon on your desktop. 
(When you install ECMap, the installation process automatically places 
this icon on your desktop.)

2 In the Password text box on the Login window, type ecmap. Press ENTER 
or select OK.

The main ECMap window opens and you are ready to begin the tutorial. 
To perform actions in ECMap, you can use the menu options at the top of 
the window or the icons on the toolbar. (The icons are also available on the 
ECMap Work Space, which can be opened by choosing Workspace from 
the View menu on the main ECMap window.)
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Table 2-1: Menu icons

Hints • On many windows with a drop-down list of available choices, if you begin 
typing your choice, ECMap automatically enters it for you.

• You can use the Tab key to move from text box to text box when entering 
data on a window.

• On windows with a Next option, you can either select Next or press Alt-N.

• We assume you are using C as your hard drive. If not, substitute your hard 
drive letter for C.

Setting up your mapping environment 
Less maps required equals less time and money spent.

ECMap Project and Map definition allows you to group related information 
together. This forms the baseline for sharing information and logic across 
projects and maps. The design of ECMap is oriented towards minimizing the 
number of maps created - a map can serve multiple trading partner 
relationships. 

Project Map Company

Partners Application Directories Files/Databases

Records/Tables Memory Variables Rules

Mapping Map Flow Generate Map

Run Map
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The bottom line is that development costs are reduced and maintenance costs 
are lowered as well. 

Setting up your mapping environment involves:

• “Setting up a project” on page 32

• “Setting up a map” on page 32

• “Entering your company information” on page 35

• “Defining your trading partner and creating a trade agreement” on page 
37

❖ Setting up a project

To set up a project, you must provide a project name and a directory path for 
grouping your maps. Optionally, you may also provide a description of the 
project and the name and telephone number of a contact person. In this tutorial, 
name your project Upgrades Division and place your mapping information in 
the directory c:\upgrades\maps.

1 Select Project on the toolbar or Workspace. The Projects window displays.

2 From the File menu on the Projects window, select New. From the New 
submenu, select Project. The New Project window displays.

3 Type Upgrades Division in the Project Name text box.

4 Project Description is an optional field.

5 Type c:\upgrades\maps in the Directory text box. You can also Browse for 
the directory if it already exists.

6 Contact is an optional field.

7 Phone Number is an optional field.

8 Select OK to return to the Projects window.

❖ Setting up a map

Sybase maintains a comprehensive set of Standards, which are shipped to you 
with your ECMap installation CD. This includes X12 standards associated 
with the American National Standards Institute (ANSI), UN/EDIFACT, and 
HL7 (Health Level 7). Our Annual Upgrade Subscription provides updates to 
these standards within 30 days of the issue of a change by DISA, the Data 
Interchange Standards Association.
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To create an X12 map, you assign a name to the map and associate that name 
with attributes, including a list of directories. You must first define the type of 
map as X12, then specify:

• The X12 transaction set used in the map

• The direction of the map - OUT writes an X12 file and IN reads an 
X12 file

• The version of the X12 standard used in the map

• The size of the date in the EDI functional group envelope

• The Y2K windowing year

• The directories in which map-related information is located 

• The directory in which the ECMap standards are located

• If you are using an ODBC database for either your trading partner or log 
database, you must also set up the DSNs (Data Source Names) to connect 
the databases that contain trading partner and/or log information to this 
map 

Optionally, you may also provide a description of the map.

1 With Upgrades Division highlighted on the Project window, select New 
from the File menu and Map from the New submenu. The New Map 
Definition window displays. It has three tabs – Map Properties, Map 
Directories, and Map DSN. Enter the required information on each tab 
before you select OK at the bottom of the window.

2 On the map properties tab:

a ECMap automatically populates the Map/Project text box with the 
name of the project – Upgrades Division.

b In the Map/Map text box, type OUTPO1.

c From the Map/MapType drop-down list, select X12.

d In the Options/Transaction text box, type 850.

e From the Options/Direction drop-down list, select OUT.

f From the Options/Version drop-down list, select 004010.
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g In the Options/8 Digit Date in X12 Envelope text box, accept the 
default entry Y.

Note  ECMap makes it easy to ensure that your data is Y2K 
compliant. You simply define a specific year as your “Century 
Minimum”. All 6-digit dates with years beginning at this year are 
assumed to be in the current century, while all dates with prior years 
are assumed to be in the next century. ECMap then automatically 
converts all 6-digit dates to 8-digit dates for you.

h Options/Description is an optional field.

3 On the map directories tab:

Projects and maps can be stored in the directory structure of your choice. 
This allows for extreme flexibility for both map development and map 
management in the operations environment.

To change multiple directories at one time, set the protection status of each 
directory you want to change to Change and make sure that all others are 
set to Protect. Select Change All to browse for a new directory, to which 
all unprotected directories are changed.

a Select the Map Directories tab to make it active. 

ECMap automatically populates all of the directory text boxes except 
the EDI Standard Tables directory, in the format c:\<project directory 
path>\<map name>. The directory entries for this example appear as 
follows:

 c:\upgrades\maps\OUTPO1

For this example, accept these directories. However, ECMap gives 
you the option to change the default entries, and it makes changing 
them a very easy process. You can manually change them one at a 
time, or you can use the Change All button in combination with the 
Change/Protect buttons to change multiple unprotected directories at 
once. The protection status does not affect manual changes.
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b Rather than manually entering the EDI Standard Tables directory, 
browse for it. First, select the Invert button to change the protection 
status of all the map directories. This causes all the directories except 
the standards directory to be protected. (Originally, only the standards 
directory was protected and all of the map directories were 
unprotected.) Then, select Change All and the Select a Directory… 
window displays. Find and double-click the following standards 
directory:

 c:\Program Files\Sybase\Standards\4010

Note  Since you are allowed to browse for unprotected directories 
only, the Invert button is a handy feature that allows you to change a 
protected directory to unprotected, browse for and select a new 
directory, and then change the status back to protected by selecting the 
Invert button again. This is particularly useful when you want to 
browse for the standards directory.

c Select OK and the directory path is automatically entered in the EDI 
Standard Tables directory text box. Select Invert again to change the 
protection status back to its original configuration.

4 On the map DSN tab:

a Enter information on the Map DSN tab only if you are using ODBC 
databases. Since we are not using ODBC databases in this tutorial, do 
not enter information on this tab.

b Select OK to return to the Map - Upgrades Division window.

❖ Making your new map the current active map

• Each time you start ECMap, it “remembers” the last map you used and 
automatically opens it for you. You now make the project and map 
“current” by highlighting the map you just defined (OUTPO1) on the Map 
– Upgrades Division window and double-clicking on it. You return to the 
main ECMap window and the “current” map information displays in the 
status bar at the bottom of the window.

❖ Entering your company information

ECMap is designed to support environments with a large number of trading 
partners and transactions. For third-party service organizations, 
business-to-business applications, and networks, ECMap allows a company to 
maintain multiple company profiles.
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The Company ID information identifies your company to the outside world. 
The Interchange Qualifier and Code you enter for your company are used in the 
ISA envelope to route your messages through the chain of networks to their 
final destination. 

1 Select Company on the toolbar or Workspace. The Company ID window 
displays.

2 From the File menu on the Company ID window, select New. The 
Company ID – New window displays.

3 In the Company section at the top of the window:

• Type 1 in the Profile Number text box.

The record number field allows a company to have multiple values to 
identify itself to the outside world. 

4 Type Computer Services, Inc. in the Name text box.

5 In the section labeled Outbound Sender Default Envelope Values:

The default value for the Interchange:Qualifier is 01. 

The associated Interchange/Description is D-U-N-S Number, Dun & 
Bradstreet. (Each qualifier has an associated description, which is used to 
automatically populate the Interchange/Description text box when you 
enter a qualifier.)

This value is placed in the ISA 05 data element of the X12 Interchange 
envelope.

6 In the Interchange/Code text box, enter 033459876.

This value is placed in the ISA 06 data element of the X12 Interchange 
envelope. 

7 The Interchange Internal ID and the Interchange Internal Sub-ID are used 
only for EDIFACT maps. Since you are creating an X12 map, you do not 
enter these values. 

8 In the Group: Code text box, type 033459876.

This value is placed in the GS 02 data element of the X12 Functional 
Group envelope. 

9 The Group: Qualifier is not required for X12 maps. Accept the default 
entries for Authorization: Qualifier, Description, and Code and for 
Security: Qualifier, Description, and Code.
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10 Select OK to return to the Company ID window. From the File menu on 
the Company ID window, select Close to return to the main ECMap 
window.

❖ Defining your trading partner and creating a trade agreement

Trading Partner management allows for support of multiple trading partners 
and trade agreements. A trade agreement defines the business transactions that 
your company is exchanging with your trading partners. The trade agreement 
also sets up the default X12 version, test/production status, and map flow 
direction to establish a baseline for “unattended” data translation. This gives 
ECMap the capability of switching maps while running, as it detects the 
parameters defined by the trade agreement and automatically invokes the 
correct map.

When you define your trading partner, you link the trading partner’s EDI 
address with the value used by application system to represent the trading 
partner. When you create a trade agreement, you link your trading partner to a 
map so the proper map is executed.

1 Select Trading Partners on the toolbar or Workspace. The Trading Partners 
window displays.

2 From the File menu on the Trading Partners window, select New. 

The Trading Partner – New window displays. It has four tabs – General, 
Contacts, Envelope/Lookup, and Delimiter/Terminator. Enter the required 
information on each tab before you select OK at the bottom of the window.

3 On the general tab:

In the Trading Partner section at the top of the window:

a Type 24680 in the Internal ID text box.

This is the value used by your company’s application to identify the 
trading partner.

b Type Memory Plus in the Name text box.

c Type Memory Plus in the Mailbox Name text box.

Mailboxing is integrated with EC Gateway Server and further 
supports a lights-out “unattended” environment. Mailboxing is 
supported by trading partner and by specific transaction type for a 
trading partner. It is also supported by communications channel if you 
use EC Gateway Server.
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d For the entry in the Mailbox Folder text box, you can either Browse 
for it on the Select a Directory … window or type c:\Program 
Files\Sybase\ECMap\maps\data\OUT. 

 (The mailbox is the directory where the data is placed for 
transmission to and receipt from the trading partner.)

e The information in the View/Modify Interchange Control Number 
section is rarely changed. Do not make any modifications to the 
numbers displayed.

f Copy this Trading Partner’s data when “Copy Tables” utility is used 
is an optional feature, which you do not use in this exercise.

ECMap has a utility that lets you copy ODBC trading partner 
databases – with the option to copy all databases or only those with 
this Export check box checked.

4 On the contacts tab:

All of the information on the Contacts tab is optional.

The qualifier value is placed in the ISA 07 data element of the X12 
interchange envelope. The code is placed in the ISA 08 data element.

5 On the envelope/lookup tab:

In the top section of the window labeled Outbound Receiver Default 
Envelope Values/Inbound Lookup Values:

a The default value for the Interchange: Qualifier is 01 with D-U-N-S 
Number, Dun & Bradstreet as the associated Description. 

In the Interchange:Code text box, type 024509876.

b The Interchange Internal ID and the Interchange Internal Sub-ID are 
used only for EDIFACT maps. 

Since you are creating an X12 map, you do not enter these values. 

c In the Group text box row, Code field, type 024509876.

This value is placed in the GS 03 data element of the X12 functional 
group envelope.

d The Group: Qualifier is not required for X12 maps. Accept the default 
entries for Authorization: Qualifier, Description, and Code and for 
Security: Qualifier, Description, and Code.

In the bottom section of the window labeled Outbound Sender 
Override Envelope Values/Inbound Lookup Values:
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e Do not enter any information in this section for this exercise.

6 On the delimiters/terminators tab:

All of the information on the Delimiters tab is optional.

a You can override the standard values for segment, element, and 
subelement separators and for release characters.

b Select OK to return to the Trading Partners window.

❖ Creating a trade agreement

ECMap trade agreement profiles establish an environment for “unattended” 
map translation, regardless of trading partner and trading partner versions. 
Using trade agreements, ECMap can automatically switch maps while it is 
running, as it detects changes in trading partners and transactions.

1 From the File menu on the Trading Partners window, select Trade 
Agreements . . . 

 The Trade Agreements with Trade Partner: Memory Plus window 
displays.

Note  Trading partners may use different EDI versions of the transaction 
sets that are sent and/or received and therefore may require different maps. 

2 From the File menu on the Trade Agreements with Trade Partner: Memory 
Plus window, select Add Map. 

A trade agreement is created linking the current map with the trading 
partner, and the map information for the current map is used to populate 
the window – Transaction, Purpose, Status, Version, and Map.

3 From the File menu on the Trade Agreements with Trade Partner: Memory 
Plus window, select Close to return to the Trading Partners window.

4 From the File menu on the Trading Partners window, select Close to return 
to the main ECMap window.

Mapping your data
Mapping your data involves:

• Defining the application data.
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• Creating a customized transaction set.

• Mapping the source data to the destination data.

• Creating the map flow.

Defining the application data 
ECMap gives you the option to import a variety of application data formats. 
You can import record definitions from COBOL copybooks, ODBC data 
sources (such as Microsoft Access, Oracle, Sequel Server, and Excel), 
delimited flat files, other maps, etc. ECMap also allows you to import record 
definitions from HTML and XML formats.

Export options are also available for ODBC databases, HTML, and XML.

The ability to import record definitions eliminates the manual step of re-keying 
the information –saving time and money and preventing the introduction of 
errors.

Import the file definition from a COBOL copybook. The purchase order file 
produced by the purchasing system consists of two records whose descriptions 
are contained in a COBOL copybook called ORDERS.CBL. The format of the 
COBOL copybook displays below.

ORDERS.CBL01 ORDER-HEADER.
10 REC-TYPE PIC X(1).
10 VENDOR-NO PIC X(12).
10 PO-DATE PIC 9(8).
10 PO-NO PIC X(22).
10 CONTRACT-NO PIC X(9).
10 SHIP-TO-DUNS PIC X(13).
10 PO-LINE-NO PIC X(2).
10 PROCESSED PIC X(1).
10 FILLER  PIC X(50).01 ORDER-DETAIL. 
10 REC-TYPE PIC X(1).
10 PO-NO  PIC X(22).
10 QTY PIC 9(4).
10 UOM PIC X(2).
10 DESCRIPTION PIC X(50).
10 ITEM-NO PIC X(12).
10 STOCK-LOC PIC X(4).
10 UPC-NO PIC X(12).
10 ITEM-PRICE PIC 9(5)v99.
10 FILLER  PIC X(50).
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The data file produced by the purchasing system, ORDERS.SEQ, contains the 
purchase order data that is mapped to the X12 850 Transaction Set. The file that 
is used in this exercise contains data for two purchase orders, as shown below:

ORDERS.SEQ
A24680 19990109PO1133557799-1 98-100010027364321 4Y
CPO1133557799-1 160EA233MHz Upgrade chip 11410-CP A310900123456890 19800
CPO1133557799-1 8DZ100MB Zip Disk 21410-ZD A311520098345690 15700
CPO1133557799-1 32EAPowerEdge 6300 400MHz 31420-CP A312100034201120 65399
CPO1133557799-1 16EAUltra ATA/66 8.4 GB Hard Drive 41420-HD 
A313090035201127 19350
A24680 19990109PO321335577-1 98-301010023364990 3Y
CPO321335577-1 20EA333MHz Upgrade 11409-CP A310990412345688 7998
CPO321335577-1 8EAPowerEdge 6300 400MHz 31420-CP A312100034201120 19350 
CPO321335577-1 32DZZip Disks 100MG 21409-ZD A315050903420190 9900

❖ Importing a data definition from COBOL

1 From the Application Files menu on the main ECMap window, select 
Import Definition. Then select COBOL from the Import Definition 
submenu. The COBOL Record Definition Import window displays. 
ECMap automatically populates the Project and Map names.

2 Select Browse next to the COBOL Definition Import File/File Name. The 
Choose COBOL Import File window displays. 

3 Locate the file c:\Program Files\Sybase\ECMap\maps\data\orders.cbl 
and double-click it. 

You return to the COBOL Record Definition Import window, and the 
program automatically enters it in the COBOL Definition Import File/File 
Name text box.

This specifies the location of the file containing the COBOL record 
definitions – orders.cbl.

4 In the Options section of the window, select Add Application Record, File 
Name, and Directory. 

This populates the File Location/File Name and the File 
Location/Directory with the file name and directory path of the imported 
record definition.

5 In the File Location section of the window, select in the File Name text box 
and change orders.cbl to orders.seq.

This specifies the location of the file containing the COBOL application 
data - orders.seq.
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6 Select Continue. 

If a file with this name does not exist, the New File window displays. Go 
to Step 7. If a file with this name already exists, the Select COBOL 
Records window displays. Go to Step 9. (A file with this name would 
already exist, for example, if you repeat this sequence of steps or if you 
have used the ECMap training manual.)

7 On the New File window, ECMap automatically enters the File Name. 
Select SEQUENTIAL-ASCII as the File Type from the drop-down list.

8 The File Description is an optional field. Select OK. The Select COBOL 
Records window displays.

9 On the Select COBOL Records window, select ORDER-DETAIL, hold 
down Shift and select ORDER-HEADER to select both records.

10 Select LOAD. If you have previously loaded the record definitions, you 
are asked to confirm that you want to overwrite the application file 
records. Select Yes. The View Log dialog box appears with the message 
“Run Complete”. The records have been imported into ECMap, and they 
are associated with the file orders.seq. The file orders.seq is associated 
with the directory c:\..\data. Select Yes.

11 You return to the COBOL Import Log window displays, with a listing of 
the extracted records and a summary of any syntax errors in the file. Select 
OK. The excobol dialog box displays, with the message “Extract Run 
Completed Successfully”. Select OK.

12 The COBOL Record Definition Import window displays. Select X in the 
upper right corner of the window to return to the main ECMap window.

❖ Adding field attributes to the imported COBOL data

1 Select Records/Tables on the toolbar or Workspace. The Records/Tables 
window displays, with the two records you imported - ORDER-DETAIL 
and ORDER-HEADER.

2 Double-click ORDER-HEADER to display the fields in the header record.

3 Select the REC-TYPE field to select it. From the Field menu at the top of 
the window, select Properties. The Field Properties window for the 
REC-TYPE field displays. It has two tabs – Fields and Options. ECMap 
automatically populates the text boxes on the Fields tab – Record Name, 
Field Name, Field Description, Start Position, Field Length, and Field 
Type.
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The “record type” field property associates an application data record with 
a layout. In this example, we assign “A” as the record type for a header 
record. This is an arbitrary choice, and you may assign any unique value 
you choose.

4 Select the Options tab to make it active, and then select the check box next 
to Record Type. Type A in the Record Type text box. Select Next to view 
the next field in the record.

5 The Field Properties window for the VENDOR-NO field displays. Select 
the Options tab to make it active, and then select the check box next to 
Trading Partner ID. Select Next to view the next field in the record.

The VENDOR-NO field is used to retrieve information from the trading 
partner file to build the X12 envelopes that surround the transaction. It is 
the internal value in the application data that identifies to whom the data 
is being sent. 

6 The Field Properties window for the PO-DATE field displays. In the Field 
Type on the Fields tab, select DT-Date from the drop-down list. Two 
additional text boxes appear – Date Format and Century Minimum Type.

COBOL date fields are imported with a Field Type of UI. They must be 
changed to DT and a date format selected.

7 In the Date Format field, select YYYYMMDD from the drop-down list. In 
the Century Minimum Type field, select Use global century minimum

The Y2K logic in ECMap allows the default value specified in the Map 
definition process to be overridden on a field by field basis.

8 Select OK to return to the Records/Tables window.

9 Close the ORDER-HEADER record by selecting the minus sign next to it. 
Double-click the ORDER-DETAIL record to display the fields in the 
detail record.

10 Select the REC-TYPE field to select it. From the Field menu at the top of 
the window, select Properties. The Field Properties window for the 
REC-TYPE field displays.

The “record type” field property associates an application data record with 
a layout. In this example, we assign “C” as the record type for a detail 
record. This is an arbitrary choice, and you may assign any unique value 
you choose.

11 Select the Options tab to make it active, and then select the check box next 
to Record Type. Type C in the Record Type text box. 
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12 Select OK to return to the Records/Tables window. From the File menu on 
the Records/Tables window, select Close to return to the main ECMap 
window.

❖  Creating a customized transaction set

ECMap comes pre-loaded with information about the ANSI X12, UN 
EDIFACT, and HL7 standards. When you select a transaction, ECMap already 
knows which segments are mandatory and which are optional. 

Annual upgrade subscriptions quickly provide you with changes almost as 
soon as they are released.

ECMap’s optional SEF (Standard Exchange Format) Utility further automates 
the mapping process by allowing you to automatically import implementation 
guides from your trading partners.

Bundled standards, timely upgrades, the SEF utility – all these features help to 
reduce the time required for both development and maintenance. 

With ECMap, it is easy to create a customized transaction set based on your 
implementation guide. The full X12 transaction set displays in the Create 
Transaction window. Simply check the segments you want to include and tell 
ECMap to “make” the transaction.

For our transaction, we include the following segments in the 850 Transaction 
Set: ST, BEG, N1, PO1, and SE.

1 From the Build menu on the main ECMap window, select Create 
Transaction. The Create Transaction- 850 Purchase Order window 
appears.

2 The mandatory segments ST, BEG, PO1, and SE are already checked. 

3 To select N1, you must first locate it. To quickly locate the N1 segment, 
choose Find from the Edit menu. When the Find dialog box displays, enter 
N1 in the Search text box and select Find. The program automatically 
takes you to the first N1 segment. (There are four N1 segments.) Select the 
N1 check box to select it. (Be sure not to check the N1 loop, but only the 
N1 segment. If you check the loop, all of the segments within the loop are 
checked.)

4 From the File menu on the 850 Purchase Order window, select Make 
Transaction. The transaction is created, and the Mapping – Application to 
X12 window displays. The left section of the window is Source: 
Application Data and the right section of the window is Destination: X12. 
The bottom of the window is the Mapping section.
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❖ Mapping the source data to the destination data

Mapping in ECMap is an easy drag-and-drop procedure. ECMap automatically 
populates some elements from information you entered. In this example, 
ECMap maps the SE and the ST segments. Map the BEG, N1, and PO1 
segments by simply dragging record fields from our application data and 
dropping them onto the appropriate elements. ECMap has a feature that allows 
you to globally ignore any elements that do not have to be mapped.

To make sure that you have “grabbed” the element that you want to 
drag-and-drop, a small icon of a page must appear when you highlight the 
element. If the small page icon does not appear until after your cursor moves 
onto the section of the window with application data, you did not “grab” the 
element and you cannot drop it onto a record field to map the element to the 
field.

As data is mapped to elements, the yellow circles next to the elements turn 
green. The most recently mapped record field has a check mark next to it. And 
the mapping assignments are displayed in the bottom section of the mapping 
window. 

To quickly locate a code, select any entry in the Value column and type the code 
you want to locate. Or you can use the Find command in the Edit menu. In 
either case, ECMap automatically displays the highlighted code. 

By giving you a graphical view of your mapping and the business rules you 
have used, ECMap makes it easy for you to review the work you have 
completed.

1 Map the BEG segment:

a On the Destination: X12 section of the Mapping - Application to X12 
window, double-click the BEG segment. 

The elements associated with the BEG segment are displayed.

b Right-click BEG 01 (Transaction Set Purpose Code) to display a 
drop-down menu. From the menu, left-click Full Code List to select it. 

The Full Code List for Element 353 displays, superimposed over the 
left section of the window.

c Click, hold, and drag the code Value 00 (not the Code Description 
Original) from the Full Code List for Element 353 section and drop it 
on BEG 01 in the Destination: X12 section. In the Mapping section at 
the bottom of the window, STRVAR appears under Record and 00 
appears under Field Name.
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d Right-click BEG 02 (Purchase Order Type Code) to display a 
drop-down menu. From the menu, left-click Full Code List to select 
it. The Full Code List for Element 92 appears on the left section of the 
window.

e Click, hold, and drag the code Value SA (not the Code Description 
Stand-alone Order) from the Full Code List for Element 92 section 
and drop it on BEG 02 in the Destination: X12 section. In the 
Mapping section, STRVAR appears under Record and SA appears 
under Field Name.

f Right-click BEG 03 (Purchase Order Number) to display a drop-down 
menu. From the menu, left-click Record/Field from to select it. 

The two records ORDER-DETAIL and ORDER-HEADER display in 
the Source: Application Data section of the window. 

g Double-click the ORDER-HEADER record to display the fields in the 
record.

h Click, hold, and drag the field PO-NO from the Source: Application 
Data section and drop it on BEG 03 (Purchase Order Number) in the 
Destination: X12 section. In the Mapping section, ORDER-HEADER 
appears under Record and PO-NO appears under Field Name.

i Close the BEG segment by selecting the minus sign next to it.

2 Mapping the N1 segment

a On the Destination: X12 section of the Mapping – Application to X12 
window, double-click the N1 segment. The elements associated with 
the N1 segment are displayed.

b From the View menu at the top of the window, select Segment Detail.

The Segment window displays. Highlight the N1 Level. From the Edit 
menu, select Properties. The Segment Properties N1 window 
displays. In the Loop text box, delete N1. In the Depth text box, 
change 1 to 0. Select OK. From the File menu on the Segment 
window, choose Close to return to the Mapping – Application to X12 
window.

Note  On outbound maps, the loop and level structure must sometimes 
be changed to allow ECMap to create the map flow automatically.
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c Right-click N1 01 (Entity Identifier Code) to display the drop-down 
menu. From the menu, left-click Full Code List to select it. The Full 
Code List for Element 98 appears on the left section of the window.

Note  ECMap contains the full code list for every element in every 
transaction in every version of X12 that is shipped with the product.

d Click, hold, and drag the code Value ST (not the Code Description 
Ship To) from the Full Code List for Element 98 section and drop it 
on N1 01 in the Destination: X12 section. In the Mapping section at 
the bottom of the window, STRVAR appears under Record and ST 
appears under Field Name.

e Right-click N1 03 (Identification Code Qualifier) to display the 
drop-down menu. From the menu, left-click Full Code List to select 
it. The Full Code List for Element 66 appears on the left section of the 
window.

f Click, hold, and drag the code Value 1 (not the Code Description 
D-U-N-S Number, Dun & Bradstreet) from the Full Code List for 
Element 66 section and drop it N1 03 in the Destination: X12 section. 
In the Mapping section at the bottom of the window, STRVAR 
appears under Record and 1 appears under Field Name.

g Right-click N1 04 (Identification Code) to display the drop-down 
menu. From the menu, left-click Record/Field to select it. The two 
records ORDER-DETAIL and ORDER-HEADER display again in 
the Source: Application Data section of the window. If the fields of 
the ORDER-HEADER record are not displayed, double-click 
ORDER-HEADER.

h Click, hold, and drag the field SHIP-TO-DUNS from the Source: 
Application Data section and drop it on N1 04 in the Destination: X12 
section. In the Mapping section, ORDER-HEADER appears under 
Record and SHIP-TO-DUNS appears under Field Name.

i Close the N1 segment by selecting the minus sign next to it.

3 Mapping the PO1 segment

a On the Destination: X12 section of the Mapping– Application to X12 
window, double-click the PO1 segment. The elements associated with 
the PO1 segment are displayed.
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b Close the ORDER-HEADER record by selecting the minus sign next 
to it. Double-click the ORDER-DETAIL record to display the fields 
in the record.

c Click, hold, and drag the field QTY from the Source: Application 
Data section and drop it on PO1 02 (Quantity Ordered) in the 
Destination: X12 section. In the Mapping section, ORDER-DETAIL 
appears under Record and QTY appears under Field Name.

d Click, hold, and drag the field UOM from the Source: Application 
Data section and drop it on PO1 03 (Unit or Basis for Measurement 
Code) in the Destination: X12 section. In the Mapping section, 
ORDER-DETAIL appears under Record and UOM appears under 
Field Name.

e Click, hold, and drag the field ITEM-PRICE from the Source: 
Application Data section and drop it on PO1 04 (Unit Price) in the 
Destination: X12 section. In the Mapping section, ORDER-DETAIL 
appears under Record and ITEM-PRICE appears under Field Name.

f Right-click PO1 06 (Product/Service ID Qualifier) to display the 
drop-down menu. From the menu, left-click Full Code List to select 
it. The Full Code List for Element 235 appears on the left section of 
the window.

g Click, hold, and drag the code Value VN (not the code Description 
Vendor’s (Seller’s) Item Number) from the Full Code List for Element 
235 section and drop it on PO1 06 in the Destination: X12 section. In 
the Mapping section at the bottom of the window, STRVAR appears 
under Record and VN appears under Field Name.

h Right-click PO1 07 (Product/Service ID) to display the drop-down 
menu. From the menu, left-click Record/Field to select it. 

i Click, hold, and drag the field ITEM-NO from the Source: 
Application Data section and drop it on PO1 07 in the Destination: 
X12 section.

j Close the PO1 segment by selecting the minus sign next to it.

4 Ignoring unmapped elements

Once you have mapped the necessary fields, ECMap gives you the option 
of ignoring the rest of the unmapped elements. You ignore elements 
because you do not need them for this map or because ECMap 
automatically fills these elements.
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a  From the Segment menu at the top of the Mapping - Application to 
X12 window, select Ignore. From the Ignore submenu, select All. 

b A Confirm dialog box displays, with the following message: “Mark 
all uninitialized elements as IGNORE?” Select YES. In the Mapping 
section, IGNVAR now appears under Record and IGNORE appears 
under Field Name for all previously unmapped elements.

c From the File menu on the Mapping- Application to X12 window, 
select Close to return to the main ECMap window.

❖ Creating the map flow

Map flow is the heart of ECMap, mirroring the relationship between input and 
output and defining the context of data at each point in the mapping cycle. 

Map flow gives you the flexibility you need to adapt any business transaction 
to your application format. 

The map flow defines the relationship between the application data and the 
segments in the X12 transaction set. 

Note  To toggle between checking and unchecking an option, simply select the 
option.

1 Select Map Flow on the toolbar or Workspace. The Outbound Map Flow 
window displays. From the Options menu, select Multiple Files to 
uncheck it. From the File menu, choose Create Flow.

If you have previously created flow for this map, a Confirm dialog box 
displays, asking whether you want to “Delete existing flow and build new 
default flow?” Go to Step 2. (You would have already created the flow, for 
example, if you are repeating these steps.) If this is the first time you have 
created flow for this map, go to Step 4.

2 If you answer NO to the question “Delete existing flow and build new 
default flow?”, the Outbound Map Flow window displays with a diagram 
of the flow you created previously - including rules, next level, and break 
level. Go to Step 5. If you answer YES, the Rule Number Control window 
displays.

3 On the Rule Number Control window, select Delete All Rules under Rule 
Number Delete Option. Select OK. 
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4 A Success dialog box displays, with the message “Flow Creation 
Complete”. Select OK and a diagram of the flow created by ECMap 
displays on the Outbound Map Flow window - with the IO Rule, Before 
Rule, After Rule, Next Level, and Break Level shown in the bottom 
section of the window.

5 From the File menu on the Outbound Map Flow window, choose Close to 
return to the main ECMap window.

Running your map
ECMap’s mapping engine is known for its high speed and ability to handle 
complex mapping requirements.

Running your map involves:

• Generating your map.

• Running your map.

The final steps in the mapping process are to generate and run your map. 
During generation, your map is checked to make sure that everything is set up 
properly. When you run your map, the outbound EDI file or inbound 
application file is actually built.

Generating a map produces a .map file that contains the mapping instructions 
you created. Running a map—with the ECRTP runtime program—interprets 
the .map file and maps the data.

❖ Generating your map

When you generate a map, you compile all your business rules and logic into 
your finished map.

1 Select Generate Map yellow traffic light icon on the toolbar or Workspace. 
The Generate Map window displays.

2 Make sure that the Multiple Files check box is not checked. Multiple Files 
is checked by default. Left-click the check box to uncheck it, or you 
receive a warning – “All Recd Files with Multiple Recs must have Record 
Type Fields”

3 Select Run on the Generate Map window. Messages flash across the text 
box until the following message appears: “Map Generation Completed 
Successfully”.
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4 You can view the results of the map generation process by selecting View 
Log. The Generate Log window displays.

5 Select Exit to return to the main ECMap window.

❖ Running your map

Map files can be distributed and deployed with the run-time engine.

1 Select Run Map (the green traffic light) on the toolbar or Workspace. The 
Run Outbound Map window displays. It has eight tabs – Required, Option 
1, Option 2, File Alias, ODBC Alias, Parameters, I/O Redirect, and Web 
Script. For this exercise, enter information only on the Required tab.

2 In the Output EDI File text box on the Required tab, type c:\Program 
Files\Sybase\ECMap\maps\data\OUT.X12. This is the name of the file 
that the runtime program creates to contain the output EDI data. ECMap 
automatically populates the Map Name, Transaction Name, Map 
Directory, Log Type, and Trading Partner Directory.

3 Select Open.

4 The Log Type contains a default value and is therefore optional.

5 The Non-ODBC Trading Partner check box must contain a check because 
you are not using an ODBC trading partner database.

6 Select Store RunTime Trading Partner Data. 

Note  Do this the first time you run a map or anytime you change trading 
partner information.

7 The runmap dialog box appears, with the message “Store TP 
Successfully!” Select OK.

8 Select Run Map. 

If you have run this map before, you get a runmap dialog box, asking “Do 
you want to delete the existing output EDI file?” If you answer NO, the 
program overwrites the previous output EDI file. If you answer YES, the 
program appends the new output EDI file to the previous output EDI file.
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9 Select View Trace to review the trace log. If the run was successful, the 
outgoing.err-Notepad window displays, with the message “Maprun 
Complete – No Errors Encountered”. If the run was not successful, you 
would use the information in this log to correct your errors and then run 
the map again. You can also select View Translog to display the 
translog.out-Notepad window. Select X in the upper right corner of the 
window to exit either window.

ECMap is designed for local development and testing. The EC Gateway 
product completes the cycle – allowing production to take place on a 
remote platform. 

10 If the run was successful, the View EDI File button is active. Press the 
button to display the output EDI file on the EDI Viewer window. Your 
output should look like the example below - with the exception of the 
italicized numbers, which represent information such as dates that change 
with each maprun. Select Exit to return to the Run Outbound Map window.

11 Select X in the upper right corner of the window to close the Run 
Outbound Map window to return to the main ECMap window.

Sample X12 output ISA*00* *00* *01*033459876 *01*024509876 
*990808*1201*U*00200*000000001*0*P*>
GS*PO*033459876*024509876*19990808*1201*0*X*004010
ST*850*1
BEG*00*SA*PO1133557799-1**19990109
N1*ST**1*027364321
PO1**160*EA*198.00**VN*11410-CP
PO1**8*DZ*157.00**VN*21410-ZD
PO1**32*EA*653.99**VN*31420-CP
PO1**16*EA*193.50**VN*41420-HD
SE*8*1
ST*850*2
BEG*00*SA*PO321335577-1**19990109
N1*ST**1*023364990
PO1**20*EA*79.98**VN*11409-CP
PO1**8*EA*193.50**VN*31420-CP
PO1**3*2D*99.00**VN*21409-ZD
SE*7*2
GE*2*0
IEA*1*000000001
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Adding complex business logic to your map
The exercise you just completed demonstrated how quickly and easily you can 
create and run a map with ECMap. You are now introduced to the features that 
really set this mapping tool apart from the competition. ECMap’s rich array of 
rule commands, flexible cross-reference functionality, conditional logic, and 
simple yet powerful memory variables allow you to imbed complex business 
rules into your maps and seamlessly integrate applications.

For the final portion of this exercise, you use memory variables, rule 
commands, and a cross-reference table to convert information imbedded in a 
description field in your application and include it in the purchase order (X12 
850 Transaction Set) that you are sending to your trading partner. If the item is 
a computer, the description field is used to find the product line code for that 
computer. If the item is not a computer, the accessory product code is used. 

Steps:

1 Select Mapping on the toolbar or Workspace. The Mapping – Application 
to X12 window displays. Notice that there are now levels on the 
Destination: X12 section on the right side of the window. These levels 
were automatically assigned by ECMap when it created the flow.

2 On the Destination: X12 section of the window, double-click the PO1 
segment to display the elements.

❖ Creating memory variables

You can create Memory Variables in more than one way - from the Tools menu 
on the main ECMap window and in several places on the mapping window.

1 Right-click PO1 09 (Product/Service ID) and select Memory Variable 
from the drop-down menu. 

Source: Memory Variables now appears on the left side of the window in 
place of the Source: Application Data.

2 Right-click the Application Directory: Memory Variables under Source: 
Memory Variables, and select New from the drop-down menu. 

The New Memory Variables window displays, with two tabs – Fields and 
Options.

3 In the Memory Variable Name text box on the Fields tab, enter 
Product_Line_Desc. The Memory Variable Description is optional. Select 
the Field Type text box, and begin typing AN-Alpha Numeric or select it 
from the drop-down list. Select the Field Length text box and enter 15. 
Select OK to return to the main mapping window.
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All you need to do is begin typing a valid field type in the text box, and 
ECMap automatically completes it and enter it in the text box.

4 Right-click the Memory Variables application directory and select New 
from the drop-down menu. The New Memory Variables window displays 
again.

5 In the Memory Variable Name text box on the Fields tab, enter 
Product_Line. The Memory Variable Description is optional. Select the 
Field Type text box, and begin typing AN-Alpha Numeric or select it from 
the drop-down list. Select the Field Length text box and enter 13. Select 
OK to return to the main mapping window.

6 Right-click the Memory Variables application directory and select New 
from the drop-down menu. The New Memory Variables window displays 
again.

7 In the Memory Variable Name text box on the Fields tab, enter 
Convert_Success. 

The Memory Variable Description is optional. Select the Field Type text 
box, and begin typing AN-Alpha Numeric or select it from the drop-down 
list. Select the Field Length text box and enter 1. Select OK to return to the 
main mapping window.

❖ Mapping a memory variable

• Drag the memory variable Product_Line from the Source: Memory 
Variables section and drop it on PO1 09 (Product/Service ID) in the 
Destination: X12 section of the window.

❖ Mapping a constant

X12 syntax rules require a qualifier for an ID code.

1 Right-click PO1 08 (Product/Service ID Qualifier) and choose Constant 
from the drop-down menu. The Constant dialog box displays.

2 In the Enter Constant text box, type ZZ. Select OK to exit the Constant 
dialog box and return to the main mapping window. The constant ZZ is 
mapped to PO1 08.

❖ Creating and using rule commands

ECMap enters 1 as the Line Number for the first command in a rule. Each time 
you add a new command, ECMap automatically enters the line number based 
on the option you chose for adding a new command.
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1 From the Element menu on the Mapping– Application to X12 window, 
choose Rule. From the Rule submenu, choose Prior. Rule Definitions 
displays on the left side of the window, with three rules listed. The 0 Do 
Nothing rule is automatically created for every map. ECMap created the 
20 READ ORDER-HEADER rule and the 30 READ ORDER-DETAIL 
when it created the map flow.

2 Right-click the Rules application directory and choose New from the 
drop-down menu. The Rule Definition – New window displays.

3 In the Rule Number text box, enter 40. In the Rule Description text box, 
enter Convert Product Line Code. Select OK to return to the mapping 
window. Rule 40: Convert Product Line Code now appears in the list of 
rules under Rule Definitions.

4 Right-click Rule 40: Convert Product Line Code and choose New 
Command from the drop-down menu. The Rule Command – New window 
displays. ECMap automatically enters the Rule Number and Line Number. 

5 In the Command text box on the Rule Command – New window, begin 
typing the command Substring or choose Substring from the drop down 
list. A Parameters section appears at the bottom of the window, with four 
text boxes. 

All you need to do is begin typing a valid rule in the text box, and ECMap 
automatically completes it and enter it in the text box.

6 Select the Source String up arrow and choose Record/Field from the 
drop-down list. The Records/Tables window displays. Double-click the 
ORDER-DETAIL record to display the fields. Double-click the 
DESCRIPTON field in the ORDER-DETAIL record to enter 
ORDER-DETAIL/ DESCRIPTON in the Source String text box. Choose 
Close from the File menu to close the Records/Tables window.

7 Select the Substring Start up arrow and choose Constant from the 
drop-down list. The Constant Value dialog box displays. In the Enter a 
Constant Value text box, enter 1. Select OK to close the dialog box and 
enter the value in the Substring Start text box.

8 Select the Substring Length up arrow and choose Constant from the 
drop-down list. The Constant Value dialog box displays. In the Enter a 
Constant Value text box, enter 15. Select OK to close the dialog box and 
enter the value in the Substring Length text box and exit from the window.
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9 Select the Destination String up arrow and choose Memory Variable from 
the drop-down list. The Memory Variables window displays. Double-click 
Product_Line_Desc to enter it into the Destination String text box. Choose 
Close from the File menu to close the Memory Variables window. Select 
OK to close the Rule Command – New window and return to the mapping 
window.

❖ Creating and using a cross-reference table

Cross-reference tables can be added as part of a rule using the Table 
Conversion command, or they can be independently created and attached to an 
element.

1 In the Rule Definitions section, right-click Rule 40: Convert Product Line 
Code and choose New Command from the drop-down menu. The Rule 
Command – New window displays.

2 In the Command text box on the Rule Command – New window, begin 
typing the command Table Conversion or choose Table Conversion from 
the drop down list. A Parameters section appears at the bottom of the 
window, with six text boxes. 

3 Select the Conversion Table up arrow and the Cross Reference Tables 
window displays. Choose New from the File menu, and the New Cross 
Reference Table window displays.

4 ECMap automatically enters the Project and Map name. Enter ProdLine - 
the name of the cross reference table - in the File Name text box. (This 
name must be 8-characters or less.) 

As the Standard Field Length, enter 13. As the Application Field Length, 
enter 15. Under Standard Field Number, select No Field Number. In the 
Description text box, enter Converts computer name to product line. Select 
Create.

5 The Cross Reference Table Properties window displays, with ProdLine 
automatically entered as the Table name. Choose New from the File menu. 
The New Cross Reference Entries window displays, with the same Table 
name automatically entered. 

6 On the New Cross Reference Entries window, enter the conversion 
formulas to be used in the cross reference table you are creating. For EDI 
Value, enter PE6300 Series. For Application Value, enter PowerEdge 
6300. For Description, enter PE6300 Series. 
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If you are making multiple entries into the cross reference table, you 
would select Next to apply the current entry and bring up a new window 
to add another entry.

7 Select OK to return to the Cross Reference Table Properties window. 
Choose Close from the File menu to return to the Cross Reference Tables 
window.

8 Double-click ProdLine on the Cross Reference Tables window to enter it 
in the Conversion Table text box. Choose Close from the File menu to 
close the Cross Reference Table window.

9 Select the Source Variable up arrow and choose Memory Variable from the 
drop-down list. The Memory Variables window displays. Double-click 
Product_Line_Desc to enter it in the Source Variable text box. 

10 Select the Destination Variable up arrow and choose Memory Variable 
from the drop-down list. Drag Product_Line from the Memory Variables 
window and drop it in the Destination Variable text box.

You can either double-click the memory variable to enter it in the text box, 
or you can drag and drop it into the text box. ECMap often gives you 
several ways to perform an action so that you can tailor mapping to your 
style.

11 Select the Status Variable up arrow and choose Memory Variable from the 
drop-down list. Either double-click Convert_Success to enter it in the 
Status Variable text box or drag and drop it into the text box. Choose Close 
from the File menu to close the Memory Variables window.

12 Select the On Failure, Return up arrow and choose Constant from the 
drop-down list. The Constant Value dialog box displays. In the Enter a 
Constant Value text box, enter Accessory. Select OK to close the dialog 
box.

13 Select the On Failure, Generate up arrow and choose No Error Message 
from the drop-down list. Select OK on the Rule Command - New window 
to return to the mapping window. Choose Close from the File menu of the 
Mapping- Application to X12 window to return to the main ECMap 
window.

If you are adding multiple commands, select Apply. The current command 
is added to the rule and a blank Rule Command – New window appears.
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❖ Associating the rule with an element

• Drag Rule 40: Convert Product Line Code from the Rule Definition 
window to the Destination: X12 window and drop it on the PO1 09 
(Product/Service ID). It displays beneath as Rule: PRIOR 40.

❖ Regenerating and rerunning the map

Now that you have added additional functionality to your map, all you need to 
do is generate the map again and then run it. 

1 Follow the instructions for Step 3. Run Your Map (starting on page E-47 
of this document).

2 When you have successfully generated and rerun your map, select View 
EDI File. The output now includes the product line codes that we mapped 
using memory variables, rule commands, and a cross reference table. The 
output should look like the sample on the next page.

Revised sample X12 
output 

ISA*00* *00* *01*033459876 *01*024509876 
*990808*1201*U*00200*000000001*0*P*>
GS*PO*033459876*024509876*19990808*1201*0*X*004010
ST*850*1
BEG*00*SA*PO1133557799-1**19990109
N1*ST**1*027364321
PO1**160*EA*198.00**VN*11410-CP**Accessory
PO1**8*DZ*157.00**VN*21410-ZD**Accessory
PO1**32*EA*653.99**VN*31420-CP**PE6300 Series
PO1**16*EA*193.50**VN*41420-HD**Accessory
SE*8*1
ST*850*2
BEG*00*SA*PO321335577-1**19990109
N1*ST**1*023364990PO1**20*EA*79.98**VN*11409-CP**Accessory
PO1**8*EA*193.50**VN*31420-CP** PE6300 Series
PO1**3*2D*99.00**VN*21409-ZD**Accessory
SE*7*2
GE*2*0IEA*1*000000001



Getting Started 59

C H A P T E R  3 Mapping XML Data

About this chapter The tutorial in this chapter walks through the creation of an an XML map 
to convert XML data to an ODBC database.

Contents Topic Page
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Mapping your data 100

Running your map 100

XML-to-ODBC mapping overview 102
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Creating an XML map
During this tutorial of ECMap, create a map that converts XML data to a 
proprietary ODBC database format. Use an any-to-any map to accomplish this 
— importing the source record definitions from XML schema and the 
destination record definitions from the ODBC output data. We use a BizTalk 
XML schema in this example.

For this exercise, you are a company called Toys for Business that sells 
electronic toys to a trading partner called Major Playtime Tools (MPT). MPT 
sends all of its purchase orders as XML data, and you must be able to accept 
purchase orders in this format in order to do business with MPT. 

You can complete this exercise in three easy steps:

1 “Setting up your mapping environment” on page 61

2 “Mapping your data” on page 66

3 “Running your map” on page 100

To use this tutorial, you need to have installed ECMap on your PC. 

You need the following data files, which were supplied with this tutorial:

• c:\Program Files\Sybase\ECMap\maps\data\podata.xml 

• c:\Program Files\Sybase\ECMap\maps\data\poschema.xsd

• c:\Program Files\Sybase\ECMap\maps\data\PO_DATA.mdb 

Throughout this tour, the above path is abbreviated to c:\..\

❖ Starting the tutorial 

1 From the desktop, double-click the ECMap (globe) icon on your desktop. 
(When you install ECMap, the installation process automatically places 
this icon on your desktop.)

2 In the Password text box on the Login window, type ecmap. Press ENTER 
or select OK.

The main ECMap window opens and you are ready to begin the tutorial. 
To perform actions in ECMap, you can use the menu options at the top of 
the window or the icons on the toolbar. (The icons are also available on the 
ECMap Work Space, which can be opened by choosing Workspace from 
the View menu on the main ECMap window.)
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Table 3-1: Menu icons

Hints • On many windows with a drop-down list of available choices, if you begin 
typing your choice, ECMap automatically enters it for you.

• You can use the Tab key to move from text box to text box when entering 
data on a window.

• On windows with a Next option, you can either select Next or press Alt-N.

• We assume you are using C as your hard drive. If not, substitute your hard 
drive letter for C.

Setting up your mapping environment 
Setting up your mapping environment involves:

• Setting up a project.

• Setting up a map.

Project Map Company

Partners Application Directories Files/Databases

Records/Tables Memory Variables Rules

Mapping Map Flow Generate Map

Run Map
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❖ Setting up a project

Less maps required = less time and money spent.

ECMap Project and Map definition allows you to group related information 
together. This forms the baseline for sharing information and logic across 
projects and maps. The design of ECMap is oriented towards minimizing the 
number of maps created - a map can serve multiple trading partner 
relationships. 

The bottom line is that development costs are reduced and maintenance costs 
are lowered as well. 

To set up a project, you must provide a project name and a directory path for 
grouping your maps. Optionally, you may also provide a description of the 
project and the name and telephone number of a contact person. In this tutorial, 
name your project Purchase Orders and place your mapping information in the 
directory c:\..\PurchaseOrders.

1 Select Project on the toolbar at the top of the window. The Projects 
window displays.

2 From the File menu on the Projects window, select New. From the New 
submenu, select Project. The New Project window displays.

3 Type PurchaseOrders in the Project Name text box.

4 Project Description is an optional field.

5 Type c:\..\PurchaseOrders in the Directory text box. You can also Browse 
for the directory on the Select a Directory window if it already exists.

6 Contact is an optional field.

7 Phone Number is an optional field.

8 Select OK to return to the Project – PurchaseOrders window. (Once you 
have created a project, the window label changes to include the name of 
that project.)

❖ Setting up a map

ECMap makes it easy to ensure that your data is Y2K compliant. You simply 
define a specific “windowing” year as your “Century Minimum”. All 6-digit 
dates with years beginning at this year are assumed to be in the current century, 
while all dates with prior years are assumed to be in the next century. ECMap 
automatically converts all 6-digit dates to 8-digit dates for you.

To create an any-to-any map, you assign a name to the map and associate that 
name with attributes, including a list of directories. You must:
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• Define the type of map as ANY2ANY.

• Specify the Y2K windowing year (Century Minimum).

• Specify the directories in which map-related information are stored.

• Set up a DSN (Data Source Name) to point to the database that contains 
log information if you are using an ODBC database.

Optionally, you may also provide a description of the map.

1 Highlight PurchaseOrders on the Project - PurchaseOrders window and 
select New from the File menu. From the New submenu, select Map. The 
New Map Definition window displays. It has three tabs – Map Properties, 
Map Directories, and Map DSN. Follow the steps below to enter the 
required information on each tab before you select OK at the bottom of the 
window.

2 On the map properties tab, under map:

a ECMap automatically populates the Project text box with the name of 
the project – PurchaseOrders.

b In the Map text box, type MPT.

c When you start typing, ECMap enters the entry automatically for you. 
From the Map Type drop-down list, select ANY2ANY. (The bottom 
part of the window changes after you make this selection.)

3 On the map properties tab, under options:

a In the Century Minimum text box, type 50. (This is arbitrary and can 
be any number from 1 to 99.)

b Description is an optional field.

4 On the map directories tab:
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Projects and maps can be stored in the directory structure of your choice. 
This allows for extreme flexibility for both map development and map 
management in the operations environment.

Note  To change multiple directories at one time, set the protection status 
of each directory you want to change to Change and set all others to 
Protect. Select Change All to browse for a new directory. All the 
unprotected directories are changed to the directory you select.

Since you are allowed to browse for unprotected directories only, the 
Invert button is a handy feature that allows you to temporarily change a 
protected directory to unprotected, browse for and select a new directory, 
and then change the status back to protected by selecting the Invert button 
again. 

Select the Map Directories tab to make it active. ECMap automatically 
populates the text boxes of all the directories, in the format c:\<project 
directory path>\<map name>. The directory entries for this example 
appear as follows:

c:\..\PurchaseOrders\MPT

For this example, use these default directories. However, ECMap gives 
you the option to change the default entries, and it makes changing them a 
very easy process. You can use the Change All button in combination with 
the Change/Protect buttons to change multiple unprotected directories at 
once, or you can manually change the directories one at a time. The 
protection status does not affect manual changes.

5 On the map DSN tab:

Select the Map DSN tab to make it active. For any-to-any maps, you enter 
information on this tab only if you are using ODBC log databases. Since 
you are using an ODBC log database in this tutorial, you must configure 
the DSN that points to the ODBC log database. (For convenience, 
configure the DSN for the ODBC database containing the output of the 
map at the same time. You could perform this step later.)

6 Configure the DSN for the proprietary inventory and billing database:

a On the System DSN tab, choose Add again. 

b Create a DSN for your Inventory and Billing ODBC application 
database. The Create New Data Source window displays.

c Highlight Microsoft Access Driver (*.mdb) and select Finish. The 
ODBC Microsoft Access Setup window displays.
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d Enter BILLING in the Data Source Name text box. Select “Select” 
under Database in the center section of the window, and the Select 
Database window displays. (The Description is optional.)

e Navigate down into c:\..\data on the right side of the window. On the 
left side of the window under Database Name, double-click 
PO_DATA.mdb. You return to the ODBC Microsoft Access Setup 
window, and the path you selected displays in the Database section: 
c:\..\DATA\PO_DATA.mdb. Select OK and you return to the ODBC 
Data Source Administrator window. Select OK to close that window 
and return to the New Map Definition window.

f The program automatically constructs the DSN for the Inventory and 
Billing database, but it does not display on the Map DSN tab of the 
New Map Definition window. 

g On the New Map Definition window, select the up arrow for Data 
Source Name. Highlight Log and double-click on the Log.

h Select OK on the New Map Definition window, and you receive the 
following message, The Log Table Does Not Exist in This Data 
Source: “DSN=LOG” Do You Want To Create The Table? Select Yes, 
and you return to the Map-Purchase Orders MPT window. (Once you 
have defined a new map, the window label changes to include the 
name of that map.)

7 Configuring the DSN for the ODBC log database

a In the Log section, enter LOG in the Data Source Name text box and 
select Configure Data Source. The program automatically constructs 
and enters the DSN for the log database (DSN=LOG) and enters it in 
the Log Driver Connect String May be Altered text box. The ODBC 
Data Source Administrator window displays.

b Select the System DSN tab of the ODBC Data Source Administrator 
window to make it active. Choose Add on the right side of the window 
to create a new DSN for the log database. The Create New Data 
Source window displays.

c In the list of drivers, highlight Microsoft Access Driver (*.mdb) and 
select Finish at the bottom of the window. The ODBC Microsoft 
Access Setup window displays.

d Enter LOG in the Data Source Name text box. The Description is 
optional. Select Create in the Database section in the middle of the 
window, and the New Database window displays.
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e Under Directories in the center section of the New Database window, 
navigate down into c:\..\data. In the Database Name text box on the 
top left side of the window, enter xml_log.mdb and select OK. You 
receive the message Database c:MAPS\DATA\xml_log.mdb was 
successfully created. Select OK and you return to the ODBC 
Microsoft Access Setup window. Select OK and you return to the 
ODBC Data Source Administrator window. You have successfully set 
up the DSN that points to the log database.

Note  If you have previously created the log database, you receive an 
Error message - The datasource named 'LOG' already exists. Replace 
it with this definition? Select Yes.

8 Making your new map the current active map

Each time you start ECMap, it “remembers” the last map you used and 
automatically opens it for you.

To make the project and map “current”, double-click MPT (the map you 
just defined on the New Maps Definition window). You return to the main 
ECMap window and the “current” map information displays in the status 
bar at the bottom of the window:

 Project: PurchaseOrders Map: MPT

Mapping your data
Mapping your data involves:

• Importing the definition of the source data – the BizTalk XML schema.

• Importing the definition of the destination data – the table definition of the 
ODBC database used by your proprietary inventory and billing 
application.

• Mapping the XML schema to the ODBC database table format.

• Creating the map flow.

A sample of the XML purchase order data that you receive is shown below. 
You import the record definition using the BizTalk schema associated with this 
data. For your reference, a copy of the schema is included at the end of this 
document in “XML PO SCHEMA (BizTalk 0.8)” on page 104.
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<?xml version="1.0" ?> 
<BizTalk xmlns="urn:schemas-biztalk-org:biztalk/biztalk-0.81.xml">

<Route> 
<From locationID="http://www.MPT.com" locationType="HTTP" 
process="http://MPT.com/biztalk" path="" handle="45" /> 

<To locationID="http://www.ToysForBusinesses.com/biztalk/recv.asp" 
locationType="HTTP" process="" 
path="http://ToysForBusinesses.com/biztalk/recv.asp" handle="45" /> 

</Route> 
<Body> 
<PO xmlns="urn:schemas-biztalk.org:fabrikam/orders.xml"> 
<POHeader refPromise="0" fromCust="Major Playtime Tools" poNumber="12345" 
description="Sample PO" paymentType="INVOICE" shipType="AIR1D" /> 
<Contact contactName="Billy Badger" contactPhone="(425) 123-1234" 
contactEmail="bbadger@MPT.com" /> 

<POShipTo street1="8230 Old Courthouse Road" street2="Suite 100" 
street3="" street4="" attn="Susie Sandella" city="Vienna" 
stateProvince="VA" postalCode="22182" country="USA" /> 

<POBillTo street1="8230 Old Courthouse Road" street2="Suite 300" 
street3="" street4="" attn="Billy Badger" city="Vienna" 
stateProvince="VA" postalCode="22182" country="USA" /> 

<POLines count="2" startAt="1"> 
<Item line="1" partNo="VoiceActivatedKeyboard" qty="1" 
unitPrice="3000" uom="Unit" discount="0.0" needAfter="2000-07-31" 
needBefore="2000-05-29" /> 

<Item line="2" partNo="VirtualVacationPackage" qty="5" unitPrice="4500" 
uom="Unit" discount="0" needAfter="2000-07-31" needBefore="2000-05-29" /> 

</POLines> 
</PO> 

</Body> 
</BizTalk>

❖ Defining the source data – importing a record definition from BizTalk 
XML schema 

In this example, you import the record definition for the source data from a 
BizTalk XML schema.

1

2 From the Application Files menu at the top of the main ECMap window, 
select Import Definition. 

Select XML from the Import Definition submenu, and then select Schema 
from the XML submenu. 
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The XML Schema Import window displays. It has three tabs - Schema 
Import, XML Elements, and XML Attributes.

3 On the Schema Import tab, select the button on the far right of the window 
at the end of the File to load text box. 

The Open window displays. At the bottom of the window, choose Any 
files from the Files of type drop-down list. 

On the Open window, locate c:\..\data\poschema.xsd and double-click it. 

You return to the XML Schema Import window, and the program 
automatically populates the File to load text box with the full-path file 
name - C:\..\data\poschema.xsd.

4 Select Create Records and the program automatically creates record 
definitions from the XML schema. 

The unexpanded XML schema tree displays on the left side of the Schema 
Import tab - three lines display initially, with one unexpanded XML 
element called Schema. The associated SAX events display on the right 
side of the tab. 

5 The globe symbol indicates an XML element, and the cloud symbol 
indicates an XML attribute. If you navigate down into the XML schema 
tree, you reveal the elements and attributes. You can also view elements 
on the XML Elements tab and attributes on the XML Attributes tab.

6 Close the XML Schema Import window to return to the main ECMap 
window.

7 Designating XML Records as Source

a On the ECMap window, select Records/Tables on the toolbar at the 
top of the main ECMap window. 

The Records/Tables window displays. (Initially, only the elements 
display. However, if you navigate down through the XML element 
“records”, the XML attribute “fields” display.)

XML elements are indicated by Records/Tables and are equivalent to 
ECMap “records”. XML attributes are indicated by Records/Tables 
and are equivalent to ECMap “fields”.

b Right-click on the BizTalk XML “record” element (listed in bold 
below) and choose Record Properties from the drop-down menu. 
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The Record Properties window displays. It has two tabs - Required 
and Optional. For each of the XML elements listed below, select the 
Optional tab to make it active and then choose Source as the Record 
Type from the drop-down list. Select Next. Do this for each of the 
three tables. Select OK to return to the Records/Tables window.

Note  If you select the Record Type text box and type S, and the 
program automatically enters Source for you in the Record Type text 
box.

c When you have designated all of the elements as Source, close the 
Records/Tables window to return to the main ECMap window.

The record definitions extracted from the XML schema are shown 
below. Bold XML elements are equivalent to records. XML attributes 
nested beneath the elements are equivalent to fields.

BizTalk

• BizTalk_data

• xmlns

Body

•  Body_data

Contact

• Contact_data

• contactPhone

• contactEmail 

• contactName

From

• From_data

• LocationType

• locationID

• handle 

• process

• path

Item
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• Item_data

• Qty

• NeedBefore

• discount

• unitPrice

• needAfter

• line

• uom

• partNo

PO

•  PO_data

•  xmlns

POBillTo

• POBillTo_data

• Street4

• Street3

• Street2

• Street1

• stateProvince 

• city

• country

• attn

• postalCode

POHeader

• POHeader_data

• RefPromise

• description

• fromCust
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• paymentType

• shipType

• poNumber

POLines

• POLines_data

• count

• startAt

POShipTo

• POShipTo_data

• Street4

• Street3

• Street2

• Street1

• stateProvince 

• city

• country

• attn

•  postalCode

Route

•  Route_data

To

• To_data

• LocationType

• locationID

• handle 

• process

•  path

8 Creating the path to the input XML data file
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You have defined the XML data to be used as input to the map so that 
ECMap knows how to read it. Now you must tell ECMap where to find the 
XML data. You do this by defining the path to the file in which the XML 
input data is stored.

a Select Application Directories on the main ECMap window and the 
Directories (Mailboxes) window displays. 

Choose New from the File menu on the Directories (Mailboxes) 
window, and the New Directory window displays.

Note  Instead of choosing New from the File menu, you can select 
New in the row of icons beneath the menu items.

b Select Browse and the Select a Directory... window displays. 

Navigate down to c:\..\data and select OK. You return to the New 
Directory window and ECMap enters c:\..\data into the Directory text 
box. 

c Select c:\..\data on the Directories(Mailboxes) window to highlight 
the directory, and choose Open from the Application Files menu at the 
top of the Directories(Mailboxes) window. 

The Files/ Databases window displays to the right of the Directories 
(Mailboxes) window. Choose New from the File menu on the 
Files/Databases window, and the New File window displays.

The directory appears to be highlighted and active when you return to 
the window, but it is not. Four icons appear under the menu options at 
the top of the window when a directory is active.

d On the New File window, select Browse to search for the File Name. 
The Choose Application File window displays. In the path c:\..\data, 
locate the file podata.xml and double-click it.

e You return to the New File window and ECMap automatically enters 
podata.xml as the File Name. For File Type, choose HTML/XML 
from the drop-down list. File Description and Decimal Indicator are 
optional. Select OK to return to the Files/Databases window.

If you start typing, ECMap enters the File Type for you automatically.

f Select podata.xml on the Files/Databases window to highlight the file, 
and choose Open from the Record menu. The Records/Tables window 
displays to the right of the Files/Databases window.
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The file appears to be highlighted and active when you return to the 
window, but it is not. Four icons appear under the menu options at the 
top of the window when a file is active.

9 Linking the directory, file, and records

a Drag podata.xml from the Files/Databases window and drop it on 
c:\..\data on the Directories (Mailboxes) window. It displays beneath 
the folder C:\..\data.

b Select the Records/Tables window to make it active. From the View 
menu on the Records/Tables window, choose Record List. The 
Record Listing window displays. On this window, left-click the first 
record, press the Shift key, and left-click the last record - continuing 
to keep the left mouse button depressed. Without lifting your finger 
from the left mouse, drag all of the highlighted records (which display 
as one file being dragged) and drop them onto the file podata.xml on 
the Files/Databases window. All of the records now display beneath 
the file podata.xml.

Note  Make sure that the element displays under the file after you 
have dropped it.

c By linking the records to the file, and the file to the directory, you have 
created the path for the input XML data file so that ECMap knows 
where to find the XML data that is the input to the map – 
c:\..\data\podata.xml. Close the four open windows – Record Listing, 
Records/Tables, Files/Databases, and Directories (Mailboxes).

❖ Defining the destination data – importing ODBC database table 
definitions

1 Next, you import the three table definitions (listed below) from the 
PO_DATA ODBC database used by your proprietary Inventory and 
Billing application. 

PO_Information
PoNumber
PO_xmls
refPromise
fromCust
description
paymentType
shipType
contactName
contactPhone
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contactEmail
Shipto_street1
Shipto_street2
Shipto_street3
Shipto_street4
Shipto_attn
Shipto_city

Shipto_stateProvince
Shipto_postalCode
Shipto_country
Billto_street1
Billto_street2
Billto_street3
Billto_street4
Billto_attn
Billto_cityBillto_stateProvince
Billto_postalCode
Billto_country

PO_LineItems
poNumber
partNo
qty
unitPrice
uom
discount
needAfter
needBefore

PO_Routing
poNumber 
To_From
locationID
locationType 
process 
path
handle
 

2 Importing the record definition

a From the Application Files menu at the top of the main ECMap 
window, select Import Definition.
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Then select ODBC from the Import Definition submenu. The ODBC 
Record Definition Import window displays. ECMap automatically 
populates the Project and Map names.

b Select the up arrow next to the Data Source Name in the center section 
of the ODBC Record Definition Import window. The Data Source 
Names window displays, with a list of all current DSNs. 

c Double-click BILLING (the DSN you set up earlier that points to the 
PO_DATA database) on the Data Source Names window. 

You return to the ODBC Record Definition Import window, and the 
program populates the Data Source Name text box with BILLING 
and the Driver Connect String text box with DSN=BILLING. Select 
Continue at the bottom of the window. The Table Selection window 
displays. 

d  All of the database tables associated with this map display in the 
bottom section of the window (together with a number of system 
tables that all start with “MS”). Scroll down through the tables and 
select the check boxes of the following tables in your PO_DATA 
database. 

PO_Information

PO_LineItems

PO_Routing

e In ECMap, tables are the equivalent of records. Select OK at the 
bottom of the window, and the program extracts the table (“record”) 
definitions. 

A Complete dialog box displays with the message “Record 
Definitions Imported”. Select OK to close the dialog box.

3 Designating the ODBC records as destination

a Select Records/Tables on the toolbar at the top of the main ECMap 
window, and the Records/Tables window displays. The ODBC tables 
(“records”) you imported display on the window. They are included 
alphabetically in the list of XML schema elements (“records”) that 
you imported earlier.



Mapping your data 

76  ECMap

b Right-click on one of the tables listed in Step 4 and choose Record 
Properties from the drop-down menu. The Records/ Tables window 
displays. It has two tabs - Required and Optional. Select the Optional 
tab and choose Destination as the Record Type. Select Next. Do this 
for each of the three tables. Select OK to return to the Records/Tables 
window. 

If you select the Record Type text box and type D, and the program 
enters Destination for you in the Record Type text box automatically.

c Close the Records/Tables window to return to the main ECMap 
window.

4 Creating the connection to the inventory and billing database

You have defined the ODBC tables to which the map writes the output 
data. Now you must tell ECMap where to find the database that contains 
these tables. You do this by linking the three tables with the database.

a Select Files/Databases on the main ECMap window, and the 
Files/Databases window displays. Choose New from the File menu, 
and the New File window displays.

b On the New File window, select Browse to search for the File Name. 
The Choose Application File window displays. In the path c:\..\data, 
locate the database PO_DATA.mdb and double-click it.

c You return to the New File window and PO_DATA.mdb is entered as 
the File Name. For the File Type, choose SQL DATABASE from the 
drop-down list. The appearance of the window changes. 

d Select the up arrow next to the Data Source Name text box, and the 
Data Source Names window displays. 

Double-click BILLING and you return to the New File window.

 The program populates the Data Source Name text box with 
BILLING and constructs the driver connect string, DSN=BILLING, 
which it uses to populate the Driver Connect String (May Be Altered) 
text box. Select OK to close the New File window. PO_DATA.mdb 
now displays as one of the files.

To make sure that the DSN is configured properly, select the Test SQL 
Connection button. The message Connection Established indicates 
that the setup is correct.

e Select PO_DATA.mdb on the Files/Databases window to highlight it. 
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Choose Open from the Record menu, and the Records/Tables window 
displays to the right of the Files/Databases window. 

The file appears to be highlighted and active when you return to the 
Files/Databases window, but it is not. You can tell when a file is active 
because Four icons appear under the menu options at the top of the 
window.

f The records associated with this map display on the Records/ Tables 
window, including the three tables in the Inventory and Billing 
database.

PO_Information

PO_LineItems

PO_Routing

g One at a time, drag each of the three tables listed above from the 
Records/Tables window and drop it on PO_DATA.mdb on the 
Files/Databases window. The tables should now display beneath 
database PO_DATA.mdb.

Make sure that each element displays under PO_DATA.mdb after you 
have dropped it.

h You have now linked the tables to the Inventory and Billing database. 
Close the Files/Databases window and the Records/Tables window.

❖ Creating the map flow

The map flow defines the relationship between the source data and the 
destination data. It is driven by rules and levels that you create and assign. In 
this example, XML elements are mapped to ODBC records. You have already 
defined the source and destination data and told the program where the input 
and output data are located. Now you set up levels and rules, and use them to 
create flow.

1 Select Map Flow on the toolbar at the top of the window. The Any-to-Any 
Map Flow window displays. From the Option menu at the top of the 
window, make sure that Multiple Files is unchecked. (If it is checked, 
select it and ECMap unchecks it. You can view it again to make sure that 
it is unchecked.)

Note  To toggle between checking and unchecking an option, simply select 
on the option.

2 Planning and creating levels: 
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Create levels based on the structure of the XML data you are reading and 
the ODBC output you are writing. In this example, you are reading the 
BizTalk XML schema included at the end of this document.

100 BizTalk Level
200 Route Level

300 From Level
310 To Level

400 Body Level
500 PO Level 

600 PO Header Level
610 Contact Level
620 Ship To Level
630 Bill To Level
800 PO Lines Level

900 Item Level

On the Levels window, create the levels that are used in defining map flow. 
Assign a number to each level. While these numbers are arbitrary, they 
generally reflect the hierarchy of the data.

Always have a master level, and it must always be the first level.

a Choose Levels from the View menu at the top of the Any-to-Any Map 
Flow window. 

The Levels window displays.

b On the Levels window, choose New from the File menu, and the New 
Level window displays. 

Create a new level for each of the levels listed above, by entering the 
level number in the first text box and the level description in the 
second text box. 
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As you define a new level, it displays on the Levels window. (If you 
move the New Level window so that it is not directly over the Levels 
window, you can see the levels display on the Levels window as you 
create them.) Begin by entering 100 in the first text box of the New 
Level window and BizTalk Level in the second text box. Select Next 
and add the next level - 200 Route Level. When you have finished 
adding all of the levels, select OK to close the New Level window. 
Close the Levels window to return to the Any-to-Any Map Flow 
window. 

Note  Select Tab to move from the first text box to the second text box. 
When you finish defining one level and want to define another, select 
Next on the window or press Alt-N.

3 Planning and creating rules

a On the Any-to-Any Map Flow window, choose Rules from the View 
menu. The Rule Definitions window displays. On this window, you 
create the rules that are used in defining map flow. In the current 
mapping example, you read each XML element in a separate rule 
command. As you read elements that contain data to be mapped, you 
perform the mapping in additional “assignment” rule commands. 
Finally, you write the output in other rule commands. Rule numbers 
are arbitrary and generally reflect the sequence of events. You create 
the rules based on the elements that must be read, the data that must 
be mapped, and the output that must be created, as shown below:

Do Nothing

100 Read <BizTalk>

200 Read <Route>
300 Read <From>
305 Map <From> 
308 Write PO_Routing
310 Read <To>
315 Map <To>
318 Write PO_Routing

400 Read <Body>

500 Read <PO> 
505 Map <PO>
 600 Read <POHeader>
 605 Map <POHeader>
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 610 Read <Contact>
 615 Map <Contact>
 620 Read <POShipTo>
 625 Map <POShipTo>
 630 Read <POBillTo>
 635 Map <POBillTo>

 700 Write <PO_Information> 

 800 Read <POLines>
 900 Read<Item>
 905 Map <Item> 

 1000 Write <POLines>

b For each rule command shown above, do the following:

At this point, you are simply creating the rules. Later, you add the 
actual rule commands that do the reading, writing, and mapping.

• On the Rule Definitions window, select New at the top of the 
window or choose New Rule from the File menu. The Rule 
Definition - New window displays. 

• On the Rule Definition - New window, enter the Rule Number 
and the Rule Description. (The Do Nothing already exists.) 

• Select OK on the window or press Enter.

As you enter a rule, it displays on the Rule Definitions window. 
Begin by entering 100 in the Rule Number text box and Read 
<BizTalk> in the Rule Description text box. Continue adding 
rules until you have finished with 1000 Write <POLines>. When 
all of the rules have been entered, close the Rule Definitions 
window.

4 Creating and defining the map flow table
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Now that you have planned and set up levels and rules, you are ready to 
create map flow, by associating levels, records, and rules with each flow 
point. Choose New from the File menu on the Any-to-Any Map Flow 
window, and then choose Add Master Level from the New submenu. The 
Any-to-Any Record Flow window displays next to the Any-to-Any Map 
Flow window. It has two tabs – Required and Advanced. The Required tab 
is active initially and has four sections – Levels, Record Type, Records, 
and Rules. Beginning with the information for level 100 (shown beginning 
on the next page) and ending with level 1000, follow the three steps 
outlined below to enter the flow information for each flow point on the 
Required tab of the Any-to-Any Record Flow window. (Enter only 
information shown in bold. ECMap automatically enters the other 
information on the Required tab for you. The program also automatically 
enters correct information on the Advanced tab, but not until after you 
have added the following level.)

a Under Levels, select the up arrow next to the Current text box, and the 
Levels window displays. Double-click a level and the program enters 
it automatically in the Current level text box.

b Under Records, select the up arrow next to the Current text box, and 
the Records/ Tables window displays. Double-click a record and the 
program enters it automatically in the Current record text box.

c Under Record Type, the program has already checked the correct type 
- based on the attributes in the schema that you imported. The only 
instance where you change this is for repeating elements/records. 
While it is Mandatory to have a detail record, it is optional to have 
multiple records. In this case, you must change Mandatory to 
Optional (No Msg) and check Repeating.

d Under Rules, select the up arrow next to the I/O text box, and the Rule 
Definitions window displays. Double-click a rule and the program 
enters it automatically in the I/O rule text box. Double-click another 
rule and the program enters it automatically in the Before rule text 
box. Double-click another rule and the program enters it 
automatically in the After rule text box. (If you need only an I/O rule 
or only I/O and Before rules, select OK to close the Rule Definitions 
window after you have added the last rule, rather than double-clicking 
to add another rule.)

After all the information for a flow point has been entered, select OK to 
add another flow point.
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At the bottom of the Any-to-Any Map Flow window, the following 
information displays for the currently highlighted flow point:

• Current Level

• I/O Rule

• Before Rule

•  After Rule

• Next Level

• Break Level

5 Associating levels, records, and rules with flow points:

a The Any-to-Any Record Flow window is open, ready for you to add 
the master level. 

Note  If the Any-to-Any Record Flow window is not open, choose 
New from the File menu on the Any-to-Any Map Flow window, and 
then choose Add Master Level from the New submenu. The 
Any-to-Any Record Flow window displays.

Following the four steps in the instructions under Creating and 
Defining the Map Flow Table, enter on the Required tab of the 
Any-to-Any Record Flow window the information shown below in 
bold.

Current Level 100
Parent Level N/A
Record Type N/A
Current Record BizTalk
Parent Record N/A
I/O Rule 100
Before Rule 0
After Rule 0

Select OK to create this flow point and close the Any-to-Any Record 
Flow window. After you create the next flow point, the program 
enters the following information on the Advanced tab for this flow 
point:

Next Level 200
Break Level 100
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b Right-click level 100 on the Any-to-Any Map Flow window. Choose 
New from the drop-down menu and Add Child Level from the New 
submenu. 

Note  When the XML schema is imported, the program stores 
information about the element, such as whether it is mandatory or 
optional.

On the Required tab of the Any-to-Any Record Flow window, enter 
the information shown below in bold:

Current Level 200
Parent Level 100
Record Type Mandatory
Current Record Route
Parent Record BizTalk
I/O Rule 200
Before Rule 0
After Rule 0

Select OK to create this flow point and close the Any-to-Any Record 
Flow window. After you create the next flow point, the program 
enters the following information on the Advanced tab for this flow 
point:

Next Level 300
Break Level 100

c Right-click level 200 on the Any-to-Any Map Flow window. Choose 
New from the drop-down menu and Add Child Level from the New 
submenu. On the Required tab of the Any-to-Any Record Flow 
window, enter the information shown below in bold:

Current Level 300
Parent Level 200
Record Type Mandatory
Current Record From
Parent Record Route
I/O Rule 300
Before Rule 305
After Rule 308
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Select OK to create this flow point and close the Any-to-Any Record 
Flow window. After you create the next flow point, the program 
enters the following information on the Advanced tab for this flow 
point:

Next Level 310
Break Level 100

d Right-click level 300 on the Any-to-Any Map Flow window. Choose 
New from the drop-down menu and Add Sibling Level from the New 
submenu. On the Required tab of the Any-to-Any Record Flow 
window, enter the information shown below in bold:

Current Level 310
Parent Level 200
Record Type Mandatory
Current Record To
Parent Record Route
I/O Rule 310
Before Rule 315
After Rule 318

Select OK to create this flow point and close the Any-to-Any Record 
Flow window. After you create the next flow point, the program 
enters the following information on the Advanced tab for this flow 
point:

Next Level 400
Break Level 100

e Right-click level 100 on the Any-to-Any Map Flow window. Choose 
New from the drop-down menu and Add Child Level from the New 
submenu. On the Required tab of the Any-to-Any Record Flow 
window, enter the information shown below in bold:

Note  You must right-click level 100. You are creating a new child 
level of the master level.

Current Level 400
Parent Level 100
Record Type Mandatory
Current Record Body
Parent Record BizTalk
I/O Rule 400
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Before Rule 0
After Rule 0

Select OK to create this flow point and close the Any-to-Any Record 
Flow window. After you create the next flow point, the program 
enters the following information on the Advanced tab for this flow 
point:

Next Level 500
Break Level 100

f Right-click level 400 on the Any-to-Any Map Flow window. Choose 
New from the drop-down menu and Add Child Level from the New 
submenu. On the Required tab of the Any-to-Any Record Flow 
window, enter the information shown below in bold:

Current Level 500
Parent Level 400
Record Type Mandatory
Current Record PO
Parent Record Body
I/O Rule 500
Before Rule 505
After Rule 0

Select OK to create this flow point and close the Any-to-Any Record 
Flow window. After you create the next flow point, the program 
enters the following information on the Advanced tab for this flow 
point:

Next Level 600
Break Level 100

g Right-click level 500 on the Any-to-Any Map Flow window. Choose 
New from the drop-down menu and Add Child Level from the New 
submenu. On the Required tab of the Any-to-Any Record Flow 
window, enter the information shown below in bold:

Current Level 600
Parent Level 500
Record Type Mandatory
Current Record POHeader
Parent Record PO
I/O Rule 600
Before Rule 605
After Rule 0
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Select OK to create the flow point and close the Any-to-Any Record 
Flow window. At this point, the program automatically enters the 
following information on the Advanced tab:

Next Level 610
Break Level 100

h Right-click level 600 on the Any-to-Any Map Flow window. Choose 
New from the drop-down menu and Add Sibling Level from the New 
submenu. On the Required tab of the Any-to-Any Record Flow 
window, enter the information shown below in bold:

Current Level 610
Parent Level 500
Record Types Mandatory
Current Record Contact
Parent Record PO
I/O Rule 610
Before Rule 615
After Rule 0

Select OK to create the flow point and close the Any-to-Any Record 
Flow window. At this point, the program automatically enters the 
following information on the Advanced tab:

Next Level 620
Break Level 100

i Right-click level 610 on the Any-to-Any Map Flow window. Choose 
New from the drop-down menu and Add Sibling Level from the New 
submenu. On the Required tab of the Any-to-Any Record Flow 
window, enter the information shown below in bold:

Current Level 620
Parent Level 500
Record Type Mandatory
Current Record POShipTo
Parent Record PO
I/O Rule 620
Before Rule 625
After Rule 0
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Select OK to create the flow point and close the Any-to-Any Record 
Flow window. At this point, the program automatically enters the 
following information on the Advanced tab:

Next Level 630
Break Level 100

j Right-click level 620 on the Any-to-Any Map Flow window. Choose 
New from the drop-down menu and Add Sibling Level from the New 
submenu. On the Required tab of the Any-to-Any Record Flow 
window, enter the information shown below in bold:

Current Level 630
Parent Level 500
Record Type Mandatory
Current Record POBillTo
Parent Record PO
I/O Rule 630
Before Rule 635
After Rule 700

Select OK to create the flow point and close the Any-to-Any Record 
Flow window. At this point, the program automatically enters the 
following information on the Advanced tab:

Next Level 800
Break Level 100

k Right-click level 630 on the Any-to-Any Map Flow window. Choose 
New from the drop-down menu and Add Sibling Level from the New 
submenu. On the Required tab of the Any-to-Any Record Flow 
window, enter the information shown below in bold:

Current Level 800
Parent Level 500
Record Type Mandatory
Current Record POLines
Parent Record PO
I/O Rule 800
Before Rule 0
After Rule 0
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Select OK to create the flow point and close the Any-to-Any Record 
Flow window. At this point, the program automatically enters the 
following information on the Advanced tab:

Next Level 900
Break Level 100

l Right-click level 800 on the Any-to-Any Map Flow window. Choose 
New from the drop-down menu and Add Child Level from the New 
submenu. On the Required tab of the Any-to-Any Record Flow 
window, enter the information shown below in bold:

Note  For level 900, be sure to change the Record Type from 
Mandatory to Optional and to check the Repeating check box. This is 
the only level for which you change the Record Type. Right-click 
level 620 on the Any-to-Any Map Flow window. Choose New from 
the drop-down menu and Add Sibling Level from the New submenu. 
On the Required tab of the Any-to-Any Record Flow window, enter 
the information shown below in bold:

Current Level 900
Parent Level 800
Record Type Optional (No Msg)

Repeating
Current Record Item
Parent Record POLines
I/O Rule 900
Before Rule 905
After Rule 1000

Select OK to create the flow point and close the Any-to-Any Record 
Flow window. At this point, the program automatically enters the 
following information on the Advanced tab:

Next Level 900
Break Level 100

When you have finished building the map flow, the Any-to-Any Map Flow 
window should look like the representation shown below:

For each flow point, or entry in the flow table, the level number and 
description display on the main window. As you select each flow point, the 
associated levels and rules display in a separate section at the bottom of 
the window.
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Close the Any-to-Any Map Flow window and any other windows that 
remain open, such as Levels, Records/Tables, or Rule Definitions.

6 Reading the XML data and writing to the ODBC database

The last step that you perform before doing the actual mapping is to enter 
the rule commands to read the XML data and write the ODBC data. For 
this tutorial, the XML source data is located in c:\..\data\podata.xml, and 
the destination data is stored in PO_DATA.mdb (in the Inventory and 
Billing database pointed to by the DSN BILLING).

• Select Rules on the toolbar at the top of the window, and the Rule 
Definitions window displays. The rules that you added earlier display 
on the window. 

❖ Adding the commands to read the XML data

1 Right-click rule 100 and choose New Command from the drop-down 
menu. The Rule Command - New window displays. Select XML I/O from 
the drop-down list for the Command text box and additional text boxes 
appear at the bottom of the window. 

Note  If you begin typing X.. in the Command text box, ECMap 
automatically enters it for you.

Apply is used to save a command and enter a new command. OK is used 
to save a command and exit the New Command window.

a Select the I/O Command up arrow and choose Read XML from the 
drop-down menu. 

b Select the Application Directory up arrow and the Directories 
(Mailboxes) window displays. Navigate down through 
c:\..\data\podata.xml and double-click BizTalk. 

c The program automatically populates the Application Directory, 
Application File, and File Record text boxes.

Select OK on the Rule Command-New window to add the command 
and close both the Directories(Mailboxes) and the Rule 
Command-New windows. The new command displays under rule 
100.

2 Right-click rule 200 and repeat the actions you performed in Step 2. 

a Choose New Command from the drop-down menu. 
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b Enter XML I/O as the Command and Read XML as the I/O Command 
on the Rule Command–New window. 

c Navigate down into c:\..\data\podata.xml and double-click Route. 
The program automatically populates the Application Directory, 
Application File, and File Record text boxes. 

d Select OK to close the Directories(Mailboxes) window and the Rule 
Command-New window.

3 Right-click rule 300 and repeat the actions you performed in Step 2. 

a Choose New Command from the drop-down menu. 

b Enter XML I/O as the Command and Read XML as the I/O Command 
on the Rule Command–New window. 

c Navigate down into c:\..\data\podata.xml and double-click From. The 
program automatically populates the Application Directory, 
Application File, and File Record text boxes. 

d Select OK to close both the Directories(Mailboxes) and the Rule 
Command-New windows.

4 Right-click rule 310 and repeat the actions you performed in Step 2. 

a Choose New Command from the drop-down menu. 

b Enter XML I/O as the Command and Read XML as the I/O Command 
on the Rule Command–New window. 

c Navigate down into c:\..\data\podata.xml and double-click To. The 
program automatically populates the Application Directory, 
Application File, and File Record text boxes. 

d Select OK to close both the Directories (Mailboxes) and the Rule 
Command-New windows.

5 Right-click rule 400 and repeat the actions you performed in Step 2. 

a Choose New Command from the drop-down menu. 

b Enter XML I/O as the Command and Read XML as the I/O Command 
on the Rule Command–New window. 

c Navigate down into c:\..\data\podata.xml and double-click Body. The 
program automatically populates the Application Directory, 
Application File, and File Record text boxes.

d  Select OK to close both the Directories (Mailboxes) and the Rule 
Command-New windows.
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6 Right-click rule 500 and repeat the actions you performed in Step 2. 

a Choose New Command from the drop-down menu. 

b Enter XML I/O as the Command and Read XML as the I/O Command 
on the Rule Command–New window. 

c Navigate down into c:\..\data\podata.xml and double-click PO. The 
program automatically populates the Application Directory, 
Application File, and File Record text boxes. 

d Select OK to close both the Directories (Mailboxes) and the Rule 
Command-New windows.

7 Right-click rule 600 and repeat the actions you performed in Step 2. 

a Choose New Command from the drop-down menu. 

b Enter XML I/O as the Command and Read XML as the I/O Command 
on the Rule Command–New window. 

c Navigate down into c:\..\data\podata.xml and double-click 
POHeader. The program automatically populates the Application 
Directory, Application File, and File Record text boxes. 

d Select OK to close both the Directories(Mailboxes) and the Rule 
Command-New windows.

8 Right-click rule 610 and repeat the actions you performed in Step 2. 

a Choose New Command from the drop-down menu. 

b Enter XML I/O as the Command and Read XML as the I/O Command 
on the Rule Command–New window. 

c Navigate down into c:\..\data\podata.xml and double-click Contact. 
The program automatically populates the Application Directory, 
Application File, and File Record text boxes.

d  Select OK to close both the Directories (Mailboxes) and the Rule 
Command-New windows.

9 Right-click rule 620 and repeat the actions you performed in Step 3. 

a Choose New Command from the drop-down menu, and then enter 
XML I/O as the Command and Read XML as the I/O Command on 
the Rule Command–New window. 

b Navigate down into c:\..\data\podata.xml and double-click 
POShipTo. The program automatically populates the Application 
Directory, Application File, and File Record text boxes. 
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c Select OK to close both the Directories (Mailboxes) and the Rule 
Command-New windows.

10 Right-click rule 630 and repeat the actions you performed in Step 2. 

a Choose New Command from the drop-down menu, and then enter 
XML I/O as the Command and Read XML as the I/O Command on 
the Rule Command–New window. 

b Navigate down into c:\..\data\podata.xml and double-click POBillTo. 
The program automatically populates the Application Directory, 
Application File, and File Record text boxes. 

c Select OK to close both the Directories (Mailboxes) and the Rule 
Command-New windows.

11 Right-click rule 800 and repeat the actions you performed in Step 2.

a Choose New Command from the drop-down menu, and then enter 
XML I/O as the Command and Read XML as the I/O Command on 
the Rule Command–New window. 

b Navigate down into c:\..\data\podata.xml and double-click POLines. 
The program automatically populates the Application Directory, 
Application File, and File Record text boxes.

c Select OK to close both the Directories (Mailboxes) and the Rule 
Command-New windows.

12 Right-click rule 900 and repeat the actions you performed in Step 2. 

a Choose New Command from the drop-down menu, and then enter 
XML I/O as the Command and Read XML as the I/O Command on 
the Rule Command–New window. 

b Navigate down into c:\..\data\podata.xml and double-click Item. The 
program automatically populates the Application Directory, 
Application File, and File Record text boxes. 

c Select OK to close both the Directories(Mailboxes) and the Rule 
Command-New windows.

❖ Adding the commands to write the ODBC data

1 Right-click rule 308. 

a Choose New Command from the drop-down menu, and then enter 
SQL as the Command and Insert Record into Table as the I/O 
Command on the Rule Command – New window. 
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b Select the up arrow next to SQL Application File Name, and the 
Files/Databases window displays. 

c Double-click on PO_DATA.mdb. 

d Double-click on PO_Routing. The program automatically populates 
the SQL Application File Name, SQL Application File Record, and 
SQL Table Name text boxes. 

e Select OK on Rule Command – New window.

2 Right-click rule 318. 

a Choose New Command from the drop-down menu, and then enter 
SQL as the Command and Insert Record into Table as the I/O 
Command on the Rule Command – New window. 

b Select the up arrow next to SQL Application File Name, and the Files/ 
Databases window displays. 

c Double-click on PO_DATA.mdb. 

d Double-click on PO_Routing. The program automatically populates 
the SQL Application File Name, SQL Application File Record, and 
SQL Table Name text boxes. 

e Select OK on Rule Command – New window.

3 Right-click on Rule 700 and choose New Command. 

a On the Rule Command – New window, enter SQL as the Command 
and Insert Record into Table as the I/O Command. 

b On the Files/Databases window, double-click PO_Information. The 
program automatically populates the SQL Application File Name, 
SQL Application File Record, and SQL Table Name text boxes on the 
Rule Command – New window. 

c Select OK on that window to add another command.

4 Right-click rule 1000 and choose New Command from the drop-down 
menu. 

a Enter SQL as the Command and Insert Record into Table as the I/O 
Command on the Rule Command – New window. 

b Select the up arrow next to SQL Application File Name, and the Files/ 
Databases window displays. 
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c Navigate down through c:\..\data\ PO_DATA.mdb and double-click 
PO_LineItems. The program automatically populates the SQL 
Application File Name, SQL Application File Record, and SQL Table 
Name text boxes. 

d Select Apply.

Note  Rule 1000 has two commands. When you finish adding the first rule 
command, select Apply instead of OK. This adds the rule command, but 
does not close the window. After you add the second rule command, select 
OK.

5 Enter the second command. The Rule Command – New window should 
still be open.

a Enter Clear Record as the Command, and the window changes. 

b Select the up arrow next to Record to Clear, and the Records/ Tables 
window displays.

c Double-click PO_LineItems, and the program automatically enters it 
in the Record to Clear text box. 

d Select the up arrow next to Type of Record Clear, and choose Clear 
All Fields from the submenu. 

e Select OK to close the Rule Command – New and Records/Tables 
windows. 

Note  Do not close the Rule Definitions window. 

❖ Mapping the source data to the destination data

Mapping in ECMap is a simple procedure of linking source record fields or 
elements to destination record fields or elements. Source data is on the left side 
of the Any-to-Any Map window, destination data is on the right, and the results 
of mapping display at the bottom of the window. In addition, there is a 
temporary mapping workspace in the middle of the window, where you can 
map multiple records at one time. 

You can create mapping links in one of two ways:

• Drag source objects and drop them on destination objects one at a time. 

• Enter multiple source and destination objects in the temporary mapping 
workspace and map them simultaneously with the select of a button.
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1 Using the Mapping icon at the top of the Rule Definitions window and the 
View Rules button at the bottom of the Any-to-Any Map window, toggle 
back and forth between the two windows.

2 The Rule Definitions window should be open. Right-click rule 305, 
choose New Command from the drop-down menu, and enter Assignment 
as the Command. As the Source under Parameters, choose Constant from 
the drop-down list and the Constant Value dialog box displays. 

a Enter From as the constant value and select OK. 

b As the Destination under Parameters, choose Record/Field and the 
Records/Tables window displays. 

c Under PO_Routing, double-click To_From. Select OK to close the 
Rule Command-New and Records/Tables windows.

The Line number specifies the order of the rule command in the rule.

d Select Mapping from the icons at the top of the Rule Definitions 
window and the Any-to-Any Map window displays. Under Rule in 
the upper right corner of the window, 305 displays in the rule Number 
text box and 1 displays in the Line text box. Type 2 in the Line text 
box.

e On the Source side of the Any-to-Any mapping window, double-click 
From. 

f Under Destination, double-click PO_Routing. 

g Drag the following elements under From and drop them on the 
specified fields under PO_Routing:

Note  On the Any-to-Any Map window, the XML elements display 
under Source, and the ODBC database tables display under 
Destination.

Source Destination
From PO_Routing
location ID locationID
locationType locationType
process process
path path
handle handle

The mapping displays in the bottom middle section of the window.
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3 Select View Rules at the bottom of the Any-to-Any Map window, and the 
Rule Definitions window displays:

a Right-click rule 315, choose New Command from the drop-down list, 
and enter Assignment as the Command. 

b As the Source under Parameters, choose Constant from the 
drop-down list and the Constant Value dialog box displays. 

c Enter To as the constant value and select OK. 

d At the Destination under Parameters, choose Record/Field and the 
Records/Tables window displays. 

e Under PO_Routing, double-click To_From. 

f Select OK to close the Rule Command-New and Records/Tables 
windows. 

g Select Mapping on the Rule Definitions window and the Any-to-Any 
Map window displays. 

h Under Rule in the upper right corner of the window, 315 displays in 
the rule Number text box and 1 displays in the Line text box. 

i Type 2 in the Line text box. 

j Under Source on the Any-to-Any mapping window, double-click To. 

k Under Destination, the elements under PO_Routing are already 
displayed. 

l Drag the following elements under To and drop them on the specified 
fields under PO_Routing:

Source Destination
To PO_Routing
location ID locationID
locationType locationType
process process
path path
handle handle

4 Select the up arrow next to the Number text box in the top right Rule 
section of the window, and the Rule Definitions window displays. 

a Double-click rule 505, and the program automatically enters 505 in 
the Number text box and 1 in the Line text box. 

b Minimize the Rule Definitions window. 
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c Under Source, double-click PO. 

d Under Destination, double-click PO_Information. 

e Drag xmlns under PO and drop it on PO_xmlns under 
PO_Information. 

5 Select the up arrow next to the Number text box in the top right Rule 
section of the window, and the Rule Definitions window displays. 

a Double-click rule 605 and the program enters 605 in the Number text 
box and 1 in the Line text box. 

b Select Mapping button and clear middle part of window.

c Minimize the Rule Definitions window. 

d Under Source, double-click POHeader

e Double-click each element in the order listed below. 

f Under Destination, double-click PO_Information and double-click all 
of the same elements in the order listed below:

Source Destination
POHeader PO_Information
refPromise refPromise
fromCust fromCust
poNumber PONumber
description description
paymentType paymentType
shipType shipType
Select => (Apply) to map elements.

g As you select elements, they display in the mapping area in the top 
middle section of the window. When you are finished, select the 
minus button and each element is mapped to the element directly 
across from it. The results display at the bottom of the window, and 
the mapping area at the top is cleared.

6 Select the up arrow next to the Number text box in the top right Rule 
section of the window, and the Rule Definitions window displays.

a Double-click rule 615 and the program enters 615 in the Number text 
box and 1 in the Line text box. 

b Minimize the Rule Definitions window. 

c Select View Mapping and clear the middle part of the window. 
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d Under Source, double-click Contact and then double-click each 
element in the order listed below. 

e On the Destination side of the window, under PO_Information, 
double-click all of the same elements in the order listed below:

Source Destination
Contact PO_Information
contactName contactName
contactPhone contactPhone
contactEmail contactEmail

f Select the minus between the two sets of data and the mapping is 
performed.

7 Select the up arrow next to the Number text box in the top right Rule 
section of the window, and the Rule Definitions window displays. 

a Double-click rule 625 and the program enters 625 in the Number text 
box and 1 in the Line text box. 

b Minimize the Rule Definitions window. 

c Select View Mapping and clear the middle part of the window. 

d Under Source, double-click POShipTo and then double-click each 
element in the order listed below. 

e On the Destination side of the window, under PO_Information, 
double-click the corresponding elements in the order listed below:

Source Destination
POShipTo PO_Information
street1 Shipto_street1
street2 Shipto_street
street3 Shipto_street3 
street4 Shipto_street4
attn Shipto_attn
city Shipto_city
stateProvince Shipto_stateProvince
postalCode Shipto_postalCode
country Shipto_country

f Select the minus between the two sets of data and the mapping is 
performed.

8 Select the up arrow next to the Number text box in the top right Rule 
section of the window, and the Rule Definitions window displays. 
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a Double-click rule 635 and the program enters 635 in the Number text 
box and 1 in the Line text box. 

b Minimize the Rule Definitions window. 

c Select View Mapping and clear the middle part of the window. 

d Under Source, double-click POBillTo and then double-click each 
element in the order listed below. 

e On the Destination side of the window, under PO_Information, 
double-click the corresponding elements in the order listed below:

Source Destination
POBillTo PO_Information
street1 Billto_street1
street2 Billto_street2
street3 Billto_street3 
street4 Billto_street4
attn Billto_attn
city Billto_city
stateProvince Billto_stateProvince
postalCode Billto_postalCode
country Billto_country 

f Select the minus between the two sets of data and mapping is 
performed.

9 Select the up arrow next to the Number text box in the top right Rule 
section of the window, and the Rule Definitions window displays. 

a Double-click rule 905 and the program automatically enters 905 in the 
Number text box and 1 in the Line text box. 

b Minimize the Rule Definitions window. 

c Select View Mapping and clear the middle part of the window. 

d Under Source, double-click Item and then double-click each element 
in the order listed below. 

e Under Destination, close PO_Information, double-click 
PO_LineItems and double-click all of the same elements in the order 
listed below: 

Source Destination
Item PO_LineItems
partNo partNo
qty qty
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unitPrice unitPrice
uom uom
discount discount
needAfter needAfter
needBefore needBefore

f Under Source, double-click POHeader and then double-click 
poNumber. Under Destination, double-click PONumber. 

g Select the minus between the two sets of data and the mapping is 
performed.

10 Close the Any-to-Any Map window. You have now finished mapping and 
are now ready to generate and run your map. Close all open windows. 

Running your map
Sybase is known for its high speed and quality performance. Map generation 
results in an efficient map run process, which in turn contributes to the speed 
and throughput of Sybase’s mapping product.

Running your map involves:

• “Generating your map” on page 100.

• “Running your map” on page 101.

The final steps in the mapping process are to generate and run your map. 
During generation, your map is checked to make sure that everything is set up 
properly. When you run your map, the outbound EDI file or inbound 
application file is actually built.

Generating the map produces the .map file, which contains all the mapping 
instructions you created. Running the map – with the ECRTP runtime program 
- interprets the .map file and maps the data.

❖ Generating your map

When you generate a map, you compile all your business rules and logic into 
your finished map 

1 Select Generate Map (the yellow traffic light) on the toolbar at the top of 
the window. The Generate Map window displays.

2 Make sure that the Multiple Files check box is not checked. 
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Multiple Files is checked by default. Left-click on the check box to 
uncheck it, or you receive a warning – “All Recd Files with Multiple Recs 
must have Record Type Fields”

3 Select Run on the Generate Map window. Messages flash across the text 
box until the following message appears: Map Generation Completed 
Successfully. 

4 You can view the results of the map generation process by selecting View 
Log. The Generate Log window displays. 

5 Select Exit to return to the main ECMap window.

❖ Running your map

Map files can be distributed and deployed with the runtime engine.

1 Select Run Map (the green traffic light) on the toolbar at the top of the 
window. The Run Any-to-Any Map window displays. It has several tabs – 
Required, Option 1, Option 2, File Alias, ODBC Alias, Parameters, I/O 
Redirect, and Web Script. 

2 ECMap automatically populates Map Name and Map Directory. Since you 
configured an ODBC log database, the Log Type is automatically 
populated with ODBC Log. On the Option 1 tab, Short Trace has already 
been entered as the default Trace Type, and 10000 has already been 
entered as the Max Memory Cross-Reference. The Number of Maps in 
Memory is optional. On the Option 1 tab, select Long Trace.

3 Select Run Map. 

4 Select View Trace to review the trace log. The Trnn.dat-Notepad window 
displays, with the message “Maprun Complete – No Errors Encountered” 
if the map run was successful. If there are errors, you can use the 
information in this log to correct your errors and then run the map again.

5 Close the Any-to-Any Map window to return to the main ECMap window.

6 You have now successfully run your map - which read XML input data and 
wrote output to the ODBC Inventory and Billing database.

If you want to view the output, open Microsoft Access and view the 
PO_DATA.mdb database.
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XML-to-ODBC mapping overview
Figure 3-1 is a graphic representation of XML to ODBC mapping.

Figure 3-1: XML to ODBC mapping

Figure 3-2 is a graphic representation of XML schema used in this tutorial

Figure 3-2: XML Schema

Annotated sample XML data
Sample XML data used in this tutorial, annotated with placement of rules and 
levels. Levels are shown under Read and Write.
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Table 3-2: Sample XML data

Rule

Read Map Write XML Purchase Order

Do Nothing

<?xml version= “1.0” ?>

100 <BizTalk xmlns= 
“urn:schemas-biztalk-org:biztalk/biztalk-0.81.xml”>

200 <Route>

300 305 <From locationID= “http://www.MPT.com” locationType= “HTTP”

process= “http://MPT.com/biztalk” path= “ “ handle= “45” />

308 Write PO_Routing

310 315 <To locationID= 
“http://www.ToysForBusinesses.com/biztalk/recv.asp”

locationType= “HTTP”process=""

path="http://ToysForBusinesses.com/biztalk/recv.asp" 
handle="45" />

318 Write PO_Routing

</Route>

400 <Body>

500 505 <PO xmlns="urn:schemas-biztalk.org:fabrikam/orders.xml">

600 605 <POHeader refPromise="0" fromCust="Major Playtime Tools"                             
poNumber="12345"

description="Sample PO" paymentType="INVOICE" 
shipType="AIR1D" />

610 615 <Contact contactName="Billy Badger" contactPhone="(425) 
123-1234"

contactEmail="bbadger@MPT.com" />

620 625 <POShipTo street1="8230 Old Courthouse Road" street2="Suite 
100"

street3="" street4="" attn="Susie Sandella" city="Vienna"

stateProvince="VA" postalCode="22182" country="USA" />

630 635 <POBillTo street1="8230 Old Courthouse Road" street2="Suite 
300"

street3="" street4="" attn="Billy Badger" city="Vienna"

stateProvince="VA" postalCode="22182" country="USA" />

  700 WRITE PO_Information

800 <POLines count="2" startAt="1">
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XML PO SCHEMA (BizTalk 0.8)
<?xml version ="1.0"?>
<!--Generated by XML Authority. Conforms to w3c 
http://www.w3.org/1999/XMLSchema-->
<schema xmlns = "http://www.w3.org/1999/XMLSchema">

<element name = "BizTalk">
<complexType content = "elementOnly">

<sequence>
<element ref = "Route"/>
<element ref = "Body"/>

</sequence>
<attribute name = "xmlns" use = "required" type = "string"/>

</complexType>
</element>
<element name = "Route">
<complexType content = "elementOnly">

<sequence>
<element ref = "From"/>
<element ref = "To"/>

</sequence>
</complexType>

</element>
<element name = "From">
<complexType content = "empty">

<Item line="1" partNo="VoiceActivatedKeyboard" qty="1" 
unitPrice="3000"

uom="Unit" discount="0.0" needAfter="2000-07-31" 
needBefore="2000-05-29" />

900 905 1000 WRITE <POLines> to PO_LineItems

<Item line="2" partNo="VirtualVacationPackage" qty="5" 
unitPrice="4500"

uom="Unit" discount="0" needAfter="2000-07-31" 
needBefore="2000-05-29"/>

900 905 1000 WRITE <POLines> to PO_PO_LineItems

</POLines>

</PO>

</Body>

</BizTalk>

Rule

Read Map Write XML Purchase Order
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<attribute name = "locationType" use = "required" type = "string"/>
<attribute name = "locationID" use = "required" type = "string"/>
<attribute name = "handle" use = "required" type = "string"/>
<attribute name = "process" use = "required" type = "string"/>
<attribute name = "path" use = "required" type = "string"/>

</complexType>
</element>
<element name = "To">

<complexType content = "empty">
<attribute name = "locationType" use = "required" type = "string"/>
<attribute name = "locationID" use = "required" type = "string"/>
<attribute name = "handle" use = "required" type = "string"/>
<attribute name = "process" use = "required" type = "string"/>
<attribute name = "path" use = "required" type = "string"/>

</complexType> 
</element>
<element name = "Body"> 

<complexType content = "elementOnly"> 
<sequence> 

<element ref = "PO"/>
</sequence> 

</complexType> 
</element>
<element name = "PO"> 

<complexType content = "elementOnly"> 
<sequence> 

<element ref = "POHeader"/>
<element ref = "Contact"/> 
<element ref = "POShipTo"/> 
<element ref = "POBillTo"/> 
<element ref = "POLines"/>

</sequence>
<attribute name = "xmlns" use = "required" type = "string"/> 

</complexType> 
</element>
<element name = "POHeader"> 

<complexType content = "empty"> 
<attribute name = "refPromise" use = "required" type = "string"/> 
<attribute name = "description" use = "required" type = "string"/> 
<attribute name = "fromCust" use = "required" type = "string"/> 
<attribute name = "paymentType" use = "required" type = "string"/>
<attribute name = "shipType" use = "required" type = "string"/> 
<attribute name = "poNumber" use = "required" type = "string"/> 

</complexType> 
</element>
<element name = "Contact"> 
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<complexType content = "empty">
<attribute name = "contactPhone" use = "required" type = "string"/> 
<attribute name = "contactEmail" use = "required" type = "string"/>
<attribute name = "contactName" use = "required" type = "string"/> 

</complexType> 
</element>
<element name = "POShipTo"> 
<complexType content = "empty"> 

<attribute name = "street4" use = "required" type = "string"/> 
<attribute name = "street3" use = "required" type = "string"/> 
<attribute name = "street2" use = "required" type = "string"/> 
<attribute name = "street1" use = "required" type = "string"/>
<attribute name = "stateProvince" use = "required" type = "string"/> 
<attribute name = "city" use = "required" type = "string"/> 
<attribute name = "country" use = "required" type = "string"/> 
<attribute name = "attn" use = "required" type = "string"/> 
<attribute name = "postalCode" use = "required" type = "string"/>

</complexType> 
</element>
<element name = "POBillTo"> 
<complexType content = "empty"> 

<attribute name = "street4" use = "required" type = "string"/> 
<attribute name = "street3" use = "required" type = "string"/> 
<attribute name = "street2" use = "required" type = "string"/> 
<attribute name = "street1" use = "required" type = "string"/> 
<attribute name = "stateProvince" use = "required" type = "string"/> 
<attribute name = "city" use = "required" type = "string"/> 
<attribute name = "country" use = "required" type = "string"/> 
<attribute name = "attn" use = "required" type = "string"/> 
<attribute name = "postalCode" use = "required" type = "string"/>

</complexType> 
</element>
<element name = "POLines"> 
<complexType content = "elementOnly"> 

<sequence> 
<element ref = "Item" minOccurs = "1" maxOccurs = "unbounded"/> 

</sequence>
<attribute name = "count" use = "required" type = "string"/> 
<attribute name = "startAt" use = "required" type = "string"/> 

</complexType> 
</element>
<element name = "Item"> 
<complexType content = "empty"> 

<attribute name = "qty" use = "required" type = "string"/> 
<attribute name = "needBefore" use = "required"> 
<simpleType base = "NMTOKEN"> 
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<enumeration value = "2000-05-29"/> 
</simpleType> 

</attribute>
<attribute name = "discount" use = "required" type = "string"/> 
<attribute name = "unitPrice" use = "required" type = "string"/>
<attribute name = "needAfter" use = "required">

<simpleType base = "NMTOKEN"> 
<enumeration value = "2000-07-31"/> 

</simpleType> 
</attribute> 
<attribute name = "line" use = "required" type = "string"/>
<attribute name = "uom" use = "required"> 

<simpleType base = "NMTOKEN"> 
<enumeration value = "Unit"/>

</simpleType> 
</attribute> 
<attribute name = "partNo" use = "required" type = "string"/> 

</complexType>
</element>

</schema>
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