## Contents

**Getting Started with Enterprise Architecture Modeling** .................................................. 1
- Creating an EAM .............................................................................................................. 2
- EAM Model Properties .................................................................................................... 3
- Creating an Enterprise Architecture Framework Project .............................................. 4

**Building Business Layer Diagrams** ........................................................................... 7
- Organization Chart Basics ............................................................................................ 7
  - Organization Chart Objects ......................................................................................... 7
  - Creating an Organization Chart .................................................................................... 8
- Business Communication Diagram Basics .................................................................... 8
  - Business Communication Diagram Objects ................................................................. 8
  - Creating a Business Communication Diagram .......................................................... 9
- Process Map Basics ....................................................................................................... 9
  - Process Map Objects .................................................................................................... 10
  - Creating a Process Map ................................................................................................ 10
- City Planning Diagram Basics ...................................................................................... 10
  - City Planning Diagram Objects .................................................................................... 11
  - Creating a City Planning Diagram .............................................................................. 12
- Organization Units (EAM) ............................................................................................ 12
  - Creating an Organization Unit ...................................................................................... 12
  - Organization Unit Properties ...................................................................................... 13
- People (EAM) ................................................................................................................ 13
  - Creating a Person ......................................................................................................... 14
  - Person Properties ......................................................................................................... 14
- Roles (EAM) ................................................................................................................... 14
  - Creating a Role ............................................................................................................. 15
  - Role Properties ............................................................................................................. 15
  - Role Associations ......................................................................................................... 15
- Architecture Areas (EAM) ............................................................................................ 16
  - Creating an Architecture Area ....................................................................................... 16
  - Architecture Area Properties ...................................................................................... 16
- Sites (EAM) .................................................................................................................... 17
  - Creating a Site .............................................................................................................. 17
  - Site Properties .............................................................................................................. 17
- Business Functions (EAM) ............................................................................................ 18
  - Creating a Business Function ....................................................................................... 18
  - Business Function Properties ...................................................................................... 18
- Processes (EAM) ............................................................................................................. 19
  - Creating a Process ........................................................................................................ 19
  - Process Properties ........................................................................................................ 19
- Business Flows (EAM) ................................................................................................. 20
  - Creating a Business Flow .............................................................................................. 20
## Building Application Layer Diagrams

- **Application Architecture Diagram Basics**
- **Application Architecture Diagram Objects**
- **Creating an Application Architecture Diagram**
- **Service-Oriented Diagram Basics**
- **Service-oriented Diagram Objects**
- **Creating a Service-oriented Diagram**
- **Application and Business Services (EAM)**
  - Creating an Application or Business Service
  - Application and Business Service Properties
  - Creating Business and Application Service Operations
- **Systems, Applications, and Databases (EAM)**
  - Creating a System, Application, or Database
  - System, Application, and Database Properties
- **Components (EAM)**
  - Creating a Component
  - Component Properties
- **Forms, Documents, and Reports (EAM)**
  - Creating a Form, Document, or Report
  - Form, Document, and Report Properties
  - Creating Document Data
- **ETL Jobs (EAM)**
  - Creating an ETL Job
  - ETL Job Properties
- **Application Links (EAM)**
  - Creating an Application Link
  - Application Link Properties
- **Contracts (EAM)**
  - Creating a Contract
  - Contract Properties

## Building Technology Layer Diagrams

- **Technology Infrastructure Diagram Objects**
- **Creating a Technology Infrastructure Diagram**
- **Networks (EAM)**
  - Creating a Network
  - Network Properties
- **Servers, Workstations, Mobile Devices, and Network Nodes (EAM)**
  - Creating a Software or Hardware Server, Workstation, Mobile Device, or Network Node
  - Software and Hardware Server, Workstation, Mobile Device, and Network Node Properties
- **Deployment Instances (EAM)**
  - Creating a Deployment Instance
  - Deployment Instance Properties
Getting Started with Enterprise Architecture Modeling

An enterprise architecture model (EAM) helps you analyze and document your organization and its business functions, along with the applications and systems that support them and the physical architecture on which they are implemented.

Enterprise architecture modeling helps you to analyze and document the architecture of your organization. Such an analysis, can be required:

- As an end in itself as part of good corporate governance
- Where you are required to document your system's compliance with standards or regulations
- In the following kinds of change management situations:
  - Rationalization – where cost savings and efficiencies are sought
  - A change in technology – where your system will be upgraded
  - An acquisition or merger – where two disparate systems must be made to work together

The diagrams in the PowerDesigner® enterprise architecture model are divided into three layers as follows:

- **Business Layer** - helps you to analyze your organization in various ways:
  - *Organization Charts* – for documenting groups and people
  - *Business Communication Diagram* – for documenting sites and analyzing the interactions between various parts of your organization
  - *Process Map* – for documenting functions
  - *City Planning Diagram* - for providing a big picture, global view of the organization, and for descending to the system and database level, to provide links into the next, application layer.

- **Application Layer** - descends into the applications, databases, and other systems that must implement the business functions identified in the business layer. The two diagrams in the application layer allow you to identify what applications you have, and how they interact with each other, in two different ways:
  - *Application Architecture Diagram* - as traditional discrete applications
  - *Service Oriented Diagram* - in terms of SOA services

- **Technology Layer** - models the hardware on which the software is deployed. If the business layer allows you to define what it is your organization does, and the application layer identifies the software that implements these functions, the technology layer documents the physical equipment on which the software will run. This layer has a single diagram:
  - *Technology Infrastructure Diagram* – for documenting your existing infrastructure, your networks, server clusters, firewalls, and client workstations, and the infrastructure that you want to put in place.

**Extending Your Analysis into Other Modules**

The enterprise architecture model is intended to give you the big picture of your organization, and to provide means to decompose your functions, processes, and systems to a certain level of detail. However, when it comes time to model the implementation of databases, web services, or OO components, you will want to do this in the PowerDesigner module designed for the task.

The EAM contains wizards that allow you to import objects from and export objects to other PowerDesigner modules. Objects exported or imported remain linked to the original objects, in order to keep all your models synchronized and to allow you to perform cross-module impact analysis to identify the technical impact of changes on your enterprise architecture.

The following diagram illustrated how you can deepen the analysis of your architecture by linking your EA objects with lower-level objects in other types of PowerDesigner models:
Using Enterprise Architecture Frameworks

PowerDesigner projects enable you to easily combine multiple models and view the connections between them. You can follow an enterprise architecture framework such as FEAF by creating a project that combines your EAM diagrams with those of a Physical Data Model and other PowerDesigner modules.

For more information, see Creating an Enterprise Architecture Framework Project on page 4.

Suggested Bibliography


The following online resources provide an introduction to enterprise architecture concepts:

- Wikipedia on enterprise architecture and service-oriented modeling:
- The Zachman Institute for Framework Advancement (ZIFA):
  - http://www.zifa.com/
- The Federal Enterprise Architecture Framework (FEAF):
- The Department of Defense Architecture Framework (DODAF):

Creating an EAM

You create a new enterprise architecture model by selecting File > New Model.

Note: In addition to creating an EAM from scratch with the following procedure, you can also create a model by importing a Visio file (see Importing Visio Diagrams into PowerDesigner on page 51).
The New Model dialog is highly configurable, and your administrator may have hidden options that are not relevant for your work or provided templates or predefined models to guide you through model creation. When you open the dialog, one or more of the following buttons will be available on the left hand side:

- **Categories** - which provides a set of predefined models and diagrams sorted in a configurable category structure.
- **Model types** - which provides the classic list of PowerDesigner model types and diagrams.
- **Template files** - which provides a set of model templates sorted by model type.

1. Select **File > New Model** to open the New Model dialog.
2. Click a button, and then select a category or model type (**Enterprise Architecture Model**) in the left-hand pane.
3. Select an item in the right-hand pane. Depending on how your New Model dialog is configured, these items may be first diagrams or templates on which to base the creation of your model.
   Use the **Views** tool on the upper right hand side of the dialog to control the display of the items.
4. Enter a model name.
   The code of the model, which is used for script or code generation, is derived from this name according to the model naming conventions.
5. [optional] Click the **Extensions** button to open the Extended Model Definitions dialog, and attach one or more extensions to your model.
6. Click **OK** to create and open the enterprise architecture model.

**Note:** Sample EAMs are available in the Example Directory.

**EAM Model Properties**
Double-click the model node in the Browser to open the model property sheet, which contains information about the model.
The General tab contains the following properties:

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>The name of the item which should be clear and meaningful, and should convey the item's purpose to non-technical users.</td>
</tr>
<tr>
<td>Code</td>
<td>The technical name of the item used for generating code or scripts, which may be abbreviated, and should not generally include spaces.</td>
</tr>
<tr>
<td>Comment</td>
<td>Descriptive label of the model.</td>
</tr>
<tr>
<td>File name</td>
<td>Specifies the location of the model file. This field is empty if the model has never been saved.</td>
</tr>
<tr>
<td>Author</td>
<td>Specifies the author of the model. If you insert a space, the Author field in the title box remains empty; if you leave the field empty, it will display the user name from the Version Info tab.</td>
</tr>
<tr>
<td>Version</td>
<td>Specifies the version of the model. You can use this field to display the repository version or a user-defined version. This parameter is defined in the display preferences of the Title node.</td>
</tr>
<tr>
<td>Default diagram</td>
<td>Specifies the diagram displayed by default when opening the model.</td>
</tr>
</tbody>
</table>

Creating an Enterprise Architecture Framework Project

PowerDesigner provides support for some of the most popular enterprise architecture frameworks in the form of project templates.

1. Select **File > New Project** to open the New Project dialog.
2. In the Project type pane, expand the EA Frameworks node and select one of the available frameworks.
3. Specify a name for the project and a location to save it, and then click OK to create the project.

The project opens to the framework matrix, from which you can create models, diagrams, lists, and other items to complete the requirements of the framework:
For detailed information about working with projects, see the Projects and Framework Matrices chapter in the Core Features Guide.
Building Business Layer Diagrams

The diagrams in the business layer of the enterprise architecture model help you to analyze your organization in terms of business units, processes, and functions:

- Organization Charts – provide graphical representations of your organization’s hierarchies (see Organization Chart Basics on page 7).
- Business Communication Diagrams – provide a consistent framework for interactions between components of the organization, and with customers, suppliers and partners (see Business Communication Diagram Basics on page 8).
- Process Maps – provide a view of how high-level processes are associated with business functions (see Process Map Basics on page 9).
- City Planning Diagrams – provide a "big picture" view of the organization broken down into architectural areas (see City Planning Diagram Basics on page 10).

Organization Chart Basics

An organization chart provides a graphical view of your organization as a tree structure, and helps you analyze and display the relationships between organization units (divisions, groups, teams, etc), individuals, and roles.

In the following example, the company is analyzed into its top-level departments and the major groups within them:

Organization Chart Objects

You can create the following objects in an organization chart:

<table>
<thead>
<tr>
<th>Object</th>
<th>Tool</th>
<th>Symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Organization unit</td>
<td></td>
<td><img src="image" alt="Organization unit" /></td>
<td>A group, department, function, or other collection of people or organization units. See Organization Units (EAM) on page 12.</td>
</tr>
<tr>
<td>Person</td>
<td></td>
<td><img src="image" alt="Person" /></td>
<td>An individual. See People (EAM) on page 13.</td>
</tr>
<tr>
<td>Hierarchy link</td>
<td><img src="image" alt="Hierarchy link" /></td>
<td>A link between organization units or people. See Roles (EAM) on page 14.</td>
<td></td>
</tr>
</tbody>
</table>

Note: Most EAM objects can be displayed as icons or as boxes that can display additional properties and sub-objects. You can toggle between the Icon and Detail modes via the contextual menu, or by pressing CTRL+Q. You can control the...
Creating an Organization Chart

You can create an organization chart in an existing EAM in any of the following ways:

- Right-click the model in the Browser and select **New > Organization Chart**.
- Right-click the background of any diagram and select **Diagram > New Diagram > Organization Chart**.

To create a new EAM with an organization chart, select **File > New Model**, choose to create an enterprise architecture model from the Model type list, choose **Organization Chart** as the first diagram, and click **OK**.

Business Communication Diagram Basics

A *business communication diagram* provides a graphical view of your organization, and helps you analyze, the relationships, flows, and other connections between business functions, organization units, roles, and sites.

In the following example, communications between the company, its customers and suppliers are analyzed, as well as those between the different company sites:

---

### Business Communication Diagram Objects

You can create the following objects in a business communication diagram:

<table>
<thead>
<tr>
<th>Object</th>
<th>Tool</th>
<th>Symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Architecture Area</td>
<td></td>
<td><img src="image_url" alt="Image" /></td>
<td>See <em>Architecture Areas (EAM)</em> on page 16.</td>
</tr>
<tr>
<td>Object</td>
<td>Tool</td>
<td>Symbol</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------</td>
<td>------</td>
<td>--------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Business Function</td>
<td></td>
<td><img src="image" alt="Business Function Icon" /></td>
<td>An aggregation of processes and/or sub-functions. See Business Functions (EAM) on page 18.</td>
</tr>
<tr>
<td>Business flow</td>
<td></td>
<td><img src="image" alt="Business Flow Icon" /></td>
<td>A link between elements in a business layer diagram. See Business Flows (EAM) on page 20.</td>
</tr>
<tr>
<td>Process</td>
<td></td>
<td><img src="image" alt="Process Icon" /></td>
<td>An ordering of tasks. See Processes (EAM) on page 19.</td>
</tr>
<tr>
<td>Site</td>
<td></td>
<td><img src="image" alt="Site Icon" /></td>
<td>A physical location. See Sites (EAM) on page 17.</td>
</tr>
<tr>
<td>Organization unit</td>
<td></td>
<td><img src="image" alt="Organization Unit Icon" /></td>
<td>A group, department, function, or other collection of people or organization units. See Organization Units (EAM) on page 12.</td>
</tr>
<tr>
<td>Person</td>
<td></td>
<td><img src="image" alt="Person Icon" /></td>
<td>An individual. See People (EAM) on page 13.</td>
</tr>
<tr>
<td>Role</td>
<td></td>
<td><img src="image" alt="Role Icon" /></td>
<td>A set of responsibilities. See Roles (EAM) on page 14.</td>
</tr>
</tbody>
</table>

Note: Most EAM objects can be displayed as icons or as boxes that can display additional properties and sub-objects. You can toggle between the Icon and Detail modes via the contextual menu, or by pressing CTRL+Q. You can control the default mode, and the information displayed in each mode through the options available by selecting Tools > Display Preferences.

Creating a Business Communication Diagram

You can create a business communication diagram in an existing EAM in any of the following ways:

- Right-click the model in the Browser and select **New > Business Communication Diagram**.
- Right-click the background of any diagram and select **Diagram > New Diagram > Business Communication Diagram**.

To create a new EAM with a business communication diagram, select **File > New Model**, choose to create an enterprise architecture model from the Model type list, choose **Business Communication Diagram** as the first diagram, and click OK.

Process Map Basics

A *process map* provides a graphical view of your business architecture, and helps you identify your business functions and high-level processes, independent of the people and business units who fulfill them.

In the following example, the major processes within the Manufacturing, Marketing, and Sales business functions are displayed:
You can create the following objects in a process map:

<table>
<thead>
<tr>
<th>Object</th>
<th>Tool</th>
<th>Symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Architecture Area</td>
<td>An abstract container object. See <em>Architecture Areas (EAM)</em> on page 16.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Business Function</td>
<td>An aggregation of processes and/or sub-functions. See <em>Business Functions (EAM)</em> on page 18.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Process</td>
<td>An ordering of tasks. See <em>Processes (EAM)</em> on page 19.</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Note:** Most EAM objects can be displayed as icons or as boxes that can display additional properties and sub-objects. You can toggle between the Icon and Detail modes via the contextual menu, or by pressing CTRL+Q. You can control the default mode, and the information displayed in each mode through the options available by selecting Tools > Display Preferences.

**Creating a Process Map**

You can create a process map in an existing EAM in any of the following ways:

- Right-click the model in the Browser and select New > Process Map.
- Right-click the background of any diagram and select Diagram > New Diagram > Process Map.

To create a new EAM with a process map, select File > New Model, choose to create an enterprise architecture model from the Model type list, choose Process Map as the first diagram, and click OK.

**City Planning Diagram Basics**

*A city planning diagram* provides a graphical view of the big picture of your enterprise architecture, using the metaphor of planning the infrastructure of a city to represent the organization of systems, applications, etc into architectural areas.
In the following example, the core system is broken up into five major sub-systems, which are in turn sub-divided into their major functions. Major applications and databases are also highlighted.

City Planning Diagram Objects

You can create the following objects in a city planning diagram:

<table>
<thead>
<tr>
<th>Object</th>
<th>Tool</th>
<th>Symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Architecture Area</td>
<td>![Zone]</td>
<td>![Zone]</td>
<td>An abstract container object. See Architecture Areas (EAM) on page 16.</td>
</tr>
<tr>
<td>System</td>
<td>![Folder]</td>
<td>![Folder]</td>
<td>A group of applications, services or sub-sytems. See Systems, Applications, and Databases (EAM) on page 29.</td>
</tr>
</tbody>
</table>
## Business Function

An aggregation of processes and/or sub-functions. See *Business Functions (EAM)* on page 18.

<table>
<thead>
<tr>
<th>Object</th>
<th>Tool</th>
<th>Symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Business Function</td>
<td>![Icon]</td>
<td>![CREDIT]</td>
<td>An aggregation of processes and/or sub-functions. See <em>Business Functions (EAM)</em> on page 18.</td>
</tr>
<tr>
<td>Application Service</td>
<td>![Icon]</td>
<td>![Folder]</td>
<td>An externally visible unit of functionality. See <em>Application and Business Services (EAM)</em> on page 27.</td>
</tr>
</tbody>
</table>

**Note:** Most EAM objects can be displayed as icons or as boxes that can display additional properties and sub-objects. You can toggle between the Icon and Detail modes via the contextual menu, or by pressing CTRL+Q. You can control the default mode, and the information displayed in each mode through the options available by selecting **Tools > Display Preferences**.

### Creating a City Planning Diagram

You can create a city planning diagram in an existing EAM in any of the following ways:

- Right-click the model in the Browser and select **New > City Planning Diagram**.
- Right-click the background of any diagram and select **Diagram > New Diagram > City Planning Diagram**.

To create a new EAM with a city planning diagram, select **File > New Model**, choose to create an enterprise architecture model from the Model type list, choose **City Planning Diagram** as the first diagram, and click **OK**.

### Organization Units (EAM)

An organization unit represents a group of people or other organization units.

An organization unit can be created in the following diagrams:

- Organization chart (see *Organization Chart Basics* on page 7)
- Business communication diagram (see *Business Communication Diagram Basics* on page 8)
- Technology infrastructure diagram (see *Building Technology Layer Diagrams* on page 37)

#### Example

In this example, the Manufacturing organization unit contains the Quality and Production sub-units:

Creating an Organization Unit

You can create an organization unit in any of the following ways:

- Use the Organization Unit tool in the diagram Palette.
- Select **Model > Organization Units** to access the List of Organization Units, and click the Add a Row tool.
- Right-click the model or package in the Browser, and select **New > Organization Unit**.
For general information about creating objects, see the Objects chapter in the *Core Features Guide*.

**Organization Unit Properties**

To open an organization unit property sheet and view or edit its properties, double-click its diagram symbol or its Browser entry.

The General Tab contains the following properties:

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Specifies the name of the item, which should be clear and meaningful, and should convey the item’s purpose to non-technical users.</td>
</tr>
<tr>
<td>Code</td>
<td>Specifies the technical name of the object, which is used for generating code or scripts</td>
</tr>
<tr>
<td>Comment</td>
<td>Descriptive comment for the object.</td>
</tr>
<tr>
<td>Stereotype</td>
<td>Extends the semantics of an object derived from existing objects but specific to your needs.</td>
</tr>
<tr>
<td>Manager</td>
<td>Specifies the manager of the organization unit. Select a user or role from the list.</td>
</tr>
<tr>
<td>Telephone</td>
<td>Specifies the telephone number of the organization unit.</td>
</tr>
<tr>
<td>Email</td>
<td>Specifies the email address of the organization unit.</td>
</tr>
<tr>
<td>Web site</td>
<td>Specifies the url for the web site of the organization unit.</td>
</tr>
</tbody>
</table>

The following tabs are also available:

- Sub-Organizations – lists the organization units that belong to this organization unit.
- People – lists the people (see *People (EAM)* on page 13) that belong to this organization unit.
- Roles – lists the roles (see *Roles (EAM)* on page 14) that this organization unit fulfills.
- Sites – lists the sites (see *Sites (EAM)* on page 17) where this organization unit is located.

**People (EAM)**

A *person* represents an individual who holds a position within an organization.

A person can be created in the following diagrams:

- Organization chart (see *Organization Chart Basics* on page 7)
- Business communication diagram (see *Business Communication Diagram Basics* on page 8)
- Technology infrastructure diagram (see *Building Technology Layer Diagrams* on page 37)

**Example**

In this example, David is the manager of Emily and Robert:
Creating a Person

You can create a person in any of the following ways:

• Use the Person tool in the diagram Palette.
• Select Model > People to access the List of People, and click the Add a Row tool.
• Right-click the model or package in the Browser, and select New > Person.

For general information about creating objects, see the Objects chapter in the Core Features Guide.

Person Properties

To open a person property sheet and view or edit its properties, double-click its diagram symbol or its Browser entry.

The General Tab contains the following properties:

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Specifies the name of the item, which should be clear and meaningful, and should convey the item's purpose to non-technical users.</td>
</tr>
<tr>
<td>Code</td>
<td>Specifies the technical name of the object, which is used for generating code or scripts.</td>
</tr>
<tr>
<td>Comment</td>
<td>Descriptive comment for the object.</td>
</tr>
<tr>
<td>Stereotype</td>
<td>Extends the semantics of an object derived from existing objects but specific to your needs.</td>
</tr>
<tr>
<td>Manager</td>
<td>Specifies the manager of the person. Select a person from the list or click the New tool to the right of the field to create a new one.</td>
</tr>
<tr>
<td>Site</td>
<td>Specifies the site where this person is located. Select a site from the list or click the New tool to the right of the field to create a new one.</td>
</tr>
<tr>
<td>Job title</td>
<td>Specifies the job title of the person.</td>
</tr>
<tr>
<td>Telephone</td>
<td>Specifies the telephone number of the person.</td>
</tr>
<tr>
<td>Email</td>
<td>Specifies the email address of the person.</td>
</tr>
</tbody>
</table>

The following tabs are also available:

• Roles – lists the roles (see Roles (EAM) on page 14) that this person fulfills.

Roles (EAM)

A role is set of responsibilities that are fulfilled by a person or an organization unit.

For more information, see People (EAM) on page 13 or Organization Units (EAM) on page 12.

A role can be created in the following diagrams:

• Organization chart (see Organization Chart Basics on page 7)
• Business communication diagram (see Business Communication Diagram Basics on page 8)
• Service oriented diagram (see Service-Oriented Diagram Basics on page 25)
• Technology infrastructure diagram (see Building Technology Layer Diagrams on page 37)

Example

In this example, the Supplier role interacts with the Central Purchasing site:
Creating a Role
You can create a role in any of the following ways:

- Select Model > Roles to access the List of Roles, and click the Add a Row tool.
- Right-click the model or package in the Browser, and select New > Role.

For general information about creating objects, see the Objects chapter in the Core Features Guide.

Role Properties
To open a role property sheet and view or edit its properties, double-click its diagram symbol or its Browser entry.

The General Tab contains the following properties:

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Specifies the name of the item, which should be clear and meaningful, and should convey the item's purpose to non-technical users.</td>
</tr>
<tr>
<td>Code</td>
<td>Specifies the technical name of the object, which is used for generating code or scripts</td>
</tr>
<tr>
<td>Comment</td>
<td>Descriptive comment for the object.</td>
</tr>
<tr>
<td>Stereotype</td>
<td>Extends the semantics of an object derived from existing objects but specific to your needs.</td>
</tr>
</tbody>
</table>

Role Associations
Role associations are used to define links between objects and people, organization units, and roles. For example:

- A person may be defined as the administrator of a hardware server and the manager of a site
- An organization unit may be identified as being responsible for the Sales business function
- A role may be designated as the contact for the Madrid site

Creating a Role Association
You create a role association on the Role Associations tab of an object.

1. Open the property sheet of the object to which you want to connect a person, organization unit, or role, and click the Role Associations tab.
2. Click the Add Objects tool to open a selection box listing all the roles, people, and organization units available in the model.
3. Select the roles, people, and organization units that you want to associate with the object and click OK.
4. [optional] On the Role Associations tab, select or enter a type for each added role association.
5. Click OK to return to the diagram.
Architecture Areas (EAM)

An architecture area is an abstract object that can contain and group together other objects.

An architecture area can be created in the following diagrams:

- Business communication diagram (see Business Communication Diagram Basics on page 8)
- Process map (see Process Map Basics on page 9)
- City planning diagram (see City Planning Diagram Basics on page 10)
- Application architecture diagram (see Application Architecture Diagram Basics on page 23)
- Service oriented diagram (see Service-Oriented Diagram Basics on page 25)
- Technology infrastructure diagram (see Building Technology Layer Diagrams on page 37)

Example

In this example, the Supply chain management area contains the Supplier management and Inventory control areas:

Creating an Architecture Area

You can create an architecture area in any of the following ways:

- Use the Architecture Area tool in the diagram Palette
- Select Model > Architecture Areas to access the List of Architecture Areas, and click the Add a Row tool.
- Right-click the model or package in the Browser, and select New > Architecture Area.

For general information about creating objects, see the Objects chapter in the Core Features Guide.

Architecture Area Properties

To open an architecture area property sheet and view or edit its properties, double-click its diagram symbol or its Browser entry.

The General Tab contains the following properties:

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Specifies the name of the item, which should be clear and meaningful, and should convey the item's purpose to non-technical users.</td>
</tr>
<tr>
<td>Code</td>
<td>Specifies the technical name of the object, which is used for generating code or scripts</td>
</tr>
<tr>
<td>Comment</td>
<td>Descriptive comment for the object.</td>
</tr>
<tr>
<td>Stereotype</td>
<td>Extends the semantics of an object derived from existing objects but specific to your needs.</td>
</tr>
</tbody>
</table>

The following tabs are also available:
• Role Associations - lists the organization units, people, and roles associated with the area, and the type of role they play in relation to it (see Role Associations on page 15).
• Attached Objects – lists the objects that are contained within this area.
• Sub-Areas – lists the architecture areas contained within this area.

Sites (EAM)

A site is a physical location that can contain and group people, organizations and other objects.

A site can be created in the following diagrams:

• Business communication diagram (see Business Communication Diagram Basics on page 8)
• Application architecture diagram (see Application Architecture Diagram Basics on page 23)
• Technology infrastructure diagram (see Building Technology Layer Diagrams on page 37)

Example

In this example, the Central and Manufacturing sites interact:

Creating a Site

You can create a site in any of the following ways:

• Use the Site tool in the diagram Palette.
• Select Model > Sites to access the List of Sites, and click the Add a Row tool.
• Right-click the model or package in the Browser, and select New > Site.

For general information about creating objects, see the Objects chapter in the Core Features Guide.

Site Properties

To open a site property sheet and view or edit its properties, double-click its diagram symbol or its Browser entry.

The General Tab contains the following properties:

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Specifies the name of the item, which should be clear and meaningful, and should convey the item's purpose to non-technical users.</td>
</tr>
<tr>
<td>Code</td>
<td>Specifies the technical name of the object, which is used for generating code or scripts</td>
</tr>
<tr>
<td>Comment</td>
<td>Descriptive comment for the object.</td>
</tr>
</tbody>
</table>
### Property Description

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Stereotype</td>
<td>Extends the semantics of an object derived from existing objects but specific to your needs.</td>
</tr>
<tr>
<td>Address</td>
<td>Specifies the street address of the site.</td>
</tr>
<tr>
<td>Zip</td>
<td>Specifies the zip code of the site.</td>
</tr>
<tr>
<td>City</td>
<td>Specifies the city where the site is located.</td>
</tr>
<tr>
<td>Country</td>
<td>Specifies the country where the site is located.</td>
</tr>
<tr>
<td>Phone</td>
<td>Specifies the telephone number of the site.</td>
</tr>
<tr>
<td>Population</td>
<td>Specifies the number of people at the site.</td>
</tr>
</tbody>
</table>

The following tabs are also available:

- Role Associations – lists the organization units, people, and roles associated with the site, and the type of role they play in relation to it (see Role Associations on page 15).
- Sub-Sites – lists the sites contained within the site.

### Business Functions (EAM)

A business function is an aggregation of related processes and sub-functions.

A business function can be created in the following diagrams:

- Business communication diagram (see Business Communication Diagram Basics on page 8)
- Process map (see Process Map Basics on page 9)
- City planning diagram (see City Planning Diagram Basics on page 10)

#### Example

In this example, the Indirect sales function contains the Contact partner and Organize event processes:

![Example Diagram]

#### Creating a Business Function

You can create a business function in any of the following ways:

- Use the Business Function tool in the diagram Palette.
- Select Model > Business Functions to access the List of Business Functions, and click the Add a Row tool.
- Right-click the model or package in the Browser, and select New > Business Function.

For general information about creating objects, see the Objects chapter in the Core Features Guide.

### Business Function Properties

To open a business function property sheet and view or edit its properties, double-click its diagram symbol or its Browser entry.

The General Tab contains the following properties:
<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Specifies the name of the item, which should be clear and meaningful, and should convey the item's purpose to non-technical users.</td>
</tr>
<tr>
<td>Code</td>
<td>Specifies the technical name of the object, which is used for generating code or scripts</td>
</tr>
<tr>
<td>Comment</td>
<td>Descriptive comment for the object.</td>
</tr>
<tr>
<td>Stereotype</td>
<td>Extends the semantics of an object derived from existing objects but specific to your needs.</td>
</tr>
</tbody>
</table>

The following tabs are also available:

- Role Associations – lists the organization units, people, and roles associated with the function, and the type of role they play in relation to it (see Role Associations on page 15).
- Sub-Functions – lists the business functions contained within the function.
- Processes – lists the processes (see Processes (EAM) on page 19) associated with the function.
- Sites – lists the sites (see Sites (EAM) on page 17) associated with the function.

**Processes (EAM)**

A process is an ordering of tasks or activities that may include manual and/or automated operations. Processes can be triggered by events, by initiatives, or by conditions.

A process can be created in the following diagrams:

- Business communication diagram (see Business Communication Diagram Basics on page 8)
- Process map (see Process Map Basics on page 9)
- Service oriented diagram (see Service-Oriented Diagram Basics on page 25)

**Example**

In this example, the Validate order process forms part of the Direct sales function:

![Diagram showing Direct sales and Validate order]

**Creating a Process**

You can create a process in any of the following ways:

- Use the Process tool in the diagram Palette.
- Select **Model > Processes** to access the List of Processes, and click the Add a Row tool.
- Right-click the model or package in the Browser, and select **New > Process**.

For general information about creating objects, see the Objects chapter in the Core Features Guide.

**Process Properties**

To open a process property sheet and view or edit its properties, double-click its diagram symbol or its Browser entry.

The General Tab contains the following properties:
<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Specifies the name of the item, which should be clear and meaningful, and should convey the item's purpose to non-technical users.</td>
</tr>
<tr>
<td>Code</td>
<td>Specifies the technical name of the object, which is used for generating code or scripts</td>
</tr>
<tr>
<td>Comment</td>
<td>Descriptive comment for the object.</td>
</tr>
<tr>
<td>Stereotype</td>
<td>Extends the semantics of an object derived from existing objects but specific to your needs.</td>
</tr>
<tr>
<td>Reused process</td>
<td>Specifies the name of the reused process.</td>
</tr>
</tbody>
</table>

The following tabs are also available:

- Role Associations – lists the organization units, people, and roles associated with the process, and the type of role they play in relation to it (see Role Associations on page 15).

**Business Flows (EAM)**

A **business flow** is an oriented link that is used to connect objects and can contain documents.

A business flow can be created in the following diagrams:

- Business communication diagram (see Business Communication Diagram Basics on page 8)

**Example**

In this example the Price request flow goes from the Purchasing function to the Supplier role:

![Business Flow Diagram Example](image)

**Creating a Business Flow**

You can create a business flow in any of the following ways:

- Use the Business Flow tool in the diagram Palette.
- Select **Model > Business Flows** to access the List of Business Flows, and click the Add a Row tool.
- Right-click the model or package in the Browser, and select **New > Business Flow**.

For general information about creating objects, see the Objects chapter in the Core Features Guide.

**Business Flow Properties**

To open a business flow property sheet and view or edit its properties, double-click its diagram symbol or its Browser entry.

The General Tab contains the following properties:

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Specifies the name of the item, which should be clear and meaningful, and should convey the item's purpose to non-technical users.</td>
</tr>
<tr>
<td>Code</td>
<td>Specifies the technical name of the object, which is used for generating code or scripts</td>
</tr>
<tr>
<td>Property</td>
<td>Description</td>
</tr>
<tr>
<td>------------</td>
<td>---------------------------------------------------------------</td>
</tr>
<tr>
<td>Comment</td>
<td>Descriptive comment for the object.</td>
</tr>
<tr>
<td>Stereotype</td>
<td>Extends the semantics of an object derived from existing objects but specific to your needs.</td>
</tr>
<tr>
<td>First object</td>
<td>Specifies the object at the origin of the link.</td>
</tr>
<tr>
<td>Second object</td>
<td>Specifies the object at the end of the link.</td>
</tr>
</tbody>
</table>

The following tabs are also available:

- **Documents** – lists the documents associated with the flow (see *Forms, Documents, and Reports (EAM)* on page 32).
- **Condition** – lets you specify a condition to be evaluated to determine if the flow will be triggered, as well as a short alias for the condition, which can be displayed on the flow symbol.
Building Application Layer Diagrams

Application layer diagrams allow you to model the architecture of your systems in order to identify your applications and their main components, and to analyze their interactions and how they implement business process and functions:

- Application Architecture Diagrams – organize applications as discrete, interconnected units (see Application Architecture Diagram Basics on page 23).
- Service Oriented Diagrams – organize applications in terms of SOA layers (see Service Oriented Diagram Basics on page 25).

Application Architecture Diagram Basics

An application architecture diagram provides a high-level graphical view of the application architecture, and helps you identify applications, sub-applications, components, databases, services, etc, and their interactions.

In the following example, interactions between the major order processing and inventory systems at the company's headquarters and manufacturing site are displayed:

Application Architecture Diagram Objects

You can create the following objects in an application architecture diagram:

<table>
<thead>
<tr>
<th>Object</th>
<th>Tool</th>
<th>Symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Architecture Area</td>
<td></td>
<td><img src="" alt="Zone.png" /></td>
<td>An abstract object for grouping other objects. See Architecture Areas (EAM) on page 16.</td>
</tr>
</tbody>
</table>
Building Application Layer Diagrams

<table>
<thead>
<tr>
<th>Object</th>
<th>Tool</th>
<th>Symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Site</td>
<td>🏢</td>
<td>🏢</td>
<td>A physical location. See Sites (EAM) on page 17.</td>
</tr>
<tr>
<td>Application Service</td>
<td>🏢</td>
<td>🏢</td>
<td>An externally visible unit of functionality. See Application and Business Services (EAM) on page 27.</td>
</tr>
<tr>
<td>Component</td>
<td>📦</td>
<td>📦</td>
<td>A replaceable part of an application. See Components (EAM) on page 31.</td>
</tr>
<tr>
<td>Form</td>
<td>📦</td>
<td>📦</td>
<td>A UI component. See Forms, Documents, and Reports (EAM) on page 32.</td>
</tr>
<tr>
<td>Document</td>
<td>📦</td>
<td>📦</td>
<td>Any conceptual document. See Forms, Documents, and Reports (EAM) on page 32.</td>
</tr>
<tr>
<td>ETL Job</td>
<td>📦</td>
<td>📦</td>
<td>An ETL job. See ETL Jobs (EAM) on page 34.</td>
</tr>
<tr>
<td>Application Link</td>
<td>🔄</td>
<td>🔄</td>
<td>A link between elements in an application layer diagram. See Application Links (EAM) on page 35.</td>
</tr>
</tbody>
</table>

**Note:** Most EAM objects can be displayed as icons or as boxes that can display additional properties and sub-objects. You can toggle between the Icon and Detail modes via the contextual menu, or by pressing CTRL+Q. You can control the default mode, and the information displayed in each mode through the options available by selecting **Tools > Display Preferences**.

### Creating an Application Architecture Diagram

You can create an application architecture diagram in an existing EAM in any of the following ways:

- Right-click the model in the Browser and select **New > Application Architecture Diagram**.
- Right-click the background of any diagram and select **Diagram > New Diagram > Application Architecture Diagram**.

To create a new EAM with an application architecture diagram, select **File > New Model**, choose to create an enterprise architecture model from the Model type list, choose **Application Architecture Diagram** as the first diagram, and click **OK**.
Service-Oriented Diagram Basics

A service-oriented diagram provides a graphical view of your business and application services and the relationships between them, and helps you associate applications and other application layer objects with business services and processes to assist with SOA design.

In the following example, the Open Account and Order-to-cash business services are shown in relation to the application services, applications, and technologies that implement them:

Service-oriented Diagram Objects

You can create the following objects in a service-oriented diagram:
<table>
<thead>
<tr>
<th>Object</th>
<th>Tool</th>
<th>Symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Architecture Area</td>
<td></td>
<td><img src="image" alt="Zone" /></td>
<td>An abstract object for grouping other objects. See Architecture Areas (EAM) on page 16.</td>
</tr>
<tr>
<td>Role</td>
<td></td>
<td><img src="image" alt="Role" /></td>
<td>A set of responsibilities. See Roles (EAM) on page 14.</td>
</tr>
<tr>
<td>Process</td>
<td></td>
<td><img src="image" alt="Process" /></td>
<td>An ordering of tasks. See Processes (EAM) on page 19.</td>
</tr>
<tr>
<td>Application Service</td>
<td></td>
<td><img src="image" alt="Application Service" /></td>
<td>An externally visible unit of functionality. See Application and Business Services (EAM) on page 27.</td>
</tr>
<tr>
<td>Business Service</td>
<td></td>
<td><img src="image" alt="Business Service" /></td>
<td>A service offered by an organization. See Application and Business Services (EAM) on page 27.</td>
</tr>
<tr>
<td>System</td>
<td></td>
<td><img src="image" alt="System" /></td>
<td>A packaged application. See Systems, Applications, and Databases (EAM) on page 29.</td>
</tr>
<tr>
<td>Application</td>
<td></td>
<td><img src="image" alt="Application" /></td>
<td>A computer program. See Systems, Applications, and Databases (EAM) on page 29.</td>
</tr>
<tr>
<td>Database</td>
<td></td>
<td><img src="image" alt="Database" /></td>
<td>A database. See Systems, Applications, and Databases (EAM) on page 29.</td>
</tr>
<tr>
<td>Component</td>
<td></td>
<td><img src="image" alt="Component" /></td>
<td>A replaceable part of an application. See Components (EAM) on page 31.</td>
</tr>
<tr>
<td>Contract</td>
<td></td>
<td><img src="image" alt="Contract" /></td>
<td>An agreement between services. See Contracts (EAM) on page 36.</td>
</tr>
<tr>
<td>Application Link</td>
<td></td>
<td><img src="image" alt="Application Link" /></td>
<td>A link between elements in an application layer diagram. See Application Links (EAM) on page 35.</td>
</tr>
</tbody>
</table>

**Note:** Most EAM objects can be displayed as icons or as boxes that can display additional properties and sub-objects. You can toggle between the Icon and Detail modes via the contextual menu, or by pressing CTRL+Q. You can control the default mode, and the information displayed in each mode through the options available by selecting **Tools > Display Preferences**.

### Creating a Service-oriented Diagram

You can create a service-oriented diagram in an existing EAM in any of the following ways:

- Right-click the model in the Browser and select **New > Service-Oriented Diagram**.
- Right-click the background of any diagram and select **Diagram > New Diagram > Service-Oriented Diagram**.

To create a new EAM with a service-oriented diagram, select **File > New Model**, choose to create an enterprise architecture model from the Model type list, choose **Service-Oriented Diagram** as the first diagram, and click **OK**.
Application and Business Services (EAM)

An application service is an externally visible unit of functionality, provided by one or more applications or components, and exposed through well-defined interfaces.

An application service can be created in the following diagrams:

- Application architecture diagram (see Application Architecture Diagram Basics on page 23)
- Service-oriented diagram (see Service Oriented Diagram Basics on page 25)
- City planning diagram (see City Planning Diagram Basics on page 10)

A business service is a service offered by an organization to its customers that directly supports the work performed in a business process or function, exposed by an application-to-business interface.

A business service can be created in the following diagrams:

- Service-oriented diagram (see Service Oriented Diagram Basics on page 25)

Example

In this example the Register sales business service is implemented by the Finance Service application service:

Creating an Application or Business Service

You can create an application or business service in any of the following ways:

- Use the Application or Business Service tool in the diagram Palette.
- Select Model > Application Services or Business Services to access the appropriate list of services, and click the Add a Row tool.
- Right-click the model or package in the Browser, and select New > Application Service or Business Service.

For general information about creating objects, see the Objects chapter in the Core Features Guide.

Application and Business Service Properties

To open an application or business service property sheet and view or edit its properties, double-click its diagram symbol or its Browser entry.

The General Tab contains the following properties:

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Specifies the name of the item, which should be clear and meaningful, and should convey the item's purpose to non-technical users.</td>
</tr>
<tr>
<td>Property</td>
<td>Description</td>
</tr>
<tr>
<td>------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Code</td>
<td>Specifies the technical name of the object, which is used for generating code or scripts</td>
</tr>
<tr>
<td>Comment</td>
<td>Descriptive comment for the object.</td>
</tr>
<tr>
<td>Stereotype</td>
<td>Extends the semantics of an object derived from existing objects but specific to your needs.</td>
</tr>
<tr>
<td>Type</td>
<td>Specifies the type of service.</td>
</tr>
<tr>
<td></td>
<td>For business services, you can choose between:</td>
</tr>
<tr>
<td></td>
<td>• Consulting</td>
</tr>
<tr>
<td></td>
<td>• Customer Service</td>
</tr>
<tr>
<td></td>
<td>• Distribution Service</td>
</tr>
<tr>
<td></td>
<td>• Marketing Service</td>
</tr>
<tr>
<td></td>
<td>• Personal Service</td>
</tr>
<tr>
<td></td>
<td>• Sales Service</td>
</tr>
<tr>
<td></td>
<td>For application services, you can choose between:</td>
</tr>
<tr>
<td></td>
<td>• Business Process</td>
</tr>
<tr>
<td></td>
<td>• Collaboration</td>
</tr>
<tr>
<td></td>
<td>• Data</td>
</tr>
<tr>
<td></td>
<td>• Infrastructure</td>
</tr>
<tr>
<td></td>
<td>• Integration</td>
</tr>
<tr>
<td></td>
<td>• Presentation</td>
</tr>
<tr>
<td>Quality of Service Level</td>
<td>Specifies the quality of the service. You can choose between:</td>
</tr>
<tr>
<td></td>
<td>• Best effort service</td>
</tr>
<tr>
<td></td>
<td>• Differentiated service</td>
</tr>
<tr>
<td></td>
<td>• Guaranteed service</td>
</tr>
<tr>
<td>Security Level</td>
<td>Specifies the security of the service. You can choose between:</td>
</tr>
<tr>
<td></td>
<td>• High</td>
</tr>
<tr>
<td></td>
<td>• Moderate</td>
</tr>
<tr>
<td></td>
<td>• Low</td>
</tr>
</tbody>
</table>

The following tabs are also available:

- Role associations – lists the organization units, people, and roles associated with the service, and the type of role they play in relation to it (see Role Associations on page 15).
- Operations – lists the operations (see Operations on page 28) that support the service.

**Creating Business and Application Service Operations**

An operation is an abstract description of an action supported by a service. For example the Login service may require a Get ID operation.

You can create an operation by using the Add a Row tool on the Operations tab of a business or application service.

For general information about creating objects, see the Objects chapter in the Core Features Guide.

**Operation Properties**

To open an operation property sheet and view or edit its properties, double-click its Browser entry or its entry on the Operations tab of a business or application service.

The General Tab contains the following properties:
<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Parent</td>
<td>Specifies the service to which the operation belongs.</td>
</tr>
<tr>
<td>Name</td>
<td>Specifies the name of the item, which should be clear and meaningful, and should convey the item's purpose to non-technical users.</td>
</tr>
<tr>
<td>Code</td>
<td>Specifies the technical name of the object, which is used for generating code or scripts</td>
</tr>
<tr>
<td>Comment</td>
<td>Descriptive comment for the object.</td>
</tr>
<tr>
<td>Stereotype</td>
<td>Extends the semantics of an object derived from existing objects but specific to your needs.</td>
</tr>
<tr>
<td>Operation type</td>
<td>Specifies the type of the operation. You can choose between:</td>
</tr>
<tr>
<td></td>
<td>• Notification</td>
</tr>
<tr>
<td></td>
<td>• One-way</td>
</tr>
<tr>
<td></td>
<td>• Request-Response</td>
</tr>
<tr>
<td></td>
<td>• Solicit-Response</td>
</tr>
<tr>
<td>Input</td>
<td>Specifies the document or data required to start the service (see <em>Forms, Documents, and Reports (EAM)</em> on page 32)</td>
</tr>
<tr>
<td>Output</td>
<td>Specifies the document or data returned by the service (see <em>Forms, Documents, and Reports (EAM)</em> on page 32)</td>
</tr>
</tbody>
</table>

**Systems, Applications, and Databases (EAM)**

A System is a packaged application that can contain sub systems, applications, services and other application elements.

An application is a computer program, a collection of data groups (databases and/or parts of databases) and program modules (components, database management systems, utilities, interactive modules, and system modules), which implements a business function.

A database is a representation of an installed database.

These objects can be created in the following diagrams:

- City planning diagram (see *City Planning Diagram Basics* on page 10)
- Application architecture diagram (see *Application Architecture Diagram Basics* on page 23)
- Service-oriented diagram (see *Service Oriented Diagram Basics* on page 25)

**Example**

In this example, the Inventory system contains the Stock Management application and the Stock database:

![Example Diagram]

**Creating a System, Application, or Database**

You can create a system, application, or database in any of the following ways:
• Use the appropriate tool in the diagram Palette.
• Select Model > Systems, Applications, or Databases to access the appropriate object list, and click the Add a Row tool.
• Right-click the model or package in the Browser, and select New > System, Application, or Database.

For general information about creating objects, see the Objects chapter in the Core Features Guide.

System, Application, and Database Properties

To open a system, application, or database property sheet and view or edit its properties, double-click its diagram symbol or its Browser entry.

The General Tab contains the following properties:

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Specifies the name of the item, which should be clear and meaningful, and should convey the item’s purpose to non-technical users.</td>
</tr>
<tr>
<td>Code</td>
<td>Specifies the technical name of the object, which is used for generating code or scripts</td>
</tr>
<tr>
<td>Comment</td>
<td>Descriptive comment for the object.</td>
</tr>
<tr>
<td>Stereotype</td>
<td>Extends the semantics of an object derived from existing objects but specific to your needs.</td>
</tr>
<tr>
<td>Type</td>
<td>[application and database only] Specifies the type of application or database. For applications, you can choose between: Web, Rich Client, Office, Tool, CRM, ERP. For databases, you can choose between: Data Warehouse, Data Mart, Multi-Dimensional Data Warehouse, OLTP Database, Virtual Database.</td>
</tr>
<tr>
<td>DBMS</td>
<td>[database only] Specifies the DBMS of the database.</td>
</tr>
</tbody>
</table>

The following tabs are also available:
• Detail – [application only] records the programming language, version, etc, for the application.
• Role Associations – lists the people, organization units, and roles associated with the application or system, and the type of role they play in relation to it (see Role Associations on page 15).
• Source Models – [database only] lists the data models associated with the database. For more information about data models, see Data Modeling.
• Applications – [application and system only] lists the applications associated with the application or system.
• Components – [application and system only] lists the components (see Components (EAM) on page 31) associated with the application or system.
• Forms – [application and system only] lists the forms (see Forms, Documents, and Reports (EAM) on page 32) associated with the application or system.
• Sites – lists the sites associated with the application or system (see Sites (EAM) on page 17).
Components (EAM)

A component is an encapsulated, reusable, and replaceable part of an application, which can be used to implement a service or an application.

A component can be created in the following diagrams:

- Application architecture diagram (see Application Architecture Diagram Basics on page 23)
- Service-oriented diagram (see Service Oriented Diagram Basics on page 25)

Example

In this example, the Inventory Management system contains the Check Inventory component:

Creating a Component

You can create a component in any of the following ways:

- Use the Component tool in the diagram Palette.
- Select Model > Components to access the List of Components, and click the Add a Row tool.
- Right-click the model or package in the Browser, and select New > Component.

For general information about creating objects, see the Objects chapter in the Core Features Guide.

Component Properties

To open a component property sheet and view or edit its properties, double-click its diagram symbol or its Browser entry.

The General Tab contains the following properties:

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Specifies the name of the item, which should be clear and meaningful, and should convey the item's purpose to non-technical users.</td>
</tr>
<tr>
<td>Code</td>
<td>Specifies the technical name of the object, which is used for generating code or scripts</td>
</tr>
<tr>
<td>Property</td>
<td>Description</td>
</tr>
<tr>
<td>------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Comment</td>
<td>Descriptive comment for the object.</td>
</tr>
<tr>
<td>Stereotype</td>
<td>Extends the semantics of an object derived from existing objects but specific to your needs.</td>
</tr>
<tr>
<td>Programming Lan-</td>
<td>Specifies the programming language in which the component is written.</td>
</tr>
<tr>
<td>guage</td>
<td></td>
</tr>
<tr>
<td>Type</td>
<td>Specifies the type of the component. You can choose between:</td>
</tr>
<tr>
<td></td>
<td>• EJB</td>
</tr>
<tr>
<td></td>
<td>• Servlet</td>
</tr>
<tr>
<td></td>
<td>• Presentation</td>
</tr>
<tr>
<td></td>
<td>• DataAccess</td>
</tr>
<tr>
<td></td>
<td>• Controller</td>
</tr>
<tr>
<td></td>
<td>• COM</td>
</tr>
<tr>
<td></td>
<td>• ActiveX</td>
</tr>
</tbody>
</table>

### Forms, Documents, and Reports (EAM)

A form represents a UI component of an application.

A document represents any conceptual document used in the enterprise.

A report represents any report used in the enterprise.

These objects can be created in the following diagrams:

- Application architecture diagram (see *Application Architecture Diagram Basics* on page 23)

### Example

In this example the HR system contains the Employee Absence report, the Vacation form, and the Health and Safety Guidelines document:

![Diagram of HR system with Employee Absence, Vacation, and Health and Safety Guidelines objects]

### Creating a Form, Document, or Report

You can create a form, document, or report in any of the following ways:

- Use the appropriate tool in the diagram Palette.
- Select **Model > Forms, Documents, or Reports** to access the appropriate object list, and click the Add a Row tool.
- Right-click the model or package in the Browser, and select **New > Form, Document, or Report**.

For general information about creating objects, see the Objects chapter in the *Core Features Guide*.

### Form, Document, and Report Properties

To open a form, document, or report property sheet and view or edit its properties, double-click its diagram symbol or its Browser entry.
The General Tab contains the following properties:

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Specifies the name of the item, which should be clear and meaningful, and should convey the item's purpose to non-technical users.</td>
</tr>
<tr>
<td>Code</td>
<td>Specifies the technical name of the object, which is used for generating code or scripts</td>
</tr>
<tr>
<td>Comment</td>
<td>Descriptive comment for the object.</td>
</tr>
<tr>
<td>Stereotype</td>
<td>Extends the semantics of an object derived from existing objects but specific to your needs.</td>
</tr>
<tr>
<td>Type</td>
<td>Specifies the type of the document, form, or report.</td>
</tr>
<tr>
<td>Version</td>
<td>[document only] Specifies the version number of the document.</td>
</tr>
</tbody>
</table>
| Category | [report only] Specifies the category of the report. You can choose between:  
  • Business  
  • Specification  
  • Strategic  
  • Technical |
| Period   | [report only] Specifies the frequency with which the report is generated. You can choose between:  
  • Daily  
  • Weekly  
  • Monthly  
  • Yearly |
| Style    | [form only] Specifies the style of the form. |
| Document Format | [document only] Lists the XML models that are used to represent the structure of the document. For more information about XML models, see the XML Modeling guide. |

The following tabs are also available:

- Data – [report and document only] lists the data (see Data on page 33) associated with the document.

**Creating Document Data**

Data objects are pieces of information that can be assigned to reports and documents.

You can create a data object by using the Add a Row tool on the Data tab of a report or document.

For general information about creating objects, see the Objects chapter in the Core Features Guide.

**Data Properties**

To open a data property sheet and view or edit its properties, double-click its Browser entry.

The General Tab contains the following properties:

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Specifies the name of the item, which should be clear and meaningful, and should convey the item's purpose to non-technical users.</td>
</tr>
<tr>
<td>Code</td>
<td>Specifies the technical name of the object, which is used for generating code or scripts</td>
</tr>
</tbody>
</table>
### ETL Jobs (EAM)

An ETL job represents a task in an ETL data transformation.

An ETL job can be created in the following diagrams:

- Application architecture diagram (see *Application Architecture Diagram Basics* on page 23)

### Example

In this example the Aggregate Sales ETL job aggregates the data from the Sales –Transactions database to the Sales –Warehouse database:

![Data Replication Diagram](image)

#### Creating an ETL Job

You can create an ETL job in any of the following ways:

- Use the ETL Job tool in the diagram Palette.
- Select **Model > ETL Jobs** to access the List of ETL Jobs, and click the Add a Row tool.
- Right-click the model or package in the Browser, and select **New > ETL Job**.

For general information about creating objects, see the Objects chapter in the *Core Features Guide*.

#### ETL Job Properties

To open an ETL job property sheet and view or edit its properties, double-click its diagram symbol or its Browser entry.

The General Tab contains the following properties:

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Specifies the name of the item, which should be clear and meaningful, and should convey the item's purpose to non-technical users.</td>
</tr>
<tr>
<td>Code</td>
<td>Specifies the technical name of the object, which is used for generating code or scripts.</td>
</tr>
<tr>
<td>Comment</td>
<td>Descriptive comment for the object.</td>
</tr>
<tr>
<td>Stereotype</td>
<td>Extends the semantics of an object derived from existing objects but specific to your needs.</td>
</tr>
</tbody>
</table>

The following tabs are also available:

- **Role Associations** – lists the people, organization units, and roles associated with the ETL job, and the type of role they play in relation to it (see *Role Associations* on page 15).
Application Links (EAM)

An application link is an oriented link that is used to connect objects in the application layer.

An application link can be created in the following diagrams:

- Application architecture diagram (see Application Architecture Diagram Basics on page 23)
- Service-oriented diagram (see Service Oriented Diagram Basics on page 25)

Example

In this example, the Create invoice component makes a request to the Invoice database:

Creating an Application Link

You can create an application link in any of the following ways:

- Use the Application Link tool in the diagram Palette.
- Select Model > Application Links to access the List of Application Links, and click the Add a Row tool.
- Right-click the model or package in the Browser, and select New > Application Link.

For general information about creating objects, see the Objects chapter in the Core Features Guide.

Application Link Properties

To open an application link property sheet and view or edit its properties, double-click its diagram symbol or its Browser entry.

The General Tab contains the following properties:

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Specifies the name of the item, which should be clear and meaningful, and should convey the item’s purpose to non-technical users.</td>
</tr>
<tr>
<td>Code</td>
<td>Specifies the technical name of the object, which is used for generating code or scripts.</td>
</tr>
<tr>
<td>Comment</td>
<td>Descriptive comment for the object.</td>
</tr>
<tr>
<td>Stereotype</td>
<td>Extends the semantics of an object derived from existing objects but specific to your needs.</td>
</tr>
<tr>
<td>First object</td>
<td>Specifies the object at the origin of the link.</td>
</tr>
<tr>
<td>Second object</td>
<td>Specifies the object at the end of the link.</td>
</tr>
</tbody>
</table>
### Contracts (EAM)

A contract is an agreement between services.

A contract can be created in the following diagrams:

- Service-oriented diagram (see *Service Oriented Diagram Basics* on page 25)

#### Example

In this example, the contract defines acceptable response times for the link between the business and application login services:

![Contract Diagram](image)

#### Creating a Contract

You can create a contract in any of the following ways:

- Use the Contract tool in the diagram Palette.
- Select **Model > Contracts** to access the List of Contracts, and click the Add a Row tool.
- Right-click the model or package in the Browser, and select **New > Contract**.

For general information about creating objects, see the Objects chapter in the *Core Features Guide*.

#### Contract Properties

To open a contract property sheet and view or edit its properties, double-click its diagram symbol or its Browser entry.

The General Tab contains the following properties:

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Specifies the name of the item, which should be clear and meaningful, and should convey the item's purpose to non-technical users.</td>
</tr>
<tr>
<td>Code</td>
<td>Specifies the technical name of the object, which is used for generating code or scripts</td>
</tr>
<tr>
<td>Comment</td>
<td>Descriptive comment for the object.</td>
</tr>
<tr>
<td>Stereotype</td>
<td>Extends the semantics of an object derived from existing objects but specific to your needs.</td>
</tr>
</tbody>
</table>

The following tabs are also available:

- Role Associations – lists the people, organization units, and roles associated with the contract, and the type of role they play in relation to it (see *Role Associations* on page 15).
- Documents – lists the documents (see *Forms, Documents, and Reports (EAM)* on page 32) associated with the contract.
- XML Models – lists the XML Models that are used to define the contract. For more information about XSMs, see the *XML Modeling* guide.
Building Technology Layer Diagrams

A technology infrastructure diagram provides a high-level graphical view of the physical architecture required to support the application architecture.

A technology infrastructure diagram is the sole diagram in the technology layer.

In the following example, the deployment of servers within the company network is shown, along with the web access afforded to thin clients:

Technology Infrastructure Diagram Objects

You can create the following objects in a technology infrastructure diagram:

<table>
<thead>
<tr>
<th>Object</th>
<th>Tool</th>
<th>Symbol</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Architecture Area</td>
<td>![Architecture Area icon]</td>
<td>![Architecture Area symbol]</td>
<td>An abstract object for grouping other objects. See Architecture Areas (EAM) on page 16.</td>
</tr>
<tr>
<td>Site</td>
<td>![Site icon]</td>
<td>![Site symbol]</td>
<td>A physical location. See Sites (EAM) on page 17.</td>
</tr>
</tbody>
</table>
### Object | Tool | Symbol | Description
--- | --- | --- | ---
Organization Unit | | | A group, department, function, or other collection of people or organization units. See Organization Units (EAM) on page 12.
Person | | | An individual. See People (EAM) on page 13.
Role | | | A set of responsibilities. See Roles (EAM) on page 14.
Network | | | Any kind of network. See Networks (EAM) on page 39.
Software Server | | | A commercial software environment. See Servers, Workstations, Mobile Devices, and Network Nodes (EAM) on page 40.
Network Node | | | Can represent various kinds of network components. See Servers, Workstations, Mobile Devices, and Network Nodes (EAM) on page 40.
Deployment Instance | | | An instance of an object defined elsewhere. See Deployment Instances (EAM) on page 41.
Infrastructure Link | | | A link between elements in a technology layer diagram. See Infrastructure Links (EAM) on page 42.

**Note:** Most EAM objects can be displayed as icons or as boxes that can display additional properties and sub-objects. You can toggle between the Icon and Detail modes via the contextual menu, or by pressing CTRL+Q. You can control the default mode, and the information displayed in each mode through the options available by selecting **Tools > Display Preferences**.

### Creating a Technology Infrastructure Diagram

You can create a technology infrastructure diagram in an existing EAM in any of the following ways:

- Right-click the model in the Browser and select **New > Technology Infrastructure Diagram**.
- Right-click the background of any diagram and select **Diagram > New Diagram > Technology Infrastructure Diagram**.
To create a new EAM with a technology infrastructure diagram, select **File > New Model**, choose to create an enterprise architecture diagram from the Model type list, choose **Technology Infrastructure Diagram** as the first diagram, and click **OK**.

**Networks (EAM)**

A network allows computers to communicate with each other either locally or over large distances via telecommunication.

A network can be created in the following diagrams:

- Technology infrastructure diagram (see *Technology Infrastructure Diagram Basics* on page 37)

**Example**

In this example, the client communicates with the server via an intranet:

![Network Diagram Example](image)

**Creating a Network**

You can create a network in any of the following ways:

- Use the Network tool in the diagram Palette.
- Select **Model > Networks** to access the List of Networks, and click the Add a Row tool.
- Right-click the model or package in the Browser, and select **New > Network**.

For general information about creating objects, see the Objects chapter in the *Core Features Guide*.

**Network Properties**

To open a network property sheet and view or edit its properties, double-click its diagram symbol or its Browser entry.

The General Tab contains the following properties:

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Specifies the name of the item, which should be clear and meaningful, and should convey the item's purpose to non-technical users.</td>
</tr>
<tr>
<td>Code</td>
<td>Specifies the technical name of the object, which is used for generating code or scripts</td>
</tr>
<tr>
<td>Comment</td>
<td>Descriptive comment for the object.</td>
</tr>
<tr>
<td>Stereotype</td>
<td>Extends the semantics of an object derived from existing objects but specific to your needs.</td>
</tr>
<tr>
<td>Type</td>
<td>Specifies the type of the network.</td>
</tr>
<tr>
<td>Site</td>
<td>Specifies the site within which the network is located.</td>
</tr>
</tbody>
</table>

The following tabs are also available:

- Role Associations – lists the people, organization units, and roles associated with the object (see *Role Associations* on page 15).
Servers, Workstations, Mobile Devices, and Network Nodes (EAM)

A software server is a commercial software environment, which contains a set of applications. A software server can be deployed on a hardware server.

A hardware server is a device that serves data or other support for devices on the network. It usually has higher specifications than client devices, such as workstations or mobile devices.

A workstation is a client machine to which an application or a server can be deployed.

A mobile device is designed to be easy to carry and used remotely to access the network.

Network nodes can represent other type of objects connected to the network (routers, switches, firewalls, modems, printers, faxes, etc).

These objects can be created in the following diagrams:

- Technology infrastructure diagram (see Technology Infrastructure Diagram Basics on page 37)

Example

In this example, the field workstation and smartphone connect via the web to the server, which is also connected to a network node of type printer:

Creating a Software or Hardware Server, Workstation, Mobile Device, or Network Node

You can create these objects in any of the following ways:

- Use the appropriate tool in the diagram Palette.
- Select Model > Objects to access the appropriate object list, and click the Add a Row tool.
- Right-click the model or package in the Browser, and select New > Object.

For general information about creating objects, see the Objects chapter in the Core Features Guide.

Software and Hardware Server, Workstation, Mobile Device, and Network Node Properties

To open a software or hardware server, workstation, mobile device, or network node property sheet and view or edit its properties, double-click its diagram symbol or its Browser entry.

The General Tab contains the following properties:

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Specifies the name of the item, which should be clear and meaningful, and should convey the item's purpose to non-technical users.</td>
</tr>
<tr>
<td>Property</td>
<td>Description</td>
</tr>
<tr>
<td>------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Code</td>
<td>Specifies the technical name of the object, which is used for generating code or scripts.</td>
</tr>
<tr>
<td>Comment</td>
<td>Descriptive comment for the object.</td>
</tr>
<tr>
<td>Type</td>
<td>Specifies the type of the object.</td>
</tr>
<tr>
<td>Site</td>
<td>Specifies the site to which the object is deployed.</td>
</tr>
<tr>
<td>Stereotype</td>
<td>Extends the semantics of an object derived from existing objects but specific to your needs.</td>
</tr>
<tr>
<td>Multiple</td>
<td>[hardware server, workstation and mobile device only] Specifies that the object represents multiple machines.</td>
</tr>
</tbody>
</table>

The following tabs are also available:

- **Detail** – contains information to identify the object in the environment.
- **Deployment Instances** – [not network node] lists the deployment instances (see Deployment Instances (EAM) on page 41) associated with the object.
- **Software Servers** – [workstation, hardware server, and mobile device only] lists the software servers associated with the object.
- **Role Associations** – lists the people, organization units, and roles associated with the object (see Role Associations on page 15).

### Deployment Instances (EAM)

A deployment instance is an instance of another object that is deployed on a server or elsewhere in the environment.

A deployment instance can be created in the following diagrams:

- Technology infrastructure diagram (see Technology Infrastructure Diagram Basics on page 37)

**Example**

In this example, an instance of the Suppliers database is stored on the Failover server:

![Database Instance](image)

**Creating a Deployment Instance**

You can create a deployment instance in any of the following ways:

- Open the property sheet of the object to deploy and use the Add a Row tool on its Deployment Instances tab.
- Use the Deployment Instance tool in the diagram Palette.
- Select **Model > Deployment Instances** to access the List of Deployment Instances, and click the Add a Row tool.
- Right-click the model or package in the Browser, and select **New > Deployment Instance**.

**Note:** In all but the first method above, you must specify the object of which you are creating an instance, by opening the deployment instance property sheet and specifying the object of which it is an instance in the Deployed object field.

For general information about creating objects, see the Objects chapter in the Core Features Guide.
**Deployment Instance Properties**

To open a deployment instance property sheet and view or edit its properties, double-click its diagram symbol or its Browser entry.

The General Tab contains the following properties:

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Specifies the name of the item, which should be clear and meaningful, and should convey the item’s purpose to non-technical users.</td>
</tr>
<tr>
<td>Code</td>
<td>Specifies the technical name of the object, which is used for generating code or scripts.</td>
</tr>
<tr>
<td>Comment</td>
<td>Descriptive comment for the object.</td>
</tr>
<tr>
<td>Stereotype</td>
<td>Extends the semantics of an object derived from existing objects but specific to your needs.</td>
</tr>
<tr>
<td>Type</td>
<td>Specifies the type of the deployment instance.</td>
</tr>
<tr>
<td>Deployed Object</td>
<td>Specifies the object being deployed. Click the buttons to the right of the field to create a new object, select an existing object, or to open the property sheet of the selected object.</td>
</tr>
</tbody>
</table>

**Infrastructure Links (EAM)**

An *infrastructure link* is an oriented link that is used to connect objects in the technology layer.

An infrastructure link can be created in the following diagrams:

* Technology infrastructure diagram (see *Technology Infrastructure Diagram Basics* on page 37)

**Example**

In this example, the Field Workstation accesses the internet:

![Example Diagram](image)

**Creating an Infrastructure Link**

You can create an infrastructure link in any of the following ways:

* Use the Infrastructure Link tool in the diagram Palette.
* Select **Model > Infrastructure Links** to access the List of Infrastructure Links, and click the Add a Row tool.
* Right-click the model or package in the Browser, and select **New > Infrastructure Links**.

For general information about creating objects, see the Objects chapter in the *Core Features Guide*.

**Infrastructure Link Properties**

To open an infrastructure link property sheet and view or edit its properties, double-click its diagram symbol or its Browser entry.

The General Tab contains the following properties:
<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Specifies the name of the item, which should be clear and meaningful, and should convey the item's purpose to non-technical users.</td>
</tr>
<tr>
<td>Code</td>
<td>Specifies the technical name of the object, which is used for generating code or scripts</td>
</tr>
<tr>
<td>Comment</td>
<td>Descriptive comment for the object.</td>
</tr>
<tr>
<td>Stereotype</td>
<td>Extends the semantics of an object derived from existing objects but specific to your needs.</td>
</tr>
<tr>
<td>First object</td>
<td>Specifies the object at the origin of the link.</td>
</tr>
<tr>
<td>Second object</td>
<td>Specifies the object at the end of the link.</td>
</tr>
<tr>
<td>Type</td>
<td>Specifies the type of the infrastructure link.</td>
</tr>
<tr>
<td>Protocol</td>
<td>Specifies the protocol of the infrastructure link.</td>
</tr>
<tr>
<td>Physical type</td>
<td>Specifies the physical type of the infrastructure link.</td>
</tr>
</tbody>
</table>
Building Technology Layer Diagrams
Working with Enterprise Architecture Models

Enterprise architecture models benefit from the powerful model tools available in the PowerDesigner enterprise modeling environment.

Customizing the Enterprise Architecture Modeling Environment

The PowerDesigner enterprise architecture modeling environment includes a set of parameters and configuration options that define various aspects of the model content and behavior. You can set these parameters:

- At model creation
- After creating a model with default options and parameters
- When creating a model template

Setting EAM Model Options

This section explains how to set global options for the objects in your EAM. These options apply only to the current EAM.

For information about controlling the naming conventions of your models, see "Naming Conventions" in the Customizing your Modeling Environment chapter of the Core Features Guide.

To set Model Settings, select Tools > Model Options or right-click the diagram background and select Model Options from the contextual menu.

The following options are available on this tab:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name/Code case sensitive</td>
<td>Specifies that the names and codes for all objects are case sensitive, allowing you to have two objects with identical names or codes but different cases in the same model. If you change case sensitivity during the design process, we recommend that you check your model to verify that your model does not contain any duplicate objects.</td>
</tr>
<tr>
<td>Enable links to requirements</td>
<td>Displays a Requirements tab in the property sheet of every object in the model, which allows you to attach requirements to objects in your model. These attached requirements are kept synchronized with your requirements model. For more information, see the Requirements Modeling guide.</td>
</tr>
</tbody>
</table>

Setting EAM Display Preferences

PowerDesigner display preferences allow you to customize the format of object symbols, and the information that is displayed on them.

To set EAM display preferences, select Tools > Display Preferences or right-click the diagram background and select Display Preferences from the contextual menu.

All EAM object symbols are fully customizable both in terms of their format and the information displayed upon them. For more information, see "Display Preferences" in the Customizing your Modeling Environment chapter of the Core Features Guide.

Generating an EAM from an EAM

You can generate another EAM from your EAM. When changes are made to the source model, they can be easily propagated to any generated models by regenerating, using the Update Existing Model generation mode.
1. Select **Tools > Generate Enterprise Architecture Model** to open the EAM Generation Options Window:

2. On the General tab, select to generate a new or update an existing model, and complete the appropriate options.

3. [optional] Click the Detail tab and set any appropriate options. We recommend that you select the Check model checkbox to check the model for errors and warnings before generation.

4. [optional] Click the Target Models tab and specify the target models for any generated shortcuts.

5. [optional] Click the Selection tab and select or deselect objects to generate.

6. Click OK to begin generation.

**Note:** For detailed information about the options available on the various tabs of the Generation window, see the Linking and Synchronizing Models chapter of the *Core Features Guide.*

### Checking an Enterprise Architecture Model

You can check the validity of your enterprise architecture model at any time in one of the following ways:

- Press F4, or
- Select **Tools > Check Model**, or
- Right-click the diagram background and select Check Model from the contextual menu.

#### Application, Application Service, Component and Database Checks

The following model checks are made on applications, application services, components, and databases:

<table>
<thead>
<tr>
<th>Check</th>
<th>Description and Correction</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name and code uniqueness</td>
<td>Names and codes must be unique in the model.</td>
</tr>
<tr>
<td></td>
<td>Manual correction: Modify the duplicate name/code.</td>
</tr>
<tr>
<td></td>
<td>Automatic correction: Appends a number to the duplicate name/code.</td>
</tr>
<tr>
<td>No deployment instance</td>
<td>The object must be deployed as at least one deployment instance.</td>
</tr>
<tr>
<td></td>
<td>Manual correction: Deploy the object as a deployment instance.</td>
</tr>
<tr>
<td></td>
<td>Automatic correction: None</td>
</tr>
</tbody>
</table>

#### Application Link Checks

The following model checks are made on application links:

<table>
<thead>
<tr>
<th>Check</th>
<th>Description and Correction</th>
</tr>
</thead>
<tbody>
<tr>
<td>Unsuitable application link type</td>
<td>The link type is not compatible with the link extremities. For example, if the link type is &quot;use&quot; the link must have a role player as one extremity.</td>
</tr>
<tr>
<td></td>
<td>Manual correction: Change the link type.</td>
</tr>
<tr>
<td></td>
<td>Automatic correction: Changes the link type.</td>
</tr>
</tbody>
</table>

#### Contract Checks

The following model checks are made on contracts:
### Check Description and Correction

<table>
<thead>
<tr>
<th>Check</th>
<th>Description and Correction</th>
</tr>
</thead>
<tbody>
<tr>
<td>Contract name and code uniqueness</td>
<td>Contract names and codes must be unique in the model. Manual correction: Modify the duplicate name/code. Automatic correction: Appends a number to the duplicate name/code.</td>
</tr>
<tr>
<td>Contracts are not correctly used</td>
<td>Contracts must have at least one incoming and one outgoing link with an application service, a business service, or a role. Manual correction: Create input and output links with the appropriate objects. Automatic correction: None</td>
</tr>
<tr>
<td>Multiple types of input</td>
<td>All input objects must be of the same type. Manual correction: Remove any input links that are not of the same type. Automatic correction: None</td>
</tr>
<tr>
<td>Same input and output link</td>
<td>Contracts cannot be the intermediary between the same service. Manual correction: Modify the input or output link. Automatic correction: None</td>
</tr>
</tbody>
</table>

### Deployment Instance Checks

The following model checks are made on deployment instances

<table>
<thead>
<tr>
<th>Check</th>
<th>Description and Correction</th>
</tr>
</thead>
<tbody>
<tr>
<td>Deployment instance name and code uniqueness</td>
<td>Deployment instance names and codes must be unique in the model. Manual correction: Modify the duplicate name/code. Automatic correction: Appends a number to the duplicate name/code.</td>
</tr>
<tr>
<td>Deployment Instance not deployed</td>
<td>Each deployment instance must be deployed to a platform or server. Manual correction: Deploy the deployment instance to the appropriate object. Automatic correction: None</td>
</tr>
<tr>
<td>No Object to Deploy</td>
<td>The deployment instance must be an instance of some object. Manual correction: Specify the object to be deployed in the deployment instance property sheet General tab. Automatic correction: None</td>
</tr>
<tr>
<td>Unsuitable Software Server</td>
<td>The deployment instance must be suitable for the server software type to which it is deployed. Manual correction: Modify the software server type or delete the deployment instance from the software server. Automatic correction: None</td>
</tr>
</tbody>
</table>

### Form Checks

The following model checks are made on forms:
<table>
<thead>
<tr>
<th>Check</th>
<th>Description and Correction</th>
</tr>
</thead>
<tbody>
<tr>
<td>Form name and code uniqueness</td>
<td>Form names and codes must be unique in the model.</td>
</tr>
<tr>
<td></td>
<td>Manual correction: Modify the duplicate name/code.</td>
</tr>
<tr>
<td></td>
<td>Automatic correction: Appends a number to the duplicate name/code.</td>
</tr>
<tr>
<td>No deployment instance</td>
<td>The object must be deployed as a deployment instance.</td>
</tr>
<tr>
<td></td>
<td>Manual correction: Deploy the object as a deployment instance.</td>
</tr>
<tr>
<td></td>
<td>Automatic correction: None</td>
</tr>
</tbody>
</table>

### Hardware Server, Mobile Device, Network Node and Workstation Checks

The following model checks are made on hardware servers, mobile devices, network nodes and workstations:

<table>
<thead>
<tr>
<th>Check</th>
<th>Description and Correction</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name and code uniqueness</td>
<td>Names and codes must be unique in the model.</td>
</tr>
<tr>
<td></td>
<td>Manual correction: Modify the duplicate name/code.</td>
</tr>
<tr>
<td></td>
<td>Automatic correction: Appends a number to the duplicate name/code.</td>
</tr>
<tr>
<td>Serial number uniqueness</td>
<td>Serial numbers must be unique in the model.</td>
</tr>
<tr>
<td></td>
<td>Manual correction: Modify the duplicate serial numbers.</td>
</tr>
<tr>
<td></td>
<td>Automatic correction: Appends a number to the duplicate serial numbers.</td>
</tr>
<tr>
<td>Asset number uniqueness</td>
<td>Asset numbers must be unique in the model.</td>
</tr>
<tr>
<td></td>
<td>Manual correction: Modify the duplicate asset numbers.</td>
</tr>
<tr>
<td></td>
<td>Automatic correction: Appends a number to the duplicate asset numbers.</td>
</tr>
<tr>
<td>Mac address uniqueness</td>
<td>Mac addresses must be unique in the model.</td>
</tr>
<tr>
<td></td>
<td>Manual correction: Modify the duplicate mac addresses.</td>
</tr>
<tr>
<td></td>
<td>Automatic correction: Appends a number to the duplicate mac addresses.</td>
</tr>
<tr>
<td>Isolated node</td>
<td>The object must be linked with at least one other node.</td>
</tr>
<tr>
<td></td>
<td>Manual correction: Link the object to an appropriate object.</td>
</tr>
<tr>
<td></td>
<td>Automatic correction: None</td>
</tr>
</tbody>
</table>

### Network Checks

The following model checks are made on networks:

<table>
<thead>
<tr>
<th>Check</th>
<th>Description and Correction</th>
</tr>
</thead>
<tbody>
<tr>
<td>Network name and code uniqueness</td>
<td>Network names and codes must be unique in the model.</td>
</tr>
<tr>
<td></td>
<td>Manual correction: Modify the duplicate name/code.</td>
</tr>
<tr>
<td></td>
<td>Automatic correction: Appends a number to the duplicate name/code.</td>
</tr>
<tr>
<td>Isolated node</td>
<td>The object must be linked with at least one other node.</td>
</tr>
<tr>
<td></td>
<td>Manual correction: Link the object to an appropriate object.</td>
</tr>
<tr>
<td></td>
<td>Automatic correction: None</td>
</tr>
</tbody>
</table>
**Organization Unit Checks**

The following model checks are made on organization units:

<table>
<thead>
<tr>
<th>Check</th>
<th>Description and Correction</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Organization Unit name and code uniqueness</strong></td>
<td>Organization Unit names and codes must be unique in the model.</td>
</tr>
<tr>
<td></td>
<td>Manual correction: Modify the duplicate name/code.</td>
</tr>
<tr>
<td></td>
<td>Automatic correction: Appends a number to the duplicate name/code.</td>
</tr>
<tr>
<td><strong>Manager must belong to the managed organization</strong></td>
<td>The manager specified in the Manager field must be listed in the People tab.</td>
</tr>
<tr>
<td></td>
<td>Manual correction: Add the manager to the list of people on the People tab.</td>
</tr>
<tr>
<td></td>
<td>Automatic correction: Adds the manager to the list of people.</td>
</tr>
</tbody>
</table>

**Person Checks**

The following model checks are made on people:

<table>
<thead>
<tr>
<th>Check</th>
<th>Description and Correction</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Person code uniqueness</strong></td>
<td>People codes must be unique in the model.</td>
</tr>
<tr>
<td></td>
<td>Manual correction: Modify the duplicate code.</td>
</tr>
<tr>
<td></td>
<td>Automatic correction: Appends a number to the duplicate code.</td>
</tr>
<tr>
<td><strong>No organization unit</strong></td>
<td>A person must belong to an organization unit.</td>
</tr>
<tr>
<td></td>
<td>Manual correction: Add the person to an organization unit.</td>
</tr>
<tr>
<td></td>
<td>Automatic correction: None</td>
</tr>
<tr>
<td><strong>Circular dependency through manager property</strong></td>
<td>A person cannot manage herself.</td>
</tr>
<tr>
<td></td>
<td>Manual correction: Remove the person from the Manager field of her own property sheet.</td>
</tr>
<tr>
<td></td>
<td>Automatic correction: None</td>
</tr>
</tbody>
</table>

**Software Server Checks**

The following model checks are made on software servers:

<table>
<thead>
<tr>
<th>Check</th>
<th>Description and Correction</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Software Server name and code uniqueness</strong></td>
<td>Software server names and codes must be unique in the model.</td>
</tr>
<tr>
<td></td>
<td>Manual correction: Modify the duplicate name/code.</td>
</tr>
<tr>
<td></td>
<td>Automatic correction: Appends a number to the duplicate name/code.</td>
</tr>
<tr>
<td><strong>Software Server not deployed</strong></td>
<td>A software server must be deployed to a physical server.</td>
</tr>
<tr>
<td></td>
<td>Manual correction: Deploy the software server in the appropriate object.</td>
</tr>
<tr>
<td></td>
<td>Automatic correction: None</td>
</tr>
<tr>
<td><strong>Software Server serial number uniqueness</strong></td>
<td>Software Server serial numbers must be unique in the model.</td>
</tr>
<tr>
<td></td>
<td>Manual correction: Modify the duplicate serial numbers.</td>
</tr>
<tr>
<td></td>
<td>Automatic correction: Appends a number to the duplicate serial numbers.</td>
</tr>
</tbody>
</table>
Exporting and Importing Objects to and from Other Models

An enterprise architecture model is intended to provide a big picture view of your organization and to permit you to decompose your functions, processes, and systems to a certain extent, but it cannot show detailed information about how they are (or will be) implemented. In order to model such information, you will want to use other PowerDesigner models, such as the conceptual, logical, physical data models, business process models, or object-oriented models.

The EAM provides wizards to export EA objects to these other, lower-level models and to import implementation objects to be represented in the EAM.

Exporting Objects from an EAM to Another Model

The Export Objects Wizard helps you to export EAM objects to other PowerDesigner models to allow you to model their implementation in detail.

1. Select Tools > Export Objects to open the Export Objects Wizard:

   ![Export Objects Wizard](figure)

   Welcome to the Enterprise Architecture Model Export Objects Wizard. This wizard helps you to export objects from an Enterprise Architecture Model to any other PowerDesigner model. Extended dependency links are created between the Enterprise Architecture Model objects and the objects that are created from them.

   Select the objects that you want to export:

   - Acme
   - Distribution
   - Manufacturing

   Process Map: Architecture Area, Site, Organization Unit, Person

   Selected object(s): 1/2

2. Specify the EAM objects that you want to export to another model by selecting them from among the sub-tabs in the selection field, and then click Next.

3. Specify the model to which you want to export the EAM objects from among the models open in the workspace, and then click Next.

4. Specify the kind of object that you want to create in the target model.

5. [optional] Enter or select a stereotype to identify the type of dependency that will be created between the EAM objects and the objects that you are creating from them. For example, "Implemented by".

6. Click Finish to start the export.

   The EAM objects are exported to and created in the specified model.

Importing Objects from Another Model into an EAM

The Import Objects Wizard helps you to import objects from other PowerDesigner models into an EAM to model their placement in your enterprise architecture.
1. Select **Tools > Import Objects** to open the Import Objects Wizard:

2. Specify the model from which you want to import the objects to the EAM from among the models open in the workspace, and then click Next.

3. Specify the objects that you want to import to the EAM by selecting them from among the sub-tabs in the selection field, and then click Next.

4. Specify the kind of object that you want to create in the EAM and the location (package) where you want to create them.

5. [optional] Enter or select a stereotype to identify the type of dependency that will be created between the objects and the EAM objects that you are creating from them. For example, "Implements".

6. Click Finish to start the import.

The objects are imported to and created in the EAM.

---

**Importing Visio Diagrams into PowerDesigner**

Importing your Visio diagrams into PowerDesigner's rich metadata environment enables you to link your architectural objects with the objects that will implement them, and to profit from PowerDesigner's powerful impact and lineage analysis features. You must have installed Visio 2002 or higher and have selected to install the Visio plug-in from the PowerDesigner installer.

You can import the following diagrams into a PowerDesigner BPM or EAM:

<table>
<thead>
<tr>
<th>Visio diagram</th>
<th>PowerDesigner</th>
</tr>
</thead>
<tbody>
<tr>
<td>Audit Diagram</td>
<td>BPM Analysis/ Business Process Diagram</td>
</tr>
<tr>
<td>Basic Flowchart</td>
<td>BPM Analysis/ Business Process Diagram</td>
</tr>
<tr>
<td>Cross-functional flowchart</td>
<td>BPM Analysis/ Business Process Diagram</td>
</tr>
<tr>
<td>Business Process/ Data flow Diagram</td>
<td>BPM Data Flow Diagram</td>
</tr>
<tr>
<td>Software/ Data Flow Diagram</td>
<td></td>
</tr>
<tr>
<td>Event Driven Process Chain Diagram</td>
<td>BPM Business Process Diagram</td>
</tr>
</tbody>
</table>
Visio diagram | PowerDesigner
---|---
ITIL Diagram | BPM Business Process Diagram
Work Flow Diagram | BPM Business Process Diagram
Flowchart/ SDL Diagram | BPM Business Process Diagram
Organization Chart | EAM Organization Chart Diagram
Software/ Enterprise Application | EAM Application Architecture Diagram
Network/ Basic Network Diagram/ Detailed Network Diagram | EAM Technology Infrastructure Diagram
Active Directory | EAM Organization Chart Diagram
LDAP Directory | EAM Organization Chart Diagram

1. Open your diagram in Visio and select **PowerDesigner > Export to PowerDesigner model** to open the PowerDesigner Export wizard:

![PowerDesigner Export Wizard](image)

Specify **PowerDesigner Model**
Specify the type and name of the model to which you want to export your diagrams.

- **Model type**: Business Process Model
- **First diagram**: Business Process Diagram
- **Model name**: Visio model

2. Specify the type of model to which you want to export your diagram, enter a name for the model to be created, and then click OK to start the export.

3. When the export is complete, click OK to close the wizard.

   The diagram is opened as a new BPM or EAM in PowerDesigner.
Index

A
application 29
check 46
create 29
properties 30
application architecture diagram 23
create 24
objects 23
symbols 23
application link 35
check 46
create 35
properties 35
application service 27
check 46
create 27
properties 27
architecture area 16
create 16
properties 16

B
business communication diagram 8
create 9
objects 8
symbols 8
business flow 20
create 20
properties 20
business function 18
create 18
properties 18
business service 27
create 27
properties 27

C
check model
software server 49
workstation 48
application 46
application link 46
application service 46
component 46
contract 46
database 46
deployment instance 47
EAM 46
form 47
hardware server 48
mobile device 48
network 48
network node 48
organization unit 49
people 49
city planning diagram 11
create 12
objects 11
symbols 11
component 31
check 46
create 31
properties 31
contract
check 46
create 36
properties 36

data
create 33
properties 33
database 29
check 46
create 29
properties 30
deployment instance 41
check 47
create 41
properties 42
display preferences
symbols 7, 8, 10, 11, 23, 25, 37
document 32
create 32
properties 33

E
EAM
application architecture 23
application architecture diagram 24
business communication diagram 8
check model 46
city planning diagram 11
create 2
define environment 45
model options 45
organization chart 7
process map 9
service-oriented diagram 25
technology infrastructure diagram 37
validate 46
enterprise architecture framework project
create 4
ETL job 34
create 34
ETL Job
properties 34
export
objects from other models 50

F
form 32
check 47
Index

create 32
properties 33

H
hardware server 40
  check 48
  create 40
  properties 40

I
import
  objects from other models 50
  Visio 51
infrastructure link 42
  create 42
  properties 42

M
mobile device 40
  check 48
  create 40
  properties 40
model
  create 2
  properties 4
model options 45

N
network 39
  check 48
  create 39
  properties 39
network node 40
  check 48
  create 40
  properties 40

O
object
  application architecture diagram 23
  business communication diagram 8
  city planning diagram 11
  organization chart 7
  process map 10
  service-oriented diagram 25
  technology infrastructure diagram 37
OBJECT
  create 12
operation
  create 28
  properties 28
organization chart 7
  create 8
  objects 7
  symbols 7
organization unit 12

P
people
  check 49
  person 13
  create 14
  properties 14
process 19
  create 19
  properties 19
process map 9
  create 10
  objects 10
  symbols 10

R
report 32
  create 32
  properties 33
role 14
  create 15
  properties 15
role association 15

S
service-oriented diagram 25
  create 26
  objects 25
  symbols 25
site 17
  create 17
  properties 17
software server 40
  create 40
  properties 40
symbol
  application architecture diagram 23
  business communication diagram 8
  city planning diagram 11
detail mode 7, 8, 10, 11, 23, 25, 37
display preferences 7, 8, 10, 11, 23, 25, 37
icon mode 7, 8, 10, 11, 23, 25, 37
organization chart 7
  process map 10
  service-oriented diagram 25
sub-objects 7, 8, 10, 11, 23, 25, 37
technology infrastructure diagram 37
system 29
  create 29
  properties 30

T
technology infrastructure diagram 37
  create 38
  objects 37
symbols 37

V
validating an EAM 46
Visio

import 51

W
workstation 40
create 40
properties 40