Getting Started

PowerBuilder®
11.0
This publication pertains to Sybase software and to any subsequent release until otherwise indicated in new editions or technical notes. Information in this document is subject to change without notice. The software described herein is furnished under a license agreement, and it may be used or copied only in accordance with the terms of that agreement.

To order additional documents, U.S. and Canadian customers should call Customer Fulfillment at (800) 685-8225, fax (617) 229-9845.

Customers in other countries with a U.S. license agreement may contact Customer Fulfillment via the above fax number. All other international customers should contact their Sybase subsidiary or local distributor. Upgrades are provided only at regularly scheduled software release dates. No part of this publication may be reproduced, transmitted, or translated in any form or by any means, electronic, mechanical, manual, optical, or otherwise, without the prior written permission of Sybase, Inc.

Sybase trademarks can be viewed at the Sybase trademarks page at http://www.sybase.com/detail?id=1011207. Sybase and the marks listed are trademarks of Sybase, Inc. ® indicates registration in the United States of America.

Java and all Java-based marks are trademarks or registered trademarks of Sun Microsystems, Inc. in the U.S. and other countries.

Unicode and the Unicode Logo are registered trademarks of Unicode, Inc.

All other company and product names used herein may be trademarks or registered trademarks of their respective companies.

Use, duplication, or disclosure by the government is subject to the restrictions set forth in subparagraph (c)(1)(ii) of DFARS 52.227-7013 for the DOD and as set forth in FAR 52.227-19(a)-(d) for civilian agencies.

Sybase, Inc., One Sybase Drive, Dublin, CA 94568.
## Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>About This Book</td>
<td>ix</td>
</tr>
<tr>
<td><strong>PART 1</strong> WELCOME TO POWERBUILDER</td>
<td></td>
</tr>
<tr>
<td><strong>CHAPTER 1</strong> Introduction to PowerBuilder</td>
<td>3</td>
</tr>
<tr>
<td>What PowerBuilder is</td>
<td>3</td>
</tr>
<tr>
<td>The PowerBuilder environment</td>
<td>6</td>
</tr>
<tr>
<td>PowerBuilder objects</td>
<td>11</td>
</tr>
<tr>
<td><strong>CHAPTER 2</strong> About the PowerBuilder Tutorial</td>
<td>19</td>
</tr>
<tr>
<td>Learning to build a client/server application</td>
<td>19</td>
</tr>
<tr>
<td>Learning to build a .NET Web Forms application</td>
<td>21</td>
</tr>
<tr>
<td>Learning to build a .NET Windows Forms application</td>
<td>21</td>
</tr>
<tr>
<td>How you will proceed</td>
<td>22</td>
</tr>
<tr>
<td>How long it will take</td>
<td>23</td>
</tr>
<tr>
<td>What you will learn</td>
<td>23</td>
</tr>
<tr>
<td>Setting up for the tutorial</td>
<td>24</td>
</tr>
<tr>
<td><strong>PART 2</strong> BUILDING A CLIENT/SERVER APPLICATION</td>
<td></td>
</tr>
<tr>
<td><strong>LESSON 1</strong> Starting PowerBuilder</td>
<td>29</td>
</tr>
<tr>
<td>Create a new workspace</td>
<td>30</td>
</tr>
<tr>
<td>Create a target</td>
<td>34</td>
</tr>
<tr>
<td>Specify an icon for the application</td>
<td>39</td>
</tr>
<tr>
<td>Change the size of the main window</td>
<td>42</td>
</tr>
<tr>
<td>Run the application</td>
<td>45</td>
</tr>
<tr>
<td><strong>LESSON 2</strong> Customizing the PowerBuilder Environment</td>
<td>49</td>
</tr>
<tr>
<td>Manipulate the System Tree window</td>
<td>50</td>
</tr>
<tr>
<td>Open an object</td>
<td>52</td>
</tr>
</tbody>
</table>
Contents

Manipulate views............................................................................  54
Add an extra Script view..........................................................  55
Display view title bars ..............................................................  56
Float and dock views...............................................................  56
Manipulate tabbed views.........................................................  57
Save a view layout scheme.....................................................  58
Reset the default view layout scheme.....................................  58
Set up the toolbars .........................................................................  59
Show labels on toolbar buttons ...............................................  59
Float the toolbars.....................................................................  60
Reposition the toolbars............................................................  61

LESSON 3

Building a Login Window .............................................................. 63
Create a new window.....................................................................  64
Add controls to the window ............................................................  68
Add a Picture control ...............................................................  70
Add StaticText controls ...........................................................  71
Specify properties of the StaticText controls...........................  72
Add SingleLineEdit controls ....................................................  74
Specify properties of the SingleLineEdit controls .............  75
Add CommandButton controls ................................................  76
Specify properties of the CommandButton controls ..........  76
Change the tab order on the window .............................................  78
Code some Help events and preview the window .........................  80
Write the script to open the window ...............................................  84
Modify the frame window Open event .....................................  85
Compile the script....................................................................  88

LESSON 4

Connecting to the Database ......................................................... 89
Look at the EAS Demo DB database .............................................  90
Look at the database profile for the EAS Demo DB database 91
Look at table definitions in the EAS Demo DB database ....  95
Run the Connection Object wizard.................................................. 100
Declare a global variable.............................................................. 103
Modify the connection information .............................................. 107
Modify the of_GetConnectionInfo function ................................ 107
Call the connection service manager .................................... 109
Complete the login and logout scripts ........................................ 112
Set up shortcuts for AutoScript................................................ 113
Add code to the OK button Clicked event ............................. 114
Add code to the Cancel button Clicked event ....................... 116
Add code to the application Close event ............................... 116
Run the application ...................................................................... 119
## Contents

### LESSON 5
**Modifying the Ancestor Window** ............................................... 121
- Add a library to the search path .................................................. 122
- Create a new ancestor sheet window ........................................... 124
  - Create a new sheet window inheritance hierarchy .................. 125
  - Add a DataWindow control for the master DataWindow .......... 127
  - Add a DataWindow control for the detail DataWindow .......... 129
- View the scripts inherited from the user object ...................... 130
- Add user events and event scripts ............................................. 132
- Add scripts to retrieve data for the DataWindow controls .......... 136
- Adjust a runtime setting for sheet window size .................... 139

### LESSON 6
**Setting Up the Menus** .............................................................. 141
- Modify the frame menu ................................................................ 142
- Modify the File menu .................................................................. 142
- Enable Help menu items ............................................................. 145
- Create a new sheet menu .......................................................... 146
  - Inherit and save a new menu ................................................ 146
  - Add items to the new menu .................................................. 147
  - Add a new toolbar for the new menu items ......................... 150
- Add menu scripts to trigger user events ..................................... 152
- Attach the new menu and run the application ......................... 154

### LESSON 7
**Building DataWindow Objects** .................................................. 157
- Create and preview a new DataWindow object ......................... 158
- Save the DataWindow object ..................................................... 163
- Make cosmetic changes to the first DataWindow object ............ 164
  - Create a second DataWindow object ...................................... 166
  - Select the data source and style .......................................... 166
  - Select the table and columns .............................................. 167
  - Define a retrieval argument ................................................. 168
  - Specify a WHERE clause .................................................... 169
  - View the DataWindow in the DataWindow painter .............. 171
  - Save the DataWindow object ............................................. 173
- Make cosmetic changes to the second DataWindow object ......... 174
  - Rearrange the columns and labels .................................... 174
  - Align the columns and labels ........................................... 176
  - Display the arrow for a drop-down DataWindow edit style .... 177

### LESSON 8
**Attaching the DataWindow Objects** .......................................... 179
- Attach the DataWindow object to the master DataWindow control .................................................. 180
- Attach the DataWindow object to the detail DataWindow control 182
Contents

Run the application ................................................................. 183
Attach DataWindow objects to the Product window .................. 186
Run the application again ....................................................... 188

LESSON 9

Running the Debugger .............................................................. 191
Add breakpoints in application scripts .................................... 192
Run in debug mode ................................................................. 196
Set a watch and a conditional breakpoint ............................... 201

LESSON 10

Exception Handling ................................................................. 203
Add a new sheet window to the existing application ............... 204
Create the sheet window ...................................................... 205
Provide access to the sheet window from the main application frame .................................................. 207
Create user-defined exception objects .................................. 210
Create a new user function and user event ............................ 212
Call the methods and catch the exceptions ............................ 215
Run the application ............................................................... 218
Test the new sheet window .................................................. 218
Add a test for the divide-by-zero error ................................. 221

LESSON 11

Preparing the Application for Deployment ............................ 225
Create the Project object ...................................................... 226
Create the executable file .................................................... 230
Create a shortcut .................................................................. 233
Test the executable file ........................................................ 235

PART 3 BUILDING A WEB FORMS APPLICATION

LESSON 12

Converting the PowerBuilder Tutorial to a Web Forms Application .................................................. 239
Run the tutorial in PowerBuilder ............................................. 240
Make changes for a .NET Web Forms application .................. 241
Create a .NET Web Forms target and project ......................... 243
Deploy a .NET Web Forms project ....................................... 247
Run the application from a Web browser ............................... 249
About This Book

**Audience**
This book is for anyone using PowerBuilder® to build applications.

**How to use this book**
This book provides information that enables you to start using PowerBuilder:

- **Part 1** is an overview of the PowerBuilder development environment.
- **Part 2** is a tutorial in which you build your first PowerBuilder application.
- **Part 3** is a tutorial in which you create and run a .NET Web Forms target.
- **Part 4** is a tutorial in which you create and run a .NET Windows Forms target.

**Related documents**
This table lists the information in the PowerBuilder documentation set, grouped by topic:

<table>
<thead>
<tr>
<th>Topic</th>
<th>Book</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Installation</td>
<td>Installation Guide</td>
<td>Tells you how to install PowerBuilder</td>
</tr>
<tr>
<td>Introduction and use of</td>
<td>Getting Started</td>
<td>Introduces you to PowerBuilder and provides a tutorial you can step through to learn the basics</td>
</tr>
<tr>
<td>PowerBuilder features</td>
<td>User’s Guide</td>
<td>Tells how to use the painters to build objects in PowerBuilder</td>
</tr>
<tr>
<td>Programmer’s information</td>
<td>Application</td>
<td>Presents collections of techniques for implementing many common application features, along with deployment details and tips for cross-platform and international development</td>
</tr>
<tr>
<td></td>
<td>Techniques</td>
<td></td>
</tr>
<tr>
<td>Topic</td>
<td>Book</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------------</td>
<td>------------------------------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>DataWindow</td>
<td>DataWindow Programmer's Guide</td>
<td>Explains how to use DataWindows in all the supported environments (PowerBuilder, Web pages, Java) and describes programming techniques for accessing, displaying, manipulating, and updating data</td>
</tr>
<tr>
<td>.NET targets information</td>
<td>Deploying Applications and Components to .NET</td>
<td>Tells you how to build, deploy, debug and run .NET Web Forms and Windows Forms targets, and how to create .NET assembly components and Web services from PowerBuilder nonvisual objects</td>
</tr>
<tr>
<td>JSP targets information</td>
<td>Working JSP Targets</td>
<td>Tells how to build, deploy, debug, and run PowerBuilder JSP targets</td>
</tr>
<tr>
<td>JSP Target Reference</td>
<td>JSP Target Reference</td>
<td>Provides reference information for objects and classes in the Web Target object model</td>
</tr>
<tr>
<td>Reference information</td>
<td>PowerScript Reference</td>
<td>Describes syntax and usage information for the PowerScript language, including variables, expressions, statements, functions, and events</td>
</tr>
<tr>
<td>DataWindow Reference</td>
<td>DataWindow Reference</td>
<td>Provides reference information for the DataWindow object, including properties and functions for expressions; syntax for accessing properties and data; and reference information for the methods, events, and properties of DataWindow controls and DataStores in all supported environments</td>
</tr>
<tr>
<td>Objects and Controls</td>
<td>Objects and Controls</td>
<td>Lists properties, events, and related functions for PowerBuilder system objects and controls</td>
</tr>
</tbody>
</table>
### Other sources of information

Use the Sybase Getting Started CD, the SyBooks CD, and the Sybase Product Manuals Web site to learn more about your product:

- The Getting Started CD contains release bulletins and installation guides in PDF format, and may also contain other documents or updated information not included on the SyBooks CD. It is included with your software. To read or print documents on the Getting Started CD, you need Adobe Acrobat Reader, which you can download at no charge from the Adobe Web site using a link provided on the CD.

- The SyBooks CD contains product manuals and is included with your software. The Eclipse-based SyBooks browser allows you to access the manuals in an easy-to-use, HTML-based format.

Some documentation may be provided in PDF format, which you can access through the PDF directory on the SyBooks CD. To read or print the PDF files, you need Adobe Acrobat Reader.

Refer to the *SyBooks Installation Guide* on the Getting Started CD, or the *README.txt* file on the SyBooks CD for instructions on installing and starting SyBooks.

- The Sybase Product Manuals Web site is an online version of the SyBooks CD that you can access using a standard Web browser. In addition to product manuals, you will find links to EBFs/Maintenance, Technical Documents, Case Management, Solved Cases, newsgroups, and the Sybase Developer Network.

<table>
<thead>
<tr>
<th>Topic</th>
<th>Book</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>PowerBuilder Extension</td>
<td>PowerBuilder Extension Reference</td>
<td>Contains reference information for PowerBuilder extension modules created with PBNI (such as PBDOM, EJBCli, and Web services)</td>
</tr>
<tr>
<td>Communicating with a database</td>
<td>Connecting to Your Database</td>
<td>Tells how to connect to a database from PowerBuilder; describes how to set up, define, and manage database connections accessed through the ODBC interface or one of the native database interfaces</td>
</tr>
<tr>
<td>Connection Reference</td>
<td>Connection Reference</td>
<td>Includes procedures for preparing, defining, establishing, maintaining, and troubleshooting your database connections</td>
</tr>
</tbody>
</table>
To access the Sybase Product Manuals Web site, go to Product Manuals at http://www.sybase.com/support/manuals/.

Technical documentation at the Sybase Web site is updated frequently.

❖ **Finding the latest information on product certifications**
2. Click Certification Report.
3. In the Certification Report filter select a product, platform, and timeframe and then click Go.
4. Click a Certification Report title to display the report.

❖ **Finding the latest information on component certifications**
2. Either select the product family and product under Search by Base Product; or select the platform and product under Search by Platform.
3. Select Search to display the availability and certification report for the selection.

❖ **Creating a personalized view of the Sybase Web site (including support pages)**
Set up a MySybase profile. MySybase is a free service that allows you to create a personalized view of Sybase Web pages.
2. Click MySybase and create a MySybase profile.
You can find information about EBFs and software maintenance on the Sybase Web site.

❖ **Finding the latest information on EBFs and software maintenance**


2. Select EBFs/Maintenance. If prompted, enter your MySybase user name and password.

3. Select a product.

4. Specify a time frame and click Go. A list of EBF/Maintenance releases is displayed.

   Padlock icons indicate that you do not have download authorization for certain EBF/Maintenance releases because you are not registered as a Technical Support Contact. If you have not registered, but have valid information provided by your Sybase representative or through your support contract, click Edit Roles to add the “Technical Support Contact” role to your MySybase profile.

5. Click the Info icon to display the EBF/Maintenance report, or click the product description to download the software.

**If you need help**

Each Sybase installation that has purchased a support contract has one or more designated people who are authorized to contact Sybase Technical Support. If you cannot resolve a problem using the manuals or online help, please have the designated person contact Sybase Technical Support or the Sybase subsidiary in your area.
Welcome to PowerBuilder

This part is an overview of the PowerBuilder development environment.
CHAPTER 1

Introduction to PowerBuilder

About this chapter

This chapter introduces the PowerBuilder development environment, which you use in the tutorials in Parts 2-4. It also describes the building blocks of a PowerBuilder application.

Contents

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>What PowerBuilder is</td>
<td>3</td>
</tr>
<tr>
<td>The PowerBuilder environment</td>
<td>6</td>
</tr>
<tr>
<td>PowerBuilder objects</td>
<td>11</td>
</tr>
</tbody>
</table>

For more information

For a more detailed description of the PowerBuilder development environment, see the *PowerBuilder User’s Guide*.

What PowerBuilder is

PowerBuilder is an enterprise development tool that allows you to build many types of applications and components. It is one of a group of Sybase products that together provide the tools to develop client/server, multitier, and Internet applications.

What’s in a PowerBuilder application?

A PowerBuilder client application can contain:

- **A user interface**  Menus, windows, and window controls that users interact with to direct an application.

- **Application processing logic**  Event and function scripts in which you code business rules, validation rules, and other application processing. PowerBuilder allows you to code application processing logic as part of the user interface or in separate modules called custom class user objects.

What is a PowerBuilder component?

In a multitier application, modules containing application processing logic (that you deploy to a server) are called components. You can design, build, and deploy custom class user objects as application server components.
### What PowerBuilder is

**PowerBuilder applications are event driven**

In a client application, users control what happens by the actions they take. For example, when a user clicks a button, chooses an item from a menu, or enters data into a text box, one or more events are triggered. You write scripts that specify the processing that should happen when events are triggered.

Windows, controls, and other application components you create with PowerBuilder each have a set of predefined events. For example, each button has a Clicked event associated with it and each text box has a Modified event. Most of the time, the predefined events are all you need. However, in some situations, you may want to define your own events.

**PowerScript language**

You write scripts using PowerScript, the PowerBuilder language. Scripts consist of PowerScript commands, functions, and statements that perform processing in response to an event.

For example, the script for a button’s Clicked event might retrieve and display information from the database; the script for a text box’s Modified event might evaluate the data and perform processing based on the data.

The execution of an event script can also cause other events to be triggered. For example, the script for a Clicked event in a button might open another window, triggering the Open event in that window.

**PowerScript functions**

PowerScript provides a rich assortment of built-in functions that can act on the various components of your application. For example, there is a function to open a window, a function to close a window, a function to enable a button, a function to update the database, and so on.

You can also build your own functions to define processing unique to your application.

**Object-oriented programming with PowerBuilder**

Each menu or window you create with PowerBuilder is a self-contained module called an object. The basic building blocks of a PowerBuilder application are the objects you create. Each object contains the particular characteristics and behaviors (properties, events, and functions) that are appropriate to it. By taking advantage of object-oriented programming techniques such as encapsulation, inheritance, and polymorphism, you can get the most out of each object you create, making your work more reusable, extensible, and powerful.

**.NET applications**

If you are using the Enterprise edition of PowerBuilder, you can develop applications and components for the .NET environment. These include Web Forms applications that you deploy to IIS servers using ASP.NET and Windows Forms applications that you can deploy with smart client functionality. You can also convert nonvisual custom class objects directly into .NET assemblies and you can deploy them as .NET Web services.
For information about .NET targets, see *Deploying Applications and Components to .NET*.

**JSP applications**

If you are using the Enterprise edition of PowerBuilder, you can develop PowerBuilder applications that run on the Web using JSP targets technology. With JSP targets, you can build complex Web pages that can include client- and server-side scripting, database content, Web DataWindows, and EAServer components.

In all editions of PowerBuilder, you can use the DataWindow and PowerBuilder window plug-ins, the PowerBuilder window ActiveX, and the DataWindow Web control for ActiveX.

For information about JSP targets, see *Working with JSP Targets*. For information about PowerBuilder plug-ins, see *Application Techniques*. For information about the DataWindow Web control for ActiveX, see the *DataWindow Programmer’s Guide* and the *DataWindow Reference*.

**Multitier applications**

PowerBuilder lets you build applications that run in a distributed computing environment. A multitier application lets you:

- Centralize business logic on servers, such as EAServer, JBoss, WebLogic, WebSphere, or COM+
- Partition application functions between the client and the server, thereby reducing the client workload
- Build scalable applications that are easy to maintain

For information about multitier applications, see the sections on distributed application techniques in *Application Techniques*.

**Database connectivity**

PowerBuilder provides easy access to corporate information stored in a wide variety of databases. Data can be accessed through the PowerBuilder ODBC or JDBC interfaces, through a middle-tier data access server like the Sybase DirectCONNECT server, or through a native or direct connection to a database.

For information on database connectivity, see *Connecting to Your Database*.

**Online Help and documentation**

PowerBuilder online Help can be accessed using Help buttons and menu items, or by selecting the F1 key from anywhere in PowerBuilder. There are jumps in several places from the online Help to books in HTML format. Manuals are also available on the Sybase Web site.
The PowerBuilder environment

Workspaces and targets

In PowerBuilder, you work with one or more targets in a workspace. You can add as many targets to the workspace as you want, open and edit objects in multiple targets, and build and deploy multiple targets at once.

A PowerBuilder target can be one of several types:

- **Application target**  A client/server or multitier executable application.

- **.NET target**  A .NET target that you can use to deploy applications as .NET Windows Forms or ASP.NET applications or to deploy nonvisual custom class components as .NET assemblies or Web services.

- **An EAServer or Application Server Component target**  A component that can be deployed to EAServer or another J2EE-compliant server.

- **JSP target**  A Web application. A JSP target can include all the elements you need to build a Web site—HTML files, scripts, images, downloaded components—as well as settings for build options, database connections, and deployment.

The first lesson in the tutorial shows you how to create a workspace and a PowerScript target. Later you learn how to create .NET targets.

When you start PowerBuilder, it opens in a window that contains a menu bar and the PowerBar at the top, and the System Tree and Clip windows on the left.
### System Tree
The System Tree window can serve as the hub of your development activities. You use it to open, run, debug, and build your targets, and for drag-and-drop programming.

### Clip window
The Clip window lets you store code fragments that you use frequently.

### Output window
The output of a variety of operations (migration, builds, deployment, project execution, object saves, and searches) displays in an Output window at the bottom of the main window. The Output window opens automatically when output information is generated, but you can open the Output window at any time by clicking the Output window toolbar button.

### Painters
Once you have created a workspace and a PowerScript target, you build the components of the target using painters. Painters provide an assortment of tools for enhancing and fine tuning the objects in a target.

PowerBuilder provides a painter for each type of object you build. For example, you build a window in the Window painter. There you define the properties of the window and add controls, such as buttons and text boxes.

### Editors
For JSP targets, PowerBuilder provides HTML, style sheet, and frame set editors. In the HTML editor you can edit pages in source or display format and preview the results. You can use a standalone script editor or one that is built into the HTML editor. The style sheet editor lets you create external style sheets that you link to your HTML pages, and the frame set editor lets you select and edit frame structures for HTML pages if you want to divide a Web page into frames.

### Wizards
Wizards simplify the creation of applications, objects, components, Web sites, and Web pages.

### Design-time controls
Design-time controls (DTCs) create basic HTML and scripts from information you provide in property sheets. The property sheets display when you drop a DTC on a Web page in the HTML editor.

The Web DataWindow DTC provides an easy way to access a database from a Web page. It displays dynamic database content in a variety of presentation styles and supports inserts, updates, and deletes against the database.

### To-Do List
The To-Do List displays a list of development tasks you need to do for the current target. Entries on the To-Do list can be created automatically by most PowerBuilder wizards. You can also type in entries or import them from a text file and then link them to a task that you want to complete.
## The PowerBuilder environment

**Browser**

The Browser lets you see all the objects, methods, variables, and structures that are defined for or available to your PowerScript target. Objects in the Browser can be displayed in alphabetic or hierarchical order. The Browser displays methods with their complete prototypes (signatures), which include the datatypes of all arguments and return values.

**PowerBar**

The PowerBar displays when you begin a PowerBuilder session. The PowerBar is the main control point for building PowerBuilder applications. You can use the New, Inherit, or Open buttons on the PowerBar to open all of the PowerBuilder painters. From the PowerBar, you can also open the Browser, debug or run the current application, and build and deploy the workspace.

**PainterBar**

When you open a painter or editor, PowerBuilder displays a new window that has a workspace in which you design the object you are building. PowerBuilder also displays one or more PainterBars with buttons that provide easy access to the tools available in the painter or editor. For example, here is the PainterBar for the DataWindow painter.

![DataWindow PainterBar](image)

**StyleBar**

The StyleBar displays when you open any painter that can contain text controls, such as the Window painter. Using buttons on the StyleBar, you can modify text properties such as the font and point size.

![Text properties](image)

**PowerTips**

When you leave the mouse pointer over a button for a second or two, PowerBuilder can display a brief description of the button (a PowerTip). The ability to display PowerTips is toggled on and off by selecting the Show PowerTips menu item in any toolbar pop-up menu.

![PowerBuilder toolbar](image)

You can also include brief descriptive texts on all toolbar buttons by selecting ShowText from any toolbar pop-up menu.
In addition to displaying text in toolbar buttons, you can move the toolbars around, add new toolbars, and customize existing ones. You can add buttons for opening painters and performing other activities.

You can also rearrange the System Tree, Clip, and Output views, set up custom layouts for each painter, choose whether PowerBuilder opens your last workspace at start-up with or without painters and editors open, customize shortcut keys, and change the colors and fonts used in scripts.

The buttons in the PowerBar give you quick access to the most common PowerBuilder tasks:

**Table 1-1: Buttons in the PowerBar**

<table>
<thead>
<tr>
<th>Button</th>
<th>Use to</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="New" /></td>
<td>Create new workspace, target, component, or other object, or open a</td>
</tr>
<tr>
<td><img src="image" alt="Inherit" /></td>
<td>tool.</td>
</tr>
<tr>
<td><img src="image" alt="Open" /></td>
<td>Inherit from menu, user object, or window.</td>
</tr>
<tr>
<td><img src="image" alt="Preview" /></td>
<td>Open an existing application, DataWindow, function, menu, pipeline,</td>
</tr>
<tr>
<td><img src="image" alt="SpyTree" /></td>
<td>project, query, structure, user object, window, HTML page, HTML frame,</td>
</tr>
<tr>
<td><img src="image" alt="Output" /></td>
<td>style sheet, or script file.</td>
</tr>
<tr>
<td><img src="image" alt="Next" /></td>
<td>Preview a window or DataWindow object.</td>
</tr>
<tr>
<td><img src="image" alt="Previous" /></td>
<td>Show or hide the System Tree window.</td>
</tr>
<tr>
<td><img src="image" alt="Next" /></td>
<td>Show or hide the Output window.</td>
</tr>
<tr>
<td><img src="image" alt="Previous" /></td>
<td>Move to the next line in the Output window.</td>
</tr>
<tr>
<td><img src="image" alt="Previous" /></td>
<td>Move to the previous line in the Output window.</td>
</tr>
<tr>
<td><img src="image" alt="To-Do List" /></td>
<td>Display a list of development tasks you need to do. These can be self</td>
</tr>
<tr>
<td><img src="image" alt="Browser" /></td>
<td>entered or entered automatically by PowerBuilder wizards.</td>
</tr>
<tr>
<td><img src="image" alt="Browser" /></td>
<td>View object information (such as object properties or global variables)</td>
</tr>
<tr>
<td><img src="image" alt="Clip" /></td>
<td>and copy, export, or print it.</td>
</tr>
<tr>
<td><img src="image" alt="Clip" /></td>
<td>Show or hide the Clip window.</td>
</tr>
</tbody>
</table>
### The PowerBuilder environment

<table>
<thead>
<tr>
<th>Button</th>
<th>Use to</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Library" /></td>
<td>Create and maintain libraries of PowerBuilder objects.</td>
</tr>
<tr>
<td><img src="image" alt="DB Prof" /></td>
<td>Specify how to connect to a database.</td>
</tr>
<tr>
<td><img src="image" alt="EAS Prof" /></td>
<td>Specify how to connect to EAServer.</td>
</tr>
<tr>
<td><img src="image" alt="Database" /></td>
<td>Maintain databases, control user access to databases, and manipulate data in databases.</td>
</tr>
<tr>
<td><img src="image" alt="Edit" /></td>
<td>Edit a file.</td>
</tr>
<tr>
<td><img src="image" alt="I Build" /></td>
<td>Start an incremental build of the workspace.</td>
</tr>
<tr>
<td><img src="image" alt="F Build" /></td>
<td>Start a full build of the workspace.</td>
</tr>
<tr>
<td><img src="image" alt="Deploy" /></td>
<td>Deploy the workspace.</td>
</tr>
<tr>
<td><img src="image" alt="Skip" /></td>
<td>When a series of operations is in progress, such as a full deploy of the workspace, skip to the next operation.</td>
</tr>
<tr>
<td><img src="image" alt="Stop" /></td>
<td>Stop a build or deploy operation or series of operations.</td>
</tr>
<tr>
<td><img src="image" alt="Debug" /></td>
<td>Debug the current target.</td>
</tr>
<tr>
<td><img src="image" alt="Sel Dbg" /></td>
<td>Select a target and debug it.</td>
</tr>
<tr>
<td><img src="image" alt="Run" /></td>
<td>Run the current target.</td>
</tr>
<tr>
<td><img src="image" alt="Sel Run" /></td>
<td>Select a target and run it.</td>
</tr>
<tr>
<td><img src="image" alt="Exit" /></td>
<td>Exit from PowerBuilder.</td>
</tr>
</tbody>
</table>
PowerBuilder objects

The basic building blocks of a PowerScript target are objects:

<table>
<thead>
<tr>
<th>Object</th>
<th>Use</th>
</tr>
</thead>
<tbody>
<tr>
<td>Application</td>
<td>Entry point into an application</td>
</tr>
<tr>
<td>Window</td>
<td>Primary interface between the user and a PowerBuilder application</td>
</tr>
<tr>
<td>DataWindow</td>
<td>Retrieves and manipulates data from a relational database or other data source</td>
</tr>
<tr>
<td>Menu</td>
<td>List of commands or options that a user can select in the currently active window</td>
</tr>
<tr>
<td>Global function</td>
<td>Performs general-purpose processing</td>
</tr>
<tr>
<td>Query</td>
<td>SQL statement used repeatedly as the data source for a DataWindow object</td>
</tr>
<tr>
<td>Structure</td>
<td>Collection of one or more related variables grouped under a single name</td>
</tr>
<tr>
<td>User object</td>
<td>Reusable processing module or set of controls, either visual or nonvisual</td>
</tr>
<tr>
<td>Pipeline</td>
<td>Reproduces data within a database or across databases</td>
</tr>
<tr>
<td>Project</td>
<td>Packages application for distribution to users</td>
</tr>
</tbody>
</table>

These objects are described in more detail in the sections that follow.

The Application object is the entry point into an application. It is a discrete object that is saved in a PowerBuilder library (PBL file), just like a window, menu, function, or DataWindow object.

The Application object defines application-level behavior, such as which fonts are used by default for text, and what processing should occur when the application begins and ends.

When a user runs the application, an Open event is triggered in the Application object. The script you write for the Open event initiates the activity in the application. When the user ends the application, the Close event in the Application object is triggered.

The script you write for the Close event typically does all the cleanup required, such as closing a database or writing to a preferences file. If there are serious errors during execution that are not caught using PowerBuilder’s exception handling mechanism, the Application object’s SystemError event is triggered.
Windows are the primary interface between the user and a PowerBuilder application. Windows can display information, request information from a user, and respond to the user’s mouse or keyboard actions.

A window consists of:

- Properties that define the window’s appearance and behavior (for example, a window might have a title bar and a Minimize box)
- Events triggered by user actions
- Controls placed in the window
Windows can have various kinds of controls, as illustrated in the following picture:

On the left of the window is a DataWindow control with horizontal and vertical trackbars. On the right is a group box that contains static text controls (containing descriptive labels), edit mask controls (as they appear when the SpinControl property is on), a check box, and two smaller group boxes with radio buttons. Under the main group box is a command button.

**DataWindow objects**

A DataWindow object is an object that you use to retrieve and manipulate data from a relational database or other data source (such as an Excel worksheet or dBASE file).

**Presentation styles** DataWindow objects also handle the way data is presented to the user. You can choose from several presentation styles. For example, you can display the data in Tabular or Freeform style.
There are many ways to enhance the presentation and manipulation of data in a DataWindow object. For example, you can include computed fields, pictures, and graphs that are tied directly to the data retrieved by the DataWindow.

### Display formats, edit styles, and validation

You can specify how to display the values for each column, and you can validate data entered by users in a DataWindow object. You do this by defining display formats, edit styles, and validation rules for columns.

For example:

- If a column can take only a small number of mutually exclusive values, you can have the data appear as radio buttons in a DataWindow so users know what their choices are.
If the data includes phone numbers, salaries, and dates, you can format the display to suit the data.

If a column can take numbers only in a specific range, you can specify a simple validation rule for the data. This can spare you from writing code to make sure users enter valid data.

**Web DataWindow** Using the XML Web DataWindow, the XHTML Web Data Window, or the HTML Web DataWindow, you can generate DataWindow objects in XML (with subsequent XSLT transformation to XHTML), XHTML directly, or HTML and display them in a browser, using a PowerBuilder component running in either EAServer or COM+ to generate the Web DataWindow. One of the lessons in the tutorial shows you how to use an XML Web DataWindow in a JSP target.

**Menus**

Menus are lists of items that a user can select from a menu bar for the active window. The items on a menu are usually related. They provide the user with commands (such as Open and Save As on the PowerBuilder File menu) or alternate ways of performing a task (for example, the items on the Edit menu in the Window painter correspond to buttons in the PainterBar).

You can select menu items with the mouse or with the keyboard, or use accelerator (mnemonic access) keys defined for the items. You can define your own keyboard shortcuts for any PowerBuilder menu item from a dialog box that you open with the Tools>Keyboard Shortcuts menu item.

A drop-down menu is a menu under an item in the menu bar. A cascading menu is a menu that appears to the side of an item in a drop-down menu.
PowerBuilder objects

Each choice in a menu is defined as a Menu object in PowerBuilder. The preceding window shows two Menu objects on the menu bar (File and Data), three Menu objects on the drop-down Data menu (Update, Delete, and Cancel), and two Menu objects on the cascading menu beside Update (Current Row and All Rows).

Global functions

PowerBuilder lets you define two types of functions:

- Object-level functions are defined for a particular type of window, menu, or other object type and are encapsulated within the object for which they are defined. These are further divided into system functions (functions that are always available for objects of a certain object class) and user-defined functions.

- Global functions are not encapsulated within another object, but instead are stored as independent objects.

Unlike object-level functions, global functions do not act on particular instances of an object. Instead, they perform general-purpose processing such as mathematical calculations or string handling.

Queries

A query is a SQL statement that is saved with a name so that it can be used repeatedly as the data source for a DataWindow object. Queries enhance developer productivity, because they can be coded once but reused as often as necessary.

Structures

A structure is a collection of one or more related variables of the same or different data types grouped under a single name. In some languages, such as Pascal and COBOL, structures are called records.

Structures allow you to refer to related entities as a unit rather than individually. For example, you can define the user’s ID, address, access level, and a picture (bitmap) of the employee as a structure called user_struct, and then refer to this collection of variables as user_struct.

There are two kinds of structures:

- Object-level structures are associated with a particular type of object such as a window or menu. These structures can always be used in scripts for the object itself. You can also choose to make the structures accessible from other scripts.

- Global structures are not associated with any object or type of object in an application. You can declare an instance of the structure and reference it in any script in an application.
User objects

Applications often have features in common. For example, several applications might have a Close button that performs a certain set of operations and then closes the window, or they might have DataWindow controls that perform the same type of error checking. Several applications might all require a standard file viewer.

If you find yourself using the same application feature repeatedly, you should define a user object. You define the user object once and use it as many times as you need.

User objects can be visual or nonvisual. They can be further divided into standard or custom user objects. Standard user objects, whether visual or nonvisual, are system objects that are always available with PowerBuilder. You can also use controls for external visual objects that were created outside PowerBuilder. The main types of user objects are:

- **Visual user objects** These are reusable controls or sets of controls that have a consistent behavior. For example, a visual user object could consist of several buttons that function as a unit. The buttons could have scripts associated with them that perform standard processing. Once the object is defined, you can use it as often as you need.

- **Nonvisual user objects** These are reusable processing modules that have no visual component. Standard class user objects inherit events and properties from built-in system objects. You typically use nonvisual objects to define business rules and other processing that acts as a unit.

For example, you might want to calculate commissions or perform statistical analysis in several applications. To do this, you could define a custom class user object. To use a custom class user object, you create an instance of the object in a script and call its functions.

Custom class user objects, which define functions and variables, are the foundation of PowerBuilder multitier applications. This is because you typically use nonvisual components for applications that are run on a server.

Libraries

You save objects, such as windows and menus, in PowerBuilder libraries (PBL files). When you run an application, PowerBuilder retrieves the objects from the library. Applications can use as many libraries as you want. When you create an application, you specify which libraries it uses.

Projects

You can create Project objects that build executable applications and components you can deploy to a server, as well as proxy objects you use in EAServer applications.
PowerBuilder objects
CHAPTER 2

About the PowerBuilder Tutorial

About this chapter
This chapter describes what you will do in the PowerBuilder tutorial and how to get set up for it.

Contents

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Learning to build a client/server application</td>
<td>19</td>
</tr>
<tr>
<td>Learning to build a .NET Web Forms application</td>
<td>21</td>
</tr>
<tr>
<td>Learning to build a .NET Windows Forms application</td>
<td>21</td>
</tr>
<tr>
<td>How you will proceed</td>
<td>22</td>
</tr>
<tr>
<td>Setting up for the tutorial</td>
<td>24</td>
</tr>
</tbody>
</table>

Learning to build a client/server application

The PowerBuilder tutorial is divided into parts. The first part of the tutorial is a set of eleven exercises in which you build a Multiple Document Interface (MDI) database application for a fictional company called SportsWear, Inc. The application allows you to retrieve customer and product information from the database and perform insert, update, and delete functions against the customer and product data.
Customer and Product windows

The MDI application includes two windows that provide access to the Customer and Product tables in the EAS Demo DB database.

These windows are master/detail windows: each allows you to display a master list of rows in a particular table and also see detailed information for each row in the table. For example, the top half of the Maintain Products window contains a list of products with a pointer to a single product; the bottom half of the window displays extra detail for the current product.

Login window

The MDI application also includes a login window that allows you to connect to the database at start-up time.
Learning to build a .NET Web Forms application

In the second part of this tutorial, you convert the client-server application that you built in the first set of exercises. However, you do not need to complete the client-server tutorial in order to follow the instructions in the .NET Web Forms tutorial. You can use the application provided in the PowerBuilder Tutorial\Solutions directory as the starting point for the Web Forms tutorial instead of the application that you build in the client-server tutorial.

The end result of the .NET Web Forms tutorial looks reasonably similar to the completed client-server tutorial, except for the fact that you run the application in a Web browser. There are other minor differences, such as the page navigation toolbar that you select in the Web Forms application. The tutorial does not cover all features of .NET Web Forms applications that you can build with PowerBuilder. Additional topics, such as Web Forms printing, theme setting, and user management are covered in the Deploying Applications and Components to .NET book.

Learning to build a .NET Windows Forms application

In the third part of this tutorial, you convert the client-server application that you built in the first set of exercises. However, you do not need to complete the client-server tutorial in order to follow the instructions in the .NET Windows Forms tutorial. You can use the application provided in the PowerBuilder Tutorial\Solutions directory as the starting point for the Windows Forms tutorial instead of the application that you build in the client-server tutorial.

The end result of the .NET Windows Forms tutorial looks reasonably similar to the completed client-server tutorial, except for the fact that you deploy it as a thin client application solution. The tutorial does not cover all features of .NET Windows Forms applications that you can build with PowerBuilder. Additional topics, such as intelligent updating and using the bootstrapper are covered in the Deploying Applications and Components to .NET book.
How you will proceed

Table 2-1 describes what you will do in each of the tutorial lessons.

<table>
<thead>
<tr>
<th>Lesson</th>
<th>What you will do</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Start PowerBuilder; begin familiarizing yourself with the development environment; use the Workspace wizard and the Template Application wizard to create an Application object, windows, and menus in a PowerBuilder workspace and target.</td>
</tr>
<tr>
<td>2</td>
<td>Explore the PowerBuilder environment and customize the workspace.</td>
</tr>
<tr>
<td>3</td>
<td>Create a login window to allow the user to enter database connection parameters (user ID and password).</td>
</tr>
<tr>
<td>4</td>
<td>Connect to the database using the Transaction object and user-entry parameters; see how database profiles are defined in the PowerBuilder environment.</td>
</tr>
<tr>
<td>5</td>
<td>Change the base sheet window by adding master and detail DataWindow controls; add scripts to allow users to retrieve data and perform insert, update, and delete operations against the database.</td>
</tr>
<tr>
<td>6</td>
<td>Modify the frame menu and create a new sheet menu for the application.</td>
</tr>
<tr>
<td>7-8</td>
<td>Build the DataWindow objects that retrieve customer and product information, then add them to the Customer and Product windows.</td>
</tr>
<tr>
<td>9</td>
<td>Run the tutorial application in debug mode; see how to set breakpoints in scripts, step through the code, and display the contents of variables.</td>
</tr>
<tr>
<td>10</td>
<td>Create a new window to test exception handling in PowerBuilder.</td>
</tr>
<tr>
<td>11</td>
<td>Create an executable file that you can use to run the application outside the PowerBuilder development environment.</td>
</tr>
<tr>
<td>12</td>
<td>Convert the PowerBuilder client-server tutorial application to a .NET Web Forms application.</td>
</tr>
<tr>
<td>13</td>
<td>Convert the PowerBuilder client-server tutorial application to a .NET Windows Forms application.</td>
</tr>
</tbody>
</table>
How long it will take

You can do all the tutorials in about six hours, or you can stop after any lesson and continue at another time.

If you are interrupted
You can save your work and exit PowerBuilder at any time. When you are ready to continue, you can open the tutorial workspace and continue where you left off.

What you will learn

This tutorial will not make you an expert in PowerBuilder. Only experience building real-world applications can do that. It will give you hands-on experience, though, and provide a foundation for continued growth.

You will learn basic PowerBuilder techniques and concepts, including those listed in Table 2-2:

<table>
<thead>
<tr>
<th>How to use the</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Application painter</td>
<td>Define an Application object and application-level scripts</td>
</tr>
<tr>
<td>Window painter</td>
<td>Create SingleLineEdit controls, StaticText controls, CommandButton controls, DataWindow controls, window-level scripts, and control-level scripts</td>
</tr>
<tr>
<td>DataWindow painter</td>
<td>Define selection and display options</td>
</tr>
<tr>
<td>Menu painter</td>
<td>Define menus, menu items, accelerators, and shortcut keys</td>
</tr>
<tr>
<td>Layout view</td>
<td>Design how the windows, menus, and DataWindows will look when you run the application</td>
</tr>
<tr>
<td>Script view</td>
<td>Define scripts for applications, windows, window controls, and menus</td>
</tr>
<tr>
<td>Debugger</td>
<td>Identify logic errors that may cause problems when you run the application</td>
</tr>
<tr>
<td>Project painter</td>
<td>Create an executable version of an application</td>
</tr>
</tbody>
</table>
You will learn basic .NET target techniques and concepts, including those listed in Table 2-3:

<table>
<thead>
<tr>
<th>How to use</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>.NET Web Forms wizards</td>
<td>Convert a client-server target to a Web Forms target and deploy it as a Web Forms project</td>
</tr>
<tr>
<td>Global variables</td>
<td>Modify the page navigation toolbar type in a Web Forms application</td>
</tr>
<tr>
<td>.NET Windows Forms wizards</td>
<td>Convert a client-server target to a Windows Forms target and deploy it as a Windows Forms project</td>
</tr>
<tr>
<td>Intelligent update technology</td>
<td>Publish a Windows Forms application to a Web browser and install the application from the browser</td>
</tr>
</tbody>
</table>

Before you start the tutorial, you need to make sure that you can connect to a database and that you have the tutorial files.

The tutorial uses the EAS Demo DB V110 database that installs with PowerBuilder. This is an SQL Anywhere database and requires the Sybase SQL Anywhere engine.

If you do not already have SQL Anywhere on your local machine or server, you must install it now. You can install it from the PowerBuilder CD. If you installed PowerBuilder in a nondefault location, you must make sure that the odbc.ini registry entry defining the EAS Demo DB as a data source points to the correct location of the SQL Anywhere engine.

The tutorial also uses the files listed in Table 2-4:

<table>
<thead>
<tr>
<th>File</th>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>tutor_pb.pbl</td>
<td>PowerBuilder library that contains several objects that you use in the tutorial</td>
</tr>
<tr>
<td>pbtutor.hlp</td>
<td>A Help file that provides context-sensitive Help to a window that you build in the tutorial</td>
</tr>
<tr>
<td>tutsport.bmp</td>
<td>A bitmap</td>
</tr>
<tr>
<td>tshirtw.jpg</td>
<td>A graphic</td>
</tr>
<tr>
<td>tutorial.ico</td>
<td>An icon</td>
</tr>
</tbody>
</table>
When you install PowerBuilder, these files are installed in the *Tutorial* directory, which is a subdirectory of the PowerBuilder installation directory. When you have finished the tutorial, you can delete the files.

The *Tutorial\Solutions* directory contains a PowerBuilder library called *pbtutor.pbl* that contains all the objects and scripts that you create in the first part of the tutorial, as well as workspace and target files. You can use this solutions library as a reference while you complete the first part of the tutorial. You can also use it as a starting point if you want to complete only the .NET application parts of the tutorial.
Setting up for the tutorial
Building a Client/Server Application

This part is a tutorial that shows you how to get started with PowerBuilder. It provides step-by-step instructions for creating a simple database application.
LESSON 1

Starting PowerBuilder

This lesson provides the information you need to start PowerBuilder and create an application.

In this lesson you:

• Create a new workspace
• Create a target
• Specify an icon for the application
• Change the size of the main window
• Run the application

How long does it take?
About 20 minutes.
Create a new workspace

Where you are
> Create a new workspace
Create a target
Specify an icon for the application
Change the size of the main window
Run the application

The workspace is where you build, edit, debug, and run PowerBuilder targets. You can build several targets within a single workspace, including JSP targets, which are covered in Part 3 of this tutorial.

Now you start PowerBuilder and create a new workspace.

First read the Release Bulletin for this release
Any last-minute items are documented in the Release Bulletin. To make sure you have all the files necessary to complete the tutorial, see “Setting up for the tutorial” on page 24.

1 Double-click the PowerBuilder icon (representing PB110.EXE) in the Sybase>PowerBuilder 11.0 path
or
Select Programs>Sybase>PowerBuilder 11.0>PowerBuilder 11.0 from the Windows Start menu.

The Welcome to PowerBuilder dialog box displays.
The Welcome to PowerBuilder dialog box allows you create a new workspace and add a new target or an existing target to the workspace.

**If you do not want PowerBuilder to display the dialog box again**
You can leave the “Show this dialog box at startup with no workspace” check box unchecked to keep PowerBuilder from displaying the welcome dialog box every time you start PowerBuilder. Select the “Reload last workspace at startup” check box to load the most recently used workspace each time you start a PowerBuilder session. Then click “Close this dialog box.”

The PowerBuilder development environment displays.
If this is the first time you are opening PowerBuilder on your machine, you see only a top-level entry in the System Tree to indicate that no workspace is currently open. Otherwise, the System Tree might show a workspace with targets and objects in it.
2 Select New from the File menu 
or
Click the New button in the PowerBar.

The Workspace page of the New dialog box displays.

PowerBuilder displays the page of the New dialog box that was used before the dialog box was last closed. In this exercise, make sure that the Workspace page of the New dialog box displays.

3 Select Workspace from the Workspace page of the New dialog box. 
Click OK.

The New Workspace dialog box displays.

4 Navigate to the Tutorial folder.

The Tutorial folder is located directly under the PowerBuilder 11.0 folder. 
The solutions for the tutorial are in the Tutorial folder, but you will create your own solutions as you work your way through the tutorial.
5 Type **MyWorkspace** in the File name text box.

6 **Click Save.**

The New Workspace dialog box closes and the workspace you created appears as the first item in the System Tree.
Create a target

Now you create a new target using the Template Application wizard. Based on the choices you make, the Template Application wizard creates precoded events, menus, windows, and user objects in addition to the application object.

1. **Select New from the File menu and click the Target tab**
   
   or
   
   **Right-click MyWorkspace in the System Tree, select New from the pop-up menu, and click the Target tab.**

   The Target page of the New dialog box displays.

2. **Select the Template Application icon and click OK.**

   The Template Application wizard displays. The first page of most wizards explains what the wizard is used for. As you step through the wizard, you can press F1 to get Help on most fields.
3 Click Next until the Specify New Application and Library page displays.

4 Type pbtutor in the Application Name text box.

   The wizard automatically assigns file names to a library and target that use this application name. It assigns the library a PBL extension and the target a PBT extension.

5 Click Next.

   The Specify Template Type page displays. The MDI Application with Microhelp radio button is selected. You will create an MDI template application, so you do not need to change this selection.

   **About MDI**

   MDI stands for multiple document interface. In an MDI application, the main window for the application is called the MDI frame. Using the MDI frame menu bar, you can open additional windows known as sheet windows that display inside the frame window.

6 Click Next 4 times until the Name Individual Sheets page displays.

   In this tutorial you accept the default application type, library search path, frame and frame menu names, sheet menu and manager service, and MDI base sheet.

   **If you have clicked Next too many times**

   You can use the wizard’s Back button to navigate back to the correct wizard page.
7 On the Name Individual Sheets page, type `w_customers` for Sheet 1, `w_products` for Sheet 2, and clear the Sheet 3 text box.

PowerBuilder will generate two windows based on the default basesheet (`w_pbtutor_basesheet`), one for customers and one for products. You will add a third sheet window later—in the lesson on exception handling.

8 Click Next.
Type **Maintain Customers** as the display name for Sheet 1.
Type **Maintain Products** as the display name for Sheet 2.

The names you type will display in the title bars of these sheet windows.
9 **Click Next twice.**

You do not need to change the names of the About and Toolbar windows.

10 **On the Specify Connectivity page, select None.**

You will add a Connection object later.

11 **Click Next twice to display the Ready To Create Application page.**

You will create a project later.

This is the last wizard page. It lists your current selections so that you can review them and use the Back button to go back and change them if necessary.
12 Make sure the Generate To-Do List check box is selected. Click Finish.

The Template Application wizard creates the pbtutor.pbt target and the pbtutor.pbl library, and sets the new pbtutor application as the default application.

You can expand the System Tree to view all the objects that have been created by the Template Application wizard. The System Tree does not display the file extension of the pbtutor target, but it does display the directory where the target file is saved.

The pbtutor.pbl library displays under the pbtutor target in the System Tree. It contains the target Application object, which has the same name as the target object but displays under the library file. Other objects generated by the wizard also display under the library file.
Specify an icon for the application

Where you are
Create a new workspace
Create a target
> Specify an icon for the application
  Change the size of the main window
  Run the application

Now you specify an icon for the application. The icon appears in the workspace when you minimize the application during execution. PowerBuilder includes the icon automatically when you create an executable file. You specify an icon from the Properties view in the Application painter.

1 Double-click the pbtutor Application object in the System Tree
   or
   Right-click the pbtutor Application object in the System Tree and select Edit from the pop-up menu.

   The pbtutor Application object is located under the pbtutor library, which is under the pbtutor target object that you created with the Template Application wizard. Different views of the Application object display in the Application painter.
Specify an icon for the application

2  Make sure the Properties view displays in the Application painter.
   If the Properties view is not open, you can open it by selecting View>Properties from the menu bar. The menu item is grayed out if the Properties view is already open.

3  Click the Additional Properties button in the Properties view.
   A tabbed Application property sheet displays.

4  Select the Icon tab.

5  Click Browse.
   Navigate to the Tutorial directory.
6 Select the tutorial.ico file.
Click Open.

If you do not see the ICO file extension
You do not see ICO file extensions if the Hide File Extensions for Known
File Types check box is selected in the Options dialog box of your
Windows Explorer.

The tutorial icon displays on the Icon page of the Application property
sheet.

7 Click OK.
Click the Save button in PainterBar1 or select File>Save.
Click the Close button in PainterBar1 or select File>Close.
Change the size of the main window

<table>
<thead>
<tr>
<th>Where you are</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create a new workspace</td>
</tr>
<tr>
<td>Create a target</td>
</tr>
<tr>
<td>Specify an icon for the application</td>
</tr>
<tr>
<td>Change the size of the main window</td>
</tr>
<tr>
<td>Run the application</td>
</tr>
</tbody>
</table>

Now you change the size of the application’s main window. When you run the application, the main window displays in the position and size that you specify.

1. **Double-click w_pbtutor_frame in the System Tree.**
   The Window painter opens the application’s frame window.

2. **Check the Center check box on the General page in the Properties view.**
   Now when you run the application, the frame window will be centered.
3 Scroll down and select normal in the WindowState drop-down list box.

If your Properties view looks different
You can change the position of Properties view labels by right-clicking the Properties view and selecting a preference from the pop-up menu. You can position the labels either to the left of all fields, or on top of the text fields and to the right of the check boxes.

4 Click the Other tab in the Properties view.

5 Type 3000 in the Width text box and 2400 in the Height text box.

The size of the window rectangle in the Layout view changes. The values you type are in PowerBuilder Units (PBUs).
Change the size of the main window

6 Press the Tab key.

7 Select File>Close from the PowerBuilder menu. 
Click Yes when you are prompted to save your changes. 
The Window painter closes. 
Next you run the application. When you run the application, the frame window will be centered and sized as you specified.
Run the application

Where you are
Create a new workspace
Create a target
Specify an icon for the application
Change the size of the main window
> Run the application

Now you run the application to see how it works. At this point the application does not do very much. By running the application, you can see the windows and menus that were created for you when PowerBuilder generated the application based on your choices. You will modify them later.

1  Click the Run button on the PowerBar.

The MDI frame window displays and is maximized. All MDI applications created using the Wizard have a menu bar and a toolbar with some items already coded for you.

2  Select File>New>Maintain Customers.

The application opens a sheet window. The display name that you typed in the Template Application wizard for Sheet 1 appears in the title bar. The sheet window title has a number after it to indicate the instance of the window that displays.
Run the application

About the number in the window title bar
The number 1 appears following the window title because this is the first instance of the w_customers sheet window that is open. The code that adds the instance number to the title bar is in the ue_postopen event of the w_master_detail_ancestor base sheet window.

3 Select File>New>Maintain Products.
A second application sheet window displays.

4 Select Window>Tile Horizontal.
The sheet windows are arranged horizontally inside the MDI frame, with the active sheet window at the top.

5 Select File>Toolbars from the menu bar.
The application displays the Toolbars dialog box.
6 Select Floating in the Toolbars dialog box.
The toolbar floats within the MDI frame. You might need to move the Toolbars dialog box to see the floating toolbar.

7 Select Top.
The toolbar is repositioned at the top of the frame.

8 Click Done to close the Toolbars dialog box.

9 Select File>Exit.
The application closes and you return to the PowerBuilder development environment.
When you exit and restart PowerBuilder, you might want to have PowerBuilder in the state it was in when you exited, with the workspace and painters you were working in open.

10 Select Tools>System Options from the menu bar and then click the Workspaces tab.

![System Options dialog box]

PowerBuilder creates registry entries for each workspace and target file you open. "Clean Up" will remove the registry entries for all workspace and target files that no longer exist.
11 Make sure the Reopen Workspace On Startup and the Reload Painters When Opening Workspace check boxes are selected. Click OK.

Now when PowerBuilder starts up, it opens the workspace and the painters that were open when you exited. If you were coding in PowerBuilder when you exited, the last script you were working on opens at the last line you edited.
Customizing the PowerBuilder Environment

This lesson provides the information you need in order to become familiar with the PowerBuilder environment and to customize the workspace. This lesson is optional—you can skip to Lesson 3 if you want to.

In this lesson you:

- Manipulate the System Tree window
- Open an object
- Manipulate views
- Set up the toolbars

How long does it take?
About 25 minutes.
Manipulate the System Tree window

The Workspace page in the System Tree provides you with an overview of your work. (The other pages of the System Tree are relevant for JSP targets, but not for PowerScript targets). By expanding the workspace and the objects it contains, you can see the content and structure of your target.

You can work directly with all the objects in the workspace. For example, you can edit, run, search, or regenerate a window using its pop-up menu in the System Tree. In this exercise you reposition, close, and open the System Tree. You can reposition the System Tree in relation to the main window using its drag bar. You can also change the way the System Tree, Clip, and Output windows are arranged.

1  Click the Output button in the PowerBar to display the Output window.

2  Select Tools>System Options from the menu bar.
Clear the Horizontal Dock Windows Dominate check box on the General page and click OK.

The System Tree and Clip windows now occupy the full height of the main window.

3  Click and hold the drag bar at the top of the System Tree.
Drag the System Tree to position it above, below, or to the right of the painter workspace.

The painter workspace is the gray (blank) area, initially to the right of the System Tree, where painters display when you open an object.

When you start dragging the System Tree, a gray rectangular outline displays. It indicates the area that the System Tree would occupy if you released the mouse button.
4 When the gray rectangular outline is positioned where you want the System Tree to display, release the mouse button.

The System Tree displays in the new location.

5 Close the System Tree by clicking the SysTree button in the PowerBar.

The current workspace remains open, but the System Tree closes. Closing the System Tree leaves more space for the painter workspace views.

6 Reopen the System Tree by clicking the SysTree button in the PowerBar again.

7 Select Tools>System Options from the menu bar. Select the Horizontal Dock Windows Dominate check box on the General page and click OK.

You change back to the default selection for this design-time property.

8 Close the Clip and Output windows by clicking their buttons on the PowerBar or by clicking the small x in the corner of each window.

9 Right-click MyWorkspace and select Close from the pop-up menu.

The workspace closes. No workspaces display in the System Tree.
Open an object

Open an object

Where you are
Manipulate the System Tree window
> Open an object
Manipulate views
Set up the toolbars

Now you open an object created by the Template Application wizard.

1. Select File>Recent Workspaces from the menu bar, then MyWorkspace from the cascading menu.

2. In the System Tree, expand MyWorkspace, the pbtutor target, and pbtutor.pbl.

3. Double-click the pbtutor Application object
   or
   Right-click the pbtutor Application object and select Edit from the pop-up menu.

The Application painter opens. It displays different views of the pbtutor Application object. Your view layout scheme may look different. To display the default layout, select View>Layouts>Default.
The default Application painter layout displays two stacks of tabbed panes. The left stack contains tabs for a Script view (Open tab—it is set to the Open event on the Application object), an Event List view, a Function List view, and the Declare Instance Variables view. The right stack contains tabs for the Properties view and a Non-Visual Object List view.

4 **Look at the code in the Open event in the Script view.**

The PowerScript code that was generated by the wizard in the Application Object Open event calls a PowerScript function to open the main window in the application. You will modify this code later in the tutorial.
Manipulate views

Now you learn to control the location and appearance of PowerBuilder painter views. You can add views to a painter workspace by selecting them from the View menu in the workspace menu bar.

You can add multiple views of the same type and you can combine views into a stack of panes with selection tabs at the bottom. You can resize a view by grabbing and dragging the separator bars that surround it or that surround neighboring views in the painter workspace.

These exercises demonstrate how you can change the appearance of Application painter views, but you can manipulate views in all painters in the same way.

Now you:

• Add an extra Script view
• Display view title bars
• Float and dock views
• Manipulate tabbed views
• Save a view layout scheme
• Reset the default view layout scheme
Add an extra Script view

The default Application painter layout actually has two Script views. One of the Script views displays the script for an Application object event, and the other Script view displays the declared variables for the object instance or the entire application. Both of these Script views are in the same stack of tabbed views (panes).

Now you add a third Script view that is not part of a stack of tabbed panes. You can add multiple Script views to your painter layout, but no two Script views can display the same script at the same time.

1 Select View>Script from the menu bar.

A new Script view displays. It is not attached to a stack of tabbed panes. It lists the Application object in the left drop-down list box. The other two drop-down lists are empty and the right drop-down list is grayed out.

If an existing Script view shows the Open event, the new Script view is empty. Otherwise it displays the Open event.

2 Select the Close event from the second drop-down list box.

If another Script view is already open to the Close event, an error message displays in the PowerBuilder status bar.
Manipulate views

Display view title bars

Now you display a view title bar by pinning it to the painter workspace background. If a title bar is unpinned, you see it only when your cursor pauses near the top edge of a view.

1  Move the cursor to the top of the extra Script view you just added.

The view title bar rolls down. It contains a pushpin button on the left and a maximize/minimize button and a close button on the right. The name of the view displays on the left side of the title bar, next to the pushpin button.

2  Click the pushpin in the title bar

or

Right-click the view title bar and click Pinned from the pop-up menu.

The pushpin button and the Pinned menu item are toggle switches. You can click the pushpin button or the pop-up menu item to pin and unpin the view title bars.

Float and dock views

Now you float and dock a view in the painter workspace. Floating a view enables you to move it around outside the painter frame.

1  Right-click the title bar of an unstacked view you want to float

or

Right-click the tab of a view in a stack of tabbed panes.

If the title bar is not pinned, move the cursor over the title bar area and wait until it displays before you right-click it.

2  Click Float in the pop-up menu.

When a view is floated, the Float menu item is not enabled. When a view is docked, the Dock menu item is not enabled.

3  Drag the view around the screen.

Notice that the floating property allows you to move the view outside the painter workspace.
4 Right-click the title bar of the floating view.  
Click Dock in the pop-up menu.  
The view returns to its original location.

Manipulate tabbed views

Now you separate a view from a stack of tabbed panes and place it above the stack. You then return it to the stack and change its position in the stack.

1 Press and hold the mouse button on the Function List tab.  
Drag the tab onto the separator bar that separates the two default stacks in the Application painter.  
Release the mouse button.  
When you release the mouse button, the Function List view is no longer part of a stack. If you drag the tab too far and release it over the right stack with the Properties view and Non-Visual Object List, the Function List becomes part of that stack.

Alternate way to float a view from a stack  
If you hold the Ctrl or Shift key down as you drag a tabbed pane from a stack, the pane becomes a floating view.

2 Press and hold the mouse button on the Function List title bar.  
Drag it over the stack from which you separated it.  
Release the mouse button when the gray rectangular outline of the Function List view overlaps the stack.  
The Function List view returns to its original stack, but it is added as the last pane in the stack.

3 Press and hold the mouse button on the Function List tab.  
Drag it sideways over the other tabs in the same stack.  
Release the mouse button when the small gray rectangular outline overlaps another tab in the stack of tabbed panes.  
The Function List view moves to the position in the stack where you release the mouse button.
Save a view layout scheme

You can save view layout schemes for a PowerBuilder painter and use them every time you open the painter.

1. Arrange the views in the painter as you like.

2. Select View>Layouts>Manage from the menu bar.

3. Click the New Layout button in the Layout dialog box.

4. Enter a name for your layout in the text field, click the background of the dialog box, and then click the x button in the upper right corner of the dialog box to close it.

Your layout scheme is saved. Now, when you select View>Layouts, you see your layout listed on the cascading menu.

Saving the toolbars and System Tree layouts
PowerBuilder saves the customizations you make to the toolbars and System Tree separately from the view layout. It retains those settings and reapplies them to every workspace you access and every view layout you select.

Reset the default view layout scheme

Each PowerBuilder painter has a default view layout scheme. You can always reset the layout scheme to this default layout.

1. Select View>Layouts from the menu bar.

2. Choose Default from the cascading menu.

The default view layout scheme displays in the painter workspace.
Set up the toolbars

Where you are
Manipulate the System Tree window
Open an object
Manipulate views
> Set up the toolbars

A painter workspace always includes the PowerBar and other PainterBar toolbars that you can use as you work. The buttons in the toolbars change depending on the type of target or object you are working with. You can also customize the toolbars to include additional functionality.

Now you change the appearance of the toolbars to:

• Show labels on toolbar buttons
• Float the toolbars
• Reposition the toolbars

Show labels on toolbar buttons

You can learn a toolbar button’s function by placing the cursor over it to view its PowerTip. A PowerTip is pop-up text that indicates a button’s function.

You can also display a label on each toolbar button.

1 Move the pointer to any button on the PowerBar, but do not click.

   The button’s PowerTip displays.

   ![PowerTip display](image)

2 Select Tools>Toolbars from the menu bar.

   The Toolbars dialog box displays.

3 Select the Show Text check box, then click the Close button.

   PowerBuilder displays a label on each of the buttons in the PowerBar and the PainterBars.
Set up the toolbars

Float the toolbars

You can float the toolbars so that you can move them around the painter workspace as you work.

1  **Right-click anywhere in the PowerBar.**

   The pop-up menu for the toolbars displays. From the pop-up menu you can set the toolbar’s location to the left, top, right, or bottom of the workspace. You can also set it to floating.

   ![Pop-up menu](image)

   **About pop-up menus**
   Throughout PowerBuilder, pop-up menus provide a fast way to do things. The menu items available in the pop-up depend on the painter you are using and where you are in the workspace when you click the right mouse button.

2  **Select Floating from the pop-up menu.**

   The PowerBar changes to a floating toolbar. You can adjust its shape.
3 Move the pointer to an edge or border area in the PowerBar. Press and drag the PowerBar toward the left side of the workspace. Release the mouse button when the PowerBar becomes a vertical bar.

Reposition the toolbars

You can customize the position of the toolbars to suit your work style.

1 Select Tools>Toolbars from the menu bar.

The Toolbars dialog box displays. The selected Move radio button indicates the position of the currently selected toolbar.
Set up the toolbars

2 Click Top.
This repositions the PowerBar at the top of the workspace.

Radio buttons are grayed if a selected toolbar is hidden
If a selected toolbar is hidden (not visible) in the painter, you cannot select where it appears in the workspace. In this case, the radio buttons are grayed and you must first click the Show button before you can select a radio button. The Show button replaces the Hide button when a toolbar is hidden.

3 Click PainterBar1 in the Select Toolbar list box and select Right.
Click Close in the Toolbars dialog box.

4 Right-click PainterBar2 and select Left from the pop-up menu.
You have swapped the locations of the two painter bars.

5 Arrange the toolbars to suit your preferences.
You can also drag the toolbars to the top, bottom, left, or right of the painter workspace. When a toolbar is in a fixed location, it has a drag bar at the left or top of its buttons. You can click the drag bar and drag the mouse to move the toolbar around the painter workspace.

PowerBuilder applies toolbar configuration properties to all painters and saves them for the next PowerBuilder session.

6 Close the Application painter.

If you are not continuing immediately with the tutorial
You can close PowerBuilder or the tutorial workspace if you want. In that case, you must open the tutorial workspace before you continue with the next lesson.
LESSON 3

Building a Login Window

Windows are the main interface between users and PowerBuilder applications. Windows can display information, request information from a user, and respond to mouse or keyboard actions.

Windows are separate objects that you create using the Window painter. In PowerBuilder, you can create windows anytime during the application development process.

In this lesson you:

• Create a new window
• Add controls to the window
• Change the tab order on the window
• Code some Help events and preview the window
• Write the script to open the window

How long does it take?
About 25 minutes.
Create a new window

About response windows
Response windows are dialog boxes that require information from the user. Response windows are application modal. When a response window displays, it is the active window (it has focus) and no other window in the application is accessible until the user responds. The user can go to other applications, but when the user returns to the application, the response window is still active.

1. Click the New button in the PowerBar.
   The New dialog box displays.

2. Click the PB Object tab. Select the Window icon and click OK.
   The Window painter opens. Notice that you have two new toolbars, the StyleBar (with character style and text alignment buttons) and PainterBar3 (with color and border buttons, as well as grayed out control alignment buttons).

3. Make sure that the Layout view and the Properties view display in the Window painter.
   You can display these views by selecting them from the View menu. If they are grayed out in the menu, the views are already displayed in the painter.
   The default view layout scheme contains both views.
Lesson 3    Building a Login Window

To retrieve the default painter layout
Select View>Layouts>Default from the workspace menu bar.

The rectangle in the Layout view represents the window you are building. The default properties in the Properties view indicate that the window is visible and enabled, and has the Main window type. You might need to scroll down in the Properties view to see the window type.

If your window does not have a pegboard look
If the window in your Layout view displays as a solid color, the Show Grid option has been disabled. To enable it, select Design>Options from the menu bar. Then select the Show Grid check box on the General page of the Options dialog box. Click Apply, then OK to save the change and close the dialog box.
Create a new window

4 Type Welcome in the Title text box on the General page of the Properties view.

5 Select response! in the Window Type drop-down list box. Make sure the TitleBar and ControlMenu check boxes are selected. Select the ContextHelp check box.

   The ContextHelp property adds a question-mark button next to the (ControlMenu) close button in the login window’s title bar. Users of your application can click the question-mark button to trigger Help events for the window controls. You can add a question-mark button to a response window, but not to a main window.

6 Click the Other tab in the Properties view. Type 2300 in the Width text box and 1000 in the Height text box. Press the Tab key.

   The size of the window rectangle in the Layout view changes. The values you type are in PowerBuilder Units (PBUs). You might need to modify these values later, while you are adding controls to the window.

Other methods for entering position properties
You can use the spin controls to enter values instead of typing them.

   Alternatively, you can change the size of the login window in the Layout view by moving the pointer to the bottom or right edge of the window. When it turns into a double-headed arrow, you can drag the arrow to change the window size.

7 Select File>Save from the menu bar.

   The Save Window dialog box displays. The only library in the Application Libraries text box is pbtutor.pbl, and it is selected.
8 Type \texttt{w\_welcome} for the window name. 

The prefix \texttt{w\_} is standard for windows.

9 (Optional) Type the following lines in the Comments text box:

This is the login window. It requires the application user to enter an ID and a password before continuing.

These comments are visible in the List view of the Library painter.

10 Click OK.

PowerBuilder saves the new login window. If you expand MyWorkspace, pbtutor, and pbtutor.pbl in the system tree, you can see \texttt{w\_welcome} listed under it.
Add controls to the window

Where you are
Create a new window
> Add controls to the window
Change the tab order on the window
Code some Help events and preview the window
Write the script to open the window

Controls allow users to interact with PowerBuilder objects, such as windows and DataWindows. You set properties of these controls and later add script for control events and functions.

Selecting a control button from the PainterBar You can add controls from the Insert menu or by selecting a control button in PainterBar1. Unless you customize your toolbars, there is only one control button that appears in the PainterBar. When you first open a painter, PainterBar1 includes the CommandButton control button, which has a down arrow to its right. Clicking the down arrow displays a drop-down list of control buttons.

Some of the controls you can select from the drop-down list are described in the table below:

<table>
<thead>
<tr>
<th>Button appearance</th>
<th>Control type</th>
<th>Use in tutorial</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="Image" alt="CommandButton" /></td>
<td>CommandButton</td>
<td>Default icon for the control button in PainterBar1. You add command buttons later in this lesson.</td>
</tr>
<tr>
<td><img src="Image" alt="Picture" /></td>
<td>Picture</td>
<td>To add a picture to the login window.</td>
</tr>
<tr>
<td><img src="Image" alt="PictureHyperlink" /></td>
<td>PictureHyperlink</td>
<td>Not used in tutorial. Its purpose is to provide a link to a Web site.</td>
</tr>
<tr>
<td><img src="Image" alt="PushButton" /></td>
<td>PictureButton</td>
<td>Not used in tutorial. It is like a command button, but it displays a picture as well as text.</td>
</tr>
<tr>
<td><img src="Image" alt="StaticText" /></td>
<td>StaticText</td>
<td>To add text labels to the login window.</td>
</tr>
<tr>
<td><img src="Image" alt="StaticHyperLink" /></td>
<td>StaticHyperLink</td>
<td>To provide a link to a Web site.</td>
</tr>
</tbody>
</table>
After you select a control, it appears in place of the CommandButton button on PainterBar1.

<table>
<thead>
<tr>
<th>Button appearance</th>
<th>Control type</th>
<th>Use in tutorial</th>
</tr>
</thead>
<tbody>
<tr>
<td>SingleLineEdit</td>
<td></td>
<td>To add user entry text boxes to the login window.</td>
</tr>
<tr>
<td>MultiLineEdit</td>
<td></td>
<td>Not used in tutorial. Its purpose is to add a multiline edit text box.</td>
</tr>
</tbody>
</table>

**Adding controls with a 3D appearance**

To make your controls look three dimensional, select Design>Options from the menu bar and make sure that the Default To 3D check box is selected on the General page of the Options dialog box. You can change the window background color from the default color of ButtonFace gray using the Properties view in the Window painter.

Now you modify the login window you just created by adding controls and changing some of their properties. You:

- Add a Picture control
- Add StaticText controls
- Specify properties of the StaticText controls
- Add SingleLineEdit controls
- Specify properties of the SingleLineEdit controls
- Add CommandButton controls
- Specify properties of the CommandButton controls
Add controls to the window

Add a Picture control

Now you add a Picture control to the login window.

1 Select the Picture button from the drop-down list of controls
   or
   Select Insert>Control>PictureButton from the menu bar.

2 Click inside the rectangular window in the Layout view.
   A Picture control displays at the selected location. At the same time you
   add the control, the Properties view switches from displaying the window
   properties to displaying the control properties.
   If you do not see the Properties view, select View>Properties from the
   menu bar. If the Properties view does not display the control properties,
   click the picture control in the Layout view.

   How to delete controls
   If you add a control to the window and later decide you do not want it,
   select the control and press the Delete key. This deletes the control and its
   scripts.

3 Select the text p_1 in the Name text box on the General tab of the
   Properties view.
   Type p_sports in the Name text box.
   This names the Picture control. The prefix p_ is standard for Picture
   controls.

4 Click the ellipsis button next to the PictureName text box.
   The Select Picture dialog box displays.

5 Navigate to the Tutorial directory if it is not already selected.
   Select the tutsport.bmp file.
   The bitmap you selected appears in the control you added to the Layout
   view. The Visible, Enabled, and OriginalSize check boxes are selected by
   default in the Properties view.
6 Make sure the picture control is selected in the Layout view. Click the Other tab in the Properties view. Type 40 in the X text box and 50 in the Y text box.

You can use the spin controls in the X and Y text boxes to enter these values. You might want to adjust the position of the picture control again after you preview the window at the end of this lesson.

7 Type 300 in the Width text box and 250 in the Height text box.

You change the size of the picture control. You might want to adjust the picture size again after you preview the window.

Add StaticText controls

Now you add StaticText controls to the login window. You will use these controls to add descriptive labels to the login window.

1 Select the Text button from the drop-down list of controls or Select Insert>Control>StaticText from the menu bar.

2 Click to the right of the Picture control you added in the Layout view.

A StaticText control displays at the selected location.
Add controls to the window

3 Right-click the StaticText control and select Duplicate from the pop-up menu.
PowerBuilder creates a duplicate of the selected control.

4 Select Duplicate from the StaticText control's pop-up menu again.
PowerBuilder creates another duplicate.
You now have three StaticText controls arranged vertically at the top of the window.

5 Adjust the location of the Static Text controls so that there are at least two grid lines between them.

Specify properties of the StaticText controls
Now you specify the properties of the StaticText controls (label text boxes) to define how they should appear on the login window.

1 Select the first StaticText control you added by clicking on it.
The Properties view displays properties of the StaticText control. If you do not see the Properties view, select View>Properties from the menu bar.

2 Select the text st_1 in the Name text box on the General page of the Properties view.
Type st_welcome in the Name text box.
Now the control has a more descriptive name. The prefix st_ is standard for StaticText controls.

3 Select the text none in the Text text box.
Type Welcome to SportsWear, Inc.
If you press Enter, click to another field or tab to another page in the Properties view, or click in a different view, the text you typed replaces none in the Layout view.
4 Click the Font tab in the Properties view. Change the TextSize property for this control to 18 points.

The size of the text in the control changes.

The default typeface is Arial TrueType. You can select a different typeface and font size if this one is not available on your system.

Using the StyleBar
You can also use the StyleBar to change fonts. If you do not see the StyleBar, select Tools>Toolbars from the menu bar, click StyleBar in the Select Toolbar list box, and then select one of the Move positions such as bottom or floating.

5 Adjust the size of the StaticText control to fit the text you entered. Keep adjusting the size until you see all of the text you entered.

To adjust the size, drag the upper-right corner of the control toward the upper-right corner of the window in the Layout view. You can also adjust the size by entering appropriate values on the Other page of the Properties view for this control.

6 Select the second StaticText control you added in the Layout view. Type st_userid in the Name text box on the Properties view General page. Type User ID: in the Text text box and press the Tab key.

The text displayed in the control changes.
7 Select the third StaticText control you added in the Layout view. Type `st_password` in the Name text box on the Properties view General page. Type `Password:` in the Text text box and press the Tab key.

Your changes display in the Layout view.

---

**Add SingleLineEdit controls**

Now you add two SingleLineEdit controls to the window to allow the user to enter a user ID and password for connecting to the database. A SingleLineEdit control is a text box in which the user can enter a single line of text. SingleLineEdit controls are typically used for the input and output of data.

1. Select the SingleLineEdit button from the drop-down list of controls or
   Select Insert>Control>SingleLineEdit from the menu bar.

2. Click to the right of the `st_userid` StaticText control in the Layout view.
   A SingleLineEdit control displays where you clicked.

3. Increase the width of the SingleLineEdit control.
4 Right-click the SingleLineEdit control and select Duplicate from the pop-up menu. Adjust the position of this SingleLineEdit control so that it is just to the right of the st_password StaticText control.

You should now have two SingleLineEdit controls arranged vertically to the right of the StaticText controls.

Specify properties of the SingleLineEdit controls

Now you define the properties of the SingleLineEdit controls you just added to the login window.

1 Select the first SingleLineEdit control you added.

The General page of the Properties view displays properties of the SingleLineEdit control. If you do not see the Properties view, select View>Properties from the menu bar.

2 Select the text sle_1 in the Name text box. Type sle_userid in the Name text box. Clear the default text none in the Text text box.

The prefix sle_ is standard for SingleLineEdit controls.
Add controls to the window

3 Select the second SingleLineEdit control you added. Type sle_password in the Name text box. Clear the default text none in the Text text box. Select the Password check box.

Because you checked the Password check box, the password the user types at runtime will display as a string of asterisks.

Add CommandButton controls

Now you add CommandButton controls. Later you define scripts that execute when users click these buttons.

1 Select the CommandButton button from the drop-down list of controls
   or
   Select Insert>Control>CommandButton from the menu bar.

2 Click to the right of the sle_userid SingleLineEdit control. A CommandButton control displays where you clicked.

3 Right-click the CommandButton control and select Duplicate from the pop-up menu. PowerBuilder creates a duplicate of the selected control.

4 Adjust the location of the controls as needed so that there is some space between them.

Specify properties of the CommandButton controls

Now you define the properties of the CommandButton controls.

1 Select the top CommandButton control. The General page of the Properties view displays properties of the CommandButton control.
2 Type `cb_ok` in the Name text box on the Properties view General page.
   Type `OK` in the Text text box.
   Select the Default check box.

   This step changes the default name of the control to something more descriptive and adds a text label (OK) to the button. Because you selected the Default check box, when an application user presses the Enter key, the Clicked event for this button will be triggered. (The user does not have to click the button itself for the event to be triggered.)

3 Select the bottom CommandButton control.
   Type `cb_cancel` in the Name text box.
   Type `Cancel` in the Text text box.
   Select the Cancel check box.

   Because you selected the Cancel check box, when an application user presses the Esc key, the Clicked event for this button will be triggered.
Change the tab order on the window

When you place controls in a window, PowerBuilder assigns them a default tab order. The tab order determines the sequence in which focus moves from control to control when the user presses the Tab key.

Now you change the tab order for the window you created.

1. **Select Format>Tab Order from the menu bar.**
   PowerBuilder displays the default tab order. The number in red at the right of each control shows the control’s relative position in the tab order. Controls with the number zero are skipped when the user tabs in the window.

2. **Click the tab order number for the sle_userid control.**
   Type 10 if the tab order value for this control is not already 10.
   You can type a new tab order number only when the old number turns blue against a red background.

3. **Make changes as needed so that the other controls have these values:**

<table>
<thead>
<tr>
<th>Click this control</th>
<th>Control name</th>
<th>Has this value</th>
</tr>
</thead>
<tbody>
<tr>
<td>SingleLineEdit control for entering a password</td>
<td>sle_password</td>
<td>20</td>
</tr>
<tr>
<td>CommandButton control for the OK button</td>
<td>cb_ok</td>
<td>30</td>
</tr>
<tr>
<td>CommandButton control for the Cancel button</td>
<td>cb_cancel</td>
<td>40</td>
</tr>
</tbody>
</table>
4 **Select Format>Tab Order from the menu bar.**

This is a toggle switch. Selecting this menu item a second time saves your changes and clears the tab order numbers from the login window. You can also use the Tab Order button on the PainterBar.
Code some Help events and preview the window

Where you are
Create a new window
Add controls to the window
Change the tab order on the window
> Code some Help events and preview the window
Write the script to open the window

Now you use the Script view to add context-sensitive Help messages to the SingleLineEdit controls that you placed on the login window, and you preview the window.

Using the Script view  The Script view has three drop-down list boxes. The first drop-down list box displays the list of available controls for the current object plus two special entries, Functions and Declare. The contents of the second drop-down list box depend on the selection in the first drop-down list box. The third drop-down list box contains all ancestor objects of the current object, if any.

<table>
<thead>
<tr>
<th>Selection in first drop-down list box</th>
<th>Contents of second drop-down list box</th>
<th>Contents of third drop-down list box</th>
</tr>
</thead>
<tbody>
<tr>
<td>An object or control name</td>
<td>List of events for the selected object or control.</td>
<td>All of the ancestor objects of the current object, if any</td>
</tr>
<tr>
<td>Functions</td>
<td>List of editable functions. Displays (New Function) if no editable functions exist.</td>
<td>All ancestor objects with functions having the same signature as selected function</td>
</tr>
<tr>
<td>Declare</td>
<td>List of declaration types: global, shared, and instance variables, and global and local external functions.</td>
<td>Empty</td>
</tr>
</tbody>
</table>

If the Script view is not currently displayed in your Window painter, you can open it by double-clicking an object in the Layout view.

1  **Double-click the top SingleLineEdit control in the Layout view.**

   The object name, sle_userid, appears in the first drop-down list box in the Script view.
2 Select the Help event in the second drop-down list box in the Script view.

The Help event has the prototype: `help (integer xpos, integer ypos) returns long [pbm_help]`

3 Type the following line of PowerScript code in the script area:

   `ShowPopupHelp("pbtutor.hlp", this, 100)`

You can find the `pbtutor.hlp` file in the Tutorial directory. The second argument refers to the current SingleLineEdit control, and the last argument refers to a context ID in the pbtutor.hlp file.

As you type text in the Script view, notice that PowerBuilder changes the text colors to show what kind of syntax element you have entered (such as keywords, variables, and comments).

4 Select `sle_password` from the first drop-down list box in the Script view.

Select the Help event in the second drop-down list box.

PowerBuilder compiles the code you typed for the Help event of the `sle_userid` SingleLineEdit text box. You now add a Help event for the `sle_password` SingleLineEdit text box.

5 Type the following lines in the script area:

   `ShowPopupHelp("pbtutor.hlp", this, 200)`

6 Select File>Run/Preview from the menu bar or Click the Run/Preview Object in the PowerBar.

The Run dialog box displays. Be sure the Objects of Type list box displays Windows and the w_welcome object is selected.
Previewing the window
You can preview the window without running scripts by selecting Design>Preview on the menu bar or the Preview button in PainterBar1 (which uses the same icon as the Run/Preview Object button in the PowerBar). However, you must run scripts to view the results of the Help event scripts you just entered.

7 Click OK.
A message box prompts you to save your changes.

8 Click Yes.
The login window appears as it would at runtime. If you do not like the window layout, you can change the size, location, and fonts of the window controls when you go back to the Window painter workspace.

9 Click the question-mark button in the login window title bar.
Click inside the sle_userid SingleLineEdit text box.
A message displays: Type your user ID here. This text is associated with context ID 100 in the pbtutor.hlp file. You entered the context ID as an argument of the ShowPopupHelp call for the sle_userid Help event.

10 Click anywhere in the window to close the message.
Click inside the sle_password SingleLineEdit text box.
Press F1.
A message displays: Type your password here. This text is associated with context ID 200 in the pbtutor.hlp file.
11 Click anywhere in the window to close the message. Click the close button in the login window title bar.

You return to the Window painter workspace.

Later you add code to the Clicked event for the Cancel button that closes the application.

12 Close the Window painter by clicking the close button in PainterBar 1.

The close button is labeled with an x.
Now you add a one-line script to open the login window as soon as the application starts executing. Although you could change the script in the Application object Open event to open the login window, in this tutorial you make the call to open the login window from the Open event of the MDI frame window. This window (w_pbtutor_frame) was created by the Template Application wizard.

In wizard-generated script, the frame window is called by the Application object Open event. When you add a call to open the login window from the MDI frame window Open event, the login window still displays before the frame window. Because the login window is a response window, it temporarily blocks execution of the remainder of the frame window Open event script.

In this exercise you:

- Modify the frame window Open event
- Compile the script
Modify the frame window Open event

Now you modify the frame window Open event script to open the login window.

**Wizard-generated script**

The frame window Open event already has a script associated with it that was generated by the Template Application wizard. The script creates an instance of a wizard-generated user object that serves as a sheet (window) manager. The Open script then calls the ue_postopen event.

The ue_postopen event registers sheet windows with the sheet manager. The event is posted to the end of the messaging queue for the window and is not processed until the remainder of the Open script (that you add in this lesson) is executed.

1. **Select File>Open from the menu bar.**
   Make or verify the following selections in the Open dialog box:

<table>
<thead>
<tr>
<th>Open dialog box item</th>
<th>Selection to make (or verify)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Target</td>
<td>pbtutor—currently your only target</td>
</tr>
<tr>
<td>Libraries</td>
<td>pbtutor.pbl—currently your only library; if you cannot see the full library name, you can</td>
</tr>
<tr>
<td></td>
<td>drag the edge of the dialog box to increase its size</td>
</tr>
<tr>
<td>Object Name</td>
<td>w_pbtutor_frame</td>
</tr>
<tr>
<td>Objects of Type</td>
<td>Windows—you must make sure this is selected before you can select a named object of this</td>
</tr>
<tr>
<td></td>
<td>type</td>
</tr>
<tr>
<td>Using</td>
<td>Painter</td>
</tr>
</tbody>
</table>

   The w_pbtutor_frame object is the main application window created by the Template Application wizard.

2. **Click OK.**

   The Window painter opens and displays views of the main application window in the painter workspace.

   If the Script view is not open, you can open it by selecting View>Script in the workspace menu bar or by double-clicking inside the Layout view.
3. **Move the cursor to the top of the Script view.**
   The view title bar rolls down. It contains a pushpin button on the left and a maximize/minimize button and a close button on the right.

4. **Click the pushpin in the title bar of the Script view.**
   The title bar of the Script view reads:
   
   ```
   Script - open for w_pbtutor_frame returns long
   ```

5. **Make sure the Open event displays in the Script view.**
   
   The PowerScript code in the Script view is preceded by comments.

   **Using comments**
   A comment in PowerScript is indicated by either two forward slashes (\//) at the start of a single-line comment, or a slash and an asterisk (/\*) at the start and an asterisk and a slash (\*/) at the end of a single-line or multiline comment. Comments are not parsed by the script compiler.

   You now modify the Open event script to cause the login window to display.

6. **Click after the parentheses in the line that reads:**
   
   ```
   this.Post Event ue_postopen (  )
   ```
   The ue_postopen event does not take any arguments.

7. **Press Enter twice.**
   This adds a blank line in the Script view for legibility. The cursor moves to a new line following the blank line.
8 **Type** Open the login window **on the new line in the Script view.** Click the Comment button in PainterBar2.

Two slashes appear in front of the line you typed—it is changed into a comment.

9 **Move the cursor to the end of the comment.**
**Press Enter to add a new line.**
**Type** open (w_welcome) **on the new line.**

This calls the Open function to display the login window you created.

---

**Accessing context-sensitive Help**
To access context-sensitive Help for a function or reserved word (such as Open), select the function or reserved word in the Script view and press Shift+F1. You can always open the main Help screen by pressing F1.
Compile the script

Now you compile the script you just typed. In this exercise, you use a pop-up menu item to compile the script. PowerBuilder also compiles a script when you close the Script view or when you select a different object, event, or function for display in the Script view.

Handling errors in scripts
When there is an error in a script, an error window displays at the bottom of the Script view with the line number of the error and the error message.

To find an error  Click on an error message to move the cursor to the line that contains that error. After you correct the error, you can try to compile the script again.

Commenting out errors  PowerBuilder does not save scripts that have errors. If you want to save a script that has errors, select the entire script and click the Comment button to comment out the code. You can come back later, uncomment the code, and fix the problem.

1  Right-click anywhere in the Script view script area.
Select Compile from the pop-up menu.

The script compiles. You do not leave the Script view or the Window painter workspace.

2  Select File>Save from the menu bar.
Select File>Close from the menu bar.

The Window painter closes.
Connecting to the Database

This lesson shows you how to make the application connect to the Enterprise Application Sample demonstration database (EAS Demo DB) at execution time and how to use the Database painter to look at the table definitions and database profile for this database.

In this lesson you:

• Look at the EAS Demo DB database
• Run the Connection Object wizard
• Declare a global variable
• Modify the connection information
• Complete the login and logout scripts
• Run the application

How long does it take?
About 30 minutes.
In many organizations, database specialists maintain the database. If this is true in your organization, you might not need to create and maintain tables within the database. However, to take full advantage of PowerBuilder, you should know how to work with databases.

**Defining a data source**  Using the ODBC administrator or other database connection utilities, you can define a database as a data source for your application. You can access the ODBC Administrator from the Database Profiles dialog box. The definitions of ODBC data sources are stored in the odbc.ini registry key.

**Using database profiles to connect**  Once you define a data source, you can create a database profile for it. A database profile is a named set of parameters that specifies a connection to a particular data source or database. Database profiles provide an easy way for you to manage database connections that you use frequently. When you are developing an application, you can change database profiles to connect to a different data source.

**When database connections occur**  PowerBuilder can establish a connection to the database in either the design-time or runtime environment. PowerBuilder connects to a database when you open certain painters, when you compile or save a PowerBuilder script that contains embedded SQL statements, or when you run a PowerBuilder application that accesses the database.

To maintain database definitions with PowerBuilder, you do most of your work using the Database painter. The Database painter allows you to:

- Create, alter, and drop tables
- Create, alter, and drop primary and foreign keys
- Create and drop indexes
- Define and modify extended attributes for columns
- Drop views
Lesson 4  Connecting to the Database

In this exercise you:

• Look at the database profile for the EAS Demo DB database
• Look at table definitions in the EAS Demo DB database

Look at the database profile for the EAS Demo DB database

If you installed PowerBuilder with standard options, you already have a data source and a database profile defined for the EAS Demo DB database. You use the EAS Demo DB database in this tutorial.

The EAS Demo DB database is an SQL Anywhere database that is accessed through ODBC. In this lesson you look at the database profile for the EAS Demo DB database. PowerBuilder stores database profile parameters in the registry.

1  Click the Database Profile button in the PowerBar
   or
   Select Tools>Database Profile from the menu bar.

   PowerBuilder displays the Database Profiles dialog box, which includes a tree view of the installed database interfaces and defined database profiles for each interface. You can click the + signs or double-click the icons next to items in the tree view to expand or contract tree view nodes.

2  Expand the ODB ODBC node by clicking on the plus sign, and select EAS Demo DB V110.

   PowerBuilder created this profile during installation.
Look at the EAS Demo DB database

If you do not see the EAS Demo DB V110 database profile
If there is no profile for the EAS Demo DB V110 database, you may not have installed the database. You can install it now from the product CD.

If you did install the database and it is defined as a data source in the ODBC Administrator, select ODBC in the tree view of the Database Profile painter and click New. In the Database Profile Setup dialog box, select the data source from the Data Source drop-down list and type EAS Demo DB V110 in the Profile Name text box. Type dba for the user ID and sql for the password, then click OK to return to the painter.
3 **Click Edit.**

PowerBuilder displays the Connection page of the Database Profile Setup dialog box.

4 **Select the Preview tab.**
Look at the EAS Demo DB database

The PowerScript connection syntax for the selected profile is shown on the Preview tab. If you change the profile connection options, the syntax changes accordingly.

5 **Click the Test Connection button.**
A message box tells you that the connection is successful.

If the message box tells you the connection is not successful
Close the message box and verify that the information on the Connection page of the Database Profile Setup dialog box is correct. Then check the configuration of the data source in the ODBC Administrator. You can run the ODBC Administrator by expanding the Utilities folder under the ODB ODBC node of the Database Profile painter and double-clicking the ODBC Administrator item.

6 **Click OK to close the message box.**
**Click Cancel to close the Database Profile Setup dialog box.**
**Click Close to close the Database Profiles dialog box.**
Look at table definitions in the EAS Demo DB database

Now you look at the definitions for the Customer and Product tables in the EAS Demo DB database. This helps you become familiar with the Database painter and the tables you will use in the tutorial.

**What happens when you connect**  To look at the table definitions, you have to connect to the database. When you connect to a database in the development environment, PowerBuilder writes the connection parameters to the Windows registry.

Each time you connect to a different database, PowerBuilder overwrites the existing parameters in the registry with those for the new database connection. When you open a PowerBuilder painter that accesses the database, you automatically connect to the last database used. PowerBuilder determines which database this is by reading the registry.

1. **Click the Database button in the PowerBar.**

PowerBuilder connects to the database and the Database painter opens. The Database painter title bar identifies the active database connection.

The Objects view of the Database painter displays all existing database profiles in a tree view under the Installed Database Interfaces heading. The EAS Demo DB V110 database is visible under the ODB ODBC node in the tree view.

**If the Objects view is not open**

The Objects view is part of the default view layout scheme. To reset to this scheme, select View>Layouts>Default. You can also open an Objects view by selecting View>Objects from the menu bar.
2. Expand the EAS Demo DB V110 database node in the Objects view.

Notice the folders under the EAS Demo DB V110 database node.

3. Expand the Tables folder.

You see the list of tables in the database.

**Table names might have a prefix**

The table names in the Select Tables dialog box might have a prefix such as `dba` or `dbo`. This depends on the login ID you are using. You can ignore the prefix.

4. Right-click the customer table and select Add To Layout from the pop-up menu

or

Drag the customer table from the Objects view to the Object Layout view.
Lesson 4  Connecting to the Database

Dragging an object from one view to another
When you start dragging an object from the Objects view to another view, the pointer changes to a barred circle. If you continue moving the cursor to a view that can accept the object, the barred circle changes back to a pointer with an additional arrow symbol in a small box. When you see this symbol, you can release the object.

5 Repeat step 4 for the product table.

Widening the Object Layout view
You can widen the Object Layout view by dragging its separator bars toward the painter frame. If the Object Layout view is part of a stack, you might find it easier to separate it from the stack before you change its size.

The Object Layout view shows the two tables you selected.
Look at the EAS Demo DB database

Viewing table data types, comments, keys, and indexes
In the Object Layout view, you can see a description for each column, as well as icons for keys and indexes. If you do not see this, right-click a blank area inside the view and select Show Comments, Show Referential Integrity, and then Show Index Keys from the pop-up menu. If you select Show Datatypes, you also see the data type for each column in the selected tables.

6 Right-click the title bar of the customer table in the Object Layout view and select Alter Table from the pop-up menu
or
Right-click the customer table in the Objects tree view and select Alter Table from the pop-up menu.

The Columns view displays the column definitions for the table.

7 Right-click a column in the customer table in the Object Layout view. Select Properties from the pop-up menu.

In the Database painter, the Properties view is also called the Object Details view.

The title bar and tab headings for the Object Details view change dynamically depending on the current object selection. The title bar gives the object type, the database connection, and the object identifier.
The Object Details view for a column has five tabs, one for general database properties, one for column header information, and the others for column extended attributes.

![Object Details view](image)

**About extended attributes**

PowerBuilder stores extended attribute information in system tables of the database. Extended attributes include headers and labels for columns, initial values for columns, validation rules, and display formats.

You can define new extended attributes or change the definitions of existing extended attributes from the pop-up menus of items in the Extended Attributes view of the Database painter.

8 Close the Database painter.
Run the Connection Object wizard

Where you are
Look at the EAS Demo DB database
  > Run the Connection Object wizard
Declare a global variable
Modify the connection information
Complete the login and logout scripts
Run the application

Now you run the Connection Object wizard to create a connection service manager, which you use to establish the runtime database connection.

The connection service manager is a nonvisual user object. It is nonvisual because it does not have a graphic representation in the runtime application; it is a user object because it is a customized object. You use it to perform database connection processing in a PowerBuilder application.

Why you run a second wizard
If you had specified connection information in the Template Application wizard, you would have created the connection service manager when you generated the application. You can use multiple wizards in building your application.

1 Click the To-Do List button in the PowerBar.

The To-Do List was generated by the Template Application wizard.
2. **Double-click the Run Connection Object Wizard item in the list** or **Right-click the Run Connection Object Wizard item. Select Go To Link from the pop-up menu.**

   This is the next-to-last item in the list. The To-Do List lists what you need to do to complete the application. You can also use the list to make comments to yourself or other developers working on the application.

   You can also run the Connection Object wizard from the PB Object page of the New dialog box. You used the New dialog box to run the Template Application wizard in Lesson 1, “Starting PowerBuilder.”

   The first page of the wizard tells you what it can do.

3. **Click Next until the Choose Database Profile page displays.**

   You accept the wizard’s default selections for the destination library (`pbtutor.pbl`) and the database connectivity options (SQL). The Choose Database Connection Profile page lists all the database profiles stored in the registry.

4. **Select EAS Demo DB V110 in the Database Profiles list box if it is not already selected.**

5. **Click Next until the Ready To Create Connection Object page displays.**

   You accept the default settings for the following items:

<table>
<thead>
<tr>
<th>Wizard page</th>
<th>Option</th>
<th>Default selection</th>
</tr>
</thead>
<tbody>
<tr>
<td>Specify Connectivity Source Info</td>
<td>Source of Connection Information</td>
<td>Application INI File</td>
</tr>
<tr>
<td></td>
<td>Connection Service Object</td>
<td>n_pbtutor_connectservice</td>
</tr>
<tr>
<td></td>
<td>Name Application INI File</td>
<td>Application INI File</td>
</tr>
</tbody>
</table>

   The wizard creates the n_pbtutor_connectservice user object to manage your database connections. If you change an instance variable in this connection service object, you can change the source of connection information to the registry or to a script file. Otherwise, the `pbtutor.ini` file—created by the wizard—is used for application connection information.
The last wizard page contains a summary of your choices, including the default selections.

6 **Click Finish.**

The wizard creates the connection service object and opens it in the User Object painter. You can see n_pbtutor_connectservice in the System Tree. The wizard also creates the application INI file. The To-Do List is still open.

7 **Close the To-Do List.**
Declare a global variable

Where you are
Look at the EAS Demo DB database
Run the Connection Object wizard
> Declare a global variable
Modify the connection information
Complete the login and logout scripts
Run the application

You will next examine the new connection service manager and create a global variable to reference it. A global variable is available to all objects in the application.

In more complex applications, you might prefer to reference the connection service manager with local variables. This would release more memory as soon as the local variable went out of scope. But in the tutorial, you should keep an instance of the connection service manager available as long as the database connection is open.

Establishing a connection  To make it possible for an application to connect to the database at execution time, the connection service manager calls a wizard-generated function to set properties for a Transaction object that serves as a communications area between the application and the database.

SQLCA Transaction object  The connection service manager uses a built-in nonvisual system object, the SQL Communications Area (SQLCA) object, as the default Transaction object. The SQLCA object has several default properties (including database name, login ID, and password) that are populated by the connection service manager.

If an application communicates with multiple databases, you can create additional Transaction objects as needed, one for each database connection.

What is required and what is not  You must have a Transaction object to connect to a database. The connection service manager is not required, but is used in the tutorial because it generates Transaction object properties you would otherwise have to type in an application script.
1 Make sure n_pbtutor_connectservice is open in the User Object painter.

Opening the connection service manager
If the n_pbtutor_connectservice object is not open in the User Object painter, double-click n_pbtutor_connectservice in the System Tree.

The default view layout scheme for the User Object painter includes a Script view and a Declare Instance Variables view as part of a stack of tabbed panes.

2 Make sure n_pbtutor_connectservice is selected in the first drop-down list box of the Script view.
Make sure the Constructor event is selected in the second drop-down list box.

The Script view displays the script created by the Connection Object wizard for the Constructor event.

The script calls the function of _GetConnectionInfo to obtain connection information. You will next look at the script for this function.
3 Select Functions in the first drop-down list box in a Script view. 
Select of_GetConnectionInfo in the second drop-down list box.

The script for this function passes database connection information to the 
Constructor event of the connection service manager. The information passed depends on an instance variable. In this case, the value of the 
is_connectfrom variable is 1. You will verify this in a moment. The instance variable is available to all functions and events of the 
n_pbtutor_connectservice object.

Because the is_connectfrom variable is 1, the connection service manager looks to the Database section of the named INI file to get database 
connection information using ProfileString function calls. In this case, the 
named INI file is pbtutor.ini. You created this file with the Connection 
Object wizard.

Later you modify the pbtutor.ini file and the of_GetConnectionInfo 
function to make sure that user ID and password information comes from 
the login window instead of the INI file.

4 Select of_ConnectDB in the second drop-down list box.

This is the connection service manager function that actually connects to 
the database using the SQLCA Transaction object. You call this function from the login window you created in Lesson 3, “Building a Login 
Window.”

Notice that the wizard-generated script for this function also opens a 
message box if the database connection fails.

5 Select of_DisconnectDB in the second drop-down list box.

This is the connection service manager function that disconnects from the 
database. You call this function from the application Close event.

6 Click the Declare Instance Variables tab. 
Make sure Instance Variables is selected in the second drop-down list 
box.

Selecting Declare in Script views
The Declare Instance Variables view is a special instance of the Script 
view. It displays when you select Declare in the first drop-down list box of 
the Script view. However, you cannot select Declare if a second Script 
view already displays instance variables.
Declare a global variable

You can now verify that the value of the is_connectfrom variable is 1.

7 Select Global Variables in the second drop-down list box. Drag n_pbtutor_connectservice from the System Tree to the Script view.

Dragging object and function names from the System Tree to the Script view saves time and helps avoid typing errors.

8 Complete the line by typing the variable name after the object name:

   n_pbtutor_connectservice gnv_connect

Although you declare this object in the Script view for the n_pbtutor_connectservice user object, it is available everywhere in the application.

Naming conventions for variables
To make scripts easier to read, it is best to follow a standard naming convention. The recommended standard is to give each variable a 2-letter or 3-letter prefix followed by an underscore (_). The first letter of the prefix identifies the scope of the variable (for example: g for global, l for local) and the next letter or letters identify the data type (for example: s for string, l for long, or nv for nonvisual object).

9 Click the Save button in the PainterBar
   or
Select File>Save from the menu bar.

PowerBuilder compiles the script and saves it. If you had typed the global variable data type (instead of dragging it from the System Tree) and you made a typing error, an error message would display. You would then correct the error and select Save again.
Modify the connection information

**Where you are**
Look at the EAS Demo DB database
Run the Connection Object wizard
Declare a global variable
> Modify the connection information
Complete the login and logout scripts
Run the application

You can now call the connection service manager to establish a database connection, but you should open a database connection only if the user enters a valid ID and password in the login window. You will therefore add the connection service call to the Clicked event of the OK button on this window, substituting user-entered information for information from the `pbtutor.ini` file.

Before you do that though, you remove or comment out the ProfileString calls that the connection service manager makes to get user ID and password information from theINI file. Then you modify the DBParm parameter in the `pbtutor.ini` file, because it includes hard-coded user ID and password values that were copied from the `pb.ini` file.

In this exercise you:
- Modify the `of_GetConnectionInfo` function
- Call the connection service manager

Modify the `of_GetConnectionInfo` function

You looked at the `of_GetConnectionInfo` function in the last exercise. Now you comment out the information that the function returns for the user ID and password information.

If you closed the User Object painter, you must open it again for the `n_pbtutor_connectservice` user object. You can use the File>Recent Objects menu to redisplay it.

1. **Select Functions in the first drop-down list box in the Script view. Select `of_GetConnectionInfo` in the second drop-down list box.**
2 Select the two ProfileString assignment lines that begin:

```plaintext
as_userid = ProfileString (...)  
as_dbpass = ProfileString (...)  
```

The four arguments of a ProfileString call are the INI file name or variable, the INI file section, the INI file key, and the default value to be used if the INI file name, section, or key is incorrect. These lines are part of the IS_USE_INIFILE case of the CHOOSE CASE statement for the of_GetConnectionInfo function.

3 Click the Comment button in PainterBar2.

By commenting out these lines, you make sure that the user ID and password information do not come from the pbtutor.ini file.

4 Click anywhere in the line that begins:

```plaintext
as_dbparm = ProfileString ( ... )  
```

5 Click the Comment button in PainterBar2.

The DBParm parameter in the pbtutor.ini file includes hard-coded values for the user ID and password as well as the database name. You do not use these values. Instead, you assign values to the DBParm parameter from user-entry information for user ID and password.

---

The SQLCA DBParm parameter

Although the user ID and password are not required for the DBParm ConnectString, assigning them to the ConnectString overwrites user ID and password values in the data source definition for an SQL Anywhere database. For this DBMS, the DBParm parameter also takes precedence over the SQLCA UserID and DBPass parameters.

---

6 Click the Save button in PainterBar1.

Click the Close button in PainterBar1.
Call the connection service manager

You will next call the connection service manager to connect to the database. Because you eventually need to add user-entry information from the login window, you add the call to the Clicked event for the OK button on this window.

An object is considered to be the parent of the controls that are added to it. The login window is therefore the parent of the OK button.

When referring to a parent object in a script, it is usually better practice to use the qualifier parent than to name the object explicitly. This allows the code to be reused more easily for controls placed on a different object. In the script for the Clicked event, you refer to the login window as parent.

Using a single wizard to create the application and connection

If you had created the connection service user object with the Template Application wizard, the code you enter in this exercise to call the connection service manager would have been generated automatically, but it would have been added to the application Open event, not to a Clicked event in a login window. It would also have used a local variable, not a global variable.

1 Double-click w_welcome in the System Tree.
   The Window painter opens.

2 Select cb_ok in the first drop-down list box of the Script view or Double-click the OK button in the Layout view.
   The Clicked event should be the selected event in the second drop-down list box. If it is not, select it. The Clicked event script is empty.

3 Type these lines:
   
   // 1) Instantiate the Transaction object
   // 2) Close login window if connection successful

   These lines explain the code you add to the Clicked event. Adding double slash marks at the front of a line turns it into a comment.

4 Type the following assignment statement below the comments:

   gnv_connect = CREATE &
   n_pbtutor_connectservice
Modify the connection information

Do not type the ampersand (&) if you combine the lines of the script into a single line. The ampersand character indicates that a line of script is continued on the next line.

The CREATE statement instantiates the SQLCA Transaction object with all the values retrieved by the of_GetConnectionInfo function from the pbtutor.ini file. Because you previously commented out the lines for the user ID and password, this information is not retrieved.

For ease of reading, you can add blank lines between the comments and the assignment statement for the global variable gnv_connect.

5 Type the following lines below the CREATE statement:

```
IF gnv_connect.of_ConnectDB () = 0 THEN
  Close (parent)
END IF
```

The of_ConnectDB function connects the application to the database. As you saw earlier in this lesson, if the connection fails (the SQLCode is not 0), a message box opens and displays the SQL error text.

If of_ConnectDB returns a zero (the SQLCode for a successful connection), the lines that follow the IF-THEN statement line are parsed. In this case, the parent window for the cb_ok control (w_welcome) closes.
6 Click the Compile button in PainterBar2
or
Right-click inside the Script view and click Compile in the pop-up menu.

The script should compile without error. If you get an error message, make sure you have typed object and function names correctly and saved gnv_connect as a global variable.

**Toggling the Error window of the Script view**
You can show or hide the Error window by clicking the icon at the far right of the Script view just under the title bar.

You still need to code the Clicked event to instantiate the Transaction object with user-entered connection information.
Complete the login and logout scripts

Where you are
Look at the EAS Demo DB database
Run the Connection Object wizard
Declare a global variable
Modify the connection information
> Complete the login and logout scripts
Run the application

Earlier in this lesson, you called the connection service manager from the Clicked event for the login window OK button. Next you add code to the same Clicked event to instantiate the Transaction object with information entered by the user.

You also add code to the login window Cancel button Clicked event and to the application Closed event.

Minimizing typing errors in the Script view
If you right-click inside the scripting area, you open a pop-up menu that includes Paste Special commands. You can use these commands to paste statements, objects, functions or even the contents of text files into the event script. This reduces the risk of typing errors. You can also use AutoScript to complete code, as you will see in this lesson.

In this exercise you:
• Set up shortcuts for AutoScript
• Add code to the OK button Clicked event
• Add code to the Cancel button Clicked event
• Add code to the application Close event
Set up shortcuts for AutoScript

When you are coding scripts, AutoScript provides help by completing the statement you are typing or displaying a list of language elements that are appropriate to insert in the script at the cursor location.

1. Select Design>Options from the menu bar and click the AutoScript tab.

2. Make sure all the check boxes in the first three group boxes are selected.

3. Make sure the Activate Only After A Dot and Automatic Popup check boxes in the fourth group box are cleared, and click OK.
   
   With these settings, AutoScript provides Help wherever it has enough information to determine what code to insert, but it does not pop up automatically when you pause. By selecting the Statement Templates check box (not selected by default), you can use AutoScript to enter structures for a multiple line PowerScript statement.

4. Select Tools>Keyboard Shortcuts from the menu bar. Expand the Edit node in the tree.


6. Expand the Edit>Go To node in the Current Menu list and select Next Marker. Type Ctrl+M in the shortcut box and click OK.
   
   Now whenever you want help completing code, you can press Ctrl+space to pop up a list of possible completions. If you paste in a statement or function with comments, you can press Ctrl+M to move to the next comment.

7. Click OK.
Complete the login and logout scripts

Add code to the OK button Clicked event

As is often the case when you are developing production applications, you get some of the connection properties from an initialization file and some from user input.

For the tutorial application, you should not get the user ID and password from the tutorial INI file. Get them directly from the user in the login window and then pass the database information in a script.

1  Make sure you are looking at the Clicked event script for the cb_ok control.

This is the script in which you added the call to the Connection Service object.

2  Click before the IF-THEN statement.
Type the following lines:

```powershell
//Local variable declarations
string ls_database, ls_userid, ls_password

//Assignment statements
ls_userid = Trim ( sle_userid.text )
ls_password = Trim ( sle_password.text )
ls_database = "ConnectString='DSN=EAS Demo DB V110;"
```

With these lines you declare local variables and assign them values. Do not use blank spaces around the = signs in the ConnectString text. Do not worry about the lone single quotation mark. You will add a single quotation mark in the next step to complete the connection script.

Using AutoScript to help code the assignment statements

When you type the assignment statements, if you type the letters before the underscore in a variable name and then press Ctrl+space, AutoScript pops up a list of possible completions. Use the arrow keys to move to the correct completion and the Tab key to paste it into your script. If you type the underscore and the first letter after the underscore and then press Ctrl+space, AutoScript pastes the completion directly into your script, as long as there is a unique completion.

The Trim function removes leading and trailing spaces from the user ID and password values passed as arguments to the function from the SingleLineEdit boxes on the login window.
Lesson 4  Connecting to the Database

3  Click after the lines you just added (which follow the CREATE statement) but before the IF-THEN statement.
Type the following lines:

```sql
//Instantiate with user-entry values
SQLCA.userid = ls_userid
SQLCA.dbpass = ls_password
SQLCA.dbparm = ls_database + "UID=" + &
               ls_userid + ";PWD=" + ls_password + ";"
```

These lines instantiate SQLCA parameters with values from the SingleLineEdit text boxes.

The lines must be added to the script after the CREATE statement to keep them from being overwritten with blank values from the Constructor event of the connection service manager. They must be added before the IF-THEN statement or their values are not used by the Transaction object when it is called by the of_ConnectDB function of the connection service manager.

```sql
//Instantiate the Transaction object.
if gvw_connect = CREATE &
   ln DbInitConnectService
   
//Local variable declarations
string ls_database, ls_userid, ls_password

//Assignment statements
ls_userid = Trim { the_userid.text }
ls_password = Trim { the_password.text }
ls_database = "ConnectString "DSN=EAS Demo DB V11;"

//Instantiate with user-entry values
SQLCA.userid = ls_userid
SQLCA.dbpass = ls_password
SQLCA.dbparm = ls_database + "UID=" + &
               ls_userid + ";PWD=" + ls_password + ";"

IF gvw_connect.of_ConnectDB () = 0 THEN
   Close [parent]
END IF
```

4  Click the Compile button in PainterBar2
   or
   Right-click inside the Script view and click Compile in the pop-up menu.
Complete the login and logout scripts

The script should compile without error. If you get an error message, make sure you have typed object and function names correctly.

Add code to the Cancel button Clicked event

Now you add code to the Cancel button to stop the application when this button is clicked.

1. Double-click the Cancel button in the Layout view
   or
   Select cb_cancel in the first drop-down list box of the Script view.
   The script area for the Cancel button is blank.

2. Type this one-line script for the Clicked event:
   \[
   \text{HALT}
   \]
   This statement terminates the application immediately when the user clicks Cancel on the login window.

3. Click the Save button in the PainterBar
   or
   Select File>Save from the menu bar.
   PowerBuilder compiles the script.

4. Click the Close button in the PainterBar
   or
   Select File>Close from the menu bar.
   The Window painter closes.

Add code to the application Close event

Because the connection service manager was called by a global variable, it is still available to the application and does not need to be instantiated again (as it would if you had used a local variable).

Now you call the connection service manager disconnect function to close the database connection.
1 Double-click the pbtutor application icon in the System Tree. The Application painter displays different views of the tutorial application object. The Script view is part of a stack in the default layout, but you might find it easier to detach it from the stack or open a second Script view.

2 Select `close()` returns (none) in the second drop-down list box of the Script view.

There is no code yet for the application Close event.

3 Type the following lines for the Close event comment:

   Application Close script:
   Disconnect from the database

4 Select all or part of the lines you just added. Click the Comment button.

5 Type the following line below the comment you typed (you can use AutoScript to complete the variable name and the function name):

   `gnv_connect.of_DisconnectDB()`

**Releasing memory by setting global variables to null**

If this were not the application Close event and you no longer needed an instance of the global connection variable, you could release the memory it occupies by calling the SetNull function.

PowerBuilder also provides a DESTROY statement to destroy object instances. Do not use the DESTROY statement for local or global variables for nonvisual objects. PowerBuilder garbage collection removes any local variables that go out of scope.
Complete the login and logout scripts

6  Right-click anywhere in the script area of the Script view. **Click Compile in the pop-up menu.**

PowerBuilder compiles the Close script. If you get an error message, look carefully at the lines you typed to make sure there is no mistyped variable or object name.

7  **Click the Close button in PainterBar1.**

A message box asks if you want to save your changes to the Application object in the application library file.

8  **Click Yes.**

This saves your changes and closes the Application painter.
Run the application

Where you are
Look at the EAS Demo DB database
Run the Connection Object wizard
Declare a global variable
Modify the connection information
Complete the login and logout scripts
> Run the application

Now you run the application.

1 Click the Run button in the PowerBar.
If a message box prompts you to save changes, click Yes to save them.

The workspace closes and your application runs.

2 Type dba in the User ID box.
Type sql in the Password box.

The password text is displayed as asterisks. Because you set the tab order for this window, you can tab from the User ID box to the Password box, and then to the OK button.

3 Click OK.

The database connection is established and the MDI frame for your application displays.

If you enter an invalid user ID or password
If you mistyped the user ID or password, the Connect to SQL Anywhere (ODBC Configuration) dialog box displays. You get a second chance to enter a valid user ID and password on the Login page of this dialog box. If you click the Test Connection button on the ODBC page of the dialog box without changing this information, a message box tells you that your user ID or password is not valid.

4 Select File>Exit from the menu bar.

The application terminates and you return to the development environment.
Run the application
In this lesson you create a window that inherits from the basesheet window that you generated with the Application Template wizard. You add predefined user objects containing DataWindow controls to the inherited window. You then create new w_customers and w_products windows that inherit from this extension layer window instead of from the original basesheet. Finally you make sure that the sheet windows open at runtime with the size you set at design time.

But first you add a library to the library list that contains the predefined user objects with DataWindow controls. In this lesson you:

- Add a library to the search path
- Create a new ancestor sheet window
- Add user events and event scripts
- Add scripts to retrieve data for the DataWindow controls
- Adjust a runtime setting for sheet window size

**How long does it take?**
About 30 minutes.
Add a library to the search path

Where you are
> Add a library to the search path
Create a new ancestor sheet window
Add user events and event scripts
Add scripts to retrieve data for the DataWindow controls
Adjust a runtime setting for sheet window size

As you add a library to the tutorial application search path. You must add all libraries on which an application depends.

The library you add to the current application contains some precoded objects, including the user object (u_dwstandard) that you will later add to the base sheet window.

1 **Right-click the pbtutor target (not the pbtutor application object) in the System Tree.**
   The pbtutor target contains the pbtutor.pbl and the pbtutor application.

2 **Select Properties from the pop-up menu.**
   The pbtutor target properties dialog box displays.

3 **Make sure the Library List page displays. Click Browse.**
   The Select Library dialog box displays.
Lesson 5  Modifying the Ancestor Window

4 Navigate to the Tutorial folder.  
Select tutor_pb.pbl and click Open.

You return to the Library List page. The tutor_pb.pbl file is now included in the search path for the tutorial application.

![Properties of Target pbtutor](image)

5 Click OK.
Create a new ancestor sheet window

Where you are
Add a library to the search path
> Create a new ancestor sheet window
Add user events and event scripts
Add scripts to retrieve data for the DataWindow controls
Adjust a runtime setting for sheet window size

Now you create a window that inherits from the basesheet window you generated with the Template Application wizard and add DataWindow controls to it. In the Source editor, you change the inheritance of the generated sheet windows (w_customers and w_products) to use the new window.

The DataWindow controls you add to the new ancestor window inherit their definitions from a user object that was created for the tutorial application. The user object is provided in the PBL file that you just added to the target library list. The user object is a customized DataWindow control that includes scripts to perform standard database error checking.

Why use a user object
You can build a user object in PowerBuilder to perform processing that you use frequently in applications. Once you have defined a user object, you can reuse it as many times as you need without any additional work.

In this exercise you:

• Create a new sheet window inheritance hierarchy
• Add a DataWindow control for the master DataWindow
• Add a DataWindow control for the detail DataWindow
• View the scripts inherited from the user object
Create a new sheet window inheritance hierarchy

Now you create a new window that inherits from the basesheet window. In this tutorial, you use the new window as an extension layer between the basesheet window and application sheet windows. Later in this lesson you make changes to the extension layer window. The changes you make are automatically extended to any new sheet windows that you inherit from the extension layer window.

In the current tutorial application, the w_customers and w_products windows already inherit from the w_pbtutor_basesheet window. Because you have not yet added any non-generic property values or functions to these sheet windows (other than their names and display text), you can write over these wizard-generated windows without having to transfer any code to the replacement windows. In this lesson you overwrite these windows with new windows that inherit from the extension layer window.

1  Select File>Inherit from the PowerBuilder menu.
   The Inherit from Object dialog box displays.

2  Make sure that pbtutor.pbl is selected in the Libraries list box and that Windows is selected in the Objects Of Type drop-down list.
   If you cannot see the full library list, you can change the size of the dialog box by clicking on one of its edges and holding down the mouse button while you drag the edge toward a corner of the screen. The pbtutor.pbl should be the first of two libraries listed in the Libraries list box.

3  Select w_pbtutor_basesheet in the Object column of the main list box and click OK.

4  Select File>Save As, and in the Save Window dialog box, select w_master_detail_ancestor in the Windows field for the new window name.

5  (Optional) Type the following text in the Comments box:
   New ancestor basesheet for the w_customers and w_products sheet windows.
Create a new ancestor sheet window

6  Make sure that pbtutor.pbl is selected in the Application Libraries list box and click OK. 
   Select File>Close to close the new ancestor basesheet. 
   You cannot create descendant windows if an ancestor window is open in 
   the Window painter.

7  Select File>Inherit from the PowerBuilder menu.

8  Make sure that pbtutor.pbl is selected in the Libraries list box and that 
   Windows is selected in the Objects Of Type drop-down list box. 
   Select w_master_detail_ancestor and click OK.

9  Type Maintain Customers in the Tag text box on the General page 
   of the Properties view. 
   Select File>Save As from the PowerBuilder menu and select 
   w_customers in the Windows list box.

10 Change the Comments text to: 
    Customer sheet window inheriting from 
    w_master_detail_ancestor.

11 Click OK, then click Yes in the Save Window message box that asks 
   if you want to replace the existing w_customers window. 
   The new sheet window inherits from w_master_detail_ancestor instead of 
   from w_pbtutor_basesheet.

12 Repeat steps 7-11, with the following modifications:

<table>
<thead>
<tr>
<th>Step</th>
<th>Modified instruction</th>
</tr>
</thead>
<tbody>
<tr>
<td>9</td>
<td>Type Maintain Products in the Tag text box on the General page of the Properties view. Select File&gt;Save As from the PowerBuilder menu and select w_products in the Windows list box.</td>
</tr>
<tr>
<td>10</td>
<td>Change the Comments text to: Product sheet window inheriting from w_master_detail_ancestor.</td>
</tr>
<tr>
<td>11</td>
<td>Replace the existing w_products window.</td>
</tr>
</tbody>
</table>

13 Close the new w_customers and w_products windows. 
   You cannot open an ancestor window in the Window painter if any of its 
   descendants are already displayed in the painter.
14 From the PowerBuilder menu, select Run>Full Build Workspace.
You should rebuild the workspace after changing the inheritance hierarchy and before making modifications to the new ancestor window. You can see the status of the build in the Output window, which displays below the System Tree at the bottom of the PowerBuilder main window. The build is finished when the Output window displays Finished Full build of workspace MyWorkspace.

15 Close the Output window.

Add a DataWindow control for the master DataWindow
Now you add a DataWindow control (saved as the user object, u_dwstandard) to the w_master_detail_ancestor window. It serves as the master DataWindow for the ancestor window and its descendants.

How to create a user object like u_dwstandard
You can create a user object based on a DataWindow control by clicking the New button and selecting Standard Visual from the PB Object page of the New dialog box. This opens the Select Standard Visual Type dialog box. You can then select DataWindow in the Types text box and add user events as needed. You see how to add user events later in this tutorial.

1 Double-click w_master_detail_ancestor in the System Tree.
The w_master_detail_ancestor window opens in the Window painter. You generated this window with the Template Application wizard. The wizard also created and attached a menu to this window, m_pbtutor_sheet. The menu is indicated in the Properties view for the window. You change this property later.

2 Make sure the Layout view is visible in the Window painter.

3 Expand tutor_pb.pbl by double-clicking it in the System Tree. Drag u_dwstandard from the System Tree to the w_master_detail_ancestor window in the Layout view.

4 Widen the window so that the control is completely visible inside the window.
PowerBuilder creates a DataWindow control that inherits its definition from the user object.

5 Make sure the new control is selected in the Layout view.
Small black squares at the corners indicate that the control is selected. The Properties view displays the properties of the selected control.

6 Select the text dw_1 in the Name text box in the Properties view.
Type dw_master in the Name text box.
Select the VScrollBar check box.

PowerBuilder adds a vertical scroll bar to the control. It also changes its name to dw_master. The prefix dw_ is standard for DataWindow controls.
Add a DataWindow control for the detail DataWindow

Now you add a second DataWindow control that is the detail DataWindow in the application.

1 **Resize the window so that there is room for a second DataWindow control below the first.**
   Drag u_dwstandard from the System Tree to below the dw_master control in the Layout view.
   PowerBuilder creates another DataWindow control that inherits its definition from the user object u_dwstandard.

2 **Move the DataWindow control so that it is completely visible inside the window.**
   If you need to, you can maximize the Layout view and enlarge the window object inside it to make more room for the DataWindow controls.

3 **Make sure that the new control is selected in the Layout view.**
   The Properties view displays the properties of the selected control.

4 **Replace the text dw_1 in the Name text box in the Properties view with dw_detail.**
   PowerBuilder changes the name of the control to dw_detail.
Create a new ancestor sheet window

View the scripts inherited from the user object

Now you view the scripts the DataWindow controls inherited from u_dwstandard.

1. **Double-click the dw_detail DataWindow in the Layout view**
   or
   **Select dw_detail from the first drop-down list box in the Script view if it is not already selected.**

   The Script view opens to the empty script for the dw_detail control’s ItemChanged event.

   Unscripted events are alphabetized separately from scripted events. Scripted events are listed at the top of the drop-down list box. You will next look at the dberror event, which contains an ancestor script, so you need to scroll up in the event drop-down list box to find it.

2. **Select dberror from the second drop-down list box in the Script view.**

   This script is also empty, but a purple script icon displays next to the event name. This indicates that the ancestor control (u_dwstandard) has an associated script.
Lesson 5    Modifying the Ancestor Window

3 Select Edit>Go To>Ancestor Script from the menu bar
or
Select u_dwstandard in the third drop-down list box.

PowerBuilder displays the script for the DBError event in the Script view. The ancestor script is read-only when it is accessed from the Script view for one of its descendants.

4 Scroll through the window to view the database error-handling logic defined for the DBError event.

The script suppresses the default error message that the DBError event normally displays. Instead, it causes an appropriate message to be displayed for each database error that might occur. The script makes calls to user events that were declared for the user object.

Because you used the u_dwstandard object to define both DataWindow controls in the window, this logic is automatically reused in both controls.

5 Select Edit>Go To>Descendant Script from the menu bar
or
Right-click inside the script area of the Script view.
Select Go To>Descendant Script from the pop-up menu.

The third drop-down list box again displays w_master_detail_ancestor, the identifier of the object that contains the current control. The script for the DBError event of this control (dw_detail) is still blank.
Add user events and event scripts

Where you are
Add a library to the search path
Create a new ancestor sheet window
> Add user events and event scripts
    Add scripts to retrieve data for the DataWindow controls
    Adjust a runtime setting for sheet window size

Windows, user objects, and controls have predefined events associated with them. Most of the time, the predefined events are all you need, but there are times when you want to declare your own events. Events that you define are called user events.

Purpose of user events  One reason to define a user event is to reduce coding in situations where an application provides several ways to perform a particular task. For example, a task like updating the database can be performed by clicking a button, selecting a menu item, or closing a window. Instead of writing the code to update the database in each of these places, you can define a user event, then trigger that user event in each place in which you update the database.

Now you define some user events to handle retrieval, insert, update, and delete operations against the tutorial database. You make these changes in the Script view of the Window painter. Later in the tutorial, you add code in the Menu painter to trigger these events.

1  Select w_master_detail_ancestor in the first drop-down list box of the Script view.

2  Select Insert>Event from the menu bar
   or
   Select New Event in the second drop-down list box of the Script view.

   The Script view displays the Prototype window for defining a new event.
The first button to the right of the third drop-down list box is a toggle switch that displays or hides the Prototype window.

3 **Type `ue_retrieve` in the Event Name text box in the Prototype window.**

   **Click inside the Script view below the Prototype window.**

   **Type these lines (or use AutoScript as described below):**

   ```
   IF dw_master.Retrieve() <> -1 THEN
       dw_master.SetFocus()
       dw_master.SetRowFocusIndicator(Hand!)
   END IF
   ```

   **Using AutoScript instead of typing**

   You can use AutoScript to paste in the IF THEN template as well as the variables and function names:

   Type **IF**, then press Ctrl+space.
   Press Tab to paste an IF THEN statement.
   Type **dw_m**, then press Ctrl+space.
   Place the cursor after **dw_master**, type a dot, then type Ctrl+space.
   Scroll and select **retrieve( )**, press Tab, and type the rest of the line.
   Press Ctrl+M to jump to the next comment.
   Enter the other function calls by typing them or using AutoScript.

   As soon as you clicked in the script area, the text in the second drop-down list box of the Script view changed from New Event to `ue_retrieve`. It has no arguments, does not return a value, and does not throw user-defined exceptions. For information on throwing user-defined exceptions, see Lesson 10, “Exception Handling.”
Add user events and event scripts

The script lines you entered execute the Retrieve function and place the retrieved rows in the dw_master DataWindow control. If the retrieval operation succeeds, the script sets the focus to the first row in the DataWindow control and establishes the hand pointer as the current row indicator.

If the retrieve fails
If the retrieval operation does not succeed, PowerBuilder triggers the DBError event. The logic for the DBError event is handled in the user object u_dwstandard. You looked at this script in the previous exercise.

4 Select File>Save from the menu bar.
Right-click the Prototype window and select New Event from the pop-up menu.

PowerBuilder compiles the script you entered for the ue_retrieve event. The Script view displays the Prototype window for another new user event.

If you get an error message
Mistyped or incomplete script entries generate compiler errors. If you select No when prompted to ignore compilation errors, a compiler error area displays at the bottom of the Script view, identifying your error. If this happens, retype the script for the ue_retrieve event.

You can display or hide the compiler error area by clicking the second toggle switch at the top right of the Script view.
5 Repeat steps 3 and 4 for the following entries:

<table>
<thead>
<tr>
<th>Event name</th>
<th>Script</th>
</tr>
</thead>
</table>
| ue_insert  | dw_detail.Reset()  
dw_detail.InsertRow(0)  
dw_detail.SetFocus() |
| ue_update  | IF dw_detail.Update() = 1 THEN  
COMMIT using SQLCA;  
MessageBox("Save","Save succeeded")  
ELSE  
ROLLBACK using SQLCA;  
END IF |
| ue_delete  | dw_detail.DeleteRow(0) |

What the scripts do The first line of the script for the ue_insert event clears the dw_detail DataWindow control. The second line inserts a new row after the last row in the DataWindow (the argument zero specifies the last row). The third line positions the cursor in the dw_detail control.

The ue_insert and ue_delete events operate on the DataWindow buffer, not on the database. When these events are triggered, a row is not inserted or deleted from the database unless the Update function is also called (the ue_update event calls this function). If the Update function returns the integer 1, changes made to the buffer are committed to the database. If it returns a different integer, changes to the buffer are rolled back.

In the script for the ue_delete event, the argument zero in the DeleteRow function specifies that the current row in the dw_detail control be deleted.

6 Make sure your work is saved.

If you repeated step 4 for each new event and script that you added, you have already saved your work.
Add scripts to retrieve data for the DataWindow controls

Where you are
Add a library to the search path
Create a new ancestor sheet window
Add user events and event scripts
> Add scripts to retrieve data for the DataWindow controls
  Adjust a runtime setting for sheet window size

The scripts you just typed have no effect on the dw_master DataWindow control, but now that you have a script for the ue_retrieve event, you need only trigger this event to retrieve data into the dw_master DataWindow.

You trigger the ue_retrieve event from the sheet window Open event. This retrieves data into the dw_master DataWindow as soon as the window (or one of its descendents) opens. Then you add a script for the RowFocusChanged event of dw_master to retrieve data into the dw_detail DataWindow. The RowFocusChanged event is triggered each time the focus is changed inside the dw_master DataWindow.

RowFocusChanged occurs upon DataWindow display
The RowFocusChanged event also occurs when the w_master DataWindow is first displayed. This allows the application to retrieve and display detail information for the first row retrieved in the master DataWindow.

Here is how the script works for the w_master_detail_ancestor window and its descendents when you are done:

- When a sheet window first opens, a list (of all customers or products) displays in the top DataWindow control. Detail information for the first item in the list displays in the bottom DataWindow control.
- When a user moves through the list in the top DataWindow control using the up arrow and down arrow keys or by clicking in a row, the details for the current row display in the bottom DataWindow control.

1 Select open from the second drop-down list box in the Script view for w_master_detail_ancestor.

The Open event has a purple script icon indicating it has an ancestor script. If you check the ancestor script, you see that it calls the ue_postopen event and posts it to the end of the window’s message queue.
**Lesson 5  Modifying the Ancestor Window**

2 Type these new lines in the script area for the w_master_detail_ancestor Open event:

```plaintext
dw_master.settransobject ( sqlca )
dw_detail.settransobject ( sqlca )
this.EVENT ue_retrieve()
```

The first two lines tell the dw_master and dw_detail DataWindows to look in the SQLCA Transaction object for the values of the database variables. The third line triggers the ue_retrieve event. The pronoun *This* refers to the current object. In this example, the w_master_detail_ancestor window is the current object.

3 Select dw_master in the first drop-down list box of the Script view. Select rowfocuschanged in the second drop-down list box.

**Read the event name carefully**
Make sure you select the RowFocusChanged event, and not the RowFocusChanging event.

You now add a script for the RowFocusChanged event of the dw_master DataWindow control. This script sends a retrieval request and the ID number of the selected row to the dw_detail DataWindow control.

4 Type this line in the script area for the RowFocusChanged event:

```plaintext
long ll_itemnum
```

This line declares the local variable `ll_itemnum` (l is a letter, not a number), which has the long data type.

5 Type this line below the variable declaration line you just typed:

```plaintext
ll_itemnum = this.object.data[currentrow, 1]
```

**Use square brackets**
The expression shown above requires square brackets, not parentheses.

This line uses a DataWindow data expression to obtain the item number in column 1 of the currently selected row of dw_master. It stores the number in the variable `ll_itemnum`. 
Add scripts to retrieve data for the DataWindow controls

CurrentRow is an argument passed to the RowFocusChanged event that specifies the current row in the DataWindow control. The current row is the row the user has selected by clicking or by scrolling with the arrow or tab keys.

6 Type these lines below the data expression line you just typed:

   IF dw_detail.Retrieve(ll_itemnum) = -1 THEN
      MessageBox("Retrieve","Retrieve error-detail")
   END IF

This group of lines sends a retrieval request to the dw_detail DataWindow along with the argument the DataWindow expects (an ID number stored in the ll_itemnum variable). The IF statement that encloses the Retrieve function checks for successful completion. If the retrieval operation fails, it displays an error message box.

7 Click the Save button in PainterBar1. Click the Close button in PainterBar1.

PowerBuilder compiles the script you typed and saves it.

8 Click the Full Build Workspace button in the PowerBar.

It is a good idea to rebuild all your objects after modifying an ancestor object.

9 Close the Output window.
Adjust a runtime setting for sheet window size

Where you are
Add a library to the search path
Create a new ancestor sheet window
Add user events and event scripts
Add scripts to retrieve data for the DataWindow controls
> Adjust a runtime setting for sheet window size

The Template Application wizard creates a sheet manager that makes the OpenSheet function call to open a sheet window. The OpenSheet function has an argument that can affect the sheet window size at runtime. By default the wizard sets this argument to the Cascaded! value that overrides the sheet window size you set at design time. Now you change this value to allow the runtime window size to be the same as the design time size.

1 Double-click n_pbtutor_sheetmanager in the System Tree
   or
   Right-click n_pbtutor_sheetmanager in the System Tree and select Edit from the pop-up menu.

2 In the Script view, select (Functions) in the first drop-down list box. Select of_opensheet in the second drop-down list box.

3 Go to the following line in the script:
   li_rc = OpenSheet ( lw_sheet, as_sheetname, w_pbtutor_frame, 0, Cascaded! )

4 Change the Cascaded! argument to Original!:
   li_rc = OpenSheet ( lw_sheet, as_sheetname, w_pbtutor_frame, 0, Original! )

5 Click the Save button in PainterBar1.
   Click the Close button in PainterBar1.

   The next time you run the tutorial application, the sheet windows will open in the size you set at design time. They will still be cascaded relative to other open sheets.
Adjust a runtime setting for sheet window size
In this lesson you set up the menus for the application. You:

- Modify the frame menu
- Create a new sheet menu
- Add menu scripts to trigger user events
- Attach the new menu and run the application

Menus are separate objects that you create using the Menu painter. After you create a menu, you can attach it to as many windows as you want. You can create menus at any time during the application development process.

**How long does it take?**
About 30 minutes.
Modify the frame menu

Where you are
> Modify the frame menu
Create a new sheet menu
Add menu scripts to trigger user events
Attach the new menu and run the application

The frame menu was created automatically by the Template Application wizard. The m_pbtutor_frame menu is the ancestor of all the other menus you work with in the tutorial. Changes you make to this menu are automatically propagated to descendent menus.

In the WYSIWYG (What You See Is What You Get) view of the Menu painter, you see menus as they appear when the application is running. In this tutorial, you use the WYSIWYG view to make changes to the application menus, but you can make the same changes from the Tree Menu view. You use the Properties view to change a toolbar button.

In this exercise you:
• Modify the File menu
• Enable Help menu items

Modify the File menu

Now you modify the File cascading menu of the m_pbtutor_frame menu.

1 Double-click m_pbtutor_frame in the System Tree.

The Menu painter displays the menu associated with the MDI frame window in the application. Because m_pbtutor_sheet inherits from m_pbtutor_frame, changes you make to the frame menu are propagated to the sheet menu.

In the WYSIWIG view, the menu items appear across the top of the view. If a WYSIWYG view is not open, you can select it from the View menu in the Menu painter menu bar.
2 Click the File menu in the WYSIWYG view of m_pbtutor_frame.
When you click a menu item in the WYSIWYG view, its menu items appear just as they would at runtime.

If the File menu does not display its menu items
The File menu is selected when you display the WYSIWYG view. You might need to click one of the other menus (Edit, Window, or Help) and then click again on the File menu to display its menu items.

3 Right-click New under the File menu.
Select Edit Menu Item Text in the pop-up menu.
Type &Report and press Enter.
You change the display name of the New menu item to Report. The menu name remains m_new and its purpose (to open new sheet windows) remains the same.

Define accelerator keys with the ampersand character
The character following the ampersand is used as an accelerator key (mnemonic) and appears with an underscore in the WYSIWYG display. In the runtime application, the user can access the File>Report menu by pressing Alt+F+R.

4 Make sure that &Report appears in the Text text box in the Properties view.
Click the Toolbar tab in the Properties view.
The toolbar item text is New, Open New Sheet. There is no selection in the ToolbarItemName box, so no toolbar button appears at runtime for the Report menu item. You do not add a toolbar button here, because you use the Report menu item to access cascading menu items rather than as a command to open a new sheet.
Modify the frame menu

5 Click the Open menu item under the File menu in the WYSIWYG view. Click the General tab in the Properties view. Clear the Visible and Enabled check boxes on the General page of the Properties view.

You hide the Open menu item in all runtime menus. When you clear the Visible property, the WYSIWYG view displays the menu item with a dithered (broken) appearance. It is not visible at runtime. When you clear the Enabled property, the WYSIWIG view displays the menu item with a very faint and inverted relief appearance. If it is visible at runtime, the menu item will still be grayed out.

6 Click the Toolbar tab of the Properties view. Clear the ToolbarItemVisible check box.

This prevents the toolbar button for this menu item from appearing in the frame menu toolbar (a button can be included in a toolbar even if its corresponding menu item is not visible or enabled).

7 Click Exit under the File menu in the WYSIWYG view.

The Toolbar page of the Properties view remains open. The ToolbarItemText and ToolbarItemName values change to show the values for the m_exit menu item.
Enable Help menu items

The Help menu has three items, but only one, Help>About, is enabled. Now you enable the other menu items, using commented-out code that was provided by the Template Application wizard and the pbtutor.hlp file in the Tutorial directory.

You call application Help topics with the ShowHelp function, passing it an enumerated value that identifies whether you want the Help contents or index to display, or a specific topic or keyword. ShowHelp can open Windows Help or compiled HTML Help (CHM) files.

1 Click the Help menu in the WYSIWYG view and then double-click the Help Index menu item.

You can double-click the Help Index item even though it is not currently enabled. The full name of the Help Index menu item, m_help.m_helpindex, displays in the Script view. It includes the m_help prefix to indicate that it is in the Help menu.

2 Select Clicked in the second drop-down box if it is not already selected.

3 Position the cursor in the line that contains the ShowHelp function and click the Uncomment button in the PowerBar. Change myapp.hlp to pbtutor.hlp:

   ShowHelp ("pbtutor.hlp", Index!)

This displays the default topic in the Help file.

4 Select the Enabled check box on the General page of the Properties view for the m_helpindex menu item.

5 Repeat the preceding steps for the Search For Help On menu item using the following Show Help function.

   ShowHelp ("pbtutor.hlp", Keyword!, "")

If the third argument contained a string that was a keyword in the Help file, the associated topic would display. Because the argument is an empty string, the Help Search window displays.

6 Select File>Save from the main PowerBuilder menu bar. Select File>Close from the main PowerBuilder menu bar.
Create a new sheet menu

Create a new sheet menu

Where you are
Modify the frame menu
> Create a new sheet menu
Add menu scripts to trigger user events
Attach the new menu and run the application

Now you create a new menu that displays whenever the user opens an MDI sheet to look at customer or product information. The menu you create is a descendant of the m_pbtutor_sheet menu that was generated by the Template Application wizard.

The m_pbtutor_sheet menu inherits in turn from m_pbtutor_frame, but has some additional menu items enabled. In the menu you create, you add menu items that are not present in the ancestor menus.

In this exercise you:

• Inherit and save a new menu
• Add items to the new menu
• Add a new toolbar for the new menu items

Inherit and save a new menu

By inheriting from the application sheet menu, you retain the sheet menu characteristics without modifying the ancestor menu. It is good practice to save the new menu immediately, then save it again after you modify it.

1  Click the Inherit button in the PowerBar.

The Inherit From Object dialog box displays.

2  Make sure Menus is selected in the Objects of Type drop-down list box.
Select m_pbtutor_sheet in the Object list box and click OK.

PowerBuilder displays an untitled menu that has all the characteristics of m_pbtutor_sheet.
On the inherited sheet menu, the Window menu items are enabled to allow for tiling and cascading windows, just as they are for the m_pbtutor_sheet menu. These items are disabled on the m_pbtutor_frame menu.

Changes made to the MDI frame menu
If you click the File menu in the WYSIWYG view, you see that the first item is now Report. The Open item is dithered to indicate that it is not visible and is grayed to indicate that it is disabled. These characteristics were propagated through the inheritance chain from m_pbtutor_frame.

3 Select File>Save from the menu bar.

The Save Menu dialog box displays.

4 Type m_my_sheet as the menu name in the Menus box.
   Type the following line in the Comments box:
   New sheet menu for w_master_detail_ancestor and its descendants.

5 Click OK.

This names the menu. The prefix m_ is standard for menus.

The name you just assigned to the new menu displays in the title bar of the Menu painter workspace and the m_my_sheet menu appears in the system tree.

Add items to the new menu

Next you add items to the Edit menu of the menu you just inherited from m_pbtutor_sheet. You use the WYSIWYG and Properties views.

1 Click the Edit menu in the WYSIWYG view for the new menu.

The list of Edit menu items appears just as it would in a runtime application. All items of the Edit menu are visible but disabled (they appear gray—but not dithered—in the WYSIWYG view).
Create a new sheet menu

2 Right-click a menu item under the Edit menu in the WYSIWYG view. Select Insert Menu Item At End from the pop-up menu.

The cursor moves into a blank box that appears at the end of the Edit menu list.

3 Type – (hyphen) and press Enter.

The hyphen changes into a separator line. In the Properties view, the menu item name changes to m_. Even the separator lines between menu items must have unique names. Other separator lines in the menu have a unique index number preceded by the prefix m_dash.

4 Clear the Enabled check box in the Properties view for the new separator line.

5 Right-click the new separator line in the WYSIWYG view. Select Insert Menu Item At End from the pop-up menu. Type &Insert in the box that appears under the new separator and press Enter.

The menu item name is set automatically to m_insert. If PowerBuilder displays a message that the default name is incorrect, it suggests an alternative name. If this occurs, click OK to accept the suggested name.

Alternative method of inserting menu item names
You can type &Insert in the Text box in the Properties view instead of typing it in the box that appears in the WYSIWYG view. In this case, you do not need to press Enter afterwards. First, however, you have to clear the Lock Name check box if the Name box is grayed (otherwise, the menu name does not reset to m_insert).

6 Type Insert a row in the MicroHelp box in the Properties view.

The new menu item is visible and enabled by default.

The text Insert a row displays in the MicroHelp line at the bottom of the application window whenever the user selects the menu item.
7 Repeat steps 5 and 6 for the following menu items:

<table>
<thead>
<tr>
<th>Menu item</th>
<th>MicroHelp text</th>
</tr>
</thead>
<tbody>
<tr>
<td>Update</td>
<td>Update the database</td>
</tr>
<tr>
<td>&amp;Delete</td>
<td>Delete the current row</td>
</tr>
</tbody>
</table>

You add Edit menu items for updating and deleting database records. Even though it is not enabled, the Undo item already uses the letter U as an accelerator key, so you should not use the same accelerator key for the Update menu item. Instead, you use the letter A for this purpose.
Add a new toolbar for the new menu items

Now you add toolbar buttons for the menu items you just defined and then place them in a second toolbar.

1. **Click the new Insert menu item in the WYSIWYG view Edit menu.**

2. **Click the Toolbar tab in the Properties view.**
   - **Type** Insert in the ToolBarItemText box.
   - **Type or select** Insert! in the ToolBarItemName drop-down list.

   This defines a toolbar button for the Insert menu item that uses the stock picture called Insert!. When the Show Text option in the runtime application is enabled for toolbars, the text Insert appears on the button.

3. **Type or click to** 1 in the ToolBarItemSpace spin control.
   **Type or click to** 1 in the ToolBarItemOrder spin control.
   **Type or click to** 2 in the ToolBarItemBarIndex spin control.

   When you start a new toolbar for the added menu items, the Insert button will be the first item in this toolbar.

4. **Click the new Update menu item in the WYSIWYG view Edit menu.**
   **Make sure it is also displayed on the title bar in the Properties view.**

5. **Click the Toolbar tab if the Toolbar page is not already open.**
   - **Type** Update in the ToolBarItemText box.
   - **Type or select** Update! in the ToolBarItemName drop-down list box.

   This defines a toolbar button for the Update menu item that uses the stock picture called Update!. The button text is Update.

6. **Type or click to** 2 in the ToolBarItemOrder spin control.
   **Type or click to** 2 in the ToolBarItemBarIndex spin control.

   This will add the Update button after the Insert button in the new toolbar.

7. **Click the new Delete menu item in the WYSIWYG view Edit menu.**
   **Make sure it is also displayed on the title bar in the Properties view.**
8 Click the Toolbar tab if the Toolbar page is not already open. Type Delete in the ToolbarItemText box. Type or select DeleteRow! in the ToolbarItemName drop-down list box.

This defines a toolbar button for the Delete menu item that uses the stock picture called DeleteRow!. The button text is Delete.

9 Type or click to 3 in the ToolbarItemOrder spin control. Type or click to 2 in the ToolbarItemBarIndex spin control.

You add the Delete button after the Update button in the new toolbar.

10 Select File>Save from the PowerBuilder menu bar.
Add menu scripts to trigger user events

Where you are
Modify the frame menu
Create a new sheet menu
> Add menu scripts to trigger user events
Attach the new menu and run the application

Now you add scripts to trigger user events from the sheet window menu bar. You added these user events in Lesson 5, “Modifying the Ancestor Window.” The Menu painter should still be open for the m_my_sheet menu. If it is not, you can open it using the Open button in the PowerBar.

1 Select m_edit.m_insert in the first list box in the Script view or Double-click the Insert menu item in the WYSIWYG view.

The full name of the Insert menu item displays in the first list box of the Script view. It includes the m_edit prefix to indicate that it is in the Edit menu.

2 Select Clicked in the second drop-down box if it is not already selected.
Type these lines for the Clicked event:

```powershell
w_master_detail_ancestor lw_activesheet
lw_activesheet = w_pbtutor_frame.GetActiveSheet()
lw_activesheet.EVENT ue_insert()
```

The first two lines determine which sheet in the MDI frame is currently active. The third line triggers the user event ue_insert for the active sheet.

3 Repeat steps 1 and 2 for the following menu items and scripts:

<table>
<thead>
<tr>
<th>Menu name</th>
<th>Script for Clicked event</th>
</tr>
</thead>
<tbody>
<tr>
<td>m_edit.m_update</td>
<td>w_master_detail_ancestor lw_activesheet</td>
</tr>
<tr>
<td></td>
<td>lw_activesheet=w_pbtutor_frame.GetActiveSheet()</td>
</tr>
<tr>
<td></td>
<td>lw_activesheet.EVENT ue_update()</td>
</tr>
<tr>
<td>m_edit.m_delete</td>
<td>w_master_detail_ancestor lw_activesheet</td>
</tr>
<tr>
<td></td>
<td>lw_activesheet = w_pbtutor_frame.GetActiveSheet()</td>
</tr>
<tr>
<td></td>
<td>lw_activesheet.EVENT ue_delete()</td>
</tr>
</tbody>
</table>
4 Select File>Save from the PowerBuilder menu bar.
   PowerBuilder compiles and saves the menu scripts.

5 Click the Close button in PainterBar1
   or
   Select File>Close from the PowerBuilder menu bar.
Attach the new menu and run the application

**Where you are**
Modify the frame menu
Create a new sheet menu
Add menu scripts to trigger user events
> Attach the new menu and run the application

Now you attach the new sheet menu and run the application again.

1. **Double-click w_master_detail_ancestor in the System Tree.**

   **If you cannot see the Properties view**
   Select View>Properties from the menu bar.

   The menu listed in the MenuName box in the Properties view of the Window painter is still m_pbtutor_sheet.

2. **Click the ellipsis button next to the MenuName box.**

   The Select Object dialog box displays.

3. **Select m_my_sheet in the Menus list box and click OK.**

   This is the sheet menu you modified after inheriting it from m_pbtutor_sheet. It is now listed as the menu name in the Properties view.

4. **Click the Save button in PainterBar1.**
   **Click the Run button in the PowerBar.**

   The application login window displays.

5. **Type dba in the User ID box.**
   **Type sql in the Password box and click OK.**

   The database connection is established, and the MDI frame for the application displays. The File menu now includes a Report cascading menu in place of the New menu item. The Open menu item is no longer visible.
6 Select File>Report>Maintain Customers from the menu bar.
Notice that a second toolbar appears and the Edit and Window cascading menus include enabled menu items.

7 Select the Edit menu.
The Edit menu has the Insert, Update, and Delete options you added. These options do not function yet, because the DataWindow controls in the Customer window do not have DataWindow objects associated with them.

8 Select the Window menu.
Notice that a new menu item has been added for the sheet you just opened.

9 Select File>Report>Maintain Products from the menu bar.
A second MDI sheet opens. This sheet cascades relative to the first sheet. The menu bar does not change. That is because m_my_sheet is the menu for both w_customers and w_products.

10 Select the Edit menu.
Because the w_products window uses the m_my_sheet menu, the Insert, Update, and Delete options are also available when the Product window is open.

11 Select the Window menu.
Another menu item has been added for the second sheet you opened. The checkmark next to this menu item indicates that it is the active sheet.

12 Select File>Exit from the menu bar.
The application terminates and you return to the Window painter workspace.

13 Close the Window painter.
Attach the new menu and run the application
Building DataWindow Objects

The DataWindow object is one of the most powerful and useful features of PowerBuilder. A DataWindow object can connect to a database, retrieve rows, display the rows in various presentation styles, and update the database.

In this lesson you:

- Create and preview a new DataWindow object
- Save the DataWindow object
- Make cosmetic changes to the first DataWindow object
- Create a second DataWindow object
- Make cosmetic changes to the second DataWindow object

How long does it take?
About 20 minutes.
Create and preview a new DataWindow object

**Where you are**
- Create and preview a new DataWindow object
- Save the DataWindow object
- Make cosmetic changes to the first DataWindow object
- Create a second DataWindow object
- Make cosmetic changes to the second DataWindow object

Now you create a new DataWindow object and display it in the DataWindow painter. Like other painters, the DataWindow painter has an assortment of views that you can open simultaneously.

**About the Design view of the DataWindow painter**
The Design view in the DataWindow painter is similar to the Layout view in other painters. You can open only one Design view at a time.

The Design view is divided into four areas called bands: header, detail, summary, and footer. You can modify the contents of these bands. For example, you can change their sizes, add objects (controls, text, lines, boxes, or ovals), and change colors and fonts.

In the Preview view of the DataWindow painter, you can see how the object looks in an application at runtime, complete with table data.

1. **Click the New button in the PowerBar.**
   - The New dialog box displays.

2. **Click the DataWindow tab.**
3 Select Tabular from the list of presentation styles.

![Image of the DataWindow wizard with Tabular selected]

4 Click OK.

The Choose Data Source for Tabular DataWindow page of the DataWindow wizard displays.
Create and preview a new DataWindow object

5 **Select Quick Select as the data source and select the Retrieve On Preview check box if it is not already selected. Click Next.**

PowerBuilder connects to the EAS Demo DB Database, and the Quick Select dialog box displays.

6 **Click the customer table in the Tables list box.**

This opens the table and lists its columns. For this DataWindow, you will select four columns.

7 **Click id, fname, and lname in the Columns list box in the order listed. Scroll down the list and click company_name.**

PowerBuilder displays the selected columns in a grid at the bottom of the Quick Select dialog box.

**Selection order determines display order**

The order in which you select the columns determines their left-to-right display order in the DataWindow object. If you clicked a column by mistake, you can click it again to clear the selection.
You can use the grid area at the bottom of the dialog box to specify sort criteria (for the SQL ORDER BY clause) and selection criteria (for the SQL WHERE clause). Now you specify sort criteria only. You sort the id column in ascending order.

8 **In the grid area of the Quick Select dialog box, click in the cell next to Sort and below Id.**

A drop-down list box displays.

9 **Select Ascending from the drop-down list box.**

This specifies that the id column is to be sorted in ascending order.

10 **Click OK.**

The DataWindow wizard asks you to select the colors and borders for the DataWindow object. By default, there are no borders for text or columns.

11 **Click Next.**

You accept the border and color defaults. The DataWindow wizard summarizes your selections.
12 Click Finish.

PowerBuilder creates the new DataWindow object and opens the DataWindow painter.

In the Design view, PowerBuilder displays a Heading band with default headings and a Detail band with the columns you selected:

The Preview view displays the DataWindow as it appears during execution. PowerBuilder displays data for all customers. The data is sorted in ascending order by customer ID, just as you specified.

Displaying the Preview view
If the Preview view is not displayed, select View>Preview from the menu bar. If Preview is grayed, it is already displayed and you cannot select it. You can open only one Preview view at a time.
Save the DataWindow object

Where you are
Create and preview a new DataWindow object
> Save the DataWindow object
  Make cosmetic changes to the first DataWindow object
  Create a second DataWindow object
  Make cosmetic changes to the second DataWindow object

Now you name the DataWindow object and save it in the pbtutor.pbl library.

Saving to another library
You can save objects to different application libraries, but to avoid complications, you save all your new tutorial objects in one library. You can also copy or move objects from one library to another using the Library painter.

1  Select File>Save from the menu bar.
   The Save DataWindow dialog box displays with the insertion point in the DataWindows box.

2  Make sure pbtutor.pbl is selected in the Application Libraries box.
   Type d_custlist in the DataWindows box.
   This names the DataWindow object. The prefix d_ is standard for DataWindow objects.

3  (Optional) Type the following comments in the Comments box:
   This DataWindow object retrieves customer names and company associations.

4  Click OK.
   PowerBuilder saves the DataWindow object and closes the Save DataWindow dialog box.
Make cosmetic changes to the first DataWindow object

Where you are
Create and preview a new DataWindow object
Save the DataWindow object
> Make cosmetic changes to the first DataWindow object
Create a second DataWindow object
Make cosmetic changes to the second DataWindow object

Now you can make cosmetic changes to the DataWindow. You reposition the columns and column headings to make room for the hand pointer, which displays to the left of the currently selected row. You also move some of the columns to make them line up with their headings.

You make these changes in the Design view. You can keep the Preview view open at the same time to see how the changes you make affect the appearance of the DataWindow at runtime.

1 Select Edit>Select>Select All from the menu bar
   or
   Press Ctrl+A.
   All of the controls in the DataWindow object are selected in the Design view.

2 Position the mouse pointer over one of the selected objects.
   Drag the object to the right about one inch.
   All of the selected objects move together.

3 Click in a blank area in the Design view.
   You clear the object selection.

4 Click the Customer ID header above the Header band.
   Hold down the Ctrl key and click the id column above the Detail band.
   Release the Ctrl key and drag the id column to the left about one-half inch.
   The column and its header move together.
5 Click the Center button in the StyleBar. 
Click in a blank area in the Design view.
This centers the Customer ID column header text and the column data.

6 Click the First Name header.
Hold down the Ctrl key and click the Last Name and Company Name headers.
Click the Left button in the StyleBar.
When you have finished, the Design view should look something like this:

7 Select File>Close from the menu bar.
A message box asks if you want to save your changes.

8 Click Yes.
PowerBuilder saves the DataWindow object and closes the DataWindow painter.
Create a second DataWindow object

Where you are
Create and preview a new DataWindow object
Save the DataWindow object
Make cosmetic changes to the first DataWindow object
Create a second DataWindow object
Make cosmetic changes to the second DataWindow object

When you built the first DataWindow object, you used Quick Select to specify the table and columns. This let you retrieve all the customers without having to use the Select painter.

To build the second DataWindow object, you use the Select painter. You need to define a retrieval argument and WHERE criteria so you can pass an argument to the DataWindow object during execution. In this case, you will pass the customer ID.

In this section, you:

- Select the data source and style
- Select the table and columns
- Define a retrieval argument
- Specify a WHERE clause
- View the DataWindow in the DataWindow painter
- Save the DataWindow object

Select the data source and style

Now you select a data source and define how the data is to be presented.

1. **Click the New button in the PowerBar.**
   The New dialog box appears.

2. **Click the DataWindow tab if it is not already selected.**
   Select Freeform from the list of presentation styles and click OK.
Lesson 7  Building DataWindow Objects

3 Select SQL Select as the data source and select the Retrieve On Preview if it is not already selected.

Since the data source is SQL Select, you go to the Select painter and the Select Tables dialog box displays.

Selecting the Retrieve On Preview check box allows you to view the data returned by a query in the development environment, but you need to provide initial values for any retrieval arguments that you specify.

4 Click Next.

Select the table and columns

Now you select the table and the columns from that table to use in the DataWindow object.

1 Select customer in the list of tables and click Open.

The Select painter displays the customer table and its columns.

Alternative method
If you double-click the customer table instead of selecting it and clicking Open, the Select Tables dialog box remains open. In this case, you must click Cancel to continue.

2 Right-click the header area of the Customer table in the Table Layout view.
Select Select All from the pop-up menu.

The column names appear in the Selection List area above the table in the Table Layout view.

The column order in the Selection List reflects the order in which columns are selected. Since you selected all the columns at once, the order displayed is the original order of the columns in the database. You change the column presentation order later.
Create a second DataWindow object

You can also see the order of selection in the Syntax view. Display the Syntax view by clicking the Syntax tab at the bottom of the stack of tabbed panes. The Syntax view displays the generated Select statement.

Define a retrieval argument

Now you define a retrieval argument.

1. Select Design->Retrieval Arguments from the menu bar.
   The Specify Retrieval Arguments dialog box displays.

2. Type `cust_id` in the Name box.
The default data type is Number, which is what you want.

![Specify Retrieval Arguments](image)

**About retrieval argument names**
You can choose any name you want for the retrieval argument; it is just a placeholder for the value you pass during execution. Nonetheless, it is a good idea to make the name meaningful.

3 Click OK.

The retrieval argument is defined.

**Specify a WHERE clause**
Now you specify a WHERE clause using the retrieval argument to retrieve a specific customer.

1 Click the Where tab in the stack.

The Where view displays.

2 Click in the box below Column in the Where view.

A down arrow displays, and the box becomes a drop-down list box.

3 Select "customer"."id".
Create a second DataWindow object

Your selection displays immediately below the Column heading. An equal sign (=) appears in the Operator box. This is correct, so do not change it.

4 Right-click in the box below the Value column header in the Where view. Select Arguments from the pop-up menu, select :cust_id, and click Paste.

5 Click the Syntax tab in the stack.

The Syntax view displays the modified SELECT statement.

6 Scroll down until you see the generated WHERE clause.

You have now created a complete SQL SELECT statement that retrieves data from several columns in the customer table where the id column is equal to an argument that will be supplied during execution.
View the DataWindow in the DataWindow painter

Now you view the DataWindow in the DataWindow painter using the Design and Preview views.

1. **Click the Return button in the PainterBar**
   or
   **Select File>Return To DataWindow Painter from the menu bar.**

   The DataWindow wizard asks you to select the borders and colors for the new DataWindow object.

2. **Select Raised from the Border drop-down list box for columns. Click Next.**

   You have added raised borders to the columns, but not to the labels in the DataWindow object. The DataWindow wizard summarizes your selections.

3. **Click Finish.**

   Because you selected the Retrieve On Preview check box and because the Preview view is part of the default layout scheme for the DataWindow painter, the Specify Retrieval Arguments dialog box appears.

   This dialog box prompts you for an argument value. When you put this DataWindow object into the tutorial application, you write a script that passes the required argument to the DataWindow object automatically.
Create a second DataWindow object

4 Type a customer ID (such as 101, 102, or 103) in the Value field. Click OK.

The DataWindow painter opens. The Design view displays the new DataWindow object.

Changing font sizes
If you cannot see all letters in a label, press Ctrl+A to select all the items in the DataWindow, then select a smaller font size in the StyleBar.

The DataWindow Preview view retrieves the requested customer data.
Retrieving other records
If you want to preview the record for another customer, you can right-click inside the DataWindow Preview view, select Retrieve from the pop-up menu, then specify a different customer ID in the Specify Retrieval Arguments dialog box.

Save the DataWindow object
Now you name the DataWindow object and save it. You could wait to save it until you leave the painter, but it is good practice to save your work frequently.

1 Select File>Save from the menu bar.
The Save DataWindow dialog box displays.

2 Make sure pbtutor.pbl is selected in the Application Libraries box.
Type d_customer in the DataWindows box.
Earlier you saved a DataWindow object as d_custlist.

3 (Optional) Type the following comments in the Comments box.
This DataWindow retrieves all columns for the Customer table. It is useful as a detail DataWindow.

4 Click OK.
You return to the DataWindow painter.
Make cosmetic changes to the second DataWindow object

Where you are
Create and preview a new DataWindow object
Save the DataWindow object
Make cosmetic changes to the first DataWindow object
Create a second DataWindow object
> Make cosmetic changes to the second DataWindow object

Now you modify the DataWindow object. You:

• Rearrange the columns and labels
• Align the columns and labels
• Display the arrow for a drop-down DataWindow edit style

Columns on freeform DataWindows
Data fields on freeform DataWindow objects are still called columns, even though they are shown in a nontabular display.

Rearrange the columns and labels

Now you rearrange the columns and labels in the new DataWindow object. You can maximize the Design view for greater ease in manipulating the columns and their labels.

1 Click the Address: label in the Design view.
Hold the Ctrl key and click the address column.

The two items are selected.

2 Keep the Ctrl key pressed and click the following column labels and column controls:

<table>
<thead>
<tr>
<th>Label</th>
<th>Column</th>
</tr>
</thead>
<tbody>
<tr>
<td>City:</td>
<td>city</td>
</tr>
<tr>
<td>State:</td>
<td>state</td>
</tr>
<tr>
<td>Zip Code:</td>
<td>zip</td>
</tr>
</tbody>
</table>
If necessary, scroll down until you can see all the columns in the DataWindow.

3 Release the Ctrl key. Position the cursor on one of the selected objects and drag it to the top-right corner of the DataWindow object.

The objects move together.

4 Use the Ctrl+click technique to move the following label and column controls to the location indicated:

<table>
<thead>
<tr>
<th>Label</th>
<th>Move with column</th>
<th>Move under</th>
</tr>
</thead>
<tbody>
<tr>
<td>Company Name:</td>
<td>company_name</td>
<td>Last Name:</td>
</tr>
<tr>
<td>Phone Number:</td>
<td>phone</td>
<td>Company Name:</td>
</tr>
</tbody>
</table>

5 Drag the Detail band up below the last column label.

This removes any extra space in the detail area.

Some of the fields might overlap others. You fix this in the next exercise.

The DataWindow should now look like this in the Design view:

![DataWindow Design View](image)

The DataWindow Preview view looks like this:

![DataWindow Preview View](image)
Align the columns and labels

Now you align the columns and labels on the new DataWindow.

1. Select the Zip Code: label in the Design view.
   Move the Zip Code: label as close as possible to the company_name column.
   A narrow space should separate the left edge of the label box from the right edge of the column box.

2. While the Zip Code: label is still selected, use the Ctrl+click technique to select the Address:, City:, and State: labels.

3. Select Format>Align from the menu bar.
   A cascading menu of align options displays.

4. Select the first option (Align left).
   PowerBuilder aligns the left edges of the selected objects with the left edge of the first item you selected (the Zip Code: label).

5. Move the zip column so that it is next to the Zip Code: label.
   Align the address, city, and state columns with the zip column, just as you aligned the column labels.
Display the arrow for a drop-down DataWindow edit style

The column for the customer state of residence has a DropdownDataWindow edit style. This is an extended attribute associated with the State column in the EAS Demo DB database. The (drop-down) DataWindow with which the column is associated has a list of states and their two-letter postal codes.

You can make the state selection list visible at all times in your application or you can display an arrow at all times to indicate that a selection list is available. Now you change the property for the state column to show the arrow at all times.

1  Click the state column in the Design view.
   Make sure the Properties view displays.

   The Properties view displays properties of the column.

2  Click the Edit tab in the Properties view.

   You might need to click the arrow keys near the top of the Properties view to display the Edit tab before you can click it. Notice that the Style Type selection is DropDownDW.

3  Select the Always Show Arrow check box.
   Make sure the state column in the Design view is wide enough to display two characters plus the arrow symbol.

   An arrow appears next to the state column in the Design and Preview views. While the column is selected in Design view, you can make the column wider by holding the cursor over the right edge of the column until the cursor symbol changes to a double-headed arrow, then dragging the edge toward the rightmost frame of the view.

4  Click the Save button in PainterBar1.
   Click the Close button in PainterBar1.
Make cosmetic changes to the second DataWindow object
LESSON 8

Attaching the DataWindow Objects

After you create and save a DataWindow object, you can use it in a window. You have already created the d_custlist and the d_customer DataWindow objects. Now you associate each of these DataWindow objects with a DataWindow control in the w_customers window.

In this lesson you:

- Attach the DataWindow object to the master DataWindow control
- Attach the DataWindow object to the detail DataWindow control
- Run the application
- Attach DataWindow objects to the Product window
- Run the application again

How long does it take?
About 15 minutes.
Attach the DataWindow object to the master DataWindow control

Where you are
> Attach the DataWindow object to the master DataWindow control
   Attach the DataWindow object to the detail DataWindow control
   Run the application
   Attach DataWindow objects to the Product window
   Run the application again

Now you attach the DataWindow object to a DataWindow control in the w_customers window.

1. Expand the pbtutor.pbl branch in the System Tree.

2. Right-click w_customers and select Edit from the pop-up menu
   or
   Double-click w_customers in the System Tree.

   The Window painter displays the w_customers window.
3 Right-click the top DataWindow control (dw_master) in the Layout view.
   If the Properties view is not displayed, select Properties from the pop-up menu.
   Click the ellipsis button next to the DataObject box in the Properties view.
   The Select Object dialog box displays.

4 Select d_custlist in the DataWindows list box and click OK.
   PowerBuilder associates the d_custlist DataWindow object with the dw_master DataWindow control.

   The Layout view now shows the d_custlist DataWindow headings inside the dw_master control, but you do not see any data yet. The DataWindow does not execute its SELECT statement until you run the application.

---

**Adding DataWindow objects to the window using drag and drop**

In this tutorial, you use a custom DataWindow control that has built-in error handling. If you want to use the standard DataWindow control, you do not need to add the control to the window and then attach a DataWindow object to it as you did in this lesson. You can simply select the DataWindow object you want from the System Tree and drag it onto the window in the Layout view. PowerBuilder creates the DataWindow control for you.
Attach the DataWindow object to the detail DataWindow control

Now you attach a DataWindow object to the detail DataWindow control. The Window painter should still be open for the w_customers window.

1 Select the bottom DataWindow control (dw_detail) in the Layout view. Click the ellipsis button next to the DataObject box in the Properties view.
   Select d_customer in the Select Object dialog box and click OK.
   PowerBuilder associates the d_customer DataWindow object with the dw_detail DataWindow control. The Window painter workspace now shows the d_customer DataWindow object inside the dw_detail control.

2 In the Layout view, make the dw_detail control larger so that you can see all of the columns you added to the DataWindow object.
   If you need to, you can also enlarge the window to make more room. If you make the dw_detail control wider, you may also want to make the dw_master control the same width.
Run the application

***Where you are***
- Attach the DataWindow object to the master DataWindow control
- Attach the DataWindow object to the detail DataWindow control

> Run the application
- Attach DataWindow objects to the Product window
- Run the application again

Now you run the application again to test the insert, update, and delete capabilities of the second DataWindow.

1. **Click the Run button in the PowerBar.**
   PowerBuilder prompts you to save your changes.

2. **Click Yes.**
   The application begins running, and the login window displays.

3. **Type dba in the User ID box.**
   **Type sql in the Password box and click OK.**
   The database connection is established, and the MDI frame for the application displays.

4. **Select File>Report>Maintain Customers from the menu bar.**
   The Customer window displays.
Run the application

The top DataWindow control (dw_master) shows all of the rows retrieved from the Customer table. The hand pointer shows which row is selected. The bottom DataWindow control (dw_detail) shows further information about the selected customer.

5 **In the running application, click the Insert button in the toolbar**  
   or  
   **Select Edit>Insert from the Frame window menu bar.**

   This clears (resets) the dw_detail DataWindow, allowing you to add information for a new row that you will insert into the data source. The cursor is in the Customer ID box in the dw_detail control.

6 **Add a new customer row by entering information in the boxes in the detail DataWindow.**

   **Typing information for a new customer**

   The Customer ID number must be unique. To avoid duplicate numbers, use a four-digit number for your new database entry, or scroll down the list of three-digit customer numbers in the master DataWindow and select an ID number that does not appear in the list.

   Enter values for the remaining fields.

   The phone number and zip code use edit masks to display the information you type. You must enter numbers only for these data fields. To specify the state in which the customer resides, you must click the arrow next to the state column and select an entry from the drop-down list box.

7 **Click the Update button in the toolbar**  
   or  
   **Select Edit>Update from the menu bar.**

   This sends the new customer data to the database and displays a confirmation message, as coded in the script for the ue_update event.

   The new customer does not yet display in the master DataWindow. (You could add code to include this feature). However, if you open another instance of the w_customers sheet, the new customer data is visible in both the master and detail DataWindow controls.
8 Click OK in the message box.
   Click a customer in the master DataWindow.
   That customer data displays in the lower DataWindow.

9 Change the customer address in the detail DataWindow.

10 Click the Update button in the toolbar
    or
    Select Edit>Update from the menu bar.
    This sends the revised customer data to the database and displays another
    confirmation message.

11 Click OK in the message box.
    Select another customer in the master DataWindow.
    That customer data displays in the detail DataWindow.

12 Click the Delete button in the toolbar
    or
    Select Edit>Delete from the menu bar.
    The customer is deleted from the DataWindow immediately but is not
    deleted from the database unless you select the Update option on the Edit
    menu. In this particular situation, the Update operation may fail, because
    rows in other tables in the EAS Demo DB database may refer to the row
    that you are trying to delete.
    You should be able to delete any row that you have added to the database.

13 Select File>Exit from the menu bar.
   The application terminates and you return to the Window painter.

14 Close the Window painter.
Attach DataWindow objects to the Product window

Where you are
Attach the DataWindow object to the master DataWindow control
Attach the DataWindow object to the detail DataWindow control
Run the application
> Attach DataWindow objects to the Product window
Run the application again

Now you add two DataWindow objects to the w_products window. These DataWindow objects are provided for you in the tutor_pb.pbl library.

1  Right-click w_products in the System Tree and select Edit from the pop-up menu
   or
   Double-click w_products in the System Tree.
   The Window painter displays the w_products window.

2  If the Control List view is not open, select View>Control List from the View menu.
   Select the dw_master DataWindow control in the Control List view.
   Click the ellipsis button next to the DataObject box in the Properties view.
   PowerBuilder displays the Select Object dialog box.

3  Select tutor_pb.pbl in the Application Libraries box.
   Select d_prodlist in the DataWindows box and click OK.
   The Data Object box in the Properties view of the Window painter now displays d_prodlist.
Lesson 8  Attaching the DataWindow Objects

PowerBuilder associates the d_prodlist DataWindow object with the dw_master DataWindow control in the w_products window. You see the headings for the DataWindow object in the Layout view. You might need to resize the control and/or the window.

4 Click the dw_detail DataWindow control in the Control List view.
   Click the ellipsis button next to the DataObject box in the Properties view.

   The Select Object dialog box displays.

5 Select tutor_pb.pbl in the Application Libraries box.
   Select d_product in the DataWindows list box and click OK.

   You return to the Window painter.

   PowerBuilder associates the d_product DataWindow object with the dw_detail DataWindow control. The Layout view now shows the d_product DataWindow object inside the dw_detail control. The d_product DataWindow object has seven columns labeled Product ID, Product Name, Product Description, Size, Color, Quantity, and Unit Price.

   If necessary, in the Layout view, make the dw_detail control larger so that you can see all of the columns in the DataWindow object. You can also enlarge the window to make more room.
Run the application again

Where you are
Attach the DataWindow object to the master DataWindow control
Attach the DataWindow object to the detail DataWindow control
Run the application
Attach DataWindow objects to the Product window
> Run the application again

Now you run the application again to test the Product window.

At this point the Product window should have all of the capabilities of the Customer window. Like the Customer window, the Product window functions as a master/detail window, providing support for retrieval, insert, update, and delete operations against the database.

1 Click the Run button in the PowerBar.
   PowerBuilder prompts you to save your changes.

2 Click Yes.
   The application begins running, and the login window displays.

3 Type dba in the User ID box.
   Type sql in the Password box and click OK.
   The database connection is established, and the MDI frame for the application displays.
4 Select File>Report>Maintain Products from the menu bar.

The Product window displays. The top DataWindow control shows all of the rows retrieved from the Product table.

The bottom DataWindow control shows information about the product selection in the top DataWindow control.

5 Select Edit>Insert from the menu bar.

This clears the dw_detail DataWindow and allows you to add a new row to the DataWindow. The cursor is in the Product ID box in the dw_detail control.

6 Add a new product row by entering information in the boxes in the lower DataWindow.

Use the Tab key to move from box to box.
Run the application again

7 Select Edit-Update from the menu bar.
This sends the new product data to the database and displays a confirmation message, as coded in the script for the ue_update event.

The new product does not display yet in the top DataWindow, but if you open another product sheet, the new information displays. If you want, you can add code to the Clicked event of the update button to automatically refresh the data in the master DataWindow control.

8 Click OK in the message box.
Click a product in the master DataWindow.
That product data displays in the detail DataWindow.

9 Change the product’s unit price.
Select Edit-Update from the menu bar.
This sends the revised product data to the database and displays another confirmation message.

10 Click OK in the message box.
Select another product in the master DataWindow.
That product’s data displays in the detail DataWindow.

11 Select Edit-Delete from the menu bar.
The product is deleted from the DataWindow immediately but is not deleted from the database until you select the Update option on the Edit menu.

12 Select File-Exit from the menu bar.
The application closes and you return to the Window painter.

13 Close the Window painter.
Getting Started

LESSON 9

Running the Debugger

Sometimes your application does not behave the way you think it will. Perhaps a variable is not being assigned the value you expect, or a script does not do what you want it to. In these situations, you can closely examine your application by running it in debug mode.

In debug mode, you can set breakpoints (stops) in scripts and functions, step through the code line by line, and display the contents of variables to locate logic errors and mistakes that result in errors during execution. When you run your application in debug mode, PowerBuilder suspends execution just before it hits a line containing a breakpoint. You can then look at and correct the values of variables.

In this lesson you:

• Add breakpoints in application scripts
• Run in debug mode
• Set a watch and a conditional breakpoint

How long does it take?
About 20 minutes.
Add breakpoints in application scripts

Now you open the Debugger and add breakpoints to examine the behavior of the login and Customer windows. When PowerBuilder runs the application in debug mode, it stops just before executing a line containing a breakpoint.

When you insert breakpoints in a script, you should select lines that contain executable statements. If you try to set a breakpoint in variable-declaration lines, comment lines, or blank lines, PowerBuilder sets the breakpoint at the next executable line.

1 Click the Debug button in the PowerBar.

PowerBuilder opens the Debugger. There are three stacks of tabbed panes in the default view layout scheme. The Source view is visible in a single pane at the top left of the Debug window. The Source Browser view is open in the pane at the top right.

If the Debug window looks different
If you have opened the Debug window before and opened, moved, or closed any views, your display may look different. To restore the default view layout scheme, select View>Layouts>Default from the menu bar.
The source code for the application Open event displays in the Source view at top left. If it does not display, expand the Application node in the Source Browser view’s tree view and double-click the Open event under the pbtutor application.

2 **In the Source view, double-click the line containing the following assignment statement:**

   
   ```csharp
   this.ToolBarSheetTitle = "MDI Application Toolbar"
   ```
   
   A black breakpoint symbol displays at the start of the line to show that a breakpoint has been set on the statement.

3 **Expand the following node in the Source Browser view:**

   Windows>`w_welcome>`cb_ok

   The Source Browser view lists only events that have been coded. The only event for the login window OK button is the Clicked event.

4 **Double-click the Clicked event for the cb_ok button in the Source Browser view.**

   The code for the Clicked event displays in the Source view.
5 Double-click the following line:

```
gnv_connect = CREATE &
    n_pbtutor_connectservice
```

A breakpoint symbol displays at the start of the line.

6 Double-click w_master_detail_ancestor in the Source Browser view.
   Double-click dw_master, then rowfocuschanged.

PowerBuilder displays the script for the RowFocusChanged event of the
dw_master DataWindow control in the Source view.

7 Double-click this line:

```
IF dw_detail.Retrieve(ll_itemnum) = -1 THEN
```

A breakpoint symbol displays at the start of the line.
8 Select the Breakpoints tab in the lower-right stack.

You should see the breakpoints you set in the Breakpoints view. To complete this lesson, you need to have these breakpoints set correctly.

If you have additional breakpoints
You can clear any excess breakpoints using the pop-up menu in the Breakpoints view.
Run in debug mode

Where you are
Add breakpoints in application scripts
> Run in debug mode
Set a watch and a conditional breakpoint

Now you run the application in debug mode. You step through the code line by line.

About the Step buttons
You can use either Step In or Step Over to step through an application one statement at a time. They have the same result except when the next statement contains a call to a function.

Use Step Over to execute the function as a single statement. Use Step In if you want to step into a function and examine the effects of each statement in the function.

If you have stepped into a function, you can use Step Out to execute the rest of the function as a single step and return to the next statement in the script that called the function.

1 Click the Start button in PainterBar1
   or
Select Debug>Start pbtutor from the menu bar.
   The application starts and runs until it hits a breakpoint (in this case, the call to the assignment statement for the toolbar title for sheet windows).
   You return to the Debug window, with the line containing the breakpoint displayed. The yellow arrow cursor means that this line contains the next statement to be executed.

2 Click the Global tab in the lower-left stack.
   The Global Variables view displays.
3 Double-click transaction sqlda. Find the DBMS property, which has a String datatype.

Notice that this property does not yet have a value associated with it because the Debugger interrupted execution before the ProfileString function executed.

4 To execute the next statement, click the Step In button in PainterBar1 or Select Debug>Step In from the menu bar.

The application starts execution of the Open event for the MDI frame window.

5 Use Step In or Step Over to step through the code until you reach this statement in the script for the frame window Open event:

```powerbuilder
open(w_welcome)
```

After PowerBuilder finishes executing this statement, the login window displays and the Debug window is minimized.

The Open event for the frame window also has a posted call to the ue_postopen function (that you stepped through without examining). This function in turn includes code that starts the processing of a chain of sheet manager functions. These functions are processed at the end of the script for the Open event, after the login window displays.
6 Click Step Over until the login window displays and the Debugger is minimized.
Type **dba** in the User ID box of the login window.
Type **sql** in the Password box and click OK.

You return to the Debug window. The yellow arrow in the Source view points to the next executable statement, the CREATE statement for the connection service object. This is the first executable line in the script for the Clicked event of the cb_ok command button.

7 Select the Call Stack tab in the lower-right stack.

The yellow arrow in the Call Stack view indicates the current location in the call stack. If you double-click another line in the stack, the Source and Variables views change to display the context of that line, and a green arrow indicates the line in the Source view. If you then single-click another line in the stack, a green arrow displays in the Call Stack view to indicate the line for which context is displayed. When you continue to step through the code, the Source and Variables views return to the current context.

8 Click the Step In button.

The Debugger takes you to the script for the Constructor event of the connection service object.

9 Click the Step Out button.
Click the Global tab in the lower-left stack.
Look again at the Transaction object properties.

You step out of the Constructor event in a single step and return to the script for the OK button Clicked event. Now the value of sqlcode has changed, and the sqllerrortext and DBMS property have values, but the UserID, DBPass, and DBParm properties do not.
The values were assigned during execution of the Constructor event of the connection service object after the of_GetConnectionInfo function returned information from the INI file, but because you commented out the lines in the code for the UserID, DBPass, and DBParm properties, these values were not retrieved.

10 Click on the Local tab in the lower-left stack.

The local variables for the Clicked script have not yet been assigned values.

11 Use the Step In button to step through the three assignment statements for the local variables.

As you step through each statement, you can check that the values assigned to the local variables are what you expected.
12 Click again on the Global tab in the lower-left stack and expand the Transaction object. Use the Step In button to step through the three lines that instantiate the Transaction object (SQLCA) with user-entry values for UserID, DBPass, and DBParm.

As you step through each statement, you can check that the values you entered in the login window are being assigned to the Transaction object. You are still not connected to the database until the connection service object of _Connect function is executed.

13 Click the Continue button in PainterBar1.

The Continue button resumes execution until the next breakpoint. The database connection is established, the login window closes, and the MDI frame for your application displays. The application is waiting for user input.

14 Select File>Report>Maintain Customers from the menu bar.

The application continues until it reaches the line in the RowFocusChanged event that contains the next breakpoint you added.

The RowFocusChanged event for a DataWindow occurs before the DataWindow is displayed. For this reason, execution stops before the Customer window is opened.
Set a watch and a conditional breakpoint

Where you are
Add breakpoints in application scripts
Run in debug mode
> Set a watch and a conditional breakpoint

Next you set a watch on a variable whose value changes when the user selects a row in the Customer window. You then change one of the simple breakpoints you have set into a conditional breakpoint that is triggered only when a variable has a specific value.

1 **Click the Watch tab in the lower-right stack.**
   **Click the Local tab in the lower-left stack.**
   **Select the ll_itemnum variable in the Local view and drag it to the Watch view.**
   The ll_itemnum variable is set to 101, the ID of the first customer retrieved. Displaying it in the Watch view makes it easier to observe when its value changes. You can also drag Global, Instance, and Parent variables to the Watch view so that you can easily keep track of several variables of different types.

2 **Click the Continue button.**
   The application resumes execution. The Customer window displays and shows the list of customers retrieved from the database. The detail DataWindow shows information about customer 101.

3 **Select a different row in the master DataWindow of the Customer window.**
   You return to the Debug window. The new value of ll_itemnum displays in both the Local Variables view and the Watch view.

4 **Click the Breakpoints tab in the lower-right stack.**
   **Double-click the rowfocuschanged breakpoint.**
   The Edit Breakpoints dialog box opens with the breakpoint in the RowFocusChanged event selected.
Set a watch and a conditional breakpoint

5 Type the following line in the Condition text box and click OK:

   ll_itemnum = 107

The breakpoint in the RowFocusChanged event script is now a conditional breakpoint. PowerBuilder suspends execution only when it reaches this statement and the value of ll_itemnum is 107.

6 Click OK to close the dialog box.
Click the Continue button.

The application resumes execution. Now you can select different rows in the Customer window, and the Debug window opens at the breakpoint only if you select the customer whose ID is 107.

If you select customer 107, click the Continue button again to return to the application.

7 Select File>Exit from the application's menu bar.

The application terminates and you return to the Debug window.

8 Select File>Close from the menu bar.

You return to the PowerBuilder development environment.
Exception Handling

Exception handling allows you to trap errors that occur during the execution of a program and to provide useful information about those errors to the application user. This lesson describes how to create user-defined exception objects and use them to catch exceptions that you throw from a method in a TRY-CATCH statement.

In this lesson you:
• Add a new sheet window to the existing application
• Create user-defined exception objects
• Create a new user function and user event
• Call the methods and catch the exceptions
• Run the application

How long does it take?
About 45 minutes.
Add a new sheet window to the existing application

Where you are
> Add a new sheet window to the existing application
   Create user-defined exception objects
   Create a new user function and user event
   Call the methods and catch the exceptions
   Run the application

In this lesson you add a third sheet window to the main tutorial application. You create and call a function to perform a routine operation (calculate a percentage) on values returned from embedded SQL commands and a value selected by the application user from a drop-down list box control.

The prototype for the function you create throws user-defined exceptions. You call the function in a TRY-CATCH block inside the Clicked event on a command button control. The CATCH clauses in the Clicked event catch user-defined exceptions thrown by the new function as well as a system exception thrown up the application call stack.

You use the new sheet window to calculate the percentage of customers that resides in a selected state. The controls you add to the new sheet window are:

- Two static text boxes that you change programmatically to display read-only results
- A command button to call a function that calculates percentages
- A drop-down list box for a list of states where customers reside
- A text box that displays the percentage of customers residing in the state that application users select from the drop-down list box

To add a sheet window to the existing application, you must:

- Create the sheet window
- Provide access to the sheet window from the main application frame
Create the sheet window

You inherit the sheet window from the w_pbtutor_basesheet window. This is the base class for sheet windows that you generated with the Template Application wizard. You do not use the w_master_detail_ancestor extension layer window, since the modifications you made to it are not useful in the new sheet window.

1 Select File> Inherit from the PowerBuilder menu. Make sure the Objects of Type box displays Windows. Select w_pbtutor_basesheet from the available windows in the pbtutor.pbl library and click OK.

2 Make sure the Layout view displays in the Window painter. Select Insert> Control> StaticText and click near the top left corner of the Layout view.

3 In the Properties view, highlight the default text in the Text text box and type the following:
   1. Select or type a state code in drop-down list:

4 Lengthen the control width and the width of the sheet window to display the entire text and allow room for a drop-down list control at the top right of the window.

   A length of 2250 should be sufficient for the sheet window width. You can set this on the Other tab of the Properties view for the window, or you can drag the window edge in the Layout view to make room for an additional control.

5 Right-click the static text control in the Layout view and click Duplicate from the pop-up menu. In the Properties view, highlight the default text in the Text text box of the new static text control and type the following:

   2. Click Percentage button
Add a new sheet window to the existing application

6 Select Insert->Control->DropDownListBox and click to the right of the static text boxes near the top right corner of the Layout view.

7 In the Properties view for the drop-down list box, type ddlb_state for the control name. Select the AllowEdit and the VScrollBar check boxes.

8 Click the command button in the painter bar and click below the two static text boxes. In the Properties view, type cb_percent for the button name and type Percentage for the button text.

9 Select Insert->Control->SingleLineEdit and click below the command button in the Layout view. In the Properties view, type sle_result for the control name and type the following for the control text:

```
Text box for percent of customers in the selected state
```

10 Lengthen the control width to display the entire text.
11 Make sure no control is selected and the sheet window properties are displayed in the Properties view.

Type Customer Location for the Tag property.

The text you typed will be visible in the sheet window title at runtime. Code in the basesheet ue_postopen event assigns the Tag text to the sheet window title.

12 Select File>Save from the PowerBuilder menu.

Select pbtutor.pbl for the application library, type w_cust_pct for the new sheet window name, and click OK.

This saves the new sheet window with all its controls to the main tutorial library.

Provide access to the sheet window from the main application frame

You must register the new sheet with the sheet manager.

1 Double-click w_pbtutor_frame in the System Tree.

2 If the ue_postopen event is not visible in the Script view, click the Event List tab and double-click ue_postopen.

The ue_postopen event script displays in the Script view.

3 Type the following line in the list of registered sheet windows:

   ls_sheets[3] = "w_cust_pct"
4  Type the following line below the list of sheet window titles to display:

```
ls_display[3] = "Customer Location"
```

Better coding practice
You could reduce the six lines of code for defining sheet windows and their display names by replacing them with the following lines of code:

```
// Define sheet windows and their display names
string ls_sheets[]="w_customers", "w_products", &
                    "w_cust_pct"
string ls_display[]="Maintain Customers", &
                "Maintain Products", "Customer Location"

inv_sheetmgmt.of_RegisterSheets(ls_sheets, ls_display)
```

5  Select File>Save and close the w_pbtutor_frame window.

The next time you run the pbtutor application, you should be able to open the new sheet window from the File menu of the main frame window. Although you can now run the new sheet window from the development environment, you must make sure that you can run it from a compiled application as well.

For this purpose, you reference the sheet windows as window objects in the sheet manager of_registersheet script. The reference is necessary for the compiler to know that this object is used in the application so that it will include it in the executable.

You create a compiled application in Lesson 11, “Preparing the Application for Deployment.”
6 Double-click n_pbtutor_sheetmanager in the System Tree.

7 Click the Function List tab and double-click of_registersheet.
The script for the of_registersheet function displays in the Script view.

8 Type the following after the lines declaring sheet window variables for
   the w_customers and w_products windows:

   w_cust_pct lw_sheet3

9 Save and close the n_pbtutor_sheetmanager user object.
Create user-defined exception objects

Now you create two user-defined exception objects that you will throw from a function that is invoked when the user clicks the command button on the w_cust_pct window. You also create a user-defined exception object that you throw from a user event on the drop-down list box control that you added to the w_cust_pct window.

1. Select File>New from the PowerBuilder menu and click the PBObject tab in the New dialog box.

2. Select the Standard Class icon and click OK.
   Select throwable from the Types list box and click OK.
   The new exception object displays in the User Object painter.

3. In the Text box of the Properties view, type the following:
   No rows were returned from the database. If you typed or selected a state code in the drop-down list box and the database connection has not been closed, either the state you entered has no customers or you entered the state code incorrectly.

   The exception object has get and set methods for handling the Text property. Here you set the text property directly in the user interface.

4. Click outside the Properties view to enable the Save button.
   Select File>Save, select the pbtutor.pbl application library, and type exc_no_rows in the User Objects box for the new exception object name, and click OK.

5. Select File>Close.
6 Repeat steps 1-5 using the following values for the Text property and the exception object name:

<table>
<thead>
<tr>
<th>Property</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text</td>
<td>Percentage too low. Only one customer in this state. Notify regional sales manager...</td>
</tr>
<tr>
<td>Exception object name</td>
<td>exc_low_number</td>
</tr>
</tbody>
</table>

7 Repeat steps 1-5 using the following values for the Text property and the exception object name:

<table>
<thead>
<tr>
<th>Property</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text</td>
<td>You must use the two-letter postal code for the state name.</td>
</tr>
<tr>
<td>Exception object name</td>
<td>exc_bad_entry</td>
</tr>
</tbody>
</table>
Create a new user function and user event

Where you are
Add a new sheet window to the existing application
Create user-defined exception objects
> Create a new user function and user event
Call the methods and catch the exceptions
Run the application

Now you add a function that you invoke from the Percentage command button’s Clicked event and an event that is triggered when the focus is changed from the drop-down list box on the w_cust_pct window. The function calculates the percentage of customers living in a particular state. The event processes the current value of the drop-down list box control to make sure it is two characters in length (for the state code).

1 Open w_cust_pct in the Window painter if it is not already open.
Select Insert>Function from the Window painter menu.

The Script view displays the Prototype window. The first drop-down list box in the Script view displays (Functions) and the second drop-down list box displays (New Function).

2 Select decimal for the Return Type and type uf_percentage for Function Name.

3 Select integer for the Argument Type and type ai_custbystate for the Argument Name.

You will add a second argument in the next step.

4 Right-click anywhere in the Prototype window and select Add Parameter from the pop-up menu.

5 Select integer for the second Argument Type and type ai_totalcust for the second Argument Name.

6 Type exc_no_rows,exc_low_number in the Throws box.
7 Type the following script for the new function:

```
Decimal my_result
exc_no_rows le_nr
exc_low_number le_ex

/* Process two integers passed as parameters. Instantiate and throw exceptions if the first
integer value is 0 or 1. Otherwise calculate a percentage and return a numeric value truncated to a
single decimal place. If the second integer value is 0, catch and rethrow the runtime dividebyzero error
during the calculation. */

CHOOSE CASE ai_custbystate
CASE 0
   le_nr = create exc_no_rows
   throw le_nr
CASE 1
   le_ex = create exc_low_number
   throw le_ex
CASE ELSE
   TRY
      my_result=(ai_custbystate/ai_totalcust)*100
   CATCH (dividebyzeroerror le_zero)
      throw le_zero
   End TRY
   END CHOOSE
return truncate(my_result,1)
```

Later in this tutorial, you will call the uf_percentage function from the Clicked event on the command button, passing in two integers and processing the return value.

You now add a user event for the drop-down list box that throws the exc_bad_entry exception object when a user-entered state code is not exactly two characters in length.

8 Select ddlb_state in the first drop-down list box of the Script view and select (New Event) in the second drop-down list box.
9  Select integer for Return Type and type `ue_modified` for Event Name.
    Select string for Argument Type and type `as_statecode` for Argument Name.
    Type `exc_bad_entry` in the Throws box or drag it from the System Tree to the Throws box.

    Note that the Event ID is (None). You do not select an Event ID for the `ue_modified` event. If you selected an Event ID, you could not enter user-defined exception objects in the event Throws clause.

10  Type the following script for the new `ue_modified` event:

    ```powershell
    exc_bad_entry  le_ex
    //Make sure the current text in the drop-down list
    //box is two characters in length. Otherwise,
    //instantiate the exc_bad_entry exception object and
    //throw the exception.
    IF len(this.text)<>2 Then
        le_ex = create exc_bad_entry
        throw le_ex
    END IF
    Return 1
    ```

    Next you call the `ue_modified` event and the `uf_percentage` function, and catch the exceptions thrown by these methods.
Call the methods and catch the exceptions

Where you are
Add a new sheet window to the existing application
Create user-defined exception objects
Create a new user function and user event
> Call the methods and catch the exceptions
Run the application

You now write code to populate the drop-down list box controls with state codes from the customer table in the EAS Demo DB database. Since you made the control editable, an application user can also type in a value for the state code. Before you process a user-entered value, you check to make sure the value conforms to the conditions you set in the ue_modified event, namely that it is two characters in length.

You also add code to the Clicked event of the command button control to process the current state code in the drop-down list box control. In the Clicked event you call the uf_percentage function to calculate the percentage of customers from the selected state and catch all exceptions that can be thrown by the function.

1 Make sure the w_cust_pct is open in the Window painter and that ddb_state displays in the first drop-down list box of the Script view.

2 Select losefocus ( ) returns long [pbm_cbnkillfocus] in the second drop-down list box.

3 Call the ue_modified event and catch the exception object that it throws by typing the following lines for the losefocus event script:

```pascal
Try
    this.EVENT ue_modified(this.text)
Catch (exc_bad_entry le_be)
    messagebox ("from exc_bad_entry", & le_be.getmessage())
End Try

return 1
```

4 Select constructor ( ) returns long [pbm_constructor] from the second drop-down list box in the Script view prototype window for the ddb_state control.
5 Type the following lines in the Constructor event to populate the drop-down list box control:

```powershell
int li_nrows, n
string ls_state

//Get the distinct count of all states in the //customer table
SELECT count(distinct state) INTO :li_nrows
FROM customer;

//Declare the SQL cursor to select all states //in customer table but avoid //rows with duplicate values for state.
DECLARE custstatecursor CURSOR FOR
SELECT state FROM customer
GROUP BY state HAVING count(state)=1
UNION
SELECT state FROM customer
GROUP BY state
HAVING count(state)>1;
OPEN custstatecursor;

//Populate the control with a single entry for //every state in the customer table.
FOR n=1 TO li_nrows
    FETCH NEXT custstatecursor INTO :ls_state;
    this.additem( ls_state)
NEXT
CLOSE custstatecursor;

//Set first item in list as selected item
this.selectitem (1)
```

6 Select cb_percent from the first drop-down list in the Script view. Make sure clicked ( ) returns long [pbum_bnclicked] displays in the second drop-down list box.

7 Type the following lines for the Clicked event script:

```powershell
Decimal my_result
Double entry_1, entry_2
Int li_int, li_rtn
String sel_state

sel_state=ddlb_state.text

//Get the number of rows with customers from the //selected states and place in the entry_1 variable.
//Change the first static control to display this number.

SELECT count(*) INTO :entry_1 FROM customer
    WHERE customer.state=:sel_state;
st_1.text="Customers in state: " + string(entry_1)

//Get the total number of customers and place in the entry_2 variable.
//Change the second static control to display this number.
SELECT count(*) INTO :entry_2 FROM customer;
st_2.text="Total number of customers: " & + string(entry_2)

//Call uf_percentage and catch its exceptions.
TRY
    my_result = uf_percentage (entry_1, entry_2)
    CATCH (exc_no_rows e_nr )
        MessageBox("From exc_no_rows", &
            e_nr.getmessage())
    CATCH (exc_low_number e_ln )
        li_int=1
        MessageBox("From exc_low_number", &
            e_ln.getmessage())
    CATCH (dividebyzeroerror e_zero)
        li_rtn = MessageBox("No Customers", &
            "Terminate Application?", Stopsign!, YesNo!)
        IF li_rtn=1 THEN
            HALT
        END IF
    END CATCH
END TRY

//Display the message in the text box. Vary the message depending on whether there is only one customer for the selected state or if more than one customer resides in selected state.
IF li_int=1 THEN
    sle_result.text ="Value not calculated for " & + sel_state + "." + " Try another state."
ELSE
    sle_result.text = String (my_result) + &
    " % of customers are in " + sel_state + "."
ENDIF
Run the application

Where you are
Add a new sheet window to the existing application
Create user-defined exception objects
Create a new user function and user event
Call the methods and catch the exceptions
> Run the application

You are now ready to run the application and calculate the percentage of customers in a selected state.

You can test the exception conditions you scripted, but to test the divide-by-zero error condition, you need to artificially set the number of customers in the database to zero. You do this by adding a check box to the sheet window, then setting the number of customers to zero if the check box is selected.

In this exercise you:

• Test the new sheet window
• Add a test for the divide-by-zero error

Test the new sheet window

1 Click the Run button in the PowerBar.
   If PowerBuilder prompts you to save changes, click Yes.

2 Type dba in the User ID box.
   Type sql in the Password box and click OK.
   The database connection is established, and the MDI frame for the application displays.
3. **Select File>Report>Customer Location from the menu bar.**

   The Customer Location window displays. The current entry in the drop-down list is AB for Alberta.

![Customer Location Window](image)

4. **Click the Percentage button.**

   Because there is only one customer in Alberta, the `exc_low_number` user-defined exception is thrown. The message from the exception is displayed in a message box that was defined in a CATCH clause in the button Clicked event.

![Message Box](image)

5. **Click OK to close the message box.**

   The text in the static text boxes now displays the number of customers in Alberta and the total number of customers in the database. The text in the editable text box tells you the value was not calculated and prompts you to select another state.
6 **Select or type CA in the drop-down list box and click the Percentage button.**

The results from the database show 10 customers in California for a total of 7.9% of all customers in the database. The percentage may be different if you have modified the database.

![Image of a dialog box showing customers in state CA and percentage calculation.]

7 **Type Ohio into the drop-down list box and click the Percentage button.**

When you lose focus from the drop-down list box by clicking the Percentage button control, the LoseFocus event fires. This event calls the ue_modified event that throws the exc_bad_entry user-defined exception. The exception message tells you to use a two-letter postal code for the state name.

8 **Click OK to close the message box, type US in the drop-down list box, and click the Percentage button.**

Because no rows are found in the database with US as the state code, the exc_no_rows exception is thrown. A message displays indicating no rows have been returned and suggests reasons why that might be the case. A more robust application might compare the typed text to a list of state codes and throw the exc_bad_entry exception instead, letting you know that US is not a state code.

9 **Click OK to close the message box.**
10 Right-click the database icon for the EAS Demo DB, a red and yellow SQL symbol, in your Windows System Tray. Select Exit from the pop-up menu, and click Yes in the Warning message box that displays.

This shuts down the connection to the EAS Demo DB database.

11 Select or type AB again in the drop-down list box and click the Percentage button.

The message from the exc_no_rows exception object displays for Alberta because the connection to the database was closed. To obtain results again, you need to terminate the application and restart it. PowerBuilder reestablishes a connection to the database at runtime when you restart the application.

12 Click OK to close the message box and select File>Exit from the application menu to return to the development environment.

The Database painter and the Database Profile painter might still list the database connection as being open. In this case you can use either painter to disconnect and reconnect to the database at design time.

Add a test for the divide-by-zero error

You now add a check box to the w_cust_pct window. You then write code to force a divide-by-zero error if the check box is selected. Because this test requires an instantiated check box object, you surround the new code in a TRY-CATCH statement that checks for null object errors.

1 Make sure the w_cust_pct window is open in the Layout view. Select Insert>Control>CheckBox from the Window painter menu.

2 Click in the window just to the right of the Percentage command button.

3 In the Name box in the Properties view, type cbx_zero. In the Text box, type Test divide-by-zero error.

4 Click the Function List tab. Double-click the uf_percentage function.
5 Type the following text just above the CHOOSE CASE statement:

```powershell
//Set denominator to zero to test error condition
//Numerator unimportant, avoid user exception cases
TRY
    IF cbx_zero.checked=TRUE THEN
        ai_totalcust=0
        ai_custbystate=2
    END IF
CATCH (nullobjecterror e_no)
    MessageBox ("Null object", "Invalid Test")
END TRY
```

---

Testing for the null object error
After you finish this lesson, you can test for the null object error by adding the following line above the TRY statement: `DESTROY cbx_zero`.

---

6 Click the Run button in the PowerBar.

If PowerBuilder prompts you to save changes, click Yes.

7 Type `dba` in the User ID box.
Type `sql` in the Password box and click OK.

The database connection is established, and the MDI frame for the application displays.

8 Select File>Report>Customer Location from the menu bar.
Select a state code from the drop-down list box.

9 Select the Test divide-by-zero error check box.
10 Click the Percentage button.

The division by zero error is thrown during the percentage calculation and caught by the button Clicked event. The message box that you coded in the CATCH clause for this error displays.

11 Click No to continue running the application. Continue to test the application by selecting another state code and optionally clearing the check box.

If the check box is selected when you click the button again and you select Yes in the error message box, the application closes and you return to the development environment.

12 Close the application when you have finished testing it.
Run the application
Preparing the Application for Deployment

In this lesson you create an executable version of the application for distribution to users. Users can run this executable version of the application just as they can any other application.

You:

• Create the Project object
• Create the executable file
• Create a shortcut
• Test the executable file

How long does it take?
About 10 minutes.
Create the Project object

Now you create the PBTUTOR Project object. You can then use the Project object to create the executable file for the application.

**About machine code**  If you are running PowerBuilder Enterprise, you can choose between Pcode (pseudocode) and machine code as the compile method for your project executable file. However, you cannot select machine code as the compile method for the tutorial application because it contains Try-Catch statements.

When you deploy an application to users, you may want to take advantage of the execution speed of machine code for some computations, such as loops, floating point or integer arithmetic, and function calls. While you are developing the application, you usually use Pcode because it is faster to generate.

**About dynamic libraries**  You can also create dynamic libraries for your application. Dynamic libraries can be used to store the objects in the application. By using dynamic libraries, you can break the application into smaller units that are easier to manage and also reduce the size of the executable file.

For small applications like the one that you are working on now, you do not need to use dynamic libraries.
1. Click the New button in the PowerBar. Click the Project tab in the New dialog box.

2. Select the Application Wizard icon and click OK.

Using the Project painter
If you clicked the Application icon on the Project page instead of the Application Wizard icon, you open the Project painter. You can make the same selections in the Project painter that you make with the wizard, but the wizard prompts you for this information.
Create the Project object

3 Click Next.
    The Specify Destination Library page displays.

4 Select pbtutor.pbl in the Application Libraries list box if it is not already selected.
    Click Next until the Specify Build Options page displays.
    The wizard will generate a project with the following default selections:

    | Wizard property   | Default value |
    |-------------------|--------------|
    | Project name      | p_pbtutor.exe|
    | Executable filename| pbtutor.exe  |
    | Optional resource file | none        |

5 Select Incremental Build for the Build Option.
    Click Next until the Specify Version Information page displays.
    The wizard will generate a project with the following default selections:

    | Wizard property   | Default value |
    |-------------------|--------------|
    | Generate machine code | No          |
    | Build dynamic libraries | No     |

6 If you want to, enter your own version information on the Specify Version Information page.
    If you do not change the information on this page, the defaults display in Windows Explorer when you look at the properties of the executable.
7 Click Next. Review the information on the Ready to Create Application page. Click the Finish button.

PowerBuilder creates a Project object for your application and displays it in the Project painter workspace.

After a project is defined, you can easily create an executable version of the application. Using a project saves time when you are working on an application that includes dynamic libraries that you expect to rebuild often. Selecting incremental build means that if you make a few changes, you can rebuild your project quickly, rebuilding only files that have changed or files that depend on files that have changed.
Create the executable file

Now you create the executable file for your application. The executable file you generate contains definitions for all the objects in the application. For the tutorial application, this includes the bitmap file used in the login window, since you did not include a separate resource file with your project.

You can create the executable in the Project painter, but usually, once you have defined the project, you do not need to open the painter again.

Workspaces and targets in the System Tree have Incremental Build, Full Build, and Deploy items on their pop-up menus that enable you to build and deploy some or all of the projects in a target or in the whole workspace. Incremental Build and Full Build compile your code. Deploy compiles the code and, for applications like the one you built in this tutorial, creates an executable file and optional dynamic libraries. For other projects, such as server component projects, Deploy also deploys the component and supporting files to the server.

In this lesson you look at the property sheets where build and deploy options are specified and then create the executable from the PowerBar.

1. Close the Project painter.
   Click Yes if prompted to save changes.

2. Right-click the pbtutor target in the System Tree.
   Select Properties and then select the Deploy tab.
This page shows all the projects in this target (currently only one).

If you have more than one project in the target, you can change the order in which they are executed and select which projects you want to build.

3 **Leaving p_pbtutor_exe checked, click the Cancel button.**  
Right-click MyWorkspace in the System Tree.  
Select Properties and select the Deploy Preview tab.

The Deploy Preview page shows all the targets in your workspace and the projects in each that have been selected for deployment, in the order in which they are to be deployed. You cannot change anything on this page—you use it to check that you have set up deployment options for your workspace the way you want to. All the projects shown on this page are deployed when you click the Deploy button in the PowerBar.

This workspace has only one target and only one project, so you can use the Deploy button to create the executable.
Create the executable file

4 Click the Cancel button to close the property sheet.

5 Click the Deploy button in the PowerBar.

The process of creating the executable file might take a few moments. While PowerBuilder is working, you can look at the Output window at the bottom of the screen to see what PowerBuilder is doing.

If you wanted to stop the deployment process, you could click the Stop button in the PowerBar. When deployment is complete, the Output window displays the following text: Finished Deploy of workspace MyWorkspace.
Create a shortcut

Where you are
Create the Project object
Create the executable file
> Create a shortcut
Test the executable file

Now you create a shortcut for the executable file. The icon serves as a shortcut to open the executable file. You can add the shortcut directly to the desktop or to the program group of your choosing.

1 Minimize PowerBuilder.
   PowerBuilder is minimized to an icon on the taskbar.

2 Right-click on a blank area of the desktop.
   Select New>Shortcut from the pop-up menu.
   The Create Shortcut dialog box displays.

3 Click the Browse button and locate pbtutor.exe.
   If you accepted the default installation folder, this is the location:
   C:\Program Files\Sybase\PowerBuilder 11.0\Tutorial\pbtutor.exe

4 Click OK.

5 Click Next.

6 Type SportsWear, Inc. as the name of the shortcut.

7 Click Finish.
   An icon and name display on the desktop.
   Now you must modify a property of the shortcut so that you can run the application. You can also change the icon.
Create a shortcut

8 Right-click the SportsWear, Inc. icon on the desktop. Select Properties in the pop-up menu.

The properties sheet for the desktop shortcut displays.

9 Select the Shortcut tab. Type the path to the PowerBuilder shared modules in the Start In box. Click OK.

About the location of the shared modules
When you install PowerBuilder, the installation process puts the DLLs in a shared directory. The default location is: C:\Program Files\Sybase\Shared\PowerBuilder.

If you want the user to be able to run the application by double-clicking the executable file, you must include the shared directory location in the system environment path.
Test the executable file

Where you are
Create the Project object
Create the executable file
Create a shortcut
> Test the executable file

Now you test the new executable file.

1 Make sure the pbtutor.ini file is in the same directory as the pbtutor.exe executable file.
   The default location of the pbtutor.ini file and the pbtutor.exe file is C:\Program Files\Sybase\PowerBuilder 11.0\Tutorial.

2 Double-click the icon for the tutorial application.
   The application begins running.

3 Test the application.
   Notice the changes you made to the customer information.

4 When you have finished testing the application, select File>Exit from the menu bar.

What to do next

Congratulations. You have completed the client-server part of the tutorial. Now you know the basics of application development with PowerBuilder. You can now continue on to the .NET Web Forms and Windows Forms lessons.

The Preface to this book includes a guide to the PowerBuilder documentation. To further your education, you should continue with these books:

User’s Guide
Application Techniques
DataWindow Programmer’s Guide

Getting Started 235
What to do next

All the PowerBuilder books are available in the Online Books and on the Sybase Web site at http://www.sybase.com/support/manuals/. For information on how to install the Online Books, see the Installation Guide.
Building a Web Forms Application

This part is a tutorial that shows you how to get started using .NET Web Forms targets. It provides step-by-step instructions for converting a client-server application to a Web Forms application.
Converting the PowerBuilder Tutorial to a Web Forms Application

This tutorial provides the information you need to convert the PowerBuilder tutorial application to an ASP.NET Web Forms application. It assumes you have installed the Microsoft .NET Framework 2.0 and an IIS server on your development computer. You can use a different computer to run the Web Forms application from a standard Web browser.

In this tutorial, you:

- Run the tutorial in PowerBuilder
- Make changes for a .NET Web Forms application
- Create a .NET Web Forms target and project
- Deploy a .NET Web Forms project
- Run the application from a Web browser

How long does it take?
About 40 minutes.
Run the tutorial in PowerBuilder

Before you deploy the PowerBuilder tutorial application as an ASP.NET Web application, make sure the application runs successfully from the PowerBuilder environment. The complete tutorial application is included in the Tutorial\Solutions directory in the PowerBuilder installation path.

Since you add a Web Forms target to the solutions workspace, it is best to copy the tutorial application workspace and targets to a separate directory first. That is what you do in the first steps of this tutorial.

**Tutorial requirements**

To run the tutorial application successfully, you must have configured ASP.NET for a .NET Web Forms project. This includes setting up appropriate permissions for running SQL Anywhere and connecting to the EAS Demo DB V110 database as an ASP.NET user. For information on configuring ASP.NET, see the first chapter in the *Deploying Applications and Components to .NET* book.

1. Create a subdirectory under the Programs>Sybase>PowerBuilder 11.0>PowerBuilder 11.0>Tutorial directory and label it *Web Forms*.

2. Copy all the files from the Tutorial\Solutions folder to the new Tutorial\Web Forms folder.

   There are four files you must copy: MyWorkspace.pbw, PBTutor.pbt, PBTutor.pbl, and Tutor_pb.pbl.

3. Select Programs>Sybase>PowerBuilder 11.0>PowerBuilder 11.0 from the Windows Start menu.

   The PowerBuilder development environment displays.
4 Select Open Workspace from the File menu.
   The Open Workspace dialog box displays.

5 Navigate to the Tutorial\Web Forms folder under the PowerBuilder 11.0 installation folder, select MyWorkspace.pbw, and click Open.
   The workspace containing the pbtutor.pbt PowerScript target file opens in the PowerBuilder IDE. This target contains two library files (pbtutor.pbl and tutor_pb.pbl) with all the objects of the tutorial application.

6 Click the Run button in the PowerBar.
   The Login window displays for the tutorial application.

7 Enter dba as the value for the user ID and sql as the password.
   Upon successful login, an MDI frame window with a menu and toolbar displays.

8 Test available menu options to make sure they are working, then terminate the application.

Make changes for a .NET Web Forms application

Where you are
   Run the tutorial in PowerBuilder
   > Make changes for a .NET Web Forms application
      Create a .NET Web Forms target and project
      Deploy a .NET Web Forms project
      Run the application from a Web browser

Unless you plan always to start the tutorial database manually before your Web Forms application connects to the database, you must grant ASP.NET users full control of the directories containing the database and the SQL Anywhere database engine, and extend that permission to all the files in those directories.

1 In Windows Explorer, browse to the Sybase\Shared\PowerBuilder directory.
   This directory contains the tutorial database.
2 Right-click the directory and select Properties from the pop-up menu.

3 Select the Security tab of the Properties dialog box for the directory and click the Add button.

The Select Users, Computers, or Groups dialog box displays.

If the Security tab does not display
To display the Security tab, you might need to modify a setting on the View tab of the Folder Options dialog box for your current directory. You open the Folder Options dialog box by selecting the Tools>Folder Options menu item from Windows Explorer. To display the Security tab, you must clear the check box labeled “Use simple file sharing (Recommended)”.

4 Click Locations, choose the server computer name from the Locations dialog box, and click OK.

5 Type ASPNET, IIS_WPG, or IIS_USRS in the list box labeled “Enter the object names to select” and click OK.

Before you click OK
If you click the Check Names button, a message displays if the system does not recognize the user name you entered. If the name is not recognized, you might have to reinstall the Microsoft 2.0 .NET Framework.

Enter ASPNET for IIS 5, IIS_WPG for IIS 6, or IIS_USRS for IIS 7. The ASP.NET account you enter is added to the Security settings tab for the current directory.
6 Select the new user account in the top list box on the Security tab, then select the “Full Control” check box under the Allow column in the bottom list box.

7 Click the Advanced button.

The Advanced Security Settings dialog box displays for the current directory.

8 Select the check box labeled “Replace permission entries on all child objects with entries shown here that apply to child objects” and click OK.

A Security dialog box displays to warn you it will remove current permissions on child objects and propagate inheritable permissions to those objects, and prompts you to respond.

9 Click Yes at the Security dialog box prompt, then click OK to close the Properties dialog box for the current directory.

10 Repeat steps 1-9 for the Sybase\SQL Anywhere 9\win32 directory.

Create a .NET Web Forms target and project

Where you are
- Run the tutorial in PowerBuilder
- Make changes for a .NET Web Forms application
- Create a .NET Web Forms target and project
- Deploy a .NET Web Forms project
- Run the application from a Web browser

You can use the PowerBuilder .NET Web Forms target wizard to create a .NET Web Forms target based on an existing PowerBuilder application target. In this tutorial, you create a .NET Web Forms target based on the PowerBuilder tutorial target. You also create a .NET Web Forms project that you will use to deploy the Web Forms application.

1 Select File>New from the PowerBuilder menu, and click the Target tab.

The Target page of the New dialog box displays.
Create a .NET Web Forms target and project

2 Select the .NET Web Forms Application icon and click OK.
   The first page of the wizard tells you what the wizard can do.

3 Click Next to display the second wizard page, then select the radio button to “use the library list and application object from an existing target” and click Next again.
   The Choose a Target page of the wizard displays. It contains a list box for targets of the current workspace. The PBTutor target is the only target in the tutorial workspace at this time.

4 Make sure PBTutor is selected, and click Next.
   The Specify Target File page displays. It lists a default name for the new Web Forms target based on the name of the existing target file that you selected. The default target file name is pbtutor_webform.pbt.

5 Click Next to use the default target name.
   The Specify Project Information page displays. It lists a default name for the new Web Forms project. The default project name is p_pbtutor_webform. The wizard page also lets you select the target library where you save the new project object. By default, the project object is saved in the main library of the new target—in this case, pbtutor.pbl.

6 Click Next again to accept the default values for project name and library.
   The Specify Settings for .NET Web Forms Application page displays default values for the following fields:

<table>
<thead>
<tr>
<th>.NET Web Forms parameter</th>
<th>Default value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Web application name</td>
<td>pbtutor</td>
</tr>
<tr>
<td>Application URL preview</td>
<td>http://&lt;ServerName&gt;/pbtutor, where &lt;ServerName&gt; is a placeholder for the name of the IIS server</td>
</tr>
</tbody>
</table>

7 Accept the default values by clicking Next.
   The Specify Resource Files / Directories page of the wizard displays.
8 Click the Add Files button.

The PowerBuilder Tutorial application uses some image files that must be selected for deployment with the Web Forms application.

The Choose Resource Files dialog box displays.

9 Select All Files from the Files of Type drop-down list and navigate to the parent Tutorial directory.

10 Hold down the Ctrl key and select the *tshirtw.jpg*, *tutsport.bmp*, and *tutorial.ico* files, and click Open.

The selected resources are added to the page as shown below:

![Specify Resource Files / Directories](image)

11 Click Next to include the selected resource files for deployment with the tutorial Web Forms application.

The Specify Win32 Dynamic Library Files page of the wizard displays. The tutorial application does not use any external DLLs.

12 Click Next twice to display the Specify Deployment Options page of the wizard.
Create a .NET Web Forms target and project

You do not include any extra JavaScript files on the Specify JavaScript Files page of the wizard, because none are needed for the tutorial application.

The Specify Deployment Options page displays:

13 Accept Localhost for the IIS server address or change this to the formal name for the local IIS server, then click Next.

In this tutorial, you deploy the Web Forms project directly to the local IIS server. After you click Next, the Summary page of the wizard displays.

14 Click the Finish button.

The .NET Web Forms Application wizard creates a .NET Web Forms target named PBTutor_WebForm that uses the library list from the pbtutorpbl library. It also creates a .NET Web Forms project named p_pbtutor_webform.
Deploy a .NET Web Forms project

After you create a Web Forms project, you must deploy it to an IIS server before you can run or debug the Web Forms application. However, before you deploy a Web Forms application, you can modify the runtime global properties for the application. In this lesson you change a global property for page navigation in the application’s DataWindow controls before you deploy the application.

1 In the System Tree, expand the PB Tutor_WebForm target and the pbtutor.pbl under that target.

Note that the pbtutor.pbl and tutor_pb.pbl libraries are listed under both the PB Tutor target and the PB Tutor_WebForm target. In the PB Tutor_WebForm target, the only project that displays in pbtutor.pbl is the .NET Web Forms project that you just created.

Although this library is shared with the PB Tutor target listed in the current workspace, the new project (p_pbtutor_webform) does not display under PB Tutor in the System Tree. In the PB Tutor target, you still see the projects for creating a standard executable file and a Web DataWindow container.

2 Right-click the p_pbtutor_webform project in the System Tree and select Edit from the pop-up menu.

The .NET Web Forms project opens in the Project painter.

3 Click the Configuration tab and make sure the “System defined configuration settings” radio button is selected.

4 Select the PBDataWindowPageNavigatorType global property in the Key column of the Configuration tab list view, and click Edit.

The Set Configuration Value dialog box displays.
5 In the Set Configuration Value dialog box, change the Value drop-down list entry to display Numeric and click OK.

You change the navigator control type from NextPrev to Numeric.

For a description of page navigation types, see the chapter on best practices in the Deploying Applications and Components to .NET book.

6 Click the project’s Run tab and note the default values in the Application and Arguments field.

The default application should be the Internet Explorer browser and the default argument should be the URL for the Web Forms application after deployment.

7 Note the selections on the other tab pages of the project.

You selected most of the properties for the project in the target wizard. The project properties sheet also has default selections for other properties that you did not set in the wizard. For this tutorial, you do not need to modify these default settings. These settings are described in Chapter 2 of the Deploying Applications and Components to .NET book. You can also right-click on a Project painter tab page and select Help from the pop-up menu for additional property descriptions.
8 Select Design>Deploy Project from the Project painter menu or click the deploy icon in the PainterBar.

You build and deploy the project to the local IIS server. A success message displays on the Default tab of the Output window. The Unsupported Features tab contains a list of properties that are not supported in the .NET Web Forms environment. The unsupported features listed for this tutorial application mostly have to do with toolbar and menu styles and do not affect the main functionality of the application.

9 Close all open painters.

Run the application from a Web browser

You are now ready to run the tutorial as a Web Forms application. In this lesson, you start one application session from PowerBuilder and another session by typing the application URL in a Web browser Address box.

1 Start the EAS Demo DB V110 database manually if necessary.

You do not need to start the database manually if you set full control permissions for the ASP.NET user for the database and database engine directories, as described in “Grant ASP.NET users full control over key directories and files” on page 112.

Starting the database manually
You can start the database manually by selecting Programs>Sybase>PowerBuilder 11.0>Demo Database from the Windows Start menu.
Run the application from a Web browser

2 Right-click the p_pbtutor_webform project in the PowerBuilder System Tree and select Run from the pop-up menu.

If you left the p_pbtutor_webform project open in the Project painter, you can select Design>Run from the Project painter menu or you can click the Run Project icon in the PainterBar instead of using the System Tree pop-up menu. You cannot run the project from the System Tree pop-up menu while a PowerBuilder painter is open for any of the project objects. The welcome window (login screen) for the tutorial application displays in the Web browser. When you run the application from the PowerBuilder design-time environment, you do not see the browser menus and toolbars.

3 Open a second Internet Explorer (IE) browser from the Windows Start menu or task bar.

You can open a browser on a different computer if you have one available. Next, you start a second session for the tutorial application.

4 Type http://servername/pbtutor/default.aspx in the IE Address box, where serverName is the name of the IIS server where you deployed the tutorial application.

If you open a Web browser on the IIS server machine, and you deployed the application to “localhost”, you can use localhost for the server name in the browser’s Address box. When you start the application from a Web browser and include the default.aspx start page, the browser menus and toolbars remain visible when the Web Forms application displays in the browser window.

5 Enter dba for the user ID, sql for the password, and click OK.

After a successful login, the tutorial application’s Frame window displays in the Web browser.

6 Select File>Report>Maintain Customers from the Frame window menu.

The Maintain Customers sheet window displays. The master DataWindow on this page uses the Numeric style page navigation control. You can click on a number to navigate to a different page. Because you did not change the PBDDataWindowRowsPerPage property in the IIS manager, the number of DataWindow rows per page is 20.
Frame window and the sheet window toolbars display separately.

7 Select File>Report>Maintain Products from the Frame window menu.

The Maintain Products sheet window displays. Sheet windows display in a tab page format rather than as detached, cascading windows.

You do not see any page navigation controls on the Maintain Products page because its DataWindow controls do not have more than 20 rows (the value set by the global PBDataWindowRowsPerPage property) and are therefore completely visible in a single page.
The following picture displays the tab page format used in the classic Web style presentation.

8 Continue testing the tutorial or select File>Exit from the application Frame window menu.

You should be able to insert, update, and delete database entries from the tutorial Web Forms application, just as you were able to do from the PowerBuilder native tutorial application.

After you finish with the current Web Forms session, you might want to experiment with changing other global properties in addition to PBDataWindowPageNavigatorType. For example, to examine the File Manager and the Mail Profile Manager, you can set the PBFileManager and PBMailManager global properties to true.

For more information about Web Forms targets, including the File Manager and Mail Profile Manager, see the Deploying to Applications and Components to .NET book.
Building a Windows Forms Application

This part is a tutorial that shows you how to get started using .NET Windows Forms targets. It includes step-by-step instructions for converting a client-server application to a Windows Forms application.
LESSON 13

Converting the PowerBuilder Tutorial to a Windows Forms Application

This tutorial demonstrates how to convert the PowerBuilder tutorial application to a Windows Forms application. It assumes you have installed the Microsoft .NET Framework 2.0, the .NET Framework 2.0 SDK, and an IIS server on your development computer. The IIS server is used as the central server for intelligent update. You can use a different computer to run the Windows Forms application.

In this tutorial, you:

• Run the tutorial in PowerBuilder
• Copy resource files to the Solutions directory
• Create a .NET Windows Forms target and project
• Deploy and run the Windows Forms target
• Publish the application to a Web browser
• Install the application from a Web browser and run it
• Install the application on another computer
• Update the application

How long does it take?
About 40 minutes.
Run the tutorial in PowerBuilder

Where you are

> Run the tutorial in PowerBuilder
Copy resource files to the Solutions directory
Create a .NET Windows Forms target and project
Deploy and run the Windows Forms target
Publish the application to a Web browser
Install the application from a Web browser and run it
Install the application on another computer
Update the application

Before you deploy the PowerBuilder tutorial application as a Windows Forms application, make sure that the application runs successfully in the PowerBuilder development environment. The complete tutorial application is included in the PowerBuilder installation folder.

To run the tutorial application successfully, you must have installed SQL Anywhere software and you must be able to connect to the EAS Demo DB V110 database.

1 Select Programs>Sybase>PowerBuilder 11.0>PowerBuilder 11.0 from the Windows Start menu.

2 Select Open Workspace from the File menu.

3 Navigate to the Tutorial>Solutions folder under the PowerBuilder 11.0 installation folder, select MyWorkspace.pbw, and click Open.

The workspace containing the pbtutor.pbt application target opens in PowerBuilder. This target contains two library files (pbtutor.pbl and tutor_pb.pbl) with all the objects used in the tutorial application.

4 Click the Run button in the PowerBar.

The Login window for the tutorial application displays.

5 Enter dba as the value for the user ID and sql as the password.

The MDI frame window for the tutorial with a menu and tool bar displays.
6 Test some menu and toolbar items to make sure they work, then terminate the application.

For example, select File>Report>Maintain Customers, use the toolbar icons or the Edit menu items to insert a new customer and update the database, then open a new instance of the Maintain Customers report to check that the new row was added.

Copy resource files to the Solutions directory

Where you are
Run the tutorial in PowerBuilder
> Copy resource files to the Solutions directory
Create a .NET Windows Forms target and project
Deploy and run the Windows Forms target
Publish the application to a Web browser
Install the application from a Web browser and run it
Install the application on another computer
Update the application

You can use the PowerBuilder .NET Windows Forms Application target wizard to reuse the library list and application object of an existing target in the current workspace to create a new Windows Forms target.

In the wizard, you can select any resource files that your application requires and they are deployed with the application, but the resource files must be present in the directory where you create the application. You need to copy three image files from the Tutorial directory to the Solutions directory and change the path of the bitmap in the w_welcome window.

1 In File Explorer, select and copy tshirtw.jpg, tutorial.ico, and tutsport.bmp in the Tutorial directory.

2 Copy the files to the Tutorial>Solutions directory.

3 In PowerBuilder, open the w_welcome window and select the Picture control.
   In the Properties view, remove the path in the PictureName box so that it contains only tutsport.bmp.
   Close the w_welcome window.
Create a .NET Windows Forms target and project

Create a .NET Windows Forms target and project

Where you are
- Run the tutorial in PowerBuilder
- Copy resource files to the Solutions directory
- Create a .NET Windows Forms target and project
- Deploy and run the Windows Forms target
- Publish the application to a Web browser
- Install the application from a Web browser and run it
- Install the application on another computer
- Update the application

Now you create a new Windows Forms target using the .NET Windows Forms Application target wizard.

1. Click the New button on the PowerBar and select the Target tab.

2. Select the .NET Windows Forms Application icon and click OK.
   The first page of the wizard displays information about what the wizard does.

3. Click Next. On the Create the Application page, select “Use the library list and application object from an existing target” and click Next.

4. Select the pbtutor target and click Next.
   By default, the new target name is pbtutor_winform.pbt.

5. Click Next to accept the target name.

6. On the Specify Project Information page, click Next to accept the default project name and library.

7. On the Specify Application General Information page, specify Acme Update as the product name and AcmeUpdate.exe as the executable file name, and click Next.

9 Click Next on the Specifying Win32 Dynamic Library Files page. Since the tutorial application does not call any external functions, you do not specify any DLL names for deployment with the application.

10 On the Specify Support for Smart Client page, select the Publish as smart client application check box and click Next.

11 Click Next on the Specifying Application Running Mode page. You accept the default option that allows users to run the application from the Windows Start menu as well as from a browser.

12 On the Specify How Application Will be Installed or Launched page, change localhost to the name of your computer, change pbtutor to acmeupdate, and click Next. You can leave the host name as localhost if you do not plan to access the published application from another computer. This is described in “Install the application on another computer” on page 266.

13 Click Next on the Specify Application Update Mode page, then click Finish on the final page. The .NET Windows Forms Application wizard creates the pbtutor_winform target and the p_pbtutor_winform project. You now have two targets in MyWorkspace, both using pbtutor.pbl and tutor_pb.pbl.

14 Expand pbtutor.pbl in both the pbtutor target and the pbtutor_winform target in the System Tree and look at the project objects that display. When you use the library list and application object of an existing target to create a Windows Forms project, the libraries are shared by both targets, but the System Tree displays only projects that are appropriate for the target type. In the pbtutor target, you see p_pbtutor.exe and p_pbtutor_webdw. In the pbtutor_winform target, you see p_pbtutor_winform.

15 Collapse the pbtutor target, but leave the pbtutor_winform target expanded.
Deploy and run the Windows Forms target

Where you are
- Run the tutorial in PowerBuilder
- Copy resource files to the Solutions directory
- Create a .NET Windows Forms target and project
- Deploy and run the Windows Forms target
  - Publish the application to a Web browser
  - Install the application from a Web browser and run it
  - Install the application on another computer
  - Update the application

Before you publish the application as a smart client application, deploy it to a local directory to make sure it builds successfully, and then run it from the deployed executable file to make sure the application runs as it did in the development environment.

1. **Double-click the p_pbtutor_winform project in the System Tree to open the Project painter.**
   - If you select each of the tab pages, you see that there are options you can set in the painter that cannot be set in the wizard. For now, use the defaults set in the wizard.

2. **Select Design » Deploy Project from the Project painter menu or click the Deploy button in the PainterBar.**
   - Deploy builds the application and deploys it to the local directory specified in the Output Path field on the General page in the Project painter.
   - A success message displays on the Default tab page in the Output window, and a new tab displays showing unsupported features. Some menu properties, such as ToolbarHighlightColor, are not supported in Windows Forms.
LESSON 13 Converting the PowerBuilder Tutorial to a Windows Forms Application

Troubleshooting
If the application fails to deploy, make sure you have the .NET Framework 2.0 SDK installed on your computer and that its bin directory is in your system PATH environment variable.

If you see the syntax error “Unexpected token: 'line 4:8'
unexpected token: -”, open m_my_sheet in the Menu painter, select Design>Options from the PowerBuilder menu, and select the Allow Dashes in Identifiers check box on the Script tab page in the Options dialog box.

For more troubleshooting tips, see the chapter on troubleshooting in the Deploying Applications and Components to .NET book.

3 Select Design>Run Project from the Project painter menu or click the Run Project button in the PainterBar.

The AcmeUpdate.exe file in the pbtutorial_winform_WinFormOutput directory runs and displays the Welcome window.

4 Enter dba as the value for the user ID and sql as the password.

Notice that the application’s icon in the Windows task bar indicates it is a Windows Forms application.

5 Run the application as you did in the development environment and test some database operations.

Close the application when you have finished testing. Next, you publish the application to a Web server and install it from the publish page.
Publish the application to a Web browser

Where you are
- Run the tutorial in PowerBuilder
- Copy resource files to the Solutions directory
- Create a .NET Windows Forms target and project
- Deploy and run the Windows Forms target

> Publish the application to a Web browser
  - Install the application from a Web browser and run it
  - Install the application on another computer
  - Update the application

Next you publish the application using intelligent update technology.

1. **Open the p_pbtutor_winform project if it is not already open.**

2. **On the Version page, enter Acme, Inc. as the Company name.**
   
The product name and company name display on the publish page and in the Windows Start menu.

3. **Examine the options on the Publish and Install/Update pages.**
   
The application will be published to a Web site on your computer. A publish page named publish.htm is generated and opened when the application has been published so that you can install the application from it onto your computer. When you make a change and republish the application, the revision number is incremented automatically.

   The defaults on the Install/Update page specify that the application will be installed so that you can run it from the Start menu on your computer whether or not it is connected to the Internet or intranet. Before the application starts, it checks for updates on the publish Web site.
4 On the Notify page, clear the “Use default notifier icon” check box and browse to select tutorial.ico in the Tutorial\Solutions directory.

The tutorial icon displays in the Notification area of the Windows task bar when the application is running. You can also specify a different background image for the window that displays when you check for updates.

5 On the Prerequisites page, select Microsoft .NET Framework 2.0 and PowerBuilder 11 Runtime Library.

If this application needs to be installed on a computer that does not have the Microsoft .NET Framework 2.0 installed, you must modify the package that installs it. For more information, see the chapter on intelligent deployment in the Deploying Applications and Components to .NET book.

6 Save the project and select Design>Publish Application or click the Publish button on the PainterBar.

PowerBuilder redeployes the project and publishes the application to the Web server on your local computer, typically C:\Inetpub\wwwroot\AcmeUpdate. It also opens a browser and displays the publish.htm page so that you can install the application and any prerequisites.

Troubleshooting
If the publish operation does not succeed, see the chapter on troubleshooting in the Deploying Applications and Components to .NET book.
Install the application from a Web browser and run it

Install the application from a Web browser and run it

Where you are
Run the tutorial in PowerBuilder
Copy resource files to the Solutions directory
Create a .NET Windows Forms target and project
Deploy and run the Windows Forms target
Publish the application to a Web browser
> Install the application from a Web browser and run it
> Install the application on another computer
Update the application

Next you install the application on your computer from the Web browser and run it.

1 In the publish.htm page, click the Install button.
2 Click Run in the File Download dialog box that displays and in any other dialog boxes that display.

The dialog boxes that display depend on your security settings.

The Acme Update Installation dialog box displays. Since the Microsoft .NET Framework is already installed on your computer, it does not display in the dialog box. If you click the Advanced button, the Components List shows all the components required for the application.

If the Runtime Library package is installed
If the PowerBuilder 11 Runtime Library package is already installed on your computer, clear its check box in the Components List and click OK.

3 Click the Install button on the Acme Update Installation dialog box.

The PowerBuilder 11 Runtime Library and Acme Update application are installed on your computer. Follow the prompts in the dialog boxes that display and close the Acme Update Installation dialog box when the installation is complete.

A pop-up “Launching Application” window displays, then the Acme Update application opens and an icon with the label AcmeUpdate displays in the notification area in the task bar.

4 Enter dba as the value for the user ID and sql as the password.
Install the application on another computer

5  Test the application to make sure it runs correctly.

If another computer has access to the IIS server on the development computer, you can use it to test installation on a client computer. This is described in the next exercise. If you want to try the next exercise, close the application on the development computer. If you want to test the update properties on the development computer, leave the application open and go to “Update the application” on page 267.

Install the application on another computer

Where you are
Run the tutorial in PowerBuilder
Copy resource files to the Solutions directory
Create a .NET Windows Forms target and project
Deploy and run the Windows Forms target
Publish the application to a Web browser
Install the application from a Web browser and run it
> Install the application on another computer
  Update the application

You can install the application on a client computer from the Web page http://hostname/acmeupdate/publish.htm, where hostname is the name of the development computer. The client computer must have access to the development computer.

1  On the client computer, create an ODBC system DSN called EAS Demo DB V11.0 that connects to the easdemodb.db on a server.

2  Open Internet Explorer and navigate to the publish page for the application (http://hostname/acmeupdate/publish.htm, where hostname is the name of the development computer).

3  Click Install and click the Run buttons in the windows that display, as you did in the previous exercise.
Click the Install button on the Acme Update Installation dialog box. The PowerBuilder 11 Runtime Library and Acme Update application are installed on your computer. Follow the prompts in the dialog boxes that display and close the Acme Update Installation dialog box when the installation is complete and the application opens.

Enter *dba* as the value for the user ID and *sql* as the password.

Test the application to make sure it runs correctly.

Right-click the Acme Update notifier icon and try each of the enabled menu items.

If you select Check for Updates, a pop-up window displays that indicates no updates are available. Next, you make a minor change in the application to test intelligent update.

**Update the application**

Where you are
- Run the tutorial in PowerBuilder
- Copy resource files to the Solutions directory
- Create a .NET Windows Forms target and project
- Deploy and run the Windows Forms target
- Publish the application to a Web browser
- Install the application from a Web browser and run it
- Install the application on another computer
- Update the application

Now you change a background color in the application and republish it to the server, then test the notification feature.

1. **On the development computer, open w_pbtutor_basesheet and change its BackColor property from ButtonFace to a color of your choice and save and close the window.**

2. **Select Design->Deploy or click the Deploy button on the PainterBar.**

PowerBuilder builds and deploys the application.
3  **Select Design>Publish or click the Publish button on the PainterBar.**

PowerBuilder publishes the updated application. If you look in the `Inetpub\wwwroot\acmeupdate` folder, you see 1.0.0.0 and 1.0.0.1 subdirectories.

**Starting the application from the Windows Start menu**

If the application is not running, select Program Files>Acme Inc.>Acme Update from the Start menu. An Update Available dialog box displays informing you that a new version of Acme Update is available. You can download the new version or click Skip to run the older version. Click Skip to continue to the next step in this exercise.

4  **On the development or client computer, right-click the Acme Update notifier icon and select Check for Update.**

A pop-up window displays informing you that a new version of Acme Update is available on the server.

5  **Right-click the Acme Update notifier icon again and select Retrieve Update.**

The updated version of the application is downloaded.

6  **Right-click the Acme Update notifier icon again and select Restart with New Version.**

The Welcome window opens.

7  **Enter the login information, click OK, and open a customer or product report.**

The background color is changed to the color you specified.
Index

A
aligning columns in DataWindow objects 176
ampersand (&), menu item accelerator key 143
ancestor, windows 121
Application object
definition 11
icon 39, 42
Open event 52
applications
building 225
debugging 191
definition 11
distributed 5
internet 4, 5
MDI 19
running 45
ASP.NET, setting user permissions 241
AutoScript
setting up shortcuts for 113
using 114, 133

B
background color, window 65
breakpoints 192
Building .NET applications 4

C
CHOOSE CASE statement 212
Clicked event
  CommandButton control 114, 116
  menu item 152
Clip window 7
Close event, Application object 117

columns on DataWindow objects
  aligning 176
  rearranging 174
comments
  DataWindow 163, 173
  menu 147
  Script view 86
  window 67
COMMIT statement 135
connection service manager 100
Constructor event, user object 104
context Help, adding 80
controls
  CommandButton 76
delleting 70
duplicating 72
Picture 70
  specifying properties for 72, 75, 76
  StaticText 71
custom class user objects 17

data source
  Quick Select 160
  SQL Select 166
database connectivity
  about 5, 90
  Transaction object 103
Database painter, using 95
database profiles 90
databases
  connecting to 5
  connecting to at execution time 103
  extended attributes 99
  retrieving, presenting, and manipulating data 13
table definitions in 95
DataWindow controls 124

Getting Started
Index

DataWindow data expressions 137
DataWindow objects
  about 157
  aligning columns 176
  attaching to DataWindow controls 180, 182, 186
  creating 160, 166
  data source 160, 166
  display order 160
  enhancing 174
  overview 13
  presentation style 160, 166
  rearranging columns 174
  retrieval arguments 168
  saving 163, 173
  selecting columns with Quick Select 160
  WHERE clause 169
DataWindow painter
  bands 158
  retrieval argument 168
  WHERE clause 169
DBError event 131, 134
DBParm parameter 108
debugging
  about 191
  adding breakpoints 192
  running in debug mode 196
  setting a watch 201
  stepping through code 196
  declaring global variables 106
  default to 3D window option 69
DeleteRow function 135
deleting controls 70
detail band in DataWindow objects 158
docking views 56
drop-down DataWindow edit style 177
drop-down menus
  adding items 142
  description 15
events
  about 4
  adding 212
  Clicked 112, 152
  Close 117
  Constructor 104, 215
  DBError 131
  LoseFocus 215
  RowFocusChanged 136
  triggering from menu scripts 152
exceptions
  catching 215
  throwing 212
  user-defined 210
executable file
  application icon 39, 42
  generating machine code 226
  regenerating objects 230
extended attributes 99, 177

F
floating
  toolbars 60
  views 56
footer band in DataWindow objects 158
frame window 84
Freeform presentation style
  columns 174
  DataWindow definition 166
functions
  about 4
  adding 212
  DeleteRow 135
  GetActiveSheet 152
  global 16
  InsertRow 135
  object-level 16
  ProfileString 105
  Reset 135
  Retrieve 134
  SetFocus 134, 135
  SetRowFocusIndicator 134
  SetTransObject 137
  Update 135

E
EAS Demo DB Database
  connecting to 89
  setting up 24
edit style, drop-down DataWindow 177
Index

G
GetActiveSheet function 152
  global functions 16
  structures 16
  variables 106

H
HALT statement 116
  header band in DataWindow objects 158, 162
Help
  context messages 80
  Microhelp 148

I
icons, application 39
  inheritance
    and menus 146
    and object-oriented programming 4
    and user objects 124
    and windows 121
initialization files
  odbc.ini 90
  pb.ini 95
  pbtutor.ini 105
InsertRow function 135

L
libraries
  about 17
  dynamic 226
  rebuild objects in 139
  search path for application 122

M
machine code 226
  main window, size 42
  manager, connection service 100
  MDI applications 19
  menu bars, description 15
  menu items
    adding scripts for 152
    defining 142
    description 15
  Menu painter, using 142
  menus
    about 15
    adding scripts for 152
    and toolbars 144, 150
    creating 146
    inheriting 146
    menu items 142
    saving 147
  MicroHelp 148

N
  .NET applications 4
  .NET Web Forms tutorial 241
  .NET Windows Forms tutorial 255

O
object orientation 4
  object-level
    functions 16
    structures 16
Open event
  frame window 84
  sheet window 136
Output window 7

P
PainterBar
  adding controls from 68
  pop-up menus 60
  using 8
  painters 7
  Parent (PowerScript pronoun) 109
Index

PBL  see PowerBuilder Library (PBL)
Pcode (pseudocode) 226
pop-up menus
   about 60
      PainterBar 60
PowerBar 8
PowerBuilder Library (PBL) 17
PowerScript 4
PowerScript targets, about 6
PowerTips 8
presentation styles
   DataWindow object 160, 166
      Freeform 166
      Tabular 160
Profile String function 105
Project wizards 227
pronouns, PowerScript
   Parent 109, 110
   This 137

Q
queries 16
Quick Select
   sort criteria 161
   using 160

R
retrieval arguments
   creating 168
      WHERE clause 169
Retrieve function
   about 134
      specifying an argument for 138
right mouse button, and pop-up menus 60
ROLLBACK statement 135
RowFocusChanged event 136

S
Script view
   description 80

error window 88
Paste Special commands 112
prototype area 134
using comments 86
scripts
   about 4
      compiling 88
error window 88
for user events 132
setting up shortcuts for AutoScript 113
using AutoScript 114, 133
scrollbars, vertical 128
Select painter
   about 167
      tab area 168
SELECT statement 168
SetFocus function 134, 135
SetRowFocusIndicator function 134
SetTransObject function 137
setup for tutorial 24
sheet windows, menus 146
size, main window 42
SQL painter 166
SQL Select data source 166
SQL statements
   COMMIT 135
   ROLLBACK 135
   SELECT 168
SQL syntax, in Select painter 168
SQLCA (SQL Communications Area) 103, 137
standard class user objects 17
structures 16
StyleBar 8
summary band in DataWindow objects 158
System Tree 7

T
tab order 78
Tabular presentation style 160
targets 6
This (PowerScript pronoun) 137
To-Do List 100
Index

toolbars
  runtime application 150
  showing text 59
Transaction object 103, 137
TRY-CATCH statement 212, 215
tutorial
  files 24
  initialization file 105
  setup 24

U
Update function 135
user events
  adding scripts for 132
  defining 132
  triggering from menu scripts 152
user objects
  about 17
  using 124

V
variables
  global 106
  gnv_connect 106
  instance 106
  naming conventions 106
vertical scrollbars 128
view, types of
  Design (DataWindow painter) 158
  HTML Preview (DataWindow painter) 162
  Layout 65
  Object Details (Database painter) 98
  Object Layout (Database painter) 97
  Objects (Database painter) 95
  Preview (DataWindow painter) 162
  Properties 65
  Script 80
  Syntax (Select painter) 168
  Table Layout (Select painter) 167
  WYSIWYG (Menu painter) 142
views
  docking 56
  floating 56
  manipulating 54
  pinning 56
  saving layout schemes 58
  stacks 57
  visual user objects 17

W
WHERE clause 169
Window painter, deleting a control 70
window size 42
windows
  about 12
  ancestor 121
  CommandButton controls on 76
  creating 64
  DataWindow controls on 124
  deleting a control 70
  Picture controls on 70
  previewing 81
  response 64
  saving 64
  StaticText controls on 71
  tab order in 78
wizards
  Connection Object 100
  DataWindow 159
  Project 227
  workspaces 6
Index