jConnect 4.5, 5.5, and Java utilities

Before you install jConnect version 4.5, 5.5, jisql, or Ribo, you must install the Java Development Kit (JDK). JDK is installed by default when you perform a full or standard install with the Studio Installer.

When you install jConnect 5.5, you receive classes that are compatible with JDBC 2.0, regardless of which JDK (1.1.x or 1.2) version you use. The following table lists the JDK and jConnect versions necessary to develop applications that are compliant with different versions of JDBC.

If you are developing

Use JDK version

Use jConnect version

JDBC 1.x applications/servlets

1.1.x or compatible browser


JDBC 2.x applications/servlets

1.2.x or

compatible browser


For information on developing applets with jConnect, see jConnect for JDBC x.x Product Documentationhttp://www.sybase.com/support/manuals.

NoteThe Java VM security manager does not allow a version of jConnect installed in your local file system to create a connection to a server, even if the server is your local system. This can create a problem if you use Netscape to run an applet that uses jConnect.

When Netscape needs to load jConnect to create a connection to a server, it looks for a CLASSPATH defined in its environment to find the jConnect classes. If it finds a CLASSPATH that you have defined to point to your local jConnect installation, it loads jConnect directly from the local file system, rather than from the server, and tries to create a connection. This generates a security error and the connection fails.

Therefore, if you are using Netscape to run jConnect applets, do not set the CLASSPATH to the local jConnect directory.